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Introduction

Dual shaft systems with intershaft bearings are becoming a standard configuration for gas 
turbine engines, where high power output is required. These systems consist of two coaxial 
rotors (shafts) running at different speeds, and interlinked through a multispool bearing. 
In this example, an eigenfrequency analysis is performed for such a dual rotor system to 
determine critical speeds. Cross-exciting vibrations through the multispool bearing couple 
the dynamic behavior of the two rotors.

Model Definition

The model consists of two coaxial rotors connected through an intershaft bearing. The 
solid inner rotor is supported by bearings at both ends, at stations 1 and 6. The left end of 
the hollow outer rotor (station 7) is supported by a bearing. At the right end of the outer 
rotor (station 10), a multispool bearing provides mutual support between the inner and 
outer rotors. The rotor configuration is shown in Figure 1.

Figure 1: Rotor configuration.

Two disks are mounted on the inner rotor at stations 2 and 5. Two additional disks are 
mounted on the outer rotor at stations 8 and 9. Table 1 lists the positions of the stations 
with station 1 as reference.

TABLE 1:  POSITIONS OF THE STATIONS.

Station Position Station Position

1 0 cm 6 50.8 cm

2 7.62 cm 7 15.24 cm

3 25.4 cm 8 20.32 cm
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Table 2 lists the properties for the rotors.

Table 3 lists the properties of the mounted disks.

All the bearings are isotropic. Table 4 lists their stiffnesses at different stations.

4 40.64 cm 9 35.56 cm

5 45.72 cm 10 40.64 cm

TABLE 2:  PROPERTIES OF THE ROTORS.

Property Value

Density ρ 8304 kg/m3

Young’s modulus E 206.9 GPa

Poisson’s ratio ν 0.3

Inner rotor radius r1 1.52 cm

Outer rotor inner radius r2i 1.905 cm

Outer rotor outer radius r2o 2.54 cm

TABLE 3:  PROPERTIES OF THE DISKS.

Station Mass Polar moment of inertia Diametral moment of inertia

2 4.904 kg 0.02712 kg/m2 0.01356 kg/m2

5 4.203 kg 0.02034 kg/m2 0.01017 kg/m2

8 3.327 kg 0.01469 kg/m2 0.007345 kg/m2

9 2.227 kg 0.00972 kg/m2 0.00486 kg/m2

TABLE 4:  BEARING STIFFNESS.

Station Stiffness

1 27.95 MN/m

4/10 8.7598 MN/m

6 17.519 MN/m

7 17.519 MN/m

TABLE 1:  POSITIONS OF THE STATIONS.

Station Position Station Position
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Results and Discussion

Figure 2 shows the whirl plot for the first mode (backward whirl, f = 70.1 Hz) at 
25,000 rpm. To relate this plot to the rotor system, the rotors, bearings, and disks are 
shown beneath it.

Figure 2: Whirl plot for the first mode.
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Whirl plots for other modes are shown in Figure 3. The figure shows that the inner rotor 
exhibits bending modes, while the outer rotor exhibits rigid body modes.

Figure 3: Mode shapes for different frequencies.

A Campbell diagram for the dual rotor system is shown in Figure 4. The two lines 
represent the rotational speeds of two rotors (inner and outer rotors), while the remaining 
lines corresponds to the eigenfrequencies of the combined rotor system. The critical 
speeds of the inner rotor are compared in Table 5 to the critical speeds of Ref. 1.

TABLE 5:  COMPARISON OF CRITICAL SPEEDS FOR THE INNER ROTOR.

Mode COMSOL (rad/s) Ref. 1 (rad/s)

First (backward) 658 660

First (forward) 866 863

Second (backward) 1430 1423

Second (forward) 1612 1606

Third (backward) 2118 2125

Third (forward) 2270 2283
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.

Figure 4: Campbell diagram for the rotor system.

The critical speeds of the outer rotor are compared in Table 6 to the critical speeds of 
Ref. 1.

Reference

1. J.S. Rao., Rotor Dynamics, example 8.11, pp. 266–269, New Age International (P) 
Limited, 2014.

TABLE 6:  COMPARISON OF CRITICAL SPEEDS FOR THE OUTER ROTOR.

Mode COMSOL (rad/s) Ref. 1 (rad/s)

First (backward) 685 687

First (forward) 823 822

Second (backward) 1467 1462

Second (forward) 1589 1584

Third (backward) 2171 2175

Third (forward) 2278 2274
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Application Library path: Rotordynamics_Module/Verification_Examples/
dual_rotors

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics > Rotordynamics > 
Beam Rotor (rotbm).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies > Eigenfrequency.

6 Click Done.

Create a list of parameters for the geometry of the rotors.

G L O B A L  D E F I N I T I O N S

Parameters: Geometry
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, type Parameters: Geometry in the Label text 
field.

3 Locate the Parameters section. In the table, enter the following settings:

Name Expression Value Description

x1 0[cm] 0 m Position of station 1

x2 7.62[cm] 0.0762 m Position of station 2

x3 25.4[cm] 0.254 m Position of station 3

x4 40.64[cm] 0.4064 m Position of station 4

x5 45.72[cm] 0.4572 m Position of station 5
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Create a list of parameters for the bearing properties.

Parameters: Bearing
1 In the Home toolbar, click Parameters and choose Add > Parameters.

2 In the Settings window for Parameters, type Parameters: Bearing in the Label text 
field.

3 Locate the Parameters section. In the table, enter the following settings:

Create a list of parameters for the material properties.

Parameters: Material
1 In the Home toolbar, click Parameters and choose Add > Parameters.

2 In the Settings window for Parameters, type Parameters: Material in the Label text 
field.

x6 50.8[cm] 0.508 m Position of station 6

x7 15.24[cm] 0.1524 m Position of station 7

x8 20.32[cm] 0.2032 m Position of station 8

x9 35.56[cm] 0.3556 m Position of station 9

x10 40.64[cm] 0.4064 m Position of station 10

r1 1.52[cm] 0.0152 m Radius of the inner rotor

r2i 1.905[cm] 0.01905 m Inner radius of the outer rotor

r2o 2.54[cm] 0.0254 m Outer radius of the outer rotor

Name Expression Value Description

k1 27.95e6[N/m] 2.795E7 N/m Stiffness, bearing at 
station 1

k4 8.7598e6[N/m] 8.7598E6 N/m Stiffness, bearing between 
stations 4 and 10

k6 17.519e6[N/m] 1.7519E7 N/m Stiffness, bearing at 
station 6

k7 17.519e6[N/m] 1.7519E7 N/m Stiffness, bearing at 
station 7

Name Expression Value Description
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3 Locate the Parameters section. In the table, enter the following settings:

Finally, create a list of parameters for the angular speeds of the rotors.

Parameters: Angular speed
1 In the Home toolbar, click Parameters and choose Add > Parameters.

2 In the Settings window for Parameters, type Parameters: Angular speed in the Label 
text field.

Name Expression Value Description

Es 206.9[GPa] 2.069E11 Pa Young's modulus of 
the rotors

rhos 8304[kg/m^3] 8304 kg/m³ Density of the 
rotors

nus 0.3 0.3 Poisson's ratio of 
the rotors

m2 4.904[kg] 4.904 kg Mass at station 2

m5 4.203[kg] 4.203 kg Mass at station 5

m8 3.327[kg] 3.327 kg Mass at station 8

m9 2.227[kg] 2.227 kg Mass at station 9

Ip2 0.02712[kg*m^2] 0.02712 kg·m² Polar moment of 
inertia at station 2

Ip5 0.02034[kg*m^2] 0.02034 kg·m² Polar moment of 
inertia at station 5

Ip8 0.01469[kg*m^2] 0.01469 kg·m² Polar moment of 
inertia at station 8

Ip9 0.00972[kg*m^2] 0.00972 kg·m² Polar moment of 
inertia at station 9

Id2 Ip2/2 0.01356 kg·m² Diametral moment of 
inertia at station 2

Id5 Ip5/2 0.01017 kg·m² Diametral moment of 
inertia at station 5

Id8 Ip8/2 0.007345 kg·m² Diametral moment of 
inertia at station 8

Id9 Ip9/2 0.00486 kg·m² Diametral moment of 
inertia at station 9
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3 Locate the Parameters section. In the table, enter the following settings:

Now, create the lines (polygons) representing the axles of the rotors. For coaxial rotors, 
these lines would overlap. Here, create the lines with an offset for clarity and to facilitate 
making selections for various features in the instructions that follow.

G E O M E T R Y  1

Polygon 1 (pol1)
1 In the Geometry toolbar, click More Primitives and choose Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

3 In the table, enter the following settings:

Add the selection as Inner Rotor for later use.

4 Locate the Selections of Resulting Entities section. Find the Cumulative selection 
subsection. Click New.

5 In the New Cumulative Selection dialog, type Inner Rotor in the Name text field.

6 Click OK.

Polygon 2 (pol2)
1 In the Geometry toolbar, click More Primitives and choose Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

Name Expression Value Description

fr 1000[rpm] 16.667 1/s Angular speed of the inner 
rotor

fr2 1.5*fr 25 1/s Angular speed of the outer 
rotor

x (m) y (m) z (m)

x1 0 0

x2 0 0

x3 0 0

x4 0 0

x5 0 0

x6 0 0
10 |  C R I T I C A L  S P E E D  O F  A  D U A L  R O T O R  S Y S T E M



3 In the table, enter the following settings:

Add the selection as Outer Rotor for later use.

4 Locate the Selections of Resulting Entities section. Find the Cumulative selection 
subsection. Click New.

5 In the New Cumulative Selection dialog, type Outer Rotor in the Name text field.

6 Click OK.

7 In the Settings window for Polygon, click Build All Objects.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

B E A M  R O T O R  ( R O T B M )

1 In the Model Builder window, under Component 1 (comp1) click Beam Rotor (rotbm).

2 In the Settings window for Beam Rotor, locate the Rotor Speed section.

3 In the text field, type fr.

Rotor Cross Section 1
1 In the Model Builder window, under Component 1 (comp1) > Beam Rotor (rotbm) click 

Rotor Cross Section 1.

x (m) y (m) z (m)

x7 0 6*r2o

x8 0 6*r2o

x9 0 6*r2o

x10 0 6*r2o

Property Variable Value Unit Property group

Young’s modulus E Es Pa Young’s modulus and 
Poisson’s ratio

Poisson’s ratio nu nus 1 Young’s modulus and 
Poisson’s ratio

Density rho rhos kg/m³ Basic
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2 In the Settings window for Rotor Cross Section, locate the Cross-Section Definition 
section.

3 In the do text field, type 2*r1.

Rotor Cross Section 2
1 In the Physics toolbar, click Edges and choose Rotor Cross Section.

2 In the Settings window for Rotor Cross Section, locate the Edge Selection section.

3 From the Selection list, choose Outer Rotor.

4 Locate the Cross-Section Definition section. From the Section type list, choose Pipe.

5 In the do text field, type 2*r2o.

6 In the di text field, type 2*r2i.

Change Rotor Speed 1
1 In the Physics toolbar, click Edges and choose Change Rotor Speed.

2 In the Settings window for Change Rotor Speed, locate the Edge Selection section.

3 From the Selection list, choose Outer Rotor.

4 Locate the Rotor Speed section. In the text field, type fr2.

Disk 1
1 In the Physics toolbar, click Points and choose Disk.

2 Select Point 2 only.

3 In the Settings window for Disk, locate the Disk Properties section.

4 In the m text field, type m2.

5 In the Ip text field, type Ip2.

6 In the Id text field, type Id2.

Disk 2
1 In the Physics toolbar, click Points and choose Disk.

2 Select Point 9 only.

3 In the Settings window for Disk, locate the Disk Properties section.

4 In the m text field, type m5.

5 In the Ip text field, type Ip5.

6 In the Id text field, type Id5.

Disk 3
1 In the Physics toolbar, click Points and choose Disk.
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2 Select Point 4 only.

3 In the Settings window for Disk, locate the Disk Properties section.

4 In the m text field, type m8.

5 In the Ip text field, type Ip8.

6 In the Id text field, type Id8.

Disk 4
1 In the Physics toolbar, click Points and choose Disk.

2 Select Point 6 only.

3 In the Settings window for Disk, locate the Disk Properties section.

4 In the m text field, type m9.

5 In the Ip text field, type Ip9.

6 In the Id text field, type Id9.

Journal Bearing 1
1 In the Physics toolbar, click Points and choose Journal Bearing.

2 Select Point 1 only.

3 In the Settings window for Journal Bearing, locate the Bearing Properties section.

4 From the Bearing model list, choose Total spring and damping constant.

5 Specify the ku matrix as

Multi-Spool Bearing 1
1 In the Physics toolbar, click Points and choose Multi-Spool Bearing.

2 Select Point 7 only.

3 In the Settings window for Multi-Spool Bearing, locate the Destination Point Selection 
section.

4 Click to select the Activate Selection toggle button.

5 Select Point 8 only.

6 Locate the Bearing Properties section. From the Displacement connection list, choose 
Flexible.

k1 0

0 k1
13 |  C R I T I C A L  S P E E D  O F  A  D U A L  R O T O R  S Y S T E M



7 Specify the ku matrix as

Journal Bearing 2
1 In the Physics toolbar, click Points and choose Journal Bearing.

2 Select Point 10 only.

3 In the Settings window for Journal Bearing, locate the Bearing Properties section.

4 From the Bearing model list, choose Total spring and damping constant.

5 Specify the ku matrix as

Journal Bearing 3
1 In the Physics toolbar, click Points and choose Journal Bearing.

2 Select Point 3 only.

3 In the Settings window for Journal Bearing, locate the Bearing Properties section.

4 From the Bearing model list, choose Total spring and damping constant.

5 Specify the ku matrix as

S T U D Y  1

Now, setup a parametric sweep with the rotational speed as the swept parameter. We will 
also make use of the mode following functionality. To make it easier to track the different 
modes, it can sometimes be better to initiate the sweep with a nonzero rotational speed.

Parametric Sweep
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

k4 0

0 k4

k6 0

0 k6

k7 0

0 k7
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4 In the table, enter the following settings:

Next, increase the number of desired eigenfrequencies to eight, and activate mode 
following for continuous tracking of the eigenfrequencies over the swept interval.

Step 1: Eigenfrequency
1 In the Model Builder window, click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Desired number of eigenfrequencies checkbox. In the associated text field, type 
8.

4 Click to expand the Filtering and Sorting section. Find the Sorting subsection. Select the 
Mode following checkbox.

Next, increase the storage of extra eigenmodes.

Solution 1 (sol1)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1 > Solver Configurations > 
Solution 1 (sol1) > Eigenvalue Solver 1 node, then click Mode Following 1.

4 In the Settings window for Mode Following, locate the Mode Following section.

5 Select the Follow extra modes checkbox.

6 From the Selection list, choose Number of expected extra modes.

7 In the Number of expected extra modes text field, type 1.

8 In the Threshold for detection of new modes text field, type 1e-6.

9 In the Study toolbar, click Compute.

Follow the instructions below to create a whirl plot similar to Figure 2.

R E S U L T S

Whirl (rotbm)
1 In the Settings window for 3D Plot Group, locate the Data section.

2 From the Eigenfrequency (Hz) list, choose 70.061.

3 In the Model Builder window, expand the Whirl (rotbm) node.

Parameter name Parameter value list Parameter unit

fr (Angular speed of the inner 
rotor)

range(250,250,25000) rpm
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Deformation
1 In the Model Builder window, expand the Results > Whirl (rotbm) > Rotor node, then click 

Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 In the Scale factor text field, type 1.5.

Disk 1
1 In the Model Builder window, under Results > Whirl (rotbm) click Disk 1.

2 In the Settings window for Point Trajectories, click to expand the Inherit Style section.

3 From the Plot list, choose Rotor.

Disk 2
1 In the Model Builder window, click Disk 2.

2 In the Settings window for Point Trajectories, locate the Inherit Style section.

3 From the Plot list, choose Rotor.

Disk 3
1 In the Model Builder window, click Disk 3.

2 In the Settings window for Point Trajectories, locate the Inherit Style section.

3 From the Plot list, choose Rotor.

Disk 4
1 In the Model Builder window, click Disk 4.

2 In the Settings window for Point Trajectories, locate the Inherit Style section.

3 From the Plot list, choose Rotor.

Journal Bearing 1
1 In the Model Builder window, click Journal Bearing 1.

2 In the Settings window for Point Trajectories, locate the Inherit Style section.

3 From the Plot list, choose Rotor.

Journal Bearing 2
1 In the Model Builder window, click Journal Bearing 2.

2 In the Settings window for Point Trajectories, locate the Inherit Style section.

3 From the Plot list, choose Rotor.

Journal Bearing 3
1 In the Model Builder window, click Journal Bearing 3.
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2 In the Settings window for Point Trajectories, locate the Inherit Style section.

3 From the Plot list, choose Rotor.

4 In the Whirl (rotbm) toolbar, click Plot.

Now, disable the nodes corresponding to the geometry in the Whirl Plot group to plot only 
the mode shapes. These plots are shown in Figure 3.

Whirl (rotbm)
In the Model Builder window, expand the Results > Whirl (rotbm) node.

Disk 1, Disk 2, Disk 3, Disk 4, Journal Bearing 1, Journal Bearing 2, Journal Bearing 3, 
Rotor
1 In the Model Builder window, under Results > Whirl (rotbm), Ctrl-click to select Rotor, 

Disk 1, Disk 2, Disk 3, Disk 4, Journal Bearing 1, Journal Bearing 2, and Journal Bearing 3.

2 Right-click and choose Disable.

Whirl (rotbm)
1 In the Model Builder window, click Whirl (rotbm).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Eigenfrequency (Hz) list, choose 169.89.

4 Click the Zoom Extents button in the Graphics toolbar.

5 In the Whirl (rotbm) toolbar, click Plot.

6 From the Eigenfrequency (Hz) list, choose 261.51.

7 In the Whirl (rotbm) toolbar, click Plot.

8 From the Eigenfrequency (Hz) list, choose 344.75.

9 In the Whirl (rotbm) toolbar, click Plot.

10 From the Eigenfrequency (Hz) list, choose 386.8.

11 In the Whirl (rotbm) toolbar, click Plot.

You can now enable the nodes corresponding to the geometry to revert the plot to the 
default state.

Disk 1, Disk 2, Disk 3, Disk 4, Journal Bearing 1, Journal Bearing 2, Journal Bearing 3, 
Rotor
1 In the Model Builder window, under Results > Whirl (rotbm), Ctrl-click to select Rotor, 

Disk 1, Disk 2, Disk 3, Disk 4, Journal Bearing 1, Journal Bearing 2, and Journal Bearing 3.

2 Right-click and choose Enable.
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Whirl (rotbm)
Click the Zoom Extents button in the Graphics toolbar.

The predefined Campbell diagram only shows the ω=Ω curve for the primary rotor (inner 
rotor). Modify the Graph Marker settings to add a similar curve for the outer rotor. The 
Campbell diagram is shown in Figure 4.

R E S U L T  T E M P L A T E S

1 In the Results toolbar, click Result Templates to open the Result Templates window.

2 Go to the Result Templates window.

3 In the tree, select Study 1/Parametric Solutions 1 (sol2) > Beam Rotor > 
Campbell Diagram (rotbm).

4 Click the Add Result Template button in the window toolbar.

5 In the Results toolbar, click Result Templates to close the Result Templates window.

R E S U L T S

Natural Frequency
1 In the Model Builder window, expand the Campbell Diagram (rotbm) node, then click 

Natural Frequency.

2 In the Settings window for Global, locate the y-Axis Data section.

3 In the table, enter the following settings:

4 Locate the x-Axis Data section. In the Expression text field, type rotbm.omegar.

5 From the Unit list, choose rad/s.

Intersection ([1,1.5]ÞΩ)
1 In the Model Builder window, expand the Natural Frequency node, then click 

Intersection (1ÞΩ).

2 In the Settings window for Graph Marker, type Intersection ([1,1.5]Þ[Omega]) in 
the Label text field.

3 Locate the Display section. In the A text field, type -1 -1.5.

Campbell Diagram (rotbm)
1 In the Model Builder window, under Results click Campbell Diagram (rotbm).

2 In the Settings window for 1D Plot Group, locate the Axis section.

Expression Unit Description

abs(freq)*2*pi rad/s Natural frequency
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3 Select the Manual axis limits checkbox.

4 In the y maximum text field, type 3100.

5 In the Campbell Diagram (rotbm) toolbar, click Plot.
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