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Introduction

An evenly distributed flow is necessary to achieve good thermal performance in plate heat 
exchangers. The flow distribution can be controlled by the design of the inlet and outlet 
manifolds that connect the plate channels.

Modeling the detailed flow within the channels of a plate heat exchanger can be 
computationally costly, or even prohibitive. However, it is often sufficient to describe the 
flow with a lumped pipe flow model. This way the computational time and memory 
requirements can be significantly reduced. The model presented here shows such an 
approach where a Pipe Flow interface, solving for the velocity and pressure in the plate 
channels, is coupled to a Laminar Flow interface, that solves for the 3D flow and pressure 
in the inflow and an outflow manifolds.

Figure 1: Plate heat exchanger assembly with stacked plates. Image courtesy of Varem S.p.a.
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Model Definition

Figure 2 shows the model geometry. The inlet and outlet manifolds are 2 mm wide, 1 mm 
high, and 85 mm long. The microchannels have a square cross section with a side of 1 mm. 
They are drawn as edges in the 3D geometry.

Figure 2: Five microchannels, inlet and outlet manifold.

D O M A I N  E Q U A T I O N S

The fluid properties of water are used in both interfaces.

Inlet and Outlet Manifolds
The laminar flow in the manifolds is described by the equations in 3D, set up by the 
Laminar Flow interface. 

Microchannels
The 1D flow in the channels is modeled using the Pipe Flow interface, that calculates the 
pressure drop over a pipe and the continuity equation according to:
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Where dh is the mean hydraulic diameter (m), given by:

where A is the pipe cross section area (m2) available for flow, and Z is the wetted perimeter 
(m).

The right hand side of Equation 1 describes the pressure drop due to internal viscous shear 
and contains the Darcy friction factor, fD. The Pipe Flow interface provides a library of 
built-in expressions for fD covering laminar and turbulent flow regimes, as well as 
Newtonian and non-Newtonian fluids.

B O U N D A R Y  C O N D I T I O N S

Coupling the 3D flow in the manifolds to the 1D flow in the channels is easily done with 
the multiphysics coupling Pipe Connection.

An fully developed flow boundary condition with average velocity of 5 cm/s is set at the 
manifold inlet. On the manifold outlets, facing the microchannel inlets, a pipe connection 
multiphysics feature sets up appropriate conditions automatically.

Figure 3: The connection between the pipe segment and the 3D flow domain is easily done with 
the multiphysics coupling Pipe Connection.
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Pipe connection
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Results and Discussion

Figure 4 shows the pressure distribution in the model. The microchannels contribute to 
the major part of the pressure drop.

Figure 4: The main pressure drop occurs the microchannels.

Figure 5 shows the velocity in the microchannels. The velocity is lower in the central 
channels, reducing the heat exchange efficiency in this region. A change in the manifold 
design would be necessary for a more uniform flow distribution in the plate channels.
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Figure 5: Flow velocity magnitude in the microchannels.

Application Library path: Pipe_Flow_Module/Tutorials/heat_exchanger_plate

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Fluid Flow > Single-Phase Flow > Pipe Flow (pfl).

3 Click Add.

4 In the Select Physics tree, select Fluid Flow > Single-Phase Flow > Laminar Flow (spf).
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5 Click Add.

6 Click Study.

7 In the Select Study tree, select General Studies > Stationary.

8 Click Done.

G E O M E T R Y  1

Insert the prepared geometry sequence from file. You can read the instruction for creating 
the geometry in the appendix.

1 In the Geometry toolbar, click Insert Sequence and choose Insert Sequence.

2 Browse to the model’s Application Libraries folder and double-click the file 
heat_exchanger_plate_geom_sequence.mph.

3 In the Geometry toolbar, click Build All.

D E F I N I T I O N S

Add Material
From the Home menu, choose Add Material.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-in > Water, liquid.

3 Click the Add to Component button in the window toolbar.

4 Click the Add to Component button in the window toolbar.

5 From the Home menu, choose Add Material.

M A T E R I A L S

Water, liquid 1 (mat2)
1 In the Settings window for Material, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Edge.

3 From the Selection list, choose Array 1.

P I P E  F L O W  ( P F L )

1 In the Model Builder window, expand the Component 1 (comp1) > Definitions node, then 
click Component 1 (comp1) > Pipe Flow (pfl).

2 In the Settings window for Pipe Flow, locate the Edge Selection section.
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3 From the Selection list, choose Array 1.

Fluid Properties 1
No settings are needed for the fluid properties because these are retrieved from the 
material.

Pipe Properties 1
1 In the Model Builder window, click Pipe Properties 1.

2 In the Settings window for Pipe Properties, locate the Pipe Shape section.

3 From the list, choose Square.

4 In the wi text field, type 1[mm].

L A M I N A R  F L O W  ( S P F )

Now set up the Laminar Flow interface. Again, the fluid properties are taken from the 
material.

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

Inlet 1
1 In the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 43 only.

3 In the Settings window for Inlet, locate the Boundary Condition section.

4 From the list, choose Fully developed flow.

5 Locate the Fully Developed Flow section. In the Uav text field, type 5[cm/s].

Outlet 1
1 In the Physics toolbar, click Boundaries and choose Outlet.

2 Select Boundary 5 only.

3 In the Settings window for Outlet, locate the Pressure Conditions section.

4 Select the Normal flow checkbox.

M U L T I P H Y S I C S

Pipe Connection 1 (plc1)
In the Physics toolbar, click Multiphysics Couplings and choose Global > 
Pipe Connection.

M E S H  1

Now proceed to make some manual adjustments of the physics-controlled mesh.
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1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Physics-Controlled Mesh section.

3 From the Element size list, choose Finer.

4 Right-click Component 1 (comp1) > Mesh 1 and choose Edit Physics-Induced Sequence.

Size 3
1 In the Model Builder window, under Component 1 (comp1) > Mesh 1 click Size 3.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Predefined button.

4 From the Predefined list, choose Normal.

5 Click Build All.

S T U D Y  1

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, locate the Study Settings section.

3 Clear the Generate default plots checkbox.

4 In the Study toolbar, click Compute.

Create the result plots shown in Figure 4 and Figure 5 following these steps:

R E S U L T  T E M P L A T E S

1 In the Home toolbar, click Result Templates to open the Result Templates window.

2 Go to the Result Templates window.

3 In the tree, select Study 1/Solution 1 (sol1) > Pipe Flow > Pressure, 3D (pfl).

4 Click the Add Result Template button in the window toolbar.

R E S U L T S

Surface 1
1 In the Model Builder window, expand the Pressure, 3D (pfl) node, then click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type p-1[atm].

4 In the Pressure, 3D (pfl) toolbar, click Plot.

Surface 2
1 In the Model Builder window, right-click Pressure, 3D (pfl) and choose Surface.

2 In the Settings window for Surface, locate the Data section.
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3 From the Dataset list, choose Study 1/Solution 1 (sol1).

4 Locate the Expression section. In the Expression text field, type p2.

5 Click to expand the Inherit Style section. From the Plot list, choose Surface 1.

6 In the Pressure, 3D (pfl) toolbar, click Plot.

This plot uses the Pipe dataset that provides a three-dimensional representation of the 
pipes. You can adjust the orientation of a pipe cross section to improve the plot.

P I P E  F L O W  ( P F L )

Pipe Properties 1
In the Model Builder window, under Component 1 (comp1) > Pipe Flow (pfl) click 
Pipe Properties 1.

Section Orientation 1
1 In the Physics toolbar, click Attributes and choose Section Orientation.

2 In the Settings window for Section Orientation, locate the Section Orientation section.

3 From the Orientation method list, choose Orientation vector.

4 Specify the V vector as

S T U D Y  1

In the Study toolbar, click Update Solution.

R E S U L T S

Surface 1
1 In the Model Builder window, under Results > Pressure, 3D (pfl) click Surface 1.

2 In the Settings window for Surface, click to expand the Title section.

3 From the Title type list, choose None.

4 In the Pressure, 3D (pfl) toolbar, click Plot.

5 Click the Zoom Extents button in the Graphics toolbar.

Velocity, 3D
1 In the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Velocity, 3D in the Label text field.

0 X

0 Y
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Surface 1
1 Right-click Velocity, 3D and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Pipe.

4 Click Replace Expression in the upper-right corner of the Expression section. From the 
menu, choose Component 1 (comp1) > Pipe Flow > pfl.U - Velocity magnitude - m/s.

5 In the Velocity, 3D toolbar, click Plot.

C R E A T I N G  T H E  G E O M E T R Y

The previously inserted geometry can be created from scratch like this:

A D D  C O M P O N E N T

In the Home toolbar, click Add Component and choose 3D.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Work Plane 1 (wp1)
1 In the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 In the z-coordinate text field, type 0.5.

Work Plane 1 (wp1) > Plane Geometry
In the Model Builder window, click Plane Geometry.

Name Expression Value Description

Lp 190[mm] 0.19 m Pipe length
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Work Plane 1 (wp1) > Line Segment 1 (ls1)
1 In the Work Plane toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 Locate the Endpoint section. From the Specify list, choose Coordinates.

5 Locate the Starting Point section. In the yw text field, type 0.5.

6 Locate the Endpoint section. In the xw text field, type Lp.

7 In the yw text field, type 0.5.

8 Click Build Selected.

9 Click the Zoom Extents button in the Graphics toolbar.

Create an array of the curve and enable Create selections to facilitate selection later on 
in the physics settings.

Array 1 (arr1)
1 In the Model Builder window, right-click Geometry 1 and choose Transforms > Array.

2 Select the object wp1 only.

3 In the Settings window for Array, locate the Size section.

4 In the y size text field, type 5.

5 Locate the Displacement section. In the y text field, type 20.

6 Locate the Selections of Resulting Entities section. Select the Resulting objects selection 
checkbox.

7 From the Show in physics list, choose Edge selection.

Create the inlet and outlet manifolds using blocks.

Block 1 (blk1)
1 In the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 2.

4 Locate the Position section. In the x text field, type -2.

5 Click Build Selected.

6 Click the Zoom Extents button in the Graphics toolbar.

Block 2 (blk2)
1 Right-click Block 1 (blk1) and choose Duplicate.

2 In the Settings window for Block, locate the Position section.
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3 In the x text field, type Lp.

4 Click Build Selected.

Array 2 (arr2)
1 In the Geometry toolbar, click Transforms and choose Array.

2 Select the objects blk1 and blk2 only.

3 In the Settings window for Array, locate the Size section.

4 In the y size text field, type 5.

5 Locate the Displacement section. In the y text field, type 20.

6 Click Build Selected.

Block 3 (blk3)
1 In the Model Builder window, under Component 1 (comp1) > Geometry 1 right-click 

Block 2 (blk2) and choose Duplicate.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Depth text field, type 85.

4 Locate the Position section. In the x text field, type -4.

5 Click Build Selected.

Block 4 (blk4)
1 Right-click Block 3 (blk3) and choose Duplicate.

2 In the Settings window for Block, locate the Position section.

3 In the x text field, type Lp+2.

4 In the y text field, type -4.

5 Click Build Selected.

Form Composite Domains 1 (cmd1)
1 In the Geometry toolbar, click Virtual Operations and choose 

Form Composite Domains.

2 On the object fin, select Domains 1–12 only.

3 In the Geometry toolbar, click Build All.
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