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Introduction

In some application fields, there is a strong focus on weight reduction. For example, this

is the case in the automotive industry, where every gram has a distinct price tag.

The bracket is used for mounting a heavy component on a vibrating foundation. It is thus
important to keep the natural frequency well above the excitation frequency in order to
avoid resonances. The bracket is also subjected to shock loads, which can be treated as a
static acceleration load. This gives an optimization problem, where results from two
different study types must be considered simultaneously.

By using the LiveLink interface for Inventor the weight of a mounting bracket is reduced,
given an upper bound on the stresses and a lower bound on the first natural frequency.
The model demonstrates how to synchronize the geometry between Inventor and
COMSOL Multiphysics while updating dimensional parameters, and how to perform an

optimization study.

Note: This model requires the Optimization Module, the Structural Mechanics Module,
and the LiveLink interface for Inventor.

Model Definition

The original bracket together with a sketched mounted component are shown in Figure 1.
The bracket is made of steel.

The component, which can be considered as rigid when compared with the bracket, has
its center of gravity at the center of the circular cutout in the bracket. The mass is 4.4 kg,
the moment of inertia around its longitudinal axis is 7.1-107% kg-m2 , and the moment of

inertia around the two transverse axes is 9.3-1074 kg-mz.
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Figure 1: Bracket supporting a heavy component.

The idea is to reduce the weight by drilling holes in the vertical surface of the bracket, and
at the same time change the dimensions of the indentations, in order to offset the loss in

stiffness.

OPTIMIZATION PARAMETERS
Six geometrical parameters are used in the optimization. They are summarized in Table 1

and shown in Figure 2.

TABLE I: GEOMETRICAL PARAMETERS.

Parameter Description Lower limit (mm) Upper limit (mm)
RC Radius of the central hole 3 15
ZC0 Vertical distance from thebendto | 23

the edge of the central hole
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TABLE I: GEOMETRICAL PARAMETERS.

Parameter Description Lower limit (mm) Upper limit (mm)
RO Radius of the outer hole 3 15
Z00 Vertical distance from thebendto 8 30
the edge of the outer hole
Y00 Horizontal distance from the 3 29
edge of the bracket to outer hole
WIND Width of the indentation 8 20

Figure 2: Optimization parameters.

CONSTRAINTS

¢ The lowest natural frequency must be at least 60 Hz.

¢ When exposed to a peak acceleration of 4g in all three global directions simultaneously,
the effective stress is not allowed to exceed 80 MPa anywhere. This criterion is
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nondifferentiable, because the location of the peak stress can jump from one place to
another. A gradient-free optimization algorithm must thus be used.

e There must be at least 3 mm of material between two holes, or between a hole and an
edge. This criterion is enforced both through the limits on the control parameters and

as constraints. The geometrical constraints are shown in Figure 3.

Figure 3: Geometrical constraints.

The COBYLA solver uses sampling in the control variable space to approximate both the
objective function, the constraints, and the control variable bounds. Individual samples
may be computed outside the bounds and in violation of the constraints. Therefore, it is
important to parameterize the geometry in such a way that it is robust with respect to

(small) constraint and bound violations.

Bounds and linear constraints are generally satisfied to high precision at the optimum
point returned by the solver, but nonlinear constrains are often slightly violated. The
reason is that the solver tends to converge from the outside of the feasible domain and
terminates before the constraints are completely satisfied. Tightening the solver tolerances
will decrease the constraint violation but is often not worth the computational effort; it is

better to specify constraints with a safety margin.
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Results and Discussion

The initial geometry used in the optimization is shown in Figure 4. Three rather small
holes have been introduced.

Figure 4: Initial geometry.

The optimal values of the geometrical parameters are shown in Table 2.

TABLE 2: OPTIMAL VALUES.

Parameter Optimal value (mm) Lower limit (mm) Upper limit (mm)
LL_RC 6.84 3 15
LL_zco 2.84 | 23
LL_RO 10.61 3 15
LL_YO0O 10.66 3 29
LL_z00 16.98 8 30
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The weight of the optimized bracket is about 179 g, a reduction of 21 g from the original
200.57 g. The stresses from the shock load on the optimized geometry are shown in
Figure 5
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Figure 5: Stresses at peak load in the optimized design.
The optimal solution gives three fairly large holes, and the widest possible indentation.

There are several possible arrangements of the holes that give the same weight reduction
within a small tolerance. It is therefore possible that the design variables are not always the

same at convergence.

Notes About the COMSOL Implementation

The bracket geometry you are using in this model comes from an Inventor design. Using
LiveLink for Inventor you synchronize the geometry and parameters for the dimension of
the bracket and the positioning of holes between Inventor and COMSOL Multiphysics.

In order for this to work you need to have both programs running during modeling, and

you need to make sure that the bracket file is the active file in Inventor.

The component mounted on the bracket is not modeled in detail. It is replaced by a Rigid
Connector having the equivalent inertial properties.
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Application Library path: LiveLink_for_Inventor/Tutorials,
_LivelLink_Interface/bracket_optimization_llinventor

Modeling Instructions

You can set up this simulation both by working inside Inventor, using the embedded
COMSOL simulation environment, and by working in the standalone COMSOL
Desktop. Regardless which way you proceed, first you need to open the CAD file with the

geometry in Inventor.
I In Inventor open the file bracket_optimization.ipt located in the model’s
Application Library folder.

2 Switch to the COMSOL Desktop, and skip the next section. Or, continue below if you

are working inside Inventor.

MODELING INSIDE INVENTOR
I On the COMSOL Multiphysics tab click the New button.

In case it is not already running, the COMSOL modeling environment will be started,

and the geometry will be synchronized automatically.

2 Continue with step 2 under the Model Wizard section.

COMSOL DESKTOP

From the File menu, choose New.

NEW
In the New window, click Model Wizard.

MODEL WIZARD
I In the Model Wizard window, click [l 3D.

2 In the Select Physics tree, select Structural Mechanics > Solid Mechanics (solid).
3 Click Add.

4 Click e Study.

5 In the Select Study tree, select General Studies > Eigenfrequency.

6 Click E,/ Done.
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GEOMETRY |

The geometry is already synchronized if you are modeling inside Inventor.

After launching the One Window interface the last added physics interface is the current
node in the Model Builder. To follow the instructions below, expand the Geometry | node

and select Geometry from Inventor (cad). Skip to step 4 in the section LiveLink for Inventor
1 (cadl).

Make sure that the CAD Import Module kernel is used.

I In the Model Builder window, under Component | (compl) click Geometry I.
2 In the Settings window for Geometry, locate the Advanced section.

3 From the Geometry representation list, choose CAD kernel.

LiveLink for Inventor | (cadl)

I Right-click Component | (compl) > Geometry | and choose LiveLink Interfaces >

LiveLink for Inventor.
2 In the Settings window for LiveLink for Inventor, locate the Synchronize section.
3 Click Synchronize.

After a few moments the geometry of the bracket appears in the Graphics window.

4 Click to expand the Parameters in CAD Package section. The table contains ten
dimensions, THK, LX, LZ, DCMP, BDIA, RC, ZCO, RO, YOO and Z00, which are part of the
Inventor model. In Inventor, the Parameter Selection button on the COMSOL Multiphysics
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tab allows you to select and view dimensions for synchronization. These dimensions are
retrieved, and appear in the CAD name column of the table. The corresponding entries
in the COMSOL name column, LL_THK, LL_LX and so on, are global parameters in the
COMSOL model. These are automatically generated during synchronization, and are
assigned the values of the linked Inventor dimensions. The parameter values are
displayed in the COMSOL value column.

Global parameters in a model allow you to parameterize settings and can be controlled
by the optimization solver to perform parametric sweeps. Thus, by linking Inventor
dimensions to COMSOL global parameters, the optimization solver can automatically

update and synchronize the geometry for each new value in a sweep.

5 Click to expand the Boundary Selections section. The selections listed here are user
defined selections saved in the Inventor files for the components that they appear on.
In Inventor, you can set up selections using the Selections button on the
COMSOL Multiphysics tab.

Both sections are only visible by working in the standalone COMSOL Desktop.

6 Right-click LiveLink for Inventor | (cadl) and choose Build All.

GLOBAL DEFINITIONS

Parameters |

I In the Model Builder window, under Global Definitions click Parameters 1.

The table already contains the automatically generated global parameters that are linked
to the Inventor dimensions.

Based on the parameters in the table you can define expressions to constrain the
positioning of the holes while optimizing the bracket. Later on you will set up the
optimization solver to take into account these geometric constraints. Now, continue
with loading the expressions for the geometric constraints and the parameters needed
to define the physics. Since the parameter file contains all parameters, including the
already synchronized ones, clear the table first to avoid duplicates.

In the Settings window for Parameters, locate the Parameters section.

Click \ Clear Table.
Click Load from File.

Vi Hh W N

Browse to the model’s Application Libraries folder and double-click the file
bracket_optimization_parameters.txt.
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MATERIALS

Add Material
From the Home menu, choose Add Material.

ADD MATERIAL
I Go to the Add Material window.

2 In the tree, select Built-in > Structural steel.
3 Click the right end of the Add to Component split button in the window toolbar.
4 From the menu, choose Add to Component.

5 From the Home menu, choose Add Material.

SOLID MECHANICS (SOLID)

Fixed (Bolts)
I In the Model Builder window, under Component | (compl) right-click

Solid Mechanics (solid) and choose Fixed Constraint.

The exact way the bolts clamp the bracket to the foundation is not important for the

results in the part being optimized.
2 In the Settings window for Fixed Constraint, type Fixed (Bolts) in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Fixed (Bolts).
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Rigid Connector (Mounted component)
I In the Model Builder window, right-click Solid Mechanics (solid) and choose Connections

> Rigid Connector.

The attached component has a high stiffness, and is bolted to the two upper bolt holes.
It is modeled as being rigid, with only mass properties.

2 In the Settings window for Rigid Connector, type Rigid Connector (Mounted
component) in the Label text field.

3 Locate the Boundary Selection scction. From the Selection list, choose
Rigid Connector (Mounted comp).

4 Locate the Center of Rotation section. From the list, choose User defined.

5 Specify the X, vector as

LL_LX-LL_THK/2 x
(4*LL_BDIA+LL_DCMP)/2 'y
LL LZ z

Mass and Moment of Inertia |
I Right-click Rigid Connector (Mounted component) and choose
Mass and Moment of Inertia.

2 In the Settings window for Mass and Moment of Inertia, locate the

Mass and Moment of Inertia scction.
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3 In the m text field, type mCmp.
4 From the list, choose Diagonal.

5 Specify the I matrix as

IXCmp 0 0

0 IYZCmp 0

0 0 IYZCmp
MESH 1|

I In the Model Builder window, under Component | (compl) click Mesh I.
2 In the Settings window for Mesh, locate the Physics-Controlled Mesh section.
3 From the Element size list, choose Finer.

Free Triangular |
I Right-click Component | (compl) > Mesh | and choosec More Generators >

Free Triangular.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Boundary Mesh.

Size |
I Right-click Free Triangular | and choose Size.

13 | GEOMETRIC PARAMETER OPTIMIZATION OF A BRACKET



In the Settings window for Size, locate the Element Size section.

Click the Custom button.

Locate the Element Size Parameters scction.

Select the Minimum element size checkbox. In the associated text field, type 0. 2.
Select the Curvature factor checkbox. In the associated text field, type 0.38.
Click ™ Build Selected.
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Swept |
In the Model Builder window, right-click Mesh | and choose Swept.

Distribution |
I In the Model Builder window, right-click Swept | and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 3.
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4 Click g5 Build All.
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EIGENFREQUENCY STUDY

Run an eigenfrequency study on the initial geometry.

I In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Eigenfrequency Study in the Label text field.
3 Click = Compute.

SOLID MECHANICS (SOLID)
Add the peak loads, and perform a stationary study.

Body load 4g on bracket
I In the Model Builder window, under Component | (compl) right-click

Solid Mechanics (solid) and choose Volume Forces > Body Load.

2 In the Settings window for Body Lead, type Body load 4g on bracket in the Label
text field.

3 Locate the Domain Selection section. From the Selection list, choose All domains.

4 Locate the Force section. Specify the fy vector as

4*g_const*solid.rho x
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4*g_const*solid.rho y

4*g_const*solid.rho z

Force 4g on mounted component
I In the Model Builder window, right-click Rigid Connector (Mounted component) and

choose Applied Force.

2 In the Settings window for Applied Force, type Force 4g on mounted component in
the Label text field.

3 Locate the Applied Force section. Specify the F vector as

4*g_const*mCmp  x
4*g_const*mCmp vy

4*g_const*mCmp z

ROOT

From the Home menu, choose Add Study.

ADD STUDY
I Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies > Stationary.
3 Click the Add Study button in the window toolbar.

4 From the Home menu, choose Add Study.

STATIONARY STUDY
I In the Settings window for Study, type Stationary Study in the Label text field.

2 Click = Compute.

DEFINITIONS

Prepare for the optimization by adding variables for the bracket mass and the maximum

stress.

Domain Probe | (doml)
I In the Model Builder window, under Component | (compl) right-click Definitions and

choose Probes > Domain Probe.
2 In the Settings window for Domain Probe, type mass in the Variable name text field.

3 Locate the Probe Type section. From the Type list, choose Integral.
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4 Click Replace Expression in the upper-right corner of the Expression section. From the
menu, choose Component | (compl) > Solid Mechanics > Material properties > solid.rho -

Density - kg/m®.
Boundary Probe | (bndl)
I In the Model Builder window, right-click Definitions and choose Probes > Boundary Probe.

2 In the Settings window for Boundary Probe, type maxStress in the Variable name text
field.

3 Locate the Probe Type section. From the Type list, choose Maximum.

The boundaries for which the maximum stress is going to be evaluated are defined as

Selections in Inventor.

4 Locate the Source Selection section. From the Selection list, choose Maximum Stress.

o

5 Click Replace Expression in the upper-right corner of the Expression section. From the
menu, choose Component | (compl) > Solid Mechanics > Stress > solid.mises -

von Mises stress - N/m?.

RESULTS
Modify the default stress plot to monitor the geometry and stresses in the optimized

region.

Stress in Optimized Region
I In the Model Builder window, under Results click Stress (solid).
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2 In the Settings window for 3D Plot Group, type Stress in Optimized Region in the
Label text field.

Volume |
I In the Model Builder window, expand the Stress in Optimized Region node, then click

Volume 1I.
2 In the Settings window for Velume, locate the Expression section.
3 From the Unit list, choose MPa.
Deformation
I In the Model Builder window, expand the Volume I node.
2 Right-click Deformation and choose Delete.
Filter |
I Right-click Volume | and choose Filter.
2 In the Settings window for Filter, locate the Element Selection scction.
3 In the Logical expression for inclusion text field, type x>LL_LX-5*LL_THK.
4 Click the Zoom Extents button in the Graphics toolbar.
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ROOT
Set up the optimization study.

From the Home menu, choose Add Study.

18 | GEOMETRIC PARAMETER OPTIMIZATION OF A BRACKET



ADD STUDY
I Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select Empty Study.
3 Click the Add Study button in the window toolbar.

4 From the Home menu, choose Add Study.

OPTIMIZATION STUDY
In the Settings window for Study, type Optimization Study in the Label text field.

General Optimization

Right-click Optimization Study and choose Optimization > General Optimization.
Eigenfrequency

I Right-click Optimization Study and choosc More Study Extensions > Study Reference.

2 In the Settings window for Study Reference, type Eigenfrequency in the Label text field.

3 Locate the Study Reference scction. From the Study reference list, choose
Eigenfrequency Study.
Stationary
I Right-click Optimization Study and choosc More Study Extensions > Study Reference.
2 In the Settings window for Study Reference, type Stationary in the Label text field.
3 Locate the Study Reference section. From the Study reference list, choose
Stationary Study.
General Optimization
I In the Model Builder window, click General Optimization.
2 In the Settings window for General Optimization, locate the Optimization Solver section.
3 From the Method list, choose COBYLA.
4 Click to expand the Solver Settings section. Clear the Stop if error checkbox.
5 Find the Constraint settings subsection. Select the Enforce design constraints strictly

checkbox.

6 Click Replace Expression in the upper-right corner of the Objective Function section.
From the menu, choose Component | (compl) > Definitions > comp|.mass -

Domain Probe | - kg.
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7 Locate the Objective Function section. In the table, enter the following settings:

Expression Description Evaluate for

comp1.mass Bracket mass Stationary

The first eigenfrequency is to be used in the optimization.
8 From the Solution list, choose Use first.
9 Locate the Control Variables and Parameters section. Click Load from File.

10 Browse to the model’s Application Libraries folder and double-click the file
bracket_optimization_ctrlvars.txt.

Il Locate the Constraints section. In the table, enter the following settings:

Expression Lower bound Upper bound Evaluate for
real(freq) minFreq Eigenfrequency
comp1.maxStress/ 1 Stationary
maxStressLimit

d_0_Cmp 3[mm] Eigenfrequency
d_C_Cmp 3[mm] Eigenfrequency
d_0_C 3[mm] Eigenfrequency
doo 3[mm] Eigenfrequency

12 Click to expand the Output section. Select the Plot checkbox.

13 In the table, enter the following settings:

Plot group Plot window

Stress in Optimized Region Graphics

If some configurations are not valid, the optimization procedure should still continue. The

default is to stop if an error occurs.

Solution 3 (sol3)
I In the Model Builder window, right-click Optimization Study and choose

Show Default Solver.
Run the optimization.

2 Right-click Optimization Study and choose Compute.
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RESULTS

Stress in Optimized Region
I In the Model Builder window, under Results right-click Stress in Optimized Region and
choose Plot.

Examine the stress distribution in the optimized configuration.
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On the last line of Global Constraints Table 7 you will find the values of the natural
frequency and maximum stress in the optimized configuration, as well as the values of
the other constraints.

OBJECTIVE TABLE 3
On the last line of Objective Table 3 you will find the optimal set of parameters, and the
minimum weight. Note that the value in the Objective column can be colored orange if the

solution violates a constraint slightly, but is still accepted within the tolerances.

I In the Objective Table 3 table, right-click the last row and select Copy Selected Rows to

New Parameter Cases.

This last step creates a new parameter case with the optimum parameter values. Next,

synchronize the optimum values and rebuild the geometry.
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GLOBAL DEFINITIONS

Parameters |
I In the Model Builder window, expand the Global Definitions > Parameters | node, then

click Parameters 1.

2 In the Settings window for Parameters, click . Case |.

GEOMETRY

In the Model Builder window, under Component | (compl) right-click Geometry | and
choose Build All.
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