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Introduction

Laminated composite shells made from graphite–epoxy fiber-reinforced plies are widely 
used in many applications due to their high strength-to-weight ratio. Evaluating their 
structural integrity under applied loads is essential for ensuring reliable designs.

This example demonstrates how to perform failure analysis of a laminated composite shells 
using the Layered Shell interface. The laminate is analyzed under multiple load cases and 
loaded to failure, considering in-plane stress states. Both classical and advanced failure 
criteria are described and compared.

This example analyzes a cross-ply laminate subjected to monotonic tension, monotonic 
compression, and biaxial tension to determine the failure loads as a function of the fiber 
angle. This work is inspired by a similar study presented in Ref. 1.

Model Definition

The geometry is a rectangular plate measuring 450 mm in length and 400 mm in width. 
The laminate features a symmetric stacking sequence of four layers, each with a thickness 
of 0.10 mm. The fiber orientation of the cross-ply laminate is parameterized as illustrated 
in Figure 1.

Read more about the Composite Materials Module in COMSOL blog, 
Introduction to the Composite Materials Module.
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Figure 1: Stacking sequence from bottom to top, showing fiber orientation in each ply.

M A T E R I A L  P R O P E R T I E S

All material properties and strengths are given in the layer coordinate system, where the 
first axis is aligned with the fiber orientation. The material parameters and failure 
coefficients are summarized in Table 1 and Table 2.

B O U N D A R Y  C O N D I T I O N S

The laminate is subjected to three different load cases: monoaxial compression, monoaxial 
tension, and biaxial tension. For monoaxial compression and tension, Edge 1 is fixed in 

TABLE 1:  ELASTIC MATERIAL PARAMETERS.

Elastic parameters Value 

{E1, E2} {130.0, 11.0} GPa

G12 5.0 GPa

{υ12, υ23} {0.280, 0.350}

TABLE 2:  FAILURE COEFFICIENTS.

Failure coefficients Value 

{σts1, σts2, σts3} {1700, 70.5, 70.5} MPa

{σcs1, σcs2, σcs3} {1050, 240, 240} MPa

{σss23, σss13, σss12} {96,90,90} MPa
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the X and Z directions, and a boundary load is applied to Edge 3. For the biaxial tension 
case, Edge 1 is fixed in the X and Z directions, Edge 4 is fixed in the Y and Z directions, 
and a boundary load is applied to Edge 2 and Edge 3.

F A I L U R E  C R I T E R I A

Three failure criteria are employed to determine the failure loads: LaRC03, Tsai–Hill, and 
Hashin. The latter two are applied in their plane-stress formulations

LaRC03
This criterion is used to accurately predict the failure of unidirectional FRP laminates 
under in-plane stress. It is one of the most advanced failure models, comprising six 
phenomenological failure modes that describe matrix and fiber failure without relying on 
curve-fitting parameters. The model assumes brittle fracture for matrix compression failure 
and applies the action-plane concept from Mohr–Coulomb theory. It accounts for fiber 
kinking due to misalignment and tensile matrix cracking associated with interlaminar crack 
propagation.

The matrix failure criterion under transverse compression (LaRC03-1) is

 for  and 

where τeff,t and τeff,l are the effective shear stresses in the transverse and longitudinal 
directions, respectively, σi

ss12 is the in situ in-plane shear strength, σss23 is the shear 
strength in the transverse direction, and σcs2 is the compressive strength in the transverse 
direction. The effective shear stresses are functions of the fracture plane angle which is 
found by maximizing the Mohr–Coulomb effective stresses.

The matrix failure criterion under transverse tension (LaRC03-2) is

 for 

where σi
ts2 is the in situ transverse tensile strength, and r is a dimensionless parameter 

based on fracture toughness.

The fiber failure criterion under longitudinal tension (LaRC03-3) is

 for 
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The fiber failure criterion under matrix tension (LaRC03-4) is

 for 

The fiber failure criterion under matrix compression (LaRC03-5) is

 for 

where σm
ij are the ply stresses transformed to the misalignment coordinate frame, and ηl 

is a nondimensional parameter based on the failure strength and fracture plane angle under 
uniaxial transverse compression.

The matrix failure criterion under biaxial compression (LaRC03-6) is

 for  and 

where the effective shear stresses in the transverse and longitudinal directions, τm
eff,t and 

τm
eff,l, are calculated from the stresses in the misaligned coordinates.

The failure criterion for the composite is then computed by selecting the most critical 
failure mode

Tsai–Hill
The Tsai-Hill criterion follows a polynomial description 

where σi is the 6-by-1 stress vector (sorted using Voigt notation), Fij is a 6-by-6 symmetric 
matrix that contains the coefficients for the quadratic terms. For the plane stress case, many 
of the coefficients are zero except for the following:
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, 

Hashin
The Hashin failure theory is an extension of the Hashin–Rotem model that incorporates 
six failure modes, including fiber, matrix, and interlaminar failure, with distinctions 
between tension and compression. Stress interactions are considered in determining the 
tensile fiber failure mode, tensile matrix failure mode, and compressive matrix failure 
mode.

The fiber failure criterion in tension is defined by

 for 

The fiber failure criterion in compression is defined by

 for 

The matrix failure criterion in tension is defined by

 for 

The matrix failure criterion in compression is defined by

for 

The interlaminar failure criterion in tension is defined by

 for 

The interlaminar failure criterion in compression is defined by
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 for 

The failure criterion for the composite is computed by selecting the most critical failure 
mode

The plane-stress version of the Hashin criterion is obtained by setting σ13 = σ23 = σ33 = 0. 
However, the interlaminar failure cannot then be predicted.

Results and Discussion

The mechanical loading of the laminate is systematically increased until damage is 
detected, at which point the load is defined as the failure load. For each load case in this 
study, the plots in Figure 2, Figure 3, and Figure 4 show the failure loads for the three 
failure criteria as functions of the fiber angle.

Figure 2: Monoaxial compression test.
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Figure 3: Monoaxial tension test.

Figure 4: Biaxial tension test.
8 |  P A R A M E T R I C  S T U D Y  O N  C R O S S - P L Y  L A M I N A T E  F A I L U R E



Notes About the COMSOL Implementation

• Modeling a composite laminate as a layered shell requires a surface geometry, in general 
referred to as a base surface, and a Layered Material node which adds an extra dimension 
(1D) to the base surface geometry in the surface normal direction. You can use the 
Layered Material functionality to model several layers stacked on top of each other 
having different thicknesses, material properties, and fiber orientations. You can 
optionally specify the interface materials between the layers, and control the number of 
through-thickness mesh elements for each layer.

• The Layered Material Link and Layered Material Stack have an option to transform given 
Layered Material into a symmetric or antisymmetric laminate. A repeated laminate can 
also be constructed using a transform option.

• The third direction for the selected coordinate system in the Single Layer Material, 
Layered Material Link, or Layered Material Stack represents the normal direction of the 
Layered Shell or Shell physics. This is also the direction in which the layer stacking is 
interpreted from bottom to top, and therefore, it is crucial to know it during modeling. 
There are two ways to achieve this: 

- Using physics symbols: Go to the physics settings, find the Physics Symbols section, 
and select the Enable physics symbols checkbox. Then go to the material feature, for 
instance, Linear Elastic Material, to see the normal direction represented by green 
arrows in the geometry.

- Using result templates: When a solution dataset is available, use the result template 
Thickness and Orientation to plot the normal direction.

• From a constitutive model point of view, you can either use the Layerwise (LW) theory 
based Layered Shell interface, or the Equivalent Single Layer (ESL) theory based Linear 

Elastic Material, Layered node in the Shell interface. The laminated composite presented 
in the current model is modeled using the Layered Shell interface.

• Since we are only interested in the failure loads, the Stop Condition node is included in 
our solver configurations to prevent the load from increasing further once damage is 
detected at the current fiber angle.

Reference

1. P. Nali and E. Carrera, “A numerical assessment on two-dimensional failure criteria for 
composite layered structures,” Composites Part B: Engineering, vol. 43, no. 2, pp. 280–
289, 2012; doi.org/10.1016/j.compositesb.2011.06.018.
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Application Library path: Composite_Materials_Module/
Verification_Examples/parametric_study_on_crossply_laminate_failure

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics > Layered Shell (lshell).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies > Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
parametric_study_on_crossply_laminate_failure_parameters.txt.

Define the load case parameters.

Load Case Parameters
1 In the Home toolbar, click Parameters and choose Add > Parameters.

2 In the Settings window for Parameters, type Load Case Parameters in the Label text 
field.
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3 Locate the Parameters section. In the table, enter the following settings:

In any node in the Model Builder, you can add comments to explain the settings. Right 
click on the node to select the Properties and Comments option to add the comment.

4 In the Home toolbar, click Parameter Case.

5 In the Settings window for Case, type Monoaxial Compression in the Label text field.

6 Locate the Parameters section. In the table, enter the following settings:

7 In the Home toolbar, click Parameter Case.

8 In the Settings window for Case, type Monoaxial Tension in the Label text field.

9 In the Home toolbar, click Parameter Case.

10 In the Settings window for Case, type Biaxial Tension in the Label text field.

11 Locate the Parameters section. In the table, enter the following settings:

In this model, three different failure criteria will be applied to determine failure. Define 
the relevant parameters to create safety cases for each criterion and to establish the stop 
condition in the study node.

Safety Case
1 In the Home toolbar, click Parameters and choose Add > Parameters.

2 In the Settings window for Parameters, type Safety Case in the Label text field.

3 Locate the Parameters section. In the table, enter the following settings:

Name Expression Value Description

xLoad 1 1 Load magnitude in x-direction

yLoad 0 0 Load magnitude in y-direction

Name Expression Description

xLoad -1 Load magnitude in x-direction

Name Expression Description

yLoad 1 Load magnitude in y-direction

Name Expression Value Description

safety1 1 1 Used to turn on the LaRC03 
criterion in the stop condition
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4 In the Home toolbar, click Parameter Case.

5 In the Settings window for Case, type LaRC03 in the Label text field.

6 In the Home toolbar, click Parameter Case.

7 In the Settings window for Case, type Tsai-Hill in the Label text field.

8 Locate the Parameters section. In the table, enter the following settings:

9 In the Home toolbar, click Parameter Case.

10 In the Settings window for Case, type Hashin in the Label text field.

11 Locate the Parameters section. In the table, enter the following settings:

Unidirectional Fiber Composite
1 In the Model Builder window, under Global Definitions right-click Materials and choose 

Blank Material.

2 In the Model Builder window, click Material 1 (mat1).

3 In the Settings window for Material, click to expand the Material Properties section.

4 In the Material properties tree, select Basic Properties > Density.

5 Click Add to Material.

6 In the Label text field, type Unidirectional Fiber Composite.

7 Locate the Material Properties section. In the Material properties tree, select 
Solid Mechanics > Linear Elastic Material > Transversely Isotropic.

safety2 0 0 Used to turn on the Tsai-Hill 
criterion in the stop condition

safety3 0 0 Used to turn on the Hashin 
criterion in the stop condition

Name Expression Description

safety1 0 Used to turn on the LaRC03 criterion in the stop 
condition

safety2 1 Used to turn on the Tsai-Hill criterion in the stop 
condition

Name Expression Description

safety1 0 Used to turn on the LaRC03 criterion in the stop 
condition

safety3 1 Used to turn on the Hashin criterion in the stop condition

Name Expression Value Description
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8 Click Add to Material.

9 In the Material properties tree, select Solid Mechanics > Strength Limits > 
Orthotropic Strength Parameters, Voigt Notation.

10 Click Add to Material.

11 In the Model Builder window, under Global Definitions > Materials > 
Unidirectional Fiber Composite (mat1) click Basic (def).

12 In the Settings window for Basic, locate the Output Properties section.

13 In the table, enter the following settings:

14 In the Model Builder window, under Global Definitions > Materials > 
Unidirectional Fiber Composite (mat1) click Transversely isotropic (TransverseIsotropic).

15 In the Settings window for Transversely Isotropic, locate the Output Properties section.

16 In the table, enter the following settings:

17 In the Model Builder window, under Global Definitions > Materials > 
Unidirectional Fiber Composite (mat1) click Orthotropic strength parameters,

Voigt notation (OrthotropicStrengthParameters).

18 In the Settings window for Orthotropic Strength Parameters, Voigt Notation, locate the 
Output Properties section.

19 In the table, enter the following settings:

Property Variable Expression Unit Size

Density rho Rho kg/m³ 1x1

Property Variable Expression Unit Size

Young’s modulus {Evect1, Evect2} {E1, E2} Pa 2x1

Poisson’s ratio {nuvect1, nuvect2} {nu12, nu23} 1 2x1

Shear modulus Gvect1 G N/m² 1x1

Property Variable Expression Unit Size

Tensile strengths {sigmats1, 
sigmats2, 
sigmats3}

{XT, YT, 
YT}

Pa 3x1

Compressive strengths {sigmacs1, 
sigmacs2, 
sigmacs3}

{XC, YC, 
YC}

Pa 3x1
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Now add a Layered Material node and assign appropriate thickness and rotation angles to 
each layer. The laminate is symmetric. It is sufficient to define only half the laminate in the 
Layered Material node. The transformation into a full laminate is performed through the 
layered material settings in the Layered Material Link node.

Laminate
1 In the Model Builder window, right-click Materials and choose Layered Material.

2 In the Settings window for Layered Material, type Laminate in the Label text field.

3 Locate the Layer Definition section. In the table, enter the following settings:

4 Click Add.

5 In the table, enter the following settings:

G E O M E T R Y  1

Work Plane 1 (wp1)
In the Geometry toolbar, click Work Plane.

Work Plane 1 (wp1) > Plane Geometry
In the Model Builder window, click Plane Geometry.

Shear strengths {sigmass1, 
sigmass2, 
sigmass3}

{ST, SL, 
SL}

Pa 3x1

Ultimate tensile strain in 
longitudinal direction

epsilont1 epsT11 1 1x1

Layer Material Rotation Value Thickness Mesh 
elements

Layer 1 Unidirectional 
Fiber 
Composite 
(mat1)

theta 0.7854 
rad

th 1

Layer Material Rotation Value Thickness Mesh 
elements

Layer 2 Unidirectional 
Fiber 
Composite 
(mat1)

-theta -0.7854 
rad

th 1

Property Variable Expression Unit Size
14 |  P A R A M E T R I C  S T U D Y  O N  C R O S S - P L Y  L A M I N A T E  F A I L U R E



Work Plane 1 (wp1) > Rectangle 1 (r1)
1 In the Work Plane toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type W.

4 In the Height text field, type H.

5 Click Build Selected.

D E F I N I T I O N S

Average 1 (aveop1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 In the Settings window for Average, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose All boundaries.

Define the stop conditions in the Variables node.

Variables 1
1 In the Model Builder window, right-click Definitions and choose Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

Name Expression Unit Description

stopCondition1 safety1*
aveop1(lshell.xdintopall(lsh
ell.lemm1.sf1.d_i))>eps

Stop 
condition 
for LaRC03 
criterion

stopCondition2 safety2*
aveop1(lshell.xdintopall(lsh
ell.lemm1.sf2.d_i))>eps

Stop 
condition 
for Tsai-
Hill 
criterion

stopCondition3 safety3*
aveop1(lshell.xdintopall(lsh
ell.lemm1.sf3.d_i))>eps

Stop 
condition 
for Hashin 
criterion
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M A T E R I A L S

Layered Material Link 1 (llmat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Layers > Layered Material Link.

The half laminate defined in the Layered Material node can be transformed into a full 
symmetric laminate using a transform option in the layered material settings.

2 In the Settings window for Layered Material Link, locate the Layered Material Settings 
section.

3 From the Transform list, choose Symmetric.

4 Click to expand the Preview Plot Settings section. In the Thickness-to-width ratio text 
field, type 0.5.

5 Locate the Layered Material Settings section. Click Layer Cross-Section Preview in the 
upper-right corner of the section.

6 Click Layer Stack Preview in the upper-right corner of the Layered Material Settings 
section.

L A Y E R E D  S H E L L  ( L S H E L L )

Set the discretization for the displacement field to Linear in order to resemble the 
benchmark example.

1 In the Model Builder window, under Component 1 (comp1) click Layered Shell (lshell).

2 In the Settings window for Layered Shell, click to expand the Discretization section.

3 From the Displacement field list, choose Linear.

Linear Elastic Material 1
1 In the Model Builder window, under Component 1 (comp1) > Layered Shell (lshell) click 

Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 Select the Transversely isotropic checkbox.

Safety 1: LaRC03
1 In the Physics toolbar, click Attributes and choose Safety.

2 In the Settings window for Safety, type Safety 1: LaRC03 in the Label text field.

3 Locate the Failure Model section. From the Failure criterion list, choose LaRC03.
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Linear Elastic Material 1
In the Model Builder window, click Linear Elastic Material 1.

Safety 2: Tsai–Hill
1 In the Physics toolbar, click Attributes and choose Safety.

2 In the Settings window for Safety, type Safety 2: Tsai-Hill in the Label text field.

3 Locate the Failure Model section. From the Failure criterion list, choose Tsai–Hill.

4 Select the Use plane stress formulation checkbox.

Linear Elastic Material 1
In the Model Builder window, click Linear Elastic Material 1.

Safety 3: Hashin
1 In the Physics toolbar, click Attributes and choose Safety.

2 In the Settings window for Safety, type Safety 3: Hashin in the Label text field.

3 Locate the Failure Model section. From the Failure criterion list, choose Hashin.

4 Select the Use plane stress formulation checkbox.

Boundary Load 1
1 In the Physics toolbar, click Edges and choose Boundary Load.

2 Select Edge 4 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the fA vector as

Boundary Load 2
1 In the Physics toolbar, click Edges and choose Boundary Load.

2 Select Edge 3 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the fA vector as

Prescribed Displacement 1
1 In the Physics toolbar, click Edges and choose Prescribed Displacement.

2 Select Edge 1 only.

xLoad*loadPara x

yLoad*loadPara y
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3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 From the Displacement in x direction list, choose Prescribed.

5 From the Displacement in z direction list, choose Prescribed.

Prescribed Displacement 2
1 In the Physics toolbar, click Edges and choose Prescribed Displacement.

2 Select Edge 2 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 From the Displacement in y direction list, choose Prescribed.

5 From the Displacement in z direction list, choose Prescribed.

M E S H  1

Mapped 1
1 In the Mesh toolbar, click More Generators and choose Mapped.

2 Select Boundary 1 only.

Distribution 1
1 Right-click Mapped 1 and choose Distribution.

2 Select Edges 1 and 2 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 10.

5 In the Model Builder window, right-click Mesh 1 and choose Build All.

S T U D Y  1

Set up three parametric sweeps: first for fiber angle, second for load cases, and third for 
failure criterion.

Theta Sweep
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, type Theta Sweep in the Label text field.

3 Locate the Study Settings section. Click Add.
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4 In the table, enter the following settings:

Load Case Switch
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, type Load Case Switch in the Label text 
field.

3 Locate the Study Settings section. From the Sweep type list, choose Parameter switch.

4 Click Add.

5 In the table, enter the following settings:

Safety Case Switch
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, type Safety Case Switch in the Label 
text field.

3 Locate the Study Settings section. From the Sweep type list, choose Parameter switch.

4 Click Add.

5 In the table, enter the following settings:

Step 1: Stationary
1 In the Model Builder window, click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study Extensions section.

3 Select the Auxiliary sweep checkbox.

4 Click Add.

5 In the table, enter the following settings:

Parameter name Parameter value list Parameter unit

theta (Fiber angle) range(0,10,90) deg

Switch Cases Case numbers

Load Case Parameters All range(1,1,3)

Switch Cases Case numbers

Safety Case All range(1,1,3)

Parameter name Parameter value list Parameter unit

loadPara (Load parameter) range(0,0.05,1.8) GPa
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Solution 1 (sol1)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

Define three stop conditions that will terminate the parametric solver and advance to 
the next fiber angle as soon as any one of them is satisfied. A condition is considered 
fulfilled when the surface-averaged damage index exceeds zero according to the selected 
failure criterion. The applicable condition depends on the current safety case.

3 In the Model Builder window, expand the Study 1 > Solver Configurations > 
Solution 1 (sol1) > Stationary Solver 1 node.

4 Right-click Study 1 > Solver Configurations > Solution 1 (sol1) > Stationary Solver 1 > 
Parametric 1 and choose Stop Condition.

5 In the Settings window for Stop Condition, locate the Stop Expressions section.

6 Click Add.

7 In the table, enter the following settings:

8 Click Add.

9 In the table, enter the following settings:

10 Click Add.

11 In the table, enter the following settings:

12 Locate the Output at Stop section. From the Add solution list, choose 
Steps before and after stop.

Disable the default plots for this study.

Stop expression Stop if Active Description

comp1.stopCondition1 True (>=1) √ Stop if LaRC03 
damage index is 
greater than zero

Stop expression Stop if Active Description

comp1.stopCondition2 True (>=1) √ Stop if Tsai-Hill 
damage index is 
greater than zero

Stop expression Stop if Active Description

comp1.stopCondition3 True (>=1) √ Stop if Hashin 
damage index is 
greater than zero
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13 In the Model Builder window, click Study 1.

14 In the Settings window for Study, locate the Study Settings section.

15 Clear the Generate default plots checkbox.

16 In the Study toolbar, click Compute.

R E S U L T S

Use evaluation groups to compute the failure loads and averaged damage index. Select the 
checkbox in the result node to enable automatic reevaluation of evaluation groups when 
the model is resolved.

1 In the Model Builder window, click Results.

2 In the Settings window for Results, locate the Update of Results section.

3 Select the Reevaluate all evaluation groups after solving checkbox.

Layered Material 1
1 In the Model Builder window, expand the Results node.

2 Right-click Results > Datasets and choose More Datasets > Layered Material.

3 In the Settings window for Layered Material, locate the Data section.

4 From the Dataset list, choose Study 1/Parametric Solutions 1 (sol2).

Failure Load and Averaged Damage Index: LaRC03
1 In the Model Builder window, right-click Results and choose Node Group.

2 In the Settings window for Group, type Failure Load and Averaged Damage Index: 
LaRC03 in the Label text field.

Monoaxial Compression, LaRC03
1 In the Results toolbar, click Evaluation Group.

2 In the Settings window for Evaluation Group, type Monoaxial Compression, LaRC03 
in the Label text field.

3 Locate the Data section. From the Dataset list, choose Layered Material 1.

4 From the Safety Case, Load Case Parameters list, choose From list.

5 In the Safety Case, Load Case Parameters list box, select 1: LaRC03,

Monoaxial Compression.

6 From the Parameter selection (loadPara) list, choose Last.

7 Click to expand the Format section. From the Include parameters list, choose Off.
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Surface Average 1
1 Right-click Monoaxial Compression, LaRC03 and choose Average > Surface Average.

2 Select Boundary 1 only.

3 In the Settings window for Surface Average, locate the Expressions section.

4 In the table, enter the following settings:

Monoaxial Compression, LaRC03
1 In the Model Builder window, click Monoaxial Compression, LaRC03.

2 In the Monoaxial Compression, LaRC03 toolbar, click Evaluate.

Monoaxial Tension,  LaRC03
1 Right-click Monoaxial Compression, LaRC03 and choose Duplicate.

2 In the Settings window for Evaluation Group, type Monoaxial Tension,  LaRC03 in 
the Label text field.

3 Locate the Data section. In the Safety Case, Load Case Parameters list box, select 
2: LaRC03, Monoaxial Tension.

4 In the Monoaxial Tension,  LaRC03 toolbar, click Evaluate.

Biaxial Tension, LaRC03
1 Right-click Monoaxial Tension, LaRC03 and choose Duplicate.

2 In the Settings window for Evaluation Group, type Biaxial Tension, LaRC03 in the 
Label text field.

3 Locate the Data section. In the Safety Case, Load Case Parameters list box, select 
3: LaRC03, Biaxial Tension.

4 In the Biaxial Tension, LaRC03 toolbar, click Evaluate.

Failure Load and Averaged Damage Index: Tsai–Hill
1 In the Model Builder window, right-click Results and choose Node Group.

2 In the Settings window for Group, type Failure Load and Averaged Damage Index: 
Tsai-Hill in the Label text field.

Monoaxial Compression, Tsai–Hill
1 In the Results toolbar, click Evaluation Group.

Expression Unit Description

theta deg Fiber angle

loadPara GPa Load parameter

lshell.lemm1.sf1.d_i 1 LaRC03 damage index
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2 In the Settings window for Evaluation Group, type Monoaxial Compression, Tsai-
Hill in the Label text field.

3 Locate the Data section. From the Dataset list, choose Layered Material 1.

4 From the Safety Case, Load Case Parameters list, choose From list.

5 In the Safety Case, Load Case Parameters list box, select 4: Tsai–Hill,

Monoaxial Compression.

6 From the Parameter selection (loadPara) list, choose Last.

7 Locate the Format section. From the Include parameters list, choose Off.

Surface Average 1
1 Right-click Monoaxial Compression, Tsai–Hill and choose Average > Surface Average.

2 Select Boundary 1 only.

3 In the Settings window for Surface Average, locate the Expressions section.

4 In the table, enter the following settings:

Monoaxial Compression, Tsai–Hill
1 In the Model Builder window, click Monoaxial Compression, Tsai–Hill.

2 In the Monoaxial Compression, Tsai–Hill toolbar, click Evaluate.

Monoaxial Tension, Tsai–Hill
1 Right-click Monoaxial Compression, Tsai–Hill and choose Duplicate.

2 In the Settings window for Evaluation Group, type Monoaxial Tension, Tsai-Hill in 
the Label text field.

3 Locate the Data section. In the Safety Case, Load Case Parameters list box, select 5: Tsai–

Hill, Monoaxial Tension.

4 In the Monoaxial Tension, Tsai–Hill toolbar, click Evaluate.

Biaxial Tension, Tsai–Hill
1 Right-click Monoaxial Tension, Tsai–Hill and choose Duplicate.

2 In the Settings window for Evaluation Group, type Biaxial Tension, Tsai-Hill in 
the Label text field.

Expression Unit Description

theta deg Fiber angle

loadPara GPa Load parameter

lshell.lemm1.sf2.d_i 1 Tsai-Hill damage index, plane 
stress
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3 Locate the Data section. In the Safety Case, Load Case Parameters list box, select 6: Tsai–

Hill, Biaxial Tension.

4 In the Biaxial Tension, Tsai–Hill toolbar, click Evaluate.

Failure Load and Averaged Damage Index: Hashin
1 In the Model Builder window, right-click Results and choose Node Group.

2 In the Settings window for Group, type Failure Load and Averaged Damage Index: 
Hashin in the Label text field.

Monoaxial Compression, Hashin
1 In the Results toolbar, click Evaluation Group.

2 In the Settings window for Evaluation Group, type Monoaxial Compression, Hashin 
in the Label text field.

3 Locate the Data section. From the Dataset list, choose Layered Material 1.

4 From the Safety Case, Load Case Parameters list, choose From list.

5 In the Safety Case, Load Case Parameters list box, select 7: Hashin,

Monoaxial Compression.

6 From the Parameter selection (loadPara) list, choose Last.

7 Locate the Format section. From the Include parameters list, choose Off.

Surface Average 1
1 Right-click Monoaxial Compression, Hashin and choose Average > Surface Average.

2 Select Boundary 1 only.

3 In the Settings window for Surface Average, locate the Expressions section.

4 In the table, enter the following settings:

Monoaxial Compression, Hashin
1 In the Model Builder window, click Monoaxial Compression, Hashin.

2 In the Monoaxial Compression, Hashin toolbar, click Evaluate.

Monoaxial Tension, Hashin
1 Right-click Monoaxial Compression, Hashin and choose Duplicate.

Expression Unit Description

theta deg Fiber angle

loadPara GPa Load parameter

lshell.lemm1.sf3.d_i 1 Hashin damage index, plane 
stress
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2 In the Settings window for Evaluation Group, type Monoaxial Tension, Hashin in the 
Label text field.

3 Locate the Data section. In the Safety Case, Load Case Parameters list box, select 
8: Hashin, Monoaxial Tension.

4 In the Monoaxial Tension, Hashin toolbar, click Evaluate.

Biaxial Tension, Hashin
1 Right-click Monoaxial Tension, Hashin and choose Duplicate.

2 In the Settings window for Evaluation Group, type Biaxial Tension, Hashin in the 
Label text field.

3 Locate the Data section. In the Safety Case, Load Case Parameters list box, select 
9: Hashin, Biaxial Tension.

4 In the Biaxial Tension, Hashin toolbar, click Evaluate.

Create 1D plots to compare failure loads for each load cases based on different failure 
criterion.

Monoaxial Compression
1 In the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Monoaxial Compression in the Label 
text field.

3 Locate the Data section. From the Dataset list, choose None.

4 Click to expand the Title section. From the Title type list, choose Manual.

5 In the Title text area, type Monoaxial Compression.

6 Locate the Plot Settings section.

7 Select the x-axis label checkbox. In the associated text field, type Fiber Angle (deg).

8 Select the y-axis label checkbox. In the associated text field, type Failure Load (GPa).

9 Locate the Grid section. Clear the Show grid checkbox.

LaRC03
1 Right-click Monoaxial Compression and choose Table Graph.

2 In the Settings window for Table Graph, type LaRC03 in the Label text field.

3 Locate the Data section. From the Source list, choose Evaluation group.

4 From the x-axis data list, choose Fiber angle (deg).

5 From the Plot columns list, choose Manual.

6 In the Columns list box, select Load parameter (GPa).
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7 Locate the Coloring and Style section. From the Color list, choose Red.

8 From the Width list, choose 3.

9 Click to expand the Legends section. Select the Show legends checkbox.

10 From the Legends list, choose Manual.

11 In the table, enter the following settings:

Tsai–Hill
1 Right-click LaRC03 and choose Duplicate.

2 In the Settings window for Table Graph, type Tsai-Hill in the Label text field.

3 Locate the Data section. From the Evaluation group list, choose Monoaxial Compression,

Tsai–Hill.

4 Locate the Coloring and Style section. From the Color list, choose Blue.

5 Find the Line markers subsection. From the Marker list, choose Asterisk.

6 Locate the Legends section. In the table, enter the following settings:

Hashin
1 Right-click Tsai–Hill and choose Duplicate.

2 In the Settings window for Table Graph, type Hashin in the Label text field.

3 Locate the Data section. From the Evaluation group list, choose Monoaxial Compression,

Hashin.

4 Locate the Coloring and Style section. From the Color list, choose Black.

5 Find the Line markers subsection. From the Marker list, choose None.

6 Find the Line style subsection. From the Line list, choose Dashed.

7 Locate the Legends section. In the table, enter the following settings:

Monoaxial Compression
1 In the Model Builder window, click Monoaxial Compression.

Legends

LaRC03

Legends

Tsai-Hill

Legends

Hashin
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2 In the Monoaxial Compression toolbar, click Plot.

Monoaxial Tension
1 Right-click Monoaxial Compression and choose Duplicate.

2 In the Settings window for 1D Plot Group, type Monoaxial Tension in the Label text 
field.

3 Locate the Title section. In the Title text area, type Monoaxial Tension.

LaRC03
1 In the Model Builder window, expand the Monoaxial Tension node, then click LaRC03.

2 In the Settings window for Table Graph, locate the Data section.

3 From the Evaluation group list, choose Monoaxial Tension, LaRC03.

Tsai–Hill
1 In the Model Builder window, click Tsai–Hill.

2 In the Settings window for Table Graph, locate the Data section.

3 From the Evaluation group list, choose Monoaxial Tension, Tsai–Hill.

Hashin
1 In the Model Builder window, click Hashin.

2 In the Settings window for Table Graph, locate the Data section.

3 From the Evaluation group list, choose Monoaxial Tension, Hashin.

Monoaxial Tension
1 In the Model Builder window, click Monoaxial Tension.

2 In the Monoaxial Tension toolbar, click Plot.

Biaxial Tension
1 Right-click Monoaxial Tension and choose Duplicate.

2 In the Settings window for 1D Plot Group, type Biaxial Tension in the Label text field.

3 Locate the Title section. In the Title text area, type Biaxial Tension.

LaRC03
1 In the Model Builder window, expand the Biaxial Tension node, then click LaRC03.

2 In the Settings window for Table Graph, locate the Data section.

3 From the Evaluation group list, choose Biaxial Tension, LaRC03.

Tsai–Hill
1 In the Model Builder window, click Tsai–Hill.
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2 In the Settings window for Table Graph, locate the Data section.

3 From the Evaluation group list, choose Biaxial Tension, Tsai–Hill.

Hashin
1 In the Model Builder window, click Hashin.

2 In the Settings window for Table Graph, locate the Data section.

3 From the Evaluation group list, choose Biaxial Tension, Hashin.

Biaxial Tension
1 In the Model Builder window, click Biaxial Tension.

2 In the Biaxial Tension toolbar, click Plot.
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