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Introduction

Fiber composites are widely used in industrial applications. Compared to more traditional 
metallic engineering materials, fiber composites often have superior specific stiffness and 
strength properties. Properties like toughness, stiffness, and weight can often be tailored 
to specific applications such as a diaphragm in loudspeakers.

Loudspeaker design is a challenging task, where the design objective is to achieve better 
sound quality without violating manufacturing and operational constraints. The sound 
quality depends on many parameters, one of them being the ability to control, damp, and 
shift the diaphragm resonance, and another controlling the diaphragm breakup. 
Composites can be used to make diaphragms that give a smoother frequency response 
compared to conventional diaphragm materials like titanium. The ability of composites to 
break the symmetries in mode shapes and shift resonances can improve the frequency 
response of a dome tweeter.

This multiphysics example analyzes the frequency response of a tweeter dome. The model 
uses the Pressure Acoustic, Frequency Domain interface of the Acoustic Module in 
combination with the Electrical Circuit interface from the AC/DC Module, the Solid 

Mechanics interface from the Structural Mechanics Module, and the Layered Shell interface 
from the Composite Materials Module.

This example uses composite materials imported from the accompanying Composite 
Materials Module Application Library model Dome Tweeter with Composite Diaphragm 
— Eigenfrequency Analysis.

Model Definition

Figure 1 shows the tweeter-dome geometry. For acoustic modeling, the air domains 
surrounding the tweeter dome also need to be modeled. The model geometry of the 
tweeter dome is shown in Figure 2. Due to geometry and material symmetries, only one 
quarter of the geometry is needed for modeling.

Read more about the Composite Materials Module in the COMSOL 
blog, Introduction to the Composite Materials Module.
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Figure 1: Geometry showing a half section of a tweeter dome.

Figure 2: Computational domain corresponding to one quarter of the geometry.

Material Properties
The different components of the tweeter dome use different materials. For the diaphragm, 
three different materials are tested: two composite materials and one monolithic material, 
like titanium. The composite properties are computed from a micromechanical analysis 
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(imported in the model), while the material properties of titanium are taken from the 
built-in material library. The suspension is made of rubber, with material properties taken 
from the built-in material library. The former is made of glass fiber and its material 
properties are noted in Table 1.

For the surrounding air domains, air from the built-in material library is used. For the soft 
porous parts of the tweeter, the fluid material is assumed to be air, while the matrix 
material is assumed to be foam with the material properties listed in Table 2.

The coil is made of built-in copper material which is available in the material library.

Physics Setup and Boundary Conditions
Each physics interface has different loading and boundary conditions. The voltage is the 
main driving force of the dome tweeter. The electric physics is modeled by lumped 
elements using the Electric Currents interface. This interface has one ground node and two 
voltage sources in addition to two resistors and one inductor.

The structural domains are modeled by Solid Mechanics and Layered Shell interfaces. The 
common boundaries between these two interfaces are connected through the multiphysics 
coupling. For the Solid Mechanics interface, a body load is applied in the axial direction to 
account for the magnetic field. For the Layered Shell interface, the outer boundaries are 
fixed.

For the PPressure Acoustic, Frequency Domain interface, the exterior boundaries of the air 
domains are modeled as perfectly matched boundaries. The structural interfaces are 
coupled to the Pressure Acoustic, Frequency Domain interface through multiphysics 
couplings.

TABLE 1:  GLASS FIBER MATERIAL PROPERTIES.

Material Property Value

E 70 GPa

υ 0.33

ρ 2000 kg/m3

TABLE 2:  FOAM MATERIAL PROPERTIES.

Material Property Value

εp 0.97

Rf 55000 Pa.s/m2

Lv 41 um

Lth 117 um

τ∞ 2.47
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All interfaces except the Electric Currents have symmetry boundary conditions.

Results and Discussion

Figure 3 shows the displacement of the diaphragm at 10 kHz with different materials. The 
displacement magnitude is larger for composite materials due to the lower specific weight.

The acoustic pressure profile and sound pressure level computed for different diaphragm 
materials are shown in Figure 4 and Figure 5, respectively.

Figure 3: Displacement of the diaphragm.
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Figure 4: Acoustic pressure profile for different diaphragm materials.

Figure 5: Sound pressure level for different diaphragm materials.
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Figure 6 shows frequency-response curves for different diaphragm materials. Note that the 
continuous curves are obtained by solving the same model for a fine frequency range, 
while the dotted response is obtained for a coarse frequency range to reduce computation 
time.

Many important observations can be made from these curves. The first breakup frequency 
is shifted to higher frequency when using composite materials as compared to titanium. 
Based on results presented in the model Dome Tweeter with Composite Diaphragm — 
Eigenfrequency Analysis, the first eigenmodes for the composite materials are 
antisymmetric and cannot thus be excited by the coil movement, leading to a higher first 
peak in the sensitivity. This helps to get a smoother frequency-response curve. A smooth 
frequency response means smoother and higher-quality sound, eliminating trashy sound 
patterns. So, for a tweeter whose working range is 4–8 kHz, the use of titanium is not 
advisable as it will give a trashy sound due to the breakup mode being in the same range. 
Using a composite diaphragm will shift the breakup mode from the working range of the 
tweeter and give a higher-quality sound. Another advantage of using a composite material 
for the diaphragm is that it is much lighter than titanium.

The spatial sensitivity analysis of a diaphragm with titanium, composite material 1, and 
composite material 2 for 10 kHz are shown in Figure 7, Figure 8, and Figure 9, 
respectively.

Figure 6: Frequency response curves for different diaphragm materials.
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Figure 7: Spatial sensitivity with a diaphragm made of titanium.

Figure 8: Spatial sensitivity with a diaphragm made of the first composite material.
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Figure 9: Spatial sensitivity with a diaphragm made of the second composite material.

Notes About the COMSOL Implementation

• Modeling a composite laminate as a layered shell requires a surface geometry, in general 
referred to as a base surface, and a Layered Material node which adds an extra dimension 
(1D) to the base surface geometry in the surface normal direction. You can use the 
Layered Material functionality to model several layers stacked on top of each other 
having different thicknesses, material properties, and fiber orientations. You can 
optionally specify the interface materials between the layers, and control the number of 
through-thickness mesh elements for each layer.

• The third direction for the selected coordinate system in the Single Layer Material, 
Layered Material Link, or Layered Material Stack represents the normal direction of the 
Layered Shell or Shell physics. This is also the direction in which the layer stacking is 
interpreted from bottom to top, and therefore, it is crucial to know it during modeling. 
There are two ways to achieve this: 

- Using physics symbols: Go to the physics settings, find the Physics Symbols section, 
and select the Enable physics symbols checkbox. Then go to the material feature, for 
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instance, Linear Elastic Material, to see the normal direction represented by green 
arrows in the geometry.

- Using result templates: When a solution dataset is available, use the result template 
Thickness and Orientation to plot the normal direction.

• To run the analysis for different layered materials and compare the results, all the layered 
materials can be defined using a Switch node in Global Materials. This Switch node can 
be selected in the Layered Material Link node and a Material Sweep node is added in the 
study.

• From a constitutive model point of view, you can either use the Layerwise (LW) theory 
based Layered Shell interface, or the Equivalent Single Layer (ESL) theory based Linear 

Elastic Material, Layered node in the Shell interface. The laminated composite presented 
in the current model is modeled using a Layered Shell interface.

Application Library path: Composite_Materials_Module/Multiphysics/
composite_dome_tweeter_freq

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics > Layered Shell (lshell).

3 Right-click and choose Add Physics.

4 In the Select Physics tree, select Structural Mechanics > Solid Mechanics (solid).

5 Right-click and choose Add Physics.

6 In the Select Physics tree, select Acoustics > Pressure Acoustics > Pressure Acoustics,

Frequency Domain (acpr).

7 Right-click and choose Add Physics.

8 In the Select Physics tree, select AC/DC > Electrical Circuit (cir).

9 Right-click and choose Add Physics.
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10 Click Study.

11 In the Select Study tree, select General Studies > Frequency Domain.

12 Click Done.

Import the geometric and model parameters from text files.

G L O B A L  D E F I N I T I O N S

Geometry Parameters
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, type Geometry Parameters in the Label text 
field.

3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
composite_dome_tweeter_freq_geom_parameters.txt.

Model Parameters
1 In the Home toolbar, click Parameters and choose Add > Parameters.

2 In the Settings window for Parameters, type Model Parameters in the Label text field.

3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
composite_dome_tweeter_freq_model_parameters.txt.

Import numerical data for interpolation functions from files.

Interpolation Function: Lp Data
1 In the Home toolbar, click Functions and choose Global > Interpolation.

2 In the Settings window for Interpolation, type Interpolation Function: Lp Data in 
the Label text field.

3 Locate the Definition section. From the Data source list, choose File.

4 Click Browse.

5 Browse to the model’s Application Libraries folder and double-click the file 
composite_dome_tweeter_freq_Lp_data.txt.

6 Locate the Data Column Settings section. In the table, click to select the cell at row 
number 1 and column number 1.

7 In the Unit text field, type Hz.
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8 In the table, enter the following settings:

9 In the Name text field, type Lp1.

10 In the Unit text field, type dB.

11 In the table, enter the following settings:

12 In the Name text field, type Lp2.

13 In the Unit text field, type dB.

14 In the table, click to select the cell at row number 4 and column number 1.

15 In the Name text field, type Lp3.

16 In the Unit text field, type dB.

17 Locate the Interpolation and Extrapolation section. From the Interpolation list, choose 
Cubic spline.

18 From the Extrapolation list, choose Linear.

Interpolation Function: Z Data
1 In the Home toolbar, click Functions and choose Global > Interpolation.

2 In the Settings window for Interpolation, type Interpolation Function: Z Data in 
the Label text field.

3 Locate the Definition section. From the Data source list, choose File.

4 Click Browse.

5 Browse to the model’s Application Libraries folder and double-click the file 
composite_dome_tweeter_freq_Z_data.txt.

6 Locate the Data Column Settings section. In the table, click to select the cell at row 
number 1 and column number 1.

7 In the Unit text field, type Hz.

8 In the table, enter the following settings:

Columns Type Settings

Column 2 Function values Function name=Lp1

Columns Type Settings

Column 3 Function values Function name=Lp2

Columns Type Settings

Column 2 Function values Function name=Zabs1
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9 In the Name text field, type Zabs1.

10 In the Unit text field, type ohm.

11 In the table, enter the following settings:

12 In the Name text field, type Zabs2.

13 In the Unit text field, type ohm.

14 In the table, click to select the cell at row number 4 and column number 1.

15 In the Name text field, type Zabs3.

16 In the Unit text field, type ohm.

17 Locate the Interpolation and Extrapolation section. From the Extrapolation list, choose 
Linear.

Define all required materials and layered materials under Global Definitions > Materials.

A D D  M A T E R I A L

1 In the Materials toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-in > Air.

4 Right-click and choose Add to Global Materials.

5 In the tree, select Built-in > Copper.

6 Right-click and choose Add to Global Materials.

7 In the tree, select Built-in > Rubber.

8 Right-click and choose Add to Global Materials.

9 In the tree, select Built-in > Titanium beta-21S.

10 Right-click and choose Add to Global Materials.

11 In the Materials toolbar, click Add Material to close the Add Material window.

G L O B A L  D E F I N I T I O N S

Glass Fiber
1 In the Model Builder window, under Global Definitions right-click Materials and choose 

Blank Material.

2 In the Settings window for Material, type Glass Fiber in the Label text field.

Columns Type Settings

Column 3 Function values Function name=Zabs2
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3 Click to expand the Material Properties section. In the Material properties tree, select 
Basic Properties > Density.

4 Right-click and choose Add to Material.

5 In the Material properties tree, select Basic Properties > Poisson’s Ratio.

6 Right-click and choose Add to Material.

7 In the Material properties tree, select Basic Properties > Young’s Modulus.

8 Right-click and choose Add to Material.

9 Locate the Material Contents section. In the table, enter the following settings:

Foam
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Foam in the Label text field.

3 Click to expand the Material Properties section. In the Material properties tree, select 
Basic Properties > Porosity.

4 Right-click and choose Add to Material.

5 In the Material properties tree, select Acoustics > Poroacoustics Model > 
Flow resistivity (Rf).

6 Right-click and choose Add This Property Group to Material.

Property Variable Value Unit Property group

Density rho 2000[kg/m^3] kg/m³ Basic

Poisson’s ratio nu 0.33 1 Basic

Young’s modulus E 70[GPa] Pa Basic
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7 Locate the Material Contents section. In the table, enter the following settings:

The homogenized composite materials can be imported from an existing Application 
Library example.

8 In the Materials toolbar, click Import Materials and choose Import Materials.

9 In the Import Materials dialog, click Browse.

10 From the File menu, choose Application Libraries.

11 In the Application Libraries window, select Composite Materials Module > 
Dynamics and Vibration > composite_dome_tweeter_eigen in the tree.

12 Click Open.

13 In the Material list, choose Homogeneous Material: RUC 1 and 
Homogeneous Material: RUC 2.

14 Click OK.

Layered Material: Rubber
1 Right-click Materials and choose Layered Material.

2 In the Settings window for Layered Material, type Layered Material: Rubber in the 
Label text field.

Property Variable Value Unit Property group

Porosity epsilon 0.97 1 Basic

Flow resistivity Rf_iso ; Rfii 
= Rf_iso, Rfij 
= 0

55000[Pa*
s/m^2]

Pa·s/m² Poroacoustics 
model

Thermal 
characteristic length

Lth 117[um] m Poroacoustics 
model

Viscous 
characteristic length

Lv_iso ; Lvii 
= Lv_iso, Lvij 
= 0

41[um] m Poroacoustics 
model

Tortuosity factor tau_iso ; 
tauii = 
tau_iso, tauij 
= 0

2.47 1 Poroacoustics 
model
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3 Locate the Layer Definition section. In the table, enter the following settings:

Layered Material: Glass Fiber
1 Right-click Layered Material: Rubber and choose Duplicate.

2 In the Settings window for Layered Material, type Layered Material: Glass Fiber 
in the Label text field.

3 Locate the Layer Definition section. In the table, enter the following settings:

Material Switch 1 (sw1)
In the Model Builder window, right-click Materials and choose Material Switch.

Layered Material: Titanium
1 In the Model Builder window, right-click Material Switch 1 (sw1) and choose 

Layered Material.

2 In the Settings window for Layered Material, type Layered Material: Titanium in the 
Label text field.

3 Locate the Layer Definition section. In the table, enter the following settings:

Layered Material: Composite Material 1
1 Right-click Layered Material: Titanium and choose Duplicate.

2 In the Settings window for Layered Material, type Layered Material: Composite 
Material 1 in the Label text field.

Layer Material Rotation Value Thickness Mesh 
elements

Layer 1 Rubber 
(mat3)

0.0 0 rad th_susp 2

Layer Material Rotation Value Thickness Mesh 
elements

Layer 1 Glass Fiber 
(mat5)

0.0 0 rad th_former 2

Layer Material Rotation Value Thickness Mesh 
elements

Layer 1 Titanium 
beta-21S 
(mat4)

0.0 0 rad th_dome 2
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3 Locate the Layer Definition section. In the table, enter the following settings:

Layered Material: Composite Material 2
1 Right-click Layered Material: Composite Material 1 and choose Duplicate.

2 In the Settings window for Layered Material, type Layered Material: Composite 
Material 2 in the Label text field.

3 Locate the Layer Definition section. In the table, enter the following settings:

Import the dome tweeter geometry from a file.

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Import 1 (imp1)
1 In the Geometry toolbar, click Import.

2 In the Settings window for Import, locate the Source section.

3 Click Browse.

4 Browse to the model’s Application Libraries folder and double-click the file 
composite_dome_tweeter_freq_geom_sequence.mphbin.

5 Click Import.

6 Click the Show Grid button in the Graphics toolbar.

Create explicit selections that are helpful for the model setup.

Layer Material Rotation Value Thickness Mesh 
elements

Layer 1 Homogeneous 
Material: RUC 1 
(solidcp1mat)

0.0 0 rad th_dome 2

Layer Material Rotation Value Thickness Mesh 
elements

Layer 1 Homogeneous 
Material: RUC 2 
(solid2cp1mat)

0.0 0 rad th_dome 2
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D E F I N I T I O N S

Acoustic Domains
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Acoustic Domains in the Label text field.

3 Locate the Input Entities section. Click Paste Selection.

4 In the Paste Selection dialog, type 2-4, 8, 11 in the Selection text field.

5 Click OK.

Poroacoustics Domains
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Poroacoustics Domains in the Label text 
field.

3 Locate the Input Entities section. Click Paste Selection.

4 In the Paste Selection dialog, type 2, 8 in the Selection text field.

5 Click OK.

Coil Domains
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Coil Domains in the Label text field.

3 Locate the Input Entities section. Click Paste Selection.

4 In the Paste Selection dialog, type 9 in the Selection text field.

5 Click OK.

Rubber Boundaries
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Rubber Boundaries in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Click Paste Selection.

5 In the Paste Selection dialog, type 41, 51 in the Selection text field.

6 Click OK.

Glass Fiber Boundaries
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Glass Fiber Boundaries in the Label text 
field.
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3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Click Paste Selection.

5 In the Paste Selection dialog, type 35, 37 in the Selection text field.

6 Click OK.

Diaphragm Boundaries
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Diaphragm Boundaries in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Click Paste Selection.

5 In the Paste Selection dialog, type 12, 39 in the Selection text field.

6 Click OK.

Layered Shell Boundaries
1 In the Definitions toolbar, click Union.

2 In the Settings window for Union, locate the Geometric Entity Level section.

3 From the Level list, choose Boundary.

4 Locate the Input Entities section. Under Selections to add, click Add.

5 In the Add dialog, in the Selections to add list, choose Rubber Boundaries, 
Glass Fiber Boundaries, and Diaphragm Boundaries.

6 Click OK.

7 In the Settings window for Union, type Layered Shell Boundaries in the Label text 
field.

Perfectly Matched Boundaries
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Perfectly Matched Boundaries in the Label 
text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Click Paste Selection.

5 In the Paste Selection dialog, type 13 in the Selection text field.

6 Click OK.

Acoustic–Solid Boundaries
1 In the Definitions toolbar, click Explicit.
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2 In the Settings window for Explicit, type Acoustic-Solid Boundaries in the Label text 
field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Click Paste Selection.

5 In the Paste Selection dialog, type 35, 36, 38, 40 in the Selection text field.

6 Click OK.

Acoustic–Layered Shell Boundaries
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Acoustic-Layered Shell Boundaries in the 
Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Click Paste Selection.

5 In the Paste Selection dialog, type 12, 35, 37, 39, 41, 51 in the Selection text field.

6 Click OK.

Fixed Boundaries
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Fixed Boundaries in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Click Paste Selection.

5 In the Paste Selection dialog, type 51 in the Selection text field.

6 Click OK.

Symmetry Boundaries
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Symmetry Boundaries in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Click Paste Selection.

5 In the Paste Selection dialog, type 1 2 4 5 7 8 10 11 14 17 20 23 34 44 53 66 
67 68 69 70 71 72 in the Selection text field.

6 Click OK.

Symmetry Edges
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Symmetry Edges in the Label text field.
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3 Locate the Input Entities section. From the Geometric entity level list, choose Edge.

4 Click Paste Selection.

5 In the Paste Selection dialog, type 12, 13, 44, 47, 50, 55, 116, 118, 120, 122 
in the Selection text field.

6 Click OK.

Define the variables needed for the Electrical Circuit interface in a Variable node.

Average 1 (aveop1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 In the Settings window for Average, locate the Source Selection section.

3 From the Selection list, choose Coil Domains.

Variables 1
1 In the Model Builder window, right-click Definitions and choose Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

M A T E R I A L S

Material Link: Air
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose More Materials > Material Link.

2 In the Settings window for Material Link, type Material Link: Air in the Label text 
field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose 
Acoustic Domains.

Material Link: Copper
1 Right-click Material Link: Air and choose Duplicate.

Name Expression Unit Description

L_E (L_e/(sin(n_e*pi/2)))*
(acpr.omega[s/
rad])^(n_e-1)

H Voice coil inductance 
(frequency dependent)

Rp_E (L_e/(cos(n_e*pi/2)))*
(acpr.omega[s/
rad])^(n_e)[ohm/H]

Ω Resistance (losses in 
magnetic system)

v0 aveop1(solid.u_tZ) m/s Voice coil velocity
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2 In the Settings window for Material Link, type Material Link: Copper in the Label 
text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose 
Coil Domains.

4 Locate the Link Settings section. From the Material list, choose Copper (mat2).

Layered Material Link: Rubber
1 In the Model Builder window, right-click Materials and choose Layers > 

Layered Material Link.

2 In the Settings window for Layered Material Link, type Layered Material Link: 
Rubber in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Rubber Boundaries.

4 Locate the Orientation and Position section. From the Position list, choose 
Top side on boundary.

Layered Material Link: Glass Fiber
1 Right-click Layered Material Link: Rubber and choose Duplicate.

2 In the Settings window for Layered Material Link, type Layered Material Link: 
Glass Fiber in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose 
Glass Fiber Boundaries.

4 Locate the Layered Material Settings section. From the Material list, choose 
Layered Material: Glass Fiber (lmat2).

Layered Material Link: Diaphragm
1 Right-click Layered Material Link: Glass Fiber and choose Duplicate.

2 In the Settings window for Layered Material Link, type Layered Material Link: 
Diaphragm in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose 
Diaphragm Boundaries.

4 Locate the Layered Material Settings section. From the Material list, choose 
Material Switch 1 (sw1).

5 Locate the Orientation and Position section. Click Go to Source for 
Coordinate system.
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D E F I N I T I O N S  ( C O M P 1 )

Boundary System 1 (sys1)
1 In the Model Builder window, under Component 1 (comp1) > Definitions click 

Boundary System 1 (sys1).

2 In the Settings window for Boundary System, locate the Settings section.

3 Find the Coordinate names subsection. From the Axis list, choose x.

L A Y E R E D  S H E L L  ( L S H E L L )

1 In the Model Builder window, under Component 1 (comp1) click Layered Shell (lshell).

2 In the Settings window for Layered Shell, locate the Boundary Selection section.

3 From the Selection list, choose Layered Shell Boundaries.

Linear Elastic Material 1
1 In the Model Builder window, under Component 1 (comp1) > Layered Shell (lshell) click 

Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Material symmetry list, choose Anisotropic.

Damping 1
1 In the Physics toolbar, click Attributes and choose Damping.

2 In the Settings window for Damping, locate the Boundary Selection section.

3 From the Selection list, choose Rubber Boundaries.

4 Locate the Damping Settings section. In the βdK text field, type 0.46/omega_loss.

Continuity 1
1 In the Physics toolbar, click Edges and choose Continuity.

2 In the Settings window for Continuity, locate the Layer Selection section.

3 From the Source list, choose Layered Material Link: Diaphragm (llmat3).

4 From the Destination list, choose Layered Material Link: Glass Fiber (llmat2).

5 In the Selection table, enter the following settings:

Continuity 2
1 Right-click Continuity 1 and choose Duplicate.

Layered material Offset (m)

√ Layered Material: Glass Fiber (lmat2) 0
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2 In the Settings window for Continuity, locate the Layer Selection section.

3 From the Destination list, choose Layered Material Link: Rubber (llmat1).

4 In the Selection table, enter the following settings:

Fixed Constraint 1
1 In the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 In the Settings window for Fixed Constraint, locate the Boundary Selection section.

3 From the Selection list, choose Fixed Boundaries.

Symmetry
1 In the Physics toolbar, click Edges and choose Symmetry.

2 In the Settings window for Symmetry, type Symmetry in the Label text field.

3 Locate the Edge Selection section. From the Selection list, choose Symmetry Edges.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Domain Selection section.

3 From the Selection list, choose Coil Domains.

Body Load 1
1 In the Physics toolbar, click Domains and choose Body Load.

2 In the Settings window for Body Load, locate the Domain Selection section.

3 From the Selection list, choose All domains.

4 Locate the Force section. From the Load type list, choose Total force.

5 Specify the Ftot vector as

Symmetry
1 In the Physics toolbar, click Boundaries and choose Symmetry.

2 In the Settings window for Symmetry, type Symmetry in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose 
Symmetry Boundaries.

Layered material Offset (m)

√ Layered Material: Rubber (lmat1) 0

0.25*BL*cir.R1.i z
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P R E S S U R E  A C O U S T I C S ,  F R E Q U E N C Y  D O M A I N  ( A C P R )

1 In the Model Builder window, under Component 1 (comp1) click Pressure Acoustics,

Frequency Domain (acpr).

2 In the Settings window for Pressure Acoustics, Frequency Domain, locate the 
Domain Selection section.

3 From the Selection list, choose Acoustic Domains.

Poroacoustics 1
1 In the Physics toolbar, click Domains and choose Poroacoustics.

2 In the Settings window for Poroacoustics, locate the Domain Selection section.

3 From the Selection list, choose Poroacoustics Domains.

4 Locate the Poroacoustics Model section. From the Poroacoustics model list, choose 
Johnson–Champoux–Allard (JCA).

5 Locate the Porous Matrix Properties section. From the Porous elastic material list, choose 
Foam (mat6).

Perfectly Matched Boundary 1
1 In the Physics toolbar, click Boundaries and choose Perfectly Matched Boundary.

2 In the Settings window for Perfectly Matched Boundary, locate the Boundary Selection 
section.

3 From the Selection list, choose Perfectly Matched Boundaries.

Exterior Field Calculation 1
1 In the Physics toolbar, click Boundaries and choose Exterior Field Calculation.

2 In the Settings window for Exterior Field Calculation, locate the Boundary Selection 
section.

3 From the Selection list, choose Perfectly Matched Boundaries.

4 Locate the Exterior Field Calculation section. From the Symmetry type list, choose 
Sector symmetry with one symmetry plane.

5 From the Transformation list, choose Rotation and reflection.

6 In the n text field, type 4.

Symmetry
1 In the Physics toolbar, click Boundaries and choose Symmetry.

2 In the Settings window for Symmetry, type Symmetry in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose 
Symmetry Boundaries.
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E L E C T R I C A L  C I R C U I T  ( C I R )

In the Model Builder window, under Component 1 (comp1) click Electrical Circuit (cir).

Voltage Source 1 (V1)
1 In the Electrical Circuit toolbar, click Voltage Source.

2 In the Settings window for Voltage Source, locate the Node Connections section.

3 In the table, enter the following settings:

4 Locate the Device Parameters section. In the vsrc text field, type V0.

Resistor 1 (R1)
1 In the Electrical Circuit toolbar, click Resistor.

2 In the Settings window for Resistor, locate the Node Connections section.

3 In the table, enter the following settings:

4 Locate the Device Parameters section. In the R text field, type R_E.

Inductor 1 (L1)
1 In the Electrical Circuit toolbar, click Inductor.

2 In the Settings window for Inductor, locate the Node Connections section.

3 In the table, enter the following settings:

4 Locate the Device Parameters section. In the L text field, type L_E.

Resistor 2 (R2)
1 In the Electrical Circuit toolbar, click Resistor.

2 In the Settings window for Resistor, locate the Node Connections section.

Label Node names

n 0

Label Node names

p 1

n 2

Label Node names

p 2

n 3
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3 In the table, enter the following settings:

4 Locate the Device Parameters section. In the R text field, type Rp_E.

Voltage Source 2 (V2)
1 In the Electrical Circuit toolbar, click Voltage Source.

2 In the Settings window for Voltage Source, locate the Node Connections section.

3 In the table, enter the following settings:

4 Locate the Device Parameters section. In the vsrc text field, type BL*v0.

M U L T I P H Y S I C S

Layered Shell–Structure Cladding 1 (lssc1)
In the Model Builder window, under Component 1 (comp1) right-click Multiphysics and 
choose Layered Shell–Structure Cladding.

Acoustic–Solid Boundary
1 In the Model Builder window, right-click Multiphysics and choose Acoustic–

Structure Boundary.

2 In the Settings window for Acoustic–Structure Boundary, type Acoustic-Solid 
Boundary in the Label text field.

3 Locate the Coupled Interfaces section. From the Structure list, choose 
Solid Mechanics (solid).

4 Locate the Boundary Selection section. From the Selection list, choose Acoustic–

Solid Boundaries.

Acoustic–Layered Shell Boundary
1 Right-click Multiphysics and choose Acoustic–Structure Boundary.

2 In the Settings window for Acoustic–Structure Boundary, type Acoustic-Layered 
Shell Boundary in the Label text field.

Label Node names

p 2

n 3

Label Node names

p 3

n 0
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3 Locate the Boundary Selection section. From the Selection list, choose Acoustic–

Layered Shell Boundaries.

Create a customized mesh sequence using the User-controlled mesh option in the Sequence 

Type section.

M E S H  1

Free Triangular 1
1 In the Mesh toolbar, click More Generators and choose Free Triangular.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Layered Shell Boundaries.

Size 1
1 Right-click Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Geometric Entity Selection section. From the Selection list, choose 
Diaphragm Boundaries.

5 Locate the Element Size Parameters section.

6 Select the Maximum element size checkbox. In the associated text field, type 1[mm].

7 Select the Minimum element size checkbox. In the associated text field, type 1[mm].

Size 2
1 Right-click Size 1 and choose Duplicate.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Selection list, choose Rubber Boundaries.

Size 3
1 Right-click Size 2 and choose Duplicate.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Selection list, choose Glass Fiber Boundaries.

4 Locate the Element Size Parameters section. In the Maximum element size text field, type 
4[mm].

Swept 1
1 In the Mesh toolbar, click Swept.

2 In the Settings window for Swept, locate the Domain Selection section.
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3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Coil Domains.

Free Tetrahedral 1
In the Mesh toolbar, click Free Tetrahedral.

Boundary Layers 1
1 In the Mesh toolbar, click Boundary Layers.

2 In the Settings window for Boundary Layers, locate the Geometric Entity Selection 
section.

3 From the Geometric entity level list, choose Domain.

4 Select Domain 4 only.

Boundary Layer Properties
1 In the Model Builder window, click Boundary Layer Properties.

2 In the Settings window for Boundary Layer Properties, locate the Boundary Selection 
section.

3 From the Selection list, choose Perfectly Matched Boundaries.

4 Locate the Layers section. In the Number of layers text field, type 1.

Size
1 In the Model Builder window, under Component 1 (comp1) > Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Maximum element size text field, type 
lam0/6.

5 In the Minimum element size text field, type 2[mm].

6 In the Curvature factor text field, type 0.5.

7 Click Build All.

S T U D Y :  F R E Q U E N C Y  R E S P O N S E

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Study: Frequency Response in the Label text 
field.

3 Locate the Study Settings section. Clear the Generate default plots checkbox.
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Material Sweep
1 In the Study toolbar, click More Study Extensions and choose Material Sweep.

2 In the Settings window for Material Sweep, locate the Study Settings section.

3 Click Add.

Step 1: Frequency Domain
1 In the Model Builder window, click Step 1: Frequency Domain.

2 In the Settings window for Frequency Domain, locate the Study Settings section.

3 Click Range.

4 In the Range dialog, choose ISO preferred frequencies from the Entry method list.

5 From the Interval list, choose 1/3 octave.

6 In the Start frequency text field, type 100.

7 In the Stop frequency text field, type 16000.

8 Click Replace.

9 In the Settings window for Frequency Domain, locate the Study Settings section.

10 From the Tolerance list, choose User controlled.

11 In the Relative tolerance text field, type 0.0001.

Create a customized solver sequence to improve convergence.

Solution 1 (sol1)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study: Frequency Response > 
Solver Configurations > Solution 1 (sol1) > Stationary Solver 1 node.

4 Right-click Study: Frequency Response > Solver Configurations > Solution 1 (sol1) > 
Stationary Solver 1 > 
Suggested Iterative Solver (GMRES with GMG and Direct Precond.) (asb1_asb2) and 
choose Enable.

5 In the Settings window for Iterative, locate the General section.

6 In the Number of iterations before restart text field, type 300.

7 From the Preconditioning list, choose Right.

8 In the Model Builder window, expand the Study: Frequency Response > 
Solver Configurations > Solution 1 (sol1) > Stationary Solver 1 > 
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Suggested Iterative Solver (GMRES with GMG and Direct Precond.) (asb1_asb2) node, then 
click Direct Preconditioner 1.

9 In the Settings window for Direct Preconditioner, locate the General section.

10 From the Solver list, choose PARDISO.

11 Click to expand the Hybridization section. Under Preconditioner variables, click 
Add.

12 In the Add dialog, in the Preconditioner variables list, choose Voltages (comp1.voltages), 
Currents (comp1.currents), and Currents, Time Derivatives (comp1.current_time).

13 Click OK.

14 In the Study toolbar, click Compute.

R E S U L T S

1 In the Model Builder window, click Results.

2 In the Settings window for Results, locate the Update of Results section.

3 Select the Only plot when requested checkbox.

R E S U L T  T E M P L A T E S

1 From the Windows menu, choose Result Templates.

2 Go to the Result Templates window.

3 In the tree, select Study: Frequency Response/Parametric Solutions 1 (sol2) > Layered Shell 
> Displacement (lshell).

4 Click the Add Result Template button in the window toolbar.

5 From the Results menu, choose Result Templates.

R E S U L T S

Sector 3D 1
1 In the Model Builder window, expand the Results node.

2 Right-click Results > Datasets and choose More 3D Datasets > Sector 3D.

3 In the Settings window for Sector 3D, locate the Data section.

4 From the Dataset list, choose Layered Material.

5 Locate the Symmetry section. In the Number of sectors text field, type 4.

6 From the Transformation list, choose Rotation and reflection.

Diaphragm Displacement (lshell)
1 In the Model Builder window, under Results click Displacement (lshell).
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2 In the Settings window for 3D Plot Group, type Diaphragm Displacement (lshell) 
in the Label text field.

3 Locate the Data section. From the Dataset list, choose Sector 3D 1.

4 From the Material Switch 1 list, choose Layered Material: Titanium.

5 From the Parameter value (freq (Hz)) list, choose 10000.

6 Click to expand the Title section. From the Title type list, choose Manual.

7 In the Title text area, type Surface: Displacement magnitude (mm).

8 In the Parameter indicator text field, type freq=10000 Hz.

9 Click to expand the Plot Array section. From the Array type list, choose Linear.

Surface 2
1 In the Model Builder window, expand the Diaphragm Displacement (lshell) node.

2 Right-click Results > Diaphragm Displacement (lshell) > Surface 1 and choose Duplicate.

3 In the Settings window for Surface, locate the Data section.

4 From the Dataset list, choose Sector 3D 1.

5 From the Material Switch 1 list, choose Layered Material: Composite Material 1.

6 From the Parameter value (freq (Hz)) list, choose 10000.

7 Click to expand the Inherit Style section. From the Plot list, choose Surface 1.

Surface 3
1 Right-click Surface 2 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Material Switch 1 list, choose Layered Material: Composite Material 2.

Diaphragm Displacement (lshell)
In the Model Builder window, click Diaphragm Displacement (lshell).

Table Annotation 1
1 In the Diaphragm Displacement (lshell) toolbar, click More Plots and choose 

Table Annotation.

2 In the Settings window for Table Annotation, locate the Data section.

3 From the Source list, choose Local table.
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4 In the table, enter the following settings:

5 Locate the Coloring and Style section. Clear the Show point checkbox.

Diaphragm Displacement (lshell)
1 In the Model Builder window, click Diaphragm Displacement (lshell).

2 In the Diaphragm Displacement (lshell) toolbar, click Plot.

3 Click the Show Grid button in the Graphics toolbar.

4 Click the Zoom Extents button in the Graphics toolbar.

Mirror 3D 1
1 In the Results toolbar, click More Datasets and choose Mirror 3D.

2 In the Settings window for Mirror 3D, locate the Data section.

3 From the Dataset list, choose Study: Frequency Response/Parametric Solutions 1 (sol2).

Mirror 3D 2
1 Right-click Mirror 3D 1 and choose Duplicate.

2 In the Settings window for Mirror 3D, locate the Data section.

3 From the Dataset list, choose Mirror 3D 1.

4 Locate the Plane Data section. From the Plane list, choose xz-planes.

Acoustic Pressure (acpr)
1 In the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Acoustic Pressure (acpr) in the 
Label text field.

3 Locate the Data section. From the Dataset list, choose Mirror 3D 2.

4 From the Material Switch 1 list, choose Layered Material: Titanium.

5 From the Parameter value (freq (Hz)) list, choose 10000.

6 Locate the Title section. From the Title type list, choose Manual.

7 In the Title text area, type Surface: Acoustic pressure (Pa).

8 In the Parameter indicator text field, type freq=10000 Hz.

9 Locate the Plot Settings section. Clear the Plot dataset edges checkbox.

x-coordinate y-coordinate z-coordinate Annotation

-20[mm] -80[mm] 0 Titanium

80[mm] -80[mm] 0 Composite Material 1

200[mm] -80[mm] 0 Composite Material 2
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10 Locate the Plot Array section. From the Array type list, choose Linear.

Multislice 1
1 In the Acoustic Pressure (acpr) toolbar, click More Plots and choose Multislice.

2 In the Settings window for Multislice, locate the Expression section.

3 In the Expression text field, type acpr.p_t.

4 Locate the Multiplane Data section. Find the z-planes subsection. In the Planes text field, 
type 0.

5 Locate the Coloring and Style section. From the Color table list, choose Wave.

6 From the Scale list, choose Linear symmetric.

Multislice 2
1 Right-click Multislice 1 and choose Duplicate.

2 In the Settings window for Multislice, locate the Data section.

3 From the Dataset list, choose Mirror 3D 2.

4 From the Material Switch 1 list, choose Layered Material: Composite Material 1.

5 From the Parameter value (freq (Hz)) list, choose 10000.

6 Click to expand the Inherit Style section. From the Plot list, choose Multislice 1.

Multislice 3
1 Right-click Multislice 2 and choose Duplicate.

2 In the Settings window for Multislice, locate the Data section.

3 From the Material Switch 1 list, choose Layered Material: Composite Material 2.

Volume 1
In the Model Builder window, right-click Acoustic Pressure (acpr) and choose Volume.

Sector 3D 2
1 In the Model Builder window, under Results > Datasets right-click Sector 3D 1 and choose 

Duplicate.

2 In the Settings window for Sector 3D, locate the Data section.

3 From the Dataset list, choose Study: Frequency Response/Parametric Solutions 1 (sol2).

4 Locate the Symmetry section. From the Sectors to include list, choose Manual.

5 In the Number of sectors to include text field, type 3.

6 In the Start sector text field, type 3.
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Volume 1
1 In the Model Builder window, under Results > Acoustic Pressure (acpr) click Volume 1.

2 In the Settings window for Volume, locate the Data section.

3 From the Dataset list, choose Sector 3D 2.

4 Locate the Expression section. In the Expression text field, type 1.

5 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

6 From the Color list, choose Gray.

7 Click to expand the Plot Array section. Select the Manual indexing checkbox.

Selection 1
1 Right-click Volume 1 and choose Selection.

2 In the Settings window for Selection, locate the Selection section.

3 Click Paste Selection.

4 In the Paste Selection dialog, type 1, 5-7, 10 in the Selection text field.

5 Click OK.

Volume 2
1 Right-click Volume 1 and choose Duplicate.

2 In the Settings window for Volume, locate the Plot Array section.

3 In the Index text field, type 1.

Volume 3
Right-click Volume 2 and choose Duplicate.

Volume 1
In the Model Builder window, collapse the Results > Acoustic Pressure (acpr) > Volume 1 
node.

Volume 3
1 In the Model Builder window, click Volume 3.

2 In the Settings window for Volume, locate the Plot Array section.

3 In the Index text field, type 2.

Acoustic Pressure (acpr)
In the Model Builder window, click Acoustic Pressure (acpr).
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Table Annotation 1
1 In the Acoustic Pressure (acpr) toolbar, click More Plots and choose 

Table Annotation.

2 In the Settings window for Table Annotation, locate the Data section.

3 From the Source list, choose Local table.

4 In the table, enter the following settings:

5 Locate the Coloring and Style section. Clear the Show point checkbox.

Acoustic Pressure (acpr)
1 In the Model Builder window, click Acoustic Pressure (acpr).

2 In the Acoustic Pressure (acpr) toolbar, click Plot.

3 Click the Show Grid button in the Graphics toolbar.

4 Click the Zoom Extents button in the Graphics toolbar.

Sound Pressure Level (acpr)
1 Right-click Acoustic Pressure (acpr) and choose Duplicate.

2 In the Settings window for 3D Plot Group, type Sound Pressure Level (acpr) in the 
Label text field.

3 Locate the Title section. In the Title text area, type Surface: Total sound pressure 
level (dB).

Multislice 1
1 In the Model Builder window, expand the Sound Pressure Level (acpr) node, then click 

Multislice 1.

2 In the Settings window for Multislice, locate the Expression section.

3 In the Expression text field, type acpr.Lp_t.

4 Locate the Coloring and Style section. From the Color table list, choose Rainbow.

5 From the Scale list, choose Linear.

Multislice 2
1 In the Model Builder window, click Multislice 2.

2 In the Settings window for Multislice, locate the Expression section.

x-coordinate y-coordinate z-coordinate Annotation

-20[mm] -140[mm] 0 Titanium

260[mm] -140[mm] 0 Composite Material 1

540[mm] -140[mm] 0 Composite Material 2
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3 In the Expression text field, type acpr.Lp_t.

Multislice 3
1 In the Model Builder window, click Multislice 3.

2 In the Settings window for Multislice, locate the Expression section.

3 In the Expression text field, type acpr.Lp_t.

Sound Pressure Level (acpr)
1 In the Model Builder window, click Sound Pressure Level (acpr).

2 In the Sound Pressure Level (acpr) toolbar, click Plot.

G L O B A L  D E F I N I T I O N S

Interpolation Function: Lp Data (Lp1, Lp2, Lp3)
1 In the Model Builder window, under Global Definitions click 

Interpolation Function: Lp Data (Lp1, Lp2, Lp3).

2 In the Settings window for Interpolation, click Create Plot.

R E S U L T S

Grid 1D 1
1 In the Settings window for Grid 1D, locate the Parameter Bounds section.

2 In the Minimum text field, type 100.

3 In the Maximum text field, type 16000.

G L O B A L  D E F I N I T I O N S

Interpolation Function: Z Data (Zabs1, Zabs2, Zabs3)
1 In the Model Builder window, under Global Definitions click 

Interpolation Function: Z Data (Zabs1, Zabs2, Zabs3).

2 In the Settings window for Interpolation, click Create Plot.

R E S U L T S

Grid 1D 1a
1 In the Settings window for Grid 1D, locate the Parameter Bounds section.

2 In the Minimum text field, type 100.

3 In the Maximum text field, type 16000.
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On-Axis Sensitivity
1 In the Model Builder window, under Results click 1D Plot Group 4.

2 In the Settings window for 1D Plot Group, type On-Axis Sensitivity in the Label text 
field.

3 Click to expand the Title section. From the Title type list, choose Label.

4 Locate the Plot Settings section.

5 Select the x-axis label checkbox. In the associated text field, type Frequency (Hz).

6 Select the y-axis label checkbox. In the associated text field, type Sound Pressure 
Level (dB).

7 Click to expand the Number Format section. Locate the Legend section. From the 
Position list, choose Lower left.

Octave Band 1
1 In the On-Axis Sensitivity toolbar, click More Plots and choose Octave Band.

2 In the Settings window for Octave Band, locate the Data section.

3 From the Dataset list, choose Study: Frequency Response/Parametric Solutions 1 (sol2).

4 Locate the y-Axis Data section. In the Expression text field, type pext(0,0,1[m]).

5 Locate the Plot section. From the Quantity list, choose 
Continuous power spectral density.

6 Click to expand the Coloring and Style section. Find the Line style subsection. From the 
Line list, choose None.

7 Find the Line markers subsection. From the Marker list, choose Point.

8 From the Color list, choose Cycle (reset).

9 Click to expand the Legends section. Select the Show legends checkbox.

10 From the Legends list, choose Manual.

11 In the table, enter the following settings:

Function 1
1 In the Model Builder window, click Function 1.

2 In the Settings window for Function, click to expand the Legends section.

Legends

Titanium

Composite Material 1

Composite Material 2
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3 In the table, enter the following settings:

Function 2
1 In the Model Builder window, click Function 2.

2 In the Settings window for Function, locate the Legends section.

3 In the table, enter the following settings:

Function 3
1 In the Model Builder window, click Function 3.

2 In the Settings window for Function, locate the Legends section.

3 In the table, enter the following settings:

On-Axis Sensitivity
1 In the Model Builder window, click On-Axis Sensitivity.

2 In the On-Axis Sensitivity toolbar, click Plot.

Electric Input Impedance
1 In the Model Builder window, under Results click 1D Plot Group 5.

2 In the Settings window for 1D Plot Group, type Electric Input Impedance in the 
Label text field.

3 Locate the Title section. From the Title type list, choose Label.

4 Locate the Plot Settings section.

5 Select the x-axis label checkbox. In the associated text field, type Frequency (Hz).

6 Select the y-axis label checkbox. In the associated text field, type Electric Impedance 
([Omega]).

Global 1
1 Right-click Electric Input Impedance and choose Global.

2 In the Settings window for Global, locate the Data section.

Legends

Titanium, Resolved

Legends

Composite Material 1, Resolved

Legends

Composite Material 2, Resolved
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3 From the Dataset list, choose Study: Frequency Response/Parametric Solutions 1 (sol2).

4 Locate the y-Axis Data section. In the table, enter the following settings:

5 Locate the x-Axis Data section. From the Axis source data list, choose freq.

6 Click to expand the Coloring and Style section. Find the Line style subsection. From the 
Line list, choose None.

7 Find the Line markers subsection. From the Marker list, choose Point.

8 From the Color list, choose Cycle (reset).

9 Click to expand the Legends section. From the Legends list, choose Manual.

10 In the table, enter the following settings:

Function 1
1 In the Model Builder window, click Function 1.

2 In the Settings window for Function, locate the Legends section.

3 In the table, enter the following settings:

Function 2
1 In the Model Builder window, click Function 2.

2 In the Settings window for Function, locate the Legends section.

3 In the table, enter the following settings:

Function 3
1 In the Model Builder window, click Function 3.

2 In the Settings window for Function, locate the Legends section.

Expression Unit Description

abs(cir.V1.v/cir.V1.i) Ω abs(Z)

Legends

Titanium

Composite Material 1

Composite Material 2

Legends

Titanium, Resolved

Legends

Composite Material 1, Resolved
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3 In the table, enter the following settings:

Electric Input Impedance
1 In the Model Builder window, click Electric Input Impedance.

2 In the Electric Input Impedance toolbar, click Plot.

Spatial Sensitivity, Titanium
1 In the Results toolbar, click Polar Plot Group.

2 In the Settings window for Polar Plot Group, type Spatial Sensitivity, Titanium 
in the Label text field.

3 Locate the Data section. From the Dataset list, choose Study: Frequency Response/

Parametric Solutions 1 (sol2).

4 From the Material Switch 1 list, choose From list.

5 In the Values (Material Switch 1) list box, select Layered Material: Titanium.

6 From the Parameter selection (freq) list, choose From list.

7 In the Parameter values (freq (Hz)) list box, select 10000.

8 Click to expand the Title section. From the Title type list, choose Label.

9 Locate the Axis section. From the Zero angle list, choose Up.

10 From the Rotation direction list, choose Clockwise.

Radiation Pattern 1
1 In the Spatial Sensitivity, Titanium toolbar, click More Plots and choose 

Radiation Pattern.

2 In the Settings window for Radiation Pattern, locate the Evaluation section.

3 Find the Angles subsection. In the Number of angles text field, type 180.

4 From the Restriction list, choose Manual.

5 In the φ start text field, type -90.

6 In the φ range text field, type 180.

7 Find the Normal vector subsection. In the y text field, type 1.

8 In the z text field, type 0.

9 Find the Evaluation distance subsection. In the Radius text field, type 1000.

10 Find the Reference direction subsection. In the x text field, type 0.

Legends

Composite Material 2, Resolved
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11 In the z text field, type 1.

12 Click to expand the Legends section. Select the Show legends checkbox.

13 From the Legends list, choose Manual.

14 In the table, enter the following settings:

Spatial Sensitivity, Titanium
1 In the Model Builder window, click Spatial Sensitivity, Titanium.

2 In the Spatial Sensitivity, Titanium toolbar, click Plot.

Spatial Sensitivity, Composite Material 1
1 Right-click Spatial Sensitivity, Titanium and choose Duplicate.

2 In the Settings window for Polar Plot Group, type Spatial Sensitivity, Composite 
Material 1 in the Label text field.

3 Locate the Data section. In the Values (Material Switch 1) list box, select 
Layered Material: Composite Material 1.

4 In the Spatial Sensitivity, Composite Material 1 toolbar, click Plot.

Spatial Sensitivity, Composite Material 2
1 Right-click Spatial Sensitivity, Composite Material 1 and choose Duplicate.

2 In the Settings window for Polar Plot Group, type Spatial Sensitivity, Composite 
Material 2 in the Label text field.

3 Locate the Data section. In the Values (Material Switch 1) list box, select 
Layered Material: Composite Material 2.

4 In the Spatial Sensitivity, Composite Material 2 toolbar, click Plot.

Directivity Plot
1 In the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Directivity Plot in the Label text 
field.

3 Locate the Data section. From the Dataset list, choose Study: Frequency Response/

Parametric Solutions 1 (sol2).

4 From the Material Switch 1 list, choose From list.

5 In the Values (Material Switch 1) list box, select Layered Material: Composite Material 2.

6 Locate the Plot Settings section. Select the y-axis label checkbox.

Legends

freq=10000 Hz
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7 Select the x-axis label checkbox. In the associated text field, type Frequency (Hz).

8 In the y-axis label text field, type Angle (deg).

Directivity 1
1 In the Directivity Plot toolbar, click More Plots and choose Directivity.

2 In the Settings window for Directivity, locate the Evaluation section.

3 Find the Angles subsection. In the Number of angles text field, type 180.

4 From the Restriction list, choose Manual.

5 In the φ start text field, type -90.

6 In the φ range text field, type 180.

7 Find the Normal vector subsection. In the y text field, type 1.

8 In the z text field, type 0.

9 Find the Evaluation distance subsection. In the Radius text field, type 1000.

10 Find the Reference direction subsection. In the x text field, type 0.

11 In the z text field, type 1.

Directivity Plot
1 In the Model Builder window, click Directivity Plot.

2 In the Directivity Plot toolbar, click Plot.
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