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Introduction

This tutorial demonstrates how to model a tubular permanent magnet generator in a 2D
axisymmetric system. This is accomplished by coupling the Magnetic Fields interface with a
Moving Mesh. Notze: for rotational electrical machines, the Rotating Machinery,
Magnetic interface is the recommended method. As the tubular generator is a type of
linear motor, this can be modeled using a 2D axisymmetric geometry and applying

periodic conditions on the appropriate boundaries.

This tubular generator model considers an array of magnetics moving with a constant
velocity through a tube of open circuit-connected three phase coils in the stator. The
model results show the magnetic fields in the system with the key result being the
calculated induced voltages from the generator. This can be the basis for then applying a

proper current.

Model Definition

The geometry consists of two parts, the stationary stator and the moving slider. The stator
consists of three coils running three different phases. The slider contains an array of
cylindrical magnets with alternating polarities separated by nonlinear magnetic material,
see Figure 1. The slider is modeled using a Moving Mesh and is connected to the stator

using a Periodic Magnetic Continuity boundary pair.

As the tubular generator consists of a periodic array of magnets and coils, symmetry can
be utilized to reduce computational cost. Here, only one unit cell of the structure is
modeled and a periodic condition is applied to the top and bottom boundaries of the
geometry to represent the rest of the array. This is done by applying continuous Periodic

Conditions to the edges of the slider and stator.

The study step of this model is divided into two parts. An initial stationary study to get the
initial condition followed by a time dependent study to analyze the induced voltages as the

slider moves through the stator.
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Figure 1: Left: 3D view of the tubular generator showing the magnetic flux density in the
nonlinear magnetic material. Right: 2D cross-sectional axisymmetric view of the tubular
generator. This shows the avrangements of the coils, the permanent magnets, and the nonlinear
magnetic material. The left “Slider” section of the geometry is mapped using o moving mesh
while the right “Stator” section uses a fixed mesh. These two meshes communicate through the
applied periodic magnetic continuity boundary pair. The ved periodic boundaries apply a
repeating functionality allowing for the representation of a larger geometry.

Results and Discussion

This model produces results in both 2D cross-sectional and revolved views. Figure 2 shows
the cross-sectional magnetic flux in the generator where the field lines show the continuity
across the periodic conditions. In Figure 3, the geometry is partially revolved to show the
3D nature of the tubular generator with a section left out to show the internal magnetic
vector potential in the nonlinear iron. Finally, Figure 4 shows the voltage induced by the
generator in each of the three coil phases.

Several of the key variables for the performance of the motor are set in the Parameters
sections of the model. This allows for convenient changing of variables such as the slider
speed and the number of turns in the coils to experiment with and produce different

voltage curves from the generator.
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Figure 2: Cross-sectional view of the magnetic flux in the tubular genervator. Three of the
modeled unit cells ave stacked together to illustrate the periodic nature of the system.
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Figure 3: Revolved vepresentation of the 2D simulation showing the magnetic vector potential
in the nonlinear magnetic material in both the slider and the stator. This plot shows three
stacked copies of the modeled geometry to vepresent a larger section of the linear generator. This

tlustrates how the periodic conditions knit the vector potentinls together at the boundaries of
the geometry.
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Figure 4: Open civcuit voltages produced in each of the three phases of coils.

Application Library path: ACDC_Module/Devices,_ Motors_and_Generators/
tubular_permanent_magnet_generator

Modeling Instructions

From the File menu, choose New.

NEW
In the New window, click Model Wizard.

MODEL WIZARD

!
I In the Model Wizard window, click : = 2D Axisymmetric.

2 In the Select Physics tree, select AC/DC > Electromagnetic Fields > Magnetic Fields (mf).
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3 Click Add.

4 In the Select Physics tree, select Mathematics > Deformed Mesh > Moving Mesh >
Prescribed Deformation.

Click Add.
Click e Study.

In the Select Study tree, sclect General Studies > Stationary.
Click [~/ Done.

0 N o un

GLOBAL DEFINITIONS

Parameters |
I In the Model Builder window, under Global Definitions click Parameters I.

2 In the Settings window for Parameters, locate the Parameters section.
3 Click the Load button. From the menu, choose Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file
tubular_permanent_magnet_generator_parameters.txt.

GEOMETRY |

I In the Model Builder window, under Component | (compl) click Geometry I.
2 In the Settings window for Geometry, locate the Units section.
3 From the Length unit list, choose mm.
4 Locate the Advanced section. From the Default repair tolerance list, choose Relative.
Rectangle | (rl)
I In the Geometry toolbar, click ] Rectangle.
In the Settings window for Rectangle, locate the Size and Shape section.
In the Width text field, type M_w.

2

3

4 In the Height text field, type P_P.

5 Locate the Pesition section. In the r text field, type S_r.
6

Click to expand the Layers section. In the table, enter the following settings:

Layer name Thickness (mm)
Layer 1 Mg_h/2
Layer 2 S1l_ch

7 Sclect the Layers on top checkbox.
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Rectangle 2 (r2)
I In the Geometry toolbar, click ] Rectangle.

In the Settings window for Rectangle, locate the Size and Shape section.
In the Width text field, type S1_tw.

2

3

4 In the Height text field, type S1_h.

5 Locate the Position section. In the r text field, type S_r+M_w.
6

In the z text field, type Mg_h/2-(S1_h-S1_ch)/2
Move | (movl) .
I In the Geometry toolbar, click /), Transforms and choose Move.
2 Select the object r2 only.
3 In the Settings window for Move, locate the Input section.
4 Seclect the Keep input objects checkbox.
5 Locate the Displacement section. In the z text field, type Mg_h+S1_ch.
Rectangle 3 (r3)
I In the Geometry toolbar, click ] Rectangle.
In the Settings window for Rectangle, locate the Size and Shape section.
In the Width text field, type M_w.

2

3

4 In the Height text field, type P_P.

5 Locate the Position section. In the r text field, type S_r+M_w+S1_tw+A_g+St_w.
6

Locate the Layers section. In the table, enter the following settings:

Layer name Thickness (mm)
Layer 1 St_h/2

Layer 2 C_h

Layer 3 St_h

7 Select the Layers on top checkbox.

Rectangle 4 (r4)

I In the Geometry toolbar, click ] Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.
3 In the Width text field, type St_w.

4 In the Height text field, type St_h*1.5.

5

Locate the Position section. In the r text field, type S_r+M_w+S1_tw+A_g.
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6 In the z text field, type St_h+C_h-St_h*1.5/2.
Move 2 (mov2) .
I In the Geometry toolbar, click ), Transforms and choose Move.
2 Select the object r4 only.
3 In the Settings window for Meve, locate the Input section.
4 Select the Keep input objects checkbox.
5 Locate the Displacement section. In the z text field, type C_h+St_h.
Rectangle 5 (r5)
I In the Geometry toolbar, click [ | Rectangle.
2 In the Settings window for Rectangle, locate the Size and Shape section.
3 In the Width text field, type St_w.
4 In the Height text field, type St_h*1.5/2.
5 Locate the Position section. In the r text field, type S_r+M_w+S1_tw+A_g.
Rectangle 6 (r6)
I In the Geometry toolbar, click ] Rectangle.
In the Settings window for Rectangle, locate the Size and Shape section.
In the Width text field, type St_w.

2

3

4 In the Height text field, type St_h*1.5/2.

5 Locate the Position section. In the r text field, type S_r+M_w+S1_tw+A_g.
6

In the z text field, type P_P-1.5*St_h/2.

Fillet I (fill)
I In the Geometry toolbar, click

Fillet.

On the object mov2, select Points 1 and 4 only.
On the object r4, select Points 1 and 4 only.
On the object r5, select Point 4 only.

2

3

4

5 On the object r6, select Point 1 only.

6 In the Settings window for Fillet, locate the Radius section.
7

In the Radius text field, type A_g.

Rectangle 7 (r7)
I In the Geometry toolbar, click ] Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.
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3 In the Width text field, type S_r+M_w+S1_tw+A_g/2.

4 In the Height text field, type P_P.

Rectangle 8 (r8)

I In the Geometry toolbar, click ] Rectangle.
In the Settings window for Rectangle, locate the Size and Shape section.
In the Width text field, type 50.

2

3

4 In the Height text field, type P_P.

5 Locate the Position section. In the r text field, type S_r+M_w+S1_tw+A_g/2.
6

Locate the Layers section. In the table, enter the following settings:

Layer name Thickness (mm)

Layer 1 A_g/2+St_w+C_w+St_ith

7 Clear the Layers on bottom checkbox.

8 Sclect the Layers to the left checkbox.

Moving Part

I In the Geometry toolbar, click @ Booleans and Partitions and choose Union.

2 In the Settings window for Union, type Moving Part in the Label text field.

3 Select the objects movl, rl, ¥2, and r7 only.

4 Locate the Selections of Resulting Entities scction. Select the Resulting objects selection
checkbox.

Statoric Part

I In the Geometry toolbar, click @ Booleans and Partitions and choose Union.

2 In the Settings window for Unien, type Statoric Part in the Label text field.

3 Select the objects fill (1), fill (2), fill (3), fill(4), ¥3, and r8 only.

4 Locate the Selections of Resulting Entities section. Select the Resulting objects selection

checkbox.

Magnets

I In the Geometry toolbar, click T Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Magnets in the Label text field.
3 On the object unil, select Domains 2, 4, and 6 only.

Laminated Core
I In the Geometry toolbar, click T Selections and choose Explicit Selection.
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2 In the Settings window for Explicit Selection, type Laminated Core in the Label text
field.

3 On the object unil, select Domains 3, 5, 8, and 9 only.

4 On the object uni2, select Domains 2-6, 8, 10, 12, and 13 only.

Coils

I In the Geometry toolbar, click " Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Coils in the Label text field.
3 On the object uni2, select Domains 7, 9, and 11 only.

Form Union (fin)

I In the Model Builder window, under Component | (compl) > Geometry I click

Form Union (fin).

In the Settings window for Form Union/Assembly, locate the Form Union/Assembly section.
From the Action list, choose Form an assembly.

From the Repair tolerance list, choose Relative.

Click the Zoom Extents button in the Graphics toolbar.

N U1 A W N

In the Geometry toolbar, click [EE Build All.
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The geometry should look like the figure above.
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ADD MATERIAL
I In the Materials toolbar, click #.7 Add Material to open the Add Material window.

2 Go to the Add Material window.
3 In the tree, select AC/DC > Soft Iron (Without Losses).

4 Click the Add to Component button in the window toolbar.

MATERIALS
Soft Iron (Without Losses) (matl)
I In the Settings window for Material, locate the Geometric Entity Selection scction.

2 From the Selection list, choose Laminated Core.

ADD MATERIAL
I Go to the Add Material window.

2 In the tree, select AC/DC > Hard Magnetic Materials >
Sintered NdFeB Grades (Chinese Standard) > N50 (Sintered NdFeB).

3 Click the Add to Component button in the window toolbar.

MATERIALS
N50 (Sintered NdFeB) (mat2)
I In the Settings window for Material, locate the Geometric Entity Selection scection.

2 From the Selection list, choose Magnets.

ADD MATERIAL
I Go to the Add Material window.

2 In the tree, select AC/DC > Copper.
3 Click the Add to Component button in the window toolbar.

4 In the Materials toolbar, click 35 Add Material to close the Add Material window.

MATERIALS

Copper (mat3)

I In the Settings window for Material, locate the Geometric Entity Selection section.

2 From the Selection list, choose Coils.
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MOVING MESH

Prescribed Deformation |
The Moving Mesh models the linear motion of the slider.

I In the Model Builder window, under Component | (compl) > Moving Mesh click
Prescribed Deformation I.

2 In the Settings window for Prescribed Deformation, locate the Geometric Entity Selection

section.
3 From the Selection list, choose Moving Part.

4 Locate the Prescribed Deformation section. Specify the dx vector as

speed*if (isdefined(t),t,0[s]) Z

MAGNETIC FIELDS (MF)

Free Space |
I In the Model Builder window, under Component | (compl) > Magnetic Fields (mf) click

Free Space |I.
2 In the Settings window for Free Space, locate the Stabilization section.
3 From the Ggyy, list, choose Automatic.
Domain Coil |
I In the Physics toolbar, click @ Domains and choose Domain Coil.
Select Domains 16, 18, and 20 only.
In the Settings window for Domain Coil, locate the Coil section.

From the Conductor model list, choose Homogenized multiturn.

Locate the Homogenized Conductor section. In the N text field, type Nturns.

2

3

4

5 In the I text field, type O[A].

6

7 From the Coil wire cross-section area list, choose Filling factor.
8

In the f text field, type 0. 8.

Domain Coil 3
Right-click Domain Coil I and choose Split by Connectivity.

Magnet |
I In the Physics toolbar, click @ Domains and choose Magnet.

2 Select Domains 2, 4, and 6 only.
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3 In the Settings window for Magnet, locate the Constitutive Relation Jc-E section.

4 From the Constrain for induced currents list, choose No induced currents constrain.
North |

I In the Model Builder window, click North 1.

2 Select Boundaries 7, 9, and 14 only.

South |

I In the Model Builder window, click South 1.

2 Select Boundaries 5, 11, and 13 only.

Laminated Core

I In the Physics toolbar, click @ Domains and choose Ampére’s Law in Solids.

2 In the Settings window for Ampére’s Law in Solids, type Laminated Core in the Label
text field.

3 Locate the Domain Selection section. From the Selection list, choose Laminated Core.

4 Locate the Constitutive Relation B-H section. From the Magnetization model list, choose
B-H curve.

Periodic Condition |

I In the Physics toolbar, click ) Boundaries and choose Periodic Condition.

2 Select Boundaries 2, 3, 5, 14, 16, and 29 only.

Periodic Condition 2

I In the Physics toolbar, click =) Boundaries and choose Periodic Condition.

2 Sclect Boundaries 34, 35, 37, 41, 49, 68, 70, 77, 79, and 80 only.

Periodic Magnetic Continuity |

I In the Physics toolbar, click E"j:_' Pairs and choose Periodic Magnetic Continuity.

2 In the Settings window for Periodic Magnetic Continuity, locate the Pair Selection section.

3 Click + Add.

4 In the Add dialog, sclect Identity Boundary Pair | (apl) in the Pairs list.

5 Click OK.

MESH |

I In the Model Builder window, under Component | (compl) right-click Mesh | and choose
Build All.
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2 Click the Zoom Extents button in the Graphics toolbar.
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The mesh should look like the figure above.

STUDY 1|

Step 2: Time Dependent
I In the Study toolbar, click

V" Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.
3 In the Output times text field, type range(0,0.02,1.5) *P_P/speed.
Solution | (soll)

I In the Study toolbar, click M= Show Default Solver.

2 In the Model Builder window, expand the Solution I (soll) node.

3 In the Model Builder window, expand the Study | > Solver Configurations >

Solution | (soll) > Time-Dependent Solver |1 node, then click Fully Coupled 1.

4 In the Settings window for Fully Coupled, click to expand the Method and Termination
section.

5 From the Jacobian update list, choose On every iteration.

6 In the Study toolbar, click = Compute.
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RESULTS

Revolution 2D |
In the Model Builder window, expand the Results > Datasets node, then click
Revolution 2D 1.

Selection

I In the Results toolbar, click " Attributes and choose Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.
3 From the Geometric entity level list, choose Domain.

4 Click % Paste Selection.
5

In the Paste Selection dialog, type 3, 5, 8, 9, 11-15, 17, 19, 21, 22inthe
Selection text field.

6 Click OK.

Revolution 2D 2

I In the Results toolbar, click More Datasets and choose Revolution 2D.

2 In the Settings window for Revolution 2D, click to expand the Revolution Layers section.
3 In the Start angle text field, type -90.

4 In the Revolution angle text field, type 225.

Selection

I In the Results toolbar, click g Attributes and choose Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.
3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Magnets.

Revolution 2D 3

I In the Results toolbar, click More Datasets and choose Revolution 2D.

2 In the Settings window for Revolution 2D, locate the Revolution Layers section.

3 In the Start angle text field, type -90.

4 In the Revolution angle text field, type 225.

Selection

I In the Results toolbar, click g Attributes and choose Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.
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4 From the Selection list, choose Coils.

Magnetic Flux Density (mf)
I In the Model Builder window, expand the Results > Magnetic Flux Density (mf) node, then
click Magnetic Flux Density (mf).

2 In the Settings window for 2D Plot Group, locate the Color Legend section.
3 Clear the Show maximum and minimum values checkbox.

4 Sclect the Show units checkbox.

Contour |

I In the Model Builder window, click Contour 1.

2 In the Settings window for Contour, locate the Expression section.

3 In the Expression text field, type r*mf.Aphi.

Color Expression |

I Right-click Contour I and choose Color Expression.

2 In the Settings window for Color Expression, locate the Coloring and Style section.
3 Clear the Color legend checkbox.

Surface 2

I In the Model Builder window, under Results > Magnetic Flux Density (mf) right-click

Surface | and choose Duplicate.
2 In the Settings window for Surface, click to expand the Title section.
3 From the Title type list, choose None.
4 Locate the Coloring and Style section. Clear the Color legend checkbox.
Transformation |
I Right-click Surface 2 and choose Transformation.
2 In the Settings window for Transformation, locate the Transformation section.
3 In the z text field, type P_P.
Surface 3

In the Model Builder window, under Results > Magnetic Flux Density (mf) right-click

Surface 2 and choose Duplicate.

Transformation |
I In the Model Builder window, expand the Surface 3 node, then click Transformation 1.

2 In the Settings window for Transformation, locate the Transformation section.
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3 In the z text field, type -P_P.

Streamline 2
In the Model Builder window, under Results > Magnetic Flux Density (mf) right-click

Streamline | and choose Duplicate.

Transformation |

I In the Model Builder window, expand the Streamline 2 node.

2 Right-click Streamline 2 and choose Transformation.

3 In the Settings window for Transformation, locate the Transformation section.
4 In the z text field, type P_P.

Streamline 3

In the Model Builder window, under Results > Magnetic Flux Density (mf) right-click

Streamline 2 and choosec Duplicate.

Transformation |

I In the Model Builder window, expand the Streamline 3 node, then click Transformation |I.
2 In the Settings window for Transformation, locate the Transformation section.

3 In the z text field, type -P_P.

Contour 2

In the Model Builder window, under Results > Magnetic Flux Density (mf) right-click

Contour | and choose Duplicate.

Transformation |

I In the Model Builder window, expand the Contour 2 node.

2 Right-click Contour 2 and choose Transformation.

3 In the Settings window for Transformation, locate the Transformation section.
4 In the z text field, type P_P.

Contour 3

In the Model Builder window, under Results > Magnetic Flux Density (mf) right-click

Contour 2 and choose Duplicate.

Transformation |
I In the Model Builder window, expand the Contour 3 node, then click Transformation 1.

2 In the Settings window for Transformation, locate the Transformation section.

3 In the z text field, type -P_P.
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4 In the Magnetic Flux Density (mf) toolbar, click Plot.
5 Click the Zoom Extents button in the Graphics toolbar.
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Magnetic Flux Density Norm, Revolved Geometry (mf)

I In the Model Builder window, under Results click Magnetic Flux Density,

N o0 i AW

8

Contour |

Revolved Geometry (mf).

In the Settings window for 3D Plot Group, type Magnetic Flux Density Norm,
Revolved Geometry (mf) in the Label text field.

Locate the Data section. From the Time (s) list, choose Interpolation.

Click to expand the Title section. From the Title type list, choose Custom.

Find the Type and data subsection. Clear the Type checkbox.

Clear the Unit checkbox.

Locate the Color Legend scction. Clear the Show maximum and minimum values
checkbox.

Select the Show units checkbox.

I In the Model Builder window, expand the Magnetic Flux Density Norm,

Revolved Geometry (mf) node, then click Contour 1.

2 In the Settings window for Contour, locate the Expression section.

3 In the Expression text field, type mf.normB.
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Filter |

I In the Model Builder window, expand the Contour | node.

2 Right-click Filter I and choose Disable.

Volume 2
I In the Model Builder window, under Results > Magnetic Flux Density Norm,

Revolved Geometry (mf) right-click Volume I and choose Duplicate.
2 In the Settings window for Volume, locate the Coloring and Style section.
3 Clear the Color legend checkbox.
Transformation |
I Right-click Volume 2 and choose Transformation.
2 In the Settings window for Transformation, locate the Transformation section.
3 In the z text field, type P_P.
Volume 3

In the Model Builder window, under Results > Magnetic Flux Density Norm,

Revolved Geometry (mf) right-click Volume 2 and choose Duplicate.

Transformation |

I In the Model Builder window, expand the Volume 3 node, then click Transformation 1.
2 In the Settings window for Transformation, locate the Transformation section.

3 In the z text field, type -P_P.

Contour 2

In the Model Builder window, under Results > Magnetic Flux Density Norm,

Revolved Geometry (mf) right-click Contour | and choose Duplicate.
Transformation |

I In the Model Builder window, right-click Contour 2 and choose Transformation.
2 In the Settings window for Transformation, locate the Transformation section.
3 In the z text field, type P_P.

Contour 3

In the Model Builder window, under Results > Magnetic Flux Density Norm,

Revolved Geometry (mf) right-click Contour 2 and choose Duplicate.

Transformation |
I In the Model Builder window, expand the Contour 3 node, then click Transformation 1.

2 In the Settings window for Transformation, locate the Transformation section.
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3 In the z text field, type -P_P.
4 In the Magnetic Flux Density Norm, Revolved Geometry (mf) toolbar, click Plot.
5 Click the Zoom Extents button in the Graphics toolbar.

Time=0.099 s Magnetic flux density norm Magnetic flux density norm Magnetic flux density norm

y‘\T/'X

Magnetic Vector Potential
I In the Results toolbar, click r. 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Magnetic Vector Potential in the
Label text field.

3 Locate the Title section. From the Title type list, choose Label.
Magnetic vector potential
I Right-click Magnetic Vector Potential and choose Surface.

2 In the Settings window for Surface, type Magnetic vector potential in the Label text
field.

3 Locate the Expression section. In the Expression text field, type mf . Aphi.

4 Locate the Coloring and Style section. From the Color table type list, choose Discrete.
5 In the Number of bands text field, type 21.

6 Click the Zoom Extents button in the Graphics toolbar.

Magnetic vector potential Translated Up
I Right-click Magnetic vector potential and choose Duplicate.
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2 In the Settings window for Surface, type Magnetic vector potential Translated
Up in the Label text field.

3 Locate the Coloring and Style section. Clear the Color legend checkbox.

Transformation |

I Right-click Magnetic vector potential Translated Up and choose Transformation.
2 In the Settings window for Transformation, locate the Transformation section.

3 In the z text field, type P_P.

Magnetic vector potential Translated Down
I In the Model Builder window, right-click Magnetic vector potential Translated Up and
choose Duplicate.

2 In the Settings window for Surface, type Magnetic vector potential Translated

Down in the Label text field.

Transformation |
I In the Model Builder window, expand the Magnetic vector potential Translated Down
node, then click Transformation 1.

In the Settings window for Transformation, locate the Transformation section.
In the z text field, type -P_P.

Click the Zoom Extents button in the Graphics toolbar.

In the Magnetic Vector Potential toolbar, click Plot.

vi A W N
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Phase Voltages
I In the Results toolbar, click ™. 1D Plot Group.

2 In the Settings window for ID Plot Group, type Phase Voltages in the Label text field.
Phase Voltages

I Right-click Phase Voltages and choose Global.

2 In the Settings window for Glebal, type Phase Voltages in the Label text field.

3 Locate the y-Axis Data section. In the table, enter the following settings:

Expression Unit Description
mf.VCoil_t1 \Y Phase A
mf.vCoil_2 \ Phase B
mf.vVCoil_3 v Phase C

4 In the Phase Voltages toolbar, click Plot.
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