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Introduction

This tutorial model shows how to trace unpolarized light rays through a Newtonian 
telescope. The incoming light is reflected off a paraboloidal mirror onto a flat elliptically 
shaped secondary mirror which folds the optical path by 90 degrees toward a flat focal 
plane. The telescope geometry is parameterized in terms of the primary mirror focal length 
and diameter, and the distance of the focal plane from the optical axis. This type of 
telescope was invented by Newton in 1668 and it remains a popular choice for amateur 
astronomers (Ref. 1).

Model Definition

The model simulates the propagation of rays coming from sources located at infinity 
(celestial objects) into a Newtonian telescope. 

The telescope geometry (see Figure 1) comprises two mirrors and two circular annuli. The 
primary mirror is a paraboloidal (conic constant k = -1) and has a radius of curvature of 
2.0 m. The primary mirror has a clear aperture slightly larger than the nominal 250 mm 
entrance pupil diameter. This gives the telescope a 1.0 m focal length with an f/4 focal 
ratio. The secondary mirror is folded at 45.0°, and it is elliptically shaped so that the 
obstruction can be minimized. An offset is applied to the axis of the fold mirror so that the 
incident cone of rays is centered on the mirror. The fold is sized so as to permit a telescope 
field of view of ±30 arcminutes. The first circular annulus is placed ahead of the secondary 
mirror to emulate the obstruction by mount for this mirror. The second annulus is placed 
at the folded focal plane.

Because the primary mirror in this single-physics simulation is a paraboloid, a quadratic 
shape function can be used to determine boundary interactions. For the same reason, a 
relatively coarse mesh can be used on primary mirror surface (see Figure 2) while still 
giving high accuracy ray traces.

Results and Discussion

Figure 3 shows the result of a ray trace. In this rendering, only the tangential and sagittal 
rays are shown. The spot diagram shown in Figure 4 gives the location of the rays in the 
focal plane. The RMS spot size of an on-axis bundle of rays is extremely small (essentially 
zero), thereby demonstrating the high precision of this model.

Other field angles can be traced by adjusting the x and y field angles (theta_x, theta_y) 
parameters in the global definitions for this model.
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Figure 1: The Newtonian telescope geometry.

Figure 2: The Newtonian telescope mesh. Note that only the primary mirror surface is refined.
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Figure 3: The Newtonian telescope ray diagram.

Figure 4: The Newtonian telescope spot diagram. The Airy ring is shown in the lower left-
corner.
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Reference

1. http://en.wikipedia.org/wiki/Newtonian_telescope.

Application Library path: Ray_Optics_Module/Lenses_Cameras_and_Telescopes/
newtonian_telescope

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Optics>Ray Optics>Geometrical Optics (gop).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Ray Tracing.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1: Telescope Geometry
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, type Parameters 1: Telescope Geometry in 
the Label text field. The telescope geometry parameters will be added when the 
geometry sequence is inserted.

Parameters 2: Wavelengths and Fields
The wavelength and field parameters can be loaded from a text file.

1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Parameters 2: Wavelengths and 
Fields in the Label text field.

3 Locate the Parameters section. Click Load from File.
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4 Browse to the model’s Application Libraries folder and double-click the file 
newtonian_telescope_parameters.txt.

N E W T O N I A N  T E L E S C O P E

Insert the prepared geometry sequence from file. You can read the instructions for creating 
the geometry in the appendix.

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, type Newtonian Telescope in the Label text field.

3 Locate the Units section. From the Length unit list, choose mm.

4 In the Geometry toolbar, click Insert Sequence and choose Insert Sequence.

5 Browse to the model’s Application Libraries folder and double-click the file 
newtonian_telescope_geom_sequence.mph.

6 Right-click Component 1 (comp1)>Newtonian Telescope and choose Build All Objects.

7 Click the Orthographic Projection button in the Graphics toolbar.

8 Click the Zoom Extents button in the Graphics toolbar. Compare the resulting 
geometry to Figure 1.

G E O M E T R I C A L  O P T I C S  ( G O P )

1 In the Model Builder window, under Component 1 (comp1) click Geometrical Optics (gop).

2 In the Settings window for Geometrical Optics, locate the Ray Release and Propagation 
section.

3 In the Maximum number of secondary rays text field, type 0.

4 Locate the Additional Variables section. Select the Count reflections check box. The 
number of reflections (gop.Nrefl) can be used to control the behavior of physics 
features or during postprocessing.

Medium Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Geometrical Optics (gop) click 

Medium Properties 1.

2 In the Settings window for Medium Properties, locate the Medium Properties section.

3 From the n list, choose User defined. The rays only propagate in the empty space around 
the mirrors, not through the mirrors themselves, so the refractive index in the domains 
can be given an arbitrary value like n=1.

Ray Properties 1
1 In the Model Builder window, click Ray Properties 1.
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2 In the Settings window for Ray Properties, locate the Ray Properties section.

3 In the λ0 text field, type lam.

Release from Grid 1
In the following, hexapolar grid release features are added. The direction vectors and 
launch positions are set using the parameters defined above.

1 In the Physics toolbar, click Global and choose Release from Grid.

2 In the Settings window for Release from Grid, locate the Initial Coordinates section.

3 From the Grid type list, choose Hexapolar.

4 Specify the qc vector as

5 Specify the rc vector as

6 In the Rc text field, type d_pupil/2.

7 In the Nc text field, type N_hex.

8 Locate the Ray Direction Vector section. Specify the L0 vector as

Release from Grid 2
1 Right-click Release from Grid 1 and choose Duplicate.

2 In the Settings window for Release from Grid, locate the Initial Coordinates section.

3 Specify the qc vector as

dx1 x

dy1 y

dz1 z

nix x

niy y

niz z

vx1 x

vy1 y

vz1 z

dx2 x

dy2 y

dz2 z
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4 Locate the Ray Direction Vector section. Specify the L0 vector as

Release from Grid 3
1 Right-click Release from Grid 2 and choose Duplicate.

2 In the Settings window for Release from Grid, locate the Initial Coordinates section.

3 Specify the qc vector as

4 Locate the Ray Direction Vector section. Specify the L0 vector as

Next, define the boundary conditions, which will be specular reflection on the mirror 
surfaces and absorption everywhere else.

Primary Mirror
1 In the Physics toolbar, click Boundaries and choose Mirror.

2 In the Settings window for Mirror, type Primary Mirror in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose 
Mirror surface (Primary Mirror).

Secondary Mirror
1 In the Physics toolbar, click Boundaries and choose Wall.

2 In the Settings window for Wall, type Secondary Mirror in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose 
Mirror surface (Secondary Mirror).

4 Locate the Wall Condition section. From the Wall condition list, choose 
Specular reflection.

vx2 x

vy2 y

vz2 z

dx3 x

dy3 y

dz3 z

vx3 x

vy3 y

vz3 z
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5 Locate the Primary Ray Condition section. From the Primary ray condition list, choose 
Expression.

6 In the e text field, type gop.Nrefl>0.

7 From the Otherwise list, choose Pass through.

Primary Obstructions
1 In the Physics toolbar, click Boundaries and choose Wall.

2 In the Settings window for Wall, type Primary Obstructions in the Label text field.

3 Locate the Wall Condition section. From the Wall condition list, choose Disappear.

4 Locate the Boundary Selection section. From the Selection list, choose 
Primary Obstructions.

Secondary Obstructions
1 In the Physics toolbar, click Boundaries and choose Wall.

2 In the Settings window for Wall, type Secondary Obstructions in the Label text field.

3 Locate the Wall Condition section. From the Wall condition list, choose Disappear.

4 Locate the Boundary Selection section. From the Selection list, choose 
Secondary Obstructions.

Image Plane
1 In the Physics toolbar, click Boundaries and choose Wall.

2 In the Settings window for Wall, type Image Plane in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Detector.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Build All. Compare this figure to Figure 2.

S T U D Y  1

Step 1: Ray Tracing
1 In the Model Builder window, under Study 1 click Step 1: Ray Tracing.

2 In the Settings window for Ray Tracing, locate the Study Settings section.

3 From the Time-step specification list, choose Specify maximum path length.

4 From the Length unit list, choose mm.
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5 In the Lengths text field, type 0 2.25*f. The maximum path length is slightly greater 
than twice the focal length of the telescope. This ensures that all rays reach the focal 
plane.

6 In the Home toolbar, click Compute.

R E S U L T S

Ray Diagram
First, refine the default ray diagram plot. A spot diagram plot will be added below.

1 In the Settings window for 3D Plot Group, type Ray Diagram in the Label text field.

2 Locate the Color Legend section. Select the Show units check box.

3 In the Model Builder window, expand the Ray Diagram node.

Color Expression 1
1 In the Model Builder window, expand the Results>Ray Diagram>Ray Trajectories 1 node, 

then click Color Expression 1.

2 In the Settings window for Color Expression, locate the Expression section.

3 In the Expression text field, type at('last',gop.rrel). This expression gives the 
radial distance from the centroid of the spot on the image plane generated by each 
release feature.

4 From the Unit list, choose µm.

5 Locate the Coloring and Style section. Click Change Color Table.

6 In the Color Table dialog box, select Thermal>ThermalWave in the tree.

7 Click OK.

Filter 1
1 In the Model Builder window, click Filter 1.

2 In the Settings window for Filter, locate the Ray Selection section.

3 From the Rays to include list, choose Logical expression.

4 In the Logical expression for inclusion text field, type gop.Nrefl>0. This will render only 
the rays after reflection from the primary mirror.

Ray Trajectories 2
1 In the Model Builder window, under Results>Ray Diagram right-click Ray Trajectories 1 

and choose Duplicate.

2 In the Settings window for Ray Trajectories, click to expand the Inherit Style section.

3 From the Plot list, choose Ray Trajectories 1.
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Filter 1
1 In the Model Builder window, expand the Ray Trajectories 2 node, then click Filter 1.

2 In the Settings window for Filter, locate the Ray Selection section.

3 In the Logical expression for inclusion text field, type gop.Nrefl==0.

Transparency 1
1 In the Model Builder window, right-click Ray Trajectories 2 and choose Transparency.

2 In the Settings window for Transparency, locate the Transparency section.

3 In the Transparency text field, type 0.8.

Surface 1
1 In the Model Builder window, right-click Ray Diagram and choose Surface.

2 In the Settings window for Surface, locate the Coloring and Style section.

3 From the Coloring list, choose Uniform.

4 From the Color list, choose Gray.

5 In the Ray Diagram toolbar, click Plot.

6 Click the Zoom Extents button in the Graphics toolbar. Compare this figure to 
Figure 3.

Now, create a spot diagram.

Spot Diagram
1 In the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Spot Diagram in the Label text field.

3 Locate the Color Legend section. Select the Show units check box.

Spot Diagram 1
1 In the Spot Diagram toolbar, click More Plots and choose Spot Diagram.

2 In the Settings window for Spot Diagram, click to expand the Annotations section.

3 Select the Show circle check box.

4 In the Radius text field, type r_Airy.

Color Expression 1
1 Right-click Spot Diagram 1 and choose Color Expression.

2 In the Settings window for Color Expression, locate the Expression section.

3 In the Expression text field, type at(0,gop.rrel). This is the radial coordinate relative 
to the centroid at the entrance pupil for each ray release.
11 |  N E W T O N I A N  T E L E S C O P E



4 Locate the Coloring and Style section. Click Change Color Table.

5 In the Color Table dialog box, select Rainbow>Prism in the tree.

6 Click OK.

7 In the Spot Diagram toolbar, click Plot.

8 Click the Zoom Extents button in the Graphics toolbar. Compare this figure to 
Figure 4.
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Appendix — Geometry Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 Click Done.

N E W T O N I A N  T E L E S C O P E  G E O M E T R Y  S E Q U E N C E

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, type Newtonian Telescope Geometry 
Sequence in the Label text field.

3 Locate the Units section. From the Length unit list, choose mm.

G L O B A L  D E F I N I T I O N S

Load the parameters for the Newtonian Telescope geometry sequence from a text file.

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
newtonian_telescope_geom_sequence_parameters.txt.

N E W T O N I A N  T E L E S C O P E  G E O M E T R Y  S E Q U E N C E

The telescope geometry is created using predefined geometry Parts.

P A R T  L I B R A R I E S

1 In the Home toolbar, click Windows and choose Part Libraries.

2 In the Model Builder window, under Component 1 (comp1) click 
Newtonian Telescope Geometry Sequence.

3 In the Part Libraries window, select Ray Optics Module>3D>Mirrors>

conic_mirror_on_axis_3d in the tree.

4 Click Add to Geometry.
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5 In the Select Part Variant dialog box, select Specify clear aperture diameter in the 
Select part variant list.

6 Click OK.

N E W T O N I A N  T E L E S C O P E  G E O M E T R Y  S E Q U E N C E

Primary Mirror
1 In the Model Builder window, under Component 1 (comp1)>

Newtonian Telescope Geometry Sequence click Conic Mirror On Axis 3D 1 (pi1).

2 In the Settings window for Part Instance, type Primary Mirror in the Label text field.

3 Locate the Input Parameters section. In the table, enter the following settings:

The input parameters are defined in the Parameters 1 node.

4 Click to expand the Boundary Selections section. Click New Cumulative Selection.

5 In the New Cumulative Selection dialog box, type Primary Obstructions in the Name 
text field.

6 Click OK. This selection, and those that follow will be used to apply boundary 
conditions later in the model setup.

7 In the Settings window for Part Instance, locate the Boundary Selections section.

8 Click New Cumulative Selection.

Name Expression Value Description

R -2*f -2000 mm Radius of curvature (+convex/-
concave)

k k -1 Conic constant

Tc Tc_prim 35 mm Center thickness

d0 d0_prim 275 mm Mirror full diameter

d1 d1_prim 260 mm Mirror surface diameter

d_clear d_clear 0 m Clear aperture diameter

d_hole 0 0 m Center hole diameter

nix -nix -0 Local optical axis, x-component

niy -niy -0 Local optical axis, y-component

niz -niz -1 Local optical axis, z-component

n_extra_r 0 0 Number of extra radial points

n_extra_a 0 0 Number of extra azimuthal points
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9 In the New Cumulative Selection dialog box, type Secondary Obstructions in the 
Name text field.

10 Click OK.

11 In the Settings window for Part Instance, locate the Boundary Selections section.

12 Click New Cumulative Selection.

13 In the New Cumulative Selection dialog box, type Detector in the Name text field.

14 Click OK.

Now, apply each of these selections.

15 In the Settings window for Part Instance, locate the Boundary Selections section.

16 In the table, enter the following settings:

P A R T  L I B R A R I E S

1 In the Home toolbar, click Windows and choose Part Libraries.

2 In the Model Builder window, click Newtonian Telescope Geometry Sequence.

3 In the Part Libraries window, select Ray Optics Module>3D>Mirrors>

elliptical_planar_mirror_3d in the tree.

4 Click Add to Geometry.

5 In the Select Part Variant dialog box, select Specify mirror angle and minor axis diameter 
in the Select part variant list.

6 Click OK.

N E W T O N I A N  T E L E S C O P E  G E O M E T R Y  S E Q U E N C E

Secondary Mirror
1 In the Model Builder window, under Component 1 (comp1)>

Newtonian Telescope Geometry Sequence click Elliptical Planar Mirror 3D 1 (pi2).

2 In the Settings window for Part Instance, type Secondary Mirror in the Label text field.

Name Keep Physics Contribute to

Mirror surface √ √ None

Mirror obstruction √ Primary Obstructions

Mirror rear surface √ Primary Obstructions

Mirror edges √ Primary Obstructions
15 |  N E W T O N I A N  T E L E S C O P E



3 Locate the Input Parameters section. In the table, enter the following settings:

As above, many of the input parameters are predefined. Note that the global optical axis 
is nix=niy=0,niz=1. Therefore, after each mirror reflection niz changes sign. The 
orientation of the fold angle is set so that the fold angle is -45 degrees with respect to 
the local optical axis, where the axis of rotation is the local y-axis.

4 Locate the Position and Orientation of Output section. Find the 
Coordinate system to match subsection. From the Take work plane from list, choose 
Primary Mirror (pi1).

5 From the Work plane list, choose Mirror vertex intersection (wp1).

6 Find the Displacement subsection. In the zw text field, type -(f-f_image). Note that 
the work plane that intersects the primary mirror vertex is defined prior to a reflection. 
Therefore, the relative position of the secondary mirror is negative.

7 Locate the Boundary Selections section. In the table, enter the following settings:

P A R T  L I B R A R I E S

1 In the Home toolbar, click Windows and choose Part Libraries.

2 In the Model Builder window, click Newtonian Telescope Geometry Sequence.

Name Expression Value Description

Tc Tc_sec 10 mm Mirror thickness

d0 1.25*d_sec 62.5 mm Minor axis diameter

theta 45.0[deg] 45 ° Mirror angle

dx delta_sec 4.4194 mm Offset from optical axis

nix 0 0 Local optical axis, x-component

niy 0 0 Local optical axis, y-component

niz -1 -1 Local optical axis, z-component

nxx -1 -1 Fold angle direction, x component

nxy 0 0 Fold angle direction, y component

nxz 0 0 Fold angle direction, z component

Name Keep Physics Contribute to

Mirror surface √ √ None

Mirror edges √ Secondary Obstructions

Mirror rear √ Secondary Obstructions
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3 In the Part Libraries window, select Ray Optics Module>3D>Apertures and Obstructions>

circular_planar_annulus in the tree.

4 Click Add to Geometry.

N E W T O N I A N  T E L E S C O P E  G E O M E T R Y  S E Q U E N C E

Secondary Obstruction
1 In the Model Builder window, under Component 1 (comp1)>

Newtonian Telescope Geometry Sequence click Circular Planar Annulus 1 (pi3).

2 In the Settings window for Part Instance, type Secondary Obstruction in the Label 
text field.

3 Locate the Input Parameters section. In the table, enter the following settings:

4 Locate the Position and Orientation of Output section. Find the 
Coordinate system to match subsection. From the Take work plane from list, choose 
Secondary Mirror (pi2).

5 From the Work plane list, choose Reference plane (wp1).

6 Find the Displacement subsection. In the xw text field, type -delta_sec.

7 In the zw text field, type d_sec.

8 Locate the Boundary Selections section. In the table, enter the following settings:

Image Plane
1 In the Geometry toolbar, click Parts and choose Circular Planar Annulus.

2 In the Settings window for Part Instance, type Image Plane in the Label text field.

Name Expression Value Description

d0 1.30*d_sec 65 mm Diameter, outer

d1 0 0 m Diameter, inner

nix 0 0 Local optical axis, x-component

niy 0 0 Local optical axis, y-component

niz 1 1 Local optical axis, z-component

Name Keep Physics Contribute to

All √ Secondary Obstructions
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3 Locate the Input Parameters section. In the table, enter the following settings:

4 Locate the Position and Orientation of Output section. Find the 
Coordinate system to match subsection. From the Take work plane from list, choose 
Secondary Mirror (pi2).

5 From the Work plane list, choose Exit plane (wp4).

6 Find the Displacement subsection. In the zw text field, type -f_image.

7 Locate the Boundary Selections section. In the table, enter the following settings:

8 Click Build All Objects.

9 Click the Orthographic Projection button in the Graphics toolbar.

10 Click the Zoom Extents button in the Graphics toolbar.

Name Expression Value Description

d0 d_image 50 mm Diameter, outer

d1 0 0 m Diameter, inner

nix 0 0 Local optical axis, x-component

niy 0 0 Local optical axis, y-component

niz 1 1 Local optical axis, z-component

Name Keep Physics Contribute to

All √ Detector
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