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Introduction

A double Gauss lens is a multiple element objective lens commonly used in imaging 
systems. It is capable of high quality imagery over moderately large field angles, at modest 
to high speed. In this tutorial, a double Gauss lens model (Figure 1) is constructed using 
multiple instances of standard parts from the built-in Part Library for the Ray Optics 
Module. The results of a ray trace will be presented together with a spot diagram and a 
wavefront aberration diagram.

Figure 1: Overview of the double Gauss lens used in this tutorial. In this view the marginal 
rays of an on-axis trace are shown, together with the chief ray of 4 additional fields.

Model Definition

The double Gauss lens simulated in this tutorial is an f/1.7, 100.2 mm focal length, 19° 
field of view lens by Lautebacher & Brendel (Agfa Camera-Werk AG, U.S. Patent 
2784643), from Ref. 1, p. 323, although some materials have been replaced with 
equivalent optical glasses. The prescription of this lens is given in Table 1 and the 
instructions for creating the lens can be found in the Appendix — Geometry Instructions.

The lens geometry is created by inserting each lens element (including the stop) 
sequentially, such that each subsequent lens is placed relative to the prior one. This process 
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is simplified by making use of the predefined work planes within the part instances. It is 
important to appreciate that the ray tracing method used by the Geometrical Optics 
interface is inherently nonsequential, so the same result could be obtained by placing part 
instances within the geometry in any order. The double Gauss lens geometry sequence is 
shown in Figure 2 and the default, Physics-controlled mesh, is seen in Figure 3.

In addition to the lens parameters used to define the lens geometry, a set of parameters are 
required to define the ray trace. These are detailed in Table 2.

TABLE 1:  DOUBLE GAUSS LENS PARAMETERS.

Index Name Radius 
(mm)

Thickness 
(mm)

Material Clear radius 
(mm)

— Object ∞ ∞ — —

1 Lens 1 75.050 9.000 S-LAM 3 33.0

— — 270.700 0.100 — 33.0

2 Lens 2 39.270 16.510 S-BAH11 27.5

3 Lens 3 ∞ 2.000 N-SF5 24.5

— — 25.650 10.990 — 19.5

4 Stop ∞ 13.000 — 18.6

5 Lens 4 −31.870 7.030 N-SF5 18.5

6 Lens 5 ∞ 8.980 S-LAM 3 21.0

— — −43.510 0.100 — 21.0

7 Lens 6 221.140 7.980 S-BAH11 23.0

— — −88.790 61.418 — 23.0

— Image ∞ — — 42.5

TABLE 2:  GLOBAL PARAMETER DEFINITIONS.

Parameter Value Description

λvac 550 nm Nominal (vacuum) wavelength

θx 0° Nominal x field angle

θy 0° Nominal y field angle

Nring 18 Number of hexapolar rings. (Nring = 18 will give 
a total of 1027 rays.)

Pnom 58.941 mm Nominal entrance pupil diameter

Pfac1 −1.15 Pupil shift factor 1

Pfac2 −0.60 Pupil shift factor 2
3 |  D O U B L E  G A U S S  L E N S



Figure 2: The double Gauss lens geometry sequence.

Figure 3: The default Physics-controlled mesh for the double Gauss lens.
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Several of the parameters defined in Table 2 are used to derive additional parameters such 
as the ray direction vector components, the stop and image plane z-coordinates, as well as 
the entrance pupil location. Table 3 gives the expressions used to derived these parameters. 
Note that the pupil shift factor is used in a empirical approximation to ensure that the chief 
ray passes through the center of the stop at all field angles.

Results and Discussion

A ray trace has been made at a single wavelength (550 nm) and field angle (on-axis). In 
Figure 4 the ray trajectories can be seen colored by optical path length and in Figure 5, a 
color expression based on the location of the rays at the image plane is used.

Spot diagrams at both the nominal and refocused image plane are shown in Figure 6. The 
refocused spot diagram in Figure 6 uses an Intersection Point 3D dataset which has been 
automatically positioned on the plane which minimizes the RMS spot size. At this 
wavelength and field angle, this plane is located 180 μm ahead of the nominal image 
surface.

Figure 7 shows the wavefront error. After removing piston and defocus, it is possible to 
see that spherical aberration dominates the remaining terms.

TABLE 3:  GLOBAL PARAMETER DEFINITIONS (DERIVED).

Parameter Value Description

vx tanθx Ray direction vector, x-component

vy tanθy Ray direction vector, y-component

vz 1 Ray direction vector, z-component

zstop Stop z-coordinate, where Tc,n is the central 
thickness of element n and Tn is the 
separation between elements n and n+1. 
Note that the stop is the 4th element in the 
double Gauss lens.

zimage Image plane z-coordinate, where Tc,n is the 
central thickness of element n and Tn is the 
separation between elements n and n+1. 
Including the stop, the double Gauss lens has 
7 elements.

Pfac Pfac1 + Pfac2 sinθ
Pupil shift factor, where 

Δxpupil (Δzpupil + Pfac zstop)tanθx Pupil shift, x-coordinate

Δypupil (Δzpupil + Pfac zstop)tanθy Pupil shift, y-coordinate

Tc n, Tn+( )
n 1=
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Tc n, Tn+( )
n 1=
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Figure 4: Ray diagram of the double Gauss lens colored by optical path length.

Figure 5: Ray diagram of the double Gauss lens where the rays are colored by their radial 
distance from the centroid on the image plane.
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Figure 6: Spot diagram for the double Gauss lens. The spot on the nominal image plane is on 
the left, and the spot on the best focus plane is seen on the right.

Figure 7: The double Gauss lens optical aberration diagram. The plot on the left uses all 
Zernike terms. On the right, piston and defocus are removed.
7 |  D O U B L E  G A U S S  L E N S



Reference

1. W.J. Smith, Modern lens design, vol. 2. New York, NY, USA: McGraw-Hill, 2005.

Application Library path: Ray_Optics_Module/Lenses_Cameras_and_Telescopes/
double_gauss_lens

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Optics>Ray Optics>Geometrical Optics (gop).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Ray Tracing.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1: Lens Prescription
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, type Parameters 1: Lens Prescription in 
the Label text field. The lens prescription will be added when the geometry sequence is 
inserted in the following section.

Parameters 2: General
The double Gauss lens simulation parameters can be loaded from a text file.

1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Parameters 2: General in the Label text 
field.

3 Locate the Parameters section. Click Load from File.
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4 Browse to the model’s Application Libraries folder and double-click the file 
double_gauss_lens_parameters.txt.

D O U B L E  G A U S S  L E N S

Insert the prepared geometry sequence from file. You can read the instructions for creating 
the geometry in the appendix. Following insertion, the lens definitions will be available in 
the Parameters node.

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, type Double Gauss Lens in the Label text field.

3 In the Geometry toolbar, click Insert Sequence and choose Insert Sequence.

4 Browse to the model’s Application Libraries folder and double-click the file 
double_gauss_lens_geom_sequence.mph.

5 In the Geometry toolbar, click Build All.

6 Click the Orthographic Projection button in the Graphics toolbar.

7 In the Graphics window toolbar, click next to Go to Default View, then choose 
Go to ZY View. Orient the view to place the z-axis (optical axis) horizontal and the y-axis 
vertical. Compare the resulting geometry to Figure 2.

M A T E R I A L S

Load the materials used by each of the lenses.

A D D  M A T E R I A L

1 In the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Optical>Ohara Glass>Ohara S-LAM 3 Glass.

4 Click Add to Component in the window toolbar.

5 In the tree, select Optical>Ohara Glass>Ohara S-BAH11 Glass.

6 Click Add to Component in the window toolbar.

7 In the tree, select Optical>Schott Glass>Schott N-SF5 Glass.

8 Click Add to Component in the window toolbar.

9 In the Home toolbar, click Add Material to close the Add Material window.
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M A T E R I A L S

Ohara S-LAM 3 Glass (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Ohara S-

LAM 3 Glass (mat1).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Lens Material 1.

Ohara S-BAH11 Glass (mat2)
1 In the Model Builder window, click Ohara S-BAH11 Glass (mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Lens Material 2.

Schott N-SF5 Glass (mat3)
1 In the Model Builder window, click Schott N-SF5 Glass (mat3).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Lens Material 3.

G E O M E T R I C A L  O P T I C S  ( G O P )

1 In the Model Builder window, under Component 1 (comp1) click Geometrical Optics (gop).

2 In the Settings window for Geometrical Optics, locate the Ray Release and Propagation 
section.

3 In the Maximum number of secondary rays text field, type 0. In this simulation stray light 
is not being traced, so reflected rays will not be produced at the lens surfaces.

4 Locate the Material Properties of Exterior and Unmeshed Domains section. From the 
Optical dispersion model list, choose Air, Edlen (1953). It is assumed that the double 
Gauss lens is surrounded by air at room temperature.

5 Locate the Additional Variables section. Select the Compute optical path length check 
box. The optical path length will be used to create an Optical Aberration plot.

Medium Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Geometrical Optics (gop) click 

Medium Properties 1.

2 In the Settings window for Medium Properties, locate the Medium Properties section.

3 From the Refractive index of domains list, choose Get dispersion model from material. 
Each of the materials added above contain the optical dispersion coefficients which can 
be used to compute the refractive index as a function of wavelength.
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Material Discontinuity 1
1 In the Model Builder window, click Material Discontinuity 1.

2 In the Settings window for Material Discontinuity, locate the Rays to Release section.

3 From the Release reflected rays list, choose Never.

Ray Properties 1
1 In the Model Builder window, click Ray Properties 1.

2 In the Settings window for Ray Properties, locate the Ray Properties section.

3 In the λ0 text field, type lambda. This wavelength is defined in the Parameters node.

Release from Grid 1
Release the rays from a hexapolar grid, using the quantities defined in the Parameters node.

1 In the Physics toolbar, click Global and choose Release from Grid.

2 In the Settings window for Release from Grid, locate the Initial Coordinates section.

3 From the Grid type list, choose Hexapolar.

4 Specify the qc vector as

The Center location of the hexapolar grid will change according to the field angle.

5 Specify the rc vector as

The Cylinder axis direction is the same as the global optical axis.

6 In the Rc text field, type P_nom/2.

7 In the Nc text field, type N_ring.

dx x

dy y

dz z

nix x

niy y

niz z
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8 Locate the Ray Direction Vector section. Specify the L0 vector as

The Ray direction vector is calculated using the field angles defined in the Parameters 
node.

Obstructions
1 In the Physics toolbar, click Boundaries and choose Wall.

2 In the Settings window for Wall, type Obstructions in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Obstructions.

4 Locate the Wall Condition section. From the Wall condition list, choose Disappear.

Stop
1 In the Physics toolbar, click Boundaries and choose Wall.

2 In the Settings window for Wall, type Stop in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Aperture Stop.

4 Locate the Wall Condition section. From the Wall condition list, choose Disappear.

Image
1 In the Physics toolbar, click Boundaries and choose Wall.

2 In the Settings window for Wall, type Image in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Image Plane. The 
default Wall condition (Freeze) will be used.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Build All. The default physics-controlled mesh settings can be used in this simulation. The 
mesh should look like Figure 3.

S T U D Y  1

Step 1: Ray Tracing
1 In the Model Builder window, under Study 1 click Step 1: Ray Tracing.

2 In the Settings window for Ray Tracing, locate the Study Settings section.

3 From the Time-step specification list, choose Specify maximum path length.

vx x

vy y

vz z
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4 From the Length unit list, choose mm.

5 In the Lengths text field, type 0 200. The maximum optical path length is sufficient for 
rays released at large field angles to reach the image plane.

6 In the Home toolbar, click Compute.

R E S U L T S

In the following steps, two different ray diagrams are created, one of which uses a custom 
color expression. Begin by making some modifications to the default ray trajectory plot. 
First, define a cut plane which can be used to render the double Gauss lens cross section.

Cut Plane 1
In the Results toolbar, click Cut Plane.

Ray Diagram 1
1 In the Model Builder window, under Results click Ray Trajectories (gop).

2 In the Settings window for 3D Plot Group, type Ray Diagram 1 in the Label text field.

3 Locate the Color Legend section. Select the Show units check box.

4 From the Position list, choose Bottom.

5 In the Model Builder window, expand the Ray Diagram 1 node.

Filter 1
1 In the Model Builder window, expand the Results>Ray Diagram 1>Ray Trajectories 1 

node, then click Filter 1.

2 In the Settings window for Filter, locate the Ray Selection section.

3 From the Rays to include list, choose Logical expression.

4 In the Logical expression for inclusion text field, type at(0,abs(gop.deltaqx) < 
0.1[mm]). Only the sagittal rays are shown in this view.

In the following steps, the cross section of the lens is rendered.

Surface 1
1 In the Model Builder window, right-click Ray Diagram 1 and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Cut Plane 1.

4 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

5 From the Color list, choose Gray.
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Line 1
1 Right-click Ray Diagram 1 and choose Line.

2 In the Settings window for Line, locate the Data section.

3 From the Dataset list, choose Cut Plane 1.

4 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

5 From the Color list, choose Black.

6 In the Ray Diagram 1 toolbar, click Plot. Compare the resulting image to Figure 4.

Ray Diagram 2
For the second ray diagram the rays will be colored according to the radial distance from 
the ray’s location in the image plane to the centroid. This makes it possible to visualize 
which rays are contributing to the image plane spot aberrations.

1 In the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Ray Diagram 2 in the Label text field.

3 Locate the Data section. From the Dataset list, choose Ray 1.

4 Locate the Plot Settings section. From the View list, choose New view.

5 Locate the Color Legend section. Select the Show units check box.

Ray Trajectories 1
In the Ray Diagram 2 toolbar, click More Plots and choose Ray Trajectories.

Color Expression 1
1 Right-click Ray Trajectories 1 and choose Color Expression.

2 In the Settings window for Color Expression, locate the Expression section.

3 In the Expression text field, type at('last',gop.rrel). This is the radial coordinate 
relative to the centroid of each release feature at the image plane.

4 From the Unit list, choose µm.

5 Locate the Coloring and Style section. Click Change Color Table.

6 In the Color Table dialog box, select Linear>Viridis in the tree.

7 Click OK.

Surface 1
1 In the Model Builder window, right-click Ray Diagram 2 and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1 (comp1)>

Geometrical Optics>Refractive index>gop.nrefd - Refractive index, d-line.
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3 Locate the Coloring and Style section. Click Change Color Table.

4 In the Color Table dialog box, select Linear>GrayScale in the tree.

5 Click OK.

Selection 1
1 Right-click Surface 1 and choose Selection.

2 In the Settings window for Selection, locate the Selection section.

3 From the Selection list, choose Lens Exteriors.

Transparency 1
1 In the Model Builder window, right-click Surface 1 and choose Transparency.

2 In the Ray Diagram 2 toolbar, click Plot.

3 Click the Orthographic Projection button in the Graphics toolbar.

4 Click the Zoom Extents button in the Graphics toolbar. Orient the view to match 
Figure 5 so that the color expression in the object plane can be clearly seen.

Spot Diagram
In the following steps, a spot diagram is created.

Spot Diagram
1 In the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Spot Diagram in the Label text field.

3 Locate the Color Legend section. Select the Show units check box.

4 From the Position list, choose Bottom.

Spot Diagram 1
1 In the Spot Diagram toolbar, click More Plots and choose Spot Diagram.

2 In the Settings window for Spot Diagram, click to expand the Annotations section.

3 Select the Show spot coordinates check box.

4 From the Coordinate system list, choose Global. Using the Global coordinate system 
allows the z coordinate to be displayed.

5 In the Display precision text field, type 6.

Color Expression 1
1 Right-click Spot Diagram 1 and choose Color Expression.

2 In the Settings window for Color Expression, locate the Expression section.
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3 In the Expression text field, type at(0,gop.rrel). This is the radial coordinate relative 
to the center at the location of the ray release.

4 Locate the Coloring and Style section. Click Change Color Table.

5 In the Color Table dialog box, select Linear>Viridis in the tree.

6 Click OK.

The first spot diagram shows the intersection of the rays with the nominal image plane. 
This surface has been positioned so as to give the best image quality over a large range of 
field angles when using polychromatic light. A second spot diagram can be generated 
automatically on the plane which minimizes the RMS spot size for a selected field angle 
and wavelength.

Spot Diagram 2
1 In the Model Builder window, under Results>Spot Diagram right-click Spot Diagram 1 and 

choose Duplicate.

2 In the Settings window for Spot Diagram, click to expand the Focal Plane Orientation 
section.

3 From the Normal to focal plane list, choose User defined. In this model, the image plane 
is assumed to be tangential to the optical axis which is also the z-axis.

4 Click Create Focal Plane Dataset. This creates an Intersection Point 3D dataset on a Plane. 
In this model, which has a single on-axis field and monochromatic light, the location of 
the best focus plane happens to be in front of the nominal image surface. If the best 
focus plane lies behind the image plane, then the Freeze condition on the Wall defining 
the image surface should be disabled. Note that the focal plane is located about 180 
microns in front of the nominal image surface.

5 Click to expand the Position section. In the x text field, type 0.25.

6 Click to expand the Inherit Style section. From the Plot list, choose Spot Diagram 1.

7 In the Spot Diagram toolbar, click Plot.

8 Click the Zoom Extents button in the Graphics toolbar. Compare the resulting 
image to Figure 6.

Optical Aberration Diagram
In the following steps, an optical aberration diagram is created.

Optical Aberration Diagram
1 In the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Optical Aberration Diagram in the 
Label text field.
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3 Locate the Color Legend section. Select the Show maximum and minimum values check 
box.

4 From the Position list, choose Bottom.

Optical Aberration 1
1 In the Optical Aberration Diagram toolbar, click More Plots and choose 

Optical Aberration.

2 In the Settings window for Optical Aberration, locate the Focal Plane Orientation section.

3 From the Normal to focal plane list, choose User defined. As with the Spot Diagram, the 
image plane is assumed to be tangential to the optical axis which is also the z-axis.

4 Click Create Reference Hemisphere Dataset. This creates an Intersection Point 3D dataset 
on a reference hemisphere.

5 Locate the Coloring and Style section. Click Change Color Table.

6 In the Color Table dialog box, select Rainbow>Dipole in the tree.

7 Click OK.

8 In the Settings window for Optical Aberration, locate the Coloring and Style section.

9 From the Scale list, choose Linear symmetric.

Optical Aberration 2
1 Right-click Optical Aberration 1 and choose Duplicate. Duplicate this Aberration plot so 

that some Zernike terms can be removed.

2 In the Settings window for Optical Aberration, locate the Zernike Polynomials section.

3 From the Terms to include list, choose Select individual terms.

4 Click Select All.

5 Clear the Z(0,0), piston check box.

6 Clear the Z(2,0), defocus check box. The piston and defocus terms are removed.

7 Locate the Position section. In the x text field, type 2.5.

8 Click to expand the Inherit Style section. From the Plot list, choose Optical Aberration 1.

9 In the Optical Aberration Diagram toolbar, click Plot.

10 Click the Zoom Extents button in the Graphics toolbar. Compare the resulting 
image to Figure 7. The remaining wavefront error (about 0.6 waves) is dominated by 
spherical aberration.
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Appendix — Geometry Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 Click Done.

G L O B A L  D E F I N I T I O N S

The detailed parameters of the lens can be imported from a text file. This lens is from 
Ref. 1, pg 323.

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
double_gauss_lens_geom_sequence_parameters.txt.

Double Gauss Lens Parameters
The parameters that define the Double Gauss Lens geometry sequence are found in 
double_gauss_lens_geom_sequence_parameters.txt. These will be described in the 
tables below.

1 First, define the global optical axis. This is used to orient the first lens only. The 
orientation of each subsequent lens will be relative to the preceding one.

Parameter Description

nix Global optical axis, x-component

niy Global optical axis, y-component

niz Global optical axis, z-component
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2 Next, define the parameters for each of the lens elements. Each lens requires 8 
parameters in addition to the local optical axis definition (which, by convention, is 
coincident with the local z-axis).

3 Finally, define the remaining lens parameters.

D O U B L E  G A U S S  L E N S  G E O M E T R Y  S E Q U E N C E

Start constructing the lens geometry.

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, type Double Gauss Lens Geometry Sequence 
in the Label text field.

3 Locate the Units section. From the Length unit list, choose mm.

Insert the first of the Double Gauss Lens elements.

P A R T  L I B R A R I E S

1 In the Home toolbar, click Windows and choose Part Libraries.

2 In the Part Libraries window, select Ray Optics Module>3D>Spherical Lenses>

spherical_lens_3d in the tree.

3 Click Add to Geometry.

Parameter Description

R1_[n] Radius of curvature, surface 1, lens [n]

R2_[n] Radius of curvature, surface 2, lens [n]

Tc_[n] Center thickness, lens [n]

d0_[n] Outer diameter, lens [n]

d1_[n] Diameter, surface 1, lens [n]

d2_[n] Diameter, surface 2, lens [n]

d1_clear_[n] Clear aperture diameter, surface 1, lens [n]

d2_clear_[n] Clear aperture diameter, surface 2, lens [n]

Parameter Description

T_[n] Distance between lens elements [n] and [n+1].

d0_S Stop maximum (outer) diameter

d1_S Stop minimum (clear) diameter

d0_D Diameter of image plane
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4 In the Select Part Variant dialog box, select Specify clear aperture diameter in the 
Select part variant list.

5 Click OK. This part is used for each of the 6 Double Gauss Lens elements.

D O U B L E  G A U S S  L E N S  G E O M E T R Y  S E Q U E N C E

Lens 1
1 In the Model Builder window, under Component 1 (comp1)>

Double Gauss Lens Geometry Sequence click Spherical Lens 3D 1 (pi1).

2 In the Settings window for Part Instance, type Lens 1 in the Label text field.

3 Locate the Input Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
double_gauss_lens_geom_sequence_lens1.txt. The files 
double_gauss_lens_geom_sequence_lens[m,m=1..6].txt contains references to 
each of the individual lens parameters. This avoids having to enter the values manually.

5 Click Build Selected.

6 Click the Orthographic Projection button in the Graphics toolbar.

7 In the Graphics window toolbar, click next to Go to Default View, then choose 
Go to ZY View. Switch the view to orthographic, and orientate the view to place the 
optical axis (z-axis) horizontal and the y-axis vertical.

Create cumulative selections defining the materials, clear apertures, obstructions and 
image plane that can be used within the final ray trace.

Cumulative Selections
In the Geometry toolbar, click Selections and choose Cumulative Selections.

Lens Material 1
1 Right-click Cumulative Selections and choose Cumulative Selection.

2 In the Settings window for Selection, type Lens Material 1 in the Label text field.

Lens Material 2
1 In the Model Builder window, right-click Cumulative Selections and choose 

Cumulative Selection.

2 In the Settings window for Selection, type Lens Material 2 in the Label text field. In 
the same manner, add selections for Lens Material 3, Clear Apertures, 
Obstructions, Aperture Stop, and Image Plane.
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Lens 1 (pi1)
Now, apply these selections.

1 In the Model Builder window, under Component 1 (comp1)>

Double Gauss Lens Geometry Sequence click Lens 1 (pi1).

2 In the Settings window for Part Instance, click to expand the Domain Selections section.

3 In the table, enter the following settings:

4 Click to expand the Boundary Selections section. In the table, enter the following 
settings:

Lens 2
Continue constructing the lens. Add the second lens element.

1 In the Geometry toolbar, click Parts and choose Spherical Lens 3D.

2 In the Settings window for Part Instance, type Lens 2 in the Label text field.

3 Locate the Input Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
double_gauss_lens_geom_sequence_lens2.txt.

Each lens element can be positioned in the geometry by referencing it to an existing 
work plane. For this example, use a work plane that is defined by the intersection of a 
plane tangential to the optical axis with the vertex on the exit surface of the preceding 
lens element.

5 Locate the Position and Orientation of Output section. Find the 
Coordinate system to match subsection. From the Take work plane from list, choose 
Lens 1 (pi1).

6 From the Work plane list, choose Surface 2 vertex intersection (wp2).

Name Keep Physics Contribute to

All √ Lens Material 1

Name Keep Physics Contribute to

Exterior √ Lens Exteriors

Surface 1 √ Clear Apertures

Surface 2 √ Clear Apertures

Surface 1 obstruction √ Obstructions

Surface 2 obstruction √ Obstructions

Edges √ Obstructions
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7 Find the Displacement subsection. In the zw text field, type T_1. This is the distance 
along the optical axis between the vertex on the exit surface of lens 1 and the vertex on 
the entrance surface of lens 2.

8 Locate the Domain Selections section. In the table, enter the following settings:

9 Locate the Boundary Selections section. In the table, enter the following settings:

Lens 3
The remaining lenses are similarly defined. Next, add the third lens element.

1 In the Geometry toolbar, click Parts and choose Spherical Lens 3D.

2 In the Settings window for Part Instance, type Lens 3 in the Label text field.

3 Locate the Input Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
double_gauss_lens_geom_sequence_lens3.txt.

5 Locate the Position and Orientation of Output section. Find the 
Coordinate system to match subsection. From the Take work plane from list, choose 
Lens 2 (pi2).

6 From the Work plane list, choose Surface 2 vertex intersection (wp2).

7 Find the Displacement subsection. In the zw text field, type T_2.

8 Locate the Domain Selections section. In the table, enter the following settings:

Name Keep Physics Contribute to

All √ Lens Material 2

Name Keep Physics Contribute to

Exterior √ Lens Exteriors

Surface 1 √ Clear Apertures

Surface 2 √ Clear Apertures

Surface 1 obstruction √ Obstructions

Surface 2 obstruction √ Obstructions

Edges √ Obstructions

Name Keep Physics Contribute to

All √ Lens Material 3
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9 Locate the Boundary Selections section. In the table, enter the following settings:

P A R T  L I B R A R I E S

Next, insert the aperture stop.

1 In the Geometry toolbar, click Parts and choose Part Libraries.

2 In the Part Libraries window, select Ray Optics Module>3D>Apertures and Obstructions>

circular_planar_annulus in the tree.

3 Click Add to Geometry. This part is also used to define the image plane and 
additional obstructions.

D O U B L E  G A U S S  L E N S  G E O M E T R Y  S E Q U E N C E

Stop
1 In the Model Builder window, under Component 1 (comp1)>

Double Gauss Lens Geometry Sequence click Circular Planar Annulus 1 (pi4).

2 In the Settings window for Part Instance, type Stop in the Label text field.

3 Locate the Input Parameters section. In the table, enter the following settings:

4 Locate the Position and Orientation of Output section. Find the 
Coordinate system to match subsection. From the Take work plane from list, choose 
Lens 3 (pi3).

5 From the Work plane list, choose Surface 2 vertex intersection (wp2).

Name Keep Physics Contribute to

Exterior √ Lens Exteriors

Surface 1 √ Clear Apertures

Surface 2 √ Clear Apertures

Surface 1 obstruction √ Obstructions

Surface 2 obstruction √ Obstructions

Edges √ Obstructions

Name Expression Value Description

d0 d0_S 60 mm Diameter, outer

d1 d1_S 37.2 mm Diameter, inner

nix 0 0 Local optical axis, x-component

niy 0 0 Local optical axis, y-component

niz 1 1 Local optical axis, z-component
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6 Find the Displacement subsection. In the zw text field, type T_3+Tc_4.

7 Locate the Boundary Selections section. In the table, enter the following settings:

Lens 4
Next, add the fourth lens element.

1 In the Geometry toolbar, click Parts and choose Spherical Lens 3D.

2 In the Settings window for Part Instance, type Lens 4 in the Label text field.

3 Locate the Input Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
double_gauss_lens_geom_sequence_lens4.txt.

5 Locate the Position and Orientation of Output section. Find the 
Coordinate system to match subsection. From the Take work plane from list, choose 
Stop (pi4).

6 From the Work plane list, choose Surface (wp1).

7 Find the Displacement subsection. In the zw text field, type T_4.

8 Locate the Domain Selections section. In the table, enter the following settings:

9 Locate the Boundary Selections section. In the table, enter the following settings:

Lens 5
Next, add the fifth lens element.

1 In the Geometry toolbar, click Parts and choose Spherical Lens 3D.

Name Keep Physics Contribute to

All √ Aperture Stop

Name Keep Physics Contribute to

All √ Lens Material 3

Name Keep Physics Contribute to

Exterior √ Lens Exteriors

Surface 1 √ Clear Apertures

Surface 2 √ Clear Apertures

Surface 1 obstruction √ Obstructions

Surface 2 obstruction √ Obstructions

Edges √ Obstructions
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2 In the Settings window for Part Instance, type Lens 5 in the Label text field.

3 Locate the Input Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
double_gauss_lens_geom_sequence_lens5.txt.

5 Locate the Position and Orientation of Output section. Find the 
Coordinate system to match subsection. From the Take work plane from list, choose 
Lens 4 (pi5).

6 From the Work plane list, choose Surface 2 vertex intersection (wp2).

7 Find the Displacement subsection. In the zw text field, type T_5.

8 Locate the Domain Selections section. In the table, enter the following settings:

9 Locate the Boundary Selections section. In the table, enter the following settings:

Lens 6
Add the final (sixth) lens element.

1 In the Geometry toolbar, click Parts and choose Spherical Lens 3D.

2 In the Settings window for Part Instance, type Lens 6 in the Label text field.

3 Locate the Input Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
double_gauss_lens_geom_sequence_lens6.txt.

5 Locate the Position and Orientation of Output section. Find the 
Coordinate system to match subsection. From the Take work plane from list, choose 
Lens 5 (pi6).

6 From the Work plane list, choose Surface 2 vertex intersection (wp2).

Name Keep Physics Contribute to

All √ Lens Material 1

Name Keep Physics Contribute to

Exterior √ Lens Exteriors

Surface 1 √ Clear Apertures

Surface 2 √ Clear Apertures

Surface 1 obstruction √ Obstructions

Surface 2 obstruction √ Obstructions

Edges √ Obstructions
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7 Find the Displacement subsection. In the zw text field, type T_6.

8 Locate the Domain Selections section. In the table, enter the following settings:

9 Locate the Boundary Selections section. In the table, enter the following settings:

Image
Now, add a surface to define the image plane.

1 In the Geometry toolbar, click Parts and choose Circular Planar Annulus.

2 In the Settings window for Part Instance, type Image in the Label text field.

3 Locate the Input Parameters section. In the table, enter the following settings:

4 Locate the Position and Orientation of Output section. Find the 
Coordinate system to match subsection. From the Take work plane from list, choose 
Lens 6 (pi7).

5 From the Work plane list, choose Surface 2 vertex intersection (wp2).

6 Find the Displacement subsection. In the zw text field, type T_7.

Name Keep Physics Contribute to

All √ Lens Material 2

Name Keep Physics Contribute to

Exterior √ Lens Exteriors

Surface 1 √ Clear Apertures

Surface 2 √ Clear Apertures

Surface 1 obstruction √ Obstructions

Surface 2 obstruction √ Obstructions

Edges √ Obstructions

Name Expression Value Description

d0 d0_D 85 mm Diameter, outer

d1 0 0 m Diameter, inner

nix 0 0 Local optical axis, x-component

niy 0 0 Local optical axis, y-component

niz 1 1 Local optical axis, z-component
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7 Locate the Boundary Selections section. In the table, enter the following settings:

8 Click Build All Objects.

9 Click the Zoom Extents button in the Graphics toolbar. Compare the resulting 
image to Figure 2.

Name Keep Physics Contribute to

All √ Image Plane
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