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Introduction

The propagation and response of acoustic signals in pipe systems is used to detect leaks and 
deformations in the pipes. This is, for example, relevant in the oil and gas industry or in 
water delivery piping systems. This model uses the pipe acoustics interfaces to model the 
propagation of acoustic waves in a pipe system using a 1D model. The 1D model is 
coupled to a detailed 3D model of a junction and a bend. In the 3D domains, a pressure 
acoustics interface is used. The 3D domains could represent any complex geometry like 
valves, reservoirs, or pipe expansions where the 1D model is not valid. The tutorial sets up 
both a transient and a frequency-domain version of the model. A Pressure Acoustics, 
Boundary Mode interface is used to compute and analyze the propagating modes in the 
pipe cross section, as only plane propagating modes are supported in the 1D pipe 
formulation.

Note: The model requires the Acoustics Module.

Model Definition

Pipe acoustics is used to model the propagation and response of acoustic signals in the long 
pipe segments using a 1D model. This interface is only valid for the analysis of plane wave 
modes. The 3D structures are modeled using pressure acoustics. To ensure correct 
coupling to the 1D model, the Acoustics-Pipe Acoustics Connection multiphysics 
coupling is used. The coupling requires a straight pipe segment connected to the 3D 
structure and it is only valid when the background fluid velocity is zero.

For a given pipe system in quiescent conditions (u0 = 0), constant background pressure, 
and completely rigid walls, the governing equations of the pipe system become:

 (1)

 (2)

where ρ is the fluid density, A is the cross-sectional area of the pipe, u is the area-averaged 
acoustic velocity, which is defined in the tangential direction u = uet, where et is the 
tangential vector, ∇t is the tangential derivative, τw is the tangential wall drag force, Z is 
the inner perimeter of the pipe, F is a volume force applied to the pipe, and c is the 
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effective speed of sound in the pipe (in a rigid pipe this has the same value as the isentropic 
bulk speed of sound). 

The pipe acoustics domain (pipe domain) is connected to the pressure acoustics domain 
(acoustic domain) through the Acoustics-Pipe Acoustics Connection multiphysics 
coupling. This coupling guarantees continuity of pressure and velocity between both 
domains through the equations:

 (3)

 (4)

Here, ppipe is the pipe pressure at the connection point, A is the total area of the connected 
acoustic boundary, pt is the total pressure in the acoustic domain and S is the connected 
acoustic boundary, n is the vector normal to the boundary, and upipe is the pipe velocity 
at the connection point. The possible dipole domain source, qd, is zero in this model.

The geometry of the pipe system, including both 1D and 3D domains, is shown in 
Figure 1.

Figure 1: Model geometry.
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The model has two separated 3D domains, shown in Figure 2, which will be included in 
the model using the Pressure Acoustics interface.

Figure 2: T-junction and bend.

The pipe ends, not connected to the Pressure Acoustics domains, have an end impedance 
condition of an infinite pipe, allowing the acoustic waves to exit the system. In our case, 
this simply corresponds to the characteristic specific impedance.

 (5)

The points where this impedance condition is imposed can be seen in Figure 3.

Zend cρ=
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Figure 3: The pipe end impedance conditions are applied to the open ends of the pipe system.

The tutorial sets up both a transient and a frequency domain version of the model. Under 
the transient analysis, a wave train is created through the imposition of a volume force on 
one end of the pipe system. The force is defined through an analytical function created 
under the Definitions node. Figure 4 shows a plot of the analytical function used in the 
model to generate the wave train.
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Figure 4: Imposed volume force as direct output of the plot functionality when defining an 
analytic function.

At last, a Pressure Acoustics, Boundary Mode interface is used to solve for the propagation 
modes on the pipe cross section at the driving frequency to check if higher order modes 
can propagate. This is easy and quick to check by solving an eigenvalue problem. The 
eigenvalue solver computes a specified number of solutions {pj, λj} to the equation

 (6)

with

 (7)

where pt is the total pressure, keq is the in-plane wave number, ω is the angular frequency, 
kn is the out-of-plane wave number, and λ = −ikn is the eigenvalue.
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Results and Discussion

Figure 5 shows the transient pressure distribution in the pipe system at various times. The 
figure shows the continuity in the pressure at the Acoustics-Pipe Acoustics Connection 
points.

Figure 5: Evolution of the Pressure in the pipe system at various times.

The initial wave train travels through the pipe system producing reflections as the wave 
finds discontinuities at the T-junction and the bend. Figure 6 shows the pressure at 
different points of the pipe system. The reflected wave from the T-junction can be 
observed in Point A after 0.09 s and the reflected wave coming from the pipe bend can be 
7 |  A C O U S T I C S  O F  A  P I P E  S Y S T E M  W I T H  3 D  B E N D  A N D  J U N C T I O N



seen after 0.13 s. By updating the parameter rbend, that controls the bending radius of 
the bend, to 160 cm this reflection can be greatly reduced.

Figure 6: Pressure at three points in the pipe system (Point B and Point C are offset on the y-
axis for clarity).

This model can be updated to consider the compressibility of the pipe section based on 
the elastic modulus and thickness of the pipe wall. Analyzing the pipe system response in 
the time domain allows us to easily identify reflections or changes in the acoustic response 
caused by changes in pipe section or wall thickness and these changes can be linked to 
corrosion or leaks in the pipe system.

The problem can be solved in the frequency domain; the results will be equivalent to 
exciting the system in the time domain with a sine wave until you reach steady state. By 
solving the model in the frequency domain, a quick and inexpensive computation, insight 
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into the pressure distribution for a given input can be obtained. Figure 7 shows the 
response of the pipe system under an excitation with a frequency of 120 Hz.

Figure 7: Pressure distribution in the frequency domain at 120 Hz.

The Pressure Acoustics, Boundary Mode interface solves for the propagating and 
nonpropagating modes on the pipe cross section at the driving frequency to check if higher 
order modes propagate at the given frequency or if it just the plane wave component. A 
mode with a real wave number will propagate, while a mode with imaginary wave number 
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will not be able to propagate. Figure 8 shows the pressure distribution for the mode (2,0) 
which cannot propagate at 120 Hz.

Figure 8: Pressure distribution for mode (2,0), which cannot propagate at 120 Hz.

This tutorial presents an introduction to the modeling of pipe systems and a selection of 
the different analysis techniques that can be applied to them. Further details like the 
compressibility of the pipes or more complex 3D domains can be added to increase the 
fidelity of the model. 

Application Library path: Pipe_Flow_Module/Pipe_Acoustics/
acoustics_pipe_system

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 Click Done.

G E O M E T R Y  1

With this, we import a fully parametric sequence that defines the geometry of the model. 
The parameters used to define the geometry can be modified and updated at any point of 
the tutorial. Detailed instructions for setting up the geometry are found at the appendix 
at the end of the instructions.

1 In the Geometry toolbar, click Insert Sequence and choose Insert Sequence.

2 Browse to the model’s Application Libraries folder and double-click the file 
acoustics_pipe_system_geom_sequence.mph.

3 In the Geometry toolbar, click Build All.

The image should look like that in Figure 1.

G L O B A L  D E F I N I T I O N S

Geometry
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, type Geometry in the Label text field.

This group includes all the parameters that define the geometry of the model.

Model Parameters
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Model Parameters in the Label text field.

3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
acoustics_pipe_system_parameters.txt.

This group includes all the parameters that define the model like material properties, 
frequencies of interest, and the total time of the analysis.

D E F I N I T I O N S

Rectangle 1 (rect1)
1 In the Model Builder window, expand the Component 1 (comp1)>Definitions node.

2 Right-click Definitions and choose Functions>Rectangle.

3 In the Settings window for Rectangle, locate the Parameters section.
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4 In the Lower limit text field, type 0.5*T0.

5 In the Upper limit text field, type 3*T0.

6 Click to expand the Smoothing section. In the Size of transition zone text field, type T0.

Volume force
1 In the Home toolbar, click Functions and choose Local>Analytic.

2 In the Settings window for Analytic, type Volume force in the Label text field.

3 In the Function name text field, type volforc.

4 Locate the Definition section. In the Expression text field, type rect1(t[1/s])*sin(2*
pi*f0*t).

5 In the Arguments text field, type t.

6 Locate the Units section. In the table, enter the following settings:

7 In the Function text field, type N/m^3.

8 Locate the Plot Parameters section. In the table, enter the following settings:

9 Click Plot.

The image should look like that in Figure 4.

1D Pipes
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type 1D Pipes in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Edge.

4 Select Edges 1, 2, 20, 37, and 60 only.

Pipe Ends
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Pipe Ends in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Point.

4 Select Points 1, 11, and 38 only.

Argument Unit

t s

Argument Lower limit Upper limit Unit

t 0 3.5*T0 s
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A D D  M A T E R I A L

1 In the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-in>Water, liquid.

4 Click Add to Component in the window toolbar three times.

5 In the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Water, liquid 1 (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Water,

liquid 1 (mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Edge.

4 From the Selection list, choose 1D Pipes.

Water, liquid 2 (mat3)
1 In the Model Builder window, click Water, liquid 2 (mat3).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 1 only.

A D D  P H Y S I C S

1 In the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Acoustics>Pipe Acoustics>Pipe Acoustics, Transient (patd).

4 Click Add to Component 1 in the window toolbar.

5 In the tree, select Acoustics>Pressure Acoustics>Pressure Acoustics, Transient (actd).

6 Click Add to Component 1 in the window toolbar.

7 In the tree, select Acoustics>Pressure Acoustics>Pressure Acoustics,

Boundary Mode (acbm).

8 Click Add to Component 1 in the window toolbar.

9 In the tree, select Acoustics>Pipe Acoustics>Pipe Acoustics, Frequency Domain (pafd).

10 Click Add to Component 1 in the window toolbar.
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11 In the tree, select Acoustics>Pressure Acoustics>Pressure Acoustics,

Frequency Domain (acpr).

12 Click Add to Component 1 in the window toolbar.

13 In the Home toolbar, click Add Physics to close the Add Physics window.

P I P E  A C O U S T I C S ,  T R A N S I E N T  ( P A T D )

1 In the Model Builder window, under Component 1 (comp1) click Pipe Acoustics,

Transient (patd).

2 In the Settings window for Pipe Acoustics, Transient, locate the Edge Selection section.

3 From the Selection list, choose 1D Pipes.

4 Locate the Transient Solver Settings section. In the fmax,sol text field, type f0.

Pipe Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Pipe Acoustics,

Transient (patd) click Pipe Properties 1.

2 In the Settings window for Pipe Properties, locate the Pipe Shape section.

3 From the list, choose Circular.

4 In the di text field, type Di.

Pipe Properties 2
1 In the Physics toolbar, click Edges and choose Pipe Properties.

2 Select Edge 20 only.

3 In the Settings window for Pipe Properties, locate the Pipe Shape section.

4 From the list, choose Circular.

5 In the di text field, type Di*2/3.

End Impedance 1
1 In the Physics toolbar, click Points and choose End Impedance.

2 In the Settings window for End Impedance, locate the Point Selection section.

3 From the Selection list, choose Pipe Ends.

Volume Force 1
1 In the Physics toolbar, click Edges and choose Volume Force.

2 Select Edge 1 only.

3 In the Settings window for Volume Force, locate the Volume Force section.
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4 Specify the F vector as

P R E S S U R E  A C O U S T I C S ,  T R A N S I E N T  ( A C T D )

1 In the Model Builder window, under Component 1 (comp1) click Pressure Acoustics,

Transient (actd).

2 In the Settings window for Pressure Acoustics, Transient, locate the 
Transient Solver and Mesh Settings section.

3 In the fmax text field, type f0.

P R E S S U R E  A C O U S T I C S ,  B O U N D A R Y  M O D E  ( A C B M )

1 In the Model Builder window, under Component 1 (comp1) click Pressure Acoustics,

Boundary Mode (acbm).

2 In the Settings window for Pressure Acoustics, Boundary Mode, locate the 
Boundary Selection section.

3 Click Clear Selection.

4 Select Boundary 1 only.

P I P E  A C O U S T I C S ,  F R E Q U E N C Y  D O M A I N  ( P A F D )

1 In the Model Builder window, under Component 1 (comp1) click Pipe Acoustics,

Frequency Domain (pafd).

2 In the Settings window for Pipe Acoustics, Frequency Domain, locate the Edge Selection 
section.

3 From the Selection list, choose 1D Pipes.

Pipe Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Pipe Acoustics,

Frequency Domain (pafd) click Pipe Properties 1.

2 In the Settings window for Pipe Properties, locate the Pipe Shape section.

3 From the list, choose Circular.

4 In the di text field, type Di.

Pipe Properties 2
1 In the Physics toolbar, click Edges and choose Pipe Properties.

volforc(t) x

0 y

0 z
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2 Select Edge 20 only.

3 In the Settings window for Pipe Properties, locate the Pipe Shape section.

4 From the list, choose Circular.

5 In the di text field, type Di*2/3.

End Impedance 1
1 In the Physics toolbar, click Points and choose End Impedance.

2 In the Settings window for End Impedance, locate the Point Selection section.

3 From the Selection list, choose Pipe Ends.

Volume Force 1
1 In the Physics toolbar, click Edges and choose Volume Force.

2 Select Edge 1 only.

3 In the Settings window for Volume Force, locate the Volume Force section.

4 Specify the F vector as

M U L T I P H Y S I C S

Acoustic-Pipe Acoustic Connection 1 (apc1)
In the Physics toolbar, click Multiphysics Couplings and choose Global>Acoustic-

Pipe Acoustic Connection.

Acoustic-Pipe Acoustic Connection 2 (apc2)
1 In the Physics toolbar, click Multiphysics Couplings and choose Global>Acoustic-

Pipe Acoustic Connection.

2 In the Settings window for Acoustic-Pipe Acoustic Connection, locate the 
Coupled Interfaces section.

3 From the Acoustics list, choose Pressure Acoustics, Frequency Domain (acpr).

4 From the Pipe acoustics list, choose Pipe Acoustics, Frequency Domain (pafd).

M E S H  1

In this model, the mesh is set up manually. Proceed by directly adding the desired mesh 
component.

1 x

0 y

0 z
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Free Tetrahedral 1
In the Mesh toolbar, click Free Tetrahedral.

Size
1 In the Model Builder window, click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Maximum element size text field, type 
min(lam0/12,Di/2).

5 In the Minimum element size text field, type min(lam0/24,Di/6).

6 Click Build Selected.

Edge 1
1 In the Mesh toolbar, click Boundary and choose Edge.

2 In the Settings window for Edge, locate the Edge Selection section.

3 From the Selection list, choose 1D Pipes.

Free Triangular 1
1 In the Mesh toolbar, click Boundary and choose Free Triangular.

2 Select Boundary 1 only.

Size 1
1 Right-click Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section.

5 Select the Maximum element size check box. In the associated text field, type Di/12.

6 Select the Minimum element size check box. In the associated text field, type Di/12.

7 Click Build All.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Physics interfaces in study subsection. In the table, clear the Solve check boxes 
for Pressure Acoustics, Boundary Mode (acbm), Pipe Acoustics, Frequency Domain (pafd), 
and Pressure Acoustics, Frequency Domain (acpr).
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4 Find the Studies subsection. In the Select Study tree, select General Studies>

Time Dependent.

5 Find the Multiphysics couplings in study subsection. In the table, clear the Solve check 
box for Acoustic-Pipe Acoustic Connection 2 (apc2).

6 Click Add Study in the window toolbar.

7 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  1

Step 1: Time Dependent
1 In the Settings window for Time Dependent, locate the Study Settings section.

2 In the Output times text field, type range(0,T0/24,Tend).

3 In the Model Builder window, click Study 1.

4 In the Settings window for Study, locate the Study Settings section.

5 Clear the Generate default plots check box.

6 In the Label text field, type Study 1 - Pipe System Transient.

7 In the Home toolbar, click Compute.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Physics interfaces in study subsection. In the table, clear the Solve check boxes 
for Pipe Acoustics, Transient (patd), Pressure Acoustics, Transient (actd), Pipe Acoustics,

Frequency Domain (pafd), and Pressure Acoustics, Frequency Domain (acpr).

4 Find the Multiphysics couplings in study subsection. In the table, clear the Solve check 
boxes for Acoustic-Pipe Acoustic Connection 1 (apc1) and Acoustic-

Pipe Acoustic Connection 2 (apc2).

5 Find the Studies subsection. In the Select Study tree, select 
Preset Studies for Selected Physics Interfaces>Mode Analysis.

6 Click Add Study in the window toolbar.

S T U D Y  2  -  M O D E  A N A L Y S I S  C U T  O N / O F F

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study 2 - Mode Analysis Cut on/off in the 
Label text field.
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3 Locate the Study Settings section. Clear the Generate default plots check box.

Step 1: Mode Analysis
1 In the Model Builder window, under Study 2 - Mode Analysis Cut on/off click 

Step 1: Mode Analysis.

2 In the Settings window for Mode Analysis, locate the Study Settings section.

3 In the Mode analysis frequency text field, type f0.

4 Select the Desired number of modes check box. In the associated text field, type 10.

5 Select the Search for modes around check box.

6 In the Home toolbar, click Compute.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Physics interfaces in study subsection. In the table, clear the Solve check boxes 
for Pipe Acoustics, Transient (patd), Pressure Acoustics, Transient (actd), and 
Pressure Acoustics, Boundary Mode (acbm).

3 Find the Multiphysics couplings in study subsection. In the table, clear the Solve check 
box for Acoustic-Pipe Acoustic Connection 1 (apc1).

4 Find the Studies subsection. In the Select Study tree, select General Studies>

Frequency Domain.

5 Click Add Study in the window toolbar.

6 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  3  -  P I P E  S Y S T E M  F R E Q U E N C Y  D O M A I N

1 In the Model Builder window, click Study 3.

2 In the Settings window for Study, type Study 3 - Pipe System Frequency Domain 
in the Label text field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

Step 1: Frequency Domain
1 In the Model Builder window, under Study 3 - Pipe System Frequency Domain click 

Step 1: Frequency Domain.

2 In the Settings window for Frequency Domain, locate the Study Settings section.

3 In the Frequencies text field, type f0.

4 In the Home toolbar, click Compute.
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R E S U L T S

Surface 1
1 In the Model Builder window, expand the Results node.

2 Right-click Results>Datasets and choose Surface.

3 In the Settings window for Surface, locate the Data section.

4 From the Dataset list, choose Study 2 - Mode Analysis Cut on/off/Solution 2 (sol2).

5 Locate the Selection section. Click Paste Selection.

6 In the Paste Selection dialog box, type 1 in the Selection text field.

7 Click OK.

Acoustic Pressure (patd)
1 In the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Acoustic Pressure (patd) in the 
Label text field.

3 Locate the Data section. From the Time (s) list, choose 0.025.

4 Click to expand the Title section. From the Title type list, choose Manual.

5 In the Title text area, type Pressure (Pa).

6 In the Parameter indicator text field, type Time= eval(t,s) s.

7 Locate the Color Legend section. Select the Show maximum and minimum values check 
box.

Line 1
1 Right-click Acoustic Pressure (patd) and choose Line.

2 In the Settings window for Line, click to expand the Range section.

3 Select the Manual color range check box.

4 In the Minimum text field, type -0.005.

5 In the Maximum text field, type 0.005.

6 Locate the Coloring and Style section. From the Line type list, choose Tube.

7 In the Tube radius expression text field, type 0.5*patd.dh.

8 Select the Radius scale factor check box.

9 Click Change Color Table.

10 In the Color Table dialog box, select Wave>Wave in the tree.

11 Click OK.
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12 In the Settings window for Line, locate the Coloring and Style section.

13 From the Scale list, choose Linear symmetric.

Deformation 1
1 Right-click Line 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Expression section.

3 In the X-component text field, type 0.

4 In the Y-component text field, type 0.

5 In the Z-component text field, type p.

6 Select the Description check box. In the associated text field, type 20.

Surface 1
1 In the Model Builder window, right-click Acoustic Pressure (patd) and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type p2.

4 Click to expand the Inherit Style section. From the Plot list, choose Line 1.

Deformation 1
1 Right-click Surface 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Expression section.

3 In the X-component text field, type 0.

4 In the Y-component text field, type 0.

5 In the Z-component text field, type p2.

Table Annotation 1
1 In the Model Builder window, right-click Acoustic Pressure (patd) and choose 

Table Annotation.

2 In the Settings window for Table Annotation, locate the Data section.

3 From the Source list, choose Local table.

4 In the table, enter the following settings:

x-coordinate y-coordinate z-coordinate Annotation

-L1+Lj/2 0 0 Point A

-Lj/2 -L2 0 Point B

L3 -L4 0 Point C
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5 In the Acoustic Pressure (patd) toolbar, click Plot.

The image should look like that in Figure 5. The image can be animated to show the 
propagation of the pressure and its subsequent reflections.

Acoustic Pressure in Points
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Acoustic Pressure in Points in the 
Label text field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type Pressure at various points (Pa).

5 Locate the Plot Settings section.

6 Select the x-axis label check box. In the associated text field, type Time (s).

7 Select the y-axis label check box. In the associated text field, type Pressure (Pa).

8 Locate the Legend section. From the Position list, choose Upper left.

Point A
1 Right-click Acoustic Pressure in Points and choose Point Graph.

2 In the Settings window for Point Graph, type Point A in the Label text field.

3 Select Point 2 only.

4 Click to expand the Legends section. Select the Show legends check box.

5 From the Legends list, choose Manual.

6 In the table, enter the following settings:

Point B
1 In the Model Builder window, right-click Acoustic Pressure in Points and choose 

Point Graph.

2 In the Settings window for Point Graph, type Point B in the Label text field.

3 Select Point 11 only.

4 Locate the y-Axis Data section. In the Expression text field, type p+1[Pa].

5 Locate the Legends section. Select the Show legends check box.

6 From the Legends list, choose Manual.

Legends

Point A
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7 In the table, enter the following settings:

Point C
1 Right-click Acoustic Pressure in Points and choose Point Graph.

2 In the Settings window for Point Graph, type Point C in the Label text field.

3 Select Point 38 only.

4 Locate the y-Axis Data section. In the Expression text field, type p+2[Pa].

5 Locate the Legends section. Select the Show legends check box.

6 From the Legends list, choose Manual.

7 In the table, enter the following settings:

8 In the Acoustic Pressure in Points toolbar, click Plot.

The image should look like that in Figure 6.

Mode Analysis Pressure (acbm)
1 In the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Mode Analysis Pressure (acbm) in 
the Label text field.

Surface 1
1 Right-click Mode Analysis Pressure (acbm) and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type p3.

4 Locate the Coloring and Style section. Click Change Color Table.

5 In the Color Table dialog box, select Wave>Wave in the tree.

6 Click OK.

7 In the Settings window for Surface, locate the Coloring and Style section.

8 From the Scale list, choose Linear symmetric.

The image should look like that in Figure 8.

9 In the Mode Analysis Pressure (acbm) toolbar, click Plot.

Legends

Point B (offset by 1 Pa)

Legends

Point C (offset by 2 Pa)
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Acoustic Pressure (pafd)
1 In the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Acoustic Pressure (pafd) in the 
Label text field.

3 Locate the Data section. From the Dataset list, choose Study 3 -

Pipe System Frequency Domain/Solution 3 (sol3).

4 Locate the Title section. From the Title type list, choose Manual.

5 In the Title text area, type Pressure (Pa).

6 In the Parameter indicator text field, type freq =eval(freq,Hz) Hz.

Line 1
1 Right-click Acoustic Pressure (pafd) and choose Line.

2 In the Settings window for Line, locate the Expression section.

3 In the Expression text field, type p4.

4 Locate the Coloring and Style section. From the Line type list, choose Tube.

5 In the Tube radius expression text field, type 0.5*pafd.dh.

6 Select the Radius scale factor check box.

7 Click Change Color Table.

8 In the Color Table dialog box, select Wave>Wave in the tree.

9 Click OK.

10 In the Settings window for Line, locate the Coloring and Style section.

11 From the Scale list, choose Linear symmetric.

Deformation 1
1 Right-click Line 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Expression section.

3 In the X-component text field, type 0.

4 In the Y-component text field, type 0.

5 In the Z-component text field, type p4.

6 Locate the Scale section.

7 Select the Scale factor check box. In the associated text field, type 2.

Surface 1
1 In the Model Builder window, right-click Acoustic Pressure (pafd) and choose Surface.

2 In the Settings window for Surface, locate the Expression section.
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3 In the Expression text field, type p5.

4 Locate the Inherit Style section. From the Plot list, choose Line 1.

Deformation 1
1 Right-click Surface 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Expression section.

3 In the X-component text field, type 0.

4 In the Y-component text field, type 0.

5 In the Z-component text field, type p5.

6 In the Acoustic Pressure (pafd) toolbar, click Plot.

The image should look like that in Figure 7.

Appendix — Geometry Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters geom sequence
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
acoustics_pipe_system_geom_sequence_parameters.txt.

5 In the Label text field, type Parameters geom sequence.

G E O M E T R Y  1

Line Segment 1 (ls1)
1 In the Model Builder window, expand the Component 1 (comp1)>Geometry 1 node.
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2 Right-click Geometry 1 and choose More Primitives>Line Segment.

3 In the Settings window for Line Segment, locate the Starting Point section.

4 From the Specify list, choose Coordinates.

5 In the x text field, type -Lj.

6 Locate the Endpoint section. From the Specify list, choose Coordinates.

7 In the x text field, type -L1+Lj/2.

8 Click Build Selected.

Line Segment 2 (ls2)
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 In the x text field, type -L1+Lj/2.

5 Locate the Endpoint section. From the Specify list, choose Coordinates.

6 In the x text field, type -L1.

7 Click Build Selected.

Cylinder 1 (cyl1)
1 In the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type Di/2.

4 In the Height text field, type Lj.

5 Locate the Position section. In the x text field, type -Lj.

6 Locate the Axis section. From the Axis type list, choose x-axis.

7 Click Build Selected.

Cylinder 2 (cyl2)
1 In the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type Di/3.

4 In the Height text field, type Lj/2.

5 Locate the Position section. In the x text field, type -Lj/2.

6 In the y text field, type -Lj/2.

7 Locate the Axis section. From the Axis type list, choose y-axis.
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8 Click Build Selected.

Union 1 (uni1)
1 In the Geometry toolbar, click Booleans and Partitions and choose Union.

2 Select the objects cyl1 and cyl2 only.

3 In the Settings window for Union, click Build Selected.

Line Segment 3 (ls3)
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 In the x text field, type -Lj/2.

5 In the y text field, type -Lj/2.

6 Locate the Endpoint section. From the Specify list, choose Coordinates.

7 In the x text field, type -Lj/2.

8 In the y text field, type -L2.

9 Click Build Selected.

Line Segment 4 (ls4)
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 Locate the Endpoint section. From the Specify list, choose Coordinates.

5 In the x text field, type L3-Lj/2.

6 Click Build Selected.

Cylinder 3 (cyl3)
1 In the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type Di/2.

4 In the Height text field, type Lj/2-rbend-Di/2.

5 Locate the Position section. In the x text field, type L3-Lj/2.

6 Locate the Axis section. From the Axis type list, choose x-axis.

7 Click Build Selected.

8 Click the Zoom Extents button in the Graphics toolbar.
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Revolve 1 (rev1)
1 In the Geometry toolbar, click Revolve.

2 On the object cyl3, select Boundary 4 only.

3 In the Settings window for Revolve, locate the Revolution Angles section.

4 Click the Angles button.

5 In the End angle text field, type 90.

6 Locate the Revolution Axis section. Find the Point on the revolution axis subsection. In 
the yw text field, type -rbend-Di/2.

7 Find the Direction of revolution axis subsection. In the xw text field, type 1.

8 In the yw text field, type 0.

9 Click Build Selected.

Cylinder 4 (cyl4)
1 In the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type Di/2.

4 In the Height text field, type Lj/2-rbend-Di/2.

5 Locate the Position section. In the x text field, type L3.

6 In the y text field, type -Lj/2.

7 Locate the Axis section. From the Axis type list, choose y-axis.

8 Click Build Selected.

Line Segment 5 (ls5)
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 In the x text field, type L3.

5 In the y text field, type -Lj/2.

6 Locate the Endpoint section. From the Specify list, choose Coordinates.

7 In the x text field, type L3.

8 In the y text field, type -L4.

9 Click Build Selected.

10 In the Geometry toolbar, click Build All.
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