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Introduction

The use of fiber composites ranges from the transportation and energy sectors to the 
consumer industry. Compared to traditional monolithic materials, fiber composites offer 
various properties suitable for tailor-made applications. Along with macroscale analyses, 
structural composites need microscale stress and failure analyses to identify the critical 
constituents in laminate structures.

Composites can be analyzed at both macro or micro scales, and either analysis has its 
benefits and limitations. Analyses at both macro and micro scales, so-called multiscale 
analyses, offer an in-depth insight into the composite structure as well as its constituents’ 
response and help to study the micromechanics of failure based on the global scale loading.

Full multiscale analysis which involves macro analysis with micro analysis at each material 
point is computationally expensive. In this example, instead of carrying out a micro-level 
analysis at each material point, the microscale analysis is performed on a few critical 
material points that are near to failure or have stress concentrations according to the 
macro-level analysis.

The continuum-based, composite-specific failure theories are useful and give satisfactory 
results in many situations. However, composite structures used in critical applications may 
demand a more accurate prediction of failure. This is possible when the mechanics-based 
failure theories are applied at micro level for individual constituents. Ref. 2 provides the 
details of micromechanical failure. 

In reality, the constituents for unidirectional composites are fiber, matrix, and the interface 
between them. For simplicity, the interface is often ignored for a micromechanical analysis. 
In this example, all three constituents are considered.

Model Definition

In this model three different types of analyses are performed:

• A micromechanical analysis to predict the homogenized material properties

• A macromechanical analysis using layerwise theory to get the global response for given 
load and boundary conditions

• A new micromechanical analysis to predict the local stress field and failure risk based on 
the average strains computed in the macro-level analysis
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M I C R O M E C H A N I C A L  A N A L Y S I S  ( M A T E R I A L  P R O P E R T I E S )

A micromechanics analysis of a unidirectional representative volume element (RVE) is 
performed to obtain its homogenized material properties. The composite layer is assumed 
to be made of graphite fibers unidirectionally embedded in epoxy resin. Between fiber and 
matrix a thin interface is assumed. A representative unit cell having a cylindrical fiber 
located at the middle of matrix is shown in Figure 1. The fiber radius is computed 
assuming a fiber volume fraction of 0.6.

Figure 1: Geometry of the unit cell with a graphite fiber, a thin interface and an epoxy matrix.

Fiber, Interface, and Matrix Properties
The layers of the laminate are made of T300 graphite fiber, DY063 epoxy resin, and a 
custom interface material. The graphite fiber is assumed to be transversely isotropic 
(modeled as orthotropic). The interface material and epoxy resin are assumed to be 
isotropic. The material properties of fiber and resin, taken from Ref. 2, are given in Table 1 
and Table 2, respectively. 

We have assumed certain material properties and the thickness for the interface material 
based on the discussion in Ref. 1. According to Ref. 1, for fiber composite materials, the 
interface, or more precisely the interfacial zone, consists of near-surface layers of fiber and 
matrix and any layer(s) of material existing between these surfaces. Very weak or very 
strong interfaces are detrimental to the overall performance of the composite. Hence, an 
interface with optimal strength is preferred to enhance the performance. With these points 

Fiber

Interface

Matrix
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in mind, this model assumes elastic properties of the interface that are not as strong as fiber 
nor as weak as matrix.

The interface material properties are based on the discussion in Ref. 1.

Thin Layer
The interface between fiber and matrix is not modeled explicitly but considered implicitly 
using the Thin Layer node in the Solid Mechanics interface. The feature has a Linear Elastic 

Material node that models the elastic behavior of the interface. The thin layer affects the 
homogenized material properties as well as the local stress distribution.

Cell Periodicity
To perform a micromechanics analysis, the Cell Periodicity node in the Solid Mechanics 
interface is used. The Cell Periodicity node is used to apply periodic boundary conditions 
on three pairs of faces of the unit cell.

To extract the homogenized elasticity matrix for a layer, the unit cell needs to be analyzed 
for six different load cases. The Average Strain periodicity type needs to be selected to 
obtain the homogenized elasticity matrix. This is automatically done with the help of the 
action buttons in the Cell Periodicity node. The Cell Periodicity node has three action 
buttons in the toolbar of the Periodicity Type section: Create Load Groups and Study, Create 

TABLE 1:  GRAPHITE FIBER MATERIAL PROPERTIES.

Material Property Value

{E1,E2,E3} {230,15,15} GPa

{G12,G23,G13} {15,7,15} GPa

{υ12,υ23,υ13} {0.2,0.2,0.2}

ρ 2260 kg/m3

TABLE 2:  EPOXY RESIN MATERIAL PROPERTIES.

Material Property Value

E 3.35 GPa

υ 0.35

ρ 1100 kg/m3

TABLE 3:  INTERFACE MATERIAL PROPERTIES.

Material Property Value

E 100 GPa

υ 0.2

ρ 1400 kg/m3
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Material by Value, and Create Material by Reference. The action button Create Load Groups 

and Study generates six different load groups and a stationary study with six load cases. The 
action button Create Material by Value generates a Global Material with an elasticity matrix 
corresponding to that of the homogenized material, where properties are in number 
format. The generated global material can be used to define the properties of individual 
layers in a composite laminate.

M A C R O M E C H A N I C A L  A N A L Y S I S  ( G L O B A L  R E S P O N S E )

Layerwise (LW) Theory
In the Layerwise theory, the degrees of freedom are the displacements (u, v, w) available 
on the reference surface (or modeled surface) as well as in the through-thickness direction. 
From a constitutive equation point of view, this theory is similar to 3D solid elasticity. The 
layerwise theory is useful for detailed modeling of thick composite laminates because it can 
capture interlaminar shear stresses. It could therefore be used to also study delamination.

Geometry and Boundary Conditions
The model represents a composite cylinder with a length of 0.5 m and a radius of 0.1 m. 
It is shown in Figure 2. The boundary conditions and loading are:

• One end of the cylinder is fixed.

• The other end has a transverse load of 50 kN, represented as a uniform boundary load 
on cross section.
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Figure 2: Geometry with boundary conditions and loading.

Figure 3: Through-thickness view of the laminated material with four layers.

Fixed endBoundary load
6 |  M I C R O M E C H A N I C S  O F  F A I L U R E :  M U L T I S C A L E  A N A L Y S I S  O F  A  C O M P O S I T E  



Stacking Sequence and Material Properties
The laminate consists of four layers of 1 mm thickness, as shown in Figure 3. The 
orientations of the layers are different; starting from the bottom of the laminate, they are 
90, 0, 90, and 0 degrees, as shown in Figure 4. The orientation of a layer is specified with 
respect to the laminate coordinate system. The material properties for each layer are given 
by the homogenized material computed in the first micromechanical analysis.

Figure 4: Stacking sequence [90/0/90/0] for the laminate showing the fiber orientation of 
each layer, from bottom to top.

Failure Criteria
Two composite-specific failure criteria, Hashin and Puck, are used to evaluate the critical 
regions in the composite cylinder for the given loading condition. These are advanced 
composite-specific criteria that account for multiaxial states of stress, and different failure 
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modes for tensile and compressive loading. The failure modes considered by these two 
criteria are summarized in Table 4.

The tensile, compressive, and shear strengths of ply are taken from Ref. 2 and are given in 
Table 5.

The Puck criterion needs additional strength properties which are tabled in Table 6.

TABLE 4:  FAILURE MODES.

Failure Criterion Failure Modes

Hashin Fiber rupture in tension and shear

Fiber buckling in compression

Matrix failure in tension and shear

Matrix failure in compression and shear

Interlaminar failure in tension

Interlaminar failure in compression

Puck Fiber rupture in tension

Fiber buckling in compression

Matrix failure in tension and in-plane shear (Interfiber

failure: Mode A)

Matrix failure in compression and in-plane shear 
(Interfiber failure: Mode B)

Matrix failure in compression and in-plane shear 
(Interfiber failure: Mode C

TABLE 5:  MATERIAL STRENGTHS.

Material strengths Value 

{σts1,σts2,σts3} {1500,50,50} MPa

{σcs1,σcs2,σcs3} {900,230,230} MPa

{σss23,σss13,σss12} {90,90,90} MPa

TABLE 6:  ADDITIONAL STRENGTH PROPERTIES

Property Variable Value

Ultimate tensile strain, 11 direction εts1 0.1

Ultimate compressive strain, 11 direction εcs1 0.08

Linear degradation stress σ1D 2000 MPa
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M I C R O M E C H A N I C A L  A N A L Y S I S  ( L O C A L  R E S P O N S E )

To determine the local response of the constituents to the global loading conditions, the 
same RVE geometry and material properties as in the first analysis are used, and the macro-
level strains from the second analysis are prescribed. The micromechanical analysis is 
performed at a few material points, chosen to be where failure or maximum stress occurs 
in the global analysis.

Failure Criteria
At a micro level, the mechanics-based failure criteria can be used as the constituents are 
monolithic. These fundamental criteria predict failure more accurately than the global level 
phenomenological criteria; see Ref. 2.

For the fiber, the Tsai–Wu orthotropic failure criterion is the most suited. For 
unidirectional composites, the fibers are longitudinally continuous and have higher 
modulus and strength in the longitudinal direction. Hence, the fibers take the longitudinal 
tensile and compressive loads. In the transverse direction, the fibers are bonded by the 
matrix, and the matrix plays an important role in transverse and shear loads. As stated in 
Ref. 2, if transverse and shear stresses from the Tsai–Wu orthotropic failure criterion are 
neglected, the failure criterion for fiber is reduced to a simple equation:

where σi is the stress component and σti and σci are the tensile and compressive strengths 
in the layer coordinate systems, respectively.

The matrix is isotropic and has different strengths in tension and compression. Theoretical 
studies and experiments show that the failure of the matrix depends on deviatoric and 
volumetric stresses. In Ref. 2 the following failure criterion is proposed for the matrix:

where σm is the von Mises stress and I1 is first invariant of the stress tensor.

The interface fails primarily because the normal and tangential tractions exceed their 
strength limits, which results in debonding. In Ref. 2, the following quadratic failure 
criterion is proposed for the interface:
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where tn and ts are normal (perpendicular to the interface boundary) and shear (tangential 
to the interface boundary) tractions, and σn and σs are the normal and shear strength, 
respectively. The angular brackets around the normal traction are Macaulay brackets, 
which return the argument if positive and zero otherwise.

The constituent’s strength properties are taken from Ref. 2 and given in Table 7.

Results and Discussion

In the micromechanics analysis, six load cases are used to evaluate the elasticity matrix. The 
distribution of the effective (von Mises) stress for four of the load cases is shown in 
Figure 5. From Figure 5 one can see how individual constituents respond to different load 
cases.

The homogenized material obtained from the first micromechanical analysis is used in the 
subsequent macromechanical analysis.

TABLE 7:  CONSTITUENT’S STRENGTH PROPERTIES

Property Variable Value

Tensile strength of fiber, 11 direction σts1 2458 MPa

Compressive strength of fiber, 11 direction σcs1 1500 MPa

Tensile strength of matrix σts 103 MPa

Compressive strength of matrix σcs 265 MPa

Interfacial normal strength of interface σns 60 MPa

Interfacial shear strength of interface σss 180 MPa
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Figure 5: von Mises stress distribution in the unit cell for four load cases.

The von Mises stress distribution in the composite cylinder obtained from the macro-level 
analysis is presented in Figure 6. Both ends of the cylinder have regions with higher 
stresses. Figure 7 shows the von Mises stress distribution in five interfaces of the laminate, 
indicating that the maximum stress occurs either in the inner or outer layers. To find the 
exact location of the maximum stress, a Surface Maximum node can be used (for details, see 
the modeling instructions). Based on this, it is clear that the maximum von Mises stress 
occurs in the outer layer of the laminate towards the fixed end. Also, the stress in the inner 
layer towards the loaded end of the cylinder is high. Both positions where the maximum 
von Mises stress occurs are used for the subsequent micromechanical analysis.

The distributions of the Hashin and Puck failure indexes in the composite cylinder are 
shown in Figure 8 and Figure 9, respectively. For the Hashin failure criterion, the 
maximum failure index is at the outer layer towards the loaded end, while for the Puck 
criterion the maximum failure index is at the second layer from inside towards the loaded 
end. The puck criterion shows higher failure index even in inner and outer layers. Hence, 
the material points from inner and outer layers are used for the subsequent 
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micromechanical analysis. Both failure criteria involve different failure modes, so it is 
important to check each individual mode’s failure indexes. Table 8 shows the maximum 
failure indexes of the individual failure mode for both failure criteria. The values indicate 
that for this composite structure, the matrix material would fail in the tension.

Figure 6: von Mises stress distribution in the composite laminate.

TABLE 8:  MAXIMUM FAILURE INDEXES OF DIFFERENT FAILURE MODES.

Failure 
Criterion

Failure Modes Failure Index

Hashin Fiber rupture in tension and shear

Fiber buckling in compression

Matrix failure in tension and shear

Matrix failure in compression and shear

Interlaminar failure in tension

Interlaminar failure in compression

0.29637

0.39070

0.53257

0.29637

6.0273·10-5

1.6742·10-5

Puck Fiber rupture in tension

Fiber buckling in compression

Matrix failure in tension and in-plane shear (Mode A)

Matrix failure in compression and in-plane shear (Mode B)

Matrix failure in compression and in-plane shear (Mode C)

0.04035

0.05044

0.72596

0.54442

0.39246
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Figure 7: von Mises stress distribution in the five interfaces of the composite laminate.

Figure 8: Hashin failure index distribution in the composite laminate.
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Figure 9: Puck failure index distribution in the composite laminate.

For the second micromechanical analysis, several material locations are selected and macro 
strains from these locations are prescribed for the RVE structure to get the local stress and 
strain fields that are eventually useful to carry out micromechanical failure analysis. 
Figure 10 shows the von Mises stress distribution in the constituents at a material point 
located in the inner layer. It shows that compared to macro stress the micro stress is very 
high. The stress distribution in the constituents at the various material locations is shown 
in Figure 11. Based on macromechanical analysis, two critical points one at inner layer and 
one at outer layer towards loaded end are chosen for subsequent micromechanical analysis. 
The micromechanical failure analysis is performed at these material points, and the results 
are presented in Figure 12 and Figure 13. Both figures show that the failure indexes are 
maximum in the matrix compared to the fiber and interface, which supports the finding 
based on the macromechanical failure analysis. The micromechanical failure indexes are 
less than one, indicating that there is no failure in the constituent materials at these critical 
points. Table 9 shows the maximum values of the failure indexes in the constituents at two 
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different material locations, which are chosen as critical locations based on the 
macromechanical analysis.

Figure 10: von Mises stress in the constituents at a particular material location of the 
composite cylinder.

TABLE 9:  MAXIMUM USER DEFINED FAILURE INDEXES IN THE CONSTITUENTS AT DIFFERENT MATERIAL LOCATIONS.

Material Locations Constituents Failure Index

First point in the inner layer Matrix

Fiber

Interface

0.54671

0.38018

4.8873·10-4

First point in the outer layer Matrix

Fiber

Interface

0.6121

0.1606

3.7685·10-5
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Figure 11: von Mises stress in the constituents at multiple material locations of the composite 
cylinder.

Figure 12: User defined failure indexes in the constituents at a particular material location 
of the composite cylinder.
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Figure 13: User defined failure indexes in the constituents at a particular material location 
of the composite cylinder.

Notes About the COMSOL Implementation

• The micromechanics analysis of a single fiber in a bulk matrix with a thin interface 
between them can be performed using the Cell Periodicity node available in the Solid 

Mechanics interface. Using this functionality, the elasticity matrix of the homogenized 
material can be computed for the given fiber, interface, and matrix properties.

• The Cell Periodicity node has three action buttons in the toolbar of the section called 
Periodicity Type: Create Load Groups and Study, Create Material by Value, and Create 

Material by Reference. The action button Create Load Groups and Study generates load 
groups and a stationary study with load cases. The action button Create Material by Value 
generates a Global Material with homogenized material properties, with material 
properties as numbers. The action button Create Material by Reference generates a Global 

Material with homogenized material properties, with material properties as variables. 
The action buttons are active depending on the choices in the Periodicity Type and 
Calculate Average Properties lists.

• The interface between fiber and matrix can be studied without creating an explicit 
geometry for the interface using the Thin Layer node available in the Solid Mechanics 
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interface. The solid approximation with a linear elastic material is used to model the thin 
interface.

• Modeling a composite laminated shell requires a 2D surface geometry, called a base 
surface, and a Layered Material node that adds an extra dimension (1D) to the base 
surface geometry in the surface normal direction. Using the Layered Material 
functionality, you can model several layers of different thicknesses, material properties, 
and fiber orientations. You can optionally specify the interface materials between the 
layers and the control mesh elements in each layer.

• The Layered Material Link and Layered Material Stack have an option to transform the 
given Layered Material into a symmetric or antisymmetric laminate. A repeated laminate 
can also be constructed using a transform option.

• To analyze the results in a composite shell, you can either create a slice plot using the 
Layered Material Slice plot for in-plane variation of a quantity, or you can create a Through 

Thickness plot for out-of-plane variation of a quantity at a point. To visualize the results 
as a 3D solid object, you can use the Layered Material dataset, which creates a virtual 3D 
solid object combining the surface geometry (2D) and the extra dimension (1D).
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Application Library path: Composite_Materials_Module/Tutorials/
composite_multiscale

Modeling Instructions (Micromechanics)

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.
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2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Done.

G L O B A L  D E F I N I T I O N S

Geometric Properties
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, type Geometric Properties in the Label text 
field.

3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
composite_multiscale_parameters.txt.

Elastic Properties
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Elastic Properties in the Label text 
field.

3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
composite_multiscale_material_properties.txt.

Strength Properties
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Strength Properties in the Label text 
field.

3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
composite_multiscale_strength_properties.txt.

5 In the Model Builder window, right-click Global Definitions and choose Geometry Parts>

Part Libraries.

P A R T  L I B R A R I E S

1 In the Part Libraries window, select COMSOL Multiphysics>

Representative Volume Elements>3D>unidirectional_fiber_square_packing in the tree.

2 Click Add to Model.
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3 In the Select Part Variant dialog box, select Specify fiber diameter in the 
Select part variant list.

4 Click OK.

C O M P O N E N T :  M I C R O M E C H A N I C S  ( M A T E R I A L  P R O P E R T I E S )

1 In the Model Builder window, click Component 1 (comp1).

2 In the Settings window for Component, type Component: Micromechanics (Material 
Properties) in the Label text field.

G E O M E T R Y  1

Unidirectional Fiber Composite, Square Packing 1 (pi1)
1 In the Geometry toolbar, click Parts and choose Unidirectional Fiber Composite,

Square Packing.

To customize the RVE geometry, enter the RVE parameters in the input parameters of 
the part.

2 In the Settings window for Part Instance, locate the Input Parameters section.

3 In the table, enter the following settings:

4 Locate the Position and Orientation of Output section. Find the Displacement subsection. 
In the xw text field, type -0.005[m].

5 In the yw text field, type -0.005[m].

6 In the zw text field, type -0.005[m].

Form Union (fin)
1 In the Model Builder window, click Form Union (fin).

2 In the Settings window for Form Union/Assembly, click Build Selected.

3 Click the Zoom Extents button in the Graphics toolbar.

In order to simplify the modeling process create explicit selections.

Name Expression Value Description

df 2*r_f 0.0087404 m Fiber diameter

wm l 0.01 m Width of RVE

dm l 0.01 m Depth of RVE

hm l 0.01 m Height of RVE
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Interface Selection
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, locate the Entities to Select section.

3 From the Geometric entity level list, choose Boundary.

4 On the object fin, select Boundaries 6–9 only.

5 In the Label text field, type Interface Selection.

Add a Thin Layer feature to model the interface between the fiber and matrix.

S O L I D  M E C H A N I C S  ( S O L I D )

Thin Layer 1
1 In the Model Builder window, under 

Component: Micromechanics (Material Properties) (comp1) right-click 
Solid Mechanics (solid) and choose Thin Layer.

2 In the Settings window for Thin Layer, locate the Boundary Selection section.

3 From the Selection list, choose Interface Selection.

4 Locate the Boundary Properties section. In the Lth text field, type th_i.

Cell Periodicity 1
1 In the Physics toolbar, click Domains and choose Cell Periodicity.

2 In the Settings window for Cell Periodicity, locate the Periodicity Type section.

3 From the list, choose Average strain.

4 From the Calculate average properties list, choose Elasticity matrix, Standard (XX, YY, ZZ,

XY, YZ, XZ).

Boundary Pair 1
1 In the Physics toolbar, click Attributes and choose Boundary Pair.

2 In the Settings window for Boundary Pair, locate the Boundary Selection section.

3 From the Selection list, choose Pair 1 (Unidirectional Fiber Composite, Square Packing 1).

Boundary Pair 2
1 Right-click Boundary Pair 1 and choose Duplicate.

2 In the Settings window for Boundary Pair, locate the Boundary Selection section.

3 From the Selection list, choose Pair 2 (Unidirectional Fiber Composite, Square Packing 1).

Boundary Pair 3
1 Right-click Boundary Pair 2 and choose Duplicate.
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2 In the Settings window for Boundary Pair, locate the Boundary Selection section.

3 From the Selection list, choose Pair 3 (Unidirectional Fiber Composite, Square Packing 1).

In the upper-right corner of the Periodicity type section, you can find three buttons: Create 

Load Groups and Study, Create Material by Reference, and Create Material by Value. When the 
Average strain option is selected for the computation of the elasticity matrix, you can 
automatically generate load groups, a study, and a material by clicking on these buttons.

Cell Periodicity 1
1 In the Model Builder window, click Cell Periodicity 1.

2 In the Settings window for Cell Periodicity, click Study and Material Generation in the 
upper-right corner of the Periodicity Type section. From the menu, choose 
Create Load Groups and Study to generate load groups and a study node.

M A T E R I A L S

Material Link 1: Matrix
1 In the Model Builder window, under 

Component: Micromechanics (Material Properties) (comp1) right-click Materials and 
choose More Materials>Material Link.

Before adding the fiber material data, set the solid model to orthotropic in the Linear 

Elastic Material node since the fiber material is is assumed to have orthotropic properties. 
The isotropic matrix material data will automatically be converted into an orthotropic 
format.

2 In the Settings window for Material Link, type Material Link 1: Matrix in the Label 
text field.

3 Select Domain 1 only.

4 Locate the Link Settings section. Click Blank Material.

G L O B A L  D E F I N I T I O N S

Material 1: Matrix
1 In the Model Builder window, under Global Definitions>Materials click Material 1 (mat1).

2 In the Settings window for Material, type Material 1: Matrix in the Label text field.
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3 Locate the Material Contents section. In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

Linear Elastic Material 1
1 In the Model Builder window, under 

Component: Micromechanics (Material Properties) (comp1)>Solid Mechanics (solid) click 
Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Material symmetry list, choose Orthotropic.

M A T E R I A L S

Material Link 2: Fiber
1 In the Model Builder window, under 

Component: Micromechanics (Material Properties) (comp1) right-click Materials and 
choose More Materials>Material Link.

2 In the Settings window for Material Link, type Material Link 2: Fiber in the Label 
text field.

3 Locate the Geometric Entity Selection section. Click Paste Selection.

4 In the Paste Selection dialog box, type 2 in the Selection text field.

5 Click OK.

6 In the Settings window for Material Link, locate the Link Settings section.

7 Click Blank Material.

G L O B A L  D E F I N I T I O N S

Material 2: Fiber
1 In the Model Builder window, under Global Definitions>Materials click Material 2 (mat2).

2 In the Settings window for Material, type Material 2: Fiber in the Label text field.

Property Variable Value Unit Property group

Young’s modulus E E_m Pa Young’s modulus and 
Poisson’s ratio

Poisson’s ratio nu nu_m 1 Young’s modulus and 
Poisson’s ratio

Density rho rho_m kg/m³ Basic
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3 Locate the Material Contents section. In the table, enter the following settings:

M A T E R I A L S

Material Link 3: Interface
1 In the Model Builder window, under 

Component: Micromechanics (Material Properties) (comp1) right-click Materials and 
choose More Materials>Material Link.

2 In the Settings window for Material Link, type Material Link 3: Interface in the 
Label text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, 
choose Boundary.

4 From the Selection list, choose Interface Selection.

5 Locate the Link Settings section. Click Blank Material.

G L O B A L  D E F I N I T I O N S

Material 3: Interface
1 In the Model Builder window, under Global Definitions>Materials click Material 3 (mat3).

2 In the Settings window for Material, type Material 3: Interface in the Label text 
field.

Property Variable Value Unit Property group

Young’s 
modulus

{Evector1, 
Evector2, 
Evector3}

{E1_f, 
E2_f, 
E2_f}

Pa Orthotropic

Poisson’s 
ratio

{nuvector1, 
nuvector2, 
nuvector3}

{nu12_f
, 
nu23_f, 
nu12_f}

1 Orthotropic

Shear 
modulus

{Gvector1, 
Gvector2, 
Gvector3}

{G12_f, 
G23_f, 
G12_f}

N/m² Orthotropic

Density rho rho_f kg/m³ Basic
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3 Locate the Material Contents section. In the table, enter the following settings:

M E S H  1

Free Triangular 1
1 In the Mesh toolbar, click Boundary and choose Free Triangular.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Pair 1, Source (Unidirectional Fiber Composite,

Square Packing 1).

4 Click Build Selected.

Copy Face 1
1 In the Mesh toolbar, click Copy and choose Copy Face.

2 In the Settings window for Copy Face, locate the Source Boundaries section.

3 From the Selection list, choose Pair 1, Source (Unidirectional Fiber Composite,

Square Packing 1).

4 Locate the Destination Boundaries section. From the Selection list, choose Pair 1,

Destination (Unidirectional Fiber Composite, Square Packing 1).

5 Click Build Selected.

Swept 1
1 In the Mesh toolbar, click Swept.

2 In the Settings window for Swept, click Build All.

S T U D Y :  M I C R O M E C H A N I C S  ( M A T E R I A L  P R O P E R T I E S )

1 In the Model Builder window, click Cell Periodicity Study.

2 In the Settings window for Study, type Study: Micromechanics (Material 
Properties) in the Label text field.

3 In the Home toolbar, click Compute.

Property Variable Value Unit Property group

Young’s modulus E E_i Pa Young’s modulus and 
Poisson’s ratio

Poisson’s ratio nu nu_i 1 Young’s modulus and 
Poisson’s ratio

Density rho rho_i kg/m³ Basic
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R E S U L T S

Stress, Unit Cell
1 In the Settings window for 3D Plot Group, type Stress, Unit Cell in the Label text 

field.

2 Click to expand the Title section. From the Title type list, choose Manual.

3 In the Title text area, type von Mises stress (MPa) .

4 Click to expand the Plot Array section. Select the Enable check box.

Volume 1
1 In the Model Builder window, expand the Stress, Unit Cell node, then click Volume 1.

2 In the Settings window for Volume, locate the Expression section.

3 From the Unit list, choose MPa.

Selection 1
1 Right-click Volume 1 and choose Selection.

2 Select Domain 1 only.

Deformation
In the Model Builder window, under Results>Stress, Unit Cell>Volume 1 right-click 
Deformation and choose Delete.

Volume 2
1 In the Model Builder window, under Results>Stress, Unit Cell right-click Volume 1 and 

choose Duplicate.

2 In the Settings window for Volume, click to expand the Inherit Style section.

3 From the Plot list, choose Volume 1.

4 Click to expand the Plot Array section. Clear the Apply to dataset edges check box.

Selection 1
1 In the Model Builder window, expand the Volume 2 node, then click Selection 1.

2 In the Settings window for Selection, locate the Selection section.

3 Click Clear Selection.

4 Select Domain 2 only.

Surface 1
In the Model Builder window, expand the Results>Stress, Thin Layer (solid) node, then click 
Surface 1.
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Surface 1
1 Drag and drop below Stress, Unit Cell

Volume 2.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 Click to expand the Inherit Style section. From the Plot list, choose Volume 1.

5 Click to expand the Plot Array section. Clear the Apply to dataset edges check box.

Deformation
1 In the Model Builder window, expand the Surface 1 node.

2 Right-click Results>Stress, Unit Cell>Surface 1>Deformation and choose Delete.

Stress, Unit Cell
In the Model Builder window, under Results click Stress, Unit Cell.

Table Annotation 1
1 In the Stress, Unit Cell toolbar, click More Plots and choose Table Annotation.

2 In the Settings window for Table Annotation, locate the Data section.

3 From the Source list, choose Local table.

4 In the table, enter the following settings:

5 Locate the Coloring and Style section. Clear the Show point check box.

Stress, Unit Cell
1 Click the Go to Default View button in the Graphics toolbar.

2 Click the Show Grid button in the Graphics toolbar.

3 In the Model Builder window, click Stress, Unit Cell.

4 In the Stress, Unit Cell toolbar, click Plot.

Stress, Thin Layer (solid)
In the Model Builder window, under Results right-click Stress, Thin Layer (solid) and choose 
Delete.

x-coordinate y-coordinate z-coordinate Annotation

-l/4 -1.2*l 0 Matrix

l -1.2*l 0 Fiber

2.2*l -1.2*l 0 Interface
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Stress, Unit Cell
In the Model Builder window, under Results right-click Stress, Unit Cell and choose Group.

Micromechanics (Material Properties)
In the Settings window for Group, type Micromechanics (Material Properties) in the 
Label text field.

Before you add a Layered Shell interface, create a homogenized material from the Cell 

Periodicity feature.

The homogenized material can be created by using either of the two action buttons in the 
Periodicity type section: Create Material by Reference or Create Material by Value. Choose 
the second action button in order to generate the material with numbers.

S O L I D  M E C H A N I C S  ( S O L I D )

Cell Periodicity 1
1 In the Model Builder window, under 

Component: Micromechanics (Material Properties) (comp1)>Solid Mechanics (solid) click 
Cell Periodicity 1.

2 In the Settings window for Cell Periodicity, click Study and Material Generation in the 
upper-right corner of the Periodicity Type section. From the menu, choose 
Create Material by Value to generate a global material node with computed elastic 
properties.

Modeling Instructions (Macromechanics: Global Response)

This section describes how to carry out macromechanics analysis of a laminated composite 
cylinder using the Layered Shell interface based on the layerwise theory.

A D D  C O M P O N E N T

In the Model Builder window, right-click the root node and choose Add Component>3D.

C O M P O N E N T :  M A C R O M E C H A N I C S  ( G L O B A L  R E S P O N S E )

In the Settings window for Component, type Component: Macromechanics (Global 
Response) in the Label text field.

G E O M E T R Y  2

Cylinder 1 (cyl1)
1 In the Geometry toolbar, click Cylinder.
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2 In the Settings window for Cylinder, locate the Object Type section.

3 From the Type list, choose Surface.

4 Locate the Size and Shape section. In the Radius text field, type rc.

5 In the Height text field, type hc.

6 Locate the Axis section. From the Axis type list, choose x-axis.

7 Click Build Selected.

8 Click the Show Grid button in the Graphics toolbar.

D E F I N I T I O N S  ( C O M P 2 )

Boundary System 2 (sys2)
1 In the Model Builder window, expand the 

Component: Macromechanics (Global Response) (comp2)>Definitions node, then click 
Boundary System 2 (sys2).

2 In the Settings window for Boundary System, locate the Settings section.

3 Find the Coordinate names subsection. From the Axis list, choose x.

A D D  P H Y S I C S

1 In the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Structural Mechanics>Layered Shell (lshell).

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Study: Micromechanics (Material Properties).

5 Click Add to Component: Macromechanics (Global Response) in the window toolbar.

6 In the Home toolbar, click Add Physics to close the Add Physics window.

G L O B A L  D E F I N I T I O N S

The full laminate is a repetition of two layers. Therefore, it is sufficient to define only a part 
of it in the Layered Material node. The transformation into the full laminate is performed 
through layered material settings in the Layered Material Link node.

Layered Material: [90/0]_2
1 In the Model Builder window, under Global Definitions right-click Materials and choose 

Layered Material.

2 In the Settings window for Layered Material, type Layered Material: [90/0]_2 in the 
Label text field.
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3 Locate the Layer Definition section. In the table, enter the following settings:

4 Click Add.

5 In the table, enter the following settings:

M A T E R I A L S

Layered Material Link 1 (llmat1)
1 In the Model Builder window, under 

Component: Macromechanics (Global Response) (comp2) right-click Materials and choose 
Layers>Layered Material Link.

The laminate partially defined in the Layered Material node can be transformed into a 
full laminate using a transform option in the layered material settings.

2 In the Settings window for Layered Material Link, locate the Layered Material Settings 
section.

3 From the Transform list, choose Repeated.

4 In the Number of repeats text field, type 2.

5 Click to expand the Preview Plot Settings section. In the Thickness-to-width ratio text 
field, type 0.4.

6 Locate the Layered Material Settings section. Click Layer Cross-Section Preview in the 
upper-right corner of the section to enable the through-thickness view of the laminated 
material.

7 Click Layer Stack Preview in the upper-right corner of the Layered Material Settings 
section to show the stacking sequence including the fiber orientation.

Layer Material Rotation 
(deg)

Thickness Mesh 
elements

Layer 1 Homogeneous Material 
(solidcp1mat)

90 th 2

Layer Material Rotation 
(deg)

Thickness Mesh 
elements

Layer 2 Homogeneous Material 
(solidcp1mat)

0 th 2
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L A Y E R E D  S H E L L  ( L S H E L L )

Linear Elastic Material 1
1 In the Model Builder window, under 

Component: Macromechanics (Global Response) (comp2)>Layered Shell (lshell) click 
Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Material symmetry list, choose Anisotropic.

Add Safety features with composite-specific Hashin and Puck failure criteria.

Safety 1
1 In the Physics toolbar, click Attributes and choose Safety.

2 In the Settings window for Safety, locate the Failure Model section.

3 From the Failure criterion list, choose Hashin.

Safety 2
1 Right-click Safety 1 and choose Duplicate.

2 In the Settings window for Safety, locate the Failure Model section.

3 From the Failure criterion list, choose Puck.

4 Find the Interfiber failure subsection. In the ptl text field, type 0.35.

5 In the pcl text field, type 0.3.

G L O B A L  D E F I N I T I O N S

Homogeneous Material (solidcp1mat)
1 In the Model Builder window, under Global Definitions>Materials click 

Homogeneous Material (solidcp1mat).

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

Property Variable Value Unit Property group

Density rho rho_l kg/m³ Basic

Tensile strengths {sigmats1, 
sigmats2, 
sigmats3}

{Sigmats1, 
Sigmats2, 
Sigmats3}

Pa Orthotropic 
strength 
parameters, Voigt 
notation
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L A Y E R E D  S H E L L  ( L S H E L L )

Fixed Constraint 1
1 In the Physics toolbar, click Edges and choose Fixed Constraint.

2 Select Edges 9–12 only.

Boundary Load 1
1 In the Physics toolbar, click Edges and choose Boundary Load.

2 Select Edges 1, 2, 4, and 6 only.

3 In the Settings window for Boundary Load, locate the Force section.

Compressive 
strengths

{sigmacs1, 
sigmacs2, 
sigmacs3}

{Sigmacs1, 
Sigmacs2, 
Sigmacs3}

Pa Orthotropic 
strength 
parameters, Voigt 
notation

Shear strengths {sigmass1, 
sigmass2, 
sigmass3}

{Sigmass23, 
Sigmass13, 
Sigmass12}

Pa Orthotropic 
strength 
parameters, Voigt 
notation

Ultimate tensile 
strain in longitudinal 
direction

epsilont1 epsilonts1 1 Orthotropic 
strength 
parameters, Voigt 
notation

Ultimate 
compressive strain 
in longitudinal 
direction

epsilonc1 epsiloncs1 1 Orthotropic 
strength 
parameters, Voigt 
notation

Young’s modulus of 
fiber in longitudinal 
direction

Ef1 E1_f Pa Orthotropic 
strength 
parameters, Voigt 
notation

In-plane Poisson’s 
ratio of fiber

nuf12 nu12_f 1 Orthotropic 
strength 
parameters, Voigt 
notation

Linear degradation 
stress

sigma1D Sigma1D N/m² Orthotropic 
strength 
parameters, Voigt 
notation

Property Variable Value Unit Property group
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4 From the Load type list, choose Total force.

5 Specify the Ftot vector as

M E S H  2

Mapped 1
1 In the Mesh toolbar, click Boundary and choose Mapped.

2 In the Settings window for Mapped, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

Distribution 1
1 Right-click Mapped 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Edge Selection section.

3 From the Selection list, choose All edges.

4 Locate the Distribution section. In the Number of elements text field, type 20.

5 Click Build All.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Solid Mechanics (solid).

5 Click Add Study in the window toolbar.

6 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y :  M A C R O M E C H A N I C S  ( G L O B A L  R E S P O N S E )

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Study: Macromechanics (Global Response) 
in the Label text field.

3 In the Home toolbar, click Compute.

0 x

0 y

-5E4 z
33 |  M I C R O M E C H A N I C S  O F  F A I L U R E :  M U L T I S C A L E  A N A L Y S I S  O F  A  C O M P O S I T E



R E S U L T S

Layered Material
1 In the Model Builder window, expand the Results>Datasets node, then click 

Layered Material.

2 In the Settings window for Layered Material, locate the Layers section.

3 In the Scale text field, type 5.

Stress (lshell)
1 In the Model Builder window, under Results click Stress (lshell).

2 In the Settings window for 3D Plot Group, click to expand the Title section.

3 From the Title type list, choose Manual.

4 In the Title text area, type von Mises stress (MPa) .

5 Locate the Color Legend section. Select the Show maximum and minimum values check 
box.

Surface 1
1 In the Model Builder window, expand the Stress (lshell) node, then click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 In the Stress (lshell) toolbar, click Plot.

5 In the Home toolbar, click Add Predefined Plot.

A D D  P R E D E F I N E D  P L O T

1 Go to the Add Predefined Plot window.

2 In the tree, select Study: Macromechanics (Global Response)/Solution 1 (3) (sol1)>

Layered Shell>Stress, Slice (lshell).

3 Click Add Plot in the window toolbar.

4 In the Home toolbar, click Add Predefined Plot.

R E S U L T S

von Mises Stress, Slice
1 In the Model Builder window, expand the Results>Stress, Slice (lshell) node, then click 

Stress, Slice (lshell).

2 In the Settings window for 3D Plot Group, type von Mises Stress, Slice in the Label 
text field.
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3 Locate the Plot Settings section. Clear the Plot dataset edges check box.

Layered Material Slice 1
1 In the Model Builder window, click Layered Material Slice 1.

2 In the Settings window for Layered Material Slice, click to expand the Title section.

3 From the Title type list, choose Manual.

4 In the Title text area, type von Mises stress (MPa) .

5 Locate the Expression section. From the Unit list, choose MPa.

6 Locate the Through-Thickness Location section. From the Location definition list, choose 
Interfaces.

7 Locate the Layout section. From the Displacement list, choose Rectangular.

8 From the Orientation list, choose zx.

9 In the Relative x-separation text field, type 0.3.

10 In the Relative z-separation text field, type 0.7.

11 Select the Show descriptions check box.

12 In the Relative separation text field, type 0.6.

13 Click to expand the Quality section. From the Resolution list, choose No refinement.

Deformation
1 In the Model Builder window, expand the Layered Material Slice 1 node.

2 Right-click Deformation and choose Disable.

von Mises Stress, Slice
1 In the Model Builder window, under Results click von Mises Stress, Slice.

2 In the von Mises Stress, Slice toolbar, click Plot.

From the von Mises Stress, Slice it is clear that the maximum von Mises stress occurs either 
at the inner or outer layer of the composite cylinder. To get the position where the 
maximum von Mises stress occurs in the laminate, add a Surface Maximum derived-values 
node. These coordinates are useful for the next micromechanical analysis.

Surface Maximum 1
1 In the Results toolbar, click More Derived Values and choose Maximum>

Surface Maximum.

2 In the Settings window for Surface Maximum, locate the Data section.

3 From the Dataset list, choose Study: Macromechanics (Global Response)/

Solution 1 (3) (sol1).
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4 Locate the Selection section. From the Selection list, choose All boundaries.

5 Locate the Expressions section. In the table, enter the following settings:

6 Click to expand the Configuration section. Select the Include position check box.

7 Click Evaluate.

Use the following instructions to plot the through-thickness variation of the von Mises 
stress at a point where the von Mises stress is maximal.

Cut Point 3D 1
1 In the Results toolbar, click Cut Point 3D.

2 In the Settings window for Cut Point 3D, locate the Data section.

3 From the Dataset list, choose Study: Macromechanics (Global Response)/

Solution 1 (3) (sol1).

4 Locate the Point Data section. In the X text field, type 0.5.

5 In the Y text field, type 0.

6 In the Z text field, type -0.1[m].

7 From the Snapping list, choose Snap to closest boundary.

8 In the Results toolbar, click Add Predefined Plot.

A D D  P R E D E F I N E D  P L O T

1 Go to the Add Predefined Plot window.

2 In the tree, select Study: Macromechanics (Global Response)/Solution 1 (3) (sol1)>

Layered Shell>Stress, Through Thickness (lshell).

3 Click Add Plot in the window toolbar.

4 In the Results toolbar, click Add Predefined Plot.

R E S U L T S

von Mises Stress, Through Thickness
1 In the Model Builder window, under Results click Stress, Through Thickness (lshell).

Expression Unit Description

lshell.atxd1(0,lshell.mises) von Mises stress in the 
inner layer

lshell.atxd1(lshell.d,
lshell.mises)

von Mises stress in the 
outer layer
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2 In the Settings window for 1D Plot Group, type von Mises Stress, Through 
Thickness in the Label text field.

3 Locate the Legend section. Clear the Show legends check box.

Through Thickness 1
1 In the Model Builder window, expand the von Mises Stress, Through Thickness node, then 

click Through Thickness 1.

2 In the Settings window for Through Thickness, locate the Data section.

3 From the Dataset list, choose Cut Point 3D 1.

4 Locate the x-Axis Data section. From the Unit list, choose MPa.

5 In the von Mises Stress, Through Thickness toolbar, click Plot.

6 In the Home toolbar, click Add Predefined Plot.

A D D  P R E D E F I N E D  P L O T

1 Go to the Add Predefined Plot window.

2 In the tree, select Study: Macromechanics (Global Response)/Solution 1 (3) (sol1)>

Layered Shell>Failure Indices (lshell)>Failure Index (Safety 1).

3 Click Add Plot in the window toolbar.

R E S U L T S

Hashin Failure Index
1 In the Settings window for 3D Plot Group, type Hashin Failure Index in the Label text 

field.

2 Click to expand the Title section. From the Title type list, choose Manual.

3 In the Title text area, type Hashin Failure Index.

4 Locate the Color Legend section. Select the Show maximum and minimum values check 
box.

5 Locate the Data section. Click Go to Source.

Layered Material 2 (Safety)
1 In the Model Builder window, under Results>Datasets click Layered Material 2 (Safety).

2 In the Settings window for Layered Material, locate the Layers section.

3 In the Scale text field, type 200*lshell.scale.

Marker 1
1 In the Model Builder window, expand the Results>Hashin Failure Index node.
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2 Right-click Surface 1 and choose Marker.

3 In the Settings window for Marker, locate the Display section.

4 From the Display list, choose Max.

5 Locate the Text Format section. In the Display precision text field, type 3.

6 Locate the Coloring and Style section. In the Point radius text field, type 4.

7 From the Background color list, choose Gray.

8 From the Anchor point list, choose Lower right.

9 In the Hashin Failure Index toolbar, click Plot.

A D D  P R E D E F I N E D  P L O T

1 Go to the Add Predefined Plot window.

2 In the tree, select Study: Macromechanics (Global Response)/Solution 1 (3) (sol1)>

Layered Shell>Failure Indices (lshell)>Failure Index (Safety 2).

3 Click Add Plot in the window toolbar.

4 In the Home toolbar, click Add Predefined Plot.

R E S U L T S

Puck Failure Index
1 In the Model Builder window, under Results click Failure Index (lshell).

2 In the Settings window for 3D Plot Group, type Puck Failure Index in the Label text 
field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type Puck Failure Index.

5 Locate the Color Legend section. Select the Show maximum and minimum values check 
box.

Marker 1
1 In the Model Builder window, expand the Puck Failure Index node.

2 Right-click Surface 1 and choose Marker.

3 In the Settings window for Marker, locate the Display section.

4 From the Display list, choose Max.

5 Locate the Text Format section. In the Display precision text field, type 3.

6 Locate the Coloring and Style section. In the Point radius text field, type 4.

7 From the Background color list, choose Gray.
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8 From the Anchor point list, choose Lower right.

9 In the Puck Failure Index toolbar, click Plot.

Hashin Failure Indexes (Study: Macromechanics (Global Response))
1 In the Results toolbar, click Evaluation Group.

2 In the Settings window for Evaluation Group, type Hashin Failure Indexes (Study: 
Macromechanics (Global Response)) in the Label text field.

3 Locate the Data section. From the Dataset list, choose Layered Material 2 (Safety).

Volume Maximum 1
1 Right-click Hashin Failure Indexes (Study: Macromechanics (Global Response)) and choose 

Maximum>Volume Maximum.

2 In the Settings window for Volume Maximum, click Add Expression in the upper-right 
corner of the Expressions section. From the menu, choose 
Component: Macromechanics (Global Response) (comp2)>Layered Shell>Safety>Hashin>

lshell.lemm1.sf1.f_ifT - Hashin fiber tensile failure index.

3 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component: Macromechanics (Global Response) (comp2)>Layered Shell>

Safety>Hashin>lshell.lemm1.sf1.f_ifC - Hashin fiber compressive failure index.

4 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component: Macromechanics (Global Response) (comp2)>Layered Shell>

Safety>Hashin>lshell.lemm1.sf1.f_imT - Hashin matrix tensile failure index.

5 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component: Macromechanics (Global Response) (comp2)>Layered Shell>

Safety>Hashin>lshell.lemm1.sf1.f_imC - Hashin matrix compressive failure index.

6 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component: Macromechanics (Global Response) (comp2)>Layered Shell>

Safety>Hashin>lshell.lemm1.sf1.f_iiT - Hashin interlaminar tensile failure index.

7 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component: Macromechanics (Global Response) (comp2)>Layered Shell>

Safety>Hashin>lshell.lemm1.sf1.f_iiC - Hashin interlaminar compressive failure index.

Hashin Failure Indexes (Study: Macromechanics (Global Response))
1 In the Model Builder window, click 

Hashin Failure Indexes (Study: Macromechanics (Global Response)).

2 In the Settings window for Evaluation Group, locate the Transformation section.

3 Select the Transpose check box.
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4 In the Hashin Failure Indexes (Study: Macromechanics (Global Response)) toolbar, click 
Evaluate.

Puck Failure Indexes (Study: Macromechanics (Global Response))
1 In the Results toolbar, click Evaluation Group.

2 In the Settings window for Evaluation Group, type Puck Failure Indexes (Study: 
Macromechanics (Global Response)) in the Label text field.

3 Locate the Data section. From the Dataset list, choose Layered Material 2 (Safety).

Volume Maximum 1
1 Right-click Puck Failure Indexes (Study: Macromechanics (Global Response)) and choose 

Maximum>Volume Maximum.

2 In the Settings window for Volume Maximum, click Add Expression in the upper-right 
corner of the Expressions section. From the menu, choose 
Component: Macromechanics (Global Response) (comp2)>Layered Shell>Safety>Puck>

lshell.lemm1.sf2.f_ifT - Puck fiber tensile failure index.

3 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component: Macromechanics (Global Response) (comp2)>Layered Shell>

Safety>Puck>lshell.lemm1.sf2.f_ifC - Puck fiber compressive failure index.

4 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component: Macromechanics (Global Response) (comp2)>Layered Shell>

Safety>Puck>lshell.lemm1.sf2.f_imA - Puck interfiber mode A failure index.

5 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component: Macromechanics (Global Response) (comp2)>Layered Shell>

Safety>Puck>lshell.lemm1.sf2.f_imB - Puck interfiber mode B failure index.

6 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component: Macromechanics (Global Response) (comp2)>Layered Shell>

Safety>Puck>lshell.lemm1.sf2.f_imC - Puck interfiber mode C failure index.

Puck Failure Indexes (Study: Macromechanics (Global Response))
1 In the Model Builder window, click 

Puck Failure Indexes (Study: Macromechanics (Global Response)).

2 In the Settings window for Evaluation Group, locate the Transformation section.

3 Select the Transpose check box.

4 In the Puck Failure Indexes (Study: Macromechanics (Global Response)) toolbar, click 
Evaluate.
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Hashin Failure Index, Puck Failure Index, Stress (lshell), von Mises Stress, Slice, von 
Mises Stress, Through Thickness
1 In the Model Builder window, under Results, Ctrl-click to select Stress (lshell), 

von Mises Stress, Slice, von Mises Stress, Through Thickness, Hashin Failure Index, and 
Puck Failure Index.

2 Right-click and choose Group.

Macromechanics (Global Response)
In the Settings window for Group, type Macromechanics (Global Response) in the 
Label text field.

Modeling Instructions (Micromechanics: Local Response)

This section describes how to carry out micromechanical failure analysis of a RVE using 
the macro level strain field from the global analysis of the Layered Shell interface.

In order to do a micromechanical analysis at multiple material points, create a list of such 
point coordinates using a Parameter node. The points where the maximum von Mises 
stress occurs in inner and outer layers are included in this list.

G L O B A L  D E F I N I T I O N S

Material Point Location
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Material Point Location in the Label 
text field.

3 Locate the Parameters section. In the table, enter the following settings:

4 In the Home toolbar, click Parameter Case.

5 Right-click Global Definitions>Material Point Location>Case 1 and choose Duplicate.

6 In the Settings window for Case, locate the Parameters section.

Name Expression Value Description

X0 0[m] 0 m Material point, X coordinate

Y0 0[m] 0 m Material point, Y coordinate

Z0 -0.1[m] -0.1 m Material point, Z coordinate
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7 In the table, enter the following settings:

8 Right-click Global Definitions>Material Point Location>Case 2 and choose Duplicate.

9 In the Settings window for Case, locate the Parameters section.

10 In the table, enter the following settings:

11 Right-click Global Definitions>Material Point Location>Case 3 and choose Duplicate.

12 In the Settings window for Case, locate the Parameters section.

13 In the table, enter the following settings:

14 Right-click Global Definitions>Material Point Location>Case 4 and choose Duplicate.

15 In the Settings window for Case, locate the Parameters section.

16 In the table, enter the following settings:

17 Right-click Global Definitions>Material Point Location>Case 5 and choose Duplicate.

18 In the Settings window for Case, locate the Parameters section.

Name Expression Description

X0 hc/2 Material point, X coordinate

Y0 0[m] Material point, Y coordinate

Z0 -0.1[m] Material point, Z coordinate

Name Expression Description

X0 hc Material point, X coordinate

Y0 0[m] Material point, Y coordinate

Z0 -0.1[m] Material point, Z coordinate

Name Expression Description

X0 0[m] Material point, X coordinate

Y0 0[m] Material point, Y coordinate

Z0 0.1[m] Material point, Z coordinate

Name Expression Description

X0 hc/2 Material point, X coordinate

Y0 0[m] Material point, Y coordinate

Z0 0.1[m] Material point, Z coordinate
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19 In the table, enter the following settings:

C O M P O N E N T :  M I C R O M E C H A N I C S  ( M A T E R I A L  P R O P E R T I E S )  ( C O M P 1 )

The model setup can be simplified by copying the Component: Micromechanics (Material 

Properties) component.

In the Model Builder window, right-click 
Component: Micromechanics (Material Properties) (comp1) and choose Copy.

C O M P O N E N T :  M I C R O M E C H A N I C S  ( L O C A L  R E S P O N S E )

1 In the Model Builder window, right-click the root node and choose Paste Multiple Items.

2 In the Messages from Paste dialog box, click OK.

3 In the Settings window for Component, type Component: Micromechanics (Local 
Response) in the Label text field.

The RVE is analyzed at different through-thickness locations of the composite cylinder 
where the layers have different rotation angles with respect to the laminate coordinate 
system. Hence, rotate the RVE geometry with a conditional rotation angle expression.

G E O M E T R Y  1

Rotate 1 (rot1)
1 In the Geometry toolbar, click Transforms and choose Rotate.

2 Select the object pi1 only.

3 In the Settings window for Rotate, locate the Rotation section.

4 In the Angle text field, type if(xd==0,90[deg],0).

5 Click Build Selected.

In order to input the fiber material properties in the correct coordinate system, use a 
Rotated System.

D E F I N I T I O N S  ( C O M P 3 )

Rotated System 4 (sys4)
1 In the Definitions toolbar, click Coordinate Systems and choose Rotated System.

Name Expression Description

X0 hc Material point, X coordinate

Y0 0[m] Material point, Y coordinate

Z0 0.1[m] Material point, Z coordinate
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2 In the Settings window for Rotated System, locate the Rotation section.

3 Find the Euler angles (Z-X-Z) subsection. In the α text field, type if(xd==0,90[deg],
0).

Boundary System 1 (sys3)
1 In the Model Builder window, click Boundary System 1 (sys3).

2 In the Settings window for Boundary System, locate the Settings section.

3 Find the Coordinate names subsection. From the Create first tangent direction from list, 
choose Rotated System 4 (sys4).

4 From the Axis list, choose x1.

The failure criteria used for fiber, matrix, and interface materials are user defined, so use 
a Variable node to define them.

Variables 1
1 In the Model Builder window, right-click Definitions and choose Variables.

2 In the Settings window for Variables, locate the Variables section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
composite_multiscale_variables.txt.

S O L I D  M E C H A N I C S  ( S O L I D 2 )

Linear Elastic Material 1
1 In the Model Builder window, expand the 

Component: Micromechanics (Local Response) (comp3)>Solid Mechanics (solid2) node, 
then click Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Coordinate System Selection 
section.

3 From the Coordinate system list, choose Rotated System 4 (sys4).

Add Safety features to the matrix, fiber, and interface domains. Use user-defined criteria.

Fiber Failure Criterion
1 In the Physics toolbar, click Attributes and choose Safety.

2 In the Settings window for Safety, type Fiber Failure Criterion in the Label text 
field.

3 Select Domain 2 only.

4 Locate the Failure Model section. From the Failure criterion list, choose User defined.
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5 In the g (σ) text field, type g_f.

6 In the sf (σ) text field, type sf_f.

Linear Elastic Material 1
In the Model Builder window, click Linear Elastic Material 1.

Matrix Failure Criterion
1 In the Physics toolbar, click Attributes and choose Safety.

2 In the Settings window for Safety, type Matrix Failure Criterion in the Label text 
field.

3 Select Domain 1 only.

4 Locate the Failure Model section. From the Failure criterion list, choose User defined.

5 In the g (σ) text field, type g_m.

6 In the sf (σ) text field, type sf_m.

Thin Layer 1
In the Model Builder window, expand the 
Component: Micromechanics (Local Response) (comp3)>Solid Mechanics (solid2)>Thin Layer 1 
node.

Linear Elastic Material 1
In the Model Builder window, expand the 
Component: Micromechanics (Local Response) (comp3)>Solid Mechanics (solid2)>

Thin Layer 1>Linear Elastic Material 1 node, then click Linear Elastic Material 1.

Interface Failure Criterion
1 In the Physics toolbar, click Attributes and choose Safety.

2 In the Settings window for Safety, type Interface Failure Criterion in the Label 
text field.

3 Locate the Failure Model section. From the Failure criterion list, choose User defined.

4 In the g (σ) text field, type g_i.

5 In the sf (σ) text field, type sf_i.

Cell Periodicity 1
1 In the Model Builder window, under 

Component: Micromechanics (Local Response) (comp3)>Solid Mechanics (solid2) click 
Cell Periodicity 1.

2 In the Settings window for Cell Periodicity, locate the Periodicity Type section.
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3 From the list, choose Mixed.

4 Find the XX component subsection. In the εavgXX text field, type comp2.at2(X0,Y0,
Z0,comp2.lshell.atxd1(xd,comp2.lshell.eXX))*para.

5 Find the YY component subsection. In the εavgYY text field, type comp2.at2(X0,Y0,
Z0,comp2.lshell.atxd1(xd,comp2.lshell.eYY))*para.

6 Find the ZZ component subsection. In the εavgZZ text field, type comp2.at2(X0,Y0,Z0,
comp2.lshell.atxd1(xd,comp2.lshell.eZZ))*para.

7 Find the XY component subsection. In the εavgXY text field, type comp2.at2(X0,Y0,
Z0,comp2.lshell.atxd1(xd,comp2.lshell.eXY))*para.

8 Find the YZ component subsection. In the εavgYZ text field, type comp2.at2(X0,Y0,
Z0,comp2.lshell.atxd1(xd,comp2.lshell.eYZ))*para.

9 Find the XZ component subsection. In the εavgXZ text field, type comp2.at2(X0,Y0,
Z0,comp2.lshell.atxd1(xd,comp2.lshell.eXZ))*para.

M E S H  1

Free Triangular 1
1 In the Model Builder window, expand the 

Component: Micromechanics (Local Response) (comp3)>Mesh 1 node, then click 
Free Triangular 1.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Pair 1, Source (Unidirectional Fiber Composite,

Square Packing 1).

4 Click Build Selected.

Copy Face 1
1 In the Model Builder window, click Copy Face 1.

2 In the Settings window for Copy Face, locate the Source Boundaries section.

3 From the Selection list, choose Pair 1, Source (Unidirectional Fiber Composite,

Square Packing 1).

4 Locate the Destination Boundaries section. From the Selection list, choose Pair 1,

Destination (Unidirectional Fiber Composite, Square Packing 1).

5 Click Build Selected.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.
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2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check boxes 
for Solid Mechanics (solid) and Layered Shell (lshell).

5 Click Add Study in the window toolbar.

6 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y :  M I C R O M E C H A N I C S  ( L O C A L  R E S P O N S E )

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study: Micromechanics (Local Response) 
in the Label text field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

Parametric Sweep
1 In the Study toolbar, click Parametric Sweep.

Add two Parametric Sweep nodes, one for different in-plane locations and another for 
different through-thickness locations.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 From the Sweep type list, choose Parameter switch.

4 Click Add.

5 In the table, enter the following settings:

Parametric Sweep 2
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

Step 1: Stationary
1 In the Model Builder window, click Step 1: Stationary.

Switch Cases Case numbers

Material Point Location All range(1,1,6)

Parameter name Parameter value list Parameter unit

xd (Extra dimension location) 0 4*th mm
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2 In the Settings window for Stationary, click to expand the Values of Dependent Variables 
section.

3 Find the Values of variables not solved for subsection. From the Settings list, choose 
User controlled.

4 From the Method list, choose Solution.

5 From the Study list, choose Study: Macromechanics (Global Response), Stationary.

6 In the Study toolbar, click Compute.

R E S U L T S

Micromechanics (Local Response)
1 In the Model Builder window, right-click Micromechanics (Material Properties) and choose 

Duplicate.

2 In the Settings window for Group, type Micromechanics (Local Response) in the 
Label text field.

Stress, Unit Cell (At First Material Point in Inner Layer)
1 In the Model Builder window, expand the Micromechanics (Local Response) node, then 

click Stress, Unit Cell 1.

2 In the Settings window for 3D Plot Group, type Stress, Unit Cell (At First 
Material Point in Inner Layer) in the Label text field.

3 Locate the Data section. From the Dataset list, choose 
Study: Micromechanics (Local Response)/Parametric Solutions 1 (9) (sol3).

4 From the Parameter value (xd (mm)) list, choose 0.

5 From the Material Point Location list, choose Case 1.

6 Locate the Title section. Clear the Parameter indicator text field.

Volume 1
1 In the Model Builder window, expand the Stress,

Unit Cell (At First Material Point in Inner Layer) node, then click Volume 1.

2 In the Settings window for Volume, locate the Expression section.

3 In the Expression text field, type solid2.mises.

4 From the Unit list, choose MPa.

Selection 1
1 In the Model Builder window, expand the Volume 1 node, then click Selection 1.

2 In the Settings window for Selection, locate the Selection section.
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3 Click to select the Activate Selection toggle button.

4 Select Domain 1 only.

Volume 2
1 In the Model Builder window, under Results>Micromechanics (Local Response)>Stress,

Unit Cell (At First Material Point in Inner Layer) click Volume 2.

2 In the Settings window for Volume, locate the Expression section.

3 In the Expression text field, type solid2.mises.

4 From the Unit list, choose MPa.

Selection 1
1 In the Model Builder window, expand the Volume 2 node, then click Selection 1.

2 In the Settings window for Selection, locate the Selection section.

3 Click to select the Activate Selection toggle button.

4 Select Domain 2 only.

Surface 1
1 In the Model Builder window, under Results>Micromechanics (Local Response)>Stress,

Unit Cell (At First Material Point in Inner Layer) click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type solid2.mises.

4 From the Unit list, choose MPa.

Selection 1
1 In the Model Builder window, click Selection 1.

2 In the Settings window for Selection, locate the Selection section.

3 Click to select the Activate Selection toggle button.

4 Select Boundaries 6–9 only.

5 Click the Zoom Extents button in the Graphics toolbar.

6 In the Stress, Unit Cell (At First Material Point in Inner Layer) toolbar, click Plot.

Stress, Unit Cell (At Multiple Material Points)
1 In the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Stress, Unit Cell (At Multiple 
Material Points) in the Label text field.

3 Locate the Data section. From the Dataset list, choose 
Study: Micromechanics (Local Response)/Parametric Solutions 1 (9) (sol3).
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4 Locate the Title section. From the Title type list, choose Manual.

5 In the Title text area, type von Mises stress (MPa) .

6 Clear the Parameter indicator text field.

7 Locate the Plot Settings section. Clear the Plot dataset edges check box.

Surface 1
1 Right-click Stress, Unit Cell (At Multiple Material Points) and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Study: Micromechanics (Local Response)/

Parametric Solutions 1 (9) (sol3).

4 From the Parameter value (xd (mm)) list, choose 0.

5 From the Material Point Location list, choose Case 1.

6 Locate the Expression section. In the Expression text field, type solid2.mises.

7 From the Unit list, choose MPa.

8 Click to expand the Range section. Select the Manual color range check box.

9 In the Maximum text field, type 100.

10 Locate the Coloring and Style section. Click Change Color Table.

11 In the Color Table dialog box, select Rainbow>Prism in the tree.

12 Click OK.

13 In the Settings window for Surface, click to expand the Quality section.

14 From the Resolution list, choose Custom.

15 In the Element refinement text field, type 2.

16 From the Smoothing threshold list, choose Manual.

17 In the Threshold text field, type 0.2.

Translation 1
1 Right-click Surface 1 and choose Translation.

2 In the Settings window for Translation, locate the Translation section.

3 In the x text field, type X0.

4 In the y text field, type Y0.

5 In the z text field, type Z0+18*th.
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Surface 2
1 In the Model Builder window, under Results>Micromechanics (Local Response)>Stress,

Unit Cell (At Multiple Material Points) right-click Surface 1 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Material Point Location list, choose Case 2.

4 Locate the Inherit Style section. From the Plot list, choose Surface 1.

Surface 3
1 Right-click Surface 2 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Material Point Location list, choose Case 3.

Surface 4
1 Right-click Surface 3 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Material Point Location list, choose Case 4.

Translation 1
1 In the Model Builder window, expand the Surface 4 node, then click Translation 1.

2 In the Settings window for Translation, locate the Translation section.

3 In the z text field, type Z0-18*th.

Surface 5
1 In the Model Builder window, under Results>Micromechanics (Local Response)>Stress,

Unit Cell (At Multiple Material Points) right-click Surface 4 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Material Point Location list, choose Case 5.

Surface 6
1 Right-click Surface 5 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Material Point Location list, choose Case 6.

Surface 7
1 Right-click Surface 6 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Parameter value (xd (mm)) list, choose 4.
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4 From the Material Point Location list, choose Case 1.

Surface 8
1 Right-click Surface 7 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Material Point Location list, choose Case 2.

Surface 9
1 Right-click Surface 8 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Material Point Location list, choose Case 3.

Surface 10
1 Right-click Surface 9 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Material Point Location list, choose Case 4.

Translation 1
1 In the Model Builder window, expand the Surface 10 node, then click Translation 1.

2 In the Settings window for Translation, locate the Translation section.

3 In the z text field, type Z0+18*th.

Surface 11
1 In the Model Builder window, under Results>Micromechanics (Local Response)>Stress,

Unit Cell (At Multiple Material Points) right-click Surface 10 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Material Point Location list, choose Case 5.

Surface 12
1 Right-click Surface 11 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Material Point Location list, choose Case 6.

Line 1
1 In the Model Builder window, right-click Stress, Unit Cell (At Multiple Material Points) and 

choose Line.

2 In the Settings window for Line, locate the Expression section.

3 In the Expression text field, type 0.
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4 Locate the Data section. From the Dataset list, choose Layered Material 2 (Safety).

5 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

6 From the Color list, choose Black.

Stress, Unit Cell (At Multiple Material Points)
1 In the Model Builder window, click Stress, Unit Cell (At Multiple Material Points).

2 In the Stress, Unit Cell (At Multiple Material Points) toolbar, click Plot.

User Defined Failure Indexes (At First Material Point in Inner Layer)
1 In the Model Builder window, right-click Stress,

Unit Cell (At First Material Point in Inner Layer) and choose Duplicate.

2 In the Settings window for 3D Plot Group, type User Defined Failure Indexes (At 
First Material Point in Inner Layer) in the Label text field.

3 Locate the Title section. In the Title text area, type User Defined failure index (1).

4 Locate the Color Legend section. Select the Show maximum and minimum values check 
box.

Volume 1
1 In the Model Builder window, expand the 

User Defined Failure Indexes (At First Material Point in Inner Layer) node, then click 
Volume 1.

2 In the Settings window for Volume, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose 
Component: Micromechanics (Local Response) (comp3)>Solid Mechanics>Safety>

User defined>solid2.lemm1.sf2.f_i - User-defined failure index.

Volume 2
1 In the Model Builder window, click Volume 2.

2 In the Settings window for Volume, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose 
Component: Micromechanics (Local Response) (comp3)>Solid Mechanics>Safety>

User defined>solid2.lemm1.sf1.f_i - User-defined failure index.

Surface 1
1 In the Model Builder window, click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose 
Component: Micromechanics (Local Response) (comp3)>Solid Mechanics>Safety>

User defined>solid2.tl1.lemm1.sf1.f_i - User-defined failure index.
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User Defined Failure Indexes (At First Material Point in Inner Layer)
1 Click the Zoom Extents button in the Graphics toolbar.

2 In the Model Builder window, click 
User Defined Failure Indexes (At First Material Point in Inner Layer).

3 In the User Defined Failure Indexes (At First Material Point in Inner Layer) toolbar, click 
Plot.

User Defined Failure Indexes (At First Material Point in Outer Layer)
1 Right-click User Defined Failure Indexes (At First Material Point in Inner Layer) and 

choose Duplicate.

2 In the Settings window for 3D Plot Group, type User Defined Failure Indexes (At 
First Material Point in Outer Layer) in the Label text field.

3 Locate the Data section. From the Parameter value (xd (mm)) list, choose 4.

4 Click the Zoom Extents button in the Graphics toolbar.

5 In the User Defined Failure Indexes (At First Material Point in Outer Layer) toolbar, click 
Plot.

User Defined Failure Indexes at First Material Point in Inner Layer (Study: 
Micromechanics (Local Response))
1 In the Results toolbar, click Evaluation Group.

2 In the Settings window for Evaluation Group, type User Defined Failure Indexes 
at First Material Point in Inner Layer (Study: Micromechanics (Local 

Response)) in the Label text field.

3 Locate the Data section. From the Dataset list, choose 
Study: Micromechanics (Local Response)/Parametric Solutions 1 (9) (sol3).

4 From the Parameter selection (xd) list, choose First.

5 From the Material Point Location list, choose First.

Volume Maximum 1
1 Right-click 

User Defined Failure Indexes at First Material Point in Inner Layer (Study: Micromechanics (

Local Response)) and choose Maximum>Volume Maximum.

2 Select Domain 1 only.

3 In the Settings window for Volume Maximum, click Replace Expression in the upper-right 
corner of the Expressions section. From the menu, choose 
Component: Micromechanics (Local Response) (comp3)>Solid Mechanics>Safety>

User defined>solid2.lemm1.sf2.f_i - User-defined failure index.
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4 Locate the Expressions section. In the table, enter the following settings:

Volume Maximum 2
1 In the Model Builder window, right-click 

User Defined Failure Indexes at First Material Point in Inner Layer (Study: Micromechanics (

Local Response)) and choose Maximum>Volume Maximum.

2 Select Domain 2 only.

3 In the Settings window for Volume Maximum, click Replace Expression in the upper-right 
corner of the Expressions section. From the menu, choose 
Component: Micromechanics (Local Response) (comp3)>Solid Mechanics>Safety>

User defined>solid2.lemm1.sf1.f_i - User-defined failure index.

4 Locate the Expressions section. In the table, enter the following settings:

Surface Maximum 3
1 Right-click 

User Defined Failure Indexes at First Material Point in Inner Layer (Study: Micromechanics (

Local Response)) and choose Maximum>Surface Maximum.

2 In the Settings window for Surface Maximum, locate the Selection section.

3 From the Selection list, choose Interface Selection.

4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component: Micromechanics (Local Response) (comp3)>Solid Mechanics>

Safety>User defined>solid2.tl1.lemm1.sf1.f_i - User-defined failure index.

5 Locate the Expressions section. In the table, enter the following settings:

Expression Unit Description

solid2.lemm1.sf2.f_i 1 User-defined matrix failure 
index

Expression Unit Description

solid2.lemm1.sf1.f_i 1 User-defined fiber failure 
index

Expression Unit Description

solid2.tl1.lemm1.sf1.f_i 1 User-defined interface 
failure index
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User Defined Failure Indexes at First Material Point in Inner Layer (Study: 
Micromechanics (Local Response))
1 In the Model Builder window, click 

User Defined Failure Indexes at First Material Point in Inner Layer (Study: Micromechanics (

Local Response)).

2 In the Settings window for Evaluation Group, locate the Transformation section.

3 Select the Transpose check box.

4 Click to expand the Format section. From the Include parameters list, choose Off.

5 In the User Defined Failure Indexes at First Material Point in Inner Layer (Study: 

Micromechanics (Local Response)) toolbar, click Evaluate.

User Defined Failure Indexes at First Material Point in Outer Layer (Study: 
Micromechanics (Local Response))
1 Right-click 

User Defined Failure Indexes at First Material Point in Inner Layer (Study: Micromechanics (

Local Response)) and choose Duplicate.

2 In the Settings window for Evaluation Group, type User Defined Failure Indexes 
at First Material Point in Outer Layer (Study: Micromechanics (Local 

Response)) in the Label text field.

3 Locate the Data section. From the Parameter selection (xd) list, choose Last.

4 In the User Defined Failure Indexes at First Material Point in Outer Layer (Study: 

Micromechanics (Local Response)) toolbar, click Evaluate.
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