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Introduction

The numerical treatment of thin structures with a membrane model is much simpler than 
with a shell model due to the assumption of zero bending stiffness. However, for some 
load cases this assumption is disadvantageous. For instance, when a membrane is subjected 
to compressive stresses, it may trigger wrinkling when these reach a critical level defined 
by the bending stiffness.This undesirable limitation can be overcame with the 
incorporation of a wrinkling model that removes these instabilities. 

In this example, a rectangular membrane is stretched uniaxially, which results in wrinkling 
in the central region. The wrinkling region and stress distribution depends on the 
geometry, loading conditions, and material properties. The analytical results are used to 
verify the numerical solution.

Model Definition

A rectangular sheet 1 m in length, 0.5 m in width, and 1 mm thick is stretched in the 
longitudinal direction. 

One of the short edges is fixed, while a prescribed displacement of 1 mm is applied on the 
opposite edge. The long edges are unconstrained.

The sheet is made of a linear elastic material, and both isotropic and orthotropic scenarios 
are analyzed. The material properties are given in Table 1.
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M A T E R I A L  P R O P E R T I E S

Results and Discussions

The numerical and analytical results are compared side by side in the same figure. For this 
particular problem, wrinkling occurs in the 2nd local direction as uniaxial stretching is 
applied in the 1st local direction. 

The analytical expression for the wrinkling measure for isotropic and orthotropic materials 
is derived from the equality 

which gives the expression for the wrinkling measure as

Figure 1 and Figure 2 show the wrinkled regions for the isotropic and orthotropic cases. 
The results match the analytical values for both scenarios. For the isotropic case, the whole 
central region is wrinkled, while for the orthotropic case, only the areas along the long 
edges are wrinkled. 

Figure 3 and Figure 4 show the measure of wrinkling in the membrane. Again, in both 
isotropic and orthotropic cases the results match the analytical expressions. The region of 
maximum wrinkling is the region where maximum compressive stress could have 
developed without a wrinkling model.

TABLE 1:  MATERIAL PROPERTIES.

Property Variable Isotropic Case Orthotropic Case

Young’s modulus, 1 direction E1 100 kPa 100 kPa

Young’s modulus, 2 direction E2 100 kPa 20 kPa

Young’s modulus, 3 direction E3 100 kPa 20 kPa

Poisson’s ratio, 12 direction ν12 0.3 0.3

Poisson’s ratio, 23 direction ν23 0.3 0

Poisson’s ratio, 13 direction ν13 0.3 0

Shear modulus, 12 direction G12 E1/(2(1+ν12)) 38.5 kPa

Shear modulus, 23 direction G23 G12 G12

Shear modulus, 13 direction G13 G12 G12

S22 D12e11 D22e22 D23e33 βD22+ + + 0= =

β
D12e11 D22e22 D23e33+ +

D22
--------------------------------------------------------------------–=
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The first principal stress and the tensile direction for the isotropic and orthotropic cases 
are shown in Figure 5 and Figure 6. Figure 7 and Figure 8 show the second principal stress 
along the wrinkling direction. As expected, the direction of wrinkling is perpendicular to 
the loading direction in uniaxial stretching. The lowest value of the second principal stress 
is nearly zero. Both figures show no compressive stresses.

Figure 1: Wrinkled region, isotropic material.
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Figure 2: Wrinkled region, orthotropic material.

Figure 3: Measure of wrinkling, isotropic material.
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Figure 4: Measure of wrinkling, orthotropic material.

Figure 5: First principal stress, isotropic material.
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Figure 6: First principal stress, orthotropic material.

Figure 7: Second principal stress, isotropic material.
7 |  U N I A X I A L  S T R E T C H I N G  O F  A  R E C T A N G U L A R  M E M B R A N E



Figure 8: Second principal stress, orthotropic material.

Notes About the COMSOL Implementation

A wrinkling model based on the modified deformation gradient is incorporated within the 
membrane theory using the Wrinkling feature, which solves a set of nonlinear equations 
with the Newton–Raphson method.

Since the unstressed membrane does not have stiffness in the normal direction, a very small 
spring support is added in order to stabilize the model.

Application Library path: Structural_Mechanics_Module/
Buckling_and_Wrinkling/membrane_uniaxial_stretching

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
8 |  U N I A X I A L  S T R E T C H I N G  O F  A  R E C T A N G U L A R  M E M B R A N E



M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Membrane (mbrn).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Geometric Parameters
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, type Geometric Parameters in the Label text 
field.

3 Locate the Parameters section. In the table, enter the following settings:

Isotropic Material Properties
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Isotropic Material Properties in the 
Label text field.

3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
membrane_uniaxial_stretching_isotropic_properties.txt.

Orthotropic Material Properties
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Orthotropic Material Properties in 
the Label text field.

3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
membrane_uniaxial_stretching_orthotropic_properties.txt.

Name Expression Value Description

th 1[mm] 0.001 m Thickness of rectangular sheet

L 1[m] 1 m Length of rectangular sheet

W 0.5[m] 0.5 m Width of rectangular sheet
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D E F I N I T I O N S

Variables 1
1 In the Model Builder window, expand the Component 1 (comp1)>Definitions node.

2 Right-click Definitions and choose Variables.

3 In the Settings window for Variables, locate the Variables section.

4 In the table, enter the following settings:

G E O M E T R Y  1

Work Plane 1 (wp1)
In the Geometry toolbar, click Work Plane.

Work Plane 1 (wp1)>Plane Geometry
In the Model Builder window, click Plane Geometry.

Work Plane 1 (wp1)>Rectangle 1 (r1)
1 In the Work Plane toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type L.

4 In the Height text field, type W.

5 Click Build Selected.

M E M B R A N E  ( M B R N )

Linear Elastic Material 1
1 In the Model Builder window, under Component 1 (comp1)>Membrane (mbrn) click 

Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Solid model list, choose Orthotropic.

Name Expression Unit Description

Beta_ana max(-(mbrn.D12*mbrn.eel11+
mbrn.D22*mbrn.eel22+
mbrn.D23*mbrn.eel33)/
mbrn.D22,0)

Wrinkling 
measure, 
analytical

iswrinkled_an
a

Beta_ana>0 Is wrinkled, 
analytical
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Wrinkling 1
In the Physics toolbar, click Attributes and choose Wrinkling.

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Membrane (mbrn) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type th.

Fixed Constraint 1
1 In the Physics toolbar, click Edges and choose Fixed Constraint.

2 Select Edge 1 only.

Prescribed Displacement 1
1 In the Physics toolbar, click Edges and choose Prescribed Displacement.

2 Select Edge 4 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in x direction check box.

5 In the u0x text field, type 1[mm].

6 Select the Prescribed in y direction check box.

7 Select the Prescribed in z direction check box.

Add a spring support in the thickness direction in order to achieve numerical stability for 
this problem.

Spring Foundation 1
1 In the Physics toolbar, click Boundaries and choose Spring Foundation.

2 In the Settings window for Spring Foundation, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

4 Locate the Spring section. From the list, choose Symmetric.

5 In the kA table, enter the following settings:

Add a Material Switch node in order to run same study with different materials.

0 0 0

0 0 0

0 0 1e-3[N/m^3]
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M A T E R I A L S

Material Switch 1 (sw1)
In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
More Materials>Material Switch.

Isotropic Material
1 In the Model Builder window, right-click Material Switch 1 (sw1) and choose 

Blank Material.

Orthotropic elastic properties are asked by the material due to the settings in the physics 
features. The isotropic material can however be defined by adding the isotropic 
properties manually. The orthotropic properties will be calculated automatically by 
synchronization rules.

2 In the Settings window for Material, type Isotropic Material in the Label text field.

3 Locate the Material Properties section. In the Material properties tree, select 
Solid Mechanics>Linear Elastic Material>Young’s Modulus and Poisson’s Ratio.

4 Click Add to Material.

5 Locate the Material Contents section. In the table, enter the following settings:

Material Switch 1 may show a warning. You can ignore it since the orthotropic material 
properties are well defined by the synchronization rules.

Orthotropic Material
1 In the Model Builder window, right-click Material Switch 1 (sw1) and choose 

Blank Material.

2 In the Settings window for Material, type Orthotropic Material in the Label text field.

Property Variable Value Unit Property group

Young’s modulus E E_iso Pa Young’s modulus and 
Poisson’s ratio

Poisson’s ratio nu nu_iso 1 Young’s modulus and 
Poisson’s ratio

Density rho 0 kg/m³ Basic
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3 Locate the Material Contents section. In the table, enter the following settings:

M E S H  1

Mapped 1
1 In the Mesh toolbar, click Boundary and choose Mapped.

2 Select Boundary 1 only.

Size
1 In the Model Builder window, click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Finer.

Convert 1
1 In the Mesh toolbar, click Modify and choose Convert.

2 In the Settings window for Convert, locate the Element Split Method section.

3 From the Element split method list, choose Insert center points.

4 Click Build All.

S T U D Y  1

Material Sweep
1 In the Study toolbar, click Material Sweep.

2 In the Settings window for Material Sweep, locate the Study Settings section.

3 Click Add.

Property Variable Value Unit Property group

Young’s 
modulus

{Evector1, 
Evector2, 
Evector3}

{E1_orth, 
E2_orth, 
E3_orth}

Pa Orthotropic

Poisson’s 
ratio

{nuvector1, 
nuvector2, 
nuvector3}

{nu12_orth, 
nu23_orth, 
nu13_orth}

1 Orthotropic

Shear 
modulus

{Gvector1, 
Gvector2, 
Gvector3}

{G12_orth, 
G23_orth, 
G13_orth}

N/m² Orthotropic

Density rho 0 kg/m³ Basic
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Solution 1 (sol1)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Stationary Solver 1 node, then click Fully Coupled 1.

4 In the Settings window for Fully Coupled, click to expand the Method and Termination 
section.

5 From the Termination criterion list, choose Solution and residual.

6 In the Model Builder window, click Study 1.

7 In the Settings window for Study, locate the Study Settings section.

8 Clear the Generate default plots check box.

9 In the Study toolbar, click Compute.

R E S U L T S

Wrinkled Region
1 In the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Wrinkled Region in the Label text field.

3 Locate the Data section. From the Dataset list, choose Study 1/

Parametric Solutions 1 (sol2).

4 From the Material Switch 1 list, choose Isotropic Material.

5 Click to expand the Plot Array section. Select the Enable check box.

6 From the Array axis list, choose y.

7 In the Relative padding text field, type 0.5.

Surface 1
1 In the Wrinkled Region toolbar, click Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1 (comp1)>Membrane>

Wrinkling>mbrn.iswrinkled - Is wrinkled.

3 Click to expand the Quality section. From the Smoothing list, choose None.

Surface 2
1 Right-click Surface 1 and choose Duplicate.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type iswrinkled_ana.
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4 Click to expand the Inherit Style section. From the Plot list, choose Surface 1.

5 Click to expand the Title section. From the Title type list, choose None.

6 In the Wrinkled Region toolbar, click Plot.

Wrinkled Region
In the Model Builder window, click Wrinkled Region.

Annotation 1
1 In the Wrinkled Region toolbar, click Annotation.

2 In the Settings window for Annotation, locate the Annotation section.

3 In the Text text field, type Computed.

4 Locate the Position section. In the X text field, type L/2.

5 Locate the Coloring and Style section. Clear the Show point check box.

6 Click to expand the Plot Array section. Select the Manual indexing check box.

Wrinkled Region
In the Model Builder window, click Wrinkled Region.

Annotation 2
1 In the Wrinkled Region toolbar, click Annotation.

2 In the Settings window for Annotation, locate the Annotation section.

3 In the Text text field, type Analytical.

4 Locate the Position section. In the X text field, type L/2.

5 In the Y text field, type W.

6 Locate the Coloring and Style section. Clear the Show point check box.

7 From the Anchor point list, choose Lower right.

8 Locate the Plot Array section. Select the Manual indexing check box.

9 In the Index text field, type 1.

10 Click the Zoom Extents button in the Graphics toolbar.

Wrinkled Region
1 In the Model Builder window, click Wrinkled Region.

2 In the Settings window for 3D Plot Group, locate the Plot Settings section.

3 From the View list, choose New view.

4 In the Wrinkled Region toolbar, click Plot.

5 Click the Show Grid button in the Graphics toolbar.
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Wrinkling Measure
1 Right-click Wrinkled Region and choose Duplicate.

2 In the Settings window for 3D Plot Group, type Wrinkling Measure in the Label text 
field.

Surface 1
1 In the Model Builder window, expand the Wrinkling Measure node, then click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1 (comp1)>Membrane>

Wrinkling>mbrn.lemm1.wr1.Beta - Wrinkling measure, material frame.

3 Locate the Quality section. From the Smoothing list, choose Inside material domains.

Surface 2
1 In the Model Builder window, click Surface 2.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type Beta_ana.

4 Locate the Quality section. From the Smoothing list, choose Inside material domains.

5 In the Wrinkling Measure toolbar, click Plot.

First Principal Stress
1 In the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type First Principal Stress in the Label 
text field.

3 Locate the Data section. From the Dataset list, choose Study 1/

Parametric Solutions 1 (sol2).

4 From the Material Switch 1 list, choose Isotropic Material.

5 Locate the Color Legend section. Select the Show maximum and minimum values check 
box.

Surface 1
1 Right-click First Principal Stress and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1 (comp1)>Membrane>

Stress>Principal stresses>mbrn.sp1 - First principal stress - N/m².

3 Locate the Coloring and Style section. From the Color table list, choose Prism.

Arrow Surface 1
1 In the Model Builder window, right-click First Principal Stress and choose Arrow Surface.
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2 In the Settings window for Arrow Surface, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Component 1 (comp1)>

Membrane>Wrinkling>mbrn.lemm1.wr1.tnx,...,mbrn.lemm1.wr1.tnz -

Tension field direction, spatial frame.

First Principal Stress
Click the Zoom Extents button in the Graphics toolbar.

Second Principal Stress
1 Right-click First Principal Stress and choose Duplicate.

2 In the Settings window for 3D Plot Group, type Second Principal Stress in the Label 
text field.

Surface 1
1 In the Model Builder window, expand the Second Principal Stress node, then click 

Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1 (comp1)>Membrane>

Stress>Principal stresses>mbrn.sp2 - Second principal stress - N/m².

Arrow Surface 1
1 In the Model Builder window, click Arrow Surface 1.

2 In the Settings window for Arrow Surface, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Component 1 (comp1)>

Membrane>Wrinkling>mbrn.lemm1.wr1.wnx,...,mbrn.lemm1.wr1.wnz -

Wrinkling direction, spatial frame.

3 In the Second Principal Stress toolbar, click Plot.

Second Principal Stress
In the Model Builder window, collapse the Results>Second Principal Stress node.

Now, group all plots for isotropic materials, and duplicate them for plotting results with 
orthotropic material.

First Principal Stress, Second Principal Stress, Wrinkled Region, Wrinkling Measure
1 In the Model Builder window, under Results, Ctrl-click to select Wrinkled Region, 

Wrinkling Measure, First Principal Stress, and Second Principal Stress.

2 Right-click and choose Group.

Isotropic Material
In the Settings window for Group, type Isotropic Material in the Label text field.
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Orthotropic Material
1 Right-click Isotropic Material and choose Duplicate.

2 In the Settings window for Group, type Orthotropic Material in the Label text field.

Wrinkled Region 1
1 In the Model Builder window, expand the Orthotropic Material node, then click 

Wrinkled Region 1.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Material Switch 1 list, choose Orthotropic Material.

4 In the Wrinkled Region 1 toolbar, click Plot.

Wrinkling Measure 1
1 In the Model Builder window, click Wrinkling Measure 1.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Material Switch 1 list, choose Orthotropic Material.

Surface 1
1 In the Model Builder window, expand the Wrinkling Measure 1 node, then click Surface 1.

2 In the Settings window for Surface, click to expand the Range section.

3 Select the Manual color range check box.

4 Set the Maximum value to 1.2E-5.

5 In the Wrinkling Measure 1 toolbar, click Plot.

First Principal Stress 1
1 In the Model Builder window, under Results>Orthotropic Material click 

First Principal Stress 1.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Material Switch 1 list, choose Orthotropic Material.

4 In the First Principal Stress 1 toolbar, click Plot.

Second Principal Stress 1
1 In the Model Builder window, click Second Principal Stress 1.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Material Switch 1 list, choose Orthotropic Material.

4 In the Second Principal Stress 1 toolbar, click Plot.
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