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Introduction

Ultrasonic flowmeters are used to determine the velocity of the fluid flowing through a 
pipe. The principle is to send an ultrasonic signal across the flow at a skew angle. In case 
of no flow, the transmitting time between the transmitter and the receiver is the same for 
the signals sent in the upstream and the downstream directions. Otherwise, the 
downstream traveling wave moves faster than the one traveling upstream. In many cases 
piezoelectric transducers are used to send and receive the ultrasonic wave.

This tutorial shows how to simulate an ultrasonic flowmeter with piezoelectric transducers 
in the simplified no-flow case. The simulatoin approach is based on the discontinuous 
Galerkin (dG) method which is well suited for acoustically large transient problems. The 
model is a true multiphyiscs problem that involves acoustic-structure interaction and 
piezoelectric effect. The former is modeled with the Elastic Waves, Time Explicit and the 
Pressure Acoustics, Time Explicit physics interfaces coupled through the Pair Acoustic-
Structure Boundary, Time Explicit multiphysics feature. The latter is handled with the 
Piezoelectric Effect, Time Explicit multiphysics feature that couples the Elastic Waves, 
Time Explicit and the Electrostatics physics interfaces. The model takes advantage of a 
geometry assembly and a nonconforming mesh.

Model Definition

The flowmeter consists of a main pipe and a signal pipe of a smaller diameter. The signal 
tube is tilted to the main pipe at the angle α = 45°. The dimensions of the pipes used in 
this tutorial are the same as the ones given in the model Ultrasound Flowmeter with 
Generic Time-of-Flight Configuration. The pipe walls are considered rigid. There are two 
transducers placed at either end of the signal pipe. They operate as a transmitter and a 
receiver. Both transducers are identical and consist of a piezoelectric unit, a matching layer, 
and a damping block. An input voltage signal applied to the transmitter results in the 
mechanical deformation of the piezoelectric transducer, which is due to the inverse 
piezoelectric effect. The mechanical deformation in its turn generates an acoustic wave in 
the fluid. When the acoustic wave reaches the receiver, the inverse process takes place: the 
mechanical load is being converted into an electric signal because of the direct 
piezoelectric effect.

As previously mentioned, this model studies the propagation of the acoustic wave is the 
simplified no-flow condition. Thus the main focus is the interaction between the fluid and 
the solid and the conversion input electric signal - acoustic wave - output electric signal. 
This model solves the full three-dimensional problem with the symmetry condition 
imposed on the sagittal plane of the structure. 
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The transmitter and the receiver can be used interchangeably; therefore, the principles of 
their construction are the same. The main part is a disk made of a piezoelectric material 
(here, PZT-5H) that is used for the conversion between the electric and the mechanical 
waves. Its thickness is taken to be 1/2 of the wavelength.

A direct propagation of the acoustic wave from the piezoelectric material to the fluid will 
result in significant reflections from the solid/fluid interface and, consequently, losses. 
This is due to the impedance mismatch: for water, the characteristic acoustic impedance 

MRayl, and for PZT-5H, MRayl. Therefore, a 1/4 wavelength 
thick matching layer is required to minimize the losses. Its impedance should be close to 
the geometric mean of those of the piezoelectric and the fluid materials, i.e.

 MRayl.

The piezoelectric element is surrounded by a backing layer block (also called damping 
block) at the back. The damping block absorbs the waves radiated from the back face of 
the piezoelectric element. The properties of the used matching and damping materials are 
shown in Table 1 .

TABLE 1:  MATCHING AND DAMPING MATERIAL PROPERTIES

The input signal applied to the transmitter is a harmonic voltage pulse of the amplitude 
V0 = 50 V, the frequency f0 = 2.5 MHz, and duration of 2 μs. The voltage profile is 
depicted in Figure 1.

Part Material Density, 
kg/m3

Longitudinal 
wave speed, 
m/s

Shear wave 
speed, 
m/s

Matching layer Alumina/Epoxy 2280 3400 1920

Damping block Tungsten/Epoxy 6580 1500 775

Zwater 1.5≈ ZPZT 34.5≈

Zmatch ZwaterZPZT= 7.2≈
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Figure 1: Input voltage applied to the transmitter.

Results and Discussion

The propagation of the pressure wave in solid and fluid domains is shown in Figure 2. The 
signal emitted by the transmitter propagates into the fluid at t = 4 μs (upper-left corner). 
The signal reaches the upper wall of the main pipe at t = 6 μs (upper-right corner) and 
propagates further in the signal pipe to the receiver at t = 8 μs (lower-left corner). The 
signal reaches the end of the signal tube and generates an elastic wave in the receiver at 
t = 10 μs (lower-right corner).

The elastic wave in the receiver piezoelectric element is converted into an electric signal. 
In Figure 3 you can see the profiles of the input voltage applied to the transducer and the 
output electric signal read on the receiver.
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Figure 2: Propagation of the acoustic pressure signal at 4 time steps.
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Figure 3: Input and output electric signals as functions of time.

Notes About the COMSOL Implementation

G E O M E T R Y  A N D  M E S H

The model geometry is an assembly and therefore parts of the geometry are separated 
from one another and connected via Identity Boundary Pairs. The nodes of the 
generated mesh elements do not have to match on either side for the pairs thus making 
the mesh non-conformal. For wave propagation problems, feasible results are achieved 
when the mesh resolves the wavelengths of the propagating waves. In the solid domains, 
the minimal wavelength is given by the shear wave speed. Thus materials with lower speed 
of sound require finer mesh than those with higher speed of sound (compare the shear 
wave speeds for the matching and the damping material given in Table 1). The use of a 
non-conformal mesh in this tutorial makes it possible to reduce the number of DOFs 
solved for in the model. 
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Application Library path: Acoustics_Module/Ultrasound/
flow_meter_piezoelectric_transducers

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 Click Done.

Load the parameters that define the geometry and the physical properties of the system.

G L O B A L  D E F I N I T I O N S

Geometry Parameters
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
flow_meter_piezoelectric_transducers_geometry_parameters.txt.

5 In the Label text field, type Geometry Parameters.

Model Parameters
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
flow_meter_piezoelectric_transducers_model_parameters.txt.

5 In the Label text field, type Model Parameters.

Import the model geometry sequence from the geometry file. The instructions to the 
geometry are found in the appendix at the end of this document.
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G E O M E T R Y  1

1 In the Geometry toolbar, click Insert Sequence and choose Insert Sequence.

2 Browse to the model’s Application Libraries folder and double-click the file 
flow_meter_piezoelectric_transducers_geom_sequence.mph.

3 In the Geometry toolbar, click Build All.

Specify the driving voltage signal applied to the transmitter.

G L O B A L  D E F I N I T I O N S

Rectangle 1 (rect1)
1 In the Home toolbar, click Functions and choose Global>Rectangle.

2 In the Settings window for Rectangle, locate the Parameters section.

3 In the Lower limit text field, type 0.5e-6.

4 In the Upper limit text field, type 1.5e-6.

5 Click to expand the Smoothing section. In the Size of transition zone text field, type 1e-
6.

6 Click Plot.
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Analytic 1 (an1)
1 In the Home toolbar, click Functions and choose Global>Analytic.

2 In the Settings window for Analytic, type Vin in the Function name text field.

3 Locate the Definition section. In the Expression text field, type V0*sin(2*pi*f0*t)*
rect1(t).

4 In the Arguments text field, type t.

5 Locate the Units section. In the Function text field, type V.

6 In the table, enter the following settings:

7 Locate the Plot Parameters section. In the table, enter the following settings:

8 Click Plot.

The input electric signal should look like the one in Figure 1.

Create selections to simplify the model setup.

D E F I N I T I O N S

Water
1 In the Definitions toolbar, click Explicit.

2 Select Domains 1–3 only.

3 In the Settings window for Explicit, type Water in the Label text field.

PZT
1 In the Definitions toolbar, click Explicit.

2 Select Domains 5 and 9 only.

3 In the Settings window for Explicit, type PZT in the Label text field.

Matching
1 In the Definitions toolbar, click Explicit.

2 Select Domains 6 and 7 only.

3 In the Settings window for Explicit, type Matching in the Label text field.

Argument Unit

t s

Argument Lower limit Upper limit Unit

t 0 10*T0 s
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Backing
1 In the Definitions toolbar, click Explicit.

2 Select Domains 4 and 8 only.

3 In the Settings window for Explicit, type Backing in the Label text field.

Symmetry
1 In the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, locate the Input Entities section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundaries 2, 6, 16, 22, 30, 33, 40, 46, and 55 only.

5 In the Label text field, type Symmetry.

Solid
1 In the Definitions toolbar, click Union.

2 In the Settings window for Union, type Solid in the Label text field.

3 Locate the Input Entities section. Under Selections to add, click Add.

4 In the Add dialog box, in the Selections to add list, choose PZT, Matching, and Backing.

5 Click OK.

Define a coordinate system that corresponds to the piezoelectric material orientation: the 
Z-axis of the piezoelectric crystal points along the signal tube axis.

Transducer Coordinate System
1 In the Definitions toolbar, click Coordinate Systems and choose Base Vector System.

2 In the Settings window for Base Vector System, locate the Base Vectors section.

3 In the table, enter the following settings:

4 Find the Simplifications subsection. Select the Assume orthonormal check box.

5 In the Label text field, type Transducer Coordinate System.

Now, proceed to setting up the physics. Note that the model geometry is an assembly and 
therefore each physics interface automatically imposes the Continuity boundary condition 
on all boundary pairs.

x y z

x1 cos(alpha) 0 -sin(alpha)

x3 sin(alpha) 0 cos(alpha)
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C O M P O N E N T  1  ( C O M P 1 )

In the Home toolbar, click Windows and choose Add Physics.

A D D  P H Y S I C S

1 Go to the Add Physics window.

2 In the tree, select Acoustics>Pressure Acoustics>Pressure Acoustics, Time Explicit (pate).

3 Click Add to Selection in the window toolbar.

P R E S S U R E  A C O U S T I C S ,  T I M E  E X P L I C I T  ( P A T E )

1 In the Settings window for Pressure Acoustics, Time Explicit, locate the Domain Selection 
section.

2 From the Selection list, choose Water.

A D D  P H Y S I C S

1 Go to the Add Physics window.

2 In the tree, select Acoustics>Elastic Waves>Elastic Waves, Time Explicit (elte).

3 Click Add to Selection in the window toolbar.

E L A S T I C  W A V E S ,  T I M E  E X P L I C I T  ( E L T E )

1 In the Settings window for Elastic Waves, Time Explicit, locate the Domain Selection 
section.

2 From the Selection list, choose Solid.

A D D  P H Y S I C S

1 Go to the Add Physics window.

2 In the tree, select AC/DC>Electric Fields and Currents>Electrostatics (es).

3 Click Add to Selection in the window toolbar.

E L E C T R O S T A T I C S  ( E S )

1 In the Settings window for Electrostatics, locate the Domain Selection section.

2 From the Selection list, choose PZT.

P R E S S U R E  A C O U S T I C S ,  T I M E  E X P L I C I T  ( P A T E )

Impedance 1
1 In the Model Builder window, under Component 1 (comp1) right-click Pressure Acoustics,

Time Explicit (pate) and choose Impedance.
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2 Select Boundaries 1 and 19 only.

Symmetry 1
1 In the Physics toolbar, click Boundaries and choose Symmetry.

2 In the Settings window for Symmetry, locate the Boundary Selection section.

3 From the Selection list, choose Symmetry.

E L A S T I C  W A V E S ,  T I M E  E X P L I C I T  ( E L T E )

In the Model Builder window, under Component 1 (comp1) click Elastic Waves,

Time Explicit (elte).

Piezoelectric Material 1
1 In the Physics toolbar, click Domains and choose Piezoelectric Material.

2 In the Settings window for Piezoelectric Material, locate the Domain Selection section.

3 From the Selection list, choose PZT.

Low-Reflecting Boundary 1
1 In the Physics toolbar, click Boundaries and choose Low-Reflecting Boundary.

2 Select Boundaries 21 and 52 only.

Symmetry 1
1 In the Physics toolbar, click Boundaries and choose Symmetry.

2 In the Settings window for Symmetry, locate the Boundary Selection section.

3 From the Selection list, choose Symmetry.

Elastic Waves, Time Explicit Model 1
1 In the Model Builder window, click Elastic Waves, Time Explicit Model 1.

2 In the Settings window for Elastic Waves, Time Explicit Model, locate the 
Linear Elastic Material section.

3 From the Specify list, choose Pressure-wave and shear-wave speeds.

Damping 1
1 In the Physics toolbar, click Attributes and choose Damping.

2 In the Settings window for Damping, locate the Domain Selection section.

3 From the Selection list, choose Matching.

4 Locate the Damping Settings section. From the Input parameters list, choose 
Damping ratios.

5 In the f1 text field, type 0.99*f0.
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6 In the ζ1 text field, type 0.01.

7 In the f2 text field, type 1.01*f0.

8 In the ζ2 text field, type 0.01.

Elastic Waves, Time Explicit Model 1
In the Model Builder window, click Elastic Waves, Time Explicit Model 1.

Damping 2
1 In the Physics toolbar, click Attributes and choose Damping.

2 In the Settings window for Damping, locate the Domain Selection section.

3 From the Selection list, choose Backing.

4 Locate the Damping Settings section. From the Input parameters list, choose 
Damping ratios.

5 In the f1 text field, type 0.99*f0.

6 In the ζ1 text field, type 0.025.

7 In the f2 text field, type 1.01*f0.

8 In the ζ2 text field, type 0.025.

Piezoelectric Material 1
1 In the Model Builder window, under Component 1 (comp1)>Elastic Waves,

Time Explicit (elte) click Piezoelectric Material 1.

2 In the Settings window for Piezoelectric Material, locate the Coordinate System Selection 
section.

3 From the Coordinate system list, choose Transducer Coordinate System (sys2).

Mechanical Damping 1
1 In the Physics toolbar, click Attributes and choose Mechanical Damping.

2 In the Settings window for Mechanical Damping, locate the Damping Settings section.

3 From the Input parameters list, choose Damping ratios.

4 In the f1 text field, type 0.99*f0.

5 In the ζ1 text field, type 0.005.

6 In the f2 text field, type 1.01*f0.

7 In the ζ2 text field, type 0.005.

E L E C T R O S T A T I C S  ( E S )

In the Model Builder window, under Component 1 (comp1) click Electrostatics (es).
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Charge Conservation, Piezoelectric 1
1 In the Physics toolbar, click Domains and choose Charge Conservation, Piezoelectric.

2 In the Settings window for Charge Conservation, Piezoelectric, locate the Domain Selection 
section.

3 From the Selection list, choose PZT.

Ground 1
1 In the Physics toolbar, click Boundaries and choose Ground.

2 Select Boundaries 29 and 57 only.

Electric Potential 1
1 In the Physics toolbar, click Boundaries and choose Electric Potential.

2 Select Boundary 32 only.

3 In the Settings window for Electric Potential, locate the Electric Potential section.

4 In the V0 text field, type Vin(t).

Floating Potential 1
1 In the Physics toolbar, click Boundaries and choose Floating Potential.

2 Select Boundary 54 only.

3 In the Settings window for Floating Potential, locate the Floating Potential section.

4 Select the Floating potential group check box.

Symmetry Plane 1
1 In the Physics toolbar, click Boundaries and choose Symmetry Plane.

2 In the Settings window for Symmetry Plane, locate the Boundary Selection section.

3 From the Selection list, choose Symmetry.

Add multiphysics coupling features.

M U L T I P H Y S I C S

Piezoelectric Effect, Time Explicit 1 (pzete1)
In the Physics toolbar, click Multiphysics Couplings and choose Domain>

Piezoelectric Effect, Time Explicit.

Pair Acoustic-Structure Boundary, Time Explicit 1 (aspte1)
1 In the Physics toolbar, click Multiphysics Couplings and choose Boundary>

Pair Acoustic-Structure Boundary, Time Explicit.
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2 In the Settings window for Pair Acoustic-Structure Boundary, Time Explicit, locate the 
Pair Selection section.

3 Under Pairs, click Add.

4 In the Add dialog box, in the Pairs list, choose Identity Boundary Pair 1 (ap1) and 
Identity Boundary Pair 2 (ap2).

5 Click OK.

Now, set up the materials.

M A T E R I A L S

In the Home toolbar, click Windows and choose Add Material from Library.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-in>Water, liquid.

3 Click Add to Component in the window toolbar.

4 In the tree, select Built-in>Lead Zirconate Titanate (PZT-5H).

5 Click Add to Component in the window toolbar.

M A T E R I A L S

Lead Zirconate Titanate (PZT-5H) (mat2)
1 In the Settings window for Material, locate the Geometric Entity Selection section.

2 From the Selection list, choose PZT.

Matching Material
1 In the Model Builder window, right-click Materials and choose Blank Material.

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Matching.

4 In the Label text field, type Matching Material.

5 Locate the Material Contents section. In the table, enter the following settings:

Property Variable Value Unit Property group

Pressure-wave 
speed

cp cp_match m/s Pressure-wave and 
shear-wave speeds
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Damping Material
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Backing.

4 In the Label text field, type Damping Material.

5 Locate the Material Contents section. In the table, enter the following settings:

Add absorbing layers (sponge layers) to truncate the computational domain.

D E F I N I T I O N S

Absorbing Layer 1 (ab1)
1 In the Definitions toolbar, click Absorbing Layer.

2 Select Domains 1 and 3 only.

Create a mesh. The mesh should be fine enough to resolve the shortest wavelength in each 
material. Note that the mesh element nodes on one side of the boundary pairs do not 
match with those on the other side. As a result, the mesh elements adjacent to the pairs 
have different size, which helps to reduce the number of DOFs in the model.

M E S H  1

Free Triangular 1
1 In the Mesh toolbar, click Boundary and choose Free Triangular.

2 Select Boundaries 32, 35, 37, 42, 43, and 54 only.

Size 1
1 Right-click Free Triangular 1 and choose Size.

Shear-wave speed cs cs_match m/s Pressure-wave and 
shear-wave speeds

Density rho rho_match kg/m³ Basic

Property Variable Value Unit Property group

Pressure-wave speed cp cp_damp m/s Pressure-wave and 
shear-wave speeds

Shear-wave speed cs cs_damp m/s Pressure-wave and 
shear-wave speeds

Density rho rho_damp kg/m³ Basic

Property Variable Value Unit Property group
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2 Select Boundaries 32 and 54 only.

3 In the Settings window for Size, locate the Element Size section.

4 Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type cs_pzt/f0/2.

Size 2
1 In the Model Builder window, right-click Free Triangular 1 and choose Size.

2 Select Boundaries 35, 37, 42, and 43 only.

3 In the Settings window for Size, locate the Element Size section.

4 Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type cs_match/f0/2.

Swept 1
1 In the Mesh toolbar, click Swept.

2 In the Settings window for Swept, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose PZT.

Distribution 1
1 Right-click Swept 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 4.

Swept 2
1 In the Mesh toolbar, click Swept.

2 In the Settings window for Swept, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Matching.

Distribution 1
1 Right-click Swept 2 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 2.
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Free Tetrahedral 1
1 In the Mesh toolbar, click Free Tetrahedral.

When modeling using physics interfaces that are based on the DG method, it is 
important to avoid small mesh elements, since they control the time steps taken by the 
solver. Use the Element Quality Optimization functionality available for the tetrahedral 
mesh to avoid this. This step is very important.

2 In the Settings window for Free Tetrahedral, click to expand the 
Element Quality Optimization section.

3 From the Optimization level list, choose High.

4 Clear the Avoid too large elements check box.

5 Select the Avoid too small elements check box.

Size 1
1 Right-click Free Tetrahedral 1 and choose Size.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Water.

5 Locate the Element Size section. Click the Custom button.

6 Locate the Element Size Parameters section. Select the Maximum element size check box.

7 In the associated text field, type lam0/1.5.

8 Select the Minimum element size check box.

9 In the associated text field, type lam0/3.

Size 2
1 In the Model Builder window, right-click Free Tetrahedral 1 and choose Size.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Backing.

5 Locate the Element Size section. Click the Custom button.

6 Locate the Element Size Parameters section. Select the Maximum element size check box.

7 In the associated text field, type cs_damp/f0/1.5.
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8 In the Model Builder window, right-click Mesh 1 and choose Build All.

R O O T

In the Home toolbar, click Windows and choose Add Study.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies>

Time Dependent.

3 Click Add Study in the window toolbar.

S T U D Y  1

Step 1: Time Dependent
1 In the Settings window for Time Dependent, locate the Study Settings section.

2 In the Output times text field, type range(0, T0/5, 30*T0).

3 Click to expand the Values of Dependent Variables section. Find the Store fields in output 
subsection. From the Settings list, choose For selections.

4 Under Selections, click Add.

Store the results on the symmetry plane only.
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5 In the Add dialog box, select Symmetry in the Selections list.

6 Click OK.

Step 1: Time Dependent
1 In the Model Builder window, click Step 1: Time Dependent.

2 In the Home toolbar, click Compute.

Plot the pressure in the fluid and solid domains and inspect the propagating acoustic signal 
at different times to get the results like the ones in Figure 2.

R E S U L T S

Acoustic and Elastic Pressure
1 In the Settings window for 3D Plot Group, type Acoustic and Elastic Pressure in 

the Label text field.

2 Click to expand the Title section. From the Title type list, choose Label.

Selection 1
1 In the Model Builder window, expand the Acoustic and Elastic Pressure node.

2 Right-click Surface and choose Selection.

3 In the Settings window for Selection, locate the Selection section.

4 From the Selection list, choose Symmetry.

Surface 2
1 Right-click Surface and choose Duplicate.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1 (comp1)>Elastic Waves,

Time Explicit>Stress>elte.p - Pressure - Pa.

3 Click to expand the Inherit Style section. From the Plot list, choose Surface.

4 In the Acoustic and Elastic Pressure toolbar, click Plot.

Plot the driving voltage applied to the transmitter and the voltage signal read on the 
receiver. The result should look like the one in Figure 3.

Sent and Received Signals
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Sent and Received Signals in the 
Label text field.

3 Locate the Data section. From the Time selection list, choose Interpolated.
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4 In the Times (s) text field, type range(0, T0/20, 30*T0).

Point Graph 1
1 Right-click Sent and Received Signals and choose Point Graph.

2 Select Point 39 only.

3 In the Settings window for Point Graph, locate the y-Axis Data section.

4 In the Expression text field, type V/V0.

5 Click to expand the Quality section. Click to expand the Legends section. Select the 
Show legends check box.

6 From the Legends list, choose Manual.

7 In the table, enter the following settings:

Point Graph 2
1 Right-click Point Graph 1 and choose Duplicate.

2 In the Settings window for Point Graph, locate the Selection section.

3 Click Clear Selection.

4 Select Point 73 only.

5 Locate the Legends section. In the table, enter the following settings:

Sent and Received Signals
1 In the Model Builder window, click Sent and Received Signals.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the Two y-axes check box.

4 In the table, select the Plot on secondary y-axis check box for Point Graph 2.

5 Locate the Legend section. From the Position list, choose Upper middle.

6 In the Sent and Received Signals toolbar, click Plot.

Legends

Relative driving voltage

Legends

Relative received voltage
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Appendix — Geometry Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 Click Done.

G L O B A L  D E F I N I T I O N S

Geometry Parameters
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
flow_meter_piezoelectric_transducers_geometry_parameters.txt.

5 In the Label text field, type Geometry Parameters.

Model Parameters
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
flow_meter_piezoelectric_transducers_model_parameters.txt.

5 In the Label text field, type Model Parameters.

G E O M E T R Y  1

Cylinder 1 (cyl1)
1 In the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Axis section.

3 From the Axis type list, choose x-axis.

4 Locate the Size and Shape section. In the Radius text field, type D/2.

5 In the Height text field, type L.
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6 Click to expand the Layers section. In the table, enter the following settings:

7 Clear the Layers on side check box.

8 Select the Layers on bottom check box.

9 Select the Layers on top check box.

Cylinder 2 (cyl2)
1 In the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type D_transducer/2.

4 In the Height text field, type L_transducer.

5 Locate the Position section. In the x text field, type L/2.

6 In the z text field, type -L_transducer/2.

Cylinder 3 (cyl3)
1 In the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type D_transducer/2.

4 In the Height text field, type L_matching.

5 Locate the Position section. In the x text field, type L/2.

6 In the z text field, type L_transducer/2.

Cylinder 4 (cyl4)
1 In the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type D_transducer/4.

4 In the Height text field, type L_piezo.

5 Locate the Position section. In the x text field, type L/2.

6 In the z text field, type L_transducer/2+L_matching.

Cylinder 5 (cyl5)
1 In the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

Layer name Thickness (m)

Layer 1 0.5*D
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3 In the Radius text field, type D_transducer/2.

4 In the Height text field, type 2*L_piezo.

5 Locate the Position section. In the x text field, type L/2.

6 In the z text field, type L_transducer/2+L_matching.

Difference 1 (dif1)
1 In the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 Select the object cyl5 only.

3 In the Settings window for Difference, locate the Difference section.

4 Find the Objects to subtract subsection. Click to select the Activate Selection toggle 
button.

5 Select the object cyl4 only.

6 Select the Keep objects to subtract check box.

Copy 1 (copy1)
1 In the Geometry toolbar, click Transforms and choose Copy.

2 Select the objects cyl3, cyl4, and dif1 only.

3 In the Settings window for Copy, locate the Displacement section.

4 In the z text field, type -L_transducer.

Mirror 1 (mir1)
1 In the Geometry toolbar, click Transforms and choose Mirror.

2 Select the objects copy1(1), copy1(2), and copy1(3) only.

3 In the Settings window for Mirror, locate the Point on Plane of Reflection section.

4 In the z text field, type -L_transducer/2.

Rotate 1 (rot1)
1 In the Geometry toolbar, click Transforms and choose Rotate.

2 Select the objects cyl2, cyl3, cyl4, dif1, mir1(1), mir1(2), and mir1(3) only.

3 In the Settings window for Rotate, locate the Rotation section.

4 From the Axis type list, choose y-axis.

5 In the Angle text field, type alpha.

6 Locate the Point on Axis of Rotation section. In the x text field, type L/2.

Work Plane 1 (wp1)
1 In the Geometry toolbar, click Work Plane.
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2 In the Settings window for Work Plane, locate the Plane Definition section.

3 From the Plane list, choose xz-plane.

Partition Objects 1 (par1)
1 In the Geometry toolbar, click Booleans and Partitions and choose Partition Objects.

2 Click the Select Box button in the Graphics toolbar.

3 Click in the Graphics window and then press Ctrl+A to select all objects.

4 In the Settings window for Partition Objects, locate the Partition Objects section.

5 From the Partition with list, choose Work plane.

Delete Entities 1 (del1)
1 In the Model Builder window, right-click Geometry 1 and choose Delete Entities.

2 In the Settings window for Delete Entities, locate the Entities or Objects to Delete section.

3 From the Geometric entity level list, choose Domain.

4 On the object par1(1), select Domains 1, 3, and 5 only.

5 On the object par1(2), select Domain 1 only.

6 On the object par1(3), select Domain 1 only.

7 On the object par1(4), select Domain 1 only.

8 On the object par1(5), select Domain 1 only.

9 On the object par1(6), select Domain 1 only.

10 On the object par1(7), select Domain 1 only.

11 On the object par1(8), select Domain 1 only.

Union 1 (uni1)
1 In the Geometry toolbar, click Booleans and Partitions and choose Union.

2 Select the objects del1(1) and del1(2) only.

Delete Entities 2 (del2)
1 Right-click Geometry 1 and choose Delete Entities.

2 On the object uni1, select Boundaries 13, 14, 16, and 19 only.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click 

Form Union (fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly section.
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3 From the Action list, choose Form an assembly.

Make sure to select the Create imprints check box to create an assembly with still 
matching surface pairs. This will eliminate the use of fallback and thus increase the 
performance.

4 Select the Create imprints check box.

5 Click Build Selected.

Ignore Edges 1 (ige1)
1 In the Geometry toolbar, click Virtual Operations and choose Ignore Edges.

2 On the object fin, select Edges 19, 20, 23, and 27 only.

3 In the Settings window for Ignore Edges, click Build Selected.
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