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Introduction

The propagation and response of acoustic signals in pipe systems is used to detect leaks and
deformations in the pipes. This is, for example, relevant in the oil and gas industry or in
water delivery piping systems. This model uses the pipe acoustics interfaces to model the
propagation of acoustic waves in a pipe system using a 1D model. The 1D model is
coupled to a detailed 3D model of a junction and a bend. In the 3D domains, a pressure
acoustics interface is used. The 3D domains could represent any complex geometry like
valves, reservoirs, or pipe expansions where the 1D model is not valid. The tutorial sets up
both a transient and a frequency-domain version of the model. A Pressure Acoustics,
Boundary Mode interface is used to compute and analyze the propagating modes in the
pipe cross section, as only plane propagating modes are supported in the 1D pipe

formulation.

Note: The application requires the Acoustics Module.

Model Definition

Pipe acoustics is used to model the propagation and response of acoustic signals in the long
pipe segments using a 1D model. This interface is only valid for the analysis of plane wave
modes. The 3D structures are modeled using pressure acoustics. To ensure correct
coupling to the 1D model, the Acoustics-Pipe Acoustics Connection multiphysics
coupling is used. The coupling requires a straight pipe segment connected to the 3D

structure and it is only valid when the background fluid velocity speed is zero.

For a given pipe system in quiescent conditions (ug = 0), constant background pressure,

and completely rigid walls, the governing equations of the pipe system become:

pA%—‘; = ~A(V,p-e)-1,Z+AF e, (1)
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where p is the fluid density, A is the cross-sectional area of the pipe, u is the area-averaged
acoustic velocity, which is defined in the tangential direction u = ue;, where ey is the
tangential vector, V, is the tangential derivative, Ty, is the tangential wall drag force, Z is

the inner perimeter of the pipe, F is a volume force applied to the pipe, and c is the
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effective speed of sound in the pipe (in a rigid pipe this has the same value as the isentropic

bulk speed of sound).

The pipe acoustics domain (pipe domain) is connected to the pressure acoustics domain
(acoustic domain) through the Acoustics-Pipe Acoustics Connection multiphysics
coupling. This coupling guarantees continuity of pressure and velocity between both
domains through the equations:

1

Ppipe = sztdS 3
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Here, ppipe is the pipe pressure at the connection point, A is the total arca of the connected
acoustic boundary, p; is the total pressure in the acoustic domain and S is the connected
acoustic boundary, n is the vector normal to the boundary, and wp;p,e is the pipe velocity
at the connection point. The possible dipole domain source, qq, is zero in this model.

The geometry of the pipe system, including both 1D and 3D domains, is shown in
Figure 1.

Figure 1: Model geometry.
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The model has two separated 3D domains, shown in Figure 2, which will be included in

the model using the Pressure Acoustics interface.

Figure 2: T-junction and bend.

The pipe ends, not connected to the Pressure Acoustics domains, have an end impedance
condition of an infinite pipe, allowing the acoustic waves to exit the system. In our case,

this simply corresponds to the characteristic specific impedance.
zZ end = cp (5)

The points where this impedance condition is imposed can be seen in Figure 3.
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Figure 3: The pipe end impedance conditions are applied to the open ends of the pipe system.

The tutorial sets up both a transient and a frequency domain version of the model. Under
the transient analysis, a wave train is created through the imposition of a volume force on
one end of the pipe system. The force is defined through an analytical function created
under the Definitions node. Figure 4 shows a plot of the analytical function used in the

model to generate the wave train.
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Figure 4: Imposed volume force as divect output of the plot functionality when defining an
analytic function.

At last, a Pressure Acoustics, Boundary Mode interface is used to solve for the propagation
modes on the pipe cross section at the driving frequency to check if higher order modes
can propagate. This is easy and quick to check by solving an eigenvalue problem. The
cigenvalue solver computes a specified number of solutions {pj, A;j} to the equation

1.2 kc
_EV pt_fpt = 0 (6)
with
2 o\ .2 .
p.=p, kcq = (E) _kn ,—lkn =X (7)

where py is the total pressure, ke is the in-plane wave number, @ is the angular frequency,
k,, is the out-of-plane wave number, and A = —ik,, is the cigenvalue.
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Results and Discussion

Figure 5 shows the transient pressure distribution in the pipe system at various times. The

figure shows the continuity in the pressure at the Acoustics-Pipe Acoustics Connection
points.
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Figure 5: Evolution of the Pressurve in the pipe system at vavious times.

The initial wave train travels through the pipe system producing reflections as the wave
finds discontinuities at the T-junction and the bend. Figure 6 shows the pressure at
different points of the pipe system. The reflected wave from the T-junction can be
observed in Point A after 0.09 s and the reflected wave coming from the pipe bend can be
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seen after 0.13 s. By updating the parameter rbend, that controls the bending radius of
the bend, to 160 cm this reflection can be greatly reduced.
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Figure 6: Pressuve at three points in the pipe system (Point B and Point C are offSet on the y-
axis for clarity).

This model can be updated to consider the compressibility of the pipe section based on
the elastic modulus and thickness of the pipe wall. Analyzing the pipe system response in
the time domain allows us to easily identify reflections or changes in the acoustic response
caused by changes in pipe section or wall thickness and these changes can be linked to

corrosion or leaks in the pipe system.

The problem can be solved in the frequency domain; the results will be equivalent to
exciting the system in the time domain with a sine wave until you reach steady state. By

solving the model in the frequency domain, a quick and inexpensive computation, insight
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into the pressure distribution for a given input can be obtained. Figure 7 shows the

response of the pipe system under an excitation with a frequency of 120 Hz.

freq =120 Hz Pressure (Pa)

Figure 7: Pressuve distvibution in the frequency domain at 120 Hz.

The Pressure Acoustics, Boundary Mode interface solves for the propagating and
nonpropagating modes on the pipe cross section at the driving frequency to check if higher
order modes propagate at the given frequency or if it just the plane wave component. A

mode with a real wave number will propagate, while a mode with imaginary wave number
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will not be able to propagate. Figure 8 shows the pressure distribution for the mode (2,0)
which cannot propagate at 120 Hz.
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Figure 8: Pressure distvibution for mode (2,0), which cannot propagate at 120 Hz.

This tutorial presents an introduction to the modeling of pipe systems and a selection of
the different analysis techniques that can be applied to them. Further details like the
compressibility of the pipes or more complex 3D domains can be added to increase the
fidelity of the model.

Application Library path: Acoustics_Module/Tutorials,_Pipe_Acoustics/
acoustics_pipe_system

Modeling Instructions

From the File menu, choose New.

NEW
In the New window, click Model Wizard.
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MODEL WIZARD
I In the Model Wizard window, click [l 3D.

2 Click E,/ Done.

GEOMETRY |

With this, we import a fully parametric sequence that defines the geometry of the model.
The parameters used to define the geometry can be modified and updated at any point of
the tutorial. Detailed instructions for setting up the geometry are found at the appendix

at the end of the instructions.

I In the Geometry toolbar, click Insert Sequence and choosc Insert Sequence.

2 Browse to the model’s Application Libraries folder and double-click the file
acoustics_pipe_system_geom_sequence.mph.

3 In the Geometry toolbar, click [E2 Build All.

The image should look like that in Figure 1.

GLOBAL DEFINITIONS
Geometry
I In the Model Builder window, under Global Definitions click Parameters I.
2 In the Settings window for Parameters, type Geometry in the Label text field.
This group includes all the parameters that define the geometry of the model
Model Parameters
I In the Home toolbar, click Pi Parameters and choosec Add>Parameters.
2 In the Settings window for Parameters, type Model Parameters in the Label text field.
3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file
acoustics_pipe_system_parameters.txt.

This group includes all the parameters that define the model like material properties,

frequencies of interest, and the total time of the analysis.

DEFINITIONS

Rectangle | (rectl)
I In the Model Builder window, expand the Component | (comp1)>Definitions node.

2 Right-click Definitions and choose Functions>Rectangle.

3 In the Settings window for Rectangle, locate the Parameters section.
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4 In the Lower limit text field, type 0.5*TO0.

5 In the Upper limit text field, type 3*TO.

6 Click to expand the Smoothing section. In the Size of transition zone text field, type TO.

Volume force

I In the Home toolbar, click TCO Functions and choose Local>Analytic.

2 In the Settings window for Analytic, type Volume force in the Label text field.

3 In the Function name text field, type volforc.

4 Locate the Definition section. In the Expression text field, type rect1 (t[1/s])*sin(2*
pi*fO*t).

5 In the Arguments text field, type t.

6 Locate the Units section. In the table, enter the following settings:

Argument  Unit

t S

7 In the Function text field, type N/m~3.

8 Locate the Plot Parameters section. In the table, enter the following settings:

Argument Lower limit Upper limit Unit

t 0 3.5*T0 s

9 Click Plot.
The image should look like that in Figure 4.
ID Pipes
I In the Definitions toolbar, click g Explicit.
2 In the Settings window for Explicit, type 1D Pipes in the Label text field.
3 Locate the Input Entities section. From the Geometric entity level list, choose Edge.
4 Sclect Edges 1, 2, 20, 37, and 60 only.
Pipe Ends
I In the Definitions toolbar, click " Explicit.
2 In the Settings window for Explicit, type Pipe Ends in the Label text field.
3 Locate the Input Entities section. From the Geometric entity level list, choose Point.

4 Seclect Points 1, 11, and 38 only.
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ADD MATERIAL

I' In the Home toolbar, click %5 Add Material to open the Add Material window.
Go to the Add Material window.

In the tree, select Built-in>Water, liquid.

Click Add to Component in the window toolbar.

Click Add to Component in the window toolbar.

Click Add to Component in the window toolbar.

N o0 it A W N

In the Home toolbar, click £37 Add Material to close the Add Material window.

MATERIALS

Water, liquid | (mat2)
I In the Model Builder window, under Component | (compl)>Materials click Water,
liquid I (mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.
3 From the Geometric entity level list, choose Edge.

4 From the Selection list, choose ID Pipes.

Water, liquid 2 (mat3)

I In the Model Builder window, click Water, liquid 2 (mat3).

2 In the Settings window for Material, locate the Geometric Entity Selection section.
3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 1 only.

ADD PHYSICS
I In the Home toolbar, click i Add Physics to open the Add Physics window.

Go to the Add Physics window.

In the tree, select Acoustics>Pipe Acoustics>Pipe Acoustics, Transient (patd).

Click Add to Component | in the window toolbar.

In the tree, select Acoustics>Pressure Acoustics>Pressure Acoustics, Transient (actd).

Click Add to Component | in the window toolbar.

N o0 it AW N

In the tree, sclect Acoustics>Pressure Acoustics>Pressure Acoustics,

Boundary Mode (acbm).

[--]

Click Add to Component | in the window toolbar.

9 In the tree, select Acoustics>Pipe Acoustics>Pipe Acoustics, Frequency Domain (pafd).
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10 Click Add to Component | in the window toolbar.

Il In the tree, select Acoustics>Pressure Acoustics>Pressure Acoustics,
Frequency Domain (acpr).

12 Click Add to Component | in the window toolbar.

13 In the Home toolbar, click i Add Physics to close the Add Physics window.

PIPE ACOUSTICS, TRANSIENT (PATD)
I In the Model Builder window, under Component | (compl) click Pipe Acoustics,

Transient (patd).
2 In the Settings window for Pipe Acoustics, Transient, locate the Edge Selection scction.
3 From the Selection list, choose ID Pipes.
4 Locate the Transient Solver Settings section. In the fi 5y sol text field, type f0.
Pipe Properties |

I In the Model Builder window, under Component | (compl)>Pipe Acoustics,

Transient (patd) click Pipe Properties I.
2 In the Settings window for Pipe Properties, locate the Pipe Shape section.
3 From the list, choose Circular.
4 In the d; text field, type Di.
Pipe Properties 2
I In the Physics toolbar, click (F5 Edges and choose Pipe Properties.
2 Select Edge 20 only.
3 In the Settings window for Pipe Properties, locate the Pipe Shape section.
4 From the list, choose Circular.
5 In the d; text field, type Di*2/3.
End Impedance |
I In the Physics toolbar, click - Points and choose End Impedance.
2 In the Settings window for End Impedance, locate the Point Selection section.
3 From the Selection list, choose Pipe Ends.

Volume Force |
I In the Physics toolbar, click (5 Edges and choose Volume Force.

2 Select Edge 1 only.

3 In the Settings window for Velume Force, locate the Volume Force section.
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4 Specify the F vector as

volforc(t) x

0 y
0 z

PRESSURE ACOUSTICS, TRANSIENT (ACTD)
I In the Model Builder window, under Component | (compl) click Pressure Acoustics,

Transient (actd).

2 In the Settings window for Pressure Acoustics, Transient, locate the

Transient Solver and Mesh Settings scction.

3 In the fa5 S0l text field, type fO0.

PRESSURE ACOUSTICS, BOUNDARY MODE (ACBM)
I In the Model Builder window, under Component | (compl) click Pressure Acoustics,

Boundary Mode (acbm).

2 In the Settings window for Pressure Acoustics, Boundary Mode, locate the

Boundary Selection scction.
| g
3 Click 7]} Clear Selection.

4 Select Boundary 1 only.

PIPE ACOUSTICS, FREQUENCY DOMAIN (PAFD)
I In the Model Builder window, under Component I (compl) click Pipe Acoustics,
Frequency Domain (pafd).

2 In the Settings window for Pipe Acoustics, Frequency Domain, locate the Edge Selection

section.
3 From the Selection list, choose ID Pipes.
Pipe Properties |

I In the Model Builder window, under Component I (compl)>Pipe Acoustics,

Frequency Domain (pafd) click Pipe Properties |I.
2 In the Settings window for Pipe Properties, locate the Pipe Shape section.
3 From the list, choose Circular.
4 In the d; text field, type Di.

Pipe Properties 2
I In the Physics toolbar, click (= Edges and choose Pipe Properties.
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2 Select Edge 20 only.

3 In the Settings window for Pipe Properties, locate the Pipe Shape section.

4 From the list, choose Circular.

5 In the d; text field, type Di*2/3.

End Impedance |

I In the Physics toolbar, click - Points and choose End Impedance.

2 In the Settings window for End Impedance, locate the Point Selection section.

3 From the Selection list, choose Pipe Ends.

Volume Force |

I In the Physics toolbar, click | Edges and choose Volume Force.
2 Select Edge 1 only.
3 In the Settings window for Velume Force, locate the Volume Force section.

4 Specity the F vector as

1 x
0 vy
0 z

MULTIPHYSICS

Acoustic-Pipe Acoustic Connection | (apcl)
In the Physics toolbar, click ﬁ{'{:}] Multiphysics Couplings and choose Global>Acoustic-

Pipe Acoustic Connection.

Acoustic-Pipe Acoustic Connection 2 (apc2)
I In the Physics toolbar, click ﬁg}] Multiphysics Couplings and choose Global>Acoustic-

Pipe Acoustic Connection.

2 In the Settings window for Acoustic-Pipe Acoustic Connection, locate the

Coupled Interfaces section.
3 From the Acoustics list, choose Pressure Acoustics, Frequency Domain (acpr).

4 From the Pipe acoustics list, choose Pipe Acoustics, Frequency Domain (pafd).

MESH |
In this model, the mesh is set up manually. Proceed by directly adding the desired mesh

component.
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Free Tetrahedral |
In the Mesh toolbar, click €%, Free Tetrahedral.

£,
“ o

Size

In the Model Builder window, click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Maximum element size text field, type
min(lam0/12,Di/2).

5 In the Minimum element size text field, type min(1am0/24,Di/6).

6 Click [ Build Selected.

Edge |

I In the Mesh toolbar, click L Boundary and choose Edge.

2 In the Settings window for Edge, locate the Edge Selection section.

3 From the Selection list, choose ID Pipes.

Free Triangular |

In the Mesh toolbar, click ;i\ Boundary and choose Free Triangular.

2 Select Boundary 1 only.

Size |

I Right-click Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters scction. Select the Maximum element size check box.
5 In the associated text field, type Di/12.

6 Sclect the Minimum element size check box.

7 In the associated text field, type Di/12.

8 Click [E§ Build All

ADD STUDY

I In the Home toolbar, click :\‘j:i Add Study to open the Add Study window.
2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select

Preset Studies for Some Physics Interfaces>Time Dependent.

17 | ACOUSTICS OF A PIPE SYSTEM WITH 3D BEND AND JUNCTION



4 Find the Physics interfaces in study subsection. In the table, clear the Solve check boxes
for Pressure Acoustics, Boundary Mode (acbm), Pipe Acoustics, Frequency Domain (pafd),

and Pressure Acoustics, Frequency Domain (acpr).

5 Find the Multiphysics couplings in study subsection. In the table, clear the Solve check

box for Acoustic-Pipe Acoustic Connection 2 (apc2).
6 Click Add Study in the window toolbar.
7 In the Home toolbar, click :\‘53 Add Study to close the Add Study window.

STUDY |

Step I: Time Dependent
I In the Settings window for Time Dependent, locate the Study Settings section.

In the Output times text field, type range (0,T0/24,Tend).

In the Model Builder window, click Study 1.

Clear the Generate default plots check box.
In the Label text field, type Study 1 - Pipe System Transient.

2
3
4 In the Settings window for Study, locate the Study Settings section.
5
6
7 In the Home toolbar, click = Compute.

ADD STUDY
I In the Home toolbar, click \Ui Add Study to open the Add Study window.
2 Go to the Add Study window.

3 Find the Physics interfaces in study subsection. In the table, clear the Solve check boxes
for Pipe Acoustics, Transient (patd), Pressure Acoustics, Transient (actd), Pipe Acoustics,

Frequency Domain (pafd), and Pressure Acoustics, Frequency Domain (acpr).

4 Find the Multiphysics couplings in study subsection. In the table, clear the Solve check
boxes for Acoustic-Pipe Acoustic Connection | (apcl) and Acoustic-

Pipe Acoustic Connection 2 (apc2).

5 Find the Studies subsection. In the Select Study tree, select
Preset Studies for Selected Physics Interfaces>Mode Analysis.

6 Click Add Study in the window toolbar.

STUDY 2 - MODE ANALYSIS CUT ON/OFF
I In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study 2 - Mode Analysis Cut on/off in the
Label text field.
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3 Locate the Study Settings section. Clear the Generate default plots check box.

Step |: Mode Analysis
I In the Model Builder window, under Study 2 - Mode Analysis Cut on/off click
Step I: Mode Analysis.

In the Settings window for Mode Analysis, locate the Study Settings section.
In the Mode analysis frequency text field, type 0.

Select the Desired number of modes check box.

In the associated text field, type 10.

Select the Search for modes around check box.

N o0 it AW N

In the Home toolbar, click = Compute.

ADD STUDY
I Go to the Add Study window.

2 Find the Physics interfaces in study subsection. In the table, clear the Solve check boxes
for Pipe Acoustics, Transient (patd), Pressure Acoustics, Transient (actd), and

Pressure Acoustics, Boundary Mode (acbm).

3 Find the Multiphysics couplings in study subsection. In the table, clear the Solve check

box for Acoustic-Pipe Acoustic Connection | (apcl).

4 Find the Studies subsection. In the Select Study tree, sclect General Studies>

Frequency Domain.
5 Click Add Study in the window toolbar.
6 In the Home toolbar, click :\‘53 Add Study to close the Add Study window.

STUDY 3 - PIPE SYSTEM FREQUENCY DOMAIN
I In the Model Builder window, click Study 3.

2 In the Settings window for Study, type Study 3 - Pipe System Frequency Domain
in the Label text field.

3 Locate the Study Settings section. Clear the Generate default plots check box.
Step I: Frequency Domain

I In the Model Builder window, under Study 3 - Pipe System Frequency Domain click

Step I: Frequency Domain.
2 In the Settings window for Frequency Domain, locate the Study Settings section.
3 In the Frequencies text field, type 0.

4 In the Home toolbar, click = Compute.
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RESULTS

Surface |

2
3
4
5
6
7

In the Model Builder window, expand the Results node.

Right-click Results>Datasets and choose Surface.

In the Settings window for Surface, locate the Data section.

From the Dataset list, choose Study 2 - Mode Analysis Cut on/off/Solution 2 (sol2).
Locate the Selection section. Click % Paste Selection.

In the Paste Selection dialog box, type 1 in the Selection text field.

Click OK.

Acoustic Pressure (patd)

In the Results toolbar, click .‘i 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Acoustic Pressure (patd) in the
Label text field.

3 Locate the Data section. From the Time (s) list, choose 0.025.

4 Click to expand the Title section. From the Title type list, choose Manual.

5 In the Title text area, type Pressure (Pa).

6 In the Parameter indicator text ficld, type Time= eval(t,s) s.

7 Locate the Color Legend scction. Select the Show maximum and minimum values check
box.

Line |

I Right-click Acoustic Pressure (patd) and choose Line.

2 In the Settings window for Line, click to expand the Range section.

3 Select the Manual color range check box.

4 In the Minimum text field, type -0.005.

5 In the Maximum text ficld, type 0.005.

6 Locate the Coloring and Style section. From the Line type list, choose Tube.

7 In the Tube radius expression text field, type 0.5*patd.dh.

8 Sclect the Radius scale factor check box.

9 From the Color table list, choose Wave.

10 From the Scale list, choose Linear symmetric.
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Deformation |

I Right-click Line I and choose Deformation.
In the Settings window for Deformation, locate the Expression section.

In the X component text field, type 0.

2
3
4 In the Y component text field, type 0.
5 In the Z component text field, type p.
6 Seclect the Description check box.

7

In the associated text field, type 20.
Surface |
I In the Model Builder window, right-click Acoustic Pressure (patd) and choose Surface.
2 In the Settings window for Surface, locate the Expression section.
3 In the Expression text field, type p2.
4 Click to expand the Inherit Style section. From the Plot list, choose Line I.
Deformation |
I Right-click Surface | and choose Deformation.
2 In the Settings window for Deformation, locate the Expression section.
3 In the X component text field, type 0.
4 In the Y component text field, type 0.
5 In the Z component text field, type p2.

Table Annotation |

I In the Model Builder window, right-click Acoustic Pressure (patd) and choose
Table Annotation.

2 In the Settings window for Table Annotation, locate the Data section.
3 From the Source list, choose Local table.

4 In the table, enter the following settings:

x-coordinate y-coordinate z-coordinate Annotation
-L1+Lj/2 0 0 Point A
-Lj/2 -L2 0 Point B
L3 -L4 0 Point C
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5

In the Acoustic Pressure (patd) toolbar, click Plot.

The image should look like that in Figure 5. The image can be animated to show the
propagation of the pressure and its subsequent reflections

Acoustic Pressure in Points

In the Home toolbar, click @1 Add Plot Group and choose ID Plot Group.

2 In the Settings window for ID Plot Group, type Acoustic Pressure in Points in the
Label text field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type Pressure at various points (Pa).

5 Locate the Plot Settings scction. Select the x-axis label check box.

6 In the associated text field, type Time (s).

7 Select the y-axis label check box.

8 In the associated text field, type Pressure (Pa).

9 Locate the Legend section. From the Pesition list, choose Upper left.

Point A

I Right-click Acoustic Pressure in Points and choose Point Graph.

2 In the Settings window for Peint Graph, type Point A in the Label text field.

3 Select Point 2 only.

4 Click to expand the Legends section. Select the Show legends check box.

5 From the Legends list, choose Manual.

6 In the table, enter the following settings:

Legends

Point A

Point B

I In the Model Builder window, right-click Acoustic Pressure in Points and choose
Point Graph.

2 In the Settings window for Peint Graph, type Point B in the Label text field.

3 Select Point 11 only.

4 Locate the y-Axis Data section. In the Expression text field, type p+1[Pa].

5 Locate the Legends section. Select the Show legends check box.

6 From the Legends list, choose Manual.
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7 In the table, enter the following settings:

Legends
Point B (offset by 1 Pa)

Point C
I Right-click Acoustic Pressure in Points and choose Point Graph.

In the Settings window for Peint Graph, type Point C in the Label text field.
Select Point 38 only.
Locate the y-Axis Data section. In the Expression text field, type p+2[Pa].

2
3
4
5 Locate the Legends section. Select the Show legends check box.
6 From the Legends list, choose Manual.

7

In the table, enter the following settings:

Legends
Point C (offset by 2 Pa)

8 In the Acoustic Pressure in Points toolbar, click Plot.
The image should look like that in Figure 6.
Mode Analysis Pressure (acbm)
I In the Home toolbar, click @1 Add Plot Group and choose 2D Plot Group.
2 In the Settings window for 2D Plot Group, typec Mode Analysis Pressure (acbm) in
the Label text field.
Surface |
I Right-click Mode Analysis Pressure (acbm) and choose Surface.
2 In the Settings window for Surface, locate the Expression section.
3 In the Expression text field, type p3.
4 Locate the Coloring and Style section. From the Color table list, choose Wave.
5 From the Scale list, choose Linear symmetric.
The image should look like that in Figure 8.
6 In the Mode Analysis Pressure (acbm) toolbar, click Plot.

Acoustic Pressure (pafd)
I In the Home toolbar, click @1 Add Plot Group and choose 3D Plot Group.
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2 In the Settings window for 3D Plot Group, type Acoustic Pressure (pafd) in the
Label text ficld.

3 Locate the Data section. From the Dataset list, choose Study 3 -
Pipe System Frequency Domain/Solution 3 (sol3).

4 Locate the Title section. From the Title type list, choose Manual.
5 In the Title text area, type Pressure (Pa).
6 In the Parameter indicator text field, type freq =eval(freq,Hz) Hz.
Line |
I Right-click Acoustic Pressure (pafd) and choose Line.
In the Settings window for Line, locate the Expression section.
In the Expression text field, type p4.

Locate the Coloring and Style section. From the Line type list, choose Tube.

2
3
4
5 In the Tube radius expression text field, type 0.5*pafd.dh.
6 Sclect the Radius scale factor check box.

7 From the Color table list, choose Wave.

8

From the Scale list, choose Linear symmetric.
Deformation |
I Right-click Line 1 and choose Deformation.
In the Settings window for Deformation, locate the Expression section.
In the X component text field, type 0.
In the Y component text field, type 0.

2

3

4

5 In the Z component text field, type p4.

6 Locate the Scale section. Select the Scale factor check box.
7

In the associated text field, type 2.
Surface |
I In the Model Builder window, right-click Acoustic Pressure (pafd) and choose Surface.
2 In the Settings window for Surface, locate the Expression section.
3 In the Expression text field, type p5.
4 Locate the Inherit Style section. From the Plot list, choose Line I.

Deformation |
I Right-click Surface | and choose Deformation.
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In the Settings window for Deformation, locate the Expression section.
In the X component text field, type 0.

In the Y component text field, type 0.

In the Z component text field, type p5.

In the Acoustic Pressure (pafd) toolbar, click Plot.

o U1 A W N

The image should look like that in Figure 7.

Appendix — Geometry Modeling Instructions

From the File menu, choose New.

NEW
In the New window, click Model Wizard.

MODEL WIZARD
I In the Model Wizard window, click [l 3D.

2 Click E,/ Done.

GLOBAL DEFINITIONS

Parameters geom sequence
I In the Model Builder window, under Global Definitions click Parameters I.

2 In the Settings window for Parameters, locate the Parameters section.
3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file
acoustics_pipe_system_geom_sequence_parameters.txt.

5 In the Label text field, type Parameters geom sequence.

GEOMETRY 1|

Line Segment | (Isl)

I In the Model Builder window, expand the Component | (compl)>Geometry | node.
2 Right-click Geometry I and choose More Primitives>Line Segment.

3 In the Settings window for Line Segment, locate the Starting Point section.

4 From the Specify list, choose Coordinates.

5 In the x text field, type -Lj.
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6 Locate the Endpoint section. From the Specify list, choose Coordinates.

7 In the x text field, type -L1+Lj/2.

8 Click ™ Build Selected.

Line Segment 2 (Is2)

I In the Geometry toolbar, click €55 More Primitives and choose Line Segment.
In the Settings window for Line Segment, locate the Starting Point section.
From the Specify list, choose Coordinates.

In the x text field, type -L1+Lj /2.

2
3
4
5 Locate the Endpoint section. From the Specify list, choose Coordinates.
6 In the x text field, type -L1.

7

Click ™ Build Selected.

Cylinder | (cyll)
I In the Geometry toolbar, click | Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.
3 In the Radius text field, type Di/2.

4 In the Height text field, type Lj.

5 Locate the Position section. In the x text field, type -Lj.

6 Locate the Axis section. From the Axis type list, choose x-axis.

7

Click ™ Build Selected.

Cylinder 2 (cyl2)
I In the Geometry toolbar, click | Cylinder.

In the Settings window for Cylinder, locate the Size and Shape section.
In the Radius text field, type Di/3.
In the Height text field, type Lj /2.

In the y text field, type -Lj/2.

2

3

4

5 Locate the Pesition section. In the x text field, type -Lj/2.

6

7 Locate the Axis section. From the Axis type list, choose y-axis.
8

Click ™ Build Selected.

Union | (unil)
I In the Geometry toolbar, click @ Booleans and Partitions and choose Union.

2 Select the objects cyll and cyl2 only.
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3 In the Settings window for Union, click [ Build Selected.

Line Segment 3 (Is3)

I In the Geometry toolbar, click €3> More Primitives and choose Line Segment.
In the Settings window for Line Segment, locate the Starting Point scction.
From the Specify list, choose Coordinates.

In the x text field, type -Lj/2.

In the y text field, type -Lj/2.

Locate the Endpoint section. From the Specify list, choose Coordinates.

In the x text field, type -Lj /2.

In the y text field, type -L2.

Click ™ Build Selected.
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Line Segment 4 (Is4)
I In the Geometry toolbar, click €3> More Primitives and choose Line Segment.

In the Settings window for Line Segment, locate the Starting Point section.

From the Specify list, choose Coordinates.

2
3
4 Locate the Endpoint section. From the Specify list, choose Coordinates.
5 In the x text field, type L3-Lj/2.

6

Click ™ Build Selected.

Cylinder 3 (cyl3)
I In the Geometry toolbar, click || Cylinder.

In the Settings window for Cylinder, locate the Size and Shape section.
In the Radius text field, type Di/2.
In the Height text field, type Lj/2-rbend-Di/2.

2
3
4
5 Locate the Position section. In the x text field, type L3-Lj /2.
6 Locate the Axis section. From the Axis type list, choose x-axis.
7 Click ] Build Selected.

8

Click the Zoom Extents button in the Graphics toolbar.

Revolve | (revl)
I In the Geometry toolbar, click =—+—~ Revolve.

2 On the object ¢yl3, select Boundary 4 only.

3 In the Settings window for Revolve, locate the Revolution Angles section.

27 | ACOUSTICS OF A PIPE SYSTEM WITH 3D BEND AND JUNCTION



4 Click the Angles button.
5 In the End angle text field, type 90.

6 Locate the Revolution Axis section. Find the Point on the revolution axis subsection. In
the yw text field, type -rbend-Di/2.

7 Find the Direction of revolution axis subsection. In the xw text field, type 1.
8 In the yw text field, type 0.
9 Click ®] Build Selected.

Cylinder 4 (cyl4)
I In the Geometry toolbar, click | Cylinder.

In the Settings window for Cylinder, locate the Size and Shape section.
In the Radius text field, type Di/2.
In the Height text field, type Lj/2-rbend-Di/2.

2
3
4
5 Locate the Pesition section. In the x text field, type L3.
6 In the y text field, type -Lj/2.

7 Locate the Axis section. From the Axis type list, choose y-axis.
8

Click ™ Build Selected.

Line Segment 5 (Is5)

I In the Geometry toolbar, click €55 More Primitives and choose Line Segment.
In the Settings window for Line Segment, locate the Starting Point section.
From the Specify list, choose Coordinates.

In the x text field, type L3.
In the y text field, type -Lj/2.

In the x text field, type L3.

2
3
4
5
6 Locate the Endpoint section. From the Specify list, choose Coordinates.
7
8 In the y text field, type -L4.

9

Click ™ Build Selected.

10 In the Geometry toolbar, click [E§ Build All.
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