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Introduction

Woelcome to the COMSOL Multiphysics® simulation software! This book details
features and techniques that help you throughout all COMSOL Multiphysics
modeling in version 6.0 using the COMSOL Dcsktop® environment. For example,
detailed information about:

* How to build geometries in COMSOL Multiphysics.

* How to create a mesh for the analysis.

* How to create parameters and variables used within a model.

* How to add the physics interfaces and material properties, and how to specify

boundary conditions, sources, loads, and other parts of the physics.
* How to solve the model that you have specified.

¢ How to evaluate and display the results and create reports and presentation of

your simulation projects.

The full set of documentation shows you, step by step, how to tap into the
functions and capabilities in the COMSOL Multiphysics software. This
introductory chapter provides an overview of COMSOL Multiphysics and its

product family, documentation set, and other resources.
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Version 6.0 adds a Model Manager that provides the functionality for simulation process and data management
(SPDM) with the ability to create databases, perform version control, and add auxiliary files to enhance and manage
your COMSOL simulation models. It is included with all COMSOL Multiphysics licenses except class kit licesnses.
There is also a new Uncertainty Quantification Module in version 6.0. This version also contains further
enhanced COMSOL Compiler™, Application Builder, and COMSOL Server™ products for creating and
deploying custom apps based on COMSOL Multiphysics.

In this chapter:

e About COMSOL Multiphysics
e COMSOL Documentation and Help

e Overview of the Reference Manual

CHAPTER |: INTRODUCTION



About COMSOL Multiphysics

COMSOL Multiphysics is a powerful interactive and integrated simulation environment used to model and solve
all kinds of scientific and engineering problems. The software provides a powerful integrated desktop environment
with a Model Builder that gives you a full overview of the model and access to all functionality. With COMSOL

Multiphysics you can easily extend conventional models for one type of physics into multiphysics models that solve
coupled physics phenomena — and that do so simultaneously. Accessing this power does not require an in-depth

knowledge of mathematics or numerical analysis.

Using the built-in physics interfaces and multiphysics interfaces and the advanced support for material properties,
you can build models by defining the relevant physical quantities — such as material properties, loads, constraints,
sources, and fluxes — rather than by defining the underlying equations. You can always apply these variables,
expressions, or numbers directly to solid and fluid domains, boundaries, edges, and points independently of the
computational mesh. The COMSOL Multiphysics software then internally compiles a set of equations representing
the entire multiphysics model.

You access the power of COMSOL Multiphysics as a standalone product through a flexible user interface (the
COMSOL Desktop environment), in apps created using the Application Builder and deployed using COMSOL
Compiler™ or COMSOL Server™, or by script programming in ]ava® or the MATLAB® language (the latter
option requires a LiveLink™ for MATLAB® license).

Using these physics interfaces, you can perform various types of studies including:

¢ Stationary and time-dependent (transient) studies
¢ Linear and nonlinear studies

* Eigenfrequency, modal, and frequency-response studies

When solving the models, the COMSOL Multiphysics software assembles and solves the problem using a set of
advanced numerical analysis tools. The software runs the analysis together with adaptive mesh refinement (if
selected) and error control using a variety of numerical solvers. The studies can make use of multiprocessor systems

and cluster computing, and you can run batch jobs and parametric sweeps.

The COMSOL Multiphysics software creates sequences to record all steps that create the geometry, mesh, physics,
studies and solver settings, and visualization and results presentation. This makes it easy to parameterize any part
of the model; simply change a node in the model tree and rerun the sequences. The program remembers and

reapplies all other information and data in the model. You can also perform powerful and flexible parametric sweeps

that vary some material, load, or other model property.

There are a large number of postprocessing tools for plotting, tabulating, and evaluating the results from your
COMSOL simulations. The entire simulation process, from inputs and geometry to the results, is performed in a

single integrated desktop environment — the COMSOL Desktop.

Furthermore, you can manage your simulation projects using the Model Manager and create reports and

presentations in HTML, Word®, and PowerPoint® formats, including stunning graphics and visualizations.

REAL-WORLD APPLICATIONS
Partial differential equations (PDEs) form the basis for the laws of science and provide the foundation for modeling

a wide range of scientific and engineering phenomena. You can use the COMSOL Multiphysics software in many
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application areas and analysis methods, including but not limited to the following, combining physics freely and
incorporating user-defined PDEs, ODEs, and DAEs if needed:

* Acoustics

* Batteries

* Bioscience

* Chemical reactions

* Composite materials

* Control system simulations

* Corrosion and corrosion protection
* Design of experiments (DOE)

* Diffusion

* Electrochemistry

* Electrodeposition

* Electromagnetics

¢ Fatigue analysis

* Fluid dynamics (CED)

* Fuel cells and electrolyzers

¢ Geophysics and geomechanics

e Heat transfer

* Layered shells and composite materials
¢ Metal processing

* Microelectromechanical systems (MEMS)
* Microfluidics

* Microwave engineering

* Mixers and mixing of fluids

Molecular flow

Multibody dynamics

Optics

Optimization and sensitivity analysis
Particle tracing

Photonics

Piezoelectric devices

Pipe flow

Plasma physics

Polymer flow

Porous media flow

Quantum mechanics
Radio-frequency components
Ray tracing and ray optics
Rotordynamics
Semiconductor devices
Structural mechanics
Subsurface flow
Thermodynamics

Transport phenomena
Uncertainty quantification (UQ)
Wave optics

Wave propagation

Many real-world applications involve simultaneous couplings of physics, represented in a system of PDEs —

multiphysics. For instance, the electric resistance of a conductor often varies with temperature, and a model of a

conductor carrying current should include resistive-heating effects. The Multiphysics Modeling Workflow section

discusses multiphysics modeling techniques. Predefined multiphysics interfaces provide easy-to-use entry points for

common multiphysics applications.

In its base configuration, COMSOL Multiphysics offers modeling and analysis power for many application areas

and fundamental types of physics. For several of the key application areas there are also optional add-on modules.

These application-specific modules use terminology, specialized material models and boundary conditions,

additional study types and solution methods, and plot types specific to the particular discipline, which simplifies

creating and analyzing models and adds a wider set of modeling tools. The modules also include comprehensive

Application Libraries with example models that show the use of the product within its application areas.

The COMSOL Multiphysics Modules and Interfacing Options

The optional modules, including interfacing options such as the CAD Import Module and bidirectional interfaces

such as the LiveLink™ products, are optimized for specific application areas and offer discipline-standard
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terminology and physics interfaces. For some modules, additional material libraries, specialized solvers, element

types, and visualization tools are also available.

For up-to-date module availability, product descriptions, and a specification chart, go to

g www.comsol.com /products.
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About the Documentation Set

The full documentation set that ships with COMSOL Multiphysics consists of the following titles:

o Introduction to COMSOL Multiphysics — information about version 6.0 and how to build models using the

desktop environment, including quick references to keyboard shortcuts and common commands and functions.

e COMSOL License Agreement.

o COMSOL Multiphysics Installation Guide — besides covering various installation options, it describes system

requirements and how to configure and run the COMSOL Multiphysics software on different platforms,

including client/server architectures as well as shared-memory and distributed (cluster) parallel versions.

o COMSOL Multiphysics Reference Manual — this book, which covers the functionality of COMSOL

Multiphysics across its entire range from geometry modeling to results evaluation and visualization, including
the physics interfaces for physics and equation-based modeling. It serves as a tutorial and a reference guide to
use COMSOL Multiphysics. This book reviews geometry, mesh, solver, and results functionality and provides
detailed information about the settings and options. Additionally, it describes some advanced functionality and
settings in COMSOL Multiphysics and provides background material and references.

e COMSOL Multiphysics Programming Reference Manual — this book provides details about features and
techniques that help you control COMSOL Multiphysics using its application programming interface (API). The
COMSOL API can be used from the Application Builder, in a standalone Java® application, and from MATLAB®
using the LiveLink™ for MATLAB® interface. For the Application Builder, the Application Programming Guide
provides information about using the COMSOL API and the API of the Application Builder components to

create methods for custom applications.

e The Model Manager Reference Manual and Model Manager Server Manual describe how to use the Model
Manager tools for managing models and auxiliary files with version control, access permissions, and other

database functionality. The Model Manager server is available with floating-network licenses.

* The Introduction to the Application Builder and the Application Builder Reference Manual provide
documentation related to the Application Builder and how to create and deploy simulation applications and how
to use COMSOL Compiler™ to create standalone runnable apps. See also the COMSOL Server Manual for
configure a server and clients for COMSOL Multiphysics applications.

e COMSOL Server Manunal — information about setting up, configuring, and running a COMSOL Server for
running and deploying applications within an organization.

o The Physics Builder Manual provides documentation related to the Physics Builder for creating custom physics
interfaces.

» The Essentials of Postprocessing and Visualization and Specialized Techniques for Postprocessing and
Visualization provide tips and information that help you get the most out of the postprocessing and
visualization tools in COMSOL Multiphysics.

* COMSOL Multiphysics Release Notes — information about new functionality and changes in the 6.0 release
and about compatibility with earlier versions of COMSOL Multiphysics.

In addition, each of the optional modules includes a manual as described in The COMSOL Multiphysics Modules
and Interfacing Options. The documentation for the optional CAD Import Module and LiveLinks to CAD
packages is available in separate manuals, and the documentation for the optional Material Library in the Mazerial
Library User’s Guide.

The COMSOL LiveLink™ for MATLAB® User’s Guide shows how to access the capabilities of COMSOL from the
MATLAB programming environment.
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DIFFERENT INSTRUCTIONS FOR DIFFERENT OPERATING SYSTEMS
The Windows® platform uses a ribbon layout, a style familiar to Microsoft® Office users and integrated into many
other Windows software designs. The ribbon-style layout is intuitive and makes it easy to locate similar and

®

frequently used features. For the Linux™~ and macOS platforms, there are extended toolbars that provide almost

identical single-click access to most functionality in the software.

The use of the ribbon for Windows users means that there are slightly different instructions about how to access
some features compared to macOS or Linux users. When specific instructions are included about where to find a

particular feature, the instructions distinguish between the operating systems using different icons.

¢ Where there are no differences, the icons are not used.

¢ Where there are minor differences in appearance or accessibility, but the functionality is the same, no icons are

used.

 In general, instructions for all platforms imply that the feature is available from a named toolbar. For example,
the Home toolbar, Physics toolbar, Mesh toolbar, or Geometry toolbar. See Toolbars and Keyboard Shortcuts for

information about each toolbar.

A ribbon tab, ribbon group, or modal ribbon tab, are available in the Windows version. See
Figure 2-1 for an example of the Windows Home toolbar.

for macOS and Linux users. See Figure 2-12 for an example of these toolbars.
Linux

The Model Toolbar and Contextual Toolbar are available in the cross-platform version, primarily

ABOUT THE SCREENSHOTS USED IN THIS MANUAL
The screenshots used throughout this reference manual are captured using the Windows platform except when

there are clear differences other than fonts or cosmetic appearance.

ADDITIONAL INTERNET RESOURCES
A number of online resources have more information about COMSOL, including licensing and technical

information. The electronic documentation, topic-based (or context-based) help, and the Application Libraries are
all accessed through the COMSOL Desktop.

If you are reading the documentation as a PDF file on your computer,
the blue links do not work to open an application or content

n referenced in a different guide. However, if you are using the Help
system in COMSOL Multiphysics, these links work to open other

modules, application examples, and documentation sets.

CONTACTING COMSOL BY EMAIL

For general product information, contact COMSOL at info@comsol.com.

COMSOL ACCESS AND TECHNICAL SUPPORT
To receive technical support from COMSOL for the COMSOL products, please contact your local COMSOL

representative or send your questions to support@comsol.com. An automatic notification and a case number will
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be sent to you by email. You can also access technical support, software updates, license information, and other
resources by registering for a COMSOL Access account.

COMSOL ONLINE RESOURCES

COMSOL website www.comsol.com

Contact COMSOL www.comsol.com/contact

COMSOL Access www.comsol.com /access

Support Center www.comsol.com/support

Product Download www.comsol.com/product-download
Product Updates www.comsol.com/support,/updates
COMSOL Blog www.comsol.com/blogs

Discussion Forum www.comsol.com/community

Events www.comsol.com/events

COMSOL Application Gallery www.comsol.com/models

COMSOL Video Gallery www.comsol.com/video

Support Knowledge Base www.comsol.com/support,/knowledgebase

The Help Window and Topic-Based Help

The Help window is useful as it is connected to many of the features in the COMSOL Desktop. This concept is
called topic-based help or context help. You can also search and access all the HTML documentation content from

this window.

The Help system automatically starts a web server using port 8090 on the computer where
COMSOL Multiphysics is installed. Depending on the security settings, you might get a question
n to allow that port to be used the first time the help system is started.

The operating system might also issue a firewall security warning. To use Help, allow COMSOL
Multiphysics access through the firewall.

To learn more about a node in the Model Builder, or a window on the Desktop, click to highlight a node or

window, then press F1. The Help window opens and displays the topic information about the selected feature.

OPENING THE HELP WINDOW AND THE TOPIC-BASED HELP
There are several ways to open the Help window, listed below with an indication if a way to open the Help window

is specific to the Windows version or the Linux and macOS (cross-platform) version:

e Press FI.

¢ In the main toolbar, click Help (E) (Linux and macOS).

¢ In the upper-right corner of the COMSOL Desktop, click the (ﬂ) button (Windows).
e From the main menu, select File>Help (Windows) Help>Help (Linux and macOS).

* Right-click any node in the Model Builder and select Help.

ABOUT USING THE FI KEY TO ACCESS CONTEXT HELP
To display topic-based (context) information in the Help window, on the COMSOL Desktop:

* Click to highlight a node in the Model Builder tree. For example, the Component or Geometry node.
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¢ Click a window tab, for example, Model Builder, Add Study, or Messages.

* For Windows users, hover over ribbon buttons or menu items to display a zooltip. While the tooltip is showing,

you can press F1 to display more detail.

At the top of the Help window you find the tools and search functionality listed in the table below. Also, above the
help text, a clickable breadcrumb trail shows the location of the displayed contents in the COMSOL documentation
set. Click any part of the trail to move to that level in the COMSOL documentation.

In some cases you need to refocus the context help on its target before pressing F1. Try clicking
to highlight a node, a window, or the button or click to focus on the Help window, hover over a

toolbar button (Windows only) and press F1.

TABLE I-1: THE HELP AND DOCUMENTATION TOOLBARS

BUTTON NAME DESCRIPTION

& Click the Home button or select the COMSOL Documentation top node in the table of
contents tree to return to the COMSOL Documentation window home page. Not
available when showing context help in the Help window.

= Show When a help topic page is shown in the Help window, click Show Table of Contents to
Table of open a tree-based menu of the COMSOL documentation. When you select a node in the
Contents/  table of contents tree the corresponding topic is shown on the topic page. Alternatively,
Show click again (Show Topic) to return to the topic page.
Topic

Q Search On the Help window, click to open the search engine to look for contents in the

COMSOL documentation. Search results are shown sorted by product.

On the Documentation window, enter search terms in the field and choose the Search
scope — All documents, Selected only, or Application libraries.

See Scarching Help and Documentation Content for more information about search
terms you can use.

—/ & Back Navigates backward to the previous page in the Help or Documentation window’s
browser history.
—/ Forward Navigates forward in the browser history, but only to the end of the current list.
(] Sticky On the Help window, click the Sticky Help button to lock the current help window (the
Help icon is highlighted [ ), which can be useful to keep some help topic or model instruction

active, or to release the window and view topic-based (context) help when a node or
window is clicked.

1 Show in On the Help window, click the Show in External Browser button to show the current help
External topic in an external web browser.
Browser

+ Previous Section  Navigates backward to the previous section in the documentation.

Mext Section » Navigates forward to the next section in the documentation.

CHANGING THE DEFAULT DOCUMENTATION AND HELP SETTINGS
To edit the following settings, open The Preferences Dialog Box and click Help.

Locate the Target arca and choose Documentation window (the default) from the Show documentation in list to show
the help contents in the Documentation window that is included in the COMSOL Desktop environment (default),
or select External browser to display the help contents in a separate web browser. For further details on how to access
and use the documentation, see the section The Documentation Window below. Similarly, using the Show help in

list, you can choose between Help window (default) and External browser to show topic-based help in the Help
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window inside the COMSOL Desktop or in an external web browser, respectively. When showing topic-based help
in an external browser, you need to press F1, choose Help>Help, or select the Help context menu item (when
applicable) to trigger an update of the browser’s contents. The PDF-file target setting controls what happens when
you click a PDF link on the COMSOL Documentation entry page. Choose In place to display PDF documents
using the native browser’s PDF display settings, or choose New window to launch them in the default system

application for PDF-files. On Windows, the native browser is always Microsoft Edge or Internet Explorer.

In the Source area, set the Location to Local to display help using locally installed help files or to Online to access help
from the COMSOL website. For the Local option, edit the Documentation root directory file path as required. The
default file paths are based on the platform:

* On Windows C:\Program Files\COMSOL\COMSOL60\Multiphysics\doc, or generically COMSOL60\doc.
¢ For macOS and Linux, under the main COMSOL installation directory: COMSOL60/Multiphysics/doc.

Proxy Server Settings

If you connect to the internet through a web proxy, you can use the controls in the Proxy server settings area to
specify the proxy server settings to use when communicating with the COMSOL website for displaying online help
in integrated mode as well as for performing updates of the COMSOL Application Library and the COMSOL Part
Library (see The Application Library Update Window and The Part Library Update Window for further details
about these services).

The Configuration list has the following options:

* No proxy server: Connect to the update server directly, bypassing any proxies. This is the default setting.
¢ Use system settings: Use the system-wide proxy server settings defined on your computer.

e Manual: Choose this alternative if you want to specify a proxy server by entering the name (or IP address) and
port number in the Server and Port number ficlds. The default port number is 443, which is the default for HTTP
secure (HTTPS). If the proxy server requires authentication, you are asked to provide username and password
the first time in each COMSOL session you access documentation or update the COMSOL Application Library
or Part Library.

Selecting a Web Browser

In the General section of the Preferences dialog, under Web browser (Windows and Linux only), you can choose
which browser the COMSOL Multiphysics software should use to show pages on the COMSOL website and
documentation when using the web browser mode. The following settings are available:

* On Windows: Choose the Program sctting System default to use the default system web browser. Alternatively,
choose Custom and then give the path to an Executable location for a different browser installed on your

computer.

* On Linux: Type the path to the web browser directly in the Executable field, or click the Browse button and then

point to the executable file on the file system.

. On macOS, this setting is not available, and COMSOL Multiphysics always uses the system’s
I_El default web browser.
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The Documentation Window

To open the Documentation window:

Win e DPress Ctrl+F1.

e From the File menu, select Help>Documentation.

To open the Documentation window:

e Press Ctrl+F1

* In the main toolbar, click the Documentation ( I! ) button.

¢ From the Help menu, sclect Documentation.

In the Documentation window (or a browser window, depending on your preference settings), you can navigate
to PDF or HTML versions of the documentation (availability is based on your license), as well as search all the
documentation, save or open PDFs, or view the HTML content in this window. There are different ways to access

the same information using either the left-hand side (Figure 1-1) or right-hand side (Figure 1-2) of the window.
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&3, COMSOL Doacumentation — o X

Q

# € 9  Searchscope:

~ COMSOL Documentation All documents

~ COMSOL Multiphysics Selected only
» COMSOL Multiphysics® Ins Application libraries
» License Agreement .
» COMSOL Multiphysics Release Notes COMSOL Documentation and Help ~

¥ COMSOL Multiphysics Reference Manual About the Documentation Set
~ Introduction

» About COMSOL Multiphysics

\|  COMSOL Multiphysics > COMSOL Multiphysics Reference Manual > Introduction > COMSOL Documentation and Help

The full documentation set that ships with COMSOL Multiphysics consists of the following titles

+ Introduction to COMSOL Multiphysics — information about version 5.4 and how to build models using the desktop environment,
including quick references to keyboard shortcuts and common commands and functions.

» COMSOL License Agreement.

~ COMSOL Documentation and Help
About the Documentation Set

The Help Window and Topic-Based Help
- COMSOL Multiphysics installation Guide — besides covering various installation options, it describes system requirements and how

The Documentation Window to configure and run the COMSOL Multiphysics software on different platforms, including client-server architectures as well as

Searching Help and Documentation Content shared-memory and distributed (cluster) parallel versions.
The About COMSOL Multiphysics Box + COMSOL Multiphysics Reference Manual — this book, which covers the functionality of COMSOL Multiphysics across ts entire range
Checking for Product Software Updates from geametry madeling to results evaluation and visualization, including the physics interfaces for physics and equation-based
N e modeling. It serves as a tutorial and a reference guide to use COMSOL Multiphysics. This book reviews geometry, mesh, solver, and
posraphicallEonventions) results functionality and provides detailed fion about the setti d options. it describes some advanced
Overview of the Reference Manual functionality and settings in COMSOL Multiphysics and provides background material and references.
» The COMSOL Modeling Environment « COMSOL Multiphysics Programming Reference Manual — this book provides details about features and techniques that help you
» Building a COMSOL Multiphysics Model control COMSOL Multiphysics using its application programming interface (API). The COMSOL API can be used from the Application
» Customizing the COMSOL Desktop Builder, in a standalone Java® application, and from MATLAS  using the LiveLink™ for taTLAS © interface. For the Application Builder,

the Application Programming Guide provides information about using the COMSOL AP| and the API of the Application Builder
components to create methods for custom applications.

Global and Local Definitions

Visualization and Selection Tools
+ The Introduction to the Application Builder and the Application Builder Reference Manual provide documentation related to the

Application Builder and how to create and deploy simulation applications and how to use COMSOL Compiler™ to create standalone

Geometry Modeling and CAD Tools

» Meshing runnable applications. See also the COMSOL Server Manual for configure a server and clients for COMSOL Multiphysics applications.
» Materials + COMSOL Server Manual — information about setting up, configuring, and running a COMSOL Server for running and deploying

» The AC/DC Interfaces applications within an organization

» The Pressure Acoustics Interface = The Physics Builder Manual provides documentation related to the Physics Builder for creating custom physics interfaces.

» The Chemical Species Transport Interfaces - The Essentials of Pastprocessing and Visualization and Specialized Techniques for Postprocessing and Visualization provide tipsand

information that help you get the most out of the postprocessing and visualization toels in COMSOL Multiphysics.

The Fluid Flow Interface
« Previous Section Next Section »

The Heat Transfer Interfaces

Figure 1-1: Based on your license, links to the HTML versions of the product documentation ave accessed and can be
browsed in the tree. When you click a topic in the tree the information displays to the right. You can also adjust the search
scope.

COMSOL Documentation

COMSOL Multiphysics

Installation Guide [ HTML | PDF ]
COMSO0L Software License Agreement [ HTML | PDF ]
COMSOL Release Motes [ HTML | PDF ]
Introduction to COMSOL Multiphysics [ PDE ]
Introduction to Application Builder [ PDE ]
Application Builder Reference Manual [ HTML | PDF ]
Application Programming Guide [ PDF ]
Essentials of Postprocessing and Visualization [ PDE ]
Specialized Technigues for Postprocessing and Visualization [ PDFE ]
Reference Manual [ HTML | PDF ]
Physics Builder Manual [ HTML | PDF ]
Programming Reference Manual [ HTML | PDF ]

Figure 1-2: Based on your license, links to PDF and HTML versions of the product documentation ave accessed from this
window. When you click HTML it jumps to the first page of the documentation for that product; when you click PDF
you can Open or Save a full PDF version of that document.

* The Help Window and Topic-Based Help

e Table 1-1 for a list of the Documentation toolbar buttons.

Searching Help and Documentation Content

After you open The Help Window and Topic-Based Help, click the Search button ( (3}, ) to open the search engine
and search the HTML content. Search results are shown sorted by product. You can also search in the contents of

The Documentation Window.
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SEARCHING THE DOCUMENTATION

On the Documentation window, you can adjust the Search scope (see Figure 1-1). Enter a search term in the Search

expression field and then select All documents, Selected only, or Application libraries from the list to narrow or expand

the search scope as needed. For Selected only (Figure 1-3), first click a branch in the tree (for example, COMSOL

Multiphysics Reference Manual) and then the search includes all the documents below the selected node until the

beginning of the next branch. In this example it searches until the end of the Troubleshooting License Errors

section.

n The first search can take a couple of minutes while the search index is generated.

L.

»

L L A IR A A A

3, COMSOL Documentation

€ Search scope:

~ COMSOL Documentation

COMSOL Multiphysics

Material Library

AC/DC Module

Acoustics Module

Batteries & Fuel Cells Module

CAD Import Madule

CFD Module

‘Chemical Engineering Flowsheet Madule
Chemical Reaction Engineering Module
‘Composite Materials Module
Corrosion Medule

Design Module

ECAD Import Module

Electrical Circuits Module
Electrochemistry Module
Electrodeposition Module

Fatigue Module

Geomechanics Module

Heat Transfer Medule

MEMS Module

Metal Processing Module
Microfluidics Module

Mixer Module

Molecular Flow Medule

Multibody Dynamics Module
Nonlinear Structural Materials Module
‘Optimization Module

Particle Tracing Module

Pipe Flow Module

All documents

- [m] X
parametric Q
~
COMSOL Multiphysics ol
LiveLink™ for PTC® Creo® Parametric™: Add-in for PTC Creo Parametric
COMSOL Multiphysics > COMSOL Multiphysics® Installation Guide > Installing on Windows
LiveLink ™ for PTC® Creo® Parametric™: Add-in for PTC Creo Parametric If you have licensed LiveLink™ for PTC® Creo®
Parametric™, you need to provide the path to the common files folder in the PTC Creo Parametric installation during the
installation process. It should point to the commeon files directory of the PTC Crea Parametric installation, which is typically for
PTC Creo Parametric 2.0 [...]
Inputs for Parametric Solver and Parametric Sweep Studies
COMSOL Multiphysics > COMSOL Multiphysics Reference Manual > Results Analysis and Plots > Results Overview
This information is useful when defining plots or derived values for Parametric Solver and Parametric Sweep studies using the
settings in the Data section. When setting parameters for parametric sweep studies in a node under Results, the available
settings depend on the problem type. For a time-dependent parametric simulation, for example, you can select both time steps
and parameter values. [..]
The Parametric Solver Algorithm
COMSOL Multiphysics > COMSOL Multiphysics Reference Manual > Studies and Solvers > Solution Attribute Nodes
The Parametric solver performs a loop around the usual stationary solver in which it estimates the initial guess using the
solution for the previous parameter value. If the nonlinear solver does not converge and you are solving for a single parameter,
it tries a smaller parameter step; COMSOL Multiphysics determines the size of this step from the convergence speed of the
Newton iteration using [...]
Parametric Extrusion 1D and Parametric Extrusion 2D
COMSOL Multiphysics > COMSOL Multiphysics Reference Manual > Results Analysis and Plots > Datasets
Use a Parametric Extrusion 1D () or Parametric Extrusion 2D () dataset to extend another dataset by using a parameter, such as
time, as a dimension. Select these from the Mare Datasets and More 2D Datasets submenus. Settings From the Level
transfermation list, select Mone {the default) to use no transformation of the extrusion level, or select Expression to enter an
expression in the [...]
p L] v
v
< Previous Section Next Section »

Figure 1-3: When searching in the Documentation window, choose a Search scope to seavch only a selected portion of the

documentation, all the documentation, ov only the Application Libraries.

SEARCH PARAMETERS FOR HELP AND THE DOCUMENTATION

Some examples of search parameters you can use:

TABLE 1-2: SEARCH PARAMETERS FOR THE COMSOL HELP SYSTEM

OPERATOR EXAMPLE SEARCH RESULT EXAMPLE

&&, AND block && cone
block AND cone
block OR cone

block || cone

Results include all instances of the words.

OR, || Results include any of the listed words.

+ - +block —cone Search for one term (+block) but not the other term (—cone).

“, ~ “plot line”~10 Search for the words enclosed in the quotation marks (plot line) within (~) a
certain number of words (10) from each other.

~ excentric~ Search for something “almost” spelled in a particular way (an approximate matching

or fuzzy search). For example, excentric~. The results include eccentric cone.
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TABLE 1-2: SEARCH PARAMETERS FOR THE COMSOL HELP SYSTEM

OPERATOR  EXAMPLE SEARCH RESULT EXAMPLE

? h’t Use in a search query to mean exactly one character. For example, search for all
instances of hat, hit, or hut where ? represents a, i, or u, or any other letter
between h and t.

* strain® The asterisk (*) is a wildcard character. Search for any word that starts with

strain®d “strain”. Results include strain-based, strain-rate, or strain, for example. The

asterisk represents any number of characters.
If the asterisk is used in the middle of the word, it searches for one letter between
“n” and “d”. The result in this example is strained.
You can use the asterisk before and after the word in order to search for it in the
middle of a longer word or expression, For example, *setdefaultgeometry*
finds ModelUtil.setDefaultGeometryKernel.

enclosed “time dependent  Use quotation marks around a text string to search for exactly that phrase; that is,

quotation  study” to search for the words in the order given within the quotation marks.

marks “”

Greek c You can also search for Greek letters. The search is case insensitive.

letters

The About COMSOL Multiphysics Box

3 About COMSOL Multiphysics

COMSOL o

MULTIPHYSICS

COMSOL Multiphysics 5.5 (Build: 236)

This product is licensed to:

License number:

Show Information

Acknowledgments

Acknowledgments

This software is furnished under a license agreement.|
COMSOL Software License Agreement, see https://wy License agreement
European (valid in DE, FR, and UK), Chinese, and Jap| L d duct
U.S. Patents 7,519,518; 7,596,474; 7,623,991; §,21{ -'-€Nsed products
9,146,652; 9,208,270; 9,323,503; 9,372,673; 9,454 Patents

owned by Siemens Product Lifecycle Management Sof Rights Reserved. Portions of this software
are owned by Spatial Corp. © 1989-2018. All Rights F k™ products are affiliated with, endorsed
by, sponsored by, or supported by Autodesk, Inc., Dassault Systémes 5.A., Dassault Systémes SOLIDWORKS Corp., Microsoft
Corp., PTC Inc., Siemens Product Lifecycle Management Software Inc., The MathWorks, Inc. or any of their affiliates and/or
subsidiaries. COMS0L, the COMSOL logo, COMSOL Server, COMSOL Multiphysics, COMSOL Desktop, and Livelink are either
registered trademarks or trademarks of COMSOL AB. Autodesk, AutoCAD, Inventor, and Revit are registered trademarks or
trademarks of Autodesk, Inc., and/or its subsidiaries and/or affiliates in the USA and/or other countries, Other product or
brand names are trademarks or registered trademarks of their respective helders. For a list of such trademark owners, see
https://www.comsol.com/tm.

Iy under the terms of version 5.5 of the
2018 COMSOL AB. Protected by U.S.,
+/fwww.comsol.com/patents. Protected by
; 8,04%9,069; 8,954,302; 9,098,106;

ts pending. Portions of this software are

System information

COMSOL Website oK

Figure 1-4: The About COMSOL Multiphysics dialog box with the setting to show the Acknowledgments list.

To open the About COMSOL Multiphysics ([=]) window:

¢ For Windows users, select it from the File menu.

* For macOS and Linux (cross platform) users, choose it from the Help menu.
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In addition to copyright and patent information, the About COMSOL Multiphysics dialog box has the following
information:

¢ The Version number

e The user or company This product is licensed to

e The License number

Select an option from the list below and then click Show Information to open a separate window of the same name

containing this information:
¢ Seclect Acknowledgments to show information about third-party software components, including license notices
required by the software component authors. Then click Show Information.

¢ Select License agreement to show the COMSOL Multiphysics software license agreement. Then click Show

Information.

¢ Seclect Licensed products to show the licensed COMSOL products, including the number of used licenses and the

total number of licenses for each product. Then click Show Information.

* Seclect Patents to show the patents that the COMSOL software products are protected by. Then click Show
Information.

* Select System information to show a list of system properties, which can be useful for troubleshooting purposes,

for example. Then click Show Information.

* Click COMSOL Web Page to open your web browser on the main COMSOL web page.

You can also get information about the licensed products from the Licensed and Used Products in

g Session window.

& The Root Settings Windows

Checking for Product Software Updates

COMSOL provides product software updates that improve the software and correct any issues found.
To check if a product update is available, from the File menu select Help>Check for Product Updates ( (%) ).

The program then checks if an update that is applicable, but not yet installed, is available from the COMSOL
website.

If an update is available, an Update dialog box appears; click Download to download the update directly, or click
Browse Update to open the COMSOL website where you can read about and download the update.

If no updates are available, the Update dialog box reports that your COMSOL installation is up to date. Open The
Preferences Dialog Box and click Updates to select the Check for updates at launch check box to make the program

check for updates each time you launch the COMSOL Multiphysics program.

Typographical Conventions

All documentation uses a set of consistent typographical conventions that make it easier to follow the discussion,
understand what you can expect to see on the graphical user interface (GUT), and know which data must be entered
into various data-entry fields.
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In particular, these conventions are used throughout the documentation:

CONVENTION

EXAMPLE

text highlighted in blue  Click text highlighted in blue to go to other information in the PDF. When you are using

boldface font

italic font

the help desk in COMSOL, links to other modules, application examples, and
documentation sets also work.

A boldface font indicates that the given word(s) appear exactly that way on the
COMSOL Desktop (or, for toolbar buttons, in the corresponding tooltip). For example,
the Model Builder window is often referred to, and this is the window that contains the
model tree. As another example, the instructions might say to click the Zoom

Extents button ([#]), and this means that when you hover over the button with your
mouse, the same label displays on the COMSOL Desktop.

An italic font is the introduction of important terminology. Expect to find an
explanation in the same paragraph or in the Glossary. The names of other documents in
the COMSOL documentation set are also in izalic font.

Forward arrow symbol >  The forward arrow symbol > means you select a series of menu items or nodes in a

code (monospace) font

specific order. For example, Component>Mesh is equivalent to: Under the Component
node, click the Mesh node.

A code (monospace) font means you make a keyboard entry in the COMSOL Desktop.
You might see an instruction such as “Enter (or type) 1.25 in the Current density field.”
The monospace font is also used to indicate programming code and variable names.

Italic code (monospace)  An italic code (monospace) font indicates user inputs and parts of names that can vary

font

Arrow brackets <>
following the code

(monospace) or code

(italic) fonts

or be defined by the user.

The arrow brackets included in, for example, programming examples (after a
monospace code or an italic code font) mean that the content in the string can be
freely chosen or entered by the user, such as a feature Name or Label. For example,
model.geom(<label>), where <label> is the geometry’s label.

When the string is predefined by COMSOL Multiphysics, no bracket is used and this
indicates that this is a finite set, such as a feature type.

KEY TO THE GRAPHICS

Throughout the documentation, icons are used to help organize the information. These icons vary in importance,

but it is reccommended that you read these text boxes.

ICON NAME

DESCRIPTION

A Caution

1] Important

Note

[

Tip

'El See Also

A Caution icon indicates that the user should proceed carefully and consider the next steps.
It might mean that an action is required, or if the instructions are not followed, that there will
be problems with the model solution.

An Important icon indicates that the information provided is key to the model building,
design, or solution. The information is of higher importance than a note or tip, and the user
should endeavor to follow the instructions.

A Note icon indicates that the information can be of use to the user. It is recommended that
the user reads the text.

A Tip icon is used to provide information, reminders, shortcuts, suggestions for improving
model design, and other information that might be useful.

The See Also icon indicates that other useful information is located in the named section. If
you are working online, click the hyperlink to go to the information directly. When the link is
outside of the current PDF document, the text indicates this, for example, “See The
Laminar Flow Interface in the COMSOL Multiphysics Reference Manual” Note that if
you are in the online help, the link works.
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ICON NAME

DESCRIPTION

[|I[| An

example
from the
Application
Libraries

Space Dimension

Windows
Win
I macOS
Linux

Linux

The icon is used in the documentation to indicate examples that demonstrate the use of
some functionality. In some cases, an example is only available if you have a license for a
specific module. The Application Library path describes how to find the actual file in
COMSOL Multiphysics, for example:

If you have the RF Module, see Radar Cross Section: Application Library path RF_Module/
Scattering_and_RCS/radar_cross_section

Another set of icons is used in the Model Builder — the component space dimension is
indicated by |D axial symmetry i—, 2D 9, 2D axial symmetry i-, and 3D @ icons. The
ID and 0D icons are not used but the space dimension is indicated. These icons are also
used in the documentation to list the differences to a physics interface, node, or theory
section, which are based on space dimension.

This icon means that the information is specific to a Microsoft Windows operating system.

This icon means that the information is specific to a macOS operating system. This may also
be referred to as cross-platform when describing how to access a feature or menu on the
COMSOL Desktop.

This icon means that the information is specific to a Linux operating system. This may also be
referred to as cross-platform when describing how to access a feature or menu on the
COMSOL Desktop.
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This COMSOL Multiphysics Refervence Manual provides comprehensive information about all modeling steps
using the COMSOL Multiphysics software. See the individual module manuals for information specific to a
specialized module (see The COMSOL Multiphysics Modules and Interfacing Options for a link to the COMSOL

website).

- As detailed in the section COMSOL Documentation and Help this information can also be
g searched from the Help system in COMSOL Multiphysics.

TABLE OF CONTENTS, GLOSSARY, AND INDEX

To help you navigate through this guide, see the Contents, Glossary, and Index.

ENVIRONMENT

The COMSOL Modeling Environment chapter provides an overview of the COMSOL modeling environment as
controlled by the COMSOL Desktop and the tools and windows it provides in the Windows version as well as the
cross-platform version. Topics include The COMSOL Desktop, The Application Libraries Window, The Physics

Interfaces, Creating a New Model with the Model Wizard, and a key to the icons including links in the Toolbars

and Keyboard Shortcuts section.

MODELING

Building a COMSOL Multiphysics Model explains a range of methods and topics including information about the
following: details about an introduction to The Model Builder, The Component Node, The Physics Nodes,
Selecting Physics Interfaces, Analyzing Model Convergence and Accuracy, Specifying Model Equation Settings,

Boundary Conditions, Using Units, Numerical Stabilization, and much more.

CUSTOMIZING THE COMSOL DESKTOP
In the Customizing the COMSOL Desktop chapter, the settings are described related to Customizing a Model,
changing Preferences Settings, and details about the Showing More Options.

DEFINITIONS

The Global and Local Definitions chapter describes the global and local (component) definitions features.
Depending on the geometric scope, you add the nodes described in this section to either the Global Definitions
node or under the Definitions node for a particular component. Topics include Operators, Functions, and
Constants, Predefined and Built-In Variables, Mass Properties, Functions, Nonlocal Couplings and Coupling
Operators, Coordinate Systems, Identity and Contact Pairs, Probes, and Infinite Elements, Perfectly Matched

Layers, and Absorbing Layers.

VISUALIZATION AND SELECTION
The Visualization and Selection Tools chapter describes the tools used to visualize and control how you view
models and select parts of the model geometry in the Graphics window and the Settings windows. Important topics

include Working with Geometric Entities, Creating Named Selections, and User-Defined Views.

GEOMETRY

The Geometry Modeling and CAD Tools chapter covers geometry modeling in 1D, 2D, and 3D with examples of
solid modeling, boundary modeling, Boolean operators, and other CAD tools in COMSOL. In addition, it shows
how to use the tools for exploring geometric properties, such as volumes and surfaces. There is also information
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about using external CAD data. Topics include Creating a Geometry for Analysis, Working with Geometry

Sequences, Geometric Primitives, Geometry Operations, and Virtual Geometry and Mesh Control Operations.

MESH

The Meshing chapter summarizes how to create and control your mesh for 1D, 2D, and 3D geometries in the
COMSOL Multiphysics software. It also explains these topics, which include: Meshing Overview, Inspecting and
Troubleshooting Meshes, Meshing Operations and Attributes, and Importing and Exporting Meshes.

MATERIAL
The Materials chapter introduces you to the material databases included with the COMSOL products. Topics
include a Materials Overview, Working with Materials, Material Properties Reference, User-Defined Materials and

Libraries, Using Functions in Materials, and Module-Specific Material Libraries.

AC/DC

The AC/DC Interfaces chapter explains the physics interfaces available for modeling electromagnetics, which you
find under the AC/DC branch ( % ) when adding a physics interface. It also contains sections about general
fundamentals and theory for electric fields.

ACOUSTICS
The Pressure Acoustics Interface chapter describes how to use the Pressure Acoustics, Frequency Domain interface,
found under the Acoustics branch ( 1)) ) when adding a physics interface, for modeling and simulation of acoustics

and vibrations.

CHEMICAL SPECIES TRANSPORT
The Chemical Species Transport Interfaces chapter explains how to use the Transport of Diluted Species interface,
found under the Chemical Species Transport branch ( #:# ) when adding a physics interface, to model and simulate

mass transfer by diffusion and convection based on Fick’s law of diffusion.

FLUID FLOW

The Fluid Flow Interface chapter explains how to use the Laminar Flow interface, found under the Fluid

Flow>Single-Phase Flow branch (=) when adding a physics interface, to model and simulate fluid mechanics for

laminar, incompressible fluids.

HEAT TRANSFER

The Heat Transfer Interfaces chapter describes the different types of Heat Transfer interfaces (Heat Transfer in
Solids and Heat Transfer in Fluids), and the Joule Heating interface, all found under the Heat Transfer

branch ( ||{ ) when adding a physics interface.

SOLID MECHANICS

The Solid Mechanics chapter explains how to use the Solid Mechanics interface, found under the Structural
Mechanics branch ( 1) when adding a physics interface, to simulate and analyze applications involving solid
mechanics. The physics interface is used for stress analysis and general solid mechanics simulation.

EQUATION-BASED MODELING

The Equation-Based Modeling chapter describes the use of the mathematics interfaces, found under the
Mathematics branch ( Au ) when adding a physics interface, which are used for equation-based modeling. With
those interfaces you can solve various types of PDEs using different formulations. You can also solve ODEs and
other global equations, add events and curvilinear coordinates, compute sensitivities, and add moving interfaces

and deforming meshes.
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SENSITIVITY ANALYSIS
The Sensitivity Analysis chapter describes how to perform sensitivity analysis using the Sensitivity interface, found
under the Mathematics>Optimization and Sensitivity (@) branch when adding a physics interface.

DEFORMED MESHES

The Deformed Geometry and Moving Mesh chapter explains how to use the modeling physics interfaces that
control mesh deformation. These are found under the Mathematics>Deformed Mesh ( /7 ) branch when adding a
physics interface. It also contains fundamentals about deformed meshes and information about the Eulerian and
Lagrangian formulations of the physics, the frame types that support these formulations, and the arbitrary

Lagrangian-Eulerian (ALE) method.

STUDIES AND SOLVERS

The Studies and Solvers chapter lists the various types of solvers and studies in the COMSOL Multiphysics software
and explains the study steps and solver configurations. It also describes the major solvers and settings as well as batch
jobs, parametric sweeps, and cluster computing. See also the Optimization Module Manual for other
supplementary information.

RESULTS AND VISUALIZATION

The Results Analysis and Plots chapter helps you analyze results in COMSOL Multiphysics and describes numerous
result-evaluation and visualization tools, including advanced graphics, data display, and export functions. Topics
include Results Overview, Datasets, Plot Groups and Plots, Derived Values, Evaluation Groups, and Tables,

Exporting Data and Images, Reports and Presentations, and Printing and Capturing Screenshots.

RUNNING COMSOL MULTIPHYSICS

Running COMSOL Multiphysics is an overview of the different ways that you can run the COMSOL Multiphysics
software in addition to running the COMSOL Desktop on a dedicated computer, including client/server and
distributed-memory architectures and cloud-based computing. This chapter also includes information about how
to compile COMSOL apps from the command line using COMSOL Compiler.
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The COMSOL Modeling Environment

The comsoL Desktop® provides a complete and integrated modeling
environment for creating, simulating, analyzing, and visualizing multiphysics
models. This chapter provides an overview of the COMSOL Multiphysics®
modeling environment as controlled by the COMSOL Desktop and the tools and

windows it provides.

In this chapter:

e The COMSOL Desktop

e The Application Libraries Window
¢ The Physics Interfaces

¢ Creating a New Model

* Toolbars and Keyboard Shortcuts
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The COMSOL Desktop

This section is an overview of the major components in the COMSOL Multiphysics environment. These
components are integrated into the COMSOL Desktop, which you can personalize to your own modeling needs
and preferences. Primarily consisting of the Model Builder nodes, Settings windows, and Graphics windows, other
dockable windows can be opened, closed, and organized according to the modeling settings you need to access and
the GUI configuration you want to work in. You can save these configurations, and the last opened configuration
is always displayed when you open COMSOL again.

* Creating a New Model

¢ Building a COMSOL Multiphysics Model
El‘ * Customizing the COMSOL Desktop

* The Model Builder

The COMSOL Desktop in the cross-platform version, primarily for the Linux and macOS
operating systems, looks slightly different than for the Windows operating system (shown in
Figure 2-1). The primary difference is that the Main Menu and Main Toolbar are used instead of
ribbons. Otherwise, the default windows (Model Builder, Graphics, Settings, Log, Progress, and

Linux

Messages) are in the same location on the default desktop layout. See The COMSOL Desktop

Menus and Toolbars for more details.

You can also launch the cross-platform version on Windows using comsolxpl.exe.
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Figure 2-1: The default COMSOL Desktop with its major windows in a widescreen layout. The ribbon tabs and groups
are available for Windows users. For macOS and Linux users the layout is similar but you access some options from the

main menu or contextual toolbars.

A ribbon tab, ribbon group, or modal ribbon tab, are available in the Windows version. In general,
these are referred to as zoolbars. See Figure 2-1 for an example of the Windows Home toolbar. Also

see Figure 2-2 for an example of how the ribbon changes when a window is resized.

The Model Toolbar and Contextual Toolbar are available in the cross-platform version, primarily

for macOS and Linux users. See Figure 2-12 for an example of these toolbars.
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ABOUT CHANGES TO THE RIBBON DISPLAY (WINDOWS USERS)
When the complete COMSOL Desktop is resized, the toolbar collapses and the buttons are grouped into menus.
In Figure 2-2, all the groups in the Home toolbar are collapsed into menus. As the window is widened, the ribbon

groups expand again to include the options as buttons or other submenus.

E QG A = A=8E

Workspace Model Definitions Geometry Materials Physics Mesh  Study Results Layout

A\ Application Builder | [ Component 1 + . 2=Variables ~ 2, - oL ; —
P NI =

' Model Manager «»Add Component - o w
Parameters

Geometry Materials Physics Mesh  Study Results Layout

Workspace Model Definitions

Figure 2-2: When the COMSOL Desktop is resized, the vibbon toolbar buttons arve grouped together with the ribbon tab
group name. In this example for the Home toolbar, all the buttons ave available from a menu, such as Definitions,
Geometry, Material, Physics, and so forth (top). As the window is widened, the menus expand accordingly (bottom).

OPENING THE APPLICATION BUILDER FROM THE COMSOL DESKTOP
When you are on the COMSOL Desktop you can toggle between the Application Builder and COMSOL
Multiphysics. In the Home toolbar click Application Builder A to open the Application Editor and modify the user

interface of the application and to create and edit code for the application. You can also press Ctrl+Shift+A.

Conversely, when you are in the Application Builder, you can click Model Builder €% in the Home toolbar to return
to COMSOL Multiphysics. You can also press Ctrl+Shift+M.

OVERVIEW

The rest of this section introduces you to the features of the COMSOL Desktop, explains some basic navigation,
and provides you with an overview of the windows, toolbars, and menus available. In this chapter you will also learn
about the model file formats, the options to save files, and the units systems available for modeling.

* Basic Navigation

* Adjusting Window Location and Size on the Desktop

¢ The COMSOL Desktop Windows

¢ The COMSOL Desktop Menus and Toolbars

* Windows Toolbars and Menus

¢ Cross Platform (macOS and Linux) Toolbars and Menus

* Features Available on Toolbars and From Menus

e The Messages Window

* COMSOL Desktop Color Themes

* About the COMSOL Model File Formats

e Saving COMSOL Files

* Keeping and Opening Recovery Files

¢ The Root Settings Windows

¢ Unit Systems

After this introductory overview, The Application Libraries Window section explains how to work with the

application libraries included with the COMSOL Multiphysics products. The Physics Interfaces section lists the
interfaces available with a basic COMSOL Multiphysics license. This prepares you to start creating a new model.
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The next section, Creating a New Model, shows you how to use the Model Wizard to begin building a new model

by choosing a physics interface and study combination.

The last section, Toolbars and Keyboard Shortcuts, is a quick reference to all the features found on the toolbars. It

includes links to the information contained throughout this reference manual.

Basic Navigation

Basic navigation on the COMSOL Desktop extensively involves the nodes in the Model Builder as well as moving

between windows and sections on Settings windows.

WORKING WITH NODES IN THE MODEL BUILDER

The following methods are available to select nodes, expand and collapse branches, open the Settings window, or

move up and down the nodes in the model tree:

Click a node in the Model Builder to highlight it and to open the associated Settings window. See Settings and
Properties Windows for Feature Nodes. You can also adjust how you are Displaying Node Names, Tags, and
Types in the Model Builder.

Once a node is highlighted, there are many things you can do; for example, you can copy, duplicate, delete, and
move most nodes around. See Copying, Pasting, and Duplicating Nodes, Moving Nodes in the Model Builder,

and Clearing Sequences and Deleting Sequences or Nodes.
Right-click a node to open a context menu. See Opening Context Menus and Adding Nodes.

Group related nodes together, for better overview and structure for the model tree. See Custom Grouping of
Nodes.

When a node is highlighted, use the up arrow key on the keyboard to move to the node above; to move to the

node below, use the down arrow key.

To expand a branch to display all nodes in the branch, click the small left-pointing white triangle next to the
branch icon in the model tree, press the right arrow key, or press the multiply keypad key. To collapse a branch
to display only the main branch node, click the small downward-right pointing black triangle next to the branch
icon in the model tree, press the left arrow key, or press the divide keypad key. See The Model Builder Toolbar
for information about how to collapse or expand all branches.

A highlighted node is also dynamic and its appearance can change based on where in the modeling process you
are. See Dynamic Nodes in the Model Builder for a list of these visual cues.

@l The COMSOL Desktop Menus and Toolbars

MOVING BETWEEN WINDOWS AND SECTIONS ON THE COMSOL DESKTOP
Keyboard shortcuts are quick ways to navigate between the windows on the COMSOL Desktop and to switch focus

between windows and Settings window sections:

Press Ctrl+Tab to switch focus to the next window on the desktop.
Press Ctrl+Shift+Tab to switch focus to the previous window in the desktop.
Press Ctrl+Alt+left arrow to switch focus to the Model Builder window.

Press Ctrl+Alt+right arrow to switch focus to the Settings window.
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¢ Press Ctrl+Alt+up arrow to switch focus to the previous section in the Settings window.

e Press Ctrl+Alt+down arrow to switch focus to the next section in the Settings window.

I’i-l' The section Keyboard Shortcuts lists additional shortcuts for all operating systems.

e The COMSOL Desktop
El * The Model Builder
* Creating a New Model

Adjusting Window Location and Size on the Desktop

MOVING AND RESIZING THE WINDOW
* To move a window, click-and-drag the window tab (the tab is where the window name displays, Model Builder

for example) to where you want it.

* To resize a window, hover your mouse over the window borders until a double arrow displays. Click-and-drag

the borders between windows until the layout appears as you want it to be.

I_El At any time, in the Home toolbar, Layout group, click the Reset desktop button.

CLOSING A WINDOW

Not all windows in the COMSOL Desktop are closable. Windows that you can close have an X to the right of the
window tab. Click that X, right-click the window and choose Close, or press Ctrl+F4 (Command+W on macOS).
You can reopen a closed window by choosing it from the Windows menu (on the Home toolbar in the Windows®
version), for the Properties and Statistics window, by right-clicking a node and choosing Properties or Statistics (for

mesh statistics), respectively.

settings  Properties X i

Figure 2-3: Click the X to close the Properties window. The Settings window cannot be closed.
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FLOATING/DETACHING A WINDOW

To detach a window to move and resize it, right-click the window tab and select Float. Right-click

the window and choose Dock to return it to its default location on the Desktop.

Right-click and select the option again to dock it to the COMSOL Desktop, or drag and drop it

Linux back to where you want it.

To detach a window to move and resize it, right-click the window tab and select Detached.

HIDING OR PINNING A WINDOW TO THE SIDE OF THE DESKTOP (WINDOWS USERS)
To hide a window, right-click the window and select Hide. The window is minimized along the side of the Desktop
(see Figure 2-4). Hover over the name to view a hidden/minimized window. To restore a hidden window, either

right-click the window, or from the list, select Float or Dock.

Pinning a window performs the same action as hiding it. Click the Toggle hide button 1 in the upper-right corner
of'any window to hide and pin it to the side of the COMSOL Desktop. To return the window to its unhidden state,
hover over the window name to open it, then click the Toggle hide button (now laying on its side, see Figure 2-4)

to restore the window to its default location.

z| :
g | Model Builder ==
m
= Float
gl « TR E S - “
& | 4 4 Untitled.mph (root)
4 () Global Definitions Toggle hide

When you hide a window, it is minimized along the
side of the Desktop. Hover over the name to view
the window.

Figure 2-4: A hidden window is minimized along the side of the Desktop. Hover over the window name to view it. You
can then choose to Float or Dock the window (either right-click the window or choose options from the menu), or click the
Togyle hide icon to vestore it to the defanlt location on the Desktop.

USING THE POSITION GUIDES (WINDOWS USERS)
When customizing your COMSOL Desktop, or when you want to return a floating window to the Desktop (dock

it), there are several visual guides available to assist.

Click and hold the mouse on a window to reposition or dock it on the Desktop. This displays the positioning guides
(Figure 2-5 and Figure 2-6). Drag the window over any of the guides to highlight the area where the window is to
be placed on the desktop (Figure 2-6). The center guide has five options. There are two vertical positioning guides,
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one on the left and one on the right of the Desktop and two horizontal positioning guides, one on the top and one

on the bottom of the Desktop.

Figure 2-5: Examples of the positioning guides.
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Figure 2-6: The positioning guides display (top image) when you click and hold the mouse pointer on a window. Dray
the window over any of the guides to see the highlighted light blue avea, which indicates the destination for the window.
Release the mouse button and the window drops into place (bottom image).

CHAPTER 2: THE COMSOL MODELING ENVIRONMENT



RESIZABLE TABLES AND TEXT AREAS (WINDOWS USERS)
Some tables and text areas are resizable so that you can drag the area to extend it if it contains a lot of text. A border

that you can drag to resize a table or text area is indicated by a thicker line:

Settings ~ Properties

Materials
¥ Material Overview

Material Selection
Aluminum {matl) {ma... Domain 1
Air (mat2) {mat2} Mo domains

Figure 2-7: You can click and dray the thicker bottom border to vesize the Material Overview table.

You can also click the >> button in the top-left corner to expand the table to show its contents. If you click at the
border between two columns in a table, you can then drag to resize the column to the left of the border, or

double-click to resize that column to fit its contents.

SELECTING, COPYING, AND PASTING IN TABLES

In tables of parameters or variables, for example, you can select a row by clicking in one of the cells, and you can
select multiple rows by Shift-clicking to select a range of rows or Ctrl-clicking to select a deselect a single row.
Pressing Ctrl+A when you are editing a cell selects all text in the cell. If you are not editing a cell, the pressing
Ctrl+A select the entire table. You can right-click selected rows in a table and choose Select All.

You can also right-click to Cut, Copy, and Paste the selected table rows. Alternatively, you can use the corresponding
keyboard shortcuts Ctrl+X, Ctrl+C, and Ctrl+V.

MOVING, MINIMIZING, AND MAXIMIZING WINDOWS (MACOS AND LINUX)
* Right-click the window tab and select Move>View (to move a separate window). Move the mouse to where you

want the window to display and left-click to confirm the move.

¢ Right-click the window tab and select Move>Tab Group (to move several tabbed windows) from the list. Move

the mouse to where you want to the group of windows to display and left-click to confirm the move.

¢ To resize a window, hover the mouse over the left, right, top, or bottom boundaries of the window until a double
arrow displays. Drag the mouse to resize the window. Or right-click the window tab and select Size>Left, Right,
Top, or Bottom. A blue line highlights the choice; drag to resize.

¢ To maximize and restore a window’s original position, double-click a window tab to maximize it; double-click
again to restore it.
¢ Click the Minimize or Maximize button in the upper-right corner, or right-click the window tab and select Minimize

or Maximize from the list.

At any time, click the Reset desktop button in the main toolbar. The section Keyboard

= Shortcuts has additional shortcuts for all operating systems.
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VERTICAL OR HORIZONTAL WINDOW ORIENTATION (MACOS AND LINUX)

After a window is minimized along the side of the COMSOL Desktop, you also have the option to change the

window Orientation to Vertical (the default) or Horizontal when you click the window icon (see Figure 2-8).

When you minimize a window, it is

available to the left of the Desktop. CIick

the button to view the window.

IT Moadel Ruilder =8
= Orientation 3 Harizontal

@ | Vertical

Restor!
a®

a |

Move 3

Size

E m

Minimize
Maximize

Close

Figure 2-8: A minimized window is accessible to the left of the Desktop. Click the window icon to view it. You can then
right-click the window to Move, Size, Minimize ov Maximize the window. You can also change the Orientation of a
minimized window to be Hovizontal or Vertical when you click and view it on the Desktop in its minimized state.

e The COMSOL Desktop

@,

¢ The Model Builder

e Creating a New Model

The COMSOL Desktop Windows

The COMSOL Desktop windows, including those shown in Figure 2-1, are integral to building your model. The

windows listed in Table 2-1 are described throughout the documentation and the table includes links to this

information. You can open windows that are currently not open in the COMSOL Desktop by choosing them from

the Windows menu. The Model Builder, Settings, Graphics, and Statistics (for mesh statistics) windows cannot be

closed and are therefore not available in the Windows menu.

TABLE 2-1: COMSOL DESKTOP WINDOWS

WINDOW NAME AND LINK

DESCRIPTION

BUILDING A MODEL
The Model Wizard

The New window

The Model Builder

The Graphics Window

The Material Browser Window
The Add Material Window

Part Libraries

The Add Physics Window

The Add Multiphysics
Window

Start building a model by choosing the Component space dimension, physics
interfaces, and study.

Open the New window to begin modeling using the Model Wizard to start with a
Blank Model. See Open a New Window to Begin Modeling.

Control the modeling procedure using the model tree. This window has all the
functionality and operations for building and solving models and displaying the
results.

This window is a graphical view of the geometry, mesh, and results of the model.
It also has useful tools to change the view and select multiple geometric entities,
for example.

Browse the material libraries and load materials into your models.
Add predefined materials.

The Part Libraries contain collections of geometry parts, which serve as more
advanced geometric primitives specially created for an application area.

Add physics interfaces.
Add applicable multiphysics couplings.
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TABLE 2-1: COMSOL DESKTOP WINDOWS

WINDOW NAME AND LINK

DESCRIPTION

The Settings and Properties
windows

The Selection List Window
The Message window for
geometry measurements

The Find Results window

The Recovery Files window

The Add-in Libraries Window

The Auxiliary Data Window
The Versions Window

The Open Window

The Select File Window
The Select Model Window

The Save Window
The Add Database window

RESULTS AND ANALYSIS
The Add Study Window
The Plot Windows

The Table window

The Messages Window
The Progress Window

The Log Window

The Debug Log window

The External Process Window

Mesh Statistics

Comparing Models and
Applications

When a node is clicked in the Model Builder a corresponding Settings window
opens with the same name as the node. It is a window with settings that define
operations and properties specific to that node. The Properties window is
accessed from the context menu and displays other node properties. See Settings
and Properties Windows for Feature Nodes.

Choose objects, for example, while working with complex geometries and when
you need to easily locate a geometric entity that is not easily viewed.

A tool used to measure geometry objects and entities. See Measuring Geometry
Objects.

Displays search results from searches performed using the Find tool. See
Searching and Finding Text.

Displays any existing recovery files and provides tools for opening, saving, and
deleting recovery files. See Keeping and Opening Recovery Files.

Add an available add-in in the Model Builder from the list of add-in in this window.

View all files referenced by the current model.

View, compare, and open all versions of a model stored in a database.

Open a COMSOL Multiphysics model file from the file system or from a database.

Open a data file from the file system or from a database.

Open a model file from the file system or from a database to insert components
or physics from it.

Save a COMSOL Multiphysics model file to the file system or to a database.

Add a new database in the Model Manager. See the Model Manager Reference
Manual for more information.

Add a study or studies to models.

Plot windows are also graphics windows. These plot windows display convergence
results and monitor probe values while solving, for example.

Displays the results from integral and variable evaluations defined in Derived
Values nodes or by Probes and stored in Table nodes. It also displays results from
nodes under an Evaluation Group node. See The Table Window and Tables
Node.

Contains information useful after an operation is performed.

Displays the progress of the solver or mesher during the process, including a
progress bar and progress information for each solver or mesher.

Contains information from previous solver runs, including convergence
information, solution time, and memory use.

Contains debug information for model methods. See the Application Builder
documentation for more information about debugging methods.

Follow external processes (such as distributed batch jobs) that have been started.
The window updates when you are attached to the external processes.

This window includes information about the minimum and average mesh element
quality and a mesh element quality histogram, which shows the relative frequency
of mesh elements with different quality values.

This window includes the resulting differences from a comparison of models or
applications.
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TABLE 2-1: COMSOL DESKTOP WINDOWS

WINDOW NAME AND LINK DESCRIPTION

APPLICATION EXAMPLES

The Application Libraries Displays all the models and applications included with an installation. The folders
Window contain models and applications specific to the installed module.

The Application Library A service that provides new and updated models and applications for each of the
Update Window application libraries of the COMSOL products that your license includes.

HELP AND DOCUMENTATION

The Help Window and Provides access to context help in the COMSOL Desktop.

Topic-Based Help

The Documentation Window  Navigate to PDF or HTML versions of the documentation (availability is based on
your license), as well as Search, Bookmark, Print Topics, and Link with Contents.

The Root Settings Windows The root node is the topmost level of the Model Builder tree. When you click this

node, the root node’s Settings window opens and includes detailed information
about the model file.

* Creating a New Model
The COMSOL Desktop
COMSOL Documentation and Help

@

* Toolbars and Keyboard Shortcuts

The COMSOL Desktop Menus and Toolbars

The menus and toolbars available from the COMSOL Desktop vary slightly between operating systems. However,

the variations are subtle and the overall functionality remains the same.

The sections Windows Toolbars and Menus and Cross Platform (macOS and Linux) Toolbars and Menus show

examples of the main terms and locations of the toolbars and menus.
The Model Builder toolbar is the same for all platforms and is described in this section.
The Features Available on Toolbars and From Menus section details the available features and functions.

THE MODEL BUILDER TOOLBAR

The Model Builder toolbar is the same for all operating systems. It is located at the top of the window as shown in
Figure 2-9. The actions listed in Table 2-2 are used to navigate the Model Builder tree.

; =5
Mode "IT Model Builder

- T Etv Bl S~ = =tS

-
Builder =4

Figure 2-9: The Model Builder toolbar for Windows (left) and macOS and Linux (right).

* The COMSOL Desktop
* Creating a New Model

@,

* The Toolbars and Keyboard Shortcuts section has detailed information about the contextual
toolbars available on the COMSOL Desktop.

Windows Toolbars and Menus

The available ribbon toolbar options are dynamic, based on where in the model you are working and what is

logically available for a specific task. When a blank model is created, only the default tabs are included (Model,
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Definitions, Study, and Results). The Physics, Geometry, and Mesh tabs are added once a model and physics
interface are added to the Model Wizard, as shown in Figure 2-10.

The top of the COMSOL Desktop includes a customizable Quick Access Toolbar. Underneath this are ribbon tabs
and ribbon groups, which together, are referred to as zool/bars. The Home toolbar is a collection of frequently used
features from all the other toolbars. For documentation purposes, a toolbar uses the same name as the tab. For
example, the Home toolbar, Physics toolbar, Geometry toolbar, or Study toolbar. See The Model Builder Toolbar and
Features Available on Toolbars and From Menus for a detailed list of all the features available.

2N = w - ——— The Quick Access Toolbar displays above the

“ Hamea Nefinitinne Ranmeatne hatariale Dhuecire ribbon by defaUIt' CIiCk the sma” arrow at the
end to customize the toolbar.

File Home  Definitions  Geometry — Materials ~ Physics

A m < Pi

Application  Model Component Add Parameters
Builder ~ Manager 1- Component = -
Workspace Model
e JH RENE -

Figure 2-10: The Quick Access Toolbar can be positioned above (top) or below (bottom) the ribbons. You can also
customize the toolbar to include or exclude a variety of buttons.

CUSTOMIZE THE QUICK ACCESS TOOLBAR

The Quick Access Toolbar has several default buttons that can be displayed above or below the ribbon. Click the
small arrow at the end of the toolbar to open the Customize the Quick Access Toolbar list. You can cither edit which
of the default buttons display directly from the list, or click More Commands to Add and Remove (or double-click to
add or remove) the buttons as detailed in the section Features Available on Toolbars and From Menus. This can

also be done in The Preferences Dialog Box in the Quick Access Toolbar section.

KEYBOARD SHORTCUTS FOR THE QUICK ACCESS TOOLBAR

You can use numeric keyboard shortcuts for the buttons on the Quick Access Toolbar. To activate those keyboard
shortcuts, press the Alt key. The keyboard shortcuts (1, 2, 3, and so on) then appear underneath the Quick Access
Toolbar (see the following screenshot). Use the numbers above the characters on the keyboard and not the numeric
keypad (numpad), which is used together with the Alt key to insert special ASCII characters.

(] Y [ I = S o IS I
102(13]|4][5 a 09 08 07 06 05
F Home Definitions Geometry Materials
a= Variabl
A ma Pi _
fix) Functic
Application Thermal Add Parameters
Builder Actuator + Component ~ -

Figure 2-11: Pressing the Alt key displays the keyboard shortcuts for the Quick Access Toolbar.

DISPLAY THE QUICK ACCESS TOOLBAR ABOVE OR BELOW THE RIBBON
Right-click a ribbon to select Show Quick Access Toolbar Above the Ribbon or Show Quick Access Toolbar Below the
Ribbon. These options are also available from the Customize Quick Access Toolbar menu. See Figure 2-10.

Select Minimize the Ribbon. To restore the ribbon, right-click anywhere in the top of the window and click Minimize

the Ribbon to deactivate it (remove the check mark).

MINIMIZE (HIDE) THE RIBBON
Right-click anywhere on a ribbon and choose Minimize the Ribbon to hide the ribbon on the Desktop. To access the

ribbon features, click the ribbon tab name (for example, Model, Definitions, or Study). The ribbon features are then
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available. To restore the ribbon to the top of the Desktop, right-click in the tab name area and click to remove the

check mark next to Minimize the Ribbon.

Cross Platform (macOS and Linux) Toolbars and Menus

For cross-platform users (primarily macOS and Linux), the Main Toolbar is similar to the Quick Access Toolbar for
Windows. In addition, there is a Model Toolbar and a variety of Contextual Toolbars available. These are a mixture of
drop-down menus and buttons for frequently used actions. For documentation purposes, a toolbar uses the same
name as the contextual toolbar. For example, the Physics toolbar, Geometry toolbar, or Study toolbar. See The Model

Builder Toolbar and Features Available on Toolbars and From Menus for a detailed list of all the features available.

The Contextual Toolbar changes when you click a Definitions, Geometry, Mesh, Study, or Results node in the Model

Builder. The Model Toolbar and Contextual Toolbar are similar to the ribbon toolbars for a Windows operating

system.
EI You can also launch the cross-platform version on Windows using comsolxpl.exe.
Main menu  Main toolbar  Tools menu Model toolbar

File| Edit Windows | Options TUU|SJHE|p

[ [ [ Q| |L='Q-||! Component 1 V(QT)v|Pi a= w fix) -

Electric Currents = 3

mE e v
= — WA . ol = A _ | o oA & WL . = DOE DO DER
74 Geometry iif Materials 552 Physics A Mesh  ~do Study Results | | a | B e o 0w | COR T VI T == =

Contextual toolbar displaying in Normal mode Definitions toolbar

Figure 2-12: The menu and toolbar options for cross-platform users (usually macOS and Linux operating systems). Only
part of the Model Toolbar and Contextual Toolbars arve shown. When one of the buttons is clicked on this toolbar, the
associated toolbar opens, in this example for the Definitions node. This toolbar also opens when the Definitions node is
clicked in the Model Builder.

DISPLAY OR HIDE THE TOOLBARS FROM THE TOOLS MENU

From the Tools menu, you can choose to display or hide each toolbar. Select Main Toolbar, Model Toolbar, or
Contextual Toolbar to turn that toolbar on or off in the COMSOL Desktop. For the Toolbar Button Label, you can
also choose to Show Icon Only or Show Icon and Text. When Show Icon and Text is on it adjusts what is available on
the toolbar as some buttons in the Model Toolbar display the text, while others have the label when you hover over
the button. Finally, choose the Toolbar Display Mode as Normal or Compact. Compact compresses some buttons in the

Contextual Toolbar and Model Toolbar under menus.

If you are using a Regular Screen Layout and want to view all available buttons, the optimal settings
n are to sct the Toolbar Button Label to Show Icon Only and the Toolbar Display Mode to Compact.

OTHER USEFUL FUNCTIONS AVAILABLE FROM THE WINDOWS MENU

From the Windows menu there are also other useful functions:

* Open avariety of useful windows. See The COMSOL Desktop Windows for a list and links to applicable sections.
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e From the Model Builder Node Label submenu, choose a way to label the nodes in the Model Builder. See

Displaying Node Names, Tags, and Types in the Model Builder.

e From the Desktop Layout submenu, choose a Widescreen or Regular Screen layout, or Reset the Desktop. Sce

Customizing the Desktop Layout.

Features Available on Toolbars and From Menus

The features listed in Table 2-2 are often accessed from multiple locations. In general, the button or menu option

is located as follows, with some minor differences between Windows and the cross-platform (macOS and Linux)

systems and as described in Windows Toolbars and Menus and Cross Platform (macOS and Linux) Toolbars and

Menus.

¢ The File menu. See Figure 2-10 (Windows) and Figure 2-12 (macOS and Linux).
¢ The Model Builder toolbar. See Figure 2-9.

¢ The Quick Access Toolbar (Windows only; see Figure 2-10). Customize the toolbar to access some of the buttons

listed in the table.

¢ Main Menu and a Main Toolbar (macOS and Linux, see Figure 2-12).

¢ Additional menus along the top of the Desktop: Edit, Windows, Options. Tools, and Help (macOS and Linux, see

Figure 2-12).

TABLE 2-2: FEATURES AVAILABLE ON VARIOUS TOOLBARS AND FROM MENUS

ICON NAME

DESCRIPTION OR LINK TO MORE INFORMATION

Creating Models

[N New (Ctrl+N)

» Blank Model

Modeling Workspaces

A Application Builder
(Ctrl+Shift+A)

ii Model Builder
(Ctrl+Shife+M)

Model Manager
(Ctrl+Shift+))

Open the New window to begin modeling using the Model Wizard or start with a
Blank Model. See Creating a New Model.

For all users, this is available from the File menu. It is also available on the Quick
Access Toolbar (Windows users) or the Main Toolbar (cross-platform users).

Additional options are available when check boxes are enabled on the Preferences
dialog box under Physics Builder.

Start a new blank model without any settings. This command is available after choose
File>New. It is also available on the Quick Access Toolbar (Windows users).

Move to the Application Builder. For Windows users this is available in the Home
toolbar and the Developer toolbar. It is also available on the Quick Access Toolbar
(Windows users).

Move to the Model Builder. For Windows users this is available in the Home toolbar.
It is also available on the Quick Access Toolbar (Windows users).

Move to the Model Manager. For Windows users this is available in the Home toolbar.
It is also available on the Quick Access Toolbar (Windows users).

Working in the Application Builder

UEl Data Access

E. Record Method

Add data and properties that can be modified from a running application. For
Windows users this is available in the Developer toolbar. See Data Access in the
Application Builder Reference Manual.

Record changes to the embedded model to a new method. For Windows users this is
available in the Developer toolbar. See Recording Code in the Application Builder
Reference Manual.
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TABLE 2-2: FEATURES AVAILABLE ON VARIOUS TOOLBARS AND FROM MENUS

ICON NAME

DESCRIPTION OR LINK TO MORE INFORMATION

[ Test Application

(Ctrl+F8)
Run Application
[E_‘ Compiler

Opening and Saving Files

3 Open (Ctrl+O)

=  Open From
(Ctrl+Shife+O)

% Recent

Find

| Application Libraries

g Open Recovery File

U Save (Ctrl+S)

EN| Save As

Launch the application in a separate window. For Windows users this is available in
the Developer toolbar and on the Quick Access Toolbar. See Testing the Application
in the Application Builder Reference Manual.

Run an application as a standalone application using a custom user interface. For all
users, this is available from the File menu. It is also available on the Quick Access
Toolbar (Windows users).

Compile an application to run separately from COMSOL Multiphysics or COMSOL
Server as a standalone executable application. Requires a license for COMSOL
Compiler.

Open an existing file from the file system using the Open dialog box that opens.

For all users, this is available from the File menu. It is also available on the Quick
Access Toolbar (Windows users) or the Main Toolbar (cross-platform users).

Open an existing file located on the computer or in a database using the Open
window (see The Open Window). From that window, you can also add and access
databases.

For all users, this is available from the File menu. It is also available on the Quick
Access Toolbar (Windows users) or the Main Toolbar (cross-platform users).

From the File menu, select a recent model file to open. For Windows users, the file is
selected from the Recent submenu. For cross-platform users, the most recent files
are listed at the bottom of the list. Choose View All Recent Models to open the Open
window, which contains a longer list of recent files.

Windows users can also customize the Quick Access Toolbar to access a Recent File
button, which you can click to revert to the most recent file.

Displays search results from searches performed using the Find tool. Press Ctrl+F.
Windows users can also customize the Quick Access Toolbar to access this button.
See Searching and Finding Text.

Open The Application Libraries Window.

For Windows users, this is available in the Home toolbar’s Windows menu or from the
File menu. You can also customize the Quick Access Toolbar and then click the
button.

For cross-platform users, this is available from the File menu.

COMSOL Multiphysics can store recovery files each time you start a solver. This is a
preference setting that is initially active by default. For all users, this is available from
the File menu. It is also available on a customized Quick Access Toolbar (Windows
users).

See Keeping and Opening Recovery Files.
Save the current file. For all users, this is available from the File menu. It is also
available on the Quick Access Toolbar (Windows users) or the Main Toolbar

(cross-platform users). If the file has not been saved before, the Save As dialog box
appears.

See Saving COMSOL Files.

Choose to save in one of the COMSOL file formats. The Save As dialog box opens,
and from the Save as type list select: COMSOL Application (*.mph) (the default), Model
file for Java (*.java), Model file for MATLAB (*.m), or Model File for Visual Basic
(*.vba).

For all users, this is available from the File menu. It is also available on the Quick
Access Toolbar (Windows users).

See About the COMSOL Model File Formats.
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TABLE 2-2: FEATURES AVAILABLE ON VARIOUS TOOLBARS AND FROM MENUS

ICON NAME

DESCRIPTION OR LINK TO MORE INFORMATION

P‘ Save To
(Ctrl+Shife+S)

=] Revert to Saved

) Compact History

Run Application

Choose to save in one of the COMSOL file formats. The Save window opens (see
The Save Window), and when you click Browse, the Save As dialog box opens. From
the Save as type list select: COMSOL Application (*.mph) (the default), Model file for
Java (*.java), Model file for MATLAB (*.m), or Model File for Visual Basic (*.vba).

For all users, this is available from the File menu.
See About the COMSOL Model File Formats.

Opens the last saved version of the file and reinitializes the GUI. For all users, this is
available from the File menu. It is also available on a customized Quick Access Toolbar
(Windows users) or the Main Toolbar (cross-platform users).

See Reverting to the Last Saved File.

The files for Java and for MATLAB contain the entire model history, including settings
that are no longer part of the model or application. For all users, this is available from
the File menu. It is also available on a customized Quick Access Toolbar (Windows
users).

See Compacting the History.
Run an application created using the Application Builder.

For all users, this is available from the File menu. It is also available on the Quick
Access Toolbar (Windows users) or the Main Toolbar (cross-platform users).

COMSOL Multiphysics Server

= Connect to Server

[ Disconnect from
Server

=, Import Application

from Server

i

Remove
Applications from
Server

Model Builder Toolbar

+“— Previous Node
(Alt+Left)

. Next Node
(Alt+Right)

= Show More Options

To connect to a server from the COMSOL Desktop. For all users, this is available
from the File>COMSOL Multiphysics Server menu. It is also available on a customized
Quick Access Toolbar (Windows users).

See Connecting to a COMSOL Multiphysics Server.

To close the connection to the server or MATLAB. For all users, this is available from
the File>COMSOL Multiphysics Server menu. It is also available on a customized Quick
Access Toolbar (Windows users).

See Disconnecting from a COMSOL Multiphysics Server.

To import a particular application when working with MATLAB, Excel, or the
COMSOL API. For all users, this is available from the

File>COMSOL Multiphysics Server menu. It is also available on a customized Quick
Access Toolbar (Windows users).

See Working with MATLAB, Excel, or the COMSOL APIL.
To delete applications (remove them from the server) that you have created using

ModelUtil. For all users, this is available from the File>COMSOL Multiphysics Server
menu. It is also available on a customized Quick Access Toolbar (Windows users).

See Working with MATLAB, Excel, or the COMSOL APIL.

Navigate back to the node previously selected or to the next node in the sequence.
See also Keyboard Shortcuts.

Click to select options to display from the Show More Options dialog box. See
Showing More Options.
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TABLE 2-2: FEATURES AVAILABLE ON VARIOUS TOOLBARS AND FROM MENUS

ICON  NAME DESCRIPTION OR LINK TO MORE INFORMATION

=T Collapse Click the Collapse All or Expand All buttons to collapse or expand all nodes in the
Expand model tree, except the top nodes on the main branch, or click the downward arrow

= next to the button to choose Collapse Selected or Expand Selected to collapse or

Model Builder Node
Label

expand nodes in the selected branch of the model tree (or use the divide and multiply
keypad keys, respectively) or Collapse All or Expand All.

Choose to display any combination of Name, Tag, or Type. See Displaying Node
Names, Tags, and Types in the Model Builder and Settings and Properties
Windows for Feature Nodes.

Undo, Redo, Copy, Paste, Duplicate, and Delete

0

5]

B

Undo (Ctrl+Z)
Redo (Ctrl+Y)

Copy

Paste

Duplicate

Delete (Del)

Select All

Clear Selection

Reset Desktop

Licensed and Used
Products

Undo and Redo the last operation for some operations (such as adding, disabling,
moving, and deleting nodes in the Model Builder) as well as changing values in the
Settings window.

For Windows users, this is available on the Quick Access Toolbar.
For cross-platform users, this is available in the Main Toolbar or from the Edit menu.
See Undoing and Redoing Operations.

Copy, paste, and duplicate some features. Also right-click a node to select one of
these options from the context menu.

For Windows users, this is available on the Quick Access Toolbar.
For cross-platform users, this is available in the Main Toolbar or from the Edit menu.

See Copying, Pasting, and Duplicating Nodes.

Delete some nodes while building 2 model, or delete a selected geometry object.
Also press the Del key or right-click a node to select this option from the context
menu.

For Windows users, this is available on the Quick Access Toolbar.
For cross-platform users, this is available in the Main Toolbar or from the Edit menu.
See Clearing Sequences and Deleting Sequences or Nodes.

To select all or clear the selection of all geometric entities in the Graphics window,
click the Select All or Clear Selection buttons, respectively.

For Windows users, this is available on the Quick Access Toolbar. For cross-platform
users, this is available from the Edit menu.

See Selecting and Clearing Selection of Geometric Entities.

Set the COMSOL Desktop back to widescreen or regular screen, or reset it to
default settings.

For Windows users, this is available in the Home toolbar, in the Layout menu. You can
also customize the Quick Access Toolbar and then click the button.

For cross-platform users, this is available in the Main Toolbar or from the
Windows>Desktop Layout menu.

See Customizing the Desktop Layout.

Open the Licensed and Used Products window to list or block the products your
license includes. See Checking and Controlling Products and Licenses Used.

For Windows users, this is available from the File menu. You can also customize the
Quick Access Toolbar and then click the button.

For cross-platform users, this is available from the Options menu.
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TABLE 2-2: FEATURES AVAILABLE ON VARIOUS TOOLBARS AND FROM MENUS

ICON  NAME DESCRIPTION OR LINK TO MORE INFORMATION

Preferences To make changes to how items are displayed or available throughout the COMSOL
Multiphysics software. See Preferences Settings.
For Windows users, this is available from the File menu. You can also customize the
Quick Access Toolbar and then click the button.
For cross-platform users, this is available from the Options menu.

= Measure Measure geometric properties such as volumes (see Measuring Geometry Objects).
Available in the Geometry toolbar. Also, for Windows users, you can customize the
Quick Access Toolbar and then click the button.

E Group (Ctrl+G) Group related and similar nodes under a Group node. Available in several parts of

Ungroup
(Ctrl+Shift+G)

Refresh Add-Ins

Help and Documentation

o

Help (FI)

Documentation
(Ctrl+F1)

Application Gallery

Support Center

Training

Check for Product
Updates

Update COMSOL
Application Libraries

Update COMSOL
Part Libraries

About COMSOL
Multiphysics

the model tree (see Custom Grouping of Nodes). Also, for Windows users, you
can customize the Quick Access Toolbar and then click the button.

Ungroup nodes that are grouped under a Group node. Available in several parts of
the model tree (see Custom Grouping of Nodes). Also, for Windows users, you
can customize the Quick Access Toolbar and then click the button.

Refresh available add-ins. For Windows users, this is available in the Developer

toolbar. You can also customize the Quick Access Toolbar and then click the button.

Open the context help. See COMSOL Documentation and Help.

For Windows users, this is available from the File>Help menu or in the upper-right
corner of the Desktop.

For cross-platform users, this is available in the Main Toolbar or from the Help menu.

Open the Documentation.

For Windows users, this is available from the File>Help menu.

For cross-platform users, this is available in the Main Toolbar or from the Help menu.

See COMSOL Documentation and Help.
Go to the online Application Gallery on the COMSOL website.

For Windows users, this is available from the File>Help menu. For cross-platform
users, this is available from the Help menu.

Go to the online Support Center on the COMSOL website.

For Windows users, this is available from the File>Help menu. For cross-platform
users, this is available from the Help menu.

Go to the Training page on the COMSOL website.

For Windows users, this is available from the File>Help menu. For cross-platform
users, this is available from the Help menu.

For Windows users, this is available from the File>Help menu. For cross-platform
users, this is available from the Help menu.

See Checking for Product Software Updates.

For Windows users, this is available from the File>Help menu. For cross-platform
users, this is available from the Help menu.

See The Application Library Update Window

For Windows users, this is available from the File>Help menu. For cross-platform
users, this is available from the Help menu.

See The Part Library Update Window

For Windows users, this is available from the File>Help menu. For cross-platform
users, this is available from the Help menu.

See The About COMSOL Multiphysics Box.
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The Messages Window

The Messages window ([-7 ) displays by default and contains information useful to you after an operation is

performed.
The information in this window includes:

* Details about opening and saving model files such as MPH-files.
¢ Information about geometry objects imported from CAD files.
* On the Mesh and Geometry toolbars, click the Measure (= ) button to view information about:

- The geometry finalization (forming a union or an assembly) and about the number of geometric entities

(domains, boundaries, and so on) in the finalized geometry.
- The number of mesh elements and degrees of freedom in the model.
* Solution times.
* Error messages. The messages are in chronological order and can be scrolled through.
By default, the messages are preceded by a timestamp, providing the current date and time for the message. To turn

off the timestamps, open the Preferences dialog box and clear the Add timestamps to messages check box on the

General page under Log and messages.
To open the Messages window:

* From the Home toolbar (Windows users) select Windows>Messages.
¢ From the main menu (macOS and Linux users) select Windows>Messages.
To clear the window of all messages, click the Clear button ( % ). Click to select the Show on New Message button

([=))- When selected, the Messages window will be brought on top when there is a new message, but it will not be

opened if it is closed.

* Meshing
El * Geometry Modeling and CAD Tools

¢ Studies and Solvers

The Auxiliary Data Window

The Auxiliary Data window shows all input files, output files, and input models (parts) that are associated with the
current model. For each entry in the table, you can see what part of the model it belongs to, what its current data
source is, and other information about its current status. See also Auxiliary Data From Databases in the Mode!

Manager Reference Manual.
The table contains the following columns:

¢ The feature icon column — icons representing features that have the input file, output file, or input model
property.
e The Node column — descriptions of the owning feature as the label followed by the model path in parentheses,

such as Global Least Squares Objective | (Component | > Optimization).

¢ The Property column — descriptions of the input file, output file, or input model property on the form of a

description followed by a property context in parentheses, such as Filename (Experimental Data).

* The source icon column — icons representing the current data source (for example, a file in the database).
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e The Source column — descriptions of the current data source.

* The Status column — descriptions of the status of the data sources with respect to versioning and embedding.

Right-click any row in the table to choose Go to Node ( Z+ ) or Set Source (P (sec below). If the Status column say
Database not connected, you can also choose Connect to Database ( .*") to reconnect to the database from which the

auxiliary data has been taken. If you successfully reconnect to the database, the Status column shows Up to date.
Click the table headers to sort the table according to the content in the column of the clicked header.
The toolbar above the table contains the following toolbar buttons, which are enabled when they are applicable:

* Click the Refresh Auxiliary Data Status button ((# ) to refresh the status of all entries in the table.

¢ From the Filter Type list ("= ) you can choose two filter options, List only with Source and List only Active:

- Select List only with Source to only show items that have a data source set. When deselected, it will show all

items, including those with no source set.

- Select List only Active to hide inactive auxiliary data. Auxiliary data that is actsve is data that is currently

accepting a value input for its source (for example, a file input not hidden by a group property).

An example in the user interface is the Data source list in the Settings windows for a global Interpolation node.
Here, Data source is a list where File, Local table, and Result table can be selected. The corresponding file input
in the Auxiliary Data window will only be active if File is selected. If File is not selected, and the List only Active

filter is enabled, the corresponding file input will not appear in the Auxiliary Data window.

* Click the Go to Node button ( ¥ ) to move to and select the feature in Model Builder that includes the data. You

can also right-click a data row in the table and choose Go to Node.

* Click the Set Source button (=) to open the Select File window to select a new data source for the selected file

input entry. You can also right-click a data row in the table and choose Set Source.
* Click the Import to Database button ([T ) to import the file into a database.
* Click the Update to Latest Version button ( (%)) to update the selected file to the newest version that is available.

* Click the Show Source Location button (i), when enabled, to show the source location for the auxiliary data.
If you select an item in the auxiliary data table that points to a database stored file, it shows the corresponding
file version in the Versions window in the Model Manager (see The Versions Window in the Model Manager
Reference Manual). In case of a file on the file system, Show Source Location shows the file on the file system in
a system explorer. In case of an embedded or uploaded file, Show Source Location will go to the source (the file
container in this case) in the Application Builder. You can also right-click a data row in the table and choose Show

Source Location.

The Versions Window

The Versions window contains a list of versions stored in a database for a model. It shows the history of the model
currently opened in the COMSOL Desktop when that model has been opened from a database or was last saved
to a database. You can use the Versions window to get an overview of recently saved versions, compare two versions
of a model, open older versions, and even restore as the latest version. See also The Versions Window for the
COMSOL Desktop Model in the Model Manager Reference Manual.

The current version is shown in a boldface font.

The toolbar on top of the Version window contains the following toolbar buttons, which are enabled when they are

applicable:

* Click the Refresh button (¥ ) to refresh the table in case a new version has been saved by someone else.

¢ Click the Show More button (= |) to add more versions to the table.
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Click the Version Details button ( = ) to open the Version Details dialog box, which contains more information
about the selected version. You can also right-click a selected model and choose Version Details.

Click the Open button (|5 ) to open the selected model version in the COMSOL Desktop. You can also
right-click a selected model and choose Open.

Click the Run button ( p ) to open and run a select version of an application; for other COMSOL models, this
option is not available.

Click the Compare button (:l'_) to compare the selected version of a model with the current model that has been
opened in the COMSOL Desktop, or select two different versions to compare those to each other. You can also
right-click a model version and choose Compare to compare it to the current model or right-click two selected

model versions and choose Compare to compare those versions to each other.

Click the Restore Version button ( () ) to save the selected version of the model as a new latest version. You can
also right-click a selected model and choose Restore Version.

In addition, you can right-click a model version and choose these options:

Select Copy Location ( []) to create a text string with a URI that uniquely identifies the model version in the
database and copy it to the clipboard.

Select Permanently Delete Version ( 3¢ ) to permanently delete the selected version in the database. This change
cannot be undone.

COMSOL Desktop Color Themes

There are three color theme preferences, which you can specify on the Color Themes page in the Preferences dialog

box:

The Desktop color theme, which controls the look of all windows and user interface components except the
Graphics window and the Help window. For the COMSOL Desktop, you can choose between a Default, Light,
or Dark theme. The Light and Dark options put the COMSOL Desktop in a light mode and dark mode,
respectively.

The Graphics color theme, which controls the colors in the Graphics windows. The default is Same as desktop
color theme; that is, to use the same theme as the desktop. You can also choose Basic, COMSOL, Dark, DarkSelection,
Default, Light, LightSelection, and RYB.

The Image export color theme, which controls the look of exported images. The reason to have a separate setting
is to make it possible to, for example, run the COMSOL Desktop in dark mode while still making light-mode

image files. The Default color theme is the default setting. You can also choose Same as graphics color theme, Basic,
COMSOL, Dark, DarkSelection, Light, LightSelection, and RYB. You can also specify the color theme when printing

and exporting images using the Print and Image Snapshot dialog boxes (see Capturing and Copying Screenshots).

The following built-in color themes are available:

The Basic color theme is based on basic colors such as red, green, blue, yellow, cyan, magenta, orange, rose,

azure, violet, crimson, purple, cerise, amber, and aquamarine.
The COMSOL color theme is based on the COMSOL brand-related colors.
The Dark and DarkSelection color themes provide colors for a dark mode.

The Default color theme provides colors similar to those in previous COMSOL versions. The default colors that

are used for colored selections are chosen for maximum usability.

CHAPTER 2: THE COMSOL MODELING ENVIRONMENT



e The Light and LightSelection color themes provide colors for a light mode.

e The RYB color theme is based on primary to quaternary RYB (red-yellow-blue) colors.

When using the dark mode on Linux®, some controls take their color from the operating system’s
. theme. It is therefore recommended to pick an operating system theme that works well together
=] with the COMSOL theme (a dark-looking theme in Linux together with the dark mode in the
COMSOL Desktop, for instance).

The built-in color themes are stored in the data/colors folder. You can also define user-defined color themes as
text files in the v60/colors preference folder. See Color Tables and Color Themes in the COMSOL Multiphysics
Programming Reference Manual.

The color settings that are not included in a color theme get the default colors depending on whether the desktop

color theme is the dark theme or the light or default theme.

Figure 2-13: The COMSOL Desktop when using the dark theme.

About Context Menus in the Graphics Window

Right-click in the Graphics window to access a context menu, where the content varies depends on the currently
selected node in the Model Builder. There are separate context menus for Geometry (also a separate one in the 2D
sketch mode), Definitions, Materials, the physics interfaces, Multiphysics, and Mesh. For results, the context menu

contains some zoom tools.

The context menu content is different depending on if there is a preselection (see Basic Selection Concepts) in the
Graphics window or not. When there is a preselection, new features can be added from the menu taking the

preselection as its selection. The context menu for physics, for example, only includes the features that can use the
preselection. If the menu does not contain what you want, a Go Te submenu is available for moving to another node
in the Model Builder while keeping the preselection, if possible. You can then right-click again and select the feature

you want to add.

THE COMSOL DESKTOP | 8l



82 |

If you right-click on a gizmo for a clipping tool, a special context menu appears for modifying the clipping tool.

Additional information about context menus is available in connection with the various contexts

= where it appear.

* The Graphics Context Menu (for geometry)

* The Graphics Context Menu (for meshing)

About the COMSOL Model File Formats

Below find a list of the COMSOL file formats: MPH-files for applications and models, model files for Java, model
files for MATLAB, and model files for VBA.

THE ROOT NODE

When you first open or create a new model, the 700t node (43 ) is the topmost level of the tree. By default,
unnamed files are called Untitled.mph. The filename changes when the file is saved for the first time, but the root
node Name does not change for this top level node. See The Root Settings Windows for details about the settings

available when this node is clicked.

COMSOL MPH-FILES
The default standard file format with the extension .mph. The files contain binary and text data. The mesh and

solution data are stored as binary data, while all other information is stored as plain text.

You can quickly save and load MPH-files. All models and applications in the COMSOL Application Libraries in the

modules are saved as MPH-files.
The MPH-files in the COMSOL Application Libraries can have three formats:

* Solved MPH-files include all meshes and solutions. In the Application Libraries window these files appear with
the icon @ . If the MPH-file’s size exceeds 25MB, a tooltip with the text “Large file” and the file size appears

when you position the cursor at the node in the Application Libraries tree.

o Compact MPH-files include all settings but have no built meshes and solution data to save space (a few compact
MPH-files have no solutions for other reasons). You can open these to study the settings and to mesh and
re-solve it. It is also possible to download the full versions — with meshes and solutions — of most of these
through Application Library Update (see The Application Library Update Window). In the Application Libraries
window these appear with the icon ¢ . If you position the cursor at a compact file in the Application Libraries
window, a No solutions stored message appears. If a full MPH-file is available for download, the corresponding

node’s context menu includes a Download File With Solution icon ( & ).
There can also be preview files for application library model MPH-files that have not been downloaded.

File Locking

Only one user can open and edit an MPH-file at the same time. If you try to open an MPH-file that is already open
in another user’s COMSOL Desktop, that MPH-file is locked, and you get an option to open the MPH-file in a
read-only mode (click Open As Read-Only). That means that you can edit the model but you cannot save it unless
you save the MPH-file under another name. When an MPH-file is locked, COMSOL creates a separate lock file
with the same filename as the MPH-file plus the extension . lock, stored in the same directory as the locked
MPH-file. If a lock file remains after all COMSOL Desktop sessions have ended (which can happen if the
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COMSOL Desktop session is ended in a nonstandard way), you can reset the lock when trying to open the file the
next time by clicking Reset Lock and Open.

Linux and macOS do not support operating system locking of files. On those platforms, locking is
I’i-l' supported to help users avoid editing the same COMSOL Multiphysics model file, but it is possible
to ignore the file locking and delete the lock files.

MODEL FILES FOR JAVA

Editable script files that contain sequences of COMSOL commands as Java code (see the COMSOL Multiphysics
Programming Reference Manual for more information about these commands). You can compile these Java files
and run them as separate applications. Edit the files in a text editor to add additional commands. For parts of the
model that appears under a component (such as the geometry, physics, and mesh), the default format is to include
the component level in the Java code. If you want do not want to include the component level, clear the Use

component syntax check box on the Methods page in the Preferences dialog box.

When saving a Model Java-file history for running a method call in the COMSOL Desktop, it
I_El contains the history produced while running the method call and not the method itself.

MODEL FILES FOR MATLAB

Model files for MATLAB are editable script files (M-files), similar to the model files for Java, for use with MATLAB.
A model file for MATLAB contains a sequence of COMSOL commands as an M-file. You can run these model files
in MATLAB like any other M-file scripts. You can also edit the files in a text editor to include additional COMSOL
commands or general MATLAB commands.

El Running model files in the M-file format requires LiveLink™ for MATLAB®.

MODEL FILES FOR VBA

Model files for VBA are editable script files (VBA-files), similar to the model files for Java, for use with VBA (Visual
Basic for Applications) in Microsoft Excel®. A model file for VBA contains a sequence of COMSOL commands as
a VBA-file (extension .vba). You can use these files from Excel® to access settings and data in COMSOL models.

|'E-|' Using model files in the VBA format requires LiveLink™ for Excel®.

* The Application Libraries Window
* Saving COMSOL Files

El * Reverting to the Last Saved File
* Printing and Capturing Screenshots

* Keeping and Opening Recovery Files

Saving COMSOL Files

The following options are selected from different menus and toolbars as described in The COMSOL Desktop

Menus and Toolbars.
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SAVING A NEW MODEL OR APPLICATION

If this is the first time saving a model or application, or if you want to update the file and keep the current name
and format, in general, these are the ways to save a model:

¢ Click the Save ( [_]) button on the Quick Access Toolbar or Main Toolbar.

e Press Ctrl+S.

¢ Select File>Save.

If you save a model or application that was previously saved in an earlier version of COMSOL
Multiphysics, you get a question about if you want to continue to save the file, thereby overwriting
the original file with a new file that has been converted so that it can only be opened in version

6.0. Select the Do not show this message again check box if desired. There is also a preference setting

[

on the Save page in the Preferences dialog box. Under Saving COMSOL application files, clear the
Warn before saving an application previously saved in an older version of COMSOL check box (selected

by default) to turn off this question.

To save a model or application to a database, use one of these ways:

¢ Click the Save To ( EE_“ ) button on the Quick Access Toolbar or Main Toolbar.
e Press Ctrl+Shift+S.

¢ Seclect File>Save To
See also The Save Window below.
CREATING A COPY USING SAVE AS

If the model has been saved before and you want to create a copy you can choose to save in one of the COMSOL
file formats (see COMSOL MPH-Files, Model Files for Java, and Model Files for MATLAB).

Select File>Save As. The Save As window opens, and from the Save as type list select COMSOL Application (*.mph) (the
default), Model file for Java (*.java), Model file for MATLAB (*.m), or COMSOL File for VBA (*.vba).

In all cases, navigate to the location where you want to save the model, enter a File name, and then click Save.

You can add the author to the header of model files for Java and for MATLAB that are saved. Open
I_El The Preferences Dialog Box and under General>History export, sclect the Include author check box.

REVERTING TO THE LAST SAVED FILE
To open the last saved version of the file and reinitialize the GUI, select File>Revert to Saved ( [2] ). For Windows
users, you can also customize the Quick Access Toolbar and then click the Revert to Saved button.

COMPACTING THE HISTORY
The COMSOL files for Java and for MATLAB contain the entire history of the model, including settings that are
no longer part of it. To compact the history so that the files only include the settings that are part of the current
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model, select File>Compact History. For Windows users, you can also customize the Quick Access Toolbar and then

click the Compact History ( <) ) button.

Compacting the history works best if you make sure that the geometry is built before running
File>Compact History.

Also, compacting the history may not work as expected in the following situations:

* Compact history is not supported for imported meshes defined by datasets.

* Compact history is not supported for models with deformed geometry configurations.

[

* When a dataset points to a component that has been deleted.

* The compacted history can be wrong when the Interfering faces list in the Detect Interference

node is active.

* If the geometry has changed since solving, selections for some result features will be missing in

the compacted history.

* Ifyou have renamed tags for some of the nodes in the model.

See also “History Logging Methods” in the COMSOL Multiphysics Programming Reference.

WHEN SAVING, OPTIMIZING FOR SPEED OR FILE SIZE

You can choose to save COMSOL files (MPH-files) that are optimized for speed (the default, using uncompressed
files that are faster to save) or optimized for file size (using compressed files). In the Preferences dialog box (see
Preferences Settings), click Save and choose Speed or File size from the Optimize for list under Saving COMSOL

application files.

¢ About the COMSOL Model File Formats
¢ Windows Toolbars and Menus
The Root Settings Windows

* Printing and Capturing Screenshots

The Save Window

When you choose Save To from the File menu or press Ctrl+Shift+S, the Save window opens. In that window, you
can choose from the following options:

¢ Click any available Model Manager database to save a model, application, or physics to that database. See Saving
Models to Databases in the Model Manager Reference Manual.

¢ Click Add Database ([ ) to add a new database using the Add Database window that opens. See Adding
Databases in the Model Manager Reference Manual.

* Click Browse ( &) to open the Save As dialog box and choose a location, filename and file type for the model file.

Click Cancel (J}) to exit this window.
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The Open Window

When you choose Open From from the File menu or press Ctrl+Shift+O, the Open window opens. In that window,
you can choose from the following options:

* Click Recent ( (1)) to list recently opened models in the list to the right. Select a model and click Open ([ =) to
open the model in the COMSOL Desktop. If the file is a COMSOL app, click Run ( p ) to launch and run the
app directly.

¢ Click any available Model Manager database (/= ) to open models, applications, or physics from that database.
See Opening Models from Databases in the Model Manager Reference Manual.

¢ Click Add Database (/= ) to add a new database using the Add Database window that opens. See Adding
Databases in the Model Manager Reference Manual.

* Click Browse ( & ) to open the Open dialog box and choose a location and filename of the model file to open.

Click Cancel (J}) to exit this window.

The Select File Window

When you choose Browse From when choosing a data file in the Settings window for an Interpolation function, for

example, the Select File window opens. In that window, you can choose from the following options:

* Click Recent ( (1)) to list recently opened data files in the list to the right. Above the list of files, you can see the
target for the file import, and to the right of the list of files you can choose a filter for the file type. Click the
Select button below the list to use the selected file and return to the Settings window from which you opened

the Select File window.

¢ Click the current model file (MPH-file) to select a data file to use from its settings in the same way as for the
Recent option.

* Click any available Model Manager database (/=] ) to select a data file from that database. Selecting Auxiliary
Data Files in Databases in the Model Manager Refevence Manual.

* Click Add Database ( .= ) to add a new database using the Add Database window that opens. See Adding
Databases in the Model Manager Reference Manual.

* Click Browse ( & ) to open a file browsing dialog box (Interpolation Data, for example) and choose a location

and filename of the data file to open.

Click Cancel (g) to exit this window.

The Select Model Window

When you right-click the root node and choose Insert Components From (T2 ) or right-click a Component node and
choose Insert Physics From (T2 ), the Select Model window opens. You can also open if by right-clicking a Materials
node and choose Import Materials From ([T, ) or by selecting Import Material From from the Import Materials menu

on the Materials toolbar. In that window, you can choose from the following options:

¢ Click any available Model Manager database (£ ) to select a model from that database from which to insert
components or physics. See Inserting Components, Materials, and Physics from Databases in the Model
Manager Reference Manual.

¢ Click Add Database ([ ) to add a new database using the Add Database window that opens. See Adding
Databases in the Model Manager Reference Manual.

* Click Browse ( & ) to open a file browsing dialog box (Interpolation Data, for example) and choose a location
and filename of the model file to open.
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Click Cancel (g) to exit this window.

Keeping and Opening Recovery Files

The COMSOL Multiphysics software can save and keep recovery files each time you start a solver. This setting is

initially active by default. If the server has lost contact with the client, a recovery file is also saved or kept.

If any recovery files exist, the Recovery Files window is open when you start the COMSOL Desktop. You can also

open the Recovery Files window from the Windows menu.

The update of the recovery file occurs at the following events:

¢ After completing the solution for each time step specified as the output times in the Times field for a
time-dependent simulation.

¢ After completing each parameter step in a parametric simulation.

* After completing each successful Newton iteration for a nonlinear stationary simulation.

The recovery files are COMSOL MPH-files that represent the state at the time that they were saved. They make it
possible to recover from a solver error, which can be especially useful for long time-dependent or parametric runs.

You can control the use of recovery files using the buttons at the top of the Recovery Files window:

* Click the Open button ([ ) to open a selected recovery file. Opening the recovery files this way ensures that the
recovery file can be deleted without compromising the open model. It does not remove the recovery file when

the open model is saved though

* Click the Save and Open ( [L|) button saves the recovery file to a Model MPH-file and open it. It also removes
the recovery file.

* Click the Save As button ([[3] ) to save the recovery file to a Model MPH-file and remove the recovery file.

¢ Click the Delete button ( W ) or press Delete to remove the selected recovery files.

The COMSOL Multiphysics software keeps track of the computed time steps or parameter steps in the recovery
file, so right-click the Study node and select Continue (== ) to continue the computation from the point where it
was stored in the recovery file. If you are solving a stationary nonparametric problem, the last converged Newton

iteration is stored in the recovery file; selecting Continue causes the software to resume solving from this stored state.
You can make changes to these default settings in The Preferences Dialog Box in the Files section.

¢ The Keep recovery files when the application terminates unexpectedly check box is selected by default to keep

recovery files on disk during the solution process for time-dependent, parametric, and nonlinear solvers.

e The Check for recovery files at launch check box is selected by default so that the Recovery Files window opens at

launch when there are any recovery files.

* In the Folder for recovery files ficld, you can specify a different folder from the default to, for example, use a folder
on the server where there is more disk space for keeping large recovery files. Click Browse to browse to a recovery
file folder.

* In the Folder for temporary files ficld you can specify a different folder than the default to, for example, use a
folder where there is more disk space for keeping large temporary files. Click Browse to browse to a folder for

temporary files.

e Ifyou run the COMSOL Multiphysics software in a client-server configuration, you can specify a Folder for

temporary files on client and a Folder for temporary files on server.

@l Studies and Solvers
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The Root Settings Windows

The root node is the topmost level of the Model Builder tree and the Explorer tree in the Application Builder. When
you click this node, the Settings window for the root node (<@, or [=] in the Application Builder) opens and
includes detailed information about the model file.

Some of the fields in the root node’s Settings window can be edited directly in this window, while others display
system information that cannot be changed, or information that changes as updates are made throughout the
model (for example, adding a node that requires an additional module license). The Settings window includes the

following sections:

PROTECTION

Click Set Password next to Editing not protected or Running not protected to enter a password in the Protect Edit
with Password or Protect Running with Password dialog boxes. To change the password, click Change Password to
enter the previous password and a new password in the Protect Edit with Password or Protect Running with Password

dialog boxes. Note that, for the password that protects editing, lost passwords cannot be recovered.

USED PRODUCTS

The information included here is based on the purchased license or modules. See Checking and Controlling
Products and Licenses Used. Also see The About COMSOL Multiphysics Box.

UNIT SYSTEM
The default unit system is SI units. If desired, select another unit system from the list, or select None for no units.

See Unit Systems and Setting the Unit System for Models to change the setting globally or locally.

PRESENTATION

In this section you can specify a title and a description of the model. By default, these texts are used on the title
page of a report; see The Title Page. Under Computation time, you can enter an expected computation time in the
Expected field. Also, the time after Last is the last measured computation time (if available). To illustrate the model
you can also set an image as a thumbnail that displays in this section, when opening a file in the Application Libraries
window, and as the default report title page image. See the section Setting and Clearing the Thumbnail Image for

details about how to do this.

SAVE
In this section you specify what to include when saving the model file, either as a file on the file system or in a

database using the Model Manager.

Under Built, computed, and plotted data, from the On file list, choose Include (the default) or Exclude to include or
exclude such data in the saved model file. Also, from the In database list, choose Include in regular and draft versions
(the default), Include in regular versions, Include in draft versions, or Exclude to control what to include when saving

models in a Model Manager database.

This settings are also available in the Preferences dialog box, on the Save page under Built, computed, and plotted
data: The Default on file and Default in database lists are similar to the On file and In database lists here. Select the
Override application settings with defaults from preferences check box if desired. The settings are then taken from

the preferences, and the settings on the model’s root node are ignored.

This section is not available from the Application Builder window.
GRAPHICS
For specifying the color themes used for the Graphics window and selection colors, use the Graphics color theme

list, where you can select from all available color themes. The default is to use the default color theme — for

example, Default from preferences (Default). You specify the default color theme in the Preferences dialog box, in the

CHAPTER 2: THE COMSOL MODELING ENVIRONMENT



Graphics color theme list on the Color Themes page. See Selection Colors for more information about selection
colors. For specifying the color themes used for image export and printing, use the Image export color theme list,
where you can select from all available color themes. The default is to use the default color theme — for example,
Default from preferences (Default). You specify the default color theme in the Preferences dialog box, in the Image
export color theme list on the Color Themes page. See Printing and Capturing Screenshots for more information

about image export and printing.

For the Font settings, the default is to use the font family that is set in the Preferences dialog box — on the Graphics
and Plot Windows page under Default font — with a default font size. Depending on the operating system and the
installed fonts on the computer, you can select from a number of other font families from the Family list. The default
font is indicated in the default settings for Family (Default from preferences (Vera), for example). For the font size,
the Default size sctting in the Size list uses the font size that is used in the graphics and plots, which is a
system-dependent value. You can also choose another font size between 6 and 24 points or type a font size in the
Size combined field and list. The font and the font size affect text in the Graphics window and other plot windows
in the COMSOL Desktop and in Graphics form objects in the Application Builder. See Changing the Font for Plot
Labels and Titles to make global changes.

APPLICATION

This section is only available from the Application Builder window. Select the Ask to save application when closing
check box to ask users if they want to save changes in an application when closing it. Also, from the When starting
with COMSOL Multiphysics list, you can control the behavior when a user starts COMSOL Multiphysics with the
option to open an application or when a user double-clicks an MPH-file in Windows: Select Edit application (the
default) to open the COMSOL Desktop for editing the application, or select Run application to launch and run the
application directly.

Select the Ignore license errors during launch check box to make it possible to start the application even if not all
required licenses are available. It is, however, still not possible to use products when the license is not available, so
available API methods will typically have to be used in the application to limit the application’s functionality

depending on what licenses are available.

The Root Properties Window

To access the Properties window, right-click the root node and choose Properties from the context menu.

You can change a filename by saving the file, but the root node Name (root) cannot be changed

for this top level node. This is different than for other nodes in the tree, where the name can be

[

edited. See Displaying Node Names, Tags, and Types in the Model Builder for information. Also

see Settings and Properties Windows for Feature Nodes.

The Node Properties section contains the following information:

* File or Database: If the model or app is saved to a file on disk: The file location where the file was saved. Also see
Documentation and Application Libraries Root Directories. If the model is saved in a database: The database

where it was saved. This field cannot be edited, but is automatically updated when the model or app is saved.

* Saved in: Includes the version and build of the COMSOL Multiphysics instance that the model or app was saved

in. This information is system generated.

* Created and Last modified: These sections cannot be edited and are automatically generated based on the

computer system or network time and date settings.

* Saved with license: The license number of the installed software that the model or application was saved with is
included here. Also see The About COMSOL Multiphysics Box.
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Application version: Enter a tracking version number for the model or application (for example, Internal Draft
V1, Sales Demonstration V2, or Version B).

Search path: Enter a file path to set a search path for external files. This path corresponds to
model.modelPath (<path>) in the COMSOL Multiphysics API.

Unit Systems

The COMSOL Multiphysics software supports the following unit systems:

METRIC UNIT SYSTEMS

SI units, the International System of Units (SI, Systeme International d’Unités). This is the default unit system
(sometimes also called MKS). For a list of SI units in COMSOL Multiphysics, see SI Base, Derived, and Other
Units.

CGSA units. The CGS system uses centimeter, gram, and second as basic units of length, mass, and time,
respectively. The remaining basic units are identical to the SI units. The CGS unit system gives nice values for
small lengths, masses, forces, pressures, and energies when working on a microscale and with weak
electromagnetic forces. The derived units of force, pressure, and energy have well-known and widely used names:
dyne, barye, and erg, respectively. CGSA adds ampere as the basic unit for electric current. For a list of CGSA
units, see Special CGSA Units.

Electromagnetic units (EMU). This system is based on Ampere’s law, which defines the unit of electric current
once you select an appropriate value for the constant C. When dealing exclusively with magnetic effects, it is
convenient to set C = 1. If CGS units are used for the remaining basic dimensions, the current unit is called an
abampere, and the corresponding coherent unit system is called electromagnetic units. Unique names for
derived units have been introduced by prefixing the SI name with 24-. For a list of EMU units, see Special EMU
Units.

Electrostatic units (ESU). Based on Coulomb’s law for the force between point charges, ESU uses a unit of
charge called the statconlomb with CGS units for length, mass, and time. From there, the statampere, or
franklin, and other derived units of the electrostatic unit system follow. For a list of ESU units, see Special ESU
Units.

MPa units. For stationary structural mechanics, where the density does not appear in the equations, it can be
convenient to use a system where newton and megapascal (hence the name “MPa system”) are naturally derived
units of force and pressure, respectively. Keeping the SI unit for time, the basic units of length and mass become
millimeter and tonne. Except for the force and pressure units, other derived units are nameless. For a list of MPa
units, see Special MPa Units.

ENGLISH UNIT SYSTEMS

Foot-pound-second unit system (FPS units). The original foot-pound-second system seems to be the absolute
system using the pound as a unit of mass. This version of the FPS system is in agreement with the IEEE standard
(the pound is a unit of mass and not of force). The natural derived unit of force is the poundal. For a list of FPS
units, see Special FPS Units.

British engineering units. An alternative to the standard FPS system is the British engineering unit system (also
called gravitational foot-pound-second system or foot-slug-second system). Here, the pound force is the natural
unit of force, which causes the introduction of the mass unit s/zg such that a pound force is a slug-foot per second
squared. For a list of British engineering units, see Special British Engineering Units.

Inch-pound-second unit system (IPS units). It is possible to define varieties of the FPS and British engineering

systems based on the inch instead of the foot as basic unit of length. This gives rise to two distinct
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inch-pound-second systems: the absolute IPS system (just called IPS) and the gravitational IPS system. For a
list of IPS units, see Special IPS Units.

e Gravitational IPS units. This alternative IPS unit system considers the pound a unit of weight rather than a unit

of mass. For a list of Gravitational IPS units, see Special Gravitational IPS Units.

OTHER
* None. No units appear in the settings, which can be useful in nondimensionalized (de-dimensionalized or

dimensionless) models.

If you want to use another unit system than ST as the default unit system for new models, you can
choose the unity system to use from the In new models list under Unit system on the General page

[

in the Preferences dialog box.

¢ Using Units

@

* Setting the Unit System for Models

Searching and Finding Text

Press Ctrl+F to open a Find tool that you can use to search for variables or text in all of the model or, for application
development, only in methods. In the Find tool, click All to search the entire model, including user interface

components, variable definitions, model entity tags, identifiers, and labels. You can specify to search using an Exact
match, a Regular expression, or a Case sensitive scarch by selecting the corresponding check boxes. Windows users

can also customize the Quick Access Toolbar to access this button ( ).

Click Methods to find and optionally replace a text string in methods developed for an application. See the
Application Builder documentation for details.

Click Advanced to access some advanced search tools. See Advanced Search Options below.

Click the Find button to launch the search. The search results for each search appears in a separate Find Results
window, where each occurrence of the search string appears in a row. Double-click the row to open the node or
method and highlight the search result in the Settings window or method where it occurs. The Node column lists
the node where the search string appears; the Type column lists the type of the search results, such as Setting,

Description, or Method); and the Text column shows the text in which the search string appears.

If the search returns a lot of results from variables and expressions defined in Equation View nodes,
you can exclude them from the search by first clearing the Equation View check box in the Show

More Options dialog box.

ADVANCED SEARCH OPTIONS

Click Advanced to enable a more specific search method where individual types of candidates can be searched for.
In the Find field, type a search query in the same way as on the All page using an Exact match, a Regular expression,
or a Case sensitive scarch, if desired. In the Filter section, below the Find field, use the Include list to specify what to
include: Node tags, Node labels, Node names, Node types, Descriptions, and Settings. The Include list specifies what
you search for, so selecting Node tags, for example, only matches the query in the Find field against node tags. The
option Descriptions scarches for any fixed text in the COMSOL Desktop but not text that can be changed such as
lists. The Settings option searches for values of a setting (for example, text in a text field or in a list). In addition, it
is possible to add a name query in the Name filter field. Any nonempty entry here will only include settings with a
specific name, which is the description of the setting. This query is also affected by the settings for the Exact match,
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Regular expression, and Case sensitive check boxes. Select the Include APl names in search check box to allow the
search filter to match against the API names. It is only applicable when searching for Nede types and Settings and
checks the API names of the following search candidates:

e The query in the Name filter ficld is matched against the API name of a setting (for example, the Axis type list in
a Block geometry feature has axistype as its API name).

* The query in the Find field is matched against the API value of list settings (for example, the option x-axis in the
Axis type list has the API value x).

¢ A search for the value of a check box (typically on or off) is ignored in normal searches but is active when

including API names. The Find field can then match values that are on or off for most check boxes.

¢ For the Node types option in the Include list, which otherwise searches for the descriptive string of the type but
also includes the API name of the type (for example, the Work Plane geometry feature has the APT type
WorkPlane).

ADDITIONAL SEARCH TOOLS FOR THE PHYSICS BUILDER

When searching in the Physics Builder, you can also control the scope of the search in the Find tool. In addition to
physics builder files, it can also search in linked files. A linked file can either be a file in an Import node under the
External Resources branch (downward search), or a file listed in the External Resources links in the table of the root
node’s Setting window (upward search). The search can look for files in the upward direction by selecting the Follow
link sources check box, and it can look for files in the downward direction by selecting the Follow imports check box.
A Depth value can be used to limit the search. Under the Links tab there is a specialized search that finds links to a
selected node. It supports the Follow link sources option, and only need to search upward one level. It is not
applicable for nodes that cannot be a target of a link.
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The Application Libraries Window

The Application Libraries window (Figure 2-14) contains models and applications that you can use for a variety of
purposes: for learning how to build COMSOL models, as starting points for your own models and applications,
and as demonstrations of specific functionality. Each add-on module includes its own application library with
information about how to use the module within its application areas. Each file includes full documentation and a

brief description, including the solution times and information about the computer used for solving the model.

Application Libraries

(' Refresh Update COMSOL Application Libraries ) Application Gallery

Helical Static Mixer

Search
4 3 COMSOL Multiphysics
4 [fff] Applications
® cluster_setup_validation
O helical_static_mixer
) transmission_line_calculator
D tubular_reactor
O tuning_fork
b [l Acoustics
b emical Engineerin
b Chemical Engineering
I [l Cluster and Batch Tutorials
b [l Diftusion . This app demonstrates the following:
b [ Electromagnetics
b [l Equation Based « Geometry parts and parameterized geometries
b [l Fluid Dynamics « Dark theme
b il Geophysics + Material appearance visualization with enviranment reflections
b [l Heat Transt » Report generation for both Microsoft® Word and Microsoft® PowerPoint
z L= 3 » Options for setting different mesh sizes
b [l Meshing Tutorials = Improved graphics visualization by showing/hiding different geometry ohjects
b m]] Multiphysics = Enabling and disabling ribbon items based on the solution state,
b [l Structural Mechanics
b % AC/DC Module Helical static mixers are often used to mix monomers and initiators which then react during a polymerization
b A tics Modul process, The concentration field is included in the analysis in order to compute the extent of mixing between two
ool i s streams injected into the static mixer through semicircle-shaped inlets,
[ & Battery Design Module
I [& CAD Import Module The app can be used to estimate the degree of mixing in a system including one to five helical blades whose
[ lﬂ:f CFD Medule dimensions can also be varied. The monomers' liquid properties and inlet velocity can alse be varied.
I 2% Chemical Reaction Engineering Module
I &2 Composite Materials Module Name Belical static: micer
[ ~=; Corrosion Module
b B Design Module Used products COMSOL Multiphysics
b CAD Import Module Physics interfaces Laminar Flow
b 55 Flertrical Cirrvits Module aripont gt Dillrled Species
ém Elﬂ Created in COMSOL Multiphysics 5.6 (Build: 266)
P> Run Application Open Computation time 8 minutes
@ Open PDF Document Athor SR
Last modified Oct 22, 2020 2:10:53 PM
Created Oct 22, 2020 2:10:33 PM

Help e Close

Figure 2-14: The Application Libraries window with Eigenmodes of & Room bighlighted in the tree. Specific
information about the model or application is displayed to the vight, including its name and the computation time.

To open the Application Libraries window ([[[]] ):

* From the Home toolbar, Windows menu, sclect Application Libraries.

* You can also customize the Quick Access Toolbar and then click the Application Libraries button

on the toolbar. See Windows Toolbars and Menus.

¢ From the File menu sclect Application Libraries.

To open the Application Libraries window ([[[]] ):

¢ In the Main toolbar, click the Application Libraries button.

¢ Sclect Windows>Application Libraries.
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Browse through the Application Libraries tree to see what is available. Click to highlight the file in the tree and read
information about it to the right, or search for a specific application. The information for each application includes:
e The COMSOL products used.

¢ The physics interfaces used.

e The version that the application was created in.

¢ The computation time. If you hover over the computation time, a tooltip displays information about the
computer used for the computation (CPU, clock rate, and number of cores) and, if applicable, the solution times

for each study step.
* The dates and times for when the application was created and last modified.
When you browse the tree, you may notice that three different icons are used for the model and application nodes.
Their respective look and significance are as follows:
* @ (solved) — The file is complete with built meshes and solutions.

* 3 (compact) — The file contains no stored meshes or solutions. A solved version is available for download via

Application Library Update (except in a few cases where the file is a template related to another, regular, model).

e o (preview) — The file is a preview of an application or a model file, containing only what is needed to
represent the model in this particular context, including the model description and information about used
products and physics interfaces and the computation time. Solved and compact versions are available for
download. Model documentation will be available if you have specified the use of online help (see The Help
Window and Topic-Based Help for details on how to do this).

The following sections describe what is available and what you can do from the Application Libraries window:

* The Applications Folders

e Running or Opening a Model or Application and Its Documentation
* Downloading MPH-Files With or Without Solutions

* Searching the Application Libraries

* The Application Library Update Window

You can also set the root directory and create and remove a user-defined library as described next.

APPLICATION LIBRARY PREFERENCES
The following settings can be modified using the buttons at the bottom of the Application Libraries tree on the
Application Libraries page in The Preferences Dialog Box and — if the Allow managing libraries in the Application

Libraries window check box on that page is selected (the default) — also in the Application Libraries window itself.

Add User Application Library

Click the Add User Application Library button (Eﬂ] ) to add customized folders. In the Add User Application Library
dialog box, navigate to a location on your computer and select an existing directory or click Make New Folder to
create a custom folder. Click OK to save the changes and exit, or Cancel to exit without saving.

It is not possible to add an application library identical to, containing, or being contained in, an

¥ ]
I_E| already used application library.

Optionally, you can replace the standard folder icon ([f[fj ) with custom icons of your choice that reflect the content
of your library folders. To use a custom icon for a folder, create a PNG-file with an image size of 16-by-16 pixels

and save it in the folder under the name folder.png.
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Set the COMSOL Application Libraries Root
Click the Set COMSOL Application Libraries Root Directory button ( ﬂﬂ] ) to edit or set the root folder. This redirects
the COMSOL software to a different folder where customized applications can be stored.

In the Set COMSOL Application Libraries Root Directory dialog box, navigate to the new root folder location or click

Make New Folder. Click OK to save the changes and exit, or Cancel to exit without saving.

Remove Selected Library
This button is enabled after a user application library folder has been created. Select a user application library root
folder in the Application libraries tree and then the click the Remove Selected ( button to remove the library from

the tree.

=)

The Applications Folders

In the Applications library folders you find runnable apps with custom user interfaces tailored with the Application
Builder to simplify solving a specific problem using COMSOL Multiphysics. To run an application, click the ( » )
Run Application button. If, instead, you want to explore how the application is constructed, click ( [«| ) Open. For
applications in this folder, clicking the ( @] ) Open PDF document button launches the PDF document that you can
access from the running application. If no such document is available, this button is not activated. For further

details, see the next section.

Running or Opening a Model or Application and Its Documentation

RUNNING AN APPLICATION
You can run an application built with the Application Builder by clicking p Run application. This button is not

activated for models.

OPENING A MODEL OR APPLICATION

Once you have located the file you want to open — for example, you used a search and it is successful (see Searching
the Application Libraries), or you browsed the Application Libraries tree — then to open the file:

* Double-click the name in the tree.

* Sclect the name, then click [«] Open.

¢ Right-click the name, then from the context menu select Open.

It is possible to open and postprocess models that include functionality that you have blocked or

that your license does not include. Nodes with functionality that requires a license for a product
n that is blocked or not available get a License Error subnode ({3 ), where you find information

about the missing but required product license. Unless you disable or remove such nodes, it is not

possible to re-solve such models.
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If the node represents a solved model ( @ ) or a compact ( {3 ) or solved application, the file will open directly. If,
instead, the file is a compact model MPH-file or a preview file ( :*: ) and you are connected to the internet, you
will be presented with the applicable download options:

» For a compact file, choose between opening the local model MPH-file and downloading the solved version
before opening.

o Open Local or Download Solved Model @
A solved version of this model is available for download.
@ Open local compact file

Downlead file with solutions (51.7 MB) and open

Do not show this dialog again (preference setting).

oK Cancel

If you select Do not show this dialog again (preference setting), the local file will open directly the next time you
open a compact model. If you change your mind later, you can control the behavior using the Ask about download

before opening compact application file check box on the Application Libraries page of the Preferences dialog

e For a preview file, choose between downloading the file with or without solutions, that is between the solved
and the compact MPH-file.

3 Download and Open @

This application is not available locally.

@ Download file with solutions (3.0 MB)

Download file without solutions (1.7 ME)

oK Cancel

The approximate download sizes are displayed next to the options. For models, the numbers

shown do not include the documentation, which is downloaded together with the MPH-file if you

[

have chosen to install documentation.

If you have no internet connection or if the Application Library Update server is unavailable for

some other reason, these dialogs will not appear and the associated context-menu options will not
n be shown. You can entirely disable availability checks on the Preferences dialog’s Application

Libraries page by clearing Check Application Library Update availability on first access. (If you already

opened the Application Libraries window, this setting will take effect in the next session.)

OPENING A PDF DOCUMENT

To read the documentation in PDF format, including step-by-step instructions:

* Click to highlight the name in the tree, then click | Open PDF Document.

* Right-click the name, then from the context menu select =] Open PDF Document.

You can enable the Open PDF Document button for a user-library model or application by placing a
PDEF-file with the same name (including case, up to the file extension) as the MPH-file in the same
folder.

[
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PDF and HTML documentation is available also for preview nodes if online help is activated; see
I_E| The Help Window and Topic-Based Help.

OPENING THE APPLICATION GALLERY

The Application Gallery, which is a part of the COMSOL website, provide access to a large number of models and
applications, and you can download the MPH-files, PDF documentation, and other related files to extend the
application libraries. Click the Application Gallery button ( {{7)) above the application libraries tree to open the

Application Gallery in a web browser.

Downloading MPH-Files With or Without Solutions

REPLACING COMPACT FILES

To replace compact MPH-files, you can download the files complete with solutions via Application Library Update
(see The Application Library Update Window). Alternatively, right-click a compact node ( ¢ ) in the Application
Libraries tree and choose @ Download File with Solutions.

4 [@ COMSOL Multiphysics

[fifi Applications
4 [fifi Acoustics
automotive muffler

Open
Open PDF Document
Download File with Solutions (51.7 MEB)

B B>

Help F1

[fiii Geophysics

You can also generate the complete models by building the mesh sequences and computing the studies.

The procedure for restoring the solutions can involve other steps, such as adjusting physics
n interface settings. See the individual documentation for details if the simple approach does not

work.

REPLACING PREVIEW FILES
To replace a preview file, use Application Library Update or right-click the node :*: in the Application Libraries tree
and choose between ¢ Download File with Solutions and ¥} Download File Without Solutions.

*r lorenz_attractor

® | §H Open PDF Document
o}
° & Download File with Solutions (3.0 ME)
(o] & Download File Without Sclutions (1.7 MB)
[fifi Flui
H Hel F1
[l Geo a i

Searching the Application Libraries

In the Application Libraries window, you can Search the application libraries to find any files using a specific feature.
For example, enter all or part of the name, a physics interface name, a feature name, a feature tag or name prefixed
by ‘@, or any other phrase or words or and click Search.
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By default, the search includes all words in the Search field (with space signifying logical AND).

COMSOL files are named using an underscore between words (for example,
effective diffusivity) because the filename is also the name of the corresponding Model

MPH-file. The underscore is required to form a valid filename, so it is reccommended that you, if

[

you are not sure of the full name, enter only the first word (rather than multiple words separated

by spaces) in the Search field when searching for a model or application name.

The search in the Application Libraries window does not include the models’ PDF documents. To

search for text in the model documentation, use the COMSOL Documentation window and select

!

Application libraries from the Search scope list to limit the search for the application libraries (see

Searching the Documentation).

SEARCH PARAMETERS FOR MODELS AND APPLICATIONS

To search for models and applications by filename only, use the prefix “@name:”, for example @name : busbar.
You can also use the wildcard character “* at the beginning and the end of the search expression, for example

@name:fluid* or @name: *electr*.

To search for models and applications whose computation time (as displayed in the Application Libraries window)
falls within a specific range, use the prefix “@time:”. For example, the search expression @time:>=1[h] <=2[h]
returns all models and applications with a computation time between 1 and 2 hours. The supported relational

operators are < (the default if no operator is given), >, <=, >=, and ==. Elapsed times can be expressed using the
supported time units (see the section SI Base, Derived, and Other Units in The COMSOL Modeling

Environment chapter for details). If no unit is specified, the expression entered is assumed to be given in seconds.

If you enter more than one search term separated by spaces (in a search that is not restricted to filename using
the “@name” prefix), the search finds files where all of the search terms appear.

Limit the search to tags (identifiers) with the prefix “@tag:”. For example, @tag:genext finds all files using a

General Extrusion node, and @tag: ehs finds all files with an Electron Heat Source node.

Limit the search to node labels (excluding trailing digits and tags enclosed in parentheses) with the prefix
“@label:”. To search for labels that include spaces, you need to enclose the label text within quotes. For
example, @label: "point evaluation" finds files containing Derived Values nodes of Point Evaluation type
with the default label base (as shown immediately below the window label in the Settings window).

Limit the search to type names with the prefix “@type:”. For example, @type:segregated finds all files using
a segregated solver, @type:slider finds all applications containing a Slider form object, and @type:bodyload
finds all files with a Body Load node. To find out the type names, consult the COMSOL Programming
Reference Manual or, for application form objects, the COMSOL Multiphysics Application Programming
Guide. Alternatively, you can save an application as a Model File for Java or Model File for MATLAB and look

up the second argument for the create(..) method for an object of the type of node you want to search for.

To search for a specific physics interface, use the scoping syntax @physics: id, where id is a default
physics-interface identifier (forming the base of the tags shown in the Model Builder window if you have selected
Model Tree Node Text>Tag in the window’s toolbar). For example, enter @physics:ec to find all models that use
the Electric Currents interface. Similarly, enter @geom: if to search for models that include an If statement

(node) in the geometry sequence. Table 2-3 lists the supported model-object context scopes.

The model-context search scopes @cpl, @export, @func, @multiphysics, @umerical, @probe, and
@selection used without an identifier return all models that contain a7y node of the corresponding type; see
Table 2-3.
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¢ In addition to the model-object scopes, the following custom keywords are available:

- @keyword:tutorial — finds introductory and tutorial models;

- @keyword:verification — finds models classified as verification models or benchmarks;

- @keyword:industrial — finds models classified as industrial applications.

* You can also search for applications with a particular identifier in the COMSOL Application Gallery

(www.comsol.com/models) using the search prefix @appdb : immediately followed by the identifier. This can be

useful when communicating with a COMSOL support or sales representative.

* To find all models and applications that are locally available in solved or compact form, or only as previews, use

the search strings $solved, $compact, and $preview, respectively.

TABLE 2-3: MODEL-OBJECT SEARCH SCOPES.

SCOPE DESCRIPTION EXAMPLES

@cpl Search for component-coupling nodes. @cpl:genext, @cpl

@dataset Search for dataset nodes. @dataset:cpt

@export Search for export nodes. @export:anim, @export
@func Search for function nodes. @func:wv, @func

@geom Search for geometry-feature nodes. @geom:c

@mesh Search for mesh-feature nodes. @mesh:swe

@multiphysics Search for multiphysics-coupling nodes. @multiphysics:emh, @multiphysics
@numerical Search for derived-values nodes. @numerical:min, @umerical
@physics Search for physics-interface nodes. @physics:c

@probe Search for probe nodes. @probe:bnd, @probe

@result Search for plot-feature nodes. @result:slc

@selection Search for selection nodes. @selection:box, @selection
@sol Search for solver nodes. @sol:se

@study Search for study nodes. @study:param

When a search result is presented, hover over a top-level node in the tree to see the number of matching files under

the corresponding folder. If the search does not return any results, the Application Libraries window contains the

message No Results Found. Click the Refresh button ( (* ) under the tree to return to the root Application Libraries

folder list.

The Application Library Update Window

Application Library Update is a service that provides new and updated models and applications for the application

libraries of the COMSOL products that your license includes. The text below describes how to use the Application

Library Update service.

Using the COMSOL Application Library Update scrvice requires internet access. For a default

A installation, you also need to run COMSOL as an administrator. See Proxy Server Settings section

below for instructions on how you can modify your installation to avoid this restriction.

APPLICATION LIBRARY UPDATE

Open the Application Library Update window by clicking Update COMSOL Application Libraries in the Application

Libraries window or by going to the File>Help menu (Windows users) or the Help menu (macOS and Linux users)
and choosing Update COMSOL Application Libraries ( [} ).
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When the Application Library Update window opens, choose if you want to download files containing solutions
(Solved) or more compact versions of the models and applications (Compact), then click Find Applications to check
if'all the models and applications you have are up to date or if there are any updated or new ones. If the message

Your Application Libraries are up to date displays, no updated or new models or applications are available.

If the library is not up to date, browse the list that appears with a description and image. Choose which ones to
download by selecting or clearing the check boxes next to the thumbnail images. By default all check boxes are

selected; by clicking Clear selection and Select all you can change the global selection state.

Note that if you chose to download solved models and applications and then choose Select all, the
download size can be on the order of 10s of GB if you have license for several products. Therefore,
-a it may be wiser to choose the compact option and then download solved versions of the examples

you are interested in directly from the Application Libraries window.

Click the Download button to download the selected models and applications. The download time depends on the

size of the files, which is listed for each file, and the bandwidth of the internet connection.

El Also see the Introduction to Application Builder.

Proxy Server Settings
If you connect to the internet through a web proxy, you can specify the required settings in the Help section of the

Preferences dialog box; for details, see Proxy Server Settings.

DESTINATION DIRECTORIES FOR LIBRARY UPDATES
To edit these settings under Destination directories for library updates, open The Preferences Dialog Box and go to
the Updates section.

The Destinations list provides two options for specifying which application, documentation, and part directories are
synchronized with the COMSOL Multiphysics server when you launch an Application Library Update or Part
Library Update (see the next section) request:

¢ Current directories (default): Synchronize with application MPH-files under the COMSOL Application Libraries
root set on the Preferences dialog’s Application Libraries page, with documentation files under the directory
specified in the Documentation root directory ficld on the Preferences dialog’s General page, and with part
MPH-files under the COMSOL Part Libraries root set on the Preferences dialog’s Part Libraries page.

¢ Specify custom directories: Choosing this option lets you specify COMSOL Application Libraries,
documentation, and COMSOL Part Libraries root directories separate from those of your current COMSOL

Desktop environment.

By default, the COMSOL Application Libraries, COMSOL Part Libraries, and documentation root directories are
located directly under the COMSOL installation root directory, in applications/, parts/, and doc/,
respectively. This typically implies that special permissions are required for saving downloaded files, and it can
therefore be beneficial to move or copy the directories to a different location. The settings referred to in this section

are provided to let you customize Application Library Update to the IT environment of your organization.
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The Part Library Update Window

Part Library Update is a service that provides new and updated geometry parts for the part libraries of the
COMSOL products that your license includes. The text below describes how to use the Part Library Update

service.

Using the COMSOL Part Library Update service requires internet access. For a default installation,
I’i-l' you also need to run COMSOL as an administrator. If you connect to the internet through a proxy

server, see the Proxy Server Settings section for the relevant settings.

PART LIBRARY UPDATE

Open the Part Library Update window by clicking Update COMSOL Part Libraries in the Part Libraries window or by
going to the File>Help menu (Windows users) or the Help menu (macOS and Linux users) and choosing Update
COMSOL Part Libraries ( [1}f] ).

If the message Your Part Libraries are up to date displays when the Part Library Update window opens, no updated
or new geometry parts are available. If the library is not up to date, browse the list that appears with a description
and image. Choose which ones to download by selecting or clearing the check boxes next to the thumbnail images.
By default all check boxes are selected; by clicking Clear selected and Select all you can change the global selection

state.

Click the Download button to download the selected geometry parts. The download time depends on the size of

the files, which is listed for each geometry part, and the bandwidth of the internet connection.
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The Physics Interfaces

This section is an overview of the core physics interfaces included with a COMSOL Multiphysics license. If your
license include add-on modules, there are additional physics interfaces described in the individual documentation

for each module.

* Building Models in the Model Builder
* Adding and Inserting Physics Interfaces
Modeling Guidelines

* Creating a New Model

Introduction to the Physics Interfuces

Solving PDEs generally means you must take the time to set up the underlying equations, material properties, and
boundary conditions for a given problem. COMSOL Multiphysics, however, relieves you of much of this work.
The software provides a number of physics interfaces that consist of nodes and settings that set up the equations
and variables for specific areas of physics. An extensive set of physics-dependent variables makes it easy to visualize

and evaluate the important physical quantities using conventional terminology and notation.

Suites of physics interfaces that are optimized for specific disciplines together with specialized
'g' application libraries are available in a group of optional products. See The COMSOL Multiphysics
Modules and Interfacing Options.

A complement to the interfaces for physics, special interfaces for equation-based modeling simplify the setup of
PDEs for modeling that does not explicitly refer to any particular application field. In addition, other interfaces

supplement the physics with special functionality such as the Sensitivity and Moving Mesh user interfaces.

* Physics Groups and Subgroups
& * Physics Interface Guide

* Seclecting Physics Interfaces

Physics Groups and Subgroups

The Select Physics page in the Model Wizard, as well as The Add Physics Window, contain groups and subgroups
of physics and mathematics interfaces (some items only display if a license includes the corresponding add-on

modules).

RECENTLY USED ( (D)

This group contains the most recently used physics interfaces for easy access.

AC/DC (%)
This group contains physics interfaces for low-frequency electromagnetics such as electrostatics, electric currents
and magnetic fields together with multiphysics couplings to heat transfer, structural mechanics and charged particle

dynamics.
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ACOUSTICS (1))
This group contains acoustics-based physics interfaces. Except for the Pressure Acoustics group, these subgroups
require additional licenses:

* Elastic Waves

* Acoustic-Structure Interaction

e Aecroacoustics

¢ Thermoviscous Acoustics

e Ultrasound

¢ Geometrical Acoustics

* Pipe Acoustics

CHEMICAL SPECIES TRANSPORT ( :%)

This group contains chemical species transport physics interfaces used, for example, for convection and diffusion,
solving for the species concentrations and for chemical reactions. These subgroups are available depending on the
specific license:

* Moisture Transport

* Moisture Flow

* Reacting Flow

* Nonisothermal Reacting Flow

* Reacting Flow in Porous Media

* Rotating Machinery, Rotating Flow

ELECTROCHEMISTRY (i)

This group contains clcctr0561nistry physics interfaces for modeling electrochemical components such as batteries
and fuel cells. This group and its subgroups are only available with additional licenses:

* Batteries

¢ Hydrogen Fuel Cells

* Water Electrolyzers

* Corrosion, Deformed Geometry

¢ Electrodeposition, Deformed Geometry

FLUID FLOW (=)

This group contains fluid flow physics interfaces such as laminar single-phase flow and, with add-on modules,
multiphase flow and turbulent flow. These subgroups are available based on the license:

* Single-Phase Flow (including additional Turbulent Flow and Rotating Machinery, Fluid Flow subgroups)
¢ Thin-Film Flow

¢ Multiphase Flow (including additional Bubbly Flow; Mixture Model; Euler-Euler Model; Two-Phase Flow,
Level Set; Two-Phase Flow, Phase Field; Two-Phase Flow, Moving Mesh; Three-Phase Flow, Phase Field; and
Rotating Machinery, Multiphase Flow subgroups)

¢ Porous Media and Subsurface Flow

* Nonisothermal Flow (including additional Turbulent Flow and Rotating Machinery, Nonisothermal Flow
subgroups).
¢ High Mach Number Flow (including an additional Turbulent Flow subgroup)
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* Rarefied Flow
 DParticle Tracing

¢ Fluid-Structure Interaction

HEAT TRANSFER ( )

This group contains physics interfaces for heat transfer in solids, fluids, pipes, and in porous media. Other physics
interfaces are available for bioheat transfer and for heat and moisture transport. There are also multiphysics
interfaces for thermal multiphysics applications such as Joule heating. These subgroups are available depending on
the specific license:

* Conjugate Heat Transfer (including an additional Turbulent Flow subgroup)

* Radiation

¢ Electromagnetic Heating

 Thin Structures (for heat transfer in thin shells, thin films, and fractures)

¢ Heat and Moisture Transport

e Porous Media

e Metal Processing

e Curing

OPTICS ( /(«)

This group contains physics interfaces for electromagnetic wave propagation in linear and nonlinear optical media
for accurate component simulation and design optimization. This group and the subgroups are only available with
additional licenses

* Ray Optics

* Wave Optics

PLASMA (@)
This group contains physics interfaces for plasma modeling. This group and the Equilibrium Discharges and Species

Transport subgroups require the Plasma Module.

RADIO FREQUENCY ( )
This group contains physics interfaces for high-frequency electromagnetic field simulations solving the full Maxwell

equations. This group is only available with the RF Module.

SEMICONDUCTOR (ﬁ"é)
This group contains physics interfaces that solves Poisson’s equation for the electric potential and the drift-diffusion
equations for electrons and holes in a semiconductor material: Semiconductor interfaces and interfaces for solving

the Schrodinger and Schrodinger-Poisson equations. This group is only available with the Semiconductor Module.

STRUCTURAL MECHANICS (=)

This group contains structural mechanics physics interfaces for example to study displacements and stresses in solids
and for multibody dynamics, fatigue, thermal stress, piezoelectricity, and other structural multiphysics couplings.
Depending on licenses, the following subgroups can be available:

* Rotordynamics

* Electromagnetics-Structure Interaction

¢ Fluid-Structure Interaction
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Poroelasticity

Thermal-Structure Interaction

MATHEMATICS ( Au)

This group contains mathematics interfaces for solving PDEs, ODEs, and DAE:s, for optimization (which requires

the Optimization Module) and sensitivity analysis, and for modeling moving meshes and parameterized geometry.

These subgroups are available:

PDE Interfaces (including a Lower Dimensions subgroup)

ODE and DAE Interfaces

Optimization and Sensitivity

Classical PDEs

Moving Interface (available with either the CFD Module or Microfluidics Module)
Deformed Mesh

Wall Distance

Mathematical Particle Tracing (available with the Particle Tracing Module)

Curvilinear Coordinates

For a list of all the physics interfaces under each group and subgroup, see the individual
n documentation included with each add-on module. Or search the online Help for the key words
Physics Interface Guide.

* Creating a New Model
.& * Physics Interface Guide

* Seclecting Physics Interfaces

Adding and Inserting Physics Interfaces

THE ADD PHYSICS WINDOW
The Add Physics window is similar to the Select Physics window accessed through The Model Wizard. It has the

same physics interfaces available. This window is a quick way to add physics interfaces to models.

To open the Add Physics window:

* Right-click a Component node and choose Add Physics.
¢ From the Home toolbar, click Add Physics &
e Seclect Windows>Add Physics.

e From the Physics toolbar, click Add Physics ==

* Right-click a Component node and choose Add Physics.

* In the Model Toolbar, click Add Physics

¢ In the Physics Contextual Toolbar, click Add Physics :&
Linux

¢ Seclect Windows>Add Physics.
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The Add Physics ::: toolbar button is a toggle button: Click it again to close the Add Physics

El window.

TO ADD PHYSICS INTERFACES TO A MODEL COMPONENT
I In the Add Physics window, either enter a Search term or navigate the tree to locate the physics interface to be
added to the Component.

The tree organizes the available physics interfaces by application areas such as fluid flow, heat transfer, and
structural mechanics. The physics interfaces found in the modules your license supports display in the different
application areas. In some cases, licensing of a module adds physics interfaces to these application areas as well
as attributes to existing physics interfaces, which are enhanced with additional functionality. The (T) Recently
Used branch lists the last five physics interfaces used in recent modeling sessions. You can also enter a text string

in the search field and click the Search button to list all the interfaces with the search term.

The contents of the Add Physics window depends on the space dimension of the active model

[

component. If there are no Component nodes in the model, the list of physics interfaces is empty.

2 Once a physics interface is clicked, review and optionally modify any dependent variable names in the Dependent
Variables section and, for some physics interfaces, specify the number of dependent variables. For PDE interfaces
under Mathematics, you can also click the Units tab to specify units for the equation by defining a unit through a
physical quantity for the dependent variable and the source term. See Units for more information about these

settings.
If you select multiple physics interfaces, the Dependent Variables section is not available.

3 When there is already a physics interface added to the Component, the existing Studies are listed under Physics
interfaces in study. By default, the studies appear with a check mark ([-]) in the Solve column, which indicates
that the study solves for the dependent variables in the physics interface. Click in the column to clear the check

mark and exclude the physics interface from that study.
4 Click the Add to Component or Add to Selection buttons.

- Ifyou click Add to Component, the physics interfaces are added to the Model Builder and become active in the
entire model component’s geometry by default. You can also press Enter to add the physics components to

the component.

- Ifyou click Add to Selection, the physics interfaces are added to the Model Builder with a selection taken from

the selected geometric entities in the Graphics window. This is a method called preselection.

COPYING, PASTING, AND INSERTING PHYSICS INTERFACES
You can copy and paste physics interfaces within a COMSOL Multiphysics session and also between COMSOL

Multiphysics sessions, as long as the copied physics interface information remains in the clipboard.

To copy a physics interface with all its subnodes, right-click the physics interface node and choose Copy (or, for
Windows users, click Copy on the Quick Access Toolbar). You can then paste it in the same or a new COMSOL
Desktop session by right-clicking a compatible Component node and choosing, for example, Paste Solid Mechanics

(or, for Windows users, click, for example, Paste Solid Mechanics on the Quick Access Toolbar).

It is also possible to insert physics interfaces from another COMSOL Multiphysics model into a model component.

To do so, right-click a Component node and choose Insert Physics ([T ) or Insert Physics From ([T ).

¢ In the first case, an Insert Physics dialog box appears where you can browse or type the path and name of the
COMSOL Multiphysics model file from which you want to insert physics interfaces in the Model field. Select one

or more of the physics interfaces in the model from the Physics list in the Insert Physics dialog box and then click
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OK to insert them into the current model. The list includes the space dimension for the physics interface so that
you can select compatible physics interfaces.

* In the last case, a fullscreen Select Model window opens, where you can insert a physics interfaces from an existing
database, add a new database, or browse for models to insert physics interfaces from. Select one or more of the
physics interfaces in the model from the Physics list in the Insert Physics dialog box and then click OK to insert
them into the current model. See also The Select Model Window.

You can insert a physics from another space dimension if it is applicable in the component you

4 insert it into. Most physics applicable in 2D axial symmetry is applicable in 3D, so an interface

specified in a 2D axisymmetric component can therefore be inserted in a 3D component.

Some aspects when inserting or pasting a physics interface into an existing model component:

* All selections of a physics interface and its physics features depend on the geometry they belong to. When you
insert or paste a physics interface into another component and geometry, there is a high risk that selections
change or become empty.

¢ Any references to named selections will be broken, and no selection nodes are included automatically in the
insertion process.

e All use of global parameters, functions, variables, materials, multiphysics couplings, and coordinate systems will
be invalid after the insertion process unless an item with the same name exists in the target component. No
attempt is made to automatically include any item in the insertion process. Materials should be of minor
importance if the physics interfaces consistently use the option From material in all their material property
settings.

* Some physics features are not applicable in all dimensions, so these will simply be ignored. You will be notified

about this in the message dialog box.

Altogether, these aspects may cause an insert or paste operation to be incomplete to some degree. In some cases,
the difference is reported in a message dialog box after the insertion process has finished. Click Cancel in this dialog

box to revert the insertion process.

* Creating a New Model

@

e Physics Interface Guide

Physics Interface Guide

The table lists the physics and mathematics interfaces in COMSOL Multiphysics and the availability for 1D, 1D
axisymmetric, 2D, 2D axisymmetric, and 3D geometries.

PHYSICS INTERFACE | ICON |TAG SPACE DIMENSION AVAILABLE PRESET STUDY TYPE
3 AC/IDC

Electric Currents x |ec All dimensions Stationary

Electrostatics By es All dimensions Stationary; Time Dependent
Magnetic Fields n |mf 2D, 2D axisymmetric |Stationary; Frequency Domain
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PHYSICS INTERFACE |ICON |TAG SPACE DIMENSION AVAILABLE PRESET STUDY TYPE

1)) Acoustics

() Pressure Acoustics

Pressure Acoustics, o) |acpr All dimensions Eigenfrequency; Frequency Domain
Frequency Domain

7:: Chemical Species Transport

Transport of Diluted o |tds All dimensions Stationary; Time Dependent
Species

=+ Fluid Flow

- Single-Phase Flow

Laminar Flow = spf 3D, 2D, 2D Stationary; Time Dependent
axisymmetric

Heat Transfer

Heat Transfer in Solids ht All dimensions Stationary; Time Dependent

o

Heat Transfer in Fluids ht All dimensions Stationary; Time Dependent

%/| Electromagnetic Heating

Joule Heatingl’ x  |— All dimensions Stationary; Time Dependent

42

&5 Structural Mechanics

Solid Mechanics = solid 3D, 2D, 2D Stationary; Eigenfrequency; Time Dependent
axisymmetric

Au Mathematics

Wall Distance % wd All dimensions Stationary; Time Dependent
Curvilinear Coordinates & cc All dimensions Stationary; Eigenvalue

Au PDE Interfaces

Coefficient Form PDE | Av  |c All dimensions Stationary; Time Dependent; Eigenvalue
General Form PDE Au |g All dimensions Stationary; Time Dependent; Eigenvalue
Woave Form PDE fav  |wahw All dimensions Time Dependent
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PHYSICS INTERFACE ICON |TAG SPACE DIMENSION AVAILABLE PRESET STUDY TYPE

Weak Form PDE fau W All dimensions Stationary; Time Dependent; Eigenvalue

PDE, Boundary E:._J_:. pdebe 3D and 2D Stationary

Elements -

Au Lower Dimensions

Coefficient Form Au |cb All dimensions Stationary; Time Dependent; Eigenvalue

Boundary PDE

Coefficient Form Edge | Au  |ce 3D Stationary; Time Dependent; Eigenvalue

PDE

Coefficient Form Point | Au |cp 3D, 2D, 2D Stationary; Time Dependent; Eigenvalue

PDE axisymmetric

General Form Au |gb All dimensions Stationary; Time Dependent; Eigenvalue

Boundary PDE

General Form Edge Au o |ge 3D Stationary; Time Dependent; Eigenvalue

PDE

General Form Point Au |gp 3D, 2D, 2D Stationary; Time Dependent; Eigenvalue

PDE axisymmetric

Weak Form Boundary | ja» |wb all dimensions Stationary; Time Dependent; Eigenvalue

PDE

Weak Form Edge PDE | ju»  |we 3D Stationary; Time Dependent; Eigenvalue

Weak Form Point PDE | jax  [wp 3D, 2D, 2D Stationary; Time Dependent; Eigenvalue
axisymmetric

< ODE and DAE Interfaces

Global ODEs and dd—t ge All dimensions Stationary; Eigenfrequency; Time

DAEs Dependent; Frequency Domain; Eigenvalue

Domain ODEs and dd—t dode All dimensions Stationary; Time Dependent; Eigenvalue

DAEs

Events T ey All dimensions Time Dependent

Boundary ODEs and dd—t bode All dimensions Stationary; Time dependent; Eigenvalue

DAEs

Edge ODEs and DAEs dd—t eode 3D Stationary; Time dependent; Eigenvalue

Point ODEs and DAEs ddT pode 3D, 2D, 2D Stationary; Time dependent; Eigenvalue
axisymmetric

@ Optimization and Sensitivity

Optimization
Requires the
Optimization Module

@

opt

All dimensions

Stationary; Eigenfrequency; Time
Dependent; Frequency Domain; Eigenvalue

THE PHYSICS INTERFACES |

109



PHYSICS INTERFACE ICON TAG SPACE DIMENSION AVAILABLE PRESET STUDY TYPE

Sensitivity i, |sens All dimensions Stationary; Eigenfrequency; Frequency
Domain; Eigenvalue; Time Dependent
(available with the Optimization Module)

v2 Classical PDEs

Laplace Equation v2  |lpeq ID, 2D, 3D Stationary

Poisson’s Equation v2 poeq ID, 2D, 3D Stationary

Woave Equation v2  |waeq ID, 2D, 3D Time Dependent

Helmholtz Equation v2  |hzeq ID, 2D, 3D Stationary

Heat Equation v2 |hteq ID, 2D, 3D Stationary; Time Dependent

Convection-Diffusion v2 cdeq 1D, 2D, 3D Stationary; Time Dependent

Equation

Stabilized v2 scdeq 1D, 2D, 3D Stationary; Time Dependent

Convection-Diffusion

Equation

/7 Deformed Mesh

Deformed Geometry [ |dg All dimensions Stationary; Time Dependent; Frequency

Domain; Eigenvalue

Moving Mesh Z o ale All dimensions Stationary; Time Dependent; Frequency

o Domain; Eigenvalue

L This physics interface is a predefined multiphysics coupling that automatically adds all the physics interfaces and
coupling features required.

Common Physics Interface and Feature Settings and Nodes

There are several common settings and sections available for the physics interfaces and feature nodes (Table 2-4).
Some of these sections also have similar settings or are implemented in the same way no matter the physics interface
or feature being used. There are also some physics feature nodes (Table 2-5) that display in COMSOL
Multiphysics.

In each module’s documentation, only unique or extra information is included; standard information and

procedures are centralized in this manual.

Table 2-4 has links to common sections and Table 2-5 to common feature nodes. You can also
n search for information: press F1 to open the Help window or Ctrl+F1 to open the Documentation

window.

SHOW MORE PHYSICS OPTIONS

To display additional sections and options for the physics interfaces (and other parts of the model tree), click the
Show More Options button ("= ) on the Model Builder and then select the applicable options in the Show More Options
dialog box that opens.
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After selecting some options, sections display on the Settings window when a node is clicked, or additional nodes
are made available from the Physics toolbar or context menu. Selecting Advanced Physics Options cither adds an

Advanced settings section or enables nodes in the context menu or Physics toolbar. In many cases these options are
described in the individual documentation.

For more information about the Show options, see Showing More Options and The Model Builder.
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COMMON PHYSICS SETTINGS SECTIONS

TABLE 2-4: COMMON PHYSICS SETTINGS SECTIONS

SECTION

CROSS REFERENCE AND NOTES

Advanced Settings — Pseudo
time stepping

Advanced Settings — Frames

Advanced

Anisotropic materials

Consistent Stabilization

Constraint Settings

Coordinate System Selection

Dependent Variables

Discretization
Discretization — Frames

Equation

Frames (Advanced Settings —
Frames and Discretization —
Frames)

Geometric entity selections

Inconsistent Stabilization

Settings

Material Type

Pseudo Time Stepping and Pseudo Time Stepping for Laminar Flow Models

See Frames.

This section can display after selecting Advanced Physics Options. The Advanced
section is often unique to a physics interface or feature node.

For some User defined parameters, the option to choose Isotropic, Diagonal,
Symmetric, or Full displays. See Modeling Anisotropic Materials for
information.

See Stabilization.

Constraint Reaction Terms, Weak Constraints, and Symmetric and
Nonsymmetric Constraints

Coordinate Systems

Selection of the coordinate system is standard in most cases. Extra information is
included in the documentation as applicable.

Predefined and Built-In Variables

This section is unique for each physics interface, although some interfaces have
the same dependent variables.

Settings for the Discretization Sections
See Frames.
Physics Nodes — Equation Section

The equation that displays is unique for each interface and feature node, but how
to access it is centrally documented.

Handling Frames in Heat Transfer and About Frames

Working with Geometric Entities

Selection of geometric entities (Domains, Boundaries, Edges, and Points) is
standard in most cases. Extra information is included in the documentation as
applicable.

See Stabilization.

Predefined and Built-In Variables

Displaying Node Names, Tags, and Types in the Model Builder
There is a unique Name for each physics interface.

About Using Materials in COMSOL Multiphysics

The Settings Window for Material

Selection of material type is standard in most cases. Extra information is included
in the documentation as applicable.
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TABLE 2-4: COMMON PHYSICS SETTINGS SECTIONS

SECTION

CROSS REFERENCE AND NOTES

Model Inputs

Override and Contribution

Pair Selection

Stabilization — Consistent and
Inconsistent

About Model Inputs and Model Inputs and Multiphysics Couplings

Selection of Model Inputs is standard in most cases. Extra information is included
in the documentation as applicable.

To define the absolute pressure for heat transfer, see the settings for the Fluid
node.

To define the absolute pressure for a fluid flow interface, see the settings for the
Fluid Properties node (described for the Laminar Flow interface).

If you have a license for a nonisothermal flow interface, see that documentation
for further information.

Physics Exclusive and Contributing Node Types
Physics Node Status

Identity and Contact Pairs

Continuity on Interior Boundaries

Selection of pairs is standard in most cases. Extra information is included in the
documentation as applicable. Contact pair modeling requires the Structural
Mechanics Module or MEMS Module. Details about this pair type can be found in
the respective user’s guide. If the pair name in the list is followed by (partial) then
the feature is only valid on parts of the pair’s geometric entities.

Numerical Stabilization, Numerical Stability — Stabilization Techniques for
Fluid Flow and Heat Transfer Consistent and Inconsistent Stabilization
Methods

COMMON FEATURE NODES

TABLE 2-5: COMMON FEATURE NODES

FEATURE NODE

CROSS REFERENCE AND NOTES

Auxiliary Dependent Variable
Axial Symmetry

Continuity

Discretization

Equation View

Excluded Edges, Excluded Points,
and Excluded Surfaces

Global Constraint
Global Equations
Harmonic Perturbation

Initial Values

Periodic Condition and
Destination Selection

Pointwise Constraint

Auxiliary Dependent Variable
See Symmetry.
Continuity on Interior Boundaries and Identity and Contact Pairs.

This is standard in many cases. When it is not, the node is documented for the
physics interface.

Discretization (Node)
Equation View

The Equation View node’s contents is unique for each physics and mathematics
interface and feature node, but it is centrally documented.

Excluded Points, Excluded Edges, Excluded Surfaces

Global Constraint. Also see the Constraint Settings section.
Global Equations
Harmonic Perturbation, Prestressed Analysis, and Small-Signal Analysis

Physics Interface Default Nodes, Specifying Initial Values, and Dependent
Variables

This is unique for each physics interface.
Periodic Condition and Destination Selection
Periodic Boundary Conditions

Periodic Condition is standard in many cases. When it is not, the node is
documented for the physics interface.

Pointwise Constraint. Also see the Constraint Settings section.
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TABLE 2-5: COMMON FEATURE NODES

FEATURE NODE CROSS REFERENCE AND NOTES

Symmetry Using Symmetries and Physics Interface Axial Symmetry Node. There is also
information for the Solid Mechanics interface about Axial Symmetry.
This is standard in many cases. When it is not, the node is documented for the
physics interface.

Weak Constraint Weak Constraint. Also see the Constraint Settings section.

Weak Contribution Weak Contribution (ODEs and DAEs) and Weak Contribution (PDEs and
Physics)

Woeak Contribution on Mesh Weak Contribution on Mesh Boundaries

Boundaries

e Creating a New Model
The Add Physics Window

Showing More Options

* Seclecting Physics Interfaces
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Creating a New Model

This section describes how to create a new model using The Model Wizard or to begin with a blank model. First
you need to Open a New Window to Begin Modeling. It is also useful to have a basic model added to the Model
Builder; then you can experiment with The Model Builder, which is described in the Building a COMSOL
Multiphysics Model chapter.

Open a New Window to Begin Modeling

To open a New window:

* On the Quick Access Toolbar (Windows users) or the Model Toolbar (macOS and Linux users), click the New

button ( [*).
e DPress Ctrl+N.

¢ Select File>New.
After the New window opens to the Model page, select an option:

¢ Click the Model Wizard button ([ ) to open the Select Space Dimension window. Go to The Model Wizard
section to continue.

¢ Click the Blank Model button ([#]) to open COMSOL Multiphysics without any model set up in the Model
Builder or return to the default COMSOL Desktop. You can then add components and physics interfaces to the

model.

To enable the Physics Builder choose Preferences ( = ) from the File menu (Windows users) or from
the Options menu (macOS and Linux users). Click Physics Builder and select the Enable Physics
Builder check box.

[

After the applicable check box is selected, go to the Model Wizard and on the New page under
Physics, click Physics Builder ([Z). See the Physics Builder Manual for information.

The Model Wizard

The Model Wizard helps you build a model by choosing the space dimension, physics interfaces, and the study you
want to use. In the Model Wizard you Select Space Dimension, Select Physics, Review Physics Interface, and finally

Select Study.

SELECT SPACE DIMENSION
I Open the Model Wizard (see Open a New Window to Begin Modeling).

2 On the Select Space Dimension page, click to choose the Component geometry dimension: 3D, 2D axisymmetric,

2D, ID axisymmetric, 1D, or OD.
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Component Nodes by Space Dimension

The Component node has different icons based on space dimension 0D ( - ) (no space dimension), ID (—), 1D
axisymmetric ( i_), 2D ( € ), 2D axisymmetric ( i.), and 3D ( Im ).

0D is used for interfaces modeling spatially homogeneous systems such as chemical reacting

[

systems, electrical circuits, and general ODEs and DAEs. If you want to import a geometry, this

is done in the Model Builder, but make sure you choose spatial dimensions that this geometry

exists in. Remember, not all physics interfaces are available for all space dimensions.

Also add a Component node to the Model Builder:

* By right-clicking the root node (44 ) and selecting it from the Add Component menu.

* In the Home toolbar, select an option from <> Add Component list.

SELECT PHYSICS

On the Select Physics window, there are different ways to select one or several physics interfaces to add to the model.

There are also interfaces for PDEs, ODEs, and DAEs, and other mathematical interfaces for equation-based

modeling under the Mathematics branch.

Once one or more physics interfaces are selected, there are several options to continue; see Figure 2-15. Click to

select one of these buttons:

ICON AND NAME

ACTION

Add

@& Space Dimension
© Study
[/ Done

Q Cancel

Double-click to add the selected physics interface to the Added physics interfaces list, or
right-click and select Add physics to add one or more selected physics interfaces. You can also
add the selected physics by pressing Enter. Add as many physics interfaces as you want. You
can use the Review Physics Interface page to edit the Dependent Variables as required. Click
Remove as required to organize the physics interfaces in the list.

Click to go back to the Select Space Dimension page.

Click to choose the study for the model.

Click to add the physics interface without a study.

Click to return to the New page of the Model Wizard.

Help Click to open the context-based Help window.
You can also add physics interfaces from the Model Builder and The Add Physics Window:
EI * In the Home toolbar, click the 7z Add Physics button.

* By right-clicking the Component node and selecting Add Physics.
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Select Physics Review Physics Interface

Search Electric Currents (ec)

b % AC/DC
b ) Acoustics Dependent Variables
I 8 Chemical Species Transport
b 1.0 Electrochemistry
I == Fluid Flow
4 (|| Heat Transfer
@ Heat Transfer in Solids (ht)
Heat Transfer in Fluids (ht)
& Heat Transfer in Solids and Fluids (ht)
= Conjugate Heat Transfer
b Radiation
4 %\ Electromagnetic Heating
X Joule Heating
™ Induction Heating
[ Microwave Heating
“f Laser Heating
£°L Lumped Thermal System (its)
b {[[] Thin Structures
| @ Heat and Moisture Transport

Electric potential  V

Add
Added physics interfaces:

% Electric Currents (ec)
@ Heat Transfer in Solids (ht)
4, Multiphysics
/! Electromagnetic Heating (emh1)

Remove

°5pm Dimension e Study
Hep € Cancel [/ Dene

Figure 2-15: The Select Physics and Review Physics Interface windows in the Model Wizard.

REVIEW PHYSICS INTERFACE

Under Added physics interfaces (sce Figure 2-15), click any interface to open the Review Physics Interface page. Here
you can review and optionally modify any Dependent Variables names and, for some physics interfaces, specify the
number of dependent variables. For other physics interfaces you can edit both the name of the field and the field
components. Examples of fields with components are the displacement field in a Solid Mechanics interface and the

Velocity field for a Laminar Flow interface.

To remove a physics interface already selected, highlight it in the list and click Remove under the table.

SELECT STUDY

On the Select Study page, click to select the type of study to perform. You can also double-click the study to select
it and close the Model Wizard. The available options depend on the set of physics interfaces included in the model.
Some study types are applicable to all physics interfaces for which you choose to solve, while others are not, but all
are in some way available. The most applicable and common studies, such as Stationary, appear at the top of the list

under General Studies. You can also select a study type from one of the following branches (see Figure 2-16):

¢ General Studies — General studies that are the most applicable for the selected physics interfaces.

* Preset Studies for Selected Physics Interfaces — Studies applicable to each physics interface that you have chosen
to include. These preset studies appear under subnodes for each physics interface or under Suggested by Some
Physics Interfaces.

* Preset Studies for Selected Multiphysics — Studies applicable to the multiphysics couplings that you have chosen
to solve for.

* More Studies — Any fundamental study types (Stationary, Time Dependent, Eigenfrequency, Eigenvalue and
Frequency Domain) that are not applicable to any of the physics interfaces being solved for. Also, this branch can
contain some advanced composite study types.
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¢ Preset Studies for Some Physics Interfaces — The study types recognized by some, but not all, of the physics
interfaces being solved for.

e Empty Study — An empty study that will not perform any type of study unless you add some study steps to it.

Select Study Stationary

4 ~n General Studies The Stationary study is used when field variables do not change over time.

|= stationary

Examples: In electromagnetics, it is used to compute static electric or
[YL Time Dependent

magnetic fields, as well as direct currents. In heat transfer, it is used to

res udies for Selecte sics Interfaces compute the temperature field at thermal equilibrium. In solid mechanics,

~c Preset Studies for Selected Physics Interf pute the temperature field at th | equilib In solid h

~dn More Studies it is used to compute deformations, stresses, and strains at static

~ Preset Studies for Some Physics Interfaces equilibrium. In fluid flow it is used to compute the steady flow and
pressure fields. In chemical species transport, it is used to compute steady-

~db Empty Study

state chemical compaosition in steady flows. In chemnical reactions, it is
used to compute the chemical composition at equilibriumn of a reacting
system.

It is also possible to compute several solutions, such as a number of load
cases, or to track the nonlinear response to a slowly varying load.
Added study:

[= Stationary
Added physics interfaces:

+\_ Electric Currents (ec)
B Heat Transfer in Solids (ht)

° Physics
Help e Cancel D\/Done

Figure 2-16: The Select Study page in the Model Wizard.

Once a study is highlighted, information about it displays to the right of the window and it is included under Added
study. There are several options to continue.

ICON AND NAME ACTION

@& Physics Click to go back to the Select Physics and Review Physics Interface window.
[/ Done Click to exit the Model Wizard.

& Cancel Click to return to the New page of the Model Wizard.

Help Click to open the context-based Help window.

Also add physics interfaces from the Model Builder and The Add Physics Window:

EI * In the Home toolbar, click the 22 Add Physics button.

* By right-clicking the Component node and selecting Add Physics.
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After clicking Done, the Model Builder window displays a model tree with a set of default nodes in the Component
branches: Definitions, Geometry, Materials, Mesh, and nodes based on the physics interfaces selected (see
Figure 2-17). The Component nodes and branches form the sequence of operations that define the model.

Madel Builder
= =tE
4 G Untitled.mph (root)
4 3 Global Definitions
Pi Parameters 1

1

== Materials
4 (@ Component 1 (comp 1)
[ = Definitions
3 '}"\.__ Geometry 1
== Materials
- }_ Electric Currents {ec)
e Current Conservation 1
TG Electric Insulation 1
T Initial Values 1
4 | [E Heat Transfer in Solids (ht)
= Solid 1
i Initial Values 1
e Thermal Insulation 1
<y Multiphysics
A Mesh 1
4 ~cih Study 1
E Step 1: Stationary

[ @ Results

Figure 2-17: After clicking Done, & 3D Component with Electric Curvents, Heat Transfer in Solids interfaces, and a

Stationary study is added to the Model Builder.

Also add a study from the Model Builder and The Add Study Window:

'g' * By right-clicking the root node and selecting Add Study.

e In the Home toolbar, click the Add Study button.

* Building a COMSOL Multiphysics Model
* The Component Node
El * The Add Physics Window
e The Add Study Window
* The Model Builder
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Toolbars and Keyboard Shortcuts

The toolbars and context menus in COMSOL Multiphysics are based on the stage of modeling. This section is a
single resource for each of the ribbon and contextual toolbars available on the COMSOL Desktop. There are also
several Keyboard Shortcuts that are useful for navigating during the modeling process. The following sections have

a table where there are links to more information about the available items in the ribbon toolbar or contextual

toolbar.
* Home Toolbar * Mesh Toolbar
e Definitions Toolbar ¢ Study Toolbar
* Geometry Toolbar * Results Toolbar
* Sketch Toolbar ¢ Plot Group Contextual Toolbar
* Work Plane Modal Toolbar e Report Group Contextual Toolbar
* Materials Toolbar ¢ Template Group Contextual Toolbar
* Physics Toolbar * View Toolbar
¢ 0D Component Toolbar e Developer Toolbar
{El About Changes to the Ribbon Display (Windows Users)

Home Toolbar

The Home ribbon toolbar (Windows) and the Model Toolbar (macOS and Linux) contains many of the common

features and actions required to build, simulate, and analyze a model.

For step-by-step instructions and general documentation descriptions, this is the Home toolbar.

TABLE 2-6: THE HOME TOOLBAR

BUTTON NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION
OR MENU

Workspace

A Application Toggle between the Application Builder and Model
Builder Builder workspaces.
(Ctrl+Shifc+A)
Model Manager Toggle between the Model Manager and Model
(Ctrl+Shifct)) Builder workspaces.
Model <>
B Component Select any existing model component to move to  The Component Node

that component. The name and icon indicates the
current component and can therefore vary.

& Add Component  Add 3D, 2D, 2D Axisymmetric, ID, 1D The Component Node
Axisymmetric, and 0D model components, and
insert components.
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TABLE 2-6: THE HOME TOOLBAR

BUTTON
OR MENU

NAME

DESCRIPTION OR OPTIONS

LINKS TO MORE INFORMATION

Definitions (=)

=/

P; Parameters

a= Variables

o)) Functions

P Parameter Case
Geometry [[&

B Build All

Import

=

(] LiveLink

Materials :::

Add Material

bt

Physics @::

— Various — the
physics interface
name

Select Physics

Interface
h Add Physics
Mesh A
B Build Mesh
L\;\ Select Mesh!
F:N Mesh!
Study =

Add globally available Parameters to your model.

Choose from Global Variables and Local Variables.

Choose from a list of all available Functions

Add a Parameter Case subnode to a Parameters
node.

Build all features in the current geometry.

Import the geometry from a COMSOL
Multiphysics file or CAD file.

Choose to connect to a CAD software using a

LiveLink connection that is included in your license.

Open the Add Material window to add materials to
components or selections.

When physics interfaces are added, these are listed
here and you can click to take you to the node in
the Model Builder.

For a blank model this is available.

Open the Add Physics window to add physics
interfaces to the current component.

Build the current mesh.

Awvailable for a blank model.

When meshes are added, these are listed here and
you can click to take you to the node in the Model
Builder.

Global Definitions,
Geometry, Mesh, and
Materials and Parameters

Global Definitions,
Geometry, Mesh, and
Materials, Predefined and
Built-In Variables

Functions

Parameter Cases

Editing and Building
Geometry Nodes

The Geometry Node

Import

See the documentation for the

CAD LiveLink products.

The Add Material Window

Physics Interface Guide

Selecting Physics Interfaces

The Add Physics Window

Adding, Editing, and

Building Meshing Operations

and Attributes

Mesh Elements for 1D, 2D,
and 3D Geometries

Meshing Overview
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TABLE 2-6: THE HOME TOOLBAR

BUTTON  NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION
OR MENU
= ComputeI Compute the selected study. Computing a Solution
& Select StudyI Available for a blank model. Open a New Window to
Begin Modeling and The Add
Study Window
~D StudyI When studies are added, these are listed here and Introduction to Solvers and
you can click to take you to the node in the Model ~ Studies
Builder.
\)1 Add StudyI Open the Add Study window to add a study to the The Add Study Window
current Component.
Results =
m Select ||°|ot Available for a blank model. About Plot Groups
Group

— Various — the
name of the plot
group

Add Plot Group'

&

Layout [

Reset Desktop2

| Windows

Add Physics?

o Add
v . .2
Multiphysics
. 2
o Add Study
it Add Material
- from Library2
Ij] Material
Browser2
[ Application
Libraries
ﬂ]]] Part Libraries?
& Selection List2

Once results are available or plot groups are added,
these are listed here and you can click to take you
to the node in the Model Builder. It also opens a
new Plot Group contextual toolbar for the plot
group.

3D Plot Group, 2D Plot Group, |1D Plot Group,
Polar Plot Group, or Smith Plot Group.

Reset the COMSOL Desktop to its default settings
and choose Widescreen Layout or Regular Screen
Layout.

Choose any of the available windows that you can
add to the COMSOL Desktop. The Windows
menu contains the windows on the following rows
in this table.

Open the Add Physics window to add physics
interfaces to the current component.

Open the Add Multiphysics window to add
multiphysics couplings to the current component.

Open the Add Study window to add a study to the
current Component.

Open the Add Material window to add materials to
components or selections from the material
libraries.

Open the Material Browser where you can access

and edit material libraries.

Open the Application Libraries window.

Open the Part Libraries window where you can
access collections of geometry parts.

Choose objects, for example, while working with
complex geometries and when you need to easily
locate a geometric entity that is not easily viewed.

Plot Groups and Plots

About Plot Groups

Customizing the Desktop
Layout

Creating a New Model

The Add Multiphysics
Window

The Model Wizard

The Add Material Window

The Material Browser
Window

The Application Libraries
Window

Part Libraries

The Selection List Window
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TABLE 2-6: THE HOME TOOLBAR

BUTTON  NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION

OR MENU

Properties? The Properties window is accessed from the Settings and Properties
context menu and displays other node properties. ~ Windows for Feature Nodes

[ Messages2 Contains information useful after an operation is The Messages Window
performed.

Debug Log Displays debug information for debugging code in  See the Application Builder
methods. Reference Manual.

B Table? Displays the results from integral and variable The Table Window and

evaluations defined in Derived Values nodes or by
Probes and stored in Table nodes.

by External Follow external processes (such as distributed
Process? batch jobs) that have been started. The window
updates when you are attached to the external
processes.
o] Recovery Files? Manage and open recovery files.
i Comparison Comparison of Physics Builder files.
Results
Physics Builder Manage testing, compilation, and comparison of
- M 2 Physics Builder fil
anager your Physics Builder files.

Tables Node

The External Process Window

Keeping and Opening
Recovery Files

See the Physics Builder Manual.

See the Physics Builder Manual.

' For cross-platform users (macOS and Linux), the combination of buttons that display is dependent on the toolbar
setting. For example, some buttons may not be visible if the Tools>Toolbar Display Mode is set to Normal and the
Tools>Toolbar Button Label is set to Show Icon and Text. It also depends on whether you are using a widescreen or

regular screen layout.

2 For cross-platform users (macOS and Linux), these options are available from other menus or toolbars. See Cross

Platform (macOS and Linux) Toolbars and Menus.

Definitions Toolbar

The Definitions ribbon toolbar (Windows) and the Definitions contextual toolbar (macOS and Linux) contain many

of the common features and actions required to work with features found under the Definitions node in the Model

Builder.

For step-by-step instructions and general documentation descriptions, this is the Definitions

EI toolbar.

TABLE 2-7: THE DEFINITIONS TOOLBAR

BUTTON NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION

OR

MENU

Variables

a= Local Variables Add a Variables node under Definitions. Global Definitions, Geometry,
Mesh, and Materials,
Predefined and Built-In
Variables

g Variable Utilities Add a variable utility such as a matrix variable Variable Utilities

under Definitions.

Functions
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TABLE 2-7: THE DEFINITIONS TOOLBAR

BUTTON NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION
OR
MENU
f':i«' Analytic Add an Analytic function node to define an Analytic
analytic function.
S Interpolation Add an Interpolation function node to define an  Interpolation
) interpolation function.
rat Piecewise Add a Piecewise function node to define a Piecewise
piecewise function.
Fo0) More Functions All available Functions (except Analytic, Functions
Interpolation, and Piecewise).
Selections
& Explicit Add an Explicit node under Definitions. Creating Named Selections and
Explicit
S Complement Add a Complement node under Definitions. Union, Intersection,
Difference, and Complement
y Adjacent Add an Adjacent node under Definitions. Adjacent
& Ball/Disk Add a Ball (3D) or Disk node under Definitions. ~ Ball, Disk
Box Add a Box node under Definitions. Box
& Cylinder Add a Cylinder node under Definitions. Cylinder
E Union Add a Union node under Definitions. Union, Intersection,
Difference, and Complement
é Intersection Add an Intersection node under Definitions.
E Difference Add a Difference node under Definitions.
"P_-\l Colors Add, reset, or remove colors for selections. Selection Colors
Probes

i

Update Probes

Probes

Physics Utilities

Mass Properties

Mass Contributions

Participation
Factors

Response Spectrum

Buckling
Imperfection

Update all probes.

Select an option from the list to add a node
under Definitions Table 5-18.

Add a Mass Properties node to the current
model component.

Add a Mass Contributions node to the current
model component.

Add a Participation Factors node to the current
model component.

Add a Response Spectrum node to the current
model component.

Add a Buckling Imperfection node to the current
model component (requires the Structural
Mechanics Module or the MEMS Module).

Probes

Mass Properties
Mass Contributions
Participation Factors
Response Spectrum

Buckling Imperfection
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TABLE 2-7: THE DEFINITIONS TOOLBAR

BUTTON NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION

OR

MENU

Coupling

P Nonlocal Couplings  Select an option from the list to add a node Nonlocal Couplings and
under Definitions. Coupling Operators

4] Pairs Select an option from the list to add a node About Identity and Contact
under Definitions. Pairs

Coordinate Systems

[ k! Coordinate Select an option from the list to add a node Coordinate Systems
SystemsI under Definitions Table 5-17.

& Perfectly Matched ~ Add a Perfectly Matched Layers node under Perfectly Matched Layer
LayerI Definitions.

|i Infinite Element Add an Infinite Element Domain node under Infinite Element Domain
Domain' Definitions.

E Absorbing LayerI Add an Absorbing Layer node under Definitions. Absorbing Layer
Deformed Mesh

= Moving Mesh Add moving mesh nodes under Definitions. Moving Mesh Features

BE| Deformed Add deformed geometry nodes under Deformed Geometry Features
Geometry Definitions.

Optimization

7 Optimization Add optimization nodes. See the documentation for the

Optimization Module.

View
L~ View! Add a View node to the current Component to ~ View (1D and 2D), View (3D),
control the view and lighting in the Graphics Axis (2D and 2D
window. - - 3D and [ 2D. Axisymmetric) and Axis (1D

and 1D Axisymmetric)

' For cross-platform users (macOS and Linux), the combination of buttons that display is dependent on the toolbar
setting. For example, some buttons may not be visible if the Tools>Toolbar Display Mode is set to Normal and the
Tools>Toolbar Button Label is set to Show Icon and Text. It also depends on whether you are using a Widescreen or
Regular Screen Layout.

Geometry Toolbar

Once a geometry is added to the model, the Geometry ribbon toolbar (Windows) and the Geometry contextual
toolbar (macOS and Linux) contains many of the common features and actions required to create and build a

geometry.
For cross-platform users, some options listed in Table 2-8 are available from other toolbars and menus. Table 2-9

lists the geometry drawing tools available on the toolbars in 1D and 2D, as well as on the Work Plane toolbar for
3D models. See Cross Platform (macOS and Linux) Toolbars and Menus.

For step-by-step instructions and general documentation descriptions, this is the Geometry toolbar.
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TABLE 2-8: THE GEOMETRY TOOLBARS

BUTTON NAME
OR
MENU

DESCRIPTION OR OPTIONS

Build &

& Build All2

Import/Export —

iE=] Import2

E‘j’] Insert Sequence

= Export

Cleanup

[+ | Defeaturing and
Repairl’3

R, Remove Details

] Virtual
OperationsI

Sketch (2D) _4'
Sketch

Primitives <& (3D)

Ny Block
Cone
() Cylinder
) Sphere
=) Torus
(*_'__, Helix
O More Primitives

Primitives = (2D)

=) Circle

() Ellipse
| Rectangle
|l Square
s Polygon

Build all features in the current geometry. See Editing and Building Geometry
Nodes.

Import the geometry from a COMSOL Multiphysics file or CAD file.

Insert a geometry sequence from a COMSOL Multiphysics file into the current
geometry. See Inserting a Sequence.

Export the current geometry as a COMSOL binary or text file or to a CAD file
format. See Exporting a Geometry.

Choose from Cap Faces, Delete Fillets, Delete Short Edges, Delete Sliver Faces, Delete
Small Faces, Delete Spikes, Delete Faces, Detach Faces, Knit to Solid, and Repair.

Remove small details from 3D geometries. See Remove Details.

Virtual geometry operations and mesh control operations. See Virtual Geometry
Operations and Virtual Geometry and Mesh Control Operations.

Toggle the sketch visualization on or off. See The Sketch Visualization.

Add a Block to the current geometry.
Add a Cone to the current geometry.
Add a Cylinder to the current geometry.
Add a Sphere to the current geometry.
Add a Torus to the current geometry.
Add a Helix to the current geometry.

Add all other 3D primitives as in Table 7-3 and Geometric Primitives. Also see the
geometry parts available in the Part Libraries.

Add a Circle to the current geometry.
Add an Ellipse to the current geometry.
Add a Rectangle to the current geometry.
Add a Square to the current geometry.

Add a Polygon to the current geometry.
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TABLE 2-8: THE GEOMETRY TOOLBARS

BUTTON NAME
OR
MENU

DESCRIPTION OR OPTIONS

. Point

More Primitives

Primitives — (ID)

— Interval

Point

Work Plane =L

&=/ Select Work
Plane

&=/ Work Plane

Operations %

= Extrude

t—_l—. Revolve

= Sweep

1_:-__I:I:- Loft

= Booleans and
Partitions

Transforms

']

% Conversions'
ﬂ Chamfer!

Fillet!

S Tangent

DeleteI

Add a Point to the current geometry.

Add all other 2D primitives as in Table 7-3 and Geometric Primitives. Also see The
1D Geometry Toolbar — Drawing Tools (Table 2-9) and the geometry parts
available in the Part Libraries.

Draw an interval (line) in the Graphics window. For |D models, first click the Interval
button, then click the starting point and endpoint in the Graphics window.

Also see Geometric Primitives and The 1D Geometry Toolbar — Drawing Tools
(Table 2-9).

Add a point to the Graphics window. Use this to draw a single point. First click the
Point button, then click in the Graphics window (in 1D and 2D), or specify the point
location in its Settings window. In 2D and 3D, this button is available on the More
Primitives menu.

Once Work Planes are available or added, these are listed here and you can click to
take you to the associated Plane Geometry node in the Model Builder. It also opens a
new Work Plane contextual toolbar for the Work Plane. See Using Work Planes,
Work Plane Modal Toolbar and Table 2-9.

Add a Work Plane to the current geometry. See Using Work Planes, Work Plane
Modal Toolbar and Table 2-9.

Extrude planar faces of geometry objects or objects from a work plane to create 3D
geometry objects.

Revolve planar faces of geometry objects or objects from a work plane about an axis
to create 3D geometry objects.

Sweep faces along a spine curve to create a solid object.
Requires the Design Module. Lofting planar sections along a path.

Create a geometry object using Boolean operations: Union, Intersection, Difference,
and Compose.

Partition geometry objects into parts using other geometry objects as tool objects for
the partition. Alternatively, in 3D, use a work plane to partition the geometry objects.
Select Partition Objects or Partition Edges.

This menu has these operations available: Array, Copy, Mirror, Move, Rotatcl, ScalcI
See Table 7-8 for a list of these features. Also see Conversion Operations.

Chamfer corners in 2D geometry objects. Also in 3D with the Design Module.

Fillet corners in 2D geometry objects. Also in 3D with the Design Module.

Add a line segment that is tangent to a given edge in 2D geometries.

Delete the selected geometry objects. See Clearing Sequences and Deleting
Sequences or Nodes.
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TABLE 2-8: THE GEOMETRY TOOLBARS

BUTTON NAME DESCRIPTION OR OPTIONS
OR
MENU
F 4 Edit Object Adjust edges and vertices for 2D geometry objects or add or delete edges and vertices
i in the object.
j=2 Cross Section Create 2D cross sections from 3D geometries.
Other
pay Parts 3D, 2D, and D Parts, Load Part, and Part Instances. See Part Libraries, Using
Geometry Parts, and Part Instance.
Pr'ogrammingI If + End If and Parameter Check. From the Add Before and Add After menus: If, Else If,
Else, and End If. See If, Else If, Else, End If; and Parameter Check.
. Selections' Create named selections of geometry objects or geometric entities in geometry
objects. See Creating Named Selections in the Geometry Sequence.
f_:u Colors! Add coloring to highlight named selections in the Graphics window. See Selection
Colors.
P Measure' Measure the volume, area, perimeter, or other geometric properties of the selected
geometric entities or objects. See Mecasuring Geometry Objects.
158 Delete Delete a geometry sequence. See Clearing Sequences and Deleting Sequences or

SequenceI Nodes.

' For cross-platform users (macOS and Linux), the combination of buttons that display is dependent on the toolbar
setting. For example, some buttons may not be visible if the Tools>Toolbar Display Mode is set to Normal and the
Tools>Toolbar Button Label is set to Show Icon and Text. It also depends on whether you are using a Widescreen or
Regular Screen Layout. It also depends if the button is available on the Work Plane toolbar, in which case it may be
visible.

2 For cross-platform users, this option is available from a different toolbar or menu. See Cross Platform (macOS
and Linux) Toolbars and Menus.

3 These features are available for the LiveLink and CAD products, and you must use the CAD kernel for the
geometry representation.

GEOMETRY DRAWING TOOLBAR BUTTONS
In 1D, there are buttons for drawing Geometric Primitives by using the mouse. In 2D, the Sketch Toolbar provides
tools for drawing 2D geometric primitives. In 3D, the buttons are available to create primitives, but you cannot

draw these using the mouse unless you are using a Work Plane.

TABLE 2-9: THE ID GEOMETRY TOOLBAR — DRAWING TOOLS

BUTTON NAME DESCRIPTION OR ACTION
OR
MENU

Draw Settings [/

3 Snap to Grid Snap to the grid when drawing a geometry object in the Graphics window.

By default, the mouse pointer snaps to the grid points. The active grid point for the
snapping is indicated with a red circle. To disable snapping to the grid, click the Snap to

Grid button.
I Snap to Snap to the vertices of other geometry objects when drawing a geometry object in the
Geometry Graphics window.

By default, the mouse pointer snaps to the geometry vertices. The active point for the
snapping is indicated with a red circle. To disable snapping to the geometry objects,
click the Snap to Geometry button.
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TABLE 2-9: THE ID GEOMETRY TOOLBAR — DRAWING TOOLS

BUTTON NAME

DESCRIPTION OR ACTION

OR
MENU
Draw 7
Interval Draw an Interval (line) in the Graphics window. For ID models, first click the Interval
button, then click the starting point and endpoint in the Graphics window.
Point Add a Point to the Graphics window. Use this to draw a single point. First click the

Point button, then click in the Graphics window (in 1D and 2D), or specify the point
location in its Settings window. In 2D and 3D, this button is available on the More
Primitives menu.

Sketch Toolbar

Use the Sketch toolbar to draw in the graphics window for a 2D geometry or part, or in a work plane for a 3D

geometry. If you have the Design Module, the Sketch toolbar also contains buttons for creating geometric

constraints and dimensions (see the Design Module documentation for more information).

TABLE 2-10: THE SKETCH TOOLBAR

BUTTON NAME
OR
MENU

DESCRIPTION OR ACTION

Sketch

r 4 Sketch

Draw Settings [~/

3 Snap to Grid
| Snap to
Geometry

rg Constrain
fa|

Solid
bAY Construction
Draw #-
Il Polygon

s Circular Arc

Toggle the sketch visualization on or off. See The Sketch Visualization.

Snap vertices and edges to the grid when drawing or dragging a vertex in the Graphics
window. The snapped cursor position is indicated with a blue circle.

Snap vertices and edges to vertices and edges when drawing or dragging a vertex in the
Graphics window. The vertex or edge snapped to is highlighted in turquoise. There can
also be a green line or circle segment between the snapped entities. If you have the
Design Module and you have enabled Use constraints and dimensions in the Geometry
node’s settings: When snapping occurs, a constraint feature will be generated in some
cases, so that the snapping will persist when you modify your geometry.

Create geometric constraints when snapping to the geometry.

Create a solid object (instead of a curve object) when drawing a closed curve in the
Graphics window.

Create construction geometry objects when drawing in the Graphics window.

Draw a sequence of line segments in the Graphics window. Click the points of the

polygon. Then right-click anywhere to finish, or click another curve drawing button to

create a Composite Curve.

Draw a sequence of circular arcs in the Graphics window in one of the following ways:

¢ Click the Circular Arc button or choose the menu item Start, Center, Angle. Then
click the starting point, the center, and the direction of the end angle.

¢ Choose the Start, Tangent, End menu item. Then click the starting point, the

direction of the tangent line at the starting point, and the endpoint.

* Choose the Start, Tangent, End menu item. Then click the starting point, the

direction of the tangent line at the starting point, and the endpoint.

TOOLBARS AND KEYBOARD SHORTCUTS | 129



TABLE 2-10: THE SKETCH TOOLBAR

BUTTON NAME DESCRIPTION OR ACTION
OR
MENU
r Interpolation Draw a cubic spline curve that interpolates given points in the Graphics window, in one
o
Curve of the following ways:

¢ Click the Interpolation Curve button or choose the Interpolation Points menu item.

Then click a sequence of points to interpolate.

¢ Choose the Start, Tangent, Other menu item. Then click the starting point, the
direction of the tangent line at the starting point, and the other interpolation

points.

Finally, right-click anywhere to finish, or click another curve drawing button to

create a Composite Curve.

Quadratic Draw a sequence of quadratic Bézier curve segments in the Graphics window. Click
the three control points to create one Bézier segment. A Quadratic Bézier node is
then added. Optionally, click an even number of additional control points to create
several Bézier segments. Finally, right-click anywhere to finish, or click another curve
drawing button to create a Composite Curve that contains Quadratic Bézier nodes
corresponding to each Bézier segment.

1]

r Cubic Draw a sequence of cubic Bézier curve segments in the Graphics window. Click the
four control points to create one Bézier segment. A Cubic Bézier node is then added.
Optionally, click additional control points to create several Bézier segments. Finally,
right-click anywhere to finish, or click another curve drawing button to create a
Composite Curve that contains Cubic Bézier nodes corresponding to each Bézier
segment.

. Point Draw a point in the Graphics window. After clicking the button, click the point in the
Graphics window.

I Rectangle Draw a rectangle or square in the Graphics window in one of the following ways:
* Click the Rectangle button or choose the Rectangle menu item. Then click two
opposite corners of the rectangle.
* Choose the Square menu item. Then click one corner. Move the mouse to adjust
the size of the square. Click to finish.
¢ Choose the Rectangle (Center) menu item. Then click the center and one corner.
¢ Choose the Square (Center) menu item. Then click the center. Move the mouse
to adjust the size of the square. Click to finish.
=) Circle Draw a circle or ellipse in the Graphics window in one of the following ways:
* Click the Circle button or choose the Circle menu item. Then click the center.
Move the mouse to adjust the size of the circle. Click to finish.
¢ Choose the Ellipse menu item. Then click the center. Move the mouse to adjust
the axes of the ellipse. Click to finish.
¢ Choose the Circle (Corner) menu item. Then click one corner of the circumscribed
square of the circle. Move the mouse to adjust the size of the circumscribed
square. Click to finish.
¢ Choose the Ellipse (Corner) menu item. Then click one corner of the
circumscribed rectangle of the ellipse. Move the mouse to adjust the size of the

circumscribed rectangle. Click to finish.
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TABLE 2-10: THE SKETCH TOOLBAR

BUTTON
OR
MENU

NAME

DESCRIPTION OR ACTION

Operations =

Composite
Curves

Delete

Create a Composite Curve feature that has a sequence of child features of type
Polygon, Circular Arc, Interpolation Curve, Quadratic Bézier, and Cubic Bézier. First
select at least one edge from each curve object to include in the Composite Curve in
the Graphics window. These objects must be of one of the following types: Polygon,
Circular Arc, Interpolation Curve, Quadratic Bézier, Cubic Bézier, or Composite
Curve. The curve objects must form a single connected chain. Then click the Compose
Curves button. The original curve features will be replaced with a Composite Curve
feature or a Polygon feature in the Model Builder.

Delete the selected vertices and edges. Select some vertices and edges in the Graphics
window. Then click the Delete button or press the Del key. This will delete the selected
entities using a combination of the following methods:

* Removing geometry features from the Model Builder

¢ Removing points from Polygon features

¢ Splitting Polygon and Composite Curve features into several features
* Adding Delete Entities features

This operation does not delete selected vertices that are adjacent to an edge that is

not selected.

If you have the Design Module, you can also select symbols for constraint and
dimension features and then delete them by clicking Delete or pressing Del.

Work Plane Modal Toolbar

The Work Plane modal toolbar is available after clicking Plane Geometry under Geometry>Work Plane in the Model

Builder.

For step-by-step instructions and general documentation descriptions, this is the Work Plane modal

toolbar.

[

The Work Plane toolbar is similar to the 2D Geometry Toolbar except that the Virtual Operations

menu is not available and there is a Close button.
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Figure 2-18: Click the Plane Geometry node to open the Work Plane toolbar.

Materials Toolbar

Once physics interfaces are added to the model, the Materials ribbon toolbar (Windows) and the Materials
contextual toolbar (macOS and Linux) contains many of the common features and actions required to work with

the features found under the Materials node in the Model Builder.

'g' For step-by-step instructions and general documentation descriptions, this is the Materials toolbar.

TABLE 2-11: THE MATERIALS TOOLBAR

BUTTON NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION
OR

MENU

Materials

Add Material Open the Add Material window to add materials to  The Add Material Window
components or selections.

o

H Blank Material Add a blank material to your model. Materials and The Settings
Window for Material
EQ Browse Open the Material Browser where you can access The Material Browser Window
Materials and edit material libraries.
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TABLE 2-11:

THE MATERIALS TOOLBAR

BUTTON NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION
OR
MENU
i More Materials  Add a global External Material, Material Switch, Material Link, Switch for
Layered Material, or Single Layer Material. If the Materials, Layered Material,
model contains a D, 2D, or 3D component,adda  Layered Material Link, Layered
Material Link, Material Switch, Single Layer Material, Material Stack, Single-Layer
Layered Material Link, or Layered Material Stack to ~ Materials, and Working with
the current component. External Materials
L H Recent Add any of the recently added materials as a global
Materials material. If the model contains a 1D, 2D, or 3D
component, you can also add a recently added
material under Local to the current component.
H Merge With Merge the currently selected material with another =~ Merging a Material With
material in the model. Another Material
= Import Import materials to the model using the Import Importing and Exporting
Materials Materials dialog box or the Select Model fullscreen ~ Materials, The Select Model
view. Window
= Export Export materials to an XML-file using the Export Importing and Exporting
Materials Materials dialog box that opens. Materials

Property Groups

Analytic

Interpolation

Piecewise

User-Defined
Property Group

User-Defined Libraries

l

Add to Library

Add an Analytic function node to define an analytic
function.

Add an Interpolation function node to define an
interpolation function.

Add a Piecewise function node to define a piecewise
function.

Add a user-defined property group to current
material.

Add a material to a user-defined material library.

Analytic and Using Functions
in Materials

Interpolation and Using
Functions in Materials

Piecewise and Using Functions
in Materials

Property Groups

User-Defined Materials and
Libraries

Physics Toolbar

Once physics interfaces are added to the model, the Physics ribbon toolbar (Windows) and the Physics contextual

toolbar (macOS and Linux) contains many of the common features and actions required to add physics interfaces
and features to the Model Builder.

B

For interfaces available in 0D, see 0D Component Toolbar.

For step-by-step instructions and general documentation descriptions, this is the Physics toolbar.
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TABLE 2-12: THE PHYSICS TOOLBAR

BUTTON NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION
OR

MENU

Physics @:¢

— Various - the
physics
interface name

eh Add Physics

14 Add
Multiphysics

= Insert Physics

i Insert Physics
From

Geometric Entity

[ Domains
- Boundaries
= Pairs
= Edges
Points
o3 Global
Contextual
— Attributes
Bt Load Group
e Constraint
Group

Any physics interfaces added to the selected
Component are listed. Click to go to the node in the
Model Builder and open the Settings window. See
Physics Interface Guide.

Open the Add Physics window to add physics
interfaces to the current component.

Open the Add Multiphysics window to add
applicable multiphysics couplings to the current
component.

Open the Insert Physics dialog box to insert physics
interfaces in the current model component from
another model file.

Open the fullscreen Select Model window insert
physics interfaces in the current model component
from another model file in a database or by
browsing.

See Table 3-3 for a list of all the icons by space
dimension.

Auvailable physics features for the physics interface

are listed. To add subnodes, however, you need to
right-click the parent node. For example, to add a

Destination Selection subnode, right-click Periodic
Condition.

Subnodes that can be added to a main (parent)
node.

“: 0D, — ID, &2 2D, and @ 3D

—

After adding a Load Group to the Global Definitions

branch you can activate it in one or more load cases.

After adding a Constraint Group to the Global
Definitions branch you can activate it in one or
more load cases.

The Physics Interfaces

The Add Physics Window

The Add Multiphysics Window

Adding and Inserting Physics
Interfaces

Adding and Inserting Physics
Interfaces

About Geometric Entities

About Selecting Geometric

Entities

For example, Destination
Selection (a subnode to Periodic
Condition) or Damping (a
subnode to Linear Elastic
Material).

When available, Harmonic
Perturbation is added from this
menu as an exclusive node. See
Harmonic Perturbation —
Exclusive and Contributing
Nodes

Using Load Cases
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TABLE 2-12: THE PHYSICS TOOLBAR

BUTTON NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION
OR
MENU
- Harmonic Click this to add Harmonic Perturbation as a Harmonic Perturbation —
Perturbation contributing node. Exclusive and Contributing
Nodes

Multiphysics .

P Multiphysics This menu contains any physics features that provide  Multiphysics Modeling
Couplings multiphysics couplings likely to be used for the set of Workflow and The
physics interfaces added to the Model Builder. Multiphysics Branch

0D Component Toolbar

Once a 0D component interface is added to the model, a toolbar with the same name as the physics interface

displays in the ribbon (Windows) and the contextual toolbar (macOS and Linux).

For step-by-step instructions and general documentation descriptions, the name of the toolbar is

=} the same as the physics interface it is attached to.

These toolbars are documented for the interfaces in the applicable module documentation.
Available with a COMSOL Multiphysics license:

¢ Global ODEs and DAEs. See The Global ODEs and DAEs Interface.
¢ Events. See The Events Interface.

* Sensitivity. See The Sensitivity Interface.
Available with the addition of various licenses:

¢ Reaction Engineering
¢ Chemistry

* Optimization

Mesh Toolbar

Once a mesh is added to the model, the Mesh ribbon toolbar (Windows) and the Mesh contextual toolbar (macOS

and Linux) contains many of the common features and actions required to work with meshes.

TABLE 2-13: THE MESH TOOLBAR

BUTTON  NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION
OR MENU
Build
(] Build Mesh? Build the current mesh. Adding, Editing, and Building
Meshing Operations and
Attributes
L\;\ Mesh (1, 2, 3,...) Lists the meshes available in the model. Click a Meshing Overview
Mesh button to go to the node in the Model
Builder.
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TABLE 2-13: THE MESH TOOLBAR

BUTTON  NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION
OR MENU
F:N Add Mesh Add a new mesh to the current model Adding, Editing, and Building

Import/Export [+
= Import
= Export

Physics Controlled :::

).

Create Geometry

L Edit
ﬁ Reset

Al

Mesh Size (Normal
is the default)

Generators A

Sizing
& Free Tetrahedral
£ Swept

Boundary

Boundary Layers

Attributes &

Al

Mesh Size (Normal
is the default)

@ Distribution
a= Size Expression
L%, More Attributes

Operations

L Modify
Copy

component, or create mesh parts by adding
Mesh Part nodes, under which you import a
mesh and prepare it for use in a component

Import mesh.
Export mesh.

Create a new model component with a
geometry created from the mesh.

Edit the physics-controlled sequence.

Reset the sequence to the physics-controlled
settings.

See Table 8-1 for a list of options.

Size, Size Expression, Distribution, Corner
Refinement, and Scale

Generate unstructured tetrahedral mesh for 3D
components.

Generate swept mesh for 3D components.

The following are available from this menu: Free
Triangular, Free Quad, Mapped, and Edge.

Generate boundary layer mesh.

See Table 8-1 for a list of options.

Add a Distribution node under the selected
node to specify an element distribution.

Add a Size Expression node under the selected
node to specify an expression for the element
size.

See Attributes.

Refine, Adapt, Convert, and Reference.

Copy Domain, Copy Edge, Copy Face, and
Copy.

Meshing Operations and
Attributes, Mesh Parts

Importing Meshes
Exporting Meshes

Creating Geometry from Mesh

Editing and Resetting a
Physics-Controlled Sequence

The Mesh Toolbar (Predefined
Mesh Element Sizes)

Mesh Element Quality

Attributes, Mesh Element
Sizing

Free Tetrahedral
Swept

Generators

Boundary Layers

The Mesh Toolbar (Predefined
Mesh Element Sizes)

Mesh Element Quality
Attributes

Attributes

Moditying Operations

Copying Operations
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TABLE 2-13: THE MESH TOOLBAR

BUTTON  NAME DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION
OR MENU
Booleans and Create geometric entities by creating a union, Booleans and Partitions
Partitions intersecting, or partitioning the mesh. See Finalizing the Mesh

Union, Intersect with Plane, Partition with
Ball, Partition with Box, Partition with
Cylinder, Partition by Expression, and Detect
Faces (in 3D).

Iﬁ Create Entities Create mesh vertices, edges, faces, and domains, Create Entities
and fill holes in imported meshes.

-= Delete Entities Delete geometric entities. Delete and Join Entities
i Join Entities Join adjacent geometric entities. Delete and Join Entities

Evaluate —

= Measure Measure the volume, area, perimeter, or other Measuring Geometry Objects
geometric properties of the selected geometry
objects.
A Statistics Write information about number and quality of =~ Mesh Statistics
elements to the Messages window.
=N Plot Add a mesh plot. Mesh (Plot)
Clear
) Clear Mesh! Clear the mesh. Clearing Sequences and
Deleting Sequences or Nodes
) é Clear All Meshes' Clear all meshes in the model.
158 Delete SequenceI Delete a meshing sequence. Clearing Sequences and

Deleting Sequences or Nodes

' For cross-platform users (macOS and Linux), the combination of buttons that display is dependent on the toolbar

setting. For example, some buttons may not be visible if the Tools>Toolbar Display Mode is set to Normal and the

Tools>Toolbar Button Label is set to Show Icon and Text. It also depends on whether you are using a Widescreen or
Regular Screen Layout.

2 For cross-platform users, this option is available from a different toolbar or menu. See Cross Platform (macOS and
Linux) Toolbars and Menus.

Study Toolbar

The Study ribbon toolbar (Windows) and the Study contextual toolbar (macOS and Linux) contains many of the

common features and actions required to work with studies and solvers.

For step-by-step instructions and general documentation descriptions, this is the Study toolbar.

TABLE 2-14: THE STUDY TOOLBAR

BUTTON  NAME OPTIONS DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION
OR
MENU
Study \)1
= ComputeI Compute the selected study. Computing a Solution
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TABLE 2-14: THE STUDY TOOLBAR

BUTTON NAME OPTIONS DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION

OR

MENU

o Select StudyI See a list of all available studies in Table 20-2. Study and Study Step Types

\ji Add StudyI Open the Add Study window to add a study to ~ The Add Study Window
the current model component.

| Continue Continue the computation of a solver sequence  The Progress Window
from the last computed feature.

€ Update Solution Update the solution using the current values of ~ Updating a Solution
parameters and user-defined variables.

=, Get Initial Value Generate a solution using the initial values of the ~ Computing the Initial Values
dependent variables (without solving for the
dependent variables).

Solver ™.

Fran Show Default Display the nodes in the solver sequences that Show Default Solver

Solver are created by default.

Study Step [—

= Study Steps

Parametric Sweep

Snw

=
[T

Fo0) Function Sweep
i Material Sweep
"~ Combine Solutions
o
ﬁ‘:"ﬁf Study Reference
[c} Optimization

Sensitivity

= Model Reduction

Batch & Cluster ElL:

Batch
;: Cluster

Operations [[5

E5 Create Solution
Copy

Evaluate =

See lists of all available study types and study
steps in Table 20-2 and Table 20-3.

Choose Parametric Sweep or Optimization, for
example.

Run a function sweep, switching between
different user-defined functions.

Run a material sweep, switching between
different materials.

Combine solutions using concatenation or
summation, or by removing solutions.

Add a study step that refers to another study.

Perform an optimization or parameter
estimation study. This is available with the
addition of the Optimization Module.

Add a Sensitivity study step.

Add a Model Reduction study step.

Add a Batch or Batch Sweep study node

Add a Cluster Computing or Cluster Sweep
study node

Make a copy of a solution.

The Add Study Window and
The Relationship Between
Study Steps and Solver
Configurations

Study Extension Steps and
Advanced Study Extension
Steps

Function Sweep
Material Sweep
Combine Solutions

Study Reference

See the Optimization Module
User’s Guide.

Sensitivity

Model Reduction

Batch and Batch Sweep

Cluster Computing and
Cluster Sweep

Solution Operation Nodes and
Solvers
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TABLE 2-14: THE STUDY TOOLBAR

BUTTON NAME OPTIONS DESCRIPTION OR OPTIONS LINKS TO MORE INFORMATION

OR

MENU

A Statistics Display statistics for the study, including the The Statistics Page
number of degrees of freedom (DOFs).

Clear

) Clear Solutions Clear the solutions in the current solver Clearing Sequences and
sequence. Deleting Sequences or Nodes

N Clear All Solutions  Clear all solutions.

External Interface *

E Cosimulation for
Simulink

Perform cosimulation with Simulink®. This is
available with the LiveLink for Simulink.

See the LiveLink for Simulink
User’s Guide.

! For cross-platform users, this option is available from a different toolbar or menu. See Cross Platform (macOS
and Linux) Toolbars and Menus.

Results Toolbar

The Results ribbon toolbar (Windows) and the Results contextual toolbar (macOS and Linux) contains many of the

common features and actions required to work with studies and solvers.

For step-by-step instructions and general documentation descriptions, this is the Results toolbar.

TABLE 2-15: THE RESULTS TOOLBAR

BUTTON OR
MENU

NAME

DESCRIPTION OR OPTIONS

LINKS TO MORE INFORMATION

Plot Group &

Plot
— Select Plot
Group
n 3D Plot Group
[ | 2D Plot Group
~ ID Plot Group
g Polar Plot Group

Definitions P;

P; Parameters

Dataset :

=

Cut Plane

Plot the selected pl