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Introduction

Loudspeaker drivers convert electric signals into sound. Due to the large frequency range 
of human hearing, loudspeaker systems usually have different drivers tuned to reproduce 
different frequency bands of the audible spectrum. At the low-frequency end, there are 
subwoofer and woofer drivers that work as almost omnidirectional sources and have large 
areas to create high sound-pressure levels. As the frequency increases, effects like cone 
breakup (the excitation of structural modes that make the membrane displace in and out 
of phase in some areas) limit the size of the speaker. The beaming effect reduces the area 
where high sound pressure levels are achieved, this occurs as the frequency increases and 
the wavelength becomes comparable to the size of the speaker. This is why tweeters —
drivers tuned for reproducing the high-frequency content of the hearing range — are 
usually small and light.

An ideal tweeter driver would have a flat sensitivity curve, meaning that the on-axis sound-
pressure level achieved, at a given distance from the driver, for a constant voltage input is 
constant as a function of frequency. The response should be similar, when the listening 
point is not exactly in front of the speaker. Both cone breakup and beaming are effects that 
are inherent to the loudspeaker driver design, but it is possible to tune a driver so that these 
two effects cancel out through the frequency range and create a speaker that is closer to 
an ideal speaker.

This model performs shape optimization of the dome (or speaker membrane) and the 
waveguide of the loudspeaker. By changing the shape of these two components, it is 
possible to create a tweeter that behaves closer to an ideal tweeter all through the range of 
frequencies of interest.

This tutorial model illustrates:

• How to obtain the sensitivity and directivity of a loudspeaker using a Thiele–Small 
equivalent for the electromagnetic circuit

• How to combine the frequency and spatial response to create a combined optimization 
objective

• How this objective can be used effectively to improve the design of the loudspeaker

• How the near acoustic field can be used to approximate the exterior acoustic field 
enabling the use of gradient-based optimization algorithms

• How changes in the shape of a boundary can indicate more radical changes in the design
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Model Definition

The model uses a Thiele–Small analogous circuit to include the electromagnetic 
characteristics of the driver. This approach is discussed in the tutorial Lumped 
Loudspeaker Driver available in the Acoustics Module Application Library. The 
suspension, voice coil, and dome are captured through the Solid Mechanics and Shell 
physics interfaces.

If the electromagnetic circuit of the tweeter is known, the two main elements that 
influence the radiation characteristics are the dome and the waveguide. The dome is the 
radiation element and creates sound as it moves back and forth. The waveguide helps to 
direct the sound to the front of the speaker. Figure 1 shows the main components of the 
tweeter.

Figure 1: Geometry of the initial tweeter design.

Throughout the range of frequencies that a tweeter reproduces, it is almost unavoidable 
to excite different dynamic effects, like resonances or dome flexible modes. These effects, 
if undamped, will create a large variation of sensitivity just above and below the frequency 
where it is found. To avoid this variation and have a more constant sensitivity throughout 
the frequency range, foam inserts are sometimes added under the dome to add damping. 
This model includes one such foam insert and also includes some other sources of 
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damping, like the losses in the narrow gaps around the voice coil and the structural 
damping of the dome and suspension.

The optimization objective is defined as the squared difference between the target and 
measured sound-pressure levels at four points in space. These points define the spatial 
extent where a uniform radiation is desired. The frequency at which the sum of these four 
squares is the largest, drives the optimization. This is a so-called min-max objective. A 
logarithmic function is applied to the objective function as the objective function is always 
positive. This improves convergence without introducing scaling of the objective.

In the model, the first study analyzes a traditional design to include as a reference. In the 
second study, a shape optimization problem is defined to obtain a tweeter that produces 
the same sound pressure level through the frequencies and angles of interest. The last 
study is an analysis of the optimized design through the complete frequency range and 
positions.

Results and Discussion

The on-axis sound pressure levels (SPL) or sensitivity for the initial and the optimized 
designs are shown in Figure 2. The target SPL is included as a dotted horizontal line. The 
plot also shows that there is a good agreement between the near acoustic field 
extrapolation (the values used in the optimization) and the actual exterior field evaluation. 
4 |  T W E E T E R  D O M E  A N D  W A V E G U I D E  S H A P E  O P T I M I Z A T I O N



Note how the initial design presents significant deviations from the target, while the 
optimized design produces a very flat response. 

Figure 2: On-axis sound pressure level at 1 meter.

The shape optimization improves the objective by changing the shape of the dome and 
waveguide. Figure 3 shows the displacement produced in the dome and waveguide during 
the optimization. Note how the segment of the former that connects the dome and the 
suspension follows the same profile as the dome, indicating that this segment could be 
removed to make the dome directly connect to the suspension and the former. Note, as 
well, how the effective radius of the waveguide has been reduced, as the flat part of the 
waveguide is reached at a smaller radius. This has the advantage of limiting the space 
requirement of the tweeter while maintaining the sound-pressure level produced.
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Figure 3: The optimization results (top) are shown together with the initial design (bottom).
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Figure 4 shows the sound-pressure level at the maximum frequency for the initial and the 
optimized design. The geometry of the dome, former, and suspension is shown as a 
deformed black line. The change in direction between the dome and the former facilitates 
a more prominent cone breakup in the initial design (left part of the image). 

Figure 4: Sound-pressure level produced at the highest frequency and structural deformation 
on the dome, former, and suspension for the initial design (left) and optimized design (right).

The directivity of the initial and the optimized design is shown in Figure 5. The on-axis 
sound pressure level is within 3 dB through the frequency range in the optimized design 
and this on-axis behavior is maintained for the angles of interest.

This tutorial presents a possible method to optimize the performance of a tweeter speaker. 
Different design variables, constraints, frequencies of interest, or spatial distributions are 
also possible and can be modified. With the prominence of additive manufacturing the 
novel waveguides can, for example, be 3D printed. By using composite materials it is also 
possible to create the new shapes for the dome.
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Figure 5: Directivity plot of the initial design (left) and optimized design (right). The colos 
show the deviation from the target sound pressure level. Black lines mark the ±3 dB and ±6 dB 
limits. The gray box marks the frequencies and locations used during the optimization.

Notes About the COMSOL Implementation

U S I N G  N E A R  A C O U S T I C  F I E L D  T O  O B T A I N  T H E  E X T E R I O R  F I E L D

In order to use gradient-based optimization algorithms like MMA, the computation 
domain is artificially large to be able to use the near acoustic field to obtain the exterior 
field (the response at 1 m). This approach has to be compared to the results using the 
Exterior Field Calculation feature to check the validity of the assumption. In this case, the 
deviation is small so the approach is deemed as acceptable.

U S I N G  L O G A R I T H M I C  F U N C T I O N  T O  T R A N S F O R M  T H E  O B J E C T I V E  F U N C T I O N

In cases where the objective function is always positive, it is possible to transform it using 
a logarithmic function to overcome the need of an objective function scaling. 

U S I N G  D O M A I N  P R O B E S  T O  C O M P U T E  T H E  O P T I M I Z A T I O N  O B J E C T I V E S

The objective of the optimization is based on a series of domain probes at the listening 
points (measurement points). The near acoustic field response is computed through these 
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domain probes and extrapolated to the sensitivity distance of 1 m. These values are used 
in the optimization objective.

O P T I M I Z I N G  F O R  A  R E D U C E D  N U M B E R  O F  F R E Q U E N C I E S

The optimization study uses a smaller number of frequencies relative to the verification 
study. This is done to limit the computational time, but with COMSOL launched in 
cluster mode supports computation of the individual frequencies in parallel. With the 
appropriate hardware it is thus possible to include significantly more frequencies for the 
optimization without increasing the computational time.

Application Library path: Optimization_Module/Shape_Optimization/
tweeter_shape_optimization

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Acoustics>Acoustic-Structure Interaction>Acoustic-

Shell Interaction, Frequency Domain.

3 Click Add.

4 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

5 Click Add.

6 In the Select Physics tree, select AC/DC>Electrical Circuit (cir).

7 Click Add.

8 Click Study.

9 In the Select Study tree, select General Studies>Frequency Domain.

10 Click Done.

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.
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2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

4 In the Geometry toolbar, click Insert Sequence.

5 Browse to the model’s Application Libraries folder and double-click the file 
tweeter_shape_optimization_geom_sequence.mph.

6 In the Geometry toolbar, click Build All.

G L O B A L  D E F I N I T I O N S

Geometry Parameters
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, type Geometry Parameters in the Label text 
field.

Model Parameters
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Model Parameters in the Label text field.

3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
tweeter_shape_optimization_model_parameters.txt.

Thiele Small Parameters
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Thiele Small Parameters in the Label 
text field.

3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
tweeter_shape_optimization_thiele_small_parameters.txt.

D E F I N I T I O N S

Variables 1
1 In the Model Builder window, under Component 1 (comp1) right-click Definitions and 

choose Variables.

2 In the Settings window for Variables, locate the Variables section.
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3 In the table, enter the following settings:

Domain Probe 1 (dom1)
1 In the Definitions toolbar, click Probes and choose Domain Probe.

2 In the Settings window for Domain Probe, locate the Source Selection section.

3 From the Selection list, choose Voice Coil.

4 In the Variable name text field, type v0.

5 Locate the Expression section. In the Expression text field, type solid.u_tZ.

Domain Point Probe 1
1 In the Definitions toolbar, click Probes and choose Domain Point Probe.

2 Select Domain 4 only.

3 In the Settings window for Domain Point Probe, locate the Point Selection section.

4 In row Coordinates, set z to r_eval.

Point Probe Expression 1 (ppb1)
1 In the Model Builder window, expand the Domain Point Probe 1 node, then click 

Point Probe Expression 1 (ppb1).

2 In the Settings window for Point Probe Expression, type mic1 in the Variable name text 
field.

3 Locate the Expression section. In the Expression text field, type acpr.Lp_t+10*
log10((r_eval/1[m])^2).

4 Select the Description check box.

5 In the associated text field, type Microphone 1 SPL.

Name Expression Unit Description

L_E (L_e/(sin(n_e*pi/2)))*
(acpr.omega[s/
rad])^(n_e-1)

H Voice coil inductance 
(frequency dependent)

Rp_E (L_e/(cos(n_e*pi/2)))*
(acpr.omega[s/
rad])^(n_e)[ohm/H]

Ω Resistance (losses in 
magnetic system)

obj_1 (mic1-target_spl)^2+
(mic2-target_spl)^2+
(mic3-target_spl)^2+
(mic4-target_spl)^2

Optimization objective
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Domain Point Probe 2
1 In the Model Builder window, under Component 1 (comp1)>Definitions right-click 

Domain Point Probe 1 and choose Duplicate.

2 In the Settings window for Domain Point Probe, locate the Point Selection section.

3 In row Coordinates, set r to r_eval*sin(angle_eval/2/4).

4 In row Coordinates, set z to r_eval*cos(angle_eval/2/4).

Point Probe Expression 1 (ppb2)
1 In the Model Builder window, expand the Domain Point Probe 2 node, then click 

Point Probe Expression 1 (ppb2).

2 In the Settings window for Point Probe Expression, type mic2 in the Variable name text 
field.

3 Locate the Expression section. In the Description text field, type Microphone 2 SPL.

Domain Point Probe 3
1 In the Model Builder window, under Component 1 (comp1)>Definitions right-click 

Domain Point Probe 1 and choose Duplicate.

2 In the Settings window for Domain Point Probe, locate the Point Selection section.

3 In row Coordinates, set r to r_eval*sin(angle_eval/2/4*3).

4 In row Coordinates, set z to r_eval*cos(angle_eval/2/4*3).

Point Probe Expression 1 (ppb3)
1 In the Model Builder window, expand the Domain Point Probe 3 node, then click 

Point Probe Expression 1 (ppb3).

2 In the Settings window for Point Probe Expression, type mic3 in the Variable name text 
field.

3 Locate the Expression section. In the Description text field, type Microphone 3 SPL.

Domain Point Probe 4
1 In the Model Builder window, under Component 1 (comp1)>Definitions right-click 

Domain Point Probe 1 and choose Duplicate.

2 In the Settings window for Domain Point Probe, locate the Point Selection section.

3 In row Coordinates, set r to r_eval*sin(angle_eval/2/4*4).

4 In row Coordinates, set z to r_eval*cos(angle_eval/2/4*4).

Point Probe Expression 1 (ppb4)
1 In the Model Builder window, expand the Domain Point Probe 4 node, then click 

Point Probe Expression 1 (ppb4).
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2 In the Settings window for Point Probe Expression, type mic4 in the Variable name text 
field.

3 Locate the Expression section. In the Description text field, type Microphone 4 SPL.

Free Shape Domain 1
1 In the Definitions toolbar, click Optimization and choose Free Shape Domain.

2 In the Settings window for Free Shape Domain, locate the Domain Selection section.

3 Click Clear Selection.

4 Select Domains 2 and 3 only.

Free Shape Boundary 1
1 In the Definitions toolbar, click Optimization and choose Free Shape Boundary.

2 In the Settings window for Free Shape Boundary, locate the Boundary Selection section.

3 From the Selection list, choose Dome.

4 Locate the Control Variable Settings section. In the dmax text field, type disp_dome.

5 Locate the Filtering section. In the Rmin text field, type 1.5*disp_dome.

Free Shape Boundary 2
1 In the Definitions toolbar, click Optimization and choose Free Shape Boundary.

2 In the Settings window for Free Shape Boundary, locate the Boundary Selection section.

3 From the Selection list, choose Waveguide.

4 Locate the Control Variable Settings section. In the dmax text field, type disp_wave.

5 Locate the Filtering section. In the Rmin text field, type 1.5*disp_wave.

Symmetry/Roller 1
1 In the Definitions toolbar, click Optimization and choose Symmetry/Roller.

2 In the Settings window for Symmetry/Roller, locate the Boundary Selection section.

3 From the Selection list, choose Symmetry/Roller Boundaries.

Perfectly Matched Layer 1 (pml1)
1 In the Definitions toolbar, click Perfectly Matched Layer.

2 In the Settings window for Perfectly Matched Layer, locate the Domain Selection section.

3 From the Selection list, choose PML Domains.

4 Locate the Geometry section. From the Type list, choose Cylindrical.

5 Locate the Scaling section. From the Coordinate stretching type list, choose Rational.

6 Right-click Perfectly Matched Layer 1 (pml1) and choose Materials>Browse Materials.
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M A T E R I A L  B R O W S E R

1 In the Material Browser window, click Import Material Library.

2 From the Application Libraries root, browse to the folder Acoustics_Module/
Electroacoustic_Transducers and double-click the file 
loudspeaker_driver_materials.mph.

3 Click Done.

M A T E R I A L S

In the Home toolbar, click Windows and choose Add Material from Library.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-in>Air.

3 Click Add to Component in the window toolbar.

4 In the tree, select loudspeaker driver materials>Composite.

5 Click Add to Component in the window toolbar.

6 In the tree, select loudspeaker driver materials>Cloth.

7 Click Add to Component in the window toolbar.

8 In the tree, select loudspeaker driver materials>Coil.

9 Click Add to Component in the window toolbar.

10 In the tree, select loudspeaker driver materials>Glass Fiber.

11 Click Add to Component in the window toolbar.

12 In the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Glass Fiber (mat5)
1 In the Settings window for Material, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 From the Selection list, choose Former.

Air (mat1)
1 In the Model Builder window, click Air (mat1).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Air Domains.
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Composite (mat2)
1 In the Model Builder window, click Composite (mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Dome.

Cloth (mat3)
1 In the Model Builder window, click Cloth (mat3).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Suspension.

Coil (mat4)
1 In the Model Builder window, click Coil (mat4).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Voice Coil.

P R E S S U R E  A C O U S T I C S ,  F R E Q U E N C Y  D O M A I N  ( A C P R )

1 In the Model Builder window, under Component 1 (comp1) click Pressure Acoustics,

Frequency Domain (acpr).

2 In the Settings window for Pressure Acoustics, Frequency Domain, locate the 
Domain Selection section.

3 From the Selection list, choose Air Domains.

Narrow Region Acoustics 1
1 In the Physics toolbar, click Domains and choose Narrow Region Acoustics.

2 In the Settings window for Narrow Region Acoustics, locate the Domain Selection section.

3 From the Selection list, choose Narrow Regions.

4 Locate the Duct Properties section. From the Duct type list, choose Slit.

5 In the h text field, type air_gap.

Poroacoustics 1
1 In the Physics toolbar, click Domains and choose Poroacoustics.

2 In the Settings window for Poroacoustics, locate the Domain Selection section.

3 From the Selection list, choose Porous Domain.
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4 Locate the Porous Matrix Properties section. From the Rf list, choose User defined. In the 
associated text field, type rf_pa.

5 From the Constants list, choose Miki.

Exterior Field Calculation 1
1 In the Physics toolbar, click Boundaries and choose Exterior Field Calculation.

2 In the Settings window for Exterior Field Calculation, locate the Boundary Selection 
section.

3 From the Selection list, choose Exterior Field.

4 Locate the Exterior Field Calculation section. From the Condition in the z = z^0 plane list, 
choose Symmetric/Infinite sound hard boundary.

S H E L L  ( S H E L L )

1 In the Model Builder window, under Component 1 (comp1) click Shell (shell).

2 In the Settings window for Shell, locate the Boundary Selection section.

3 From the Selection list, choose Shell Boundaries.

Linear Elastic Material 1
In the Model Builder window, under Component 1 (comp1)>Shell (shell) click 
Linear Elastic Material 1.

Damping 1
1 In the Physics toolbar, click Attributes and choose Damping.

2 In the Settings window for Damping, locate the Damping Settings section.

3 From the Damping type list, choose Isotropic loss factor.

Linear Elastic Material 1
In the Model Builder window, click Linear Elastic Material 1.

Damping 2
1 In the Physics toolbar, click Attributes and choose Damping.

2 In the Settings window for Damping, locate the Boundary Selection section.

3 From the Selection list, choose Suspension.

4 Locate the Damping Settings section. From the Input parameters list, choose 
Damping ratios.

5 In the f1 text field, type fmin.

6 In the ζ1 text field, type damp_susp.
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7 In the f2 text field, type fmax.

8 In the ζ2 text field, type damp_susp.

Thickness and Offset 1
1 In the Model Builder window, click Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type th_dome.

Thickness and Offset 2
1 In the Physics toolbar, click Boundaries and choose Thickness and Offset.

2 In the Settings window for Thickness and Offset, locate the Boundary Selection section.

3 From the Selection list, choose Former.

4 Locate the Thickness and Offset section. In the d text field, type th_former.

Thickness and Offset 3
1 In the Physics toolbar, click Boundaries and choose Thickness and Offset.

2 In the Settings window for Thickness and Offset, locate the Boundary Selection section.

3 From the Selection list, choose Suspension.

4 Locate the Thickness and Offset section. In the d text field, type th_susp.

Fixed Constraint 1
1 In the Physics toolbar, click Points and choose Fixed Constraint.

2 In the Settings window for Fixed Constraint, locate the Point Selection section.

3 From the Selection list, choose Fixed Points.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Domain Selection section.

3 From the Selection list, choose Voice Coil.

Body Load 1
1 In the Physics toolbar, click Domains and choose Body Load.

2 In the Settings window for Body Load, locate the Domain Selection section.

3 From the Selection list, choose Voice Coil.

4 Locate the Force section. From the Load type list, choose Total force.
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5 Specify the Ftot vector as

E L E C T R I C A L  C I R C U I T  ( C I R )

In the Model Builder window, under Component 1 (comp1) click Electrical Circuit (cir).

Voltage Source 1 (V1)
1 In the Electrical Circuit toolbar, click Voltage Source.

2 In the Settings window for Voltage Source, locate the Node Connections section.

3 In the table, enter the following settings:

4 Locate the Device Parameters section. In the vsrc text field, type V0.

Resistor 1 (R1)
1 In the Electrical Circuit toolbar, click Resistor.

2 In the Settings window for Resistor, locate the Node Connections section.

3 In the table, enter the following settings:

4 Locate the Device Parameters section. In the R text field, type R_g.

Resistor 2 (R2)
1 In the Electrical Circuit toolbar, click Resistor.

2 In the Settings window for Resistor, locate the Node Connections section.

3 In the table, enter the following settings:

0 r

BL*cir.R1_i z

Label Node names

p 1

n 0

Label Node names

p 1

n 2

Label Node names

p 2

n 3
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4 Locate the Device Parameters section. In the R text field, type R_E.

Inductor 1 (L1)
1 In the Electrical Circuit toolbar, click Inductor.

2 In the Settings window for Inductor, locate the Node Connections section.

3 In the table, enter the following settings:

4 Locate the Device Parameters section. In the L text field, type L_E.

Resistor 3 (R3)
1 In the Electrical Circuit toolbar, click Resistor.

2 In the Settings window for Resistor, locate the Node Connections section.

3 In the table, enter the following settings:

4 Locate the Device Parameters section. In the R text field, type Rp_E.

Voltage Source 2 (V2)
1 In the Electrical Circuit toolbar, click Voltage Source.

2 In the Settings window for Voltage Source, locate the Node Connections section.

3 In the table, enter the following settings:

4 Locate the Device Parameters section. In the vsrc text field, type BL*v0.

M U L T I P H Y S I C S

Acoustic-Structure Boundary 2 (asb2)
1 In the Model Builder window, under Component 1 (comp1) right-click Multiphysics and 

choose Acoustic-Structure Boundary.

Label Node names

p 3

n 4

Label Node names

p 3

n 4

Label Node names

p 4

n 0
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2 In the Settings window for Acoustic-Structure Boundary, locate the Boundary Selection 
section.

3 From the Selection list, choose All boundaries.

4 Locate the Coupled Interfaces section. From the Structure list, choose 
Solid Mechanics (solid).

Solid-Thin Structure Connection 1 (sshc1)
1 In the Model Builder window, right-click Multiphysics and choose Solid-

Thin Structure Connection.

2 In the Settings window for Solid-Thin Structure Connection, locate the Connection Settings 
section.

3 From the Connection type list, choose Shared boundaries.

M E S H  1

Free Quad 1
1 In the Mesh toolbar, click Free Quad.

2 In the Settings window for Free Quad, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domains 1, 4, 7, 8, and 11 only.

Size 1
1 Right-click Free Quad 1 and choose Size.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Selection list, choose Narrow Regions.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type air_gap.

Size
1 In the Model Builder window, click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Maximum element size text field, type 
lam0/5.

5 In the Minimum element size text field, type r1_susp.
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6 Click Build All.

Free Triangular 1
1 In the Mesh toolbar, click Free Triangular.

2 In the Settings window for Free Triangular, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domains 2, 3, 6, 9, and 10 only.

Size 1
1 Right-click Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Dome.

5 Locate the Element Size section. Click the Custom button.

6 Locate the Element Size Parameters section. Select the Maximum element size check box.

7 In the associated text field, type mesh_optim.

Size 2
1 Right-click Size 1 and choose Duplicate.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Selection list, choose Waveguide.

Mapped 1
1 In the Mesh toolbar, click Mapped.

2 In the Settings window for Mapped, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose PML Domains.

Distribution 1
1 Right-click Mapped 1 and choose Distribution.

2 Select Boundaries 41 and 42 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 6.

5 Click Build All.

Boundary Layers 1
1 In the Mesh toolbar, click Boundary Layers.
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2 In the Settings window for Boundary Layers, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domains 3 and 4 only.

5 Click to expand the Transition section. Clear the Smooth transition to interior mesh 
check box.

Boundary Layer Properties
1 In the Model Builder window, click Boundary Layer Properties.

2 In the Settings window for Boundary Layer Properties, locate the Boundary Selection 
section.

3 From the Selection list, choose Exterior Field.

4 Locate the Boundary Layer Properties section. In the Number of boundary layers text 
field, type 1.

5 Click Build All.

S T U D Y  1  -  I N I T I A L  D E S I G N

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Study 1 - Initial Design in the Label text 
field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

Step 1: Frequency Domain
1 In the Model Builder window, under Study 1 - Initial Design click 

Step 1: Frequency Domain.

2 In the Settings window for Frequency Domain, locate the Study Settings section.

3 In the Frequencies text field, type range(fmin,(fmax-fmin)/(nf-1),fmax).

4 Click to expand the Results While Solving section. From the Probes list, choose None.

5 Locate the Physics and Variables Selection section. In the table, clear the Solve for check 
box for Deformed geometry (Component 1).

6 In the Home toolbar, click Compute.

R E S U L T S

In the Model Builder window, expand the Results node.

Study 1 - Initial Design/Solution 1 (sol1)
In the Model Builder window, expand the Results>Datasets node, then click Study 1 -

Initial Design/Solution 1 (sol1).
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Selection
1 In the Results toolbar, click Attributes and choose Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Visualization Domains.

Study 1 - Initial Design/Revolution
1 Right-click Study 1 - Initial Design/Solution 1 (sol1) and choose Duplicate.

2 In the Model Builder window, click Study 1 - Initial Design/Solution 1 (2) (sol1).

3 In the Settings window for Solution, type Study 1 - Initial Design/Revolution in 
the Label text field.

Selection
1 In the Model Builder window, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Revolution Boundaries.

Revolution 2D - Initial Design
1 In the Results toolbar, click More Datasets and choose Revolution 2D.

2 In the Settings window for Revolution 2D, type Revolution 2D - Initial Design in 
the Label text field.

3 Locate the Data section. From the Dataset list, choose Study 1 - Initial Design/

Revolution (sol1).

4 Click to expand the Revolution Layers section. In the Start angle text field, type 90.

5 In the Revolution angle text field, type 90.

6 Click to expand the Advanced section. Select the Define variables check box.

Mirror 2D 1
1 In the Results toolbar, click More Datasets and choose Mirror 2D.

2 In the Settings window for Mirror 2D, click to expand the Advanced section.

3 Select the Define variables check box.

On-axis Sound Pressure Level at 1 m
1 In the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type On-axis Sound Pressure Level at 
1 m in the Label text field.
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3 Click to expand the Title section. From the Title type list, choose Label.

4 Locate the Plot Settings section. Select the x-axis label check box.

5 In the associated text field, type freq (Hz).

6 Select the y-axis label check box.

7 In the associated text field, type SPL (dB).

8 Locate the Legend section. From the Position list, choose Lower middle.

Global 1
1 Right-click On-axis Sound Pressure Level at 1 m and choose Global.

2 In the Settings window for Global, locate the y-Axis Data section.

3 In the table, enter the following settings:

4 In the On-axis Sound Pressure Level at 1 m toolbar, click Plot.

On-axis Sound Pressure Level at 1 m
In the Model Builder window, click On-axis Sound Pressure Level at 1 m.

Octave Band 1
1 In the On-axis Sound Pressure Level at 1 m toolbar, click More Plots and choose 

Octave Band.

2 In the Settings window for Octave Band, locate the Selection section.

3 From the Geometric entity level list, choose Global.

4 Locate the y-Axis Data section. In the Expression text field, type pext(0,1[m]).

5 Select the Description check box.

6 In the associated text field, type SPL at 1 m (Exterior field) - Initial Design.

7 Locate the Plot section. From the Style list, choose Continuous.

8 Click to expand the Legends section. Select the Show legends check box.

9 In the On-axis Sound Pressure Level at 1 m toolbar, click Plot.

Global 2
1 Right-click On-axis Sound Pressure Level at 1 m and choose Global.

2 In the Settings window for Global, locate the y-Axis Data section.

Expression Unit Description

mic1 dB SPL at 1 m (Near Field) - Initial Design
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3 In the table, enter the following settings:

4 Click to expand the Coloring and Style section. Find the Line style subsection. From the 
Line list, choose Dotted.

5 From the Color list, choose Black.

6 Click to expand the Legends section. Clear the Show legends check box.

7 In the On-axis Sound Pressure Level at 1 m toolbar, click Plot.

Directivity
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Directivity in the Label text field.

3 Locate the Title section. From the Title type list, choose Label.

Directivity 1
1 In the Directivity toolbar, click More Plots and choose Directivity.

2 In the Settings window for Directivity, locate the Expression section.

3 From the Normalization list, choose None.

4 In the Expression text field, type acpr.efc1.Lp_pext-target_spl.

5 Locate the Evaluation section. Find the Angles subsection. From the Restriction list, 
choose Manual.

6 In the φ start text field, type -90.

7 In the φ range text field, type 90.

8 Find the Evaluation distance subsection. In the Radius text field, type 1000.

9 Locate the Levels section. From the Entry method list, choose Levels.

10 In the Levels text field, type -42 -30 -24 -18 -12 -6 -3 3 6 9.

11 Click to expand the Coloring and Style section. From the Layout list, choose 
Frequency on y-axis.

12 Clear the Color legend check box.

13 In the Directivity toolbar, click Plot.

Directivity 2
1 Right-click Directivity 1 and choose Duplicate.

2 In the Settings window for Directivity, locate the Levels section.

Expression Unit Description

target_spl dB
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3 In the Levels text field, type -6 -3 3 6.

4 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

5 From the Color list, choose Black.

6 From the Contour type list, choose Line.

7 Set the Width value to 2.

8 In the Directivity toolbar, click Plot.

Sound Pressure Level
1 In the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Sound Pressure Level in the Label text 
field.

3 Locate the Data section. From the Dataset list, choose Mirror 2D 1.

4 Click to expand the Title section. From the Title type list, choose Label.

5 Locate the Plot Settings section. Clear the Plot dataset edges check box.

Surface 1
1 Right-click Sound Pressure Level and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type acpr.Lp_t.

Filter 1
1 Right-click Surface 1 and choose Filter.

2 In the Settings window for Filter, locate the Element Selection section.

3 In the Logical expression for inclusion text field, type mir1x<0.

4 In the Sound Pressure Level toolbar, click Plot.

Line 1
1 In the Model Builder window, right-click Sound Pressure Level and choose Line.

2 In the Settings window for Line, locate the Expression section.

3 In the Expression text field, type 0.

4 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

5 From the Color list, choose Gray.

Filter 1
1 Right-click Line 1 and choose Filter.

2 In the Settings window for Filter, locate the Element Selection section.
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3 In the Logical expression for inclusion text field, type mir1x<0.

4 In the Sound Pressure Level toolbar, click Plot.

Line 2
1 In the Model Builder window, under Results>Sound Pressure Level right-click Line 1 and 

choose Duplicate.

2 In the Settings window for Line, locate the Coloring and Style section.

3 From the Line type list, choose Tube.

4 From the Color list, choose Black.

Deformation 1
1 Right-click Line 2 and choose Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 Select the Scale factor check box.

4 In the associated text field, type 10000.

5 In the Sound Pressure Level toolbar, click Plot.

Geometry
1 In the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Geometry in the Label text field.

3 Click to expand the Title section. From the Title type list, choose Label.

Surface 1
1 Right-click Geometry and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type 0.

4 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

5 From the Color list, choose Gray.

Filter 1
1 Right-click Surface 1 and choose Filter.

2 In the Settings window for Filter, locate the Element Selection section.

3 In the Logical expression for inclusion text field, type (rev1y>0)*(rev1x<0).

4 In the Geometry toolbar, click Plot.

R O O T

In the Home toolbar, click Windows and choose Add Study.
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A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies>

Frequency Domain.

3 Click Add Study in the window toolbar.

4 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2  -  O P T I M I Z A T I O N  

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study 2 - Optimization  in the Label text field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

Shape Optimization
1 In the Study toolbar, click Optimization and choose Shape Optimization.

2 In the Settings window for Shape Optimization, locate the Optimization Solver section.

3 In the Maximum number of iterations text field, type 20.

4 Locate the Objective Function section. From the Solution list, choose 
Maximum of objectives.

5 In the table, enter the following settings:

6 Locate the Output While Solving section. From the Probes list, choose None.

Step 1: Frequency Domain
1 In the Model Builder window, click Step 1: Frequency Domain.

2 In the Settings window for Frequency Domain, locate the Study Settings section.

3 In the Frequencies text field, type range(fmin_optim,(fmax_optim-fmin_optim)/
(nf_optim-1),fmax_optim).

4 In the Study toolbar, click Get Initial Value.

R E S U L T S

Study 2 - Optimization /Solution 2 (sol2)
In the Model Builder window, under Results>Datasets click Study 2 - Optimization /

Solution 2 (sol2).

Expression Description

log10(comp1.obj_1)
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Selection
1 In the Results toolbar, click Attributes and choose Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Visualization Domains.

Shape Optimization
1 In the Results toolbar, click 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Shape Optimization in the Label text 
field.

3 Locate the Data section. From the Dataset list, choose Study 2 - Optimization /

Solution 2 (sol2).

4 In the Shape Optimization toolbar, click Plot.

5 Click the Zoom Extents button in the Graphics toolbar.

6 Locate the Title section. From the Title type list, choose Label.

7 Locate the Plot Settings section. From the Color list, choose Gray.

8 From the Frame list, choose Geometry (Rg, PHIg, Zg).

Line 1
1 Right-click Shape Optimization and choose Line.

2 In the Settings window for Line, locate the Expression section.

3 In the Expression text field, type 1.

4 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

5 From the Color list, choose Black.

Arrow Line 1
1 In the Model Builder window, right-click Shape Optimization and choose Arrow Line.

2 In the Settings window for Arrow Line, locate the Expression section.

3 In the R component text field, type fsd1.dRg.

4 In the Z component text field, type fsd1.dZg.

5 Locate the Arrow Positioning section. From the Placement list, choose Mesh nodes.

6 Locate the Coloring and Style section. Select the Scale factor check box.

7 From the Arrow base list, choose Head.

Color Expression 1
1 Right-click Arrow Line 1 and choose Color Expression.
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2 In the Settings window for Color Expression, locate the Expression section.

3 In the Expression text field, type fsd1.rel_disp.

4 Click to expand the Range section. Select the Manual color range check box.

5 In the Maximum text field, type 1.

6 In the Shape Optimization toolbar, click Plot.

S T U D Y  2  -  O P T I M I Z A T I O N

Shape Optimization
1 In the Model Builder window, under Study 2 - Optimization click Shape Optimization.

2 In the Settings window for Shape Optimization, locate the Output While Solving section.

3 Select the Plot check box.

4 From the Plot group list, choose Shape Optimization.

5 In the Home toolbar, click Compute.

R O O T

Click Windows and choose Add Study.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies>

Frequency Domain.

3 Click Add Study in the window toolbar.

4 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  3

Step 1: Frequency Domain
1 In the Settings window for Frequency Domain, locate the Study Settings section.

2 In the Frequencies text field, type range(fmin,(fmax-fmin)/(nf-1),fmax).

3 Locate the Physics and Variables Selection section. In the table, clear the Solve for check 
box for Deformed geometry (Component 1).

4 Click to expand the Values of Dependent Variables section. Find the 
Initial values of variables solved for subsection. From the Settings list, choose 
User controlled.

5 From the Method list, choose Solution.
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6 From the Study list, choose Study 2 - Optimization , Frequency Domain.

7 Find the Values of variables not solved for subsection. From the Settings list, choose 
User controlled.

8 From the Method list, choose Solution.

9 From the Study list, choose Study 2 - Optimization , Frequency Domain.

10 Locate the Results While Solving section. From the Probes list, choose None.

11 In the Model Builder window, click Study 3.

12 In the Settings window for Study, locate the Study Settings section.

13 Clear the Generate default plots check box.

14 In the Label text field, type Study 3 - Optimized Design.

15 In the Home toolbar, click Compute.

R E S U L T S

Probe Solution 4 (sol3)
In the Model Builder window, under Results>Datasets right-click Probe Solution 4 (sol3) and 
choose Delete.

Study 3 - Optimized Design/Solution 3 (sol3)
In the Model Builder window, click Study 3 - Optimized Design/Solution 3 (sol3).

Selection
1 In the Results toolbar, click Attributes and choose Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Visualization Domains.

Study 3 - Optimized Design/Revolution
1 Right-click Study 3 - Optimized Design/Solution 3 (sol3) and choose Duplicate.

2 In the Settings window for Solution, type Study 3 - Optimized Design/Revolution 
in the Label text field.

Selection
1 In the Model Builder window, expand the Results>Datasets>Study 3 - Optimized Design/

Revolution (sol3) node, then click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.
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4 From the Selection list, choose Revolution Boundaries.

Revolution 2D - Optimized Design
1 In the Results toolbar, click More Datasets and choose Revolution 2D.

2 In the Settings window for Revolution 2D, type Revolution 2D - Optimized Design 
in the Label text field.

3 Locate the Data section. From the Dataset list, choose Study 3 - Optimized Design/

Revolution (sol3).

4 Locate the Revolution Layers section. In the Revolution angle text field, type 90.

5 Locate the Advanced section. Select the Define variables check box.

Global 3
1 In the Model Builder window, under Results>On-axis Sound Pressure Level at 1 m right-

click Global 1 and choose Duplicate.

2 In the Settings window for Global, locate the Data section.

3 From the Dataset list, choose Study 3 - Optimized Design/Solution 3 (sol3).

4 Locate the y-Axis Data section. In the table, enter the following settings:

5 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Dashed.

6 From the Color list, choose Cycle (reset).

Octave Band 2
1 In the Model Builder window, under Results>On-axis Sound Pressure Level at 1 m right-

click Octave Band 1 and choose Duplicate.

2 In the Settings window for Octave Band, locate the Data section.

3 From the Dataset list, choose Study 3 - Optimized Design/Solution 3 (sol3).

4 Locate the y-Axis Data section. In the Description text field, type SPL at 1 m (Exterior 
field) - Optimized.

5 Click to expand the Coloring and Style section. Find the Line style subsection. From the 
Line list, choose Dashed.

Directivity 3
1 In the Model Builder window, under Results>Directivity right-click Directivity 1 and 

choose Duplicate.

Expression Unit Description

mic1 dB SPL at 1 m (Near Field) - Optimized
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2 In the Settings window for Directivity, locate the Data section.

3 From the Dataset list, choose Study 3 - Optimized Design/Solution 3 (sol3).

4 Locate the Evaluation section. Find the Angles subsection. In the φ start text field, type 0.

5 Locate the Coloring and Style section. Select the Color legend check box.

Directivity 4
1 In the Model Builder window, under Results>Directivity right-click Directivity 2 and 

choose Duplicate.

2 In the Settings window for Directivity, locate the Data section.

3 From the Dataset list, choose Study 3 - Optimized Design/Solution 3 (sol3).

4 Locate the Evaluation section. Find the Angles subsection. In the φ start text field, type 0.

5 In the Directivity toolbar, click Plot.

Line Segments 1
1 In the Model Builder window, right-click Directivity and choose Line Segments.

2 In the Settings window for Line Segments, locate the x-Coordinates section.

3 In the table, enter the following settings:

4 Locate the y-Coordinates section. In the table, enter the following settings:

5 Click to expand the Coloring and Style section. Find the Line style subsection. From the 
Line list, choose Dashed.

6 From the Color list, choose Gray.

Expression Unit Description

-angle_eval/2 deg

angle_eval/2 deg

angle_eval/2 deg

-angle_eval/2 deg

-angle_eval/2 deg

Expression Unit Description

fmin_optim Hz Minimum frequency optimized for

fmin_optim Hz Minimum frequency optimized for

fmax_optim Hz Maximum frequency optimized for

fmax_optim Hz Maximum frequency optimized for

fmin_optim Hz Minimum frequency optimized for
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7 Set the Width value to 2.

8 In the Directivity toolbar, click Plot.

Line Segments 2
1 Right-click Directivity and choose Line Segments.

2 In the Settings window for Line Segments, locate the x-Coordinates section.

3 In the table, enter the following settings:

4 Locate the y-Coordinates section. In the table, enter the following settings:

5 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Dash-dot.

6 From the Color list, choose Black.

7 Set the Width value to 2.

8 In the Directivity toolbar, click Plot.

Surface 2
1 In the Model Builder window, right-click Sound Pressure Level and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Study 3 - Optimized Design/Solution 3 (sol3).

4 Locate the Expression section. In the Expression text field, type acpr.Lp_t.

5 Click to expand the Inherit Style section. From the Plot list, choose Surface 1.

6 In the Sound Pressure Level toolbar, click Plot.

7 Click the Zoom Extents button in the Graphics toolbar.

Line 3
1 Right-click Sound Pressure Level and choose Line.

2 In the Settings window for Line, locate the Data section.

3 From the Dataset list, choose Study 3 - Optimized Design/Solution 3 (sol3).

Expression Unit Description

0 1

0 1

Expression Unit Description

fmin Hz Minimum frequency analyzed

fmax Hz Maximum frequency analyzed
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4 Locate the Expression section. In the Expression text field, type 0.

5 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

6 From the Color list, choose Gray.

Line 4
1 Right-click Sound Pressure Level and choose Line.

2 In the Settings window for Line, locate the Data section.

3 From the Dataset list, choose Study 3 - Optimized Design/Solution 3 (sol3).

4 Locate the Expression section. In the Expression text field, type 0.

5 Locate the Coloring and Style section. From the Line type list, choose Tube.

6 Click to expand the Inherit Style section. From the Plot list, choose Line 2.

Deformation 1
Right-click Line 4 and choose Deformation.

Surface 2
1 In the Model Builder window, right-click Geometry and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Revolution 2D - Optimized Design.

4 Locate the Expression section. In the Expression text field, type 0.

5 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

6 From the Color list, choose Custom.

7 On Windows, click the colored bar underneath, or — if you are running the cross-
platform desktop — the Color button.

8 Click Define custom colors.

9 Set the RGB values to 105, 105, and 105, respectively.

10 Click Add to custom colors.

11 Click Show color palette only or OK on the cross-platform desktop.

Filter 1
1 Right-click Surface 2 and choose Filter.

2 In the Settings window for Filter, locate the Element Selection section.

3 In the Logical expression for inclusion text field, type (rev2y>0)*(rev2x>0).

4 In the Geometry toolbar, click Plot.
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Line 1
1 In the Model Builder window, right-click Geometry and choose Line.

2 In the Settings window for Line, locate the Data section.

3 From the Dataset list, choose Revolution 2D - Optimized Design.

4 Locate the Expression section. In the Expression text field, type 0.

5 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

6 From the Color list, choose Black.

7 In the Geometry toolbar, click Plot.

8 Click the Zoom Extents button in the Graphics toolbar.

Contour 1
1 Right-click Geometry and choose Contour.

2 In the Settings window for Contour, locate the Data section.

3 From the Dataset list, choose Revolution 2D - Optimized Design.

4 Locate the Expression section. In the Expression text field, type fsd1.rel_disp.

5 Locate the Coloring and Style section. From the Color table list, choose HeatCamera.

6 Clear the Color legend check box.

7 In the Geometry toolbar, click Plot.

Geometry Modeling Instructions

If you want to create the geometry yourself, follow these steps.

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.
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3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
tweeter_shape_optimization_geometry_parameters.txt.

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Rectangle 1 (r1)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type r_model+th_pml.

4 In the Height text field, type h_model+th_pml.

5 Click to expand the Layers section. Locate the Position section. In the z text field, type 
-h_former+h_voice_coil/2-h_top_plate/2-h_back-h_waveguide.

6 Locate the Layers section. In the table, enter the following settings:

7 Select the Layers to the right check box.

8 Clear the Layers on bottom check box.

9 Select the Layers on top check box.

10 Click Build Selected.

Rectangle 2 (r2)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type th_voice_coil+2*air_gap.

4 In the Height text field, type h_voice_coil.

5 Locate the Position section. In the r text field, type d_voice_coil/2-air_gap.

6 In the z text field, type -h_former-h_waveguide.

Layer name Thickness (mm)

Layer 1 th_pml
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7 Locate the Layers section. In the table, enter the following settings:

8 Select the Layers to the left check box.

9 Select the Layers to the right check box.

10 Clear the Layers on bottom check box.

11 Click Build Selected.

Polygon 1 (pol1)
1 In the Geometry toolbar, click Polygon.

2 In the Settings window for Polygon, locate the Object Type section.

3 From the Type list, choose Open curve.

4 Locate the Coordinates section. In the table, enter the following settings:

5 Click Build Selected.

Interpolation Curve 1 (ic1)
1 In the Geometry toolbar, click More Primitives and choose Interpolation Curve.

Layer name Thickness (mm)

Layer 1 air_gap

r (mm) z (mm)

0 -h_former+h_voice_coil/2+h_top_plate/2-
h_waveguide

d_voice_coil/2-air_gap -h_former+h_voice_coil/2+h_top_plate/2-
h_waveguide

d_voice_coil/2-air_gap -h_former+h_voice_coil/2-h_top_plate/2-
h_back-h_waveguide

d_magnet/2 -h_former+h_voice_coil/2-h_top_plate/2-
h_back-h_waveguide

d_magnet/2 -h_former+h_voice_coil/2-h_top_plate/2-
h_waveguide

d_voice_coil/2+
th_voice_coil+air_gap

-h_former+h_voice_coil/2-h_top_plate/2-
h_waveguide

d_voice_coil/2+
th_voice_coil+air_gap

-h_former+h_voice_coil/2+h_top_plate/2-
h_waveguide

d_voice_coil/2+4*r1_susp+
2*r2_susp

-h_former+h_voice_coil/2+h_top_plate/2-
h_waveguide

d_voice_coil/2+4*r1_susp+
2*r2_susp

-h_waveguide
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2 In the Settings window for Interpolation Curve, locate the Interpolation Points section.

3 In the table, enter the following settings:

4 Locate the End Conditions section. From the Condition at starting point list, choose 
Tangent direction.

5 In the r text field, type cos(alpha1).

6 In the z text field, type -sin(alpha1).

7 From the Condition at endpoint list, choose Tangent direction.

8 In the r text field, type cos(alpha2).

9 In the z text field, type -sin(alpha2).

10 Click Build Selected.

Interpolation Curve 2 (ic2)
1 In the Geometry toolbar, click More Primitives and choose Interpolation Curve.

2 In the Settings window for Interpolation Curve, locate the Interpolation Points section.

3 In the table, enter the following settings:

r (mm) z (mm)

0 d1-h_waveguide

(d_voice_coil/2)*1/5 d2-h_waveguide

(d_voice_coil/2)*2/5 d3-h_waveguide

(d_voice_coil/2)*3/5 d4-h_waveguide

(d_voice_coil/2)*4/5 d5-h_waveguide

(d_voice_coil/2)*5/5 -h_waveguide

r (mm) z (mm)

d_voice_coil/2+4*r1_susp+2*r2_susp -
h_wavegu
ide

d_voice_coil/2+4*r1_susp+2*r2_susp+(d_waveguide/2-
(d_voice_coil/2+4*r1_susp+2*r2_susp))*1/5

w1-
h_wavegu
ide

d_voice_coil/2+4*r1_susp+2*r2_susp+(d_waveguide/2-
(d_voice_coil/2+4*r1_susp+2*r2_susp))*2/5

w2-
h_wavegu
ide

d_voice_coil/2+4*r1_susp+2*r2_susp+(d_waveguide/2-
(d_voice_coil/2+4*r1_susp+2*r2_susp))*3/5

w3-
h_wavegu
ide
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4 Locate the End Conditions section. From the Condition at starting point list, choose 
Tangent direction.

5 In the r text field, type cos(beta1).

6 In the z text field, type sin(beta1).

7 From the Condition at endpoint list, choose Tangent direction.

8 In the r text field, type cos(beta2).

9 In the z text field, type sin(beta2).

10 Click Build Selected.

Former
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, type Former in the Label text field.

3 On the object ic1, select Point 2 only.

4 Locate the Endpoint section. Find the End vertex subsection. Select the 
Activate Selection toggle button.

5 On the object r2, select Point 3 only.

6 Locate the Selections of Resulting Entities section. Select the Resulting objects selection 
check box.

7 Click Build Selected.

Line Segment 2 (ls2)
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 On the object ic2, select Point 2 only.

3 In the Settings window for Line Segment, locate the Endpoint section.

4 From the Specify list, choose Coordinates.

5 In the r text field, type r_model+th_pml.

6 Click Build Selected.

Circular Arc 1 (ca1)
1 In the Geometry toolbar, click More Primitives and choose Circular Arc.

d_voice_coil/2+4*r1_susp+2*r2_susp+(d_waveguide/2-
(d_voice_coil/2+4*r1_susp+2*r2_susp))*4/5

w4-
h_wavegu
ide

d_voice_coil/2+4*r1_susp+2*r2_susp+(d_waveguide/2-
(d_voice_coil/2+4*r1_susp+2*r2_susp))*5/5

0

r (mm) z (mm)
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2 In the Settings window for Circular Arc, locate the Center section.

3 In the r text field, type d_voice_coil/2+r1_susp.

4 In the z text field, type (-h_former+h_voice_coil/2+h_top_plate/2)*2/3-
h_waveguide.

5 Locate the Radius section. In the Radius text field, type r1_susp.

6 Locate the Angles section. In the End angle text field, type 180.

7 Click Build Selected.

Circular Arc 2 (ca2)
1 In the Geometry toolbar, click More Primitives and choose Circular Arc.

2 In the Settings window for Circular Arc, locate the Center section.

3 In the r text field, type d_voice_coil/2+2*r1_susp+r2_susp.

4 In the z text field, type (-h_former+h_voice_coil/2+h_top_plate/2)*2/3-
h_waveguide.

5 Locate the Radius section. In the Radius text field, type r2_susp.

6 Locate the Angles section. In the Start angle text field, type -180.

7 In the End angle text field, type 0.

8 Click Build Selected.

Circular Arc 3 (ca3)
1 In the Geometry toolbar, click More Primitives and choose Circular Arc.

2 In the Settings window for Circular Arc, locate the Center section.

3 In the r text field, type d_voice_coil/2+3*r1_susp+2*r2_susp.

4 In the z text field, type (-h_former+h_voice_coil/2+h_top_plate/2)*2/3-
h_waveguide.

5 Locate the Radius section. In the Radius text field, type r1_susp.

6 Locate the Angles section. In the End angle text field, type 180.

7 Click Build Selected.

Mirror 1 (mir1)
1 In the Geometry toolbar, click Transforms and choose Mirror.

2 Select the objects ca1, ca2, and ca3 only.

3 In the Settings window for Mirror, locate the Input section.

4 Select the Keep input objects check box.
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5 Locate the Point on Line of Reflection section. In the z text field, type (-h_former+
h_voice_coil/2+h_top_plate/2)/2 -h_waveguide.

6 Locate the Normal Vector to Line of Reflection section. In the r text field, type 0.

7 In the z text field, type 4.

8 Click Build Selected.

Polygon 2 (pol2)
1 In the Geometry toolbar, click Polygon.

2 In the Settings window for Polygon, locate the Object Type section.

3 From the Type list, choose Open curve.

4 Locate the Coordinates section. In the table, enter the following settings:

5 Click Build Selected.

Porous Domain
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, type Porous Domain in the Label text field.

3 Locate the Size and Shape section. In the Width text field, type d_porous/2.

4 In the Height text field, type h_porous.

5 Locate the Position section. In the z text field, type -h_former+h_voice_coil/2+
h_top_plate/2-h_waveguide.

6 Locate the Selections of Resulting Entities section. Select the Resulting objects selection 
check box.

7 Click Build Selected.

Union 1 (uni1)
1 In the Geometry toolbar, click Booleans and Partitions and choose Union.

2 Select the object r1 only.

3 Click the Select All button in the Graphics toolbar.

r (mm) z (mm)

0 r_mode
l/4

d_voice_coil/2+4*r1_susp+2*r2_susp+(d_waveguide/2-
(d_voice_coil/2+4*r1_susp+2*r2_susp))

r_mode
l/4

d_voice_coil/2+4*r1_susp+2*r2_susp+(d_waveguide/2-
(d_voice_coil/2+4*r1_susp+2*r2_susp))

0
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4 In the Settings window for Union, click Build Selected.

Delete Entities 1 (del1)
1 In the Model Builder window, right-click Geometry 1 and choose Delete Entities.

2 In the Settings window for Delete Entities, locate the Entities or Objects to Delete section.

3 From the Geometric entity level list, choose Domain.

4 On the object uni1, select Domains 1, 13, and 14 only.

5 Click Build Selected.

PML Domains
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type PML Domains in the Label text field.

3 On the object del1, select Domains 5, 12, and 13 only.

Voice Coil
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Voice Coil in the Label text field.

3 On the object del1, select Domain 8 only.

Air Domains
1 In the Geometry toolbar, click Selections and choose Complement Selection.

2 In the Settings window for Complement Selection, type Air Domains in the Label text 
field.

3 Locate the Input Entities section. Click Add.

4 In the Add dialog box, select Voice Coil in the Selections to invert list.

5 Click OK.

Narrow Regions
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Narrow Regions in the Label text 
field.

3 On the object del1, select Domains 7 and 11 only.

Visualization Domains
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Visualization Domains in the Label 
text field.
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3 On the object del1, select Domains 1–3, 6, 7, and 9–11 only.

Exterior Field
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Exterior Field in the Label text 
field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose 
Boundary.

4 On the object del1, select Boundaries 9 and 39 only.

Dome
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Dome in the Label text field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose 
Boundary.

4 On the object del1, select Boundary 46 only.

Symmetry/Roller Boundaries
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Symmetry/Roller Boundaries in 
the Label text field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose 
Boundary.

4 On the object del1, select Boundaries 3 and 5 only.

Suspension
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Suspension in the Label text field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose 
Boundary.

4 On the object del1, select Boundaries 47–52 only.

Revolution Boundaries
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Revolution Boundaries in the Label 
text field.
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3 Locate the Entities to Select section. From the Geometric entity level list, choose 
Boundary.

4 On the object del1, select Boundaries 2, 4, 11–15, 17, 19–25, 28–36, and 46–53 only.

Shell Boundaries
1 In the Geometry toolbar, click Selections and choose Union Selection.

2 In the Settings window for Union Selection, type Shell Boundaries in the Label text 
field.

3 Locate the Geometric Entity Level section. From the Level list, choose Boundary.

4 Locate the Input Entities section. Click Add.

5 In the Add dialog box, in the Selections to add list, choose Former, Dome, and Suspension.

6 Click OK.

Waveguide
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Waveguide in the Label text field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose 
Boundary.

4 On the object del1, select Boundary 53 only.

Fixed Points
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Fixed Points in the Label text field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose Point.

4 On the object del1, select Points 31 and 32 only.

R O O T

In the Home toolbar, click Windows and choose Add Study.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select 
Preset Studies for Selected Physics Interfaces>Stationary.

3 Click Add Study in the window toolbar.

4 In the Home toolbar, click Add Study to close the Add Study window.
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S T U D Y  1

Step 1: Stationary
Right-click Study 1>Step 1: Stationary and choose Get Initial Value for Step.

R E S U L T S

In the Model Builder window, expand the Results node.

Revolution 2D 1
1 In the Model Builder window, expand the Results>Datasets node.

2 Right-click Results>Datasets and choose Revolution 2D.

3 In the Settings window for Revolution 2D, click to expand the Revolution Layers section.

4 In the Start angle text field, type -90.

5 In the Revolution angle text field, type 225.

Study 1/Solution 1 (sol1)
In the Model Builder window, click Study 1/Solution 1 (sol1).

Selection
1 In the Results toolbar, click Attributes and choose Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domain 1 only.

Study 1/Solution 1 (2) (sol1)
Right-click Study 1/Solution 1 (sol1) and choose Duplicate.

Selection
1 In the Model Builder window, expand the Study 1/Solution 1 (2) (sol1) node, then click 

Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Revolution Boundaries.

Revolution 2D 2
1 In the Model Builder window, under Results>Datasets right-click Revolution 2D 1 and 

choose Duplicate.

2 In the Settings window for Revolution 2D, locate the Data section.

3 From the Dataset list, choose Study 1/Solution 1 (2) (sol1).
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3D Plot Group 1
1 In the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Dataset list, choose Revolution 2D 2.

Surface 1
1 Right-click 3D Plot Group 1 and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type 0.

4 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

5 From the Color list, choose Gray.

6 In the 3D Plot Group 1 toolbar, click Plot.

Revolution 2D 2
1 In the Model Builder window, click Revolution 2D 2.

2 In the Settings window for Revolution 2D, locate the Revolution Layers section.

3 Clear the Add end caps if the revolution is not full check box.

4 Select the Add end caps if the revolution is not full check box.

5 Click to expand the Advanced section. Select the Define variables check box.

Surface 1
1 In the Model Builder window, click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type if((rev1phi==-90[deg])*(rev1phi==225[deg]),
1,NaN).

4 In the 3D Plot Group 1 toolbar, click Plot.

5 In the Expression text field, type if((rev1phi==-90[deg])*(rev1phi==225[deg]),
1,0).

6 In the 3D Plot Group 1 toolbar, click Plot.

7 Locate the Coloring and Style section. From the Coloring list, choose Color table.

8 Locate the Expression section. In the Expression text field, type if((rev1phi>-
90[deg])*(rev1phi<135[deg]),1,0).

9 In the 3D Plot Group 1 toolbar, click Plot.

10 In the Expression text field, type if((rev1phi>-90[deg])*(rev1phi<135[deg]),1,
NaN).
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11 In the 3D Plot Group 1 toolbar, click Plot.

12 In the Expression text field, type if((rev1phi>=-90[deg])*(rev1phi<=135[deg]),
1,NaN).

13 In the 3D Plot Group 1 toolbar, click Plot.

14 In the Expression text field, type if((rev1phi>=-90[deg])*
(rev1phi<=134.999[deg]),1,NaN).

15 In the 3D Plot Group 1 toolbar, click Plot.

16 In the Expression text field, type if((rev1phi>=-90[deg])*(rev1phi<=135[deg]),
1,NaN).

17 In the 3D Plot Group 1 toolbar, click Plot.

Filter 1
1 Right-click Surface 1 and choose Filter.

2 In the Settings window for Filter, locate the Element Selection section.

3 In the Logical expression for inclusion text field, type (rev1phi>=-90[deg])*
(rev1phi<=135[deg]).

4 In the 3D Plot Group 1 toolbar, click Plot.

5 In the Logical expression for inclusion text field, type (rev1phi>-90[deg])*
(rev1phi<135[deg]).

6 In the 3D Plot Group 1 toolbar, click Plot.

Revolution 2D 2
1 In the Model Builder window, click Revolution 2D 2.

2 In the Settings window for Revolution 2D, locate the Revolution Layers section.

3 From the Number of layers list, choose Fine.

Surface 1
1 In the Model Builder window, click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type 1.

4 In the 3D Plot Group 1 toolbar, click Plot.

Filter 1
1 In the Model Builder window, click Filter 1.

2 In the Settings window for Filter, locate the Element Selection section.
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3 In the Logical expression for inclusion text field, type (rev1phi>-90[deg])*
(rev1phi<135[deg])*(r>0).

4 In the 3D Plot Group 1 toolbar, click Plot.

Surface 1
In the Model Builder window, right-click Surface 1 and choose Delete.

Revolution 2D 3
1 In the Model Builder window, under Results>Datasets right-click Revolution 2D 2 and 

choose Duplicate.

2 In the Settings window for Revolution 2D, locate the Revolution Layers section.

3 Clear the Add end caps if the revolution is not full check box.

Surface 1
1 In the Model Builder window, right-click 3D Plot Group 1 and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type 0.

4 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

5 From the Color list, choose Gray.

6 Locate the Data section. From the Dataset list, choose Revolution 2D 3.

7 In the 3D Plot Group 1 toolbar, click Plot.

Study 1/Solution 1 (3) (sol1)
In the Model Builder window, under Results>Datasets right-click Study 1/

Solution 1 (2) (sol1) and choose Duplicate.

Selection
1 In the Model Builder window, expand the Study 1/Solution 1 (3) (sol1) node, then click 

Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Selection list, choose Waveguide.

Revolution 2D 4
1 In the Model Builder window, under Results>Datasets right-click Revolution 2D 3 and 

choose Duplicate.

2 In the Settings window for Revolution 2D, locate the Data section.

3 From the Dataset list, choose Study 1/Solution 1 (3) (sol1).
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Surface 1
1 In the Model Builder window, click Surface 1.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Revolution 2D 4.

4 In the 3D Plot Group 1 toolbar, click Plot.

5 Locate the Coloring and Style section. From the Color list, choose Custom.

6 On Windows, click the colored bar underneath, or — if you are running the cross-
platform desktop — the Color button.

7 Click Define custom colors.

8 Set the RGB values to 83, 84, and 107, respectively.

9 Click Add to custom colors.

10 Click Show color palette only or OK on the cross-platform desktop.

Study 1/Solution 1 (4) (sol1)
In the Model Builder window, under Results>Datasets right-click Study 1/

Solution 1 (3) (sol1) and choose Duplicate.

Selection
1 In the Model Builder window, expand the Study 1/Solution 1 (4) (sol1) node, then click 

Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Selection list, choose Dome.

Revolution 2D 5
1 In the Model Builder window, under Results>Datasets right-click Revolution 2D 4 and 

choose Duplicate.

2 In the Settings window for Revolution 2D, locate the Data section.

3 From the Dataset list, choose Study 1/Solution 1 (4) (sol1).

Surface 2
1 In the Model Builder window, under Results>3D Plot Group 1 right-click Surface 1 and 

choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Revolution 2D 5.

4 Locate the Coloring and Style section. On Windows, click the colored bar underneath, 
or — if you are running the cross-platform desktop — the Color button.
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5 Click Define custom colors.

6 Set the RGB values to 192, 192, and 192, respectively.

7 Click Add to custom colors.

8 Click Show color palette only or OK on the cross-platform desktop.

Selection
1 In the Model Builder window, click Selection.

2 Select Domain 1 only.

Study 1/Solution 1 (5) (sol1)
In the Model Builder window, under Results>Datasets right-click Study 1/

Solution 1 (4) (sol1) and choose Duplicate.

Selection
1 In the Model Builder window, expand the Study 1/Solution 1 (5) (sol1) node, then click 

Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Selection list, choose Former.

Revolution 2D 6
1 In the Model Builder window, under Results>Datasets right-click Revolution 2D 5 and 

choose Duplicate.

2 In the Settings window for Revolution 2D, locate the Data section.

3 From the Dataset list, choose Study 1/Solution 1 (5) (sol1).

Surface 3
1 In the Model Builder window, under Results>3D Plot Group 1 right-click Surface 2 and 

choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Revolution 2D 6.

4 Locate the Coloring and Style section. On Windows, click the colored bar underneath, 
or — if you are running the cross-platform desktop — the Color button.

5 Click Define custom colors.

6 Set the RGB values to 253, 185, and 19, respectively.

7 Click Add to custom colors.

8 Click Show color palette only or OK on the cross-platform desktop.
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Surface 4
1 In the Model Builder window, right-click 3D Plot Group 1 and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Revolution 2D 1.

4 Locate the Expression section. In the Expression text field, type 0.

5 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

6 From the Color list, choose Custom.

7 On Windows, click the colored bar underneath, or — if you are running the cross-
platform desktop — the Color button.

8 Click Define custom colors.

9 Set the RGB values to 132, 194, and 234, respectively.

10 Click Add to custom colors.

11 Click Show color palette only or OK on the cross-platform desktop.

12 In the 3D Plot Group 1 toolbar, click Plot.

Study 1/Solution 1 (6) (sol1)
In the Model Builder window, under Results>Datasets right-click Study 1/

Solution 1 (5) (sol1) and choose Duplicate.

Selection
1 In the Model Builder window, expand the Study 1/Solution 1 (6) (sol1) node, then click 

Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Selection list, choose Suspension.

Revolution 2D 7
1 In the Model Builder window, under Results>Datasets right-click Revolution 2D 6 and 

choose Duplicate.

2 In the Settings window for Revolution 2D, locate the Data section.

3 From the Dataset list, choose Study 1/Solution 1 (6) (sol1).

Surface 5
1 In the Model Builder window, under Results>3D Plot Group 1 right-click Surface 4 and 

choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Revolution 2D 7.
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4 Locate the Coloring and Style section. On Windows, click the colored bar underneath, 
or — if you are running the cross-platform desktop — the Color button.

5 Click Define custom colors.

6 Set the RGB values to 196, 106, and 72, respectively.

7 Click Add to custom colors.

8 Click Show color palette only or OK on the cross-platform desktop.

9 Click the Go to Default View button in the Graphics toolbar.

Study 1/Solution 1 (7) (sol1)
In the Model Builder window, under Results>Datasets right-click Study 1/

Solution 1 (1) (sol1) and choose Duplicate.

Selection
1 In the Model Builder window, expand the Study 1/Solution 1 (7) (sol1) node, then click 

Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Selection list, choose Voice Coil.

Revolution 2D 8
1 In the Model Builder window, under Results>Datasets right-click Revolution 2D 7 and 

choose Duplicate.

2 In the Settings window for Revolution 2D, locate the Data section.

3 From the Dataset list, choose Study 1/Solution 1 (7) (sol1).

Surface 6
1 In the Model Builder window, under Results>3D Plot Group 1 right-click Surface 5 and 

choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Revolution 2D 8.

4 Locate the Coloring and Style section. On Windows, click the colored bar underneath, 
or — if you are running the cross-platform desktop — the Color button.

5 Click Define custom colors.

6 Set the RGB values to 242, 101, and 34, respectively.

7 Click Add to custom colors.

8 Click Show color palette only or OK on the cross-platform desktop.
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Revolution 2D 8
1 In the Model Builder window, click Revolution 2D 8.

2 In the Settings window for Revolution 2D, locate the Revolution Layers section.

3 Select the Add end caps if the revolution is not full check box.

3D Plot Group 1
1 In the Model Builder window, click 3D Plot Group 1.

2 In the Settings window for 3D Plot Group, click to expand the Title section.

3 From the Title type list, choose None.

Study 1/Solution 1 (8) (sol1)
In the Model Builder window, under Results>Datasets right-click Study 1/

Solution 1 (6) (sol1) and choose Duplicate.

Selection
1 In the Model Builder window, expand the Study 1/Solution 1 (8) (sol1) node, then click 

Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 Click Clear Selection.

4 Select Boundaries 12–15, 17, and 28–36 only.

Revolution 2D 9
1 In the Model Builder window, under Results>Datasets right-click Revolution 2D 7 and 

choose Duplicate.

2 In the Settings window for Revolution 2D, locate the Data section.

3 From the Dataset list, choose Study 1/Solution 1 (8) (sol1).

Surface 7
1 In the Model Builder window, under Results>3D Plot Group 1 right-click Surface 1 and 

choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Revolution 2D 9.

4 Locate the Coloring and Style section. On Windows, click the colored bar underneath, 
or — if you are running the cross-platform desktop — the Color button.

5 Click Define custom colors.

6 Set the RGB values to 42, 49, and 76, respectively.

7 Click Add to custom colors.
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8 Click Show color palette only or OK on the cross-platform desktop.

Transparency 1
Right-click Surface 7 and choose Transparency.

Transparency 1
1 In the Model Builder window, right-click Surface 4 and choose Transparency.

2 Click the Go to Default View button in the Graphics toolbar.

3 Click the Orthographic Projection button in the Graphics toolbar.

4 Click the Go to Default View button in the Graphics toolbar.

5 Click the Show Grid button in the Graphics toolbar.

6 Click the Show Grid button in the Graphics toolbar.
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