
Created in COMSOL Multiphysics 5.6
Geome t r i c  Pa r ame t e r  Op t im i z a t i o n  o f  a  B r a c k e t
This model is licensed under the COMSOL Software License Agreement 5.6.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

In some application fields, there is a strong focus on weight reduction. For example, this 
is the case in the automotive industry, where every gram has a distinct price tag.

The bracket is used for mounting a heavy component on a vibrating foundation. It is thus 
important to keep the natural frequency well above the excitation frequency in order to 
avoid resonances. The bracket is also subjected to shock loads, which can be treated as a 
static acceleration load. This gives an optimization problem, where results from two 
different study types must be considered simultaneously.

By using the LiveLink interface for SOLIDWORKS, the weight of a mounting bracket is 
reduced, given an upper bound on the stresses and a lower bound on the first natural 
frequency. The model demonstrates how to synchronize the geometry between 
SOLIDWORKS and COMSOL Multiphysics while updating dimensional parameters, and 
how to perform an optimization study.

Note: This application requires the Optimization Module, the Structural Mechanics 
Module, and the LiveLink interface for SOLIDWORKS.

Model Definition

The original bracket together with a sketched mounted component are shown in Figure 1. 
The bracket is made of steel.

The component, which can be considered as rigid when compared with the bracket, has 
its center of gravity at the center of the circular cutout in the bracket. The mass is 4.4 kg, 
the moment of inertia around its longitudinal axis is 7.1·10−4 kg·m2, and the moment of 
inertia around the two transverse axes is 9.3·10−4 kg·m2.
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Figure 1: Bracket supporting a heavy component.

The idea is to reduce the weight by drilling holes in the vertical surface of the bracket, and 
at the same time change the dimensions of the indentations, in order to offset the loss in 
stiffness.

O P T I M I Z A T I O N  P A R A M E T E R S

Six geometrical parameters are used in the optimization. They are summarized in Table 1 
and shown in Figure 2.

TABLE 1:  GEOMETRICAL PARAMETERS.

Parameter Description Lower limit (mm) Upper limit (mm)

RC Radius of the central hole 3 15

ZCO Vertical distance from the bend to 
the edge of the central hole

1 23
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Figure 2: Optimization parameters.

C O N S T R A I N T S

• The lowest natural frequency must be at least 60 Hz.

• When exposed to a peak acceleration of 4g in all three global directions simultaneously, 
the effective stress is not allowed to exceed 80 MPa anywhere. This criterion is 

RO Radius of the outer hole 3 15

ZOO Vertical distance from the bend to 
the edge of the outer hole

8 30

YOO Horizontal distance from the 
edge of the bracket to outer hole

3 29

WIND Width of the indentation 8 20

 YOO
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RO
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 WIND RC

TABLE 1:  GEOMETRICAL PARAMETERS.

Parameter Description Lower limit (mm) Upper limit (mm)
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nondifferentiable, because the location of the peak stress can jump from one place to 
another. A gradient-free optimization algorithm must thus be used.

• There must be at least 3 mm of material between two holes, or between a hole and an 
edge. This criterion is enforced both through the limits on the control parameters and 
as constraints. The geometrical constraints are shown in Figure 3.

Figure 3: Geometrical constraints.

The COBYLA solver uses sampling in the control variable space to approximate both the 
objective function, the constraints, and the control variable bounds. Individual samples 
may be computed outside the bounds and in violation of the constraints. Therefore, it is 
important to parameterize the geometry in such a way that it is robust with respect to 
(small) constraint and bound violations.

Bounds and linear constraints are generally satisfied to high precision at the optimum 
point returned by the solver, but nonlinear constrains are often slightly violated. The 
reason is that the solver tends to converge from the outside of the feasible domain and 
terminates before the constraints are completely satisfied. Tightening the solver tolerances 
will decrease the constraint violation but is often not worth the computational effort; it is 
better to specify constraints with a safety margin.

 d_O_Cmp

 d_O_O

 d_C_Cmp

 d_O_C
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Results and Discussion

The initial geometry used in the optimization is shown in Figure 4. Three rather small 
holes have been introduced.

Figure 4: Initial geometry.

The optimal values of the geometrical parameters are shown in Table 2.

Parameter Optimal value (mm) Lower limit (mm) Upper limit (mm)

LL_RC 6.81  3  15

LL_ZCO 2.83  1  23

LL_RO  10.65  3  15

LL_YOO 10.56  3  29

LL_ZOO  16.95  8  30

TABLE 2:  OPTIMAL VALUES.
6 |  G E O M E T R I C  P A R A M E T E R  O P T I M I Z A T I O N  O F  A  B R A C K E T



The weight of the optimized bracket is about 180 g, a reduction of 20 g from the original 
200.54 g. The stresses from the shock load on the optimized geometry are shown in 
Figure 5

Figure 5: Stresses at peak load in the optimized design.

The optimal solution gives three fairly large holes, and the widest possible indentation.

There are several possible arrangements of the holes that give the same weight reduction 
within a small tolerance. It is therefore possible that the design variables are not always the 
same at convergence.

Notes About the COMSOL Implementation

The bracket geometry you are using in this model comes from a SOLIDWORKS design. 
Using LiveLink for SOLIDWORKS you synchronize the geometry and parameters for the 
dimension of the bracket and the positioning of holes between SOLIDWORKS and 
COMSOL Multiphysics. In order for this to work you need to have both programs 
running during modeling, and you need to make sure that the bracket file is the active file 
in SOLIDWORKS.

The component mounted on the bracket is not modeled in detail. It is replaced by a Rigid 
Connector having the equivalent inertial properties.
7 |  G E O M E T R I C  P A R A M E T E R  O P T I M I Z A T I O N  O F  A  B R A C K E T



Application Library path: LiveLink_for_SOLIDWORKS/Tutorials,
_LiveLink_Interface/bracket_optimization_llsw

Modeling Instructions

You can set up this simulation both by working inside SOLIDWORKS, using the 
embedded COMSOL simulation environment, and by working in the standalone 
COMSOL Desktop. Regardless which way you proceed, first you need to open the CAD 
file with the geometry in SOLIDWORKS.

1 In SOLIDWORKS open the file bracket_optimization.SLDPRT located in the 
model’s Application Library folder.

2 Switch to the COMSOL Desktop, and skip the next section. Or, continue below if you 
are working inside SOLIDWORKS.

M O D E L I N G  I N S I D E  S O L I D W O R K S

1 On the COMSOL Multiphysics tab click the New button.

In case it is not already running, the COMSOL modeling environment will be started, 
and the geometry will be synchronized automatically.

2 Continue with step 2 under the Model Wizard section.

C O M S O L  D E S K T O P

From the File menu, choose New.

N E W

In the New window, click  Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click  3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click  Study.

5 In the Select Study tree, select General Studies>Eigenfrequency.

6 Click  Done.
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G E O M E T R Y  1

The geometry is already synchronized if you are modeling inside SOLIDWORKS, and you 
can skip to step 4 in the section LiveLink for SOLIDWORKS 1 (cad1).

Make sure that the CAD Import Module kernel is used.

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Advanced section.

3 From the Geometry representation list, choose CAD kernel.

LiveLink for SOLIDWORKS 1 (cad1)
1 Right-click Component 1 (comp1)>Geometry 1 and choose LiveLink Interfaces>

LiveLink for SOLIDWORKS.

2 In the Settings window for LiveLink for SOLIDWORKS, locate the Synchronize section.

3 Click Synchronize.

After a few moments the geometry of the bracket appears in the Graphics window.

4 Click to expand the Parameters in CAD Package section. The table contains ten 
dimensions, THK, LX, LZ, DCMP, BDIA, RC, ZCO, RO, YOO and ZOO, which are part of the 
SOLIDWORKS model. In SOLIDWORKS, the Parameter Selection button on the 
COMSOL Multiphysics tab allows you to select and view dimensions for synchronization. 
These dimensions are retrieved, and appear in the CAD name column of the table. The 
corresponding entries in the COMSOL name column, LL_THK, LL_LX and so on, are 
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global parameters in the COMSOL model. These are automatically generated during 
synchronization, and are assigned the values of the linked SOLIDWORKS dimensions. 
The parameter values are displayed in the COMSOL value column.

Global parameters in a model allow you to parameterize settings and can be controlled 
by the optimization solver to perform parametric sweeps. Thus, by linking 
SOLIDWORKS dimensions to COMSOL global parameters, the optimization solver 
can automatically update and synchronize the geometry for each new value in a sweep.

5 Click to expand the Boundary Selections section. The selections listed here are user 
defined selections saved in the SOLIDWORKS files for the components that they 
appear on. In SOLIDWORKS, you can set-up selections using the Selections button on 
the COMSOL Multiphysics tab.

6 Right-click LiveLink for SOLIDWORKS 1 (cad1) and choose Build All.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

The table already contains the automatically generated global parameters that are linked 
to the SOLIDWORKS dimensions.

Based on the parameters in the table you can define expressions to constrain the 
positioning of the holes while optimizing the bracket. Later on you will set up the 
optimization solver to take into account these geometric constraints. Now, continue 
with loading the expressions for the geometric constraints and the parameters needed 
to define the physics. Since the parameter file contains all parameters, including the 
already synchronized ones, clear the table first to avoid duplicates.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click  Clear Table.

4 Click  Load from File.

5 Browse to the model’s Application Libraries folder and double-click the file 
bracket_optimization_parameters.txt.

M A T E R I A L S

Add Material
From the Home menu, choose Add Material.

A D D  M A T E R I A L

1 Go to the Add Material window.
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2 In the tree, select Built-in>Structural steel.

3 Click the right end of the Add to Component split button in the window toolbar.

4 From the menu, choose Add to Component.

5 From the Home menu, choose Add Material.

S O L I D  M E C H A N I C S  ( S O L I D )

Fixed (Bolts)
1 In the Model Builder window, under Component 1 (comp1) right-click 

Solid Mechanics (solid) and choose Fixed Constraint.

The exact way the bolts clamp the bracket to the foundation is not important for the 
results in the part being optimized.

2 In the Settings window for Fixed Constraint, type Fixed (Bolts) in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Fixed (Bolts).

Rigid Connector (Mounted component)
1 In the Model Builder window, right-click Solid Mechanics (solid) and choose Connections>

Rigid Connector.

The attached component has a high stiffness, and is bolted to the two upper bolt holes. 
It is modeled as being rigid, with only mass properties.
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2 In the Settings window for Rigid Connector, type Rigid Connector (Mounted 
component) in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose 
Rigid Connector (Mounted comp).

4 Locate the Center of Rotation section. From the list, choose User defined.

5 Specify the Xc vector as

Mass and Moment of Inertia 1
1 Right-click Rigid Connector (Mounted component) and choose 

Mass and Moment of Inertia.

2 In the Settings window for Mass and Moment of Inertia, locate the 
Mass and Moment of Inertia section.

3 In the m text field, type mCmp.

4 From the list, choose Diagonal.

LL_LX-LL_THK/2 x

(4*LL_BDIA+LL_DCMP)/2 y

LL_LZ z
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5 In the I table, enter the following settings:

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Physics-Controlled Mesh section.

3 From the Element size list, choose Finer.

Free Triangular 1
1 Right-click Component 1 (comp1)>Mesh 1 and choose More Operations>Free Triangular.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Boundary Mesh.

Size 1
1 Right-click Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. Select the Minimum element size check box.

IXCmp 0 0

0 IYZCmp 0

0 0 IYZCmp
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5 In the associated text field, type 0.2.

6 Select the Curvature factor check box.

7 In the associated text field, type 0.38.

8 Click  Build Selected.

Swept 1
In the Model Builder window, right-click Mesh 1 and choose Swept.

Distribution 1
1 In the Model Builder window, right-click Swept 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 3.
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4 Click  Build All.

E I G E N F R E Q U E N C Y  S T U D Y

Run an eigenfrequency study on the initial geometry.

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Eigenfrequency Study in the Label text field.

3 Click  Compute.

S O L I D  M E C H A N I C S  ( S O L I D )

Add the peak loads, and perform a stationary study.

Body load 4g on bracket
1 In the Model Builder window, under Component 1 (comp1) right-click 

Solid Mechanics (solid) and choose Volume Forces>Body Load.

2 In the Settings window for Body Load, type Body load 4g on bracket in the Label text 
field.

3 Locate the Domain Selection section. From the Selection list, choose All domains.

4 Locate the Force section. Specify the FV vector as

4*g_const*solid.rho x
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Force 4g on mounted component
1 In the Model Builder window, right-click Rigid Connector (Mounted component) and 

choose Applied Force.

2 In the Settings window for Applied Force, type Force 4g on mounted component in 
the Label text field.

3 Locate the Applied Force section. Specify the F vector as

R O O T

From the Home menu, choose Add Study.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

3 Click Add Study in the window toolbar.

4 From the Home menu, choose Add Study.

S T A T I O N A R Y  S T U D Y

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Stationary Study in the Label text field.

3 Click  Compute.

D E F I N I T I O N S

Prepare for the optimization by adding variables for the bracket mass and the maximum 
stress.

Integration 1 (intop1)
1 In the Model Builder window, under Component 1 (comp1) right-click Definitions and 

choose Nonlocal Couplings>Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Selection list, choose All domains.

4*g_const*solid.rho y

4*g_const*solid.rho z

4*g_const*mCmp x

4*g_const*mCmp y

4*g_const*mCmp z
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Maximum 1 (maxop1)
1 In the Model Builder window, right-click Definitions and choose Nonlocal Couplings>

Maximum.

The boundaries for which the maximum stress is going to be evaluated are defined as 
Selections in SOLIDWORKS.

2 In the Settings window for Maximum, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Maximum Stress.

Variables 1
1 Right-click Definitions and choose Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

R E S U L T S

Add a plot for monitoring the geometry and stresses in the optimized region.

Name Expression Unit Description

mass intop1(solid.rho) kg Bracket mass

maxStress maxop1(solid.mises) N/m² Maximum stress
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Stress in Optimized Region
1 In the Model Builder window, right-click Results and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Stress in Optimized Region in the 
Label text field.

3 Locate the Data section. From the Dataset list, choose Stationary Study/Solution 2 (sol2).

Volume 1
1 Right-click Stress in Optimized Region and choose Volume.

2 In the Settings window for Volume, locate the Expression section.

3 In the Expression text field, type solid.mises.

Filter 1
1 Right-click Volume 1 and choose Filter.

2 In the Settings window for Filter, locate the Element Selection section.

3 In the Logical expression for inclusion text field, type x>LL_LX-5*LL_THK.

4 Click the  Zoom Extents button in the Graphics toolbar.

Set up the optimization study.

R O O T

From the Home menu, choose Add Study.
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A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select Empty Study.

3 Click Add Study in the window toolbar.

4 From the Home menu, choose Add Study.

O P T I M I Z A T I O N  S T U D Y

In the Settings window for Study, type Optimization Study in the Label text field.

Optimization
Right-click Optimization Study and choose Optimization>Optimization.

Eigenfrequency
1 Right-click Optimization Study and choose Study Reference.

2 In the Settings window for Study Reference, type Eigenfrequency in the Label text field.

3 Locate the Study Reference section. From the Study reference list, choose 
Eigenfrequency Study.

Stationary
1 Right-click Optimization Study and choose Study Reference.

2 In the Settings window for Study Reference, type Stationary in the Label text field.

3 Locate the Study Reference section. From the Study reference list, choose 
Stationary Study.

Optimization
1 In the Model Builder window, click Optimization.

2 In the Settings window for Optimization, locate the Optimization Solver section.

3 From the Method list, choose COBYLA.

4 Find the Solver settings subsection. Clear the Stop if error check box.

5 Locate the Constraints section. Select the Enforce design constraints strictly check box.

6 Locate the Objective Function section. In the table, enter the following settings:

7 Locate the Optimization Solver section. In the Optimality tolerance text field, type 0.1.

The first eigenfrequency is to be used in the optimization.

8 Locate the Objective Function section. From the Solution list, choose Use first.

Expression Description Evaluate for

comp1.mass Bracket mass Stationary
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9 Locate the Control Variables and Parameters section. Click  Load from File.

10 Browse to the model’s Application Libraries folder and double-click the file 
bracket_optimization_ctrlvars.txt.

11 Locate the Constraints section. In the table, enter the following settings:

12 Locate the Output While Solving section. Select the Plot check box.

13 From the Plot group list, choose Stress in Optimized Region.

If some configurations are not valid, the optimization procedure should still continue. The 
default is to stop if an error occurs.

Solution 3 (sol3)
1 In the Model Builder window, right-click Optimization Study and choose 

Show Default Solver.

Run the optimization.

2 Right-click Optimization Study and choose Compute.

R E S U L T S

On the last line of Objective Table 2 you will find the optimal set of parameters, and the 
minimum weight. Note that the value in the Objective column can be colored orange if the 
solution violates a constraint slightly, but is still accepted within the tolerances.

On the last line of Global Constraints Table 6 you will find the values of the natural 
frequency and maximum stress in the optimized configuration, as well as the values of the 
other constraints.

To avoid scrolling through a large number of table entries, insert a Global Evaluation which 
shows only the optimized parameters.

Expression Lower bound Upper bound Evaluate for

real(comp1.solid.fre
q)

minFreq Eigenfrequency

comp1.maxStress/
maxStressLimit

1 Stationary

d_O_Cmp 3[mm] Eigenfrequency

d_C_Cmp 3[mm] Eigenfrequency

d_O_C 3[mm] Eigenfrequency

d_O_O 3[mm] Eigenfrequency
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1 In the table, enter the following settings:

Global Evaluation 1
1 In the Model Builder window, expand the Results>Tables node.

2 Right-click Results>Derived Values and choose Global Evaluation.

Instead of adding each parameter manually load a txt file

3 In the Settings window for Global Evaluation, locate the Data section.

4 From the Dataset list, choose Optimization Study/Solution 3 (sol3).

5 Locate the Expressions section. Click  Load from File.

6 Browse to the model’s Application Libraries folder and double-click the file 
bracket_optimization_eval_parameters.txt.

7 Click next to  Evaluate, then choose New Table.

T A B L E

Go to the Table window.

R E S U L T S

Global Evaluation 1
1 In the Model Builder window, click Global Evaluation 1.

2 In the Settings window for Global Evaluation, click  Evaluate.

Examine the stress distribution in the optimized configuration.

Name Description

LL_THK Plate thickness

LL_LX Bracket length

LL_LZ Bracket height

LL_DCM
P

Diameter of component

LL_BDIA Diameter of mounting bolts

LL_RC Radius of central hole

LL_ZCO Distance from bend to bottom of central hole

LL_RO Radius of outer holes

LL_YOO Distance from edge to outer hole

LL_ZOO Distance from bend to bottom of outer hole
21 |  G E O M E T R I C  P A R A M E T E R  O P T I M I Z A T I O N  O F  A  B R A C K E T



Stress in Optimized Region
1 In the Model Builder window, right-click Stress in Optimized Region and choose Plot.

2 Click the  Zoom Extents button in the Graphics toolbar.

As a last step, update the parameters in SOLIDWORKS.

G E O M E T R Y  1

LiveLink for SOLIDWORKS 1 (cad1)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click 

LiveLink for SOLIDWORKS 1 (cad1).

2 In the Settings window for LiveLink for SOLIDWORKS, locate the 
Parameters in CAD Package section.

3 Click Update Parameters from CAD in the upper-right corner of the section.

Form Union (fin)
1 In the Model Builder window, click Form Union (fin).
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2 In the Settings window for Form Union/Assembly, click  Build All.
23 |  G E O M E T R I C  P A R A M E T E R  O P T I M I Z A T I O N  O F  A  B R A C K E T



24 |  G E O M E T R I C  P A R A M E T E R  O P T I M I Z A T I O N  O F  A  B R A C K E T


	Geometric Parameter Optimization of a Bracket
	Introduction
	Model Definition
	Results and Discussion
	Notes About the COMSOL Implementation
	Modeling Instructions

