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 1
I n t r o d u c t i o n
This Structural Mechanics Module Verification Manual consists of a set of benchmark models from 
various areas of structural mechanics and solid mechanics engineering. These are models with a theoretical 
solution or an solution from an established benchmark. Their purpose is to show the close agreement between 
the numerical solution obtained in COMSOL Multiphysics and the established benchmark data, so that you 
can gain confidence in the solutions provided when using the Structural Mechanics Module.

The models illustrate the use of the various structural-mechanics specific physics interfaces and study types. 
We have tried to cover a wide spectrum of the capabilities in the Structural Mechanics Module.

Note that the model descriptions in this book do not contain details on how to carry out every step in the 
modeling process. Before tackling these models, we urge you to first read the Structural Mechanics Module 
User’s Guide. This book introduces you to the functionality in the module, reviews new features, and covers 
basic modeling techniques with tutorials and example models. Another book, the Structural Mechanics 
Module Applications Library, contains a large number of examples models from important application areas 
such as automotive applications, dynamics and vibration, fluid-structure interaction, fatigue analysis, and 
piezoelectric applications.

For more information on how to work with the COMSOL Multiphysics graphical user interface, please refer 
to the COMSOL Multiphysics Reference Manual or the Introduction to COMSOL Multiphysics manual.

The book you are reading, the Structural Mechanics Module Verification Manual, provides details about 
a large number of ready-to-run models that provide numerical solutions to benchmark problems and 
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textbook examples with theoretical closed-form solutions. Each entry comes with 
theoretical background, a discussion about the results with a comparison to the 
benchmark data or the analytical solution, as well as instructions that illustrate how to set 
it up. The documentation for all models contains references to the textbook or technical 
publication from which we have collected the benchmark data or other verification data.

Finally note that we supply these models as COMSOL model files so you can open them 
in the COMSOL Desktop for immediate access, allowing you to follow along with these 
examples every step along the way.

Note: The full documentation set is available in electronic formats—PDF and HTML—
through the COMSOL Documentation window after installation.

Comparison With Theoretical and Benchmark Results

COMSOL Multiphysics and the Structural Mechanics Module use the finite element 
method to solve problems on a computational mesh using discrete numerical methods. 
Theoretical, closed-form solutions are typically based on continuous mathematical models 
and would require infinitely small mesh elements to reproduce exactly. These benchmark 
models, on the other hand, use relatively coarse meshes. The comparisons of the numerical 
solution in COMSOL Multiphysics to the benchmark results therefore allow for a small 
discrepancy. Comparisons to established benchmark results also show similar accuracy. 
Sources to these differences in the results include different solution methods, different 
discretization (computational grids), and other differences between the code or method 
used in the benchmark and the COMSOL Multiphysics code. Also note that the numerical 
solution might vary slightly depending on the computer platform that you use because 
different platforms have small differences handling floating-point operations.

COMSOL Software Verification and Quality Assurance Programs

COMSOL uses extensive manual and automatic testing to validate and verify the code. 
The benchmark models in this book make up a subset of the test cases that are part of a 
continuous automatic testing program. The automatic test program also frequently 
rebuilds all models in the COMSOL Application Libraries to ensure that they work and 
provide consistent solutions.
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Introduction

This conceptual example shows how to calculate critical points in models with contact. 
The model consists of a block modeled with the Solid Mechanics interface pressing on an 
arch modeled with the Shell interface and also exemplifies how to model the contact 
between a shell and a solid. During loading, the arch exhibits a snap-through behavior. 
The definition of the problem is based on a benchmark example from Ref. 1.

Model Definition

The model geometry consists of an arch and a block as shown in Figure 1. Since the arch 
is modeled with the Shell interface, a 3D geometry is used. However, a 2D plane strain 
behavior is intended, and consequently symmetry conditions are applied to all boundaries 
and edges in the y direction to suppress any out-of-plane deformation.

Figure 1: Model geometry

Only contact without friction is considered and the augmented Lagrangian contact 
method is used.
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A boundary load is applied the top surface of the block. Its magnitude is controlled by the 
monotonically increasing deflection of the arch, which makes it possible to track the entire 
load path, even though the force does not increase monotonically. The ends of the arch 
are fixed and the displacement of the block is constrained in the x direction.

Results and Discussion

Figure 2 depicts the deformed shape and the von Mises stress distribution at the last step 
of the simulation. The snap-through of the arch is clearly observed. The arch is represented 
by a shell dataset that shows both its top and bottom surface.

Figure 2: Deformation and von Mises stress at the final step.

The load versus deflection curve is shown in Figure 3. The load is in the figure represented 
by a dimensionless load factor. Two limit points can be observed, the first occurs for a load 
factor equal to 18 and a deflection of 36 mm. At this point the arch becomes unstable and 
a snap-through occurs. When the deflection of the arch reaches 80 mm, the load factor has 
decreased to 14. At this point the second limit point is reached, and the arch finds a new 
stable configuration. After this point the load factor increases with increasing deflection.
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Figure 3: Load versus deflection curve.

The progressive deformation of the block and the arch, including the snap-through of the 
arch, is shown in Figure 4 for six values of the continuation parameter. Figure 5 shows the 
contact pressure exerted by the block on the arch during the snap-through.
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Figure 4: Deformation of the model for six different parameter values.

Figure 5: Contact pressure acting on the arch.
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Notes About the COMSOL Implementation

When a Shell interface is used in a contact simulation, it is recommended that the 
destination boundary always belongs to the shell. Moreover, the contact definition should 
be made in the Shell interface. In this example, the block modeled with a Solid Mechanics 
interface is thus, in the Contact node, considered as external to the current physics.

Contact problems are often unstable in their initial configuration. To help the solver find 
an initial solution, a Spring Foundation is added to the otherwise unconstrained block 
during the first parameter step.

Modeling the post-critical behavior of a system is not possible by incrementally increasing 
the boundary load. The unstable behavior is even more pronounced when contact is 
present. To be able to find all limit points and to track the full load versus deflection curve, 
a displacement controlled load scheme is used by adding a Global Equation. Here, the 
magnitude of the boundary load is controlled through the monotonically increasing 
deflection of the arch. Alternatively, the vertical displacement could be prescribed on the 
top surface of the block, but this is a less general technique that fails for some cases. Also, 
a prescribed displacement would not give an evenly distributed load.

Reference

1. P. Wriggers, Computational Contact Mechanics, Springer-Verlag, 2006

Application Library path: Structural_Mechanics_Module/
Verification_Examples/block_on_arch

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Shell (shell).

3 Click Add.
6 |  B L O C K  P R E S S I N G  O N  A R C H



4 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

5 Click Add.

6 In the Displacement field text field, type u.

7 Click Study.

8 In the Select Study tree, select General Studies>Stationary.

9 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
block_on_arch_parameters.txt.

G E O M E T R Y  1

Work Plane 1 (wp1)
1 In the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 From the Plane list, choose xz-plane.

4 Click Show Work Plane.

Work Plane 1 (wp1)>Circle 1 (c1)
1 In the Work Plane toolbar, click Circle.

2 In the Settings window for Circle, locate the Object Type section.

3 From the Type list, choose Curve.

4 Locate the Size and Shape section. In the Radius text field, type R_arch.

5 In the Sector angle text field, type seg_arch.

6 Locate the Position section. In the yw text field, type -R_arch.

7 Locate the Rotation Angle section. In the Rotation text field, type 90-seg_arch/2.

8 Click Build Selected.

9 Click the Zoom Extents button in the Graphics toolbar.
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Work Plane 1 (wp1)>Delete Entities 1 (del1)
1 In the Model Builder window, right-click Plane Geometry and choose Delete Entities.

2 On the object c1, select Boundaries 2 and 3 only.

Work Plane 1 (wp1)>Partition Edges 1 (pare1)
1 In the Work Plane toolbar, click Booleans and Partitions and choose Partition Edges.

2 On the object del1, select Boundary 1 only.

Work Plane 1 (wp1)>Circle 2 (c2)
1 In the Work Plane toolbar, click Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type R_block.

4 In the Sector angle text field, type seg_block.

5 Locate the Position section. In the yw text field, type R_block.

6 Locate the Rotation Angle section. In the Rotation text field, type -90-seg_block/2.

7 Click Build Selected.

8 Click the Zoom Extents button in the Graphics toolbar.

Work Plane 1 (wp1)>Rectangle 1 (r1)
1 In the Work Plane toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type R_block.

4 In the Height text field, type height_block.

5 Locate the Position section. In the xw text field, type -R_block/2.

6 Click Build Selected.

Work Plane 1 (wp1)>Intersection 1 (int1)
1 In the Work Plane toolbar, click Booleans and Partitions and choose Intersection.

2 Select the objects c2 and r1 only.

Work Plane 1 (wp1)
1 In the Model Builder window, click Work Plane 1 (wp1).

2 In the Settings window for Work Plane, locate the Unite Objects section.

3 Clear the Unite objects check box.

Extrude 1 (ext1)
1 In the Geometry toolbar, click Extrude.
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2 In the Settings window for Extrude, locate the Distances section.

3 In the table, enter the following settings:

4 Click Build Selected.

5 Click the Zoom Extents button in the Graphics toolbar.

Explicit Selection 1 (sel1)
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Arch in the Label text field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose Object.

4 Select the object ext1(1) only.

5 Locate the Color section. From the Color list, choose Color 4.

6 Click Build Selected.

Arch 1 (sel2)
1 Right-click Arch and choose Duplicate.

2 In the Settings window for Explicit Selection, type Block in the Label text field.

3 Locate the Entities to Select section. In the list, select ext1(1).

4 Select the object ext1(2) only.

5 Locate the Color section. From the Color list, choose Color 12.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click 

Form Union (fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly section.

3 From the Action list, choose Form an assembly.

4 Click Build Selected.

5 Click the Zoom Extents button in the Graphics toolbar.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

Distances (m)

d
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2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Arch.

5 Locate the Material Contents section. In the table, enter the following settings:

D E F I N I T I O N S

Average 1 (aveop1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 In the Settings window for Average, locate the Source Selection section.

3 From the Geometric entity level list, choose Point.

4 Select Point 11 only.

Average 2 (aveop2)
1 Right-click Average 1 (aveop1) and choose Duplicate.

2 In the Settings window for Average, locate the Source Selection section.

3 Click Clear Selection.

4 Select Point 3 only.

Variables 1
1 In the Model Builder window, right-click Definitions and choose Variables.

2 In the Settings window for Variables, locate the Variables section.

Property Variable Value Unit Property group

Young’s modulus E 10[GPa] Pa Basic

Poisson’s ratio nu 0.2 1 Basic

Density rho 1 kg/m³ Basic

Property Variable Value Unit Property group

Young’s modulus E 70[GPa] Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 1 kg/m³ Basic
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3 In the table, enter the following settings:

Contact Pair 1 (p1)
1 In the Definitions toolbar, click Pairs and choose Contact Pair.

2 Select Boundaries 4 and 8 only.

3 Click the Go to Default View button in the Graphics toolbar.

4 In the Settings window for Pair, locate the Destination Boundaries section.

5 From the Selection list, choose Arch.

The destination boundary should be on a boundary modeled with the Shell interface.

S H E L L  ( S H E L L )

1 In the Model Builder window, under Component 1 (comp1) click Shell (shell).

2 In the Settings window for Shell, locate the Boundary Selection section.

3 From the Selection list, choose Arch.

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Shell (shell) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type d.

4 From the Offset definition list, choose Relative offset.

5 In the zreloffset text field, type -1.

Prescribed Displacement/Rotation 1
1 In the Physics toolbar, click Edges and choose Prescribed Displacement/Rotation.

2 Select Edges 1 and 7 only.

3 In the Settings window for Prescribed Displacement/Rotation, locate the 
Prescribed Displacement section.

4 Select the Prescribed in x direction check box.

5 Select the Prescribed in z direction check box.

6 Locate the Prescribed Rotation section. From the By list, choose Rotation.

Name Expression Unit Description

disp_block aveop1(-w) m Block displacement

disp_arch aveop2(-w) m Arch displacement
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Symmetry 1
1 In the Physics toolbar, click Edges and choose Symmetry.

2 Select Edges 2, 3, 5, and 6 only.

Contact 1
1 In the Physics toolbar, in the Boundary section, click Pairs and choose Contact.

2 In the Settings window for Contact, locate the Pair Selection section.

3 Under Pairs, click Add.

4 In the Add dialog box, select Contact Pair 1 (p1) in the Pairs list.

5 Click OK.

6 In the Settings window for Contact, locate the Contact Method section.

7 From the Formulation list, choose Augmented Lagrangian.

8 Select the Source external to current physics check box.

The source boundary is in the Solid Mechanics interface.

S O L I D  M E C H A N I C S  ( S O L I D )

In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

Prescribed Displacement 1
1 In the Physics toolbar, click Edges and choose Prescribed Displacement.

2 Select Edges 13 and 19 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in x direction check box.

Symmetry 1
1 In the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 5 and 6 only.

Boundary Load 1
1 In the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundary 7 only.

3 In the Settings window for Boundary Load, locate the Force section.
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4 Specify the FA vector as

The dependent variable load will be created in the next step using a global equation.

5 Click the Show More Options button in the Model Builder toolbar.

6 In the Show More Options dialog box, in the tree, select the check box for the node 
Physics>Equation-Based Contributions.

7 Click OK.

Global Equations 1
1 In the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Global Equations section.

3 In the table, enter the following settings:

4 Locate the Units section. Click Select Source Term Quantity.

5 In the Physical Quantity dialog box, type displacement in the text field.

6 Click Filter.

7 In the tree, select General>Displacement (m).

8 Click OK.

Add a small spring stiffness to the block to stabilize the model during the initial step.

Spring Foundation 1
1 In the Physics toolbar, click Domains and choose Spring Foundation.

2 In the Settings window for Spring Foundation, locate the Domain Selection section.

3 From the Selection list, choose Block.

4 Locate the Spring section. In the kV text field, type 1e3*(para<0.01).

0 x

0 y

load*F_ref z

Name f(u,ut,utt,
t) (1)

Initial value 
(u_0) (1)

Initial value 
(u_t0) (1/s)

Description

load disp_bl
ock-
para*
max_dis
p

0 0
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M E S H  1

Mapped 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Mapped.

2 In the Settings window for Mapped, locate the Boundary Selection section.

3 From the Selection list, choose Arch.

Distribution 1
1 Right-click Mapped 1 and choose Distribution.

2 Select Edges 2 and 5 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type n_elem_arch.

Mapped 2
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Mapped.

2 Select Boundary 5 only.

Distribution 1
1 Right-click Mapped 2 and choose Distribution.

2 Select Edges 10 and 17 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type n_elem_block.

Distribution 2
1 In the Model Builder window, right-click Mapped 2 and choose Distribution.

2 Select Edges 9 and 20 only.

Swept 1
1 In the Model Builder window, right-click Mesh 1 and choose Swept.

2 In the Settings window for Mesh, click Build All.
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3 Click the Zoom Extents button in the Graphics toolbar.

S T U D Y  1

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study Extensions section.

3 Select the Auxiliary sweep check box.

4 Click Add.

5 In the table, enter the following settings:

Solution 1 (sol1)
In the Study toolbar, click Show Default Solver.

Stationary Solver 1
1 In the Model Builder window, expand the Solution 1 (sol1) node, then click 

Stationary Solver 1.

2 In the Settings window for Stationary Solver, locate the General section.

3 In the Relative tolerance text field, type 0.0005.

Parameter name Parameter value list Parameter unit

para (Load parameter) range(0,0.05,1)
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State variable load (comp1.ODE1)
1 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Dependent Variables 1 node, then click 
State variable load (comp1.ODE1).

2 In the Settings window for State, locate the Scaling section.

3 From the Method list, choose Manual.

Segregated 1
In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 (sol1)>

Stationary Solver 1 node.

Shell
1 In the Model Builder window, expand the Segregated 1 node, then click Shell.

2 In the Settings window for Segregated Step, locate the General section.

3 Under Variables, click Add.

4 In the Add dialog box, select State variable load (comp1.ODE1) in the Variables list.

5 Click OK.

Solid Mechanics
1 In the Model Builder window, right-click Solid Mechanics and choose Delete.

Structural mechanics interfaces should be solved in a single segregated step.

2 In the Study toolbar, click Compute.

R E S U L T S

Surface 2
1 In the Model Builder window, expand the Stress (shell) node.

2 Right-click Results>Stress (shell)>Surface 1 and choose Duplicate.

3 In the Settings window for Surface, locate the Data section.

4 From the Dataset list, choose Study 1/Solution 1 (sol1).

5 Locate the Expression section. In the Expression text field, type solid.mises.

6 Click to expand the Inherit Style section. From the Plot list, choose Surface 1.

7 In the Stress (shell) toolbar, click Plot.

8 Click the Show Grid button in the Graphics toolbar.

9 Click the Zoom Extents button in the Graphics toolbar.
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Contact (shell)
1 In the Model Builder window, click Contact (shell).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Parameter value (para) list, choose 0.4.

Contact 1, Pressure
1 In the Model Builder window, expand the Contact (shell) node, then click Contact 1,

Pressure.

2 In the Settings window for Arrow Surface, locate the Coloring and Style section.

3 Select the Scale factor check box.

4 In the associated text field, type 5e-10.

Gray Surfaces
In the Model Builder window, right-click Gray Surfaces and choose Enable.

Selection 1
1 In the Model Builder window, expand the Gray Surfaces node.

2 Right-click Gray Surfaces and choose Selection.

3 Select Boundary 1 only.

4 In the Settings window for Selection, locate the Selection section.

5 From the Selection list, choose Arch.

6 In the Contact (shell) toolbar, click Plot.

Animation 1
1 In the Contact (shell) toolbar, click Animation and choose Player.

2 In the Settings window for Animation, locate the Frames section.

3 From the Frame selection list, choose All.

4 Right-click Animation 1 and choose Play.

1D Plot Group 7
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Load vs Deflection in the Label text 
field.

Global 1
1 Right-click Load vs Deflection and choose Global.

2 In the Settings window for Global, locate the y-Axis Data section.
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3 In the table, enter the following settings:

4 Locate the x-Axis Data section. From the Parameter list, choose Expression.

5 In the Expression text field, type load.

6 Click to expand the Coloring and Style section. Find the Line markers subsection. From 
the Marker list, choose Cycle.

Load vs Deflection
1 In the Model Builder window, click Load vs Deflection.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the Flip the x- and y-axes check box.

4 Locate the Legend section. From the Position list, choose Upper left.

5 Locate the Plot Settings section. Select the x-axis label check box.

6 In the associated text field, type Deflection (mm).

7 In the Load vs Deflection toolbar, click Plot.

1D Plot Group 8
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Deformation in the Label text field.

3 Locate the Data section. From the Parameter selection (para) list, choose Manual.

4 In the Parameter indices (1-21) text field, type range(1,4,21).

5 Click to expand the Title section. From the Title type list, choose None.

Line Graph 1
1 Right-click Deformation and choose Line Graph.

2 Select Edges 2 and 5 only.

3 In the Settings window for Line Graph, locate the y-Axis Data section.

4 In the Expression text field, type z.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type x.

7 Click to expand the Coloring and Style section. In the Width text field, type 2.

Expression Unit Description

disp_block mm Block displacement

disp_arch mm Arch displacement
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Line Graph 2
1 Right-click Line Graph 1 and choose Duplicate.

2 In the Settings window for Line Graph, locate the Selection section.

3 Select the Activate selection toggle button.

4 Select Edges 9, 10, 14, 17, and 20 only.

5 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Dashed.

6 From the Color list, choose Cycle (reset).

Line Graph 1
1 In the Model Builder window, click Line Graph 1.

2 In the Settings window for Line Graph, click to expand the Legends section.

3 Select the Show legends check box.

4 Find the Include subsection. In the Prefix text field, type para = .

5 In the Deformation toolbar, click Plot.

Stress (shell)
Click the Zoom Extents button in the Graphics toolbar.
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Introduction

In the following example you build and solve a simple 3D beam model using the 3D Beam 
interface. This example calculates the deformation, section forces, and stresses in a 
cantilever beam, and compares the results with analytical solutions. The first few natural 
frequencies are also computed. The purpose of the example is twofold: It is a verification 
of the functionality of the beam element in COMSOL Multiphysics, and it explains in 
detail how to give input data and interpret results for a nontrivial cross section. 

This example also illustrates how to use the Beam Cross Section interface to compute the 
beam section properties and evaluate the stress distribution within the beam cross section.

Model Definition

The physical geometry is displayed in Figure 1. The finite element idealization consists 
of a single line.

Figure 1: The physical geometry.

The cross section with its local coordinate system is shown in Figure 2. The height of the 
cross section is 50 mm and the width is 25 mm. The thickness of the flanges is 6 mm, while 
the web has a thickness of 5 mm. Note that the global y direction corresponds to the local 
negative z direction, and the global z direction corresponds to the local y direction. In the 
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following, uppercase subscripts are used for the global directions and lowercase subscripts 
for the local directions.

Figure 2: The beam cross section with local direction indicated.

For a detailed analysis, a case where the corners between the flange and the web are 
rounded are also studied. A 4 mm radius fillet is used at the external corner and a 2 mm 
radius fillet at the internal corner. This geometry is considered using the Beam Cross Section 

interface.

G E O M E T R Y

• Beam length, L = 1 m

• Cross-section area A = 4.90·10-4 m2 (from the cross section library)

• Area moment of inertia in stiff direction, Izz = 1.69·10-7 m4

• Area moment of inertia in weak direction, Iyy = 2.77·10-8 m4

• Torsional constant, J = 5.18 ·10-9 m4

• Position of the shear center (SC) with respect to the area center of gravity (CG), 
ez = 0.0148 m

• Torsional section modulus Wt = 8.64·10-7 m3

• Ratio between maximum and average shear stress for shear in y direction, μy=2.44
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• Ratio between maximum and average shear stress for shear in z direction, μz=2.38

• Locations for axial stress evaluation are positioned at the outermost corners of the 
profile at the points 
(y1, z1)=(−0.025, −0.0164) 
(y2, z2)=(0.025, −0.0164)
(y3, z3)=(0.025, 0.0086),
(y4, z4)=(−0.025, 0.0086)
measured in the local coordinate system. The indices of the coordinates are point 
identifiers.

The values above are based on the idealized geometry with sharp corners. In a separate 
study you compute the section properties including fillets, using the Beam Cross Section 
interface.

M A T E R I A L

• Young’s modulus, E = 210 GPa

• Poisson’s ratio, ν = 0.25

• Mass density, ρ = 7800 kg/m3

C O N S T R A I N T S

One end of the beam is fixed.

L O A D S

In the first load case, the beam is subjected to three forces and one twisting moment at the 
tip. The values are:

• Axial force FX = 10 kN

• Transverse forces FY = 50 N and FZ = 100 N 

• Twisting moment MX = −10 Nm

In the second load case, the beam is subjected to a gravity load in the negative Z direction.

The third case is an eigenfrequency analysis.

Results and Discussion

The analytical solutions for a slender cantilever beam with loads at the tip are summarized 
below. The displacements are
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The stresses from the axial force, shear force, and torsion are constant along the beam, 
while the bending moment and bending stresses, are largest at the fixed end. The axial 
stresses at the fixed end caused by the different loads are computed as

 (1)

 (2)

δX δx
FxL
EA
----------

FXL
EA

-----------

10000 N 1 m⋅
2 1011 Pa 4.90 10 4–  m2⋅ ⋅ ⋅
-------------------------------------------------------------------- 1.02 10 4–  m⋅

= = = =

=

δZ δy
FyL3

3EIzz
---------------

FZL3

3EIzz
---------------

100 N 1 m( )3⋅
3 2 1011 Pa 1.69 10 7–  m4⋅ ⋅ ⋅ ⋅
-------------------------------------------------------------------------- 9.86 10⋅ 4–  m

= = = =

=

δY δ– z
F– zL3

3EIyy
----------------

FYL3

3EIyy
----------------

50 N 1 m( )3⋅
3 2 1011 Pa 2.77 10 8–  m4⋅ ⋅ ⋅ ⋅
---------------------------------------------------------------------------- 3.01 10 3–  m⋅

= = = =

=

θX θx
MxL
GJ

------------
MXL

GJ
--------------

10–  Nm 1 m⋅
2 10⋅ 11 Pa
2 1 0.25+( )
---------------------------- 5.18 10 9–  m4⋅ ⋅

---------------------------------------------------------------------- 2– .41 10 2–  rad⋅

= = = =

=

σx Fx,
Fx
A
------

FX
A

------- 10000 N
4.90 10 4–  m2⋅
------------------------------------ 2.04 107 Pa⋅= = = =

σx Mz,
M– zy
Izz

--------------
F– yLy
Izz

-----------------
F– ZLy
Izz

------------------

100 N– 1 m⋅
1.69 10 7–  m4⋅
------------------------------------ y⋅ 5.92– 108 Pa

m
------ y⋅⋅

= = = =

=

σx My,
Myz
Iyy

-----------
F– zLz
Iyy

-----------------
FYLz

Iyy
---------------

50 N 1 m⋅

2.77 10 8–  m4⋅
------------------------------------ y⋅ 1.81 109 Pa

m
------ z⋅⋅

= = = =

=
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In Table 1 the stresses in the stress evaluation points are summarized after insertion of the 
local coordinates y and z in Equation 1 and Equation 2.

Due to the shear forces and twisting moment there are also shear stresses in the section. 
In general, the shear stresses have a complex distribution, which depends strongly on the 
geometry of the actual cross section. The peak values of the shear stress contributions from 
shear forces are

The peak value of the shear stress created by torsion is

Since the general cross-section data used for the analysis cannot predict the exact locations 
of the peak stresses from each type of action, a conservative scheme for combining the 
stresses is used in COMSOL Multiphysics. If the computed results exceeds allowable 
values somewhere in a beam structure, this may be due to this conservatism. You must 
then check the details, using information about the exact type of cross section and 
combination of loadings. This can be done using the Beam Cross Section interface.

The conservative maximum shear stresses are created by adding the maximum shear stress 
from torsion to the maximum shear stresses from shear force:

TABLE 1:  AXIAL STRESSES IN MPA AT EVALUATION POINTS.

Point Stress from 
Fx (=FX)

Stress from 
Fy (=-FZ)

Stress from 
Fz (=FY)

Total bending 
stress

Total axial 
stress

1 20.4 14.8 -29.7 -14.9 5.5

2 20.4 -14.8 -29.7 -44.5 -24.1

3 20.4 -14.8 15.6 0.8 21.2

4 20.4 14.8 15.6 30.4 50.8

τsy max, μyτsy mean, μy
Fy
A
------ μy

FZ
A
-------= = = =

2.44 100 N
4.90 10 4–  m2⋅
------------------------------------⋅ 2.44 2.04 105 Pa 4.98=⋅ ⋅= 105 Pa⋅

τsz max, μzτsz mean, μz
Fz
A
------ μz

F– Y
A

----------= = = =

2.38 50–  N
4.90 10 4–  m2⋅
------------------------------------⋅ 2– .38 1.02 105 Pa⋅ ⋅ 2– .43 105 Pa⋅= =

τt max,
Mx
Wt

-----------
MX
Wt

------------ 10 Nm
8.64 10 7–  m3⋅
------------------------------------ 11.6 106 Pa⋅= = = =
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A conservative equivalent stress is then computed as 

The maximum normal stress, σmax, is taken as the highest absolute value in the any of the 
stress evaluation points (the rightmost column in Table 1).

The COMSOL results for the first load case give 58.6 MPa von Mises stress at the 
constrained end of the beam which is in total agreement with the analytical solution. 
Actually, the results would have been the same with any mesh density, because the 
formulation of the beam elements in COMSOL contains the exact solutions to beam 
problems with only point loads.

In the second load case there is an evenly distributed gravity load. Since the resultant of a 
gravity load acts through the mass center of the beam, it does not just cause pure bending 
but also a twist of the beam. The reason is that in order to cause pure bending, a transverse 
force must act through the shear center of the section. In COMSOL Multiphysics this 
effect is automatically accounted for when you apply an edge load. An additional edge 
moment is created, using the ez (or, depending on load direction, ey) cross section 
property. The analytical solution to the tip deflections in the self-weight problem is

τxz max, τsz max, τt max, 11.8 106 Pa⋅=

τxy max, τsy max, τt max, 12.1 106 Pa⋅=+=

+=

σmises σmax
2 3τxy max,

2 3τxz max,
2

+ + 58.6 106 Pa⋅= =

δZ δ– y
q– yL4

8EIzz
----------------

qZL4

8EIzz
--------------- ρgA– L4

8EIzz
---------------------

8000 kg

m3
------- 9.81 m

s2
----- 4.90 10 4–  m2⋅ ⋅ ⋅– 1 m( )4⋅

8 2 1011 Pa 1.69 10 7–  m4⋅ ⋅ ⋅ ⋅
----------------------------------------------------------------------------------------------------------- 1– .42 10⋅ 4–  m

= = = = =

=

θx
mxL2

2GJ
---------------

qyezL2

2GJ
------------------

ρgAezL2

2GJ
-----------------------

8000 kg

m3
------- 9.81 m

s2
----- 4.90 10 4–  m2 0.0148 m⋅ ⋅ ⋅ ⋅– 1 m( )2⋅

2 2 10⋅ 11 Pa
2 1 0.25+( )
----------------------------- 5.18 10 9–  m4⋅ ⋅ ⋅

----------------------------------------------------------------------------------------------------------------------------------------- 6.– 87 10 2–  rad⋅

= = = =

=
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Also for this case, the COMSOL Multiphysics solution captures the analytical solution 
exactly. Note, however, that in this case the resolution of the stresses is mesh dependent.

When using a shear center offset as in this example, you must bear in mind that the beam 
theory assumes that torsional moments and shear forces are applied at the shear center, 
while axial forces and bending moments are referred to the center of gravity. Thus, when 
point loads are applied it may be necessary to account for this offset.

The mode shapes and the natural frequencies of the beam are of three types: tension, 
torsion, and bending. The analytical expressions for the natural frequencies of the different 
types are:

 (3)

 (4)

 (5)

In Table 2 the computed results are compared with the results from Equation 3, 
Equation 4, and Equation 5. The agreement is generally very good. The largest difference 
occurs in Mode 12. This is the fifth order torsional mode, for which the mesh is not 
sufficient for a high accuracy resolution.

TABLE 2:  COMPARISON BETWEEN ANALYTICAL AND COMPUTED NATURAL FREQUENCIES.

Mode 
number

Mode type Analytical 
frequency (Hz)

COMSOL result (Hz)

1 First y bending 21.02 21.04

2 First z bending 51.96 51.96

3 First torsion 128.3 128.4

4 Second y bending 131.7 131.8

5 Second z bending 325.5 325.7

6 Third y bending 368.8 369.2

7 Second torsion 384.9 388.4

fn tension,
2n 1+

4L
----------------- E

ρ
----=

fn torsion,
2n 1+

4L
----------------- GJ

ρ Iyy Izz+( )
-----------------------------=

fn bending,
kn

2π
------ EI

ρAL4
---------------

kn( ) kn( )coshcos 1

  kn 3.516, 22.03, 61.70, 120.9, 200.0, ...=

–

=

=
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When the computed section forces at the constrained end of the beam are fed into the 
Beam Cross Section interface, Figure 3 below shows the von Mises stress distribution within 
the cross section. One can notice that the maximum stress value is about 66 MPa which is 
slightly higher than the value computed in the beam interface (58 MPa). The stress 
computed with analytical cross section data is slightly underestimated. The reason is that 
the geometric representation used includes the fillets. If exactly the same cross section data 
are used, the stresses computed by the Beam interface are always conservative.

In Figure 4 to Figure 6 examples are shown of how the stress distributions from the 
individual section forces are displayed in the Beam Cross Section interface.

8 Third torsion 641.5 658.1

9 Fourth y bending 722.8 724.1

10 Fourth torsion 898.1 943.7

11 Third z bending 911.8 912.0

12 Fifth torsion 1155 1251

13 Fifth y bending 1196 1199

14 First axial 1250 1251

TABLE 2:  COMPARISON BETWEEN ANALYTICAL AND COMPUTED NATURAL FREQUENCIES.

Mode 
number

Mode type Analytical 
frequency (Hz)

COMSOL result (Hz)
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Figure 3: von Mises stress distribution at the fixed end (x = 0).

Figure 4: Plot of stresses from a bending moment. The center of gravity is highlighted.
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Figure 5: Plot of stresses from shear force. The shear center is highlighted.

Figure 6: Plot of shear stresses from torsion.
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Table 3 lists the beam cross section data computed using the Beam Cross Section interface 
and a geometry with fillets. There are significant differences in the maximum shear stress 
factor and torsional section modulus values. The stress concentration around the round 
corner explains these differences.

If these cross section data are used in the Beam interface, the maximum von Mises stress 
is 73 MPa, which is slightly above the real value.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/channel_beam

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Beam (beam).

3 Click Add.

4 Click Study.

TABLE 3:  COMPUTED BEAM CROSS SECTION DATA.

Parameter Value

Area 4.8485e-4 m2

First moment of inertia 1.6556e-7 m4

Distance to shear center in the first principal direction 0.014611 m

Second moment of inertia 2.7252e-8 m4

Distance to shear center in the second principal direction -9.5565e-9 m

Torsional constant 4.79754e-9 m4

Torsional section modulus 5.6922e-7 m3

Max shear stress factor in the second principal direction 3.0504

Max shear stress factor in the first principal direction 3.6711
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5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Load Group 1
1 In the Model Builder window, right-click Global Definitions and choose 

Load and Constraint Groups>Load Group.

2 In the Settings window for Load Group, type edge in the Parameter name text field.

Load Group 2
1 In the Model Builder window, right-click Load and Constraint Groups and choose 

Load Group.

2 In the Settings window for Load Group, type point in the Parameter name text field.

G E O M E T R Y  1

Polygon 1 (pol1)
1 In the Geometry toolbar, click More Primitives and choose Polygon.

Name Expression Value Description

h1 25[mm] 0.025 m Flange width

h2 50[mm] 0.05 m Section height

t1 5[mm] 0.005 m Web thickness

t2 6[mm] 0.006 m Flange thickness

L 1[m] 1 m Beam length

Eb 2e11[Pa] 2E11 Pa Young's modulus

nub 0.25 0.25 Poisson's ratio

rhob 8000[kg/m^3] 8000 kg/m³ Density

FX 10e3[N] 10000 N Force in X direction

FY 50[N] 50 N Force in Y direction

FZ 100[N] 100 N Force in Z direction

MX -10[N*m] -10 N·m Moment in X direction
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2 In the Settings window for Polygon, locate the Coordinates section.

3 In the table, enter the following settings:

4 Click Build All Objects.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

D E F I N I T I O N S

Define the cross section parameters to compute the analytical values of the displacement 
and section forces of the beam.

Variables 1
1 In the Model Builder window, under Component 1 (comp1) right-click Definitions and 

choose Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

x (m) y (m) z (m)

0 0 0

1 0 0

Property Variable Value Unit Property group

Young’s modulus E Eb Pa Basic

Poisson’s ratio nu nub 1 Basic

Density rho rhob kg/m³ Basic

Name Expression Unit Description

Gb Eb/(2*(1+nub)) Pa Shear Modulus

A 4.9e-4[m^2] m² Cross section area

Iyy 2.77e-8[m^4] m^4 Area moment of inertia, y 
component

Izz 1.69e-7[m^4] m^4 Area moment of inertia, z 
component
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Define an analytic function to evaluate the bending stress at different locations of the cross 
section.

Analytic 1 (an1)
1 In the Home toolbar, click Functions and choose Global>Analytic.

2 In the Settings window for Analytic, type sigmabx in the Function name text field.

3 Locate the Definition section. In the Expression text field, type -FZ*L*y/comp1.Izz+
FY*L*z/comp1.Iyy.

4 In the Arguments text field, type y, z.

Jbeam 5.18e-9[m^4] m^4 Torsion constant

Wt 8.64e-7[m^3] m³ Torsion section modulus

ey 0[m] m Shear center relative to 
centroid, y-coordinate

ez 0.0148[m] m Shear center relative to 
centroid, z-coordinate

muy 2.44 Max shear stress factor in local 
y direction

muz 2.38 Maximum shear stress factor in 
local z direction

y1 -0.025[m] m Evaluation point 1, local y-
coordinate

z1 -0.0164[m] m Evaluation point 1, local z-
coordinate

y2 0.025[m] m Evaluation point 2, local y-
coordinate

z2 -0.0164[m] m Evaluation point 2, local z-
coordinate

y3 0.025[m] m Evaluation point 3, local y-
coordinate

z3 0.0086[m] m Evaluation point 3, local z-
coordinate

y4 -0.025[m] m Evaluation point 4, local y-
coordinate

z4 0.0086[m] m Evaluation point 4, local z-
coordinate

Name Expression Unit Description
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5 Locate the Plot Parameters section. In the table, enter the following settings:

6 Locate the Units section. In the Arguments text field, type m, m.

7 In the Function text field, type N/m^2.

8 Right-click Analytic 1 (an1) and choose Rename.

9 In the Rename Analytic dialog box, type sigmabx in the New label text field.

10 Click OK.

Define the variables for analytical values of the displacements, rotations and stresses.

Variables 2
1 In the Model Builder window, right-click Definitions and choose Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

Argument Lower limit Upper limit

y -h2/2 h2/2

z -h1/2 h1/2

Name Expression Unit Description

deltaX FX*L/(Eb*A) m X 
displacement

deltaY FY*L^3/(3*Eb*Iyy) m Y 
displacement

deltaZ FZ*L^3/(3*Eb*Izz) m Z 
displacement

thetaX MX*L/(Gb*Jbeam) Twist

sigmax_Fx FX/A N/m² Stress due to 
axial load

tausy_max muy*FZ/A N/m² Maximum shear 
stress due y 
force

tausz_max -muz*FY/A N/m² Maximum shear 
stress due to 
z force

taut_max abs(MX)/Wt N/m² Shear stress 
due to 
torsion

tauxz_max abs(tausz_max)+taut_max N/m² Maximum shear 
stress, z 
component
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B E A M  ( B E A M )

Cross Section Data 1
1 In the Model Builder window, under Component 1 (comp1)>Beam (beam) click 

Cross Section Data 1.

2 In the Settings window for Cross Section Data, locate the Cross Section Definition section.

3 From the list, choose Common sections.

4 From the Section type list, choose U-profile.

5 In the hy text field, type h2.

6 In the hz text field, type h1.

7 In the ty text field, type t2.

8 In the tz text field, type t1.

tauxy_max abs(tausy_max)+taut_max N/m² Maximum shear 
stress, y 
component

sigx1 sigmax_Fx+sigmabx(y1,z1) N/m² Normal stress 
at point 1

sigx2 sigmax_Fx+sigmabx(y2,z2) N/m² Normal stress 
at point 2

sigx3 sigmax_Fx+sigmabx(y3,z3) N/m² Normal stress 
at point 3

sigx4 sigmax_Fx+sigmabx(y4,z4) N/m² Normal stress 
at point 4

sigx_max max(max(max(sigx1,sigx2),
sigx3),sigx4)

N/m² Maximum 
normal stress 
in cross 
section

sig_mises sqrt(sigx_max^2+3*tauxy_max^2+
3*tauxz_max^2)

N/m² Maximum von 
Mises stress

deltaZ_g -rhob*g_const*A*L^4/(8*Eb*Izz) m Z 
displacement 
due to 
gravity load

thetaX_g rhob*g_const*A*ez*L^2/(2*Gb*
Jbeam)

Twist due to 
gravity load

Name Expression Unit Description
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Section Orientation 1
1 In the Model Builder window, expand the Cross Section Data 1 node, then click 

Section Orientation 1.

2 In the Settings window for Section Orientation, locate the Section Orientation section.

3 From the Orientation method list, choose Orientation vector.

4 Specify the V vector as

Gravity 1
1 In the Physics toolbar, click Edges and choose Gravity.

2 Select Edge 1 only.

3 In the Physics toolbar, click Load Group and choose Load Group 1.

Fixed Constraint 1
1 In the Physics toolbar, click Points and choose Fixed Constraint.

2 Select Point 1 only.

Point Load 1
1 In the Physics toolbar, click Points and choose Point Load.

2 Select Point 2 only.

3 In the Settings window for Point Load, locate the Force section.

4 Specify the FP vector as

5 Locate the Moment section. Specify the MP vector as

6 In the Physics toolbar, click Load Group and choose Load Group 2.

0 X

0 Y

1 Z

FX x

FY y

FZ z

MX x

0 y

0 z
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S T U D Y  1

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study Extensions section.

3 Select the Define load cases check box.

4 Click Add twice to add two rows to the load case table.

5 In the table, enter the following settings:

6 In the Model Builder window, right-click Study 1 and choose Rename.

7 In the Rename Study dialog box, type Stationary Study: Beam in the New label text 
field.

8 Click OK.

9 In the Home toolbar, click Compute.

R E S U L T S

Stress (beam)
The first default plot shows the von Mises stress distribution for the second load case. You 
can switch to the first load case to evaluate von Mises stress distribution caused by the 
point load.

1 In the Settings window for 3D Plot Group, locate the Data section.

2 From the Load case list, choose Point load.

3 In the Stress (beam) toolbar, click Plot.

The following steps illustrate how to evaluate the displacement and stress values in specific 
tables.

Point Evaluation 1
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, type Case1: Displacement/Rotation in 
the Label text field.

3 Locate the Data section. From the Parameter selection (Load case) list, choose First.

Load case edge Weight point Weight

Point load 1.0 √ 1.0

Edge load √ 1.0 1.0
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4 Select Point 2 only.

5 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Displacement>Displacement field - m>u -

Displacement field, x component.

6 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>deltaX - X displacement - m.

7 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Displacement>Displacement field - m>v -

Displacement field, y component.

8 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>deltaY - Y displacement - m.

9 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Displacement>Displacement field - m>w -

Displacement field, z component.

10 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>deltaZ - Z displacement - m.

11 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Displacement>Rotation field - rad>thx -

Rotation field, X component.

12 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>thetaX - Twist.

13 Locate the Expressions section. In the table, enter the following settings:

14 Click Evaluate.

Table 1
1 In the Model Builder window, expand the Results>Tables node, then click Table 1.

Expression Unit Description

u m delta_x computed

deltaX m delta_x analytical

v m delta_y computed

deltaY m delta_y analytical

w m delta_z computed

deltaZ m delta_z analytical

thx rad theta_x computed

thetaX 1 theta_x analytical
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2 In the Settings window for Table, type Case1: Displacement/Rotation in the Label 
text field.

Point Evaluation 2
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, type Case2: Displacement/Rotation in 
the Label text field.

3 Select Point 2 only.

4 Locate the Data section. From the Parameter selection (Load case) list, choose Last.

5 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Displacement>Displacement field - m>w -

Displacement field, z component.

6 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>deltaZ_g -

Z displacement due to gravity load - m.

7 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Displacement>Rotation field - rad>thx -

Rotation field, X component.

8 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>thetaX_g -

Twist due to gravity load.

9 Locate the Expressions section. In the table, enter the following settings:

10 Click Evaluate.

Table 2
1 In the Model Builder window, under Results>Tables click Table 2.

2 In the Settings window for Table, type Case2: Displacement/Rotation in the Label 
text field.

Point Evaluation 3
1 In the Results toolbar, click Point Evaluation.

Expression Unit Description

w m delta_z computed

deltaZ_g m delta_z analytical

thx rad theta_x computed

thetaX_g 1 theta_x analytical
21 |  C H A N N E L  B E A M



2 Select Point 2 only.

3 In the Settings window for Point Evaluation, locate the Data section.

4 From the Parameter selection (Load case) list, choose First.

5 In the Label text field, type Axial Stress from Fx.

6 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>

Stress variables at first evaluation point>beam.s1 -

Normal stress at first evaluation point - N/m².

7 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>

Stress variables at second evaluation point>beam.s2 -

Normal stress at second evaluation point - N/m².

8 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>

Stress variables at third evaluation point>beam.s3 -

Normal stress at third evaluation point - N/m².

9 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>

Stress variables at fourth evaluation point>beam.s4 -

Normal stress at fourth evaluation point - N/m².

10 Locate the Expressions section. In the table, enter the following settings:

11 Click Evaluate.

Table 3
1 In the Model Builder window, under Results>Tables click Table 3.

2 In the Settings window for Table, type Normal Stress from Fx in the Label text field.

Point Evaluation 4
1 In the Results toolbar, click Point Evaluation.

Expression Unit Description

beam.s1 MPa first point

beam.s2 MPa second point

beam.s3 MPa third point

beam.s4 MPa fourth point
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2 In the Settings window for Point Evaluation, type Total Bending Stress in the Label 
text field.

3 Locate the Data section. From the Parameter selection (Load case) list, choose First.

4 Select Point 1 only.

5 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>

Stress variables at first evaluation point>beam.sb1 -

Bending stress at first evaluation point - N/m².

6 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Functions>sigmabx(y, z) - sigmabx.

7 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>

Stress variables at second evaluation point>beam.sb2 -

Bending stress at second evaluation point - N/m².

8 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Functions>sigmabx(y, z) - sigmabx.

9 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>

Stress variables at third evaluation point>beam.sb3 -

Bending stress at third evaluation point - N/m².

10 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Functions>sigmabx(y, z) - sigmabx.

11 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>

Stress variables at fourth evaluation point>beam.sb4 -

Bending stress at fourth evaluation point - N/m².

12 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Functions>sigmabx(y, z) - sigmabx.

13 Locate the Expressions section. In the table, enter the following settings:

Expression Unit Description

beam.sb1 MPa first point, computed

sigmabx(y1, z1) MPa first point, analytical

beam.sb2 MPa second point, computed

sigmabx(y2, z2) MPa second point, analytical

beam.sb3 MPa third point, computed
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14 Click Evaluate.

Table 4
1 In the Model Builder window, under Results>Tables click Table 4.

2 In the Settings window for Table, type Total Bending Stress in the Label text field.

Point Evaluation 5
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, type Shear Stress in the Label text field.

3 Locate the Data section. From the Parameter selection (Load case) list, choose First.

4 Select Point 1 only.

5 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>beam.tsymax -

Max shear stress from shear force, y direction - N/m².

6 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>tausy_max -

Maximum shear stress due y force - N/m².

7 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>beam.tszmax -

Max shear stress from shear force, z direction - N/m².

8 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>tausz_max -

Maximum shear stress due to z force - N/m².

9 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>beam.ttmax -

Max torsional shear stress - N/m².

10 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>taut_max -

Shear stress due to torsion - N/m².

11 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>beam.txymax - Max shear stress,

y direction - N/m².

sigmabx(y3, z3) MPa third point, analytical

beam.sb4 MPa fourth point, computed

sigmabx(y4, z4) MPa fourth point, analytical

Expression Unit Description
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12 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>tauxy_max -

Maximum shear stress, y component - N/m².

13 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>beam.txzmax - Max shear stress,

z direction - N/m².

14 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>tauxz_max -

Maximum shear stress, z component - N/m².

15 Locate the Expressions section. In the table, enter the following settings:

16 Click Evaluate.

Table 5
1 In the Model Builder window, under Results>Tables click Table 5.

2 In the Settings window for Table, type Shear Stress in the Label text field.

Perform an eigenfrequency analysis.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

Expression Unit Description

beam.tsymax MPa Max shear stress from shear force, y direction 
(Computed)

tausy_max MPa Max shear stress from shear force, y direction 
(Analytical)

beam.tszmax MPa Max shear stress from shear force, z direction 
(Computed)

tausz_max MPa Max shear stress from shear force, z direction 
(Analytical)

beam.ttmax MPa Max torsional shear stress (Computed)

taut_max MPa Max torsional shear stress (Analytical)

beam.txymax MPa Max shear stress, y direction (Computed)

tauxy_max MPa Max shear stress, y direction (Analytical)

beam.txzmax MPa Max shear stress, z direction (Computed)

tauxz_max MPa Max shear stress, z direction (Analytical)
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3 Find the Studies subsection. In the Select Study tree, select General Studies>

Eigenfrequency.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

1 In the Model Builder window, right-click Study 2 and choose Rename.

2 In the Rename Study dialog box, type Eigenfrequency Study: Beam in the New label 
text field.

3 Click OK.

Step 1: Eigenfrequency
Before computing the study, increase the desired number of eigenfrequencies.

1 In the Settings window for Eigenfrequency, locate the Study Settings section.

2 Select the Desired number of eigenfrequencies check box.

3 In the associated text field, type 20.

4 In the Home toolbar, click Compute.

R E S U L T S

Mode Shape (beam)
1 In the Settings window for 3D Plot Group, locate the Data section.

2 From the Eigenfrequency (Hz) list, choose 51.956.

3 In the Mode Shape (beam) toolbar, click Plot.

The following steps illustrate how to use the Beam Cross Section interface to compute beam 
physical properties and evaluate stresses within a cross section.

Datasets
Start by evaluating the section forces at the fixed end of the beam. These values are needed 
to get an accurate stress distribution within the beam cross section. To make it possible to 
change this location we start by creating a Cut Point.

Cut Point 3D 1
1 In the Results toolbar, click Cut Point 3D.

2 In the Settings window for Cut Point 3D, locate the Point Data section.

3 In the X text field, type 0.

4 In the Y text field, type 0.
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5 In the Z text field, type 0.

Point Evaluation 6
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, type Section Forces in the Label text field.

3 Locate the Data section. From the Dataset list, choose Cut Point 3D 1.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Table 6
1 In the Model Builder window, under Results>Tables click Table 6.

2 In the Settings window for Table, type Section Forces in the Label text field.

A D D  C O M P O N E N T

In the Model Builder window, right-click the root node and choose Add Component>2D.

A D D  P H Y S I C S

1 In the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Structural Mechanics>Beam Cross Section (bcs).

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Study 1 and Study 2.

5 Click Add to Component 2 in the window toolbar.

6 In the Home toolbar, click Add Physics to close the Add Physics window.

R O O T

In the Model Builder window, click the root node.

Expression Unit Description

beam.Nxl N N

beam.Mzl N*m M1

beam.Tyl N T2

beam.Myl N*m M2

beam.Tzl N T1

beam.Mxl N*m Mt
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A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Beam (beam) interface.

5 Click Add Study in the window toolbar.

6 From the Home menu, choose Add Study.

C O M P O N E N T  2  ( C O M P 2 )

1 In the Model Builder window, collapse the Component 2 (comp2) node.

2 Right-click Study 3 and choose Rename.

3 In the Rename Study dialog box, type Stationary Study: Beam Cross Section in 
the New label text field.

4 Click OK.

Use the predefined Generic C-beam geometry part to draw the beam section geometry.

G E O M E T R Y  2

In the Model Builder window, under Component 2 (comp2) click Geometry 2.

P A R T  L I B R A R I E S

1 In the Home toolbar, click Windows and choose Part Libraries.

2 In the Part Libraries window, select Structural Mechanics Module>Beams>Generic>

C_beam_generic in the tree.

3 Click Add to Geometry.

G E O M E T R Y  2

Generic C-beam 1 (pi1)
1 In the Model Builder window, under Component 2 (comp2)>Geometry 2 click Generic C-

beam 1 (pi1).

2 In the Settings window for Part Instance, locate the Input Parameters section.
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3 In the table, enter the following settings:

Form Union (fin)
1 In the Model Builder window, click Form Union (fin).

2 Click Build Selected.

3 Click the Zoom Extents button in the Graphics toolbar.

B E A M  C R O S S  S E C T I O N  ( B C S )

Input the section force data evaluated previously from the Beam into Beam Cross Section. 
To automate this process of transferring the section forces at any arbitrary location, create 
a model method first.

1 In the Model Builder window, under Component 2 (comp2) click Beam Cross Section (bcs).

N E W  M E T H O D

1 In the Developer toolbar, click New Method.

2 In the New Method dialog box, type EvaluateSectionForces in the Name text field.

3 Click OK.

A P P L I C A T I O N  B U I L D E R

1 Copy the following code into the EvaluateSectionForces window:

double Len = model.param().evaluate("L");
String xPos = xp;
try {
  double xP = Double.valueOf(xp);
  if (xP < 0) {
    alert("Evaluation point out of range. Using the root of the beam for 
evaluation.", "Evaluation point out of range warning");
    xPos  = "0"
  }

Name Expression Value Description

d h2 0.05 m Beam height

b h1 0.025 m Flange width

tw t1 0.005 m Web thickness

tf t2 0.006 m Flange thickness

r1 2[mm] 0.002 m Web fillet radius

r2 0 0 mm Flange fillet radius

slope 0 0 Flange slope [%]

u 0 0 mm Flange thickness evaluation location
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  if (xP > Len) {
    alert("Evaluation point out of range. Using the tip of the beam for 
evaluation.", "Evaluation point out of range warning");
    xPos = "L";
  }
} catch (Exception e) {
  
}

with(model.result().dataset("cpt1"));
  set("pointx", xPos);
endwith();

double[][] SecForce = model.result().numerical("pev6").getReal();
with(model.component("comp2").physics("bcs").prop("UserInput"));
  set("N", Double.toString(SecForce[0][0]));
  set("M1", Double.toString(SecForce[1][0]));
  set("T2", Double.toString(SecForce[2][0]));
  set("M2", Double.toString(SecForce[3][0]));
  set("T1", Double.toString(SecForce[4][0]));
  set("Mt", Double.toString(SecForce[5][0]));
endwith();

2 In the Application Builder window, under Methods click EvaluateSectionForces.

3 In the Settings window for Method, locate the Inputs and Output section.

4 Click Add.

5 Find the Inputs subsection. In the table, enter the following settings:

M E T H O D S

EvaluateSectionForces
In the Home toolbar, click Model Builder to switch to the main desktop.

G L O B A L  D E F I N I T I O N S

EvaluateSectionForces 1
1 In the Home toolbar, click Method Call and choose EvaluateSectionForces.

Run the method EvaluateSectionForces to transfer the cross section forces in Beam Cross 

Section interface.

2 Click Run Method Call and choose EvaluateSectionForces 1.

Name Type Default Description Unit

xp String 0
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S T A T I O N A R Y  S T U D Y :  B E A M  C R O S S  S E C T I O N

Click Compute.

Evaluate the beam physical properties required for the Beam interface.

R E S U L T S

Section Properties
In the Model Builder window, right-click Section Properties and choose Evaluate>New Table.

Table 7
1 In the Model Builder window, under Results>Tables click Table 7.

2 In the Settings window for Table, type Section Properties in the Label text field.

B E A M  ( B E A M )

In the Model Builder window, under Component 1 (comp1) click Beam (beam).

Cross Section Data 2
1 In the Physics toolbar, click Edges and choose Cross Section Data.

2 Select Edge 1 only.

3 In the Settings window for Cross Section Data, locate the Basic Section Properties section.

4 In the A text field, type comp2.bcs.A.

5 In the Izz text field, type comp2.bcs.I1.

6 In the ez text field, type comp2.bcs.ei1.

7 In the Iyy text field, type comp2.bcs.I2.

8 In the ey text field, type comp2.bcs.ei2.

9 In the J text field, type comp2.bcs.J.

10 Click to expand the Stress Evaluation Properties section. In the hy text field, type 
comp2.bcs.h2.

11 In the hz text field, type comp2.bcs.h1.

12 In the wt text field, type comp2.bcs.Wt.

13 In the μy text field, type comp2.bcs.mu2.

14 In the μz text field, type comp2.bcs.mu1.

Section Orientation 1
1 In the Model Builder window, expand the Cross Section Data 2 node, then click 

Section Orientation 1.
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2 In the Settings window for Section Orientation, locate the Section Orientation section.

3 Specify the P vector as

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Beam Cross Section (bcs) interface.

5 Click Add Study in the window toolbar.

6 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  4

1 In the Model Builder window, click Study 4.

2 In the Settings window for Study, locate the Study Settings section.

3 Clear the Generate default plots check box.

4 Right-click Study 4 and choose Rename.

5 In the Rename Study dialog box, type Stationary Study: Beam (Inputs from Beam 
Cross Section) in the New label text field.

6 Click OK.

Step 1: Stationary
Some cross section properties are now defined using a dependent variable from the Beam 
Cross Section Interface. An example is the torsional section modulus defined as 
comp2.bcs.Wt. Follow the steps below to get access to these variables in this study.

1 In the Settings window for Stationary, click to expand the Values of Dependent Variables 
section.

2 Find the Values of variables not solved for subsection. From the Settings list, choose 
User controlled.

3 From the Method list, choose Solution.

4 From the Study list, choose Stationary Study: Beam Cross Section, Stationary.

0 X

0 Y

1 Z
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5 Locate the Study Extensions section. Select the Define load cases check box.

6 Click Add.

7 In the table, enter the following settings:

8 In the Home toolbar, click Compute.

Compare the von Mises stress for the two cross sections.

Point Evaluation 7
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, type von Mises Stress in the Label text 
field.

3 Locate the Data section. From the Parameter selection (Load case) list, choose First.

4 Select Point 1 only.

5 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Beam>Stress>beam.mises - von Mises stress - N/m².

6 Locate the Expressions section. In the table, enter the following settings:

7 Click Evaluate.

8 Locate the Data section. From the Dataset list, choose 
Stationary Study: Beam (Inputs from Beam Cross Section)/Solution 4 (5) (sol4).

9 Click Evaluate.

Table 8
1 In the Model Builder window, under Results>Tables click Table 8.

2 In the Settings window for Table, type von Mises Stress in the Label text field.

Finally modify Study 1 and Study 2 so that you can re-compute the solution later.

S T A T I O N A R Y  S T U D Y :  B E A M

Step 1: Stationary
1 In the Model Builder window, under Stationary Study: Beam click Step 1: Stationary.

Load case edge Weight point Weight

Point Load 1.0 √ 1.0

Expression Unit Description

beam.mises MPa von Mises stress
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2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify model configuration for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Beam (beam)>

Cross Section Data 2.

5 Click Disable.

E I G E N F R E Q U E N C Y  S T U D Y :  B E A M

Step 1: Eigenfrequency
1 In the Model Builder window, under Eigenfrequency Study: Beam click 

Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Physics and Variables Selection 
section.

3 Select the Modify model configuration for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Beam (beam)>

Cross Section Data 2.

5 Click Disable.
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Introduction

This is a benchmark model involving stick-slip friction of a ring rolling inside another ring. 
The displacement of the inner ring is computed and compared to the analytical result 
(Ref. 1). 

Model Definition

As illustrated in Figure 1, the geometry consists of two rings. The outer ring is 4 mm thick 
and has an inner radius of 156 mm. The inner ring has an inner radius of 100 mm and a 
thickness of 11.5 mm.

Figure 1: Model geometry.

The outer ring is fixed and rigid. Thus for the contact analysis only its mesh is required, 
without any physics attached. The inner ring is subjected to a prescribed rotation phi at 
its origin.

At the center of rotation, the resultant of the gravity load (P = 500 N) is applied to the 
inner ring.

A friction coefficient with the value 1 is used.
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Results and Discussion

The analytical solution of the problem can be described as follows. The inner ring rolls 
along the outer ring until the tangential component of the gravity load becomes equal to 
the friction force (see Figure 2). At this critical point, slip occurs and the elevation of the 
inner ring reaches its maximum value.

Figure 2: Representation of the contact and friction forces and the resultant of the gravity 
load.

The contact force corresponds to the normal component of the gravity load, 
. In this problem, the friction coefficient is 1, thus Tn = Tt when sliding. 

As the critical position is reached when , the critical angle is α = 45o.

The maximum rolling distance is then .

The vertical displacement of the center of the inner ring is defined as 
, where R is the inner radius of the outer ring and r is the outer 

radius of the inner ring. The maximum vertical displacement Ymax = 13 mm is reached at 
α = 45o.

Pcos(α)

Psin(α)

Tn

Tt

P

Tn P α( )sin=

Tt P α( )cos=

L R π 4⁄⋅ 122.5 mm= =

Y R r–( ) 1 α( )cos–( )=
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Figure 3 shows the von Mises stress distribution in the inner ring at the final step.

Figure 3: Stress distribution.

In Figure 4, you can see the elevation of the center of the inner ring with respect to its 
rotation angle. 
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Figure 4: Elevation of the inner ring center versus applied rotation angle.

The computed maximum elevation is about 13 mm, and is in excellent agreement with the 
analytical solution.

Figure 5 shows the contact pressure on the outer ring with respect to its length. The peak 
of the contact pressure occurs at 123 mm, as predicted by the analytical solution.
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Figure 5: Contact pressure versus length of the outer ring.

Notes About the COMSOL Implementation

A rigid connector is used to prescribe the rotation of the inner ring, while leaving the 
translation free so that it can follow the curvature of the outer ring. The rigid connector 
is attached to the inner boundary of the inner ring.

Since the outer ring is assumed fixed and rigid, it requires no physics. By selecting the 
Source external to current physics check box in the contact node, it is sufficient to define 
a mesh on its the boundary.

To capture the transition between stick friction and slip friction, a small continuation 
parameter step is used. Furthermore, the augmented Lagrangian method is better suited 
for problems dominated by stick-slip friction than the default penalty method, and is thus 
used in this example.

The model is not stable in its initial configuration; there are possible rigid body 
displacements before contact is established. To stabilize it, you add a small spring which is 
only active in the first parameter step.
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Application Library path: Structural_Mechanics_Module/
Verification_Examples/contacting_rings

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

r1 160[mm] 0.16 m Outer ring radius

r2 111.5[mm] 0.1115 m Inner ring radius

t1 4[mm] 0.004 m Outer ring thickness
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G E O M E T R Y  1

Circle 1 (c1)
1 In the Geometry toolbar, click Circle.

Only the inner surface of the outer ring needs to be modeled.

2 In the Settings window for Circle, locate the Object Type section.

3 From the Type list, choose Curve.

4 Locate the Size and Shape section. In the Radius text field, type r1-t1.

5 In the Sector angle text field, type 90.

6 Locate the Rotation Angle section. In the Rotation text field, type -95.

7 Click to expand the Layers section. Click Build Selected.

Circle 2 (c2)
1 In the Geometry toolbar, click Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type r2.

4 In the Sector angle text field, type 90.

5 Locate the Position section. In the y text field, type y0.

6 Locate the Rotation Angle section. In the Rotation text field, type -95.

7 Locate the Layers section. In the table, enter the following settings:

8 Click Build Selected.

Delete Entities 1 (del1)
1 In the Model Builder window, right-click Geometry 1 and choose Delete Entities.

2 In the Settings window for Delete Entities, locate the Entities or Objects to Delete section.

3 From the Geometric entity level list, choose Domain.

4 On the object c2, select Domain 1 only.

t2 11.5[mm] 0.0115 m Inner ring thickness

y0 111.5[mm]-156[mm] -0.0445 m Inner ring center 
initial y-position

Layer name Thickness (m)

Layer 1 t2

Name Expression Value Description
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Delete Entities 2 (del2)
1 Right-click Geometry 1 and choose Delete Entities.

2 On the object c1, select Boundaries 2 and 3 only.

3 In the Settings window for Delete Entities, click Build Selected.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click 

Form Union (fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly section.

3 From the Action list, choose Form an assembly.

4 Click Build Selected.

D E F I N I T I O N S

Variables 1
1 In the Home toolbar, click Variables and choose Local Variables.

2 In the Settings window for Variables, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 1 only.

5 Locate the Variables section. In the table, enter the following settings:

Contact Pair 1 (p1)
1 In the Definitions toolbar, click Pairs and choose Contact Pair.

2 In the Settings window for Pair, locate the Source Boundaries section.

3 Click Paste Selection.

4 In the Paste Selection dialog box, type 1 in the Selection text field.

5 Click OK.

6 In the Settings window for Pair, locate the Destination Boundaries section.

7 Select the Activate selection toggle button.

8 Click Paste Selection.

9 In the Paste Selection dialog box, type 4 in the Selection text field.

10 Click OK.

Name Expression Unit Description

L (r1-t1)*(atan2(-y,-x)-
pi/2)

m Length of the outer ring
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M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

Contact 1
1 In the Model Builder window, under Component 1 (comp1) right-click 

Solid Mechanics (solid) and choose Pairs>Contact.

Use the augmented Lagrange method to evaluate the stick-slip contact.

2 In the Settings window for Contact, locate the Contact Method section.

3 From the Formulation list, choose Augmented Lagrangian.

4 Select the Source external to current physics check box.

5 Locate the Pair Selection section. Under Pairs, click Add.

6 In the Add dialog box, select Contact Pair 1 (p1) in the Pairs list.

7 Click OK.

Friction 1
1 In the Physics toolbar, click Attributes and choose Friction.

2 In the Settings window for Friction, locate the Friction Parameters section.

3 In the μ text field, type 1.

4 Click the Show More Options button in the Model Builder toolbar.

5 In the Show More Options dialog box, in the tree, select the check box for the node 
Physics>Advanced Physics Options.

6 Click OK.

7 In the Settings window for Friction, click to expand the Advanced section.

8 Select the Store accumulated slip check box.

Property Variable Value Unit Property group

Young’s modulus E 210[GPa] Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 7850 kg/m³ Basic
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G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

Rigid Connector 1
1 In the Physics toolbar, click Boundaries and choose Rigid Connector.

2 Select Boundary 5 only.

3 In the Settings window for Rigid Connector, locate the Center of Rotation section.

4 From the list, choose User defined.

5 Specify the Xc vector as

6 Locate the Prescribed Rotation section. From the By list, choose Prescribed rotation.

7 In the φ0 text field, type -phi.

Applied Force 1
1 In the Physics toolbar, click Attributes and choose Applied Force.

2 In the Settings window for Applied Force, locate the Applied Force section.

3 Specify the F vector as

Rigid Connector 1
In the Model Builder window, click Rigid Connector 1.

Spring Foundation 1
1 In the Physics toolbar, click Attributes and choose Spring Foundation.

2 In the Settings window for Spring Foundation, locate the Spring section.

Name Expression Value Description

phi 0[rad] 0 rad Inner ring rotation angle

0 x

y0 y

0 x

-500 y
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3 In the ku text field, type 1e6*(phi==0).

4 Locate the Rotational Spring section. In the kθ text field, type 1e6*(phi==0).

M E S H  1

Mapped 1
In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Mapped.

Distribution 1
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 Select Boundary 2 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 3.

Distribution 2
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 Select Boundary 4 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 60.

Edge 1
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Edge.

2 Select Boundary 1 only.

Distribution 1
1 Right-click Edge 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 100.

4 Click Build All.

S T U D Y  1

Step 1: Stationary
Set up an auxiliary continuation sweep for the phi parameter.

1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Results While Solving section.

3 Select the Plot check box.
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4 From the Update at list, choose Steps taken by solver.

5 Click to expand the Study Extensions section. Select the Auxiliary sweep check box.

6 Click Add.

7 In the table, enter the following settings:

Solution 1 (sol1)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Dependent Variables 1 node, then click 
Contact pressure (comp1.solid.Tn_p1).

4 In the Settings window for Field, locate the Scaling section.

5 In the Scale text field, type 1e5.

6 In the Model Builder window, click Friction force (spatial frame) (comp1.solid.Tt_p1).

7 In the Settings window for Field, locate the Scaling section.

8 In the Scale text field, type 1e5.

9 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Stationary Solver 1 node, then click Parametric 1.

10 In the Settings window for Parametric, click to expand the Continuation section.

11 Select the Tuning of step size check box.

12 In the Initial step size text field, type pi/1000.

13 In the Maximum step size text field, type pi/1000.

14 In the Minimum step size text field, type pi/10000.

15 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Stationary Solver 1>Segregated 1 node, then click Solid Mechanics.

16 In the Settings window for Segregated Step, click to expand the Method and Termination 
section.

17 In the Number of iterations text field, type 15.

18 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1) click 
Compile Equations: Stationary.

19 Click Compute to Selected.

Parameter name Parameter value list Parameter unit

phi (Inner ring rotation angle) range(0,pi/120,pi/6) rad
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R E S U L T S

Stress (solid)
Create a marker to make it easier to track the rotation of the inner ring. One way of doing 
it is to add an arrow to the default plot, which is generated below.

Point Trajectories 1
1 In the Stress (solid) toolbar, click More Plots and choose Point Trajectories.

2 In the Settings window for Point Trajectories, locate the Trajectory Data section.

3 In the X-expression text field, type solid.u_rig1.

4 In the Y-expression text field, type y0+solid.v_rig1.

5 Locate the Coloring and Style section. Find the Point style subsection. From the Type list, 
choose Arrow.

6 In the Arrow, X component text field, type cos(phi+5[deg]).

7 In the Arrow, Y component text field, type sin(-phi-5[deg]).

8 From the Arrow type list, choose Cone.

9 From the Arrow base list, choose Head.

10 From the Color list, choose Black.

S T U D Y  1

In the Home toolbar, click Compute.

R E S U L T S

1D Plot Group 4
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Legend section.

3 From the Position list, choose Upper left.

4 In the Label text field, type Rigid body y-displacement.

Global 1
1 Right-click Rigid body y-displacement and choose Global.

2 In the Settings window for Global, click Replace Expression in the upper-right corner of 
the y-axis data section. From the menu, choose Component 1>Solid Mechanics>

Rigid connectors>Rigid Connector 1>Rigid body displacement (spatial frame) - m>

solid.rig1.v - Rigid body displacement, y component.

3 In the Rigid body y-displacement toolbar, click Plot.
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1D Plot Group 5
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Parameter selection (phi) list, choose Last.

Line Graph 1
1 Right-click 1D Plot Group 5 and choose Line Graph.

2 Select Boundary 1 only.

3 In the Settings window for Line Graph, locate the y-Axis Data section.

4 In the Expression text field, type dst2src_p1(solid.Tn_p1).

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type L.

7 From the Unit list, choose mm.

8 In the 1D Plot Group 5 toolbar, click Plot.

1D Plot Group 5
1 In the Model Builder window, under Results click 1D Plot Group 5.

2 In the Settings window for 1D Plot Group, type Contact pressure along outer ring 
in the Label text field.

Edge 2D 1
1 In the Results toolbar, click More Datasets and choose Edge 2D.

2 Select Boundary 4 only.

Parametric Extrusion 1D 1
In the Results toolbar, click More Datasets and choose Parametric Extrusion 1D.

2D Plot Group 6
1 In the Results toolbar, click 2D Plot Group.

2 In the Settings window for 2D Plot Group, locate the Data section.

3 From the Dataset list, choose Parametric Extrusion 1D 1.

Surface 1
1 Right-click 2D Plot Group 6 and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>Contact>

Friction>solid.sliptot - Accumulated slip - m.
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Height Expression 1
1 Right-click Surface 1 and choose Height Expression.

2 In the 2D Plot Group 6 toolbar, click Plot.
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Introduction

Consider an infinitely long steel cylinder resting on a flat aluminum foundation, where 
both structures are elastic. The cylinder is subjected to a point load along its top. The 
objective of this study is to find the contact pressure distribution and the length of contact 
between the foundation and the cylinder. An analytical solution exists, and this tutorial 
includes a comparison with the COMSOL Multiphysics solution. The application is based 
on a NAFEMS benchmark (see Ref. 1).

Model Definition

This is a plane strain problem and the 2D Solid Mechanics interface from the Structural 
Mechanics Module is thus suitable. The 2D geometry is further cut in half at the vertical 
symmetry axis.

Figure 1: Model geometry.

In 2D, the cylinder is subjected to a point load along its top with an intensity of 35 kN/
mm. Both the cylinder and block material are elastic, homogeneous, and isotropic.

The contact modeling in this example only includes the frictionless part of the example 
described in Ref. 1. The problem is implemented with the Solid Mechanics interface, and 
two studies are set up to compare the default penalty contact method and the augmented 
Lagrangian method.
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Results and Discussion

Figure 2 depicts the deformed shape and the von Mises stress distribution obtained with 
the penalty contact method.

Figure 2: Deformation and von Mises stress at the contact area.

The analytical solution for the contact pressure as a function of the x-coordinate is

where Fn is the applied load per unit length, E' is the combined elasticity modulus, and R' 
is the combined radius. The combined Young’s modulus and radius are defined as:

P
FnE'

2πR'
------------ 1 x

a
--- 
  2

– 
 ×=

a
8FnR'

πE'
----------------=
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In these equations, E1 and E2 are Young’s modulus of the roller and the block, 
respectively, and R1 is the radius of the roller. Combining these equations results in a 
contact length of 6.21 mm and a maximum contact pressure of 3585 MPa.

Figure 3 depicts the contact pressure along the contact area for both the analytical and the 
two COMSOL Multiphysics solutions.

Figure 3: Analytical pressure distribution (dashed line) and COMSOL Multiphysics solution 
(solid lines).

Notes About the COMSOL Implementation

The Structural Mechanics Module supports contact boundary conditions using contact 
pairs. The contact pair is defined by a source boundary and a destination boundary. The 
destination boundary is the one which is coupled to the source boundary if contact is 
established. The terms source and destination should be interpreted as in “the destination 
receives its displacements from the source.” As a result, the contact pressure variable is 

E'
2E1E2

E2 1 ν1
2

–( ) E1 1 ν2
2

–( )+
-------------------------------------------------------------=

R'
R1R2

R1 R2+
--------------------

R2 ∞→
lim R1= =
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available on the destination boundary. The mesh on the destination side should always be 
finer than on the source side.

In this example, the contact boundary pair consists of a flat source boundary and a curved 
destination boundary.

When using the penalty method, the cylinder is initially stabilized with a weak spring. In a 
second step, the spring is removed to arrive at the final solution.

To reduce the number of iteration steps and improve convergence when using the 
augmented Lagrangian method, it is good practice to set an initial contact pressure as close 
to the anticipated solution as possible. A good approximation is to use the value of the 
external pressure — in this case the external point load divided by an estimated contact 
length and the thickness. In this example, it is necessary to specify an initial contact 
pressure to make the model stable with respect to the initial conditions, because the initial 
configuration — where the cylinder is free to move in the vertical direction — is singular. 

The small size of the contact region necessitates a local mesh refinement. Use a free mesh 
for the cylindrical domain and a mapped mesh for the aluminum block. The block 
geometry requires some modification to set up a refined mesh area.
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Application Library path: Structural_Mechanics_Module/
Verification_Examples/cylinder_roller_contact

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
cylinder_roller_contact.txt.

D E F I N I T I O N S

Variables 1
1 In the Home toolbar, click Variables and choose Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Now create the geometry. Recall that you only need to model one half of the 2D cross 
section.

Circle 1 (c1)
1 In the Geometry toolbar, click Circle.

Name Expression Unit Description

p_analytical pmax*sqrt(1-(x/a)^2) N/m² Analytical contact 
pressure
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2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type R.

4 In the Sector angle text field, type 180.

5 Locate the Position section. In the y text field, type R+dist.

6 Locate the Rotation Angle section. In the Rotation text field, type -90.

7 Click Build Selected.

Rectangle 1 (r1)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type d/2.

4 In the Height text field, type d.

5 Locate the Position section. In the y text field, type -d.

6 Click to expand the Layers section. In the table, enter the following settings:

7 Click Build Selected.

8 Click the Zoom Extents button in the Graphics toolbar.

Square 1 (sq1)
1 In the Geometry toolbar, click Square.

2 In the Settings window for Square, locate the Size section.

3 In the Side length text field, type R/2.

4 Locate the Position section. In the y text field, type -R/2.

5 Click Build Selected.

Point 1 (pt1)
1 In the Geometry toolbar, click Point.

2 In the Settings window for Point, locate the Point section.

3 In the y text field, type dist.

Layer name Thickness (mm)

Layer 1 d/2
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4 Click Build Selected.

Rotate 1 (rot1)
1 In the Geometry toolbar, click Transforms and choose Rotate.

2 Select the object pt1 only.

3 In the Settings window for Rotate, locate the Rotation section.

4 In the Angle text field, type 10.

5 Locate the Center of Rotation section. In the y text field, type R+dist.

6 Click Build Selected.

Convert to Solid 1 (csol1)
1 In the Geometry toolbar, click Conversions and choose Convert to Solid.

2 Click in the Graphics window and then press Ctrl+A to select all objects.

3 Click Build Selected.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click 

Form Union (fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly section.

3 From the Action list, choose Form an assembly.

4 Clear the Create pairs check box.
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Mesh Control Domains 1 (mcd1)
1 In the Geometry toolbar, click Virtual Operations and choose Mesh Control Domains.

2 On the object fin, select Domains 1–3 only.

3 In the Geometry toolbar, click Build All.

The model geometry is now complete.

D E F I N I T I O N S

Contact Pair 1 (p1)
1 In the Definitions toolbar, click Pairs and choose Contact Pair.

2 Select Boundary 3 only.

3 In the Settings window for Pair, locate the Destination Boundaries section.

4 Select the Activate selection toggle button.

5 Select Boundary 7 only.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Thickness section.

3 In the d text field, type th.
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Symmetry 1
1 In the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 1, 4, and 5 only.

Fixed Constraint 1
1 In the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundary 2 only.

Point Load 1
1 In the Physics toolbar, click Points and choose Point Load.

2 Select Point 5 only.

Use only half the total load since you only model one symmetry half of the full 
geometry.

3 In the Settings window for Point Load, locate the Force section.

4 Specify the FP vector as

Contact 1
1 In the Physics toolbar, in the Boundary section, click Pairs and choose Contact.

2 In the Settings window for Contact, locate the Pair Selection section.

3 Under Pairs, click Add.

4 In the Add dialog box, select Contact Pair 1 (p1) in the Pairs list.

5 Click OK.

Attach a spring to the cylinder in order to prevent rigid body motion before the contact is 
detected.

Spring Foundation 1
1 In the Physics toolbar, click Points and choose Spring Foundation.

2 Select Point 5 only.

3 In the Settings window for Spring Foundation, locate the Spring section.

4 In the kP text field, type k.

0 x

-Fn/2 y
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M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 Select Domain 2 only.

3 In the Settings window for Material, locate the Material Contents section.

4 In the table, enter the following settings:

The analytical solution to this problem assumes that engineering strains are used. Since the 
solution of a contact problem forces the study step to be geometrically nonlinear, you must 
explicitly enforce a linear strain representation.

S O L I D  M E C H A N I C S  ( S O L I D )

Linear Elastic Material 1
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Geometric Nonlinearity 
section.

3 Select the Force linear strains check box.

Property Variable Value Unit Property group

Young’s modulus E E1 Pa Basic

Poisson’s ratio nu nu0 1 Basic

Density rho 1 kg/m³ Basic

Property Variable Value Unit Property group

Young’s modulus E E2 Pa Basic

Poisson’s ratio nu nu0 1 Basic

Density rho 1 kg/m³ Basic
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M E S H  1

Free Triangular 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

Free Triangular.

2 In the Settings window for Free Triangular, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domain 2 only.

Size 1
1 Right-click Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 7 only.

5 Locate the Element Size section. Click the Custom button.

6 Locate the Element Size Parameters section. Select the Maximum element size check box.

7 In the associated text field, type 0.6.

8 Click Build All.

Mapped 1
1 In the Model Builder window, right-click Mesh 1 and choose Mapped.

2 In the Settings window for Mapped, click to expand the Control Entities section.

3 Clear the Smooth across removed control entities check box.

Distribution 1
1 Right-click Mapped 1 and choose Distribution.

2 Select Boundaries 3, 10, and 11 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 20.

Distribution 2
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 Select Boundary 1 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 10.

5 Click Build All.
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S T U D Y  1

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study Extensions section.

3 Select the Auxiliary sweep check box.

4 Click Add.

5 In the table, enter the following settings:

6 In the Model Builder window, click Study 1.

7 In the Settings window for Study, type Study 1: Penalty in the Label text field.

8 In the Home toolbar, click Compute.

R E S U L T S

Surface 1
1 In the Model Builder window, expand the Results>Stress (solid) node, then click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 In the Stress (solid) toolbar, click Plot.

Because the point load gives a singular stress at the top of the cylinder, adjust the color 
range to see the stress distribution around the contact region better.

5 Click to expand the Range section. Select the Manual color range check box.

6 In the Maximum text field, type 2500.

7 In the Stress (solid) toolbar, click Plot.

1D Plot Group 4
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Parameter selection (k) list, choose Last.

Line Graph 1
1 Right-click 1D Plot Group 4 and choose Line Graph.

2 Select Boundary 7 only.

Parameter name Parameter value list Parameter unit

k (Spring coefficient) Fn/dist/5 0 N/m
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3 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Component 1>Definitions>

Variables>p_analytical - Analytical contact pressure - N/m².

4 Locate the y-Axis Data section. From the Unit list, choose MPa.

5 Click Replace Expression in the upper-right corner of the x-axis data section. From the 
menu, choose Model>Component 1>Geometry>Coordinate (spatial frame)>x - x-

coordinate.

6 Click to expand the Coloring and Style section. Find the Line style subsection. From the 
Line list, choose Dashed.

7 In the Width text field, type 2.

8 Click to expand the Legends section. Select the Show legends check box.

9 From the Legends list, choose Manual.

10 In the table, enter the following settings:

11 In the 1D Plot Group 4 toolbar, click Plot.

Line Graph 2
1 Right-click Line Graph 1 and choose Duplicate.

2 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Component 1>Solid Mechanics>

Contact>solid.Tn - Contact pressure - N/m².

3 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Solid.

4 Locate the Legends section. In the table, enter the following settings:

To avoid oscillations in the contact pressure representation, turn off the refinement 
within the elements.

5 Click to expand the Quality section. From the Resolution list, choose No refinement.

1D Plot Group 4
1 In the Model Builder window, click 1D Plot Group 4.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

Legends

Analytical

Legends

Computed (Penalty)
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3 Select the x-axis label check box.

4 In the associated text field, type Distance from center (mm).

5 Select the y-axis label check box.

6 In the associated text field, type Contact pressure (MPa).

7 In the 1D Plot Group 4 toolbar, click Plot.

Now, solve the model using the augmented Lagrangian contact method.

S O L I D  M E C H A N I C S  ( S O L I D )

Contact 2
1 In the Physics toolbar, in the Boundary section, click Pairs and choose Contact.

2 In the Settings window for Contact, locate the Pair Selection section.

3 Under Pairs, click Add.

4 In the Add dialog box, select Contact Pair 1 (p1) in the Pairs list.

5 Click OK.

6 In the Settings window for Contact, locate the Contact Method section.

7 From the Formulation list, choose Augmented Lagrangian.

8 Locate the Initial Value section. In the Tn text field, type (Fn/2)/(lc*th).

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study.

5 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

Step 1: Stationary
1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 Select the Modify model configuration for study step check box.

3 In the Physics and variables selection tree, select Component 1 (comp1)>

Solid Mechanics (solid), Controls spatial frame>Contact 1.

4 Click Disable.

5 In the Model Builder window, click Study 2.
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6 In the Settings window for Study, locate the Study Settings section.

7 Clear the Generate default plots check box.

8 In the Label text field, type Study 1: Augmented Lagrangian.

Solution 2 (sol2)
1 In the Study toolbar, click Show Default Solver.

Adjust the scale for the contact pressure variable based on the analytical solution.

2 In the Model Builder window, expand the Solution 2 (sol2) node.

3 In the Model Builder window, expand the Study 1: Augmented Lagrangian>

Solver Configurations>Solution 2 (sol2)>Dependent Variables 1 node, then click 
Contact pressure (comp1.solid.Tn_p1).

4 In the Settings window for Field, locate the Scaling section.

5 In the Scale text field, type 1e9.

6 In the Study toolbar, click Compute.

The default plot for the second study was disabled. To visualize the stress and contact 
forces, change the data set in the 2D plot group.

R E S U L T S

Line Graph 3
1 In the Model Builder window, under Results>1D Plot Group 4 right-click Line Graph 2 and 

choose Duplicate.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Dataset list, choose Study 1: Augmented Lagrangian/Solution 2 (sol2).

4 Locate the Legends section. In the table, enter the following settings:

5 In the 1D Plot Group 4 toolbar, click Plot.

Prepare the model for later use by disabling the second contact feature in the first study 
(Penalty).

S T U D Y  1 :  P E N A L T Y

Step 1: Stationary
1 In the Model Builder window, under Study 1: Penalty click Step 1: Stationary.

Legends

Computed (Augmented Lagrangian)
16 |  C Y L I N D E R  R O L L E R  C O N T A C T



2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify model configuration for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>

Solid Mechanics (solid), Controls spatial frame>Contact 2.

5 Click Disable.
17 |  C Y L I N D E R  R O L L E R  C O N T A C T



18 |  C Y L I N D E R  R O L L E R  C O N T A C T



Created in COMSOL Multiphysics 5.5
S t r e s s  Ana l y s i s  o f  an E l l i p t i c  Memb r an e
This model is licensed under the COMSOL Software License Agreement 5.5.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


General Description

In this benchmark, the static stress analysis described in the NAFEMS Test LE1, “Elliptic 
Membrane”, found on page 5 in Ref. 1 is performed. It is an analysis of a linear elastic 
plane stress model.

The computed stress level is compared with the values given in the benchmark report.

In addition to the original benchmark, a mesh convergence study is performed.

G E O M E T R Y

The geometry is an ellipse with an elliptical hole in it. The outer and inner edges are 
defined by the equations

The thickness (which actually does not influence the analysis) is 0.1 m.

Due to symmetry in load and in geometry, the analysis only includes a quarter of the 
geometry as shown in Figure 1. 

X
3.25
------------ 
  2 Y

2.75
------------ 
  2

+ 1=

X
2
---- 
  2 Y

1
---- 
  2
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Figure 1: The geometry and load. Only the quarter which is analyzed is shown.

M A T E R I A L

Isotropic with E = 2.1·1011 Pa and ν = 0.3.

L O A D

An evenly distributed load of 10 MPa acts along the outward normal of the outer 
boundary.

C O N S T R A I N T S

Symmetry conditions are used along the cuts at X = 0 and Y = 0.

Model Setup

The Solid Mechanics interface with the plane stress assumption is used.

Four meshes are exactly specified in Ref. 1. The ‘coarse’ mesh has 6 quadrilateral or 12 
triangular elements. The ‘fine’ mesh has 24 quadrilateral or 48 triangular elements. The 
triangular elements are created by splitting the quadrilateral elements along a diagonal. 
The specified meshes are shown in Figure 2 and Figure 3.

D
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For the mesh convergence study, these meshes are uniformly refined using a parameter 
div. The number of elements along the elliptical boundaries is 3*div and the number of 
elements along the symmetry cuts is 2*div.

The number of degrees of freedom varies from 48 (div = 1 and quadrilaterals with linear 
shape order) to 935810 (div = 64 and triangles with cubic shape order.)

Figure 2: The meshes as specified in Ref. 1. Left column: ‘coarse’ (div=1). Right column: ‘fine’ 
(div=2).

Figure 3: A quadrilateral mesh with div=8.
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Due to the specification of the benchmark, the modeling differs somewhat from what you 
would use in practice:

• The interior boundaries in the model are created for matching the specification of the 
mesh in the NAFEMS benchmark as close as possible. If you were to solve the problem 
without these constraints, the modeling would be significantly simplified. Only two 
ellipses would be needed in the Geometry sequence.

• The knowledge about where a stress concentration is expected suggests that you should 
use a mesh such that more elements are present in the region around point D to get 
optimal accuracy, see Figure 1.

• Using the possibility to generate a free triangular mesh instead of one where 
quadrilateral elements are split along the diagonals would also give a mesh with better 
element quality.

Results and Discussion

The purpose of this test, in addition to a pure verification of the element formulation, is 
to check how well the software can represent a nontrivial geometrical shape such as an 
ellipse. It also evaluates the application of a distributed load.
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The distribution of the direct stress in the Y direction is shown in Figure 4. As can be seen 
the result has steep gradients towards the point with maximum values.

Figure 4: The distribution of the σy stress component using div=4 and second order 
quadrilateral elements.

The normal stress σy at the elliptic hole is evaluated at the point D located at X = 2, Y = 0 
(see Figure 1). The target value according to Ref. 1 is 92.7 MPa. The value is based on an 
analytical result. The COMSOL Multiphysics results for the “coarse” and “fine” meshes 
are given in Table 1. 

TABLE 1:  COMPUTED RESULTS FOR THE MESHES SPECIFIED IN THE BENCHMARK.

STUDY 
NUMBER

ELEMENT TYPE DISCRETIZATION MESH COMPUTED 
VALUE

RELATIVE 
ERROR

1 Quadrilateral Linear Coarse 77.4 -16.5%

1 Quadrilateral Linear Fine 88.3 -4.7%

2 Quadrilateral Quadratic Coarse 91.9 -0.9%

2 Quadrilateral Quadratic Fine 93.4 0.8%

3 Quadrilateral Cubic Coarse 94.7 2.2%

3 Quadrilateral Cubic Fine 93.0 0.3%

4 Triangle Linear Coarse 36.0 -61.1%

4 Triangle Linear Fine 55.2 -40.4%

5 Triangle Quadratic Coarse 70.7 -23.7%
6 |  S T R E S S  A N A L Y S I S  O F  A N  E L L I P T I C  M E M B R A N E



As can be expected, the coarse mesh is not able to capture the stress concentration unless 
elements with high order are used. Generally the quadrilaterals perform better than the 
corresponding triangles. 

The mesh which is denoted as ‘fine’ is probably similar to what you would use in an analysis 
of a larger structure in a case where you are not specifically interested in a high resolution 
of the stress concentration. Still, with quadratic shape order elements the accuracy is good 
enough for most engineering purposes, at least for the quadrilateral elements. With the 
current mesh, the triangular elements will have a small angle at the stress evaluation point, 
hence the less accurate result.

Using elements with linear shape functions for structural analysis is commonly avoided in 
the finite element community.

The results of the mesh convergence study are shown in Figure 5. The element size h is 
defined as 0.417[m]/div, which is the length of an edge in the element where the stress 
is measured.

The target value in Ref. 1, 92.7 MPa, is given with only three digits. This is not accurate 
enough for the convergence study here. Instead, the error is measured relative to the value 
92.65817 MPa, towards which σy converges.

The convergence behavior is as expected since it is faster for elements with a higher shape 
function order. It can also be seen that quadrilaterals are somewhat more accurate than 
triangles for quadratic and cubic elements.

The other two in-plane stress components σx and τxy should both be zero at point D since 
the boundary is free. In Figure 6 and Figure 7 similar convergence graphs are shown for 
these stress components.

5 Triangle Quadratic Fine 85.6 -7.7%

6 Triangle Cubic Coarse 81.7 -11.9%

6 Triangle Cubic Fine 90.3 -2.6%

TABLE 1:  COMPUTED RESULTS FOR THE MESHES SPECIFIED IN THE BENCHMARK.

STUDY 
NUMBER

ELEMENT TYPE DISCRETIZATION MESH COMPUTED 
VALUE

RELATIVE 
ERROR
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Figure 5: Error with respect to the stress target value as a function of the element size h. 

Figure 6: Error in the stress σx. The values are normalized with the target for σy.
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Figure 7: Error in the stress τxy. The values are normalized with the target for σy.

Since elements with different shape function orders are used, a comparison based only on 
element size may not be fair when efficiency is considered. The number of degrees of 
freedom in the model varies a lot for the same element size, and so does the solution time. 
In Figure 8, the error is shown as a function of the number of degrees of freedom. Also 
when compared this way, the elements with cubic shape functions have the best 
performance. This is usually true as long as the solutions are smooth, but it may not be 
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true, for example, when solving nonlinear problems.

Figure 8: Error with respect to the stress target value as a function of the number of degrees of 
freedom.

Reference

1. G.A.O. Davies, R.T. Fenner, and R.W. Lewis, Background to Benchmarks, NAFEMS, 
Glasgow, 1993.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/elliptic_membrane

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Ellipse 1 (e1)
1 In the Geometry toolbar, click Ellipse.

2 In the Settings window for Ellipse, locate the Size and Shape section.

3 In the Sector angle text field, type 90.

4 In the a-semiaxis text field, type 3.25.

5 In the b-semiaxis text field, type 2.75.

Create an extra mesh control ellipse.

Ellipse 2 (e2)
1 In the Geometry toolbar, click Ellipse.

2 In the Settings window for Ellipse, locate the Size and Shape section.

3 In the a-semiaxis text field, type 2.417.

4 In the b-semiaxis text field, type 1.583.

5 In the Sector angle text field, type 90.

Name Expression Value Description

div 1 1 Mesh refinement factor

sy_ref 92.65817[MPa] 9.2658E7 Pa Target stress
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Ellipse 3 (e3)
1 In the Geometry toolbar, click Ellipse.

2 In the Settings window for Ellipse, locate the Size and Shape section.

3 In the a-semiaxis text field, type 2.

Difference 1 (dif1)
1 In the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 Select the objects e1 and e2 only.

3 In the Settings window for Difference, locate the Difference section.

4 Find the Objects to subtract subsection. Select the Activate selection toggle button.

5 Select the object e3 only.

6 Click Build All Objects.

Line Segment 1 (ls1)
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 Locate the Endpoint section. From the Specify list, choose Coordinates.

5 Locate the Starting Point section. In the x text field, type 1.783 and y to 2.3.

6 Locate the Endpoint section. In the x text field, type 1.165 and y to 0.812.

Line Segment 2 (ls2)
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 Locate the Endpoint section. From the Specify list, choose Coordinates.

5 Locate the Starting Point section. In the x text field, type 2.833 and y to 1.348.

6 Locate the Endpoint section. In the x text field, type 1.783 and y to 0.453.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.
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3 In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the 2D Approximation section.

3 From the list, choose Plane stress.

4 Locate the Thickness section. In the d text field, type 0.1.

Symmetry 1
1 In the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 1, 2, 9, and 11 only.

Boundary Load 1
1 In the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 15, 18, and 21 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 From the Load type list, choose Pressure.

5 In the p text field, type -10[MPa].

M E S H  1

Mapped 1
In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Mapped.

Distribution 1
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type div.

4 Select Boundaries 1, 2, 13, 16, and 19 only.

Property Variable Value Unit Property group

Young’s modulus E 210E3[MPa] Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 0 kg/m³ Basic
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5 Click Build All.

The default discretization of the displacement field consists of quadratic serendipity 
shape functions. Change to Lagrange shape functions.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, click to expand the Discretization section.

3 From the Displacement field list, choose Quadratic Lagrange.

Add linear and cubic displacement fields as well. The actual selection of discretization 
type will be done in each study.

4 Click the Show More Options button in the Model Builder toolbar.

5 In the Show More Options dialog box, in the tree, select the check box for the node 
Physics>Advanced Physics Options.

6 Click OK.

Discretization 1
1 In the Physics toolbar, click Global and choose Discretization.

2 In the Settings window for Discretization, locate the Discretization section.

3 From the Displacement field list, choose Linear.

4 In the Label text field, type Discretization Linear.

Discretization Linear 1
1 Right-click Discretization Linear and choose Duplicate.

2 In the Settings window for Discretization, locate the Discretization section.

3 From the Displacement field list, choose Cubic Lagrange.

4 In the Label text field, type Discretization Cubic.

S T U D Y  1

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Study Quad Linear in the Label text field.

Parametric Sweep
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.
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4 In the table, enter the following settings:

Step 1: Stationary
1 In the Model Builder window, click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 In the table, enter the following settings:

R O O T

Add five more studies for the other discretizations and element shapes. The parameter 
values are copied from the first study.

A D D  S T U D Y

1 In the Study toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study in the window toolbar.

S T U D Y  Q U A D  L I N E A R

Parametric Sweep
In the Model Builder window, under Study Quad Linear right-click Parametric Sweep and 
choose Copy.

S T U D Y  2

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study Quad Quadratic in the Label text field.

3 Right-click Study Quad Quadratic and choose Paste Parametric Sweep.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

Parameter name Parameter value list Parameter unit

div (Mesh refinement factor) 1 2 3 4 8 12 16 24 32 48 
64

Physics interface Solve for Discretization

Solid Mechanics (solid) √ Discretization Linear
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3 Click Add Study in the window toolbar.

S T U D Y  3

1 In the Model Builder window, click Study 3.

2 In the Settings window for Study, type Study Quad Cubic in the Label text field.

3 Right-click Study Quad Cubic and choose Paste Parametric Sweep.

Step 1: Stationary
1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 In the table, enter the following settings:

M E S H  1

Create a triangular mesh. This mesh case will be the default for the new studies created 
from now on.

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Duplicate.

M E S H  2

In the Settings window for Mesh, type Mesh Tria in the Label text field.

Convert 1
Right-click Component 1 (comp1)>Meshes>Mesh Tria and choose More Operations>Convert.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

3 Click Add Study in the window toolbar.

S T U D Y  4

1 In the Model Builder window, click Study 4.

2 In the Settings window for Study, type Study Tria Linear in the Label text field.

Parametric Sweep
Right-click Study Tria Linear and choose Paste Parametric Sweep.

Physics interface Solve for Discretization

Solid Mechanics (solid) √ Discretization Cubic
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Step 1: Stationary
1 In the Settings window for Stationary, click to expand the Mesh Selection section.

2 Locate the Physics and Variables Selection section. In the table, enter the following 
settings:

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

3 Click Add Study in the window toolbar.

S T U D Y  5

1 In the Model Builder window, click Study 5.

2 In the Settings window for Study, type Study Tria Quadratic in the Label text field.

Parametric Sweep
Right-click Study Tria Quadratic and choose Paste Parametric Sweep.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

3 Click Add Study in the window toolbar.

4 In the Study toolbar, click Add Study to close the Add Study window.

S T U D Y  6

1 In the Model Builder window, click Study 6.

2 In the Settings window for Study, type Study Tria Cubic in the Label text field.

3 Right-click Study Tria Cubic and choose Paste Parametric Sweep.

Step 1: Stationary
1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 In the table, enter the following settings:

Physics interface Solve for Discretization

Solid Mechanics (solid) √ Discretization Linear

Physics interface Solve for Discretization

Solid Mechanics (solid) √ Discretization Cubic
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S T U D Y  Q U A D  L I N E A R

In the Study toolbar, click Compute.

S T U D Y  Q U A D  Q U A D R A T I C

1 In the Model Builder window, click Study Quad Quadratic.

2 In the Settings window for Study, locate the Study Settings section.

3 Clear the Generate default plots check box.

4 In the Study toolbar, click Compute.

S T U D Y  Q U A D  C U B I C

1 In the Model Builder window, click Study Quad Cubic.

2 In the Settings window for Study, locate the Study Settings section.

3 Clear the Generate default plots check box.

4 In the Study toolbar, click Compute.

S T U D Y  T R I A  L I N E A R

1 In the Model Builder window, click Study Tria Linear.

2 In the Settings window for Study, locate the Study Settings section.

3 Clear the Generate default plots check box.

4 In the Study toolbar, click Compute.

S T U D Y  T R I A  Q U A D R A T I C

1 In the Model Builder window, click Study Tria Quadratic.

2 In the Settings window for Study, locate the Study Settings section.

3 Clear the Generate default plots check box.

4 In the Study toolbar, click Compute.

S T U D Y  T R I A  C U B I C

1 In the Model Builder window, click Study Tria Cubic.

2 In the Settings window for Study, locate the Study Settings section.

3 Clear the Generate default plots check box.

4 In the Study toolbar, click Compute.
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R E S U L T S

1D Plot Group 3
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Mesh convergence sy at D in the Label 
text field.

Point Graph 1
1 Right-click Mesh convergence sy at D and choose Point Graph.

2 Select Point 11 only.

3 In the Settings window for Point Graph, locate the Data section.

4 From the Dataset list, choose Study Quad Linear/Parametric Solutions 1 (sol2).

5 Locate the y-Axis Data section. In the Expression text field, type abs(solid.sy/
sy_ref-1).

6 Locate the x-Axis Data section. From the Parameter list, choose Expression.

7 In the Expression text field, type div/0.417.

8 Click to expand the Coloring and Style section. Find the Line markers subsection. From 
the Marker list, choose Cycle.

9 From the Positioning list, choose In data points.

10 Click to expand the Legends section. Select the Show legends check box.

11 From the Legends list, choose Manual.

12 In the table, enter the following settings:

Point Graph 2
1 Right-click Point Graph 1 and choose Duplicate.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Dataset list, choose Study Quad Quadratic/Parametric Solutions 2 (sol15).

4 Locate the Legends section. In the table, enter the following settings:

Point Graph 3
1 Right-click Point Graph 2 and choose Duplicate.

Legends

1st order quad

Legends

2nd order quad
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2 In the Settings window for Point Graph, locate the Data section.

3 From the Dataset list, choose Study Quad Cubic/Parametric Solutions 3 (sol28).

4 Locate the Legends section. In the table, enter the following settings:

Point Graph 4
1 Right-click Point Graph 3 and choose Duplicate.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Dataset list, choose Study Tria Linear/Parametric Solutions 4 (sol41).

4 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Dash-dot.

5 Locate the Legends section. In the table, enter the following settings:

Point Graph 5
1 Right-click Point Graph 4 and choose Duplicate.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Dataset list, choose Study Tria Quadratic/Parametric Solutions 5 (sol54).

4 Locate the Legends section. In the table, enter the following settings:

Point Graph 6
1 Right-click Point Graph 5 and choose Duplicate.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Dataset list, choose Study Tria Cubic/Parametric Solutions 6 (sol67).

4 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Dash-dot.

5 Locate the Legends section. In the table, enter the following settings:

Legends

3rd order quad

Legends

1st order tria

Legends

2nd order tria

Legends

3rd order tria
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Point Graph 4
1 In the Model Builder window, click Point Graph 4.

2 In the Settings window for Point Graph, locate the Coloring and Style section.

3 From the Color list, choose Cycle (reset).

4 Find the Line markers subsection. From the Marker list, choose Cycle (reset).

Mesh convergence sy at D
1 In the Model Builder window, click Mesh convergence sy at D.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the x-axis label check box.

4 In the associated text field, type 1/h (1/m).

5 Select the y-axis label check box.

6 In the associated text field, type Relative error.

7 Click to expand the Title section. From the Title type list, choose None.

8 Locate the Axis section. Select the x-axis log scale check box.

9 Select the y-axis log scale check box.

10 Locate the Legend section. From the Position list, choose Lower left.

11 In the Mesh convergence sy at D toolbar, click Plot.

Mesh convergence sy at D 1
1 Right-click Mesh convergence sy at D and choose Duplicate.

2 In the Settings window for 1D Plot Group, type Mesh convergence sx at D in the Label 
text field.

Point Graph 1
1 In the Model Builder window, expand the Results>Mesh convergence sx at D node, then 

click Point Graph 1.

2 In the Settings window for Point Graph, locate the y-Axis Data section.

3 In the Expression text field, type abs(solid.sx/sy_ref).

4 Do the same modification for all graphs from Point Graph 2 to Point Graph 6.

5 In the Mesh convergence sx at D toolbar, click Plot.

Mesh convergence sx at D 1
1 In the Model Builder window, right-click Mesh convergence sx at D and choose Duplicate.

2 In the Settings window for 1D Plot Group, type Mesh convergence sxy at D in the 
Label text field.
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Point Graph 1
1 In the Model Builder window, expand the Results>Mesh convergence sxy at D node, then 

click Point Graph 1.

2 In the Settings window for Point Graph, locate the y-Axis Data section.

3 In the Expression text field, type abs(solid.sxy/sy_ref).

4 Do the same modification for all graphs from Point Graph 2 to Point Graph 6.

5 In the Mesh convergence sxy at D toolbar, click Plot.

Mesh convergence sy at D 1
1 In the Model Builder window, right-click Mesh convergence sy at D and choose Duplicate.

2 In the Settings window for 1D Plot Group, type Mesh convergence sy at D (by 
DOFs) in the Label text field.

Point Graph 1
1 In the Model Builder window, expand the Results>Mesh convergence sy at D (by DOFs) 

node, then click Point Graph 1.

2 In the Settings window for Point Graph, locate the x-Axis Data section.

3 In the Expression text field, type 12*div^2*1+10*div*1+2+6*div^2*4.

4 Do the same modification for all graphs from Point Graph 2 to Point Graph 6 according 
to the following table:

5 In the table, enter the following settings:

Mesh convergence sy at D (by DOFs)
1 In the Model Builder window, click Mesh convergence sy at D (by DOFs).

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 In the x-axis label text field, type Number of degrees of freedom.

4 In the Mesh convergence sy at D (by DOFs) toolbar, click Plot.

Point Evaluation 1
1 In the Results toolbar, click Point Evaluation.

Name x-Axis Data Expression

Point Graph 2 12*div^2*4+10*div*2+2+6*div^2*9

Point Graph 3 12*div^2*9+10*div*3+2+6*div^2*16

Point Graph 4 12*div^2*1+10*div*1+2+6*div^2*2*3

Point Graph 5 12*div^2*4+10*div*2+2+6*div^2*2*6

Point Graph 6 12*div^2*9+10*div*3+2+6*div^2*2*10
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2 Select Point 11 only.

3 In the Settings window for Point Evaluation, locate the Data section.

4 From the Dataset list, choose Study Quad Linear/Parametric Solutions 1 (sol2).

5 From the Parameter selection (div) list, choose From list.

6 In the Parameter values (div) list, choose 1 and 2.

7 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component 1>Solid Mechanics>Stress>Stress tensor (spatial frame) - N/m²>

solid.sy - Stress tensor, y component.

8 Locate the Expressions section. In the table, enter the following settings:

9 Click Evaluate.

Point Evaluation 2
1 Right-click Point Evaluation 1 and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Study Quad Quadratic/Parametric Solutions 2 (sol15).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Point Evaluation 3
1 Right-click Point Evaluation 2 and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Study Quad Cubic/Parametric Solutions 3 (sol28).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Point Evaluation 4
1 Right-click Point Evaluation 3 and choose Duplicate.

Expression Unit Description

solid.sy MPa Stress, quad linear

Expression Unit Description

solid.sy MPa Stress, quad quadratic

Expression Unit Description

solid.sy MPa Stress, quad cubic
23 |  S T R E S S  A N A L Y S I S  O F  A N  E L L I P T I C  M E M B R A N E



2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Study Tria Linear/Parametric Solutions 4 (sol41).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Point Evaluation 5
1 Right-click Point Evaluation 4 and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Study Tria Quadratic/Parametric Solutions 5 (sol54).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Point Evaluation 6
1 Right-click Point Evaluation 5 and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Study Tria Cubic/Parametric Solutions 6 (sol67).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Stress (solid)
1 In the Model Builder window, click Stress (solid).

2 In the Settings window for 2D Plot Group, locate the Data section.

3 From the Dataset list, choose Study Quad Quadratic/Parametric Solutions 2 (sol15).

4 From the Parameter value (div) list, choose 4.

Surface 1
1 In the Model Builder window, expand the Stress (solid) node, then click Surface 1.

Expression Unit Description

solid.sy MPa Stress, tria linear

Expression Unit Description

solid.sy MPa Stress, tria quadratic

Expression Unit Description

solid.sy MPa Stress, tria cubic
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2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>Stress>

Stress tensor (spatial frame) - N/m²>solid.sy - Stress tensor, y component.

3 Locate the Expression section. From the Unit list, choose MPa.

4 In the Stress (solid) toolbar, click Plot.

Stress (solid)
1 In the Model Builder window, click Stress (solid).

2 In the Settings window for 2D Plot Group, locate the Color Legend section.

3 Select the Show maximum and minimum values check box.

4 Click the Zoom Extents button in the Graphics toolbar.
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Introduction

Laminated shells made of carbon fiber reinforced plastic (CRFP) are common in a large 
variety of applications due to their high strength to weight ratio. Evaluation of the 
structural integrity of a laminated shell for a set of applied loads is necessary to make the 
design of such structures reliable.

This example shows how to model laminated shells using an ordinary Linear Elastic 
Material model in the Shell interfaces available with the Structural Mechanics Module. The 
same example can be modeled using a Layered Linear Elastic Material model in the Shell 
interface. The model using the latter approach can be found in the Verification Examples 
folder of the Composite Materials Application Library. 

The structural integrity of a stack of shells with different fiber orientations is assessed 
through the parameters called Failure Index and Safety Factor, using different polynomial 
failure criteria. Because of the orientation, each ply will have different strength in the 
longitudinal and transversal direction, and hence different response to the loading. The 
analysis using a polynomial failure criterion is termed first ply failure analysis, where 
failure in any ply is considered as failure of the whole laminate. In this example, seven 
different polynomial criteria are compared.

The original model is a NAFEMS benchmark model, described in Benchmarks for 
Membrane and Bending Analysis of Laminated Shells, Part 2: Strength Analysis 
(Ref. 1). The COMSOL Multiphysics solutions are compared with the reference data.

Model Definition

The physical geometry of the problem consists of four square shells stacked above each 
other. The side length is 1 cm and each layer has thickness of 0.05 mm. The laminate (90/
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-45/45/0) is subjected to an in-plane axial tensile load. The actual geometry of the 
laminate is shown in Figure 1.

Figure 1: Geometry of layered shell with ply orientations 90/-45/45/0 from top to bottom.

M A T E R I A L  P R O P E R T I E S

The orthotropic material properties (Young’s modulus, shear modulus, and Poisson’s 
ratio) are given in Table 1:

The tensile, compressive, and shear strengths are given in Table 2.

All material properties and strengths are given in the local material directions, where the 
first axis is aligned with the fiber orientation.

TABLE 1:  MATERIAL PROPERTIES.

Material property Value 

{E1,E2,E3} {207,7.6,7.6}(GPa)

{G12,G23,G13} {5,5,5}(GPa)

{υ12,υ23,υ13} {0.3,0,0}

TABLE 2:  MATERIAL STRENGTHS IN MPA.

Material strengths Value

{σt1,σt2,σt3} {500,5,5}(MPa)

{σc1,σc2,σc3} {350,75,75}(MPa)

{σss23,σss13,σss12} {35,35,35}(MPa)
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B O U N D A R Y  C O N D I T I O N S

The applied boundary conditions and loads on each node are given in the table below.

The numbers within parenthesis are point numbers in COMSOL Multiphysics geometry. 
The boundary conditions provided in the benchmark specifications apply to the layered 
shell as a single entity. The rotation around the z-axis, θz, is automatically constrained so 
it does not need to be considered.

F A I L U R E  C R I T E R I A

Seven different failure criteria are used to predict the failure in the layered shell. These are 
Tsai-Wu Anisotropic, Tsai-Wu Orthotropic, Tsai-Hill, Hoffman, Modified Tsai-Hill, Azzi-
Tsai-Hill, and Norris criteria.

Tsai-Wu Anisotropic
For the Tsai-Wu Anisotropic criterion, the material strength parameters are taken from 
Table 2 in order to obtain the same results as with the Tsai-Wu Orthotropic criterion. This 
exercise is done in order to verify the correctness of the implementation. The nonzero 
elements in the second rank tensor f are given below. Here, and in the following equations, 
repeated indices do not imply summation.

 (1)

The nonzero elements in the fourth rank tensor F are

 (2)

TABLE 3:  NODE LOCATIONS AND BOUNDARY CONDITIONS.

Node X
(m)

Y
(m)

Z
(m)

Constrained 
DOF

Fx
(N)

Fy
(N)

Fz
(N)

1(1) 0 0 0 u, v, w, θx, 
θy, θz

0 0 0

2(3) 0.01 0 0 θz 7.5 0 0

3(4) 0.01 0.01 0 θz 7.5 0 0

4(2) 0 0.01 0 u, θz 0 0 0

fii
1

σti
------- 1

σci
------- i;– 1 2 3, ,= =

Fii
1

σtiσci
---------------     i; 1 2 3, ,= =

F44
1

σss23
2

-------------    F55, 1

σss13
2

-------------    F66, 1

σss12
2

-------------= = =

Fij
1
2
--- FiiFjj( )–     i; 1 2 3, ,= =
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Modified Tsai-Hill Orthotropic
The Hill criterion in Ref. 1 is called the Modified Tsai-Hill Orthotropic criterion in 
COMSOL Multiphysics.

Ref. 1 does not give results for either the Tsai-Wu Anisotropic, Tsai-Hill, Azzi-Tsai-Hill, 
nor Norris criteria; so the analytical results for failure index and safety factor are here 
derived from the stress values given in Ref. 1.

The stresses from Ref. 1 are given in Table 4. Apart from σ11, σ22, and σ12, all other stress 
components are either zero or negligible.

For all the selected polynomial criteria, the failure index (FI) is written as

 (3)

where σi is the 6-by-1 stress vector (sorted using Voigt notation), Fij is a 6-by-6 symmetric 
matrix (fourth rank tensor) that contains the coefficients for the quadratic terms, and fi is 
a 6-by-1 vector (second rank tensor) that contains the linear terms. A failure index equal 
to or greater than 1.0 indicates failure in the material. In order to find the safety factor SF, 
the applied stress in Equation 3 is multiplied by the safety factor SF, and the failure index 
FI is set equal to 1.0, which results in a quadratic equation of the form

 (4)

where  and .

The lowest positive root in Equation 4 is selected as the safety factor. Based on the stress 
values given in Table 4, the failure index and safety factor are computed for the criteria for 
which results in Ref. 1 are missing.

Tsai-Wu Anisotropic
For the Tsai-Wu Anisotropic criterion, the nonzero elements of the vector fi and the 
matrix Fij are given by Equation 1 and Equation 2. By taking values of stresses from 

TABLE 4:  STRESSES IN DIFFERENT PLIES.

Stresses Ply 1 Ply 2 Ply 3 Ply 4

σ11 (MPa) -5.128 12.59 8.520 9.357

σ22 (MPa) 4.407 1.983 0.125 -1.859

σ12 (MPa) -1.663 2.572 -2.051 -0.5557

FI σiFijσj σifi+=

a SF2 b SF+ 1=

a σiFijσj= b σifi=
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Table 4, the failure index and safety factor are computed from Equation 3 and Equation 4, 
and given in Table 5 below.

Tsai-Hill Orthotropic
For the Tsai-Hill Orthotropic criterion, all elements of the vector fi are zero, while the 
nonzero elements of the matrix Fij are given by the Equation 5.

 (5)

By taking values of stresses from Table 4, the failure index and safety factor are computed 
from Equation 3, Equation 4, and Equation 5, and given in Table 6 below.

Azzi-Tsai-Hill
For the Azzi-Tsai-Hill criterion, all elements of the vector fi are zero, while the nonzero 
elements of the matrix Fij are given by Equation 6.

TABLE 5:  ANALYTIC VALUES OF FAILURE INDEX AND SAFETY FACTOR FOR TSAI-WU ANISOTROPIC CRITERION.

Index Ply 1 Ply 2 Ply 3 Ply 4

FI 0.8840 0.3730 0.0199 -0.34309

SF 1.122 2.536 14.30 31.88

TABLE 6:  ANALYTIC VALUES OF FAILURE INDEX AND SAFETY FACTOR FOR TSAI-HILL CRITERION.

Index Ply 1 Ply 2 Ply 3 Ply 4

FI 0.7795 0.16323 0.0043 0.1390

SF 1.132 2.474 15.15 2.682

Fii
1

σti
2

------- i; 1 2 3

F44

, ,

1

σss23
2

------------- F55, 1

σss13
2

------------- F66, 1

σss12
2

-------------

Fij
1
2
--- Fii Fjj Fkk–+( )– i;= j k i,≠ ≠ 1 2 3, ,

= =

= = =

=
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 (6)

By taking values of the stresses from Table 4, the failure index and safety factor are 
computed from Equation 3, Equation 4, and Equation 6, and given in Table 7 below.

Norris
For the Norris criterion, all elements of the vector fi are zero, while the nonzero elements 
of the matrix Fij are given by Equation 7.

 (7)

TABLE 7:  ANALYTIC VALUES OF FAILURE INDEX AND SAFETY FACTOR FOR AZZI-TSAI-HILL CRITERION.

Index Ply 1 Ply 2 Ply 3 Ply 4

FI 0.7796 0.1632 0.00435 0.00128

SF 1.132 2.474 15.15 27.87

σi 0:   Fii
1

σti
2

-------=
 
 
 

≥

σi 0:   Fii
1

σci
2

-------=
 
 
 

<

   i; 1 2,=











F66
1

σss12
2

-------------=

σ1 0:   F12
1

2σt1
2

------------–=
 
 
 

≥

σ1 0:   F12
1

2σc1
2

------------–=
 
 
 

<











σi 0:   Fii
1

σti
2

-------=
 
 
 

≥

σi 0:   Fii
1

σci
2

-------=
 
 
 

<

   i; 1 2,=











F66
1

σss12
2

-------------=

F12
1
2
--- F11F22( )–=
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By taking values of the stresses from Table 4, the failure index and safety factor are 
computed from Equation 3, Equation 4, and Equation 7, and given in Table 8 below. 

Note that for the current model, failure index and safety factor are computed at the 
midplane of each shell interface. However, COMSOL Multiphysics actually computes 
failure index, safety factor, damage index, and margin of safety at bottom, middle, and top 
surfaces of the shell, as well as the most critical of the three values.

Results and Discussion

The computed stresses are shown in Table 4, while Table 5 through Table 8 show the 
analytical values for failure index and safety factor (reserve factor) for certain failure 
criteria. For the Tsai-Wu Orthotropic, Modified Tsai-Hill, and Hoffman criteria, the 
failure index and safety factor are taken from Ref. 1. The results are compared with results 
from COMSOL Multiphysics.

TABLE 8:  ANALYTIC VALUES OF FAILURE INDEX AND SAFETY FACTOR FOR NORRIS CRITERION.

Index Ply 1 Ply 2 Ply 3 Ply 4

FI 0.7923 0.1533 0.0039 0.00168

SF 1.126 2.553 15.95 24.38

TABLE 9:  COMPARISON OF STRESSES FOR A LAYERED SHELL.

Ply σ11 from 
benchmark 

σ11 from 
COMSOL

σ22 from 
benchmark 

σ22 from 
COMSOL

σ12 from 
benchmark 

σ12 from 
COMSOL

Ply 1 -5.128E6 -5.128E6 4.407E6 4.407E6 -1.663E6 -1.663E6

Ply 2 1.259E7 1.259E7 1.983E6 1.983E6 2.572E6 2.571E6

Ply 3 8.520E6 8.520E6 1.256E5 1.256E5 -2.051E6 -2.051E6

Ply 4 9.357E6 9.357E6 -1.859E6 -1.859E6 -5.557E5 -5.557E5

TABLE 10:  COMPARISON OF FAILURE INDEX (FI) AND SAFETY FACTORS (SF) FOR PLY 1 (90 DEGREE PLY).

Criterion FI from 
benchmark or 
analytical 
computations

FI from 
COMSOL

SF from 
benchmark or 
analytical 
computations

SF from 
COMSOL

Tsai-Wu Orthotropic 0.8840 0.8841 1.122 1.1223

Tsai-Hill 0.7795 0.7794 1.132 1.1327

Hoffman 0.8811 0.8814 1.1253 1.1258

Modified Tsai-Hill 0.7795 0.7794 1.1325 1.1327
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.

Azzi-Tsai-Hill 0.7796 0.7794 1.132 1.1327

Norris 0.7923 0.7883 1.126 1.1262

Tsai-Wu Anisotropic 0.8840 0.8841 1.122 1.1223

TABLE 11:  COMPARISON OF FAILURE INDEX (FI) AND SAFETY FACTORS (SF) FOR PLY 2 (-45 DEGREE PLY).

Criterion FI from 
benchmark or 
analytical 
computations

FI from 
COMSOL

SF from 
benchmark or 
analytical 
computations

SF from 
COMSOL

Tsai-Wu Orthotropic 0.3730 0.3731 2.5367 2.5367

Tsai-Hill 0.1632 0.1632 2.474 2.4748

Hoffman 0.3763 0.3760 2.4944 2.4941

Modified Tsai-Hill 0.1632 0.1632 2.4748 2.4748

Azzi-Tsai-Hill 0.1632 0.1632 2.474 2.4748

Norris 0.1533 0.1533 2.553 2.5534

Tsai-Wu Anisotropic 0.37308 0.3731 2.536 2.5367

TABLE 12:  COMPARISON OF FAILURE INDEX (FI) AND SAFETY FACTORS (SF) FOR PLY 3(45 DEGREE PLY).

Criterion FI from 
benchmark or 
analytical 
computations

FI from 
COMSOL

SF from 
benchmark or 
analytical 
computations

SF from 
COMSOL

Tsai-Wu Orthotropic 0.0199 0.0199 14.302 14.302

Tsai-Hill 0.0043 0.0043 15.15 15.157

Hoffman 0.0200 0.0200 14.098 14.098

Modified Tsai-Hill 0.0043 0.0043 15.157 15.157

Azzi-Tsai-Hill 0.0043 0.0043 15.15 15.157

Norris 0.0039 0.0039 15.95 15.954

Tsai-Wu Anisotropic 0.0199 0.0199 14.30 14.302

TABLE 10:  COMPARISON OF FAILURE INDEX (FI) AND SAFETY FACTORS (SF) FOR PLY 1 (90 DEGREE PLY).

Criterion FI from 
benchmark or 
analytical 
computations

FI from 
COMSOL

SF from 
benchmark or 
analytical 
computations

SF from 
COMSOL
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For many industrial and real life applications, the safety factor (SF) is more useful than the 
failure index (FI). The safety factor (or reserve factor) gives a direct indication of how close 
the component is to failure. Figure 2 shows the Hoffman safety factor (SF) at the 
midplane for the different plies. Ply 1 (90-degree ply) is close to failure as expected because 
of its orientation, where fibers are perpendicular to the loading direction.

Figure 2: Hoffman safety factors at midplanes for a stack of shells.

TABLE 13:  COMPARISON OF FAILURE INDEX (FI) AND SAFETY FACTORS (SF) FOR PLY 4 (0 DEGREE PLY).

Criterion FI from 
benchmark or 
analytical 
computations

FI from 
COMSOL

SF from 
benchmark or 
analytical 
computations

SF from 
COMSOL

Tsai-Wu Orthotropic -0.3430 -0.3430 31.885 31.884

Tsai-Hill 0.1390 0.1390 2.68 2.682

Hoffman -0.3451 -0.3450 37.876 37.876

Modified Tsai-Hill 0.00140 0.00135 27.12 27.124

Azzi-Tsai-Hill 0.00128 0.00126 27.87 27.877

Norris 0.00168 0.00168 24.38 24.388

Tsai-Wu Anisotropic -0.3430 -0.3430 31.88 31.884
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The von Mises stresses in all plies are shown in Figure 3. The stress in ply 1 is the lowest, 
but this layer is still more susceptible to failure due to the orientation of its fibers.

Figure 3: von Mises stress in a stack of shells.

Notes About the COMSOL Implementation

This layered shell is modeled using four separate Shell interfaces on top of each other. All 
four interfaces are located on the same boundary, and share the translational and rotational 
degrees of freedom. Is is only the different values of the offset properties which describes 
the stacking.

The boundary conditions provided in the benchmark specifications apply to the layered 
shell as a single entity. When implemented in this model, special attention must be paid to 
the boundary condition stating that in one point, only the x-translation should be 
constrained. In the shell sense, this is a condition on the midsurface of the stack, which is 
between ply 2 and ply 3. Setting the degree of freedom u to zero, would in this case imply 
that also the rotation around the y-axis is constrained, since it would be applied on all 
layers. The intended boundary condition is instead implemented by stating that the x-
displacement in ply 3 should be the negative of the x-displacement in ply 2.
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Reference

1. P. Hopkins, Benchmarks for Membrane and Bending Analysis of Laminated Shells, 
Part 2: Strength Analysis, NAFEMS, 2005.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/failure_prediction_in_a_layered_shell

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Shell (shell).

3 Click Add.

4 In the Select Physics tree, select Structural Mechanics>Shell (shell).

5 Click Add.

6 In the Select Physics tree, select Structural Mechanics>Shell (shell).

7 Click Add.

8 In the Select Physics tree, select Structural Mechanics>Shell (shell).

9 Click Add.

10 Click Study.

11 In the Select Study tree, select General Studies>Stationary.

12 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
Load the text file containing the material properties and material strengths.

1 In the Model Builder window, under Global Definitions click Parameters 1.
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2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
failure_prediction_in_a_layered_shell_materialproperties.txt.

D E F I N I T I O N S

Set up three rotated coordinate systems.

Rotated System 2 (sys2)
1 In the Definitions toolbar, click Coordinate Systems and choose Rotated System.

2 In the Settings window for Rotated System, locate the Rotation section.

3 Find the Euler angles (Z-X-Z) subsection. In the α text field, type pi/2.

Rotated System 3 (sys3)
1 Right-click Rotated System 2 (sys2) and choose Duplicate.

2 In the Settings window for Rotated System, locate the Rotation section.

3 Find the Euler angles (Z-X-Z) subsection. In the α text field, type -pi/4.

Rotated System 4 (sys4)
1 Right-click Rotated System 3 (sys3) and choose Duplicate.

2 In the Settings window for Rotated System, locate the Rotation section.

3 Find the Euler angles (Z-X-Z) subsection. In the α text field, type pi/4.

G E O M E T R Y  1

Work Plane 1 (wp1)
In the Geometry toolbar, click Work Plane.

Plane Geometry
In the Model Builder window, click Plane Geometry.

Work Plane 1 (wp1)>Square 1 (sq1)
1 In the Work Plane toolbar, click Square.

2 In the Settings window for Square, locate the Size section.

3 In the Side length text field, type 1e-2.

4 Click Build Selected.

5 Click the Zoom Extents button in the Graphics toolbar.
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M A T E R I A L S

Material 1 (mat1)
In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

S H E L L  ( S H E L L )

Activate Advanced Physics option from Show button.

1 Click the Show More Options button in the Model Builder toolbar.

2 In the Show More Options dialog box, in the tree, select the check box for the node 
Physics>Advanced Physics Options.

3 Click OK.

The layered shell is modeled using four separate shell interfaces located on the same 
boundary (mesh surface), sharing the degrees of freedom. The stacking of the shells is 
done using a Physical Offset option. With this option the constraints and loads are 
transferred to the actual midplane of the shells without modeling it.

As the same degrees of freedom are to be shared by all shell interfaces, set the 
displacement field to u and the displacement of the shell normals to ar for Shell 2, Shell 
3, and Shell 4.

Set the discretization for the displacement field to Linear in order to resemble the 
benchmark example.

The results given in the benchmark example are at the midplane of each shell layer. Set 
the Default Through-Thickness Result Location to zero for all shells.

4 In the Settings window for Shell, type Ply 1 in the Label text field.

5 In the Name text field, type shell1.

6 Click to expand the Default Through-Thickness Result Location section. In the z text field, 
type 0.

7 Click to expand the Discretization section. From the Displacement field list, choose 
Linear.

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Ply 1 (shell1) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type th.

4 From the Offset definition list, choose Physical offset.
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5 In the zoffset text field, type 1.5*th.

Linear Elastic Material 1
Choose the orthotropic solid model for the linear elastic material and assign Rotated 

System 2 as Shell Local System.

1 In the Model Builder window, click Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Solid model list, choose Orthotropic.

Shell Local System 1
1 In the Model Builder window, expand the Linear Elastic Material 1 node, then click 

Shell Local System 1.

2 In the Settings window for Shell Local System, locate the Coordinate System Selection 
section.

3 From the Coordinate system list, choose Rotated System 2 (sys2).

S H E L L  2  ( S H E L L 2 )

1 In the Model Builder window, under Component 1 (comp1) click Shell 2 (shell2).

2 In the Settings window for Shell, type Ply 2 in the Label text field.

3 Locate the Discretization section. From the Displacement field list, choose Linear.

4 Locate the Default Through-Thickness Result Location section. In the z text field, type 0.

5 Click to expand the Dependent Variables section. In the Displacement field text field, type 
u.

6 In the Displacement of shell normals text field, type ar.

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Ply 2 (shell2) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type th.

4 From the Offset definition list, choose Physical offset.

5 In the zoffset text field, type 0.5*th.

Linear Elastic Material 1
Choose the orthotropic solid model for the linear elastic material and assign Rotated 

System 3 as Shell Local System.
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1 In the Model Builder window, click Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Solid model list, choose Orthotropic.

Shell Local System 1
1 In the Model Builder window, expand the Linear Elastic Material 1 node, then click 

Shell Local System 1.

2 In the Settings window for Shell Local System, locate the Coordinate System Selection 
section.

3 From the Coordinate system list, choose Rotated System 3 (sys3).

S H E L L  3  ( S H E L L 3 )

1 In the Model Builder window, under Component 1 (comp1) click Shell 3 (shell3).

2 In the Settings window for Shell, type Ply 3 in the Label text field.

3 Locate the Discretization section. From the Displacement field list, choose Linear.

4 Locate the Default Through-Thickness Result Location section. In the z text field, type 0.

5 Locate the Dependent Variables section. In the Displacement field text field, type u.

6 In the Displacement of shell normals text field, type ar.

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Ply 3 (shell3) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type th.

4 From the Offset definition list, choose Physical offset.

5 In the zoffset text field, type -0.5*th.

Linear Elastic Material 1
Choose the orthotropic solid model for the linear elastic material and assign Rotated 

System 4 as Shell Local System.

1 In the Model Builder window, click Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Solid model list, choose Orthotropic.
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Shell Local System 1
1 In the Model Builder window, expand the Linear Elastic Material 1 node, then click 

Shell Local System 1.

2 In the Settings window for Shell Local System, locate the Coordinate System Selection 
section.

3 From the Coordinate system list, choose Rotated System 4 (sys4).

S H E L L  4  ( S H E L L 4 )

1 In the Model Builder window, under Component 1 (comp1) click Shell 4 (shell4).

2 In the Settings window for Shell, type Ply 4 in the Label text field.

3 Locate the Discretization section. From the Displacement field list, choose Linear.

4 Locate the Default Through-Thickness Result Location section. In the z text field, type 0.

5 Locate the Dependent Variables section. In the Displacement field text field, type u.

6 In the Displacement of shell normals text field, type ar.

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Ply 4 (shell4) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type th.

4 From the Offset definition list, choose Physical offset.

5 In the zoffset text field, type -1.5*th.

Linear Elastic Material 1
1 In the Model Builder window, click Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Solid model list, choose Orthotropic.

M A T E R I A L S

Material 1 (mat1)
Select the material properties for the orthotropic material from Table 1.

1 In the Model Builder window, under Component 1 (comp1)>Materials click 
Material 1 (mat1).

2 In the Settings window for Material, locate the Material Contents section.
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3 In the table, enter the following settings:

P L Y  1  ( S H E L L 1 )

Linear Elastic Material 1
In the Model Builder window, under Component 1 (comp1)>Ply 1 (shell1) click 
Linear Elastic Material 1.

Safety 1
1 In the Physics toolbar, click Attributes and choose Safety.

2 In the Settings window for Safety, type Safety: Tsai-Wu Orthotropic Criterion 
in the Label text field.

3 Locate the Failure Model section. From the Failure criterion list, choose Tsai-

Wu Orthotropic.

Property Variable Value Unit Property group

Young’s 
modulus

{Evector1, 
Evector2, 
Evector3}

{E1,E2,
E3}

Pa Orthotropic

Poisson’s 
ratio

{nuvector1, 
nuvector2, 
nuvector3}

{nu12,
nu23,
nu13}

1 Orthotropic

Shear 
modulus

{Gvector1, 
Gvector2, 
Gvector3}

{G,G,G} N/m² Orthotropic

Density rho 7800 kg/m³ Basic
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Safety 2, 3, 4, 5, 6, 7
1 Create six similar Safety nodes by duplicating the Safety 1 node, and replace the failure 

criterion as given in the table below:

Select all Safety nodes under  Play 1 (shell1)>> Linear Elastic Material 1, and right click 
to Copy. Then, go to Linear Elastic Material 1 under  Play 2 (shell2), Play 3 (shell3), and 
Ply 4 (shell4) and right click to Paste Mutiple Items.

M A T E R I A L S

Material 1 (mat1)
Enter the material properties for the Tsai-Wu Anisotropic criterion as shown in Equation 1 
and Equation 2.

1 In the Model Builder window, under Component 1 (comp1)>Materials click 
Material 1 (mat1).

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

Name Failure Criterion

Safety 2 Tsai-Hill Orthotropic

Safety 3 Hoffman Orthotropic

Safety 4 Modified Tsai-Hill Orthotropic

Safety 5 Azzi-Tsai-Hill Orthotropic

Safety 6 Norris Orthotropic

Safety 7 Tsai-Wu Anisotropic

Property Variable Value Unit Property group

Tensile strengths {sigmats1, 
sigmats2, 
sigmats3}

{Sigmats1,
Sigmats2,
Sigmats3}

Pa Orthotropic 
strength 
parameters, Voigt 
notation

Compressive 
strengths

{sigmacs1, 
sigmacs2, 
sigmacs3}

{Sigmacs1,
Sigmacs2,
Sigmacs3}

Pa Orthotropic 
strength 
parameters, Voigt 
notation

Shear strengths {sigmass1, 
sigmass2, 
sigmass3}

{Sigmass23,
Sigmass13,
Sigmass12}

Pa Orthotropic 
strength 
parameters, Voigt 
notation
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Second rank 
tensor, Voigt 
notation

{F_s1, F_s2, 
F_s3, F_s4, 
F_s5, F_s6}

{1/Sigmats1-1/
Sigmacs1,1/
Sigmats2-1/
Sigmacs2,1/
Sigmats3-1/
Sigmacs3,0,0,
0}

1/Pa Anisotropic 
strength 
parameters, Voigt 
notation

Fourth rank 
tensor, Voigt 
notation

{F_f11, F_f12, 
F_f22, F_f13, 
F_f23, F_f33, 
F_f14, F_f24, 
F_f34, F_f44, 
F_f15, F_f25, 
F_f35, F_f45, 
F_f55, F_f16, 
F_f26, F_f36, 
F_f46, F_f56, 
F_f66} ; F_fij 
= F_fji

{1/(Sigmats1*
Sigmacs1),-
0.5*sqrt(1/
((Sigmats1*
Sigmacs1)*
(Sigmats2*
Sigmacs2))),1/
(Sigmats2*
Sigmacs2),-
0.5*sqrt(1/
((Sigmats1*
Sigmacs1)*
(Sigmats3*
Sigmacs3))),-
0.5*sqrt(1/
((Sigmats2*
Sigmacs2)*
(Sigmats3*
Sigmacs3))),1/
(Sigmats3*
Sigmacs3),0,0,
0,1/
Sigmass23^2,0,
0,0,0,1/
Sigmass13^2,0,
0,0,0,0,1/
Sigmass12^2}

m²·s^4/
kg²

Anisotropic 
strength 
parameters, Voigt 
notation

Density rho 7800 kg/m³ Basic

Young’s modulus {Evector1, 
Evector2, 
Evector3}

{207e9,7.6e9,
7.6e9}

Pa Orthotropic

Poisson’s ratio {nuvector1, 
nuvector2, 
nuvector3}

{0.3,0,0} 1 Orthotropic

Shear modulus {Gvector1, 
Gvector2, 
Gvector3}

{5e9,5e9,5e9} N/m² Orthotropic

Property Variable Value Unit Property group
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P L Y  1  ( S H E L L 1 )

Fixed Constraint 1
1 In the Physics toolbar, click Points and choose Fixed Constraint.

2 Select Point 1 only.

Apply a nodal tensile load of 15 N as an edge load. The load is shared by all shell 
midplanes, hence it is divided by 4 in order to keep a total value of 15 N.

Edge Load 1
1 In the Physics toolbar, click Edges and choose Edge Load.

2 Select Edge 4 only.

3 In the Settings window for Edge Load, locate the Force section.

4 From the Load type list, choose Total force.

5 Specify the Ftot vector as

Now select Fixed Constraint and Edge Load nodes under  Ply 1 (shell1), and right click to 
Copy. Then go to Ply 2 (shell2), Ply 3 (shell3), and Ply 4 (shell4); and right click to Paste 

Mutiple Items.

P L Y  2  ( S H E L L 2 )

To enforce a fixed x-direction translation on Node 2, apply the displacement u0 in the 
x direction to Point 2 of shell2, and the displacement -u0 in the x direction to the same 

Loss factor for 
orthotropic 
Young’s modulus

{eta_Evector
1, 
eta_Evector2, 
eta_Evector3
}

{0,0,0} 1 Orthotropic

Loss factor for 
orthotropic shear 
modulus

{eta_Gvector
1, 
eta_Gvector2
, 
eta_Gvector3
}

{0,0,0} 1 Orthotropic

Ftotal/4 x

0 y

0 z

Property Variable Value Unit Property group
21 |  F A I L U R E  P R E D I C T I O N  I N  A  L A Y E R E D  S H E L L



point of shell3. Also add a Global Equation node under shell3 for the additional degree 
of freedom u0.

1 In the Model Builder window, under Component 1 (comp1) click Ply 2 (shell2).

Prescribed Displacement/Rotation 1
1 In the Physics toolbar, click Points and choose Prescribed Displacement/Rotation.

2 Select Point 2 only.

3 In the Settings window for Prescribed Displacement/Rotation, locate the 
Prescribed Displacement section.

4 Select the Prescribed in x direction check box.

5 In the u0x text field, type u0.

P L Y  3  ( S H E L L 3 )

1 In the Model Builder window, under Component 1 (comp1) click Ply 3 (shell3).

2 In the Physics toolbar, click Points and choose Prescribed Displacement/Rotation.

Prescribed Displacement/Rotation 1
1 Select Point 2 only.

2 In the Settings window for Prescribed Displacement/Rotation, locate the 
Prescribed Displacement section.

3 Select the Prescribed in x direction check box.

4 In the u0x text field, type -u0.

5 Click the Show More Options button in the Model Builder toolbar.

6 In the Show More Options dialog box, in the tree, select the check box for the node 
Physics>Equation-Based Contributions.

7 Click OK.

Global Equations 1
1 In the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Global Equations section.

3 In the table, enter the following settings:

4 Locate the Units section. Click Select Dependent Variable Quantity.

Name f(u,ut,utt,
t) (1)

Initial value 
(u_0) (1)

Initial value 
(u_t0) (1/s)

Description

u0 0 0
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5 In the Physical Quantity dialog box, type displacement in the text field.

6 Click Filter.

7 In the tree, select General>Displacement (m).

8 Click OK.

M E S H  1

Use a single quadrilateral element.

Free Quad 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Free Quad.

2 Select Boundary 1 only.

Distribution 1
1 Right-click Free Quad 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Edge Selection section.

3 From the Selection list, choose All edges.

4 Locate the Distribution section. In the Number of elements text field, type 1.

5 Click Build All.

S T U D Y  1

Switch off the generation of default plots, since each Shell interface will generate three 
plots by default.

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, locate the Study Settings section.

3 Clear the Generate default plots check box.

4 In the Home toolbar, click Compute.

R E S U L T S

In the Model Builder window, expand the Results node.

Cut Point 3D 1
1 In the Results toolbar, click Cut Point 3D.

2 In the Settings window for Cut Point 3D, locate the Point Data section.

3 In the X text field, type 0.5e-2.

4 In the Y text field, type 0.5e-2.
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5 In the Z text field, type 0.

Point Evaluation 1
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, type Failure indices in Ply 1 in the 
Label text field.

3 Locate the Data section. From the Dataset list, choose Cut Point 3D 1.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Table 1
1 In the Model Builder window, expand the Results>Tables node, then click Table 1.

2 In the Settings window for Table, type Failure indices in Ply 1 in the Label text 
field.

Point Evaluation 2, 3, 4
Create three similar Point Evaluation nodes by duplicating the Point Evaluation 1 node, and 
replace the word shell1 in the Expressions by shell2, shell3, and shell4 for Point 

Evaluation 2, Point Evaluation 3, and Point Evaluation 4, respectively. Rename point 
evaluation nodes and tables appropriately.

Point Evaluation 5
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, type Safety factors in Ply 1 in the 
Label text field.

3 Locate the Data section. From the Dataset list, choose Cut Point 3D 1.

Expression Unit Description

shell1.emm1.sf1.f_im 1

shell1.emm1.sf2.f_im 1

shell1.emm1.sf3.f_im 1

shell1.emm1.sf4.f_im 1

shell1.emm1.sf5.f_im 1

shell1.emm1.sf6.f_im 1

shell1.emm1.sf7.f_im 1
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4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Table 5
1 In the Model Builder window, under Results>Tables click Table 5.

2 In the Settings window for Table, type Safety factors in Ply 1 in the Label text field.

Point Evaluation 6, 7, 8
Create three similar Point Evaluation nodes by duplicating the Point Evaluation 5 node and 
replace the word shell1 in the Expressions by shell2, shell3, and shell4 for Point Evaluation 

6, Point Evaluation 7, and Point Evaluation 8, respectively. Rename them appropriately.

Point Evaluation 9
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, type Stresses in Ply 1 in the Label text 
field.

3 Locate the Data section. From the Dataset list, choose Cut Point 3D 1.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Table 9
1 In the Model Builder window, under Results>Tables click Table 9.

2 In the Settings window for Table, type Stresses in Ply 1 in the Label text field.

Expression Unit Description

shell1.emm1.sf1.s_fm 1

shell1.emm1.sf2.s_fm 1

shell1.emm1.sf3.s_fm 1

shell1.emm1.sf4.s_fm 1

shell1.emm1.sf5.s_fm 1

shell1.emm1.sf6.s_fm 1

shell1.emm1.sf7.s_fm 1

Expression Unit Description

shell1.Sl11 N/m^2

shell1.Sl22 N/m^2

shell1.Sl12 N/m^2
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Point Evaluation 10, 11, 12
Create three similar Point Evaluation nodes by duplicating the Point Evaluation 9 node, and 
replace the word shell1 in the Expressions by shell2, shell3, and shell4 for Point Evaluation 

10, Point Evaluation 11, and Point Evaluation 12, respectively. Rename them appropriately.

To visualize von Mises stress in the layered shell, use four different Surface plots for four 
shells in the 3D Plot Group. Modify the Z component in the Deformation node for each 
surface in order to visualize it better.

3D Plot Group 1
1 In the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type von-Mises Stress in Stack of 
Shells in the Label text field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type von-Mises Stress (MPa).

Surface 1
1 Right-click von-Mises Stress in Stack of Shells and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type round(shell1.mises).

4 From the Unit list, choose MPa.

Deformation 1
1 Right-click Surface 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Expression section.

3 In the Z component text field, type w+1.5e-3.

4 Locate the Scale section. Select the Scale factor check box.

5 In the associated text field, type 1.

Surface 2, 3, 4
Create three similar Surface nodes by duplicating the Surface 1 node, and replace the word 
shell1 in the Expression by shell2, shell3, and shell4 for Surface 2, Surface 3, and Surface 4, 
respectively. Replace the choice of color table in the subsequent Surface nodes, and also 
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replace the Z component field in the corresponding Deformation node with the following 
choices in the table:

von-Mises Stress in Stack of Shells
1 In the Model Builder window, click von-Mises Stress in Stack of Shells.

2 In the Settings window for 3D Plot Group, locate the Color Legend section.

3 From the Position list, choose Right double.

4 Click the Zoom Extents button in the Graphics toolbar.

To visualize the Hoffman safety factors in the layered shell, use four different Surface plots 
for the four shells in the 3D Plot Group. Modify the Z component in the Deformation node 
for each surface in order to visualize it better.

3D Plot Group 2
1 In the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Hoffman Safety Factors in Stack 
of Shells in the Label text field.

3 Locate the Title section. From the Title type list, choose Manual.

4 In the Title text area, type Hoffman Safety Factor (1).

Surface 1
1 Right-click Hoffman Safety Factors in Stack of Shells and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type shell1.emm1.sf3.s_fm.

Deformation 1
1 Right-click Surface 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Expression section.

3 In the Z component text field, type w+1.5e-3.

4 Locate the Scale section. Select the Scale factor check box.

5 In the associated text field, type 1.

Name Choice of color table Z component field expression

Surface 2 Cyclic w+0.5e-3

Surface 3 Disco w-0.5e-3

Surface 4 Thermal w-1.5e-3
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Surface 2, 3, 4
Create three similar Surface nodes by duplicating the above node, and replace the word 
shell1 in the Expression by shell2, shell3, and shell4 for Surface 2, Surface 3, and Surface 4, 
respectively. Replace the choice of color table in the subsequent Surface nodes, and also 
replace the Z component field in the corresponding Deformation node with the following 
choices in the table:

Hoffman Safety Factors in Stack of Shells
1 In the Model Builder window, click Hoffman Safety Factors in Stack of Shells.

2 In the Settings window for 3D Plot Group, locate the Color Legend section.

3 From the Position list, choose Right double.

Name Choice of color table Z component field expression

Surface 2 Cyclic w+0.5e-3

Surface 3 Disco w-0.5e-3

Surface 4 Thermal w-1.5e-3
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Introduction

In the following example you compute the eigenfrequencies of a free circular pipe using 
three different approaches:

• An axisymmetric model using the Solid Mechanics interface.

• An axisymmetric model using the Shell interface.

• A sector of a 3D model using cyclic symmetry in the Solid Mechanics interface.

The example is taken from NAFEMS Free Vibration Benchmarks (Ref. 1). The 
eigenfrequencies are compared with the values given in the benchmark report.

As an extension, you will also compute eigenfrequencies with twisting deformation.

Model Definition

The model is NAFEMS Test No 41, “Free Cylinder” described on page 41 in NAFEMS 
Free Vibration Benchmarks, vol. 3 (Ref. 1). The Benchmark tests the capability to handle 
rigid body modes and eigenfrequencies.
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The cylinder is 10 m tall with an inner radius of 1.8 m and a thickness of 0.4 m.

Figure 1: Model geometry in the rz-plane.

In the axisymmetric solid model, the geometry consists of this rectangle.

In the axisymmetric shell interface, the mesh is placed on the line representing the inner 
boundary of the cylinder, and an offset property is used in order to account for the fact 
that the shell model should represent the midsurface.

In the 3D solid model, the rectangle is swept around the axis of revolution, so that a 15° 
sector is formed. As long as 360° is as an exact multiple of the sector angle, any angle could 
have been used.

M A T E R I A L

The material is isotropic linear elastic with E = 2.0·1011 Pa, ν = 0.3, and ρ = 8000 kg/m3.

z

r
1.8 m 0.4 m

10
.0

 m
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L O A D S

In an eigenfrequency analysis loads are not needed.

C O N S T R A I N T S

In the axisymmetric models, no constraints are applied because the cylinder is free. In the 
3D solid model, cyclic symmetry constraints are applied to the cuts in the azimuthal 
direction.

Results

For structural mechanics, there are two possible interpretations of axisymmetry. The most 
common one is that there are no displacements out of the RZ-plane. Another 
interpretation, which also allows twisting motion, is that all derivatives of the 
displacements with respect to the azimuthal coordinate is zero. Such an extension is 
available when using the Solid Mechanics interface.

The original NAFEMS example does not contain out-of-plane displacements, in which 
case there is one rigid body mode. The rigid body mode with an eigenvalue close to zero 
is found in all physics interfaces. The corresponding shape is a pure axial rigid body 
translation without any radial displacement. The eigenfrequencies are in close agreement 
with the target values from the NAFEMS Free Vibration Benchmarks (Ref. 1); see below.

The analytical solution for twisting vibration of a free cylindrical pipe is

 (1)

Here, G is the shear modulus,

 (2)

EIGENFREQUENCY SOLID 
MECHANICS, 
AXISYMMETRY

SHELL , 
AXISYMMETRY

SOLID 
MECHANICS, 
3D

TARGET (Ref. 1)

f2 243.50 243.64 243.50 243.53

f3 377.39 378.16 377.39 377.41

f4 394.21 394.11 394.22 394.11

f5 397.84 397.36 397.84 397.72

f6 405.36 407.43 405.36 405.28

fn
n

2L
------- G

ρ
----=

G E
2 1 ν+( )
---------------------=
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In this case, there is one more rigid body mode: pure rotation around the axis of 
revolution. The computed non-trivial eigenfrequencies have a very good agreement with 
the analytical solution:

Figure 2 shows the shape of the second eigenmode in the axisymmetric solid model. In 
Figure 3, the same plot is shown for the axisymmetric shell interface. In both cases, 
Revolution 2D data sets have been used for extending the axisymmetric model into 3D 
space..

Figure 2: The second non-rigid eigenmode, computed using an axisymmetric solid mechanics 
interface.

EIGENFREQUENCY SOLID 
MECHANICS, 
AXISYMMETRY

SOLID 
MECHANICS, 
3D

TARGET 
(ANALYTICAL)

f1 155.04 155.04 155.04

f2 310.09 310.09 310.09
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Figure 3: The first non-rigid eigenmode, computed using an axisymmetric shell interface. Due 
to the offset property, the shell is modeled at the true midsurface, even though the mesh is at the 
inner boundary of the cylinder.

In Figure 4 and Figure 5, two eigenmodes from the 3D solid model are shown. A Sector 

3D data set has been used for expanding the results from the original 15° sector.
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Figure 4: The second non-rigid eigenmode, computed using a 3D solid mechanics interface 
with cyclic symmetry boundary conditions.
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Figure 5: The first non-rigid eigenmode, computed using a 3D solid mechanics interface with 
cyclic symmetry boundary conditions.

Notes About the COMSOL Implementation

In the 3D solid model, you could have used ordinary Symmetry boundary conditions 
instead of the Periodic Condition. The effect would have been that only the in-plane modes 
were computed.

In a real pipe, there are however also other eigenmodes, which are not axially symmetric. 
You can find such modes by using azimuthal mode numbers other than zero in the settings 
for the cyclic symmetry condition (3D) and Solid Mechanics interface settings 
(2D axisymmetry). Such modes can be visualized by setting the azimuthal mode number 
to the corresponding value in the Advanced section in the settings for the Revolution 2D and 
Sector 3D data sets.

Reference

1. F. Abassian, D.J. Dawswell, and N.C. Knowles, Free Vibration Benchmarks, vol.3, 
NAFEMS, Glasgow, 1987.
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Application Library path: Structural_Mechanics_Module/
Verification_Examples/free_cylinder

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Eigenfrequency.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Rectangle 1 (r1)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

Name Expression Value Description

height 10[m] 10 m Height of cylinder

thic 0.4[m] 0.4 m Thickness of cylinder

r_in 1.8[m] 1.8 m Inner radius
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3 In the Width text field, type thic.

4 In the Height text field, type height.

5 Locate the Position section. In the r text field, type r_in.

6 Click Build All Objects.

7 Click the Zoom Extents button in the Graphics toolbar.

G L O B A L  D E F I N I T I O N S

In this example, the same material data will be referenced from several physics interfaces, 
so it is convenient to define a global material.

Material 1 (mat1)
1 In the Model Builder window, under Global Definitions right-click Materials and choose 

Blank Material.

2 In the Settings window for Material, click to expand the Material Properties section.

3 In the Material properties tree, select Basic Properties>Density.

4 Click Add to Material.

5 In the Material properties tree, select Solid Mechanics>Linear Elastic Material>

Young’s Modulus and Poisson’s Ratio.

6 Click Add to Material.
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7 Locate the Material Contents section. In the table, enter the following settings:

M A T E R I A L S

Material Link 1 (matlnk1)
In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
More>Material Link.

M E S H  1

Mapped 1
In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Mapped.

Distribution 1
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 20.

4 Select Boundary 1 only.

Distribution 2
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 2.

4 Select Boundary 2 only.

5 Click Build All.

S T U D Y  1

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Study 1, 2D axisymmetric solid in the Label 
text field.

Property Variable Value Unit Property group

Density rho 8000 kg/m³ Basic

Young’s modulus E 2e11 Pa Young’s modulus and 
Poisson’s ratio

Poisson’s ratio nu 0.3 1 Young’s modulus and 
Poisson’s ratio
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3 In the Home toolbar, click Compute.

R E S U L T S

Mode Shape (solid)
Visualize an eigenmode in 3D.

Mode Shape, 3D (solid)
1 In the Model Builder window, click Mode Shape, 3D (solid).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Eigenfrequency (Hz) list, choose 243.5.

4 Click the Show Grid button in the Graphics toolbar.

5 In the Mode Shape, 3D (solid) toolbar, click Plot.

6 Click the Zoom Extents button in the Graphics toolbar.

C O M P O N E N T  1  ( C O M P 1 )

Add a Shell interface with the same data, and compute the eigenfrequencies.

A D D  P H Y S I C S

1 In the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Structural Mechanics>Shell (shell).

4 Click Add to Component 1 in the window toolbar.

5 In the Home toolbar, click Add Physics to close the Add Physics window.

S H E L L  ( S H E L L )

Select Boundary 1 only.

Thickness and Offset 1
Since the inner boundary of the cylinder is used as geometry for the shell interface, you 
must use an offset to position the midsurface at the correct radial coordinate.

1 In the Model Builder window, under Component 1 (comp1)>Shell (shell) click 
Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type thic.

4 From the Offset definition list, choose Relative offset.

5 In the zreloffset text field, type -1.
12 |  E I G E N F R E Q U E N C Y  A N A L Y S I S  O F  A  F R E E  C Y L I N D E R



M A T E R I A L S

Material Link 2 (matlnk2)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose More>Material Link.

2 In the Settings window for Material Link, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 1 only.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>

Eigenfrequency.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Solid Mechanics interface.

5 Click Add Study in the window toolbar.

6 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study 2, 2D axisymmetric shell in the Label 
text field.

3 In the Home toolbar, click Compute.

R E S U L T S

Mode Shape, 3D (shell)
1 In the Model Builder window, under Results click Mode Shape, 3D (shell).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Eigenfrequency (Hz) list, choose 243.64.

4 Click the Show Grid button in the Graphics toolbar.

5 In the Mode Shape, 3D (shell) toolbar, click Plot.
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R O O T

Now, add a 3D solid sector with cyclic symmetry boundary conditions and compute the 
eigenfrequencies.

A D D  C O M P O N E N T

In the Model Builder window, right-click the root node and choose Add Component>3D.

G E O M E T R Y  2

Work Plane 1 (wp1)
1 In the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 From the Plane list, choose xz-plane.

G E O M E T R Y  1

Rectangle 1 (r1)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click 
Rectangle 1 (r1) and choose Copy.

G E O M E T R Y  2

Plane Geometry
In the Model Builder window, under Component 2 (comp2)>Geometry 2>

Work Plane 1 (wp1) click Plane Geometry.

Work Plane 1 (wp1)>Rectangle 1 (r1)
Right-click Plane Geometry and choose Paste Rectangle.

Revolve 1 (rev1)
1 In the Geometry toolbar, click Revolve.

2 In the Settings window for Revolve, locate the Revolution Angles section.

3 Click the Angles button.

4 In the End angle text field, type 15.

5 Click Build All Objects.

A D D  P H Y S I C S

1 In the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.
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3 In the tree, select Structural Mechanics>Solid Mechanics (solid).

4 Click Add to Component 2 in the window toolbar.

5 In the Model Builder window, click Component 2 (comp2).

6 In the Home toolbar, click Add Physics to close the Add Physics window.

S O L I D  M E C H A N I C S  2  ( S O L I D 2 )

Periodic Condition 1
1 In the Physics toolbar, click Boundaries and choose Periodic Condition.

2 Select Boundaries 2 and 5 only.

3 In the Settings window for Periodic Condition, locate the Periodicity Settings section.

4 From the Type of periodicity list, choose Cyclic symmetry.

M E S H  2

Mapped 1
1 In the Model Builder window, under Component 2 (comp2) right-click Mesh 2 and choose 

More Operations>Mapped.

2 Select Boundary 3 only.

Distribution 1
1 Right-click Mapped 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 2.

4 Select Edges 2 and 7 only.

Mapped 1
1 In the Model Builder window, click Mapped 1.

2 Click Build Selected.

Swept 1
In the Model Builder window, right-click Mesh 2 and choose Swept.

Distribution 1
1 In the Model Builder window, right-click Swept 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 20.

4 Click Build All.
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M A T E R I A L S

Material Link 3 (matlnk3)
In the Model Builder window, under Component 2 (comp2) right-click Materials and choose 
More>Material Link.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>

Eigenfrequency.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Solid Mechanics and Shell interfaces.

5 Click Add Study in the window toolbar.

6 From the Home menu, choose Add Study.

S T U D Y  3

1 In the Model Builder window, click Study 3.

2 In the Settings window for Study, type Study 3, 3D solid sector in the Label text 
field.

Step 1: Eigenfrequency
1 In the Model Builder window, under Study 3, 3D solid sector click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Desired number of eigenfrequencies check box.

4 In the associated text field, type 10.

5 In the Model Builder window, collapse the Study 3, 3D solid sector node.

6 In the Home toolbar, click Compute.

R E S U L T S

Mode Shape (solid2)
1 In the Settings window for 3D Plot Group, locate the Data section.

2 From the Eigenfrequency (Hz) list, choose 243.5.

3 In the Mode Shape (solid2) toolbar, click Plot.
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Datasets
In the Model Builder window, click Datasets.

Sector 3D 1
1 In the Results toolbar, click More Datasets and choose Sector 3D.

2 In the Settings window for Sector 3D, locate the Symmetry section.

3 In the Number of sectors text field, type 360/15.

4 From the Sectors to include list, choose Manual.

5 In the Start sector text field, type 18.

6 In the Number of sectors to include text field, type 15.

Mode Shape (solid2)
1 In the Model Builder window, click Mode Shape (solid2).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Dataset list, choose Sector 3D 1.

4 Click the Zoom Extents button in the Graphics toolbar.

5 In the Mode Shape (solid2) toolbar, click Plot.

6 Click the Show Grid button in the Graphics toolbar.

Also twisting modes can be displayed.

7 From the Eigenfrequency (Hz) list, choose 155.04.

8 In the Mode Shape (solid2) toolbar, click Plot.

S O L I D  M E C H A N I C S  ( S O L I D )

The twisting modes can also be computed using the axisymmetric Solid Mechanics 
interface. To do that, use circumferential mode extension.

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Axial Symmetry Approximation 
section.

3 Select the Circumferential mode extension (time-harmonic) check box.

S T U D Y  1 ,  2 D  A X I S Y M M E T R I C  S O L I D

Step 1: Eigenfrequency
1 In the Model Builder window, under Study 1, 2D axisymmetric solid click 

Step 1: Eigenfrequency.
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2 Find the Physics and Variable Selection subsection. In the table, clear the Solve check box 
for Shell and Solid Mechanics 2 interface.

3 In the Settings window for Eigenfrequency, locate the Study Settings section.

4 Select the Desired number of eigenfrequencies check box.

5 In the associated text field, type 10.

6 In the Home toolbar, click Compute.

R E S U L T S

Mode Shape, 3D (solid)
In the Model Builder window, expand the Results>Mode Shape, 3D (solid) node.

Deformation
To display also twisting modes, add the rotational displacement component to the 
deformation.

1 In the Model Builder window, expand the Results>Mode Shape, 3D (solid)>Surface 1 node, 
then click Deformation.

2 In the Settings window for Deformation, locate the Expression section.

3 In the PHI component text field, type v.

Mode Shape, 3D (solid)
Display the first twist mode.

1 In the Model Builder window, click Mode Shape, 3D (solid).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Eigenfrequency (Hz) list, choose 155.04.

4 In the Mode Shape, 3D (solid) toolbar, click Plot.

5 From the Eigenfrequency (Hz) list, choose 243.5.

6 In the Mode Shape, 3D (solid) toolbar, click Plot.

S T U D Y  2 ,  2 D  A X I S Y M M E T R I C  S H E L L

Step 1: Eigenfrequency
1 In the Model Builder window, under Study 2, 2D axisymmetric shell click 

Step 1: Eigenfrequency.

2 Find the Physics and Variable Selection subsection. In the table, clear the Solve check box 
for Solid Mechanics 2 interface.
18 |  E I G E N F R E Q U E N C Y  A N A L Y S I S  O F  A  F R E E  C Y L I N D E R



19 |  E I G E N F R E Q U E N C Y  A N A L Y S I S  O F  A  F R E E  C Y L I N D E R



20 |  E I G E N F R E Q U E N C Y  A N A L Y S I S  O F  A  F R E E  C Y L I N D E R



Created in COMSOL Multiphysics 5.5
I n - P l a n e  and S p a c e  T r u s s
This model is licensed under the COMSOL Software License Agreement 5.5.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

In the following example you first build and solve a simple 2D truss model using the 2D 
Truss interface. Later on, you analyze a 3D variant of the same problem using the 3D 
Truss interface. This model calculates the deformation and forces of a simple geometry. 
The example is based on problem 11.1 in Aircraft Structures for Engineering Students 
by T.H.G Megson (Ref. 1). The results are compared with the analytical results given in 
Ref. 1.

Model Definition

The 2D geometry consists of a square symmetrical truss built up by five members. All 
members have the same cross-sectional area. The side length is L, and the Young’s 
modulus is E.

Figure 1: The truss geometry.

In the 3D case, another copy of the diagonal bars are rotated 90° around the vertical axis 
so that a cube with one space diagonal is generated. The figure above is thus applicable to 
a view in the zy-plane as well as in the xy-plane. The central bar is then given twice the area 
of the other members. In this way, a space truss with exactly the same type of symmetry, 
but twice the vertical stiffness is generated.

L, E, A

F

ab

c

d
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G E O M E T R Y

• Truss side length, L = 2 m

• The truss members have a circular cross section with a radius of 0.05 m. In the 3D case, 
the area of the central bar is doubled.

M A T E R I A L

Aluminum: Young’s modulus, E = 70 GPa.

C O N S T R A I N T S

Displacements in both directions are constrained at a and b. In the 3D case, the two new 
points are constrained in the same way.

L O A D

A vertical force F of 50 kN is applied at the bottom corner. In the 3D case, the value 
100 kN is used instead in order to get the same displacements.

Results and Discussion

The following table shows a comparison between the results calculated with the Structural 
Mechanics Module and the analytical results from Ref. 1.

The results are in nearly perfect agreement.

Figure 2 and Figure 3 show plots visualizing the deformed geometry together with the 
axial forces in the truss members.

RESULT COMSOL MULTIPHYSICS Ref. 1

Displacement at d -5.14·10-4 m -5.15·10-4 m

Displacement at c -2.13·10-4 m -2.13·10-4 m

Axial force in member ac=bc -10.4 kN -10.4 kN

Axial force in member ad=bd 25.0 kN 25.0 kN

Axial force in member cd 14.6 kN 14.6 kN
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Figure 2: Deformed geometry and axial forces for the 2D case.

Figure 3: Deformed geometry and axial forces for the 3D case.
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Notes About the COMSOL Implementation

In this example you build the 2D and the 3D truss as two different components within the 
same MPH file. This is not essential, you could equally well choose to create the 
components in separate MPH files.

Reference

1. T.H.G. Megson, Aircraft Structures for Engineering Students, Edward Arnold, 
p. 404, 1985

Application Library path: Structural_Mechanics_Module/
Verification_Examples/inplane_and_space_truss

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Truss (truss).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Square 1 (sq1)
1 In the Geometry toolbar, click Square.

2 In the Settings window for Square, locate the Size section.

3 In the Side length text field, type 2.

4 Locate the Rotation Angle section. In the Rotation text field, type 45.
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5 Locate the Object Type section. From the Type list, choose Curve.

6 Click Build All Objects.

7 Click the Zoom Extents button in the Graphics toolbar.

Line Segment 1 (ls1)
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 Locate the Endpoint section. From the Specify list, choose Coordinates.

5 In the y text field, type sqrt(8).

6 Click Build All Objects.

T R U S S  ( T R U S S )

Cross Section Data 1
1 In the Model Builder window, under Component 1 (comp1)>Truss (truss) click 

Cross Section Data 1.

2 In the Settings window for Cross Section Data, locate the Cross Section Data section.

3 In the A text field, type pi/4*0.05^2.

Pinned 1
1 In the Physics toolbar, click Points and choose Pinned.

2 Select Points 1 and 4 only.

Point Load 1
1 In the Physics toolbar, click Points and choose Point Load.

2 Select Point 2 only.

3 In the Settings window for Point Load, locate the Force section.

4 Specify the FP vector as

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

0 x

-50e3 y
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2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

S T U D Y  1

In the Home toolbar, click Compute.

R E S U L T S

Force (truss)
1 In the Model Builder window, expand the Results>Force (truss) node, then click 

Force (truss).

2 In the Settings window for 2D Plot Group, locate the Color Legend section.

3 Select the Show maximum and minimum values check box.

4 Click the Zoom Extents button in the Graphics toolbar.

Derived Values
Next, compute the displacements at d (Vertex 2) and c (Vertex 3).

Point Evaluation 1
1 In the Results toolbar, click Point Evaluation.

2 Select Points 2 and 3 only.

3 In the Settings window for Point Evaluation, click Replace Expression in the upper-right 
corner of the Expressions section. From the menu, choose Component 1>Truss>

Displacement>Displacement field - m>v - Displacement field, Y component.

4 Click Evaluate.

Although you can read off the values of the local axial force in the members ac and ad 
from the max and min values for the color legend for the plot in the Graphics window, 
it is instructive to see how you can compute such values more generally.

D E F I N I T I O N S

Add nonlocal average couplings for the members ac, ad, and cd. You will use these for 
defining variables that evaluate the axial forces in these members.

Property Variable Value Unit Property group

Young’s modulus E 70e9 Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 2900 kg/m³ Basic
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Average 1 (aveop1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 In the Settings window for Average, type aveop_ac in the Operator name text field.

3 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

4 Select Boundary 5 only.

Average 2 (aveop2)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 In the Settings window for Average, type aveop_ad in the Operator name text field.

3 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

4 Select Boundary 4 only.

Average 3 (aveop3)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 In the Settings window for Average, type aveop_cd in the Operator name text field.

3 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

4 Select Boundary 3 only.

Variables 1
1 In the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

S T U D Y  1

Update the solution to evaluate the variables you just defined.

Solution 1 (sol1)
1 In the Model Builder window, expand the Study 1>Solver Configurations node.

2 Right-click Study 1>Solver Configurations>Solution 1 (sol1) and choose Solution>Update.

Name Expression Unit Description

F_ac aveop_ac(truss.Nxl) N Axial force, member ac

F_ad aveop_ad(truss.Nxl) N Axial force, member ad

F_cd aveop_cd(truss.Nxl) N Axial force, member cd
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R E S U L T S

Global Evaluation 1
1 In the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Expressions section.

3 In the table, enter the following settings:

4 Click Evaluate.

The values in the Table window agree with those of the analytical reference solution.

T A B L E

1 Go to the Table window.

Now create the 3D truss as a new model.

A D D  C O M P O N E N T

In the Model Builder window, right-click the root node and choose Add Component>3D.

A D D  P H Y S I C S

1 In the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Recently Used>Truss (truss).

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Study 1.

5 Click Add to Component 2 in the window toolbar.

6 In the Home toolbar, click Add Physics to close the Add Physics window.

R O O T

In the Model Builder window, click the root node.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

Expression Unit Description

F_ac N Axial force, member ac

F_ad N Axial force, member ad

F_cd N Axial force, member cd
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3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

Switch off the 2D truss physics in this study.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Truss (truss) interface.

5 Click Add Study in the window toolbar.

6 From the Home menu, choose Add Study.

G E O M E T R Y  2

In the Model Builder window, under Component 2 (comp2) click Geometry 2.

Work Plane 1 (wp1)
In the Geometry toolbar, click Work Plane.

Work Plane 1 (wp1)>Plane Geometry
1 Right-click Work Plane 1 (wp1) and choose Show Work Plane.

2 In the Model Builder window, click Plane Geometry.

Work Plane 1 (wp1)>Square 1 (sq1)
1 In the Work Plane toolbar, click Square.

2 In the Settings window for Square, locate the Size section.

3 In the Side length text field, type 2.

4 Locate the Rotation Angle section. In the Rotation text field, type 45.

5 Locate the Object Type section. From the Type list, choose Curve.

6 In the Work Plane toolbar, click Build All.

7 In the Model Builder window, click Geometry 2.

Rotate 1 (rot1)
1 In the Geometry toolbar, click Transforms and choose Rotate.

2 In the Settings window for Rotate, locate the Input section.

3 Select the Keep input objects check box.

4 Select the object wp1 only.

5 Locate the Rotation section. From the Axis type list, choose Cartesian.

6 In the y text field, type 1.

7 In the z text field, type 0.

8 In the Angle text field, type 90.

9 Click Build All Objects.
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10 In the Model Builder window, click Geometry 2.

Line Segment 1 (ls1)
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 Locate the Endpoint section. From the Specify list, choose Coordinates.

5 In the y text field, type sqrt(8).

6 Click Build All Objects.

D E F I N I T I O N S  ( C O M P 2 )

Add nonlocal average couplings for the members ac, ad, and cd and corresponding axial 
force variables.

1 In the Model Builder window, under Component 2 (comp2) click Definitions.

Average 4 (aveop4)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 In the Settings window for Average, type aveop_ac in the Operator name text field.

3 Locate the Source Selection section. From the Geometric entity level list, choose Edge.

4 Select Edge 8 only.

5 In the Model Builder window, under Component 2 (comp2) click Definitions.

Average 5 (aveop5)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 In the Settings window for Average, type aveop_ad in the Operator name text field.

3 Locate the Source Selection section. From the Geometric entity level list, choose Edge.

4 Select Edge 4 only.

5 In the Model Builder window, click Definitions.

Average 6 (aveop6)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 In the Settings window for Average, type aveop_cd in the Operator name text field.

3 Locate the Source Selection section. From the Geometric entity level list, choose Edge.

4 Select Edge 5 only.

5 In the Model Builder window, click Definitions.
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Variables 2
1 In the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

T R U S S  2  ( T R U S S 2 )

Cross Section Data 1
1 In the Model Builder window, under Component 2 (comp2)>Truss 2 (truss2) click 

Cross Section Data 1.

2 In the Settings window for Cross Section Data, locate the Cross Section Data section.

3 In the A text field, type pi/4*0.05^2.

Cross Section Data 2
1 In the Physics toolbar, click Edges and choose Cross Section Data.

2 Select Edge 5 only.

3 In the Settings window for Cross Section Data, locate the Cross Section Data section.

4 In the A text field, type 2*pi/4*0.05^2.

Pinned 1
1 In the Physics toolbar, click Points and choose Pinned.

2 Select Points 1, 3, 4, and 6 only.

Point Load 1
1 In the Physics toolbar, click Points and choose Point Load.

2 Select Point 2 only.

3 In the Settings window for Point Load, locate the Force section.

4 Specify the FP vector as

Name Expression Unit Description

F_ac aveop_ac(truss2.Nxl) N Axial force, member ac

F_ad aveop_ad(truss2.Nxl) N Axial force, member ad

F_cd aveop_cd(truss2.Nxl) N Axial force, member cd

0 x

-100e3 y

0 z
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M A T E R I A L S

Material 2 (mat2)
1 In the Model Builder window, under Component 2 (comp2) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

S T U D Y  2

In the Home toolbar, click Compute.

R E S U L T S

Force (truss2)
1 In the Settings window for 3D Plot Group, locate the Color Legend section.

2 Select the Show maximum and minimum values check box.

Derived Values
Proceed to compute the displacements at d (Vertex 2) and c (Vertex 5).

Point Evaluation 2
1 In the Model Builder window, right-click Derived Values and choose Point Evaluation.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Study 2/Solution 2 (3) (sol2).

4 Select Points 2 and 5 only.

5 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component 2>Truss 2>Displacement>Displacement field - m>v2 -

Displacement field, Y component.

6 Click New Table.

Property Variable Value Unit Property group

Young’s modulus E 70e9 Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 2900 kg/m³ Basic
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T A B L E

1 Go to the Table window.

The results are nearly identical to those of the 2D case.

Finally, compute the axial force values.

R E S U L T S

Derived Values
In the Model Builder window, under Results click Derived Values.

Global Evaluation 2
1 In the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Data section.

3 From the Dataset list, choose Study 2/Solution 2 (2) (sol2).

4 Locate the Expressions section. In the table, enter the following settings:

Because the applied force was doubled to get the same displacement as, in the 2D case, 
you need to divide the value of the axial force in member cd by 2 to get a value 
comparable to that of the 2D case.

5 Click Evaluate.

Again, the values in the Results table agree very well with the reference solution.

Expression Unit Description

comp2.F_ac N Axial force, member ac

comp2.F_ad N Axial force, member ad

comp2.F_cd/2 N Axial force, member cd
14 |  I N - P L A N E  A N D  S P A C E  T R U S S



Created in COMSOL Multiphysics 5.5
I n - P l a n e  F r amewo r k  w i t h  D i s c r e t e  Ma s s  and Ma s s
Momen t  o f  I n e r t i a
This model is licensed under the COMSOL Software License Agreement 5.5.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

In the following example you build and solve a 2D beam model using the 2D Structural 
Mechanics Beam interface. This example describes the eigenfrequency analysis of a simple 
geometry. A point mass and point mass moment of inertia are used. The two first 
eigenfrequencies are compared with the values given by an analytical expression.

In addition, it is shown how to evaluate modal participation factors and modal masses.

Model Definition

The geometry consists of a frame with one horizontal and one vertical member. The cross 
section of both members has an area, A, and an area moment of inertia, I. The length of 
each member is L and Young’s modulus is E. A point mass m is added at the middle of the 
horizontal member and a point mass moment of inertia J at the corner (see Figure 1 
below).

Figure 1: Definition of the problem.

G E O M E T R Y

• Framework member lengths, L = 1 m.

• The framework members has a square cross section with a side length of 0.03 m giving 
an area of A = 9·10−4 m2 and an area moment of inertia of I = 0.034/12 m4.

M A T E R I A L

Young’s modulus E = 200 GPa.

J=m r2

E I

m

L

L/2 L/2

E IE I

y

x
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M A S S

• Point mass m = 1000 kg.

• Point mass moment of inertia J = mr2 where r is chosen as L/4. This gives the value 
62.5 kgm2.

C O N S T R A I N T S

The beam is pinned at x = 0, y = 0 and x = 1, y = 1, meaning that the displacements are 
constrained whereas the rotational degrees of freedom are free.

Results and Discussion

The analytical values for the two first eigenfrequencies fe1 and fe2 are given by:

and

where ω is the angular frequency.

The following table shows a comparison between the eigenfrequencies calculated with 
COMSOL Multiphysics and the analytical values.

EIGENMODE COMSOL MULTIPHYSICS ANALYTICAL

1 4.05 Hz 4.05 Hz

2 8.65 Hz 8.66 Hz

ωe1
2 48EI

mL3
--------------=

ωe2
2 48 32EI⋅

7mL3
-------------------------=

fe1
ωe1
2π
---------=

fe2
ωe2
2π
---------=
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The following two plots visualize the two eigenmodes.

Figure 2: The first eigenmode.

Figure 3: The second eigenmode.
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Because the beams have no density in this example, the total mass is the 1000 kg supplied 
by the point mass. The mass moment of inertia is also a point contribution, and has the 
value 62.5 kgm2. The mass represented by the computed eigenmodes can be evaluated 
using the modal participation factors, see Figure 4 and Figure 5. In this case, it can be seen 
that in the y direction, the correspondence is perfect, while almost none of the mass in the 
x direction is represented. The axial deformation mode for the horizontal member has a 
higher frequency, and was not computed. Similarly, all rotational inertia is captured by the 
first two modes.

Figure 4: Participation factors for each eigenfrequency.

Figure 5: Summed modal masses.

Notes About the COMSOL Implementation

The variables for evaluation of participation factors are created in the Participation Factors 
node under Definitions. This node is created automatically when an Eigenfrequency study is 
added.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/inplane_framework_freq

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Beam (beam).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Eigenfrequency.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
inplane_framework_freq_parameters.txt.

G E O M E T R Y  1

Polygon 1 (pol1)
1 In the Geometry toolbar, click Polygon.

2 In the Settings window for Polygon, locate the Object Type section.

3 From the Type list, choose Open curve.

4 Locate the Coordinates section. In the table, enter the following settings:

5 Click Build All Objects.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

x (m) y (m)

0 0

0 L

L/2 L

L L
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2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

B E A M  ( B E A M )

Cross Section Data 1
1 In the Model Builder window, under Component 1 (comp1)>Beam (beam) click 

Cross Section Data 1.

2 In the Settings window for Cross Section Data, locate the Cross Section Definition section.

3 From the list, choose Common sections.

4 In the hy text field, type a.

5 In the hz text field, type a.

Pinned 1
1 In the Physics toolbar, click Points and choose Pinned.

2 Select Points 1 and 4 only.

Point Mass 1
1 In the Physics toolbar, click Points and choose Point Mass.

2 Select Point 3 only.

3 In the Settings window for Point Mass, locate the Point Mass section.

4 In the m text field, type m.

Point Mass 2
1 In the Physics toolbar, click Points and choose Point Mass.

2 Select Point 2 only.

3 In the Settings window for Point Mass, locate the Point Mass section.

4 In the Jz text field, type J.

S T U D Y  1

Step 1: Eigenfrequency
1 In the Model Builder window, under Study 1 click Step 1: Eigenfrequency.

Property Variable Value Unit Property group

Young’s modulus E Emod Pa Basic

Poisson’s ratio nu 0 1 Basic

Density rho 0 kg/m³ Basic
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2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Desired number of eigenfrequencies check box.

4 In the associated text field, type 2.

5 In the Home toolbar, click Compute.

R E S U L T S

Line 1
1 In the Model Builder window, expand the Results>Mode Shape (beam) node, then click 

Line 1.

2 In the Mode Shape (beam) toolbar, click Plot.

3 Click the Zoom Extents button in the Graphics toolbar.

Mode Shape (beam)
1 In the Model Builder window, click Mode Shape (beam).

2 In the Settings window for 2D Plot Group, locate the Data section.

3 From the Eigenfrequency (Hz) list, choose 8.6474.

4 In the Mode Shape (beam) toolbar, click Plot.

Derived Values
Compare the computed eigenfrequencies to the analytical values.

Global Evaluation 1
1 In the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, type Eigenfrequnecy comparison in the 
Label text field.

3 Locate the Expressions section. In the table, enter the following settings:

4 Click Evaluate.

Participation factors (Study 1)
Examine the modal participation factors.

Finally, compute the total effective mass accounted for in the computed eigenmodes.

Expression Unit Description

f1 1/s Eigenfrequency 1, analytical

f2 1/s Eigenfrequency 2, analytical
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Global Evaluation 2
1 In the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, type Summed modal masses in the Label 
text field.

3 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component 1>Definitions>Participation Factors 1>Effective modal mass>

mpf1.mEffLY - Effective modal mass, Y-translation - kg.

4 Locate the Expressions section. In the table, enter the following settings:

5 Locate the Data Series Operation section. From the Operation list, choose Integral.

6 From the Method list, choose Summation.

7 Click Evaluate.

Expression Unit Description

mpf1.mEffLY kg Effective modal mass, Y-translation

mpf1.mEffRZ kg*m^2 Effective modal mass, Z-rotation
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Introduction

In this example, you perform a static stress analysis to obtain the stress distribution in the 
vicinity of a small hole in an infinite plate. Two approximations of the infinite plate are 
evaluated. The first one uses a plate that is large compared to the hole while the second 
one employs an infinite element domain. 

The problem is a classic benchmark, and the theoretical solution was derived by G. Kirsch 
in 1898. This implementation is based on the Kirsch plate model described on page 184 
in Mechanics of Materials, D. Roylance (Ref. 1). The stress level is compared with the 
theoretical values.

Model Definition

Model the infinite plate in a 2D plane stress approximation as a 2 m-by-2 m plate with a 
hole with a radius of 0.1 m in the middle. Due to symmetry in load and geometry you need 
to analyze only a quarter of the plate, see Figure 1. Choose the size of the plate sufficiently 
large so that the stress concentration close to the hole is not affected.

Figure 1: Geometry model of the Kirsch plate with rollers defining the symmetry plane.

When modeling a plate using the infinite element domain you need to create an additional 
layers around the plate. Those layers simulate the part that stretches to infinity and can 
have an arbitrarily length along the direction that stretches to infinity, for example 0.1 m. 

y

x

Thickness 0.1 m

1000 Pa

1 m

1 m

0.1 m
2 |  K I R S C H  I N F I N I T E  P L A T E  P R O B L E M



In the model the infinite element domain is created along the y direction only since the 
numerical results along x = 0 symmetry plane are compared to an analytical reference and 
infinite element domain in x direction only have a minor influence. 

M A T E R I A L

Isotropic material with, E = 2.1·1011 Pa, ν = 0.3.

L O A D

A distributed stress of 103 Pa on the right edge pointing in the x direction.

C O N S T R A I N T S

Symmetry planes, x = 0, y = 0.

Results and Discussion

The distribution of the normal stress in the x direction, σx, is shown in Figure 2and 
Figure 3. The stress contours of the finite model and the infinite model are very similar.

Figure 2: Distribution of the normal stress in the x direction for the finite model.
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Figure 3: Distribution of the normal stress in the x direction for the infinite model.

According to Ref. 1 the stress σx along the vertical symmetry line can be calculated as

 (1)σx
1000

2
------------- 2 0,12

y2
----------- 30,14

y4
-----------+ +

 
 
 

=
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Figure 4 shows the stress σx obtained from the solved models, and plotted as a function 
of the true y-coordinate along the left symmetry edge, which are in close agreement with 
the theoretical value according to Equation 1.

Figure 4: Normal stress, simulated results (solid line) versus the theoretical values (dashed 
line).

Away from the hole, stresses from the finite model starts drifting from the theoretical 
values, while stresses from the infinite model matches closely with the theoretical value.

The stress error is reported in the following table:

Notes About the COMSOL Implementation

The default scaling function in Infinite Element Domain is rational. This type of function is 
well adapted to cases where the degrees of freedom vanish to zero at infinity. The present 
model is submitted to infinite loads at infinity, that means that constant strain and linear 

TABLE 1:  STRESS ERROR RELATIVE TO ANALYTICAL SOLUTION.

FINITE PLATE INFINITE PLATE

Near hole 1.1 % 0.1 %

Away from hole -4 % -0.1 %
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displacement are expected. For this type of infinite solution, polynomial functions are 
preferred. The relation between the stretched and geometric coordinates is

where the function f is defined with an analytic function. Here we want f as a second-order 
polynomial: . The continuity condition at X0, , and at the 
end of the domain  imply that the polynomial is:

The infinite element domain gives best results when meshed with rectangular elements; 
see Figure 5.

Figure 5: Infinite element domain modeled with rectangular elements.

Reference

1. D. Roylance, Mechanics of Materials, John Wiley & Sons, 1996.

Xm X0– f
X X0–

ΔX
----------------- 
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Application Library path: Structural_Mechanics_Module/
Verification_Examples/kirsch_plate

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Draw a rectangle with a top layer that represents the infinite element domain.

G E O M E T R Y  1

Rectangle 1 (r1)
1 In the Geometry toolbar, click Rectangle.

Name Expression Value Description

pw 10[m] 10 m Physical width of infinite element 
domain

deltaY 0.1[m] 0.1 m Geometric thickness of infinite 
element layer
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2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Height text field, type 1+deltaY.

4 Click to expand the Layers section. Clear the Layers on bottom check box.

5 Select the Layers on top check box.

6 In the table, enter the following settings:

Circle 1 (c1)
1 In the Geometry toolbar, click Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type 0.1.

4 Click Build Selected.

Difference 1 (dif1)
1 In the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 Add the rectangle and remove the circle in the Difference section.

3 In the Settings window for Difference, click Build All Objects.

G L O B A L  D E F I N I T I O N S

First add an analytical function for stress, based on Kirsch’s theoretical solution of an 
infinite plate.

Analytic 1 (an1)
1 In the Home toolbar, click Functions and choose Global>Analytic.

2 In the Settings window for Analytic, type Analytic Stress in the Label text field.

3 In the Function name text field, type AnaStress.

4 Locate the Definition section. In the Expression text field, type 1000/2*(2+(0.1/y)^2+
3*(0.1/y)^4).

5 In the Arguments text field, type y.

6 Locate the Units section. In the Arguments text field, type m.

7 In the Function text field, type N/m^2.

Create an analytic polynomial function to define the scaling in the infinite element domain.

Layer name Thickness (m)

Layer 1 deltaY
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D E F I N I T I O N S

Analytic 2 (an2)
1 In the Home toolbar, click Functions and choose Global>Analytic.

2 In the Settings window for Analytic, locate the Definition section.

3 In the Expression text field, type (pw-10*deltaY)*x^2+10*deltaY*x.

4 Locate the Units section. In the Arguments text field, type m.

5 In the Function text field, type m.

Infinite Element Domain 1 (ie1)
1 In the Definitions toolbar, click Infinite Element Domain.

2 Select Domain 2 only.

3 In the Settings window for Infinite Element Domain, locate the Scaling section.

4 From the Coordinate stretching type list, choose User defined.

5 From the Stretching function list, choose Analytic 2 (an2).

Add a variable representing the physical y-coordinate to be used in postprocessing.

Variables 1
1 In the Model Builder window, right-click Definitions and choose Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

First set up a model without the Infinite Element Domain.

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Domain Selection section.

3 In the list, select 2 (infinite elements).

4 Click Remove from Selection.

5 Select Domain 1 only.

6 Locate the 2D Approximation section. From the list, choose Plane stress.

7 Locate the Thickness section. In the d text field, type 0.1.

Name Expression Unit Description

ym if(dom==2,ie1.Ym,y) m Physical y-coordinate
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Symmetry 1
1 In the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 1, 2, and 5 only.

Boundary Load 1
1 In the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 6 and 7 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

Now set up a model with the infinite element domain.

A D D  P H Y S I C S

1 In the Physics toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Structural Mechanics>Solid Mechanics (solid).

4 Click Add to Component 1 in the window toolbar.

5 In the Model Builder window, click Component 1 (comp1).

6 In the Physics toolbar, click Add Physics to close the Add Physics window.

S O L I D  M E C H A N I C S  2  ( S O L I D 2 )

1 In the Settings window for Solid Mechanics, locate the 2D Approximation section.

2 From the list, choose Plane stress.

3 Locate the Thickness section. In the d text field, type 0.1.

Symmetry 1
1 In the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 1, 2, and 5 only.

Boundary Load 1
1 In the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 6 and 7 only.

3 In the Settings window for Boundary Load, locate the Force section.

1e3 x

0 y
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4 Specify the FA vector as

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

M E S H  1

For the finite plate selection, a customized free triangular mesh must be used for getting 
a better solution in the stress concentration region. A lower element size is set at the 
expected location of stress concentration.

Free Triangular 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

Free Triangular.

2 In the Settings window for Free Triangular, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domain 1 only.

Size 1
1 Right-click Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Point.

4 Select Point 1 only.

5 Locate the Element Size section. Click the Custom button.

6 Locate the Element Size Parameters section. Select the Maximum element size check box.

1e3 x

0 y

Property Variable Value Unit Property group

Young’s modulus E 2.1e11 Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 7800 kg/m³ Basic
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7 In the associated text field, type 0.02.

Infinite elements give better results when meshed with rectangular elements.

Mapped 1
In the Model Builder window, right-click Mesh 1 and choose Mapped.

Distribution 1
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 Select Boundary 2 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 4.

5 Click Build All.

S T U D Y  1

In the Home toolbar, click Compute.

R E S U L T S

To check the error in the computed results, make a point evaluation of stresses near the 
hole (y = 0.1) and away from the hole (y = 1) for the solution computed with and without 
infinite element domain. The error can be determined by finding the difference between 
computed stresses and analytical stresses.

Point Evaluation 1
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, type Error Evaluation in the Label text 
field.

3 Select Points 1 and 2 only.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Expression Unit Description

(solid.sx-AnaStress(y))/
AnaStress(y)

Error in finite plate

(solid2.sx-AnaStress(y))/
AnaStress(y)

Error in infinite plate
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Stress (solid)
The default plots show the von Mises stress combined with a scaled deformation of the 
plate. Remove deformation and display the stress field in the x direction instead since the 
external load is oriented in that direction.

Surface 1
1 In the Model Builder window, expand the Stress (solid) node, then click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>Stress>

Stress tensor (spatial frame) - N/m²>solid.sx - Stress tensor, x component.

Deformation
1 In the Model Builder window, expand the Surface 1 node.

2 Right-click Deformation and choose Delete.

Surface 1
1 In the Model Builder window, expand the Results>Stress (solid2) node, then click 

Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics 2>Stress>

Stress tensor (spatial frame) - N/m²>solid2.sx - Stress tensor, x component.

Deformation
1 In the Model Builder window, expand the Surface 1 node.

2 Right-click Deformation and choose Delete.

1D Plot Group 5
1 In the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Stress Profile in the Label text field.

Line Graph 1
1 Right-click Stress Profile and choose Line Graph.

2 Select Boundaries 1 and 2 only.

3 In the Settings window for Line Graph, locate the y-Axis Data section.

4 In the Expression text field, type AnaStress(ym).

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type ym.

7 In the Stress Profile toolbar, click Plot.
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8 Click to expand the Legends section. From the Legends list, choose Manual.

9 Select the Show legends check box.

10 In the table, enter the following settings:

11 Click to expand the Coloring and Style section. Find the Line style subsection. From the 
Line list, choose Dashed.

12 In the Stress Profile toolbar, click Plot.

Line Graph 2
1 In the Model Builder window, right-click Stress Profile and choose Line Graph.

2 Select Boundary 1 only.

3 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Component 1>Solid Mechanics>Stress>

Stress tensor (spatial frame) - N/m²>solid.sx - Stress tensor, x component.

4 Locate the x-Axis Data section. From the Parameter list, choose Expression.

5 In the Expression text field, type y.

6 Locate the Legends section. Select the Show legends check box.

7 From the Legends list, choose Manual.

8 In the table, enter the following settings:

Line Graph 3
1 Right-click Stress Profile and choose Line Graph.

2 Select Boundaries 1 and 2 only.

3 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Component 1>Solid Mechanics 2>

Stress>Stress tensor (spatial frame) - N/m²>solid2.sx - Stress tensor, x component.

4 Locate the x-Axis Data section. From the Parameter list, choose Expression.

5 In the Expression text field, type ym.

6 Locate the Legends section. Select the Show legends check box.

7 From the Legends list, choose Manual.

Legends

Analytical

Legends

Finite plate
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8 In the table, enter the following settings:

Stress Profile
1 In the Model Builder window, click Stress Profile.

2 In the Settings window for 1D Plot Group, locate the Axis section.

3 Select the Manual axis limits check box.

4 In the x minimum text field, type 0.

5 In the x maximum text field, type 1.5.

6 Locate the Plot Settings section. Select the x-axis label check box.

7 In the associated text field, type Physical y-coordinate (m).

8 Select the y-axis label check box.

9 In the associated text field, type Stress (N/m²).

10 In the Stress Profile toolbar, click Plot.

Legends

Infinite plate
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Model Definition

In this example you study the deflection of a cantilever beam undergoing very large 
deflections. The model is called “Straight Cantilever GNL Benchmark” and is described 
in detail in section 5.2 of NAFEMS Background to Finite Element Analysis of Geometric 
Non-linearity Benchmarks (Ref. 1). A schematic description of the beam and its 
characteristics is shown in Figure 1.

Figure 1: Cantilever beam geometry.

G E O M E T R Y

• The length of the beam is 3.2 m.

• The cross section is a square with side lengths 0.1 m.

M A T E R I A L

The beam is linear elastic with E = 2.1·1011 N/m2 and ν = 0.

C O N S T R A I N T S  A N D  L O A D S

• The left end is fixed.

• The right end is subjected to a total load of 
Fx = −3.844·106 N and Fy = −3.844·103 N.

M O D E L I N G  I N  C O M S O L

This problem is modeled separately using both Solid Mechanics and Beam interfaces and 
the results are compared with the benchmark value. Using the Solid Mechanics interface, 
the problem is modeled as a “plane stress” problem considering that out-of-plane 
dimension is small. Poisson’s ratio ν is set to zero to make the boundary conditions 
consistent with the beam theory assumptions. The load on the right end of the beam is 
modeled as a uniformly distributed boundary load, corresponding to the specified total 
load.

Cross section

0.1 m

0.1 m

3.2 m

y

x
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In the second part of this problem, a linear buckling analysis study is carried out to 
compute the critical buckling load of the structure.

Results and Discussion

Due to the large compressive axial load and the slender geometry, this is a buckling 
problem. If you are to study the buckling and post-buckling behavior of a symmetric 
problem, it is necessary to perturb the symmetry somewhat. Here the small transversal 
load serves this purpose. An alternative approach would be to introduce an initial 
imperfection in the geometry.

Figure 2 below shows the final state with the 1:1 displacement scaling.

Figure 2: The effective von Mises stress of the deformed beam.

The horizontal and vertical displacements of the tip versus the compressive load 
normalized by its maximum value are shown in Figure 3.
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Figure 3: Horizontal and vertical tip displacements versus normalized compressive load.

Table 1 contains a summary of some significant results. Because the reference values are 
given as graphs, an estimate of the error caused by reading this graph is added:

The results are in excellent agreement, especially considering the coarse mesh used.

The plot of the axial deflection reveals that an instability occurs at a parameter value close 
to 0.1, corresponding to the compressive load 3.84·105 N. It is often seen in practice that 
the critical load of an imperfect structure is significantly lower than that of the ideal 
structure.

TABLE 1:  COMPARISON BETWEEN MODEL RESULTS AND REFERENCE VALUES.

QUANTITY COMSOL (SOLID) COMSOL (BEAM) REFERENCE

Maximum vertical 
displacement at the tip

-2.58 -2.58 -2.58 ± 0.02

Final vertical displacement at 
the tip

-1.34 -1.35 -1.36 ± 0.02

Final horizontal displacement 
at the tip

-5.07 -5.05 -5.04 ± 0.04
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This problem (without the small transverse load) is usually referred to as the Euler-1 case. 
The theoretical critical load is

Figure 4 shows the first buckling mode of the beam computed from a linear buckling 
analysis.

Figure 4: First buckling mode of the beam.

Reference

1. A.A. Becker, Background to Finite Element Analysis of Geometric Non-linearity 
Benchmarks, NAFEMS, Ref: -R0065, Glasgow, 1999.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/large_deformation_beam

Pc
π2EI

4L2
------------- π2 2.1 1011 0.14 12⁄( )⋅ ⋅ ⋅

4 3.22⋅
------------------------------------------------------------------ 4.22 105 N⋅= = =
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 In the Select Physics tree, select Structural Mechanics>Beam (beam).

5 Click Add.

6 Click Study.

7 In the Select Study tree, select General Studies>Stationary.

8 Click Done.

G L O B A L  D E F I N I T I O N S

Define parameters for the geometric data, compressive and transverse load components as 
well as a parameter that you will use to gradually turn up the compressive load.

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
large_deformation_beam_parameters.txt.

By restricting the range of parameter NCL to [0, 1], it serves as a compressive load 
normalized by maximum compressive load.

G E O M E T R Y  1

Rectangle 1 (r1)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type l.

4 In the Height text field, type d.
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Polygon 1 (pol1)
1 In the Geometry toolbar, click Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

3 In the table, enter the following settings:

4 Click Build All Objects.

Form Union (fin)
1 In the Model Builder window, click Form Union (fin).

2 Click Build Selected.

G L O B A L  D E F I N I T I O N S

In this example, the same material data will be referenced for Solid Mechanics and Beam 
interfaces, hence it can be added as a Global Material in the model. Using Material Link 
node, we assign the Global Material to different domains, boundaries and edges of the 
structure.

Material 1 (mat1)
1 In the Model Builder window, under Global Definitions right-click Materials and choose 

Blank Material.

2 In the Settings window for Material, click to expand the Material Properties section.

3 In the Material properties tree, select Basic Properties>Density.

4 Click Add to Material.

5 In the Material properties tree, select Basic Properties>Poisson’s Ratio.

6 Click Add to Material.

7 In the Material properties tree, select Basic Properties>Young’s Modulus.

8 Click Add to Material.

9 Locate the Material Contents section. In the table, enter the following settings:

x (m) y (m)

0 5*d

l 5*d

Property Variable Value Unit Property group

Density rho 7850 kg/m³ Basic

Poisson’s ratio nu 0 1 Basic

Young’s modulus E 2.1e5[MPa] Pa Basic
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M A T E R I A L S

Material Link 1 (matlnk1)
In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
More>Material Link.

Material Link 2 (matlnk2)
1 Right-click Materials and choose More>Material Link.

2 In the Settings window for Material Link, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 4 only.

Add physics settings for the Solid Mechanics interface.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the 2D Approximation section.

3 From the list, choose Plane stress.

4 Locate the Thickness section. In the d text field, type d.

Fixed Constraint 1
1 In the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundary 1 only.

Boundary Load 1
1 In the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundary 5 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 From the Load type list, choose Total force.

5 Specify the Ftot vector as

B E A M  ( B E A M )

1 In the Model Builder window, under Component 1 (comp1) click Beam (beam).

2 In the Settings window for Beam, locate the Boundary Selection section.

3 Click Clear Selection.

NCL*F_Lx x

F_Ly y
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4 Select Boundary 4 only.

Cross Section Data 1
1 In the Model Builder window, under Component 1 (comp1)>Beam (beam) click 

Cross Section Data 1.

2 In the Settings window for Cross Section Data, locate the Cross Section Definition section.

3 From the list, choose Common sections.

4 In the hy text field, type d.

5 In the hz text field, type d.

Fixed Constraint 1
1 In the Physics toolbar, click Points and choose Fixed Constraint.

2 Select Point 3 only.

Point Load 1
1 In the Physics toolbar, click Points and choose Point Load.

2 In the Settings window for Point Load, locate the Force section.

3 Specify the FP vector as

4 Select Point 6 only.

Add unit point load for linear buckling analysis.

Point Load 2
1 Right-click Point Load 1 and choose Duplicate.

2 In the Settings window for Point Load, locate the Force section.

3 Specify the FP vector as

M E S H  1

Edge 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Edge.

NCL*F_Lx x

F_Ly y

-1 x

0 y
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2 Select Boundaries 2–4 only.

Distribution 1
1 Right-click Edge 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

4 Select Boundary 4 only.

5 Locate the Distribution section. In the Number of elements text field, type 40.

Distribution 2
1 In the Model Builder window, right-click Edge 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

4 Select Boundaries 2 and 3 only.

5 Locate the Distribution section. In the Number of elements text field, type 20.

Mapped 1
1 In the Model Builder window, right-click Mesh 1 and choose Mapped.

2 Click Build All.

S T U D Y  1

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Study Settings section.

3 Select the Include geometric nonlinearity check box.

4 Locate the Physics and Variables Selection section. Select the 
Modify model configuration for study step check box.

5 In the Physics and variables selection tree, select Component 1 (comp1)>Beam (beam)>

Point Load 2.

6 Click Disable.

7 Click to expand the Study Extensions section. Select the Auxiliary sweep check box.

8 Click Add.
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9 In the table, enter the following settings:

10 Right-click Study 1>Step 1: Stationary and choose Get Initial Value for Step.

S T U D Y  1

Solver Configurations
In the Model Builder window, expand the Study 1>Solver Configurations node.

Solution 1 (sol1)
1 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 (sol1) 

node, then click Stationary Solver 1.

2 In the Settings window for Stationary Solver, locate the General section.

3 In the Relative tolerance text field, type 1e-4.

4 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Stationary Solver 1 node.

5 Right-click Stationary Solver 1 and choose Segregated.

6 In the Settings window for Segregated, locate the General section.

7 From the Termination technique list, choose Iterations.

8 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Stationary Solver 1>Segregated 1 node, then click Segregated Step.

9 In the Settings window for Segregated Step, locate the General section.

10 In the Variables list, select 
Displacement field (material and geometry frames) (comp1.beam.uLin).

11 Under Variables, click Delete.

12 Under Variables, click Delete.

13 Click to expand the Method and Termination section. From the Termination technique 
list, choose Tolerance.

14 In the Model Builder window, right-click Segregated 1 and choose Segregated Step.

15 In the Settings window for Segregated Step, locate the General section.

16 Under Variables, click Add.

Parameter name Parameter value list

NCL (Normalized compressive load) range(0,0.01,1)
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17 In the Add dialog box, in the Variables list, choose 
Rotation field (material and geometry frames) (comp1.beam.thLin) and 
Displacement field (material and geometry frames) (comp1.beam.uLin).

18 Click OK.

19 In the Settings window for Segregated Step, locate the Method and Termination section.

20 From the Nonlinear method list, choose Automatic (Newton).

21 In the Maximum number of iterations text field, type 200.

22 In the Tolerance factor text field, type 1.

Step 1: Stationary
1 In the Model Builder window, click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Results While Solving section.

3 Select the Plot check box.

4 From the Plot group list, choose Stress (beam).

5 In the Home toolbar, click Compute.

R E S U L T S

Line 1
1 In the Model Builder window, expand the Results>Stress (beam) node, then click Line 1.

2 In the Settings window for Line, locate the Expression section.

3 From the Unit list, choose MPa.

4 Right-click Line 1 and choose Copy.

Line 1
1 In the Model Builder window, right-click Stress (solid) and choose Paste Line.

2 In the Settings window for Line, type Stress (solid and beam) in the Label text field.

Surface 1
1 In the Model Builder window, click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

Stress (solid and beam)
1 In the Model Builder window, click Stress (solid and beam).

2 In the Settings window for Line, click to expand the Inherit Style section.

3 From the Plot list, choose Surface 1.
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4 Clear the Tube radius scale factor check box.

Stress (solid)
1 In the Model Builder window, click Stress (solid).

2 In the Stress (solid) toolbar, click Plot.

3 Click the Zoom Extents button in the Graphics toolbar.

Add a data set to use for plotting of the results at the tip of the solid beam.

Cut Point 2D 1
1 In the Results toolbar, click Cut Point 2D.

2 In the Settings window for Cut Point 2D, locate the Point Data section.

3 In the X text field, type l.

4 In the Y text field, type d/2.

5 Click Plot.

6 Click the Zoom Extents button in the Graphics toolbar.

1D Plot Group 8
1 In the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Tip displacement in the Label text 
field.

3 Locate the Data section. From the Dataset list, choose Cut Point 2D 1.

Point Graph 1
1 Right-click Tip displacement and choose Point Graph.

2 In the Settings window for Point Graph, click Replace Expression in the upper-right 
corner of the y-axis data section. From the menu, choose Component 1>Solid Mechanics>

Displacement>Displacement field - m>u - Displacement field, X component.

3 Click to expand the Coloring and Style section. In the Width text field, type 3.

4 Click to expand the Legends section. Select the Show legends check box.

5 From the Legends list, choose Manual.

6 In the table, enter the following settings:

Point Graph 2
1 In the Model Builder window, right-click Tip displacement and choose Point Graph.

Legends

u (solid)
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2 In the Settings window for Point Graph, click Replace Expression in the upper-right 
corner of the y-axis data section. From the menu, choose Component 1>Solid Mechanics>

Displacement>Displacement field - m>v - Displacement field, Y component.

3 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Dashed.

4 In the Width text field, type 3.

5 Locate the Legends section. Select the Show legends check box.

6 From the Legends list, choose Manual.

7 In the table, enter the following settings:

Point Graph 3
1 Right-click Tip displacement and choose Point Graph.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Dataset list, choose Study 1/Solution 1 (sol1).

4 Locate the Selection section. Select the Activate selection toggle button.

5 Select Point 6 only.

6 Click Replace Expression in the upper-right corner of the y-axis data section. From the 
menu, choose Component 1>Beam>Displacement>Displacement field - m>u2 -

Displacement field, X component.

7 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Dotted.

8 Find the Line markers subsection. From the Marker list, choose Asterisk.

9 In the Width text field, type 3.

10 Locate the Legends section. Select the Show legends check box.

11 From the Legends list, choose Manual.

12 In the table, enter the following settings:

Point Graph 4
1 Right-click Point Graph 3 and choose Duplicate.

Legends

v (solid)

Legends

u (beam)
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2 In the Settings window for Point Graph, click Replace Expression in the upper-right 
corner of the y-axis data section. From the menu, choose Component 1>Beam>

Displacement>Displacement field - m>v2 - Displacement field, Y component.

3 Locate the Coloring and Style section. Find the Line markers subsection. From the Marker 
list, choose Circle.

4 Locate the Legends section. In the table, enter the following settings:

5 In the Tip displacement toolbar, click Plot.

Tip displacement
1 In the Model Builder window, click Tip displacement.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 From the Title type list, choose Manual.

4 In the Title text area, type Tip displacement components (m) vs. normalized 
compressive load.

5 Locate the Plot Settings section. Select the y-axis label check box.

6 In the associated text field, type Tip displacement.

7 In the Tip displacement toolbar, click Plot.

8 Click the Zoom Extents button in the Graphics toolbar.

Evaluate the deformation of the structure.

Point Evaluation 1
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Cut Point 2D 1.

4 From the Parameter selection (NCL) list, choose Last.

5 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component 1>Solid Mechanics>Displacement>Displacement field - m>u -

Displacement field, X component.

6 Locate the Expressions section. In the table, enter the following settings:

Legends

v (beam)

Expression Unit Description

u m Solid: x-disp
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7 Click Evaluate.

Point Evaluation 2
1 Right-click Point Evaluation 1 and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Study 1/Solution 1 (sol1).

4 Locate the Selection section. Select the Activate selection toggle button.

5 Select Point 6 only.

6 Locate the Expressions section. In the table, enter the following settings:

7 Click Table 1 - Point Evaluation 1.

Point Evaluation 3
1 In the Model Builder window, under Results>Derived Values right-click Point Evaluation 1 

and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Expressions section.

3 In the table, enter the following settings:

4 Click New Table.

Point Evaluation 4
1 In the Model Builder window, under Results>Derived Values right-click Point Evaluation 2 

and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Expressions section.

3 In the table, enter the following settings:

4 Click Table 2 - Point Evaluation 3.

Expression Unit Description

u2 m Beam: x-disp

uFinal_Ref m Reference value for final horizontal 
displacement at the tip

Expression Unit Description

v m Solid: y-disp

Expression Unit Description

v2 m Beam: y-disp

vFinal_Ref m Reference value for final vertical 
displacement at the tip
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Point Evaluation 5
1 In the Model Builder window, under Results>Derived Values right-click Point Evaluation 3 

and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Parameter selection (NCL) list, choose All.

4 Locate the Expressions section. In the table, enter the following settings:

5 Locate the Data Series Operation section. From the Operation list, choose Maximum.

6 Click New Table.

Point Evaluation 6
1 In the Model Builder window, under Results>Derived Values right-click Point Evaluation 4 

and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Parameter selection (NCL) list, choose All.

4 Locate the Expressions section. In the table, enter the following settings:

5 Locate the Data Series Operation section. From the Operation list, choose Maximum.

6 Click Table 3 - Point Evaluation 5.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select 
Preset Studies for Selected Physics Interfaces>Linear Buckling.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

Expression Unit Description

abs(v) m Solid: y-disp

Expression Unit Description

abs(v2) m Beam: y-disp

abs(vMax_Ref) m
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S T U D Y  2

Step 1: Stationary
1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 Select the Modify model configuration for study step check box.

3 In the Physics and variables selection tree, select Component 1 (comp1)>

Solid Mechanics (solid).

4 Click Disable.

5 In the Physics and variables selection tree, select Component 1 (comp1)>Beam (beam)>

Point Load 1.

6 Click Disable.

Step 2: Linear Buckling
1 In the Model Builder window, click Step 2: Linear Buckling.

2 In the Settings window for Linear Buckling, locate the Physics and Variables Selection 
section.

3 Select the Modify model configuration for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>

Solid Mechanics (solid).

5 Click Disable.

6 In the Physics and variables selection tree, select Component 1 (comp1)>Beam (beam)>

Point Load 1.

7 Click Disable.

8 In the Home toolbar, click Compute.

R E S U L T S

Mode Shape (beam)
Click the Zoom Extents button in the Graphics toolbar.

Point Evaluation 7
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Study 2/Solution 2 (sol2).

4 Select Point 6 only.
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5 Locate the Expressions section. In the table, enter the following settings:

6 Click Evaluate.

Expression Unit Description

Fcr N First critical buckling load
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Introduction

A classical flow pattern is the von Kármán vortex street that can form as fluid flows past an 
object. These vortices may induce vibrations in the object. This problem involves a fluid-
structure interaction where the large deformation affects the flow path.

The magnitude and the frequencies of the oscillation generated by the fluid around the 
structure are computed and compared with the values proposed by Turek and Horn; see 
Ref. 1. 

Model Definition

The model geometry consists of a structure inside a channel with a fluid flow as 
represented in Figure 1 below.

Figure 1: Model geometry including solid and fluid domains (blue and gray, respectively).

The fluid domain is a 2.5 m long and 0.41 m high channel. The structure is composed of 
a fixed circular domain with 0.05 m radius and centered at (0.2, 0.2). The second domain 
of the structure is a 0.35 m by 0.02 m rectangular beam made of elastic material. 

The fluid enters the channel from the left with a mean velocity of 2 m/s, and the inlet 
velocity profile is assumed to be fully developed.

With the inlet boundary so close to the solid structure, one can expect the inlet velocity 
condition to affect the flow pattern. To avoid such an effect, one might need to increase 
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the distance between the inlet boundary and the solid structure. For the sake of 
comparison, the geometry in this model is kept as it is in the reference paper (Ref. 1).

The Reynolds number based on the diameter of the circle is about 200.

The fluid and solid properties are represented in the table below:

The quantities of interest are the beam rear tip displacements and the fluid forces acting 
on the structure. The magnitude and frequency targets (Ref. 1) are represented in the 
table below:

Results and Discussion

Figure 2 shows the velocity field and the von Mises stress in the structure on the deformed 
shape at different times. Note the von Kármán vortex street past the structure, which is 
significantly deformed and affects the flow field.

TABLE 1:  FLUID AND SOLID MATERIAL PROPERTIES.

PARAMETER VALUE

Fluid density 103 kg/m3

Dynamic viscosity 1 Pa·s

Young’s modulus 5.6 MPa

Poisson ratio 0.4

TABLE 2:  TARGET RESULTS.

PARAMETER MAGNITUDE FREQUENCY

x-displacement -2.69±2.53 mm 10.9 Hz

y-displacement 1.48±34.38 mm 5.3 Hz

Drag 457.3±22.66 N 10.9 Hz

Lift 2.22±149.78 N 5.3 Hz
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Figure 2: Velocity field in fluid and von Mises stress in structure for eight different time steps.
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Figure 3 below shows the evolution of the fluid forces all along the time step. The 
oscillation is fully developed after t = 3.5 s. This is due to the external perturbation added 
at t = 1.5 s. Without this perturbation, the oscillation would develop after a longer time. 
Note that the oscillation can develop with some time shift due to nonlinearities in the 
model.

Figure 3: Drag and lift forces versus time.
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Figure 4 shows the displacement of the tip of the beam in the x and y directions:

Figure 4: Tip displacement of the structure in the x and y directions (in green and blue 
respectively).

In the above figure, you can see that the magnitude of the x-displacement oscillation is 
about 2.5 mm around the average of −2.5 mm. The y-displacement varies around 1 mm 
with an oscillation magnitude of 33 mm, in good agreement with the targeted value.
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The trajectory of the tip is shown in Figure 6.

Figure 5: Beam tip trajectory. The origin corresponds to the initial position.

Figure 6 below shows the frequency spectrum of the structure oscillation.

Figure 6: Frequency spectrum of the structure tip displacement.
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The peaks show the main frequencies of the harmonic oscillation. For the x-displacement, 
the frequency is about 11 Hz, while for the y-displacement the main frequency is about 
5.5 Hz, which agree well with the targeted results.

Figure 7 below shows the variations of the lift and drag forces applied to the structure:

Figure 7: Lift and drag forces (green and blue curves, respectively) after the periodic 
oscillations have established.

The average of the total lift force is about 2 N with an oscillation magnitude of 154 N, 
while the drag force average is about 456 N with an oscillation magnitude of 26 N.

Notes About the COMSOL Implementation

The default discretization for the flow equations in the fluid-structure interface is based on 
P1+P1 elements. This means that linear order elements are used for the velocity variables. 
Such discretization is more stable for high Reynolds number but has lower accuracy 
especially in the forces evaluation. In this model, use P2+P2 elements to increase the 
accuracy for the flow equations.

Reference

1. S. Turek and J. Hron, Proposal for numerical benchmarking of fluid-structure 
interaction between an elastic object and laminar incompressible flow, Institute for 
Applied Mathematics and Numerics, University of Dortmund.
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Application Library path: Structural_Mechanics_Module/
Verification_Examples/oscillating_fsi

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Fluid Flow>Fluid-Structure Interaction>Fluid-

Solid Interaction.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Time Dependent.

6 Click Done.

G E O M E T R Y  1

Rectangle 1 (r1)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 2.5.

4 In the Height text field, type 0.41.

Circle 1 (c1)
1 In the Geometry toolbar, click Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type 0.05.

4 Locate the Position section. In the x text field, type 0.2.

5 In the y text field, type 0.2.
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Rectangle 2 (r2)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.35+0.05.

4 In the Height text field, type 0.02.

5 Locate the Position section. From the Base list, choose Center.

6 In the x text field, type 0.2+0.4/2.

7 In the y text field, type 0.2.

Rectangle 3 (r3)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.6.

4 In the Height text field, type 0.41.

5 Locate the Position section. In the x text field, type 0.2.

Difference 1 (dif1)
1 In the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 In the Settings window for Difference, type Solid in the Label text field.

3 Select the object r2 only.

4 Locate the Difference section. Find the Objects to subtract subsection. Select the 
Activate selection toggle button.

5 Select the object c1 only.

6 Select the Keep input objects check box.

7 Locate the Selections of Resulting Entities section. Select the Resulting objects selection 
check box.

Difference 2 (dif2)
1 In the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 In the Settings window for Difference, type Fluid in the Label text field.

3 Select the objects r1 and r3 only.

4 Locate the Difference section. Find the Objects to subtract subsection. Select the 
Activate selection toggle button.

5 Select the objects c1 and r2 only.
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6 Locate the Selections of Resulting Entities section. Select the Resulting objects selection 
check box.

Form Union (fin)
1 In the Geometry toolbar, click Build All.

2 In the Model Builder window, click Form Union (fin).

3 Click Build Selected.

4 Click the Zoom Extents button in the Graphics toolbar.

D E F I N I T I O N S

Deforming Domain 1
1 In the Model Builder window, under Component 1 (comp1)>Definitions>Moving Mesh click 

Deforming Domain 1.

2 Select Domain 2 only.

Step 1 (step1)
1 In the Home toolbar, click Functions and choose Global>Step.

2 In the Settings window for Step, locate the Parameters section.

3 In the Location text field, type 0.5.

4 Click to expand the Smoothing section. In the Size of transition zone text field, type 1.

Gaussian Pulse 1 (gp1)
1 In the Home toolbar, click Functions and choose Global>Gaussian Pulse.

2 In the Settings window for Gaussian Pulse, locate the Parameters section.

3 In the Location text field, type 1.5.

4 In the Standard deviation text field, type 5e-2.

L A M I N A R  F L O W  ( S P F )

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 In the Settings window for Laminar Flow, locate the Domain Selection section.

3 From the Selection list, choose Fluid.

4 Click the Show More Options button in the Model Builder toolbar.

5 In the Show More Options dialog box, in the tree, select the check box for the node 
Physics>Stabilization.

6 Click OK.

7 In the Model Builder window, click Laminar Flow (spf).
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8 In the Settings window for Laminar Flow, click to expand the Consistent Stabilization 
section.

9 Find the Navier-Stokes equations subsection. Clear the Crosswind diffusion check box.

10 Click to expand the Discretization section. From the Discretization of fluids list, choose 
P2+P2.

Inlet 1
1 In the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 1 only.

3 In the Settings window for Inlet, locate the Velocity section.

4 In the U0 text field, type 1.5*2[m/s]*Y*(0.41[m]-Y)/(0.41[m]/2)^2*step1(t/
1[s]).

Outlet 1
1 In the Physics toolbar, click Boundaries and choose Outlet.

2 Select Boundary 14 only.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Domain Selection section.

3 From the Selection list, choose Solid.

Fixed Constraint 1
1 In the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundaries 19 and 20 only.

Point Load 1
1 In the Physics toolbar, click Points and choose Point Load.

2 Select Point 11 only.

3 In the Settings window for Point Load, locate the Force section.

4 Specify the FP vector as

0 x

1[N]*gp1(t/1[s]) y
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M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Solid.

4 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Fluid.

4 Locate the Material Contents section. In the table, enter the following settings:

M E S H  1

Size
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

Edit Physics-Induced Sequence.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Coarse.

Size 1
1 In the Model Builder window, click Size 1.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Normal.

Property Variable Value Unit Property group

Young’s modulus E 5.6[MPa] Pa Basic

Poisson’s ratio nu 0.4 1 Basic

Density rho 1e3 kg/m³ Basic

Property Variable Value Unit Property group

Density rho 1000 kg/m³ Basic

Dynamic viscosity mu 1 Pa·s Basic
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Free Triangular 1
1 In the Model Builder window, click Free Triangular 1.

2 In the Settings window for Free Triangular, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domains 1–3 only.

Mapped 1
1 In the Model Builder window, right-click Mesh 1 and choose Mapped.

2 Right-click Mapped 1 and choose Move Up.

3 In the Settings window for Mapped, click to expand the Control Entities section.

4 Clear the Smooth across removed control entities check box.

Distribution 1
1 Right-click Mapped 1 and choose Distribution.

2 Select Boundaries 12 and 13 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 From the Distribution type list, choose Predefined.

5 In the Number of elements text field, type 40.

6 In the Element ratio text field, type 5.

7 Select the Reverse direction check box.

Boundary Layers 1
1 In the Model Builder window, click Boundary Layers 1.

2 In the Settings window for Boundary Layers, click to expand the Corner Settings section.

3 From the Handling of sharp corners list, choose None.

4 Click to expand the Transition section. Clear the Smooth transition to interior mesh 
check box.

5 Click Build All.

You can now prepare the probe variables to display during the computation.

D E F I N I T I O N S

Integration 1 (intop1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.
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4 Select Boundaries 8–10 and 15–18 only.

Global Variable Probe 1 (var1)
1 In the Definitions toolbar, click Probes and choose Global Variable Probe.

2 In the Settings window for Global Variable Probe, type drag in the Variable name text 
field.

3 Locate the Expression section. In the Expression text field, type -
intop1(spf.T_stressx).

4 Select the Description check box.

5 In the associated text field, type Drag.

6 Click to expand the Table and Window Settings section. Click Add Plot Window.

Global Variable Probe 2 (var2)
1 Right-click Global Variable Probe 1 (var1) and choose Duplicate.

2 In the Settings window for Global Variable Probe, type lift in the Variable name text 
field.

3 Locate the Expression section. In the Expression text field, type -
intop1(spf.T_stressy).

4 In the Description text field, type Lift.

Domain Point Probe 1
1 In the Definitions toolbar, click Probes and choose Domain Point Probe.

2 In the Settings window for Domain Point Probe, locate the Point Selection section.

3 From the Frame list, choose Material.

4 In row Coordinates, set X to 0.595.

5 In row Coordinates, set Y to 0.2.

Point Probe Expression 1 (ppb1)
1 In the Model Builder window, expand the Domain Point Probe 1 node, then click 

Point Probe Expression 1 (ppb1).

2 In the Settings window for Point Probe Expression, type u in the Variable name text field.

3 Locate the Expression section. In the Expression text field, type u_solid.

4 From the Table and plot unit list, choose mm.

5 Click to expand the Table and Window Settings section. Click Add Plot Window.
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Point Probe Expression 2 (ppb2)
1 Right-click Component 1 (comp1)>Definitions>Domain Point Probe 1>

Point Probe Expression 1 (ppb1) and choose Duplicate.

2 In the Settings window for Point Probe Expression, locate the Expression section.

3 In the Expression text field, type v_solid.

4 In the Variable name text field, type v.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,5e-2,5).

4 Click to expand the Results While Solving section. Select the Plot check box.

5 From the Update at list, choose Time steps taken by solver.

Solution 1 (sol1)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

Spatial mesh displacement (comp1.spatial.disp)
1 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Dependent Variables 1 node, then click 
Spatial mesh displacement (comp1.spatial.disp).

2 In the Settings window for Field, locate the Scaling section.

3 In the Scale text field, type 1e-3.

Displacement field (comp1.u_solid)
1 In the Model Builder window, click Displacement field (comp1.u_solid).

2 In the Settings window for Field, locate the Scaling section.

3 In the Scale text field, type 1e-3.

Pressure (comp1.p)
1 In the Model Builder window, click Pressure (comp1.p).

2 In the Settings window for Field, locate the Scaling section.

3 From the Method list, choose Manual.

4 In the Scale text field, type 1e3.
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Velocity field (spatial frame) (comp1.u_fluid)
1 In the Model Builder window, click Velocity field (spatial frame) (comp1.u_fluid).

2 In the Settings window for Field, locate the Scaling section.

3 From the Method list, choose Manual.

4 In the Scale text field, type 1.

5 In the Study toolbar, click Compute.

R E S U L T S

Velocity (spf)
The first plot group shows the fluid velocity magnitude.

Surface 2
1 Right-click Velocity (spf) and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type solid.mises.

4 Locate the Coloring and Style section. From the Color table list, choose Traffic.

Arrow Surface 1
Right-click Velocity (spf) and choose Arrow Surface.

Animation 1
In the Velocity (spf) toolbar, click Animation and choose Player.

Probe Plot Group 5
1 In the Settings window for 1D Plot Group, type Lift and drag forces in the Label text 

field.

2 Locate the Plot Settings section. Select the x-axis label check box.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type Lift and drag forces (N).

5 Locate the Legend section. From the Position list, choose Middle left.

6 In the Lift and drag forces toolbar, click Plot.

7 Locate the Axis section. Select the Manual axis limits check box.

8 In the x minimum text field, type 3.

9 In the x maximum text field, type 5.

10 In the y minimum text field, type -160.

11 In the y maximum text field, type 500.
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12 Locate the Legend section. From the Position list, choose Upper right.

13 In the Lift and drag forces toolbar, click Plot.

Probe Plot Group 6
1 In the Model Builder window, under Results click Probe Plot Group 6.

2 In the Settings window for 1D Plot Group, type Beam tip displacement in the Label 
text field.

3 Locate the Plot Settings section. Select the x-axis label check box.

4 Locate the Axis section. Select the Manual axis limits check box.

5 In the x minimum text field, type 3.

6 In the x maximum text field, type 5.

7 In the y minimum text field, type -40.

8 In the y maximum text field, type 40.

9 Locate the Title section. From the Title type list, choose Manual.

10 In the Title text area, type Beam tip displacement (mm).

11 In the Beam tip displacement toolbar, click Plot.

1D Plot Group 7
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Frequency spectrum in the Label text 
field.

3 Locate the Data section. From the Dataset list, choose Domain Point Probe 1.

4 From the Time selection list, choose Interpolated.

5 In the Times (s) text field, type range(3,5e-3,5).

Point Graph 1
1 Right-click Frequency spectrum and choose Point Graph.

2 In the Settings window for Point Graph, locate the y-Axis Data section.

3 In the Expression text field, type u_solid.

4 From the Unit list, choose mm.

5 Locate the x-Axis Data section. From the Parameter list, choose Frequency spectrum.

6 Select the Frequency range check box.

7 In the Minimum text field, type 1.

8 In the Maximum text field, type 15.
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Point Graph 2
1 Right-click Point Graph 1 and choose Duplicate.

2 In the Settings window for Point Graph, locate the y-Axis Data section.

3 In the Expression text field, type v_solid.

4 In the Frequency spectrum toolbar, click Plot.

1D Plot Group 8
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Beam tip trajectory in the Label text 
field.

Table Graph 1
1 Right-click Beam tip trajectory and choose Table Graph.

2 In the Settings window for Table Graph, locate the Data section.

3 From the x-axis data list, choose Displacement field, X component (mm), Point: (0.595,

0.2).

4 From the Plot columns list, choose Manual.

5 In the Columns list, select Displacement field, Y component (mm), Point: (0.595, 0.2).

6 In the Beam tip trajectory toolbar, click Plot.
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Introduction

This example studies the deformation of a hemispherical shell, where the loads cause 
significant geometric nonlinearity. The maximum deflections are more than two 
magnitudes larger than the thickness of the shell. The problem is a standard benchmark, 
used for testing shell formulations in a case which contains membrane and bending action, 
as well as large rigid body rotation. It is described in Ref. 1.

Model Definition

Figure 1 shows the geometry and the applied loads. Due to the double symmetry, the 
model only includes one quarter of the hemisphere.

Figure 1: The geometry and loads.

The material is linear elastic with E = 68.25 MPa and ν = 0.3. The radius of the 
hemisphere is 10 m, and the thickness of the shell is 0.04 m. The hole at the top has a 
radius of 3.0902 m because 18° in the meridional direction from the top has been 
removed. The forces all have the value 200 N before taking symmetry into account. In the 
model, two forces of 100 N are applied in the symmetry planes at the lower edge of the 
shell.

Results and Discussion

The target solution in Ref. 1 is u = −5.952 m under the inward acting load and 
v = 3.427 m under the outward acting load. Both target values have an error bound of 
±2%. The values computed in COMSOL are u = −5.862 m and v = 3.407 m. Both values 
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are within 2% of the target. Figure 2 shows the deformed shape of the shell together with 
contours for the equivalent stress.

Figure 2: von Mises stress on top surface.
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The change in the displacement as the load parameter increases is shown in Figure 3. As 
can be seen, the nonlinear effects are strong. The incremental stiffness with respect to the 
y direction force increases by one order of magnitude during the loading.

Figure 3: Displacements as functions of applied load.

Notes About the COMSOL Implementation

In a highly nonlinear problem it is a good idea to use the parametric continuation solver 
to track the solution instead of trying to solve at the full load. Several solver settings can 
be tuned to improve the convergence. Due to the large difference between the bending 
and the membrane stiffnesses in a thin shell, a small error in the approximated 
displacements during the iterations can cause large residual forces. For this reason, manual 
control of the damping is used in the Newton method. This will often improve solution 
speed for problems with severe geometrical nonlinearities.

Because the model uses point loads, the gradients are steep close to the locations where 
the loads are applied. For this reason you modify the distribution of the elements so that 
finer elements are generated toward the corners of the model. From a computational point 
of view, this is more effective than using a uniform refinement of the mesh.
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Reference

1. N.K. Prinja and R.A. Clegg, “A Review of Benchmark Problems for Geometric Non-
linear Behaviour of 3-D Beams and Shells (SUMMARY),” NAFEMS Ref: R0024, 
pp. F9A–F9B, 1993.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/pinched_hemispherical_shell

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Shell (shell).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Sphere 1 (sph1)
1 In the Geometry toolbar, click Sphere.

2 In the Settings window for Sphere, locate the Size section.

3 In the Radius text field, type 10.

4 Click Build Selected.

Block 1 (blk1)
1 In the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 10.
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4 In the Depth text field, type 10.

5 In the Height text field, type 10.

6 Locate the Position section. In the x text field, type -5.

7 In the y text field, type -5.

8 In the z text field, type 10*cos(18*pi/180)[m].

9 Click Build Selected.

Difference 1 (dif1)
1 In the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 Select the object sph1 only.

3 In the Settings window for Difference, locate the Difference section.

4 Find the Objects to subtract subsection. Select the Activate selection toggle button.

5 Select the object blk1 only.

6 Click Build Selected.

Convert to Surface 1 (csur1)
1 In the Geometry toolbar, click Conversions and choose Convert to Surface.

2 Select the object dif1 only.

3 In the Settings window for Convert to Surface, click Build Selected.

Delete Entities 1 (del1)
1 In the Model Builder window, right-click Geometry 1 and choose Delete Entities.

2 On the object csur1, select Boundaries 1–8 only.

You can do this by first selecting all boundaries and then removing Boundary 9.

3 In the Settings window for Delete Entities, click Build Selected.

4 Click the Zoom Extents button in the Graphics toolbar.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Steel in the Label text field.
6 |  P I N C H E D  H E M I S P H E R I C A L  S H E L L



3 Locate the Material Contents section. In the table, enter the following settings:

Note that the density is not used for a static analysis so the value you enter has no effect 
on the solution.

S H E L L  ( S H E L L )

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Shell (shell) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type 0.04.

Symmetry 1
1 In the Physics toolbar, click Edges and choose Symmetry.

2 Select Edges 1 and 4 only.

Prescribed Displacement/Rotation 1
1 In the Physics toolbar, click Points and choose Prescribed Displacement/Rotation.

Property Variable Value Unit Property group

Young’s modulus E 68.25e6 Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 6850 kg/m³ Basic
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2 Select Point 4 only.

It might be easier to select the correct point by using the Selection List window. To open 
this window, in the Home toolbar click Windows and choose Selection List. (If you are 
running the cross-platform desktop, you find Windows in the main menu.)

3 In the Settings window for Prescribed Displacement/Rotation, locate the 
Prescribed Displacement section.

4 Select the Prescribed in z direction check box.

Point Load 1
1 In the Physics toolbar, click Points and choose Point Load.

2 In the Settings window for Point Load, type Point Load, X in the Label text field.

3 Select Point 4 only.

4 Locate the Force section. Specify the FP vector as

Point Load 2
1 In the Physics toolbar, click Points and choose Point Load.

2 In the Settings window for Point Load, type Point Load, Y in the Label text field.

3 Select Point 2 only.

4 Locate the Force section. Specify the FP vector as

M E S H  1

Mapped 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Mapped.

2 In the Settings window for Mapped, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

-100*para x

0 y

0 z

0 x

100*para y

0 z
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Distribution 1
1 Right-click Mapped 1 and choose Distribution.

2 Select Edges 1 and 4 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 From the Distribution type list, choose Predefined.

5 In the Number of elements text field, type 16.

6 In the Element ratio text field, type 3.

7 From the Growth formula list, choose Geometric sequence.

Distribution 2
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 Select Edges 2 and 3 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 From the Distribution type list, choose Predefined.

5 In the Number of elements text field, type 16.

6 In the Element ratio text field, type 3.

7 Select the Symmetric distribution check box.

8 From the Growth formula list, choose Geometric sequence.

9 Click Build All.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

S T U D Y  1

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Study Settings section.

Name Expression Value Description

para 0 0 Solver parameter
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3 Select the Include geometric nonlinearity check box.

Set up an auxiliary continuation sweep for the para parameter.

4 Click to expand the Study Extensions section. Select the Auxiliary sweep check box.

5 Click Add.

6 In the table, enter the following settings:

Solution 1 (sol1)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Stationary Solver 1.

3 In the Settings window for Stationary Solver, locate the General section.

4 In the Relative tolerance text field, type 0.0001.

5 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Stationary Solver 1 node, then click Fully Coupled 1.

6 In the Settings window for Fully Coupled, click to expand the Method and Termination 
section.

7 From the Nonlinear method list, choose Constant (Newton).

8 In the Study toolbar, click Compute.

R E S U L T S

Surface 1
1 In the Model Builder window, expand the Results>Stress (shell) node, then click Surface 1.

2 In the Settings window for Surface, click to expand the Range section.

3 Select the Manual color range check box.

4 In the Maximum text field, type 5e5.

5 In the Stress (shell) toolbar, click Plot.

1D Plot Group 5
In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

Point Graph 1
1 Right-click 1D Plot Group 5 and choose Point Graph.

2 Select Point 4 only.

Parameter name Parameter value list

para (Solver parameter) range(0,0.1,1)
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3 In the Settings window for Point Graph, locate the y-Axis Data section.

4 In the Expression text field, type -u.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type para*100[N].

7 Click to expand the Coloring and Style section. In the Width text field, type 3.

8 Click to expand the Legends section. Select the Show legends check box.

9 From the Legends list, choose Manual.

10 In the table, enter the following settings:

Point Graph 2
1 Right-click Point Graph 1 and choose Duplicate.

2 In the Settings window for Point Graph, locate the Selection section.

3 Select the Activate selection toggle button.

4 In the list, select 4.

5 Click Remove from Selection.

6 Select Point 2 only.

7 Locate the y-Axis Data section. In the Expression text field, type v.

8 Locate the Legends section. In the table, enter the following settings:

1D Plot Group 5
1 In the Model Builder window, click 1D Plot Group 5.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the x-axis label check box.

4 In the associated text field, type Force (N).

5 Select the y-axis label check box.

6 In the associated text field, type Displacement under force (m).

7 Locate the Legend section. From the Position list, choose Upper left.

Legends

-u under x force

Legends

v under y force
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8 In the 1D Plot Group 5 toolbar, click Plot.

Evaluate the displacements in the points where a comparison should be made with the 
target.

Evaluation Group 1
1 In the Results toolbar, click Evaluation Group.

2 In the Settings window for Evaluation Group, locate the Data section.

3 From the Parameter selection (para) list, choose Last.

4 Locate the Transformation section. Select the Transpose check box.

Point Evaluation 1
1 Right-click Evaluation Group 1 and choose Point Evaluation.

2 Select Points 2 and 4 only.

3 In the Settings window for Point Evaluation, locate the Expressions section.

4 In the table, enter the following settings:

5 In the Evaluation Group 1 toolbar, click Evaluate.

Expression Unit Description

u m Displacement field, X component

v m Displacement field, Y component
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Introduction

Buckling is a phenomenon that can cause sudden failure of a structure.

A linear buckling analysis predicts the critical buckling load. Such an analysis, however, 
does not give any information about what happens at loads higher than the critical load. 
Tracing the solution after the critical load is called a postbuckling analysis.

A linear buckling analysis also often overpredicts the load-carrying capacity of the 
structure.

In order to accurately determine the critical buckling load or predict the postbuckling 
behavior, you can use the nonlinear solver and ramp up the applied load to compute the 
structure deformation. The buckling load can then be based on when a certain, not 
acceptable, deformation is reached.

Once the critical buckling load has been reached it can happen that the structure 
undergoes a sudden large deformation into a new stable configuration. This is known as a 
snap-through phenomenon. A snap-through process cannot be simulated using prescribed 
load in a standard nonlinear static solver because the problem becomes numerically 
singular. Physically speaking, it is a highly transient problem as the structure “jumps” from 
one state to another. For simple cases with a single point load, it is often possible to replace 
the point load with a prescribed displacement and then measure the reaction force instead.

For more general problems the post-buckling solution must however be tracked using 
more sophisticated methods, as shown in this example.
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Figure 1 shows the variation of load versus the displacement for such a difficult case. It 
illustrates the possible computational problem by using either a load control (path A) or a 
displacement control (path B).

Figure 1: Load versus displacement in snap-through buckling

The shell structure in this example has a behavior similar to this.

Model Definition

The model studied here is a benchmark for a hinged cylindrical panel subjected to a point 
load at its center; see Ref. 1.

• The radius of the cylinder is R = 2.54 m and all edges have a length of 2L = 0.508 m. 
The angular span of the panel is thus 0.2 radians. The panel thickness is th = 6.35 mm.

• The straight edges are hinged.

• In the study the variation of the panel center vertical displacement with respect to the 
change of the applied load is of interest.

Load

A

B

u
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Due to the double symmetry, only one quarter of the geometry is modeled as shown in 
Figure 2. The blue lines show the symmetry edge conditions, while the red line shows the 
location of the hinged edge condition.

Figure 2: Problem description.

In general, you should be careful with using symmetry in buckling problems, because 
nonsymmetric solutions may exist.

L

R

P

theta
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Results

In Figure 3 you can see the applied load as a function of the panel center displacement. 
The figure shows clearly a non-unique solution for a given applied load (between -400 N 
to 600 N) or a given displacement (between 14.4 mm and 17 mm).

Figure 3: Applied load versus panel center displacement.

As shown in Table 1, the results agree well with the target data from Ref. 1.

TABLE 1:  COMPARISON BETWEEN TARGET AND COMPUTED DATA.

Applied Load (N) Displacement 
target (mm)

Displacement 
computed (mm)

Difference (%)

155.1 1.846 1.818 1.52

574.2 11.904 12.05 1.23

485.1 15.501 15.56 0.38

24.9 17.008 17.028 0.12

-300.3 14.520 14.537 0.12

-381.3 16.961 16.77 1.13

-1.8 24.824 24.81 0.06

1469.4 33.388 33.34 0.14
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Notes About the COMSOL Implementation

The main feature of this model is that a limit point instability occurs at the buckling load. 
Neither a load control, nor a point displacement control, would be able to track the jump 
between the stable solution paths (see Figure 1). To solve this type of problem it is 
important to find a proper parameter that increases monotonically.

In this example, a good such parameter is the average of the displacement in the direction 
of the applied force. You use a nonlocal average coupling to measure the displacement and 
then add a global equation to compute the appropriate point load for each prescribed 
parameter value.

There is no general way to determine which controlling parameter to use, so it is necessary 
to use some physical insight.

Reference

1. K.Y. Sze, X.H. Liua, and S.H. Lob, “Popular Benchmark Problems for Geometric 
Nonlinear Analysis of Shells,” Finite Element in Analysis and Design, vol. 40, issue 11, 
pp. 1551–1569, 2004.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/postbuckling_shell

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Shell (shell).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.
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6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Work Plane 1 (wp1)
1 In the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 From the Plane list, choose xz-plane.

4 Click Show Work Plane.

Work Plane 1 (wp1)>Line Segment 1 (ls1)
1 In the Work Plane toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 Locate the Endpoint section. From the Specify list, choose Coordinates.

5 Locate the Starting Point section. In the yw text field, type R.

6 Locate the Endpoint section. In the xw text field, type L and yw to R.

7 Click Build Selected.

8 In the Model Builder window, click Geometry 1.

Name Expression Value Description

R 2540[mm] 2.54 m Panel radius

L 254[mm] 0.254 m Panel length

thic 6.35[mm] 0.00635 m Panel thickness

theta 0.1[rad] 0.1 rad Panel section angle

E0 3.103[GPa] 3.103E9 Pa Young's modulus

nu0 0.3 0.3 Poisson's ratio

disp 0 0 Displacement parameter
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Revolve 1 (rev1)
1 In the Geometry toolbar, click Revolve.

2 In the Settings window for Revolve, locate the Revolution Angles section.

3 Click the Angles button.

4 In the End angle text field, type theta.

5 Locate the Revolution Axis section. Find the Direction of revolution axis subsection. In 
the xw text field, type 1.

6 In the yw text field, type 0.

7 Click Build Selected.

D E F I N I T I O N S

Click the Zoom Extents button in the Graphics toolbar.

Average 1 (aveop1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 In the Settings window for Average, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 1 only.

Integration 1 (intop1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Point.

4 Select Point 4 only.

Variables 1
1 In the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

Name Expression Unit

w_center -intop1(w) m
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S H E L L  ( S H E L L )

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Shell (shell) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type thic.

Linear Elastic Material 1
1 In the Model Builder window, click Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the E list, choose User defined. In the associated text field, type E0.

4 From the ν list, choose User defined. In the associated text field, type nu0.

Symmetry 1
1 In the Physics toolbar, click Edges and choose Symmetry.

2 Select Edge 3 only.

Symmetry 2
1 In the Physics toolbar, click Edges and choose Symmetry.

2 Select Edge 4 only.

3 In the Settings window for Symmetry, locate the Coordinate System Selection section.

4 From the Coordinate system list, choose Global coordinate system.

5 Locate the Symmetry section. From the Axis to use as symmetry plane normal list, choose 
1.

Pinned 1
1 In the Physics toolbar, click Edges and choose Pinned.

2 Select Edge 2 only.

Point Load 1
1 In the Physics toolbar, click Points and choose Point Load.

2 Select Point 4 only.

Apply 1/4th of the total load because of the double symmetry used in this model.

3 In the Settings window for Point Load, locate the Force section.
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4 Specify the FP vector as

5 Click the Show More Options button in the Model Builder toolbar.

6 In the Show More Options dialog box, in the tree, select the check box for the node 
Physics>Equation-Based Contributions.

7 Click OK.

Global Equations 1
1 In the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Global Equations section.

3 In the table, enter the following settings:

4 Locate the Units section. Click Select Dependent Variable Quantity.

5 In the Physical Quantity dialog box, type force in the text field.

6 Click Filter.

7 In the tree, select General>Force (N).

8 Click OK.

9 In the Settings window for Global Equations, locate the Units section.

10 Click Select Source Term Quantity.

11 In the Physical Quantity dialog box, type displacement in the text field.

12 Click Filter.

13 In the tree, select General>Displacement (m).

14 Click OK.

0 x

0 y

-P/4 z

Name f(u,ut,utt,t) (1) Initial value 
(u_0) (1)

Initial value 
(u_t0) (1/s)

Description

P aveop1(-w)-disp 0 0 Force at shell 
center
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M E S H  1

Mapped 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Mapped.

2 Select Boundary 1 only.

Distribution 1
1 Right-click Mapped 1 and choose Distribution.

2 Select Edges 1 and 2 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 10.

5 Click Build Selected.

S T U D Y  1

Step 1: Stationary
Set up an auxiliary continuation sweep for the disp parameter.

1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study Extensions section.

3 Select the Auxiliary sweep check box.

4 Click Add.

5 In the table, enter the following settings:

6 Locate the Study Settings section. Select the Include geometric nonlinearity check box.

Sometimes it is not straightforward to guess the maximum value of the parameter used. 
You can then instead set a stop condition for the parametric solver based on something 
that is known.

Solution 1 (sol1)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Stationary Solver 1 node.

Parameter name Parameter value list

disp (Displacement parameter) range(0,2e-4,1)
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4 Right-click Parametric 1 and choose Stop Condition.

5 In the Settings window for Stop Condition, locate the Stop Expressions section.

6 Click Add.

7 In the table, enter the following settings:

Specify that the solution is to be stored just before the stop condition is reached.

8 Locate the Output at Stop section. From the Add solution list, choose Step before stop.

9 Clear the Add warning check box.

10 In the Model Builder window, click Stationary Solver 1.

11 In the Settings window for Stationary Solver, click to expand the Output section.

12 Clear the Reaction forces check box.

13 Click Compute.

R E S U L T S

1D Plot Group 5
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Force at Shell Center in the Label 
text field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type Force at Shell Center.

Point Graph 1
1 Right-click Force at Shell Center and choose Point Graph.

2 Select Point 4 only.

3 In the Settings window for Point Graph, click Replace Expression in the upper-right 
corner of the y-axis data section. From the menu, choose Component 1>Shell>P -

Force at shell center - N.

4 Locate the x-Axis Data section. From the Parameter list, choose Expression.

5 In the Expression text field, type w_center.

6 Select the Description check box.

7 In the associated text field, type Vertical displacement at shell center.

Stop expression Stop if Active Description

comp1.w_center>0.035 True (>=1) √ Stop expression 1
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8 In the Force at Shell Center toolbar, click Plot.
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Introduction

This example studies forced random vibrations of a simply-supported deep beam. The 
beam is loaded by a distributed force with a uniform power spectral density (PSD). The 
output PSD are computed for the displacement and bending stress response. The 
computed values are compared with analytical results (NAFEMS test 5R from Ref. 1).

Model Definition

The model studied in this example consists of a simply supported beam with a square cross 
section. One end is pinned and has a constrained rotation along the beam axis. At the other 
end, the displacements in the plane of beam cross section are constrained.

G E O M E T R Y

• Beam length, L = 10 m

• Beam cross section dimension l = 2 m

With such aspect ratio of the cross section size to the beam length, shear deformations and 
rotational inertia effects can no longer be neglected as it is done in the Euler-Bernoulli 
theory. Therefore, the solution is computed using a Timoshenko beam.

M A T E R I A L

• Young’s modulus, E = 200 GPa

• Poisson’s ratio, ν = 0.3

• Mass density, ρ = 8000 kg/m3

• Rayleigh damping coefficient: α = 5.36 s-1, β = 7.46·10−5 m/s

The values of the damping coefficients are chosen to give a damping ratio of 2% for the 
first eigenmode.

C O N S T R A I N T S

At x = 0, u = v = w =0; thx =0

At x = 10, v = w = 0

L O A D

For a linear system, the response in the frequency domain for a single variable V to the 
excitation F can be written

V f( ) HVF f( )F=
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where f is the frequency, and H is the complex valued transfer function. It can then be 
shown that the corresponding spectral densities have the relation

where the asterisk denotes a complex conjugate. This type of relation is true not only for 
the degrees of freedom, but for any quantity that is linearly related to the input. This 
includes components of stress and (engineering) strain, but not nonlinear quantities such 
as equivalent or principal stresses.

In this example, a load of F = 106 N/m in the y direction is applied uniformly along the 
beam for the forced harmonic vibration study. For the random vibration analysis, the load 
is assumed to have a uniformly distributed PSD of 1012 (N/m)2/Hz. Thus, one should 
expect that results have the property

That is, the PSD response is simply the square of the standard harmonic response.

SV f( ) HVF f( ) 2SF f( ) H*
VF f( )HVF f( )SF f( )= =

SV f( ) V 2 f( )=
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Results and Discussion

The plot below shows the computed PSD of the beam vertical displacement at the mid 
point. Note that is also matches the squared non-random frequency response at the same 
point.

Figure 1: The PSD of the displacement response at the midpoint of the beam.

In Table 1, the computed results are compared with the analytical results from Ref. 1. The 
agreement is good.

In this benchmark, a mesh consisting of only five elements is prescribed. The stress is 
measured at the midpoint of the beam, that is at the midpoint of the central beam element. 
Since the finite element approximation in the beam elements give a linear variation of the 
bending moment within each element, the bending moment (and thus the stress) in the 
central element is constant for symmetry reasons. The true midpoint value will thus be 

TABLE 1:  COMPARISON BETWEEN ANALYTICAL AND COMPUTED RANDOM RESPONSES.

Peak displacement PSD Peak stress PSD Frequency 

mm2/Hz (N/mm2)2/Hz Hz

REFERENCE 180.90 58516 42.65

COMSOL 180.89 56933 42.66
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underestimated. If six elements are used instead, there will be a node at the midpoint. The 
stress PSD value in that node turns out to be 60,652 (N/mm2)2/Hz.

Reference

1. J. Maguire, D.J. Dawswell, and L. Gould, “Selected Benchmarks for Forced Vibration”, 
NAFEMS R0016, 1989.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/random_vibration_deep_beam

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Beam (beam).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>

Random Vibration (PSD).

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

G E O M E T R Y  1

Line Segment 1 (ls1)
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 Locate the Endpoint section. From the Specify list, choose Coordinates.

5 In the x text field, type 10.

6 Click Build All Objects.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

B E A M  ( B E A M )

1 In the Model Builder window, under Component 1 (comp1) click Beam (beam).

2 In the Settings window for Beam, locate the Beam Formulation section.

3 From the list, choose Timoshenko.

Cross Section Data 1
1 In the Model Builder window, under Component 1 (comp1)>Beam (beam) click 

Cross Section Data 1.

Name Expression Value Description

F 1e6[N/m] 1E6 N/m Edge load

PSD F^2/1[Hz] 1E12 kg²/s³ Random edge load, power 
spectral density

Property Variable Value Unit Property group

Young’s modulus E 2e11 Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 8000 kg/m³ Basic
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2 In the Settings window for Cross Section Data, locate the Cross Section Definition section.

3 From the list, choose Common sections.

4 In the hy text field, type 2.

5 In the hz text field, type 2.

Section Orientation 1
1 In the Model Builder window, click Section Orientation 1.

2 In the Settings window for Section Orientation, locate the Section Orientation section.

3 From the Orientation method list, choose Orientation vector.

4 Specify the V vector as

Linear Elastic Material 1
In the Model Builder window, click Linear Elastic Material 1.

Damping 1
1 In the Physics toolbar, click Attributes and choose Damping.

2 In the Settings window for Damping, locate the Damping Settings section.

3 In the αdM text field, type 5.36.

4 In the βdK text field, type 7.46e-5.

Prescribed Displacement/Rotation 1
1 In the Physics toolbar, click Points and choose Prescribed Displacement/Rotation.

2 Select Point 1 only.

3 In the Settings window for Prescribed Displacement/Rotation, locate the 
Prescribed Displacement section.

4 Select the Prescribed in x direction check box.

5 Select the Prescribed in y direction check box.

6 Select the Prescribed in z direction check box.

7 Locate the Prescribed Rotation section. From the list, choose Rotation.

8 Select the Free rotation around y direction check box.

9 Select the Free rotation around z direction check box.

0 X

0 Y

1 Z
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Prescribed Displacement/Rotation 2
1 In the Physics toolbar, click Points and choose Prescribed Displacement/Rotation.

2 Select Point 2 only.

3 In the Settings window for Prescribed Displacement/Rotation, locate the 
Prescribed Displacement section.

4 Select the Prescribed in y direction check box.

5 Select the Prescribed in z direction check box.

M E S H  1

Edge 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Edge.

2 Select Edge 1 only.

Distribution 1
1 Right-click Edge 1 and choose Distribution.

2 In the Settings window for Edge, click Build All.

D E F I N I T I O N S

Set up an operator to evaluate variables at the beam midpoint.

General Extrusion 1 (genext1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose General Extrusion.

2 In the Settings window for General Extrusion, locate the Source Selection section.

3 From the Geometric entity level list, choose Edge.

4 Select Edge 1 only.

5 Locate the Destination Map section. In the x-expression text field, type 5.

6 In the y-expression text field, type 0.

7 In the z-expression text field, type 0.

8 Locate the Source section. From the Source frame list, choose Material (X, Y, Z).

Variables 1
1 In the Model Builder window, right-click Definitions and choose Variables.

2 In the Settings window for Variables, locate the Variables section.
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3 In the table, enter the following settings:

G L O B A L  D E F I N I T I O N S

Reduced-Order Modeling
Set up a control parameter to be used as the edge load.

Global Reduced Model Inputs 1
1 In the Model Builder window, expand the Global Definitions>Reduced-Order Modeling 

node, then click Global Reduced Model Inputs 1.

2 In the Settings window for Global Reduced Model Inputs, locate the Reduced Model Inputs 
section.

3 In the table, enter the following settings:

B E A M  ( B E A M )

Edge Load 1
1 In the Physics toolbar, click Edges and choose Edge Load.

2 Select Edge 1 only.

3 In the Settings window for Edge Load, locate the Force section.

4 Specify the FL vector as

S T U D Y  1

Step 1: Eigenfrequency
Set the search position close to the target value of the first natural frequency.

1 In the Model Builder window, under Study 1 click Step 1: Eigenfrequency.

Name Expression Unit Description

V genext1(v) m Displacement, y 
component

Sb genext1(beam.sb1) N/m² Bending stress

Control name Expression

Fy F

0 X

Fy Y

0 Z
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2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 In the Search for eigenfrequencies around text field, type 40.

4 Locate the Physics and Variables Selection section. Select the 
Modify model configuration for study step check box.

5 In the Physics and variables selection tree, select Component 1 (comp1)>Beam (beam)>

Linear Elastic Material 1>Damping 1.

6 Click Disable.

The eigenmode computation should be always performed for the undamped system. 
The damping will be used however in the consequent modal frequency response and 
random response analysis.

S T U D Y  3

Model Reduction
1 In the Model Builder window, under Study 3 click Model Reduction.

2 In the Settings window for Model Reduction, locate the Model Reduction Settings section.

3 Select the Reduced model simulation check box.

The computation of the solution for Study 3 will find the eigenfrequencies and build up 
a modal reduced-order model (ROM) based on the computed eigenmodes.

4 In the Home toolbar, click Compute.

You can see all computed eigenfrequencies in the automatically generated evaluation 
group.

G L O B A L  D E F I N I T I O N S

Next, set up the input PSD for the random edge load.

Reduced-Order Modeling
1 In the Model Builder window, under Global Definitions>Reduced-Order Modeling click 

Random Vibration 1 (rvib1).

2 In the Settings window for Random Vibration, locate the Power Spectrum section.

3 In the table, enter the following settings:

Update the study to make the input change available for the solution.

Control name Power spectral density

rom1.Fy PSD
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S T U D Y  3

1 In the Study toolbar, click Update Solution.

The random response computations can be performed as postprocessing steps using the 
updated solution.

R E S U L T S

Add a plot of the PSD for the displacement responses at the midpoint. For verification, 
you also plot the non-random frequency response result computed using ROM.

Global Evaluation Sweep 1
1 In the Results toolbar, click More Derived Values and choose Other>

Global Evaluation Sweep.

Use the frequency range to resolve well the values close to the target first natural 
frequency.

2 In the Settings window for Global Evaluation Sweep, locate the Parameters section.

3 In the table, enter the following settings:

4 Locate the Expressions section. In the table, enter the following settings:

Tables
Click Evaluate.

T A B L E

1 Go to the Table window.

2 Click Table Graph in the window toolbar.

R E S U L T S

Table Graph 1
1 In the Model Builder window, expand the Results>Tables node, then click Results>

1D Plot Group 3>Table Graph 1.

Parameter name Parameter value list

freq range(20,1,41) range(41.5,0.01,43.5) range(44,1,60) 
[Hz]

Expression Unit Description

rvib1.psd(V)*1e6 Random response PSD [mm^2/Hz]

abs(rom1.eval(V))^2*1e6 Frequency response squared 
[mm^2]
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2 In the Settings window for Table Graph, click to expand the Legends section.

3 Locate the Coloring and Style section. Find the Line markers subsection. From the Marker 
list, choose Cycle.

4 Locate the Legends section. Select the Show legends check box.

1D Plot Group 3
Indicate the target peak frequency.

1 In the Model Builder window, click 1D Plot Group 3.

2 In the Settings window for 1D Plot Group, locate the Grid section.

3 In the Extra x text field, type 42.65.

4 Locate the Legend section. From the Position list, choose Upper left.

5 In the 1D Plot Group 3 toolbar, click Plot.

The actually computed peak frequency is close to 42.66 (Hz).

Finally, calculate the maximum PSD values in the computed frequency range for both the 
displacement and bending stress responses.

Global Evaluation Sweep 2
1 In the Model Builder window, under Results>Derived Values right-click 

Global Evaluation Sweep 1 and choose Duplicate.

2 In the Settings window for Global Evaluation Sweep, locate the Parameters section.

3 In the table, click to select the cell at row number 1 and column number 2.

4 In the table, enter the following settings:

5 Locate the Expressions section. In the table, enter the following settings:

6 Click New Table.

Compare the results with the target values.

Parameter name Parameter value list

freq 42.66 [Hz]

Expression Unit Description

rvib1.psd(V)*1e6 Displacement, y component, maximum PSD 
[mm^2/Hz]

rvib1.psd(Sb)/1e12 Bending stress, maximum PSD [(N/
mm^2)^2/Hz]
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Introduction

In the following example you build and solve a 3D shell model using the Shell interface. 
This example is a widely used benchmark model called the Scordelis-Lo roof. The 
computed maximum z-deformation is compared with the value given in Ref. 1.

Model Definition

G E O M E T R Y

The geometry consists of a curved face as shown in Figure 1. Only one quarter is analyzed 
due to symmetry.

Figure 1: The Scordelis-Lo roof shell benchmark geometry.

• Roof length 2L = 50 m

• Roof radius R = 25 m.

M A T E R I A L

• Isotropic material with Young’s modulus set to E = 4.32·108 N/m2.

• Poisson’s ratio set to ν = 0.0.

y

x

z

Symmetry edge

Free edge

Modeled area
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C O N S T R A I N T S

• The outer straight edge is free.

• The outer curved edge is constrained against translation in the y and z directions.

• The straight edge on the top of the roof has symmetry edge constraints.

• The curved inner edge also has symmetry constraints.

L O A D

A force per area unit of −90 N/m2 in the z direction is applied on the surface.

Results and Discussion

The maximum deformation in the global z direction with the default mesh settings is 
shown in Figure 2. The computed value is −0.303 m.

Figure 2: z-displacement with 176 triangular elements.

When changing to a mapped mesh, the more efficient quadrilateral elements are used. The 
result is −0.301 m as shown in Figure 3. With a very fine mesh, the value converges to −
0.302 m, Figure 4. The reference solution quoted in Ref. 1 for the midside vertical 
displacement is −0.3086 m. The value −0.302 m is in fact observed in other published 
benchmark results treating this problem as the value that this problem converges towards. 
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A summary of the performance for different element types and mesh densities is given in 
Table 1. As can be seen the results are good even with rather coarse meshes.

Figure 3: z-displacement with 70 quadrilateral elements.
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Figure 4: z-displacement with 580 quadrilateral elements.

Reference

1. R.H. MacNeal and R.L. Harder, Proposed Standard Set of Problems to Test Finite 
Element Accuracy, Finite Elements in Analysis and Design, 1, 1985.

TABLE 1:  CONVERGENCE OF MIDPOINT VERTICAL DISPLACEMENT.

MESH SIZE 
SETTING

ELEMENT TYPE NUMBER OF 
ELEMENTS

MIDPOINT 
DISPLACEMENT

Coarser Triangle 64 -0.304

Coarser Quadrilateral 24 -0.300

Normal Triangle 176 -0.303

Normal Quadrilateral 70 -0.301

Extra fine Triangle 1384 -0.302

Extra fine Quadrilateral 580 -0.302
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Application Library path: Structural_Mechanics_Module/
Verification_Examples/scordelis_lo_roof

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Shell (shell).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Work Plane 1 (wp1)
In the Geometry toolbar, click Work Plane.

Work Plane 1 (wp1)>Plane Geometry
Right-click Work Plane 1 (wp1) and choose Show Work Plane.

Work Plane 1 (wp1)>Polygon 1 (pol1)
1 In the Work Plane toolbar, click Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

3 In the table, enter the following settings:

4 Right-click Polygon 1 (pol1) and choose Build All Objects.

xw (m) yw (m)

0 25

25 25
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Work Plane 1 (wp1)
In the Model Builder window, click Work Plane 1 (wp1).

Revolve 1 (rev1)
1 In the Geometry toolbar, click Revolve.

2 In the Settings window for Revolve, locate the Revolution Angles section.

3 Click the Angles button.

4 In the Start angle text field, type 90.

5 In the End angle text field, type 90+40.

6 Locate the Revolution Axis section. Find the Direction of revolution axis subsection. In 
the xw text field, type 1.

7 In the yw text field, type 0.

8 Click Build Selected.

9 Click the Zoom Extents button in the Graphics toolbar.

Form Union (fin)
1 In the Model Builder window, click Form Union (fin).

2 Click Build Selected.

S H E L L  ( S H E L L )

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Shell (shell) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type 0.25.

Symmetry 1
1 In the Physics toolbar, click Edges and choose Symmetry.

2 Select Edges 3 and 4 only.

Prescribed Displacement/Rotation 1
1 In the Physics toolbar, click Edges and choose Prescribed Displacement/Rotation.

2 Select Edge 1 only.

3 In the Settings window for Prescribed Displacement/Rotation, locate the 
Prescribed Displacement section.

4 Select the Prescribed in y direction check box.
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5 Select the Prescribed in z direction check box.

Face Load 1
1 In the Physics toolbar, click Boundaries and choose Face Load.

2 Select Boundary 1 only.

3 In the Settings window for Face Load, locate the Force section.

4 Specify the FA vector as

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

M E S H  1

First, compute the results with the default triangular mesh.

Free Triangular 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Free Triangular.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

4 Click Build All.

S T U D Y  1

1 In the Model Builder window, click Study 1.

0 x

0 y

-90 z

Property Variable Value Unit Property group

Young’s modulus E 4.32e8 Pa Basic

Poisson’s ratio nu 0 1 Basic

Density rho 1 kg/m³ Basic
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2 In the Settings window for Study, type Study 1: Tri Normal in the Label text field.

3 In the Home toolbar, click Compute.

R E S U L T S

Stress (shell)
1 In the Settings window for 3D Plot Group, type Vertical displacement in the Label 

text field.

2 Click the Zoom Extents button in the Graphics toolbar.

Surface 1
1 In the Model Builder window, expand the Results>Vertical displacement node, then click 

Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Shell>Displacement>

Displacement field - m>w - Displacement field, Z component.

3 Locate the Coloring and Style section. Select the Reverse color table check box.

Vertical displacement
1 In the Model Builder window, click Vertical displacement.

2 In the Vertical displacement toolbar, click Plot.
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Study 1: Tri Normal/Solution 1 (sol1)
1 In the Model Builder window, expand the Results>Datasets node, then click 

Study 1: Tri Normal/Solution 1 (sol1).

2 In the Settings window for Solution, type Tri Normal in the Label text field.

Switch to the more effective quadrilateral mesh elements.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, type Tri Normal in the Label text field.

M E S H  2

1 In the Mesh toolbar, click Add Mesh.

2 In the Settings window for Mesh, type Quad Normal in the Label text field.

Mapped 1
1 Right-click Quad Normal and choose More Operations>Mapped.

2 In the Settings window for Mapped, locate the Boundary Selection section.

3 From the Geometric entity level list, choose Remaining.

4 Click Build All.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study 2: Quad Normal in the Label text field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

4 In the Home toolbar, click Compute.

R E S U L T S

Vertical displacement
1 In the Model Builder window, under Results click Vertical displacement.
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2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Dataset list, choose Study 2: Quad Normal/Solution 2 (sol2).

4 In the Vertical displacement toolbar, click Plot.

Study 2: Quad Normal/Solution 2 (sol2)
1 In the Model Builder window, under Results>Datasets click Study 2: Quad Normal/

Solution 2 (sol2).

2 In the Settings window for Solution, type Quad Normal in the Label text field.

Examine a well converged result with a fine quadrilateral mesh.

Q U A D  N O R M A L

In the Model Builder window, under Component 1 (comp1)>Meshes right-click Quad Normal 
and choose Duplicate.

Q U A D  N O R M A L  1

In the Settings window for Mesh, type Quad Extra fine in the Label text field.

Size
1 In the Model Builder window, expand the Component 1 (comp1)>Meshes>Quad Extra fine 

node, then click Size.

2 In the Settings window for Size, locate the Element Size section.
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3 From the Predefined list, choose Extra fine.

4 Click Build All.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  3

1 In the Model Builder window, click Study 3.

2 In the Settings window for Study, type Study 3: Quad Extra finel in the Label text 
field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

4 In the Home toolbar, click Compute.

R E S U L T S

Vertical displacement
1 In the Model Builder window, under Results click Vertical displacement.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Dataset list, choose Study 3: Quad Extra finel/Solution 3 (sol3).
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4 In the Vertical displacement toolbar, click Plot.

Study 3: Quad Extra finel/Solution 3 (sol3)
1 In the Model Builder window, under Results>Datasets click Study 3: Quad Extra finel/

Solution 3 (sol3).

2 In the Settings window for Solution, type Quad Extra fine in the Label text field.

Examine a well converged result with triangles.

T R I  N O R M A L

In the Model Builder window, under Component 1 (comp1)>Meshes right-click Tri Normal 
and choose Duplicate.

T R I  N O R M A L  1

In the Settings window for Mesh, type Tri Extra Fine in the Label text field.

Size
1 In the Model Builder window, expand the Component 1 (comp1)>Meshes>Tri Extra Fine 

node, then click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Extra fine.

4 Click Build All.
13 |  S C O R D E L I S - L O  R O O F  S H E L L  B E N C H M A R K



A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  4

1 In the Model Builder window, click Study 4.

2 In the Settings window for Study, type Study 4: Tri Extra fine in the Label text field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

4 In the Home toolbar, click Compute.

R E S U L T S

Vertical displacement
1 In the Model Builder window, under Results click Vertical displacement.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Dataset list, choose Study 4: Tri Extra fine/Solution 4 (sol4).
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4 In the Vertical displacement toolbar, click Plot.

Study 4: Tri Extra fine/Solution 4 (sol4)
1 In the Model Builder window, under Results>Datasets click Study 4: Tri Extra fine/

Solution 4 (sol4).

2 In the Settings window for Solution, type Tri Extra fine in the Label text field.

Investigate how well the elements perform with a very coarse mesh.

T R I  N O R M A L

In the Model Builder window, under Component 1 (comp1)>Meshes right-click Tri Normal 
and choose Duplicate.

T R I  N O R M A L  1

In the Settings window for Mesh, type Tri Coarser in the Label text field.

Size
1 In the Model Builder window, expand the Component 1 (comp1)>Meshes>Tri Coarser 

node, then click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Coarser.

4 Click Build All.
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A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  5

1 In the Model Builder window, click Study 5.

2 In the Settings window for Study, type Study 5: Tri Coarser in the Label text field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

4 In the Home toolbar, click Compute.

R E S U L T S

Vertical displacement
1 In the Model Builder window, under Results click Vertical displacement.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Dataset list, choose Study 5: Tri Coarser/Solution 5 (sol5).
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4 In the Vertical displacement toolbar, click Plot.

Study 5: Tri Coarser/Solution 5 (sol5)
1 In the Model Builder window, under Results>Datasets click Study 5: Tri Coarser/

Solution 5 (sol5).

2 In the Settings window for Solution, type Tri Coarser in the Label text field.

Q U A D  N O R M A L

In the Model Builder window, under Component 1 (comp1)>Meshes right-click Quad Normal 
and choose Duplicate.

Q U A D  N O R M A L  1

In the Settings window for Mesh, type Quad Coarser in the Label text field.

Size
1 In the Model Builder window, expand the Component 1 (comp1)>Meshes>Quad Coarser 

node, then click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Coarser.
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A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  6

1 In the Model Builder window, click Study 6.

2 In the Settings window for Study, type Study 6: Quad Coarser in the Label text field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

4 In the Home toolbar, click Compute.

R E S U L T S

Vertical displacement
1 In the Model Builder window, under Results click Vertical displacement.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Dataset list, choose Study 6: Quad Coarser/Solution 6 (sol6).
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4 In the Vertical displacement toolbar, click Plot.

Study 6: Quad Coarser/Solution 6 (sol6)
1 In the Model Builder window, under Results>Datasets click Study 6: Quad Coarser/

Solution 6 (sol6).

2 In the Settings window for Solution, type Quad Coarser in the Label text field.

The following section compares the maximum deformation of midpoint in vertical 
direction for different element types and mesh densities.

Point Evaluation 1
1 In the Results toolbar, click Point Evaluation.

2 Select Point 3 only.

3 In the Settings window for Point Evaluation, locate the Expressions section.

4 In the table, enter the following settings:

5 Click Evaluate.

Expression Unit Description

w m Midpoint displacement, Tri Normal
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Point Evaluation 2
1 Right-click Point Evaluation 1 and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Quad Normal (sol2).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Table 1 - Point Evaluation 1.

Point Evaluation 3
1 Right-click Point Evaluation 2 and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Quad Extra fine (sol3).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Table 1 - Point Evaluation 1.

Point Evaluation 4
1 Right-click Point Evaluation 3 and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Tri Extra fine (sol4).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Table 1 - Point Evaluation 1.

Point Evaluation 5
1 Right-click Point Evaluation 4 and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Tri Coarser (sol5).

Expression Unit Description

w m Midpoint displacement, Quad Normal

Expression Unit Description

w m Midpoint displacement, Quad Extra fine

Expression Unit Description

w m Midpoint displacement, Tri Extra fine
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4 Locate the Expressions section. In the table, enter the following settings:

5 Click Table 1 - Point Evaluation 1.

Point Evaluation 6
1 Right-click Point Evaluation 5 and choose Duplicate.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Dataset list, choose Quad Coarser (sol6).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Table 1 - Point Evaluation 1.

Expression Unit Description

w m Midpoint displacement, Tri Coarser

Expression Unit Description

w m Midpoint displacement, Quad Coarser
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Introduction

This example deals with the stability of a plate with an edge crack that is subjected to a 
tensile load. To analyze the stability of existing cracks, you can apply the principles of 
fracture mechanics.

A common parameter in fracture mechanics, the so-called stress intensity factor KI, 
provides a means to predict if a specific crack causes the plate to fracture. When this 
calculated value becomes equal to the critical fracture toughness of the material, KIc (a 
material property), then usually catastrophic fracture occurs.

Determining the stress intensity factor directly from the local state at the crack tip is often 
problematic, since the stresses are singular there. Because of this, more indirect energy 
based methods are attractive. In this example, KI is computed using the J-integral and 
from the energy release rate.

In addition, the crack growth rate and number of cycles needed to propagate the crack a 
certain distance are computed.

Model Definition

A plate with a width of 1.5 m and height of 4.5 m has a single horizontal edge-crack of 
length a = 0.6 m at the middle of the left vertical edge, see Figure 1. An external load is 
pulling the plate such that the top and bottom edges experience tensile stress, σ, of 
20 MPa.

The analysis is made using a number of crack lengths ranging from 0.5 m to 0.7 m, so that 
the influence of the crack length can be studied.

Because of the symmetry, only half of the plate is modeled. Additional domains are created 
in the half plate rectangle to create a path for integration contours for the J-integral. There 
are three paths for computing the J-integral:

1 The external boundaries, excluding the crack surface.

2 A path with three straight lines, formed by adding an extra rectangle.

3 A semicircular path, formed by adding a circle to the geometry.
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Figure 1: Plate geometry.

You apply a tensile load to the upper horizontal edge, while the lower horizontal edge is 
constrained in the y direction from the crack tip to the right vertical boundary using a 
symmetry condition. One point is constrained in the horizontal direction in order to 
suppress rigid body motions.

M A T E R I A L  M O D E L

The same material properties are representative for steel.

T H E  J - I N T E G R A L

In this model, you determine the stress intensity factor KI using the so-called J-integral.

TABLE 1:  MATERIAL DATA.

QUANTITY NAME EXPRESSION

Young's modulus E 206·109 Pa

Poisson's ratio ν 0.3

Coefficient in Paris’ law A 1.4·10-11 (KI unit system: MN/m3/2)

Exponent in Paris’ law m 3.1
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The J-integral is a two-dimensional path independent line integral along a 
counterclockwise contour, Γ, surrounding the crack tip. The J-integral is defined as

where W is the strain energy density

and T is the traction vector defined as

σij denotes the stress components, εij the strain components, and ni the normal vector 
components.

The J-integral has the following relation to the stress intensity factor for a plane stress case 
and a linear elastic material:

 (1)

where E is Young’s modulus.

E N E R G Y  R E L E A S E  R A T E

For a linear elastic material it is actually possible to compute the value of the J-integral 
without using the path integrals. The reason is that its value equals the value of the energy 
release rate, G,

 (2)

Here U is the potential energy, a is the crack length, and t is the thickness. By computing 
the potential energy for two slightly different crack lengths, G can be estimated as

 (3)

The potential energy of an elastic body is
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The first term is the strain energy in the volume, and the second term is the potential of 
the prescribed tractions on the boundary. Because of the linearity,

Thus, it is possible to compute the potential energy using either of these terms 
independently.

The total strain energy density exists as a built-in variable, making the first expression 
attractive for determining G.

C R A C K  P R O P A G A T I O N

When subjected to a periodic load, the crack growth rate (in meters per load cycle) can be 
expressed by Paris’ law:

 (4)

Here A and m are material parameters and ΔKI is the range of the stress intensity factor. 
It is assumed that the load varies between zero and 20 MPa, so that ΔKI equals the 
computed KI.

Results

Based on Ref. 1 an analytical solution for the stress intensity factor is

where σ = 20 MPa (edge stress), a = 0.6 m (crack length), and ccf = 2.1 (configuration 
correction factor). This correction factor is calculated with an polynomial equation from 
Ref. 1. The above values gives the stress intensity factor KIa = 57.7 MN/m3/2.
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The calculated stress intensity factors for the three different contours are

It is clear from these results that the values for the stress intensity factor in the COMSOL 
Multiphysics model are in good agreement with the reference value for all contours.

Figure 2 shows the stress singularity at the crack tip.

Figure 2: von Mises stresses and the deformed shape of the plate when the crack length is 0.6 m. 
The displacement is exaggerated to illustrate the deformation under the applied load.

The three different ways of computing the energy release rate, and thus KI, are compared 
in Figure 3. As can be seen, all three methods give essentially the same values. You can use 
the most convenient approach when you need to compute a stress intensity factor.

CONTOUR STRESS INTENSITY FACTOR

1 57.8 MPa·m1/2

2 57.7 MPa·m1/2

3 57.7 MPa·m1/2
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Figure 3: J-integral compared with energy release rates computed using numerical 
differentiation.

Finally, the crack growth speed can be investigated. In Figure 4, the crack growth speed is 
shown as function of the crack length. The dependence is quite strong: an increase in crack 
length from 0.5 m to 0.7 m (40%) increases the crack growth rate by a factor of 5. 
According to the constants used in Paris’ law, the crack growth rate is proportional to the 
stress intensity factor raised to the power of 3.1. As can be seen from the previous results, 
the stress intensity factor increases strongly with the crack length, and this combination 
results in the increase in crack growth rate.

In practice, Paris’ law may not be applicable when KI approaches the critical value KIc.
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Figure 4: Crack propagation rate as function of the crack length.

Notes about the COMSOL Implementation

In this analysis you compute the J-integral for three different contours traversing three 
different regions around the crack tip. To calculate the J-integral, you define integration 
operators for each contour. You then use these operators when setting up global 
expressions for the calculation of the stress intensity factors for the contours. Finally, you 
can compute the stress intensity factor from the J-integral value, according to Equation 1.

Note that the boundaries along the crack are not included in the J-integral because they 
do not give any contribution to the J-integral. This is due to the following facts: for an 
ideal crack, dy is zero along the crack faces, and all traction components are also zero 
(Ti = 0) as the crack faces are not loaded.

When calculating the J-integral, the contour normals must point outward of the region 
which the contour encloses. To make sure that this is the case, the built-in normal vector 
is replaced by a local variable which is reversed when needed. The criterion is based on the 
sign of the scalar product between the normal to the contour, n, and the vector from the 
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crack tip to the current point on the contour, r. If n is oriented inward, then this scalar 
product is negative, and the normal used in the J-integral evaluation must be reversed.

When computing the energy release rates, the derivative of the potential energy is 
computed using a difference approximation. In order to access different solutions in a 
single expression, the withsol() operator is used.

Reference

1. A-R. Ragab and S.E. Bayoumi, Engineering Solid Mechanics, CRC Press, 1998.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/single_edge_crack

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.
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4 Browse to the model’s Application Libraries folder and double-click the file 
single_edge_crack_parameters.txt.

G E O M E T R Y  1

Rectangle 1 (r1)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type Wp.

4 In the Height text field, type Hp.

Add the integration paths, one rectangular and one circular.

Rectangle 2 (r2)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Height text field, type 0.8.

4 Locate the Position section. In the x text field, type max(Xa-0.5[m],0.05[m]).

Circle 1 (c1)
1 In the Geometry toolbar, click Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type 0.3.

4 In the Sector angle text field, type 180.

5 Locate the Position section. In the x text field, type Xa.

6 Click Build All Objects.

Add a point at the crack tip.

Point 1 (pt1)
1 In the Geometry toolbar, click Point.

2 In the Settings window for Point, locate the Point section.

3 In the x text field, type Xa.

Form Union (fin)
1 In the Model Builder window, click Form Union (fin).

2 In the Settings window for Form Union/Assembly, click Build Selected.
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M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Steel in the Label text field.

3 Locate the Material Contents section. In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the 2D Approximation section.

3 From the list, choose Plane stress.

4 Locate the Thickness section. In the d text field, type Th.

Symmetry 1
1 In the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 8, 9, and 11 only.

Boundary Load 1
1 In the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundary 3 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

Prescribed Displacement 1
1 In the Physics toolbar, click Points and choose Prescribed Displacement.

Suppress rigid body motion.

2 Select Point 11 only.

Property Variable Value Unit Property group

Young’s modulus E E0 Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 7850 kg/m³ Basic

0 x

Q0 y
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3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in x direction check box.

Add integration operators for the path integrals.

D E F I N I T I O N S

Integration 1 (intop1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Integration.

2 In the Settings window for Integration, type J-integral path 1 in the Label text field.

3 In the Operator name text field, type Jpath1.

4 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

5 Select Boundaries 1, 3, and 12 only.

Integration 2 (intop2)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Integration.

2 In the Settings window for Integration, type J-integral path 2 in the Label text field.

3 In the Operator name text field, type Jpath2.

4 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

5 Select Boundaries 4, 6, and 10 only.

Integration 3 (intop3)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Integration.

2 In the Settings window for Integration, type J-integral path 3 in the Label text field.

3 In the Operator name text field, type Jpath3.

4 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

5 Select Boundaries 13 and 14 only.

Integration 4 (intop4)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Integration.

2 In the Settings window for Integration, type Loaded edge integration in the Label 
text field.

3 In the Operator name text field, type LoadEdgeInt.
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4 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

5 Select Boundary 3 only.

Variables 1
1 In the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
single_edge_crack_variables.txt.

Use a fine mesh close to the crack tip where the stress gradients are large.

M E S H  1

Free Triangular 1
In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Triangular.

Size 1
1 In the Model Builder window, right-click Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domain 3 only.

5 Locate the Element Size section. From the Predefined list, choose Extremely fine.

Size
1 In the Model Builder window, click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Fine.

4 Click Build All.

Set up a parametric sweep over the crack length.

S T U D Y  1

Parametric Sweep
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.
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3 Click Add.

4 In the table, enter the following settings:

5 In the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
1 In the Settings window for 2D Plot Group, locate the Data section.

2 From the Parameter value (Xa (m)) list, choose 0.6.

Surface 1
1 In the Model Builder window, expand the Stress (solid) node, then click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 Click to expand the Range section. Select the Manual color range check box.

5 In the Minimum text field, type 0.

6 In the Maximum text field, type 140.

7 In the Stress (solid) toolbar, click Plot.

8 Click the Zoom Extents button in the Graphics toolbar.

Global Evaluation 1
1 In the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, type Stress intensity factors in the 
Label text field.

3 Locate the Data section. From the Dataset list, choose Study 1/

Parametric Solutions 1 (sol2).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Parameter name Parameter value list Parameter unit

Xa (Crack length) range(0.5,da,0.7) m

Expression Unit Description

KI_1 Stress intensity factor, contour 1

KI_2 Stress intensity factor, contour 2

KI_3 Stress intensity factor, contour 3
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T A B L E

1 Go to the Table window.

Compare J-integral by with an energy release rate based on numerical differentiation of 
the strain energy density with respect to the crack length.

R E S U L T S

1D Plot Group 3
1 In the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type J-integral and G in the Label text field.

3 Locate the Data section. From the Dataset list, choose Study 1/

Parametric Solutions 1 (sol2).

4 From the Parameter selection (Xa) list, choose Manual.

5 In the Parameter indices (1-21) text field, type range(2,20).

Global 1
1 Right-click J-integral and G and choose Global.

2 In the Settings window for Global, locate the y-Axis Data section.

3 In the table, enter the following settings:

4 Click to expand the Coloring and Style section. Find the Line style subsection. From the 
Line list, choose Cycle.

5 In the Width text field, type 2.

6 Find the Line markers subsection. From the Marker list, choose Cycle.

J-integral and G
1 In the Model Builder window, click J-integral and G.

Expression Unit Description

J_1 J/m^2 J-integral, contour 1

((withsol('sol2',2*
solid.Ws_tot,setval(Xa,Xa+
da))-withsol('sol2',2*
solid.Ws_tot,setval(Xa,Xa-
da))))/(2*da*Th)

J/m^2 Energy release rate, strain 
energy

-((withsol('sol2',PE,
setval(Xa,Xa+da))-
withsol('sol2',PE,
setval(Xa,Xa-da))))/(2*da*
Th)

J/m^2 Energy release rate, load 
potential
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2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the x-axis label check box.

4 In the associated text field, type Crack length (m).

5 Select the y-axis label check box.

6 In the associated text field, type Energy release rate (J/m^2).

7 Locate the Legend section. From the Position list, choose Lower right.

8 In the J-integral and G toolbar, click Plot.

1D Plot Group 4
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Crack growth rate in the Label text 
field.

3 Locate the Data section. From the Dataset list, choose Study 1/

Parametric Solutions 1 (sol2).

Global 1
1 Right-click Crack growth rate and choose Global.

2 In the Settings window for Global, locate the y-Axis Data section.

3 In the table, enter the following settings:

4 Locate the Coloring and Style section. In the Width text field, type 2.

Crack growth rate
1 In the Model Builder window, click Crack growth rate.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 From the Title type list, choose None.

4 Locate the Plot Settings section. Select the x-axis label check box.

5 In the associated text field, type Crack length (m).

6 Select the y-axis label check box.

7 In the associated text field, type Crack growth rate (m/cycle).

8 Locate the Legend section. Clear the Show legends check box.

9 In the Crack growth rate toolbar, click Plot.

Compute the total number of cycles needed for driving the crack from 0.5 m to 0.7 m.

Expression Unit Description

dadN 1 Crack growth rate (m/cycle)
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Global Evaluation 2
1 In the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, type Number of cycles in the Label text 
field.

3 Locate the Data section. From the Dataset list, choose Study 1/

Parametric Solutions 1 (sol2).

4 Locate the Expressions section. In the table, enter the following settings:

5 Locate the Data Series Operation section. From the Operation list, choose Integral.

6 Click Evaluate.

Expression Unit Description

1/dadN 1
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Introduction

This is a benchmark model for contact and friction described in the NAFEMS publication 
in Ref. 1. An analytical solution exists, and this example includes a comparison of the 
COMSOL Multiphysics solution against the analytical solution. 

Model Definition

A contactor wedge under the gravity load G is forced to slide due to a boundary load, F, 
over a target wedge surface, both infinitely thick (see Figure 1). Horizontal linear springs 
are also connected between the left vertical boundary of the contactor and the ground. 
The total spring stiffness is K. 

This is a large sliding problem including contact pressure and friction forces. A boundary 
contact pair is created and the contact functionality in the Solid Mechanics interface is used 
to solve the contact problem. Both the penalty method and the augmented Lagrangian 
method are used, and friction is modeled with the Coulomb friction model. 

Figure 1: Sliding wedge with linear springs, a boundary load, and a gravity load.

The aim of this benchmark is to calculate the horizontal sliding distance and compare it 
with an elementary statics calculation. Three cases using different friction coefficients 
(μ = 0; 0.1; 0.2) are analyzed.

For each friction coefficient, a specific total spring stiffness K is used (K = 1194 N/m; 882 
N/m and 563.9 N/m respectively).

The horizontal applied force F = 1500 N, the total vertical gravity load G = 3058 N, the 
wedge angle is tanθ = 0.1. 

For all study cases, the horizontal sliding distance is expected to be 1m.

F

K

G

θ

Target wedge

Contactor wedge
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The mesh is shown in Figure 2.

Figure 2: Quadrilateral elements are used to mesh the geometry.

The total number of elements in this model is 1000 and the number of degrees of freedom 
is 6484 for the displacement field.

Results and Discussion

The horizontal displacement computed for all friction cases agree very well with the 
reference data, see Ref. 1. For all cases, the difference is lower than 0.1%. Furthermore, 
both contact methods available in the Structural Mechanics Module converge to the same 
results. However, for this type of large sliding problem, the convergence and stability of 
the augmented Lagrangian method is superior to the penalty method.
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Figure 3 below shows the result for the case μ = 0.2, K = 563.9 N/m, and Figure 4 show 
the contact pressure and friction forces for the same case. Both figures shows the results 
obtained with the penalty method..

Figure 3: A surface plot of the x-displacement of the contactor wedge.

Figure 4: Contact pressure and friction forces acting on the contactor wedge.
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Notes About the COMSOL Implementation

The initial unloaded state of the model is unstable and cause difficulties for the solver to 
find an initial solution. To avoid this issue, the first parameter step is set to 0.001. For this 
parameter value, a small amount of friction forces are present that stabilize the model.

The penalty method is not ideal for the type of large sliding problem with friction modeled 
in this example. While it in the limit will converge to the correct solution, the problem is 
stiff and ill-conditioned, meaning that small changes in the input can cause large changes 
to the results or even lead to no solution being found. In this example, the default solver 
suggestion does not give a stable solution, and the solver settings are modified to obtain a 
correct solution. Even with the modified settings, a warning from the linear solver gives 
an indication that the problem is ill-conditioned.

Reference

1. Feng Q., NAFEMS Benchmark Tests for Finite Element Modelling of Contact, 
Gapping and Sliding. NAFEMS Ref. R0081, UK, 2001.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/sliding_wedge

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.
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G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Polygon 1 (pol1)
1 In the Geometry toolbar, click Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

3 In the table, enter the following settings:

4 Click Build All Objects.

Rectangle 1 (r1)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 4.

4 In the Height text field, type 1.2.

5 Locate the Position section. In the x text field, type 1.

6 In the y text field, type 0.8.

Name Expression Value Description

G 3058[N] 3058 N Gravity load

F 1500[N] 1500 N Applied force

K 0[N/m] 0 N/m Spring stiffness

mu 0 0 Friction coefficient

para 0 0 Computation parameter

x (m) y (m)

0 0

6 0

6 1.3

0 0.7
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Copy 1 (copy1)
1 In the Geometry toolbar, click Transforms and choose Copy.

2 Select the object pol1 only.

3 In the Settings window for Copy, click Build Selected.

Difference 1 (dif1)
1 In the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 Select the object r1 only.

3 In the Settings window for Difference, locate the Difference section.

4 Find the Objects to subtract subsection. Select the Activate selection toggle button.

5 Select the object copy1 only.

6 Click Build Selected.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click 

Form Union (fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly section.

3 From the Action list, choose Form an assembly.

4 From the Pair type list, choose Contact pair.

5 Click Build Selected.

6 Click the Zoom Extents button in the Graphics toolbar.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

Property Variable Value Unit Property group

Young’s modulus E 206[GPa] Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 6000[kg/m^3] kg/m³ Basic
7 |  S L I D I N G  W E D G E



S O L I D  M E C H A N I C S  ( S O L I D )

Body Load 1
1 In the Model Builder window, under Component 1 (comp1) right-click 

Solid Mechanics (solid) and choose Volume Forces>Body Load.

2 Select Domain 2 only.

3 In the Settings window for Body Load, locate the Force section.

4 From the Load type list, choose Total force.

5 Specify the Ftot vector as

Contact 1
1 In the Physics toolbar, in the Boundary section, click Pairs and choose Contact.

2 In the Settings window for Contact, locate the Pair Selection section.

3 Under Pairs, click Add.

4 In the Add dialog box, select Contact Pair 1 (ap1) in the Pairs list.

5 Click OK.

Friction 1
1 In the Physics toolbar, click Attributes and choose Friction.

2 In the Settings window for Friction, locate the Friction Parameters section.

3 In the μ text field, type mu.

4 Locate the Initial Value section. From the Previous contact state list, choose In contact.

Spring Foundation 1
1 In the Physics toolbar, click Boundaries and choose Spring Foundation.

2 Select Boundary 5 only.

3 In the Settings window for Spring Foundation, locate the Spring section.

4 From the Spring type list, choose Total spring constant.

5 From the list, choose Diagonal.

6 In the ktot table, enter the following settings:

0 x

-G*para y

K 0

0 0
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Boundary Load 1
1 In the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundary 5 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 From the Load type list, choose Total force.

5 Specify the Ftot vector as

Fixed Constraint 1
1 In the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundary 2 only.

M E S H  1

Mapped 1
In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Mapped.

Distribution 1
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 Select Boundaries 1 and 5 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 10.

Distribution 2
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 Select Boundary 2 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 60.

Distribution 3
1 Right-click Mapped 1 and choose Distribution.

2 Select Boundary 7 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 40.

F*para x

0 y
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5 Click Build All.

S T U D Y  1

Parametric Sweep
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

5 Click Add.

6 In the table, enter the following settings:

Step 1: Stationary
Set up an auxiliary continuation sweep for the para parameter.

1 In the Model Builder window, click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study Extensions section.

3 Select the Auxiliary sweep check box.

4 Click Add.

5 In the table, enter the following settings:

Set a stricter tolerance and tune the parameter stepping of the auxiliary sweep to improve 
the convergence of the model. The convergence is also improved by changing the non-
linear solver to Constant Newton.

Solution 1 (sol1)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Stationary Solver 1.

Parameter name Parameter value list Parameter unit

mu (Friction coefficient) 0 0.1 0.2

Parameter name Parameter value list Parameter unit

K (Spring stiffness) 1194 882 563.9 N/m

Parameter name Parameter value list Parameter unit

para (Computation parameter) 1e-3 1
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3 In the Settings window for Stationary Solver, locate the General section.

4 In the Relative tolerance text field, type 1e-6.

5 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Stationary Solver 1 node, then click Parametric 1.

6 In the Settings window for Parametric, click to expand the Continuation section.

7 Select the Tuning of step size check box.

8 In the Initial step size text field, type 1e-2.

9 In the Minimum step size text field, type 1e-6.

10 From the Predictor list, choose Linear.

11 In the Model Builder window, click Fully Coupled 1.

12 In the Settings window for Fully Coupled, click to expand the Method and Termination 
section.

13 From the Nonlinear method list, choose Constant (Newton).

14 In the Model Builder window, click Study 1.

15 In the Settings window for Study, type Study 1: Penalty in the Label text field.

16 In the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
In the Settings window for 2D Plot Group, type Displacement (solid): Penalty in the 
Label text field.

Surface 1
1 In the Model Builder window, expand the Results>Displacement (solid): Penalty node, 

then click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>

Displacement>Displacement field - m>u - Displacement field, X component.

3 In the Displacement (solid): Penalty toolbar, click Plot.

4 Click the Zoom Extents button in the Graphics toolbar.

Applied Loads (solid)
1 In the Model Builder window, click Applied Loads (solid).

2 In the Settings window for Group, type Applied Loads (solid): Penalty in the Label 
text field.
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Contact (solid)
1 In the Model Builder window, click Contact (solid).

2 In the Settings window for 2D Plot Group, type Contact (solid): Penalty in the 
Label text field.

Gray Surfaces
1 In the Model Builder window, expand the Results>Contact (solid): Penalty node.

2 Right-click Gray Surfaces and choose Enable.

3 In the Contact (solid): Penalty toolbar, click Plot.

4 Click the Zoom Extents button in the Graphics toolbar.

Follow the instructions below to evaluate the horizontal displacement for all three friction 
cases.

Point Evaluation 1
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, type Point Evaluation 1: Penalty in 
the Label text field.

3 Locate the Data section. From the Dataset list, choose Study 1: Penalty/

Parametric Solutions 1 (sol2).

4 From the Parameter selection (para) list, choose Last.

5 From the Table columns list, choose mu, K.

6 Select Point 8 only.

7 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component 1>Solid Mechanics>Displacement>Displacement field - m>u -

Displacement field, X component.

8 Click Evaluate.

Now, solve the model using the augmented Lagrangian contact method.

S O L I D  M E C H A N I C S  ( S O L I D )

Contact 2
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) right-

click Contact 1 and choose Duplicate.

2 In the Settings window for Contact, locate the Contact Method section.

3 From the Formulation list, choose Augmented Lagrangian.
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A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study.

5 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

Parametric Sweep
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

5 Click Add.

6 In the table, enter the following settings:

Step 1: Stationary
1 In the Model Builder window, click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify model configuration for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>

Solid Mechanics (solid), Controls spatial frame>Contact 1.

5 Click Disable.

6 Click to expand the Study Extensions section. Select the Auxiliary sweep check box.

7 Click Add.

Parameter name Parameter value list Parameter unit

mu (Friction coefficient) 0 0.1 0.2

Parameter name Parameter value list Parameter unit

K (Spring stiffness) 1194 882 563.9 N/m
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8 In the table, enter the following settings:

9 In the Model Builder window, click Study 2.

10 In the Settings window for Study, type Study 1: Augmented Lagrangian in the Label 
text field.

In this example the contact forces are very small, so it is necessary so set proper scales for 
these variables.

Solution 6 (sol6)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 6 (sol6) node.

3 In the Model Builder window, expand the Study 1: Augmented Lagrangian>

Solver Configurations>Solution 6 (sol6)>Dependent Variables 1 node, then click 
Friction force (spatial frame) (comp1.solid.Tt_ap1).

4 In the Settings window for Field, locate the Scaling section.

5 In the Scale text field, type 100.

6 In the Model Builder window, click Contact pressure (comp1.solid.Tn_ap1).

7 In the Settings window for Field, locate the Scaling section.

8 In the Scale text field, type 1000.

9 In the Model Builder window, expand the Study 1: Augmented Lagrangian>

Solver Configurations>Solution 6 (sol6)>Stationary Solver 1 node, then click Parametric 1.

10 In the Settings window for Parametric, click to expand the Continuation section.

11 Select the Tuning of step size check box.

12 In the Initial step size text field, type 0.1.

13 In the Maximum step size text field, type 1.

14 In the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
In the Settings window for 2D Plot Group, type Displacement (solid): Augmented 
Lagrange in the Label text field.

Parameter name Parameter value list Parameter unit

para (Computation parameter) 1e-3 1
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Surface 1
1 In the Model Builder window, expand the Results>

Displacement (solid): Augmented Lagrange node, then click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>

Displacement>Displacement field - m>u - Displacement field, X component.

3 In the Displacement (solid): Augmented Lagrange toolbar, click Plot.

4 Click the Zoom Extents button in the Graphics toolbar.

Applied Loads (solid)
1 In the Model Builder window, click Applied Loads (solid).

2 In the Settings window for Group, type Applied Loads (solid): Augmented 
Lagrange in the Label text field.

Contact (solid)
1 In the Model Builder window, click Contact (solid).

2 In the Settings window for 2D Plot Group, type Contact (solid): Augmented 
Lagrange in the Label text field.

Gray Surfaces
1 In the Model Builder window, expand the Results>Contact (solid): Augmented Lagrange 

node.

2 Right-click Gray Surfaces and choose Enable.

3 In the Contact (solid): Augmented Lagrange toolbar, click Plot.

4 Click the Zoom Extents button in the Graphics toolbar.

Point Evaluation 1: Penalty 1
1 In the Model Builder window, right-click Point Evaluation 1: Penalty and choose 

Duplicate.

2 In the Settings window for Point Evaluation, type Point Evaluation 1: Augmented 
Lagranage in the Label text field.

3 Locate the Data section. From the Dataset list, choose Study 1: Augmented Lagrangian/

Parametric Solutions 2 (sol7).

4 Click New Table.

Prepare the model for later use by disabling the second contact feature in the first study 
(Penalty).
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S T U D Y  1 :  P E N A L T Y

Step 1: Stationary
1 In the Model Builder window, under Study 1: Penalty click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify model configuration for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>

Solid Mechanics (solid), Controls spatial frame>Contact 2.

5 Click Disable.
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Model Definition

In this example you study the lateral deflection of a space frame subjected to concentrated 
vertical loading at four different points. A small lateral load is applied to break the 
symmetry of the structure. The model is described in detail in section 6.3 of Ref. 1, where 
it is called “Space frame subjected to concentrated loading”. A schematic description of 
the frame and loads are shown in Figure 1. There are two types of members used in the 
frame, marked as 1 and 2 respectively. 

Figure 1: Space frame geometry.

G E O M E T R Y

• Cross section properties of type 1 members are A1 = 0.5, Iy1 = 0.4, Iz1=0.133.

• Cross section properties of type 2 members are A2 = 0.1, Iy2 = 0.05, Iz2=0.05.

The local y direction coincides with the global y direction.

The torsional constant is not supplied in the reference, so the common approximation J = 
Iy + Iz is used.

M A T E R I A L

Linear elastic with E = 4.32·105 and G = 1.66·105.

C O N S T R A I N T S  A N D  L O A D S

• All the base points of the frame are pinned.

• The four corners at the top are subjected to vertical loads P, ranging from 0 to 8.65, 
acting downward.

P P

P P

0.001 P 0.001P

l1 = 69.28 l2 = 61.44 l1 = 69.28

h1 = 40

b = 30

A

v

1

1 1

1

1

1

2 2

x

y

z
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• The front two corners are subjected to lateral loads of 0.001·P.

Results and Discussion

With only vertical loads active on the frame this is a symmetric problem. Hence, it is 
necessary to perturb the symmetry somewhat to induce a controlled instability. The small 
lateral loads serve this purpose. As an alternative, you could introduce an initial 
imperfection in the geometry.

Figure 2 below shows the final state of the frame.

Figure 2: Final state of the deformed frame.

The horizontal displacement of point A on the frame versus the compressive load is shown 
in Figure 3. Data obtained from Ref. 1 is marked on the same curve. The agreement with 
the data from the reference is very good.
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Figure 3: Load vs. displacement.

The plot of the lateral deflection shows that an instability occurs at a parameter value close 
to 8.0. In practice, the critical load of an imperfect structure is often significantly lower 
than that of the ideal structure.

Linear buckling analysis also gives the first critical buckling load as 8.67 which matches 
well with the critical load obtained from the above analysis. Corresponding buckling mode 
shape is shown in the Figure 4 below. 
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Figure 4: First buckling mode.

Reference

1. Z.X. Li and L. Vu-Quoc, A Mixed Co-rotational 3D Beam Element for Arbitrarily 
Large Rotations, Advanced Steel Construction Vol. 6, No. 2, 767-787, 2010.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/space_frame_instability

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Beam (beam).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Define the load parameter as well as the geometric data.

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
space_frame_instability_parameters.txt.

G E O M E T R Y  1

Since the frame is symmetric, create only one quarter of the geometry and use two mirror 
operations to obtain the full geometry.

Polygon 1 (pol1)
1 In the Geometry toolbar, click More Primitives and choose Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

3 From the Data source list, choose Vectors.

4 In the x text field, type -l1-l2/2 -l2/2 -l2/2 0 .

5 In the y text field, type -b/2 -b/2 -b/2 -b/2.

6 In the z text field, type 0 h1 h1 h1.

Line Segment 1 (ls1)
1 In the Geometry toolbar, click More Primitives and choose Line Segment.

2 In the Settings window for Line Segment, locate the Starting Point section.

3 From the Specify list, choose Coordinates.

4 Locate the Endpoint section. From the Specify list, choose Coordinates.

5 Locate the Starting Point section. In the x text field, type -l2/2, y to -b/2, and z to h1.
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6 Locate the Endpoint section. In the x text field, type -l2/2 and z to h1.

Mirror 1 (mir1)
1 In the Geometry toolbar, click Transforms and choose Mirror.

2 Click in the Graphics window and then press Ctrl+A to select both objects.

3 In the Settings window for Mirror, locate the Input section.

4 Select the Keep input objects check box.

5 Locate the Point on Plane of Reflection section. In the x text field, type -l2/2.

6 In the z text field, type h1.

7 Locate the Normal Vector to Plane of Reflection section. In the y text field, type 1.

8 In the z text field, type 0.

Mirror 2 (mir2)
1 In the Geometry toolbar, click Transforms and choose Mirror.

2 Click in the Graphics window and then press Ctrl+A to select all objects.

3 In the Settings window for Mirror, locate the Input section.

4 Select the Keep input objects check box.

5 Locate the Normal Vector to Plane of Reflection section. In the x text field, type 1.

6 In the z text field, type 0.

7 In the Geometry toolbar, click Build All.

8 Click the Go to Default View button in the Graphics toolbar.

B E A M  ( B E A M )

Linear Elastic Material 1
1 In the Model Builder window, under Component 1 (comp1)>Beam (beam) click 

Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Specify list, choose Young’s modulus and shear modulus.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.
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2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

The density is set to zero since it is not used in the present analysis.

B E A M  ( B E A M )

Cross Section Data 1
1 In the Model Builder window, under Component 1 (comp1)>Beam (beam) click 

Cross Section Data 1.

2 In the Settings window for Cross Section Data, locate the Basic Section Properties section.

3 In the A text field, type A1.

4 In the Izz text field, type Iz1.

5 In the Iyy text field, type Iy1.

6 In the J text field, type Iy1+Iz1.

Section Orientation 1
1 In the Model Builder window, expand the Cross Section Data 1 node, then click 

Section Orientation 1.

2 In the Settings window for Section Orientation, locate the Section Orientation section.

3 From the Orientation method list, choose Orientation vector.

4 Specify the V vector as

Cross Section Data 2
1 In the Physics toolbar, click Edges and choose Cross Section Data.

2 Select Edges 3, 5, 9, and 11 only.

3 In the Settings window for Cross Section Data, locate the Basic Section Properties section.

Property Variable Value Unit Property group

Young’s modulus E 4.32e5 Pa Basic

Shear modulus G 1.66e5 N/m² Bulk modulus and shear 
modulus

Density rho 0 kg/m³ Basic

0 X

1 Y

0 Z
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4 In the A text field, type A2.

5 In the Izz text field, type Iz2.

6 In the Iyy text field, type Iy2.

7 In the J text field, type Iy2+Iz2.

Section Orientation 1
1 In the Model Builder window, expand the Cross Section Data 2 node, then click 

Section Orientation 1.

2 In the Settings window for Section Orientation, locate the Section Orientation section.

3 From the Orientation method list, choose Orientation vector.

4 Specify the V vector as

Pinned 1
1 In the Physics toolbar, click Points and choose Pinned.

2 Select Points 1, 2, 11, and 12 only.

Point Load 1
1 In the Physics toolbar, click Points and choose Point Load.

2 Select Points 3, 5, 8, and 10 only.

3 In the Settings window for Point Load, locate the Force section.

4 Specify the FP vector as

Point Load 2
1 In the Physics toolbar, click Points and choose Point Load.

2 Select Points 3 and 8 only.

3 In the Settings window for Point Load, locate the Force section.

1 X

0 Y

0 Z

0 x

0 y

-P z
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4 Specify the FP vector as

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Physics-Controlled Mesh section.

3 From the Element size list, choose Fine.

S T U D Y  1

Step 1: Stationary
Use geometric nonlinearity since the problem is expected to have an instability.

1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Study Settings section.

3 Select the Include geometric nonlinearity check box.

Set up parametric sweep for the load.

4 Click to expand the Study Extensions section. Select the Auxiliary sweep check box.

5 Click Add.

Due to instability, the load increment for P>8 is reduced.

6 In the table, enter the following settings:

Solution 1 (sol1)
1 In the Study toolbar, click Show Default Solver.

Scale the dependent variables appropriately.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Dependent Variables 1 node, then click 
Displacement field (comp1.beam.uLin).

4 In the Settings window for Field, locate the Scaling section.

5 From the Method list, choose Manual.

0 x

0.001*P y

0 z

Parameter name Parameter value list

P (Load) range(0,0.1,8) range(8.02, 0.02, 8.65)
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6 In the Model Builder window, click Rotation field (comp1.beam.thLin).

7 In the Settings window for Field, locate the Scaling section.

8 From the Method list, choose Manual.

9 In the Scale text field, type pi/10.

Increase the maximum allowed number of iterations due to the expected instability.

10 In the Model Builder window, expand the Study 1>Solver Configurations>

Solution 1 (sol1)>Stationary Solver 1 node, then click Fully Coupled 1.

11 In the Settings window for Fully Coupled, click to expand the Method and Termination 
section.

12 In the Maximum number of iterations text field, type 40.

13 In the Study toolbar, click Compute.

R E S U L T S

Stress (beam)
In the Settings window for 3D Plot Group, type Displacement (beam) in the Label text 
field.

Line 1
1 In the Model Builder window, expand the Results>Displacement (beam) node, then click 

Line 1.

2 In the Settings window for Line, click Replace Expression in the upper-right corner of the 
Expression section. From the menu, choose Component 1>Beam>Displacement>

beam.disp - Total displacement - m.

3 In the Displacement (beam) toolbar, click Plot.

4 Click the Zoom Extents button in the Graphics toolbar.

Compare load-displacement curve with values from the reference.

1D Plot Group 10
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Load vs. displacement in the Label 
text field.

3 Locate the Plot Settings section. Select the x-axis label check box.

4 In the associated text field, type v.

5 Select the y-axis label check box.

6 In the associated text field, type P.
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7 Click to expand the Title section. From the Title type list, choose Manual.

8 In the Title text area, type Load vs. displacement.

Point Graph 1
1 Right-click Load vs. displacement and choose Point Graph.

2 Select Point 4 only.

3 In the Settings window for Point Graph, locate the y-Axis Data section.

4 In the Expression text field, type P.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type beam.uLinY.

7 Click to expand the Legends section. Select the Show legends check box.

8 From the Legends list, choose Manual.

9 In the table, enter the following settings:

10 Click to expand the Coloring and Style section. In the Width text field, type 3.

Table 1
1 In the Results toolbar, click Table.

2 In the Settings window for Table, locate the Data section.

3 Click Import.

4 Browse to the model’s Application Libraries folder and double-click the file 
space_frame_instability_data.txt.

5 In the Label text field, type Ref data.

Table Graph 1
1 In the Model Builder window, right-click Load vs. displacement and choose Table Graph.

2 In the Settings window for Table Graph, locate the Coloring and Style section.

3 Find the Line style subsection. From the Line list, choose None.

4 Find the Line markers subsection. From the Marker list, choose Cycle.

5 In the Number text field, type 20.

6 Click to expand the Legends section. Select the Show legends check box.

7 From the Legends list, choose Manual.

Legends

COMSOL
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8 In the table, enter the following settings:

Load vs. displacement
1 In the Model Builder window, click Load vs. displacement.

2 In the Settings window for 1D Plot Group, locate the Legend section.

3 From the Position list, choose Lower right.

4 In the Load vs. displacement toolbar, click Plot.

5 Click the Zoom Extents button in the Graphics toolbar.

Next, you verify the critical buckling load by performing the linear buckling analysis.

R O O T

In the Home toolbar, click Windows and choose Add Study.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select 
Preset Studies for Selected Physics Interfaces>Linear Buckling.

3 Click Add Study in the window toolbar.

4 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

In the Home toolbar, click Compute.

First default plot from the buckling analysis shows the first buckling mode shape as shown 
in Figure 4.

R E S U L T S

Mode Shape (beam)
1 In the Mode Shape (beam) toolbar, click Plot.

2 Click the Zoom Extents button in the Graphics toolbar.

Legends

Ref. data
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Introduction

Buckling is a phenomenon that can cause sudden failure of a structure. A linear buckling 
analysis predicts the critical buckling load. Such an analysis, however, does not give any 
information about what happens at loads higher than the critical load. Tracing the solution 
after the critical load is called a postbuckling analysis.

A spherical cap with a point load at its crown is a common example to study postbuckling 
analysis of 2D axisymmetric shells. The critical load, snap-through behavior, softening and 
stiffing effects are the interesting aspects which are studied in this example.

In order to predict the postbuckling behavior, one need to use the nonlinear solver and 
ramp up the applied load to compute the structure deformation. The buckling load can 
then be based on when a certain, not acceptable, deformation is reached.

Once the critical buckling load has been reached, it can happen that the structure 
undergoes a sudden large deformation into a new stable configuration. This is known as a 
snap-through phenomenon. A snap-through phenomenon cannot be always simulated 
using prescribed load in a standard nonlinear static solver because the problem becomes 
numerically singular. In the current example, the displacement at the crown increases 
monotonically even if the load decreases after a critical point in the snap-through region. 
Thus, using displacement control is a useful strategy for this example.

Model Definition

The model studied here is a benchmark for a spherical cap subjected to a point load at its 
crown; see Ref. 1.

• The radius of the spherical cap is a = 10 m and the thickness is th = 0.20384 m. The 
sector angle of the spherical cap is π/4 radians.

• The edge/point which is not on axis of revolution is fixed.

• In the study the variation of the crown (center) axial displacement with respect to the 
applied load is of interest.
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Due to the axial symmetry, only the part of the cap which is located at positive r-
coordinates is modeled. The full geometry of the spherical cap with loading and boundary 
conditions is shown in Figure 1.

Figure 1: Problem description.

Results

For a spherical cap, the load versus displacement curve exhibits a critical load which is 
followed by a gradual snap and further increase in stiffness. Figure 2 and Figure 3 show 
the total displacement using the Solid Mechanics and Shell interfaces, respectively, at three 

F

Axis of symmetry

Support
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different crown displacements. The annotations in the figures shows the corresponding 
point loads which closely match the benchmarked numerical solutions given in Ref. 1.

Figure 2: Total displacement computed in the Solid Mechanics Interface using 40 mesh 
elements.

What’s important to note in the figures is the snap-through behavior and softening effect 
after the critical load. The top surface in both figures corresponds to the critical load, while 
the middle surface is corresponding to the load after the critical point. This shows that 
although deformation increases the load decreases due to softening after the critical load. 
The third surface in both figures shows an increase in displacement with an increase in 
load, indicating an increase in stiffness after the snap through phase.

Figure 4 shows the variation of axial displacement at the crown of the spherical cap versus 
the applied load. For the Shell interface, three different discretizations (4, 8, 16 mesh 
elements) are used. For the Solid Mechanics interface 40 mesh elements are used. These 
discretizations are the same as in Ref. 1.

The results match the values in the reference quite closely. Note however, that these results 
are reported for certain discretizations and element formulations. There is no target value 
as such.
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Figure 3: Total displacement computing in the Shell Interface using 16 mesh elements.
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Figure 4: Applied load versus center displacement.

In Table 1, the results from the Solid Mechanics interface with 40 mesh elements are 
compared with the reference. 

In Table 2, Table 3, and Table 4, the results from the Shell interface with 4, 8 and 16 mesh 
elements respectively, are compared with the reference. Note that with only four elements, 

TABLE 1:  SOLID MECHANICS IN NONDIMENSIONAL FORMAT.

Applied Load Displacement 
in reference

Displacement 
computed 

0.320 2.165 2.250

0.584 6.769 6.920

0.975 13.335 13.600

1.624 19.706 20.025

1.808 22.073 22.450

1.758 24.398 24.665

1.962 26.788 27.170

4.699 29.851 30.265
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there is no snap through behavior, indicating that the mesh is much to coarse. This is 
experienced also in the reference, even though different types of shell element 
formulations are used. 

TABLE 2:  SHELL RESULTS WITH 4 ELEMENTS IN NONDIMENSIONAL FORMAT.

Applied Load Displacement 
target 

Displacement 
computed 

0.335 2.367 3.100

0.579 6.921 5.940

0.920 11.614 12.665

1.176 16.423 14.850

1.705 18.964 20.300

2.488 21.393 27.850

2.540 23.659 28.050

3.765 28.541 29.870

TABLE 3:  SHELL RESULTS WITH 8 ELEMENTS IN NONDIMENSIONAL FORMAT.

Applied Load Displacement 
target 

Displacement 
computed 

0.332 2.326 2.440

0.580 6.720 6.775

0.994 13.642 13.760

1.502 18.487 18.815

1.757 20.887 21.240

1.678(1.722) 25.668 25.500

3.705 28.680 29.330

TABLE 4:  SHELL RESULTS WITH 16 ELEMENTS IN NONDIMENSIONAL FORMAT.

Applied Load Displacement 
target 

Displacement 
computed 

0.332 2.326 2.445

0.580 6.720 6.800

0.994 13.642 13.800

1.502 18.487 18.945

1.757 20.887 21.640

1.678(1.717) 25.668 25.500

3.705 28.680 29.410
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Note that the lowest load after the critical load when using a shell formulation is 1.678 in 
the reference. This value is not reached in the solutions, where the lowest load is predicted 
as 1.722 and 1.717 with 8 and 16 elements, respectively. A refined Solid Mechanics model 
actually indicates that the current that the values computed here are more accurate than 
those reported in the reference.

Notes About the COMSOL Implementation

The main feature of this model is that a limit point instability occurs at the buckling load. 
Load control would not able to track the unstable solution paths after the limit point, so 
a displacement control is used since the displacement at the crown increases 
monotonically.

In this case, where the only load is a point load, it would be possible to directly prescribe 
the displacement in that point, and then measure the reaction force. If the load was more 
complex, for example a pressure load, that would not be possible. For this reason, a more 
general approach is shown here.

To employ a displacement control strategy, a point load at the crown is considered as a 
global degree of freedom and a global equation in terms of axial displacement at the crown 
is solved to get the point load value.

For a nonlinear problem experiencing a snap-through behavior there is no general way to 
determine which controlling parameter to use, so it is necessary to use some physical 
insight. You need to find a quantity which is monotonically increasing to use as a 
controlling parameter.

Reference

1. P. Lyons and S. Holsgrove, Finite Element Benchmarks For 2D Beams And 
Axisymmetric Shells Involving Geometric Non-Linearity, NAFEMS, 2005.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/spherical_cap_with_central_point_load

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 In the Select Physics tree, select Structural Mechanics>Shell (shell).

5 Click Add.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Define a set of nondimensional variables that will be useful in the postprocessing plots and 
evaluations.

D E F I N I T I O N S

Variables 1
1 In the Model Builder window, under Component 1 (comp1) right-click Definitions and 

choose Variables.

2 In the Settings window for Variables, locate the Variables section.

Name Expression Value Description

a 10[m] 10 m Radius of cap

th 0.203840[m] 0.20384 m Thickness of cap

EE 210e9[Pa] 2.1E11 Pa Young's modulus

Nu 0.3 0.3 Poisson's ratio

Rho 7800 7800 Density

disp 0[m] 0 m Displacement parameter

meshdist 4 4 Mesh distribution parameter
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3 In the table, enter the following settings:

G E O M E T R Y  1

Circle 1 (c1)
1 In the Geometry toolbar, click Circle.

2 In the Settings window for Circle, locate the Object Type section.

3 From the Type list, choose Curve.

4 Locate the Size and Shape section. In the Sector angle text field, type 45.

5 In the Radius text field, type a+th.

6 Click Build Selected.

7 Locate the Rotation Angle section. In the Rotation text field, type 45.

8 Click to expand the Layers section. In the table, enter the following settings:

9 Click Build Selected.

Delete Entities 1 (del1)
1 In the Model Builder window, right-click Geometry 1 and choose Delete Entities.

Name Expression Unit Description

Fn1 -F1*a/(EE*th^3*2*pi) Nondimensional force

wn1 -w/th Nondimensional 
displacement

Fn2 -F2*a/(EE*th^3*2*pi) Nondimensional force

wn2 -w2/th Nondimensional 
displacement

Layer name Thickness (m)

Layer 1 th
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2 On the object c1, select Boundaries 1 and 2 only.

3 In the Settings window for Delete Entities, click Build Selected.

Add a same material through a material link for Solid Mechanics and Shell interfaces.

G L O B A L  D E F I N I T I O N S

Material 1 (mat1)
In the Model Builder window, under Global Definitions right-click Materials and choose 
Blank Material.

M A T E R I A L S

Material Link 1 (matlnk1)
In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
More>Material Link.

Material Link 2 (matlnk2)
1 Right-click Materials and choose More>Material Link.

2 In the Settings window for Material Link, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.
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4 Select Boundary 3 only.

It might be easier to select the correct boundary by using the Selection List window. To 
open this window, in the Home toolbar click Windows and choose Selection List. (If you 
are running the cross-platform desktop, you find Windows in the main menu.)

G L O B A L  D E F I N I T I O N S

Material 1 (mat1)
1 In the Model Builder window, under Global Definitions>Materials click Material 1 (mat1).

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

D E F I N I T I O N S

Integration 1 (intop1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Point.

4 Select Point 1 only.

5 Locate the Advanced section. From the Method list, choose Summation over nodes.

S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 In the Model Builder window, under Component 1 (comp1) right-click 

Solid Mechanics (solid) and choose Fixed Constraint.

2 Select Boundary 2 only.

Now add a global equation for a point load, so that the crown displacement equals to 
the prescribed one. For that, you need to show advanced physics options.

3 Click the Show More Options button in the Model Builder toolbar.

4 In the Show More Options dialog box, in the tree, select the check box for the node 
Physics>Equation-Based Contributions.

Property Variable Value Unit Property group

Young’s modulus E EE Pa Basic

Poisson’s ratio nu Nu 1 Basic

Density rho Rho kg/m³ Basic
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5 Click OK.

Global Equations 1
1 In the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Global Equations section.

3 In the table, enter the following settings:

4 Locate the Units section. Click Select Dependent Variable Quantity.

5 In the Physical Quantity dialog box, type force in the text field.

6 Click Filter.

7 In the tree, select General>Force (N).

8 Click OK.

9 In the Settings window for Global Equations, locate the Units section.

10 Click Select Source Term Quantity.

11 In the Physical Quantity dialog box, type disp in the text field.

12 Click Filter.

13 In the tree, select General>Displacement (m).

14 Click OK.

Point Load (on Axis) 1
1 In the Physics toolbar, click Points and choose Point Load (on Axis).

2 Select Point 1 only.

3 In the Settings window for Point Load (on Axis), locate the Force section.

4 From the Fz list, choose State variable F1 (solid/ge1).

S H E L L  ( S H E L L )

1 In the Model Builder window, under Component 1 (comp1) click Shell (shell).

2 In the Settings window for Shell, locate the Boundary Selection section.

3 Click Clear Selection.

4 Select Boundary 3 only.

Name f(u,ut,utt,t) 
(1)

Initial value 
(u_0) (1)

Initial value 
(u_t0) (1/s)

Description

F1 intop1(w)-
disp

0 0
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In order to model the solid midplane using Shell interface assign a proper offset from the 
Thickness and Offset feature. As shell normal is pointing inward (which can be verified in 
postprocessing plot) use -th/2 as a physical offset.

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Shell (shell) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type th.

4 From the Offset definition list, choose Physical offset.

5 In the zoffset text field, type -th/2.

Fixed Constraint 1
1 In the Physics toolbar, click Points and choose Fixed Constraint.

2 Select Point 3 only.

Global Equations 1
1 In the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Global Equations section.

3 In the table, enter the following settings:

4 Locate the Units section. Click Select Dependent Variable Quantity.

5 In the Physical Quantity dialog box, type force in the text field.

6 Click Filter.

7 In the tree, select General>Force (N).

8 Click OK.

9 In the Settings window for Global Equations, locate the Units section.

10 Click Select Source Term Quantity.

11 In the Physical Quantity dialog box, type disp in the text field.

12 Click Filter.

13 In the tree, select General>Displacement (m).

14 Click OK.

Name f(u,ut,utt,t) (1) Initial value 
(u_0) (1)

Initial value 
(u_t0) (1/s)

Description

F2 intop1(w2)-
disp

0 0
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Point Load (on Axis) 1
1 In the Physics toolbar, click Points and choose Point Load (on Axis).

2 Select Point 1 only.

3 In the Settings window for Point Load (on Axis), locate the Force section.

4 From the Fz list, choose State variable F2 (shell/ge1).

Use different Mesh nodes in order to use different discretizations for Solid Mechanics and 
Shell interfaces as given in the benchmark example.

M E S H  2

In the Mesh toolbar, click Add Mesh.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1)>Meshes click Mesh 1.

2 In the Settings window for Mesh, type Mesh: Solid Mechanics in the Label text field.

Mapped 1
Right-click Component 1 (comp1)>Meshes>Mesh: Solid Mechanics and choose Mapped.

Distribution 1
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.
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2 Select Boundaries 3 and 4 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 40.

5 Click Build Selected.

M E S H  2

1 In the Model Builder window, under Component 1 (comp1)>Meshes click Mesh 2.

2 In the Settings window for Mesh, type Mesh: Shell in the Label text field.

Edge 1
1 Right-click Component 1 (comp1)>Meshes>Mesh: Shell and choose More Operations>

Edge.

2 Select Boundary 3 only.

Distribution 1
1 Right-click Edge 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type meshdist.

4 Click Build Selected.
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Add a stationary study for Solid Mechanics interface.

R O O T

In the Home toolbar, click Windows and choose Add Study.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

3 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Shell (shell) interface.

4 Click Add Study in the window toolbar.

S T U D Y  1

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Study: Solid Mechanics in the Label text field.

Step 1: Stationary
1 In the Model Builder window, under Study: Solid Mechanics click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Study Settings section.

3 Select the Include geometric nonlinearity check box.

4 Click to expand the Mesh Selection section. In the table, enter the following settings:

5 Click to expand the Study Extensions section. Select the Auxiliary sweep check box.

6 Click Add.

7 In the table, enter the following settings:

8 In the Home toolbar, click Compute.

Add a stationary study for Shell interface. Parameterize the mesh discretization using a 
parametric sweep.

R O O T

Click Windows and choose Add Study.

Geometry Mesh

Geometry 1 Mesh: Solid Mechanics

Parameter name Parameter value list Parameter unit

disp (Displacement parameter) range(0,-0.01,-6.2) m
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A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

3 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Solid Mechanics (solid) interface.

4 Click Add Study in the window toolbar.

S T U D Y  2

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study: Shell in the Label text field.

Parametric Sweep
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

Step 1: Stationary
1 In the Model Builder window, click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Study Settings section.

3 Select the Include geometric nonlinearity check box.

4 Locate the Study Extensions section. Select the Auxiliary sweep check box.

5 Click Add.

6 In the table, enter the following settings:

7 In the Study toolbar, click Compute.

R E S U L T S

Revolution 2D 1
1 In the Model Builder window, expand the Datasets node, then click Revolution 2D 1.

Parameter name Parameter value list Parameter unit

meshdist (Mesh distribution 
parameter)

4,8,16

Parameter name Parameter value list Parameter unit

disp (Displacement parameter) range(0,-0.01,-6.2) m
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2 In the Settings window for Revolution 2D, click to expand the Revolution Layers section.

3 In the Start angle text field, type 45.

4 In the Revolution angle text field, type -90.

Revolution 2D 2
1 In the Model Builder window, click Revolution 2D 2.

2 In the Settings window for Revolution 2D, locate the Revolution Layers section.

3 In the Start angle text field, type 45.

4 In the Revolution angle text field, type -90.

In order to visualize the softening and stiffening effect after the critical point, generate 
a 3D displacement plot of spherical cap at the critical point, and on unstable and stable 
part of the equilibrium path after critical point.

Stress, 3D (solid)
1 In the Model Builder window, under Results click Stress, 3D (solid).

2 In the Settings window for 3D Plot Group, type Total Displacement, 3D (solid) in 
the Label text field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type Total Displacement (m).

5 Locate the Plot Settings section. Clear the Plot dataset edges check box.

Surface 1
1 In the Model Builder window, expand the Results>Total Displacement, 3D (solid) node, 

then click Surface 1.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Revolution 2D 1.

4 From the Parameter value (disp (m)) list, choose -4.7.

5 Locate the Expression section. In the Expression text field, type solid.disp.

Annotation 1
1 In the Model Builder window, expand the Surface 1 node.

2 Right-click Total Displacement, 3D (solid) and choose Annotation.

3 In the Settings window for Annotation, locate the Data section.

4 From the Dataset list, choose Revolution 2D 1.

5 From the Parameter value (disp (m)) list, choose -4.7.

6 Locate the Annotation section. In the Text text field, type F1=eval(F1).
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7 Select the Allow evaluation of expressions check box.

8 From the Geometry level list, choose Global.

9 Locate the Position section. In the Z text field, type a-4.7.

10 Click to expand the Advanced section. Locate the Coloring and Style section. From the 
Anchor point list, choose Lower right.

Surface 2
In the Model Builder window, under Results>Total Displacement, 3D (solid) right-click 
Surface 1 and choose Duplicate.

Annotation 2
In the Model Builder window, under Results>Total Displacement, 3D (solid) right-click 
Annotation 1 and choose Duplicate.

Surface 2
1 In the Settings window for Surface, locate the Data section.

2 From the Parameter value (disp (m)) list, choose -5.2.

3 Click to expand the Inherit Style section. From the Plot list, choose Surface 1.

Annotation 2
1 In the Model Builder window, click Annotation 2.

2 In the Settings window for Annotation, locate the Data section.

3 From the Parameter value (disp (m)) list, choose -5.2.

4 Locate the Position section. In the Z text field, type a-5.2.

Surface 3
In the Model Builder window, under Results>Total Displacement, 3D (solid) right-click 
Surface 2 and choose Duplicate.

Annotation 3
In the Model Builder window, under Results>Total Displacement, 3D (solid) right-click 
Annotation 2 and choose Duplicate.

Surface 3
1 In the Settings window for Surface, locate the Data section.

2 From the Parameter value (disp (m)) list, choose -5.8.

Annotation 3
1 In the Model Builder window, click Annotation 3.

2 In the Settings window for Annotation, locate the Data section.
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3 From the Parameter value (disp (m)) list, choose -5.8.

4 Locate the Position section. In the Z text field, type a-5.8.

5 In the Total Displacement, 3D (solid) toolbar, click Plot.

6 Click the Zoom Extents button in the Graphics toolbar.

For better visualization change the dataset from Shell 1 to Study: Shell/Solution 2.

Stress (shell)
1 In the Model Builder window, click Stress (shell).

2 In the Settings window for 2D Plot Group, locate the Data section.

3 From the Dataset list, choose Study: Shell/Solution 2 (sol2).

Line 1
1 In the Model Builder window, expand the Stress (shell) node, then click Line 1.

2 In the Settings window for Line, locate the Expression section.

3 In the Expression text field, type shell.mises_max.

4 Locate the Coloring and Style section. In the Radius scale factor text field, type 1.

For better visualization change the dataset in Revolution 2D 2 from Shell 1 to Study: Shell/

Solution 2.

Revolution 2D 2
1 In the Model Builder window, click Revolution 2D 2.

2 In the Settings window for Revolution 2D, locate the Data section.

3 From the Dataset list, choose Study: Shell/Solution 2 (sol2).

Stress, 3D (shell)
1 In the Model Builder window, under Results click Stress, 3D (shell).

2 In the Settings window for 3D Plot Group, type Total Displacement, 3D (shell) in 
the Label text field.

3 Locate the Title section. From the Title type list, choose Manual.

4 In the Title text area, type Total Displacement (m).

5 Locate the Plot Settings section. Clear the Plot dataset edges check box.

Surface 1
1 In the Model Builder window, expand the Results>Total Displacement, 3D (shell) node, 

then click Surface 1.

2 In the Settings window for Surface, locate the Data section.
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3 From the Dataset list, choose Revolution 2D 2.

4 From the Parameter value (disp (m)) list, choose -4.7.

5 Locate the Expression section. In the Expression text field, type shell.disp.

Annotation 1
1 In the Model Builder window, expand the Surface 1 node.

2 Right-click Total Displacement, 3D (shell) and choose Annotation.

3 In the Settings window for Annotation, locate the Data section.

4 From the Dataset list, choose Revolution 2D 2.

5 From the Parameter value (disp (m)) list, choose -4.7.

6 Locate the Annotation section. In the Text text field, type F2=eval(F2).

7 Select the Allow evaluation of expressions check box.

8 From the Geometry level list, choose Global.

9 Locate the Position section. In the Z text field, type a-4.7.

10 Locate the Coloring and Style section. From the Anchor point list, choose Lower right.

Surface 2
In the Model Builder window, under Results>Total Displacement, 3D (shell) right-click 
Surface 1 and choose Duplicate.

Annotation 2
In the Model Builder window, under Results>Total Displacement, 3D (shell) right-click 
Annotation 1 and choose Duplicate.

Surface 2
1 In the Settings window for Surface, locate the Data section.

2 From the Parameter value (disp (m)) list, choose -5.2.

3 Locate the Inherit Style section. From the Plot list, choose Surface 1.

Annotation 2
1 In the Model Builder window, click Annotation 2.

2 In the Settings window for Annotation, locate the Data section.

3 From the Parameter value (disp (m)) list, choose -5.2.

4 Locate the Position section. In the Z text field, type a-5.2.
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Surface 3
In the Model Builder window, under Results>Total Displacement, 3D (shell) right-click 
Surface 2 and choose Duplicate.

Annotation 3
In the Model Builder window, under Results>Total Displacement, 3D (shell) right-click 
Annotation 2 and choose Duplicate.

Surface 3
1 In the Settings window for Surface, locate the Data section.

2 From the Parameter value (disp (m)) list, choose -5.8.

Annotation 3
1 In the Model Builder window, click Annotation 3.

2 In the Settings window for Annotation, locate the Data section.

3 From the Parameter value (disp (m)) list, choose -5.8.

4 Locate the Position section. In the Z text field, type a-5.8.

5 In the Total Displacement, 3D (shell) toolbar, click Plot.

6 Click the Zoom Extents button in the Graphics toolbar.

In order to better visualize the shell normal in Thickness and Orientation plot, reduce the 
number of arrows.

Shell Local System
1 In the Model Builder window, expand the Thickness and Orientation (shell) node, then 

click Shell Local System.

2 In the Settings window for Coordinate System Line, locate the Positioning section.

3 In the Number of arrows text field, type 20.

4 In the Thickness and Orientation (shell) toolbar, click Plot.

Plot a 1D curve showing the relationship between axial displacement and point load at the 
crown.

1D Plot Group 9
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Load vs. Displacement at Crown in 
the Label text field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type Load vs. Displacement at Crown.
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5 Locate the Legend section. From the Position list, choose Upper left.

Point Graph 1
1 Right-click Load vs. Displacement at Crown and choose Point Graph.

2 Select Point 1 only.

3 In the Settings window for Point Graph, locate the y-Axis Data section.

4 In the Expression text field, type Fn1.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type wn1.

7 Click to expand the Legends section. Select the Show legends check box.

8 From the Legends list, choose Manual.

9 In the table, enter the following settings:

Point Graph 2
1 Right-click Point Graph 1 and choose Duplicate.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Dataset list, choose Study: Shell/Parametric Solutions 1 (sol3).

4 Locate the y-Axis Data section. In the Expression text field, type Fn2.

5 Locate the x-Axis Data section. In the Expression text field, type wn2.

6 Locate the Legends section. In the table, enter the following settings:

7 In the Load vs. Displacement at Crown toolbar, click Plot.

Point Evaluation 1
1 In the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, type Solid Mechanics, 40 Elements in 
the Label text field.

3 Select Point 1 only.

Legends

Solid Mechanics, 40 Elements

Legends

Shell, 4 Elements

Shell, 8 Elements

Shell, 16 Elements
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4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Solid Mechanics, 40 Elements 1
1 Right-click Solid Mechanics, 40 Elements and choose Duplicate.

2 In the Settings window for Point Evaluation, type Shell, 4 Elements in the Label text 
field.

3 Locate the Data section. From the Dataset list, choose Study: Shell/

Parametric Solutions 1 (sol3).

4 From the Parameter selection (meshdist) list, choose From list.

5 In the Parameter values (meshdist) list, select 4.

6 From the Table columns list, choose Outer solutions.

7 Locate the Expressions section. In the table, enter the following settings:

8 Click Evaluate.

Shell, 4 Elements 1
1 Right-click Shell, 4 Elements and choose Duplicate.

2 In the Settings window for Point Evaluation, type Shell, 8 Elements in the Label text 
field.

3 Locate the Data section. In the Parameter values (meshdist) list, select 8.

4 Locate the Expressions section. In the table, enter the following settings:

Expression Unit Description

Fn1 1 Nondimensional force (Solid Mechanics, 40 
Elements)

wn1 1 Nondimensional displacement (Solid Mechanics, 
40 Elements)

Expression Unit Description

Fn2 1 Nondimensional force (Shell, 4 Elements)

wn2 1 Nondimensional displacement (Shell, 4 
Elements)

Expression Unit Description

Fn2 1 Nondimensional force (Shell, 8 Elements)

wn2 1 Nondimensional displacement (Shell, 8 
Elements)
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5 Click Evaluate.

Shell, 8 Elements 1
1 Right-click Shell, 8 Elements and choose Duplicate.

2 In the Settings window for Point Evaluation, type Shell, 16 Elements in the Label text 
field.

3 Locate the Data section. In the Parameter values (meshdist) list, select 16.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Expression Unit Description

Fn2 1 Nondimensional force (Shell, 16 Elements)

wn2 1 Nondimensional displacement (Shell, 16 
Elements)
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Introduction

In the following tutorial, you build and solve a 3D beam model using the 3D Beam 
interface. This example shows how to model a thermally induced deformation of a beam. 
Temperature gradients are applied between the top and bottom surfaces as well as the left 
and right surfaces of the beam. The deformation is compared with the value given by a 
theoretical solution given in Ref. 1.

Model Definition

G E O M E T R Y

The geometry consists of one beam. The beam cross-section area is A and the area 
moment of inertia I. The beam is L long, and the Young’s modulus is E.

• Beam length L = 3 m.

• The beam has a square cross section with a side length of 0.04 m giving an area of 
A = 1.6·10−3 m2 and an area moment of inertia of I = 0.044/12 m4.

M A T E R I A L

• Young’s modulus E = 210 GPa.

• Poisson’s ratio ν = 0.3.

• Coefficient of thermal expansion α = 11·10−6/°C.

C O N S T R A I N T S

• On one end the beam has constrained displacements in all directions and it has the 
rotation around its length constraint as well to prevent the singular rotational degrees 
of freedom. 

• On the other end the movement perpendicular to the beams length is constrained. 

T H E R M A L  L O A D

Figure 1 shows the surface temperature at each corner of the cross section. The 
temperature varies linearly between each corner. The deformation caused by this 
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temperature distribution is modeled by specifying the temperature differences across the 
beam in the local y and z directions.

Figure 1: Geometric properties and thermal loads at corners.

Results and Discussion

Based on Ref. 1, you can compare the maximum deformation in the global z direction 
with analytical values for a simply supported 2D beam with a temperature difference 
between the top and the bottom surface. The maximum deformation, according to Ref. 1 
is:

where t is the depth of the beam, 0.04 m, T2 is the temperature at the top and T1 at the 
bottom.

The following table shows a comparison of the maximum global z-displacement, 
calculated with COMSOL Multiphysics, with the theoretical solution.

Figure 2 shows the global z-displacement along the beam.

w COMSOL Multiphysics (max) Analytical

15.5 mm 15.5 mm

T=150°C

E IA

z

y

T=250°C

T=200°C

T=200°C

w αL2

8t
---------- T2 T1–( )=
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Figure 2: z-displacement along the beam.

The analytical values for the maximum total transverse displacement can be calculated by:

where v is the maximum deformation in the global y direction which is calculated in the 
same way as w.

A comparison of the maximum transverse displacement calculated with COMSOL 
Multiphysics and the analytical value is shown in the table below.

Figure 3 shows the total displacement, the total transverse displacement and the axial 
displacement along the beam.

COMSOL Multiphysics Analytical

21.9 mm 21.9 mm

δ w2 v2
+=
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Figure 3: Camber along the beam.

Reference

1. W. Young, Roark’s Formulas for Stress & Strain, McGraw-Hill, 1989.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/thermally_loaded_beam

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Beam (beam).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Polygon 1 (pol1)
1 In the Geometry toolbar, click More Primitives and choose Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

3 In the table, enter the following settings:

Name Expression Value Description

a 0.04[m] 0.04 m Side length

deltaT 50[K] 50 K Temperature difference

Tg deltaT/a 1250 K/m Temperature gradient

Lb 3[m] 3 m Beam length

x (m) y (m) z (m)

0 0 0

Lb/2 0 0

Lb 0 0
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M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, click to expand the Material Properties section.

3 In the Material properties tree, select Basic Properties>Coefficient of Thermal Expansion.

4 Click Add to Material.

5 Locate the Material Contents section. In the table, enter the following settings:

B E A M  ( B E A M )

Cross Section Data 1
1 In the Model Builder window, under Component 1 (comp1)>Beam (beam) click 

Cross Section Data 1.

2 In the Settings window for Cross Section Data, locate the Cross Section Definition section.

3 From the list, choose Common sections.

4 In the hy text field, type a.

5 In the hz text field, type a.

Section Orientation 1
1 In the Model Builder window, expand the Cross Section Data 1 node, then click 

Section Orientation 1.

2 In the Settings window for Section Orientation, locate the Section Orientation section.

3 From the Orientation method list, choose Orientation vector.

Property Variable Value Unit Property 
group

Coefficient of thermal expansion alpha_iso ; 
alphaii = 
alpha_iso, 
alphaij = 0

11e-6 1/K Basic

Young’s modulus E 210e9 Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 7800 kg/m³ Basic
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4 Specify the V vector as

Prescribed Displacement/Rotation 1
1 In the Physics toolbar, click Points and choose Prescribed Displacement/Rotation.

2 Select Point 1 only.

3 In the Settings window for Prescribed Displacement/Rotation, locate the 
Prescribed Displacement section.

4 Select the Prescribed in x direction check box.

5 Select the Prescribed in y direction check box.

6 Select the Prescribed in z direction check box.

7 Locate the Prescribed Rotation section. From the list, choose Rotation.

8 Select the Free rotation around y direction check box.

9 Select the Free rotation around z direction check box.

Prescribed Displacement/Rotation 2
1 In the Physics toolbar, click Points and choose Prescribed Displacement/Rotation.

2 Select Point 3 only.

3 In the Settings window for Prescribed Displacement/Rotation, locate the 
Prescribed Displacement section.

4 Select the Prescribed in y direction check box.

5 Select the Prescribed in z direction check box.

Linear Elastic Material 1
In the Model Builder window, click Linear Elastic Material 1.

Thermal Expansion 1
1 In the Physics toolbar, click Attributes and choose Thermal Expansion.

2 In the Settings window for Thermal Expansion, locate the Model Input section.

3 Click Go to Source.

0 X

1 Y

0 Z
8 |  T H E R M A L L Y  L O A D E D  B E A M



G L O B A L  D E F I N I T I O N S

Default Model Inputs
1 In the Model Builder window, under Global Definitions click Default Model Inputs.

2 In the Settings window for Default Model Inputs, locate the Browse Model Inputs section.

3 Find the Expression for remaining selection subsection. In the 
Volume reference temperature text field, type 0.

B E A M  ( B E A M )

Thermal Expansion 1
1 In the Model Builder window, under Component 1 (comp1)>Beam (beam)>

Linear Elastic Material 1 click Thermal Expansion 1.

2 In the Settings window for Thermal Expansion, locate the Model Input section.

3 From the T list, choose User defined. In the associated text field, type 200.

4 Locate the Thermal Bending section. In the Tgy text field, type Tg.

5 In the Tgz text field, type -Tg.

S T U D Y  1

In the Home toolbar, click Compute.

R E S U L T S

Stress (beam)
In the Settings window for 3D Plot Group, type Displacements in the Label text field.

Line 1
1 In the Model Builder window, expand the Results>Displacements node, then click Line 1.

2 In the Settings window for Line, click Replace Expression in the upper-right corner of the 
Expression section. From the menu, choose Component 1>Beam>Displacement>

beam.disp - Total displacement - m.

3 In the Displacements toolbar, click Plot.

1D Plot Group 9
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Transverse Displacement in the Label 
text field.

3 Locate the Plot Settings section. Select the y-axis label check box.
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4 In the associated text field, type z displacement (m).

Line Graph 1
1 Right-click Transverse Displacement and choose Line Graph.

2 In the Settings window for Line Graph, type Transverse displacement (z-
direction) in the Label text field.

3 Click in the Graphics window and then press Ctrl+A to select both edges.

4 Locate the y-Axis Data section. In the Expression text field, type w.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type x.

7 Click to expand the Coloring and Style section. In the Width text field, type 2.

8 In the Transverse Displacement toolbar, click Plot.

1D Plot Group 10
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Displacement in the Label text field.

3 Locate the Plot Settings section. Select the y-axis label check box.

4 In the associated text field, type displacement (m).

5 Locate the Legend section. From the Position list, choose Center.

Line Graph 1
1 Right-click Displacement and choose Line Graph.

2 In the Settings window for Line Graph, type Total displacement in the Label text field.

3 Click in the Graphics window and then press Ctrl+A to select both edges.

4 Locate the y-Axis Data section. Select the Description check box.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type x.

7 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Cycle.

8 Find the Line markers subsection. From the Marker list, choose Cycle.

9 In the Width text field, type 2.

10 Click to expand the Legends section. Find the Include subsection. Select the Description 
check box.

11 Clear the Solution check box.

12 Select the Show legends check box.
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Total displacement 1
1 Right-click Total displacement and choose Duplicate.

2 In the Settings window for Line Graph, type Total transverse displacement in the 
Label text field.

3 Locate the Selection section. Select the Activate selection toggle button.

4 Locate the y-Axis Data section. In the Expression text field, type sqrt(v^2+w^2).

5 In the Description text field, type Total transverse displacement.

Total transverse displacement 1
1 Right-click Total transverse displacement and choose Duplicate.

2 In the Settings window for Line Graph, type Axial displacement in the Label text field.

3 Locate the y-Axis Data section. In the Expression text field, type u.

4 In the Description text field, type Axial displacement.

5 In the Displacement toolbar, click Plot.
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Introduction

This example implements the static stress analysis described in the NAFEMS Test No 
LE10, “Thick Plate Pressure,” found on page 77 in the NAFEMS report Background to 
Benchmarks (Ref. 1). The computed stress level is compared with the values given in the 
benchmark report.

Model Definition

The geometry is an ellipse with an ellipse-shaped hole in it. Due to symmetry in load and 
in geometry, the analysis only includes a quarter of the ellipse.

Figure 1: The thick plate geometry, reduced to a quarter of the ellipse due to symmetry.

M A T E R I A L

Isotropic with E = 2.1·1011 Pa, ν = 0.3.

L O A D

A distributed load of 106 Pa on the upper surface pointing in the negative z direction.

C O N S T R A I N T S

• Symmetry planes, x = 0, y = 0.

x

y

2.0

1.
0

1.
75

1.25

Thickness 0.6 m

D

Load 1MPa

z
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• Outer ellipse surface constrained in the x and y directions.

• Midplane on outer ellipse surface constrained in the z direction.

Results

The normal stress σy is evaluated on the top surface at the inside of the elliptic hole, point 
D in Figure 1 with coordinate (2, 0, 0.6). It is in good agreement with the NAFEMS 
benchmark (Ref. 1), considering the coarse mesh. The difference is less than 4%.

The y-component of the stress is shown in Figure 2.

Figure 2: The stress in the y direction.

A note about this example is that the z direction constraint is applied to an edge only. This 
is a singular constraint, which causes local stresses at the constrained edge. These stresses 
are unlimited from a theoretical point of view, and in practice the stresses and vertical 
displacements are strongly mesh dependent. This does not invalidate the possibility to 
determine stresses at a distance far away from the singular constraint.

RESULT COMSOL MULTIPHYSICS NAFEMS (Ref. 1)

σy (at D) -5.57 MPa -5.38 MPa
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Notes About the COMSOL Implementation

In order to get the same mesh as in the original benchmark, some extra lines are drawn in 
the 2D geometry. As an effect, there will be several domains. This approach is efficient in 
this simple example, whereas for more complex geometries, the use of Mesh Control 

Domains should be considered.

Reference

1. G.A.O. Davies, R.T. Fenner, and R.W. Lewis, Background to Benchmarks, NAFEMS, 
Glasgow, 1993.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/thick_plate

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

If you do not want to build all the geometry, you can load the geometry sequence from 
the stored model. In the Model Builder window, under Component 1 (comp1) right-click 
Geometry 1 and choose Insert Sequence. Browse to the model’s Application Libraries folder 
and double-click the file thick_plate.mph. You can then continue to the Add Material 
section below.
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To build the geometry from a scratch, continue here.

Work Plane 1 (wp1)
In the Geometry toolbar, click Work Plane.

Work Plane 1 (wp1)>Plane Geometry
Right-click Work Plane 1 (wp1) and choose Show Work Plane.

Work Plane 1 (wp1)>Ellipse 1 (e1)
1 In the Work Plane toolbar, click Ellipse.

2 In the Settings window for Ellipse, locate the Size and Shape section.

3 In the a-semiaxis text field, type 3.25.

4 In the b-semiaxis text field, type 2.75.

5 In the Sector angle text field, type 90.

6 Click Build Selected.

7 Click the Zoom Extents button in the Graphics toolbar.

Work Plane 1 (wp1)>Ellipse 2 (e2)
1 In the Work Plane toolbar, click Ellipse.

2 In the Settings window for Ellipse, locate the Size and Shape section.

3 In the a-semiaxis text field, type 2.

4 In the Sector angle text field, type 90.

5 Click Build Selected.

Work Plane 1 (wp1)>Ellipse 3 (e3)
1 In the Work Plane toolbar, click Ellipse.

2 In the Settings window for Ellipse, locate the Size and Shape section.

3 In the a-semiaxis text field, type 2.416.

4 In the b-semiaxis text field, type 1.583.

5 In the Sector angle text field, type 90.

6 Click Build Selected.

Work Plane 1 (wp1)>Difference 1 (dif1)
1 In the Work Plane toolbar, click Booleans and Partitions and choose Difference.

2 Select the objects e1 and e3 only.

3 In the Settings window for Difference, locate the Difference section.

4 Find the Objects to subtract subsection. Select the Activate selection toggle button.
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5 Select the object e2 only.

6 Click Build Selected.

Work Plane 1 (wp1)>Polygon 1 (pol1)
1 In the Work Plane toolbar, click Polygon.

2 In the Settings window for Polygon, locate the Object Type section.

3 From the Type list, choose Open curve.

4 Locate the Coordinates section. In the table, enter the following settings:

Work Plane 1 (wp1)>Polygon 2 (pol2)
1 In the Work Plane toolbar, click Polygon.

2 In the Settings window for Polygon, locate the Object Type section.

3 From the Type list, choose Open curve.

4 Locate the Coordinates section. In the table, enter the following settings:

5 In the Work Plane toolbar, click Build All.

Work Plane 1 (wp1)>Plane Geometry
Click the Zoom Extents button in the Graphics toolbar.

Work Plane 1 (wp1)>Partition Objects 1 (par1)
1 In the Work Plane toolbar, click Booleans and Partitions and choose Partition Objects.

2 Select the object dif1 only.

3 In the Settings window for Partition Objects, locate the Partition Objects section.

4 Find the Tool objects subsection. Select the Activate selection toggle button.

5 Select the objects pol1 and pol2 only.

xw (m) yw (m)

1.783 2.3

1.165 0.812

xw (m) yw (m)

2.833 1.348

1.783 0.453
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6 Click Build Selected.

Work Plane 1 (wp1)
In the Model Builder window, click Work Plane 1 (wp1).

Extrude 1 (ext1)
1 In the Geometry toolbar, click Extrude.

2 In the Settings window for Extrude, locate the Distances section.

3 In the table, enter the following settings:

4 Click Build Selected.

Distances (m)

0.3

0.6
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5 Click the Zoom Extents button in the Graphics toolbar.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

Symmetry 1
1 In the Model Builder window, under Component 1 (comp1) right-click 

Solid Mechanics (solid) and choose More Constraints>Symmetry.

2 Select Boundaries 1, 4, 8, 11, 40, 41, 49, and 50 only.

Property Variable Value Unit Property group

Young’s modulus E 210[GPa] Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 7850 kg/m³ Basic
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Prescribed Displacement 1
1 In the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundaries 15, 16, 31, 32, 51, and 52 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in x direction check box.

5 Select the Prescribed in y direction check box.

Prescribed Displacement 2
1 In the Physics toolbar, click Edges and choose Prescribed Displacement.

2 Select Edges 20, 41, and 72 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in z direction check box.

Boundary Load 1
1 In the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 7, 14, 23, 30, 39, and 48 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

M E S H  1

Mapped 1
In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
More Operations>Mapped.

Distribution 1
In the Model Builder window, right-click Mapped 1 and choose Distribution.

Mapped 1
Select Boundaries 7, 14, 23, 30, 39, and 48 only.

Distribution 1
1 In the Model Builder window, click Distribution 1.

0 x

0 y

-1e6 z
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2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 2.

4 Locate the Edge Selection section. From the Selection list, choose All edges.

5 Click Build Selected.

Swept 1
1 In the Model Builder window, right-click Mesh 1 and choose Swept.

2 In the Settings window for Swept, click Build All.

S T U D Y  1

In the Home toolbar, click Compute.

R E S U L T S

Point Evaluation 1
1 In the Results toolbar, click Point Evaluation.

2 Select Point 24 only.

This corresponds to point D in Figure 1.

3 In the Settings window for Point Evaluation, click Replace Expression in the upper-right 
corner of the Expressions section. From the menu, choose Component 1>

Solid Mechanics>Stress>Stress tensor (spatial frame) - N/m²>solid.sy - Stress tensor,

y component.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Stress (solid)
Modify the default surface plot to show the y component of the stress tensor.

Surface 1
1 In the Model Builder window, expand the Results>Stress (solid) node, then click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>Stress>

Stress tensor (spatial frame) - N/m²>solid.sy - Stress tensor, y component.

3 Locate the Expression section. From the Unit list, choose MPa.

Expression Unit Description

solid.sy MPa Stress tensor, y component (COMSOL)

-5.38[MPa] MPa Stress tensor, y compoent, (NAFEMS)
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4 In the Stress (solid) toolbar, click Plot.
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Introduction

This conceptual example shows how to calculate critical points in models with contact. 
The model consists of two contacting arches modeled with the Shell interface. During 
loading, the lower arch exhibits a snap-through behavior. The definition of the problem is 
based on a benchmark example from Ref. 1.

Model Definition

The model geometry consists of an arch and a block as shown in Figure 1. Since the arches 
are modeled with the Shell interface, a 3D geometry is used. However, a 2D plane strain 
behavior is intended, and consequently symmetry conditions are applied to all edges in the 
y direction to suppress any out-of-plane deformation

.

Figure 1: Model geometry.

Only contact without friction is considered and the penalty contact method is used.

The ends of the upper arch are constrained against displacement in the x direction and 
subjected to vertical edge loads. The magnitude of the edge loads is controlled by the 
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monotonically increasing deflection of the upper arch, which makes it possible to track the 
entire load path, even though the force does not increase monotonically. The ends of the 
lower arch are fixed.

Results and Discussion

Figure 2 depicts the deformed shape and the von Mises stress distribution at the last step 
of the simulation. The snap-through of the lower arch is clearly visible. Both arches are 
represented by a shell dataset that shows both their top and bottom surfaces.

Figure 2: Deformation and von Mises stress at the final step.

Three different load versus deflection curves are shown in Figure 3. The load is 
represented by a dimensionless load factor, and is plotted against either the mid deflections 
of the two arches or the average deflection of the ends of the upper arch. Several critical 
points can be observed. For example, looking at the lower arch, a first limit point is reached 
for a load factor equal to 107.5 and a deflection of 13 mm. At this point the lower arch 
becomes unstable and a snap-through occurs. When the deflection reaches 45 mm, the 
load factor has decreased to 45. At this point a second limit point is reached, and the model 
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finds a new stable configuration. After this point the load factor increases with increasing 
deflection. 

Several bifurcation points are also present, indicating the unstable nature of the problem 
and possible branching of the load path. A first point is, for example, visible already at a 
deflection of 1 mm, where there is a clear change in the slope of the load-deflection curve.

Figure 3: Load versus deflection curves.

The progressive deformation of the two arches, including the snap-through of the lower 
arch, is shown in Figure 4 for five values of the continuation parameter. In the figure, it 
also is clearly visible how the contact problem changes throughout the simulation. 
Figure 5 shows the contact pressure exerted by the upper arch on the lower arch during 
the post-critical stage.
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Figure 4: Deformation of the model for five different parameter values

Figure 5: Contact pressure acting on the lower arch.
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Notes About the COMSOL Implementation 

Contact problems are often unstable in their initial configuration. To help the solver find 
an initial solution, a Spring Foundation is added to the otherwise unconstrained upper arch 
during the first parameter step.

Modeling the post-critical behavior of a system is not possible by incrementally increasing 
the boundary load. The unstable behavior is even more pronounced when contact is 
present. To be able to find all limit points and to track the full load versus deflection curve, 
a displacement controlled load scheme is used by adding a Global Equation. Here, the 
magnitude of the edge loads is controlled through the monotonically increasing deflection 
of the upper arch. Alternatively, the vertical displacement could be prescribed on end 
points of the upper arch, but this is a less general technique that fails for some cases.

This problem is highly unstable and several branches of the equilibrium path are possible. 
To suppress these so that a stable solution is obtained, the mid-point of both arches is 
constrained against sideways displacement through a symmetry condition. By deactivating 
this constraint, it is possible to study the branching of the equilibrium path.

Reference

1. P. Wriggers, Computational Contact Mechanics, Springer-Verlag, 2006

Application Library path: Structural_Mechanics_Module/
Verification_Examples/two_arches

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Shell (shell).

3 Click Add.
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4 Click Study.

5 In the Select Study tree, select General Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
two_arches_parameters.txt.

G E O M E T R Y  1

Work Plane 1 (wp1)
1 In the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 From the Plane list, choose xz-plane.

4 Click Show Work Plane.

Work Plane 1 (wp1)>Circle 1 (c1)
1 In the Work Plane toolbar, click Circle.

2 In the Settings window for Circle, locate the Object Type section.

3 From the Type list, choose Curve.

4 Locate the Size and Shape section. In the Radius text field, type Ri_upper.

5 In the Sector angle text field, type seg_upper.

6 Locate the Position section. In the yw text field, type Ri_upper.

7 Locate the Rotation Angle section. In the Rotation text field, type -90-seg_upper/2.

8 Click Build Selected.

9 Click the Zoom Extents button in the Graphics toolbar.

Work Plane 1 (wp1)>Circle 2 (c2)
1 In the Work Plane toolbar, click Circle.

2 In the Settings window for Circle, locate the Object Type section.

3 From the Type list, choose Curve.
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4 Locate the Size and Shape section. In the Radius text field, type Ri_lower.

5 In the Sector angle text field, type seg_lower.

6 Locate the Position section. In the yw text field, type -Ri_lower.

7 Locate the Rotation Angle section. In the Rotation text field, type 90-seg_lower/2.

8 Click Build Selected.

9 Click the Zoom Extents button in the Graphics toolbar.

Work Plane 1 (wp1)>Delete Entities 1 (del1)
1 In the Model Builder window, right-click Plane Geometry and choose Delete Entities.

2 On the object c1, select Boundaries 2 and 3 only.

3 On the object c2, select Boundaries 3 and 4 only.

Work Plane 1 (wp1)>Partition Edges 1 (pare1)
1 In the Work Plane toolbar, click Booleans and Partitions and choose Partition Edges.

2 On the object del1(1), select Boundary 1 only.

Work Plane 1 (wp1)
1 In the Model Builder window, click Work Plane 1 (wp1).

2 In the Settings window for Work Plane, locate the Unite Objects section.

3 Clear the Unite objects check box.

Extrude 1 (ext1)
1 In the Geometry toolbar, click Extrude.

2 In the Settings window for Extrude, locate the Distances section.

3 In the table, enter the following settings:

4 Click Build Selected.

5 Click the Zoom Extents button in the Graphics toolbar.

Explicit Selection 1 (sel1)
1 In the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Upper Arch in the Label text field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose Object.

4 Select the object ext1(2) only.

Distances (m)

d
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5 Locate the Color section. From the Color list, choose Color 4.

6 Click Build Selected.

Upper Arch 1 (sel2)
1 Right-click Upper Arch and choose Duplicate.

2 In the Settings window for Explicit Selection, type Lower Arch in the Label text field.

3 Locate the Entities to Select section. In the list, select ext1(2).

4 Select the object ext1(1) only.

5 Locate the Color section. From the Color list, choose Color 12.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click 

Form Union (fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly section.

3 From the Action list, choose Form an assembly.

4 Click Build Selected.

5 Click the Zoom Extents button in the Graphics toolbar.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Lower Arch.

4 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Upper Arch.

Property Variable Value Unit Property group

Young’s modulus E 40[GPa] Pa Basic

Poisson’s ratio nu 0.2 1 Basic

Density rho 1 kg/m³ Basic
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4 Locate the Material Contents section. In the table, enter the following settings:

D E F I N I T I O N S

Average 1 (aveop1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 In the Settings window for Average, locate the Source Selection section.

3 From the Geometric entity level list, choose Point.

4 Select Point 9 only.

Average 2 (aveop2)
1 Right-click Average 1 (aveop1) and choose Duplicate.

2 In the Settings window for Average, locate the Source Selection section.

3 Click Clear Selection.

4 Select Point 3 only.

Average 3 (aveop3)
1 Right-click Average 2 (aveop2) and choose Duplicate.

2 In the Settings window for Average, locate the Source Selection section.

3 Click Clear Selection.

4 Select Points 7 and 11 only.

Variables 1
1 In the Model Builder window, right-click Definitions and choose Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

Property Variable Value Unit Property group

Young’s modulus E 20[GPa] Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 1 kg/m³ Basic

Name Expression Unit Description

disp_upper aveop1(-w) m Upper arch displacement

disp_lower aveop2(-w) m Lower arch displacement

disp_load aveop3(-w) m Average load point displacement
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Contact Pair 1 (p1)
1 In the Definitions toolbar, click Pairs and choose Contact Pair.

2 In the Settings window for Pair, locate the Source Boundaries section.

3 From the Selection list, choose Upper Arch.

4 Locate the Destination Boundaries section. From the Selection list, choose Lower Arch.

S H E L L  ( S H E L L )

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Shell (shell) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type d.

4 From the Offset definition list, choose Relative offset.

5 In the zreloffset text field, type -1.

Symmetry 1
1 In the Physics toolbar, click Edges and choose Symmetry.

2 Select Edges 2, 3, 5, 6, 9, 10, 12, and 13 only.

Prescribed Displacement/Rotation 1
1 In the Physics toolbar, click Edges and choose Prescribed Displacement/Rotation.

2 Select Edges 8 and 14 only.

3 In the Settings window for Prescribed Displacement/Rotation, locate the 
Prescribed Displacement section.

4 Select the Prescribed in x direction check box.

5 Select the Prescribed in y direction check box.

Prescribed Displacement/Rotation 2
1 In the Physics toolbar, click Edges and choose Prescribed Displacement/Rotation.

2 Select Edges 1 and 7 only.

3 In the Settings window for Prescribed Displacement/Rotation, locate the 
Prescribed Displacement section.

4 Select the Prescribed in x direction check box.

5 Select the Prescribed in y direction check box.

6 Select the Prescribed in z direction check box.
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7 Locate the Prescribed Rotation section. From the By list, choose Rotation.

Contact 1
1 In the Physics toolbar, in the Boundary section, click Pairs and choose Contact.

2 In the Settings window for Contact, locate the Pair Selection section.

3 Under Pairs, click Add.

4 In the Add dialog box, select Contact Pair 1 (p1) in the Pairs list.

5 Click OK.

Edge Load 1
1 In the Physics toolbar, click Edges and choose Edge Load.

2 Select Edges 8 and 14 only.

3 In the Settings window for Edge Load, locate the Force section.

4 Specify the FL vector as

The dependent variable load will be created in the next step using a global equation.

5 Click the Show More Options button in the Model Builder toolbar.

6 In the Show More Options dialog box, in the tree, select the check box for the node 
Physics>Equation-Based Contributions.

7 Click OK.

Global Equations 1
1 In the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Global Equations section.

3 In the table, enter the following settings:

4 Locate the Units section. Click Select Source Term Quantity.

5 In the Physical Quantity dialog box, type displacement in the text field.

0 x

0 y

load*F_ref z

Name f(u,ut,utt,
t) (1)

Initial value 
(u_0) (1)

Initial value 
(u_t0) (1/s)

Description

load disp_up
per-
max_dis
p*para

0 0 Load Factor
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6 Click Filter.

7 In the tree, select General>Displacement (m).

8 Click OK.

Add a small spring stiffness to the upper arch to stabilize the model during the initial step.

Spring Foundation 1
1 In the Physics toolbar, click Boundaries and choose Spring Foundation.

2 In the Settings window for Spring Foundation, locate the Spring section.

3 In the kA text field, type 1e3*(para<0.01).

4 Locate the Boundary Selection section. From the Selection list, choose Upper Arch.

Several possible branches are possible during the snap-through. Adding a constraint to 
each arch enforces a symmetric and stable solution.

Symmetry 2
1 In the Physics toolbar, click Edges and choose Symmetry.

2 Select Edges 4 and 11 only.

M E S H  1

Mapped 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Mapped.

2 In the Settings window for Mapped, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

Distribution 1
1 Right-click Mapped 1 and choose Distribution.

2 Select Edges 2 and 5 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type n_elem_lower.

Distribution 2
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 Select Edges 9 and 12 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type n_elem_upper.
13 |  I N S T A B I L I T Y  O F  T W O  C O N T A C T I N G  A R C H E S



5 In the Model Builder window, click Mesh 1.

6 In the Settings window for Mesh, click Build All.

7 Click the Zoom Extents button in the Graphics toolbar.

S T U D Y  1

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study Extensions section.

3 Select the Auxiliary sweep check box.

4 Click Add.

5 In the table, enter the following settings:

Solution 1 (sol1)
In the Study toolbar, click Show Default Solver.

Stationary Solver 1
1 In the Model Builder window, expand the Solution 1 (sol1) node, then click 

Stationary Solver 1.

Parameter name Parameter value list Parameter unit

para (Load parameter) range(0,0.02,1)
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2 In the Settings window for Stationary Solver, locate the General section.

3 In the Relative tolerance text field, type 0.0005.

Parametric 1
1 In the Model Builder window, expand the Stationary Solver 1 node, then click 

Parametric 1.

2 In the Settings window for Parametric, click to expand the Continuation section.

3 Select the Tuning of step size check box.

4 In the Minimum step size text field, type 1e-6.

Stop Condition 1
1 Right-click Parametric 1 and choose Stop Condition.

2 In the Settings window for Stop Condition, locate the Stop Expressions section.

3 Click Add.

4 In the table, enter the following settings:

5 Locate the Output at Stop section. From the Add solution list, choose Step before stop.

Fully Coupled 1
1 In the Model Builder window, click Fully Coupled 1.

2 In the Settings window for Fully Coupled, click to expand the Method and Termination 
section.

3 From the Nonlinear method list, choose Constant (Newton).

4 In the Study toolbar, click Compute.

R E S U L T S

Stress (shell)
1 In the Settings window for 3D Plot Group, locate the Plot Settings section.

2 From the Frame list, choose Spatial (x, y, z).

3 In the Stress (shell) toolbar, click Plot.

4 Click the Show Grid button in the Graphics toolbar.

5 Click the Zoom Extents button in the Graphics toolbar.

Stop expression Stop if Active Description

comp1.load/250 True (>=1) √ Stop expression 1
15 |  I N S T A B I L I T Y  O F  T W O  C O N T A C T I N G  A R C H E S



Contact (shell)
1 In the Model Builder window, click Contact (shell).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Parameter value (para) list, choose 0.6.

Contact 1, Pressure
1 In the Model Builder window, expand the Contact (shell) node, then click Contact 1,

Pressure.

2 In the Settings window for Arrow Surface, locate the Coloring and Style section.

3 Select the Scale factor check box.

4 In the associated text field, type 2e-10.

Gray Surfaces
In the Model Builder window, right-click Gray Surfaces and choose Enable.

Animation 1
1 In the Contact (shell) toolbar, click Animation and choose Player.

2 In the Settings window for Animation, locate the Frames section.

3 From the Frame selection list, choose All.

4 Right-click Animation 1 and choose Play.

1D Plot Group 6
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Load vs Deflection in the Label text 
field.

Global 1
1 Right-click Load vs Deflection and choose Global.

2 In the Settings window for Global, locate the y-Axis Data section.

3 In the table, enter the following settings:

4 Locate the x-Axis Data section. From the Parameter list, choose Expression.

5 In the Expression text field, type load.

Expression Unit Description

disp_upper mm Upper arch displacement

disp_lower mm Lower arch displacement

disp_load mm Average load point displacement
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6 Click to expand the Coloring and Style section. Find the Line markers subsection. From 
the Marker list, choose Cycle.

Load vs Deflection
1 In the Model Builder window, click Load vs Deflection.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the Flip the x- and y-axes check box.

4 Locate the Legend section. From the Position list, choose Upper left.

5 Locate the Plot Settings section. Select the x-axis label check box.

6 In the associated text field, type Deflection (mm).

7 In the Load vs Deflection toolbar, click Plot.

1D Plot Group 7
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Deformation in the Label text field.

3 Locate the Data section. From the Parameter selection (para) list, choose Manual.

4 In the Parameter indices (1-46) text field, type range(1,10,41).

5 Click to expand the Title section. From the Title type list, choose None.

Line Graph 1
1 Right-click Deformation and choose Line Graph.

2 Select Edges 2 and 5 only.

3 In the Settings window for Line Graph, locate the y-Axis Data section.

4 In the Expression text field, type z.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type x.

7 Click to expand the Coloring and Style section. In the Width text field, type 2.

Line Graph 2
1 Right-click Line Graph 1 and choose Duplicate.

2 In the Settings window for Line Graph, locate the Selection section.

3 Click Clear Selection.

4 Select Edges 9 and 12 only.

5 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Dashed.
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6 From the Color list, choose Cycle (reset).

Line Graph 1
1 In the Model Builder window, click Line Graph 1.

2 In the Settings window for Line Graph, click to expand the Legends section.

3 Select the Show legends check box.

4 Find the Include subsection. In the Prefix text field, type para = .

5 In the Deformation toolbar, click Plot.

Stress (shell)
Click the Zoom Extents button in the Graphics toolbar.
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Introduction

When a structure is subjected to vibrations of high frequency, a significant amount of heat 
can be generated within the structure because of mechanical losses in the material such as, 
for example, viscoelastic effects. 

In this example, you model the slow rise of the temperature in a vibrating beam-like 
structure. You use a transient heat-transfer problem with source term which represents the 
heat generation due to mechanical losses. The simulation is based on a structural analysis 
performed in the frequency domain. 

Model Definition

The beam consists of two layers made of aluminum and titanium, respectively, with the 
corresponding loss factors 0.001 and 0.005. One end of the beam is fixed, and the other 
one is subjected to periodic loading in the z direction, which is represented in the 
frequency domain as Fzexp(jωt), where j is the imaginary unit, and the angular frequency 
is

The excitation frequency f = 7767 Hz and the load magnitude Fz =  1.7 MPa are used in 
this example.

The temperature rise is given by the heat-transfer equation

where k is the thermal conductivity, and the volumetric heat capacity ρCp is independent 
of the temperature in accordance with the Dulong-Petit law. 

Note that T represents the temperature averaged over the time period 2π/ω. The heat 
source

presents the internal work of the nonelastic (for example, viscous) forces over the period. 
In the above expression, η is the loss factor, ε is the strain tensor, and  is the elasticity 
tensor. The term is computed from a structural analysis performed in the frequency 
domain.

ω 2πf=

ρCp t∂
∂T ∇ k T∇( )⋅– Qh=

Qh
1
2
---ωηReal ε : Conj C : ε( )[ ]=

C
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The initial state at time t = 0 is stress-free, and the initial temperature is 293.15 K over the 
entire beam.

Use the following boundary conditions:

• At the fixed end, use the temperature condition T = 293.15 K.

• At the end subjected to periodic force, use the thermal insulation condition.

• The boundary between the layers of different materials is an interior boundary.

• At all other boundaries, use the convective cooling condition:

where h = 5 W/(m2·K) is the heat transfer coefficient and Text = 293.15 K is the external 
temperature.

For the simulation, apply a periodic loading in the z direction of magnitude 1.7 MPa and 
frequency 7767 Hz at the free end of the beam for 2 seconds, keeping the fixed end and 
the structure environment at a constant temperature of 300 K during the process.

Results and Discussion

Figure 1 displays the temperature distribution at the end of the simulated 2-second forced 
vibrations. As the figure shows, the maximum temperature rise in the beam is about 0.2 K.

n k∇T–( )⋅ h T Text–( )=
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Figure 1: Temperature increase in the beam after 2 seconds of forced vibrations.

Application Library path: Structural_Mechanics_Module/Thermal-
Structure_Interaction/vibrating_beam

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).
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5 Click Add.

6 Click Study.

7 In the Select Study tree, select General Studies>Time Dependent.

8 Click Done.

G E O M E T R Y  1

Block 1 (blk1)
1 In the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 0.01.

4 In the Depth text field, type 0.001.

5 In the Height text field, type 0.001.

Block 2 (blk2)
1 In the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 0.01.

4 In the Depth text field, type 0.001.

5 In the Height text field, type 0.001.

6 Locate the Position section. In the z text field, type 0.001.

7 In the Model Builder window, click Geometry 1.

8 Click Build All Objects.

A D D  M A T E R I A L

1 In the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-in>Aluminum.

4 Click Add to Component in the window toolbar.

5 In the tree, select Built-in>Titanium beta-21S.

6 Click Add to Component in the window toolbar.

7 In the Home toolbar, click Add Material to close the Add Material window.
5 |  H E A T  G E N E R A T I O N  I N  A  V I B R A T I N G  S T R U C T U R E



M A T E R I A L S

Aluminum (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click 

Aluminum (mat1).

2 Select Domain 1 only.

Titanium beta-21S (mat2)
1 In the Model Builder window, click Titanium beta-21S (mat2).

2 Select Domain 2 only.

S O L I D  M E C H A N I C S  ( S O L I D )

You need to set up the Solid Mechanics equation form to frequency-domain, since the 
study type will be set to time dependent. The time dependent equations should be applied 
to the heat transfer physics only.

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, click to expand the Equation section.

3 From the Equation form list, choose Frequency domain.

4 From the Frequency list, choose User defined. In the f text field, type 7767.

Fixed Constraint 1
1 In the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundaries 1 and 4 only.

Boundary Load 1
1 In the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 10 and 11 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

Linear Elastic Material 1
In the Model Builder window, click Linear Elastic Material 1.

0 x

0 y

1.7[MPa] z
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Damping 1
1 In the Physics toolbar, click Attributes and choose Damping.

2 Select Domain 1 only.

3 In the Settings window for Damping, locate the Damping Settings section.

4 From the Damping type list, choose Isotropic loss factor.

5 From the ηs list, choose User defined. In the associated text field, type 0.001.

Linear Elastic Material 1
In the Model Builder window, click Linear Elastic Material 1.

Damping 2
1 In the Physics toolbar, click Attributes and choose Damping.

2 Select Domain 2 only.

3 In the Settings window for Damping, locate the Damping Settings section.

4 From the Damping type list, choose Isotropic loss factor.

5 From the ηs list, choose User defined. In the associated text field, type 0.005.

H E A T  T R A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids (ht).

Temperature 1
1 In the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundaries 1 and 4 only.

Heat Flux 1
1 In the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Heat Flux section.

3 Click the Convective heat flux button.

4 In the h text field, type 5.

5 Select Boundaries 2, 3, 5, and 7–9 only.

Heat Source 1
1 In the Physics toolbar, click Domains and choose Heat Source.

2 In the Settings window for Heat Source, locate the Domain Selection section.

3 From the Selection list, choose All domains.
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4 Locate the Heat Source section. From the Q0 list, choose 
Total power dissipation density (solid/lemm1).

This choice models the heat generated by the vibrations in the structure.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Physics-Controlled Mesh section.

3 From the Element size list, choose Extra fine.

Swept 1
1 Right-click Component 1 (comp1)>Mesh 1 and choose Swept.

2 Click Build All.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,0.05,2).

Before computing the solution, generate the default plots.

4 In the Model Builder window, right-click Study 1 and choose Get Initial Value for Step.

R E S U L T S

Surface
1 In the Model Builder window, expand the Temperature (ht) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type T-293.15.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, click to expand the Results While Solving 
section.

3 Select the Plot check box.
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Solver Configurations
In the Model Builder window, expand the Study 1>Solver Configurations node.

Solution 1 (sol1)
You need to enable complex values because they are used in the solid mechanics equations, 
which you manually reconfigured for the frequency-domain analysis.

1 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 (sol1) 
node, then click Time-Dependent Solver 1.

2 In the Settings window for Time-Dependent Solver, click to expand the Advanced section.

3 Select the Allow complex numbers check box.

4 In the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
1 Click the Zoom Out button in the Graphics toolbar.

The computed solution should closely resemble that shown in Figure 1.
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Introduction

In the following example you compute the natural frequencies of a pretensioned 
membrane using the 3D Membrane interface. This is an example of “stress stiffening”; 
where the transverse stiffness of a membrane is directly proportional to the tensile force.

The results are compared with the analytical solution.

Model Definition

The model consists of a circular membrane, supported along its outer edge.

G E O M E T R Y

• Membrane radius, R = 0.25 m

• Membrane thickness, h = 0.2 mm

M A T E R I A L

• Young’s modulus, E = 200 GPa

• Poisson’s ratio, ν = 0.33

• Mass density, ρ = 7850 kg/m3

C O N S T R A I N T S

The outer edge of the membrane is supported in the transverse direction. Two points have 
constraints in the in-plane direction in order to avoid rigid body motions.

L O A D

The membrane is pretensioned by in the radial direction with σi = 100 MPa, giving a 
membrane force T0 = 20 kN/m.

Results and Discussion

The analytical solution for the natural frequencies of the vibrating membrane given in 
Ref. 1 is:

 (1)

The values kij are derived from the roots of the Bessel functions of the first kind.

fij
kij

2πR
-----------

T0
hρ
-------=
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In Table 1 the computed results are compared with the results from Equation 1. The 
agreement is very good. The mode shapes for the first six modes are shown in Figure 1 
through Figure 6. Note that some of the modes have duplicate eigenvalues, which is a 
common property for structures with symmetries.

TABLE 1:  COMPARISON BETWEEN ANALYTICAL AND COMPUTED NATURAL FREQUENCIES.

Mode 
number

Factor Analytical 
frequency (Hz)

COMSOL result (Hz)

1 k10 = 2.4048 172.8 172.8

2 k11 = 3.8317 275.3 275.3

3 k11 = 3.8317 275.3 275.3

4 k12 = 5.1356 369.0 369.0

5 k12 = 5.1356 369.0 369.0

6 k20 = 5.5201 396.6 396.7
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Figure 1: First eigenmode.

Figure 2: Second eigenmode.
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Figure 3: Third eigenmode.

Figure 4: Fourth eigenmode.
5 |  V I B R A T I N G  M E M B R A N E



Figure 5: Fifth eigenmode.

Figure 6: Sixth eigenmode.
6 |  V I B R A T I N G  M E M B R A N E



Notes About the COMSOL Implementation

An eigenfrequency simulation with a pre-stressed structure can be simulated in two ways. 
If stresses are known in advance, it is possible to use an initial stress condition. This is 
shown in the first study.

In a general case, the prestress is given by some external loading, and is thus the result of 
a previous step in the solution. Such a study would consist of two steps: One stationary 
step for computing the prestressed state, and one step for the eigenfrequency. The special 
study type Prestressed Analysis, Eigenfrequency can be used to set up such a sequence. 
This is shown in the second study in this example.

Since an unstressed membrane has no stiffness in the transverse direction, it is generally 
difficult to get an analysis to converge without taking special measures. One such method 
is shown in the second study: A spring foundation is added during initial loading, and is 
then removed.

Reference

1. A. Bower, Applied Mechanics of Solids, CRC Press, 2010.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/vibrating_membrane

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Membrane (mbrn).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Eigenfrequency.
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6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters 1
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

D E F I N I T I O N S

Cylindrical System 2 (sys2)
In the Definitions toolbar, click Coordinate Systems and choose Cylindrical System.

G E O M E T R Y  1

Work Plane 1 (wp1)
In the Geometry toolbar, click Work Plane.

Work Plane 1 (wp1)>Plane Geometry
Right-click Work Plane 1 (wp1) and choose Show Work Plane.

Work Plane 1 (wp1)>Circle 1 (c1)
1 In the Work Plane toolbar, click Circle.

Name Expression Value Description

R 250[mm] 0.25 m Radius

thic 0.2[mm] 2E-4 m Thickness

T0 100[MPa]*thic 20000 N/m Pretension force

E1 200[GPa] 2E11 Pa Young's modulus

rho1 7850[kg/m^3] 7850 kg/m³ Density

nu1 0.33 0.33 Poisson's ratio

fct sqrt(T0/(thic*
rho1))/(2*pi*R)

71.853 1/s Common factor in 
natural frequencies

f10 2.4048*fct 172.79 1/s 1st natural frequency

f11 3.8317*fct 275.32 1/s 2nd and 3d natural 
frequencies

f12 5.1356*fct 369.01 1/s 4th and 5th natural 
frequencies

f20 5.5201*fct 396.64 1/s 6th natural frequency
8 |  V I B R A T I N G  M E M B R A N E



2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type R.

4 In the Model Builder window, click Geometry 1.

5 In the Home toolbar, click Build All.

6 Click the Zoom Extents button in the Graphics toolbar.

M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

M E M B R A N E  ( M B R N )

Thickness and Offset 1
1 In the Model Builder window, under Component 1 (comp1)>Membrane (mbrn) click 

Thickness and Offset 1.

2 In the Settings window for Thickness and Offset, locate the Thickness and Offset section.

3 In the d text field, type thic.

Linear Elastic Material 1
In the Model Builder window, click Linear Elastic Material 1.

Initial Stress and Strain 1
1 In the Physics toolbar, click Attributes and choose Initial Stress and Strain.

2 In the Settings window for Initial Stress and Strain, locate the Initial Stress and Strain 
section.

3 In the N0 table, enter the following settings:

Property Variable Value Unit Property group

Young’s modulus E E1 Pa Basic

Poisson’s ratio nu nu1 1 Basic

Density rho rho1 kg/m³ Basic

T0 0

0 T0
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Prescribed Displacement 1
1 In the Physics toolbar, click Edges and choose Prescribed Displacement.

2 Select all four edges.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in z direction check box.

Fixed Constraint 1
1 In the Physics toolbar, click Points and choose Fixed Constraint.

2 Select Point 1 only.

Prescribed Displacement 2
1 In the Physics toolbar, click Points and choose Prescribed Displacement.

2 Select Point 2 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in y direction check box.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Physics-Controlled Mesh section.

3 From the Element size list, choose Fine.

S T U D Y  1

Step 1: Eigenfrequency
1 In the Model Builder window, under Study 1 click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Include geometric nonlinearity check box.

4 In the Home toolbar, click Compute.

R E S U L T S

Surface 1
1 In the Model Builder window, expand the Mode Shape (mbrn) node, then click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type w.
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4 In the Mode Shape (mbrn) toolbar, click Plot.

5 Click the Zoom Extents button in the Graphics toolbar.

Mode Shape (mbrn)
1 In the Model Builder window, click Mode Shape (mbrn).

2 From the Eigenfrequency list, choose the first frequency at 275.3 Hz.

3 In the Mode Shape (mbrn) toolbar, click Plot.

4 From the Eigenfrequency list, choose the first frequency at 275.3 Hz.

5 In the Mode Shape (mbrn) toolbar, click Plot.

6 From the Eigenfrequency list, choose the first frequency at 369.1 Hz.

7 In the Mode Shape (mbrn) toolbar, click Plot.

8 From the Eigenfrequency list, choose the first frequency at 369.1 Hz.

9 In the Mode Shape (mbrn) toolbar, click Plot.

10 In the Settings window for 3D Plot Group, locate the Data section.

11 From the Eigenfrequency (Hz) list, choose 396.72.

12 In the Mode Shape (mbrn) toolbar, click Plot.

Now, prepare a second study where the prestress is instead computed from an external 
load.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select 
Preset Studies for Selected Physics Interfaces>Eigenfrequency, Prestressed.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

M E M B R A N E  ( M B R N )

Edge Load 1
1 In the Physics toolbar, click Edges and choose Edge Load.

2 Select all four edges.

3 In the Settings window for Edge Load, locate the Coordinate System Selection section.

4 From the Coordinate system list, choose Cylindrical System 2 (sys2).
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5 Locate the Force section. Specify the FL vector as

Add a spring with an arbitrary small stiffness in order to suppress the out-of-plane 
singularity of the unstressed membrane.

Spring Foundation 1
1 In the Physics toolbar, click Boundaries and choose Spring Foundation.

2 Select Boundary 1 only.

3 In the Settings window for Spring Foundation, locate the Spring section.

4 From the list, choose Diagonal.

5 In the kA table, enter the following settings:

Switch off the initial stress, which should not be part of the second study. In the 
eigenfrequency step, the stabilizing spring support must also be removed.

S T U D Y  2

Step 1: Stationary
1 In the Model Builder window, under Study 2 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Study Settings section.

3 Select the Include geometric nonlinearity check box.

4 Locate the Physics and Variables Selection section. Select the 
Modify model configuration for study step check box.

5 In the Physics and variables selection tree, select Component 1 (comp1)>

Membrane (mbrn), Controls spatial frame>Linear Elastic Material 1>

Initial Stress and Strain 1.

6 Click Disable.

Step 2: Eigenfrequency
1 In the Model Builder window, click Step 2: Eigenfrequency.

T0 r

0 phi

0 a

0 0 0

0 0 0

0 0 10
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2 In the Settings window for Eigenfrequency, locate the Physics and Variables Selection 
section.

3 Select the Modify model configuration for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>

Membrane (mbrn), Controls spatial frame>Linear Elastic Material 1>

Initial Stress and Strain 1 and Component 1 (comp1)>Membrane (mbrn),

Controls spatial frame>Spring Foundation 1.

5 Click Disable.

6 In the Home toolbar, click Compute.

R E S U L T S

Mode Shape (mbrn) 1
The eigenfrequencies computed using this more general approach are the same as before, 
except some small numerical differences.

To make Study 1 behave as when it was first created, the features added for Study 2 must 
be disabled.

S T U D Y  1

Solver Configurations
1 In the Settings window for Eigenfrequency, locate the Physics and Variables Selection 

section.

2 Select the Modify model configuration for study step check box.

3 In the Physics and variables selection tree, select Component 1 (comp1)>

Membrane (mbrn), Controls spatial frame>Edge Load 1 and Component 1 (comp1)>

Membrane (mbrn), Controls spatial frame>Spring Foundation 1.

4 Click Disable.
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Introduction

In the following example you compute the natural frequencies of a pretensioned string 
using the 2D Truss interface. This is an example of “stress stiffening”. In fact the transverse 
stiffness of truss elements is directly proportional to the tensile force.

Strings made of piano wire have an extremely high yield limit, thus enabling a wide range 
of pretension forces.

The results are compared with the analytical solution.

Model Definition

The finite element idealization consists of a single line. The diameter of the wire is 
irrelevant for the solution of this particular problem, but it must still be given.

G E O M E T R Y

• String length, L = 0.5 m

• Cross section diameter 1.0 mm; A = 0.785 mm2

M A T E R I A L

• Young’s modulus, E = 210 GPa

• Poisson’s ratio, ν = 0.31

• Mass density, ρ = 7850 kg/m3

C O N S T R A I N T S

Both ends of the wire are fixed.

L O A D

The wire is pretensioned to σni = 1520 MPa.

Results and Discussion

The analytical solution for the natural frequencies of the vibrating string (Ref. 1) is

 (1)

The pretensioning stress σni in this example is tuned so that the first natural frequency is 
Concert A; 440 Hz.

fk
k

2L
-------

σni
ρ

--------=
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In Table 1 the computed results are compared with the results from Equation 1. The 
agreement is very good. The accuracy decreases with increasing complexity of the mode 
shape, because the possibility for the relatively coarse mesh to describe such a shape is 
limited. The mode shapes for the first three modes are shown in Figure 1 through 
Figure 3.

TABLE 1:  COMPARISON BETWEEN ANALYTICAL AND COMPUTED NATURAL FREQUENCIES.

Mode number Analytical frequency (Hz) COMSOL result (Hz)

1 440.0 440.1

2 880.0 880.6

3 1320 1322

4 1760 1765

5 2200 2209
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Figure 1: First eigenmode.

Figure 2: Second eigenmode.
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Figure 3: Third eigenmode.

Notes About the COMSOL Implementation

In this example, the stresses are known in advance, so it is possible to use an initial stress 
condition. This is shown in the first study.

In a general case, the prestress is given by some external loading. The structural response 
of to this loading needs to be calculated and incorporated into the structure before the 
eigenfrequency can be computed. Such a study therefore consists of two steps: One 
stationary step for computing the prestressed state, and one step for the eigenfrequency. 
The special study type Prestressed Analysis, Eigenfrequency can be used to set up such a 
sequence. This is shown in the second study in this example.

Since an unstressed string has no stiffness in the transverse direction, it is generally difficult 
to get an analysis to converge without taking special measures. One such method is shown 
in the second study: A spring foundation is added during initial loading, and is then 
removed.

You must switch on geometrical nonlinearity in the study in order to capture effects of 
prestress. This is done automatically when a study of the type Prestressed Analysis, 
Eigenfrequency is used.
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Reference

1. R. Knobel, An Introduction to the Mathematical Theory of Waves, The American 
Mathematical Society, 2000.

Application Library path: Structural_Mechanics_Module/
Verification_Examples/vibrating_string

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Truss (truss).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Eigenfrequency.

6 Click Done.

G E O M E T R Y  1

Polygon 1 (pol1)
1 In the Geometry toolbar, click Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

3 In the table, enter the following settings:

4 Click Build All Objects.

x (m) y (m)

0 0

0.5 0
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M A T E R I A L S

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

T R U S S  ( T R U S S )

Cross Section Data 1
1 In the Model Builder window, under Component 1 (comp1)>Truss (truss) click 

Cross Section Data 1.

2 In the Settings window for Cross Section Data, locate the Cross Section Data section.

3 In the A text field, type pi/4*0.001^2.

Pinned 1
1 In the Physics toolbar, click Points and choose Pinned.

2 In the Settings window for Pinned, locate the Point Selection section.

3 From the Selection list, choose All points.

The straight edge constraint must be removed because the vibration gives the string a 
curved shape.

Linear Elastic Material 1
In the Model Builder window, click Linear Elastic Material 1.

Initial Stress and Strain 1
1 In the Physics toolbar, click Attributes and choose Initial Stress and Strain.

2 In the Settings window for Initial Stress and Strain, locate the Initial Stress and Strain 
section.

3 In the σn0 text field, type 1520e6.

Property Variable Value Unit Property group

Young’s modulus E 210e9 Pa Basic

Poisson’s ratio nu 0.31 1 Basic

Density rho 7850 kg/m³ Basic
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M E S H  1

Edge 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Edge.

2 In the Settings window for Edge, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

Size
1 In the Model Builder window, click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Maximum element size text field, type 
0.01.

This setting gives 50 elements for the mesh that COMSOL Multiphysics generates 
when you solve the model.

The stiffness caused by the prestress is a nonlinear effect, so geometric nonlinearity must 
be switched on.

S T U D Y  1

Step 1: Eigenfrequency
1 In the Model Builder window, under Study 1 click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Include geometric nonlinearity check box.

4 In the Home toolbar, click Compute.

R E S U L T S

Mode Shape (truss)
1 Click the Zoom Extents button in the Graphics toolbar.

The default plot shows the displacement for the first eigenmode.

Line 1
1 In the Model Builder window, expand the Mode Shape (truss) node, then click Line 1.

2 In the Settings window for Line, locate the Coloring and Style section.

3 In the Radius scale factor text field, type 2.
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Mode Shape (truss)
1 Click the Zoom Extents button in the Graphics toolbar.

2 In the Model Builder window, click Mode Shape (truss).

3 In the Settings window for 2D Plot Group, locate the Data section.

4 From the Eigenfrequency (Hz) list, choose 880.65.

This corresponds to the second eigenmode.

5 In the Mode Shape (truss) toolbar, click Plot.

6 Click the Zoom Extents button in the Graphics toolbar.

7 From the Eigenfrequency (Hz) list, choose 1322.1.

This is the third eigenmode.

8 In the Mode Shape (truss) toolbar, click Plot.

9 Click the Zoom Extents button in the Graphics toolbar.

Now, prepare a second study where the prestress is instead computed from an external 
load. The pinned condition in the right end must then be replaced by a force.

T R U S S  ( T R U S S )

Pinned 2
1 In the Physics toolbar, click Points and choose Pinned.

2 Select Point 1 only.

Prescribed Displacement 1
1 In the Physics toolbar, click Points and choose Prescribed Displacement.

2 Select Point 2 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in y direction check box.

Point Load 1
1 In the Physics toolbar, click Points and choose Point Load.

2 Select Point 2 only.

3 In the Settings window for Point Load, locate the Force section.
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4 Specify the FP vector as

Add a spring with an arbitrary small stiffness in order to suppress the out-of-plane 
singularity of the unstressed wire.

Spring Foundation 1
1 In the Physics toolbar, click Boundaries and choose Spring Foundation.

2 Select Boundary 1 only.

3 In the Settings window for Spring Foundation, locate the Spring section.

4 From the list, choose Diagonal.

5 In the kL table, enter the following settings:

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select 
Preset Studies for Selected Physics Interfaces>Eigenfrequency, Prestressed.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

Step 1: Stationary
Switch off the initial stress and double-sided pinned condition, which should not be part 
of the second study. In the eigenfrequency step, the stabilizing spring support must also 
be removed.

1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 Select the Modify model configuration for study step check box.

3 In the Physics and variables selection tree, select Component 1 (comp1)>Truss (truss)>

Linear Elastic Material 1>Initial Stress and Strain 1 and Component 1 (comp1)>

Truss (truss)>Pinned 1.

1520[MPa]*truss.area x

0 y

0 0

0 10
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4 Click Disable.

Step 2: Eigenfrequency
1 In the Model Builder window, click Step 2: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Physics and Variables Selection 
section.

3 Select the Modify model configuration for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Truss (truss)>

Linear Elastic Material 1>Initial Stress and Strain 1, Component 1 (comp1)>Truss (truss)>

Pinned 1, and Component 1 (comp1)>Truss (truss)>Spring Foundation 1.

5 Click Disable.

6 In the Home toolbar, click Compute.

R E S U L T S

Mode Shape (truss) 1
The eigenfrequencies computed using this more general approach are close to those 
computed in the previous step.

Line 1
1 In the Model Builder window, expand the Mode Shape (truss) 1 node, then click Line 1.

2 In the Settings window for Line, locate the Coloring and Style section.

3 In the Radius scale factor text field, type 2.

To make Study 1 behave as when it was first created, the features added for Study 2 must 
be disabled.

S T U D Y  1

Step 1: Eigenfrequency
1 In the Model Builder window, under Study 1 click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Physics and Variables Selection 
section.

3 Select the Modify model configuration for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Truss (truss)>

Pinned 2, Component 1 (comp1)>Truss (truss)>Prescribed Displacement 1, 
Component 1 (comp1)>Truss (truss)>Point Load 1, and Component 1 (comp1)>

Truss (truss)>Spring Foundation 1.

5 Click Disable.
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