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 1
I n t r o d u c t i o n
This guide describes the Heat Transfer Module, an optional package that extends 
the COMSOL Multiphysics® modeling environment with customized physics 
interfaces for the analysis of heat transfer.

This chapter introduces you to the capabilities of this module. A summary of the 
physics interfaces and where you can find documentation and model examples is 
also included. The last section is a brief overview with links to each chapter in this 
guide. 

• About the Heat Transfer Module

• Overview of the User’s Guide
 17
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Abou t  t h e  Hea t  T r a n s f e r  Modu l e

In this section:

• Why Heat Transfer is Important to Modeling

• How the Heat Transfer Module Improves Your Modeling

• The Heat Transfer Module Physics Interface Guide

• Common Physics Interface and Feature Settings and Nodes

• The Heat Transfer Module Study Capabilities

• Additional Materials Database

• Where Do I Access the Documentation and Application Libraries?

Why Heat Transfer is Important to Modeling

The Heat Transfer Module is an optional package that extends the COMSOL 
Multiphysics modeling environment with customized physics interfaces and 
functionality optimized for the analysis of heat transfer. It is developed for a wide 
audience including researchers, developers, teachers, and students. To assist users at all 
levels of expertise, this module comes with a library of ready-to-run examples that 
appear in the companion Heat Transfer Module Applications Libraries.

Heat transfer is involved in almost every kind of physical process, and can in fact be the 
limiting factor for many processes. Therefore, its study is of vital importance, and the 
need for powerful heat transfer analysis tools is virtually universal. Furthermore, heat 
transfer often appears together with, or as a result of, other physical phenomena. 

The modeling of heat transfer effects has become increasingly important in product 
design including areas such as electronics, automotive, and medical industries. 
Computer simulation has allowed engineers and researchers to optimize process 
efficiency and explore new designs, while at the same time reducing the need for costly 
experimental trials.

The Physics Interfaces and Building a COMSOL Multiphysics Model in 
the COMSOL Multiphysics Reference Manual.
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How the Heat Transfer Module Improves Your Modeling

The Heat Transfer Module has been developed to greatly expand upon the base 
capabilities available in COMSOL Multiphysics. The module supports all fundamental 
mechanisms including conductive, convective, and radiative heat transfer. Using the 
physics interfaces in this module along with the inherent multiphysics capabilities of 
COMSOL Multiphysics, you can model a temperature field in parallel with other 
physics — a versatile combination increasing the accuracy and predicting power of your 
models.

This book introduces the basic modeling process. The different physics interfaces are 
described and the modeling strategy for various cases is discussed. These sections cover 
different combinations of conductive, convective, and radiative heat transfer. This 
guide also reviews special modeling techniques for thin layers, thin shells, participating 
media, and out-of-plane heat transfer. Throughout the guide the topics and examples 
increase in complexity by combining several heat transfer mechanisms and also by 
coupling these to physics interfaces describing fluid flow — conjugate heat transfer.

Another source of information is the Heat Transfer Module Applications Libraries, a 
set of fully-documented examples that is divided into broadly defined application areas 
where heat transfer plays an important role — electronics and power systems, 
processing and manufacturing, and medical technology — and includes tutorial and 
verification models. 

Most of the examples involve multiple heat transfer mechanisms and are often coupled 
to other physical phenomena, for example, fluid dynamics, moisture transport, or 
electromagnetics. The authors developed several state-of-the art examples by 
reproducing examples that have appeared in international scientific journals. See 
Where Do I Access the Documentation and Application Libraries?.

The Heat Transfer Module Physics Interface Guide

The table below lists all the physics interfaces specifically available with this module. 
Having this module also enhances these COMSOL Multiphysics basic interfaces: Heat 
Transfer in Fluids, Heat Transfer in Solids, Joule Heating, and the Single-Phase Flow, 
Laminar interface.
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If you have a Subsurface Flow Module combined with the Heat Transfer Module, this 
module also enhances the Heat Transfer in Porous Media interface.  

The Nonisothermal Flow, Laminar Flow (nitf) and Nonisothermal Flow, 
Turbulent Flow (nitf) interfaces found under the Fluid 

Flow>Nonisothermal Flow branch are identical to the Conjugate Heat 
Transfer interfaces (Laminar Flow and Turbulent Flow) found under the 
Heat Transfer>Conjugate Heat Transfer branch. The difference is that Fluid 
is the default domain node for the Nonisothermal Flow interfaces.

In the COMSOL Multiphysics Reference Manual:

• Studies and Solvers

• The Physics Interfaces 

• For a list of all the core physics interfaces included with a COMSOL 
Multiphysics license, see Physics Interface Guide.

PHYSICS INTERFACE ICON TAG SPACE 
DIMENSION

AVAILABLE PRESET STUDY 
TYPE

 Chemical Species Transport

 Moisture Transport

Moisture Transport in 
Building Materials

mt all dimensions stationary; time dependent

Moisture Transport in 
Air

mt all dimensions stationary; time dependent

 Fluid Flow

 Single-Phase Flow

Laminar Flow(1) spf 3D, 2D, 2D 
axisymmetric

stationary; time dependent
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 Turbulent Flow

Turbulent Flow, 
Algebraic yPlus

spf 3D, 2D, 2D 
axisymmetric

stationary with 
initialization; transient with 
initialization

Turbulent Flow, L-VEL spf 3D, 2D, 2D 
axisymmetric

stationary with 
initialization; transient with 
initialization

Turbulent Flow, k-ε spf 3D, 2D, 2D 
axisymmetric

stationary; time dependent

Turbulent Flow, Low 
Re k-ε

spf 3D, 2D, 2D 
axisymmetric

stationary with 
initialization; transient with 
initialization

 Nonisothermal Flow

Laminar Flow(2) — 3D, 2D, 2D 
axisymmetric

stationary; time dependent

 Turbulent Flow

Turbulent Flow, 
Algebraic yPlus(2)

— 3D, 2D, 2D 
axisymmetric

stationary with 
initialization; transient with 
initialization

Turbulent Flow, 
L-VEL(2)

— 3D, 2D, 2D 
axisymmetric

stationary with 
initialization; transient with 
initialization

Turbulent Flow, k-ε(2) — 3D, 2D, 2D 
axisymmetric

stationary; time dependent

Turbulent Flow, Low 
Re k-ε(2)

— 3D, 2D, 2D 
axisymmetric

stationary with 
initialization; transient with 
initialization

 Heat Transfer

Heat Transfer in Solids(1) ht all dimensions stationary; time dependent; 
thermal perturbation, 
frequency domain

PHYSICS INTERFACE ICON TAG SPACE 
DIMENSION

AVAILABLE PRESET STUDY 
TYPE
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Heat Transfer in Fluids(1) ht all dimensions stationary; time dependent; 
thermal perturbation, 
frequency domain

Local Thermal 
Non-Equilibrium(2)

— all dimensions stationary; time dependent; 
thermal perturbation, 
frequency domain

Heat Transfer in Porous 
Media

ht all dimensions stationary; time dependent; 
thermal perturbation, 
frequency domain

Bioheat Transfer ht all dimensions stationary; time dependent; 
thermal perturbation, 
frequency domain

Thermoelectric Effect(2) — all dimensions stationary; time dependent; 
thermal perturbation, 
frequency domain

Heat and Moisture Transport

Building Materials(2) — all dimensions stationary; time dependent; 
thermal perturbation, 
frequency domain

Moist Air(2) — all dimensions stationary; time dependent; 
thermal perturbation, 
frequency domain

Thin Structures

Heat Transfer in Thin 
Shells

htsh 3D, 2D, 2D 
axisymmetric

stationary; time dependent; 
thermal perturbation, 
frequency domain

Heat Transfer in Thin 
Films

htsh 3D, 2D, 2D 
axisymmetric

stationary; time dependent; 
thermal perturbation, 
frequency domain

Heat Transfer in Fractures htsh 3D, 2D, 2D 
axisymmetric

stationary; time dependent; 
thermal perturbation, 
frequency domain

PHYSICS INTERFACE ICON TAG SPACE 
DIMENSION

AVAILABLE PRESET STUDY 
TYPE
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Conjugate Heat Transfer

Laminar Flow(2) — 3D, 2D, 2D 
axisymmetric

stationary; time dependent; 
stationary, one-way 
coupled, NITF; time 
dependent, one-way 
coupled, NITF; thermal 
perturbation, frequency 
domain

 Turbulent Flow

Turbulent Flow, 
Algebraic yPlus(2)

— 3D, 2D, 2D 
axisymmetric

stationary with 
initialization; transient with 
initialization; stationary, 
one-way coupled, NITF; 
time dependent, one-way 
coupled, NITF

Turbulent Flow, 
L-VEL(2)

— 3D, 2D, 2D 
axisymmetric

stationary with 
initialization; transient with 
initialization; stationary, 
one-way coupled, NITF; 
time dependent, one-way 
coupled, NITF

Turbulent Flow, k-ε(2)  — 3D, 2D, 2D 
axisymmetric

stationary; time dependent; 
stationary, one-way 
coupled, NITF; time 
dependent, one-way 
coupled, NITF; thermal 
perturbation, frequency 
domain

Turbulent Flow, Low 
Re k-ε(2)

 — 3D, 2D, 2D 
axisymmetric

stationary with 
initialization; transient with 
initialization; stationary, 
one-way coupled, NITF; 
time dependent, one-way 
coupled, NITF

PHYSICS INTERFACE ICON TAG SPACE 
DIMENSION

AVAILABLE PRESET STUDY 
TYPE
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Common Physics Interface and Feature Settings and Nodes

There are several common settings and sections available for the physics interfaces and 
feature nodes. Some of these sections also have similar settings or are implemented in 
the same way no matter the physics interface or feature being used. There are also some 
physics feature nodes that display in COMSOL Multiphysics.

 Radiation

Heat Transfer with 
Surface-to-Surface 
Radiation

ht all dimensions stationary; time dependent; 
thermal perturbation, 
frequency domain

Heat Transfer with 
Radiation in 
Participating Media

ht 3D, 2D stationary; time dependent; 
thermal perturbation, 
frequency domain

Surface-to-Surface 
Radiation

rad all dimensions stationary; time dependent

Radiation in 
Participating Media

rpm 3D, 2D stationary; time dependent

 Electromagnetic Heating

Joule Heating(1,2) — all dimensions stationary; time dependent; 
thermal perturbation, 
frequency domain

(1) This physics interface is included with the core COMSOL package but has added 
functionality for this module.
(2) This physics interface is a predefined multiphysics coupling that automatically adds all the 
physics interfaces and coupling features required.

PHYSICS INTERFACE ICON TAG SPACE 
DIMENSION

AVAILABLE PRESET STUDY 
TYPE
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In each module’s documentation, only unique or extra information is included; 
standard information and procedures are centralized in the COMSOL Multiphysics 
Reference Manual.

The Heat Transfer Module Study Capabilities

Table 1-1 lists the Preset Studies available for the physics interfaces most relevant to 
this module. 

In the COMSOL Multiphysics Reference Manual see Table 2-3 for 
links to common sections and Table 2-4 to common feature nodes. 
You can also search for information: press F1 to open the Help 
window or Ctrl+F1 to open the Documentation window. 

Studies and Solvers in the COMSOL Multiphysics Reference Manual

TABLE 1-1:  HEAT TRANSFER MODULE DEPENDENT VARIABLES AND PRESET STUDY AVAILABILITY
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FLUID FLOW>SINGLE-PHASE FLOW

Laminar Flow spf u, p √ √

Turbulent Flow, k-ε spf u, p, k, ep √ √

Turbulent Flow, Low Re k-ε spf u, p, k, ep, G √ √
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FLUID FLOW>NONISOTHERMAL FLOW

Laminar Flow(2,4) — u, p, T √ √

Turbulent Flow, k-ε(2,4) — u, p, k, ep, T √ √

Turbulent Flow, Low Re k-ε(2,4) — u, p, k, ep, G, T √ √
HEAT TRANSFER

Heat Transfer in Solids(2) ht T √ √ √

Heat Transfer in Fluids(2) ht T √ √ √

Heat Transfer in Porous Media(2) ht T √ √ √

Bioheat Transfer(2) ht T √ √ √

Thermoelectric Effect(4) — T √ √ √

HEAT TRANSFER>HEAT AND MOISTURE 

TRANSPORT

Building Materials — φ √ √

Moist Air — φ √ √
HEAT TRANSFER>THIN STRUCURES

Heat Transfer in Thin Shells(3) htsh T √ √ √

Heat Transfer in Thin Films(3) htsh T √ √ √

Heat Transfer in Fractures(3) htsh T √ √ √
HEAT TRANSFER>CONJUGATE HEAT TRANSFER

Laminar Flow(2,4) — u, p, T √ √

Turbulent Flow, k-ε(2,4) — u, p, k, ep, T √ √

Turbulent Flow, Low Re k-ε(2,4) — u, p, k, ep, G, T √ √

TABLE 1-1:  HEAT TRANSFER MODULE DEPENDENT VARIABLES AND PRESET STUDY AVAILABILITY
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Additional Materials Database

The Heat Transfer Module includes additional material databases:

• The Liquids and Gases material database provides temperature-dependent fluid 
dynamic and thermal properties (dynamic viscosity, heat capacity at constant 
pressure, density, and thermal conductivity).

• The Bioheat material database contains materials used with the Bioheat Transfer 
interface. In addition to thermal properties (heat capacity at constant pressure, 

HEAT TRANSFER>RADIATION

Heat Transfer with 
Surface-to-Surface Radiation(2)

ht T, J √ √ √

Heat Transfer with Radiation in 
Participating Media(2)

ht T, I (radiative 
intensity)

√ √ √

Surface-to-Surface Radiation rad J √ √

Radiation in Participating Media rpm I (radiative intensity) √ √
HEAT TRANSFER>ELECTROMAGNETIC HEATING

Joule Heating(2,4) — T, V √ √ √
1 Custom studies are also available based on the physics interface. 
2 For these physics interfaces, it is possible to enable surface to surface radiation and 
radiation in participating media. In these cases, J and I are dependent variables.
3 For these physics interfaces, it is possible to enable surface to surface radiation. In this 
case, J is a dependent variable.
4 Multiphysics interfaces

TABLE 1-1:  HEAT TRANSFER MODULE DEPENDENT VARIABLES AND PRESET STUDY AVAILABILITY
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density, and thermal conductivity), properties for thermal damage analysis of 
biological tissues are provided.

• The Building material database contains hygroscopic and thermal properties for 
materials used with the Moisture Transport interface.

Where Do I Access the Documentation and Application Libraries?

A number of Internet resources have more information about COMSOL, including 
licensing and technical information. The electronic documentation, topic-based (or 
context-based) help, and the application libraries are all accessed through the 
COMSOL Desktop.

T H E  D O C U M E N T A T I O N  A N D  O N L I N E  H E L P

The COMSOL Multiphysics Reference Manual describes the core physics interfaces 
and functionality included with the COMSOL Multiphysics license. This book also has 
instructions about how to use COMSOL and how to access the electronic 
Documentation and Help content.

Opening Topic-Based Help
The Help window is useful as it is connected to many of the features on the GUI. To 
learn more about a node in the Model Builder, or a window on the Desktop, click to 
highlight a node or window, then press F1 to open the Help window, which then 

For detailed information, see Liquids and Gases Materials Database, 
Bioheat Materials Database, Building Materials Database, and Materials 
in the COMSOL Multiphysics Reference Manual.

If you are reading the documentation as a PDF file on your computer, 
the blue links do not work to open an application or content 
referenced in a different guide. However, if you are using the Help 
system in COMSOL Multiphysics, these links work to open other 
modules, application examples, and documentation sets.
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displays information about that feature (or click a node in the Model Builder followed 
by the Help button ( ). This is called topic-based (or context) help.

Opening the Documentation Window

To open the Help window:

• In the Model Builder, Application Builder, or Physics Builder click a node or 
window and then press F1. 

• On any toolbar (for example, Home, Definitions, or Geometry), hover the 
mouse over a button (for example, Add Physics or Build All) and then 
press F1.

• From the File menu, click Help ( ).

• In the upper-right corner of the COMSOL Desktop, click the Help ( ) 
button.

To open the Help window:

• In the Model Builder or Physics Builder click a node or window and then 
press F1.

• On the main toolbar, click the Help ( ) button.

• From the main menu, select Help>Help.

To open the Documentation window:

• Press Ctrl+F1.

• From the File menu select Help>Documentation ( ).

To open the Documentation window:

• Press Ctrl+F1.

• On the main toolbar, click the Documentation ( ) button.

• From the main menu, select Help>Documentation.
A B O U T  T H E  H E A T  TR A N S F E R  M O D U L E  |  29
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T H E  A P P L I C A T I O N  L I B R A R I E S  W I N D O W

Each application includes documentation with the theoretical background and 
step-by-step instructions to create a model application. The applications are available 
in COMSOL as MPH-files that you can open for further investigation. You can use the 
step-by-step instructions and the actual applications as a template for your own 
modeling and applications. In most models, SI units are used to describe the relevant 
properties, parameters, and dimensions in most examples, but other unit systems are 
available.

Once the Application Libraries window is opened, you can search by name or browse 
under a module folder name. Click to view a summary of the application and its 
properties, including options to open it or a PDF document. 

Opening the Application Libraries Window
To open the Application Libraries window ( ):

C O N T A C T I N G  C O M S O L  B Y  E M A I L

For general product information, contact COMSOL at info@comsol.com.

To receive technical support from COMSOL for the COMSOL products, please 
contact your local COMSOL representative or send your questions to 

The Application Libraries Window in the COMSOL Multiphysics 
Reference Manual.

• From the Home toolbar, Windows menu, click ( ) Applications 

Libraries.

• From the File menu select Application Libraries.

To include the latest versions of model examples, from the File>Help 
menu, select ( ) Update COMSOL Application Library.

Select Application Libraries from the main File> or Windows> menus.

To include the latest versions of model examples, from the Help menu 
select ( ) Update COMSOL Application Library.
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support@comsol.com. An automatic notification and case number is sent to you by 
email.

C O M S O L  WE B S I T E S

COMSOL website www.comsol.com

Contact COMSOL www.comsol.com/contact

Support Center www.comsol.com/support

Product Download www.comsol.com/product-download

Product Updates www.comsol.com/support/updates

Discussion Forum www.comsol.com/community

Events www.comsol.com/events

COMSOL Video Gallery www.comsol.com/video

Support Knowledge Base www.comsol.com/support/knowledgebase
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Ove r v i ew o f  t h e  U s e r ’ s  Gu i d e

This Heat Transfer Module User’s Guide gets you started with modeling heat transfer 
using COMSOL Multiphysics. The information in this guide is specific to this module. 
Instructions on how to use COMSOL in general are included with the COMSOL 
Multiphysics Reference Manual. 

TA B L E  O F  C O N T E N T S ,  N O TAT I O N S  A N D  I N D E X

To help you navigate through this guide, see the Contents, Notations, and Index.

M O D E L I N G  W I T H  T H E  H E A T  TR A N S F E R  M O D U L E

The Modeling with the Heat Transfer Module chapter includes the following topics:

• Heat Transfer Variables

• Moisture Transport Variables

• Using the Boundary Conditions for the Heat Transfer Interfaces

• Handling Frames in Heat Transfer

• Heat Transfer Consistent and Inconsistent Stabilization Methods

• Heat Transfer and Fluid Flow Coupling 

• Boundary Wall Temperature

• Solver Settings

• Plotting Results in Thin Layers Extra Dimensions

• Using Ambient Data

• Modeling Heat Transfer by Radiation

• Heat Part Library

T H E O R Y  F O R  T H E  H E A T  TR A N S F E R  M O D U L E

The Theory for the Heat Transfer Module chapter includes the theory related to the 
heat transfer and moisture transport interfaces and multiphysics interfaces, and also to 
some nodes.

As detailed in the section Where Do I Access the Documentation and 
Application Libraries? this information can also be searched from the 
COMSOL Multiphysics Help menu in the COMSOL Desktop. 
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After the establishment of the heat balance equation from the energy conservation laws 
in Foundations of the General Heat Transfer Equation, the various versions of the heat 
equation solved in COMSOL Multiphysics are presented in the following sections:

• Theory for Heat Transfer in Solids

• Theory for Heat Transfer in Fluids

• Theory for Bioheat Transfer

• Theory for Heat Transfer in Porous Media

• Theory for Heat Transfer with Phase Change

• Theory for Heat Transfer in Building Materials

• Theory for Lumped Isothermal Domain

• Theory for Heat Transfer in Thin Structures

• Theory for Surface-to-Surface Radiation

• Theory for Radiation in Participating Media

• Theory for Moisture Transport

Then the theory related to multiphysics interfaces is described in Theory for the Heat 
Transfer Multiphysics Couplings.

Finally, topics related to specific features or variables are treated in Theory for Thermal 
Contact, Moist Air Fluid Type, Out-of-Plane Heat Transfer, The Heat Transfer 
Coefficients, Equivalent Thermal Conductivity Correlations, Temperature 
Dependence of Surface Tension, Heat Flux and Heat Balance, and Frames for the Heat 
Transfer Equations.

T H E  H E A T  TR A N S F E R  M O D U L E  I N T E R F A C E S

The Heat Transfer Module Interfaces chapter describes the main Heat Transfer 
interface (ht) that forms the backbone for all the fundamental interfaces in this 
module, and the other interfaces (Heat Transfer in Thin Shells (htsh), Radiation in 
Participating Media (rpm), Surface-to-Surface Radiation (rad), and Moisture 
Transport (mt)). 

The Heat Transfer in Solids Interface, The Heat Transfer in Fluids Interface, and The 
Heat Transfer Interface discuss modeling heat transfer in solids and fluids.

The Heat Transfer in Porous Media Interface section discusses modeling heat transfer 
in porous media.
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The particular case of heat transfer in moist air and building materials is considered in 
The Heat Transfer in Moist Air Interface and The Heat Transfer in Building Materials 
Interface sections.

The Bioheat Transfer Interface section discusses modeling heat transfer within 
biological tissue using the Bioheat Transfer interface.

The Heat Transfer in Thin Shells Interface, The Heat Transfer in Thin Films Interface, 
and The Heat Transfer in Fractures Interface sections describe the physics interfaces 
which are suitable for solving thermal conduction, convection, and radiation problems 
in thin structures.

The The Heat Transfer with Surface-to-Surface Radiation Interface, The Heat 
Transfer with Radiation in Participating Media Interface, The Surface-To-Surface 
Radiation Interface, and The Radiation in Participating Media Interface sections 
discuss the modeling of radiative heat transfer in transparent and participating media.

Finally, The Moisture Transport in Building Materials Interface and the The Moisture 
Transport in Air Interface sections describe the modeling of moisture transfer in a 
porous medium through moisture storage, vapor diffusion and capillary moisture 
flows; or in air, through convection and diffusion.

T H E  H E A T  TR A N S F E R  F E A T U R E S

The Heat Transfer Features chapter describes the Domain Features, Boundary 
Features, Edge Features, Point Features, and Global Features available with the Heat 
Transfer interfaces.

T H E  M O I S T U R E  TR A N S P O R T  F E A T U R E S

The Moisture Transport Features chapter describes the Domain Features and 
Boundary Features available with the Moisture Transport interface.

T H E  H E A T  TR A N S F E R  M U L T I P H Y S I C S  I N T E R F A C E S

The Multiphysics Interfaces chapter describes the predefined multiphysics interfaces.

The Thermoelectric Effect Interface section describes the predefined multiphysics 
interface used to model the Peltier-Seebeck-Thomson effect.

The Nonisothermal Flow and Conjugate Heat Transfer Interfaces chapter describes 
the multiphysics versions of both the Nonisothermal Flow Laminar Flow and 
Turbulent Flow interfaces found under the Fluid Flow branch, which are identical to 
the Conjugate Heat Transfer interfaces. Each section describes the applicable physics 
interfaces in detail and concludes with the underlying theory.
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The Local Thermal Non-Equilibrium Interface section describes the predefined 
multiphysics interface used to model heat transfer in porous media when there is no 
thermal equilibrium between porous and fluid phases.

The Heat and Moisture Transport Interfaces section describes the predefined 
multiphysics interfaces used to model coupled heat and moisture transport either in 
building materials, by taking into account heat and moisture storage, latent heat 
effects, and liquid and convective transport of moisture; or in moist air by convection 
and diffusion of moisture and heat.

T H E  H E A T  TR A N S F E R  M U L T I P H Y S I C S  C O U P L I N G S

The Multiphysics Couplings chapter describes the Domain Multiphysics Couplings 
and the Boundary Multiphysics Couplings available with the predefined multiphysics 
interfaces.
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 2
N o t a t i o n s
This section introduces the notations used in the remaining of the guide. The 
notations are listed by alphabetical order and grouped in two tables, for Latin and 
Greek symbols.

For each entry the SI unit and a short description are given.
 37
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L A T I N  S Y M B O L S

NOTATION SI UNIT DESCRIPTION

A 1/s Frequency factor, damage integral analysis

A m2 Total boundaries area

a1,..., a12 dimensionless Legendre coefficients

Ac m2 Cross sectional area of domain

Al m2 Cross sectional area of thin rod

asf 1/m Specific surface area

Bi m Spectral band i

b dimensionless Thermal conductivity supplement

c mol/m3 Concentration

c kg/m3 Concentration

cl mol/m2 Liquid water concentration on moist surface

Cp, b J/(kg·K) Specific heat capacity at constant pressure, blood

Cp, l J/(kg·K) Specific heat capacity at constant pressure of thin rod

Cμ dimensionless Turbulence modeling constant

Cp J/(kg·K) Specific heat capacity at constant pressure

Cp, a J/(kg·K) Specific heat capacity at constant pressure, dry air

Cp, d J/(kg·K) Specific heat capacity at constant pressure, damaged tissue

Cp, f J/(kg·K) Specific heat capacity at constant pressure, fluid phase

Cp, fr J/(kg·K) Specific heat capacity at constant pressure of solid material in 
fracture

Cp, g J/(kg·K) Specific heat capacity at constant pressure of immobile fluid 
in porous media

Cp, gi J/(kg·K) Specific heat capacity at constant pressure of immobile fluid i 
in porous media

Cp, m kg/m3 Mixture specific heat capacity at constant pressure (moist air)

Cp, p J/(kg·K) Specific heat capacity at constant pressure of solid material in 
porous media

Cp, pi J/(kg·K) Specific heat capacity at constant pressure of solid material i 
in porous media

Cp, s J/(kg·K) Specific heat capacity at constant pressure, solid phase

Cp, s J/(kg·K) Specific heat capacity at constant pressure of dry solid

Cp, v J/(kg·K) Specific heat capacity at constant pressure, water vapor 
 2 :  N O T A T I O N S



Cp, s J/(kg·K) Specific heat capacity at constant pressure of thin layer

csat mol/m3 Saturation concentration of water vapor

Cp, si J/(kg·K) Specific heat capacity at constant pressure of layer i in thin 
layer

Cp, w J/(kg·K) Specific heat capacity at constant pressure of water

cv mol/m3 Water vapor concentration

d m Average particle diameter

D m Cylinder diameter (heat transfer coefficient)

D m Cylinder or sphere diameter (heat transfer coefficient)

D W/(m·K) Dispersion tensor

D m Parallel-plate gap average gas particle diameter

D 1/s Strain-rate tensor

D m2/s Vapor diffusion coefficient in air

Da dimensionless Darcy number

ΔE J/mol Activation energy, damage integral analysis

df m Thickness of thin film

dfr m Thickness of fracture

DP1 m2/s P1 method diffusion coefficient

ds m Thickness of shell or thin layer

dsi m Thickness of layer i in thin layer

Dw m2/s Moisture diffusivity

dz m Thickness of domain in the out-of-plane direction

DPTamb K Ambient dew point temperature

e m Beam orientation

E J/kg Internal energy

E Pa Young’s modulus

E0 J/kg Total internal energy

EΩ J Internal energy of a body

eb, λ(λ, T) W/m2 Blackbody spectral emissive power

eb(T) W/m2 Blackbody total emissive power

Econtact Pa Effective contact interface Young’s modulus

Ed Pa Young’s modulus, down contact surface

NOTATION SI UNIT DESCRIPTION
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Ek J/kg Kinetic energy

ep m2/s3 Turbulent dissipation rate

Ep J/kg Potential energy

Eu Pa Young’s modulus, up contact surface

etot W/m2 Total energy flux

F N/m3 Body force vector

F dimensionless Deformation gradient tensor

Famb dimensionless Ambient view factor

Famb, d dimensionless Ambient view factor, downside

Famb, u dimensionless Ambient view factor, upside

g m/s2 Acceleration of gravity

gevap kg/(m2·s) Evaporation flux

G W/m3 Moisture source

G 1/m Reciprocal wall distance

G W/m2 Surface irradiation

Gamb W/m2 Ambient irradiation

Gamb, d W/m2 Ambient irradiation, downside

Gamb, u W/m2 Ambient irradiation, upside

Gd W/m2 Surface irradiation, downside

Gext W/m2 External irradiation

Gext, d W/m2 External irradiation, downside

Gext, u W/m2 External irradiation, upside

Gm W/m2 Mutual surface irradiation

Gm, d W/m2 Mutual surface irradiation, downside

Gm, u W/m2 Mutual surface irradiation, upside

GrL dimensionless Grashof number associated with characteristic length L

Gu W/m2 Surface irradiation, upside

H m Chimney height (heat transfer coefficient)

H J/kg Enthalpy

h W/(m2·K) Gap conductance (thermal contact)

h W/(m2·K) Heat transfer coefficient

H0 J/kg Total enthalpy

NOTATION SI UNIT DESCRIPTION
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HB Pa Brinell hardness

hc W/(m2·K) Constriction conductance

Hc Pa Microhardness

hd W/(m2·K) Out-of-plane heat transfer coefficient, downside

Hd J/kg Enthalpy, downside

Hext J/kg External enthalpy

hg W/(m2·K) Parallel-plate gap gas conductance

hr W/(m2·K) Radiative conductance

Href J/kg Reference enthalpy

hsf W/(m2·K) Interstitial heat transfer coefficient

hth W/K Thermal conductance (isothermal domain interface)

hu W/(m2·K) Out-of-plane heat transfer coefficient, upside

Hu J/kg Enthalpy, upside

hz W/(m2·K) Out-of-plane heat transfer coefficient, 1D

I(Ω) W/(m2·sr) Radiative intensity traveling in direction Ω

Ib(T) W/(m2·sr) Blackbody radiative intensity

Idiff W/m2 Diffuse irradiance

Iext W/(m2·sr) Incident radiative intensity

Ii W/(m2·sr) Radiative intensity traveling in ith discrete direction

is dimensionless Incident radiation direction (external radiation source)

Is W/m2 Solar irradiance

Is,amb W/m2 Ambient solar irradiance

Ish,amb W/m2 Clear sky noon diffuse horizontal irradiance

Isn,amb W/m2 Clear sky noon beam normal irradiance

isx, isy, 
isz

dimensionless Solar source direction vector components

Iwall W/(m2·sr) Boundary radiative intensity

J W/m2 Surface radiosity

Jd W/m2 Surface radiosity, downside

Ju W/m2 Surface radiosity, upside

k W/(m·K) Thermal conductivity

k J/kg Turbulent kinetic energy (turbulent nonisothermal flow)

NOTATION SI UNIT DESCRIPTION
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ka W/(m·K) Dry air thermal conductivity

kB J/K Stefan-Boltzmann constant

kbnd W/(m·K) Thermal conductivity in shell local coordinate system

kcontact W/(m·K) Harmonic mean of contacting surface conductivities

kd W/(m·K) Thermal conductivity, damaged tissue

kdisp W/(m·K) Dispersive thermal conductivity tensor

keff W/(m·K) Effective thermal conductivity

kf W/(m·K) Thermal conductivity, fluid phase

kfr W/(m·K) Thermal conductivity of solid material in fracture

kg W/(m·K) Thermal conductivity of immobile fluid in porous media

kgap W/(m·K) Parallel-plate gap gas thermal conductivity 

kgi W/(m·K) Thermal conductivity of immobile fluid i in porous media

kl W/(m·K) Thermal conductivity of thin rod

kL W/(m·K) Thermal conductivity of mobile fluid in porous media

kp W/(m·K) Thermal conductivity of solid material in porous media

kpi W/(m·K) Thermal conductivity of solid material i in porous media

kR W/(m·K) Rosseland radiative conductivity

ks W/(m·K) Thermal conductivity of thin layer

ks W/(m·K) Thermal conductivity, solid phase

ks W/(m·K) Thermal conductivity of dry solid

ksi W/(m·K) Thermal conductivity of layer i in thin layer

kT W/(m·K) Turbulent thermal conductivity

kv W/(m·K) Water vapor thermal conductivity

K m/s Evaporation rate

KΩ J Kinetic energy of a body

L J/kg Latent heat

L m Total edge length

L m Wall height or plate diameter, distance or length (heat 
transfer coefficient)

Ld, c J/kg Damage enthalpy change, cryogenic analysis

Ld, h J/kg Damage enthalpy change, hyperthermia analysis

Lit, c J/kg Transformation enthalpy change, overcooling analysis

NOTATION SI UNIT DESCRIPTION
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Lit, h J/kg Transformation enthalpy change, overheating analysis

Lv J/kg Latent heat of evaporation

m kg Mass

ma kg Dry air mass

Ma kg/mol Dry air molar mass

masp m Asperities average slope (surface roughness)

Mg m Parallel-plate gap gas parameter

Mn kg/mol Mean molar mass

mtot kg Total mass (moist air)

mv kg Water vapor mass

Mv kg/mol Water vapor molar mass

n dimensionless Refractive index, transparent media

n dimensionless Normal vector toward exterior

na mol Amount of dry air

nr dimensionless Refractive index, participating media

ntot mol Amount of moist air

Nu dimensionless Nusselt number

NuL dimensionless Nusselt number associated with characteristic length L

nv mol Amount of water vapor

O m Beam origin point

p Pa Contact pressure, pressure

P N/m2 First Piola-Kirchhoff stress tensor

P V Peltier coefficient

P0 W Heat rate

pa Pa Dry air partial pressure

pA Pa Absolute pressure

Pb W Heat rate, boundary heat source

Pc m Cross sectional perimeter of domain 

pext Pa External absolute pressure

Pext W Power of applied forces

pgap Pa Parallel-plate gap gas pressure

Pindex dimensionless Performance index of the discrete ordinates method

NOTATION SI UNIT DESCRIPTION
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Pl W Heat rate, line heat source, deposited beam power

Pr dimensionless Prandtl number

pamb Pa Ambient absolute pressure

pref Pa Reference pressure

PrT dimensionless Turbulent Prandtl number

Ps W Heat rate, layer heat source

Ps W Source power (external radiation source)

psat Pa Saturation pressure of water vapor

Pstr W Stress power

pv Pa Water vapor partial pressure

q W/m2 Conductive heat flux

qf W/m2 Conductive heat flux in fluid phase

qs W/m2 Conductive heat flux in solid phase

Q W/m3 Heat source

q0 W/m2 Inward heat flux

Q0 W/m3 Distributed heat source

q0, d W/m2 Out-of-plane heat flux, downside

q0, s W/m2 Source heat flux (external radiation source)

q0, u W/m2 Out-of-plane heat flux, upside

Qb W/m2 Boundary heat source

Qb, tot W/m2 Total boundary heat source

Qe W/m3 Electromagnetic heat source

qevap W/m2 Latent heat source

Qexch W Exchanged heat source rate

Qf W/m3 Heat source in fluid phase

qgeo W/kg Radiogenic heating per mass

Qgeo W/m3 Geothermal heat source

QInt W Total heat source over interior boundaries

Qit W/m3 Irreversible transformation heat source

Ql W/m Line heat source

Qmet W/m3 Metabolic heat source

Qp W Point heat source

NOTATION SI UNIT DESCRIPTION
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Qp W/m3 Pressure work

Qr W/m3 Radiative heat source term

qr W/m2 Radiative heat flux

qr, net W/m2 Net radiative heat flux

qr, out W/m2 Radiative heat flux striking the wall

qs W/(m3·K) Production/absorption coefficient

Qs W/m3 Heat source in solid phase

Qs W/m3 Thin layer heat source

qsf W/(m3·K) Interstitial convective heat transfer coefficient

Qsi W/m3 Layer i heat source

Qted W/m3 Thermoelastic damping

qtot W/m2 Total heat flux

Qtot W/m3 Total domain heat source

Qvd W/m3 Viscous dissipation

r m Distance of the irradiated surface from the source

r dimensionless Heat partition coefficient (thermal friction)

R m Heat source radius, beam radius

R J/(mol·K) Universal gas constant

Ra dimensionless Rayleigh number

RaD dimensionless Rayleigh number associated with cylinder diameter D

RaL dimensionless Rayleigh number associated with characteristic length L

Reinf dimensionless Reynolds number at infinity

ReL dimensionless Reynolds number associated with characteristic length L

Rep dimensionless Particle Reynolds number

rh m Hydraulic radius

rl m Rod radius

rp m Average pellet radius

Rs J/(kg·K) Specific gas constant

Rt K·m2/W Thermal resistance

Rt, th K/W Absolute thermal resistance

sd m Vapor diffusion equivalent air layer thickness

S N/m2 Second Piola-Kirchhoff stress tensor

NOTATION SI UNIT DESCRIPTION
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S V/K Seebeck coefficient

Si dimensionless Unit vector of discrete direction in space, i-th component 
(angular space discretization)

Sp dimensionless Sparrow number

T K Temperature

T0 K Equilibrium temperature

T’ K Complex amplitude of harmonic perturbation

T+ dimensionless Dimensionless temperature

Tamb K Ambient temperature

Tamb, d K Ambient temperature, downside

Tamb, u K Ambient temperature, upside

Tb K Arterial blood temperature

Td K Temperature, downside

td, c s Damage time, cryogenic analysis

Td, c K Damage temperature, cryogenic analysis

td, h s Damage time, hyperthermia analysis

Td, h K Damage temperature, hyperthermia analysis

Text K External temperature

Text, d K Out-of-plane external temperature, downside

Text, u K Out-of-plane external temperature, upside

Text, z K Out-of-plane external temperature, 1D

Tf K Temperature, fluid phase

tit, c Transformation time, overcooling analysis

Tit, c Transformation temperature, overcooling analysis

tit, h Transformation time, overheating analysis

Tit, h Transformation temperature, overheating analysis

Tn, c K Temperature of necrosis, cryogenic

Tn, h K Temperature of necrosis, hyperthermia

Tpc K Phase change temperature

Tref K Reference temperature

Tref K Strain reference temperature

Ts K Temperature, solid phase

NOTATION SI UNIT DESCRIPTION
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G R E E K  S Y M B O L S

Tu K Temperature, upside

Tw K Wall temperature 

u m/s Fluid velocity vector

u, v, w m/s Fluid velocity vector’s components

uf m/s Average linear velocity

up m/s Porous velocity field

utrans m/s Translational motion velocity vector

vamb m/s Wind velocity

V V Electric potential

V m3 Total domain volume

W W/m3 Work source

w kg/m3 Moisture storage function

WInt W Work from custom volume forces

Wdiss W Dissipative work from momentum equation

Xa dimensionless Molar fraction of dry air

xpl m Position along the plate (heat transfer coefficient)

xs m Source location (external radiation source)

Xv dimensionless Molar fraction of water vapor

xvap dimensionless Moisture content

xvap,amb dimensionless Ambient moisture content

Y m Parallel-plate gap mean separation thickness

NOTATION SI UNIT DESCRIPTION

NOTATION SI UNIT DESCRIPTION

(ρCp)eff J/(m3·K) Effective volumetric heat capacity at constant pressure

∂Ω - Geometry domain’s boundaries

∂Ωext - Geometry domain’s exterior boundaries

∂Ωint - Geometry domain’s interior boundaries

∇t - Tangential gradient operator

α 1/K Coefficient of thermal expansion tensor in a solid

α dimensionless Degree of tissue injury (Arrhenius equation)
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α dimensionless Irreversible transformation indicator (Arrhenius equation)

α dimensionless Parallel-plate gap gas thermal accommodation parameter 

α dimensionless Surface absorptivity

α m2/s Thermal diffusivity

α1 dimensionless Damaged tissue indicator

α2 dimensionless Necrosis time indicator

αm dimensionless Vapor mass fraction

αp 1/K Coefficient of thermal expansion in a fluid

β 1/m Extinction coefficient

β s/m Moisture transfer coefficient

β dimensionless Parallel-plate gap gas property parameter

βR 1/m Rosseland mean extinction coefficient

γ dimensionless Ratio of specific heats

γTeq Pa/K Psychrometer constant

ΔR m Size of transition zone (deposited beam power)

ΔT K Temperature offset for periodic condition

ΔT0 K Temperature perturbation

δ s Vapor permeability of still air

δp s Vapor permeability

δw m Distance between the computational fluid domain and the 
wall

ε dimensionless Surface emissivity

εd dimensionless Surface emissivity, downside

ελ dimensionless Surface spectral emissivity

εu dimensionless Surface emissivity, upside

εz dimensionless Surface emissivity, 1D out-of-plane radiation

θ rad Angle between the normal to the irradiated surface and the 
direction of the source

θd dimensionless Volume fraction of necrotic tissue

θfr dimensionless Volume fraction of solid material in fracture

θg dimensionless Volume fraction of immobile fluid in porous media

θgi dimensionless Volume fraction of immobile fluid i in porous media

θit dimensionless Fraction of transformation

NOTATION SI UNIT DESCRIPTION
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θL dimensionless Volume fraction of mobile fluid in porous media

θp dimensionless Volume fraction of solid material in porous media

θpi dimensionless Volume fraction of solid material i in porous media

θs rad Zenith angle of the Sun

κ 1/m Absorption coefficient (radiation)

κ m2 Permeability (porous media)

λ W/(m·K) Thermal conductivity (turbulent nonisothermal flow)

λ m Wavelength

Λ m Parallel-plate gap gas mean free path

λi m Wavelength band i endpoint

λijkl m Fourth-order dispersivity tensor’s component

λlo m Longitudinal dispersivity

λtr m Transverse dispersivity

λtr, h m Transverse horizontal dispersivity

λtr, v m Transverse vertical dispersivity

μ Pa·s Dynamic viscosity

μ dimensionless Vapor resistance factor

μ0 dimensionless Scattering angle

μa Pa·s Dry air dynamic viscosity

μf Pa·s Dynamic viscosity

μm Pa·s Mixture dynamic viscosity (moist air)

μT Pa·s Turbulent dynamic viscosity 

μTh V/K Thomson coefficient

μv Pa·s Water vapor dynamic viscosity

ν dimensionless Poisson ratio

νd dimensionless Poisson ratio, down contact surface

νu dimensionless Poisson ratio, up contact surface

ρ kg/m3 Density

ρ dimensionless Surface reflectivity

ρb kg/m3 Density, blood

ρd kg/m3 Density, damaged tissue

ρf kg/m3 Density, fluid phase

NOTATION SI UNIT DESCRIPTION
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ρfr kg/m3 Density of solid material in fracture

ρg kg/m3 Density of immobile fluid in porous media

ρgeo kg/m3 Geothermal density

ρgi kg/m3 Density of immobile fluid i in porous media

ρl kg/m3 Density of thin rod

ρm kg/m3 Mixture density (moist air)

ρp kg/m3 Density of solid material in porous media

ρpi kg/m3 Density of solid material i in porous media

ρs kg/m3 Density of thin layer

ρs kg/m3 Density, solid phase

ρs kg/m3 Density of dry solid

ρsi kg/m3 Density of layer i in thin layer

σ Pa Cauchy stress tensor

σ m Standard deviation (deposited beam power)

σ W/(m2·K4) Stefan-Boltzmann constant

σ N/m Surface tension coefficient

σasp m Asperities average height (surface roughness)

σs 1/m Scattering coefficient

τ dimensionless Optical thickness

τ Pa Viscous stress tensor

φ dimensionless Relative humidity

φamb dimensionless Ambient relative humidity

φ rad Tilt angle (heat transfer coefficient)

φext dimensionless External relative humidity

φd dimensionless Relative humidity, downside

φu dimensionless Relative humidity, upside

Φd → u kg/s Mass flow rate, positive direction

Φu → d kg/s Mass flow rate, negative direction

ϕ(Ω′, Ω) dimensionless Scattering phase function

ϕs rad Azimuth angle of the Sun

ϕd → u kg/(m2·s) Mass flux, positive direction

ϕu → d kg/(m2·s) Mass flux, negative direction

NOTATION SI UNIT DESCRIPTION
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Ψ J/kg Force potential

Ω dimensionless Unit vector of a direction in space

Ω - Geometry domain

ω dimensionless Specific humidity

ω rad/s Angular frequency

ωb 1/s Blood perfusion rate

ωi W/(m2·K) Discrete incident radiation vector, i-th component

ξ kg/m3 Moisture storage capacity

NOTATION SI UNIT DESCRIPTION
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 3
M o d e l i n g  w i t h  t h e  H e a t  T r a n s f e r  M o d u l e
A variety of modeling techniques are discussed in the following sections:

• Heat Transfer Variables

• Moisture Transport Variables

• Using the Boundary Conditions for the Heat Transfer Interfaces

• Handling Frames in Heat Transfer

• Heat Transfer Consistent and Inconsistent Stabilization Methods

• Heat Transfer and Fluid Flow Coupling

• Boundary Wall Temperature

• Solver Settings

• Plotting Results in Thin Layers Extra Dimensions

• Using Ambient Data

• Modeling Heat Transfer by Radiation

• Heat Part Library
 53
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Hea t  T r a n s f e r  V a r i a b l e s

In this section:

• Predefined Variables

• Global Variables

• Domain Fluxes

• Out-of-Plane Domain Fluxes

• Boundary Fluxes (Heat Transfer interface)

• Boundary fluxes (Heat Transfer in Thin Shells interface)

• Internal Boundary Heat Fluxes

• Domain Heat Sources

• Boundary Heat Sources

• Line and Point Heat Sources

• Ambient Variables

• Moist Air Variables

Predefined Variables

This section lists some predefined variables that are available to evaluate heat fluxes, 
sources, and integral quantities used in energy balance. All the variable names begin 
with the physics interface name (the prefix). By default the Heat Transfer interface 
prefix is ht, and the Heat Transfer in Thin Shells interface prefix is htsh. As an 
example, you can access the variable named tflux using ht.tflux (as long as the 
physics interface is named ht).

TABLE 3-1:  HEAT TRANSFER PREDEFINED VARIABLES

VARIABLE NAME GEOMETRIC ENTITY LEVEL

dEiInt Total Accumulated Heat Rate Global

ntfluxInt Total Net Heat Rate Global

QInt Total Heat Source Global

WnsInt Total Fluid Losses Global

dEi0Int Total Accumulated Energy Rate Global

ntefluxInt Total Net Energy Rate Global
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tflux Total Heat Flux (Heat Transfer 
interface)

Domains, boundaries

dflux Conductive Heat Flux (Heat 
Transfer interface)

Domains, boundaries

cflux Convective Heat Flux (Heat 
Transfer interface)

Domains, boundaries

turbflux Turbulent Heat Flux (Heat Transfer 
interface)

Domains, boundaries

trlflux Translational Heat Flux (Heat 
Transfer interface)

Domains, boundaries

teflux Total Energy Flux (Heat Transfer 
interface)

Domains, boundaries

not 
applicable

Radiative Heat Flux (Heat Transfer 
interface)

Domains

rflux_u

rflux_d

rflux_z

Radiative Out-of-Plane Heat Flux 
(Heat Transfer interface)

Out-of-plane domains (1D 
and 2D), boundaries

q0_u

q0_d

q0_z

Out-of-Plane Inward Heat Flux 
(Heat Transfer interface)

Out-of-plane domains (1D 
and 2D)

h Heat transfer coefficient (see The 
Heat Transfer Coefficients)

Exterior boundaries

ntflux Normal Total Heat Flux (Heat 
Transfer interface)

Boundaries

ndflux Normal Conductive Heat Flux 
(Heat Transfer interface)

Boundaries

ncflux Normal Convective Heat Flux (Heat 
Transfer interface)

Boundaries

ntrlflux Normal Translational Heat Flux 
(Heat Transfer interface)

Boundaries

nteflux Normal Total Energy Flux (Heat 
Transfer interface)

Boundaries

ndflux_u Internal Normal Conductive Heat 
Flux, Upside (Heat Transfer 
interface)

Interior boundaries

TABLE 3-1:  HEAT TRANSFER PREDEFINED VARIABLES

VARIABLE NAME GEOMETRIC ENTITY LEVEL
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ndflux_d Internal Normal Conductive Heat 
Flux, Downside (Heat Transfer 
interface)

Interior boundaries

ncflux_u Internal Normal Convective Heat 
Flux, Upside (Heat Transfer 
interface)

Interior boundaries

ncflux_d Internal Normal Convective Heat 
Flux, Downside (Heat Transfer 
interface)

Interior boundaries

ntrlflux_u Internal Normal Translational Heat 
Flux, Upside (Heat Transfer 
interface)

Interior boundaries

ntrlflux_d Internal Normal Translational Heat 
Flux, Downside (Heat Transfer 
interface)

Interior boundaries

ntflux_u Internal Normal Total Heat Flux, 
Upside (Heat Transfer interface)

Interior boundaries

ntflux_d Internal Normal Total Heat Flux, 
Downside (Heat Transfer interface)

Interior boundaries

nteflux_u Internal Normal Total Energy Flux, 
Upside (Heat Transfer interface)

Interior boundaries

nteflux_d Internal Normal Total Energy Flux, 
Downside (Heat Transfer interface)

Interior boundaries

tflux Total Heat Flux (Heat Transfer in 
Thin Shells interface)

Boundaries

dflux Conductive Heat Flux (Heat 
Transfer in Thin Shells interface)

Boundaries

cflux Convective Heat Flux (Heat 
Transfer in Thin Shells interface)

Boundaries

teflux Total Energy Flux (Heat Transfer in 
Thin Shells interface)

Boundaries

ttflux In-Plane Total Heat Flux (Heat 
Transfer in Thin Shells interface)

Exterior boundaries

tdflux In-Plane Conductive Heat Flux 
(Heat Transfer in Thin Shells 
interface)

Exterior boundaries

TABLE 3-1:  HEAT TRANSFER PREDEFINED VARIABLES

VARIABLE NAME GEOMETRIC ENTITY LEVEL
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tcflux In-Plane Convective Heat Flux 
(Heat Transfer in Thin Shells 
interface)

Exterior boundaries

tteflux In-Plane Total Energy Flux (Heat 
Transfer in Thin Shells interface)

Exterior boundaries

q0 Inward Heat Flux (Heat Transfer 
interface)

Boundaries

rflux Radiative Heat Flux (Heat Transfer 
interface)

Boundaries

Qtot Domain Heat Sources Domains

Qbtot Boundary Heat Sources Boundaries

Qltot Line heat source (Line and Point 
Heat Sources)

Edges, Points (2D, 2Daxi)

Qptot Point heat source (Line and Point 
Heat Sources)

Points

T_amb Ambient temperature Global

p_amb Ambient absolute pressure Global

v_amb Wind velocity Global

phi_amb Ambient relative humidity Global

Is_amb Ambient solar irradiance Global

Ish_amb Clear sky noon diffuse horizontal 
irradiance

Global

Isn_amb Clear sky noon beam normal 
irradiance

Global

xvap_amb Ambient moisture content Global

alpha Damage indicator (see Theory for 
Bioheat Transfer)

Domains

alpha1 Damage indicator (see Theory for 
Bioheat Transfer)

Domains

alpha2 Instant tissue necrosis indicator (see 
Theory for Bioheat Transfer)

Domains

theta_d Fraction of damage (see Theory for 
Bioheat Transfer)

Domains

theta_d_sm Fraction of total damage (see Theory 
for Bioheat Transfer)

Domains

TABLE 3-1:  HEAT TRANSFER PREDEFINED VARIABLES

VARIABLE NAME GEOMETRIC ENTITY LEVEL
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Global Variables

This section describes variables defined by integrals. A concise notation denotes the 
different domains of integration: Ω is the geometry domain, ∂Ωext stands for the 
exterior boundaries, and ∂Ωint for the interior boundaries.

TO T A L  A C C U M U L A T E D  H E A T  R A T E

The total accumulated heat rate variable, dEiInt, is the variation of internal energy per 
unit time in the domain:

TO T A L  N E T  H E A T  R A T E

The total net heat rate, ntfluxInt, is the integral of Total Heat Flux (Heat Transfer 
interface) over all external boundaries. In the case of a fluid domain, it reads:

This indicates the sum of incoming and outgoing total heat flux through the system. 

TO T A L  H E A T  S O U R C E

The total heat source, QInt, accounts for all domain sources, interior boundary, edge 
and point sources, and radiative sources at interior boundaries:

T_dp Dew Point Temperature Domains

T_eq Equivalent Temperature Domains

psat Saturation Pressure Domains

phi Relative Humidity Domains

Lv Latent Heat of Evaporation Domains

TABLE 3-1:  HEAT TRANSFER PREDEFINED VARIABLES

VARIABLE NAME GEOMETRIC ENTITY LEVEL

Some of these variables are only available with the Heat Transfer Module 
(rflux_u, rflux_d, rflux_z, q0_u, q0_d, and q0_z), or when either the 
CFD Module or the Heat Transfer Module is added (rflux and 
turbflux).

dEiInt
td

d ρEi ωd
Ω
=

ntfluxInt ρuEi k∇T– qr+( ) n σd⋅
Ωext∂
=
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TO T A L  F L U I D  L O S S E S

The total fluid losses, WnsInt, correspond to the work lost by a fluid by degradation 
of energy. These works are transmitted to the system through pressure work and 
viscous dissipation:

TO T A L  A C C U M U L A T E D  E N E R G Y  R A T E

The total accumulated energy rate, dEi0Int, is the variation of total internal energy 
per unit time in the domain:

where the total internal energy, Ei0, is defined as

TO T A L  N E T  E N E R G Y  R A T E

The total net energy rate, ntefluxInt, is the integral of Total Energy Flux (Heat 
Transfer interface) over all external boundaries. In the case of a fluid domain, it reads:

This indicates the sum of incoming and outgoing total energy flux through the system.

H E A T  B A L A N C E

According to Equation 4-145, the following equality between COMSOL Multiphysics 
variables holds:

dEiInt + ntfluxInt = QInt - WnsInt

This is the most general form that can be used for time-dependent models. At 
steady-state the formula is simplified. The accumulated heat rate equals zero, so the 
total net heat rate (the sum of incoming and outgoing heat rates) should correspond 
to the heat and work sources:

QInt Q ωd
Ω
 Qb ωd

Ω∂ int
 Qr ωd

Ω∂ int
+ +=

WnsInt u ∇p⋅ A( ) ωd
Ω
 τ– : u∇( ) ωd

Ω
+=

dEi0Int
td

d ρEi0 ωd
Ω
=

Ei0 Ei
u u⋅

2
------------+=

ntefluxInt ρuH0 k∇T– τu– qr+( ) n σd⋅
Ωext∂
=
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ntfluxInt = QInt - WnsInt

The sign convention used in COMSOL Multiphysics for QInt is positive when energy 
is produced (as for a heater) and negative when energy is consumed (as for a cooler). 
For WnsInt, the losses that heat up the system are positive and the gains that cool 
down the system are negative.

For stationary models with convection by an incompressible flow, the heat balance 
becomes:

ntfluxInt = QInt

which corresponds to the conservation of convective and conductive flux as in:

E N E R G Y  B A L A N C E

According to Equation 4-146, the following equality between COMSOL Multiphysics 
predefined variables holds:

dEi0Int + ntefluxInt = QInt

In stationary models, dEi0Int is zero so the energy balance simplifies into:

ntefluxInt = QInt

At steady state, and without any additional heat source (QInt equal to zero), the 
integral of the net energy flux on all boundaries of the flow domain, ntefluxInt, 
vanishes. On the other hand, the corresponding integral of the net heat flux does not, 
in general, vanish. It corresponds instead to the losses from mass and momentum 
equations, such as WnsInt for pressure work and viscous dissipation in fluids. Hence, 
energy is the conserved quantity, not heat.

ρuEi n σd⋅
Ωext∂
 k∇T n σd⋅

Ωext∂
– QInt=

Depending on the radiation discretization method chosen in Heat 

Transfer with Radiation in Participating Media, the contribution to the heat 
balance is handled differently. In the definition of ntfluxInt, the 
Rosseland approximation defines qr, the radiative flux, as an extra 
contribution to the conductive heat flux. The P1 approximation and 
Discrete ordinates method, however, include the radiative source ∇ ⋅ qr to 
Q on the domain, in the variable QInt.
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Domain Fluxes

On domains the fluxes are vector quantities. The definition can vary depending on the 
active physics nodes and selected properties.

TO T A L  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

On domains the total heat flux, tflux, corresponds to the conductive and convective 
heat flux. For accuracy reasons the radiative heat flux is not included.

For solid domains — for example, the solid and biological tissue domains — the total 
heat flux is defined as:

For fluid domains (for example, Fluid), the total heat flux is defined as:

C O N D U C T I V E  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

The conductive heat flux variable, dflux, is evaluated using the temperature gradient 
and the effective thermal conductivity:

In the general case keff is the thermal conductivity, k.

For heat transfer in fluids with turbulent flow, keff = k + kT, where kT is the turbulent 
thermal conductivity.

For heat transfer in porous media, keff is the effective conductivity computed from the 
solid and fluid conductivities.

For heat transfer in building materials, a latent heat source due to evaporation is 
included in the conductive heat flux variable:

See Radiative Heat Flux (Heat Transfer interface) to evaluate the radiative 
heat flux.

tflux trlflux dflux+=

tflux cflux dflux+=

dflux keff T∇–=

dflux keff∇T Lvδp φpsat( )∇+( )–=
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TU R B U L E N T  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

The turbulent heat flux variable, turbflux, enables access to the part of the 
conductive heat flux that is due to turbulence.

C O N V E C T I V E  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

The convective heat flux variable, cflux, is defined using the internal energy, Ei:

The internal energy, Ei, is defined as:

• Ei = H for solid domains

• Ei = H − p/ρ for fluid domains

where H is the enthalpy defined in Equation 4-5.

The convective heat flux may be oriented in the opposite direction of the velocity 
field’s direction, when the internal energy, Ei, has a negative value. This happens when 
the sensible enthalpy (variation from reference enthalpy Href) is negative. Href is set to 
0 J/kg at pref (1 atm) and Tref (298.15 K) in COMSOL Multiphysics. See 
Thermodynamic Description of Heat Transfer for details.

TR A N S L A T I O N A L  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

Similar to convective heat flux but defined for solid domains with translation. The 
variable name is trlflux.

TO T A L  E N E R G Y  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

The total energy flux, teflux, is defined when viscous dissipation is enabled:

where the total enthalpy, H0, is defined as

R A D I A T I V E  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

In participating media, the radiative heat flux, qr, is not available for analysis on 
domains because it is more accurate to evaluate the radiative heat source .

turbflux kT T∇–=

cflux ρuEi=

teflux ρuH0 dflux τu+ +=

H0 H u u⋅
2

------------+=

Qr ∇ qr⋅=
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Out-of-Plane Domain Fluxes

R A D I A T I V E  O U T - O F - P L A N E  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

The radiative out-of-plane heat flux, rflux, is generated by the Out-of-Plane 
Radiation feature.

• In 2D:

upside: 

downside: 

• In 1D:

O U T - O F - P L A N E  I N W A R D  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

The convective out-of-plane heat flux, q0, is generated by the Out-of-Plane Heat Flux 

feature.

• In 2D:

upside: 

downside: 

• In 1D:

Boundary Fluxes (Heat Transfer interface)

All the domain fluxes (vector quantity) computed by the Heat Transfer interface are 
also available as boundary fluxes. The boundary fluxes are then equal to the mean value 
of the fluxes on adjacent domains. In addition, normal boundary heat fluxes (scalar 
quantity) are available on boundaries.

N O R M A L  TO T A L  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

The variable ntflux is defined as:

rflux_u εuσ T
amb u,
4 T4

–( )=

rflux_d εdσ T
amb d,
4 T4

–( )=

rflux_z εzσ Tamb z,
4 T4

–( )=

q0_u hu T
ext u, T–( )=

q0_d hd T
ext d, T–( )=

q0_z hz Text z, T–( )=
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N O R M A L  C O N D U C T I V E  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

The variable ndflux is defined on exterior boundaries as:

• ndflux = −dflux_spatial(T) if the adjacent domain is on the downside,

• ndflux = −uflux_spatial(T) if the adjacent domain is on the upside,

and, on interior boundaries, as: 

ndflux = (uflux_spatial(T) − dflux_spatial(T))/2

N O R M A L  C O N V E C T I V E  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

The variable ncflux is defined as:

N O R M A L  TR A N S L A T I O N A L  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

The variable ntrlflux is defined as

N O R M A L  TO T A L  E N E R G Y  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

The variable nteflux is defined as:

I N W A R D  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

On boundaries the inward heat flux, q0, is a scalar quantity defined either in a general 
way or as a convective heat flux as follows:

where Text is the external temperature defined in the Heat Flux feature.

R A D I A T I V E  H E A T  F L U X  ( H E A T  TR A N S F E R  I N T E R F A C E )

On boundaries the radiative heat flux, rflux, is a scalar quantity defined as:

ntflux ndflux ncflux ntrlflux+ +=

Frames for the Heat Transfer Equations for a description of spatial and 
material frames.

ncflux mean cflux( ) n⋅=

ntrlflux mean trlflux( ) n⋅=

nteflux mean teflux( ) n mean dflux( ) n ndflux+⋅–⋅=

q0 h Text T–( )=
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where the terms account for surface-to-ambient radiative flux, surface-to-surface 
radiative flux, and radiation in participating net radiative flux, respectively.

Boundary fluxes (Heat Transfer in Thin Shells interface)

On boundaries, the Heat Transfer in Shells interface computes fluxes (vector 
quantities) depending on active physics nodes and selected properties.

TO T A L  H E A T  F L U X  ( H E A T  TR A N S F E R  I N  T H I N  S H E L L S  I N T E R F A C E )

The total heat flux, tflux, is the sum of the conductive and convective heat fluxes: 

C O N D U C T I V E  H E A T  F L U X  ( H E A T  TR A N S F E R  I N  T H I N  S H E L L S  I N T E R F A C E )

The conductive heat flux variable, dflux, is evaluated depending on the conductive 
behavior of the boundary (thermally thin approximation, thermally thick 
approximation, or general).

C O N V E C T I V E  H E A T  F L U X  ( H E A T  TR A N S F E R  I N  T H I N  S H E L L S  I N T E R F A C E )

The convective heat flux variable, cflux, is defined using the internal energy, Ei:

The internal energy, Ei, is defined as:

• Ei = H for solid boundaries

• Ei = H − p/ρ for fluid boundaries

where H is the enthalpy defined in Equation 4-5.

TO T A L  E N E R G Y  F L U X  ( H E A T  TR A N S F E R  I N  T H I N  S H E L L S  I N T E R F A C E )

The total energy flux, teflux, is defined as:

where the total enthalpy, H0, is defined as

rflux εσ Tamb
4 T4

–( ) εσ G T4
–( ) qr net,+ +=

tflux cflux dflux+=

cflux ρuEi=

teflux ρuH0 dflux+=

H0 H u u⋅
2

------------+=
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In addition, in-plane boundary heat fluxes (scalar quantities) are available on 
boundaries.

I N - P L A N E  TO T A L  H E A T  F L U X  ( H E A T  TR A N S F E R  I N  T H I N  S H E L L S  

I N T E R F A C E )

The variable ttflux is defined as:

I N - P L A N E  C O N D U C T I V E  H E A T  F L U X  ( H E A T  TR A N S F E R  I N  T H I N  S H E L L S  

I N T E R F A C E )

The variable tdflux is defined as:

I N - P L A N E  C O N V E C T I V E  H E A T  F L U X  ( H E A T  TR A N S F E R  I N  T H I N  S H E L L S  

I N T E R F A C E )

The variable tcflux is defined as:

I N - P L A N E  TO T A L  E N E R G Y  F L U X  ( H E A T  TR A N S F E R  I N  T H I N  S H E L L S  

I N T E R F A C E )

The variable tteflux is defined as:

Internal Boundary Heat Fluxes

The internal normal boundary heat fluxes (scalar quantity) are available on interior 
boundaries. They are calculated using the upside and the downside value of heat fluxes 
from the adjacent domains.

I N T E R N A L  N O R M A L  C O N D U C T I V E  H E A T  F L U X ,  U P S I D E  ( H E A T  TR A N S F E R  

I N T E R F A C E )

The variable ndflux_u is defined as:

ttflux tdflux tcflux+=

tdflux dflux t⋅=

tcflux cflux t⋅=

tteflux teflux t⋅=

ndflux_u uflux_spatial T( )=
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I N T E R N A L  N O R M A L  C O N D U C T I V E  H E A T  F L U X ,  D O W N S I D E  ( H E A T  

TR A N S F E R  I N T E R F A C E )

The variable ndflux_d is defined as:

I N T E R N A L  N O R M A L  C O N V E C T I V E  H E A T  F L U X ,  U P S I D E  ( H E A T  TR A N S F E R  

I N T E R F A C E )

The variable ncflux_u is defined as:

I N T E R N A L  N O R M A L  C O N V E C T I V E  H E A T  F L U X ,  D O W N S I D E  ( H E A T  

TR A N S F E R  I N T E R F A C E )

The variable ncflux_d is defined as:

I N T E R N A L  N O R M A L  TR A N S L A T I O N A L  H E A T  F L U X ,  U P S I D E  ( H E A T  

TR A N S F E R  I N T E R F A C E )

The variable ntrlflux_u is defined as:

I N T E R N A L  N O R M A L  TR A N S L A T I O N A L  H E A T  F L U X ,  D O W N S I D E  ( H E A T  

TR A N S F E R  I N T E R F A C E )

The variable ntrlflux_d is defined as:

I N T E R N A L  N O R M A L  TO T A L  H E A T  F L U X ,  U P S I D E  ( H E A T  TR A N S F E R  

I N T E R F A C E )

The variable ntflux_u is defined as:

ndflux_d dflux_spatial T( )=

Frames for the Heat Transfer Equations for a description of spatial and 
material frames.

ncflux_u up cflux( ) un⋅=

ncflux_d down cflux( ) dn⋅=

ntrlflux_u up trlflux( ) un⋅=

ntrlflux_d down trlflux( ) dn⋅=

ntflux_u ndflux_u ncflux_u ntrlflux_u+ +=
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I N T E R N A L  N O R M A L  TO T A L  H E A T  F L U X ,  D O W N S I D E  ( H E A T  TR A N S F E R  

I N T E R F A C E )

The variable ntflux_d is defined as:

I N T E R N A L  N O R M A L  TO T A L  E N E R G Y  F L U X ,  U P S I D E  ( H E A T  TR A N S F E R  

I N T E R F A C E )

The variable nteflux_u is defined as:

I N T E R N A L  N O R M A L  TO T A L  E N E R G Y  F L U X ,  D O W N S I D E  ( H E A T  TR A N S F E R  

I N T E R F A C E )

The variable nteflux_d is defined as:

Domain Heat Sources

The sum of the domain heat sources added by different physics features is available in 
the variable Qtot, which is the sum of:

• Q’s, which are the heat sources added by the Heat Source (described for the Heat 
Transfer interface) and Electromagnetic Heat Source (described for the Joule 
Heating interface in the COMSOL Multiphysics Reference Manual) features.

• Qmet, which is the metabolic heat source added by the Bioheat feature.

• Qdmg, which is the cooling source added by the Irreversible Transformation feature.

• Qr, which is the radiative heat source added by the Radiation in Participating Media 
(Heat Transfer Interface) and Radiation in Participating Media (RPM Interface) 
features.

• Qgeo, which is the geothermal heat source added by the Geothermal Heating 
feature. 

ntflux_d ndflux_d ncflux_d ntrlflux_d+ +=

nteflux_u up teflux( ) un up dflux( ) un ndflux_u+⋅–⋅=

nteflux_d down teflux( ) dn down dflux( ) dn ndflux_d+⋅–⋅=

In Bioheat, the out-of-plane (heat flux and radiation) and blood 
contributions are not added to Qtot because these are considered to be 
fluxes.
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Boundary Heat Sources

The sum of the boundary heat sources added by different boundary conditions is 
available in the variable, Qb,tot (SI unit: W/m2). This variable Qbtot is the sum of:

• Qb, which is the boundary heat source added by the Boundary Heat Source 
boundary condition.

• Qsh, which is the boundary heat source added by the Boundary Electromagnetic 
Heat Source boundary condition (described for the Joule Heating interface in the 
COMSOL Multiphysics Reference Manual).

• Qs, which is the boundary heat source added by a Layer Heat Source subfeature of 
a thin layer, see Layer Heat Source.

Line and Point Heat Sources

The sum of the line heat sources is available in a variable called Qltot (SI unit: W/m).

The sum of the point heat sources is available in a variable called Qptot (SI unit: W).

Ambient Variables

A M B I E N T  T E M P E R A T U R E

See Conditions of temperature in Using Ambient Data section.

A M B I E N T  A B S O L U T E  P R E S S U R E

See Pressure in Using Ambient Data section.

W I N D  V E L O C I T Y

See Conditions of wind speed in Using Ambient Data section.

A M B I E N T  R E L A T I V E  H U M I D I T Y

See Relative humidity in Using Ambient Data section.

A M B I E N T  S O L A R  I R R A D I A N C E

The ambient solar irradiance Is_amb is the sum of the Direct and diffuse Solar 
irradiances.

C L E A R  S K Y  N O O N  D I F F U S E  H O R I Z O N T A L  I R R A D I A N C E

See Direct and diffuse Solar irradiances in Using Ambient Data section.
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C L E A R  S K Y  N O O N  B E A M  N O R M A L  I R R A D I A N C E

See Direct and diffuse Solar irradiances in Using Ambient Data section.

A M B I E N T  M O I S T U R E  C O N T E N T

See Moisture content in Using Ambient Data section.

Moist Air Variables

The temperature variable solved by the Heat Transfer interfaces corresponds to the dry 
bulb temperature. This is the temperature measured by a thermometer with a dry 
sensor and screening to prevent from deviation due to external radiation like solar 
radiation.

When the presence of water vapor is accounted for in the model, other temperatures 
may be considered, depending on vapor pressure.

D E W  PO I N T  TE M P E R A T U R E

The dew point temperature of a sample of air with water vapor pressure pv is the 
temperature to which it must be cooled to become fully saturated. 

The variable T_dp is defined in Ref. 1 by:

where phi is the Relative Humidity variable. See Saturation State for the definition of 
saturation pressure psat as a function of temperature. See also Saturation Pressure for 
the definition of the variable psat.

E Q U I V A L E N T  T E M P E R A T U R E

The equivalent temperature is obtained by adiabatically condensing all the water vapor 
of a sample of air with initial vapor pressure pv. In this process, the latent heat decrease 
due to total removal of the vapor is balanced by a increase of the sensible heat and 
temperature.

The variable T_eq is approximated in Ref. 1 by:

where phi is the Relative Humidity, and γTeq (SI unit: Pa/K) is the psychrometer 
constant, defined in Ref. 1 by: 

psat T_dp( ) pv phi psat⋅= =

T_eq T phi psat⋅
γTeq

-----------------------------+=
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where p is the total pressure, Cp, a is the heat capacity at constant pressure of dry air at 
temperature T, Lv is the latent heat of evaporation at temperature T (see Latent Heat 
of Evaporation), and Ma and Mv are the molar mass of dry air and water vapor, 
respectively.

See also Saturation Pressure for the definition of the variable psat.

These definitions are illustrated on Figure 3-1.

Figure 3-1: Relation between dry bulb, dew point, equivalent, and wet bulb temperatures.

The wet bulb temperature is also represented on Figure 3-1. It is obtained by 
adiabatically reaching saturation state for a sample of air with initial water vapor 
pressure pv. In this process, the latent heat increase due to evaporation is balanced by 
a decrease of the sensible heat and temperature. It is not available as a predefined 
variable, but it can be approximated by solving the following equation:

The psychrometer constant is again evaluated at temperature T.

S A T U R A T I O N  P R E S S U R E

The variable psat is defined by:

where T is the temperature. See Functions for the definition of the function fpsat.

R E L A T I V E  H U M I D I T Y

The variable phi is defined by:

γTeq

MapCp a,
MvLv

------------------------=

Twb
psat Twb( )

γ
---------------------------+ T phi psat⋅

γ
-----------------------------+=

psat fpsat T( )=
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L A T E N T  H E A T  O F  E V A P O R A T I O N

The variable Lv is defined by:

where T is the temperature. See Functions for the definition of the function Lv.

phi
pv

psat T( )
--------------------=

Lv lv T( )=
 3 :  M O D E L I N G  W I T H  T H E  H E A T  TR A N S F E R  M O D U L E



Mo i s t u r e  T r a n s po r t  V a r i a b l e s

Predefined Variables 

This section lists the predefined variables that are available with the Moisture Transport 
interface. All variable names begin with the physics interface name (the prefix). By 
default, the Moisture Transport interface prefix is mt. As an example, you can access 
the variable named phi using mt.phi (as long as the physics interface is named mt).

TABLE 3-2:  MOISTURE TRANSPORT PREDEFINED VARIABLES

VARIABLE NAME GEOMETRIC ENTITY LEVEL

phi Relative humidity Domains

cv Vapor concentration Domains

cw Total moisture concentration Domains

cl Liquid water concentration Domains

csat Saturation concentration Domains

psat Saturation pressure of water vapor Domains

pv Partial pressure of water vapor Domains

rhol Liquid water content Domains

rhov Vapor content Domains

omega_moist Vapor mass fraction Domains

xvap Moisture content Domains

Lv Latent heat of evaporation Domains

cflux Convective moisture flux Domains

dflux Diffusive moisture flux Domains

tflux Total moisture flux Domains

tfluxMag Total moisture flux magnitude Domains

Gtot Total moisture source Domains

ncflux Normal convective moisture flux Boundaries

ndflux Normal diffusive moisture flux Boundaries

ntflux Normal total moisture flux Boundaries

ncflux_u Normal convective moisture flux, 
upside

Interior boundaries

ncflux_d Normal convective moisture flux, 
downside

Interior boundaries
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Moist air properties

P A R T I A L  A N D  S A T U R A T I O N  P R E S S U R E S  O F  W A T E R  V A P O R

The partial pressure of vapor pv is the product of the saturation pressure psat and the 
relative humidity phi:

S A T U R A T I O N  C O N C E N T R A T I O N  O F  W A T E R  V A P O R

The saturation concentration csat is obtained from the saturation pressure psat and 
temperature T by:

where R is the universal gas constant.

M O I S T U R E  C O N T E N T

The moisture content xvap is obtained from the vapor concentration cv, the absolute 
pressure pA and temperature T by:

where R is the universal gas constant, Mv is the water vapor molar mass, and Ma is the 
dry air molar mass.

VA P O R  M A S S  F R A C T I O N

The vapor mass fraction omega_moist is obtained from the moisture content by:

ndflux_u Normal diffusive moisture flux, upside Interior boundaries

ndflux_d Normal diffusive moisture flux, 
downside

Interior boundaries

ntflux_u Normal total moisture flux, upside Interior boundaries

ntflux_d Normal total moisture flux, downside Interior boundaries

gtot Total moisture flux Boundaries

TABLE 3-2:  MOISTURE TRANSPORT PREDEFINED VARIABLES

VARIABLE NAME GEOMETRIC ENTITY LEVEL

pv phi psat⋅=

csat psat
RT

------------=

xvap cv
pA
RT
-------- cv– 
 
--------------------------

Mv
Ma
--------⋅=
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L I Q U I D ,  V A P O R ,  A N D  M O I S T U R E  C O N C E N T R A T I O N S

The total moisture concentration cw is the sum of the liquid water and vapor 
concentrations cl and cv:

C O N C E N T R A T I O N S  A N D  C O N T E N T S

The liquid water and vapor contents rhol and rhov are obtained by multiplying the 
concentrations cl and cv by the molar mass of water Mv:

L A T E N T  H E A T  O F  E V A P O R A T I O N

The variable Lv is defined by:

where T is the temperature. See Functions for the definition of the function Lv.

Domain Moisture Fluxes

C O N V E C T I V E  M O I S T U R E  F L U X

In building materials domains, the variable cflux is defined as:

In moist air domains, the variable cflux is defined as:

D I F F U S I V E  M O I S T U R E  F L U X

In building materials domains, the variable dflux is defined as:

In moist air domains, the variable dflux is defined as:

omega_moist xvap
1 xvap+
------------------------=

cw cv cl+=

rhol Mv cl⋅=

rhov Mv cv⋅=

Lv lv T( )=

cflux δpφ∇ psat T( )( )–=

cflux Mvucv=

dflux ξ(– Dw δ+
p
psat T( ) )∇φ=
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TO T A L  M O I S T U R E  F L U X

The variable tflux is defined as:

TO T A L  M O I S T U R E  F L U X  M A G N I T U D E

The variable tfluxMag is defined as:

Boundary Moisture Fluxes

N O R M A L  C O N V E C T I V E  M O I S T U R E  F L U X

The variable ncflux is defined on all boundaries as:

I N T E R N A L  N O R M A L  C O N V E C T I V E  M O I S T U R E  F L U X ,  U P S I D E

The variable ncflux_u is defined on interior boundaries as:

I N T E R N A L  N O R M A L  C O N V E C T I V E  M O I S T U R E  F L U X ,  D O W N S I D E

The variable ncflux_d is defined on interior boundaries as:

N O R M A L  D I F F U S I V E  M O I S T U R E  F L U X

The variable ndflux is defined on all boundaries as:

I N T E R N A L  N O R M A L  D I F F U S I V E  M O I S T U R E  F L U X ,  U P S I D E

The variable ndflux_u is defined on interior boundaries as:

dflux M– vD∇cv=

tflux cflux+dflux=

tfluxMag norm tflux( )=

ncflux mean cflux( ) n⋅=

ncflux_u up cflux( ) un⋅=

ncflux_d down cflux( ) dn⋅=

ndflux mean dflux( ) n⋅=

ndflux_u up dflux( ) un⋅=
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I N T E R N A L  N O R M A L  D I F F U S I V E  M O I S T U R E  F L U X ,  D O W N S I D E

The variable ndflux_d is defined on interior boundaries as:

N O R M A L  TO T A L  M O I S T U R E  F L U X

The variable ntflux is defined on all boundaries as:

I N T E R N A L  N O R M A L  TO T A L  M O I S T U R E  F L U X ,  U P S I D E

The variable ntflux_u is defined on interior boundaries as:

I N T E R N A L  N O R M A L  TO T A L  M O I S T U R E  F L U X ,  D O W N S I D E

The variable ntflux_d is defined on interior boundaries as:

TO T A L  M O I S T U R E  F L U X

The sum of the boundary moisture fluxes added by Moisture Flux features is available 
as the variable gtot.

Domain Moisture Source

The sum of the domain moisture sources added by Moisture Source features is 
available as the variable Gtot.

ndflux_d down dflux( ) dn⋅=

ntflux mean tflux( ) n⋅=

ntflux_u up tflux( ) un⋅=

ntflux_d down tflux( ) dn⋅=
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U s i n g  t h e  Bounda r y  Cond i t i o n s  f o r  
t h e  Hea t  T r a n s f e r  I n t e r f a c e s

In this section:

• Temperature and Heat Flux Boundary Conditions

• Overriding Mechanism for Heat Transfer Boundary Conditions

Temperature and Heat Flux Boundary Conditions

The heat equation accepts two basic types of boundary conditions: specified 
temperature and specified heat flux. The specified condition is of constraint type and 
prescribes the temperature on a boundary:

while the latter specifies the inward heat flux

where

• q is the conductive heat flux vector (SI unit: W/m2), q = −k∇T.

• n is the normal vector on the boundary.

• q0 is the inward heat flux (SI unit: W/m2), normal to the boundary.

The inward heat flux, q0, is often a sum of contributions from different heat transfer 
processes (for example, radiation and convection). The special case q0 = 0 is called 
thermal insulation.

A common type of heat flux boundary conditions is one for which q0 = h·(Text − T), 
where Text is the temperature far away from the modeled domain and the heat transfer 
coefficient, h, represents all the physics occurring between the boundary and “far 
away.” It can include almost anything, but the most common situation is that h 

T T0= on ∂Ω

n– q⋅ q0= on ∂Ω
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represents the effect of an exterior fluid cooling or heating the surface of a solid, a 
phenomenon often referred to as convective cooling or heating.

Overriding Mechanism for Heat Transfer Boundary Conditions

Many boundary conditions are available in heat transfer. Some of these can coexist (for 
example, Heat Flux and Thin Layer); others cannot (for example, Heat Flux and 
Thermal Insulation).

Several categories of boundary condition exist in heat transfer. Table 3-3 gives the 
overriding rules for these groups.

1 Temperature, Open Boundary, Open Boundary, Inflow Heat Flux

2 Thermal Insulation, Symmetry, Periodic Condition

3 Heat Flux

4 Boundary Heat Source, Radiation Group, Line Heat Source on Axis

5 Diffuse Mirror, Prescribed Radiosity, Diffuse Surface 

6 Opaque Surface, Incident Intensity, Continuity on Interior Boundary

7 Thin Layer, Thermal Contact, Thin Film

8 Isothermal Domain Interface

The CFD Module and the Heat Transfer Module contain a set of 
correlations for convective heat flux and heating. See Heat Transfer and 
Fluid Flow Coupling.

TABLE 3-3:  OVERRIDING RULES FOR HEAT TRANSFER BOUNDARY CONDITIONS

A\B 1 2 3 4 5 6 7 8

1-Temperature X X X

2-Thermal Insulation X X X

3-Heat Flux X X

4-Boundary heat source

5-Radiation X X

6-Opaque Surface X

7-Thin Layer X X

8-Isothermal Domain Interface X
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When there is a boundary condition A above a boundary condition B in the model 
tree and both conditions apply to the same boundary, use Table 3-3 to determine if A 
is overridden by B or not:

• Locate the line that corresponds to the A group (see above the definition of the 
groups). In the table above only the first member of the group is displayed.

• Locate the column that corresponds to the group of B.

• If the corresponding cell is empty, A and B contribute. If it contains an X, B 
overrides A.

Example 1
Consider a boundary where Temperature is applied. Then a Diffuse Surface boundary 
condition is applied on the same boundary afterward.

• Temperature belongs to group 1.

• Diffuse Surface belongs to group 5.

• The cell on the line of group 1 and the column of group 5 is empty so Temperature 
and Diffuse Surface contribute.

This mechanism can be checked on the COMSOL Desktop, in the Override and 

Contribution section of each feature, as shown in the following table:

Group 3 and group 4 boundary conditions are always contributing. That 
means that they never override any other boundary condition. But they 
might be overridden.

Table 3-4:  Override and Contribution sections

TEMPERATURE DIFFUSE SURFACE
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Example 2
Consider a boundary where Heat Flux is applied. Then a Symmetry boundary condition 
is applied on the same boundary afterward.

• Heat Flux belongs to group 3.

• Symmetry belongs to group 2.

• The cell on the line of group 3 and the column of group 2 contains an X so Heat 

Flux is overridden by Symmetry.

This mechanism can be checked on the COMSOL Desktop, in the Override and 

Contribution section of each feature, as shown in the following table:

Table 3-5:  Override and Contribution sections

HEAT FLUX SYMMETRY

In Example 2 above, if Symmetry followed by Heat Flux is added, the 
boundary conditions contribute. 
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Hand l i n g  F r ame s  i n  Hea t  T r a n s f e r

In this section:

Heat Transfer Analysis with Moving Frames

Material Density in Features Defined on the Material Frame

Heat Transfer Analysis with Moving Frames

This section discusses heat transfer analysis with moving frames, when spatial and 
material frames do not coincide. 

When the Enable conversions between material and spatial frame check box is selected 
in the Advanced Settings section, all heat transfer interfaces account for deformation 
effects on heat transfer properties.

The entire physics (equations and variables) are defined on the spatial frame. When a 
moving mesh is detected, the user inputs for certain features are defined on the 
material frame and are converted so that all the corresponding variables contain the 
value on the spatial frame.

This subsection contains the list of all heat transfer nodes and the corresponding 
definition frame:

• Physics Feature Nodes and Definition Frame

• Definition Frame of Domain Nodes

• Definition Frame of Boundary Nodes

• Definition Frame of Edge and Point Nodes

• Material and Spatial Frames

• About Frames in the COMSOL Multiphysics Reference Manual

Conversion Between Material and Spatial Frames
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P H Y S I C S  F E A T U R E  N O D E S  A N D  D E F I N I T I O N  F R A M E

The following explains the different values listed in the definition frame column in 
Table 3-6, Table 3-7, Table 3-8, and Table 3-9:

Material: The inputs are entered by the user and defined on the material frame. 
Because the heat transfer variables and equations are defined on the spatial frame, the 
inputs are internally converted to the spatial frame.

Spatial: The inputs are entered by the user and defined on the spatial frame. No 
conversion is done.

Material/(Spatial): For these physics nodes, select from a menu to decide if the inputs 
are defined on the material or spatial frame. The default definition frame is the material 
frame.

(Material)/Spatial: For these physics nodes, select from a menu to decide if the inputs 
are defined on the material or spatial frame. The default definition frame is the spatial 
frame.

N/A: There is no definition frame for this physics node.
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D E F I N I T I O N  F R A M E  O F  D O M A I N  N O D E S

D E F I N I T I O N  F R A M E  O F  B O U N D A R Y  N O D E S

TABLE 3-6:  DOMAIN PHYSICS NODES FOR FRAMES 

NODE NAME DEFINITION FRAME

Bioheat Material 

Biological Tissue Material

Building Material Spatial

Change Cross Section Spatial

Change Thickness Spatial

Fluid Spatial

Geothermal Heating Material

Heat Source Material/(Spatial)

Immobile Fluids Spatial

Infinite Elements Spatial

Initial Values Spatial

Isothermal Domain Spatial

Opacity N/A

Out-of-Plane Heat Flux Spatial

Out-of-Plane Radiation Spatial

Phase Change Material Spatial

Porous Medium Material (Solid part) 
Spatial (Fluid part)

Pressure Work Spatial

Radiation in Participating Media Spatial

Solid Material

Thermal Dispersion Spatial

Thermoelastic Damping Spatial

Translational Motion Material

Viscous Dissipation Spatial

TABLE 3-7:  BOUNDARY PHYSICS NODES FOR FRAMES

NODE NAME DEFINITION FRAME

Boundary Heat Source Material/(Spatial)

Continuity Spatial
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The definition frames of the corresponding pair features are identical to the ones of the 
standard features.

Continuity on Interior Boundary Spatial

Diffuse Mirror Spatial

Diffuse Surface Spatial

Fracture Material (Solid part) 
Spatial (Fluid part)

Heat Flux (Material)/Spatial

Incident Intensity Spatial

Inflow Heat Flux Spatial

Isothermal Domain Interface Spatial

Layer Heat Source Material

Opaque Surface Spatial

Open Boundary Spatial

Outflow N/A

Periodic Condition Spatial

Prescribed Radiosity Spatial

Radiation Group N/A

Symmetry N/A

Temperature Spatial

Thermal Contact Material

Thermal Insulation N/A

Thin Film Spatial

Thin Layer Material

TABLE 3-7:  BOUNDARY PHYSICS NODES FOR FRAMES

NODE NAME DEFINITION FRAME
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D E F I N I T I O N  F R A M E  O F  E D G E  A N D  PO I N T  N O D E S

TABLE 3-9:  HEAT TRANSFER IN THIN SHELLS NODES

Material Density in Features Defined on the Material Frame

In a model the features defined on the material frame with an input field for the density 
expect the density on the material frame, defined for the reference geometry. Hence 
this density is constant in most cases. A non constant density in the material frame 
means that there is addition or removal of matter. 

As a consequence when the material is defined from a material library and is 
temperature dependent, a constant reference temperature should be used for the 
definition of the density in the Material Contents table. 

This reference temperature defines the density in the reference geometry that should 
match with the geometry in the material frame.

TABLE 3-8:  EDGE AND POINT NODES FOR FRAMES

NODE NAME DEFINITION FRAME

Line Heat Source Material/(Spatial)

Line Heat Flux (Material)/Spatial

Point Heat Flux Spatial

Point Heat Source Material

Surface-to-Ambient Radiation Spatial

Temperature Spatial

Thin Rod Material

NODE NAME DEFINITION FRAME

Change Effective Thickness Spatial

Change Thickness Spatial

Heat Flux Spatial/(Material)

Heat Source Material/(Spatial)

Initial Values Spatial

Surface-to-Ambient Radiation Spatial

Temperature Spatial

Thin Conductive Layer Material

Thin Layered Shell Material
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Following Table 3-6, Table 3-7, Table 3-8, and Table 3-9, this concerns the following 
features: Solid, Porous Medium, Biological Tissue, Thin Layer, Fracture, Thin Rod, 
Thin Conductive Layer (Heat Transfer in Thin Shells Interface), and Thin Layered 
Shell (Heat Transfer in Thin Shells Interface).
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Hea t  T r a n s f e r  C on s i s t e n t  and 
I n c on s i s t e n t  S t a b i l i z a t i o n  Me t hod s

The different versions of the Heat Transfer interface include the advanced option to 
set stabilization method parameters. This section has information about these options. 
To display the stabilization sections, click the Show button ( ) and select 
Stabilization.

In this section:

• Consistent Stabilization

• Inconsistent Stabilization

Consistent Stabilization

This section contains two consistent stabilization methods: streamline diffusion and 
crosswind diffusion. These are consistent stabilization methods, which means that they 
do not perturb the original transport equation.

The consistent stabilization methods are active by default. A stabilization method is 
active when the corresponding check box is selected.

S T R E A M L I N E  D I F F U S I O N

Streamline diffusion is active by default and should remain active for optimal 
performance for heat transfer in fluids or other applications that include a convective 
or translational term.

C R O S S W I N D  D I F F U S I O N

Streamline diffusion introduces artificial diffusion in the streamline direction. This is 
often enough to obtain a smooth numerical solution provided that the exact solution 
of the heat equation does not contain any discontinuities. At sharp gradients, however, 
undershoots and overshoots can occur in the numerical solution. Crosswind diffusion 
addresses these spurious oscillations by adding diffusion orthogonal to the streamline 
direction — that is, in the crosswind direction.

Continuous Casting: Application Library path 
Heat_Transfer_Module/Thermal_Processing/continuous_casting
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Inconsistent Stabilization

This section contains a single stabilization method: isotropic diffusion. Adding 
isotropic diffusion is equivalent to adding a term to the physical diffusion coefficient. 
This means that the original problem is not solved, which is why isotropic diffusion is 
an inconsistent stabilization method. Although the added diffusion definitely 
attenuates spurious oscillations, try to minimize the use of isotropic diffusion.

By default there is no isotropic diffusion. To add isotropic diffusion, select the Isotropic 

diffusion check box. The field for the tuning parameter δid then becomes available. The 
default value is 0.25; increase or decrease the value of δid to increase or decrease the 
amount of isotropic diffusion.

In the COMSOL Multiphysics Reference Manual:

• Stabilization Techniques

• Stabilization
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Hea t  T r a n s f e r  and F l u i d  F l ow 
Coup l i n g

COMSOL Multiphysics offers physics interfaces for heat transfer and fluid flow 
computations. These interfaces have model inputs that make it possible to couple the 
physics. In addition, COMSOL Multiphysics and the Heat Transfer Module contain 
multiphysics coupling interfaces that facilitate the coupling between heat transfer and 
fluid flow interfaces: Temperature Coupling, Flow Coupling, and Nonisothermal Flow can 
be used to couple fluid flow and heat transfer interfaces.

All these options make it possible to build a coupling in different ways. Even if the use 
of the predefined multiphysics coupling interfaces — Nonisothermal Flow and Conjugate 

Heat Transfer — is the preferred choice, other alternatives can be of interest in 
particular cases. This section describes the possibility for coupling heat transfer and 
fluid flow interface and lists the advantages and limitations of each approach.

In this section:

• Coupling Based on Model Inputs

• Temperature Coupling and Flow Coupling Multiphysics Features

• Adding Nonisothermal Flow Coupling in an Existing Model

• Nonisothermal Flow and Conjugate Heat Transfer Multiphysics Interfaces

See The Laminar Flow Interface, The Turbulent Flow, Algebraic yPlus Interface, The 
Turbulent Flow, L-VEL Interface, The Turbulent Flow, k-e Interface, and The 
Turbulent Flow, Low Re k-e Interface in the CFD Module User’s Guide for a 
description of the laminar and turbulent single-phase flow interfaces.

See Domain, Boundary, Pair, and Point Nodes for Single-Phase Flow in the CFD 
Module User’s Guide for a description of the nodes associated to these interfaces.

Coupling Based on Model Inputs

This option does not use any multiphysics feature. Instead you define the model inputs 
in each physics interface. You define the temperature model input in the flow interface 
and the velocity and pressure model inputs in the heat transfer interface. This approach 
is valid for laminar flow only. Also, the consistent stabilization does not account for the 
multiphysics coupling, which can lead to convergence issues when the multiphysics 
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coupling is strong. Pressure work and viscous dissipation are not handled. In addition 
the physics interface settings may not be optimal for the numerical treatment of the 
coupling.

One interesting aspect of this method it that the temperature, velocity, or pressure field 
does not have to be a dependent variable. You can use an analytical expression instead.

Temperature Coupling and Flow Coupling Multiphysics Features

These multiphysics features implement a one-way coupling (one in each direction) 
between the heat transfer and the fluid flow coupling. These couplings are interesting 
when you want to explicitly show that the coupling is not bidirectional: it is possible 
to use only the Flow Coupling when the fluid properties are not temperature dependent.

This approach is valid for laminar flow only. Also, the consistent stabilization does not 
account for the multiphysics coupling, which, similarly to the previous approach, can 
lead to convergence issues when the multiphysics coupling is strong, in particular when 
the temperature dependence of the fluid properties is large. Pressure work and viscous 
dissipation are not handled. In addition, the physics interface settings may not be 
optimal for the numerical treatment of the coupling.

Adding Nonisothermal Flow Coupling in an Existing Model

The Heat Transfer Module provides the Nonisothermal Flow multiphysics feature. This 
feature can be added to a model containing a single-phase flow and a heat transfer 
interface. It is common to start a model with a single physics (for example, fluid flow), 
then implement the second one (for example, heat transfer). Then adding the 
Nonisothermal Flow multiphysics feature realizes the coupling between the two 
interfaces.

This multiphysics interface handles the two-way coupling. In addition, it accounts for 
the turbulence in the coupling. In particular, it modifies the effective thermal 
conductivity and implements thermal wall functions if the fluid flow model requires 
them. Those modifications affect the implementation of several heat transfer features. 
This multiphysics feature also redefines the consistent stabilization so that the 
multiphysics coupling effects are accounted for in the numerical stabilization. It allows 
to include work done by pressure changes and viscous dissipation, and Boussinesq 
approximation is supported. Finally some physics features are updated when the 
Nonisothermal Flow multiphysics feature is active. In particular, the Interior Fan and 
Screen fluid-flow features are updated to account for the multiphysics coupling.
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Note that the physics interface settings may not be optimal for the numerical treatment 
of the coupling when the multiphysics feature is added afterward.

Nonisothermal Flow and Conjugate Heat Transfer Multiphysics 
Interfaces

These Nonisothermal Flow and Conjugate Heat Transfer Multiphysics 
Interfacesmultiphysics interfaces are identical except that they do not have the same 
default features. Both contain a single-phase flow interface and a heat transfer interface 
coupled with the Nonisothermal Flow multiphysics feature. So all the benefits of this 
multiphysics feature (see above) are present when these multiphysics interfaces are 
used.

In addition, the heat transfer and fluid flow interfaces are set up with optimal interface 
settings: the discretization order of the heat transfer interface is the same as the one 
used for the fluid flow interface, and the pseudo time stepping is activated in both 
interfaces.

For these reasons, the use of these multiphysics interfaces is preferred.

Note that you can do a gradual implementation of the model: It is possible to start 
from these multiphysics interfaces and to disable the multiphysics feature or one of the 
physics in a first step and then reactivate them when the first step is validated.
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Bounda r y  Wa l l  T empe r a t u r e

Depending on the model configuration, a single temperature field per boundary may 
not be sufficient to model accurately the temperature. In some cases, different 
dependent variables are used to compute the temperature in the wall, at the wall sides, 
or in the turbulent boundary layer. This section describes when additional degrees of 
freedom are needed and how they are handled.

The boundary temperature variable called ht.Tvar describes the wall temperature. 
When the wall has a nonconstant temperature across its thickness, this variable contains 
the average value between the temperatures of the two sides of the wall. The actual 
definition of ht.Tvar depends on the model configuration.

Some features define a local temperature: ht.feat1.Tvar. For example, when a 
boundary heat source is applied on a particular side of the layer, this local variable 
ht.bhs1.Tvar contains either the temperature upside or downside the boundary.

The following list includes existing boundary temperature variables that are available 
depending on the model configuration: 

• T: general temperature variable that coincides with the wall temperature in most 
cases

• TWall_u: upside wall temperature defined by a Wall or an Interior Wall feature with 
turbulence only if a Fluid feature is defined on the upside of the wall.

• TWall_d: downside wall temperature defined by a Wall or an Interior Wall feature 
with turbulence only if a Fluid feature is defined on the downside of the wall.

• Tu: temperature on the upside of the boundary.

• Td: temperature on the downside of the boundary.

• TExtFace: external temperature of an external boundary defined by a thermally 
thick boundary condition.

• TuWF: temperature of the fluid in the turbulent boundary layer near the wall only if 
the Fluid feature is defined on the upside of the Wall feature.

• TdWF: temperature of the fluid in the turbulent boundary layer near the wall only if 
the Fluid feature is defined on the downside of the Wall feature.
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The values of these variables depend on the selections where they are defined. Here are 
some illustrated cases:

• Intersection between a Wall boundary feature selection and interface exterior 
boundaries

• Interface between a fluid domain feature and a solid domain feature where a Wall 
boundary feature is active

• Interface between two fluid domain features where an Interior Wall boundary 
feature is active

Depending on the turbulence model selected for the flow, wall functions are used or 
not:

• No turbulence model: no wall functions, and TuWF = Tu, TdWF = Td.

• Turbulence models: wall functions detected by the Single Phase Flow physics 
interface. TuWF and TdWF have different definitions and a flux qwf is applied on the 
wall boundaries. See Temperature Condition for Automatic Wall Treatment and 
Wall functions in the CFD Modue User’s Manual for details.

The following sections summarize the definitions of the temperature variables for the 
above mentioned configurations. 

I N T E R S E C T I O N  B E T W E E N  A  WA L L  B O U N D A R Y  F E A T U R E  S E L E C T I O N  A N D  

I N T E R F A C E  E X T E R I O R  B O U N D A R I E S

The following figure shows a configuration with a fluid domain, a thermally thick 
boundary condition on the left boundary, and a Wall feature on the right boundary. 
This example uses wall functions.

Td=TWall_dTu=TExtFace

Thermally thick layer boundary

Fluid

TdWF=T

Tu=Td=TWall_d

TdWF=T
 3 :  M O D E L I N G  W I T H  T H E  H E A T  TR A N S F E R  M O D U L E



I N T E R F A C E  B E T W E E N  A  F L U I D  D O M A I N  F E A T U R E  A N D  A  S O L I D  D O M A I N  

F E A T U R E  W H E R E  A  WA L L  B O U N D A R Y  F E A T U R E  I S  A C T I V E  

Solid in the domain downside the wall
The following figures show configurations with a solid as downside domain and a fluid 
as upside domain with either a thermally thick or thermally thin boundary condition 
in between. This example uses wall functions.

Tu=TWall_uTd=down(T)

Thermally thick layer boundary

Upside domain 
of the boundary

Downside domain 
of the boundary

Solid Fluid

TuWF=up(T)

Tu=Td=TWall_d

TdWF=T

 Tu=Td=down(T)

Thermally thin layer boundary

Upside domain 
of the boundary

Downside domain 
of the boundary

Solid Fluid

Tu=Td=TWall_d
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Solid in the domain upside the wall
The following figures show configurations with a fluid as downside domain and a solid 
as upside domain with either a thermally thick or thermally thin boundary condition 
in between. This example uses wall functions.

Tu=up(T)Td=TWall_d

Thermally thick layer boundary

Upside domain 
of the boundary

Downside domain 
of the boundary

Fluid Solid

TdWF=down(T)

Tu=Td=Twall_d

Tu=Td=up(T)

Thermally thin layer boundary

Upside domain 
of the boundary

Downside domain 
of the boundary

Fluid Solid

Tu=Td=Twall_d
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I N T E R F A C E  B E T W E E N  T W O  F L U I D  D O M A I N  F E A T U R E S  W H E R E  A N  

I N T E R I O R  WA L L  B O U N D A R Y  F E A T U R E  I S  A C T I V E

The following figure shows a configuration with two fluid domains with a thermally 
thick boundary condition and an Interior Wall feature in between. This example uses 
wall functions.

Tu=TWall_uTd=TWall_d

Thermally thick layer and Interior 

Wall boundary

Upside domain 
of the boundary

Downside domain 
of the boundary

Fluid Fluid

Tu=Td=TWall_d

TdWF=down(T) TuWF=up(T)

Tu=Td=TWall_d
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S o l v e r  S e t t i n g s

The information about default solvers given below is specific to the Heat Transfer and 
Moisture Transport interfaces when the Stationary and Time-Dependent studies are 
used. A comprehensive description of solver settings and corresponding theory is 
available in the Study and Study Step Types section of the COMSOL Multiphysics 
Reference Manual.

In this section:

• Linearity property of the temperature equation

• Linear Solver

• Nonlinear Solver

• Time-Dependent Study Step

• Guidelines for Solving Surface-to-Surface Radiation Problems

• Guidelines for Solving Multiphysics problems

Linearity property of the temperature equation

The Heat Transfer interfaces define an elliptic partial differential equation for the 
temperature, T, of the form:

with Dirichlet and Neumann boundary conditions at some boundaries:

In its basic form, the density, ρ, heat capacity, Cp, thermal conductivity, k, heat sources, 
Q, constraint temperatures, T0, and heat fluxes, q0, are all constant, which leads to a 

See also Studies and Solvers in the COMSOL Multiphysics Reference 
Manual

ρCp t∂
∂T ∇ q⋅+ Q=

q k T∇–=

T T0=

n q⋅– q0=
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linear system. Here, linear solvers described in the next paragraphs are completely 
suited for the resolution.

However, nonlinearities can appear in the equation in the following cases:

• The material properties, ρ, Cp, and k, have a temperature dependency.

• The heat sources are not linear in temperature.

• The Neumann boundary condition is not linear in temperature, hence

- A convective cooling condition of type −n ⋅ q = h(Text − T) keeps the linearity of 
the problem when the heat transfer coefficient, h, is constant.

- A radiative condition of type −n ⋅ q = εσ(Tamb
4 − T4) is strongly nonlinear.

Different nonlinear solvers are also provided for these kinds of problems.

Linear Solver

D E F A U L T  S E T T I N G S  F O R  H E A T  TR A N S F E R  I N T E R F A C E S

The default linear solver is determined based on the number of degrees of freedom and 
physics interface settings.

For small number of degrees of freedom, the direct PARDISO solver is used. It is 
known to be robust and fast for small-sized problems.

For larger models, the linear iterative GMRES solver with multigrid preconditioner is 
used. In most cases, SOR line is the presmoother and postsmoother. This solver is 
memory effective and fast for large models. When the heat transfer model contains 
settings that lead to a system matrix with 0 on the diagonal (for example, Lagrange 
multipliers for weak constraints), SOR line cannot be used and is replaced by Vanka, 
which is usually slower and uses more memory.

D E F A U L T  S E T T I N G S  F O R  M O I S T U R E  TR A N S P O R T  I N T E R F A C E

The linear iterative GMRES solver with geometric multigrid (GMG) acceleration is 
used by default. In most cases, SOR line is used as the presmoother and postsmoother 
for better performance. When weak constraints are set, the use of Lagrange multipliers 
leads to a system matrix with 0 on the diagonal, and SOR line cannot be used. It is 
replaced by Vanka, which is usually slower and uses more memory.

TU N I N G  L I N E A R  S O L V E R

Tuning the linear solver may be considered in case of nonconvergence or low 
performance. When convergence fails you should first verify that this is not due to an 
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ill-posed model, or inappropriate settings in the Time-Dependent study or nonlinear 
solver.

Several options are available to tune the linear solver settings. This paragraph focuses 
only on the most commonly used ones.

Switch to PARDISO
When the GMRES solver with multigrid preconditioner is set by default, using 
PARDISO instead can be considered provided that enough RAM is available. Indeed, 
PARDISO usually converges easily but uses much more memory than the default 
iterative solver. If PARDISO does not converge, it may indicate that there is an issue 
in the model definition or with other solver settings.

Optimize GMRES/Multigrid for Memory
In order to optimize further the memory needed by the iterative solver, the number of 
mesh elements on the coarser multigrid level can be reduced by, for instance, 
increasing the Mesh coarsening factor or the Number of multigrid levels. The latter 
strategy may also increase the resolution time.

Optimize GMRES/Multigrid for Convergence
When the linear solver has difficulties to converge, the following settings can be tuned:

• When the convergence graph of GMRES shows a slow down every 50 iterations, the 
Number of iteration before restart parameter (default value of 50) should be 
increased — doubled for example. This may also increase the memory consumption.

• Increasing the Number of iteration in the Multigrid settings, and in the presmoother 
and postsmoother nodes improves the quality of the preconditioner and 
convergence of GMRES.

• Since an excessive difference between two multigrid levels can affect the 
convergence, lowering the Mesh coarsening factor in the Multigrid settings can help 
convergence.

• Consider creating the multigrid level meshes manually if the automatic coarsening 
method fails or leads to poor quality meshes.

Choosing the Right Linear System Solver in the COMSOL Multiphysics 
Reference Manual
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Nonlinear Solver

D E F A U L T  S E T T I N G S  F O R  H E A T  TR A N S F E R  I N T E R F A C E S

Nonlinear solver settings depend on the heat transfer model and on the study type.

Fully Coupled Solver Attribute
Heat transfer models with and without surface-to-surface radiation use a fully coupled 
nonlinear solver attribute by default. The Jacobian update is set to minimal. A Newton 
nonlinear method is set by default with

• Automatic damping factor computation for stationary studies

• Constant damping factor for time-dependent studies

Segregated Solver Attribute
The segregated solver attribute is set by default in the following cases:

• Another physics interface is solved together with heat transfer. The dependent 
variables of the heat transfer interface are placed in a separate segregated group.

• Radiation in participating media using the Discrete ordinates method defines a large 
number of dependent variables (up to 80), which are placed in segregated groups. 
The number of dependent variables per segregated group and the nonlinear method 
settings depend on the Performance index parameter available in the heat transfer 
interface settings in the Participating Media Settings section.

• The Biological Tissue feature with Include damage integral analysis option selected 
defines an additional dependent variable that is placed in a dedicated segregated 
group. In addition when the Temperature threshold option is used, a dependent 
variable is added to the Previous solution step. It uses a direct linear solver. The 
default nonlinear method is the Newton method with constant damping factor.

D E F A U L T  S E T T I N G S  F O R  M O I S T U R E  TR A N S P O R T  I N T E R F A C E S

A Newton nonlinear method is set by default with a constant damping factor (0.5). 
The Jacobian update is set to On every iteration. The termination technique is Iterations, 
with Number of iterations set to 2.

TU N I N G  T H E  N O N L I N E A R  S O L V E R

Default solver settings are defined to handle efficiently classical configurations. For 
particular applications, the default settings may need modifications to improve the 
robustness and performance of the solver.
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Optimize Nonlinear Solver for Robustness
When the nonlinear solver fails or converges erratically, different options can be 
considered:

• Using the Automatic highly nonlinear (Newton) option forces to start the 
computation with a very low damping factor and increases it carefully. Alternatively 
a low constant damping factor can be used. The damping factor ranges between 0 
and 1. A constant damping factor equal to 0.1 is a very low value and should be 
robust but slow to converge. For low values of the damping factor, it is thus usually 
needed to increase the number of nonlinear iterations. If the nonlinear solver is 
unstable with such a damping factor then the automatic option should be used 
because it makes it possible to start with a lower damping factor and gradually 
increases it.

• A good initial value, as close as possible from the expected solution and consistent 
with the boundary conditions, helps to guide the nonlinear solver to a stable 
physical solution. To do that:

- Try to ramp the temperature on the boundary from the initial to the desired value 
by using a auxiliary sweep — for stationary problems — or a time-dependent step 
function — for time-dependent problems.

- Use results from a simplified problem, for instance with no temperature 
dependency, or using a one-way multiphysics coupling, as initial value.

Note that it is sometimes easier to update the boundary conditions than the initial 
condition to get consistent initial settings (see the Heat Conduction in a Finite Slab 
model).

• When it is not possible to provide a good initial value, the segregated solver 
associated with low damping factors in each segregated step helps to achieve 
convergence.

• Forcing the Jacobian update at every iteration ensures that the nonlinear solver 
iterates using optimal information from the equation system. This is needed when 
nonlinearities are due to the temperature itself — for example, in case of strong 
temperature dependency of material properties — or to another variable solved in 
the same segregated group as the temperature — for example, in natural convection 
models.
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Optimize Convergence Speed
Low convergence can be improved by following ways:

• Using a constant damping factor equal to 1 for linear problems. The linearity is 
determined at the beginning of the resolution and indicated in the Log section of the 
solver window.

• Providing a good initial value is an asset for computational speed.

• In the convergence area, the fully coupled solver has a better convergence rate than 
the segregated solver.

• Using minimal Jacobian update option avoid to spend time in Jacobian 
computation. This is suited for linear models and models with mild nonlinearities.

Time-Dependent Study Step

D E F A U L T  S E T T I N G S  F O R  H E A T  TR A N S F E R  I N T E R F A C E S

The default time-stepping method for the Heat Transfer interfaces is BDF at second 
order. It excludes algebraic variable from the error estimate.

When the Biological Tissue feature is active with the Include damage integral analysis 
option selected, particular settings for the time-dependent solver are used to efficiently 
compute the damage indicators:

• The Absolute Tolerance of the scaled damage indicator dependent variables is set to 
1, meaning that these variable are neglected in the error estimate.

• The damaged tissue indicator, α1, is solved with an iterative Jacobi method.

• If the Adaptive mesh refinement option is selected in the study settings, the error 
indicator is set to  where θd, sm is the smoothed indicator of 
necrotic tissue (the fraction of necrotic tissue, θd, is discontinuous in general).

• If the Temperature threshold option is used in the Biological Tissue feature, the instant 
necrosis indicator, α2, is placed in the Previous Solution step. This setting avoids 
wrong detection of irreversible damage due to nonlinear iterations that may go 
through a state where the damage criteria is met and then converge to a solution 
where the damage criteria is no longer met.

When the Irreversible Transformation feature is active, similar settings are used:

• The Absolute Tolerance of the scaled irreversible transformation indicator dependent 
variable is set to 1.

• The irreversible transformation indicator α is solved with an iterative Jacobi method.

θd sm,∇ θd sm,∇⋅
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D E F A U L T  S E T T I N G S  F O R  M O I S T U R E  TR A N S P O R T  I N T E R F A C E S

The default time-stepping method for the Moisture Transport interfaces is BDF at 
second order.

TU N I N G  T H E  T I M E - D E P E N D E N T  S O L V E R

The quality of the time-stepping influences the nonlinear solver convergence. Tiny 
time steps usually lead to mildly nonlinear problems at each time step whereas large 
time steps can result in (fewer) highly nonlinear problems.

The default solver settings for transient heat transfer defines the maximal number of 
nonlinear iterations to 5. If this is not sufficient, it is recommended to use smaller time 
steps and to verify if the model definition does not contain discontinuities in time. If 
so, consider using smooth step functions to model sharp variations in time.

There are several ways to control the time step size:

• An implicit way is to define a lower relative tolerance in the study settings. When the 
relative tolerance is lowered, the absolute tolerance should be reduced in the same 
proportion.

• The most explicit way is to define a maximum time step. This is an appropriate 
option when the same maximum time step is relevant for the entire simulation. 
Otherwise, it is possible to include times of interest in the Times field of the 
time-dependent study and to use the Intermediate option in the Time Stepping 
settings.

• Lastly you can control the time step by triggering an event when a particular 
condition is meet (see the documentation about The Events Interface in the 
COMSOL Multiphysics Reference Manual). This advanced method can be 
efficient when the other simpler methods are not applicable.

It is also recommended to inspect the solver log and check the default scaling of 
dependent variables in case of convergence failure. In case of incorrect automatic 
scaling, consider using Manual settings in the Dependent Variable attribute node.

Time-Dependent Solver in the COMSOL Multiphysics Reference 
Manual
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Guidelines for Solving Surface-to-Surface Radiation Problems

The following guidelines are helpful when selecting solver settings for models that 
involve surface-to-surface radiation:

• Surface-to-surface radiation makes the Jacobian matrix of the discrete model partly 
filled as opposed to the usual sparse matrix. The additional nonzero elements in the 
matrix appear in the rows and columns corresponding to the radiosity degrees of 
freedom. It is therefore common practice to keep the element order of the radiosity 
variable, J, low. By default, linear Lagrange elements are used irrespective of the 
shape-function order specified for the temperature. When you need to increase the 
resolution of your temperature field, it might be worth considering raising the order 
of the temperature elements instead of refining the mesh.

• The Assembly block size parameter (found in the Advanced solver feature) can have a 
major influence on memory usage during the assembly of problems where 
surface-to-surface radiation is enabled. When surface-to-surface is detected, the 
solver sets the assembly block size at 100. Using a smaller block size also leads to 
more frequent updates of the progress bar.

Guidelines for Solving Multiphysics problems

M U L T I P H Y S I C S  M O D E L S

Unless the model contains a multiphysics node that defines a coupling between a Heat 
Transfer interface and another interface (see Multiphysics Couplings below), each 
physics interface defines default solver settings that are merged.

The Heat Transfer interfaces always define a dedicated segregated group that uses a 
linear solver optimized for the heat transfer equations. For strongly coupled models, it 
may be efficient to merge two (or more) segregated steps. In this case, a unique linear 
solver must be chosen for the fully coupled solver or the new segregated group.

Time-dependent settings from different physics interfaces may compete. When the 
different settings are merged the strictest one is kept.

Introduction to Solvers and Studies and Advanced in the COMSOL 
Multiphysics Reference Manual
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M U L T I P H Y S I C S  C O U P L I N G S

When a Heat Transfer interface is coupled with another physics interface through a 
multiphysics coupling feature, additional predefined default settings are loaded. The 
next two paragraphs describes the subtleties of the Nonisothermal Flow, 
Electromagnetic Heating, and Heat and Moisture Transport interfaces.

Nonisothermal Flow
The Nonisothermal Flow multiphysics coupling controls the solver settings for the 
flow and the temperature-dependent variables.

When it assumes a weak coupling between the flow and the heat interfaces (typically 
no Volume Force feature in the flow interface), the default solver contains dedicated 
segregated groups for heat and flow dependent variables. Each uses the default linear 
solver of the corresponding interface.

When a strong coupling is assumed (at least one Volume Force feature in the flow 
interface), the default solver merges the temperature, pressure, and velocity. In this 
case, the linear solver corresponds to the default linear solver of the flow interface. The 
Jacobian is updated once per time step.

Electromagnetic Heating
The Electromagnetic Heating multiphysics interfaces (Joule heating, Laser Heating, 
Induction Heating, and Microwave Heating) define default settings that solve the 
temperature and the electromagnetic fields using a coupled step. It can be the fully 
coupled nonlinear solver if there is no additional variable to solve for, otherwise it is a 
segregated step containing the temperature and the electromagnetic variables. 
However when radiation in participating media or damage variable are solved they are 
placed in a separate group as described above.

Heat and Moisture Transport 
The Heat and Moisture Transport interface defines dedicated segregated groups for 
heat and moisture dependent variables. Each uses the default linear solver of the 
corresponding interface. A Lower Limit node is added for the relative humidity to 
enforce a positive value.
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P l o t t i n g  R e s u l t s  i n  Th i n  L a y e r s  E x t r a  
D imen s i o n s

When modeling thin layers with extra dimensions — if the Layer type is set to General 
in the Thin Layer feature of the Heat Transfer interface, or when using the Thin Layered 

Shell feature of the Heat Transfer in Thin Shells interface — a new shape function, 
Txdim, is automatically created. This variable corresponds to the temperature field in 
the layer. Because the layer is not explicitly represented in the geometry, dedicated 
tools are available. There are two ways of plotting the temperature in the 1D extra 
dimension: 

• Along the layer, for a fixed coordinate between 0 and ds (the layer thickness) in the 
1D extra dimension.

• Through the thin layer, at one position on the boundary

Along the Layer

The extra dimension temperature Txdim can be evaluated along the layer by using the 
atxd1 operator on the extra dimension, with the expression xdimTag.atxd1(xd, 
expr), where:

• xdimTag is the extra dimension tag. For example, it is ht_tl1_xdim5_xdim, in the 
case of a thin layer (tl1) with five layers (xdim5) in a physics interface with tag ht. 
This tag can be deduced from the Selection column of the Equation View subnode of 
Thin Layer, by clicking the Show button ( ) on the Model Builder tool bar and 
selecting Equation View.

• xd is the coordinate in the extra dimension. It varies from 0 to ds, which is the sum 
of layer thicknesses. By convention, xd=0 corresponds to the upside of the 

Theory for Heat Transfer in Thin Structures

Thin Layer

Thin Layered Shell (Heat Transfer in Thin Shells Interface)

Using Extra Dimensions in the COMSOL Multiphysics Reference 
Manual.
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boundary where the thin layer is defined, whereas xd=ds corresponds to its 
downside. Upside and downside settings can be visualized by plotting the global 
normal vector (nx, ny, nz), that always points from downside to upside. See Tangent 
and Normal Variables in the COMSOL Multiphysics Reference Manual. Note that 
the normal vector (ht.nx, ht.ny, ht.nz) may be oriented differently. The layer 
thickness variables (ht.tl1.ds1 for example) can be retrieved from the Equation 

View subnode of Thin Layer.

• expr is the quantity to be evaluated at the point xd. For example, it can be set to 
ht.tl1.Txdim to evaluate the temperature. There are others postprocessing 
variables defined on the extra dimension that can be found in the Equation View 
subnode of Thin Layer.

In 2D and 2D axisymmetric geometries, the section is represented in a line graph 
under a 1D plot group, whereas it is a surface plot for 3D geometries.

Figure 3-2: Schematic representation of a 2D geometry with a thin layer composed of three 
layers, with an evaluation of the results along the layer at the coordinate xd.

Through the Thin Layer

The extra dimension temperature Txdim can be evaluated through the thin layer, at a 
specific point (x0, y0) or (x0, y0,z0), by using the operators atxd1 in 2D and 2D 
axisymmetric geometries, and atxd2 in 3D geometries. Note that this time the 
operators are used on the component and not on the extra dimension.

For all dimensions, the section is represented in a line graph under a 1D plot group. 
In order to use this, the Data set selected in the Data section of the 1D plot group has 
to select the extra dimension as component. One method is to duplicate the default 
Solution node under the Data Sets node, set the Component of the new node to the extra 

xd

Thin Layer boundary

Computational 
domain

Extra 
dimension

Along 
the layer
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dimension, and use this new data set into the 1D plot group, with the domains of the 
extra dimension selected. 

In 2D and 2D axisymmetric geometries, use compTag.atxd1(x0, y0, expr), where:

• compTag is the component tag. In most cases, this tag is comp1. It is possible to 
check it in the Properties window of the component node (display it by 
right-clicking on the node and selecting Properties).

• x0 and y0 are the coordinates of the point in the base geometry that belongs to the 
boundary linked with the extra dimension. Note that these are 2D coordinates from 
the global coordinate system and not curvilinear coordinates.

• expr is the quantity to be evaluated at the point (x0, y0). For example, it can be set 
to ht.tl1.Txdim to evaluate the temperature.

In 3D geometries, use compTag.atxd2(x0, y0, z0, expr), where:

• compTag is the component tag. For example, it can be comp1. 

• x0, y0, and z0 are the coordinates of the point in the base geometry that belongs 
to the boundary linked with the extra dimension. 

• expr is the quantity to be evaluated at the point (x0, y0, z0). For example, it can 
be set to ht.tl1.Txdim to plot the temperature. Note that here too, these are 3D 
coordinates from the global coordinate system and not curvilinear coordinates.

Figure 3-3: Schematic representation of a 2D geometry with a thin layer composed of three 
layers, with an evaluation of the results through the layer at the point (x0,y0).

(x0,y0)

Thin Layer boundary

Computational 
domain

Extra 
dimension

Along the extra dimension
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U s i n g  Amb i e n t  Da t a

The ambient data available within the Heat Transfer interfaces come from the 
processing of measured data from ASHRAE Weather Data Viewer 5.0 (©2013 
ASHRAE, www.ashrae.org), given as frequencies of observations, monthly and hourly 
averaged for several past years of observation. They provide time-dependent weather 
conditions for more than 6000 stations worldwide in terms of the dry bulb 
temperature, the dew point temperature, the relative humidity, the wind speed, and the 
solar direct and diffuse irradiance.

See Ambient Settings for the settings related to the ambient variables in the Heat 
Transfer (ht) and Heat Transfer in Thin Shells (htsh) interfaces.

Processing of ASHRAE Data

From frequencies of measured values, a weighted mean of the data and a standard 
deviation from the weighted mean are computed for each month. For the temperature, 
more data are available and the weighted mean and standard deviation are also 
computed at each hour. Figure 3-4 shows an example of weighted mean computation 
for the diurnal temperature fluctuations from the initial data given as frequencies of 
observations. 

Figure 3-4: Computation of weighted mean from frequencies of observations for the 
diurnal fluctuations of temperature.

When no special mention is added, the term temperature stands for the 
dry bulb temperature. See Moist Air Variables for the definition of the dry 
bulb temperature, the dew point temperature, and the relative humidity.
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These values are used for the definition of different conditions, as detailed in Ambient 
Variables and Conditions.

All the monthly averaged observations except the solar irradiance are supposed to be 
made at the middle of each month. This time depends on the number of days in the 
month:

• Months with 31 days (January, March, May, July, August, October, December): 
data at the 16th at noon

• Months with 30 days (April, June, September, November): data at the 16th at 
midnight

• Months with 29 days (February, leap years): data at the 15th at noon

• Months with 28 days (February, other years): data at the 15th at midnight

In addition, the temperature observations are supposed to be made at the beginning 
of each hour (00:00 a.m. to 11:00 p.m.). 

Finally, the solar irradiance observations are made at the 21st of each month at noon. 
Depending on the number of days in the month, this date corresponds to 68% (for 
months with 31 days), 70% (for months with 30 days), or 75% (for February) of the 
month. The leap years are not considered and the 21st of February always corresponds 
to 75% of this month.

Ambient Data Interpolation

The temperature is the only variable for which hourly data are available in addition to 
monthly averages. So for the temperature a double interpolation is performed to get a 
temperature profile for every time in a year depending on the date and the hour. For 
other data the interpolation is based on date only. This interpolation provides: 

• The annual fluctuation of the dew point temperature, the relative humidity, the 
wind speed, and the direct and diffuse solar irradiances.

• The annual and diurnal fluctuation of the temperature.

In all cases, the interpolation is of second order, with continuous first-order derivative. 

Ambient Variables and Conditions

The observed values are processed by computing weighted means, standard deviations, 
maximum, and minimum, to define different conditions for the temperature, dew 
point temperature, and wind speed.
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C O N D I T I O N S  O F  T E M P E R A T U R E

• Average:

• Low:

• High:

• Lowest:

• Highest:

• User defined coefficient for deviation:

• User defined correction:

where: 

• <Tstation> (SI unit: K) is the weighted mean of the observed values of temperature 
at the station.

• σT,station (SI unit: K) is the standard deviation of the observed values of 
temperature at the station.

• Tstation (SI unit: K) is the set of the observed values of temperature at the station.

• cσ (dimensionless) is a user defined multiplicative coefficient applied to σT,station.

• ΔT (SI unit: K) is a user defined additive correction applied to <Tstation>.

Tamb Tstation =

Tamb Tstation  σT station,–=

Tamb Tstation  σT station,+=

Tamb min Tstation( )=

Tamb max Tstation( )=

Tamb Tstation  cσ σ⋅ T station,+=

Tamb Tstation  ΔT+=
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All these conditions are illustrated on Figure 3-5 for the variation of temperature over 
1 day at New York/John F. Ke, on the 1st of June.

Figure 3-5: Comparison of ambient conditions for the temperature at New York/John F. 
Ke, on the 1st of June

Additional conditions are defined from observed couples of temperature and wind 
speed and direction values: 

• Heating wind correlation:

• Cooling wind correlation:

where ΔTwind (SI unit: K) is an additive correction applied to <Tstation>, defined as

where ΔTws,station (SI unit: K) and ΔTwd,station (SI unit: K) are respectively the 
maximal variations of observed values of temperature correlated with a set of wind 
speed and direction observed values.

Tamb Tstation  ΔTwind+=

Tamb Tstation  ΔTwind–=

ΔTwind
1
2
---max ΔTws station, ΔTwd station,,( )=
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The heating and cooling wind correlations are illustrated on Figure 3-6 for the 
variation of temperature over 1 day, at New York/John F. Ke, on the 1st of June.

Figure 3-6: Comparison of heating and cooling wind correlations for the temperature at 
New York/John F. Ke, on the 1st of June

C O N D I T I O N S  O F  D E W  P O I N T  T E M P E R A T U R E

• Average:

• Low:

• High:

• Lowest:

• Highest:

DPTamb DPTstation =

DPTamb DPTstation  σDPT station,–=

DPTamb DPTstation  σDPT station,+=

DPTamb min DPTstation( )=

DPTamb max DPTstation( )=
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where:

• <DPTstation> (SI unit: K) is the weighted mean of the observed values of dew point 
temperature at the station.

• σDPT,station (SI unit: K) is the standard deviation of the observed values of dew 
point temperature at the station.

• DPTstation (SI unit: K) is the set of the observed values of dew point temperature 
at the station.

All these conditions are illustrated on Figure 3-7 for the variation of the dew point 
temperature over 1 year at New York/John F. Ke.

Figure 3-7: Comparison of the ambient conditions for the dew point temperature at New 
York/John F. Ke

C O N D I T I O N S  O F  W I N D  S P E E D

• Average:

• Low:

• High:

vamb vstation =

vamb vstation  σv station,–=

vamb vstation  σv station,+=
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• Lowest:

• Highest:

where:

• <vstation> (SI unit: m/s) is the weighted mean of the observed values of wind 
velocity at the station. 

• σv,station (SI unit: m/s) is the standard deviation of the observed values of wind 
velocity at the station.

• vstation (SI unit: m/s) is the set of the observed values of wind velocity at the station.

All these conditions are illustrated on Figure 3-8 for the variation of the wind speed 
over 1 year at New York/John F. Ke.

Figure 3-8: Comparison of the ambient conditions for the wind speed at New York/John 
F. Ke

P R E S S U R E

where pstation (SI unit: Pa) is the observed value of absolute pressure at the station. 
Only a single value is available so this data does not vary with time.

vamb min vstation( )=

vamb max vstation( )=

pamb pstation=
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R E L A T I V E  H U M I D I T Y

The relative humidity φamb (dimensionless) is computed from the temperature Tamb 
and the dew point temperature DPTamb with the following relation:

where psat(Tamb) is the saturation pressure of vapor at Tamb.

See Relative Humidity for more details.

As the diurnal variation of temperature is available, the diurnal fluctuations of relative 
humidity can be computed, as illustrated on Figure 3-9 for New York/John F. Ke, on 
the 1st of June, for different ambient conditions.

Figure 3-9: Diurnal fluctuations of relative humidity for different ambient conditions at 
New York/John F. Ke, on the 1st of June

Several conditions of relative humidity can be obtained from the selection of 
conditions for the temperature and dew point temperature. For consistency, the 
relative humidity is majored by 1, as shown on the red curve of Figure 3-9.

M O I S T U R E  C O N T E N T

The moisture content xvap,amb (dimensionless) is computed from the temperature 
Tamb, the absolute pressure pamb, and the relative humidity φamb with the following 
relation:

φamb
psat DPTamb( )

psat Tamb( )
---------------------------------------=
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where psat(Tamb) is the saturation pressure of vapor at Tamb, and Mv and Ma are the 
molar masses of water vapor and dry air.

See Moisture Content for more details.

D I R E C T  A N D  D I F F U S E  S O L A R  I R R A D I A N C E S

With clear sky conditions, the noon solar irradiance is essentially provided by the beam 
normal irradiance, coming directly from the sun. However, the diffuse horizontal 
irradiance may be also considered. The sum of direct and diffuse solar irradiances is the 
ambient solar irradiance Is, amb (SI unit: W/m3), defined by:

where Isn,station (SI unit: W/m3) and Ish,station (SI unit: W/m3) are respectively the 
observed values of the clear sky noon beam normal and horizontal diffuse solar 
irradiances.

Figure 3-10 illustrates the evolution of ambient solar irradiance for New York/John F. 
Ke, over the year.

Figure 3-10: Decomposition of solar irradiance into normal and horizontal irradiance at 
New York/John F. Ke

xvap amb,

φamb p⋅ sat Tamb( )
pamb φ– amb p⋅

sat
Tamb( )

--------------------------------------------------------------------
Mv
Ma
--------⋅=

Is amb, Isn station, Ish station,+=
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Use of Ambient Data From the Features 

The ambient variables defined in the physics interface are available as inputs for several 
boundary and initial conditions. For example, when defining the heat transfer 
coefficient for a Heat Flux boundary condition by using a correlation for external forced 
convection, the wind velocity vamb, the ambient absolute pressure pamb, and the 
ambient temperature Tamb can be selected as inputs:

Figure 3-11: Use of ambient data from Heat Flux feature

For an example of the use of user-defined ambient data, see:

Temperature Field in a Cooling Flange: Application Library path 
Heat_Transfer_Module/Thermal_Processing/cooling_flange

For an example of the use of meteorological ambient data, see:

Condensation Detection in an Electronic Device with Transport and 
Diffusion: Application Library path 
Heat_Transfer_Module/Power_Electronics_and_Electronic_Cooling/condensati

on_electronic_device_transport_diffusion

Condensation Detection in an Electronic Device: Application Library 
path 
Heat_Transfer_Module/Power_Electronics_and_Electronic_Cooling/condensati

on_electronic_device
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Mode l i n g  Hea t  T r a n s f e r  b y  Rad i a t i o n

This section summarizes the functionalities available within the Heat Transfer Module 
for the modeling of heat transfer by radiation.

Radiation is a heat transfer mode that should be considered in addition to conduction 
and convection in the following cases:

• In a transparent or semi-transparent medium. 

• For a surface with a large emissivity (close to 1). Whereas most polished metals have 
an emissivity below 0.1, other materials such as concrete, black painting, glass, 
plastic, skin, paper, and ceramic have an emissivity over 0.8.

• When the difference between a surface temperature and the ambient temperature is 
large.

• When conduction and convection are small, as radiation becomes the predominant 
transfer mode.

• At small time scales, for which conduction and convection effects are too slow and 
have a less significant effect.

As an example, consider a plate of concrete with a cold bottom wall at temperature T0, 
placed in a hot environment with an air flux at temperature Tamb:
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The figures below illustrate the relative importance of heat transfer by radiation and by 
convection (due to the air flux), when the emissivity ε is 0.1 (left) and 0.9 (right).

Figure 3-12: Integral of convective and radiative heat fluxes (W/m) along the top 
boundary, for two values of emissivity, in function of temperature gradient.

Whereas the boundary radiative and convective heat fluxes are of the same order for 
temperature gradients up to 500K when the emissivity is low (ε=0.1), radiation 
becomes the dominant mode of heat transfer even for small temperature gradients 
when the emissivity is high (ε=0.9). Note that the convective heat flux decrease 
observed for high temperature gradients is related to the fact that the velocity, not the 
mass flow rate, is prescribed at the air inlet.

The following table recalls the functionalities available for the modeling of heat transfer 
by radiation.

See Heat Transfer Variables for the definition of the variables q0 and 
rflux giving access to the convective and radiative heat fluxes on 
boundaries.

TABLE 3-10:  MODELING OF HEAT TRANSFER BY RADIATION

SURFACE-TO-AMBIENT SURFACE-TO-SURFACE PARTICIPATING 
MEDIA

Description

Physical and modeling assumptions

Propagation 
medium for 
radiation

Transparent Transparent Participating (semi 
transparent)
M O D E L I N G  H E A T  TR A N S F E R  B Y  R A D I A T I O N  |  121



122 |  C H A P T E
Refractive index of 
domain

n=1 Any, uniform Any, uniform

Scattering in 
domain

N/A N/A Isotropic 
(Rosseland 
approximation)

Linear anisotropic 
(P1 method)

Anisotropic (DOM)

Shadowing effects 
in view factor 
computation

No Yes (Hemicube)

No (Direct Area 
Integration)

N/A

Wavelength 
dependency of 
emissivity

No No (Constant)

Yes (Solar and 
ambient / Multiple 
spectral bands)

No

Dimension of the 
domain

3D, 2D axi, 2D, 1D 
axi, 1D

3D, 2D axi, 2D, 1D 
axi, 1D

3D, 2D axi(5), 2D

Example model Continuous Casting Heat Sink with 
Surface-to-Surface 
Radiation

Glass Plate

License, interfaces and features

License 
requirement

COMSOL 
Multiphysics / 

Heat Transfer 
Module

Heat Transfer 
Module

Heat Transfer 
Module

Interfaces with the 
functionality as 
default

Heat Transfer (ht)

Heat Transfer in 
Thin Shells (htsh)

Heat Transfer (ht), 
with 
Surface-to-surface 
radiation option

Heat Transfer in 
Thin Shells (htsh), 
with 
Surface-to-surface 
radiation option

Surface-to-Surface 
Radiation (rad)

Heat Transfer (ht), 
with Radiation in 
Participating Media 
option

Radiation in 
Participating Media 
(rpm)

TABLE 3-10:  MODELING OF HEAT TRANSFER BY RADIATION

SURFACE-TO-AMBIENT SURFACE-TO-SURFACE PARTICIPATING 
MEDIA
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Domain features Out-of-Plane 
Radiation (1)(2)

Opacity Radiation in 
Participating Media

Boundary features Diffuse Surface Diffuse Surface

Diffuse Mirror

Prescribed 
Radiosity

Radiation Group

Continuity of 
Interior Boundary 
(DOM)

Incident Intensity 
(P1 method/DOM)

Opaque Surface (P1 
method/DOM)

Edges/Point 
features

Surface-to-Ambient 
Radiation(1) 

N/A N/A

Global features N/A External Radiation 
Source (3) 

Symmetry for 
Surface-to-Surface 
Radiation (4) 

N/A

Numerical aspects

Numerical cost Low Medium to high Low (Rosseland 
approximation)

Medium (P1 
method)

High (DOM)

Additional variables None Surface radiosity J 
(if constant 
wavelength), 
JB1,JB2 (if solar 
and ambient 
wavelengths),

JB1,...,JB5 (if 
multiple 
wavelengths)

None (Rosseland 
approximation)

Incident radiation 
G (P1 method)

Radiative intensity 
I=I1,..., In, with n 
up to 80 (DOM)

(1) Only with the Heat Transfer Module
(2) Only in 2D and 1D components
(3) Only in 3D and 2D components
(4) Only in 3D, 2D axi, and 2D components
(5) Only with Rosseland approximation and P1 method

TABLE 3-10:  MODELING OF HEAT TRANSFER BY RADIATION

SURFACE-TO-AMBIENT SURFACE-TO-SURFACE PARTICIPATING 
MEDIA
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Hea t  Pa r t  L i b r a r y

The Part Libraries can be used to store and access a set of standard geometric entities. 
It is possible to create custom user-defined geometry libraries or to use built-in 
collections of geometric entities that are available with many add-on modules for 
COMSOL Multiphysics.

In this section:

• Heat Part Library Contents

• Heat Sink - Parameterized Fin Types Part

• Heat Sink - Dissimilar Border Pins Part

• Heat Sink - Pin Fins Part

• Heat Sink - Straight Fins Part

Heat Part Library Contents

The part library included with the Heat Transfer Module contains typical heat sink 
geometries. When accessing the library, the parts are sorted as in the figure below:

The heat sinks are composed of a rectangular base and an array of pin or straight fins, 
as shown on Figure 3-13.

Part Libraries in the COMSOL Multiphysics Reference Manual
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Figure 3-13: Heat sinks components

All entities are fully parameterized, making them easy to use as parts in industrial 
models where heat sinks are used for cooling. For example, you can control the 
number, the shape, the dimensions, and the placement of the fins on the base. In 
addition, fillet, chamfer, and notch transformations can be applied to the fins, and 
parameter checks are applied to ensure that the values set in the Input Parameters 
section are valid.

The library includes four parts. The Heat Sink - Parameterized Fin Types part is the most 
general part. It supports multiple parameterization, while a reduced number of 

base

fins

border offset
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parameters is available in the three other parts, as shown in Table 3-11.

In the Heat Sink - Pin Fins part, all the fins are pins with the same dimension, whereas 
the outer and inner fins (in y-direction) can have distinct dimensions in the Heat Sink 

- Dissimilar Border Pins part. You may use the Heat Sink - Straight Fins part to define a 
heat sink made of only straight fins.

By default, the base of the heat sink is positioned at the origin of the x-y plane. You 
can apply a Displacement and a Rotation to this configuration in the Position and 

Orientation of Output section.

TABLE 3-11:  OVERVIEW OF HEAT SINK PARTS

Heat Sink - Parameterized Fin Types

fin_type =1,2,3 (editable)

Heat Sink - Pin Fins Heat Sink - Dissimilar 
Border Pins

Heat Sink - Straight Fins

fin_type = 1 (not editable) fin_type = 2 (not editable) fin_type = 3 (not editable)
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Finally, each fin is a separate domain and can be easily deleted, and selections can be 
defined, for example for the base bottom face (Boundary Selections section) or the array 
of fins (Domain Selections section).

Heat Sink - Parameterized Fin Types Part

The dimensions of the base and the fins can be parameterized, as shown on 
Figure 3-14. In addition, an offset from the base border can be added.

Figure 3-14: Fins and base parameters in Heat Sink - Parameterized part

A step can be defined in the x-direction at the center on the base. The parameter 
step_width specifies the number of filled gaps from middle to border by the step, as 
shown on Figure 3-15.

X_baseY_base

Z_base

Y_fins_bottom_2

Y_fins_bottom X_fins_bottom

Y_fins_top
Y_fins_top_2

X_fins_top

Z_fins

o_x
o_y

n_fins_x=3

n_fins_y=4
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Figure 3-15: Step parameters in Heat Sink - Parameterized part

Finally, a fillet transformation can be applied at the top and bottom of the fins, as 
shown on Figure 3-16.

Figure 3-16: Fillet parameters in Heat Sink - Parameterized part

step=1

step_heightstep_height

step_width=1step_width=1

(odd number of fins in x-direction) (even number of fins in x-direction)

fillet_top=1

fillet_bottom=1
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Heat Sink - Dissimilar Border Pins Part

This part inherits all the functionalities of the Heat Sink - Parameterized Fin Types part, 
but different dimensions are set by default for the inner and outer fins in the 
y-direction:

• Y_fins_bottom = 3 mm (outer fins) and Y_fins_bottom_2 = 6 mm (inner fins)

• Y_fins_top = 3 mm (outer fins) and Y_fins_top_2 = 6 mm (inner fins)

Heat Sink - Pin Fins Part

This part inherits all the functionalities of the Heat Sink - Parameterized Fin Types part, 
but identical dimensions are enforced for the inner and outer fins in the y-direction:

• Y_fins_bottom = 3 mm (all fins) 

• Y_fins_top = 3 mm (all fins) 

Heat Sink - Straight Fins Part

This part inherits all the functionalities of the Heat Sink - Parameterized Fin Types part, 
but the y-direction parameters are enforced to define straight fins. 

In addition, notch and chamfer transformations can be applied to the fins, as shown 
on Figure 3-17.

Figure 3-17: Notch and chamfer parameters in Heat Sink - Straight Fins part

notch=1 chamfer=1

chamfer_width
chamfer_height

notch_width
notch_height
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 4
T h e o r y  f o r  t h e  H e a t  T r a n s f e r  M o d u l e
This chapter details the theory of the physics interfaces, multiphysics couplings, 
and features found under the Heat Transfer branch ( ).

In this chapter:

• Foundations of the General Heat Transfer Equation

• Theory for Heat Transfer in Solids

• Theory for Heat Transfer in Fluids

• Theory for Bioheat Transfer

• Theory for Heat Transfer in Porous Media

• Theory for Heat Transfer with Phase Change

• Theory for Heat Transfer in Building Materials

• Theory for Harmonic Heat Transfer

• Theory for Lumped Isothermal Domain

• Theory for Heat Transfer in Thin Structures

• Theory for Surface-to-Surface Radiation

• Theory for Radiation in Participating Media

• Theory for Moisture Transport
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• Theory for the Heat Transfer Multiphysics Couplings

• Theory for Thermal Contact

• Moist Air Fluid Type

• Temperature Dependence of Surface Tension

• Out-of-Plane Heat Transfer

• The Heat Transfer Coefficients

• Equivalent Thermal Conductivity Correlations

• Heat Flux and Heat Balance

• Frames for the Heat Transfer Equations

• References
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Founda t i o n s  o f  t h e  Gen e r a l  H ea t  
T r a n s f e r  Equa t i o n

This section presents basic results leading to the heat transfer equations solved in 
COMSOL Multiphysics. Starting by a presentation of heat as another mode of energy 
transfer different from work, the energy conservation laws that apply lead to the 
establishment of The Heat Balance Equation. The latter is further derived to give the 
different versions of the heat transfer equations in various media.

In this section:

• Thermodynamic Description of Heat Transfer

• The Physical Mechanisms under Heat Transfer

• The Heat Balance Equation

• Consistency with Mass and Momentum Conservation Laws

Thermodynamic Description of Heat Transfer

In continuum mechanics, a domain Ω is submitted to variations of its kinetic energy 
due to some external forces according to an equation of motion. The study of such 
phenomena is covered by solid mechanics and fluid mechanics and the theories behind 
can be found in the Structural Mechanics Module User’s Guide and CFD Module 
User’s Guide. From an energy point of view, the aforementioned description is 
incomplete because it does not include heat as another form of energy transfer due to 
microscopic vibration and interactions of particles. The laws of thermodynamics 
introduce several concepts to define heat transfer consistently with mechanical energy. 
In the next paragraphs, a concise presentation of the theory adapted to the use of 
COMSOL Multiphysics is given. More materials and details are provided in the 
references listed in the References section.

E X T E N S I V E  P A R A M E T E R S  C H A R A C T E R I Z I N G  A  S Y S T E M

A homogeneous fluid taking place in a domain Ω is characterized by the knowledge of 
three extensive parameters:

• The entropy, SΩ (SI unit: J),
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• The volume, VΩ (SI unit: m3),

• The mass, MΩ (SI unit: kg).

The internal energy, EΩ (SI unit: J), is an extensive state function of these three 
variables. It measures the amount of energy in the system excluding kinetic energy and 
potential energy from external applied forces and is the subject of conservation laws 
more detailed in The Heat Balance Equation section. To fit with the finite element 
method solved by COMSOL Multiphysics, specific quantities per unit mass are 
preferred:

The specific internal energy, E (SI unit: J/kg), is then a function of specific entropy, 
S, and specific volume, ν, related to EΩ by:

For a solid, the specific internal energy, E(S, F), is a function of entropy and 
deformation gradient, F.

Internal energy is related to the enthalpy, H, via the following for a fluid:

or the following for a solid (7.33 in Ref. 1):

Compared to the internal energy, the enthalpy also includes the pressure-volume 
potential energy, p ⁄ ρ, necessary for instance in volume expansion after an isobaric 
transformation.

F I R S T - O R D E R  P A R A M E T E R S

The variations of internal energy correspond to variations of entropy and volume 
according to:

S
SΩ
MΩ
---------= ν

VΩ
MΩ
---------=

E S ν,( ) 1
MΩ
---------EΩ SΩ VΩ MΩ, ,( )=

H E p
ρ
---+=

H E 1
det F( )ρ
---------------------P:F–=

Ed
S∂

∂E
 
 

ν
Sd

ν∂
∂E
 
 

S
νd+=
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First-order parameters are partial derivatives of the specific internal energy. They 
correspond to the thermodynamic definitions of temperature and pressure:

 (4-1)

These lead to the fundamental thermodynamic relation:

Similar relations as those of Equation 4-1 hold for solids:

 (4-2)

Here, the counterpart of the fluid pressure is the first Piola-Kirchhoff stress tensor, P.

S E C O N D  O R D E R  P A R A M E T E R S

Second order parameters correspond to second partial derivatives of the specific 
internal energy and provide a various number of thermodynamic coefficients. These 
are usually given as material properties of the domain material. Among them, the heat 
capacity at constant pressure and the coefficient of thermal expansion are most often 
provided. For a fluid, these are

 (4-3)

and for a solid, the definitions become:

 (4-4)

T
S∂

∂E
 
 

ν
= p

ν∂
∂E
 
 

S
–=

Ed T Sd p νd–=

Temperature is the measurable quantity that gives a phenomenological 
description of heat transfer. When expressed in kelvin (K), the Second 
Law of Thermodynamics ensures that T can only take positive values.

T
S∂

∂E
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 
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Specific heat capacity at constant pressure is the amount of energy required to raise one 
unit of mass of a substance by one degree while maintained at constant pressure. This 
quantity is also commonly referred to as specific heat or specific heat capacity.

The heat capacity at constant pressure and coefficient of thermal expansion are related 
to the enthalpy, seen as a function of T and p (or P), according to:

The enthalpy can then be retrieved from Cp and αp (or α) by:

 (4-5)

where r is the integration vector variable, containing temperature and pressure or 
stress tensor components:

The starting point, r0, is the value of r at reference conditions, that is, pref (one 
atmosphere) and Tref (298.15 K) for a fluid. The ending point, r1, is the solution 
returned after simulation. In theory any value can be assigned to the enthalpy at 
reference conditions, Href (Ref. 2), and COMSOL Multiphysics sets it to 0 J/kg by 
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default. The integral in Equation 4-5 is sometimes referred to as the sensible enthalpy 
(Ref. 2) and is evaluated by numerical integration.

The Physical Mechanisms under Heat Transfer

The amount of heat transferred per unit time (heat transfer rate) depends on the 
underlying physical mechanisms that define the mode of transfer. These are:

• Conduction — Heat conduction (or diffusion) occurs as a consequence of different 
mechanisms in different media. Theoretically, it takes place in a gas through 
collisions of molecules; in a fluid through oscillations of each molecule in a “cage” 
formed by its nearest neighbors; in metals mainly by electrons carrying heat and in 
other solids by molecular motion, which in crystals take the form of lattice vibrations 
known as phonons.

In a continuous medium, Fourier’s law of heat conduction states that the 
conductive heat flux, q, is proportional to the temperature gradient:

 (4-6)

The coefficient of proportionality, k, is the thermal conductivity (SI unit: W/(m·K)) 
and takes a positive value meaning that heat flows from regions of high temperature 
to low temperature. More generally, the thermal conductivity can take the form of 
a symmetric positive-definite second-order tensor (matrix) in anisotropic media 
such as composite materials:

For the evaluation of H to work, it is important that the dependencies of 
Cp, ρ, and γ on the temperature are prescribed either via Model Inputs or 
as functions of the temperature variable. If Cp, ρ, or γ depends on the 
pressure, that dependency must be prescribed either via a model input or 
by using the variable pA, which is the variable for the absolute pressure in 
COMSOL Multiphysics.

q k∇T–=

k

kxx kxy kxz

kxy kyy kyz

kxz kyz kzz

=

Thermal conductivity tensors that do not respect the symmetric 
positive-definite property lead to unphysical results (Ref. 3).
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• Convection — Heat convection (sometimes called heat advection) takes place 
through the net displacement of a fluid that transports the heat content with its 
velocity. The term convection (especially convective cooling and convective heating) 
also refers to the heat dissipation from a solid surface to a fluid, typically described 
by a heat transfer coefficient.

• Radiation — Heat transfer by radiation takes place through the transport of 
photons. Participating (or semitransparent) media absorb, emit, and scatter 
photons. Opaque surfaces absorb or reflect them.

The Heat Balance Equation

The equations of heat transfer in continua are derived from the first law of 
thermodynamics, commonly referred to as the principle of conservation of energy. The 
present part establishes the heat balance equation in its integral and localized forms 
that stand as a root for deriving the different heat transfer equations solved in 
COMSOL Multiphysics.

I N T E G R A L  F O R M

The first law of thermodynamics states that the variations of macroscopic kinetic 
energy, KΩ, and internal energy, EΩ, of a domain Ω are caused either by the mechanical 
power of forces applied to the system, Pext, or by exchanged heat rate, Qexch (2.3.53 
in Ref. 4):

 (4-7)

Mass and momentum balance are needed to complete the description of the system. 
The mechanical laws, either for solids or fluids, generate the following balance 
equation between variation of kinetic energy, KΩ, stress power, Pstr, and power of 
applied forces, Pext (2.3.64 in Ref. 4):

 (4-8)

This equation involves quantities of the macroscopic level where the variation of the 
kinetic energy due to some forces applied to it reflects a sensible displacement. In 
COMSOL Multiphysics, the Solid Mechanics or Single-Phase Flow interfaces are 
examples of physics interfaces that simulate the macroscopic level described by 
Equation 4-8.

EΩd
td

-----------
KΩd
td

-----------+ Pext Qexch+=

KΩd
td

----------- Pstr+ Pext=
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Combining Equation 4-7 and Equation 4-8 yields the so-called heat balance equation 
(2.3.65 in Ref. 4):

 (4-9)

This time, the equation involves quantities of the microscopic level (exchanged heat 
rate, Qexch, and internal energy, EΩ) more concerned with the atomic vibrations and 
similar microscopic phenomena that are felt as heat. The presence of the stress power, 
Pstr, in both Equation 4-8 and Equation 4-9 stands for the fact that such power is 
converted into heat by dissipation. The Heat Transfer interfaces, described in the next 
sections, simulate the heat exchanges described by Equation 4-9.

L O C A L I Z E D  F O R M

In this paragraph, the different terms of Equation 4-9 are more detailed to obtain the 
localized form of the heat balance equation.

Variation of Internal Energy
The equations given in the previous paragraph holds for a given macroscopic 
continuous domain Ω where the internal energy is defined using the specific internal 
energy (per unit mass), E, as:

Note that by conservation of mass, the variation of internal energy in time is:

In these last relations, ρ is the density, and dv denotes an elementary volume of Ω. 
Contrary to the constant elementary mass, dm, the elementary volume changes by 
expansion or contraction of the domain. Recall that the derivation operator d ⁄ dt 
under the integrals is in the material frame (see Time Derivative in the Frames for the 
Heat Transfer Equations section).

Stress Power
The stress power, derived from the Continuum Mechanics theory, is defined by 
(2.3.59 in Ref. 4):

EΩd
td

----------- Pstr Qexch+=

EΩ E md
Ω
=

EΩd
td

-----------
td

dE md
Ω
 ρ

td
dE vd

Ω
= =

Pstr σ:D( ) vd
Ω
=
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where σ is the Cauchy stress tensor and D is the strain rate tensor. The operation “:” 
is a contraction and can in this case be written on the following form:

Note that in fluid mechanics, the Cauchy stress tensor is divided into a static part for 
the pressure, p, and a symmetric deviatoric part, τ, as in:

 (4-10)

so that Pstr becomes the following sum of pressure-volume work and viscous 
dissipation:

Equivalently, the stress power can also be expressed as:

Exchanged Heat
Finally, the exchanged heat rates, Qexch, account for thermal conduction (see Fourier’s 
Law at Equation 4-6), radiation and potentially additional heat sources. Joule heating 
and exothermic chemical reactions are such examples of domain heat source. The 
different kinds of exchanged heat are summarized by the equality below:

Recall the following notations used above: q for the heat flux by conduction, qr for 
the heat flux by radiation, Q for additional heat sources, and n for the external normal 
vector to the boundary ∂Ω.

Localized Heat Balance Equation
With all these elements, the heat balance equation (Equation 4-9) becomes:

 (4-11)

which leads to the following localized form in the material frame:

a:b anmbnm

m


n
=

σ pI– τ+=

Pstr p ∇ u⋅( ) vd
Ω
 τ: u∇( ) vd

Ω
–=

Pstr
1

det F( )
----------------- P:

td
dF

 
  vd

Ω
=

Qexch q n⋅( ) sd
∂Ω
– qr n⋅( ) sd

∂Ω
– Q vd

Ω
+=

ρ
td

dE vd
Ω
 q n⋅( ) sd

∂Ω
 qr n⋅( ) sd

∂Ω
+ + σ:D( ) vd

Ω
 Q vd

Ω
+=
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 (4-12)

or equivalently in the spatial frame:

 (4-13)

This verbally means that variations of internal energy in time are balanced by 
convection of internal energy, thermal conduction, radiation, dissipation of mechanical 
stress and additional volumetric heat sources. In the next sections, Equation 4-13 will 
be derived to obtain the heat transfer equations in different media.

Consistency with Mass and Momentum Conservation Laws

Although the heat transfer interfaces only solve for the energy equation, the context 
leading to Equation 4-13 does account for the three additional conservation laws that 
complete the Continuum Mechanics theory:

• Conservation of mass

• Conservation of linear momentum

• Conservation of angular momentum

The equations corresponding to each of them are recalled below in Table 4-1. For 
more details about the theory of Solid and Fluid Mechanics, see the Structural 
Mechanics Module User’s Guide and CFD Module User’s Guide.

ρ
td

dE ∇ q qr+( )⋅+ σ:D Q+=

ρ
t∂

∂E ρu ∇E⋅ ∇ q qr+( )⋅+ + σ:D Q+=

See Frames for the Heat Transfer Equations for more details about the use 
of material and spatial frames in the Heat Transfer interfaces.

TABLE 4-1:  CONSERVATION OF MASS AND MOMENTUM

CONSERVATION LAW MATHEMATICAL 
EXPRESSION IN 
MATERIAL FRAME

MATHEMATICAL EXPRESSION IN SPATIAL 
FRAME

Conservation of 
Mass

Conservation of 
Linear Momentum

Conservation of 
Angular Momentum

ρ0 ρdet F( )=

t∂
∂ρ ∇ ρu( )⋅+ 0=

ρ
td

du ∇ σ⋅ Fv+= ρ
t∂

∂u ρ u ∇⋅( )u+ ∇ σ⋅ Fv+=

σT σ= σT σ=
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When modeling a heat transfer problem with one of the Heat Transfer interfaces, the 
aforementioned laws needs to be respected. For example, the velocity field, u, 
provided in the energy equation and responsible for convection in a fluid, should 
satisfy the continuity equation here below in order to avoid unphysical results.

This is especially true when the velocity field is not computed from an additional 
physics interface — such as Single-Phase Flow that solves for the continuity equation 
— but instead defined by a custom expression in a Heat Transfer interface.

t∂
∂ρ ∇ ρu( )⋅+ 0=
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Th eo r y  f o r  Hea t  T r a n s f e r  i n  S o l i d s

The Heat Transfer in Solids Interface solves for the following equation derived from 
Equation 4-13:

 (4-14)

The different quantities involved here are recalled below:

• ρ is the density (SI unit: kg/m3)

• Cp is the specific heat capacity at constant stress (SI unit: J/(kg·K))

• T is the absolute temperature (SI unit: K)

• utrans is the velocity vector of translational motion (SI unit: m/s)

• q is the heat flux by conduction (SI unit: W/m2)

• qr is the heat flux by radiation (SI unit: W/m2)

• α is the coefficient of thermal expansion (SI unit: 1/K)

• S is the second Piola-Kirchhoff stress tensor (SI unit: Pa)

• Q contains additional heat sources (SI unit: W/m3)

For a steady-state problem the temperature does not change with time and the terms 
with time derivatives disappear.

The first term on the right-hand side of Equation 4-14 is the thermoelastic damping 
and accounts for thermoelastic effects in solids:

 (4-15)

It should be noted that the d ⁄ dt operator is the material derivative, as described in the 
Time Derivative subsection of Material and Spatial Frames.

ρCp
∂T
∂t
------- utrans ∇⋅ T+ 
  ∇ q qr+( )⋅+ αT:

td
dS

– Q+=

Qted αT:
td

dS
–=
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Th eo r y  f o r  Hea t  T r a n s f e r  i n  F l u i d s

The Heat Transfer in Fluids Interface solves for the following equation (11.2-5 in 
Ref. 5):

 (4-16)

which is derived from Equation 4-13, considering that:

• the Cauchy stress tensor, σ, is split into static and deviatoric parts as in:

• the dependent variables are the temperature, T, and pressure, p.

The different quantities involved here are recalled below:

• ρ is the density (SI unit: kg/m3)

• Cp is the specific heat capacity at constant pressure (SI unit: J/(kg·K))

• T is the absolute temperature (SI unit: K)

• u is the velocity vector (SI unit: m/s)

• q is the heat flux by conduction (SI unit: W/m2)

• qr is the heat flux by radiation (SI unit: W/m2)

• αp is the coefficient of thermal expansion (SI unit: 1/K):

for ideal gases, the thermal expansion coefficient takes the simpler form αp = 1 ⁄ T

• p is the pressure (SI unit: Pa)

• τ is the viscous stress tensor (SI unit: Pa)

• Q contains heat sources other than viscous dissipation (SI unit: W/m3)

For a steady-state problem the temperature does not change with time and the terms 
with time derivatives disappear.

The first term of the right-hand side of Equation 4-16 is the work done by pressure 
changes and is the result of heating under adiabatic compression as well as some 
thermoacoustic effects. It is generally small for low Mach number flows.

ρCp
∂T
∂t
------- u ∇⋅ T+ 
  ∇ q qr+( )⋅+ αpT

t∂
∂p u p∇⋅+ 
  τ: u∇ Q+ +=

σ pI– τ+=

αp
1
ρ
---

T∂
∂ρ

–=
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 (4-17)

The second term represents viscous dissipation in the fluid:

 (4-18)

Qp αpT
t∂

∂p u p∇⋅+ 
 =

Qvd τ: u∇=
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Th eo r y  f o r  B i o h e a t  T r a n s f e r

The Bioheat Equation

The Bioheat Transfer Interface solves for the bioheat equation using Pennes’ 
approximation (Ref. 6). This is used to model heat transfer within biological tissue. It 
accounts for heat sources from blood perfusion and metabolism in the classical heat 
transfer equation:

 (4-19)

The different quantities involved here are recalled below:

• ρ is the density of the tissue (SI unit: kg/m3)

• Cp is the specific heat capacity at constant pressure of the tissue (SI unit: J/(kg·K))

• T is the absolute temperature of the tissue (SI unit: K)

• q is the heat flux by conduction in the tissue (SI unit: W/m2)

• ρb is the blood density (SI unit: kg/m3)

• Cp, b is the blood specific heat capacity at constant pressure (SI unit: J/(kg·K))

• ωb is the blood perfusion rate (SI unit: 1/s)

• Tb is the arterial blood temperature (SI unit: K)

• Qmet is the metabolic heat source (SI unit: W/m3)

For a steady-state problem the temperature does not change with time and the terms 
with time derivatives disappear.

Damaged Tissue

On the Biological Tissue node, select the Include damage integral analysis check box to 
calculate tissue damage. 

ρ C p t∂
∂T ∇ q⋅+ ρb Cp b, ωb Tb T–( ) Qmet+=

There are specific predefined materials available in the Bioheat material 
database. See Materials Overview and Bioheat Materials Database in the 
COMSOL Multiphysics Reference Manual.
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In hyperthermia and cryogenic processes, tissue necrosis (permanent damage or death 
of living tissue) occurs when one of the two phenomenas happens:

• an excessive thermal energy is absorbed (hyperthermia process) or released 
(cryogenic process),

• a critical high (hyperthermia process) or low (cryogenic process) temperature is 
exceeded.

Correspondingly, COMSOL Multiphysics has two ways to model energy absorption 
— computing the period of time the tissue remained in the necrotic temperature 
interval and direct time integration of the energy.

First Form Integral
In the first form of damage integral, tissue necrosis occurs in four cases:

• When the temperature exceeds the hyperthermia damage temperature Td, h for 
more than a certain time period td, h,

• When the temperature falls below the cryogenic damage temperature Td, c for more 
than a certain time period td, c,

• Instantly after the temperature exceeds the hyperthermia necrosis temperature 
Tn, h,

• Instantly after the temperature falls below the cryogenic necrosis temperature Tn, c.

For the first two cases, the damaged tissue indicator, α1, defined by

is the ratio of the period of time when T > Td, h to the time limit td, h, plus the ratio of 
the period of time when T < Td, c to the time limit td, c. It gives an indication of 
damage state of the tissue. When it reaches 1, the tissue is necrotic. The fraction of 
necrotic tissue corresponds to the quantity min(α1, 1).

For the last two cases, the necrosis time indicator, α2, defined by

α1
1

td h,
---------- ϕd h, td

0

t

 1
td c,
--------- ϕd c, td

0

t

+=

ϕd h, t( )
1
0




=
if T Td h,>

otherwise
ϕd c, t( )

1
0




=
if T Td c,<

otherwise

α2 ϕn h, td
0

t

 ϕn c, td
0

t

+=
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evaluates the period of time when T > Tn, h plus the period of time when T < Tn, c. If 
α2 > 0, the tissue is necrotic because it already reached the necrosis temperatures Tn, h 
or Tn, c at some time step of the simulation. Hence, the fraction of necrotic tissue due 
to immediate necrosis is equal to 1 if α2 > 0 and 0 otherwise.

Combining all cases, the overall fraction of necrotic tissue, θd, is equal to:

 (4-20)

Second Form Integral
The second form of damage integral is applicable only for hyperthermia processes and 
provides the degree of tissue injury, α, based on the Arrhenius equation:

Here, A is the frequency factor (SI unit: 1/s), and ΔE is the activation energy for the 
irreversible damage reaction (SI unit: J/mol). The parameters A and ΔE are dependent 
on the type of tissue and have been characterized for liver tissues by Jacques et others 
(Ref. 7) to be A = 7.39 ⋅ 1039 s–1 and ΔE = 2.577 ⋅ 105 J/mol. See Ref. 8, Ref. 9, and 
Ref. 10 for the characterization of these parameters for prostate, skin, and fat. See also 
Ref. 11 and Ref. 12 for more references on biological tissues material properties.

The fraction of necrotic tissue is then expressed by:

 (4-21)

Thermal Properties
The material properties of the damaged tissue is redefined to take into account the 
influence of tissue injury. If ρd, Cp, d, and kd denote the density, heat capacity at 
constant pressure, and thermal conductivity of the necrotic tissue, respectively, then 
two effective quantities are defined:

• The effective thermal conductivity, keff = θdkd + (1 − θd)k

• The effective heat capacity at constant pressure, (ρCp)eff = θdρdCp, d + (1 − θd)ρCp

ϕn h, t( )
1
0




=
if T Tn h,>

otherwise
ϕn c, t( )

1
0




=
if T Tn c,<

otherwise

θd
1

min α1 1,( )



=
if α2 0>

otherwise

α Ae
ΔE–

RT
-----------

td
0

t

=

θd 1 e α–
–=
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In these equalities, θd takes one of the two definitions given above in Equation 4-20 
or Equation 4-21 according to the integral form chosen.

Heat source
A cooling or heating source is associated with the reaction leading to damage of tissue. 
Depending on the damage integral model, this source is expressed as follows:

• Temperature threshold for hyperthermia analysis:

• Temperature threshold for cryogenic analysis:

• Energy absorption:

Q ρLd h,
∂θd
∂t

--------- T Td h,>( )–=

Q ρLd c,
∂θd
∂t

--------- T Td c,<( )=

Q ρL
∂θd
∂t

----------–=
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Th eo r y  f o r  Hea t  T r a n s f e r  i n  Po r ou s  
Med i a

The heat transfer equation for porous media is derived from the mixture rule on 
energies appearing in solid and fluid heat transfer equations (see Ref. 13). For 
undeformed immobile solids, Equation 4-14 simplifies into:

and for a fluid domain where pressure work and viscous dissipation are neglected, 
Equation 4-16 becomes:

The mixture rule applies by multiplying the first equation by the solid volume fraction, 
θp, multiplying the second one by the porosity, 1−θp, and summing resulting 
equations. 

The local thermal equilibrium hypothesis assumes equality of temperature in both fluid 
and solid phases:

 (4-22)

The theory for this hypothesis is detailed in the section Local Thermal Equilibrium 
below. Otherwise, the Local Thermal Non-Equilibrium section describes the theory 
for modeling heat transfer in porous media using two temperatures.

When Should Local Thermal Equilibrium and Non-Equilibrium be 
Considered?

The classical local equilibrium hypothesis in modeling heat transfer in porous media 
considers pointwise equality of solid and fluid temperatures as said in Equation 4-22. 
The Local Thermal Equilibrium section below details the derivation of the energy 
equation considering such assumption that remains accurately sufficient for several 
applications. Ref. 29 shows for instance that solid and fluid temperatures are equal in 
steady conduction problems where only prescribed temperature conditions are 

ρsCp s,
∂Ts
∂t

--------- ∇ qs⋅+ Qs=

ρfCp f,
∂Tf
∂t

--------- ρfCp f, uf ∇Tf ∇ qf⋅+⋅+ Qf=

Tf Ts T= =
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applied. Most slow motion problems can also assume equality of phase temperatures if 
volumetric internal heating do not differ in both materials.

In the case of conduction in porous plates, Ref. 30 provides criteria based on the 
dimensionless Sparrow number, Sp, to indicate if temperature equilibrium is still valid 
or if a non-equilibrium point of view should be preferred. In Ref. 31, the influence of 
the Darcy number, Da, and the ratio of phase conductivities is examined for transient 
heat transfer in packed beds. The Sparrow and Darcy numbers are defined by:

where:

• hsf is the interstitial heat transfer coefficient between solid and fluid phases (SI unit: 
W/(m2·K))

• L is the plate layer thickness (SI unit: m)

• keff is the equivalent thermal conductivity of the porous medium (SI unit: 
W/(m·K))

• rh is the hydraulic radius (SI unit: m)

• κ is the permeability (SI unit: m2)

• d is the average particle diameter (SI unit: m)

In the situations described in Ref. 30 and Ref. 31, small values of Sp (less than 100 or 
500) and large values of Da (from order of magnitude 10-7) indicate discrepancies of 
temperature in each phase. However, in general, assessing the validity of local thermal 
equilibrium assumption remains not straightforward in specific situations. The Local 
Thermal Non-Equilibrium approach, described below, makes use of two energy 
equations, one for each phase of the porous medium, that solve for two temperature 
fields. It numerically doubles the number of freedom to solve but provides a general 
frame for heat transfer in porous media where evaluating the validity of the equilibrium 
hypothesis is not required anymore.

Local Thermal Equilibrium

The local thermal equilibrium hypothesis of Equation 4-22 implies a common 
temperature, T, for both solid and fluid phase. The Heat Transfer in Porous Media 
Interface solves for the following version of the heat equation (Ref. 16), reformulated 
using T:

Sp
hsfL

2

keffrh
---------------= Da κ

d2
------=
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 (4-23)

 (4-24)

The different quantities appearing here are:

• ρ is the fluid density.

• Cp is the fluid heat capacity at constant pressure.

• (ρCp)eff is the effective volumetric heat capacity at constant pressure, defined by

• keff is the effective thermal conductivity (a scalar or a tensor if the thermal 
conductivity is anisotropic).

• q is the conductive heat flux.

• u is the velocity field, either an analytic expression or computed from a Fluid Flow 
interface. It should be interpreted as the Darcy velocity, that is, the volume flow rate 
per unit cross sectional area. The average linear velocity (the velocity within the 
pores) can be calculated as uf = u/(1−θp), where (1−θp) is the fluid’s volume fraction, 
or equivalently the porosity.

• Q is the heat source (or sink). Add one or several heat sources as separate physics 
features.

For a steady-state problem the temperature does not change with time, and the terms 
with time derivatives of Equation 4-23 disappear.

The effective thermal conductivity of the solid-fluid system, keff, is related to the 
conductivity of the solid, kp, and to the conductivity of the fluid, k, and depends in a 
complex way on the geometry of the medium. In Ref. 13, three models are proposed 
for an isotropic medium:

• If the heat conduction occurs in parallel in the solid and the fluid, then the effective 
thermal conductivity is the weighted arithmetic mean of the conductivities k and kp:

This volume average model provides an upper bound for the effective thermal 
conductivity.

ρCp( )eff
∂T
∂t
------- ρCpu ∇T ∇ q⋅+⋅+ Q=

q keff∇T–=

ρCp( )eff θpρpCp p, 1 θp–( )ρCp+=

keff θpkp 1 θp–( )k+=
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• If the heat conduction takes place in series, with all of the heat flux passing through 
both solid and fluid, then the effective thermal conductivity is the weighted 
harmonic mean of the conductivities k and kp:

This reciprocal average model provides a lower bound for the effective thermal 
conductivity.

• A last estimate is given by the weighted geometric mean of k and kp: 

This model provides a good estimate as long as k and kp are not too different from 
each other.

When k and kp are equal the three models give the same effective thermal conductivity.

Local Thermal Non-Equilibrium

The Local Thermal Non-Equilibrium Interface implements heat transfer in porous 
media for which the temperatures into the porous matrix and the fluid are not in 
equilibrium.

E Q U A T I O N S  F O R  L O C A L  N O N - E Q U I L I B R I U M  H E A T  TR A N S F E R

Non-equilibrium heat transfer in porous media for binary systems of rigid porous 
matrix and fluid phase are governed by a set of two equations. These are the usual heat 
equations for solids and fluids, multiplied by the volume fractions θp and (1 − θp) 
respectively, and with an additional source term quantifying exchanged heat between 
both phases (2.12 and 2.13 in Ref. 13):

 (4-25)

1
keff
---------

θp
kp
------

1 θp–( )
k

--------------------+=

keff kp
θp k

1 θp–
⋅=

θpρsCp s,
Ts∂
t∂

--------- ∇ qs⋅+ qsf Tf Ts–( ) θpQs+=

qs θpks Ts∇–=

1 θp–( )ρfCp f,
Tf∂
t∂

-------- 1 θp–( )ρfCp f, uf Tf∇⋅ ∇ qf⋅+ + qsf Ts Tf–( ) 1 θp–( )Qf+=

qf 1 θp–( )kf Tf∇–=
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In these expressions:

• θp is the solid volume fraction (SI unit: 1)

• ρs and ρf are the solid and fluid densities (SI unit: kg/m3)

• Cp, s and Cp, f are the solid and fluid heat capacities at constant pressure (SI unit: 
J/(kg·K))

• qs and qf are the solid and fluid conductive heat fluxes (SI unit: W/m2)

• ks and kf are the solid and fluid thermal conductivities (SI unit: W/(m·K))

• qsf is the interstitial convective heat transfer coefficient (SI unit: W/(m3·K))

• Qs and Qf are the solid and fluid heat sources (SI unit: W/m3)

• uf is the fluid velocity vector (SI unit: m/s)

The fluid velocity is often deduced from a porous velocity up, coming for example 
from Darcy’s law or Brinkman equations, according to:

so that the heat equations in the fluid domain reduces to:

 (4-26)

The Local Thermal Non-Equilibrium multiphysics coupling adds the exchanged 
opposite heat sources qsf(Tf − Ts) and qsf(Ts − Tf) that one phase receives from or 
releases to the other when respective temperatures differ. The porous temperature, T, 
has the following definition (Ref. 32):

C O R R E L A T I O N  F O R  T H E  I N T E R S T I T I A L  C O N V E C T I V E  H E A T  TR A N S F E R  

C O E F F I C I E N T

The Local Thermal Non-Equilibrium multiphysics feature provides a built-in 
correlation for qsf in the spherical pellet bed configuration (2.14, 2.15, and 2.16 in 
Ref. 13):

uf
up

1 θp–
---------------=

1 θp–( )ρfCp f,
Tf∂
t∂

-------- ρfCp f, up Tf∇⋅ ∇ qf⋅+ + qsf Ts Tf–( ) 1 θp–( )Qf+=

qf 1 θp–( )kf Tf∇–=

T
θpρsCp s, Ts 1 θp–( )ρfCp f, Tf+

θpρsCp s, 1 θp–( )ρfCp f,+
--------------------------------------------------------------------------------=

qsf asfhsf=
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The specific surface area, asf (SI unit: 1/m), for a bed packed with spherical particles 
of radius rp is:

The interstitial heat transfer coefficient, hsf (SI unit: W/(m2·K)), satisfies the relation:

where β = 10 for spherical particles, and Nu is the fluid-to-solid Nusselt number 
derived from following correlation (Ref. 14):

The Prandtl number, Pr, and particle Reynolds number, Rep, are defined by:

VO L U M E T R I C  A N D  S U R F A C E  T H E R M A L  C O N D I T I O N S

Because the Local Thermal Non-Equilibrium multiphysics coupling multiplies each 
energy equation by its volume fraction, θp and (1 − θp) for solid and fluid phases 
respectively, a heat source or heat flux defined in a couple heat transfer interface is also 
accounted with that ratio. As shown in Equation 4-25 and Equation 4-26, the 
volumetric heat sources θpQs and (1 − θp)Qf are applied to the energy equations while 
the Heat Source features of each physics interface specify Qs and Qf.

asf
6θp
2rp
---------=

1
hsf
-------

2rp
kfNu
--------------

2rp
βks
---------+=

Nu 2.0 1.1Pr1 3⁄ Rep
0.6

+=

Pr
μCp f,

kf
--------------= Rep

2rpρf uf

μ
--------------------------=
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Th eo r y  f o r  Hea t  T r a n s f e r  w i t h  Pha s e  
Chang e

The Phase Change Material node is used to solve the heat equation after specifying the 
properties of a phase change material according to the apparent heat capacity 
formulation.

Instead of adding a latent heat L in the energy balance equation exactly when the 
material reaches its phase change temperature Tpc, it is assumed that the 
transformation occurs in a temperature interval between Tpc − ΔT ⁄ 2 and Tpc + ΔT ⁄ 2. 
In this interval, the material phase is modeled by a smoothed function, θ, representing 
the fraction of phase before transition, which is equal to 1 before Tpc − ΔT ⁄ 2 and to 
0 after Tpc + ΔT ⁄ 2. The density, ρ, and the specific enthalpy, H, are expressed by:

where the indices ph1 and ph2 indicate a material in phase 1 or in phase 2, respectively. 
Differentiating with respect to temperature, this equality provides the following 
formula for the specific heat capacity:

which becomes, after some formal transformations:

Here, θ1 and θ2 are equal to θ and 1−θ, respectively. The mass fraction, αm, is defined 
from ρph1, ρph2 and θ according to:

It is equal to −1 ⁄ 2 before transformation and 1 ⁄ 2 after transformation. The specific 
heat capacity is the sum of an equivalent heat capacity Ceq:

ρ θρph1 1 θ–( )ρph2+=

H 1
ρ
--- θρph1Hph1 1 θ–( )ρph2Hph2+( )=

Cp T∂
∂H

=

Cp
1
ρ
--- θ1ρph1Cp ph1, θ2ρph2Cp ph2,+( ) Hph2 Hph1–( )

αmd
Td

-----------+=

αm
1
2
---

θ2ρph2 θ1ρph1–

ρ
-------------------------------------------=
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and the distribution of latent heat CL:

The latent heat distribution CL is approximated by

so that the total heat per unit volume released during the phase transformation 
coincides with the latent heat:

Finally, the apparent heat capacity, Cp, used in the heat equation, is given by:

The effective thermal conductivity reduces to:

and the effective density is:

Ceq
1
ρ
--- θ1ρph1Cp ph1, θ2ρph2Cp ph2,+( )=

CL T( ) Hph2 Hph1–( )
αmd
Td

-----------=

In the ideal case, when 1 − θ is the Heaviside function (equal to 0 before 
Tpc and to 1 after Tpc), dαm ⁄ dT is the Dirac pulse.

Therefore, CL is the enthalpy jump, L, at temperature Tpc that is added 
when you have a pure substance.

CL T( ) L
αmd
Td

-----------=

CL T( ) Td
Tpc

ΔT
2

--------–

Tpc
ΔT
2

--------+

 L
αmd
Td

----------- Td
Tpc

ΔT
2

--------–

Tpc
ΔT
2

--------+

 L= =

The latent heat, L, can depend on the absolute pressure but should not 
depend on the temperature.

Cp
1
ρ
--- θ1ρph1Cp ph1, θ2ρph2Cp ph2,+( ) CL+=

k θ1kph1 θ2kph2+=

ρ θ1ρph1 θ2ρph2+=
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To satisfy energy and mass conservation in phase change models, particular attention 
should be paid to the density in time simulations. When the material density is not 
constant over time, for example, dependent on the temperature, volume change is 
expected. The transport velocity field and the density must be defined so that mass is 
conserved locally. 

Moving Mesh Interface (described in the COMSOL Multiphysics 
Reference Manual) can be used to account for model deformation.
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Th eo r y  f o r  Hea t  T r a n s f e r  i n  Bu i l d i n g  
Ma t e r i a l s

The Heat Transfer in Building Materials Interface solves for the following equations 
derived from Ref. 15:

 (4-27)

 (4-28)

which is derived from Equation 4-13, considering the building material as a porous 
medium in local thermal equilibrium in which the following mixing rules apply:

• (ρCp)eff (SI unit: J/(m3·K)) is the effective volumetric heat capacity at constant 
pressure, defined to account for both solid matrix and moisture properties:

where ρs (SI unit: kg/m3) is the dry solid density, Cp,s (SI unit: J/(kg·K)) is the dry 
solid specific heat capacity, w (SI unit: kg/m3) is the water content given by a 
moisture storage function, and Cp,w (SI unit: J/(kg·K)) is the water heat capacity at 
constant pressure.

• keff (SI unit: W/(m·K)) is the effective thermal conductivity, defined in function of 
the solid matrix and moisture properties:

where ks (SI unit: W/(m·K)) is the dry solid thermal conductivity and b 
(dimensionless) is the thermal conductivity supplement.

This definition neglects the contribution due to the volume fraction change of the 
moist air.

The heat source due to moisture content variation is expressed as the vapor diffusion 
flow multiplied by latent heat of evaporation:

ρCp( )eff
∂T
∂t
------- ∇ q⋅+ Q=

q keff∇T Lvδp φpsat( )∇+( )–=

ρCp( )eff ρsCp s, wCp w,+=

keff ks 1 bw
ρs
--------+ 

 =

Lvδp φpsat( )∇
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where Lv (SI unit: J/kg) is the latent heat of evaporation, δp (SI unit: s) is the vapor 
permeability, φ (dimensionless) is the relative humidity, and psat (SI unit: Pa) is the 
vapor saturation pressure.
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Th eo r y  f o r  Ha rmon i c  Hea t  T r a n s f e r

When submitted to periodic sinusoidal heat loads at a given frequency, the temperature 
response of a body can, in some cases, be assumed periodic, sinusoidal, and of same 
frequency around an equilibrium temperature. If the temperature changes are small 
enough or if the thermal properties are constant, this time-dependent periodic 
problem may be replaced by an equivalent linear steady-state problem in the frequency 
domain, which is far less computationally expensive. The Heat Transfer interfaces 
support such frequency domain studies via the Thermal Perturbation, Frequency Domain 
study sequence. 

In complex notations, the aforementioned temperature decomposition is expressed as:

 (4-29)

where T0 is the equilibrium temperature that verifies the steady-state heat transfer 
equation and may come from the solution of a previous study, T′ is the complex 
amplitude of the harmonic perturbation around T0, and ω is the angular frequency, 
related to the ordinary frequency, f, according to

Note: The amplitude, T′, is complex-valued since it includes the phase term ejϕ.

From the temperature decomposition in Equation 4-29, and according to the heat 
transfer equation in Equation 4-14, heat transfer by conduction in solids is then 
governed by:

where Q′ejωt is the harmonic perturbation in domain around an average heat source, 
Q. Removing the terms of the steady-state heat transfer equation satisfied by T0, and 
simplifying by ejωt, this reduces to:

T t( ) T0 T'ejωt
+=

ω 2πf=

jωρCpT'ejωt ∇ k∇T0–( )⋅ ∇ k∇T'–( )ejωt⋅+ + Q Q+ 'ejωt
=

jωρCpT' ∇ k∇T'–( )⋅+ Q'=
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which is the governing equation for T′. For constant material properties, the linearized 
form reads:

 (4-30)

and for nonlinear material properties:

 (4-31)

Here, ρ0, Cp, 0, and k0 denote the density, heat capacity at constant pressure, and 
thermal conductivity, evaluated at T0, that is: ρ(T0), Cp(T0), and k(T0), respectively.

When the linearized heat transfer equation, such as Equation 4-30 or Equation 4-31, 
can still describe the model accurately, the problem becomes steady-state in the 
frequency domain, therefore computationally less expensive than a time-dependent 
simulation. An automatic linearization process is performed by COMSOL 
Multiphysics so that no additional action is needed from the user to get these 
equations, even in the presence of temperature-dependent coefficients, in domains and 
boundaries. Only the expressions of the material properties and other parameters, as 
functions of the temperature, are required as for usual nonlinear modeling.

Harmonic loads can be prescribed through temperature harmonic constraints on 
boundaries or heat sources on domains and boundaries.

jωρ0Cp 0, T' ∇ k0∇T'–( )⋅+ Q'=

jωρ0Cp 0, T' ∇ k0∇T'– T'
T∂

∂k
 
 

T0

T0∇– 
 ⋅+ Q'=
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Th eo r y  f o r  L umped I s o t h e rma l  
Doma i n

The Isothermal Domain feature considers the temperature to be homogeneous in 
space but not necessarily in time. This is an approximation adapted to situations where 
a domain is nearly at the average temperature and with small fluctuations, for instance, 
solid objects made of conductive material immersed in water, or global temperature of 
a heated and well insulated room adjacent to a cold environment.

Recalling Equation 4-16 given previously in the Theory for Heat Transfer in Fluids 
section, without pressure-volume work and viscous dissipation, the equation to be 
solved reduces to:

Integrating this equation over the domain leads to:

 (4-32)

where the domain mass and the heat capacity at constant pressure are

ρCp td
dT ∇ q⋅+ Q=

mCp td
dT n q⋅( ) sd

S
+ Q vd

V
=

m ρ vd
V
= Cp

1
m
----- ρCp vd

V
=
T H E O R Y  F O R  L U M P E D  I S O T H E R M A L  D O M A I N  |  163



164 |  C H A P T E
The exterior boundaries of each Isothermal Domain need the heat exchange to be 
specified.

Figure 4-1: Interfaces at exterior boundaries of each Isothermal Domain.

COMSOL Multiphysics provides several types of interfaces: thermal insulation, 
continuity, ventilation, convective heat flux, and thermal contact.

T H E R M A L  I N S U L A T I O N

The Thermal insulation condition prevents any heat transfer between both adjacent 
domains.

C O N T I N U I T Y

The Continuity condition ensures equal temperature at both sides of the interface.

VE N T I L A T I O N

The Ventilation condition is used for cases when an isothermal domain is considered 
fluid and has an adjacent domain containing the same fluid. An opening lets the fluid 
going from one domain to another with a determined mass flux, denoted by ϕd → u or 
ϕu → d, respectively, along or opposite to the geometrical normal vector. The 
Ventilation condition is written

Isothermal domain 3

Isothermal domain 2

Isothermal domain 1

Isothermal domain interfaces
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 (4-33)

C O N V E C T I V E  H E A T  F L U X

The Convective heat flux condition is adapted to cases when an isothermal domain is 
considered solid and is adjacent to a fluid. Convection occurs at the interface with a 
specified heat transfer coefficient, h. The interface condition reads

 (4-34)

T H E R M A L  C O N T A C T

When an isothermal domain is considered solid and is adjacent to another solid, 
thermal contact occurs and is characterized by a given thermal resistance, Rt. At the 
interface, the condition Thermal contact reads

 (4-35)

nd– qd⋅ ϕd u→ Hd ϕu d→ Hu–=

nd– qd⋅ h– Tu Td–( )=

nd– qd⋅
Tu Td–

Rt
--------------------–=
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Th eo r y  f o r  Hea t  T r a n s f e r  i n  Th i n  
S t r u c t u r e s

In COMSOL Multiphysics, thin domains of solid, fluid or porous materials have 
dedicated tools to model them with boundaries instead of full domains. This way, 
simulations directly benefit from a reduced number of mesh elements. This section 
presents the hypotheses needed for such approximations and the resulting heat transfer 
equations that hold.

In this section:

• Modeling Thin Structures

• Theoretical Background of the Different Formulations

• Thin Layer

• Thin Film

• Fracture

• Thin Rod

Modeling Thin Structures

The Heat Transfer interfaces contain several lumped conditions for modeling heat 
transfer in thin domains: Thin Layer, Thin Film, Fracture, and Thin Rod. 

In addition, standalone physics interface are available for the modeling of heat transfer 
by conduction, convection and radiation in thin structures:

• The Heat Transfer in Thin Shells Interface

• The Heat Transfer in Thin Films Interface

• The Heat Transfer in Fractures Interface

Either the Thin Conductive Layer (Heat Transfer in Thin Shells Interface), Thin Film, 
or Fracture feature is available by default in each of these interfaces. The Thin Layered 
Shell (Heat Transfer in Thin Shells Interface) feature is also available to model 
multi-layered structures.

The features mentioned above are the counterparts of domain features for the 
modeling of heat transfer in solid, fluid, and porous thin structures that can be 
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represented as boundaries or edges, as described in Table 4-2.

All these functionalities have in common the fact that the thin domains they model are 
lumped into boundaries (for The Heat Transfer in Thin Shells Interface, Thin Layer, 
Thin Film and Fracture) or 3D edges (for Thin Rod).

R E D U C E D  M E S H  E L E M E N T  N U M B E R

A significant benefit is that a thin structure can be represented as a boundary instead 
of a domain and a rod can be represented as a 3D edge. This simplifies the geometry 
and reduces the required number of mesh elements. Figure 4-2 shows an example 
where a thin structure significantly reduces the mesh density.

Figure 4-2: Modeling a copper wire as a domain (top) requires a denser mesh compared to 
modeling it as a boundary with a conductive layer (bottom).

T H I N  S T R U C T U R E  A S  A N  E X T R A  D I M E N S I O N

To model heat transfer through the thickness of a thin structure, or multiple 
sandwiched layers with different material properties and thicknesses, COMSOL 
Multiphysics gives the possibility to create a product space between the dimensions of 
the boundary and an additional dimension. This is realized by the Extra Dimension 
tool through either the Thin Layered Shell (Heat Transfer in Thin Shells Interface) 

TABLE 4-2:  EQUIVALENT DOMAIN AND THIN STRUCTURES FEATURES

TYPE OF MEDIUM DOMAIN FEATURE BOUNDARY FEATURE EDGE FEATURE

Solid Solid Thin Layer (ht)

Thin Conductive 
Layer (ht, htsh)

Thin Rod (ht)

Fluid Fluid Thin Film (ht, htsh) —

Porous Porous Medium Fracture (ht, htsh) —

Copper wire modeled 
with a mesh

Copper wire represented 
as a thin structure
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feature or the General option of the Thin Layer and Thin Film features.

An additional 1D segmented line represents the thickness of the thin structure. The 
number of mesh points for each interval of the extra dimension is set to 2 by default. 

TA N G E N T I A L  A N D  N O R M A L  G R A D I E N T S

In thin structures, the tangential gradient and the normal gradient can be more 
appropriate to express the governing equations.

The normal gradient is the projection of the gradient operator onto the normal 
vector, n, of the boundary representing the thin structure. This is mathematically 
expressed for any scalar field T as:

The tangential gradient removes the normal component from the gradient 
operation, so that only tangential components remain. This is mathematically 
expressed for any scalar field T as:

The gradient operator is then split into a tangential part and a normal part:

 (4-36)

This relation simplifies to:

Adding Extra Dimensions to a Model and Using Extra Dimensions in the 
COMSOL Multiphysics Reference Manual.

Plotting Results in Thin Layers Extra Dimensions

∇nT ∇T n⋅( )n=

∇tT ∇T ∇T n⋅( )n–=

∇T ∇tT ∇nT+=

∇T ∇tT= or ∇T ∇nT=
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when tangential heat transfer is dominant or negligible. These results will be useful in 
the next sections describing heat transfer in the different thin structures.

T H E R M A L  C O N D U C T I V I T Y  T E N S O R  I N  L O C A L  B O U N D A R Y  S Y S T E M S

The thermal conductivity k describes the relationship between the heat flux vector q 
and the temperature gradient ∇T as in

which is Fourier’s law of heat conduction (see also The Physical Mechanisms under 
Heat Transfer).

The tensor components can be specified in the local coordinate system of the 
boundary, which is defined from the geometric tangent and normal vectors. The local 
x-direction, ex, loc, is the surface tangent vector t1, and the local z-direction, ez, loc, is 
the normal vector n. Their cross product defines the third orthogonal direction such 
that:

From this, a transformation matrix between the local coordinate system and the global 
coordinate system can be constructed in the following way:

The thermal conductivity tensor in the local coordinate system, kbnd, is then expressed 
as

It should be noted that when an extra dimension is used, the equations 
are written from the point of view of the extra dimension. In particular, 
the dtang() operator would correspond to ∇n since it performs the 
derivation along the extra line. In the thin structure boundary, dtang() 
would correspond to ∇t.

q k T∇–=

ex loc, t1=

ey loc, n t1×=

ez loc, n=

A

ex
x loc, ex

y loc, ex
z loc,

ey
x loc, ey

y loc, ey
z loc,

ez
x loc, ez

y loc, ez
z loc,

=
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Theoretical Background of the Different Formulations

Three formulations are available for the modeling of heat transfer in thin structures 
defined as boundaries:

• The general formulation, using the Extra Dimension tool to solve the equations 
into the boundaries and through the thin structure’s thickness

• The thermally thin approximation, a lumped formulation assuming that heat 
transfer mainly follows the tangential direction of the thin structure

• The thermally thick approximation, a lumped formulation assuming that heat 
transfer is dominant in the direction normal to the thin structure

They all derive from the energy equation established in Equation 4-13, and recalled 
here below:

where E is the variable for the internal energy.

G E N E R A L  F O R M U L A T I O N

The general formulation uses the Extra Dimension tool to solve the equations through 
the thin structure’s thickness. The thin structure has its domain represented by the 
product space between the lumped boundary and the additional dimension for the 
thickness. Applying the split of the gradient operator given earlier at Equation 4-36, 
the energy equation becomes

 (4-37)

The ∇t operator is the tangential derivative in the thin structure boundary, and the ∇n 
operator is the derivation operator along the extra dimension which is normal to the 
thin structure (see Tangential and Normal Gradients). The subscript s appended on E 
(and T in the following) is here to recall that this variable lives in the product space of 
the thin structure.

Equation 4-37 comes along with Fourier’s law of conduction:

 (4-38)

kbnd AkAT=

ρ
t∂

∂E ρu ∇E⋅ ∇ q qr+( )⋅+ + σ:D( )– Q+=

ρ
t∂

∂Es ρu ∇tEs ∇nEs+( )⋅ ∇ q qr+( )⋅+ + σ:D( )– Q+=

q k ∇tTs ∇nTs+( )–=
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and constraints on the temperature at the extremities of the extra dimension:

 (4-39)

Here, ds is the length of the extra dimension, or equivalently the thickness of the thin 
structure, and Tu and Td are the temperature at the upside and the downside of the 
thin structure.

T H E R M A L L Y  T H I N  A P P R O X I M A T I O N

This formulation applies to a thin structure where heat transfer mainly follows the 
tangential direction. The gradient operator is then simplified to

This assumption is often valid for thin structures that are good thermal conductors 
compared to the adjacent domains, and/or with fast convection along the tangential 
direction.

With these assumptions, Equation 4-13 becomes:

 (4-40)

 (4-41)

where ds is the layer thickness (SI unit: m). The heat source Q is a density distributed 
in the layer while q0 is the received out-of-plane heat flux.

When Equation 4-40 is solved in a boundary adjacent to a domain modeling heat 
transfer, the two entities exchange a certain amount of heat flux according to:

In this coupling relation, the outgoing heat flux n ⋅ q leaves the domain and is received 
in the source term q0 by the adjacent thin layer modeled as a boundary. From the point 
of view of the domain, and neglecting thermoelastic effects, the following heat source 
is received from the thin structure:

Tu Ts( )L 0=
= Td Ts( )L ds=

=

∇T ∇tT=

dsρ
t∂

∂E dsρu ∇tE⋅ ∇t qs qr+( )⋅+ + ds σ:D( )– dsQ q0+ +=

qs dsk∇tT–=

In 2D, Equation 4-40 and Equation 4-41 have an additional factor, dz, 
to account for the out-of-plane thickness.

q0 n q⋅=
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 (4-42)

Equations for all supported types of medium are presented in the next sections, Thin 
Layer, Thin Film, Fracture, and Thin Rod.

T H E R M A L L Y  T H I C K  A P P R O X I M A T I O N

This formulation applies to a thin structure where heat transfer mainly follows the 
normal direction. The gradient operator is then simplified to

This assumption is often valid for thin structures that are thermally resistive compared 
to the adjacent domains.

With these assumptions, Equation 4-13 becomes:

 (4-43)

 (4-44)

where ds is the layer thickness (SI unit: m). The heat source Q is a density distributed 
in the layer while q0 is the received out-of-plane heat flux.

When Equation 4-43 is solved in a boundary adjacent to a domain modeling heat 
transfer, the two entities exchange a certain amount of heat flux according to:

In this coupling relation, the outgoing heat flux n ⋅ q leaves the domain and is received 
in the source term q0 by the adjacent thin layer modeled as a boundary. From the point 
of view of the domain, and neglecting thermoelastic effects, the following heat source 
is received from the thin structure:

 (4-45)

n– q⋅ dsQs dsρ
t∂

∂E
– dsρu ∇tE⋅( )– ∇t qs qr+( )⋅–=

∇T ∇nT=

dsρ
t∂

∂E dsρu ∇nE⋅ ∇n qs qr+( )⋅+ + ds σ:D( )– dsQ q0+ +=

qs dsk∇nT–=

In 2D, Equation 4-43 and Equation 4-44 have an additional factor, dz, 
to account for the out-of-plane thickness.

q0 n q⋅=

n– q⋅ dsQs dsρ
t∂

∂E
– dsρu ∇nE⋅( )– ∇n qs qr+( )⋅–=
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To evaluate the normal gradient operation, ∇n, temperatures Tu and Td are 
introduced for the upside and downside of the thin structure boundary. They are 
defined from the heat flux across the thin resistive structure. At the middle of the 
thickness, the temperature, T1 ⁄ 2, is approximated by (1 ⁄ 2)(Tu + Td). The term 
∇n ⋅ (−dsk∇nT) is then given by:

which can be seen as the sum of two contributive sources on the upside and on the 
downside of the boundary that compensate:

Similarly, the time-dependent term can be expressed using Tu and Td by: 

leading to:

 (4-46)

 (4-47)

Equations for all supported types of medium are presented in the next sections, Thin 
Layer, Thin Film, Fracture, and Thin Rod.

∇n dsk∇nT–( )⋅ ks
Td 2T1 2⁄ Tu+–

ds
------------------------------------------–≈

ks
Tu Td–

ds
--------------------– ks

Td Tu–

ds
--------------------–

ρCp
∂T
∂t
------- ρCp

∂T1 2⁄
∂t

---------------≈ 1
2
---ρCp

∂Tu
∂t

---------- 1
2
---ρCp

∂Td
∂t

----------+=

nd– qd⋅
dsQ

2
----------- ρCp

ds
2
------

∂Td
∂t

---------- ud ndTd⋅+ 
 – ks

Tu Td–

ds
--------------------– 

 – qr d, nd⋅( )–=

nu– qu⋅
dsQ

2
----------- ρCp

ds
2
------

∂Tu
∂t

---------- uu nuTu⋅+ 
 – ks

Td Tu–

ds
--------------------– 

 – qr u, nu⋅( )–=
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U P S I D E ,  D O W N S I D E ,  A N D  E X T E R I O R  TE M P E R A T U R E S

This formulation is provided by the Thermally thick approximation option of the Thin 
Layer feature. Figure 4-3 shows how Thin Layer splits the temperature into Tu and Td 
on interior boundaries:

Figure 4-3: Upside and downside temperatures at a thin layer applied on an interior 
boundary. The thin layer is represented by the gray domain.

On exterior boundaries, it introduces a new degree of freedom represented by the 
variable TextFace. Depending on whether the heat domain is on the upside or the 
downside of the boundary, TextFace, is equal to Tu or Td and the same thing goes for 
the dependent variable T. An example is illustrated in the figure below:

Figure 4-4: Upside and downside temperatures at a thin layer applied on an exterior 
boundary.

TuTd

Thin Layer boundary

Upside domain 
of the boundary

Downside domain 
of the boundary

Tu = TextFace

T = Td

Downside domain 
of the boundary

Thin Layer boundary

When using the pair Thin Layer node, the u and d subscripts refer to the 
upside and the downside of the pair, respectively, instead of the layer.
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F O R M U L A T I O N S  A V A I L A B L E  W I T H I N  T H E  F E A T U R E S

Table 4-3 summarizes the formulations available within the thin structure features of 
the Heat Transfer (ht) and Heat Transfer in Thin Shells (htsh) interfaces.

Thin Layer

Thin layers of solid materials can be considered as boundaries when their thickness is 
significantly smaller than the typical lengths of the adjacent domains.

G E N E R A L  F O R M U L A T I O N

With this formulation, multiple sandwiched layers with different material properties 
and thicknesses can be modeled. An additional 1D segmented line represents the 
multiple layers in the thin structure. In this extra dimension, the governing equation 
is derived from Equation 4-37 to give:

 (4-48)

 (4-49)

Like any pair feature, the Thin Layer condition contributes to any other 
pair feature. However, do not use two conditions of the same type on the 
same pair. In order to model a thin resistive layer made of several 
materials, use the Multiple layers option, which is available with the Heat 
Transfer Module.

TABLE 4-3:  FORMULATIONS AVAILABLE WITH THE THIN STRUCTURES FEATURES

FEATURE GENERAL THERMALLY THIN 
APPROXIMATION

THERMALLY THICK 
APPROXIMATION

Thin layer (ht) Yes Yes Yes

Thin conductive layer (htsh) No Yes No

Thin layered shell (htsh) Yes No No

Thin film (ht, htsh) Yes Yes No

Fracture (ht, htsh) No Yes No

ρsiCp si,
∂Ts
∂t

--------- ∇t qsi⋅+ Qsi=

qsi ksi Ts Tn∇ s+t∇( )–=

Tu Ts( )L 0=
=

Td Ts( )L ds=
=
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where Ts is an auxiliary dependent variable defined on the product space. The 
remaining quantities are recalled below:

• ρsi is the density of layer i (SI unit: kg/m3)

• Cp, si is the heat capacity of layer i (SI unit: J/(kg·K))

• ksi is the thermal conductivity of layer i (SI unit: W/(m·K))

• Qsi is the heat source applied to layer i (SI unit: W/m3)

• ds is the shell thickness (SI unit: m)

The constraint T = Ts is specified on each side of the extra dimension to connect T to 
Ts.

T H E R M A L L Y  T H I N  A P P R O X I M A T I O N

The Heat Transfer Module supports heat transfer in thermally thin structures in 3D, 
2D, and 2D axisymmetry. The material in the thin structure might be a good thermal 
conductor for this approximation to be valid. For example, in a printed circuit with 
copper traces, where the traces are often good thermal conductors compared to the 
board’s substrate material.

The thermally thin approximation is derived from Equation 4-40 to Equation 4-42. 
Inside the thin layer, the heat equation becomes:

 (4-50)

 (4-51)

where ds is the layer thickness (SI unit: m). The heat source Qs is a density distributed 
in the layer while q0 is the received out-of-plane heat flux.

From the point of view of the domain, the following heat source, derived from 
Equation 4-42, is received from the layer:

See Thin Layer with Layer type set as General or more information about 
the boundary feature solving Equation 4-48 and Equation 4-49.

dsρCp s, t∂
∂T ∇t qs⋅+ dsQs q0+=

qs dsk Tt∇–=

In 2D, Equation 4-50 and Equation 4-51 have an additional factor, dz, 
to account for the out-of-plane thickness.
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 (4-52)

T H E R M A L L Y  T H I C K  A P P R O X I M A T I O N

When a thin layer is formed of one or more thermally resistive materials, it can be 
defined through its thermal resistance:

The heat flux across the thermally thick structure is derived from Equation 4-45 and 
gives

 (4-53)

 (4-54)

where the u and d subscripts refer to the upside and downside of the layer, respectively.

When the material has a multilayer structure, ks and ds in the expressions above are 
replaced by dtot and ktot, which are defined according to Equation 4-55 and 
Equation 4-56:

n– q⋅ dsQs dsρCp s,
∂T
∂t
-------– ∇t qs⋅–=

See Thin Layer with Layer type set as Thermally thin approximation for 
more information about the boundary feature solving Equation 4-52. See 
The Heat Transfer in Thin Shells Interface for more information about 
the physics interface solving Equation 4-50.

• Heat Transfer in a Surface-Mount Package for a Silicon Chip: 
Application Library path 
Heat_Transfer_Module/Power_Electronics_and_Electronic_Cooling/surface

_mount_package

• Silica Glass Block Coated with a Copper Layer: Application Library 
path Heat_Transfer_Module/Tutorials,_Thin_Structure/copper_layer

Rs
ds
ks
------=

nd– qd⋅ 1
2
---dsρsCp s,

∂Td
∂t

----------– ks
Tu Td–

ds
--------------------–

1
2
---dsQs+=

nu qu⋅–
1
2
---dsρsCp s,

∂Tu
∂t

----------– ks
Td Tu–

ds
--------------------–

1
2
---dsQs+=
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 (4-55)

 (4-56)

where n is the number of layers.

Thin Film

Thin films of fluid can be considered as boundaries of thickness significantly smaller 
than the typical lengths of the overall model. 

G E N E R A L  F O R M U L A T I O N

With this formulation, heat transfer is modeled in the whole film, including its 
thickness. An additional 1D segmented line represents the thickness in the thin film. 
In this extra dimension, the governing equation is derived from Equation 4-37 to give:

 (4-57)

 (4-58)

where Ts is an auxiliary dependent variable defined on the product space. The 
remaining quantities are recalled below:

• ρ is the density (SI unit: kg/m3)

• Cp is the heat capacity (SI unit: J/(kg·K))

dtot dsj

j 1=

n

=

ktot
dtot

dsj
ksj
-------

j 1=

n



------------------=

See Thin Layer with Layer type set as Thermally thick approximation for 
more information about the boundary feature solving Equation 4-53 and 
Equation 4-54.

ρCp
∂Ts
∂t

--------- ρCpu Ts Tn∇ s+t∇( )⋅ ∇+
t

qf⋅+ Qf=

qf k Ts Tn∇ s+t∇( )–=

Tu Ts( )L 0=
=

Td Ts( )L df=
=
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• k is the thermal conductivity (SI unit: W/(m·K))

• Qf is the heat source applied to the film (SI unit: W/m3)

• df is the film thickness (SI unit: m)

The constraint T = Ts is specified on each side of the extra dimension to connect T to 
Ts.

T H E R M A L L Y  T H I N  A P P R O X I M A T I O N

The thermally thin approximation is derived from Equation 4-40 to Equation 4-42. 
Inside the thin layer, the heat equation becomes:

 (4-59)

 (4-60)

where df is the film thickness (SI unit: m). The heat source Qf is a density distributed 
in the layer while q0 is the received out-of-plane heat flux.

From the point of view of the domain, the following heat source, derived from 
Equation 4-42, is received from the layer:

 (4-61)

See Thin Film with Thin film model set as General for more information 
about the boundary feature solving Equation 4-57 and Equation 4-58.

dfρCp
∂T
∂t
------- u ∇t⋅ T+ 
  ∇t qf⋅+ dfQf q0+=

qf dfk∇tT–=

In 2D, Equation 4-50 and Equation 4-51 have an additional factor, dz, 
to account for the out-of-plane thickness.

n– q⋅ dfQf dfρCp
∂T
∂t
-------– dfρCpu ∇t⋅ T– ∇t qf⋅–=

See Thin Film with Thin film model set as Thermally thin approximation for 
more information about the boundary feature solving Equation 4-59. See 
The Heat Transfer in Thin Films Interface for more information about 
the physics interface solving Equation 4-61.
T H E O R Y  F O R  H E A T  TR A N S F E R  I N  T H I N  S T R U C T U R E S  |  179



180 |  C H A P T E
Fracture

When fractures occur in porous media, fluid flow tends to move faster than in the bulk 
medium. The transport of heat occurs faster in the fractures that in the surrounding 
medium, so in this sense, heat transfer in fractures filled with fluids is more similar to 
a highly conductive layer than to a thin thermally resistive layer.

The mass transport in fractures can be modeled as Darcy’s law in a thin sheet of porous 
medium:

where u is the tangential Darcy’s velocity (SI unit: m/s), κ is the fracture permeability 
(SI unit: m2), μ the fluid’s dynamic viscosity (SI unit: Pa⋅s), and ∇tp the tangential 
gradient of the fluid’s pressure.

Typically, Darcy’s Law with tangential derivatives is solved to compute mass transport, 
so in addition to the fluid properties, the fracture should define its own permeability 
(or hydraulic conductivity in case the fluid is water), porosity, and fracture thickness.

For heat transfer in fractures, the fracture also needs to define the density of the porous 
sheet, heat capacity, and thermal conductivity. The effective thermal conductivity of 
the fracture must be adjusted to the fracture porosity and thermal conductivity of the 
fluid. In rocks and geological formations, the fracture might also contain highly 
conductive material, different than the bulk porous matrix.

The equation to solve for computing heat transfer in fractures is derived from 
Equation 4-40 to Equation 4-42 and using the procedure detailed in Theory for Heat 
Transfer in Porous Media to apply the mixture rule on solid and fluid internal energies. 
The resulting equations are:

 (4-62)

 (4-63)

Here (ρCp)eff is the effective heat capacity at constant pressure of the fracture-fluid 
volume, ρ is the fluid’s density, Cp is the fluid’s heat capacity at constant pressure, qfr 
is the conductive heat flux in the fracture-fluid volume, keff is the effective thermal 
conductivity of the fluid-fracture mixture, and Q is a possible heat source.

u κ
μ
---∇tp=

dfr ρCp( )eff t∂
∂T dfrρCpu ∇tT ∇t qfr⋅+⋅+ dfrQ q0+=

qfr dfrkeff∇tT–=
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From the point of view of the domain, the following heat source, derived from 
Equation 4-42, is received from the fracture:

 (4-64)

Thin Rod

The Thin Rod feature is similar to Thin Layer with Layer type set as Thermally thin 

approximation. It provides a lumped heat transfer model to model thermally thin rods 
as edges.

The edge condition reads:

 (4-65)

 (4-66)

with

n– q⋅ dfrQ0 dfr ρCp( )eff t∂
∂T

– dfrρCpu ∇tT⋅– ∇t qfr⋅–=

See Fracture for more information about the boundary feature solving 
Equation 4-64. See The Heat Transfer in Fractures Interface for more 
information about the physics interface solving Equation 4-62.

Q sd
S R( )
 AlQl AlρlCp l, t∂

∂T ∇t ql⋅–+–=

ql Alkl∇tT–=

Al πrl
2

=

See Thin Rod for node information.
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Th eo r y  f o r  S u r f a c e - t o - S u r f a c e  
Rad i a t i o n

In addition to conduction and convection, the third mechanism for heat transfer is 
radiation. Consider an environment with fully transparent or fully opaque objects. 
Thermal radiation denotes the stream of electromagnetic waves emitted from a body 
at a certain temperature.

The Surface-To-Surface Radiation Interface theory is described in this section:

• Deriving the Radiative Heat Flux

• Wavelength Dependence of Surface Emissivity and Absorptivity

• The Radiosity Method for Diffuse-Gray Surfaces

• The Radiosity Method for Diffuse-Spectral Surfaces

• View Factor Evaluation

Deriving the Radiative Heat Flux

In Figure 4-5, consider a point P located on a surface that has an emissivity ε, 
reflectivity ρ, absorptivity α, refractive index n, and temperature T. The body is 
assumed opaque, which means that no radiation is transmitted through the body. This 
is true for most solid bodies.

Figure 4-5: Incoming irradiation (left), outgoing radiosity (right).

The total incoming radiative flux at P is called irradiation and denoted G. The total 
outgoing radiative flux at P is called radiosity and denoted J. This radiosity is the sum 
of reflected and emitted radiation:

 (4-67)

G

P

εn2σT4

ρG

J = ρG + εn2σT4

P

J ρG εeb T( )+=
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According to the Stefan-Boltzmann law, eb(T) is the power radiated across all 
wavelengths and depends on the forth power of the temperature:

The net inward radiative heat flux, q, is then given by the difference between the 
irradiation and the radiosity:

 (4-68)

Using Equation 4-67 and Equation 4-68, J can be eliminated and a general expression 
is obtained for the net inward heat flux into the opaque body based on G and T.

 (4-69)

Most opaque bodies also behave as ideal gray bodies, meaning that the absorptivity and 
emissivity are equal, and the reflectivity is therefore obtained from the following 
relation:

 (4-70)

Thus, for ideal gray bodies, q is given by:

 (4-71)

This is the expression used for the radiative boundary condition.

Wavelength Dependence of Surface Emissivity and Absorptivity

The surface properties for radiation, the emissivity, and absorptivity can be dependent 
on the angle of emission or absorption, the surface temperature, or the radiation 
wavelength. The emissivity and absorptivity are defined in Ref. 17.

The Surface-to-Surface Radiation interface in the Heat Transfer module implements 
the radiosity method that enables arbitrary temperature dependence and assumes that 
the emissivity and absorptivity is independent of the angle of emission and absorption. 
It is also possible to account for wavelength dependence on the surface emissivity and 
absorptivity.

P L A N C K  S P E C T R A L  D I S T R I B U T I O N

The Planck’s distribution of emissive power for a blackbody in vacuum is given as a 
function of surface temperature and wavelength.

eb T( ) n2σT4=

q G J–=

q 1 ρ–( )G εeb T( )–=

α ε 1 ρ–= =

q ε G eb T( )–( )=
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The blackbody hemispherical emissive power (SI unit: W/(m3·sr)), is denoted 
eb, λ(λ, T), and defined as (1-37 in Ref. 17):

 (4-72)

where:

• the two constants C1 (SI unit: W·m2/sr) and C2 (SI unit: m·K) are given by

• h is the Planck constant (SI unit: J·s)

• kB is the Boltzmann constant (SI unit: J/K)

• c0 is the speed of the light in vacuum (SI unit: m/s)

• λ is the wavelength in vacuum (SI unit: m)

• n is the refractive index of the media (SI unit: 1), equal to 1 in vacuum

Figure 4-6 and Figure 4-7 show the hemispherical spectral emissive power for a 
blackbody at 5780 K (the Sun’s blackbody temperature) and for a blackbody at 300 K. 
The dotted vertical lines delimit the visible spectrum (from 0.4 µm to 0.7 µm).

Figure 4-6: Planck distribution of a blackbody at 5780 K.

eb λ, λ T,( )
2πn2C1

λ5 e

C2

λT
-------

1–
 
 
 
 

------------------------------=

C1 hc0
2

= C2
hc0
kB
---------=
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Figure 4-7: Planck distribution of a blackbody at 300 K.

The integral of eb, λ(λ, T) over a spectral band represents the power radiated on the 
spectral band and is defined by

where  is the fractional blackbody emissive power,

Recall the Stefan-Boltzmann law that computes the power radiated across all 
wavelengths:

where n is the refractive index, and σ is the Stefan-Boltzmann constant equal to 
5.67 ⋅ 10-8 W/(m2·K4). The power radiated in the spectral band [λ1, λ2] becomes:

eb λ, λ T,( ) λd
λ1

λ2

 Fλ1T λ2T→ eb λ, λ T,( ) λd
0

∞

=

Fλ1T λ2T→

Fλ1T λ2T→

eb λ, λ T,( ) λd
λ1

λ2



eb λ, λ T,( ) λd
0

∞


-----------------------------------------=

eb λ, λ T,( ) λd
0

∞

 eb T( ) n2σT4= =
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Notice that:

 and 

The figure below shows the value of  for different values of λT.

D I F F U S E - G R A Y  S U R F A C E S

Diffuse-gray surfaces correspond to the hypothesis that surface properties are 
independent of the radiation wavelength and angle between the surface normal and 
the radiation direction.

The assumption that the surface emissivity is independent of the radiation wavelength 
is often valid when most of the radiative power is concentrated on a relatively narrow 

eb λ, λ T,( ) λd
λ1

λ2

 Fλ1T λ2T→ eb T( )=

The function eb(T) is available as a predefined function via ht.feb(T) in 
the Heat Transfer interfaces.

Fλ1T λ2T→ F0 λ2T→ F0 λ1T→–= F0 ∞→ 1=

F0 λT→
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spectral band. This is likely the case when the radiation is emitted by a surface at 
temperatures in limited range.

This setting is rarely applicable if there is solar radiation.

S O L A R  A N D  A M B I E N T  S P E C T R A L  B A N D S

When solar radiation is part of the model, it is possible to enhance a diffuse-gray 
surface model by considering two spectral bands: one for short wavelengths and one 
for large wavelengths.

It is interesting to notice that about 97% of the radiated power from a blackbody at 
5800 K is at wavelengths of 2.5 µm or shorter, and 97% of the radiated power from a 
blackbody at 700 K is at wavelengths of 2.5 µm or longer (see Figure 4-8).

Figure 4-8: Normalized Planck distribution of blackbodies at 700 K and 5800 K.

Many problems have a solar load, but the peak temperatures are below 700 K.

In such cases, it is appropriate to use a two-band approach with

• A solar band for wavelengths shorter than 2.5 µm

• An ambient band for wavelengths above 2.5 µm
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For each surface, properties are then described in terms of a solar absorptivity and an 
emissivity.

Figure 4-9: Absorption of solar radiation and emission to the surroundings.

By splitting the bands at the default of 2.5 μm, the fraction of absorbed solar radiation 
on each surface is defined primarily by the solar absorptivity.

The reradiation at longer wavelengths (objects below ~700 K) and the reabsorption of 
this radiation is defined primarily via the emissivity

Figure 4-10: Solar and ambient spectral band approximation of the surface emissivity by 
a constant per band emissivity.

λ < 2.5 µm

λ > 2.5 µm

Solar irradiation,

Reradiation to 
surroundings, 

Emissivity

Wavelength
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G E N E R A L  D I F F U S E - S P E C T R A L  S U R F A C E S

Diffuse-spectral surfaces correspond to the hypothesis that surface properties are 
wavelength dependent but independent of the angle between the surface normal and 
the radiation direction.

The heat transfer module enables to define constant surface properties per spectral 
bands (with up to 5 spectral bands) and to adjust spectral intervals endpoints.

The multiple spectral bands approach is used in cases when the surface emissivity varies 
significantly over the bands of interest.

The Radiosity Method for Diffuse-Gray Surfaces

The heat transfer by radiation is combined with convective and conductive heat 
transfer through a source term added to the heat equation along with the other 
contributions from the heat flux and boundary heat source boundary conditions. 
Recalling Equation 4-68, this source account for the difference between incident 
radiation, or irradiation, G, and radiation leaving the surface, or radiosity, J:

The radiosity, J, is given in Equation 4-67. It is the sum of reflected and emitted 
radiation. For diffuse-gray surfaces, J is defined by:

Here

• G is the incoming radiative heat flux, or irradiation (SI unit: W/m2)

• ε is the surface emissivity (SI unit: 1), a dimensionless number in the range 0 ≤ ε ≤ 1. 
The diffuse-gray surface hypothesis corresponds to surfaces where ε is independent 
of the radiation wavelength.

λ1 λ2 λ3

Emissivity

Wavelength

q G J–=

J 1 ε–( )G εeb T( )+=
T H E O R Y  F O R  S U R F A C E - T O - S U R F A C E  R A D I A T I O N  |  189



190 |  C H A P T E
• eb(T) is the blackbody hemispherical total emissive power (SI unit: W/m2).

• T is the surface temperature (SI unit: K).

The irradiation, G, at a given point is split into three contributions according to:

 (4-73)

where:

• Gm is the mutual irradiation, coming from other boundaries in the model 
(SI unit: W/m2).

• Gext is the irradiation from external radiation sources (SI unit: W/m2). It is the sum 
of the products, for each external source, of the external heat sources view factor 
Fext by the corresponding source radiosity:

The first term of the sum gathers radiation sources located on a point. The second 
term stands for directional radiative sources.

• Gamb is the ambient irradiation (SI unit: W/m2), defined as:

• Famb is an ambient view factor; its value is equal to the fraction of the field of view 
that is not covered by other boundaries. Therefore, by definition, 0 ≤ Famb ≤ 1 at 
all points.

• Tamb is the assumed far-away temperature (SI unit: K) in the directions included in 
Famb.

The Surface-To-Surface Radiation Interface includes the following radiation types:

• Diffuse Surface is the default radiation type. It requires accurate evaluation of the 
mutual irradiation, Gm. The incident radiation at one point on the boundary is a 
function of the radiosity, J, at every other point in view. The radiosity, in turn, is a 
function of Gm, which leads to an implicit radiation balance:

 (4-74)

• Diffuse Mirror is a variant of the Diffuse Surface radiation type with ε = 0. 
Reradiation surfaces are common as an approximation of a surface that is well 
insulated on one side and for which convection effects can be neglected on the 
opposite (radiating) side (see Ref. 18). It resembles a mirror that absorbs all 

G Gm Gext Gamb+ +=

Gext FextPs Fextq0 s,+=

Gamb Fambeb Tamb( )=

J 1 ε–( ) Gm J( ) Gext Gamb+ +( ) εeb T( )+=
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irradiation and then radiates it back in all directions.

• Prescribed Radiosity makes it possible to specify graybody radiation. The radiosity 
expression is then εeb(T). A user-defined surface radiosity expression can also be 
defined.

The Surface-to-Surface Radiation interface handles the radiosity J as a shape function 
unless J is prescribed.

The Radiosity Method for Diffuse-Spectral Surfaces

For a general diffuse-spectral surface:

where

• ε(λ, T) is the hemispherical spectral surface emissivity, a dimensionless quantity in 
the range 0 ≤ ε ≤ 1. Diffuse-spectral surface corresponds to a surface where ε is 
dependent on the radiation wavelength and surface temperature.

• T is the surface temperature (SI unit: K).

• eb, λ(λ, T) is the blackbody hemispherical emissive power (SI unit: W/(m3·sr)) 
defined in Equation 4-72.

The Surface-To-Surface Radiation Interface assumes that the surface emissivity and 
opacity properties are constant per spectral band. It defines N spectral bands (N = 2 
when solar and ambient radiation model is used),

so that the radiosity has a custom definition in each interval:

J 1 ε λ T,( )–( )G λ( ) ε λ T,( )eb λ, λ T,( )+( ) λd
0

∞

=

Bi λi 1– λi[ , ]= for 1 i N≤ ≤

λ0 0=

λN ∞=





J Ji

i 1=

N

=

Ji 1 εi–( )Gi εieb T( )+=
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The surface properties can then be defined per spectral band:

• Surface emissivity on Bi: εi(T) = ε(λ, T) for λ in the interval Bi

• Ambient irradiation on Bi, assuming that the ambient fractional emissive power 
corresponds to the one of a blackbody at temperature Tamb:

• External radiation sources on Bi with q0, s, i and Ps, i the external radiation source 
heat flux and heat rate, respectively, over Bi:

or

When the external source fractional emissive power corresponds to the one of a 
blackbody at Text, external radiation sources on Bi can be defined from the external 
radiation source heat flux, q0, s, and heat rate, Ps, over all wavelengths:

or

The Surface-To-Surface Radiation Interface includes the following radiation types:

• Diffuse Surface is the default radiation type. The incident radiation over the Bi 
spectral band at one point of the boundary is a function of the radiosity, Ji (SI unit: 
W/m2), at every other point in view. The radiosity, in turn, is a function of Gm, i, 
which leads to an implicit radiation balance:

 (4-75)

• Diffuse Mirror is a variant of the Diffuse Surface radiation type with εi = 0. 
Reradiation surfaces are common as an approximation of a surface that is well 
insulated on one side and for which convection effects can be neglected on the 
opposite (radiating) side (see Ref. 18). It resembles a mirror that absorbs all 

Gamb i, Gamb λ( ) λd
λ λi 1–=

λi

 Fλi 1– T λiT→ Fambeb Tamb( )= =

Gext i, Gext λ( ) λd
λ λi 1–=

λi

 Fext i, is( )q0 s i, ,= =

Gext i, Gext λ( ) λd
λ λi 1–=

λi

 Fext i, is( )Ps i,= =

Gext i, Fext i, Fλi 1– T λiT→ is( )q0 s,=

Gext i, Fext i, Fλi 1– T λiT→ is( )Ps=

Ji 1 εi–( ) Gm i, Ji( ) Gext i, Gamb i,+ +( ) εieb T( )+=
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irradiation and then radiates it back in all directions.

• Prescribed Radiosity makes it possible to specify the surface radiation for each 
spectral band. Using the graybody radiation definition, the radiosity is then 

. A user-defined surface radiosity expression can also be defined.

The Surface-to-Surface Radiation interface handles the radiosity Ji as a shape function 
unless Ji is prescribed.

View Factor Evaluation

The strategy for evaluating view factors is central to any radiation simulation. Loosely 
speaking, a view factor is a measure of how much influence the radiosity at a given part 
of the boundary has on the irradiation at some other part.

The quantities Gm and Famb in Equation 4-74 are not strictly view factors in the 
traditional sense. Instead, Famb is the view factor of the ambient portion of the field 
of view, which is considered to be a single boundary with constant radiosity

On the other hand, Gm is the integral over all visible points of a differential view factor, 
multiplied by the radiosity of the corresponding source point. In the discrete model, 
think of it as the product of a view factor matrix and a radiosity vector. This is, however, 
not necessarily the way the calculation is performed.

Consider a point P on a surface as in Figure 4-11. It can be seen by points on other 
surfaces such as S′ in the figure, as well as the ambient surrounding, Samb. Assume 

Fλ1T λ2T→ eb T( )

Jamb eb Tamb( )=
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that the points on S′ have a local radiosity, J′, while the ambient surrounding has a 
constant temperature, Tamb.

Figure 4-11: Example geometry for surface-to-surface radiation.

The mutual irradiation at point P is given by the following surface integral:

The heat flux that arrives from P′ depends on the local radiosity J′ projected onto P. 
The projection is computed using the normal vectors n and n′ along with the vector 
r, which points from P to P′. 

The ambient view factor, Famb, is determined from the integral of the surrounding 
surfaces S′, here denoted as F′:

The two last equations plug into Equation 4-73 to yield the final equation for 
irradiative flux.

The equations used so far apply to the general 3D case. 2D geometries result in simpler 
integrals. For the 2D case, the resulting equations for the mutual irradiation and 
ambient view factor are

P

P′

nn′ r

Samb

Samb

S′

Jamb

J′

Gm
n′– r⋅( ) n r⋅( )

π r 4
--------------------------------------J′ sd

S ′
=

Famb 1 F ′– 1 n′– r⋅( ) n r⋅( )
π r 4

-------------------------------------- sd
S ′
–= =
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 (4-76)

where the integral over S⊥′ denotes the line integral along the boundaries of the 2D 
geometry.

In axisymmetric geometries or when a symmetry plane is defined, the irradiation and 
ambient view factor cannot be computed directly from a closed-form expression. 
Instead, a virtual geometry must be constructed, and the view factors evaluated 
according to Equation 4-76.

A separate evaluation is performed for each unique point where Gm or Famb is 
requested, typically for each quadrature point during solution. Differential view factors 
are normally computed only once, the first time they are needed, and then stored in 
memory until next time the model definition or the mesh is changed.

The Heat Transfer Module supports two surface-to-surface radiation methods, which 
are selected in the Radiation Settings section in a Heat Transfer interface:

• Hemicube

• Discrete area integration

V I E W  F A C T O R  F O R  E X T E R N A L  R A D I A T I O N  S O U R C E S

In 3D, the view factor for a point at finite distance is given by

where θ is the angle between the normal to the irradiated surface and the direction of 
the source, and r is the distance from the source. For a source at infinity, the view factor 
is given by cos θ.

Gm
n′– r⊥⋅( ) n r⊥⋅( )

2 r⊥
3

---------------------------------------------J′ sd
S⊥′
=

Famb 1
n′– r⊥⋅( ) n r⊥⋅( )

2 r⊥
3

--------------------------------------------- sd
S⊥'
–=

View factors are always calculated directly from the mesh, which is a 
polygonal representation of the geometry. To improve the accuracy of the 
radiative heat transfer simulation, the mesh must be refined rather than 
raising the element order.

θcos

4πr2
------------
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In 2D the view factor for a point at finite distance is given by

and the view factor for a source at infinity is cos θ.

S O L A R  PO S I T I O N

The Sun is the most common example of an external radiation source. The position of 
the Sun is necessary to determine the direction of the corresponding external radiation 
source. The direction of sunlight (zenith angle and the solar elevation) is automatically 
computed from the latitude, longitude, time zone, date, and time using similar a 
method as described in Ref. 17. The estimated solar position is accurate for a date 
between year 2000 and 2199, due to an approximation used in the Julian Day calendar 
calculation.

The zenith angle, θs, and azimuth angle, ϕs, of the Sun are converted into a direction 
vector is = (isx, isy, isz) in Cartesian coordinates assuming that the north, the west, and 
the up directions correspond to the x, y, and z directions, respectively, in the model. 
The relation between θs, ϕs, and is is given by:

R A D I A T I O N  I N  A X I S Y M M E T R I C  G E O M E T R I E S

For an axisymmetric geometry, Gm and Famb must be evaluated in a corresponding 
3D geometry obtained by revolving the 2D boundaries around the axis. COMSOL 
Multiphysics creates this virtual 3D geometry by revolving the 2D boundary mesh into 
a 3D mesh. The resolution can be controlled in the azimuthal direction by setting the 
number of azimuthal sectors, which is the same as the number of elements to a full 
revolution. Try to balance this number against the mesh resolution in the rz-plane. 
This number, the azimuthal sectors, is accessible from the Radiation Settings section 
in physics interfaces for heat transfer.

Select between the hemicube and the direct area integration methods also in axial 
symmetry. Their settings work the same way as in 3D.

θcos
2πr
------------

isx ϕs( )cos θs( )sin–=

isy ϕs( )sin θs( )sin=

isz θs( )cos–=
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While Gm and Famb are in fact evaluated in a full 3D, the number of 
points where they are requested is limited to the quadrature points on the 
boundary of a 2D geometry. The savings compared to a full 3D 
simulation are therefore substantial despite the full 3D view factor code 
being used.
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Th eo r y  f o r  Rad i a t i o n  i n  Pa r t i c i p a t i n g  
Med i a

Radiation and Participating Media Interactions

Figure 4-12: Example of interactions between participating media and radiation.

In some applications the medium is not completely transparent and the radiation rays 
interact with the medium.

Let I(Ω) denote the radiative intensity traveling in a given direction, Ω. Different kinds 
of interactions are observed:

• Absorption: The medium absorbs a fraction of the incident radiation. The amount 
of absorbed radiation is κI(Ω), where κ is the absorption coefficient.

• Emission: The medium emits radiation in all directions. The amount of emitted 
radiative intensity is equal to κIb, where Ib is the blackbody radiation intensity.

• Scattering: Part of the radiation coming from a given direction is scattered in other 
directions. The scattering properties of the medium are described by the scattering 
phase function φ(Ω′, Ω), which gives the probability that a ray coming from one 
direction Ω′ is scattered into the direction Ω. The phase function φ(Ω′, Ω) satisfies:
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Radiative intensity in a given direction is attenuated and augmented by scattering:

- It is attenuated because a part of the incident radiation in this direction is 
scattered into other directions. The amount of radiation attenuated by scattering 
is σsI(Ω).

- It is augmented because a part of the radiative intensity coming from other 
directions is scattered in all direction, including the direction we are looking at. 
The amount of radiation augmented by scattering is obtained by integrating 
scattering coming from all directions Ω′:

Radiative Transfer Equation

The balance of the radiative intensity including all contributions (propagation, 
emission, absorption, and scattering) can now be formulated. The general radiative 
transfer equation can be written as (see Ref. 20):

 (4-77)

where

• I(Ω) is the radiative intensity at a given position following the Ω direction (SI unit: 
W/(m2·sr))

• Ib(T) is the blackbody radiative intensity (SI unit: W/(m2·sr)), defined as

 (4-78)

• nr is the refractive index (SI unit: 1)

• σ is the Stefan-Boltzmann constant (SI unit: W/(m2·K4))

1
4π
------ φ Ω′ Ω,( ) Ω′d

4π
 1=

σs
4π
------ I Ω′( )φ Ω′ Ω,( ) Ω′d

4π


Ω I Ω( )∇⋅ κIb T( ) βI Ω( )–
σs
4π
------ I Ω′( )φ Ω′ Ω,( ) Ω′d

4π
+=

Ib T( )
nr

2σT4

π
-----------------=

The quantity Ib(T) is available as a predefined function, ht.fIb(T), in 
heat transfer interfaces.
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• κ, β, σs are absorption, extinction, and scattering coefficients, respectively (SI unit: 
1/m) and are related by:

• φ(Ω′, Ω) is the scattering phase function (SI unit: 1)

• T is the temperature (SI unit: K)

The phase function, φ(Ω′, Ω), gives the probability that a ray from the Ω′ direction is 
scattered into the Ω direction. The phase function’s definition is material dependent 
and its definition can be complicated. It is common to use approximate scattering 
phase functions that are defined using the cosine of the scattering angle, μ0. The 
current implementation handles:

• Isotropic phase functions:

• Linear anisotropic phase functions:

• Polynomial anisotropic up to the 12th order:

where Pn are the n-th order Legendre polynomials.

Legendre polynomials can be defined by the Rodriguez formula:

A quantity of interest is the incident radiation, denoted G, and defined by

Boundary Condition for the Radiative Transfer Equation

For gray walls, corresponding to opaque surfaces reflecting diffusively and emitting, 
the radiative intensity I(Ω) entering participating media along the Ω direction is

β κ σs+=

φ Ω′ Ω,( ) φ μ0( ) 1= =

φ μ0( ) 1 a1μ0+=

φ μ0( ) 1 anPn μ0( )

n 1=

12

+=

Pk x( ) 1

2kk!
-----------

xk

k

d

d x2 1–( )
k

( )=

G I Ω( ) Ωd
4π
=
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where

 (4-79)

• Equation 4-78 is the blackbody radiation intensity and nr is the refractive index

• ε is the surface emissivity, which is in the range [0, 1]

• 1 − ε is the diffusive reflectivity

• n is the outward normal vector

• qr,out is the heat flux striking the wall:

For black walls ε = 1. Thus I(Ω) = Ib(T).

Heat Transfer Equation in Participating Media

Heat flux in gray media is defined by 

Heat flux divergence can be defined as a function of G and T (see Ref. 20):

In order to couple radiation in participating media, radiative heat flux is taken into 
account in addition to conductive heat flux. Recalling Equation 4-16, the heat transfer 
equation reads:

and is implemented using following form:

I Ω( ) εIb T( ) 1 ε–
π

-----------qr out,+= for all Ω such that n Ω 0<⋅

Ib T( )
nr

2σT4

π
--------------------=

qr out, I Ω( ) n Ω⋅( ) Ωd
n Ω⋅ 0>
=

qr I Ω( )Ω Ωd
4π
=

Qr ∇ qr⋅ κ G 4πIb T( )–( )= =

ρCp
∂T
∂t
------- u ∇⋅ T+ 
  ∇ q qr+( )⋅+ αpT

t∂
∂p u p∇⋅+ 
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ρCp
∂T
∂t
------- u ∇⋅ T+ 
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Discrete Ordinates Method (DOM)

Radiative intensity is defined for any direction Ω, because the angular space is 
continuous. In order to handle the radiative intensity equation numerically, the angular 
space is discretized.

The discrete ordinates method (or SN approximation) provides a discretization of 
angular space into n = N(N + 2) in 3D (or n = N(N + 2)/2 in 2D) discrete directions. 
It consists in a set of directions and quadrature weights. Several sets are available in the 
literature. A set should satisfy first, second, and third moments (see Ref. 20); it is also 
recommended that the quadrature fulfills the half moment for vectors of Cartesian 
basis. Since it is not possible to fulfill exactly all these conditions, accuracy should be 
improved when N increases.

Following the conclusion of Ref. 21, the implementation uses the LSE symmetric 
quadrature for S2, S4, S6, and S8. The LSE symmetric quadrature fulfills the half, first, 
second, and third moments.

Thanks to angular space discretization, integrals over directions are replaced by 
numerical quadratures of discrete directions:

Depending on the value of N, a set of n dependent variables has to be defined and 
solved for I1,  I2, …, In.

Each dependent variable satisfies the equation

where Si is the i-th discrete ordinate, with the following boundary condition

The discrete ordinates method is implemented for 3D and 2D 
geometries.

I Ω( ) Ωd
4π
 wjIj

j 1=

n

≈

Si Ii∇⋅ κIb T( ) βIi–
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4π
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n

+=
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with

Discrete Ordinates Method Implementation in 2D

For a given index i, define two indices, i+ and i−, so that

• Ω, Si+, and Si- have the same components in the xy–plane

• and Si+ and Si- have opposite components in the z direction.

Assuming that a model is invariant in the z direction, the radiative transfer equation in 
two directions, Si+ and Si-, for the discrete ordinates method (DOM) reads:

By summing these two equations and introducing  which is equal to  and  
(these are equal in 2D):

which can be rewritten as:

In addition if φ(Si, Sj) can be rewritten as a function of Si ⋅ Sj, as it is in COMSOL 
Multiphysics implementation, then
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 and 

In addition

so the above equation can be simplified:

 (4-80)

with

since the third component of  is zero in 2D.

Also notice that 

 (4-81)

with .

Using results from Equation 4-80 and Equation 4-81 the DOM is formulated in 2D 
using only radiative intensities, , on half of the 3D DOM directions, , except for 
the scattering term. In other expressions than the scattering term, the z component of 
the radiative intensities Ii and of the discrete directions Ωi can be ignored (or set to 
zero) and the weight wi, multiplied by 2.

Rosseland Approximation Theory

For The Heat Transfer with Radiation in Participating Media Interface, Rosseland 

approximation is available as a radiation discretization method. Then for Radiation in 
Participating Media (Heat Transfer Interface) feature node this theory is applicable.
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Rosseland approximation relies on the hypotheses that the participating media is 
optically thick — that is, τ >>1 — where τ is the optical thickness defined by the integral 
of absorption coefficient, κ, along a typical optical path: 

From a computational point of view this approximation has a limited impact because 
it does not introduce any extra degree of freedom to the heat equation. Instead it adds 
nonlinear contribution to the thermal conductivity. This is why this method is popular 
for some applications where the optical thickness is large. Nevertheless, because it gives 
a simple approximation of heat transfer by radiation in a participating media, it should 
be carefully validated.

In this case, the radiative heat flux can be evaluated by (Ref. 20): 

For a gray media it leads to

Assuming a constant refractive index, this can be rewritten as qr = − kR ΔT with

and

Notice that the Rosseland approximation does not account at all for the scattering in 
the participating media.

P1 Approximation Theory

For The Heat Transfer with Radiation in Participating Media Interface and The 
Radiation in Participating Media Interface, P1 approximation is available as a radiation 
discretization method. 

τ κ sd
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------∇ib λ,–=

qr
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16n2σT3

3βR
------------------------=

qr
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------------------------∇T–=
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P1 approximation is the simplest approximation provided by the method of spherical 
harmonics method (PN-method). This approximation provides additional accuracy 
compared to a Rosseland approximation even if it remains a very simple method. The 
P1 method relies on the following hypotheses: 

• The media is optically thick media: τ >>1, where τ is the optical thickness defined by 
the integral of absorption coefficient, κ, along a typical optical path:

• The scattering is linear isotropic.

From a computational point of view this approximation has a limited impact because 
it introduces only one additional degree of freedom for G, which is a scalar quantity 
and adds a heat source or sink to the temperature equation to account for radiative heat 
transfer contributions. This method, however, fails to accurately represent cases where 
the radiative intensity propagation dominates over its diffusivity or where the 
scattering effects cannot be described by a linear isotropic phase function.

The P1 approximation accounts for the radiation transfer equation

by solving following equation for (Ref. 20): 

 (4-82)

where

• DP1is the P1 diffusion coefficient, defined as 

• a1 is the linear Legendre coefficient of the scattering phase function

• Qr is the radiative heat source:

 (4-83)

When scattering is modeled as isotropic, a1=0 and the P1 diffusion coefficient reduces 
to
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The following boundary condition applies (Ref. 20):

where qr, net is the net radiative heat flux at the boundary.

R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A

For the Radiation in Participating Media (Heat Transfer Interface) and Radiation in 
Participating Media (RPM Interface) feature nodes, the equation Equation 4-82 is 
implemented.

In addition Qr, defined by Equation 4-83, is added as an heat source in the heat 
transfer equation:

O P A Q U E  S U R F A C E

The Opaque Surface boundary condition defines a boundary opaque to radiation and 
defines the incident intensity on a boundary:

The Opaque Surface feature accounts for the net radiative heat flux, qr, net, in the heat 
balance.

Two cases are considered, depending on surface emissivity value: 

• Gray wall: ε is a number between 0 and 1

• Black wall: ε=1

Gray Wall
The radiative heat flux at the boundary depends on the surface emissivity, ε:

with
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Black Wall
The radiative heat flux at the boundary expression simplifies to

with

I N C I D E N T  I N T E N S I T Y

The Incident Intensity node defines a boundary that receives incident radiative 
intensity Iext and that is transparent for outgoing intensity. On these boundaries, the 
relation between G, qr, net (net radiative heat flux) and Iext (incident radiative 
intensity) is

by defining

there is

which defines the heat radiative heat flux and also contributes to G boundary 
condition:
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Th eo r y  f o r  Mo i s t u r e  T r a n s po r t

Theory for moisture transport in building materials

The Moisture Transport in Building Materials Interface solves for the following 
equation derived from Ref. 15:

 (4-84)

This equation models the moisture transfer as the sum of the capillary moisture flux:

and the vapor diffusion flux:

with the following material properties, fields, and source:

• ξ (SI unit: kg/m3) is the moisture storage capacity.

• δp (SI unit: s) is the vapor permeability.

• φ (dimensionless) is the relative humidity.

• psat (SI unit: Pa) is the vapor saturation pressure.

• T (SI unit: K) is the temperature.

• Dw (SI unit: m2/s) is the moisture diffusivity.

• G (SI unit: kg/m3·s) is the moisture source.

Theory for moisture transport in air

The Moisture Transport in Air Interface solves for the following equation, in which 
the moisture content variation is expressed through the transport of vapor 
concentration, which itself can be expressed as the product of molar mass of water, 
relative humidity, and vapor saturation concentration:

 (4-85)

ξ∂φ
∂t
------ ∇ ξ– Dw∇φ δp∇ φpsat T( )( )–( )⋅+ G=

Dw∇ w φ( )( )– Dw
∂w
∂φ
-------∇φ– ξDw∇φ–= =

δp∇pv T( ) δp∇ φpsat T( )( )=

∂ Mvφcsat( )

∂t
--------------------------------- ∇ D Mvφcsat( )∇–( ) u Mvφcsat( )∇⋅+⋅+ G=
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with the following material properties, fields, and source:

• Μv (SI unit: kg/mol) is the molar mass of water vapor.

• φ (dimensionless) is the relative humidity.

• csat (SI unit: mol/m3) is the vapor saturation concentration.

• D (SI unit: m2/s) is the vapor diffusion coefficient in air.

• u (SI unit: m/s) is the air velocity field.

• G (SI unit: kg/(m3⋅s)) is the moisture source (or sink). 

The transport of vapor concentration is done by convection and diffusion in moist air.

The moisture is supposed to be constituted only of vapor. In other terms the liquid 
concentration is null.

cv Mvφcsat=
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Th eo r y  f o r  t h e  Hea t  T r a n s f e r  
Mu l t i p h y s i c s  C oup l i n g s

In this section:

• Theory for the Nonisothermal Flow and Conjugate Heat Transfer Interfaces

• Theory for the Thermoelectric Effect Interface

• Theory for the Local Thermal Non-Equilibrium Interface

• Theory for the Heat and Moisture Transport Interface

• Theory for the Electromagnetic Heating Interfaces

• Theory for the Thermal Stress Interface

Theory for the Nonisothermal Flow and Conjugate Heat Transfer 
Interfaces

The following points of the theory of Nonisothermal Flow and Conjugate Heat 
Transfer are discussed in this part:

• The Nonisothermal Flow and Conjugate Heat Transfer Equations

• Turbulent Nonisothermal Flow Theory

• Theory for the Nonisothermal Screen Boundary Condition

• Theory for the Interior Fan Boundary Condition

See Theory for the Single-Phase Flow Interfaces and Theory for the Turbulent Flow 
Interfaces in the CFD Module User’s Guide for a description of the theory related to 
laminar and turbulent single-phase flow interfaces.

T H E  N O N I S O T H E R M A L  F L O W  A N D  C O N J U G A T E  H E A T  TR A N S F E R  

E Q U A T I O N S

In industrial applications it is common that the density of a process fluid varies. These 
variations can have a number of different sources but the most common one is the 
presence of an inhomogeneous temperature field. This module includes the 
Nonisothermal Flow predefined multiphysics coupling to simulate systems in which 
the density varies with temperature.
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Other situations where the density might vary includes chemical reactions, for instance 
where reactants associate or dissociate.

The Nonisothermal Flow and Conjugate Heat Transfer interfaces contain the fully 
compressible formulation of the continuity and momentum equations:

 (4-86)

where

• ρ is the density (SI unit: kg/m3)

• u is the velocity vector (SI unit: m/s)

• p is the pressure (SI unit: Pa)

• τ is the viscous stress tensor (SI unit: Pa), equal for a compressible fluid to:

• μ is the dynamic viscosity (SI unit: Pa·s)

• F is the body force vector (SI unit: N/m3)

It also solves the heat equation, which for a fluid is given in Equation 4-16 by

where in addition to the quantities above

• Cp is the specific heat capacity at constant pressure (SI unit: J/(kg·K))

• T is the absolute temperature (SI unit: K)

• q is the heat flux by conduction (SI unit: W/m2)

• qr is the heat flux by radiation (SI unit: W/m2)

• αp is the coefficient of thermal expansion (SI unit: 1/K):

• Q contains heat sources other than viscous heating (SI unit: W/m3)

The work done by pressure changes term

∂ρ
∂t
------ ∇ ρu( )⋅+ 0=

ρ∂u
∂t
------- ρu ∇u⋅+ ∇p– ∇ τ F+⋅+=

τ μ ∇u ∇u( )T+( ) 2
3
---μ ∇ u⋅( )I–=

ρCp
∂T
∂t
------- u ∇⋅ T+ 
  ∇ q qr+( )⋅+ αpT

t∂
∂p u p∇⋅+ 
  τ: u∇ Q+ +=

αp
1
ρ
---

T∂
∂ρ

–=
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and the viscous heating term

are not included by default because they are usually negligible. These terms can, 
however, be added by selecting corresponding check boxes in the Nonisothermal Flow 
feature.

The physics interface also supports heat transfer in solids (Equation 4-14):

where Qted is the thermoelastic damping heat source (SI unit: W/(m3)). This term is 
not included by default but must be added by selecting the corresponding check box.

TU R B U L E N T  N O N I S O T H E R M A L  F L O W  T H E O R Y

Turbulent energy transport is conceptually more complicated than energy transport in 
laminar flows because the turbulence is also a form of energy.

Equations for compressible turbulence are derived using the Favre average. The Favre 
average of a variable T is denoted  and is defined by

where the bar denotes the usual Reynolds average. The full field is then decomposed as

With this notation the energy balance equation becomes

Qp αpT ∂p
∂t
------ u ∇⋅ p+ 
 =

Qvd τ: u∇=

ρCp
∂T
∂t
------- utrans ∇⋅ T+ 
  ∇ q qr+( )⋅+ Qted Q+=

• The Heat Balance Equation

• Turbulent Nonisothermal Flow Theory

T̃

T̃ ρT
ρ

-------=

T T̃ T″+=
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 (4-87)

where H is the enthalpy. The vector

 (4-88)

is the laminar conductive heat flux and

is the laminar, viscous stress tensor. Notice that the thermal conductivity is denoted λ.

The modeling assumptions are in large part analogous to those for incompressible 
turbulence modeling. The stress tensor

is modeled using the Boussinesq approximation:

 (4-89)

where k is the turbulent kinetic energy, which in turn is defined by

 (4-90)

The correlation between uj″ and H″ in Equation 4-87 is the turbulent transport of 
heat. It is modeled analogously to the laminar conductive heat flux

 (4-91)

The molecular diffusion term,
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and turbulent transport term,

are modeled by a generalization of the molecular diffusion and turbulent transport 
terms found in the incompressible k equation

 (4-92)

Inserting Equation 4-88, Equation 4-89, Equation 4-90, Equation 4-91 and 
Equation 4-92 into Equation 4-87 gives

 (4-93)

The Favre average can also be applied to the momentum equation, which, using 
Equation 4-89, can be written

 (4-94)

Taking the inner product between  and Equation 4-94 results in an equation for the 
resolved kinetic energy, which can be subtracted from Equation 4-93 with the 
following result:

 (4-95)

where the relation

has been used.
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According to Wilcox (Ref. 24), it is usually a good approximation to neglect the 
contributions of k for flows with Mach numbers up to the supersonic range. This gives 
the following approximation of Equation 4-95:

 (4-96)

Larsson (Ref. 25) suggests to make the split

Since

for all applications of engineering interest, it follows that

and consequently

 (4-97)

where

Equation 4-97 is completely analogous to the laminar energy equation of 
Equation 4-13 and can be expanded using the same theory to get the temperature 
equation similar to Equation 4-16 (see for example Ref. 25):

which is the temperature equation solved in the turbulent Nonisothermal Flow and 
Conjugate Heat Transfer interfaces.
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Turbulent Conductivity

Kays-Crawford This is a relatively exact model for PrT, while still quite simple. In 
Ref. 26, it is compared to other models for PrT and found to be a good approximation 
for most kinds of turbulent wall bounded flows except for turbulent flow of liquid 
metals. The model is given by

 (4-98)

where the Prandtl number at infinity is PrT∞ = 0.85 and λ is the conductivity.

Extended Kays-Crawford Weigand et al. (Ref. 27) suggested an extension of 
Equation 4-98 to liquid metals by introducing

where Re∞, the Reynolds number at infinity must be provided either as a constant or 
as a function of the flow field. This is entered in the Model Inputs section of the Fluid 
feature.

Temperature Wall Functions
Analogous to the single-phase flow wall functions (see Wall Functions described for the 
Wall boundary condition), there is a theoretical gap between the solid wall and the 
computational domain for the fluid and temperature fields. This gap is often ignored 
when the computational geometry is drawn. 

The heat flux between the fluid with temperature Tf and a wall with temperature Tw, is:

where ρ is the fluid density, Cp is the fluid heat capacity, Cμ is a turbulence modeling 
constant, and k is the turbulent kinetic energy. T+ is the dimensionless temperature 
and is given by (Ref. 28):
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where in turn

λ is the thermal conductivity, and κ is the von Karman constant equal to 0.41.

The computational results should be checked so that the distance between the 
computational fluid domain and the wall, δw, is everywhere small compared to any 
geometrical quantity of interest. The distance δw is available for evaluation on 
boundaries.

T H E O R Y  F O R  T H E  N O N I S O T H E R M A L  S C R E E N  B O U N D A R Y  C O N D I T I O N

When the Nonisothermal Flow multiphysics coupling feature is active, the conditions 
that apply across a screen in isothermal flow are complemented by:

 (4-99)

where H0 is the total enthalpy.
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• See Screen for the feature node details. 

• Also see Screen boundary condition described for the single-phase flow 
interfaces.
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T H E O R Y  F O R  T H E  I N T E R I O R  F A N  B O U N D A R Y  C O N D I T I O N

When the Nonisothermal Flow multiphysics coupling feature is active, the conditions 
that apply across an interior fan are complemented by:

• If direction is Along normal vector, the outlet temperature is T_avg where T_avg is 
the weighted averaged temperature defined as:

• If the direction is opposite to normal vector, the outlet temperature is T_avg where 
T_avg is:

Theory for the Thermoelectric Effect Interface

The Thermoelectric Effect Interface implements thermoelectric effect, which is the 
direct conversion of temperature differences to electric voltage or vice versa. Devices 
such as thermoelectric coolers for electronic cooling or portable refrigerators rely on 
this effect. While Joule heating (resistive heating) is an irreversible phenomenon, the 
thermoelectric effect is, in principle, reversible.

Historically, the thermoelectric effect is known by three different names, reflecting its 
discovery in experiments by Seebeck, Peltier, and Thomson. The Seebeck effect is the 
conversion of temperature differences into electricity, the Peltier effect is the 
conversion of electricity to temperature differences, and the Thomson effect is heat 
produced by the product of current density and temperature gradients. These effects 
are thermodynamically related by the Thomson relations:
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
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P ST=
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where P is the Peltier coefficient (SI unit: V), S is the Seebeck coefficient 
(SI unit: V/K), T is the temperature (SI unit: K), and μTh is the Thomson coefficient 
(SI unit: V/K). These relations show that all coefficients can be considered different 
descriptions of one and the same quantity. The COMSOL formulation primarily uses 
the Seebeck coefficient. The Peltier coefficient is also used as an intermediate variable, 
but the Thomson coefficient is not used.

When simulating the thermoelectric effect, the following fluxes are the quantities of 
interest:

• Conductive heat flux q, defined by

 (4-100)

• Electric current density J, defined by

 (4-101)

Thermoelectric efficiency is measured by the figure of merit Z (SI unit: 1/K), defined 
as:

where σ is the electrical conductivity and k the thermal conductivity.

Some other quantities of relevance are the electric field E and the Joule heat source Q:

From these definitions, conservation of heat energy and electrical current in an 
immobile solid reads:

where ρ is the density, Cp the heat capacity, and Qj is the current source.

q k∇T– PJ+=

J σ ∇V S∇T+( )–=

Z S2σ
k

----------=

E ∇V–=

Q J E⋅=

ρCp t∂
∂T ∇ q⋅+ Q=

∇ J⋅ Qj=
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H O W  T H E  S E E B E C K ,  P E L T I E R ,  A N D  T H O M S O N  E F F E C T S  A R E  I N C L U D E D  

I N  T H E  G E N E R A L  F O R M U L A T I O N

The general formulation of thermoelectric effect redefines the heat flux and the electric 
current according to Equation 4-100 and Equation 4-101, respectively. This 
formulation does not necessarily correspond to the formulation used when only a 
particular aspect of thermoelectric effect is considered: Seebeck, Peltier, or Thomson. 
This paragraph describes how these separated effects can be recognized in the general 
formulation.

Seebeck Effect
The Seebeck effect is described as the conversion of temperature gradient into electric 
current. The contribution of the Seebeck effect is defined as a current contribution

This formulation corresponds directly to Equation 4-101 used in the general 
formulation.

Peltier Effect
The Peltier effect is described as the conversion of t electric current in heat source or 
sink. It is defined as an heat source contribution

This contribution is obtained by developing the divergence of q term in the heat 
equation when q is defined following Equation 4-100.

Thomson Effect
The Thomson effect defines the heat source induced by a current in presence of a 
temperature gradient in thermoelectric material. The heat source is defined by

This contribution is obtained again by developing the divergence of the q term in the 
heat equation when q is defined following Equation 4-100. This time consider the 
term −TJ ⋅ ∇S. Assuming that S is function of T, then:

JSe σS∇T–=

QPe P∇ J⋅–=

QTh μThJ ∇T⋅–=

TJ ∇S⋅– T
Td

dSJ ∇T⋅– μThJ ∇T⋅–= =
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Theory for the Local Thermal Non-Equilibrium Interface

The detailed theory leading to the equations of local thermal non-equilibrium heat 
transfer in porous media is presented above in Theory for Heat Transfer in Porous 
Media. This part only recalls the main results and describes how Local Thermal 
Non-Equilibrium multiphysics coupling feature implements them.

The local thermal non-equilibrium hypothesis describes heat transfer in a porous 
medium using two temperature fields to solve: Tf for the fluid phase and Ts for the 
porous matrix. These should satisfy the following couple of partial differential 
equations:

 (4-102)

 (4-103)

Recall the Fourier’s law of conduction adapted to the local thermal non-equilibrium 
hypothesis:

and the quantities used in this problem:

• θp is the solid volume fraction (SI unit: 1)

• ρs and ρf are the solid and fluid densities (SI unit: kg/m3)

• Cp, s and Cp, f are the solid and fluid heat capacities at constant pressure (SI unit: 
J/(kg·K))

• qs and qf are the solid and fluid conductive heat fluxes (SI unit: W/m2)

• ks and kf are the solid and fluid thermal conductivities (SI unit: W/(m·K))

• qsf is the interstitial convective heat transfer coefficient (SI unit: W/(m3·K))

• Qs and Qf are the solid and fluid heat sources (SI unit: W/m3)

• up is the porous velocity vector (SI unit: m/s)

P R E D E F I N E D  M U L T I P H Y S I C S  I N T E R F A C E

The Local Thermal Non-Equilibrium Interface is a predefined coupling between The 
Heat Transfer in Solids Interface and The Heat Transfer in Fluids Interface. These two 

θpρsCp s, t∂
∂Ts ∇ qs⋅+ qsf Tf Ts–( ) θpQs+=

1 θp–( )ρfCp f, t∂
∂Tf ρfCp f, up Tf∇⋅ ∇ qf⋅+ + qsf Ts Tf–( ) 1 θp–( )Qf+=

qs θpks Ts∇–=

qf 1 θp–( )kf Tf∇–=
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interfaces solve for Equation 4-102 and Equation 4-103, respectively, but without the 
heat exchange term ±qsf(Tf − Ts).

The Local Thermal Non-Equilibrium multiphysics coupling feature combines two 
actions in order to couple the two aforementioned physics interfaces. It first multiplies 
each energy equation by its volume fraction: θp and (1 − θp) for solid and fluid phases, 
respectively. Then it adds the heat exchange term ±qsf(Tf − Ts) in both equations.

VO L U M E T R I C  A N D  S U R F A C E  T H E R M A L  C O N D I T I O N S

As shown in Equation 4-102 and Equation 4-103, the volumetric heat sources θpQs 
and (1 − θp)Qf are applied to the energy equations. The Heat Source features of each 
physics interface though specifies Qs and Qf. Special care is therefore needed when 
defining a heat source for the whole porous medium. You would have to ensure that 
the heat source densities, Qs and Qf, are both equal to the heat rate density that was 
intended to the porous medium.

Theory for the Heat and Moisture Transport Interface

The Heat and Moisture multiphysics coupling implements the following equations for 
heat and moisture transport, derived from Ref. 15:

 (4-104)

 (4-105)

where:

• (ρCp)eff (SI unit: J/(m3·K)) is the effective volumetric heat capacity at constant 
pressure.

• T (SI unit: K) is the temperature.

• keff (SI unit: W/(m·K)) is the effective thermal conductivity.

• Lv (SI unit: J/kg) is the latent heat of evaporation.

• δp (SI unit: s) is the vapor permeability.

• φ (dimensionless) is the relative humidity.

• psat (SI unit: Pa) is the vapor saturation pressure.

• Q (SI unit: W/m3) is the heat source.

• ξ (SI unit: kg/m3) is the moisture storage capacity.

ρCp( )eff
∂T
∂t
------- ∇ k– eff∇T Lv– δp φpsat( )∇( )⋅+ Q=

ξ∂φ
∂t
------ ∇ ξ– Dw∇φ δp φpsat( )∇–( )⋅+ G=
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• Dw (SI unit: m2/s) is the moisture diffusivity.

• G (SI unit: W/m3) is the moisture source.

Theory for the Electromagnetic Heating Interfaces

COMSOL Multiphysics provides four multiphysics interfaces for handling 
electromagnetic heating in the Heat Transfer interfaces:

• The Joule Heating Interface

• The Laser Heating Interface (requires the Wave Optics Module)

• The Induction Heating Interface (requires the AC/DC Module for 3D models)

• The Microwave Heating Interface (requires the RF Module)

They all have in common these three multiphysics coupling features:

• Electromagnetic Heat Source

• Boundary Electromagnetic Heat Source

• Temperature Coupling

The first two features add weak contributions due to resistive losses in the domains and 
boundaries, respectively. The underlying theory can be found in the AC/DC Module 
User’s Guide, RF Module User’s Guide, and Wave Optics Module User’s Guide.

The reverse coupling is carried by the Temperature Coupling feature that shares the 
temperature variable with the electromagnetics interfaces.

Theory for the Thermal Stress Interface

In the Structural Mechanics interfaces, two multiphysics interfaces handle thermal 
stress:

• The Thermal Stress Interface

• The Joule Heating and Thermal Expansion Interface

Both require the Structural Mechanics Module. They have in common the use of the 
Thermal Expansion multiphysics coupling that models temperature dependence of the 
strain tensor and thermoelastic damping. For more details about the underlying 
theory, see the Structural Mechanics Module User’s Guide.
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Th eo r y  f o r  T h e rma l  C on t a c t

The Thermal Contact feature has correlations to evaluate the joint conductance at two 
contacting surfaces.

The heat fluxes at the upside and downside boundaries depend on the temperature 
difference according to the relations:

At a microscopic level, contact is made at a finite number of spots as in Figure 4-13.

Figure 4-13: Contacting surfaces at the microscopic level.

The joint conductance, h, has three contributions: the constriction conductance, hc, 
from the contact spots, the gap conductance, hg, due to the fluid at the interstitial 
space, and the radiative conductance, hr:

Surface Asperities

The microscopic surface asperities are characterized by the average height σu, asp and 
σd, asp and the average slope mu, asp and md, asp. The RMS values σasp and masp are 
(4.16 in Ref. 22):

nd– kd∇Td–( )⋅ h– Tu Td–( ) rQb+=

nu– ku∇Tu–( )⋅ h– Td Tu–( ) 1 r–( )Qb+=

Y
masp,u asp,u

h hc hg hr+ +=

σasp σu asp,
2 σd asp,

2+= masp mu asp,
2 md asp,

2+=
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Constriction Conductance

C O O P E R - M I K I C - YOV A N O V I C H  ( C M Y )  C O R R E L A T I O N

The Cooper-Mikic-Yovanovich (CMY) correlation is valid for isotropic rough surfaces 
and has been formulated using a model assuming plastic deformation of the surface 
asperities. However, this model does not compute nor store the plastic deformations 
of the asperities. It means that, despite that a plastic deformation of the asperities is 
assumed, this contact model has no memory. For example, if a load is applied twice the 
thermal contact is identical in both cases. The Cooper-Mikic-Yovanovich (CMY) 
correlation relates hc to the asperities and pressure load at the contact interface:

Here, Hc is the microhardness of the softer material, p is the contact pressure, and 
kcontact is the harmonic mean of the contacting surface conductivities:

The relative pressure p ⁄ Hc can be evaluated by specifying Hc directly or using the 
following relation (4.16.1 in Ref. 22) for the relative pressure using the Vickers 
correlation coefficient c1 and size index c2:

where σ0 is equal to 1 µm. For materials with a Brinell hardness between 1.30 and 
7.60 GPa, c1 and c2 are given by the correlation below (4.16.1 in Ref. 22):

hc 1.25kcontact
masp
σasp
------------- p

Hc
------- 
  0.95

=

kcontact
2kukd
ku kd+
-------------------=

When ku (resp. kd) is not isotropic, it is replaced by its normal 
conductivity nTkun (resp. nTkdn).

p
Hc
------- p

c1 1.62
σasp

maspσ0
--------------------

 
 
  c2

------------------------------------------------

 
 
 
 
 
 
  1

1 0.071c2+( )
-----------------------------------

=

c1
H0
------- 4.0 5.77

HB
H0
--------– 4.0

HB
H0
-------- 
 

2
0.61

HB
H0
-------- 
 

3
–+=
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The Brinell hardness is denoted by HB, and H0 is equal to 3.178 GPa.

M I K I C  E L A S T I C  C O R R E L A T I O N

The Mikic correlation is valid for isotropic rough surfaces and assumes elastic 
deformations of surface asperities. It gives hc by the following relation:

Here, Econtact is an effective Young’s modulus for the contact interface, satisfying 
(4.16.3 in Ref. 22):

where Eu and Ed are the Young’s moduli of the two contacting surfaces and νu and νd 
are the Poisson’s ratios.

Gap Conductance

The gap conductance due to interstitial fluid cannot be neglected for high fluid 
thermal conductivity or high contact pressure. The parallel-plate gap gas correlation 
assumes that the interstitial fluid is a gas and defines hg by:

Here kgap is the gas conductivity, Y denotes the mean separation thickness (see 
Figure 4-13), and Mg is the gas parameter equal to:

In these relations, α is the contact thermal accommodation parameter, β is a gas 
property parameter (equal to 1.7 for air), Λ is the gas mean free path, kB is the 
Boltzmann constant, D is the average gas particle diameter, pg is the gas pressure 
(often the atmospheric pressure), and Tg is the gap temperature equal to:

c2 0.37– 0.442
HB
c1
--------+=

hc 1.54kcontact
masp
σasp
------------- 2p

mEcontact
--------------------------- 
 

0.94
=

1
Econtact
----------------------

1 νu
2–

Eu
---------------

1 νd
2–

Ed
---------------+=

hg
kgap

Y Mg+
------------------=

Mg αβΛ= Λ
kBTg

2πD2pg

-------------------------=
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The mean separation thickness, Y, is a function of the contact pressure, p. For low 
values of p near 0 Pa, Y goes to infinity since no contact occur. For high values of p — 
greater than Hc ⁄ 2 in the Cooper-Mikic-Yovanovich model and greater than Hc ⁄ 4 in 
the Mikic elastic model — Y reduces to 0 meaning that the contact is considered as 
perfect.

Radiative Conductance

At high temperatures, above 600 °C, radiative conductance needs to be considered. 
The gray-diffuse parallel plate model provides the following formula for hr:

which implies that:

Thermal Friction

The friction heat source, Qb, is partitioned into rQb and (1 − r)Qb at the contact 
interface. If the two bodies are identical, r and (1 − r) would be 0.5 so that half of the 
friction heat goes to each surface. However, in the general case where the two bodies 
are made of different materials, the partition rate might not be 0.5. The Charron’s 
relation (Ref. 23) defines r as:

and symmetrically, (1 − r) is:

Tg
Tu Td+

2
--------------------=

hr
εuεd

εu εd εuεd–+
-----------------------------------σ Tu

3 Tu
2Td TuTd

2 Td
3+ + +( )=

hr Tu Td–( )
εuεd

εu εd εuεd–+
-----------------------------------σ Tu

4 Td
4–( )=

hr Td Tu–( )
εuεd

εu εd εuεd–+
-----------------------------------σ Td

4 Tu
4–( )=

r 1
1 ξd+
---------------= ξd

ρuCp u, ku
ρdCp d, kd
-------------------------=

1 r–( ) 1
1 ξu+
---------------= ξu

ρdCp d, kd
ρuCp u, ku
-------------------------=
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For anisotropic conductivities, nTkdn and nTkun replaces kd and ku, respectively.

Thermal Contact

Contact Switch: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/contact_switch
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Mo i s t  A i r  F l u i d  T y p e

For The Heat Transfer in Fluids Interface, you can select moist air as the fluid type. 
This is provided to calculate the relative humidity and to deduce if there is 
condensation. The following theory assumes that moist air is an ideal gas.

Humidity

This part defines the different definitions of humidity in the moist air theory.

M O I S T U R E  C O N T E N T

The moisture content (also called mixing ratio or humidity ratio) is defined as the 
ratio of water vapor mass, mv, to dry air mass, ma:

 (4-106)

where pv is the water vapor partial pressure, pa is the dry air partial pressure, and Ma 
and Mv are the molar mass of dry air and water vapor, respectively. Without 
condensation, the moisture content is not affected by temperature and pressure. The 
moisture content represents a ratio of mass, and it is thus a dimensionless number.

R E L A T I V E  H U M I D I T Y

The relative humidity of an air mixture is expressed as follows:

 (4-107)

where pv is the water vapor partial pressure and psat is the saturation pressure of water 
vapor.

According to Dalton’s law, the total pressure of a mixture of gases is the sum of all the 
partial pressures of each individual gas; that is, p = pv + pa where pa is the dry air 
partial pressure.

The relative humidity formulation is often used to quantify humidity. However, for the 
same quantity of moisture content, the relative humidity changes with temperature 
and pressure, so in order to compare different values of φ it has to be at the same 
temperature and pressure conditions.

xvap
mv
ma
--------

pvMv
paMa
---------------= =

φ
pv

psat
----------=
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This quantity is useful to study the condensation as it defines the boundary between 
the liquid phase and the vapor phase. In fact, when the relative humidity φ reaches 
unity, it means that the vapor is saturated and that water vapor condenses.

The Reference relative humidity (dimensionless) is a quantity defined between 0 and 1, 
where 0 corresponds to dry air and 1 to a water vapor-saturated air. This Reference 

relative humidity associated to the Reference temperature and the Reference pressure are 
used to calculate the moisture content. Then the thermodynamical properties of moist 
air can be deduced through the mixture formula described below.

S P E C I F I C  H U M I D I T Y

The specific humidity is defined as the ratio of water vapor, mv, to the total mass, 
mtot = mv + ma:

  (4-108)

C O N C E N T R A T I O N

The concentration is defined by:

 (4-109)

where nv is the amount of water vapor (SI unit: mol) and V is the total volume (SI unit: 
m3). According to the ideal gas hypothesis, the saturation concentration is defined as 
follows:

The Reference relative humidity cannot be greater than 1, above which 
value the water vapor is condensing. If the value is greater than 1, the 
Reference relative humidity value is forced to be 1. The condensation area 
cannot be simulated.

ω
mv

mtot
------------=

When the water vapor only accounts for a few percent in the total mass, 
the moisture content and the specific humidity are very close: xvap ≈ ω 
(only for low values). For larger values of ω, the two quantities are more 
precisely related by:

xvap
ω

1 ω–
-------------=

cv
nv
V
------=
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 (4-110)

Saturation State

The saturation state is reached when the relative humidity reaches one. It means that 
the partial pressure of the water vapor is equal to the saturation pressure (which also 
depends on the temperature).

From Ref. 33, the saturation pressure can be defined using the following expression:

 (4-111)

Temperature and saturation pressure are deduced from this formulation.

Moist Air Properties

The thermodynamical properties of moist air can be found with some mixture laws. 
These are defined in this paragraph.

P R E L I M I N A R Y  D E F I N I T I O N S

Molar Fraction
The molar fraction of dry air, Xa, and the molar fraction of water vapor, Xv, are defined 
such as:

 (4-112)

 (4-113)

where:

• na is amount of dry air

• nv is amount of water vapor

• ntot is the total amount of moist air in mol

• pa is the partial pressure of dry air

• pv is the partial pressure of water vapor

csat
psat T( )

RT
--------------------=

psat T( ) 610.7 Pa[ ] 10
7.5T 273.15 K[ ]–

T 35.85 K[ ]–
--------------------------------------

⋅=

Xa
na

ntot
----------

pa
p
------

p φpsat–

p
-----------------------= = =

Xv
nv

ntot
----------

pv
p
------

φpsat
p

--------------= = =
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• p is the pressure

• φ is the relative humidity, and

• psat is the saturation pressure.

Relative Humidity and Moisture Content
Moisture content and relative humidity can be related with the following expression:

 (4-114)

M I X T U R E  P R O P E R T I E S

The thermodynamical properties are built through a mixture formula. The expressions 
depend on dry air properties and pure steam properties and are balanced by the mass 
fraction.

Density
According to the ideal gas law, the mixture density ρm expression is defined as follows:

 (4-115)

where Ma and Mv are the molar mass of dry air and water vapor, respectively, and Xa 
and Xv are the molar fraction of dry air and water vapor, respectively.

Heat Capacity at Constant Pressure
According to Ref. 34, the heat capacity at constant pressure of a mixture is:

 (4-116)

where Mm represents the mixture molar fraction and is defined by

From Equation 4-112 and Equation 4-113, the following relation holds:

Xa Xv+ 1=

φ
xvapp

psat
Mv
Ma
-------- xvap+ 
 

-------------------------------------------=

ρm
p

RT
-------- MaXa MvXv+( )=

The ideal gas assumption sets the compressibility factor and the 
enhancement factor to unity. In fact, the accuracy lost by this assumption 
is small as the pure steam represents a small fraction.

Cp m,
Ma
Mm
----------XaCp a,

Mv
Mm
----------XvCp v,+=
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and where Cp, a and Cp, v are the heat capacity at constant pressure of dry air and 
steam, respectively.

Dynamic Viscosity
According to Ref. 34 and Ref. 35, the dynamic viscosity is defined as:

 (4-117)

where ϕij is given by

Here, μa and μv are the dynamic viscosity of dry air and steam, respectively.

Thermal Conductivity
According to Ref. 35 and Ref. 34, the thermal conductivity of the mixture is defined 
similarly:

 (4-118)

where ka and kv are the thermal conductivity of dry air and steam, respectively.

P U R E  C O M P O N E N T  P R O P E R T I E S

The dry air and steam properties used to define the mixture properties are 
temperature-dependent high-order polynomials. The polynomials have been 
computed according to Ref. 18 for dry air properties and Ref. 36 for pure steam 
properties. The steam properties are based on the Industrial Formulation 
IAPWS-IF97.

The valid temperature range is 200 K < T < 1200 K for dry air properties and 
273.15 K < T < 873.15 K for steam properties.
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R E S U L T S  A N D  A N A L Y S I S  V A R I A B L E S

These variables are provided to display the related quantities:

• Moisture content xvap.

• Vapor mass fraction omega_moist.

• Concentration of water vapor c.

• Relative humidity phi. This variable corresponds to the calculated φ with the system 
temperature and pressure.

• Condensation indicator condInd; this indicator is set to 1 if condensation has been 
detected (φ = 1) and 0 if not.

F U N C T I O N S

The following functions are defined and can be used as feature parameters as well as in 
postprocessing. Here, feature stands for fluid or porous, depending on whether the 
function is defined in the Fluid or in the Porous Medium feature:

• ht.feature.fc(RH,T, pA), where RH is the relative humidity 0 ≤ φ ≤ 1, T is the 
temperature (SI unit: K), and pA is the pressure (SI unit: Pa). It returns the 
corresponding water vapor concentration (SI unit: mol/m3) by deriving the 
following relation from Equation 4-107, Equation 4-110, and Equation 4-114:

• ht.feature.fxvap(RH, T, pA), where RH is the relative humidity 0 ≤ φ ≤ 1, T is 
the temperature (SI unit: K) and pA is the pressure (SI unit Pa). It returns the 
moisture content (SI unit: 1) by using the following relation:

• ht.feature.fpsat(T), where T is the temperature (SI unit: K). It returns the 
saturation pressure (SI unit: Pa) by using Equation 4-111.

• ht.feature.Lv(T), where T is the temperature (SI unit: K). It returns the latent 
heat of evaporation (SI unit: J/kg) as a linear interpolation of the data from Ref. 36, 

cv
xvapp

xvap
Mv
Ma
--------+ 

 RT

-----------------------------------------=

The concentration computation assumes that the ideal gas assumption is 
valid.

xvap
φpsat

p φpsat–
-----------------------

Mv
Ma
--------⋅=
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which provides steam properties based on the Industrial Formulation IAPWS-IF97. 
The temperature-dependency is as shown on Figure 4-14.

Figure 4-14: Latent heat of evaporation in function of temperature.
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Ou t - o f - P l a n e  Hea t  T r a n s f e r

When the object to model in COMSOL Multiphysics is thin or slender enough along 
one of its geometry dimensions, there is usually only a small variation in temperature 
along the object’s thickness or cross section. For such objects, it is computationally 
more efficient to reduce the model geometry to 2D or even 1D and to use the 
out-of-plane heat transfer mechanism. Figure 4-15 shows examples of possible 
situations in which this type of geometry reduction can be applied.

Figure 4-15: Geometry reduction from 3D to 1D (top) and from 3D to 2D (bottom).

The reduced geometry does not include all the boundaries of the original 3D 
geometry. For example, the reduced geometry does not represent the upside and 
downside surfaces of the plate in Figure 4-15 as boundaries.

Equation Formulation

2 D  G E O M E T R I E S

In 2D geometries, the temperature is assumed to be constant in the out-of-plane 
direction (z-direction with default spatial coordinate names). The equation for heat 
transfer in solids, Equation 4-14, and in fluids, Equation 4-16, are replaced by:

qup

qdown

q

Out-of-Plane Radiation and Out-of-Plane Heat Flux
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 (4-119)

 (4-120)

Here dz is the thickness of the domain in the out-of-plane direction. Here, the 
conductive heat flux, q, becomes

1 D  A X I S Y M M E T R I C  G E O M E T R I E S

In 1D axisymmetric geometries, the temperature is assumed to be constant in the 
out-of-plane direction (z-direction with default spatial coordinate names) in addition 
to the axisymmetry (φ-coordinate with default spatial coordinate names). The equation 
for heat transfer in solids, Equation 6-9 is replaced by

 (4-121)

where dz is the thickness of the domain in the z-direction. The equation for heat 
transfer in fluids, Equation 6-3, is replaced by

 (4-122)

Here, the conductive heat flux, q, becomes

1 D  G E O M E T R I E S

In 1D geometries, the temperature is assumed to be constant in the radial direction. 
The equation for heat transfer in solids, Equation 6-9 is replaced by

 (4-123)

where Ac is the cross section of the domain in the plane perpendicular to the 1D 
geometry. The equation for heat transfer in fluids, Equation 6-3, is replaced by

 (4-124)

Here, the conductive heat flux, q, becomes

dzρCp
∂T
∂t
------- ∇ q⋅+ dzQ q0+=

dzρCp
∂T
∂t
------- ρCpdzu ∇T ∇ q⋅+⋅+ dzQ q0+=

q d– zk∇T=

2πrdz( )ρCp
∂T
∂t
------- ∇ q⋅+ 2πrdz( )Q q0+=

2πrdz( )ρCp
∂T
∂t
------- 2πrdz( )ρCpu ∇T ∇ q⋅+⋅+ 2πrdz( )Q q0+=

q 2πrdz( )k∇T–=

AcρCp
∂T
∂t
------- ∇ q⋅+ AcQ q0+=

AcρCp
∂T
∂t
------- AcρCpu ∇T ∇ q⋅+⋅+ AcQ q0+=
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Out-of-plane flux conditions would apply to the exterior boundaries of the domain if 
the 1D geometry was seen as a cylinder. With the geometry reduction process, this 
heat flux condition is mathematically expressed using the cross section perimeter, Pc, 
as in:

where q0, z is the heat flux density distributed along the cross section perimeter.

q Ac– k∇T=

q0 Pcq0 z,=
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Th e  Hea t  T r a n s f e r  C o e f f i c i e n t s

One of the most common boundary conditions when modeling heat transfer is 
convective cooling or heating whereby a fluid cools or heats a surface by natural or 
forced convection. In principle, it is possible to model this process in two ways:

• Using a heat transfer coefficient on the surfaces

• Extending the model to describe the flow and heat transfer in the surrounding fluid

The second approach is the most accurate if the geometry or the external flow is 
complicated. The Heat Transfer Module includes the Conjugate Heat Transfer 
predefined multiphysics coupling and the CFD Module includes the Nonisothermal 
Flow predefined multiphysics coupling for this purpose. However, such a simulation 
can become costly, both in terms of computational time and memory requirement.

The first method is simple, yet powerful and efficient. The convective heat flux on the 
boundaries in contact with the fluid is then modeled as being proportional to the 
temperature difference across a fictitious thermal boundary layer. Mathematically, the 
heat flux is described by the equation

where h is a heat transfer coefficient and Text the temperature of the external fluid far 
from the boundary.

The main difficulty in using heat transfer coefficients is in calculating or specifying the 
appropriate value of the h coefficient. That coefficient depends on the fluid’s material 
properties, and the surface temperature — and, for forced convection, also on the 
fluid’s flow rate. In addition, the geometrical configuration affects the coefficient. The 
Heat Transfer interface has built-in functions for the heat transfer coefficients. For 
most engineering purposes, the use of such coefficients is an accurate and numerically 
efficient modeling approach.

In this section:

• Defining the Heat Transfer Coefficients

• Nature of the Flow — The Grashof Number

• Heat Transfer Coefficients — External Natural Convection

• Heat Transfer Coefficients — Internal Natural Convection

n– q⋅ h Text T–( )=
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• Heat Transfer Coefficients — External Forced Convection

• Heat Transfer Coefficients — Internal Forced Convection

Defining the Heat Transfer Coefficients

It is possible to divide the convective heat flux into four main categories depending on 
the type of convection condition (natural or forced) and on the type of geometry 
(internal or external flow). In addition, these cases can all experience either laminar or 
turbulent flow conditions, resulting in eight types of convection, as in Figure 4-16.

Figure 4-16: The eight categories of convective heat flux.

The difference between natural and forced convection is that in the forced convection 
an external force such as a fan creates the flow. In natural convection, buoyancy forces 
induced by temperature differences together with the thermal expansion of the fluid 
drive the flow.

Heat transfer books generally contain a large set of empirical and theoretical 
correlations for h coefficients. This module includes a subset of them. The expressions 
are based on the following set of dimensionless numbers:

• The Nusselt number, NuL = hL ⁄ k

• The Reynolds number, ReL = ρUL ⁄ μ

Natural Forced

External

Internal

Laminar Flow

Turbulent Flow
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• The Prandtl number, Pr = μCp ⁄ k

• The Rayleigh number, RaL = GrLPr = ρ2gαpCpΔTL3 ⁄ (μk)

where

• h is the heat transfer coefficient (SI unit: W/(m2·K))

• L is the characteristic length (SI unit: m)

• ΔT is the temperature difference between the surface and the external fluid bulk 
(SI unit: K)

• g is the acceleration of gravity (SI unit: m/s2)

• k is the thermal conductivity of the fluid (SI unit: W/(m·K))

• ρ is the fluid density (SI unit: kg/m3)

• U is the bulk velocity (SI unit: m/s)

• μ is the dynamic viscosity (SI unit: Pa·s)

• Cp is the heat capacity at constant pressure of the fluid (SI unit: J/(kg·K))

• αp is the coefficient of thermal expansion (SI unit: 1/K)

Further, GrL refers to the Grashof number, which is the squared ratio of the viscous 
time scale to the buoyancy time scale multiplied by the Reynolds number.

Nature of the Flow — The Grashof Number

In cases of externally driven flow, such as forced convection, the nature of the flow is 
characterized by the Reynolds number, Re, which describes the ratio of the inertial 
forces to the viscous forces. However, the velocity scale is initially unknown for 
internally driven flows such as natural convection. In such cases the Grashof number, 
Gr, characterizes the flow. It describes the ratio of the time scales for viscous diffusion 
in the fluid and the internal driving force (the buoyancy force). Like the Reynolds 
number it requires the definition of a length scale, the fluid’s physical properties, and 
the temperature scale (temperature difference). The Grashof number is defined as:

where g is the acceleration of gravity, αp is the fluid’s coefficient of thermal expansion, 
Ts denotes the temperature of the hot surface, T0 equals the temperature of the 
surrounding air, L is the length scale, μ represents the fluid’s dynamic viscosity, and ρ 
its density.

GrL
gαp Ts T0–( )L3

μ ρ⁄( )2
------------------------------------------=
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In general, the coefficient of thermal expansion αp is given by

which for an ideal gas reduces to

The transition from laminar to turbulent flow occurs at a Gr value of 109; the flow is 
turbulent for larger values.

The Rayleigh number, Ra, is another indicator of the regime. It is similar to the 
Grashof number except that it accounts for the thermal diffusivity: Ra = Pr Gr. A small 
value of the Ra number indicates that the conduction dominates. It such case using 
heat transfer coefficients to model convective heat transfer is not relevant. Instead, 
modeling the fluid as immobile is likely to be accurate.

Heat Transfer Coefficients — External Natural Convection

VE R T I C A L  WA L L

Figure 4-17: Schematic representation of geometry and parameters for the heat transfer 
coefficient correlation applied to natural convection on a vertical wall.

The following correlations correspond to equations 9.26 and 9.27 in Ref. 18:

αp
1
ρ
--- ρ∂

T∂
------- 
 

p
–=

αp
1
T
----=
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 (4-125)

where the height of the wall, L, is a correlation input and

 (4-126)

where in turn g is the acceleration of gravity equal to 9.81 m/s2. All material 
properties are evaluated at (T + Text) ⁄ 2. This correlation is valid for 104≤ RaL ≤ 1013.

I N C L I N E D  WA L L

Figure 4-18: Schematic representation of geometry and parameters for the heat transfer 
coefficient correlation applied to natural convection on an inclined wall.

The following correlations correspond to equations 9.26 and 9.27 in Ref. 18 (the 
same as for a vertical wall):

h

k
L
---- 0.68

0.67RaL
1 4⁄

1 0.492k
μCp

------------------- 
  9 16/

+ 
  4 9/
----------------------------------------------------------+

 
 
 
 
 

if RaL 109≤

k
L
---- 0.825

0.387RaL
1 6⁄

1 0.492k
μCp

------------------- 
  9 16/

+ 
  8 27/
-------------------------------------------------------------+

 
 
 
 
  2

if RaL 109>















=

RaL
gαpρ2Cp T Text– L3

kμ
--------------------------------------------------------=
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 (4-127)

where the length of the wall, L, is a correlation input and ϕ is the tilt angle (the angle 
between the wall and the vertical direction; ϕ = 0 for vertical walls). These correlations 
are valid for −60° < ϕ < 60° and 104≤ RaL ≤ 1013. 

The definition of the Raleigh number, RaL, is analogous to the one for vertical walls 
and is given by the following:

 (4-128)

where in turn g denotes the gravitational acceleration, equal to 9.81 m/s2.

For turbulent flow, 1 is used instead of cos φ in the expression for h, because this gives 
better accuracy (see Ref. 38).

The laminar-turbulent transition depends on φ (see Ref. 38). Unfortunately, little data 
is available about transition. There is some data available in Ref. 38 but this data is only 
approximative, according to the authors. In addition, data is only provided for water 
(Pr around 6). For this reason, the flow is defined as turbulent, independently of the 
φ value, when

All material properties are evaluated at (T + Text) ⁄ 2.

h

k
L
---- 0.68

0.67 ϕRaLcos( )1 4/

1 0.492k
μCp

------------------- 
  9 16/

+ 
  4 9/
----------------------------------------------------------+

 
 
 
 
 

if RaL 109≤

k
L
---- 0.825

0.387RaL
1 6⁄

1 0.492k
μCp

------------------- 
  9 16/

+ 
  8 27/
-------------------------------------------------------------+

 
 
 
 
  2

if RaL 109>















=

RaL
gαpρ2Cp T Text– L3

kμ
--------------------------------------------------------=

According to Ref. 18, correlations for inclined walls are only satisfactory 
for the top side of a cold plate or the down face of a hot plate. Hence, 
these correlations are not recommended for the bottom side of a cold face 
and for the top side of a hot plate.

gαpρ2Cp T Text– L3

kμ
-------------------------------------------------------- 109>
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H O R I Z O N T A L  P L A T E ,  U P S I D E

Figure 4-19: Schematic representation of geometry and parameters for the heat transfer 
coefficient correlation applied to natural convection on the top surface of an horizontal 
plate.

The following correlations correspond to equations 9.30–9.32 in Ref. 18 but can also 
be found as equations 7.77 and 7.78 in Ref. 38.

If T > Text, then

 (4-129)

while if T ≤ Text, then

 (4-130)

RaL is given by Equation 4-126, and L, the characteristic length (defined as 
area/perimeter, see Ref. 38) is a correlation input. The material data are evaluated at 
(T + Text) ⁄ 2.

h

k
L
----0.54RaL

1 4⁄ if 104 RaL≤ 107≤

k
L
----0.15RaL

1 3⁄ if 107 RaL≤ 1011≤








=

h k
L
----0.27RaL

1 4⁄  if 105 RaL≤ 1010≤=
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H O R I Z O N T A L  P L A T E ,  D O W N S I D E

Figure 4-20: Schematic representation of geometry and parameters for the heat transfer 
coefficient correlation applied to natural convection on the bottom surface of an 
horizontal plate.

Equation 4-129 is used when T ≤ Text and Equation 4-130 is used when T > Text. 
Otherwise it is the same implementation as for Horizontal Plate, Upside.

L O N G  H O R I Z O N T A L  C Y L I N D E R

Figure 4-21: Schematic representation of geometry and parameters for the heat transfer 
coefficient correlation applied to natural convection on a long horizontal cylinder.

The following correlations correspond to equations 9.34 in Ref. 18. It is validated for 
RaD ≤ 1012.

 (4-131)

Here D is the cylinder diameter and RaD is given by

h k
D
---- 0.6

0.387RaD
1 6⁄

1 0.559
Pr

--------------- 
  9 16⁄

+ 
  8 27⁄
----------------------------------------------------------+

 
 
 
 
  2

=

RaD
gαpρ2Cp T Text– D3

kμ
---------------------------------------------------------=
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The material data are evaluated at (T + Text) ⁄ 2.

S P H E R E

Figure 4-22: Schematic representation of geometry and parameters for the heat transfer 
coefficient correlation applied to natural convection on a sphere.

The following correlations correspond to equation 9.35 in Ref. 18. It is validated for 
RaD ≤ 1011 and Pr ≥ 0.7.

 (4-132)

Here D is the cylinder diameter and RaD is given by

The material data are evaluated at (T + Text) ⁄ 2.

VE R T I C A L  T H I N  C Y L I N D E R

Figure 4-23: Schematic representation of geometry and parameters for the heat transfer 
coefficient correlation applied to natural convection on a vertical thin cylinder.

h k
D
---- 2

0.589RaD
1 4⁄

1 0.469
Pr

--------------- 
  9 16⁄

+ 
  4 9⁄
-------------------------------------------------------+

 
 
 
 
  2

=

RaD
gαpρ2Cp T Text– D3

kμ
---------------------------------------------------------=
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The following correlation corresponds to equation 7.83 in Ref. 38. It is validated only 
for side walls of the thin cylinder (δT ≥ D), the horizontal disks (top and bottom) 
should be treated as horizontal plates. If the boundary thin layer is much smaller than 
D, vertical wall correlations should be used.

where D is the cylinder diameter, H is the cylinder height, and RaH is given by

The material data are evaluated at (T + Text) ⁄ 2.

Heat Transfer Coefficients — Internal Natural Convection

N A R R O W  C H I M N E Y,  P A R A L L E L  P L A T E S

Figure 4-24: Schematic representation of geometry and parameters for the heat transfer 
coefficient correlation applied to natural convection in a parallel-plate narrow chimney.

If RaL < H ⁄ L and T > Text, then

 (4-133)

where the plate distance, L, and the chimney height, H, are correlation inputs 
(equation 7.96 in Ref. 38). RaL is given by Equation 4-126. The material data are 
evaluated at (T + Text) ⁄ 2.

h k
H
----- 4

3
---

7RaHPr
5 20 21Pr+( )
----------------------------------- 
 

1 4⁄ 4 272 315Pr+( )H
35 64 63Pr+( )D

-----------------------------------------------+ 
 =

RaH
gαp T Text– H3

kμ
-------------------------------------------=

h k
H
----- 1

24
------RaL=
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N A R R O W  C H I M N E Y,  C I R C U L A R  TU B E

Figure 4-25: Schematic representation of geometry and parameters for the heat transfer 
coefficient correlation applied to natural convection in a circular narrow chimney.

If RaD < H ⁄ D, then

where the tube diameter, D, and the chimney height, H, are correlation inputs (table 
7.2 in Ref. 38 with Dh = D). RaD is given by Equation 4-126 with L replaced by D. 
The material data are evaluated at (T + Text) ⁄ 2.

Heat Transfer Coefficients — External Forced Convection

P L A T E ,  A V E R A G E D  TR A N S F E R  C O E F F I C I E N T

Figure 4-26: Schematic representation of geometry and parameters for the averaged heat 
transfer coefficient correlation applied to forced convection on an horizontal plate.

This correlation is a combination of equations 7.33 and 7.41 in Ref. 18:

h k
H
----- 1

128
----------RaD=
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 (4-134)

where Pr = μCp ⁄ k and ReL = ρUL ⁄ μ. The plate length, L, and the exterior velocity, 
U, are correlation inputs. The material data are evaluated at (T + Text) ⁄ 2.

P L A T E ,  L O C A L  TR A N S F E R  C O E F F I C I E N T

Figure 4-27: Schematic representation of geometry and parameters for the local heat 
transfer coefficient correlation applied to forced convection on an horizontal plate.

This correlation corresponds to equations 5.79b and 5.131’ in Ref. 38:

 (4-135)

where Pr = μCp ⁄ k and Rex = ρUx ⁄ μ. The correlation inputs are x, the position along 
the plate, and U, the exterior velocity. The material data are evaluated at (T + Text) ⁄ 2. 
To avoid division by zero when the position along the plate is located at the origin 
point (x = 0), the implementation replaces k ⁄ x by k ⁄ max(x, √ε) where ε is the floating 
point relative accuracy.

h

2k
L
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0.3387Pr1 3/ ReL
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1 0.0468
Pr

------------------- 
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+ 
  1 4/
------------------------------------------------------- if ReL 5 10⋅ 5≤
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4 5⁄ 871–( ) if ReL 5 10⋅ 5>
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


=

h

k
x
---0.332Pr1 3/ Rex
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x
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




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

=
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C Y L I N D E R  I N  C R O S S  F L O W

Figure 4-28: Schematic representation of geometry and parameters for the averaged heat 
transfer coefficient correlation applied to forced convection on a cylinder in cross flow.

This correlation is given by equation 7.54 in Ref. 18:

 (4-136)

where Pr = μCp ⁄ k and ReD = ρUD ⁄ μ. The cylinder diameter, D, and the exterior 
velocity, U, are correlation inputs. The material data are evaluated at (T + Text) ⁄ 2.

S P H E R E

Figure 4-29: Schematic representation of geometry and parameters for the averaged heat 
transfer coefficient correlation applied to forced convection on a sphere.

This correlation corresponds to equation 7.56 in Ref. 18:

 (4-137)

h k
D
---- 0.3

0.62ReD
1 2⁄ Pr1 3/

1 0.4
Pr
--------- 
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----------------------------------------------- 1
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282000
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 
 
 
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1 2⁄ 0.06ReD
2 3⁄

+( )Pr0.4 μ
μ T( )
------------- 
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+ 
 =
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where Pr = μCp ⁄ k and ReD = ρUD ⁄ μ. The sphere diameter, D, and the exterior 
velocity, U, are correlation inputs. All material data are evaluated at Text except μ(T), 
which is evaluated at the wall temperature, T.

Heat Transfer Coefficients — Internal Forced Convection

I S O T H E R M A L  TU B E

Figure 4-30: Schematic representation of geometry and parameters for the averaged heat 
transfer coefficient correlation applied to forced convection in an isothermal circular tube.

This correlation corresponds to equations 8.55 and 8.61 in Ref. 18:

 (4-138)

where Pr = μCp ⁄ k, ReD = ρUextD ⁄ μ and n = 0.3 if T < Text and n = 0.4 if T ≥ Text. 
D (the tube diameter) and the velocity U are correlation inputs. All material data are 
evaluated at Text except μ(T), which is evaluated at the wall temperature, T.
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Equ i v a l e n t  T h e rma l  C ondu c t i v i t y  
C o r r e l a t i o n s

The Nusselt number Nu is the ratio of total heat flux to conductive heat flux. If the 
fluid flow is not solved, the heat equation can still use an equivalent conductivity to 
account for the convective heat flux in the conductive part. The conductivity is 
increased according to Nu to account for the contribution of the convective heat flux.

Correlations giving Nu from various material properties for two configurations of 
rectangular enclosures are described below. These correlations are based on the 
Rayleigh number

where ρ is the fluid density, g the gravitational acceleration, αp the coefficient of 
thermal expansion, Cp the heat capacity, μ the dynamic viscosity, k the thermal 
conductivity coefficient, ΔT the temperature difference through the cavity, and L the 
characteristic dimension of the cavity. The temperature difference through the cavity 
may be unknown a priori. In this case, ΔT can be defined using the Automatic option. 
The Automatic option defines a minimum and a maximum operator on the external 
boundaries of the domains where the correlation is used. As this option is designed for 
fluid domains where no heat source is defined, the difference between the maximum 
and the minimum of the temperature corresponds to the temperature difference 
through the cavity.

Horizontal Cavity With Bottom Heating

The following correlation corresponds to equation 9.49 in Ref. 18. It is validated for 
3⋅105 ≤ RaH ≤ 7⋅109:

 (4-139)

Fluid node

Ra
ρ2gαpCp

μk
------------------------ΔTL3=

Nu 0.069RaH
1 3/ Pr0.074=
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where RaH is computed from the height H of the cavity and the temperatures T1 and 
T2 of the bottom and top walls, and Pr = μCp ⁄ k. The material data are evaluated at 
(T1 + T2) ⁄ 2.

Vertical Cavity With Sidewall Heating

The following correlations correspond to equations 9.50, 9.51, and 9.52 in Ref. 18:

• If 1 ≤ H ⁄ L ≤ 2, , and :

 (4-140)

• If 2 ≤ H ⁄ L ≤ 10, Pr ≤ 105, and 103 ≤ RaL ≤ 1010:

 (4-141)

• If 10 ≤ H ⁄ L ≤ 40, 1 ≤ Pr ≤ 2 ⋅ 104, and 104 ≤ RaL ≤ 107:

 (4-142)

where H is the height of the cavity, L is the distance between the side plates, RaL is 
computed from L and the temperatures T1 and T2 of the side walls, and Pr = μCp ⁄ k. 
The material data are evaluated at (T1 + T2) ⁄ 2.

10 3– Pr 105≤ ≤ 103 PrRaL

0.2 Pr+
----------------------≤

Nu 0.18 Pr
0.2 Pr+
----------------------RaL 
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=

Nu 0.22 Pr
0.2 Pr+
----------------------RaL 
  0.28 H

L
----- 
  1 4⁄–

=

Nu 0.42RaL
1 4⁄ Pr0.012 H

L
----- 
  0.3–

=
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T empe r a t u r e  Dep end en c e  o f  S u r f a c e  
T en s i o n

The variation of the surface tension σ (SI unit: N/m) with temperature at fluid 
interfaces must be taken into account for the computation of phenomena such as 
Marangoni effect. These temperature dependencies are available in the form of a 
coefficient library for a set of liquid-gas interfaces. 

For a liquid water-air interface, the following quadratic relation is used:

where T (SI unit: K) is the temperature.

In other cases, a linear relation is used instead:

where T0 is a reference temperature taken at 0 °C (273.15 K) and the coefficients A 
(SI unit: N/(m·K)) and B (SI unit: N/m) are given in the following table for some 
liquid-gas interfaces:

More data can be found in Ref. 39 and Ref. 40.

TABLE 4-4:  COEFFICIENTS OF SURFACE TENSION

INTERFACE A B REFERENCE

Acetone - Air −1.120 ⋅ 10-4 2.626 ⋅ 10-2 Ref. 39

Acetic Acid - Air −0.994 ⋅ 10-4 2.958 ⋅ 10-2 Ref. 39

Ethanol - Air −0.832 ⋅ 10-4 2.405 ⋅ 10-2 Ref. 39

Toluene - Air −1.189 ⋅ 10-4 3.09 ⋅ 10-2 Ref. 39

Diethyl Ether - Air −0.908 ⋅ 10-4 1.892 ⋅ 10-2 Ref. 39

Glycerol - Air −0.885 ⋅ 10-4 6.517 ⋅ 10-2 Ref. 39

Heptane - Nitrogen −0.980 ⋅ 10-4 2.21 ⋅ 10-2 Ref. 40

Mercury - Mercury (Vapor) −2.049 ⋅ 10-4 49.06 ⋅ 10-2 Ref. 40

Ethylene Glycol - Ethylene 
Glycol (Vapor)

−0.890 ⋅ 10-4 5.021 ⋅ 10-2 Ref. 40

σ 2.3519705 10 7– T2 1.63350014 10 5– T 9.77001279 10 2–⋅+⋅–⋅–=

σ A T T0–( ) B+=
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Hea t  F l u x  and Hea t  Ba l a n c e

The concept of heat flux is not as simple as it first might seem. The reason is that heat 
is not a conserved quantity. Instead, the conserved quantity is the total energy. Hence, 
there is both a heat flux and an energy flux that are similar but not identical.

This section briefly describes the theory for the variables for Total Heat Flux and 
Energy Flux, used when computing Heat and Energy Balance. The definitions of these 
postprocessing variables do not affect the computational results, only variables 
available for results analysis and visualization.

In this section:

• Total Heat Flux and Energy Flux

• Heat and Energy Balance

Total Heat Flux and Energy Flux

TO T A L  H E A T  F L U X

The total heat flux vector is defined as (Ref. 5):

 (4-143)

where E is the internal energy. It is the sum of convective heat flux, ρuE, conductive 
heat flux, q, and radiative heat flux, qr. Hence, the total heat flux accounts for all 
three kinds of heat transfer described in The Physical Mechanisms under Heat 
Transfer. Recall that the internal energy is related to the enthalpy, H, via the following 
for a fluid (see Thermodynamic Description of Heat Transfer):

or the following for a solid:

The total heat flux vector, qtot, is more suited to check the heat balance as described 
in the next section Heat and Energy Balance.

qtot ρuE q qr+ +=

E H p
ρ
---–=

E H 1
ρ
---P:F+=
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TO T A L  E N E R G Y  F L U X

The total energy flux is equal to:

Again, convective heat flux, ρuE, conductive heat flux, q, and radiative heat flux, qr 
are accounted in the sum. The additional terms that complete the total energy flux are 
the convected kinetic energy, ρu(u ⋅ u ⁄ 2), force potential energy, ρuΨ, and stress, 
−σu. For a fluid, this expression becomes (Ref. 5, chapter 3.5):

Introducing the total internal energy, E0, and total enthalpy, H0:

leads to the following equivalent expression involving total enthalpy:

The potential Ψ has a simple form in some special cases — for example, for 
gravitational effects (Chapter 1.4 in Ref. 37) — but it is in general rather difficult to 
derive. Potential energy is therefore often excluded and the total energy flux is 
approximated by

 (4-144)

The total energy flux vector, etot, is more suited to check the energy balance as 
described in the next section Heat and Energy Balance.

Heat and Energy Balance

H E A T  B A L A N C E

This section assumes a heat transfer model that only solves for the temperature T. In 
particular, for a fluid, the velocity field u and pressure field p are user defined or 
computed from another physics interface. In this case, the heat balance in a domain 
follows the identity below (chapter 11.2 in Ref. 5), derived from Equation 4-11. It 
expresses the idea that internal energy variations in time and net heat flux are balanced 
by external heat and work sources.

etot ρu 1
2
---u u⋅ 
  ρu E Ψ+( ) q qr σu–+ + +=

etot ρu 1
2
---u u⋅ 
  ρu E Ψ+( ) q qr pI– τ+( )u–+ + +=

E0 E 1
2
---u u⋅+= H0 H 1

2
---u u⋅+=

etot ρu H0 Ψ+( ) q qr τu–+ +=

etot ρuE0 q qr σu–+ +=
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The different variables in this formula are defined in Total Heat Flux and Energy Flux. 
For this equality to be true, the provided dependent variables (velocity field u and 
pressure field p for the Navier-Stokes equations) must satisfy a mass and a momentum 
conservation equation. The dissipation power, Wstr, Int, contains both pressure work 
and viscous dissipation in fluids. The heat sources QInt include domain sources, 
interior boundary, edge and point sources, and radiative source at interior boundaries.

Equation 4-145 is more visually represented by the diagram of Figure 4-31 below.

Figure 4-31: A heat balance diagram.

Several predefined variables are available in COMSOL Multiphysics to describe the 
heat rates involved in the system heat balance. See Global Variables for their definition.

E N E R G Y  B A L A N C E

When the temperature T is solved together with additional mass and momentum 
equations, the total energy flux also becomes a conserved quantity and the following 
equation holds (chapter 11.1 in Ref. 5):

 (4-146)

td
d ρE vd

Ω
 qtot n sd⋅

Ωext∂
+ QInt Wstr Int,–=

In 2D and 3D components if isolated point or edge source is not adjacent 
to a boundary, these are not included in QInt. In this case, these need to 
be computed separately.

Mechanical Losses: Wstr

Heat source: Q

Accumulated heat: 
t∂

∂E

Net heat transfer: qtot ρuE q qr+ +=

td
d ρE0 vd

Ω
 etot n sd⋅

Ωext∂
+ QInt WInt+=
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The variables in this formula are defined in Total Heat Flux and Energy Flux. 
Equation 4-146 is more visually represented by the diagram of Figure 4-32 below.

Figure 4-32: An energy balance diagram.

Several predefined variables are available in COMSOL Multiphysics to describe the 
energy rates involved in the system energy balance. See Global Variables for their 
definition.

Heat source: Q

Work source: W

Accumulated energy: 
t∂

∂E0

 

Net energy transfer: etot ρuE0 q qr σu–+ +=
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F r ame s  f o r  t h e  Hea t  T r a n s f e r  
Equa t i o n s

In this section:

• Material and Spatial Frames

• Conversion Between Material and Spatial Frames

Material and Spatial Frames

The heat equation can be formulated either in a spatial coordinate system, with 
coordinate axes fixed in space, or in a material coordinate system, fixed to the material 
in its reference configuration and following the material as it deforms. COMSOL 
Multiphysics refers to these coordinate systems as the spatial frame and the material 
frame. In the case of immobile and undeformed materials, these two frames coincide.

U S E  O F  F R A M E S

The spatial frame is well adapted to simulate heat transfer in liquids and gases, where 
it is unreasonable to follow the state of individual material particles. The temperature 
is computed at fixed positions in space.

In solids, the material frame is more convenient. The temperature is computed at 
material particles uniquely identified by their position in some given reference 
configuration. It makes in particular the anisotropic material properties (thermal 
conductivity for example) independent of the current spatial orientation of the 
material.

In the heat transfer interfaces, the variables and equations are all defined on the spatial 
frame, and depending on the features, the user inputs may be defined on the material 
or spatial frame. Hence, they must be internally converted into the spatial frame if 
some deformation occurs.

PO S I T I O N  VE C T O R S  A N D  D E F O R M A T I O N  G R A D I E N T

The position vector in the physical space is identified by the lowercase symbol x and 
lowercase letters x, y, and z for each coordinate (or r, ϕ, and z in axisymmetric 
components). After a given transformation, the position of an elementary volume is 
modified in the spatial frame but not in the material frame. The position vector in the 
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this material frame is denoted by the uppercase symbol X and uppercase letters X, Y, 
and Z for each coordinate (or R, Φ, and Z in axisymmetric components).

The relation between x and X is carried by the deformation gradient:

  (4-147)

It relates elementary distances dx and dX in the domain, expressed in material and 
spatial frames, according to:

 (4-148)

The determinant of the deformation gradient, det(F), is the volume ratio field. In 
COMSOL Multiphysics, det(F) should always be strictly positive. Otherwise, the 
negative value is likely to be caused by an inverted mesh during the resolution of the 
model since it corresponds to a mathematical reflection operation.

The deformation gradient tensor and its determinant are essential in the conversion of 
physical quantities presented in the next paragraphs between material and spatial 
frames.

Note: In COMSOL Multiphysics, the variables spatial.F11, spatial.F12, …, 
store the coefficient of the transpose of the deformation gradient tensor F.

Conversion Between Material and Spatial Frames

This section explains how the user inputs are converted between material and spatial 
frames. The conversion depends on the dimension of the variables (scalars, vectors, or 
tensors) and on the density order.

F

X∂
∂x

Y∂
∂x

Z∂
∂x

X∂
∂y

Y∂
∂y

Z∂
∂y

X∂
∂z

Y∂
∂z

Z∂
∂z

=

dx FdX=

• About Frames in the COMSOL Multiphysics Reference Manual.

• Handling Frames in Heat Transfer
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As described in the previous paragraph Material and Spatial Frames, lowercase letters 
are used to denote the spatial frame coordinates while uppercase letters denote the 
material frame coordinates. In the followings, a physical quantity A will be referred to 
as A(x, y, z) in the spatial frame and to as A(X, Y, Z) in the material frame.

The equations solved by the heat transfer interfaces are written in the spatial frame. 
When an input is specified in the material frame, conversion is necessary to deduce 
A(x, y, z) from A(X, Y, Z).

D E N S I T Y ,  H E A T  S O U R C E ,  H E A T  F L U X

In heat transfer, the following variables are relative scalars of weight one (also called 
scalar densities):

• Mass density, ρ (SI unit: kg/m3),

• Heat source, Q0 (SI unit: W/m3),

• Production/absorption coefficient, qs (SI unit: W/(m3·K)),

• Heat flux, q0 (SI unit: W/m2),

• Heat transfer coefficient, h (SI unit: W/(m2·K)).

For all these variables, the conversion between material and spatial frame follows the 
relation:

This way, the integral of volumetric quantities over the domain, such as the mass 
density, is invariant between frames:

In these equalities, Ω0 and Ω denote the same domain but represented in material or 
in spatial frame, respectively. As expected, the same mass is found by integrating 
ρ(X, Y, Z) over the domain in the material frame or by integrating ρ(x, y, z) over the 
domain in the spatial frame. The same invariance principle applies to quantities per unit 
area, in particular heat flux and heat transfer coefficient:

Here, ∂Ω0 and ∂Ω are the boundaries of the same domain in material and spatial 
frames, respectively.

A x y z, ,( )
A X Y Z, ,( )
det F( )

----------------------=

ρ X Y Z, ,( ) τ0d
Ω0
 ρ x y z, ,( )det F( ) τ0d

Ω0
 ρ x y z, ,( ) τd

Ω
= =

h X Y Z, ,( ) s0d
∂Ω0
 h x y z, ,( )det F( ) s0d

∂Ω0
 h x y z, ,( ) sd

∂Ω
= =
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VE L O C I T Y

The relationship between the velocity vectors in material and spatial frames, u(X, Y, Z) 
and u(x, y, z), is

This is directly deduced from the differential relation of Equation 4-148.

T H E R M A L  C O N D U C T I V I T Y

Thermal conductivity, k, is a tensor density. The relationship between the value on the 
spatial frame and the material frame is:

With this relation, and recalling that

the total conductive heat flux through a boundary, computed in both frames according 
to the integrals below, gives the same result:

Here, ∂Ω0 and ∂Ω are the boundaries of the same domain in material and spatial 
frames, respectively.

T H E R M A L  C O N D U C T I V I T Y  O F  A  L A Y E R

The same transformations are applied to thermal conductivity but with different 
transformation matrices. The deformation gradient tensor depends on the layer type:

• When the layer is resistive, the deformation gradient tensor Fxdim is equal to the 
deformation gradient tensor F defined in Equation 4-147.

• When the layer is conductive, the deformation gradient tensor Ft is defined using 
tangential derivatives as follows:

u x y z, ,( ) Fu X Y Z, ,( )=

k x y z, ,( )
1

det F( )
-------------------Fk X Y Z, ,( )F

T
=

n X Y Z, ,( ) FTn x y z, ,( )=

∇ X Y Z, ,( )T FT∇ x y z, ,( )T=

k X Y Z, ,( )∇ X Y Z, ,( )T– n X Y Z, ,( )⋅ s0d
∂Ω0
 k x y z, ,( )∇ x y z, ,( )T– n x yz,( )⋅ sd

∂Ω
=
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where xTX corresponds to the tangential derivative x with respect to X, and so on.

• When the layer is an extra dimension, the deformation gradient tensor Fxdim is 
defined as follows:

where xTX corresponds to the tangential derivative x with respect to X, and so on. 
The (nx, ny, nz) vector corresponds to the normal vector in the spatial frame, and 
the (nX, nY, nZ) vector corresponds to the normal vector in the material frame.

T I M E  D E R I V A T I V E

Partial differential equations often involve time derivative of a physical quantity such 
as temperature or internal energy in heat transfer. The variations of such state variables 
during an elementary time step are studied for a same elementary volume that could 
be subjected to spatial transformations. The material derivative, denoted d ⁄ dt, is the 
derivation operator used in such cases. The following relation defines the material 
derivative in the spatial frame.

The right-hand side of this relation shows a new term u ⋅ ∇ corresponding to 
convection in the case of fluids, or convected quantity by translational motion of a 
solid.

Ft

xTX xTY xTZ

yTX yTY yTZ

zTX zTY zTZ

=

Fxdim

xTX nxnX+

yTX nynX+

zTX nznX+

xTY nxnY+

yTY nynY+

zTY nznY+

xTZ nxnZ+

yTZ nynZ+

zTZ nznZ+

=

td
d

t∂
∂ u x y z, ,( ) ∇ x y z, ,( )⋅+=

• About Frames in the COMSOL Multiphysics Reference Manual.

• Handling Frames in Heat Transfer
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 5
T h e  H e a t  T r a n s f e r  M o d u l e  I n t e r f a c e s
The Heat Transfer Module includes five physics interfaces used to compute the 
temperature field, the radiative intensity field, or the relative humidity field:

TABLE 5-1:  THE HEAT TRANSFER MODULE INTERFACES

INTERFACE TAG VERSIONS

Heat Transfer ht Heat Transfer

Heat Transfer in Solids

Heat Transfer in Fluids

Bioheat Transfer

Heat Transfer in Porous Media

Heat Transfer in Building Materials

Heat Transfer in Moist Air

Heat Transfer with Surface-to-Surface Radiation

Heat Transfer with Radiation in Participating 
Media

Heat Transfer in Thin 
Structures

htsh Heat Transfer in Thin Shells

Heat Transfer in Thin Films

Heat Transfer in Fractures
 271



272 |  C H A P T E
See also The Heat Transfer in Pipes Interface (htp) in the Pipe Flow Module User’s 
Guide.

In this chapter:

• About the Heat Transfer Interfaces

• The Heat Transfer in Solids Interface

• The Heat Transfer in Fluids Interface

• The Heat Transfer Interface

• The Heat Transfer in Porous Media Interface

• The Heat Transfer in Building Materials Interface

• The Heat Transfer in Moist Air Interface

• The Bioheat Transfer Interface

• The Heat Transfer with Surface-to-Surface Radiation Interface

• The Heat Transfer with Radiation in Participating Media Interface

• The Heat Transfer in Thin Shells Interface

• The Heat Transfer in Thin Films Interface

• The Heat Transfer in Fractures Interface

• The Surface-To-Surface Radiation Interface

• The Radiation in Participating Media Interface

• The Moisture Transport in Building Materials Interface

• The Moisture Transport in Air Interface

See also the Multiphysics Interfaces.

Surface-to-Surface 
Radiation

rad Surface-to-Surface Radiation

Radiation in 
Participating Media

rpm Radiation in Participating Media

Moisture Transport mt Moisture Transport in Air

Moisture Transport in Building Materials

TABLE 5-1:  THE HEAT TRANSFER MODULE INTERFACES

INTERFACE TAG VERSIONS
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The Heat Transfer Module includes the following interfaces:

• Heat Transfer (with several versions)

• Heat Transfer in Thin Structures (with several versions)

• Surface-to-Surface Radiation

• Radiation in Participating Media

• Moisture Transport (with several versions)

They are used to compute the temperature field, the radiative intensity field, and the 
relative humidity field. 

The multiphysics interfaces also compute other physical fields like velocity, pressure, or 
electromagnetic fields, depending on the available COMSOL products. See 
Multiphysics Interfaces.

The main dependent variable is the temperature, T.

The various kinds of Heat Transfer interfaces and the thermal multiphysics couplings 
can be used for modeling heat transfer by conduction, convection, or radiation, as well 
as conjugate heat transfer, evaporation, and electromagnetic heating.

Space Dimensions

The physics interfaces are available in 1D, 2D, and 3D and for axisymmetric 
components with cylindrical coordinates in 1D and 2D.

All the interfaces except Heat Transfer in Thin Structures apply in domains, with 
features available at each geometric level (volumes, surfaces, edges, and points).

Study Types

Stationary, time-dependent, and frequency domain studies are available with the Heat 
Transfer interfaces.

You can consider a heat transfer problem as stationary if the temperature field is 
independent of time at each point. The system is said to be at thermal equilibrium. It 
happens when the conditions are independent of time or vary on a time scale large 
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enough so that they can be approximated as constant. This type of study can be used 
as an initial step for a time-dependent analysis.

For other cases, use a time-dependent or a frequency domain study.

Versions of the Heat Transfer Physics Interface

The versions of the Heat Transfer physics interface (ht) are:

• The Heat Transfer in Solids Interface

• The Heat Transfer in Fluids Interface

• The Heat Transfer Interface

• The Bioheat Transfer Interface

• The Heat Transfer in Porous Media Interface

• The Heat Transfer in Building Materials Interface

• The Heat Transfer with Surface-to-Surface Radiation Interface

• The Heat Transfer with Radiation in Participating Media Interface

After selecting a version, default nodes are added under the main node, which then 
defines which version of the Heat Transfer interface is added. Depending on the 
version of the physics interface selected, the default nodes vary. For example:

• If Heat Transfer in Solids ( ) is selected, a Heat Transfer in Solids (ht) interface is 
added with a default Solid model.

• If Heat Transfer in Fluids ( ) is selected, a Heat Transfer in Fluids (ht) interface is 
added with a default Fluid model.

• The Heat Transfer (ht) interface is automatically added when a multiphysics interface 
under the Conjugate Heat Transfer branch is added. It contains two default models: 
Solid (enabled by default) and Fluid (empty selection by default).

Benefits of the Different Heat Transfer Interfaces

The benefit of the different versions of the Heat Transfer interface, with ht as the 
common default name (see Heat Transfer Variables), is that it is easy to add the default 

Study and Study Step Types in the COMSOL Multiphysics Reference 
Manual
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settings when selecting the physics interface. At any time, add a Fluid or Solid node from 
the Physics toolbar — the functionality is always available.  

Also see The Heat Transfer in Pipes Interface in the Pipe Flow Module User’s Guide 
for simulating heat transfer in pipe networks, including wall heat transfer to the 
surroundings.

Depending on the available COMSOL products, physics interface options 
are also available from a Heat Transfer interface by selecting a specific 
check box under the Physical Model section (for surface-to-surface 
radiation, biological tissue, radiation in participating media, porous 
media, or isothermal domain). See Table 5-2 and Table 5-4 for a 
description of the interface options.

TABLE 5-2:  THE HEAT TRANSFER (HT) INTERFACE OPTIONS

ICON NAME DEFAULT PHYSICAL MODEL

Heat Transfer in Solids No check box is selected.

Heat Transfer in Fluids No check box is selected.

Heat Transfer with 
Surface-to-Surface 
Radiation (under the 
Radiation branch)

The Surface-to-surface radiation check box is 
selected (which enables the Radiation Settings 
section).

Heat Transfer with 
Radiation in Participating 
Media (under the 
Radiation branch)

The Radiation in participating media check box is 
selected (which enables the Participating Media 
Settings section).

Bioheat Transfer The Heat transfer in biological tissue check box is 
selected (which enables the Damage Integral 
Analysis Discretization section).

Heat Transfer in Porous 
Media

The Heat Transfer in Porous Media check box is 
selected (which enables the Porous matrix model 
list).

Heat Transfer in Building 
Materials

The Heat Transfer in Porous Media check box is 
selected (which enables the Porous matrix model 
list).

Heat Transfer No check box is selected.
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Versions of the Heat Transfer in Thin Structures Physics Interface

The versions of the Heat Transfer in Thin Structures physics interface (htsh) are:

• The Heat Transfer in Thin Shells Interface

• The Heat Transfer in Thin Films Interface

• The Heat Transfer in Fractures Interface

After selecting a version, default nodes are added under the main node, which then 
defines which version of the Heat Transfer in Thin Structures interface is added. 
Depending on the version of the physics interface selected, the default nodes vary:

• If Heat Transfer in Thin Shells ( ) is selected, a Heat Transfer in Thin Shells (htsh) 

interface is added with a default Thin Conductive Layer model.

• If Heat Transfer in Thin Films ( ) is selected, a Heat Transfer in Thin Films (htsh) 

interface is added with a default Thin Film model.

• If Heat Transfer in Fractures ( ) is selected, a Heat Transfer in Fractures (htsh) 

interface is added with a default Fracture model.

Benefits of the Different Heat Transfer in Thin Structures Interfaces

The benefit of the different versions of the Heat Transfer in Thin Structures interface, 
with htsh as the common default name (see Heat Transfer Variables), is that it is easy 
to add the default settings when selecting the physics interface. At any time, add a Thin 

Conductive Layer node from the Physics toolbar — the functionality is always available. 

Depending on the available COMSOL products, physics interface options 
are also available from a Heat Transfer in Thin Structures interface by 
selecting a specific check box under the Physical Model section (for 
surface-to-surface radiation and porous media). See Table 5-3 and 
Table 5-4 for a description of the interface options.

TABLE 5-3:  THE HEAT TRANSFER IN THIN STRUCTURES (HTSH) INTERFACE OPTIONS

ICON NAME DEFAULT PHYSICAL MODEL

Heat Transfer in Thin 
Shells

No check box is selected.
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Versions of the Moisture Transport Physics Interface

The versions of the Moisture Transport physics interface (mt) are:

• The Moisture Transport in Building Materials Interface

• The Moisture Transport in Air Interface

After selecting a version, default nodes are added under the main node, which then 
defines which version of the Moisture Transport interface is added. Depending on the 
version of the physics interface selected, the default nodes vary:

• If Moisture Transport in Building Materials ( ) is selected, a Moisture Transport in 

Building Materials (mt) interface is added with a default Building Material model.

• If Moisture Transport in Air ( ) is selected, a Moisture Transport in Air (mt) interface 
is added with a default Moist Air model.

Benefits of the Different Moisture Transport Interfaces

The benefit of the different versions of the Moisture Transport interface, with mt as 
the common default name (see Moisture Transport Variables), is that it is easy to add 
the default settings when selecting the physics interface. At any time, add a Building 

Material or a Moist Air node from the Physics toolbar — the functionality is always 
available.

Heat Transfer in Thin 
Films

No check box is selected.

Heat Transfer in Fractures The Heat Transfer in Porous Media check box is 
selected.

TABLE 5-3:  THE HEAT TRANSFER IN THIN STRUCTURES (HTSH) INTERFACE OPTIONS

ICON NAME DEFAULT PHYSICAL MODEL
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Additional physics options

Then, additional physics options are provided with the other interfaces and 
multiphysics interfaces:

More turbulent flow interfaces are available under the Conjugate Heat Transfer branch 
with the CFD Module:

• Turbulent Flow, Algebraic yPlus

• Turbulent Flow, L-VEL

• Turbulent Flow, k-ω

• Turbulent Flow, SST

• Turbulent Flow, Spalart-Allmaras

See The Conjugate Heat Transfer, Laminar Flow and Turbulent Flow Interfaces in the 
CFD Module User’s Guide for more details.

TABLE 5-4:  ADDITIONAL HEAT TRANSFER PHYSICS OPTIONS

ICON NAME ID DEFAULT PHYSICAL MODEL 

Laminar Flow (under the 
Conjugate Heat Transfer 
branch)

— See Table 5-2.

Turbulent Flow k-ε and 
Turbulent Flow, Low Re 
k-ε (under the Conjugate 
Heat Transfer branch)

— See Table 5-2.

Thermoelectric Effect — No check boxes are selected under 
Physical Model.

Surface-to-Surface 
Radiation (under the 
Radiation branch)

rad No Physical Model section, but the 
Radiation Settings section is automatically 
available by default.

Radiation in Participating 
Media (under the 
Radiation branch)

rpm No Physical Model section, but the 
Participating Media Settings section is 
automatically available by default.

Joule Heating (under the 
Electromagnetic Heating 
branch)

— No check boxes are selected under 
Physical Model.

 Local Thermal 
Non-Equilibrium

— See Table 5-2.

Heat and Moisture — See Table 5-2.
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More interfaces are available under the Electromagnetic Heating branch with ACDC, 
WaveOptics, and RF Modules. 

See The Laser Heating Interface in the Wave Optics Module User’s Guide, The 
Induction Heating Interface in the AC/DC Module User’s Guide, and The 
Microwave Heating Interface in the RF Module User’s Guide for more details.

Settings for the Heat Transfer Interface

The Label is the default physics interface name. 

The Name is used primarily as a scope prefix for variables defined by the physics 
interface. Refer to such physics interface variables in expressions using the pattern 
<name>.<variable_name>. In order to distinguish between variables belonging to 
different physics interfaces, the name string must be unique. Only letters, numbers, and 
underscores (_) are permitted in the Name field. The first character must be a letter.

The default Name (for the first physics interface in the model) is ht.

P H Y S I C A L  M O D E L

In 2D and 1D axisymmetric components, set the Thickness dz, which is the thickness 
of the domain in the out-of-plane direction. The default value is 1 m.

In 1D components, set the Cross sectional area Ac and the Cross sectional perimeter Pc 
of the domain. Default values are 1 m2 and 1 m, respectively.

Some check boxes are also present in this section with certain COMSOL products.

Click to select any of the following check boxes to activate the versions of the ht 
interface as described in Benefits of the Different Heat Transfer Interfaces:

• Select the Surface-to-surface radiation check box to enable surface-to-surface 
radiation features as described in The Heat Transfer with Surface-to-Surface 
Radiation Interface.

• Select the Radiation in participating media check box to enable radiation in 
participating media features. See The Heat Transfer with Radiation in Participating 
Media Interface.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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• Select the Heat transfer in biological tissue check box to enable the Biological Tissue 
feature.

• Selecting Isothermal domain provides support for isothermal domain modeling. See 
Isothermal Domain Interface and Isothermal Domain.

• Select the Heat Transfer in Porous Media check box to enable the Porous Medium, 
Fracture, and Building Material features. See The Heat Transfer in Porous Media 
Interface and The Heat Transfer in Building Materials Interface.

A M B I E N T  S E T T I N G S

In this section, you can define ambient variables to be available as inputs from several 
features: the temperature Tamb, the absolute pressure pamb, the relative humidity 
φamb, the wind velocity vamb, and the direct and diffuse solar irradiances Isn,amb and 
Ish,amb. 

Two options are available for the definition of the Ambient data:

• When User defined (the default) is selected, the Ambient temperature Tamb, the 
Ambient absolute pressure pamb, the Ambient relative humidity φamb, the Wind 

velocity vamb, the Clear sky noon beam normal irradiance Isn,amb, and the Clear sky 

noon diffuse horizontal irradiance Ish,amb should be specified directly.

• When Meteorological data (ASHRAE 2013) is selected, the ambient variables are 
computed from monthly and hourly averaged measurements, made over several 
years at weather stations worldwide. See Using Ambient Data for more information. 
Further settings for the choice of the location, time, and ambient conditions are 
needed; and additional input fields are displayed underneath.

See Heat Flux, Diffuse Surface, Temperature, Initial Values, or External 
Radiation Source for examples of features of the Heat Transfer interface 
that have ambient variables available as inputs.

See Initial Values, Moisture Content, or Moisture Flux for examples of 
features of the Moisture Transport interface that have ambient variables 
available as inputs.
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Location
In this section you can set the location by choosing among more than 6000 weather 
stations worldwide. Two options are available for the selection of the Weather station:

• When From list is selected, additional lists display underneath for the selection of a 
Region, a Country, and a Station. The Country list is refreshed for each selection in the 
Region list, and the Station list is refreshed for each selection in the Country list.

• It is also possible to select a station From reference by entering the corresponding 
World Meteorological Organization reference, which is a 6-digit number.

Time
The Date and Local time should be set by entering values or expressions in the Day, 
Month, Hour, Minute, and Second fields of the two tables. 

If the Specify year check box is selected, a value or expression for the Year should also 
be set. As the data are given as averages over several past years, this input is only used 
for the detection of leap years, in order to interpolate the data over the months.

For temporal studies, these inputs define the starting time of the simulation. By 
default, the Update time from solver check box is selected, and the time is then 
automatically updated with the time from the solver to evaluate the variables by 
interpolation of the measured data. Unselect this check box to manually set the time 
update.

A single country may be available for more than one region selection if it 
has stations spread over different regions. For example, United States of 
America is available in the Country list when either North America, 
Eurasia, or Oceania is selected in the Region list.

When a station is selected From list, its World Meteorological 
Organization (WMO) reference is displayed below the Station list. The 
WMO references can also be retrieved from maps offered by third parties 
like the one available as of this product release on 
http://ashrae-meteo.info/.

See Ambient Data Interpolation for more information about the 
interpolation of data over months and hours.

See Processing of ASHRAE Data for more information about the data.
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Ambient conditions
Based on the measured data, several conditions are available for the Temperature, the 
Dew point temperature, and the Wind speed. The formula for each condition is recalled 
in Table 5-5, Table 5-6, and Table 5-7. The Average conditions correspond to 
weighted means of the measured data, whereas the other conditions are obtained by 
applying standard or modified deviations (Low, High, and User defined coefficient for 

deviation conditions), user defined corrections, or wind correlations to the average 
conditions; or by taking the minimum or maximum of the measured data (Lowest and 
Highest conditions). More information about these definitions can be found in 
Ambient Variables and Conditions.

A time unit suitable for simulations over a day or a year may be set in the 
Study Settings section of the Time Dependent node, by using for example 
h for hour, d for day, or a for a year. See Using Units in the COMSOL 
Multiphysics Reference Manual for more details.

TABLE 5-5:  TEMPERATURE CONDITIONS

CONDITION DEFINITION

Average

Low

High

Lowest

Highest

User defined coefficient for deviation

User defined correction

Heating wind correlation(1)

Cooling wind correlation(1)

(1)These correlations are not related to the wind speed conditions described in 
Table 5-7.

TABLE 5-6:  DEW POINT TEMPERATURE CONDITIONS

CONDITION DEFINITION

Average

Low

High

Lowest

Highest

Tamb Tstation =

Tamb Tstation  σT station,–=

Tamb Tstation  σT station,+=

Tamb min Tstation( )=

Tamb max Tstation( )=

Tamb Tstation  cσ σ⋅ T station,+=

Tamb Tstation  ΔT+=

Tamb Tstation  ΔTwind+=

Tamb Tstation  ΔTwind–=

DPTamb DPTstation =

DPTamb DPTstation  σDPT station,–=

DPTamb DPTstation  σDPT station,+=

DPTamb min DPTstation( )=

DPTamb max DPTstation( )=
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C O N S I S T E N T  S T A B I L I Z A T I O N

The Streamline diffusion check box is selected by default and should remain selected for 
optimal performance for heat transfer in fluids or other applications that include a 
convective or translational term. Crosswind diffusion provides extra diffusion in regions 

TABLE 5-7:  WIND SPEED CONDITIONS

CONDITION DEFINITION

Average

Low

High

Lowest

Highest

vamb vstation =

vamb vstation  σv station,–=

vamb vstation  σv station,+=

vamb min vstation( )=

vamb max vstation( )=

The conditions set for Temperature and Dew point temperature should be 
consistent in order to keep the temperature larger than the dew point 
temperature. However, all settings combinations are available, and the 
relative humidity is majored by 1 when necessary.

The sum of the Clear sky noon beam normal irradiance and the Clear sky 

noon diffuse horizontal irradiance is available through the post-processing 
variable ht.Is_amb, defined as the Ambient solar irradiance.

For an example of the use of user-defined ambient data, see:

Temperature Field in a Cooling Flange: Application Library path 
Heat_Transfer_Module/Thermal_Processing/cooling_flange

For an example of the use of meteorological ambient data, see:

Condensation Detection in an Electronic Device with Transport and 
Diffusion: Application Library path 
Heat_Transfer_Module/Power_Electronics_and_Electronic_Cooling/condensati

on_electronic_device_transport_diffusion

Condensation Detection in an Electronic Device: Application Library 
path 
Heat_Transfer_Module/Power_Electronics_and_Electronic_Cooling/condensati

on_electronic_device
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with sharp gradients. The added diffusion is orthogonal to the streamlines, so 
streamline diffusion and crosswind diffusion can be used simultaneously. The 
Crosswind diffusion check box is also selected by default.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

The Isotropic diffusion check box is not selected by default. 

A D V A N C E D  S E T T I N G S

Add both a Heat Transfer (ht) and a Moving Mesh (ale) interface (found under the 
Mathematics>Deformed Mesh branch when adding a physics interface) then click the 
Show button ( ) and select Advanced Physics Options to display this section.

When the component contains a moving mesh, the Enable conversions between material 

and spatial frame check box is selected by default. This option has no effect when the 
component does not contain a moving frame because the material and spatial frames 
are identical in such cases. With a moving mesh, and when this option is active, the 
heat transfer features automatically account for deformation effects on heat transfer 
properties. In particular the effects of volume changes on the density are considered. 
Rotation effects on the thermal conductivity of an anisotropic material and, more 
generally, deformation effects on an arbitrary thermal conductivity, are also covered. 
When the Enable conversions between material and spatial frame check box is not 
selected, the feature inputs (for example, Heat Source, Heat Flux, Boundary Heat 
Source, and Line Heat Source) are not converted and are instead defined on the Spatial 
frame.

D I S C R E T I Z A T I O N

To display this section, click the Show button ( ) and select Discretization.

In the Heat Transfer interfaces you can choose not only the order of the discretization, 
but also the type of shape functions: Lagrange or serendipity. For highly distorted 
elements, Lagrange shape functions provide better accuracy than serendipity shape 
functions of the same order. The serendipity shape functions will however give 
significant reductions of the model size for a given mesh containing hexahedral, prism, 
or quadrilateral elements. At first order, Lagrange and serendipity shape functions are 
the same.

Heat Transfer Consistent and Inconsistent Stabilization Methods
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The default shape functions used for the temperature are Quadratic Lagrange for the 
modeling of heat transfer in solids, and Linear for the modeling of heat transfer in 
fluids. See the description of each version of the physics interface for more details.

D E P E N D E N T  V A R I A B L E S

The Heat Transfer interfaces have the dependent variable Temperature T. The 
dependent variable names can be changed. Editing the name of a scalar dependent 
variable changes both its field name and the dependent variable name. If a new field 
name coincides with the name of another field of the same type, the fields share degrees 
of freedom and dependent variable names. A new field name must not coincide with 
the name of a field of another type or with a component name belonging to some other 
field. 

Settings for the Heat Transfer in Thin Structures Interface

The Label is the default physics interface name. 

The Name is used primarily as a scope prefix for variables defined by the physics 
interface. Refer to such physics interface variables in expressions using the pattern 
<name>.<variable_name>. In order to distinguish between variables belonging to 
different physics interfaces, the name string must be unique. Only letters, numbers, and 
underscores (_) are permitted in the Name field. The first character must be a letter.

The default Name (for the first physics interface in the model) is htsh.

S H E L L  T H I C K N E S S

Define the Shell thickness ds (SI unit: m) (see Equation 4-50). The default is 0.01 m.

O U T - O F - P L A N E  T H I C K N E S S

For 2D components, define the Out-of-plane thickness dz (SI unit: m) (see 
Equation 4-50). The default is 1 m.

P H Y S I C A L  M O D E L

Some check boxes are present in this section with certain COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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Click to select any of the following check boxes to activate related features:

• Select the Surface-to-surface radiation check box to add a Radiation Settings section. 
By selecting this check box you can also add an Opacity node.

• Select the Heat Transfer in Porous Media check box to enable the Fracture feature for 
the modeling of porous media. This check box is selected by default in The Heat 
Transfer in Fractures Interface.

A M B I E N T  S E T T I N G S

The settings are the same as for the Heat Transfer interface. See Ambient Settings for 
details.

R A D I A T I O N  S E T T I N G S

To display this section for any version of the Heat Transfer in Thin Structures interface, 
select the Surface-to-surface radiation check box under the Physical Model section.

Define the Wavelength dependence of emissivity.

• Keep the default value, Constant, to define a diffuse gray radiation model. In this 
case, the surface emissivity has the same definition for all wavelengths. The surface 
emissivity can still depend on other quantities, in particular on the temperature.

• For Solar and ambient define a diffuse spectral radiation model with two spectral 
bands, one for short wavelengths, [0, λ1], (solar radiation) and one for large 
wavelengths, [λ1, +∞[, (ambient radiation). It is then possible to define the Intervals 

endpoint (SI unit: m), λ1, to adjust the wavelength intervals corresponding to the 
solar and ambient radiation. The surface properties can then be defined for each 
spectral band. In particular it is possible to define the solar absorptivity for short 
wavelengths and the surface emissivity for large wavelengths.

• For Multiple spectral bands set the Number of wavelength bands value (2 to 5), to 
define a diffuse spectral radiation model. It is then possible to provide a definition 
of the surface emissivity for each spectral band. Update Intervals endpoint (SI unit: 
m), λ1, λ2, ..., to define the wavelength intervals [λi − 1, λi[ for i from 1 to the 
Number of wavelength bands. Note that the first and the last endpoints, λ0 and λN 

See The Heat Transfer with Surface-to-Surface Radiation Interface for 
details about the Surface-to-surface radiation method and Radiation 

resolution settings.
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(with N equal to the value selected to define the Number of wavelength bands), are 
predefined and equal to 0 and +∞ respectively.

Modify the Transparent media refractive index if it is different from 1 that corresponds 
to vacuum refractive index and that is usually a good approximation for air refractive 
index.

Also select the Use radiation groups check box to enable the ability of defining radiation 
groups, which can, in many cases, speed up the radiation calculations.

Select the Surface-to-surface radiation method: Hemicube (the default) or Direct area 

integration. See below for descriptions of each method.

• For Direct area integration select the Radiation integration order. Sharp angles and 
small gaps between surfaces can require a higher integration order for more accuracy 
but also more computational cost to evaluate the irradiation.

• For Hemicube select the Radiation resolution — 256 is the default.

Select Linear (the default), Quadratic, Cubic, Quartic, or Quintic to define the 
Discretization level used for the surface radiosity shape function.

C O N S I S T E N T  S T A B I L I Z A T I O N

The Streamline diffusion check box is selected by default and should remain selected for 
optimal performance for heat transfer in fluids or other applications that include a 
convective or translational term. Crosswind diffusion provides extra diffusion in regions 
with sharp gradients. The added diffusion is orthogonal to the streamlines, so 
streamline diffusion and crosswind diffusion can be used simultaneously. The 
Crosswind diffusion check box is also selected by default.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

The Isotropic diffusion check box is not selected by default. 

A D V A N C E D  S E T T I N G S

Add both a Heat Transfer in Thin Shells (htsh) and a Moving Mesh (ale) interface (found 
under the Mathematics>Deformed Mesh branch when adding a physics interface) then 
click the Show button ( ) and select Advanced Physics Options to display this section.

Heat Transfer Consistent and Inconsistent Stabilization Methods
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When the component contains a moving mesh, the Enable conversions between material 

and spatial frame check box is selected by default. This option has no effect when the 
component does not contain a moving frame because the material and spatial frames 
are identical in such cases. With a moving mesh, and when this option is active, the 
heat transfer features automatically account for deformation effects on heat transfer 
properties. In particular the effects of volume changes on the density are considered. 
Rotation effects on the thermal conductivity of an anisotropic material and, more 
generally, deformation effects on an arbitrary thermal conductivity, are also covered. 
When the Enable conversions between material and spatial frame check box is not 
selected, the feature inputs (for example, Heat Source (Heat Transfer in Thin Shells 
Interface) and Heat Flux (Heat Transfer in Thin Shells Interface)) are not converted 
and are instead defined on the Spatial frame.

D I S C R E T I Z A T I O N

To display this section, click the Show button ( ) and select Discretization.

In the Heat Transfer in Thin Structures interfaces you can choose not only the order 
of the discretization, but also the type of shape functions: Lagrange or serendipity. 
For highly distorted elements, Lagrange shape functions provide better accuracy than 
serendipity shape functions of the same order. The serendipity shape functions will 
however give significant reductions of the model size for a given mesh containing 
hexahedral, prism, or quadrilateral elements.

The shape functions used for the temperature are Quadratic Lagrange for the modeling 
of heat transfer in thin shells, and Linear for the modeling of heat transfer in thin films 
and heat transfer in fractures.

D E P E N D E N T  V A R I A B L E S

The Heat Transfer in Thin Structures interfaces have the dependent variable 
Temperature T. The dependent variable names can be changed. Editing the name of a 
scalar dependent variable changes both its field name and the dependent variable 
name. If a new field name coincides with the name of another field of the same type, 
the fields share degrees of freedom and dependent variable names. A new field name 
must not coincide with the name of a field of another type or with a component name 
belonging to some other field.
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Th e  Hea t  T r a n s f e r  i n  S o l i d s  I n t e r f a c e

The Heat Transfer in Solids ( ) interface is used to model heat transfer in solids by 
conduction, convection, and radiation. A Solid model is active by default on all 
domains. All functionality for including other domain types, such as a fluid domain, is 
also available.

The temperature equation defined in solid domains corresponds to the differential 
form of the Fourier’s law that may contain additional contributions like heat sources.

When this version of the physics interface is added, these default nodes are added to 
the Model Builder: Solid, Thermal Insulation (the default boundary condition), and Initial 

Values. Then, from the Physics toolbar, add other nodes that implement, for example, 
boundary conditions and sources. You can also right-click Heat Transfer is Solids to 
select physics features from the context menu.

P H Y S I C A L  M O D E L

By default, no check boxes are selected under the Physical Model section.

A M B I E N T  S E T T I N G S

See Ambient Settings for details.

C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Consistent Stabilization for more details.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Inconsistent Stabilization for more details.

D I S C R E T I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Discretization. 
By default, the shape functions used for the temperature are Quadratic Lagrange. See 
Discretization for more details.
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D E P E N D E N T  V A R I A B L E S

See Dependent Variables for details.

Feature Nodes for the Heat Transfer in Solids Interface

This section details the nodes available with The Heat Transfer in Solids Interface with 
default settings:

• Domain Nodes for the Heat Transfer in Solids Interface

• Boundary Nodes for the Heat Transfer in Solids Interface

• Edge Nodes for the Heat Transfer in Solids Interface

• Point Nodes for the Heat Transfer in Solids Interface

See Settings for the Heat Transfer Interface for a description of all the 
settings.

In the COMSOL Multiphysics Reference Manual see Table 2-3 for links 
to common sections and Table 2-4 to common feature nodes. You can 
also search for information: press F1 to open the Help window or Ctrl+F1 
to open the Documentation window.

• Handling Frames in Heat Transfer

• Feature Nodes for the Heat Transfer in Solids Interface

• Theory for Heat Transfer in Solids

Some nodes are only available with some COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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The Heat Transfer in Solids Interface has the following domain nodes:

When the Isothermal domain check box is selected in the Physical Model section, the 
Isothermal Domain node is also available from the context menu or the Physics toolbar 
Domains menu.

B O U N D A R Y  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  S O L I D S  I N T E R F A C E

The Heat Transfer in Solids Interface has the following boundary nodes:

When the Isothermal domain check box is selected in the Physical Model section, the 
Isothermal Domain Interface node is added by default and is also available from the 
context menu or the Physics toolbar Boundaries menu.

• Change Cross Section

• Change Thickness

• Fluid

• Heat Source

• Initial Values

• Out-of-Plane Heat Flux 

• Out-of-Plane Radiation

• Phase Change Material

• Pressure Work

• Solid

• Irreversible Transformation

• Thermoelastic Damping

• Translational Motion

• Viscous Dissipation

• Boundary Heat Source

• Continuity

• Deposited Beam Power

• External Temperature (Thin Layer, 
Thin Film)

• Heat Flux

• Heat Source (Thin Film)

• Inflow Heat Flux

• Layer Heat Source

• Line Heat Source on Axis

• Open Boundary

• Outflow

• Periodic Condition

• Symmetry

• Temperature

• Thermal Contact

• Thermal Insulation

• Thin Film

• Thin Layer
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E D G E  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  S O L I D S  I N T E R F A C E

The Heat Transfer in Solids Interface has the following edge nodes (3D components 
only):

PO I N T  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  S O L I D S  I N T E R F A C E

The Heat Transfer in Solids Interface has the following point nodes:

More nodes are available with more advanced settings. For the complete list of nodes 
available see Domain Features, Boundary Features, Edge Features, Point Features, and 
Global Features.

• Line Heat Source (Thin Rod)

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Thin Rod

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source 

• Point Heat Flux (Thin Rod)

• Point Heat Source

• Point Heat Source on Axis

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Surface-to-Ambient Radiation (Thin 
Rod)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Temperature (Thin Rod)

Select the Isothermal domain check box to make the Isothermal Domain 
and Isothermal Domain Interface nodes available.
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Th e  Hea t  T r a n s f e r  i n  F l u i d s  I n t e r f a c e

The Heat Transfer in Fluids ( ) interface is used to model heat transfer in fluids by 
conduction, convection, and radiation. A Fluid model is active by default on all 
domains. All functionality for including other domain types, such as a solid domain, is 
also available.

The temperature equation defined in fluid domains corresponds to the 
convection-diffusion equation that may contain additional contributions like heat 
sources.

When this version of the physics interface is added, these default nodes are added to 
the Model Builder: Fluid, Thermal Insulation (the default boundary condition), and Initial 

Values. Then, from the Physics toolbar, add other nodes that implement, for example, 
boundary conditions and sources. You can also right-click Heat Transfer in Fluids to 
select physics features from the context menu.

P H Y S I C A L  M O D E L

By default, no check boxes are selected under the Physical Model section.

A M B I E N T  S E T T I N G S

See Ambient Settings for details.

C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Consistent Stabilization for more details.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Inconsistent Stabilization for more details.

D I S C R E T I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Discretization. 
By default, the shape functions used for the temperature are Linear. See Discretization 
for more details.
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D E P E N D E N T  V A R I A B L E S

See Dependent Variables for details.

Feature Nodes for the Heat Transfer in Fluids Interface

This section details the nodes available with The Heat Transfer in Fluids Interface with 
default settings:

• Domain Nodes for the Heat Transfer in Fluids Interface

• Boundary Nodes for the Heat Transfer in Fluids Interface

• Edge Nodes for the Heat Transfer in Fluids Interface

• Point Nodes for the Heat Transfer in Fluids Interface

See Settings for the Heat Transfer Interface for a description of all the 
settings.

In the COMSOL Multiphysics Reference Manual see Table 2-3 for links 
to common sections and Table 2-4 to common feature nodes. You can 
also search for information: press F1 to open the Help window or Ctrl+F1 
to open the Documentation window.

• Handling Frames in Heat Transfer

• Feature Nodes for the Heat Transfer in Fluids Interface

• Theory for Heat Transfer in Fluids

Some nodes are only available with some COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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D O M A I N  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  F L U I D S  I N T E R F A C E

The Heat Transfer in Fluids Interface has the following domain nodes:

B O U N D A R Y  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  F L U I D S  I N T E R F A C E

The Heat Transfer in Fluids Interface has the following boundary nodes:

• Change Cross Section

• Change Thickness

• Fluid

• Heat Source

• Initial Values

• Out-of-Plane Heat Flux 

• Out-of-Plane Radiation

• Phase Change Material

• Pressure Work

• Solid

• Irreversible Transformation

• Thermoelastic Damping

• Translational Motion

• Viscous Dissipation

• Boundary Heat Source

• Continuity

• Deposited Beam Power

• External Temperature (Thin Layer, 
Thin Film)

• Heat Flux

• Heat Source (Thin Film)

• Inflow Heat Flux

• Layer Heat Source

• Line Heat Source on Axis

• Open Boundary

• Outflow

• Periodic Condition

• Symmetry

• Temperature

• Thermal Contact

• Thermal Insulation

• Thin Film

• Thin Layer
T H E  H E A T  TR A N S F E R  I N  F L U I D S  I N T E R F A C E  |  295



296 |  C H A P T E
E D G E  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  F L U I D S  I N T E R F A C E

The Heat Transfer in Fluids Interface has the following edge nodes (3D components 
only):

PO I N T  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  F L U I D S  I N T E R F A C E

The Heat Transfer in Fluids Interface has the following point nodes:

More nodes are available with more advanced settings. For the complete list of nodes 
available see Domain Features, Boundary Features, Edge Features, Point Features, and 
Global Features.

• Line Heat Source (Thin Rod)

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Thin Rod

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source 

• Point Heat Flux (Thin Rod)

• Point Heat Source

• Point Heat Source on Axis

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Surface-to-Ambient Radiation (Thin 
Rod)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Temperature (Thin Rod)

Select the Isothermal domain check box to make the Isothermal Domain 
and Isothermal Domain Interface nodes available.
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Th e  Hea t  T r a n s f e r  I n t e r f a c e

The Heat Transfer ( ) interface is automatically added when a predefined 
multiphysics interface under the Conjugate Heat Transfer branch is added. 

It is used to model heat transfer in solids and fluids by conduction, convection, and 
radiation. A Solid model is active by default on all domains, and a Fluid model is also 
added but not active.

Feature Nodes for the Heat Transfer Interface

The settings and the feature nodes are the same as for The Heat Transfer in Fluids 
Interface.
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Th e  Hea t  T r a n s f e r  i n  Po r ou s  Med i a  
I n t e r f a c e

The Heat Transfer in Porous Media interface ( ), found under the Heat Transfer 

branch ( ) when adding a physics interface, is used to model heat transfer by 
conduction, convection, and radiation in porous media. A Porous Medium model is 
active by default on all domains. All functionality for including other domain types, 
such as a solid domain, is also available.

The temperature equation defined in porous media domains corresponds to the 
convection-diffusion equation with thermodynamic properties averaging models to 
account for both solid matrix and fluid properties. This equation is valid when the 
temperatures into the porous matrix and the fluid are in equilibrium. If not, use The 
Local Thermal Non-Equilibrium Interface instead.

The physics interface is an extension of the generic Heat Transfer interface. When this 
physics interface is added, the following default nodes are added in the Model Builder: 
Porous Medium, Thermal Insulation (the default boundary condition), and Initial Values. 
Then, from the Physics toolbar, add other nodes that implement, for example, 
boundary conditions. You can also right-click Heat Transfer in Porous Media to select 
physics features from the context menu.

P H Y S I C A L  M O D E L

The capability to define material properties, boundary conditions, and more for 
porous media heat transfer is activated by selecting the Heat Transfer in Porous Media 
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check box (see Figure 5-1). 

Figure 5-1: The capability to model porous media heat transfer is activated by selecting the 
Heat Transfer in Porous Media check box in any Settings window for Heat Transfer (ht) 
under Physical Model.

This check box is selected by default when adding The Heat Transfer in Porous Media 
Interface.

When the Subsurface Flow Module is added, under Physical Model, select Extended 
from the Porous matrix model list to use a version of the matrix feature to account for 
multiple immobile solids and fluids, as well as for geothermal heating.

D I S C R E T I Z A T I O N

By default, the shape functions used for the temperature are Linear.

Free Convection in Porous Media: Application Library path 
Subsurface_Flow_Module/Heat_Transfer/convection_porous_medium

In the COMSOL Multiphysics Reference Manual see Table 2-3 for links 
to common sections and Table 2-4 to common feature nodes. You can 
also search for information: press F1 to open the Help window or Ctrl+F1 
to open the Documentation window.

The rest of the settings are the same as for The Heat Transfer in Solids 
Interface. See Settings for the Heat Transfer Interface for a description of 
the other settings.
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Feature Nodes for the Heat Transfer in Porous Media Interface

This section details the nodes available with The Heat Transfer in Porous Media 
Interface with default settings:

• Domain Nodes for the Heat Transfer in Porous Media Interface

• Boundary Nodes for the Heat Transfer in Porous Media Interface

• Edge Nodes for the Heat Transfer in Porous Media Interface

• Point Nodes for the Heat Transfer in Porous Media Interface

D O M A I N  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  PO R O U S  M E D I A  

I N T E R F A C E

The Heat Transfer in Porous Media Interface has the following domain nodes:

• Feature Nodes for the Heat Transfer in Porous Media Interface

• Theory for Heat Transfer in Porous Media

Some nodes are only available with some COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

• Building Material

• Change Cross Section

• Change Thickness

• Fluid

• Geothermal Heating

• Heat Source

• Immobile Fluids

• Initial Values

• Out-of-Plane Heat Flux

• Out-of-Plane Radiation

• Phase Change Material

• Porous Medium

• Pressure Work

• Solid

• Irreversible Transformation

• Thermal Dispersion

• Thermoelastic Damping

• Translational Motion

• Viscous Dissipation
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Set the Porous matrix model to Extended to make the Geothermal Heating and 
Immobile Fluids subnodes available. 

B O U N D A R Y  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  P O R O U S  M E D I A  

I N T E R F A C E

The Heat Transfer in Porous Media Interface has the following boundary nodes:

E D G E  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  P O R O U S  M E D I A  I N T E R F A C E

The Heat Transfer in Porous Media Interface has the following edge nodes (for 3D 
components only):

• Boundary Heat Source

• Continuity

• Deposited Beam Power

• External Temperature (Thin Layer, 
Thin Film)

• Fracture

• Heat Flux

• Heat Source (Thin Film)

• Inflow Heat Flux

• Layer Heat Source

• Line Heat Source on Axis

• Open Boundary

• Outflow

• Periodic Condition

• Symmetry

• Temperature

• Thermal Contact

• Thermal Insulation

• Thin Film

• Thin Layer

• Line Heat Source (Thin Rod)

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Thin Rod
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PO I N T  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  P O R O U S  M E D I A  I N T E R F A C E

The Heat Transfer in Porous Media Interface has the following point nodes:

More nodes are available with more advanced settings. For the complete list of nodes 
available see Domain Features, Boundary Features, Edge Features, Point Features, and 
Global Features.

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source 

• Point Heat Flux (Thin Rod)

• Point Heat Source

• Point Heat Source on Axis

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Surface-to-Ambient Radiation (Thin 
Rod)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Temperature (Thin Rod)

Select the Isothermal domain check box to make the Isothermal Domain 
and Isothermal Domain Interface nodes available.
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Th e  Hea t  T r a n s f e r  i n  Bu i l d i n g  
Ma t e r i a l s  I n t e r f a c e

The Heat Transfer in Building Materials ( ) interface is automatically added when the 
Building Materials version of the predefined multiphysics interface Heat and Moisture 

Transport is added. A Building Material model is active by default on all domains.

It is used to model heat transfer in building materials defined as porous media 
containing moisture, which is a mixture of liquid water and vapor. The temperature 
equation corresponds to the diffusion equation in which effective thermodynamic 
properties account for both the dry solid matrix and moisture properties. The latent 
heat of evaporation is included to define a heat source or sink.

When this physics interface is added, the following default nodes are added in the 
Model Builder: Building Material, Thermal Insulation, and Initial Values. Then, from the 
Physics toolbar, add other nodes that implement, for example, boundary conditions. 
You can also right-click Heat Transfer in Building Materials to select physics features from 
the context menu.

Settings for the Heat Transfer in Building Materials Interface

The settings are the same as for The Heat Transfer in Porous Media Interface, except 
for the discretization of the temperature, for which Quadratic Lagrange shape functions 
are used.

Feature Nodes for the Heat Transfer in Building Materials Interface

The feature nodes are the same as for The Heat Transfer in Porous Media Interface, 
with in addition the Moist Air node.

Theory for Heat Transfer in Building Materials
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See Building Materials Database in the COMSOL Multiphysics Reference 
Manual for a description of materials containing the thermal and 
hygroscopic properties required by some feature nodes of the The Heat 
Transfer in Building Materials Interface.
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Th e  Hea t  T r a n s f e r  i n  Mo i s t  A i r  
I n t e r f a c e

The Heat Transfer in Moist Air ( ) interface is automatically added when the Moist Air 
version of the predefined multiphysics interface Heat and Moisture Transport is added. 
A Moist Air model is active by default on all domains.

It is used to model heat transfer in moist air by convection and diffusion, by using 
thermodynamics properties defined as a function of the quantity of vapor in the moist 
air. 

When this physics interface is added, the following default nodes are added in the 
Model Builder: Moist Air, Thermal Insulation, and Initial Values. Then, from the Physics 
toolbar, add other nodes that implement, for example, boundary conditions. You can 
also right-click Heat Transfer in Moist Air to select physics features from the context 
menu.

Settings for the Heat Transfer in Moist Air Interface

The settings are the same as for The Heat Transfer in Fluids Interface.

Feature Nodes for the Heat Transfer in Moist Air Interface

The feature nodes are the same as for The Heat Transfer in Fluids Interface, with in 
addition the Moist Air node.

Theory for Heat Transfer in Fluids

Moist Air Fluid Type
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Th e  B i o h e a t  T r a n s f e r  I n t e r f a c e

The Bioheat Transfer interface ( ), selected under the Heat Transfer branch ( ) 
when adding a physics interface, is used to model heat transfer by conduction, 
convection, and radiation. A Biological Tissue model is active by default on all domains. 
All functionality for including other domain types, such as a solid domain, are also 
available.

The temperature equation defined in biological tissue domains corresponds to the 
differential form of the Fourier’s law with predefined contributions for bioheat 
sources. In addition, tissue damage integral models can be included, based on a 
temperature threshold or an energy absorption model.

When this version of the physics interface is added, these default nodes are added to 
the Model Builder: Biological Tissue (with a default Bioheat node), Thermal Insulation 
(the default boundary condition), and Initial Values. All functionality to include both 
solid and fluid domains are also available. Then, from the Physics toolbar, add other 
nodes that implement, for example, boundary conditions and sources. You can also 
right-click Bioheat Transfer to select physics features from the context menu. 

P H Y S I C A L  M O D E L

The Heat transfer in biological tissue check box is selected by default, which enables the 
Damage Integral Analysis Discretization section.

A M B I E N T  S E T T I N G S

See Ambient Settings for details.

C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Consistent Stabilization for more details.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Inconsistent Stabilization for more details.

D A M A G E  I N T E G R A L  A N A L Y S I S  D I S C R E T I Z A T I O N

Select the type of the Shape function for damaged tissue indicators. The default is 
Discontinuous Lagrange. The order is set in the Discretization section. 
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D I S C R E T I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Discretization. 
By default, the shape functions used for the temperature are Quadratic Lagrange. See 
Discretization for more details.

Select Constant (the default), Linear, Quadratic, Cubic, Quartic or Quintic to define the 
discretization level used for the Damage tissue indicator shape function.

D E P E N D E N T  V A R I A B L E S

See Dependent Variables for details.

Feature Nodes for the Bioheat Transfer Interface

This section details the nodes available with The Bioheat Transfer Interface with 
default settings:

• Domain Nodes for the Bioheat Transfer Interface

• Boundary Nodes for the Bioheat Transfer Interface

• Edge Nodes for the Bioheat Transfer Interface

• Point Nodes for the Bioheat Transfer Interface

See Settings for the Heat Transfer Interface for a description of all the 
settings.

• Theory for Bioheat Transfer

• Biological Tissue and Bioheat

• Feature Nodes for the Bioheat Transfer Interface

Hepatic Tumor Ablation: Application Library path 
Heat_Transfer_Module/Medical_Technology/tumor_ablation

Some nodes are only available with some COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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D O M A I N  N O D E S  F O R  T H E  B I O H E A T  TR A N S F E R  I N T E R F A C E

The Bioheat Transfer Interface has the following domain nodes:

B O U N D A R Y  N O D E S  F O R  T H E  B I O H E A T  TR A N S F E R  I N T E R F A C E

The Bioheat Transfer Interface has the following boundary nodes:

• Bioheat

• Biological Tissue

• Change Cross Section

• Change Thickness

• Fluid

• Heat Source

• Initial Values

• Out-of-Plane Heat Flux 

• Out-of-Plane Radiation

• Phase Change Material

• Pressure Work

• Solid

• Irreversible Transformation

• Thermoelastic Damping

• Translational Motion

• Viscous Dissipation

• Boundary Heat Source

• Continuity

• Deposited Beam Power

• External Temperature (Thin Layer, 
Thin Film)

• Heat Flux

• Heat Source (Thin Film)

• Inflow Heat Flux

• Layer Heat Source

• Line Heat Source on Axis

• Open Boundary

• Outflow

• Periodic Condition

• Symmetry

• Temperature

• Thermal Contact

• Thermal Insulation

• Thin Film

• Thin Layer
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E D G E  N O D E S  F O R  T H E  B I O H E A T  TR A N S F E R  I N T E R F A C E

The Bioheat Transfer Interface has the following edge nodes (for 3D components 
only):

PO I N T  N O D E S  F O R  T H E  B I O H E A T  TR A N S F E R  I N T E R F A C E

The Bioheat Transfer Interface has the following point nodes:

More nodes are available with more advanced settings. For the complete list of nodes 
available see Domain Features, Boundary Features, Edge Features, Point Features, and 
Global Features.

• Line Heat Source (Thin Rod)

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Thin Rod

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source 

• Point Heat Flux (Thin Rod)

• Point Heat Source

• Point Heat Source on Axis

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Surface-to-Ambient Radiation (Thin 
Rod)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Temperature (Thin Rod)
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Th e  Hea t  T r a n s f e r  w i t h  
S u r f a c e - t o - S u r f a c e  Rad i a t i o n  
I n t e r f a c e

The Heat Transfer with Surface-to-Surface Radiation (ht) interface ( ), found under 
the Radiation branch ( ), is used to model heat transfer by conduction, convection, 
and radiation, including surface-to-surface radiation.

A Solid model is active by default on all domains and when the Surface-to-surface 

radiation check box is selected for the Heat Transfer interface. All functionality to 
include other heat transfer models, such as Fluid, is also available. The radiosity 
equation defined on boundaries where surface-to-surface radiation is enabled 
corresponds to the radiosity method equation.

These default nodes are added to the Model Builder: Solid (with a default Opacity node, 
with Opacity set to Transparent), Thermal Insulation, and Initial Values. Then, from the 
Physics toolbar, add other nodes that implement, for example, boundary conditions. 
You can also right-click Heat Transfer with Surface-to-Surface Radiation to select physics 
features from the context menu.

P H Y S I C A L  M O D E L

When this physics interface is added, the Surface-to-surface radiation check box is 
selected by default, which enables the Radiation Settings section.

A M B I E N T  S E T T I N G S

See Ambient Settings for details.

Whereas The Surface-To-Surface Radiation Interface requires the 
temperature field as model input, this physics interface computes it. If the 
medium participates in the radiation (semi-transparent medium), then 
use The Heat Transfer with Radiation in Participating Media Interface 
instead.
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C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Consistent Stabilization for more details.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Inconsistent Stabilization for more details.

R A D I A T I O N  S E T T I N G S

This section is available when the Surface-to-surface radiation check box is selected in 
the Physical Model section. See Radiation Settings for more details.

D I S C R E T I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Discretization. 
By default, the shape functions used for the temperature are Quadratic Lagrange. See 
Discretization for more details.

Select Linear (the default), Quadratic, Cubic, Quartic or Quintic to define the 
discretization level used for the Surface radiosity shape function.

D E P E N D E N T  V A R I A B L E S

See Dependent Variables for details.

Feature Nodes for the Heat Transfer with Surface-to-Surface 
Radiation Interface

This section details the nodes available with The Heat Transfer with Surface-to-Surface 
Radiation Interface with default settings:

• Domain Nodes for the Heat Transfer with Surface-to-Surface Radiation Interface

• Boundary Nodes for the Heat Transfer with Surface-to-Surface Radiation Interface

See Settings for the Heat Transfer Interface for a description of all the 
settings.

Thermo-Photo-Voltaic Cell: Application Library path 
Heat_Transfer_Module/Thermal_Radiation/tpv_cell
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• Edge Nodes for the Heat Transfer with Surface-to-Surface Radiation Interface

• Point Nodes for the Heat Transfer with Surface-to-Surface Radiation Interface

D O M A I N  N O D E S  F O R  T H E  H E A T  TR A N S F E R  W I T H  S U R F A C E - T O - S U R F A C E  

R A D I A T I O N  I N T E R F A C E

The Heat Transfer with Surface-to-Surface Radiation Interface has the following 
domain nodes:

Some nodes are only available with some COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

• Change Cross Section

• Change Thickness

• Fluid

• Heat Source

• Initial Values

• Opacity

• Out-of-Plane Heat Flux 

• Out-of-Plane Radiation

• Phase Change Material

• Pressure Work

• Solid

• Irreversible Transformation

• Thermoelastic Damping

• Translational Motion

• Viscous Dissipation
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B O U N D A R Y  N O D E S  F O R  T H E  H E A T  TR A N S F E R  W I T H  

S U R F A C E - T O - S U R F A C E  R A D I A T I O N  I N T E R F A C E

The Heat Transfer with Surface-to-Surface Radiation Interface has the following 
boundary nodes:

E D G E  N O D E S  F O R  T H E  H E A T  TR A N S F E R  W I T H  S U R F A C E - T O - S U R F A C E  

R A D I A T I O N  I N T E R F A C E

The Heat Transfer with Surface-to-Surface Radiation Interface has the following edge 
nodes (for 3D components only):

• Boundary Heat Source

• Continuity

• Deposited Beam Power

• Diffuse Mirror

• Diffuse Surface

• External Radiation Source

• External Temperature (Thin Layer, 
Thin Film)

• Heat Flux

• Heat Source (Thin Film)

• Inflow Heat Flux

• Layer Heat Source

• Line Heat Source on Axis

• Open Boundary

• Outflow

• Periodic Condition

• Prescribed Radiosity

• Radiation Group

• Symmetry

• Temperature

• Thermal Contact

• Thermal Insulation

• Thin Film

• Thin Layer

• Line Heat Source (Thin Rod)

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Thin Rod
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PO I N T  N O D E S  F O R  T H E  H E A T  TR A N S F E R  W I T H  S U R F A C E - T O - S U R F A C E  

R A D I A T I O N  I N T E R F A C E

The Heat Transfer with Surface-to-Surface Radiation Interface has the following point 
nodes:

More nodes are available with more advanced settings. For the complete list of nodes 
available see Domain Features, Boundary Features, Edge Features, Point Features, and 
Global Features.

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source 

• Point Heat Flux (Thin Rod)

• Point Heat Source

• Point Heat Source on Axis

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Surface-to-Ambient Radiation (Thin 
Rod)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Temperature (Thin Rod)
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Th e  Hea t  T r a n s f e r  w i t h  Rad i a t i o n  i n  
Pa r t i c i p a t i n g  Med i a  I n t e r f a c e

The Heat Transfer with Radiation in Participating Media (ht) interface ( ), found under 
the Heat Transfer>Radiation branch ( ), is used to model heat transfer by 
conduction, convection, and radiation, including radiation in participating 
(semi-transparent) media.

A Solid model is active by default on all domains and when the Radiation in participating 

media check box is selected for the Heat Transfer interface. All functionality to include 
other heat transfer models, like Fluid, is also available.

The radiative intensity equations defined in participating media domains are 
approximated either with the Rosseland approximation, P1 approximation, or discrete 
ordinates method.

The following default nodes are added to the Model Builder: Solid, Initial Values, Thermal 

Insulation, Opaque Surface, and Continuity on Interior Boundary. Then, from the Physics 
toolbar, add other nodes that implement, for example, boundary conditions. You can 
also right-click Heat Transfer with Radiation in Participating Media to select physics 
features from the context menu.

P H Y S I C A L  M O D E L

When this physics interface is added, the Radiation in participating media check box is 
selected by default, which enables the Participating Media Settings section.

A M B I E N T  S E T T I N G S

See Ambient Settings for details.

Whereas The Radiation in Participating Media Interface requires the 
temperature field as model input, this physics interface computes it. If the 
medium does not participate in the radiation (transparent medium), then 
use The Heat Transfer with Surface-to-Surface Radiation Interface 
instead.
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C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Consistent Stabilization for more details.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Inconsistent Stabilization for more details.

P A R T I C I P A T I N G  M E D I A  S E T T I N G S

Radiation Discretization Method
Select a Radiation discretization method: Discrete ordinates method (the default), 
Rosseland approximation, or P1 approximation.

• When Discrete ordinates method is selected, Opaque Surface and Continuity on 
Interior Boundary are automatically added as default features.

• When P1 approximation is selected, Opaque Surface is automatically added as a 
default feature and both this and Incident Intensity are made available from the 
Physics ribbon toolbar (Windows users), Physics context menu (Mac or Linux users), 
or the context menu (all users). Continuity on Interior Boundary is not available.

• When Rosseland approximation is selected, neither Continuity on Interior Boundary 
nor Opaque Surface is included or available.

Refractive Index
For either selection, define the Refractive index nr (dimensionless) of the participating 
media. The same refractive index is used for the whole model.

Performance Index
For Discrete ordinates method select a Performance index Pindex from the list. Select a 
value between 0 and 1 that modifies the strategy used to define automatic solver 
settings. The default is 0.4. With small values, a robust setting for the solver is 
expected. With large values (up to 1), less memory is needed to solve the model.

The choice of Radiation discretization method also offers different settings 
for the Radiation in Participating Media (Heat Transfer Interface) (all 
methods), Opaque Surface (P1 approximation), and Incident Intensity 
(P1 approximation) nodes.
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Discrete Ordinates Method
For Discrete ordinates method, select an order from the list. This order defines the 
angular discretization of the radiative intensity direction.

D I S C R E T I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Discretization. 
By default, the shape functions used for the temperature are Quadratic Lagrange. See 
Discretization for more details.

When the Radiation discretization method is set to Discrete ordinates method in 
Participating Media Settings, set the discretization level of the Radiative intensity: 
Constant, Linear (the default), Quadratic, Cubic, Quartic, or Quintic.

When the Radiation discretization method is set to P1 approximation in Participating 

Media Settings, set the discretization level of the Incident radiation: Linear (the default), 
Quadratic, Cubic, Quartic, or Quintic.

D E P E N D E N T  V A R I A B L E S

See Dependent Variables for details.

In 3D, S2, S4, S6, and S8 generate 8, 24, 48, and 80 directions, 
respectively. The default is S4.

In 2D, S2, S4, S6, and S8 generate 4, 12, 24, and 40 directions, 
respectively.

For additional background theory also see Discrete Ordinates Method 
(DOM), Discrete Ordinates Method Implementation in 2D, Rosseland 
Approximation Theory, and P1 Approximation Theory. 

See Settings for the Heat Transfer Interface for a description of all the 
settings.
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Feature Nodes for the Heat Transfer with Radiation in Participating 
Media Interface

This section details the nodes available with The Heat Transfer with Radiation in 
Participating Media Interface with default settings:

• Domain Nodes for the Heat Transfer with Radiation in Participating Media 
Interface

• Boundary Nodes for the Heat Transfer with Radiation in Participating Media 
Interface

• Edge Nodes for the Heat Transfer with Radiation in Participating Media Interface

• Point Nodes for the Heat Transfer with Radiation in Participating Media Interface

D O M A I N  N O D E S  F O R  T H E  H E A T  TR A N S F E R  W I T H  R A D I A T I O N  I N  

P A R T I C I P A T I N G  M E D I A  I N T E R F A C E

The The Heat Transfer with Radiation in Participating Media Interface has the 
following domain nodes:

Some nodes are only available with some COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

• Change Cross Section

• Change Thickness

• Fluid

• Heat Source

• Initial Values

• Out-of-Plane Heat Flux

• Out-of-Plane Radiation

• Phase Change Material

• Pressure Work

• Radiation in Participating Media 
(Heat Transfer Interface)

• Solid

• Irreversible Transformation

• Thermoelastic Damping

• Translational Motion

• Viscous Dissipation
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B O U N D A R Y  N O D E S  F O R  T H E  H E A T  TR A N S F E R  W I T H  R A D I A T I O N  I N  

P A R T I C I P A T I N G  M E D I A  I N T E R F A C E

The The Heat Transfer with Radiation in Participating Media Interface has the 
following boundary nodes:

E D G E  N O D E S  F O R  T H E  H E A T  TR A N S F E R  W I T H  R A D I A T I O N  I N  

P A R T I C I P A T I N G  M E D I A  I N T E R F A C E

The The Heat Transfer with Radiation in Participating Media Interface has the 
following edge nodes (for 3D components only):

• Boundary Heat Source

• Continuity

• Continuity on Interior Boundary

• Deposited Beam Power

• Diffuse Surface

• External Temperature (Thin Layer, 
Thin Film)

• Heat Flux

• Heat Source (Thin Film)

• Incident Intensity

• Inflow Heat Flux

• Layer Heat Source

• Line Heat Source on Axis

• Opaque Surface

• Open Boundary

• Outflow

• Periodic Condition

• Symmetry

• Temperature

• Thermal Contact

• Thermal Insulation

• Thin Film

• Thin Layer

• Line Heat Source (Thin Rod)

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Thin Rod
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PO I N T  N O D E S  F O R  T H E  H E A T  TR A N S F E R  W I T H  R A D I A T I O N  I N  

P A R T I C I P A T I N G  M E D I A  I N T E R F A C E

The The Heat Transfer with Radiation in Participating Media Interface has the 
following point nodes:

More nodes are available with more advanced settings. For the complete list of nodes 
available see Domain Features, Boundary Features, Edge Features, Point Features, and 
Global Features.

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source 

• Point Heat Flux (Thin Rod)

• Point Heat Source

• Point Heat Source on Axis

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Surface-to-Ambient Radiation (Thin 
Rod)

• Temperature (Thin Rod)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)
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Th e  Hea t  T r a n s f e r  i n  Th i n  S h e l l s  
I n t e r f a c e

The Heat Transfer in Thin Shells (htsh) interface ( ), found in the Thin Structures 

physics area under the Heat Transfer branch ( ), is used to model heat transfer by 
conduction, convection and radiation in thin structures. A Thin Conductive Layer model 
is active by default on all boundaries. All functionalities for including other boundary 
contributions, such as surface-to-surface radiation, are also available.

The temperature equation defined on shells corresponds to the tangential differential 
form of the Fourier’s law (see Equation 4-50) that may contain additional 
contributions such as heat sources.

The physics interface is available for 2D components, 3D components, and for 
axisymmetric components with cylindrical coordinates in 2D.

When this version of the physics interface is added, these default nodes are also added 
to the Model Builder: Thin Conductive Layer, Insulation/Continuity (a boundary 
condition), and Initial Values. Then, from the Physics toolbar, add additional nodes that 
implement, for example, edge or point conditions, and heat sources. You can also 
right-click Heat Transfer in Thin Shells to select physics features from the context menu.

P H Y S I C A L  M O D E L

By default, no check boxes are selected under the Physical Model section.

A M B I E N T  S E T T I N G S

See Ambient Settings for details.

C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Consistent Stabilization for more details.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Inconsistent Stabilization for more details.
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R A D I A T I O N  S E T T I N G S

This section is available when the Surface-to-surface radiation check box is selected in 
the Physical Model section. See Radiation Settings for more details.

D I S C R E T I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Discretization. 
By default, the shape functions used for the temperature are Quadratic Lagrange. See 
Discretization for more details.

D E P E N D E N T  V A R I A B L E S

See Dependent Variables for details.

Feature Nodes for the Heat Transfer in Thin Shells Interface

This section details the nodes available with The Heat Transfer in Thin Shells Interface 
with default settings:

• Boundary Nodes for the Heat Transfer in Thin Shells Interface

• Edge Nodes for the Heat Transfer in Thin Shells Interface

• Point Nodes for the Heat Transfer in Thin Shells Interface

See Settings for the Heat Transfer in Thin Structures Interface for a 
description of the other settings.

• Handling Frames in Heat Transfer

• Feature Nodes for the Heat Transfer in Thin Shells Interface

• Theory for Heat Transfer in Thin Structures

Shell Conduction: Application Library path 
Heat_Transfer_Module/Tutorials,_Thin_Structure/shell_conduction

Some nodes are only available with some COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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B O U N D A R Y  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  T H I N  S H E L L S  

I N T E R F A C E

The Heat Transfer in Thin Shells Interface has the following boundary nodes:

E D G E  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  T H I N  S H E L L S  I N T E R F A C E

The Heat Transfer in Thin Shells Interface has the following edge nodes (for 3D 
components only):

The Heat Transfer in Thin Shells Interface does not have any domain 
node, as it can be applied only on boundaries.

• Change Thickness (Heat Transfer in 
Thin Shells Interface)

• Continuity

• Deposited Beam Power

• Diffuse Surface

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Thin Layered Shell)

• Initial Values (Heat Transfer in Thin 
Shells Interface)

• Thin Conductive Layer (Heat 
Transfer in Thin Shells Interface)

• Thin Layered Shell (Heat Transfer in 
Thin Shells Interface)

• Change Effective Thickness (Heat 
Transfer in Thin Shells Interface)

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface) 

• Insulation/Continuity (Heat 
Transfer in Thin Shells Interface)

• Surface-to-Ambient Radiation 
(Heat Transfer in Thin Shells 
Interface)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)
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PO I N T  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  T H I N  S H E L L S  I N T E R F A C E

The Heat Transfer in Thin Shells Interface has the following point nodes:

More nodes are available with more advanced settings. For the complete list of nodes 
available see Domain Features, Boundary Features, Edge Features, Point Features, and 
Global Features.

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Insulation/Continuity (Heat 
Transfer in Thin Shells Interface)

• Surface-to-Ambient Radiation 
(Heat Transfer in Thin Shells 
Interface)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)
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Th e  Hea t  T r a n s f e r  i n  Th i n  F i lm s  
I n t e r f a c e

The Heat Transfer in Thin Films (htsh) interface ( ), found in the Thin Structures 

physics area under the Heat Transfer branch ( ), is used to model heat transfer by 
conduction, convection and radiation in thin structures. A Thin Film model is active by 
default on all boundaries. All functionalities for including other boundary 
contributions, such as surface-to-surface radiation, are also available.

The temperature equation defined on thin films corresponds to the tangential 
differential form of the convection-diffusion equation that may contain additional 
contributions such as heat sources.

The physics interface is available for 2D components, 3D components, and for 
axisymmetric components with cylindrical coordinates in 2D.

When this version of the physics interface is added, these default nodes are also added 
to the Model Builder: Thin Film, Insulation/Continuity (a boundary condition), and Initial 

Values. Then, from the Physics toolbar, add additional nodes that implement, for 
example, edge or point conditions, and heat sources. You can also right-click Heat 

Transfer in Thin Films to select physics features from the context menu.

P H Y S I C A L  M O D E L

By default, no check boxes are selected under the Physical Model section.

A M B I E N T  S E T T I N G S

See Ambient Settings for details.

C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Consistent Stabilization for more details.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Inconsistent Stabilization for more details.
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R A D I A T I O N  S E T T I N G S

This section is available when the Surface-to-surface radiation check box is selected in 
the Physical Model section. See Radiation Settings for more details.

D I S C R E T I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Discretization. 
By default, the shape functions used for the temperature are Linear. See Discretization 
for more details.

D E P E N D E N T  V A R I A B L E S

See Dependent Variables for details.

Feature Nodes for the Heat Transfer in Thin Films Interface

This section details the nodes available with The Heat Transfer in Thin Films Interface 
with default settings:

• Boundary Nodes for the Heat Transfer in Thin Films Interface

• Edge Nodes for the Heat Transfer in Thin Films Interface

• Point Nodes for the Heat Transfer in Thin Films Interface

See Settings for the Heat Transfer in Thin Structures Interface for a 
description of the other settings.

• Handling Frames in Heat Transfer

• Feature Nodes for the Heat Transfer in Thin Films Interface

• Theory for Heat Transfer in Thin Structures

Some nodes are only available with some COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

The Heat Transfer in Thin Films Interface does not have any domain 
node, as it can be applied only on boundaries.
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B O U N D A R Y  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  T H I N  F I L M S  I N T E R F A C E

The Heat Transfer in Thin Films Interface has the following boundary nodes:

E D G E  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  T H I N  F I L M S  I N T E R F A C E

The Heat Transfer in Thin Films Interface has the following edge nodes (for 3D 
components only):

• Change Thickness (Heat Transfer in 
Thin Shells Interface)

• Continuity

• Deposited Beam Power

• Diffuse Surface

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Thin Layered Shell)

• Initial Values (Heat Transfer in Thin 
Shells Interface)

• Thin Conductive Layer (Heat 
Transfer in Thin Shells Interface)

• Thin Film

• Thin Layered Shell (Heat Transfer in 
Thin Shells Interface)

• Change Effective Thickness (Heat 
Transfer in Thin Shells Interface)

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface) 

• Insulation/Continuity (Heat 
Transfer in Thin Shells Interface)

• Surface-to-Ambient Radiation 
(Heat Transfer in Thin Shells 
Interface)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)
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PO I N T  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  T H I N  F I L M S  I N T E R F A C E

The Heat Transfer in Thin Films Interface has the following point nodes:

More nodes are available with more advanced settings. For the complete list of nodes 
available see Domain Features, Boundary Features, Edge Features, Point Features, and 
Global Features.

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Insulation/Continuity (Heat 
Transfer in Thin Shells Interface)

• Surface-to-Ambient Radiation 
(Heat Transfer in Thin Shells 
Interface)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)
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Th e  Hea t  T r a n s f e r  i n  F r a c t u r e s  
I n t e r f a c e

The Heat Transfer in Fractures (htsh) interface ( ), found in the Thin Structures 

physics area under the Heat Transfer branch ( ), is used to model heat transfer by 
conduction, convection and radiation in porous thin structures. A Fracture model is 
active by default on all boundaries. All functionalities for including other boundary 
contributions, such as surface-to-surface radiation, are also available.

The temperature equation defined on fractures corresponds to the tangential 
differential form of the convection-diffusion equation with thermodynamic properties 
averaging models to account for both solid matrix and fluid properties. The equation 
is valid when the temperatures into the porous matrix and the fluid are in equilibrium, 
and may contain additional contributions such as heat sources.

The physics interface is available for 2D components, 3D components, and for 
axisymmetric components with cylindrical coordinates in 2D.

When this version of the physics interface is added, these default nodes are also added 
to the Model Builder: Fracture, Insulation/Continuity (a boundary condition), and Initial 

Values. Then, from the Physics toolbar, add additional nodes that implement, for 
example, edge or point conditions, and heat sources. You can also right-click Heat 

Transfer in Fractures to select physics features from the context menu.

P H Y S I C A L  M O D E L

By default, the Heat Transfer in Porous Media check box is selected under the Physical 

Model section.

A M B I E N T  S E T T I N G S

See Ambient Settings for details.

C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Consistent Stabilization for more details.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Stabilization. 
See Inconsistent Stabilization for more details.
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R A D I A T I O N  S E T T I N G S

This section is available when the Surface-to-surface radiation check box is selected in 
the Physical Model section. See Radiation Settings for more details.

D I S C R E T I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Discretization. 
By default, the shape functions used for the temperature are Linear. See Discretization 
for more details.

D E P E N D E N T  V A R I A B L E S

See Dependent Variables for details.

Feature Nodes for the Heat Transfer in Fractures Interface

This section details the nodes available with The Heat Transfer in Fractures Interface 
with default settings:

• Boundary Nodes for the Heat Transfer in Fractures Interface

• Edge Nodes for the Heat Transfer in Fractures Interface

• Point Nodes for the Heat Transfer in Fractures Interface

See Settings for the Heat Transfer in Thin Structures Interface for a 
description of the other settings.

• Handling Frames in Heat Transfer

• Feature Nodes for the Heat Transfer in Fractures Interface

• Theory for Heat Transfer in Thin Structures

Some nodes are only available with some COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

The Heat Transfer in Fractures Interface does not have any domain node, 
as it can be applied only on boundaries.
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B O U N D A R Y  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  F R A C T U R E S  I N T E R F A C E

The Heat Transfer in Fractures Interface has the following boundary nodes:

E D G E  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  F R A C T U R E S  I N T E R F A C E

The Heat Transfer in Fractures Interface has the following edge nodes (for 3D 
components only):

• Change Thickness (Heat Transfer in 
Thin Shells Interface)

• Continuity

• Deposited Beam Power

• Diffuse Surface

• Fracture

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Thin Layered Shell)

• Initial Values (Heat Transfer in Thin 
Shells Interface)

• Thin Conductive Layer (Heat 
Transfer in Thin Shells Interface)

• Thin Layered Shell (Heat Transfer in 
Thin Shells Interface)

• Change Effective Thickness (Heat 
Transfer in Thin Shells Interface)

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface) 

• Insulation/Continuity (Heat 
Transfer in Thin Shells Interface)

• Surface-to-Ambient Radiation 
(Heat Transfer in Thin Shells 
Interface)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)
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PO I N T  N O D E S  F O R  T H E  H E A T  TR A N S F E R  I N  F R A C T U R E S  I N T E R F A C E

The Heat Transfer in Fractures Interface has the following point nodes:

More nodes are available with more advanced settings. For the complete list of nodes 
available see Domain Features, Boundary Features, Edge Features, Point Features, and 
Global Features.

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Insulation/Continuity (Heat 
Transfer in Thin Shells Interface)

• Surface-to-Ambient Radiation 
(Heat Transfer in Thin Shells 
Interface)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)
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Th e  S u r f a c e - T o - S u r f a c e  Rad i a t i o n  
I n t e r f a c e

The Surface-to-Surface Radiation (rad) interface ( ), found under the Heat 

Transfer>Radiation branch ( ), is used to model heat transfer by radiation. It treats 
thermal radiation as an energy transfer between boundaries and external heat sources 
where the medium does not participate in the radiation (radiation in transparent 
media).

The radiosity equation defined on boundaries where surface-to-surface radiation is 
enabled corresponds to the radiosity method equation.

From the Physics toolbar, add other nodes that implement, for example, boundary 
conditions. You can also right-click Surface-to-Surface Radiation to select physics 
features from the context menu. For the Surface-to-Surface Radiation interface, select a 
Stationary or Time Dependent study as a preset study type. The surface-to-surface 
radiation is always stationary (that is, the radiation time scale is assumed to be shorter 
than any other time scale), but the physics interface is compatible with all standard 
study types.

In this section:

• Settings for the Surface-to-Surface Radiation Interface

• Feature Nodes for the Surface-to-Surface Radiation Interface

Whereas The Heat Transfer with Surface-to-Surface Radiation Interface 
computes the temperature field, this physics interface requires it as model 
input. If the medium participates in the radiation (semi-transparent 
medium), then use The Radiation in Participating Media Interface 
instead.

Absolute (thermodynamical) temperature units must be used. See 
Specifying Model Equation Settings in the COMSOL Multiphysics 
Reference Manual.
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Settings for the Surface-to-Surface Radiation Interface

The Label is the default physics interface name. 

The Name is used primarily as a scope prefix for variables defined by the physics 
interface. Refer to such physics interface variables in expressions using the pattern 
<name>.<variable_name>. In order to distinguish between variables belonging to 
different physics interfaces, the name string must be unique. Only letters, numbers, and 
underscores (_) are permitted in the Name field. The first character must be a letter.

The default Name (for the first physics interface in the model) is rad.

R A D I A T I O N  S E T T I N G S

This section is always available for The Surface-To-Surface Radiation Interface. To 
display this section for any version of the Heat Transfer interface, select the 
Surface-to-surface radiation check box in the Physical Model section.

Define the Wavelength dependence of emissivity.

• Keep the default value, Constant, to define a diffuse gray radiation model. In this 
case, the surface emissivity has the same definition for all wavelengths. The surface 
emissivity can still depend on other quantities, in particular on the temperature.

• Select Solar and ambient to define a diffuse spectral radiation model with two 
spectral bands, one for short wavelengths, [0, λ1], (solar radiation) and one for large 
wavelengths, [λ1, +∞[, (ambient radiation). It is then possible to define the Intervals 

endpoint (SI unit: m), λ1, to adjust the wavelength intervals corresponding to the 
solar and ambient radiation. The surface properties can then be defined for each 
spectral band. In particular it is possible to define the solar absorptivity for short 
wavelengths and the surface emissivity for large wavelengths.

• Select Multiple spectral bands and set the Number of wavelength bands value (2 to 5), 
to define a diffuse spectral radiation model. It is then possible to provide a definition 
of the surface emissivity for each spectral band. Update Intervals endpoint (SI unit: 
m), λ1, λ2, ..., to define the wavelength intervals [λi − 1, λi[ for i from 1 to the 
Number of wavelength bands. 

The first and the last endpoints, λ0 and λN (with N equal to the value 
selected to define the Number of wavelength bands), are predefined and 
equal to 0 and +∞, respectively.
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Modify the Transparent media refractive index if it is different from 1 and corresponds 
to vacuum refractive index, which is usually a good approximation for air refractive 
index.

In the Exterior radiation menu, select Exterior is transparent or Exterior is opaque to 
define if the exterior of the heat transfer interface selection should be considered as 
transparent or opaque, respectively, when Opacity controlled option is used to define 
Radiation direction in surface-to-surface radiation boundary conditions. It has no effect 
on a boundary where Opacity controlled option is not selected.

Also select the Use radiation groups check box to enable the ability to define radiation 
groups, which can, in many cases, speed up the radiation calculations.

Select the Surface-to-surface radiation method: Hemicube (the default) or Direct area 

integration.

• For Direct Area Integration select a Radiation integration order — 4 is the default.

• For Hemicube select a Radiation resolution — 256 is the default.

Hemicube
Hemicube is the default method for the heat transfer interfaces. The more 
sophisticated and general hemicube method uses a z-buffered projection on the sides 
of a hemicube (with generalizations to 2D and 1D) to account for shadowing effects. 
Think of it as rendering digital images of the geometry in five different directions (in 
3D; in 2D only three directions are needed), and counting the pixels in each mesh 
element to evaluate its view factor.

Its accuracy can be influenced by setting the Radiation resolution of the virtual 
snapshots. The number of z-buffer pixels on each side of the 3D hemicube equals the 
specified resolution squared. Thus the time required to evaluate the irradiation 
increases quadratically with resolution. In 2D, the number of z-buffer pixels is 
proportional to the resolution property, and thus the time is, as well.

For an axisymmetric geometry, Gm and Famb must be evaluated in a corresponding 
3D geometry obtained by revolving the 2D boundaries about the axis. COMSOL 
Multiphysics creates this virtual 3D geometry by revolving the 2D boundary mesh into 
a 3D mesh. The resolution can be controlled in the azimuthal direction by setting the 
number of azimuthal sectors, which is the same as the number of elements to a full 
revolution. Try to balance this number against the mesh resolution in the rz-plane.
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Direct Area Integration
COMSOL Multiphysics evaluates the mutual irradiation between surface directly, 
without considering which face elements are obstructed by others. This means that 
shadowing effects (that is, surface elements being obstructed in nonconvex cases) are 
not taken into account. Elements facing away from each other are, however, excluded 
from the integrals.

Direct area integration is fast and accurate for simple geometries with no shadowing, 
or where the shadowing can be handled by manually assigning boundaries to different 
groups.

D I S C R E T I Z A T I O N

To display this section, click the Show button ( ) and select Discretization. 

Select Linear (the default), Quadratic, Cubic, Quartic or Quintic to define the 
discretization level used for the Surface radiosity shape function. 

Feature Nodes for the Surface-to-Surface Radiation Interface

This section details the nodes available with The Surface-To-Surface Radiation 
Interface with default settings:

• Domain Nodes for the Surface-to-Surface Radiation Interface

If shadowing is ignored, global energy is not conserved. Control the 
accuracy by specifying a Radiation integration order. Sharp angles and small 
gaps between surfaces may require a higher integration order for accuracy 
but also more time to evaluate the irradiation.

• About the Heat Transfer Interfaces

• Feature Nodes for the Surface-to-Surface Radiation Interface

• The Surface-To-Surface Radiation Interface

• Theory for Surface-to-Surface Radiation
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• Boundary Nodes for the Surface-to-Surface Radiation Interface

D O M A I N  N O D E S  F O R  T H E  S U R F A C E - T O - S U R F A C E  R A D I A T I O N  I N T E R F A C E

The Surface-To-Surface Radiation Interface has one domain node: Opacity.

B O U N D A R Y  N O D E S  F O R  T H E  S U R F A C E - T O - S U R F A C E  R A D I A T I O N  

I N T E R F A C E

The Surface-To-Surface Radiation Interface has the following boundary nodes:

Some nodes are only available with some COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

• Continuity

• Diffuse Mirror

• Diffuse Surface

• External Radiation Source

• Prescribed Radiosity

• Radiation Group
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Th e  Rad i a t i o n  i n  Pa r t i c i p a t i n g  Med i a  
I n t e r f a c e

The Radiation in Participating Media (rpm) interface ( ), found under the Heat 

Transfer>Radiation branch ( ), is used to model radiative heat transfer inside 
participating (semi-transparent media) media.

The radiative intensity equations defined in participating media domains correspond 
to a P1 approximation or to the discrete ordinates method approximation equations 
depending on the selected approximation.

When the physics interface is added, these default nodes are added to the Model Builder: 
Radiation in Participating Media, Wall, Continuity on Interior Boundary, and Initial Values. 
Right-click the main node to add boundary conditions or other features. Then, from 
the Physics toolbar, add other nodes that implement, for example, boundary 
conditions. You can also right-click Radiation in Participating Media node to select 
physics features from the context menu.

In this section:

• Settings for the Radiation in Participating Media Interface

• Feature Nodes for the Radiation in Participating Media Interface

Settings for the Radiation in Participating Media Interface

The Label is the default physics interface name. 

The Name is used primarily as a scope prefix for variables defined by the physics 
interface. Refer to such physics interface variables in expressions using the pattern 
<name>.<variable_name>. In order to distinguish between variables belonging to 
different physics interfaces, the name string must be unique. Only letters, numbers, and 
underscores (_) are permitted in the Name field. The first character must be a letter.

Whereas The Heat Transfer with Radiation in Participating Media 
Interface computes the temperature field, this physics interface requires it 
as a model input. If the medium does not participate in the radiation 
(transparent medium), then use The Surface-To-Surface Radiation 
Interface instead.
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The default Name (for the first physics interface in the model) is rpm.

P A R T I C I P A T I N G  M E D I A  S E T T I N G S

To display this section select the Radiation in participating media check box under 
Physical Model on any version of the Settings window for Heat Transfer. 

Radiation Discretization Method
Select a Radiation discretization method: Discrete ordinates method (the default) or P1 

approximation. 

• When Discrete ordinates method is selected, Opaque Surface and Continuity on 
Interior Boundary are automatically added as default features.

• When P1 approximation is selected, Opaque Surface is automatically added as a 
default feature and both this and Incident Intensity are made available from the 
Physics ribbon toolbar (Windows users), Physics context menu (Mac or Linux users), 
or the context menu (all users). Continuity on Interior Boundary is not available.

Refractive Index
For either selection, define the Refractive index nr (dimensionless) of the participating 
media. The same refractive index is used for the whole model.

Performance Index
When Discrete ordinates method is selected, choose a Performance index Pindex from the 
list. Select a value between 0 and 1 that modifies the strategy used to define automatic 
solver settings. The default is 0.4. With small values, a robust setting for the solver is 
expected. With large values (up to 1), less memory is needed to solve the model.

• Radiative Heat Transfer in Finite Cylindrical Media: Application 
Library path Heat_Transfer_Module/Verification_Examples/

cylinder_participating_media

• Radiative Heat Transfer in a Utility Boiler: Application Library 
path Heat_Transfer_Module/Thermal_Radiation/boiler

The choice of Radiation discretization method also offers different settings 
for the Radiation in Participating Media (Heat Transfer Interface) (all 
methods), Opaque Surface (P1 approximation), and Incident Intensity 
(P1 approximation) nodes.
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Discrete Ordinates Method
When Discrete ordinates method is selected, choose the Discrete ordinates method order 
from the list. This order defines the angular discretization of the radiative intensity 
direction.

D I S C R E T I Z A T I O N

This section is available by clicking the Show button ( ) and selecting Discretization. 

When the Radiation discretization method is set to Discrete ordinates method in 
Participating Media Settings, set the discretization level of the Radiative intensity: 
Constant, Linear (the default), Quadratic, Cubic, Quartic, or Quintic.

When the Radiation discretization method is set to P1 approximation in Participating 

Media Settings, set the discretization level of the Incident radiation: Linear (the default), 
Quadratic, Cubic, Quartic, or Quintic.

Feature Nodes for the Radiation in Participating Media Interface

This section details the nodes available with The Radiation in Participating Media 
Interface with default settings:

• Domain Nodes for the Radiation in Participating Media Interface

In 3D, S2, S4, S6, and S8 generate 8, 24, 48, and 80 directions, 
respectively. The default is S4.

In 2D, S2, S4, S6, and S8 generate 4, 12, 24, and 40 directions, 
respectively.

For additional background theory also see Discrete Ordinates Method 
(DOM), Discrete Ordinates Method Implementation in 2D, and P1 
Approximation Theory. 
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• Boundary Nodes for the Radiation in Participating Media Interface

D O M A I N  N O D E S  F O R  T H E  R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A  

I N T E R F A C E

The Radiation in Participating Media Interface has one domain node: Radiation in 
Participating Media (RPM Interface).

B O U N D A R Y  N O D E S  F O R  T H E  R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A  

I N T E R F A C E

The Radiation in Participating Media Interface has the following boundary nodes:

Some nodes are only available with some COMSOL products.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

• Continuity

• Continuity on Interior Boundary

• Incident Intensity

• Opaque Surface
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Th e  Mo i s t u r e  T r a n s p o r t  i n  Bu i l d i n g  
Ma t e r i a l s  I n t e r f a c e

The Moisture Transport in Building Materials ( ) interface is used to model moisture 
transport in building materials by taking into account moisture storage, liquid 
transport by capillary suction forces, and the convective transport of vapor. A Building 
Material model is active by default on all domains. 

When this physics interface is added, these default nodes are added to the Model 

Builder: Building Material, Insulation (the default boundary condition), and Initial 

Values. Then, from the Physics toolbar, add other nodes that implement, for example, 
boundary conditions. You can also right-click Moisture Transport in Building Materials 

to select physics features from the context menu.

Settings for the Moisture Transport in Building Materials Interface

The Label is the default physics interface name. 

The Name is used primarily as a scope prefix for variables defined by the physics 
interface. Refer to such physics interface variables in expressions using the pattern 
<name>.<variable_name>. In order to distinguish between variables belonging to 
different physics interfaces, the name string must be unique. Only letters, numbers, and 
underscores (_) are permitted in the Name field. The first character must be a letter.

The default Name (for the first physics interface in the model) is mt.

P H Y S I C A L  M O D E L

In 2D and 1D axisymmetric components, set the Thickness dz, which is the thickness 
of the domain in the out-of-plane direction. The default value is 1 m.

In 1D components, set the Cross sectional area Ac and the Cross sectional perimeter Pc 
of the domain. Default values are 1 m2 and 1 m, respectively.

See Building Materials Database in the COMSOL Multiphysics Reference 
Manual for a description of materials containing the thermal and 
hygroscopic properties required by some feature nodes of the Moisture 
Transport in Building Materials Interface.
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C O N S I S T E N T  S T A B I L I Z A T I O N

The Streamline diffusion check box is selected by default and should remain selected for 
optimal performance for applications that include a convective or translational term. 
Crosswind diffusion provides extra diffusion in regions with sharp gradients. The added 
diffusion is orthogonal to the streamlines, so streamline diffusion and crosswind 
diffusion can be used simultaneously. The Crosswind diffusion check box is also selected 
by default.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

The Isotropic diffusion check box is not selected by default. To add isotropic diffusion, 
select the Isotropic diffusion check box. The field for the tuning parameter δid then 
becomes available. The default value is 0.25; increase or decrease the value of δid to 
increase or decrease the amount of isotropic diffusion.

A D V A N C E D  S E T T I N G S

To display this section, click the Show button ( ) and select Advanced Physics Options. 
Normally these settings do not need to be changed, and only apply to the domains in 
which a Moist Air feature is active. Select a Convective term—Non-conservative form (the 
default) or Conservative form. The latter should be used for compressible flow.

D I S C R E T I Z A T I O N

To display this section, click the Show button ( ) and select Discretization. The shape 
functions used for the relative humidity are Quadratic Lagrange. 

In the COMSOL Multiphysics Reference Manual:

• Stabilization Techniques

• Stabilization

In the COMSOL Multiphysics Reference Manual see Table 2-3 for links 
to common sections and Table 2-4 to common feature nodes. You can 
also search for information: press F1 to open the Help window or Ctrl+F1 
to open the Documentation window.

Theory for Moisture Transport
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Feature Nodes for the Moisture Transport in Building Materials 
Interface

This section details the nodes available with The Moisture Transport in Building 
Materials Interface with default settings:

• Domain Nodes for the Moisture Transport in Building Materials Interface

• Boundary Nodes for the Moisture Transport in Building Materials Interface

D O M A I N  N O D E S  F O R  T H E  M O I S T U R E  TR A N S P O R T  I N  B U I L D I N G  

M A T E R I A L S  I N T E R F A C E

The Moisture Transport in Building Materials Interface has the following domain 
nodes:

B O U N D A R Y  N O D E S  F O R  T H E  M O I S T U R E  TR A N S P O R T  I N  B U I L D I N G  

M A T E R I A L S  I N T E R F A C E

The Moisture Transport in Building Materials Interface has the following boundary 
nodes:

• Building Material

• Initial Values

• Moist Air

• Moisture Source

• Continuity

• Insulation

• Moist Surface

• Moisture Content

• Moisture Flux

• Outflow

• Symmetry

• Thin Moisture Barrier

• Wet Surface
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Th e  Mo i s t u r e  T r a n s po r t  i n  A i r  
I n t e r f a c e

The Moisture Transport in Air ( ) interface is used to model moisture transport 
through convection and diffusion of vapor in moist air. A Moist Air model is active by 
default on all domains. 

When this physics interface is added, these default nodes are added to the Model 

Builder: Moist Air, Insulation (the default boundary condition), and Initial Values. Then, 
from the Physics toolbar, add other nodes that implement, for example, boundary 
conditions. You can also right-click Moisture Transport in Air to select physics features 
from the context menu.

Settings for the Moisture Transport in Air Interface

The Label is the default physics interface name. 

The Name is used primarily as a scope prefix for variables defined by the physics 
interface. Refer to such physics interface variables in expressions using the pattern 
<name>.<variable_name>. In order to distinguish between variables belonging to 
different physics interfaces, the name string must be unique. Only letters, numbers, and 
underscores (_) are permitted in the Name field. The first character must be a letter.

The default Name (for the first physics interface in the model) is mt.

P H Y S I C A L  M O D E L

In 2D and 1D axisymmetric components, set the Thickness dz, which is the thickness 
of the domain in the out-of-plane direction. The default value is 1 m.

In 1D components, set the Cross sectional area Ac and the Cross sectional perimeter Pc 
of the domain. Default values are 1 m2 and 1 m, respectively.

C O N S I S T E N T  S T A B I L I Z A T I O N

The Streamline diffusion check box is selected by default and should remain selected for 
optimal performance for applications that include a convective or translational term. 
Crosswind diffusion provides extra diffusion in regions with sharp gradients. The added 
diffusion is orthogonal to the streamlines, so streamline diffusion and crosswind 
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diffusion can be used simultaneously. The Crosswind diffusion check box is also selected 
by default.

I N C O N S I S T E N T  S T A B I L I Z A T I O N

The Isotropic diffusion check box is not selected by default. To add isotropic diffusion, 
select the Isotropic diffusion check box. The field for the tuning parameter δid then 
becomes available. The default value is 0.25; increase or decrease the value of δid to 
increase or decrease the amount of isotropic diffusion.

A D V A N C E D  S E T T I N G S

To display this section, click the Show button ( ) and select Advanced Physics Options. 
Normally these settings do not need to be changed, and only apply to the domains in 
which a Moist Air feature is active. Select a Convective term—Non-conservative form (the 
default) or Conservative form. The latter should be used for compressible flow.

D I S C R E T I Z A T I O N

To display this section, click the Show button ( ) and select Discretization. The shape 
functions used for the relative humidity are Linear. 

In the COMSOL Multiphysics Reference Manual:

• Stabilization Techniques

• Stabilization

In the COMSOL Multiphysics Reference Manual see Table 2-3 for links 
to common sections and Table 2-4 to common feature nodes. You can 
also search for information: press F1 to open the Help window or Ctrl+F1 
to open the Documentation window.

Theory for Moisture Transport
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Feature Nodes for the Moisture Transport in Air Interface

This section details the nodes available with The Moisture Transport in Air Interface 
with default settings:

• Domain Nodes for the Moisture Transport in Air Interface

• Boundary Nodes for the Moisture Transport in Air Interface

D O M A I N  N O D E S  F O R  T H E  M O I S T U R E  TR A N S P O R T  I N  A I R  I N T E R F A C E

The Moisture Transport in Air Interface has the following domain nodes:

B O U N D A R Y  N O D E S  F O R  T H E  M O I S T U R E  TR A N S P O R T  I N  A I R  I N T E R F A C E

The Moisture Transport in Air Interface has the following boundary nodes:

• Building Material

• Initial Values

• Moist Air

• Moisture Source

• Continuity

• Insulation

• Moist Surface

• Moisture Content

• Moisture Flux

• Outflow

• Symmetry

• Thin Moisture Barrier

• Wet Surface
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 6
T h e  H e a t  T r a n s f e r  F e a t u r e s
The Heat Transfer Interfaces have domain, boundary, edge, point, and pair nodes 
and subnodes (including out-of-plane and layer features) available. These nodes, 
listed in alphabetical order in this section, are available from the Physics ribbon 
toolbar (Windows users), from the Physics context menu (Mac or Linux users), or 
by right-clicking to access the context menu (all users). Subnodes are available by 
right-clicking the parent node and selecting it from the Attributes menu.

In this section:

• Domain Features

• Boundary Features

• Edge Features

• Point Features

• Global Features
 349
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Doma i n  F e a t u r e s

The Heat Transfer interfaces have the following domain nodes and subnodes available: 

Bioheat

This feature provides the source terms that represent blood perfusion and metabolism 
to model heat transfer in biological tissue using the bioheat equation:

• Bioheat

• Biological Tissue

• Building Material

• Change Cross Section

• Change Thickness

• Fluid

• Geothermal Heating

• Heat Source

• Immobile Fluids

• Initial Values

• Irreversible Transformation

• Isothermal Domain

• Moist Air

• Opacity

• Out-of-Plane Heat Flux

• Out-of-Plane Radiation

• Phase Change Material

• Porous Medium

• Pressure Work

• Radiation in Participating Media 
(Heat Transfer Interface)

• Radiation in Participating Media 
(RPM Interface)

• Solid

• Thermal Dispersion

• Thermoelastic Damping

• Translational Motion

• Viscous Dissipation

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

ρbCp b, ωb Tb T–( ) Qmet+
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Enter values or expressions for these properties and source terms:

• Arterial blood temperature Tb, which is the temperature at which blood leaves the 
arterial blood veins and enters the capillaries. T is the temperature in the tissue, 
which is the dependent variable that is solved for and not a material property. 

• Specific heat, blood Cp, b, which describes the amount of heat energy required to 
produce a unit temperature change in a unit mass of blood. 

• Blood perfusion rate ωb (SI unit: 1/s, which in this case means (m3/s)/m3), 
describes the volume of blood per second that flows through a unit volume of tissue.

• Density, blood ρb, which is the mass per volume of blood.

• Metabolic heat source Qmet, which describes heat generation from metabolism. 
Enter this quantity as the unit power per unit volume.

L O C A T I O N  I N  U S E R  I N T E R F A C E

A default Bioheat node is automatically added to the Biological Tissue node. 

Context menus
Bioheat Transfer>Biological Tissue>Bioheat

More locations are available if the Heat transfer in biological tissue check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Biological Tissue>Bioheat

Ribbon
Physics Tab with Biological Tissue selected in the model tree:
Attributes>Bioheat

Hepatic Tumor Ablation: Application Library path 
Heat_Transfer_Module/Medical_Technology/tumor_ablation

Microwave Heating of a Cancer Tumor: Application Library path 
Heat_Transfer_Module/Medical_Technology/microwave_cancer_therapy

Modeling a Conical Dielectric Probe for Skin Cancer Diagnosis: 
Application Library path 
Heat_Transfer_Module/Medical_Technology/conical_dielectric_probe
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Biological Tissue

This node adds the bioheat equation as the mathematical model for heat transfer in 
biological tissue. This equation can include source terms representing blood perfusion 
and metabolism using Pennes’ approximation, through the addition of a Bioheat 
subnode; see Equation 4-19. Optionally it can define a damage model to account for 
overheating or freezing in tissues.

H E A T  C O N D U C T I O N ,  S O L I D

The default Thermal conductivity k uses values From material. For User defined select 
Isotropic, Diagonal, Symmetric, or Anisotropic based on the characteristics of the thermal 
conductivity and enter another value or expression in the field or matrix.

T H E R M O D Y N A M I C S ,  S O L I D

The default Density ρ and Heat capacity at constant pressure Cp are taken From material. 
See Material Density in Features Defined on the Material Frame if a 
temperature-dependent density should be set.

The heat capacity describes the amount of heat energy required to produce a unit 
temperature change in a unit mass. 

For User defined enter other values or expressions.

D A M A G E D  T I S S U E

Select the Include damage integral analysis check box to account for overheating or 
freezing in tissues with a damage model. 

Two methods are available for the analysis; choose Damage integral form: Temperature 

threshold (the default) or Energy absorption. Depending to the material properties you 
have access to, you may choose one of the damage models.

The Energy absorption method is only applicable to hyperthermia analysis.

For Temperature threshold, define the settings for the Hyperthermia Analysis and 
Cryogenic Analysis. See First Form Integral for more details on the parameters of the 
model.

Hyperthermia Analysis
Enter values for:

• Damage temperature Td, h to define the (high) temperature that the tissue needs to 
reach to start getting damaged. The default is 323.15 K. 
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• Damage time td, h to define the time needed for the necrosis to happen while the 
temperature is above Td, h. The default is 50 s.

• Temperature of necrosis Tn, h to define the (high) temperature to be reached for the 
necrosis to happen instantly. The default is 373.15 K. 

• Enthalpy change Ld, h to define the enthalpy variation associated with damage by 
hyperthermia. The following heat source is added to the right-hand side of the 
bioheat equation:

Cryogenic Analysis
Enter values for:

• Damage temperature Td, c to define the (low) temperature that the tissue needs to 
reach to start getting damaged. The default is 273.15 K. 

• Damage time td, c to define the time needed for the necrosis to happen while the 
temperature is below Td, c. The default is 50 s.

• Temperature of necrosis Tn, c to define the (low) temperature to be reached for the 
necrosis to happen instantly. The default is 253.15 K. 

• Enthalpy change Ld, c to define the enthalpy variation associated with damage by 
freezing. The following heat source is added to the right-hand side of the bioheat 
equation:

For Energy absorption, define the Frequency Factor and Activation Energy to compute 
the degree of tissue injury with the Arrhenius equation. See Second Form Integral for 
more details.

Frequency Factor and Activation Energy
Enter values for:

• Frequency factor A in the Arrhenius equation. Default is taken From material. For 
User defined enter a value or an expression. The default is 7.39 ⋅ 1039 s–1. 

• Activation energy ΔE in the Arrhenius equation. Default is taken From material. For 
User defined enter a value or an expression. The default is 2.577 ⋅ 105 J/mol.

• Enthalpy change L to define the enthalpy variation associated with damage. The 
following heat source is added to the right-hand side of the bioheat equation: 

Q ρLd h,
∂θd
∂t

--------- T Td h,>( )–=

Q ρLd c,
∂θd
∂t

--------- T Td c,<( )=
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As required, also define how to Specify Different Material Properties for healthy and 
damaged tissue.

Specify Different Material Properties
When the Specify different material properties for damaged tissue check box is selected, 
choose a Damaged material, which can point to any material in the model. The default 
uses the Domain material. The healthy tissue properties correspond to the properties 
specified in the Heat Conduction, Solid and Thermodynamics, Solid sections. The effective 
tissue properties change from the healthy tissue properties to the damaged tissue 
properties as the damage evolves. 

H E A T  C O N D U C T I O N ,  D A M A G E D  T I S S U E

This section is available when the Specify different material properties for damaged tissue 
check box is selected.

Select a Thermal conductivity kd —From material (the default) or User defined, to be 
used for damaged tissue. For User defined choose Isotropic, Diagonal, Symmetric, or 
Anisotropic based on the characteristics of the thermal conductivity and enter another 
value or expression in the field or matrix. 

T H E R M O D Y N A M I C S ,  D A M A G E D  T I S S U E

This section is available when the Specify different material properties for damaged tissue 
check box is selected.

Select a Density ρd and Heat capacity at constant pressure Cp, d —From material (the 
default) or User defined, to be used for damaged tissue. The heat capacity describes the 
amount of heat energy required to produce a unit temperature change in a unit mass.

Q ρL
∂θd
∂t

---------–=

Theory for Bioheat Transfer

Damaged Tissue
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Bioheat Transfer>Biological Tissue

More locations are available if the Heat transfer in biological tissue check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Biological Tissue

Ribbon
Physics Tab with interface as Heat Transfer, Bioheat Transfer, Heat Transfer in Solids, 
Heat Transfer in Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Domains>interface>Biological Tissue

When Surface-to-surface radiation is activated, the Opacity subnode is 
automatically added to the entire selection, with Opaque option selected. 
The domain selection can’t be edited. To set some part of the domain as 
transparent, add a new Opacity subnode from the context menu 
(right-click the parent node) or from the Physics toolbar, Attributes menu. 

There are specific predefined materials available in the Bioheat material 
database. See Materials Overview and Bioheat Materials Database in the 
COMSOL Multiphysics Reference Manual.

Hepatic Tumor Ablation: Application Library path 
Heat_Transfer_Module/Medical_Technology/tumor_ablation

Microwave Heating of a Cancer Tumor: Application Library path 
Heat_Transfer_Module/Medical_Technology/microwave_cancer_therapy

Modeling a Conical Dielectric Probe for Skin Cancer Diagnosis: 
Application Library path 
Heat_Transfer_Module/Medical_Technology/conical_dielectric_probe
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Building Material

Use this node to model a building material as a porous medium containing a mixture 
of liquid water and vapor. The overall material properties change due to moisture 
transfer is accounted for through an apparent thermal conductivity change and a heat 
source or sink given in the divergence operator in function of the latent heat of 
evaporation:

 (6-1)

 (6-2)

with the following material properties, fields, and source:

• (ρCp)eff (SI unit: J/(m3·K)) is the effective volumetric heat capacity at constant 
pressure.

• keff (SI unit: W/(m·K)) is the effective thermal conductivity (a scalar or a tensor if 
the thermal conductivity is anisotropic).

• Lv (SI unit: J/kg) is the latent heat of evaporation.

• δp (SI unit: s) is the vapor permeability.

• φ (dimensionless) is the relative humidity.

• psat (SI unit: Pa) is the vapor saturation pressure.

• Q (SI unit: W/m3) is the heat source (or sink). Add one or several heat sources as 
separate physics features. See Heat Source node for example.

For a steady-state problem the temperature does not change with time and the first 
term disappears.

M O D E L  I N P U T S

This section has fields and values that are inputs to expressions that define material 
properties. If such user-defined property groups are added, the model inputs appear 
here.

Relative humidity
This section has an input for the definition of the relative humidity, used in the right 
hand side of Equation 6-2.

The default Relative humidity φ is User defined. When additional physics interfaces are 
added to the model, the relative humidity variables defined by these physics interfaces 

ρCp( )eff
∂T
∂t
------- ∇ q⋅+ Q=

q keff∇T Lvδp φpsat( )∇+( )–=
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can also be selected from the list. For example, if a Moisture Transport interface is 
added, you can select Relative humidity (mt/pm1) from the list.

If the node was added automatically after selecting the predefined multiphysics 
interface Heat and Moisture Transport, the relative humidity of the multiphysics node 
Heat and Moisture is used by default and the section is not editable. To edit the Relative 

humidity field, click Make All Model Inputs Editable ( ).

H E A T  C O N D U C T I O N

This section provides two options for the definition of the effective thermal 
conductivity keff:

• When Equivalent thermal conductivity is selected (the default), a value for the 
Effective thermal conductivity keff should be specified directly. The default Effective 

thermal conductivity is taken From material. For User defined, select Isotropic, 
Diagonal, Symmetric, or Anisotropic based on the characteristics of the thermal 
conductivity, and enter another value or expression. For Isotropic enter a scalar 
which will be used to define a diagonal tensor. For the other options, enter values 
or expressions into the editable fields of the tensor.

• When Dry material thermal conductivity is selected, the effective thermal 
conductivity is defined in function of the solid matrix and moisture properties:

This definition neglects the contribution due to the volume fraction change of the 
moist air.

The Dry solid thermal conductivity ks (SI unit: W/(m·K)) and the Thermal 

conductivity supplement b (dimensionless) should be specified. The default Dry solid 

thermal conductivity and Thermal conductivity supplement are taken From material. 
For User defined, enter values or expressions into the editable fields.

The Density ρs and the Moisture storage function w are specified in the 
Thermodynamics, Dry Solid and Building Material Properties sections respectively.

T H E R M O D Y N A M I C S ,  D R Y  S O L I D

This section sets the thermodynamics properties of the dry solid.

The specific heat capacity describes the amount of heat energy required to produce a 
unit temperature change in a unit mass of the dry solid material.

keff ks 1 bw
ρs
--------+ 

 =
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The Density ρs and the Specific heat capacity Cp,s should be specified. The default 
Density and Specific heat capacity are taken From material. For User defined, enter values 
or expressions into the editable fields.

The effective volumetric heat capacity at constant pressure is defined to account for 
both solid matrix and moisture properties:

where

• ρs (SI unit: kg/m3) is the dry solid density.

• Cp,s (SI unit: J/(kg·K)) is the dry solid specific heat capacity.

• w (SI unit: kg/m3) is the water content given by a moisture storage function.

• Cp,w (SI unit: J/(kg·K)) is the water heat capacity at constant pressure.

B U I L D I N G  M A T E R I A L  P R O P E R T I E S

This section sets the properties of the building material for moisture storage and vapor 
diffusion.

The Moisture storage function w should be set to characterize the relationship between 
the amount of accumulated water and the relative humidity in the material. The default 
Moisture storage function is taken From material. For User defined, enter another value 
or expression.

Two options are available for the specification of the building material properties for 
vapor diffusion:

• Vapor permeability (default) to define directly the vapor permeability δp. The default 
Vapor permeability is taken From material. For User defined, enter another value or 
expression.

• Vapor resistance factor μ to define the vapor permeability δp as:

where δ (SI unit: s) is the vapor permeability of still air. The default Vapor resistance 

factor is taken From material. For User defined, enter another value or expression.

If the node was added automatically after selecting the predefined multiphysics 
interface Heat and Moisture Transport, the building material properties of the 
multiphysics node Heat and Moisture are used by default and the inputs are not editable. 

ρCp( )eff ρsCp s, wCp w,+=

δp
δ
μ
---=
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To edit these fields, click Make All Model Inputs Editable ( ) in the Model Inputs 
section.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Building Materials>Building Material

More locations are available if the Heat transfer in porous media check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Building Material

The Heat Transfer in Building Materials Interface

The Heat and Moisture Transport Interfaces

Heat and Moisture

See Building Materials Database in the COMSOL Multiphysics Reference 
Manual for a description of materials containing the thermal and 
hygroscopic properties required by the Building Material node.

The Building Material node is defined on the spatial frame. The material 
properties should be entered in the spatial frame, and the coupling with 
a moving frame interface is not supported. See Handling Frames in Heat 
Transfer for more details.

When Surface-to-surface radiation is activated, the Opacity subnode is 
automatically added to the entire selection, with Opaque option selected. 
The domain selection can’t be edited. To set some part of the domain as 
transparent, add a new Opacity subnode from the context menu 
(right-click the parent node) or from the Physics toolbar, Attributes menu. 

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Domains>interface>Building Material

Change Cross Section

Use this node with 1D components to model domains with another cross sectional 
area or another cross sectional perimeter than the global one that is used in the Heat 
Transfer interface Physical Model section. In 1D geometries, the temperature is 
assumed to be constant in the radial direction, and the heat equation is modified to 
account for that. See Equation 4-123 and Equation 4-124.

C H A N G E  C R O S S  S E C T I O N

Enter values for the Cross sectional area Ac and the Cross sectional perimeter Pc to set 
the cross section of the domain in the plane perpendicular to the 1D geometry. 

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Change Cross Section
Heat Transfer in Solids>Change Cross Section
Heat Transfer in Fluids>Change Cross Section
Heat Transfer in Porous Media>Change Cross Section
Heat Transfer in Building Materials>Change Cross Section
Bioheat Transfer>Change Cross Section
Heat Transfer with Surface-to-Surface Radiation>Change Cross Section

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Bioheat Transfer, Heat Transfer with 

Surface-to-Surface Radiation or Heat Transfer with Radiation in Participating Media 

selected:
Domains>interface>Change Cross Section

Out-of-Plane Heat Transfer
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Change Thickness

Use this node with 2D components to model domains with another thickness than the 
overall thickness that is specified in the Heat Transfer interface Physical Model section. 
In 2D geometries, the temperature is assumed to be constant in the out-of-plane 
direction (z direction with default spatial coordinate names). The heat equation is 
modified to account for that. See Equation 4-119 and Equation 4-120.

C H A N G E  T H I C K N E S S

Specify a value for the Thickness dzof the domain in the out-of-plane direction. This 
value replaces the overall thickness in the domains that are selected in the Domain 

Selection section, and is used to multiply some terms into the heat equation.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Change Thickness
Heat Transfer in Solids>Change Thickness
Heat Transfer in Fluids>Change Thickness
Heat Transfer in Porous Media>Change Thickness
Heat Transfer in Building Materials>Change Thickness
Bioheat Transfer>Change Thickness
Heat Transfer with Surface-to-Surface Radiation>Change Thickness
Heat Transfer with Radiation in Participating Media>Change Thickness

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Domains>interface>Change Thickness

Fluid

This node uses the following version of the heat equation to model heat transfer in 
fluids:

Out-of-Plane Heat Transfer
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 (6-3)

with the following material properties, fields, and sources:

• ρ (SI unit: kg/m3) is the fluid density.

• Cp (SI unit: J/(kg·K)) is the fluid heat capacity at constant pressure.

• k (SI unit: W/(m·K)) is the fluid thermal conductivity (a scalar or a tensor if the 
thermal conductivity is anisotropic).

• u (SI unit: m/s) is the fluid velocity field, either an analytic expression or a velocity 
field from a Fluid Flow interface.

• Q (SI unit: W/m3) is the heat source (or sink). Add one or several heat sources as 
separate physics features. See Heat Source node, and Viscous Dissipation and 
Pressure Work subnodes for example.

For a steady-state problem the temperature does not change with time and the first 
term disappears.

M O D E L  I N P U T S

This section has fields and values that are inputs to expressions that define material 
properties. If such user-defined property groups are added, the model inputs appear 
here.

Temperature
This section is available when temperature-dependent material properties are used. By 
default the temperature of the parent interface is used and the section is not editable. 
To edit the Temperature field, click Make All Model Inputs Editable ( ). The available 
options are User defined (default) and all temperature variables from the physics 
interfaces included in the model. These physics interfaces have their own tags (the 
Name). For example, if a Heat Transfer in Fluids interface is included in the model, the 
Temperature (ht) option is available.

Absolute Pressure
The absolute pressure is used in some predefined quantities that include the enthalpy 
(the energy flux, for example).

It is also used if the ideal gas law is applied. See Thermodynamics, Fluid.

The default Absolute pressure pA is User defined. When additional physics interfaces are 
added to the model, the absolute pressure variables defined by these physics interfaces 

ρCp
∂T
∂t
------- ρCpu ∇T⋅+ ∇ q⋅+ Q=

q k∇– T=
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can also be selected from the list. For example, if a Laminar Flow interface is added you 
can select Absolute pressure (spf) from the list.

Velocity Field
The default Velocity field u is User defined. For User defined enter values or expressions 
for the components based on space dimensions. Or select an existing velocity field in 
the component (for example, Velocity field (spf) from a Laminar Flow interface).

Concentration
From the Concentration c (SI unit: mol/m3 or kg/m3) list, select an existing 
concentration variable from another physics interface, if any concentration variables 
exist, or select User defined to enter a value or expression for the concentration. This 
section can be edited anytime a material property is concentration dependent; for 
example, when the Fluid type is set to Moist air with Input quantity set to Concentration.

F L U I D  M A T E R I A L

This section is available only when the Local Thermal Non-Equilibrium multiphysics 
coupling is included in the component to model porous media. It makes it possible to 
define different material properties for the fluid phase when the domain material 
corresponds to the solid phase (porous matrix) material.

Select any material from the list to define the Fluid material. The default uses the 
Domain material.

H E A T  C O N D U C T I O N ,  F L U I D

The thermal conductivity k describes the relationship between the heat flux vector q 
and the temperature gradient ∇T in q = −k∇T, which is Fourier’s law of heat 
conduction. Enter this quantity as power per length and temperature.

The default Thermal conductivity k is taken From material. For User defined select 
Isotropic, Diagonal, Symmetric, or Anisotropic based on the characteristics of the thermal 
conductivity, and enter values or expressions for the thermal conductivity or its 
components. For Isotropic enter a scalar which will be used to define a diagonal tensor. 
For the other options, enter values or expressions into the editable fields of the tensor.

T H E R M O D Y N A M I C S ,  F L U I D

This section sets the thermodynamics properties of the fluid.

The heat capacity at constant pressure Cp describes the amount of heat energy required 
to produce a unit temperature change in a unit mass. 
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The ratio of specific heats γ is the ratio of the heat capacity at constant pressure, Cp, to 
the heat capacity at constant volume, Cv. When using the ideal gas law to describe a 
fluid, specifying γ is sufficient to evaluate Cp. For common diatomic gases such as air, 
γ = 1.4 is the standard value. Most liquids have γ = 1.1 while water has γ = 1.0. γ is used 
in the streamline stabilization and in the variables for heat fluxes and total energy 
fluxes. It is also used if the ideal gas law is applied.

The available Fluid type options are Gas/Liquid (default), Moist air, and Ideal gas. After 
selecting a Fluid type from the list, further settings display underneath. 

Gas/Liquid
This option specifies the Density, the Heat capacity at constant pressure, and the Ratio 

of specific heats for a general gas or liquid. 

Ideal Gas
This option uses the ideal gas law to describe the fluid. Only two properties are needed 
to define the thermodynamics of the fluid:

• The gas constant, with two options for the Gas constant type: Specific gas constant 
Rs or Mean molar mass Mn. If Mean molar mass is selected the software uses the 
universal gas constant R = 8.314 J/(mol·K), which is a built-in physical constant, to 
compute the specific gas constant.

• Either the Heat capacity at constant pressure Cp or Ratio of specific heats γ by 
selecting the option from the Specify Cp or γ list. For an ideal gas, it is sufficient to 
specify either Cp or the ratio of specific heats, γ, as these properties are 
interdependent.

Moist Air
If Moist air is selected, the thermodynamics properties are defined as a function of the 
quantity of vapor in the moist air. The available Input quantity options to define the 
amount of vapor in the moist air are the following:

• Vapor mass fraction to define the ratio of the vapor mass to the total mass. Enter a 
value or expression for the Vapor mass fraction ω.

• Concentration to define the amount of water vapor in the total volume. If selected, 
a Concentration model input is added in the Model Inputs section.

• Moisture content (the default), also called mixing ratio or humidity ratio, to define 
the ratio of the water vapor mass to the dry air mass. For User defined, enter a value 
or expression for the Moisture Content xvap. Else, select an Ambient moisture content 

defined from the Ambient Settings section of a Heat Transfer or Heat Transfer in 
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Shells interface.

• Relative humidity, by defining the Reference relative humidity at Reference 

temperature and Reference pressure. The Reference relative humidity is a quantity 
defined between 0 and 1, where 0 corresponds to dry air and 1 to a water 
vapor-saturated air. For User defined, enter a value or expression for the Reference 

relative humidity φref. Else, select an Ambient relative humidity defined in the 
Ambient Settings section of a Heat Transfer or Heat Transfer in Shells interface. For 
consistency, the Reference temperature and Reference pressure should also be taken 
from ambient conditions.

D Y N A M I C  V I S C O S I T Y

This section is only available when the Equivalent conductivity for convection check box 
is selected in the Equivalent conductivity for convection section. The Dynamic viscosity μ 
is then used to compute the Nusselt number. 

E Q U I V A L E N T  C O N D U C T I V I T Y  F O R  C O N V E C T I O N

When the Equivalent conductivity for convection check box is selected, the fluid thermal 
conductivity is increased according to the Nusselt number to account for the 
contribution of the convective heat flux. In addition the user-defined or predefined 
velocity model input is ignored and the fluid velocity is set to zero. This check box is 
not selected by default and requires the Heat Transfer Module.

The options in the Nusselt number correlation list are:

• Horizontal cavity heated from below, for which values for the Cavity height H and the 
Temperature difference ΔT should be specified for the computation of the Nusselt 
number.

• Vertical rectangular cavity, for which values for the Cavity height H, the Plate distance 
L, and the Temperature difference ΔT should be specified for the computation of the 
Nusselt number. 
Select Automatic (default) or User defined to define the Temperature difference ΔT. 
When Automatic is selected the temperature difference is evaluated as the difference 
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between the maximal and the minimal temperature on the exterior boundaries of 
the feature selection.

• User defined, for which a value for Nu should be specified directly.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Fluid
Heat Transfer in Solids>Fluid
Heat Transfer in Fluids>Fluid
Heat Transfer in Porous Media>Fluid
Heat Transfer in Building Materials>Fluid

Moist Air Fluid Type

Local Thermal Non-Equilibrium 

Theory for Heat Transfer in Fluids

Equivalent Thermal Conductivity Correlations

With certain COMSOL products, the Viscous Dissipation (for heat 
generated by viscous friction) and Pressure Work subnodes are available 
from the context menu (right-click the parent node) or from the Physics 
toolbar, Attributes menu.

When Surface-to-surface radiation is activated, the Opacity subnode is 
automatically added to the entire selection, with Transparent option 
selected. The domain selection can’t be edited. To set some part of the 
domain as opaque, add a new Opacity subnode from the context menu 
(right-click the parent node) or from the Physics toolbar, Attributes menu. 

Heat Sink: Application Library path 
Heat_Transfer_Module/Tutorials,_Forced_and_Natural_Convection/heat_sink

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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Bioheat Transfer>Fluid
Heat Transfer with Surface-to-Surface Radiation>Fluid
Heat Transfer with Radiation in Participating Media>Fluid

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Domains>interface>Fluid

Geothermal Heating

Use this node to account for the contribution of geothermal heat production by 
adding a source term Qgeo to the right-hand side of the heat equation:

The predefined expression of the heat source uses the Geothermal Density, the 
Radiogenic heating per unit mass, and a distribution function that can be set.

G E O T H E R M A L  H E A T  P R O D U C T I O N

Specify the Radiogenic heating per unit mass qgeo. 

The two option buttons in the same group control the distribution function f(zgeo):

• If Uniform distribution is selected, f(zgeo) = 1 and the geothermal heat source is 
assumed to be independent on depth.

• If Exponential distribution is selected, two additional input fields are displayed 
underneath. The exponential distribution f(zgeo) = exp(zgeo ⁄ hgeo), is defined by the 
constant Length scale: hgeo and the variable Depth zgeo. The depth can be, for 
example, the vertical coordinate direction. The heat source achieves its maximum 
value where zgeo = 0, typically the top surface of a model. 

G E O T H E R M A L  D E N S I T Y

Select the Geothermal density: Solids, Porous media, or User defined:

• If Solids is selected, it calculates the geothermal density based on the volume fraction 
of solid material

Qgeo ρgeoqgeof zgeo( )=
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• If Porous media is selected, it calculates the geothermal density based on all mobile 
and immobile components of the porous medium:

• If User defined is selected, enter a value for the Geothermal density ρgeo.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
If the Porous matrix model is set to Extended under the Physical Model section:
Heat Transfer in Porous Media>Porous Medium>Geothermal Heating

More locations are available if the Heat transfer in porous media check box is selected 
and Porous matrix model is set to Extended under the Physical Model section. For 
example:
Heat Transfer in Solids>Porous Medium>Geothermal Heating

Ribbon
Physics Tab with Porous Medium selected in the model tree:
Attributes>Porous Medium>Geothermal Heating

Heat Source

This node describes heat generation within the domain. You express heating and 
cooling with positive and negative values, respectively. Add one or more nodes as 
needed — all heat sources within a domain contribute to the total heat source. 

The Heat Source node adds a source term Q to the right-hand side of the heat equation:

ρgeo

θpiρpi

i


θpi

i


------------------------=

ρgeo θpiρpi θgiρgi

i
 θLρL+ +

i
=

The Geothermal Heating subnode requires the Subsurface Flow Module. 
For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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Specify Q0 as the heat per unit volume, as a linear heat source, or as a heat rate.

H E A T  S O U R C E

Click the General source (the default), Linear source, or Heat rate buttons.

• For General source enter a value for the distributed heat source Q0 when the default 
option (User defined) is selected. See also Additional General Source Options to use 
predefined heat sources available from other interfaces.

• For Linear source enter a value for the Production/absorption coefficient qs used in the 
predefined linear expression. The advantage of writing the source on this form is 
that it can be accounted for in the streamline diffusion stabilization. The 
stabilization applies when qs is independent of the temperature, but some stability 
can be gained as long as qs is only weakly dependent on the temperature.

• For Heat rate enter a value for the heat rate P0. In this case Q0 = P0 ⁄ V, where V is 
the total volume of the selected domains.

Additional General Source Options
For the general heat source Q0 there are predefined heat sources available (in addition 
to a User defined heat source) when simulating heat transfer together with electrical or 
electromagnetic interfaces. Such sources represent, for example, ohmic heating and 
induction heating. Depending on additional physics interfaces, the following are 
available:

• With the addition of an Electric Currents interface, the Total power dissipation 

density (ec) heat source is available from the General source list.

• With the addition of any version of the Electromagnetic Waves interface (which 
requires the RF Module), the Total power dissipation density (emw) and 
Electromagnetic power loss density (emw) heat sources are available from the General 

source list.

• With the addition of a Magnetic Fields interface (a 3D component requires the 
AC/DC Module), the Electromagnetic heating (mf) heat source is available from the 
General source list.

• With the addition of a Magnetic and Electric Fields interface (which requires the 
AC/DC Module), the Electromagnetic heating (mef) heat source is available from the 
General source list.

• For the Heat Transfer in Porous Media interface, with the addition of interfaces 
from the Batteries & Fuel Cells Module, Corrosion Module, or Electrodeposition 

Q Q0=
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Module, heat sources from the electrochemical current distribution interfaces are 
available.

F R A M E  S E L E C T I O N

To display this section, add both a Heat Transfer (ht) and a Moving Mesh (ale) interface 
(found under the Mathematics>Deformed Mesh branch when adding a physics 
interface). Then click the Show button ( ) and select Advanced Physics Options.

When the model contains a moving mesh, the Enable conversions between material and 

spatial frame check box is selected by default in the Heat Transfer interface, which in 
turn enables further options. Use Frame Selection to select the frame where the input 
variables are defined. If Spatial is selected, the variables take their values from the text 
fields. If Material (the default) is selected, a conversion from the material to the spatial 
frame is applied to the text field values.

• Handling Frames in Heat Transfer

• Stabilization Techniques in the COMSOL Multiphysics Reference 
Manual

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.

For the definition of a localized heat source, see Line Heat Source, Line 
Heat Source and Point Heat Source.

For the definition of a heat on a boundary, see Boundary Heat Source.

Forced Convection Cooling of an Enclosure with Fan and Grille: 
Application Library path 
Heat_Transfer_Module/Power_Electronics_and_Electronic_Cooling/electronic

_enclosure_cooling
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Heat Source
Heat Transfer in Solids>Heat Source
Heat Transfer in Fluids>Heat Source
Heat Transfer in Porous Media>Heat Source
Heat Transfer in Building Materials>Heat Source
Bioheat Transfer>Heat Source
Heat Transfer with Surface-to-Surface Radiation>Heat Source
Heat Transfer with Radiation in Participating Media>Heat Source

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Domains>interface>Heat Source

Immobile Fluids

This node should be used to model an unsaturated porous matrix for which the pore 
space is not filled with liquid and contains one or more gas considered as immobile 
fluids; or a porous matrix containing insulated enclosures.

It is possible to add and define up to five different immobile fluids and volume 
fractions to the porous matrix.

I M M O B I L E  F L U I D S

In this section, the Number of fluids to define — 1, 2, 3, 4, or 5 — is set. Depending on 
the Number of fluids, further settings display underneath. For each fluid: 

• The material must be set from the Fluid material list, which can point to any material 
in the model.

• The Volume fraction of the immobile fluid θg {1,2,3,4,5} should be set.

The total volume fraction of immobile fluids is calculated from

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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The volume fraction available for mobile fluids (that is, the effective porosity) is then 
calculated from

where the total volume fraction of immobile solids is calculated from

H E A T  C O N D U C T I O N

For the same number of fluids selected under Immobile Fluids, the defaults for the 
Thermal conductivity kg use values From material. For User defined select Isotropic, 
Diagonal, Symmetric, or Anisotropic based on the characteristics of the thermal 
conductivity and other values or expressions in the fields or matrices.

The effective conductivity for the equivalent immobile fluid is calculated from

When one or more than one solid is selected in the Immobile Solids section, the effective 
conductivity of immobile solids and immobile fluids can be calculated in three different 
ways:

• If Volume average is selected under Effective Thermal Conductivity, the effective 
conductivity of the solid-fluid system is given by

where kp and kg are the effective conductivities of immobile solids and fluids.

• If Reciprocal average is selected under Effective Thermal Conductivity, the effective 
conductivity is calculated from

θg θgi

i
=

θL 1 θp θg––=

θp θpi

i
=

kg θgikgi

i
=

keff θpkp θgkg θL+ kL+=
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where kp and kg are the effective conductivities of immobile solids and fluids.

• If Power law is selected under Effective Thermal Conductivity, the effective 
conductivity is calculated from

where kp and kg are the effective conductivities of immobile solids and fluids.

T H E R M O D Y N A M I C S

For the same number of fluids selected under Immobile Fluids, the following properties 
should be set:

• Density ρg{1,2,3,4,5}

• Specific heat capacity Cp,g{1,2,3,4,5} 

The effective volumetric heat capacity of the composite solid-fluid system is defined as

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
If the Porous matrix model is set to Extended under the Physical Model section:
Heat Transfer in Porous Media>Porous Medium>Immobile Fluids

More locations are available if the Heat transfer in porous media check box is selected 
and Porous matrix model is set to Extended under the Physical Model section. For 
example:
Heat Transfer in Solids>Porous Medium>Immobile Fluids

1
keff
---------

θp
kp
------

θg
kg
------

θL
kL
------+ +=

keff kp
θp kg

θg kL
θL⋅ ⋅=

ρCp( )eff θpiρpiCp pi, θgiρgiCp gi,
i
+

i
 θLρLCp L,+=

The Immobile Fluids node requires the Subsurface Flow Module. For a 
detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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Ribbon
Physics Tab with Porous Medium selected in the model tree:
Attributes>Porous Medium>Immobile Fluids

Initial Values

This node adds an initial value for the temperature that can serve as an initial condition 
for a transient simulation or as an initial guess for a nonlinear solver. In addition to the 
default Initial Values node always present in the interface, you can add more Initial 

Values nodes if needed.

I N I T I A L  V A L U E S

For User defined, enter a value or expression for the initial value of the Temperature T 
(SI unit: K). The default value is approximately room temperature, 293.15 K (20 ºC). 
Else, select an Ambient temperature defined in the Ambient Settings section of a Heat 
Transfer or Heat Transfer in Shells interface.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Initial Values
Heat Transfer in Solids>Initial Values
Heat Transfer in Fluids>Initial Values
Heat Transfer in Porous Media>Initial Values
Heat Transfer in Building Materials>Initial Values
Bioheat Transfer>Initial Values
Heat Transfer with Surface-to-Surface Radiation>Initial Values
Heat Transfer with Radiation in Participating Media>Initial Values

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Domains>interface>Initial Values

Isothermal Domain

This node should be used when the temperature shows sufficiently small spatial 
fluctuations to be considered homogeneous in space but not necessarily in time. 
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I S O T H E R M A L  D O M A I N

Two options are available for the Temperature definition into the Isothermal Domain:

• If From heat balance (the default) is selected, the temperature is computed as the 
solution of a reduced form of the heat equation due to spatial homogeneity. See 
Equation 4-32.

• If From prescribed temperature is selected, the temperature is set to the domain 
Temperature T0 that needs to be specified. For User defined, enter a value or 
expression for the Temperature T0. Else, select an Ambient temperature defined in 
the Ambient Settings section of a Heat Transfer or Heat Transfer in Shells interface.

T H E R M O D Y N A M I C S

The thermodynamics properties of the Isothermal Domain are set in this section. Two 
options are available for the Mass definition:

• If Density is selected, the Density ρ should be specified.

• If Total mass is selected, the Mass m should be specified.

Finally the Heat capacity at constant pressure Cp should be specified. 

It is not possible to couple an Isothermal Domain with the Laminar Flow 
interface through the Nonisothermal Flow multiphysics condition.

The following conditions of heat exchange can be applied at isothermal 
domain interfaces: thermal insulation, continuity, ventilation, convective 
heat flux, and thermal contact. See Isothermal Domain Interface for more 
details.

Also see Theory for Lumped Isothermal Domain.

When Surface-to-surface radiation is activated, the Opacity subnode is 
automatically added to the entire selection, with Transparent option 
selected. The domain selection can’t be edited. To set some part of the 
domain as opaque, add a new Opacity subnode from the context menu 
(right-click the parent node) or from the Physics toolbar, Attributes menu. 
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
If the Isothermal domain check box is selected under the Physical Model section:
Heat Transfer>Isothermal Domain

Heat Transfer in Solids>Isothermal Domain

Heat Transfer in Fluids>Isothermal Domain

Heat Transfer in Porous Media>Isothermal Domain

Heat Transfer in Building Materials>Isothermal Domain

Bioheat Transfer>Isothermal Domain

Heat Transfer with Surface-to-Surface Radiation>Isothermal Domain

Heat Transfer with Radiation in Participating Media>Isothermal Domain

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Domains>interface>Isothermal Domain

Moist Air

This node should be used to model heat transfer by convection and diffusion in moist 
air, by using moisture-dependent thermodynamics properties. It solves Equation 6-3, 
with the density ρ (SI unit: kg/m3), the heat capacity at constant pressure Cp (SI unit: 
J/(kg·K)), and the thermal conductivity k (SI unit: W/(m·K)) defined as a function of 
the quantity of vapor in the moist air. 

M O D E L  I N P U T S

This section has fields and values that are inputs to expressions that define material 
properties. If such user-defined property groups are added, the model inputs appear 
here.

Natural Convection Cooling of a Vacuum Flask: Application Library 
path 
Heat_Transfer_Module/Tutorials,_Forced_and_Natural_Convection/vacuum_fl

ask
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Absolute Pressure
The default Absolute pressure pA is User defined. When additional physics interfaces are 
added to the model, the absolute pressure variables defined by these physics interfaces 
can also be selected from the list. For example, if a Laminar Flow interface is added you 
can select Absolute pressure (spf) from the list.

Velocity Field
The default Velocity field u is User defined. For User defined enter values or expressions 
for the components based on space dimensions. Or select an existing velocity field in 
the component (for example, Velocity field (spf) from a Laminar Flow interface).

Concentration
From the Concentration c (SI unit: mol/m3 or kg/m3) list, select an existing 
concentration variable from another physics interface, if any concentration variables 
exist, or select User defined to enter a value or expression for the concentration. This 
section can be edited anytime a material property is concentration dependent; for 
example, when the Input quantity is set to Concentration.

T H E R M O D Y N A M I C S ,  F L U I D

The available Input quantity options to define the amount of vapor in the moist air are 
the following:

• Vapor mass fraction ω to define the ratio of the vapor mass to the total mass. 

• Concentration to define the amount of water vapor in the total volume. If selected, 
a Concentration model input is added in the Model Inputs section.

• Moisture content xvap, also called mixing ratio or humidity ratio, to define the ratio 
of the water vapor mass to the dry air mass. 

• Relative humidity φref (the default), a quantity defined between 0 and 1, where 0 
corresponds to dry air and 1 to a water vapor-saturated air. The Reference 

temperature and Reference pressure must be specified.

Depending on the selected Input quantity, enter values or expressions for the User 

defined option, select an ambient value (for example, an Ambient relative humidity 

defined in the Ambient Settings section of a Heat Transfer or Heat Transfer in Shells 
interface), or select a value from a Moisture Transport interface.

E Q U I V A L E N T  C O N D U C T I V I T Y  F O R  C O N V E C T I O N

When the Equivalent conductivity for convection check box is selected, the fluid thermal 
conductivity is increased according to the Nusselt number to account for the 
contribution of the convective heat flux. In addition the user-defined or predefined 
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velocity model input is ignored and the fluid velocity is set to zero. This check box is 
not selected by default and requires the Heat Transfer Module. See Equivalent 
Conductivity for Convection in Fluid node for details.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Moist Air>Moist Air
Heat Transfer in Building Materials>Moist Air

Ribbon
Physics Tab with Heat Transfer in Moist Air or Heat Transfer in Building Materials selected:
Domains>Moist Air

Moist Air Fluid Type

Theory for Heat Transfer in Fluids

Equivalent Thermal Conductivity Correlations

With certain COMSOL products, the Viscous Dissipation (for heat 
generated by viscous friction) and Pressure Work subnodes are available 
from the context menu (right-click the parent node) or from the Physics 
toolbar, Attributes menu.

When Surface-to-surface radiation is activated, the Opacity subnode is 
automatically added to the entire selection, with Transparent option 
selected. The domain selection can’t be edited. To set some part of the 
domain as opaque, add a new Opacity subnode from the context menu 
(right-click the parent node) or from the Physics toolbar, Attributes menu. 

Evaporative Cooling of Water: Application Library path 
Heat_Transfer_Module/Phase_Change/Evaporative_cooling

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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Opacity

This subnode enables to define the surface-to-surface radiation direction on 
boundaries surrounding the domains where it is defined. When several spectral bands 
are defined, the opacity can be set for all or only a selection of wavelengths.

When the Radiation direction is defined by Opacity controlled in surface-to-surface 
boundary features (Diffuse Mirror, Diffuse Surface, Prescribed Radiosity), 
surface-to-surface radiation propagates in non-opaque domains. Alternatively the 
Radiation direction can be defined using the normal orientation or on both sides of 
boundaries. In this case the Opacity node is ignored.

O P A C I T Y

Select Opaque or Transparent to set the domain’s opacity type. Depending on the 
Wavelength dependence of emissivity defined in the Radiation Settings section of the 
physics interface settings, different sections display underneath:

• When Wavelength dependence of emissivity is set to Constant in the physics interface 
settings, set the opacity for all wavelengths.

• When Wavelength dependence of emissivity is set to Solar and ambient or Multiple 

spectral bands in the physics interface settings, set the opacity for each spectral band 
by selecting the corresponding check box in Opacity on solar spectral band and 
Opacity on ambient spectral band, or Opacity on spectral band i sections. By default 
the opacity is set to the same type for all spectral bands.

The default opacity type depends on the parent node’s type. It is set to Opaque for 
Solid, Porous Medium, Biological Tissue and Building Material domain features and 
Surface-to-Surface Radiation interface; and to Transparent for Fluid, Phase Change 
Material, and Isothermal Domain domain features.

• The Wavelength dependence of emissivity is defined in the physics 
interface settings, in the Radiation Settings section.

• If this feature is combined with heat transfer in 2D and 1D, the 
thickness is assumed to be infinite for the view factor computation. The 
user-defined value for d is still used in the heat transfer equation.
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer with Surface-to-Surface Radiation>Solid>Opacity
Heat Transfer with Surface-to-Surface Radiation>Fluid>Opacity
Heat Transfer with Surface-to-Surface Radiation>Porous Medium>Opacity
Heat Transfer with Surface-to-Surface Radiation>Phase Change Material>Opacity
Heat Transfer with Surface-to-Surface Radiation>Biological Tissue>Opacity
Heat Transfer with Surface-to-Surface Radiation>Building Material>Opacity
Heat Transfer with Surface-to-Surface Radiation>Isothermal Domain>Opacity
Heat Transfer in Moist Air>Moist Air>Opacity
Surface-to-Surface Radiation>Opacity

More locations are available if the Surface-to-surface radiation check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Solid>Opacity

Ribbon
Physics Tab with Solid, Fluid, Porous Medium, Phase Change Material, Biological Tissue, 
Building Material, or Isothermal Domain selected in the model tree:
Attributes>Opacity

Physics Tab with Surface-to-Surface Radiation selected in the model tree:
Domains>Opacity

Out-of-Plane Heat Flux

Out-of-plane heat transfer mechanism is used to reduce a model geometry to 2D or 
even 1D when the temperature variation is small in one or more directions; for 
example, when the object to model is thin or slender. For the obtained 1D and 2D 
components, this node adds a heat flux q0, u for the upside heat flux and a heat flux 
q0, d for the downward heat flux to the right-hand side of the heat equation. 

For example, in 2D components, heat transfer in solids and heat transfer in fluids are 
given by Equation 6-4 and Equation 6-5:

Free Convection in a Light Bulb: Application Library path 
Heat_Transfer_Module/Thermal_Radiation/light_bulb

Thermo-Photo-Voltaic Cell: Application Library path 
Heat_Transfer_Module/Thermal_Radiation/tpv_cell
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 (6-4)

  (6-5)

The convective heat flux adds the following contribution

U P S I D E  I N W A R D  H E A T  F L U X

The available options are General inward heat flux and Convective heat flux. The settings 
are the same as for the Heat Flux node.

D O W N S I D E  I N W A R D  H E A T  F L U X

The available options are General inward heat flux and Convective heat flux. The settings 
are the same as for the Heat Flux node.

dzρCp
∂T
∂t
------- ∇– q⋅ dzQ q0+=

dzρCp
∂T
∂t
------- u ∇T⋅+ 
  ∇ q⋅ dzQ q0+ +=

q0 q0 u, q0 d,+=

q0 hu Text u, T–( ) h+ d Text d, T–( )=

See Out-of-Plane Heat Transfer for the formulation of out-of-plane heat 
transfer in 1D, 1D axisymmetric, and 2D geometries.

See also Out-of-Plane Domain Fluxes.

Upside and downside settings can be visualized by plotting the global 
normal vector (nx, ny, nz), that always points from downside to upside. 
Note that the normal vector (ht.nx, ht.ny, ht.nz) may be oriented 
differently.

See Tangent and Normal Variables in the COMSOL Multiphysics 
Reference Manual.

Out-of-Plane Heat Transfer for a Thin Plate: Application Library path 
Heat_Transfer_Module/Verification_Examples/thin_plate
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Context menus
Heat Transfer>Out-of-Plane Heat Flux
Heat Transfer in Solids>Out-of-Plane Heat Flux
Heat Transfer in Fluids>Out-of-Plane Heat Flux
Heat Transfer in Porous Media>Out-of-Plane Heat Flux
Heat Transfer in Building Materials>Out-of-Plane Heat Flux
Bioheat Transfer>Out-of-Plane Heat Flux
Heat Transfer with Radiation in Participating Media>Out-of-Plane Heat Flux

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer 
or Heat Transfer with Radiation in Participating Media selected:
Domains>interface>Out-of-Plane Heat Flux

Out-of-Plane Radiation

Out-of-plane heat transfer mechanism is used to reduce a model geometry to 2D or 
even 1D when the temperature variation is small in one or more directions; for 
example, when the object to model is thin or slender. This node models 
surface-to-ambient radiation on the upside and downside for the obtained 1D and 2D 
components. It adds the following contribution to the right-hand side of Equation 6-4 
or Equation 6-5:

 

U P S I D E  P A R A M E T E R S

Surface emissivity
The default Surface emissivity εu (a dimensionless number between 0 and 1) is taken 
From material. For User defined, it should be specified. An emissivity of 0 means that 
the surface emits no radiation at all while an emissivity of 1 means that it is a perfect 
blackbody. The default is 0.

Ambient temperature

For User defined, enter a value or expression for the Ambient temperature Tamb, u. The 
default value is approximately room temperature, 293.15 K (20 ºC). Else, select an 
Ambient temperature defined in the Ambient Settings section of a Heat Transfer or 
Heat Transfer in Shells interface.

εuσ Tamb u,
4 T4–( ) εdσ Tamb d,

4 T4–( )+
R  6 :  T H E  H E A T  TR A N S F E R  F E A T U R E S



D O W N S I D E  P A R A M E T E R S

Follow the instructions for the Upside Parameters section to define the downside 
parameters εd and Tamb, d.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Out-of-Plane Radiation
Heat Transfer in Solids>Out-of-Plane Radiation
Heat Transfer in Fluids>Out-of-Plane Radiation
Heat Transfer in Porous Media>Out-of-Plane Radiation
Heat Transfer in Building Materials>Out-of-Plane Radiation
Bioheat Transfer>Out-of-Plane Radiation
Heat Transfer with Radiation in Participating Media>Out-of-Plane Radiation

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer 
or Heat Transfer with Radiation in Participating Media selected:
Domains>interface>Out-of-Plane Radiation

Out-of-Plane Heat Transfer

Upside and downside settings can be visualized by plotting the global 
normal vector (nx, ny, nz), that always points from downside to upside. 
Note that the normal vector (ht.nx, ht.ny, ht.nz) may be oriented 
differently.

See Tangent and Normal Variables in the COMSOL Multiphysics 
Reference Manual.

Out-of-Plane Heat Transfer for a Thin Plate: Application Library path 
Heat_Transfer_Module/Verification_Examples/thin_plate
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Phase Change Material

This node should be used to solve the heat equation after specifying the properties of 
a phase change material according to the apparent heat capacity formulation. This 
formulation gets its name from the fact that the latent heat is included as an additional 
term in the heat capacity. Up to five transitions in phase per material are supported.

N U M B E R  O F  TR A N S I T I O N S

To display this section, click the Show button ( ) and select Advanced Physics Options. 
The Number of phase transitions to model is set in this section. In most cases, only one 
phase transition is needed to simulate solidification, melting, or evaporation. If you 
want to model successive melting and evaporation, or any couple of successive phase 
transformations, choose 2 in the Number of phase transitions list. The maximum value 
is 5.

Depending on the Number of phase transitions, several parts display in the Phase Change 
section, and several Phase sections display underneath.

P H A S E  C H A N G E

The parameters for the definition of the transition temperature intervals are set in this 
section. 

Each transition is assumed to occur smoothly in a temperature interval between 
Tpc, j → j + 1 − ΔTj → j + 1 ⁄ 2 and Tpc, j → j + 1 + ΔTj → j + 1 ⁄ 2, releasing a total heat per 
unit volume equal to Lj →j + 1. 

The Phase change temperature between phase 1 and phase 2 Tpc, 1 → 2 should be set to 
define the center of the first transition interval. The default is 273.15 K. Enter any 
additional phase change temperatures as per the Number of phase transitions.

The Transition interval between phase 1 and phase 2 ΔT1 → 2 should be set to define the 
width of the first transition interval. The default is 10 K. Enter any additional transition 
intervals as per the Number of phase transitions. 

The value of ΔTj → j + 1 must be strictly positive. A value near 0 K corresponds to a 
behavior close to a pure substance.

The Latent heat from phase 1 and phase 2 L1 → 2 should be set to define the total heat 
per unit volume released during the first transition. Enter any additional latent heat 
values as per the Number of phase transitions.

The value of Lj → j + 1 must be positive. The default is 333 kJ/kg, which corresponds 
to the latent heat of fusion of water at a pressure of 1 atm. 
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About the Phases
The different phases are ordered according to the temperatures of fusion. Hence, the 
material properties of phase 1 are valid when T < Tpc, 1 → 2 while the material 
properties of phase 2 hold for T > Tpc, 1 → 2.

When more than one transition is modeled, the number of phases exceeds 2 and new 
variables are created (for example, Tpc, 2 → 3, ΔT2 → 3 or L2 → 3). The phase change 
temperatures Tpc, j → j + 1 are increasing and satisfy

This defines distinct domains of temperature bounded by Tpc, j − 1 → j and Tpc, j → j + 1 
where the material properties of phase j only apply.

In addition, the values of ΔTj → j + 1 are chosen so that the ranges between 
Tpc, j → j + 1 − ΔTj → j + 1 ⁄ 2 and Tpc, j → j + 1 + ΔTj → j + 1 ⁄ 2 do not overlap. If this 
condition is not satisfied, unexpected behavior can occur because some phases would 
never form completely. The values of ΔTj → j + 1 must all be strictly positive.

P H A S E

In each Phase section (based on the Number of phase transitions), the thermal 
conductivity and thermodynamics properties of each phase must be set. Then, within 
the transition interval, there is a “mushy zone” with mixed material properties.

Select a Material, phase [1,2,...], which can point to any material in the model. The 
default uses the Domain material.

The following material properties should be set:

• Thermal conductivity kphase[1,2,...]. The default uses the material values for phase i. 
For User defined select Isotropic, Diagonal, Symmetric, or Anisotropic based on the 
characteristics of the thermal conductivity, and enter another value or expression. 
The default is 1 W/(m·K).

• Density ρphase[1,2,...]. The default is 1000 kg/m3.

• Heat capacity at constant pressure Cp, phase[1,2,...]. The default is 4200 J/(kg·K).

• Ratio of specific heats γ phase[1,2,...]. The default is 1.1

Tpc 1 2→, Tpc 2 3→, …< <

Theory for Heat Transfer with Phase Change
D O M A I N  F E A T U R E S  |  385



386 |  C H A P T E
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Context menus
Heat Transfer>Phase Change Material
Heat Transfer in Solids>Phase Change Material
Heat Transfer in Fluids>Phase Change Material
Heat Transfer in Porous Media>Phase Change Material
Heat Transfer in Building Materials>Phase Change Material

It is useful to choose three or more phase transitions to handle extra 
changes of material properties such as in mixtures of compounds, metal 
alloys, composite materials, or allotropic varieties of a substance. For 
example, α, γ, and δ-iron are allotropes of solid iron that can be 
considered as phases with distinct phase change temperatures.

When Surface-to-surface radiation is activated, the Opacity subnode is 
automatically added to the entire selection, with Transparent option 
selected. The domain selection can’t be edited. To set some part of the 
domain as opaque, add a new Opacity subnode from the context menu 
(right-click the parent node) or from the Physics toolbar, Attributes menu. 

To satisfy energy and mass conservation in phase change models, 
particular attention should be paid to the density in time simulations. 
When the material density is not constant over time — for example, 
dependent on the temperature — volume change is expected. The 
transport velocity field and the density must be defined so that mass is 
conserved locally. A Moving Mesh Interface (described in the COMSOL 
Multiphysics Reference Manual) can be used to account for model 
deformation.

Phase Change: Application Library path 
Heat_Transfer_Module/Phase_Change/phase_change

Continuous Casting: Application Library path 
Heat_Transfer_Module/Thermal_Processing/continuous_casting

Cooling and Solidification of Metal: Application Library path 
Heat_Transfer_Module/Thermal_Processing/cooling_solidification_metal
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Bioheat Transfer>Phase Change Material
Heat Transfer with Surface-to-Surface Radiation>Phase Change Material
Heat Transfer with Radiation in Participating Media>Phase Change Material

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Domains>interface>Phase Change Material

Porous Medium

This node uses the following version of the heat equation to model heat transfer in a 
porous matrix filled with a fluid:

 (6-6)

 (6-7)

with the following material properties, fields, and sources:

• ρ (SI unit: kg/m3) is the fluid density.

• Cp (SI unit: J/(kg·K)) is the fluid heat capacity at constant pressure.

• (ρCp)eff (SI unit: J/(m3·K)) is the effective volumetric heat capacity at constant 
pressure defined by an averaging model to account for both solid matrix and fluid 
properties.

• q is the conductive heat flux (SI unit: W/m2).

• u (SI unit: m/s) is the fluid velocity field, either an analytic expression or the 
velocity field from a Fluid Flow interface. u should be interpreted as the Darcy 
velocity, that is, the volume flow rate per unit cross sectional area. The average linear 
velocity (the velocity within the pores) can be calculated as uL = u ⁄ θL, where θL is 
the fluid’s volume fraction, or equivalently the porosity.

• keff (SI unit: W/(m·K)) is the effective thermal conductivity (a scalar or a tensor if 
the thermal conductivity is anisotropic), defined by an averaging model to account 
for both solid matrix and fluid properties.

• Q (SI unit: W/m3) is the heat source (or sink). Add one or several heat sources as 
separate physics features. See Heat Source node and Viscous Dissipation subnode 
for example.

ρCp( )eff
∂T
∂t
------- ρCpu ∇T ∇ q⋅+⋅+ Q=

q keff∇T–=
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For a steady-state problem the temperature does not change with time and the first 
term disappears.

M O D E L  I N P U T S

This section has fields and values that are inputs to expressions that define material 
properties. If such user-defined property groups are added, the model inputs appear 
here.

Temperature
This section is available when temperature-dependent material properties are used. By 
default the temperature of the parent interface is used and the section is not editable. 
To edit the Temperature field, click Make All Model Inputs Editable ( ). The available 
options are User defined (default) and all the temperature variables from the physics 
interfaces included in the model. These physics interfaces have their own tags (the 
Name). For example, if a Heat Transfer in Fluids interface is included in the model, the 
Temperature (ht) option is available.

Absolute Pressure
The absolute pressure is used in some predefined quantities that include the enthalpy 
(the energy flux, for example).

It is also used if the ideal gas law is applied. See Thermodynamics, Fluid.

The default Absolute pressure pA is User defined. When additional physics interfaces are 
added to the model, the absolute pressure variables defined by these physics interfaces 
can also be selected from the list. For example, if a Brinkman Equations interface is 
added you can select Absolute pressure (br) from the list.

Velocity Field
The default Velocity field u is User defined. For User defined enter values or expressions 
for the components based on space dimensions. Or select an existing velocity field in 
the component (for example, Velocity field (br) from a Brinkman Equations interface).

Concentration
From the Concentration c (SI unit: mol/m3 or kg/m3) list, select an existing 
concentration variable from another physics interface, if any concentration variables 
exist, or select User defined to enter a value or expression for the concentration. This 
section can be edited anytime a material property is concentration dependent; for 
example, when the Fluid type is set to Moist air with Input quantity set to Concentration.
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F L U I D  M A T E R I A L

Select any component material from the list to define the Fluid material. The default 
uses the Domain material. It makes it possible to define different material properties for 
the fluid phase when the domain material corresponds to the solid phase (porous 
matrix) material.

H E A T  C O N D U C T I O N ,  F L U I D

The thermal conductivity k describes the relationship between the heat flux vector q 
and the temperature gradient ∇T in q = −k∇T, which is Fourier’s law of heat 
conduction. Enter this quantity as power per length and temperature.

The default Thermal conductivity k is taken From material. For User defined select 
Isotropic, Diagonal, Symmetric, or Anisotropic based on the characteristics of the thermal 
conductivity, and enter another value or expression. For Isotropic enter a scalar which 
will be used to define a diagonal tensor. For the other options, enter values or 
expressions into the editable fields of the tensor.

T H E R M O D Y N A M I C S ,  F L U I D

This section sets the thermodynamics properties of the fluid.

The heat capacity at constant pressure Cp describes the amount of heat energy required 
to produce a unit temperature change in a unit mass. 

The ratio of specific heats γ is the ratio of the heat capacity at constant pressure, Cp, to 
the heat capacity at constant volume, Cv. When using the ideal gas law to describe a 
fluid, specifying γ is sufficient to evaluate Cp. For common diatomic gases such as air, 
γ = 1.4 is the standard value. Most liquids have γ = 1.1 while water has γ = 1.0. γ is used 
in the streamline stabilization and in the variables for heat fluxes and total energy 
fluxes. It is also used if the ideal gas law is applied.

The available Fluid type options are Gas/Liquid (default), Moist air, or Ideal gas. After 
selecting a Fluid type from the list, further settings display underneath. 

Gas/Liquid
This option specifies the Density, the Heat capacity at constant pressure, and the Ratio 

of specific heats for a general gas or liquid. 
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Ideal Gas
This option uses the ideal gas law to describe the fluid. Only two properties are needed 
to define the thermodynamics of the fluid:

• The gas constant, with two options for the Gas constant type: Specific gas constant 
Rs or Mean molar mass Mn. If Mean molar mass is selected the software uses the 
universal gas constant R = 8.314 J/(mol·K), which is a built-in physical constant, to 
compute the specific gas constant.

• Either the Heat capacity at constant pressure Cp or Ratio of specific heats γ by 
selecting the option from the Specify Cp or γ list. For an ideal gas, it is sufficient to 
specify either Cp or the ratio of specific heats, γ, as these properties are dependent.

Moist Air
If Moist air is selected, the thermodynamics properties are defined as a function of the 
quantity of vapor in the moist air. The available Input quantity options to define the 
amount of vapor in the moist air are the following:

• Vapor mass fraction (the default) to define the ratio of the vapor mass to the total 
mass.

• Concentration to define the amount of water vapor in the total volume. If selected, 
a Concentration model input is automatically added in the Model Inputs section.

• Moisture content (also called mixing ratio or humidity ratio) to define the ratio of 
the water vapor mass to the dry air mass.

• Relative humidity, by defining the Reference relative humidity at Reference 

temperature and Reference pressure. The Reference relative humidity is a quantity 
defined between 0 and 1, where 0 corresponds to dry air and 1 to a water 
vapor-saturated air. 

I M M O B I L E  S O L I D S

This section sets the material and volume fraction of the porous matrix.

If the Standard porous matrix model is selected under Physical Model, select any 
component material in the Solid material list. The Volume fraction θp for the solid 
material should be specified.

If the Extended porous matrix model is selected under Physical Model (with the 
Subsurface Flow Module), the Number of solids can be set from 1 to 5. Then for each 
solid a Solid material list and a Volume fraction field display underneath.

The total volume fraction of solid material is given by
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and the available volume fraction for the mobile fluid is defined as

H E A T  C O N D U C T I O N ,  PO R O U S  M A T R I X

The thermal conductivity kp describes the relationship between the heat flux vector q 
and the temperature gradient ∇T in q = −kp∇T, which is Fourier’s law of heat 
conduction. Enter this quantity as power per length and temperature.

The default Thermal conductivity kp is taken From material. For User defined select 
Isotropic, Diagonal, Symmetric, or Anisotropic based on the characteristics of the thermal 
conductivity, and enter another value or expression. For Isotropic enter a scalar which 
will be used to define a diagonal tensor. For the other options, enter values or 
expressions into the editable fields of the tensor.

When the Extended porous matrix model is selected under Physical Model (with the 
Subsurface Flow Module), and more than one solid is selected in the Immobile Solids 
section, the thermal conductivities kpi should be specified for each immobile solid. The 
average property for the porous matrix is given by:

T H E R M O D Y N A M I C S ,  PO R O U S  M A T R I X

This section sets the thermodynamics properties of the porous matrix.

The specific heat capacity describes the amount of heat energy required to produce a 
unit temperature change in a unit mass of the solid material.

The Density ρp and the Specific heat capacity Cp, p should be specified. For From 

Material option, see Material Density in Features Defined on the Material Frame if a 
temperature-dependent density should be set.

The effective volumetric heat capacity of the solid-liquid system is calculated from

θp θpi

i
=

θL 1 θpi

i
–=

kp θpikpi

i
=

ρCp( )eff θpρpCp p, 1 θ–( p )ρCp+=
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When the Extended porous matrix model is selected under Physical Model (with the 
Subsurface Flow Module), and more than one solid is selected in the Immobile Solids 
section, the Density and Specific heat capacity should be specified for each immobile 
solid. 

The effective volumetric heat capacity of the composite solid-fluid system is defined as

E F F E C T I V E  T H E R M A L  C O N D U C T I V I T Y

This section sets the averaging model for the computation of the Effective conductivity 

by accounting for both solid matrix and fluid properties. The following options are 
available with either the Subsurface Flow Module or the Heat Transfer Module:

• Volume average (default), which computes the effective conductivity of the 
solid-fluid system as the weighted arithmetic mean of fluid and porous matrix 
conductivities:

• Reciprocal average, which computes the effective conductivity of the solid-fluid 
system as the weighted harmonic mean of fluid and porous matrix conductivities:

• Power law, which computes the effective conductivity of the solid-fluid system as the 
weighted geometric mean of fluid and porous matrix conductivities:

When the Extended porous matrix model is selected under Physical Model (with the 
Subsurface Flow Module), and more than one solid is selected in the Immobile Solids 
section, these averaging models are modified in the following way:

• Volume average:

• Reciprocal average:

ρCp( )eff θpiρpiCp pi,
i
 1 θpi

i
–

 
 
 

ρCp+=

keff θpkp 1 θp–( )k+=

1
keff
---------

θp
kp
------

1 θp–

k
---------------+=

keff kp
θp k

1 θp–( )⋅=

keff θpikpi

i
 1 θpi

i
–

 
 
 

k+=
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• Power law:

1
keff
--------- θpi

i


θpi

i


θpikpi

i

------------------------ 1 θpi

i
–

 
 
  1

k
---+=

keff

θpikpi

i


θpi

i


------------------------

 
 
 
 
 
 
  θpi

i


k

1 θpi

i

–
 
 
 

⋅=

Moist Air Fluid Type

Local Thermal Non-Equilibrium

Theory for Heat Transfer in Porous Media

With certain COMSOL products, the Thermal Dispersion, Viscous 
Dissipation, Geothermal Heating and Immobile Fluids subnodes are 
available from the context menu (right-click the parent node) or from the 
Physics toolbar, Attributes menu.

When Surface-to-surface radiation is activated, the Opacity subnode is 
automatically added to the entire selection, with Opaque option selected. 
The domain selection can’t be edited. To set some part of the domain as 
transparent, add a new Opacity subnode from the context menu 
(right-click the parent node) or from the Physics toolbar, Attributes menu. 

Evaporation in Porous Media with Small Evaporation Rates: 
Application Library path Heat_Transfer_Module/Phase_Change/ 

evaporation_porous_media_small_rate
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Context menus
Heat Transfer in Porous Media>Porous Medium

More locations are available if the Heat transfer in porous media check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Porous Medium

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Domains>interface>Porous Medium

Pressure Work

This subnode adds the following contribution to the right-hand side of the Heat 

Transfer in Fluids equation to model the result of heating under adiabatic compression 
as well as some thermoacoustic effects:

 (6-8)

where αp is the coefficient of thermal expansion defined as:

The pressure work is computed using the relative pressure, and is generally small for 
low Mach number flows.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

Qp αpT
∂pA
∂t

---------- u ∇⋅ pA+ 
 =

αp
1
ρ
---

T∂
∂ρ
 
 

p
–=
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No settings are required.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Fluids>Fluid>Pressure Work

More locations are available. For example:
Heat Transfer in Solids>Fluid>Pressure Work

Heat Transfer in Moist Air>Moist Air>Pressure Work

Ribbon
Physics Tab with Fluid selected in the model tree:
Attributes>Pressure Work

Radiation in Participating Media (Heat Transfer Interface)

This node should be used when radiation occurs in a medium not completely 
transparent, in which the radiation rays interact with the medium. It computes and 
adds in the heat transfer equation the radiative heat source term Qr (SI unit: W/m3), 
defined by:

where 

• κ is the absorption coefficient (SI unit: m–1).

When the Nonisothermal Flow multiphysics coupling node is added, the 
effect of pressure work can be taken into account by selecting the Include 

work done by pressure changes check box under the Flow Heating section. 
In this case, the Pressure Work feature is overridden by the multiphysics 
coupling node’s contribution.

Theory for Heat Transfer in Fluids

A similar term can be included to account for thermoelastic effects in 
solids. See Thermoelastic Damping.

Qr κ G 4πIb T( )–( )=
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• G is the incident radiation (SI unit: W/m2), defined by 

• I(Ω) is the radiative intensity (SI unit: W/(m2·sr)) at a given position following the 
Ω direction, that satisfies the radiative transfer equation

• Ib(T) is the blackbody radiative intensity (SI unit: W/(m2·sr)), defined as

• nr is the refractive index (dimensionless).

• σ is the Stefan-Boltzmann constant (SI unit: W/(m2·K4)).

• β = κ + σs is the extinction coefficient (SI unit: 1/m).

• σs is the scattering coefficient (SI unit: 1/m).

• φ(Ω′, Ω) is the scattering phase function (dimensionless).

• T is the temperature (SI unit: K).

It takes into account the absorbed and the emitted radiation, and depending on 
approximation method, also the scattered radiation.

Three approximation methods are available for the radiation discretization method. 
The characteristics of each of them are summarized in the following table.

TABLE 6-1:  DISCRETIZATION METHODS FOR RADIATION IN PARTICIPATING MEDIA (HT INTERFACE)

OPTION DISCRETE ORDINATES 
METHOD

P1 
APPROXIMATION

ROSSELAND 
APPROXIMATION

Optical thickness 
validity

All τ>>1 τ>>1

Scattering 
modeling

Linear 

Polynomial 

Linear No

G I Ω( ) Ωd
4π
=

Ω I Ω( )∇⋅ κIb T( ) βI Ω( )–
σs
4π
------ I Ω′( )φ Ω′ Ω,( ) Ω′d

0

4π

+=

Ib T( )
nr

2σT4

π
--------------------=
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M O D E L S  I N P U T S

There is one standard model input — the Temperature T. The default is to use the heat 
transfer interface’s dependent variable.

R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A

This section sets the absorption and scattering properties of the participating medium.

It is available when Rosseland approximation is selected as the Radiation discretization 

method for the physics interface. Depending on the available quantities, the extinction 
coefficient βR can be specified directly or defined as the sum of the absorption and 
scattering coefficients. Also see Rosseland Approximation Theory.

The following options are available from the Specify media properties list: 

• Absorption and scattering coefficients (default): in this case βR is defined as 
βR = κ + σs and the Absorption and Scattering sections display underneath. 

• Extinction coefficient: the default Rosseland mean extinction coefficient βR should be 
specified directly.

A B S O R P T I O N

This section sets the absorption property of the participating medium, and is available 
in the following cases:

• Discrete ordinates method is selected as the Radiation discretization method, or

• P1 approximation is selected as the Radiation discretization method, or

• Rosseland approximation is selected as the Radiation discretization method, and 
Absorption and scattering coefficients is selected from the Specify media properties list.

Computation of 
G

G not computed.

Thermal 
conductivity 
modified with 

Computational 
cost

High: up to 80 
additional degrees 
of freedom (Ii)

Medium: 1 
additional degree 
of freedom (G)

Low: No 
additional degree 
of freedom

TABLE 6-1:  DISCRETIZATION METHODS FOR RADIATION IN PARTICIPATING MEDIA (HT INTERFACE)

OPTION DISCRETE ORDINATES 
METHOD

P1 
APPROXIMATION

ROSSELAND 
APPROXIMATION

G ωiIi

i 1=

N

≈

∇ DP1∇G( )
κ G 4πIb–( )

+⋅
0=

kR
16nr

2σT3

3βR
-------------------------=
D O M A I N  F E A T U R E S  |  397



398 |  C H A P T E
The Absorption coefficient κ should be specified. It defines the amount of radiation, 
κI(Ω), that is absorbed by the medium. 

S C A T T E R I N G

This section sets the scattering property of the participating medium, and is available 
in the following cases:

• Discrete ordinates method is selected as the Radiation discretization method, or

• P1 approximation is selected as the Radiation discretization method, or

• Rosseland approximation is selected as the Radiation discretization method, and 
Absorption and scattering coefficients is selected from the Specify media properties list.

The Scattering coefficient σs should be specified.

When Discrete ordinates method or P1 approximation is selected as the Radiation 

discretization method for the physics interface, choose in addition the Scattering type: 
Isotropic, Linear anisotropic, or Polynomial anisotropic (only with Discrete ordinates 

method). This provides options to approximate the scattering phase function using the 
cosine of the scattering angle, μ0:

• Isotropic (the default) corresponds to the scattering phase function φ(μ0) = 1.

• For Linear anisotropic it defines the scattering phase function as φ(μ0) = 1 + a1μ0. 
Enter the Legendre coefficient a1.

• For Polynomial anisotropic it defines the scattering phase function as

Enter each Legendre coefficient a1, …, a12 as required.

I N I T I A L  V A L U E S

When Discrete ordinates method is selected as the Radiation discretization method for 
the physics interface, the Initial radiative intensity I should be specified. The default is 
ht.Ibinit, which is the blackbody radiative intensity at initial temperature.

When P1 approximation is selected as the Radiation discretization method for the physics 
interface, the Initial incident radiation G should be specified. The default is 
(4*pi)*ht.Ibinit, computed from the blackbody radiative intensity at initial 
temperature.

φ μ0( ) 1 amPm μ0( )

m 1=

12

+=
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This section is not available when Rosseland approximation is selected as the Radiation 

discretization method for the physics interface. 

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer with Radiation in Participating Media>Radiation in Participating Media

More locations are available if the Radiation in participating media check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Radiation in Participating Media

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Domains>interface>Radiation in Participating Media

Radiation in Participating Media (RPM Interface)

This node should be used when radiation occurs in a medium not completely 
transparent, in which the radiation rays interact with the medium. It computes the 
radiative heat source term Qr (SI unit: W/m3), defined by:

where 

• κ is the absorption coefficient (SI unit: m-1).

Theory for Radiation in Participating Media

Discrete Ordinates Method (DOM)

Rosseland Approximation Theory

P1 Approximation Theory

Radiative Cooling of a Glass Plate: Application Library path 
Heat_Transfer_Module/Thermal_Radiation/glass_plate

Qr κ G 4πIb T( )–( )=
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• G is the incident radiation (SI unit: W/m2), defined by 

• I(Ω) is the radiative intensity (SI unit: W/(m2·sr)) at a given position following the 
Ω direction, that satisfies the radiative transfer equation

• Ib(T) is the blackbody radiative intensity (SI unit: W/(m2·sr)), defined as

• nr is the refractive index (dimensionless).

• σ is the Stefan-Boltzmann constant (SI unit: W/(m2·K4)).

• β = κ + σs is the extinction coefficient (SI unit: 1/m).

• σs is the scattering coefficient (SI unit: 1/m).

• φ(Ω′, Ω) is the scattering phase function (dimensionless).

• T is the temperature (SI unit: K).

It takes into account the absorbed, emitted, and scattered radiation of the participating 
medium.

Two approximation methods are available for the radiation discretization method. The 
characteristics of each of them are summarized in the following table.

TABLE 6-2:  DISCRETIZATION METHODS FOR RADIATION IN PARTICIPATING MEDIA (RPM INTERFACE)

OPTION DISCRETE ORDINATES METHOD P1 APPROXIMATION

Optical thickness 
validity

All τ>>1

Scattering 
modeling

Linear 

Polynomial 

Linear 

Computation of 
G

Computational 
cost

High: up to 80 additional 
degrees of freedom (Ii)

Medium: 1 additional degree of freedom 
(G)

G I Ω( ) Ωd
4π
=

Ω I Ω( )∇⋅ κIb T( ) βI Ω( )–
σs
4π
------ I Ω′( )φ Ω′ Ω,( ) Ω′d

4π
+=

Ib T( )
nr

2σT4

π
--------------------=

G ωiIi

i 1=

N

≈

∇ DP1∇G( ) κ G 4πIb–( )+⋅ 0=
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M O D E L S  I N P U T S

There is one standard model input — the Temperature T. The default is 293.15 K and 
is used in the blackbody radiative intensity expression.

A B S O R P T I O N

The Absorption coefficient κ should be specified. It defines the amount of radiation, 
κI(Ω), that is absorbed by the medium. 

S C A T T E R I N G

This section sets the scattering property of the participating medium.

The Scattering coefficient σs should be specified.

Choose in addition the Scattering type: Isotropic, Linear anisotropic, or Polynomial 

anisotropic (only with Discrete ordinates method). This setting provides options to 
approximate the scattering phase function using the cosine of the scattering angle, μ0:

• Isotropic (the default) corresponds to the scattering phase function φ(μ0) = 1.

• For Linear anisotropic it defines the scattering phase function as φ(μ0) = 1 + a1μ0. 
Enter the Legendre coefficient a1.

• For Polynomial anisotropic it defines the scattering phase function as

Enter each Legendre coefficient a1, …, a12 as required.

I N I T I A L  V A L U E S

When Discrete ordinates method is selected as the Radiation discretization method for 
the physics interface, the Initial radiative intensity I should be specified. The default is 
rpm.Ibinit, which is the blackbody radiative intensity at initial temperature.

When P1 approximation is selected as the Radiation discretization method for the physics 
interface, the Initial incident radiation G should be specified. The default is 

φ μ0( ) 1 amPm μ0( )

m 1=

12

+=
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(4*pi)*rpm.Ibinit, computed from the blackbody radiative intensity at initial 
temperature.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Radiation in Participating Media>Radiation in Participating Media

Ribbon
Physics Tab with Radiation in Participating Media selected:
Domains>Radiation in Participating Media>Radiation in Participating Media

Solid

This node uses this version of the heat equation to model heat transfer in solids:

 (6-9)

with the following material properties, fields, and sources:

• ρ (SI unit: kg/m3) is the solid density.

• Cp (SI unit: J/(kg·K)) is the solid heat capacity at constant pressure.

Theory for Radiation in Participating Media

Discrete Ordinates Method (DOM)

P1 Approximation Theory

Radiative Heat Transfer in a Utility Boiler: Application Library path 
Heat_Transfer_Module/Thermal_Radiation/boiler

Radiative Heat Transfer in Finite Cylindrical Media: Application 
Library path 
Heat_Transfer_Module/Verification_Examples/cylinder_participating_media

Radiative Heat Transfer in Finite Cylindrical Media—P1 Method: 
Application Library path Heat_Transfer_Module/Verification_Examples/

cylinder_participating_media_p1

ρCp
∂T
∂t
------- ρCpu ∇T⋅+ ∇ q⋅+ Q=

q k∇– T=
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• k (SI unit: W/(m·K)) is the solid thermal conductivity (a scalar or a tensor if the 
thermal conductivity is anisotropic).

• u (SI unit: m/s) is the velocity field defined by the Translational Motion subnode 
when parts of the model are moving in the material frame.

• Q (SI unit: W/m3) is the heat source (or sink). Add one or several heat sources as 
separate physics features. See Heat Source node and Thermoelastic Damping 
subnode for example.

For a steady-state problem the temperature does not change with time and the first 
term disappears.

S O L I D  M A T E R I A L

This section is available only when the Local Thermal Non-Equilibrium multiphysics 
coupling is included in the component to model porous media. It makes it possible to 
define different material properties for the porous matrix and the fluid. 

Select any material from the list to define the Solid material. The default uses the 
Domain material. See Material Density in Features Defined on the Material Frame for 
the setting of a temperature-dependent density.

H E A T  C O N D U C T I O N ,  S O L I D

The thermal conductivity k describes the relationship between the heat flux vector q 
and the temperature gradient ∇T in q = −k∇T, which is Fourier’s law of heat 
conduction. Enter this quantity as power per length and temperature.

The default Thermal conductivity k is taken From material. For User defined select 
Isotropic, Diagonal, Symmetric, or Anisotropic based on the characteristics of the thermal 
conductivity, and enter another value or expression. For Isotropic enter a scalar which 
will be used to define a diagonal tensor. For the other options, enter values or 
expressions into the editable fields of the tensor.

The components of the thermal conductivity k when given on tensor form (kxx, kyy, 
and so on, representing an anisotropic thermal conductivity) are available as ht.kxx, 
ht.kyy, and so on (using the default name ht). The single scalar mean effective 
thermal conductivity ht.kmean is the mean value of the diagonal elements kxx, kyy, 
and kzz.

Fourier’s law assumes that the thermal conductivity tensor is symmetric. 
A nonsymmetric tensor can lead to unphysical results.
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T H E R M O D Y N A M I C S ,  S O L I D

This section sets the thermodynamics properties of the solid.

The heat capacity at constant pressure describes the amount of heat energy required to 
produce a unit temperature change in a unit mass. 

The Density ρ and Heat capacity at constant pressure Cp should be specified. 

In addition, the thermal diffusivity α, defined as k ⁄ (ρCp) (SI unit: m2/s), is also a 
predefined quantity. The thermal diffusivity can be interpreted as a measure of thermal 
inertia (heat propagates slowly where the thermal diffusivity is low, for example). The 
components of the thermal diffusivity α, when given on tensor form (αxx, αyy, and so 
on, representing an anisotropic thermal diffusivity) are available as ht.alphaTdxx, 
ht.alphaTdyy, and so on (using the default physics name ht). The single scalar mean 
thermal diffusivity ht.alphaTdMean is the mean value of the diagonal elements αxx, 
αyy, and αzz. The denominator ρCp is the effective volumetric heat capacity which is 
also available as a predefined quantity, ht.C_eff.

Local Thermal Non-Equilibrium 

Theory for Heat Transfer in Solids

The Thermoelastic Damping subnode is available from the context menu 
(right-click the parent node) or from the Physics toolbar, Attributes menu. 

When Surface-to-surface radiation is activated, the Opacity subnode is 
automatically added to the entire selection, with Opaque option selected. 
The domain selection can’t be edited. To set some part of the domain as 
transparent, add a new Opacity subnode from the context menu 
(right-click the parent node) or from the Physics toolbar, Attributes menu. 

Heat Generation in a Disc Brake: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/brake_disc

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Solid
Heat Transfer in Solids>Solid
Heat Transfer in Fluids>Solid
Heat Transfer in Porous Media>Solid
Heat Transfer in Building Materials>Solid
Bioheat Transfer>Solid
Heat Transfer with Surface-to-Surface Radiation>Solid
Heat Transfer with Radiation in Participating Media>Solid

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Domains>interface>Solid

Irreversible Transformation

This subnode should be used to model thermally induced irreversible transformations 
in solids. 

I R R E V E R S I B L E  T R A N S F O R M A T I O N

Two models are available to define the material transformation depending on 
temperature, both using integral forms over time.

Select the Transformation model—Temperature threshold (the default) or Energy 

absorption, depending on the material properties you have access to.

For Temperature threshold, select the type of analysis—Overheating analysis (the 
default) or Overcooling analysis, depending on the expected temperature variations. 

Overheating Analysis
Enter values for:

• Transformation temperature Tit, h to define the (high) temperature that the solid 
needs to reach to start getting transformed.
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• Transformation time tit, h to define the time needed for the complete transformation 
to happen while the temperature is above Tit, h.

• Enthalpy change Lit, h to define the enthalpy variation associated with transformation 
due to overheating. The following heat source is added to the right-hand side of 
Equation 6-9 in Solid node: 

Overcooling Analysis
Enter values for:

• Transformation temperature Tit, c to define the (low) temperature that the solid 
needs to reach to start getting transformed. 

• Transformation time tit, c to define the time needed for the complete transformation 
to happen while the temperature is below Tit, c. 

• Enthalpy change Lit, c to define the enthalpy variation associated with transformation 
due to overcooling. The following heat source is added to the right-hand side of 
Equation 6-9 in Solid node: 

For Energy absorption, define the Frequency Factor and Activation Energy to compute 
the degree of transformation with the Arrhenius equation. 

Frequency Factor and Activation Energy
Enter values for:

• Frequency factor A in the Arrhenius equation. Default is taken From material. For 
User defined enter a value or an expression. 

• Activation energy ΔE in the Arrhenius equation. Default is taken From material. For 
User defined enter a value or an expression. 

• Enthalpy change L to define the enthalpy variation associated with the 
transformation. The following heat source is added to the right-hand side of 
Equation 6-9 in Solid node: 

Q ρLit h,
∂θit
∂t

---------- T Tit h,>( )–=

Q ρLit c,
∂θit
∂t

---------- T Tit c,<( )=

Q ρL
∂θit
∂t

----------–=
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Specific thermodynamics properties before and after complete transformation may be 
defined by selecting the check box Specify different material properties for the 

transformed state. 

Choose a Transformed material, which can point to any material in the model. The 
default uses the Domain material. The properties before transformation are the ones 
specified in the Heat Conduction, Solid and Thermodynamics, Solid sections of the parent 
Solid node. The effective material properties are dynamically updated with the 
transformation evolution.

H E A T  C O N D U C T I O N

This section is available when the Specify different material properties for the 

transformed state check box is selected.

Select a Thermal conductivity kd —From material (the default) or User defined, to be 
used for transformed solid. For User defined choose Isotropic, Diagonal, Symmetric, or 
Anisotropic based on the characteristics of the thermal conductivity and enter another 
value or expression in the field or matrix. 

T H E R M O D Y N A M I C S

This section is available when the Specify different material properties for the 

transformed state check box is selected.

Select a Density ρd and Heat capacity at constant pressure Cp, d —From material (the 
default) or User defined, to be used for transformed solid. The heat capacity describes 
the amount of heat energy required to produce a unit temperature change in a unit 
mass.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Solid>Irreversible Transformation

More locations are available. For example:
Heat Transfer in Fluids>Solid>Irreversible Transformation

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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Ribbon
Physics Tab with Solid selected in the model tree:
Attributes>Irreversible Transformation

Thermal Dispersion

This subnode should be used to model the heat transfer due to hydrodynamic mixing 
in a fluid flowing through a porous medium. It adds an extra term ∇ ⋅ (kdisp∇T) to the 
right-hand side of the heat equation in porous media, through the modification of the 
effective thermal conductivity keff with the dispersive thermal conductivity kdisp:

and specifies values for the longitudinal and transverse dispersivities.

D I S P E R S I V I T I E S

This section sets the Longitudinal dispersivity λlo and Transverse dispersivity λtr used for 
the definition of the tensor of dispersive thermal conductivity:

where Dij is the dispersion tensor 

and λijkl is the fourth-order dispersivity tensor

If the Extended porous matrix model is selected under Physical Model (with the 
Subsurface Flow Module), the Transverse horizontal dispersivity λtr, h and Transverse 

vertical dispersivity λtr, v are defined instead of the Transverse dispersivity λtr.

In this case it is assumed that z is the vertical direction and it defines the dispersion 
tensor as

ρCp( )eff
∂T
∂t
------- ρCpu ∇T⋅+ ∇ keff∇T( )⋅ Q+=

kdisp( )ij ρLCp L, Dij=

Dij λijkl
ukul

u
------------=

λijkl λtrδijδkl
λlo λtr–

2
--------------------- δikδjl δilδjk+( )+=
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Porous Media>Porous Medium>Thermal Dispersion

More locations are available if the Heat transfer in porous media check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Porous Medium>Thermal Dispersion

Ribbon
Physics Tab with Porous Medium selected in the model tree:
Attributes>Thermal Dispersion

Dij

1
u
-------

λlou2 λtr h, v2 λtr v, w2+ + λlo λtr h,–( )uv λlo λtr v,–( )uw

λlo λtr h,–( )uv λtr h, u2 λlov2 λtr v, w2+ + λlo λtr v,–( )vw

λlo λtr v,–( )uw λlo λtr v,–( )vw λtr v, u2 λtr v, v2 λlow2+ +

=

The former formulation corresponds to the general formulation when 
λtr, h =  λtr, v.

Porous Medium

The Thermal Dispersion node is only available with certain COMSOL 
products. For a detailed overview of the functionality available in each 
product, visit http://www.comsol.com/products/specifications/
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Thermoelastic Damping

This subnode should be used to model heat generation due to changes in stress, which 
may be important in small structures vibrating at high frequencies.

T H E R M O E L A S T I C  D A M P I N G

The Thermoelastic damping Qted should be specified either as a User defined value, or as 
the thermoelastic damping contribution straight from the solid mechanics interfaces, 
when you add a Thermal Expansion subnode (with the Structural Mechanics Module). 
In the latter case it is defined by 

where S is the second Piola-Kirchhoff tensor and α is the coefficient of thermal 
expansion.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Solid>Thermoelastic Damping

More locations are available. For example:
Heat Transfer in Fluids>Solid>Thermoelastic Damping

Ribbon
Physics Tab with Solid selected in the model tree:
Attributes>Thermoelastic Damping

Translational Motion

This subnode provides movement by translation to the model for heat transfer in 
solids. It adds the following contribution to the right-hand side of Equation 6-9, 
defined in the parent node:

Qted αT:∂S
∂t
-------–=

Solid

Thermal Expansion (for materials) in the Structural Mechanics Module 
User’s Guide

ρ– Cputrans T∇⋅
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The contribution describes the effect of a moving coordinate system, which is required 
to model, for example, a moving heat source.

D O M A I N  S E L E C T I O N

By default, the selection is the same as for the Solid node that it is attached to, but it is 
possible to use more than one Translational Motion subnode, each covering a subset of 
the Solid node’s selection.

TR A N S L A T I O N A L  M O T I O N

The x, y, and z (in 3D) components of the Velocity field utrans should be specified in 
this section.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Solid>Translational Motion

Bioheat Transfer>Biological Tissue>Translational Motion

More locations are available. For example:
Heat Transfer in Fluids>Solid>Translational Motion

Ribbon
Physics Tab with Solid or Biological Tissue selected in the model tree:
Attributes>Translational Motion

Special care must be taken on boundaries where n ⋅ utrans ≠ 0. The Heat 
Flux boundary condition does not, for example, work on boundaries 
where n ⋅ utrans < 0.

Solid

Heat Generation in a Disc Brake: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/brake_disc

Friction Stir Welding of an Aluminum Plate: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/friction_stir_welding
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Viscous Dissipation

This subnode should be used to account for the heat source coming from the 
transformation of kinetic energy into internal energy due to viscous stresses. Such 
effect is expected in fluid regions with large velocity gradients or with high turbulence 
levels.

V I S C O U S  D I S S I P A T I O N

The Qvd input should be specified either as a User defined value, or as the viscous 
dissipation term contribution straight from the fluid flow interfaces. 

For laminar flows, it is defined by 

where τ is the viscous tensor.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Fluids>Fluid>Viscous Dissipation
Heat Transfer in Fluids>Phase Change Material>Viscous Dissipation
Heat Transfer in Fluids>Porous Medium>Viscous Dissipation

Qvd τ: u∇=

When the Nonisothermal Flow multiphysics coupling node is added, the 
effect of viscous dissipation can be taken into account by selecting the 
Include viscous dissipation check box under the Flow Heating section. In this 
case, the Viscous Dissipation feature is overriden by the multiphysics 
coupling node’s contribution.

Fluid

Porous Medium

Phase Change Material

This feature was previously called Viscous Heating.
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More locations are available. For example:
Heat Transfer in Solids>Fluid>Viscous Dissipation

Heat Transfer in Solids>Phase Change Material>Viscous Dissipation

Heat Transfer in Solids>Porous Medium>Viscous Dissipation

Heat Transfer in Moist Air>Moist Air>Viscous Dissipation

Ribbon
Physics Tab with Fluid, Phase Change Material, Moist Air, or Porous Medium selected in 
the model tree:
Attributes>Viscous Dissipation
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Bounda r y  F e a t u r e s

The Heat Transfer interfaces have the following boundary nodes and subnodes 
available: 

• Boundary Heat Source

• Change Thickness (Heat Transfer in 
Thin Shells Interface)

• Continuity

• Continuity on Interior Boundary

• Deposited Beam Power

• Diffuse Mirror

• Diffuse Surface

• External Temperature (Thin Layer, 
Thin Film)

• External Temperature (Thin 
Layered Shell, Thin Film)

• Fracture

• Harmonic Perturbation

• Heat Flux

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Fracture)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Thin Film)

• Heat Source (Thin Layered Shell)

• Incident Intensity

• Inflow Heat Flux

• Initial Values (Heat Transfer in Thin 
Shells Interface)

• Isothermal Domain Interface

• Layer Heat Source

• Line Heat Source on Axis

• Opaque Surface

• Open Boundary 

• Outflow

• Periodic Condition

• Prescribed Radiosity

• Radiation Group

• Symmetry

• Temperature

• Thermal Contact

• Thermal Insulation

• Thin Conductive Layer (Heat 
Transfer in Thin Shells Interface)

• Thin Film

• Thin Layer

• Thin Layered Shell (Heat Transfer in 
Thin Shells Interface)
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Boundary Heat Source

This node models a heat source (or heat sink) that is embedded in the boundary. When 
selected as a Pair Boundary Heat Source, it also prescribes that the temperature field is 
continuous across the pair. Note that in this case the source term is applied on the 
source side.

P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

B O U N D A R Y  H E A T  S O U R C E

Click the General source (the default) or Heat rate button.

• For General source enter a value for the boundary heat source Qb when the default 
option, User defined, is selected. 

A positive Qb corresponds to heating and a negative Qb corresponds to cooling. For 
the general boundary heat source Qb, there are predefined heat sources available 
when simulating heat transfer together with electrical or electromagnetic interfaces. 
Such sources represent, for example, ohmic heating and induction heating.

• For Heat rate enter the heat rate Pb. In this case Qb = Pb ⁄ A, where A is the total 
area of the selected boundaries.

F R A M E  S E L E C T I O N

The settings are the same as for the Heat Source node and are described under Frame 

Selection.

For axisymmetric components, COMSOL Multiphysics takes the axial 
symmetry boundaries into account and automatically adds an Axial 

Symmetry node that is valid on the axial symmetry boundaries only.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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S O U R C E  PO S I T I O N

To display this section, click the Show button ( ) and select Advanced Physics Options. 

Select a Source position to define a side where the heat source is defined: Layer (the 
default), Upside, or Downside. This setting has no effect unless the temperature differs 
from one side of the boundary to the other. Typically when Boundary Heat Source 
contributes with a Thin Layer feature.

To define the boundary heat source Qb as a function of the temperature, 
use the local temperature variable on the selected boundary, 
ht.bhs1.Tvar, that corresponds to the appropriate variable (upside, 
downside, or average temperature of a layer, wall temperature with 
turbulence modeling), depending on the model configurations. See 
Boundary Wall Temperature for a thorough description of the boundary 
temperature variables.

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.

Upside and downside settings can be visualized by plotting the global 
normal vector (nx, ny, nz), that always points from downside to upside. 
Note that the normal vector (ht.nx, ht.ny, ht.nz) may be oriented 
differently.

See Tangent and Normal Variables in the COMSOL Multiphysics 
Reference Manual.

• Handling Frames in Heat Transfer

• About the Heat Transfer Interfaces
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Boundary Heat Source
Heat Transfer in Solids>Boundary Heat Source
Heat Transfer in Fluids>Boundary Heat Source
Heat Transfer in Porous Media>Boundary Heat Source
Heat Transfer in Building Materials>Boundary Heat Source
Bioheat Transfer>Boundary Heat Source
Heat Transfer with Surface-to-Surface Radiation>Boundary Heat Source
Heat Transfer with Radiation in Participating Media>Boundary Heat Source

Heat Transfer in Solids>Pairs>Pair Boundary Heat Source
Heat Transfer in Fluids>Pairs>Pair Boundary Heat Source
Heat Transfer in Porous Media>Pairs>Pair Boundary Heat Source
Heat Transfer in Building Materials>Pairs>Pair Boundary Heat Source
Bioheat Transfer>Pairs>Pair Boundary Heat Source
Heat Transfer with Surface-to-Surface Radiation>Pairs>Pair Boundary Heat Source
Heat Transfer with Radiation in Participating Media>Pairs>Pair Boundary Heat Source

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Boundary Heat Source

Pairs>interface>Pair Boundary Heat Source

Change Thickness (Heat Transfer in Thin Shells Interface)

Use this node to give parts of the shell a different thickness than that what is specified 
on the Heat Transfer in Thin Shells interface Shell Thickness section.

C H A N G E  T H I C K N E S S

Specify a value for the Shell thickness ds. The default value is 0.01 m. This value 
replaces the overall thickness for the boundaries that are selected.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Change Thickness
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Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Boundaries>Heat Transfer in Thin Shells>Change Thickness

Continuity

This node can be added to pairs. It prescribes that the temperature field is continuous 
across the pair. Continuity is only suitable for pairs where the boundaries match.

P A I R  S E L E C T I O N

Choose the pair on which to apply this condition. A pair has to be created first. See 
Identity and Contact Pairs in the COMSOL Multiphysics Reference Manual for more 
details.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Pairs>Continuity
Heat Transfer in Solids>Pairs>Continuity
Heat Transfer in Fluids>Pairs>Continuity
Heat Transfer in Porous Media>Pairs>Continuity
Bioheat Transfer>Pairs>Continuity
Heat Transfer in Thin Shells>Pairs>Continuity
Heat Transfer with Surface-to-Surface Radiation>Pairs>Continuity
Heat Transfer with Radiation in Participating Media>Pairs>Continuity
Surface-to-Surface Radiation>Pairs>Continuity
Radiation in Participating Media>Pairs>Continuity

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer in Thin Shells, Heat Transfer with Surface-to-Surface Radiation or Heat 

Transfer with Radiation in Participating Media, Radiation in Participating Media or 
Surface-to-Surface Radiation selected:
Pairs>interface>Continuity

Thermo-Mechanical Analysis of a Surface-Mounted Resistor: 
Application Library path 
Heat_Transfer_Module/Thermal_Stress/surface_resistor
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Continuity on Interior Boundary

When Discrete ordinates method is selected, this node enables intensity conservation 
across internal boundaries. It is the default boundary condition for all interior 
boundaries. For P1 approximation and Rosseland approximation this boundary 
condition is not available since it is not needed.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer with Radiation in Participating Media>Radiation in Participating 
Media>Continuity on Interior Boundary
Radiation in Participating Media>Continuity on Interior Boundary

More locations are available if the Radiation in participating media check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Radiation in Participating Media>Continuity on Interior Boundary

Ribbon
Physics Tab with Heat Transfer, Heat Transfer in Solids, Heat Transfer in Fluids, Heat 

Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, Heat 

Transfer with Surface-to-Surface Radiation, Heat Transfer with Radiation in Participating 

Media or Radiation in Participating Media selected:
Boundaries>Radiation in Participating Media>Continuity on Interior Boundary

Deposited Beam Power

This node models heat sources brought by narrow beams, such as laser or electron 
beams, to a given boundary. This feature is only available in 3D components.

D E P O S I T E D  B E A M  PO W E R

Enter a value for the Deposited beam power Pl, the Beam origin point O, and the Beam 

orientation e. The orientation vector needs not to be normalized.

Radiative Heat Transfer in a Utility Boiler: Application Library path 
Heat_Transfer_Module/Thermal_Radiation/boiler
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B E A M  P R O F I L E

Select a Distribution type: Gaussian (the default) or Top-hat disk.

• For Gaussian, enter the Standard deviation σ.

• For Top-hat disk, enter the Beam radius R. Smoothing can be applied by entering a 
positive Size of transition zone ΔR. The default value of 0 m corresponds to an ideal 
discontinuous top-hat profile.

S O U R C E  PO S I T I O N

To display this section click the Show button ( ) and select Advanced Physics Options.

Select a Source position to define a side where the heat source is defined: Layer (the 
default), Upside, or Downside. This setting has no effect unless the temperature differs 
from one side of the boundary to the other.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Deposited Beam Power
Heat Transfer in Solids>Deposited Beam Power
Heat Transfer in Fluids>Deposited Beam Power
Heat Transfer in Porous Media>Deposited Beam Power
Bioheat Transfer>Deposited Beam Power
Heat Transfer with Surface-to-Surface Radiation>Deposited Beam Power
Heat Transfer with Radiation in Participating Media>Deposited Beam Power

The standard deviation of the Gaussian distribution and the radius of the 
top-hat distribution can take values smaller than the mesh element size. 
For more accurate results, it is important to refine the mesh enough at the 
deposited heat source location. Otherwise, an automatic substitution 
replaces the standard deviation σ or the beam radius R by the minimum 
length to get acceptable results which depends on the mesh element size.

Upside and downside settings can be visualized by plotting the global 
normal vector (nx, ny, nz), that always points from downside to upside. 
Note that the normal vector (ht.nx, ht.ny, ht.nz) may be oriented 
differently.

See Tangent and Normal Variables in the COMSOL Multiphysics 
Reference Manual.
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Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Deposited Beam Power

Diffuse Mirror

This node is a variant of the Diffuse Surface node with a surface emissivity equal to 
zero. Diffuse mirror surfaces are common as approximations of a surface that is well 
insulated on one side and for which convection effects can be neglected on the 
opposite (radiating) side. It resembles a mirror that absorbs all irradiation and then 
radiates it back in all directions. The node adds radiosity shape function for each 
spectral band to its selection and uses it as surface radiosity.

The radiative heat flux on a diffuse mirror boundary is zero.

M O D E L  I N P U T S

This section has fields and values that are inputs to expressions that define material 
properties. If such user-defined property groups have been added, the model inputs 
are included here.

There is one standard model input — the Temperature T. The default is the 
temperature variable in the Heat Transfer interface or 293.15 K in the 
Surface-to-Surface Radiation interface. It is used in the blackbody radiation intensity 
expression.

R A D I A T I O N  S E T T I N G S

Select the Radiation direction: Opacity controlled (the default), Negative normal 

direction, Positive normal direction, or Both sides. For information about these options, 
see Diffuse Surface.

A M B I E N T

These settings are the same as for the Diffuse Surface node.
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I N I T I A L  V A L U E S

These settings are the same as for the Diffuse Surface node.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer with Surface-to-Surface Radiation>Radiation>Diffuse Mirror

Surface-to-Surface Radiation>Diffuse Mirror

More locations are available if the Surface-to-surface radiation check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Radiation>Diffuse Mirror

Ribbon
Physics Tab with Surface-to-Surface Radiation selected:
Boundaries>Surface-to-Surface Radiation>Diffuse Mirror

Physics Tab with Heat Transfer, Heat Transfer in Solids, Heat Transfer in Fluids, Heat 

Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, Heat 

Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in Participating 

Media selected:
Boundaries>Radiation>Diffuse Mirror

Diffuse Surface

Diffuse surfaces reflect radiative intensity uniformly in all directions. This node handles 
radiation with a view factor calculation. The feature adds one radiosity shape function 
per spectral interval to its selection and uses it as surface radiosity.

It adds a radiative heat source contribution

on the side of the boundary where the radiation is defined, where ε is the surface 
emissivity, G is the irradiation, and eb(T) is the blackbody hemispherical total emissive 
power. Where the radiation is defined on both sides, the radiative heat source is defined 
on both sides too.

If this feature is combined with heat transfer in 2D and 1D, the thickness 
is assumed to be infinite for the view factor computation. The 
user-defined value for d is still used in the heat transfer equation.

q ε G eb T( )–( )=
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M O D E L  I N P U T S

This section has fields and values that are inputs to expressions that define material 
properties. If such user-defined property groups have been added, the model inputs 
are included here.

There is one standard model input — the Temperature T. The default is the 
temperature variable in the Heat Transfer interface or 293.15 K in the 
Surface-to-Surface Radiation interface. This model input is used in the expression for 
the blackbody radiation intensity and, when multiple wavelength intervals are used, for 
the fractional emissive power. The temperature model input is also used to determine 
the variable that receives the radiative heat source. When the model input does not 
contain a dependent variable, the radiative heat source is ignored.

R A D I A T I O N  S E T T I N G S

When Wavelength dependence of emissivity is set to Constant in the Radiation Settings 
section of the physics interface (available when the Surface-to-surface radiation check 
box is selected), select a Radiation direction based on the geometric normal 
(nx, ny, nz): Opacity controlled, Negative normal direction, Positive normal direction, or 
Both sides. 

• Opacity controlled requires that each boundary is adjacent to exactly one opaque 
domain. Opacity is controlled by the Opacity domain subfeature. For external 
boundaries, the exterior side opacity is controlled by the Exterior radiation setting at 
the interface level. This is the default option when the node is added from any 
version of the Heat Transfer interface with the Surface-to-surface radiation check box 
is selected.

• Select Negative normal direction to specify that the surface radiates in the negative 
normal direction. An arrow indicates the negative normal direction that corresponds 
to the direction of the radiation emitted by the surface. 

• Select Positive normal direction if the surface radiates in the positive normal 
direction. An arrow indicates the positive normal direction that corresponds to the 
direction of the radiation emitted by the surface.

• Select Both sides if the surface radiates on both sides. This is the default option when 
the node is added from the Heat Transfer in Thin Shells interface or the 
Surface-to-Surface Radiation interface.

When Wavelength dependence of emissivity is set to Solar and ambient or Multiple 

spectral bands in the Radiation Settings section of the physics interface (available when 
the Surface-to-surface radiation check box is selected), select a Radiation direction for 
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each spectral band: Opacity controlled, Negative normal direction, Positive normal 

direction, Both sides, or None. The Radiation direction defines the radiation direction for 
each spectral band similarly as when Wavelength dependence of emissivity is Constant. 
Defining a radiation direction for each spectral band makes it possible to build models 
where the transparency or opacity properties defers between spectral bands. 

None is used when adjacent domains are either both transparent or both opaque for a 
given spectral band.

When the Surface-to-surface radiation check box is not selected or not available, the 
Radiation Settings section can be displayed by clicking the Show button ( ) and 
selecting Advanced Physics Options. Select a Radiation direction between Negative normal 

direction and Positive normal direction.

A M B I E N T

If the Surface-to-surface radiation check box is selected, select Define ambient 

temperature on each side when the ambient temperature differs between the sides of a 
boundary. This is needed to define ambient temperature for a surface that radiates on 
both sides and that is exposed to a hot temperature on one side (for example, fire) and 
to a cold temperature on the other side (for example, external temperature). By 
default, Define ambient temperature on each side is not selected when the node is added 
from any version of the Heat Transfer interface; but it is selected when the node is 
added from the Heat Transfer in Thin Shells interface or the Surface-to-Surface 
Radiation interface.

Set the Ambient temperature Tamb. For User defined, enter a value or expression. Else, 
select an Ambient temperature defined in the Ambient Settings section of a Heat 
Transfer or Heat Transfer in Shells interface. When Define ambient temperature on each 

side is selected, define the Ambient temperature Tamb, u and Tamb, d on the up and 

This is useful for example to represent glass opaque to radiation outside 
of the 0.3–2.5 µm wavelength range.

The Thin Layer boundary also defines the layer opacity that determines the 
side of the layer where the radiation occurs, depending on radiation 
direction. When the Surface-to-surface radiation check box is not selected 
or not available, the thin layer is set opaque.
R  6 :  T H E  H E A T  TR A N S F E R  F E A T U R E S



down side, respectively. The geometric normal points from the down side to the up 
side.

By default, a diffuse irradiation contribution Idiff is included into the external 
irradiation. For User defined, enter a value or expression. When considering solar 
irradiation, it accounts for the irradiation from the sun, scattered by the atmosphere, 
and supposed to be isotropic. Else, select a Clear sky noon diffuse horizontal irradiance 

defined in the Ambient Settings section of a Heat Transfer or Heat Transfer in Shells 
interface.

To consider only the direct irradiation defined in the External Radiation Source 
feature, clear the Include diffuse irradiance check box.

S U R F A C E  F R A C T I O N A L  E M I S S I V E  P O W E R

This section is only available when the Surface-to-surface radiation check box is selected.

This section is available when the Wavelength dependence of emissivity is defined as Solar 

and ambient or Multiple spectral bands for the physics interface (see Radiation Settings).

When the Fractional emissive power is Blackbody/Graybody, the fractional emissive 
power is automatically computed for each spectral band as a function of the band 
endpoints and surface temperature.

When the Fractional emissive power is User defined, define the Fractional emissive power, 
FEPBi for each spectral band. All fractional emissive powers are expected to be in [0,1] 
and their sum is expected to be equal to 1.

S U R F A C E  E M I S S I V I T Y

Set Tamb to the far-away temperature in directions where no other 
boundaries obstruct the view. Inside a closed cavity, the ambient view 
factor, Famb, is theoretically zero and the value of Tamb therefore should 
not matter. It is, however, good practice to set Tamb to T or to a typical 
temperature value for the cavity surfaces in such cases because that 
minimizes errors introduced by the finite resolution of the view factor 
evaluation.

In diffuse gray and diffuse spectral radiation models, the surface emissivity 
and the absorptivity must be equal. For this reason it is equivalent to 
define the surface emissivity or the absorptivity.
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The surface emissivity settings are defined per spectral interval. 

When the Radiation direction is Opacity controlled, Negative normal direction, or Positive 

normal direction for a spectral band, by default, the Surface emissivity ε (dimensionless) 
uses values From material. This is a property of the material surface that depends both 
on the material itself and the structure of the surface. Make sure that a material is 
defined at the boundary level (by default materials are defined at the domain level).

When the Radiation direction is set to Both sides for a spectral band, define the Material 

on upside and Material on downside:

• The defaults for both Material on upside and Material on downside use Boundary 

material. The list has options based on the materials defined in the model. 

• Define the Surface emissivity on the upside and downside, respectively. The 
geometric normal points from the down side to the up side. Set the surface 
emissivity to a number between 0 and 1, where 0 represents diffuse mirror and 1 is 
appropriate for a perfect blackbody. The proper value for a physical material lies 
somewhere in-between and can be found from tables or measurements.

When the Radiation direction is set to None for a spectral band, no information is 
needed for this spectral band in the Surface Emissivity section.

I N I T I A L  V A L U E S

This section is only available when the Surface-to-surface radiation check box is selected.

The surface radiosity initial values are defined per spectral interval.

When the Radiation direction is Opacity controlled, Negative normal direction, or Positive 

normal direction for a spectral band Bi, the default Surface radiosity JBi, init is defined as

When Both sides is selected as the Radiation direction, 

Enter initial values for the Surface radiosity JBi, init, u and JBi, init, d. The default Surface 

radiosity is ht.JBiinitU and ht.JBiinitD.

JBi init, εBieb Tinit( ) 1 εBi–( )eb Tamb( )+=

JBi init u,, εBi u, eb Tinit( ) 1 εBi u,–( )eb Tamb u,( )+=

JBi init d,, εBi d, eb Tinit( ) 1 εBi d,–( )eb Tamb d,( )+=
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When None is selected as the Radiation direction, no surface radiosity is defined; hence 
no initial value is needed.

• In the notation used here, Bi stands for B1, B2,... up to the maximum 
number of spectral intervals.

• When the model contains one spectral interval, JBi, init, JBi, init, u and 
JBi, init, d are named, respectively, Jinit, Jinit, u and Jinit, d.

• If this feature is combined with heat transfer in 2D and 1D, the 
thickness is assumed to be infinite for the view factor computation. The 
user-defined value for d is still used in the heat transfer equation.

To define temperature dependencies for the user inputs (surface 
emissivity for example), use the temperature variable ht.T, that 
corresponds to the appropriate variable (upside, downside, or average 
temperature of a layer, wall temperature with turbulence modeling), 
depending on the model configurations. See Boundary Wall Temperature 
for a thorough description of the boundary temperature variables.

Several settings for this node depend on the Wavelength dependence of 

emissivity setting, which is defined for the physics interface when the 
Surface-to-surface radiation check box is selected. 

In addition, the Transparent media refractive index is equal to 1 by default, 
and can be set when the Surface-to-surface radiation check box is selected.

See Radiation Settings.

Theory for Surface-to-Surface Radiation
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Radiation>Diffuse Surface
Heat Transfer in Solids>Radiation>Diffuse Surface
Heat Transfer in Fluids>Radiation>Diffuse Surface
Heat Transfer in Porous Media>Radiation>Diffuse Surface
Bioheat Transfer>Radiation>Diffuse Surface
Heat Transfer with Surface-to-Surface Radiation>Radiation>Diffuse Surface
Surface-to-Surface Radiation>Diffuse Surface
Heat Transfer with Radiation in Participating Media>Radiation>Diffuse Surface
Heat Transfer in Thin Shells>Radiation>Diffuse Surface

Ribbon
Physics Tab with Surface-to-Surface Radiation selected:
Boundaries>Surface-to-Surface Radiation>Diffuse Surface

Physics Tab with Heat Transfer, Heat Transfer in Solids, Heat Transfer in Fluids, Heat 

Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, Heat 

Transfer with Surface-to-Surface Radiation, Heat Transfer with Radiation in Participating 

Media, or Heat Transfer in Thin Shells selected:
Boundaries>Radiation>Diffuse Surface 

External Temperature (Thin Layer, Thin Film)

Use this subnode to specify the temperature on the exterior side of a thin layer or a 
thin film. As a subfeature of Thin Layer, it is only applicable when Layer type is set to 
Thermally thick approximation or General, on exterior boundaries. As a subfeature of 
Thin Film, it is only applicable when Thin film model is set to General, on exterior 

Upside and downside settings can be visualized by plotting the global 
normal vector (nx, ny, nz), that always points from downside to upside. 
Note that the normal vector (ht.nx, ht.ny, ht.nz) may be oriented 
differently.

See Tangent and Normal Variables in the COMSOL Multiphysics 
Reference Manual.

Heat Generation in a Disc Brake: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/brake_disc
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boundaries.

TE M P E R A T U R E

For User defined, enter a value or expression for the Temperature T0. Else, select an 
Ambient temperature defined in the Ambient Settings section of a Heat Transfer or 
Heat Transfer in Shells interface.

The equation for this condition is T = T0 where T0 is the external temperature to be 
prescribed.

C O N S T R A I N T  S E T T I N G S

To display this section, click the Show button ( ) and select Advanced Physics Options.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Thin Layer>External Temperature

Heat Transfer in Solids>Thin Film>External Temperature

More locations are available. For example:
Heat Transfer in Fluids>Thin Layer>External Temperature

Ribbon
Physics Tab with Thin Layer or Thin Film selected in the model tree:
Attributes>External Temperature

You can specify a harmonic variation of the temperature value in a 
frequency domain analysis of perturbation type, by adding a Harmonic 

Perturbation subnode. See Theory for Harmonic Heat Transfer for more 
details.

Thin Layer

Thin Film

Theory for Heat Transfer in Thin Structures
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External Temperature (Thin Layered Shell, Thin Film)

Use this subnode to specify the temperature on the exterior of a thin layered shell or a 
thin film (downside and/or upside). As a subfeature of Thin Film, it is only applicable 
when Thin Film model is set to General, on exterior boundaries.

TE M P E R A T U R E

By default, the temperature is specified on downside and upside. Unselect the Downside 
or Upside check boxes to apply the constraint on one side only.

For each side, select an Ambient temperature defined in the Ambient Settings section 
of a Heat Transfer or Heat Transfer in Shells interface. For User defined, enter values 
or expressions for T0,d and T0,u.

C O N S T R A I N T  S E T T I N G S

To display this section, click the Show button ( ) and select Advanced Physics Options.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Thin Layered Shell>External Temperature

Heat Transfer in Thin Shells>Thin Film>External Temperature

More locations are available. For example:
Heat Transfer in Thin Film>Thin Layered Shell>External Temperature

Ribbon
Physics Tab with Thin Layered Shell or Thin Film selected in the model tree:
Attributes>External Temperature

Fracture

Use this node to allow heat transfer in fractures inside domains. It can also be used to 
allow heat transfer in films.

Thin Layered Shell (Heat Transfer in Thin Shells Interface)

Thin Film

Theory for Heat Transfer in Thin Structures
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P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

F R A C T U R E  P R O P E R T I E S

This section is only available when the node is added from one of the versions of the 
Heat Transfer interface (ht). Specify a value for the Fracture thickness dfr. The default 
is 0.01 m.

F L U I D  M A T E R I A L

By default, the Boundary material is used.

PO R O U S  M A T E R I A L

By default, the Boundary material is used. The Volume fraction θfr should be specified. 
The default is 0.

H E A T  C O N D U C T I O N ,  F R A C T U R E

The default Thermal conductivity kfr is taken From material. For User defined select 
Isotropic, Diagonal, Symmetric, or Anisotropic based on the characteristics of the thermal 
conductivity, and enter another value or expression. Select an Effective conductivity: 
Volume average (the default) or Power law.

T H E R M O D Y N A M I C S ,  F R A C T U R E

The default Density ρfr and Specific heat capacity Cp, fr are taken From material. See 
Material Density in Features Defined on the Material Frame if a 
temperature-dependent density should be set. For User defined enter other values or 
expressions.

The settings for the Model Inputs, Heat Conduction, Fluid, and 
Thermodynamics, Fluid sections are the same as for Fluid.

When the Fracture node is added from a Heat Transfer in Thin Shells 
interface, only in-plane anisotropy is supported for the thermal 
conductivity of the fracture material.
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Porous Media>Fracture
Heat Transfer in Porous Media>Pairs>Fracture
Heat Transfer in Fractures>Fracture

More locations are available if the Heat transfer in porous media check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Fracture

Heat Transfer in Solids>Pairs>Fracture

Heat Transfer in Thin Shells>Fracture

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Fracture

Pairs>interface>Fracture

Physics Tab with interface as Heat Transfer in Thin Shells, Heat Transfer in Thin Films or 
Heat Transfer in Fractures selected:
Boundaries>interface>Fracture

Harmonic Perturbation

Use this subnode to specify the harmonic variation of a prescribed temperature value. 
It is used only in a study step of type Frequency-Domain Perturbation. 

Enter a value or expression for the Temperature perturbation ΔT0 to be added to the 
equilibrium temperature T0 defined in the parent node.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Temperature>Harmonic Perturbation

Fracture in Theory for Heat Transfer in Thin Structures
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More locations are available. For example:
Heat Transfer in Solids>Thin Rod>Temperature>Harmonic Perturbation
Heat Transfer in Solids>Thin Layer>Temperature>Harmonic Perturbation
Heat Transfer in Solids>Thin Film>Temperature>Harmonic Perturbation
Heat Transfer in Solids>Fracture>Temperature>Harmonic Perturbation
Heat Transfer in Solids>Thin Layer>External Temperature>Harmonic Perturbation
Heat Transfer in Thin Shells>Temperature>Harmonic Perturbation

Ribbon
Physics Tab with Temperature or External Temperature selected in the model tree:
Attributes>Harmonic Perturbation

Heat Flux

Use this node to add heat flux across boundaries. A positive heat flux adds heat to the 
domain. This feature is not applicable to inlet boundaries, use the Inflow Heat Flux 
condition instead.

H E A T  F L U X

Click to select the General inward heat flux (the default), Convective heat flux, or Heat 

rate button.

General Inward Heat Flux
It adds q0 to the total flux across the selected boundaries. Enter a value for q0 to 
represent a heat flux that enters the domain. For example, any electric heater is well 
represented by this condition, and its geometry can be omitted. 

Convective Heat Flux
The default option is to enter a User defined value for the Heat transfer coefficient h. In 
addition, the following options are also available to control the type of convective heat 
flux to model: External natural convection, Internal natural convection, External forced 

convection, or Internal forced convection.

For all options except User defined, select a Fluid: Air (the default), Transformer oil, or 
Water. 

For Air, also set the Absolute pressure, pA. For User Defined, enter a value or expression. 
The default is 1 atm. Else, select an Ambient absolute pressure defined in the Ambient 
Settings section of a Heat Transfer or Heat Transfer in Shells interface.

Depending of the selected option, different parameters are needed. You can refer to 
the Sketch section to get an illustration of the configuration.
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External Natural Convection

For External natural convection select Vertical wall, Inclined wall, Horizontal plate, upside, 
Horizontal plate, downside, Long horizontal cylinder, Sphere, or Vertical Thin Cylinder 

from the list under Heat transfer coefficient. Then enter the applicable information:

• Wall height L.

• Wall height L and the Tilt angle φ. The tilt angle is the angle between the wall and 
the vertical direction, φ = 0 for vertical walls. 

• Characteristic length (area/perimeter) L. The characteristic length is the ratio 
between the surface area and its perimeter. 

• Cylinder diameter D.

• Sphere diameter D.

• Cylinder height H.

Internal Natural Convection

For Internal natural convection select Narrow chimney, parallel plates or Narrow chimney, 

circular tube from the list under Heat transfer coefficient. Then enter the applicable 
information:

• Plate distance L and a Chimney height H.

• Tube diameter D and a Chimney height H.

External Forced Convection

For External forced convection select Plate, averaged transfer coefficient, Plate, local 

transfer coefficient, Cylinder in cross flow, or Sphere from the list under Heat transfer 

coefficient. Then enter the applicable information:

• Plate length L and Velocity, fluid U.

• Position along the plate xpl and Velocity, fluid U.

• Cylinder Diameter D and Velocity, fluid U.

• Sphere Diameter D and Velocity, fluid U.

Internal Forced Convection

For Internal forced convection the only option is Isothermal tube. Enter a Tube diameter 

D and a Velocity, fluid U.
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If Velocity, fluid U is User defined, enter a value or expression. Else, select a Wind velocity 

defined in the Ambient Settings section of a Heat Transfer or Heat Transfer in Shells 
interface.

Finally, enter an External temperature, Text. The value depends on the geometry and 
the ambient flow conditions. Convective heat flux is defined by q0 = h(Text − T).

For User defined, enter a value or expression. Else, select an Ambient temperature 

defined in the Ambient Settings section of a Heat Transfer or Heat Transfer in Shells 
interface.

Heat Rate
For Heat rate enter the heat rate P0 across the boundaries where the Heat Flux node is 
active. In this case q0 = P0 ⁄ A, where A is the total area of the selected boundaries.

F R A M E  S E L E C T I O N

The settings are the same as for the Heat Source node and are described under Frame 

Selection.

The detailed definition of the predefined heat transfer coefficients is given 
in The Heat Transfer Coefficients.

For a thorough introduction about how to calculate heat transfer 
coefficients, see Incropera and DeWitt in Ref. 18.

• Handling Frames in Heat Transfer

• About the Heat Transfer Interfaces

• Power Transistor: Application Library path 
Heat_Transfer_Module/Power_Electronics_and_Electronic_Cooling/power_

transistor

• Free Convection in a Water Glass: Application Library path 
Heat_Transfer_Module/Tutorials,_Forced_and_Natural_Convection/

cold_water_glass
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Heat Flux
Heat Transfer in Solids>Heat Flux
Heat Transfer in Fluids>Heat Flux
Heat Transfer in Porous Media>Heat Flux
Bioheat Transfer>Heat Flux
Heat Transfer with Surface-to-Surface Radiation>Heat Flux
Heat Transfer with Radiation in Participating Media>Heat Flux

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Heat Flux 

Heat Flux (Heat Transfer in Thin Shells Interface)

This node adds a heat flux q0, u for the upside heat flux and a heat flux q0, d for the 
downward heat flux to the right-hand side of Equation 6-4 

 (6-10)

where

For the convective heat flux, q0 is defined as:

F R A M E  S E L E C T I O N

To display this section add both a Heat Transfer in Thin Shells (htsh) and Moving 

Mesh (ale) interface (found under the Mathematics>Deformed Mesh branch when adding 
a physics interface). Then click the Show button ( ) and select Advanced Physics 

Options.

The rest of the settings are the same as for the Out-of-Plane Heat Flux node as 
described under Frame Selection for About the Heat Transfer Interfaces.

dsρCp
∂T
∂t
------- ∇– dsk∇T( )⋅ dsQ dsq0+=

q0 q0 u, q0 d,+=

q0 hu Text u, T–( ) h+ d Text d, T–( )=
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U P S I D E  C O N V E C T I V E  H E A T  F L U X

Select between specifying the upside convective heat flux directly or as a convective 
term using a heat transfer coefficient. 

General Inward Heat Flux
General inward heat flux is selected by default. Enter a value or expression for the inward 
(or outward, if the quantity is negative) heat flux through the upside in the q0, u field. 

Convective Heat Flux
Click the Convective heat flux button to specify an inward (or outward, if the quantity 
is negative) heat flux through the upside as hu ⋅ (Text, u − T). 

Select a Heat transfer coefficient hu to control the type of convective heat flux to model: 
User defined (the default), External natural convection, Internal natural convection, 
External forced convection, or Internal forced convection. If convective flux is only 
required on the downside, use the default, which sets hu = 0. 

For all of the options, enter an External temperature, Text, u. For User defined, enter a 
value or expression. Else, select an Ambient temperature defined in the Ambient 
Settings section of a Heat Transfer or Heat Transfer in Shells interface.

The rest of the settings are the same for the Out-of-Plane Heat Flux node, as described 
for the Heat Transfer interface under Convective Heat Flux.

D O W N S I D E  I N W A R D  H E A T  F L U X

The options in the Downside Inward Heat Flux section are the same as in the Upside 

Inward Heat Flux section except it applies to the downside instead of the upside.

In 2D the heat flux contribution is multiplied by dz to account for the 
out-of-plane thickness.

Theory for Heat Transfer in Thin Structures

The Heat Transfer Coefficients
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Heat Flux

Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Boundaries>Heat Transfer in Thin Shells>Heat Flux

Heat Source (Fracture)

Use this subnode to add an internal heat source Qfr within the fracture. Add one or 
more heat sources. If this subnode is applied on a pair, note that the source term is 
applied on the source side.

H E A T  S O U R C E

Select the General source (the default) or Heat rate button to define Qfr.

• For General source enter a value or expression for Qfr as a heat source per volume.

• For Heat rate define the heat rate Pfr. In this case Qfr = Pfr ⁄ V where V = Adfr with 
A equal to the area of the boundary selection.

Upside and downside settings can be visualized by plotting the global 
normal vector (nx, ny, nz), that always points from downside to upside. 
Note that the normal vector (ht.nx, ht.ny, ht.nz) may be oriented 
differently.

See Tangent and Normal Variables in the COMSOL Multiphysics 
Reference Manual.

Disk-Stack Heat Sink: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/disk_stack_heat_sink

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Porous Media>Fracture>Heat Source

Heat Transfer in Porous Media>Pairs>Fracture>Heat Source

More locations are available if the Heat transfer in porous media check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Fracture>Heat Source

Heat Transfer in Solids>Pairs>Fracture>Heat Source

Ribbon
Physics Tab with Fracture selected in the model tree:
Attributes>Heat Source

Heat Source (Heat Transfer in Thin Shells Interface)

This node describes heat generation within the shell through a dsQ contribution to the 
right-hand side of Equation 4-50. If it is applied on a pair, note that the source term 
is applied on the source side.

Express heating and cooling with positive and negative values, respectively. Add one or 
more nodes as needed; all heat sources within a boundary contribute to the total heat 
source. Specify the heat source as the heat per volume in the domain, as a linear heat 
source, or as a heat rate.

H E A T  S O U R C E

These settings are the same as for the Heat Source node available for the other 
interfaces.

F R A M E  S E L E C T I O N

The settings are the same as for the Heat Source node Frame Selection section 

Fracture in Theory for Heat Transfer in Thin Structures

In 2D components the heat source is multiplied by dz to account for the 
out-of-plane thickness.
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Heat Source

Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Boundaries>Heat Transfer in Thin Shells>Heat Source

Heat Source (Thin Film)

Use this subnode to add an internal heat source Qf within the thin film. Add one or 
more heat sources. If this subnode is applied on a pair, note that the source term is 
applied on the source side.

H E A T  S O U R C E

Select the General source (the default) or Heat rate button to define Qf.

• For General source enter a value or expression for Qf as a heat source per volume.

• For Heat rate define the heat rate Pf. In this case Qf = Pf ⁄ V where V = Adf with A 
equal to the area of the boundary selection.

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.

Theory for Heat Transfer in Thin Structures

Handling Frames in Heat Transfer

Thin Film

Theory for Heat Transfer in Thin Structures
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Thin Film>Heat Source

More locations are available. For example:
Heat Transfer in Fluids>Thin Film>Heat Source

Ribbon
Physics Tab with Thin Film selected in the model tree:
Attributes>Heat Source

Heat Source (Thin Layered Shell)

Use this subnode to add an internal heat source Qs,i within each layer of a thin layered 
shell. Add one or more heat sources. 

H E A T  S O U R C E

Enter a value or expression for the source input Qs,i for each layer as a heat source per 
volume. The layers are numbered from the upside to the downside.

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.

Thin Layered Shell (Heat Transfer in Thin Shells Interface)

Theory for Heat Transfer in Thin Structures
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Thin Layered Shell>Heat Source

Ribbon
Physics Tab with Thin Layered Shell selected in the model tree:
Attributes>Heat Source

Incident Intensity

Use this node to specify the radiative intensity along incident directions on a boundary. 
This intensity is a power per unit solid angle and unit surface area projected onto the 
plane normal to the radiation direction.

P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

I N C I D E N T  I N T E N S I T Y

The Boundary radiation intensity I should be specified. This represents the value of 
radiative intensity along incoming discrete directions. Values of radiative intensity on 
outgoing discrete directions are not prescribed.

When Discrete ordinates method is selected, the components of each 
discrete ordinate vector can be used in this expression. The syntax is 
name.sx, name.sy, and name.sz, where name is the physics interface 
node name. By default, the Heat Transfer interface is ht so ht.sx, ht.sy, 
and ht.sz correspond to the components of discrete ordinate vectors.

When P1 approximation is selected as the Radiation discretization method 
for the physics interface, there is additional theory, equations, and 
variables described in P1 Approximation Theory.

Radiation in Participating Media (RPM Interface)

Theory for Radiation in Participating Media
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer with Radiation in Participating Media>Radiation in Participating 

Media>Incident Intensity

Radiation in Participating Media>Incident Intensity

Heat Transfer with Radiation in Participating Media>Pairs>Incident Intensity

Radiation in Participating Media>Pairs>Incident Intensity

More locations are available if the Radiation in participating media check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Radiation in Participating Media>Incident Intensity

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation, Heat Transfer with Radiation in 

Participating Media or Radiation in Participating Media selected:
Boundaries>Radiation in Participating Media>Incident Intensity

Pairs>interface>Incident Intensity

Inflow Heat Flux

Use this node to model inflow of heat through a virtual domain with a heat source. 
The temperature at the outer boundary of the virtual domain is known. This boundary 
condition estimates the heat flux through the system boundary

 (6-11)

where A is the total area of the selected boundaries and

 (6-12)

A positive heat flux adds heat to the domain. This feature is applicable to inlet 
boundaries of non-solid domains.

n q⋅– q– 0
A u n⋅( )

u n⋅ sd
S

----------------------------- ρ hin hext–( )u n⋅+=

hin hext– Cp Td
Text

T in

 1
ρ
--- 1 αp–( ) pd

pext

pA

+=
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I N F L O W  H E A T  F L U X

Select the Inward heat flux (the default) or Heat rate buttons.

• For Inward heat flux define q0 to add to the total flux across the selected boundaries. 

• For Heat rate define the heat rate P0. In this case q0 = P0 ⁄ A. 

For either selection, the External temperature Text and the External absolute pressure 
pext should be specified. For User Defined, enter values or expressions. Else, select an 
Ambient temperature and an Ambient absolute pressure defined in the Ambient Settings 
section of a Heat Transfer or Heat Transfer in Shells interface.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Inflow Heat Flux
Heat Transfer in Solids>Inflow Heat Flux
Heat Transfer in Fluids>Inflow Heat Flux
Heat Transfer in Porous Media>Inflow Heat Flux
Bioheat Transfer>Inflow Heat Flux
Heat Transfer with Surface-to-Surface Radiation>Inflow Heat Flux
Heat Transfer with Radiation in Participating Media>Inflow Heat Flux

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Inflow Heat Flux

Initial Values (Heat Transfer in Thin Shells Interface)

This node adds an initial value for the temperature that can serve as an initial condition 
for a transient simulation or as an initial guess for a nonlinear solver. If more than one 
set of initial values is needed, add an Initial Values node from the Physics toolbar.

I N I T I A L  V A L U E S

For User defined, enter a value or expression for the initial value of the Temperature T. 
The default is approximately room temperature, 293.15 K (20º C). Else, select an 
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Ambient temperature defined in the Ambient Settings section of a Heat Transfer or 
Heat Transfer in Shells interface.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Initial Values

Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Boundaries>Heat Transfer in Thin Shells>Initial Values

Isothermal Domain Interface

This node adds several conditions for temperature exchange at the interfaces of an 
isothermal domain. It can be applied on interior and exterior boundaries of the 
computational domain, except on the boundaries found inside a single isothermal 
domain.

In addition to the default Isothermal domain Interface node always present when the 
Isothermal domain check box is selected under Physical Model section, you can add more 
Isothermal domain Interface nodes if needed.

P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

I S O T H E R M A L  D O M A I N  I N T E R F A C E

The available Interface type options are Thermal insulation (the default), Continuity, 
Ventilation, Convective heat flux, and Thermal contact. Depending on the Interface type 
selected from the list, further settings are required.

Theory for Heat Transfer in Thin Structures

Disk-Stack Heat Sink: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/disk_stack_heat_sink
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The description of all the available options is summarized in the following table:

Thermal Insulation
This condition should be used if no heat exchange occurs between the isothermal 
domain and the adjacent domain.

Continuity
With this condition, the temperatures of each side of the boundary are forced to be 
equal.

Ventilation
This condition specifies the mass flux at the interface between an isothermal domain 
and another domain containing the same fluid. 

The available Flow direction options are Positive normal direction (the default), Negative 

normal direction, and Both sides. For each option, either the Mass flux or the Mass flow 

rate should be specified:

• ϕd → u is the mass flux in the positive direction and ϕu → d is the mass flux in the 
negative direction. 

• Φd → u is the mass flow rate in the positive direction and Φu → d is the mass flow rate 
in the negative direction.

The External temperature found under the section of the same name must be set when 
the isothermal domain interface is also an exterior boundary. 

Convective Heat Flux
This condition specifies the convective heat flux at the interface of a solid isothermal 
domain adjacent to a fluid. 

Either the Heat transfer coefficient h or the Thermal conductance hth should be 
specified.

TABLE 6-3:  ISOTHERMAL DOMAIN INTERFACE OPTIONS

OPTION ISOTHERMAL DOMAIN ADJACENT DOMAIN DESCRIPTION

Thermal Insulation Any Any No flux

Continuity Any Any Temperature 
continuity

Ventilation Fluid Fluid Mass flux

Convective Heat Flux Solid Fluid Heat flux 
(convective)

Thermal Contact Solid Solid Heat flux 
(conductive)
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The External temperature found under the section of the same name must be set when 
the isothermal domain interface is also an exterior boundary. 

Thermal Contact
This condition specifies the conductive heat flux at the interface of a solid isothermal 
domain adjacent to a solid.

Either the Thermal resistance, Rt or the Absolute thermal resistance, Rt, th should be 
specified.

The External temperature found under the section of the same name must be set when 
the isothermal domain interface is also an exterior boundary. 

E X T E R N A L  TE M P E R A T U R E

This section is not available if the Interface type is set to Thermal Insulation or Continuity. 
Else, the External temperature, Text should be specified. It is used to compute the heat 
exchange with the exterior by the Ventilation, Convective heat flux, and Thermal contact 
options on isothermal domain interfaces that are also exterior boundaries. The value is 
ignored on interior boundaries. 

For User defined, enter a value or expression for the Temperature Text. Else, select an 
Ambient temperature defined in the Ambient Settings section of a Heat Transfer or 
Heat Transfer in Shells interface.

I N T E R F A C E  O P A C I T Y

This section is only available when the Surface-to-surface radiation check box is selected 
under the Physical Model section on the parent physics interface.

Select Opaque (the default) or Transparent to set the interface’s opacity type.

This is needed when the interface contributes with any boundary condition from the 
Radiation menu. It picks the side where irradiation starts from.

Isothermal Domain

Theory for Lumped Isothermal Domain

Natural Convection Cooling of a Vacuum Flask: Application Library 
path Heat_Transfer_Module/Tutorials,_Forced_and_Natural_Convection/

vacuum_flask
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
If the Isothermal domain check box is selected under the Physical Model section:
Heat Transfer>Isothermal Domain Interface

Heat Transfer in Solids>Isothermal Domain Interface

Heat Transfer in Fluids>Isothermal Domain Interface

Heat Transfer in Porous Media>Isothermal Domain Interface

Bioheat Transfer>Isothermal Domain Interface

Heat Transfer with Surface-to-Surface Radiation>Isothermal Domain Interface

Heat Transfer with Radiation in Participating Media>Isothermal Domain Interface

Heat Transfer in Solids>Pairs>Isothermal Domain Interface
Heat Transfer in Fluids>Pairs>Isothermal Domain Interface
Heat Transfer in Porous Media>Pairs>Isothermal Domain Interface
Bioheat Transfer>Pairs>Isothermal Domain Interface
Heat Transfer with Surface-to-Surface Radiation>Pairs>Isothermal Domain Interface
Heat Transfer with Radiation in Participating Media>Pairs>Isothermal Domain Interface

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Isothermal Domain Interface

Pairs>interface>Isothermal Domain Interface

Layer Heat Source

Use this subnode to add an internal heat source Qs within a thin layer. Add one or 
more heat sources. If this subnode is applied on a pair, note that the source term is 
applied on the source side.
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L A Y E R  H E A T  S O U R C E

Select the General source (the default) or Heat rate button to define Qs.

• For General source enter a value or expression for Qs as a heat source per volume.

• For Heat rate define the heat rate Ps. In this case Qs = Ps ⁄ V where V = Ads with A 
equal to the area of the boundary selection.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Thin Layer>Layer Heat Source

More locations are available. For example:
Heat Transfer in Fluids>Thin Layer>Layer Heat Source

Ribbon
Physics Tab with Thin Layer selected in the model tree:
Attributes>Layer Heat Source

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.

Thin Layer

Theory for Heat Transfer in Thin Structures

The Heat rate option is only available when the Layer type is Thermally thin 

approximation or Thermally thick approximation in the Thin Layer parent 
node.

With General layer type, a general source user input, Qs,i, is available for 
each layer. In this case the layers are numbered from the upside (Layer 1) 
to the downside.
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Line Heat Source on Axis

This node, available for 2D axisymmetric components, models a heat source (or sink) 
that is so thin that it has no thickness in the model geometry. The settings are the same 
as for the Line Heat Source node.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Line Heat Source on Axis
Heat Transfer in Solids>Line Heat Source on Axis
Heat Transfer in Fluids>Line Heat Source on Axis
Heat Transfer in Porous Media>Line Heat Source on Axis
Bioheat Transfer>Line Heat Source on Axis
Heat Transfer with Surface-to-Surface Radiation>Line Heat Source on Axis
Heat Transfer with Radiation in Participating Media>Line Heat Source on Axis

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Line Heat Source on Axis

Opaque Surface

This node defines a boundary opaque to radiation. It prescribes incident intensities on 
a boundary and accounts for the net radiative heat flux, qw, that is absorbed by the 
surface. 

P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.
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M O D E L S  I N P U T S

This section has fields and values that are inputs to expressions that define material 
properties. If such user-defined materials are added, the model inputs appear here.

There is one standard model input — the Temperature T, which is used in the 
blackbody radiative intensity expression.

WA L L  S E T T I N G S

Select a Wall type to define the behavior of the wall: Gray wall or Black wall.

Gray Wall
If Gray wall is selected the default Surface emissivity ε value is taken From material (a 
material defined on the boundaries). For User defined enter another value or 
expression.

An emissivity of 0 means that the surface emits no radiation at all and that all outgoing 
radiation is diffusely reflected by this boundary. An emissivity of 1 means that the 
surface is a perfect blackbody: outgoing radiation is fully absorbed on this boundary. 
The radiative intensity along incoming discrete directions on this boundary is defined 
by

Black Wall
If Black wall is selected, no user input is required, and the radiative intensity along the 
incoming discrete directions on this boundary is defined by

Values of radiative intensity along outgoing discrete directions are not prescribed.

The boundary temperature definition can differ from that of the 
temperature in the adjacent domain.

Ii bnd, εIb T( ) 1 ε–
π

-----------qout+=

Ii bnd, Ib T( )=

When P1 approximation is selected as the Radiation discretization method 
for the physics interface, there is additional theory, equations, and 
variables described in P1 Approximation Theory.
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer with Radiation in Participating Media>Radiation in Participating 

Media>Opaque Surface

Radiation in Participating Media>Opaque Surface

Heat Transfer with Radiation in Participating Media>Pairs>Opaque Surface
Radiation in Participating Media>Pairs>Opaque Surface

More locations are available if the Radiation in participating media check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Radiation in Participating Media>Opaque Surface

Heat Transfer in Solids>Pairs>Opaque Surface

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation, Heat Transfer with Radiation in 

Participating Media or Radiation in Participating Media selected:
Boundaries>Radiation in Participating Media>Opaque Surface

Pairs>interface>Opaque Surface

Open Boundary

This node adds a boundary condition for modeling heat flux across an open boundary; 
the heat can flow out of the domain or into the domain with a specified exterior 
temperature. Use this node to limit a modeling domain that extends in an open 
fashion.

Radiation in Participating Media (RPM Interface)

Theory for Radiation in Participating Media

Radiative Heat Transfer in a Utility Boiler: Application Library path 
Heat_Transfer_Module/Thermal_Radiation/boiler
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O P E N  B O U N D A R Y

Enter the exterior Temperature T0 outside the open boundary.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Open Boundary
Heat Transfer in Solids>Open Boundary
Heat Transfer in Fluids>Open Boundary
Heat Transfer in Porous Media>Open Boundary
Bioheat Transfer>Open Boundary
Heat Transfer with Surface-to-Surface Radiation>Open Boundary
Heat Transfer with Radiation in Participating Media>Open Boundary

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Open Boundary

Outflow

This node provides a suitable boundary condition for convection-dominated heat 
transfer at outlet boundaries. In a model with convective heat transfer, this condition 
states that the only heat transfer occurring across the boundary is by convection. The 
temperature gradient in the normal direction is zero, and there is no radiation. This is 
usually a good approximation of the conditions at an outlet boundary in a heat transfer 
model with fluid flow.

Natural Convection Cooling of a Vacuum Flask: Application Library 
path Heat_Transfer_Module/Tutorials,_Forced_and_Natural_Convection/

vacuum_flask
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B O U N D A R Y  S E L E C T I O N

In most cases, the Outflow node does not require any user input. If required, select 
the boundaries that are convection-dominated outlet boundaries.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Outflow
Heat Transfer in Solids>Outflow
Heat Transfer in Fluids>Outflow
Heat Transfer in Porous Media>Outflow
Bioheat Transfer>Outflow
Heat Transfer with Surface-to-Surface Radiation>Outflow
Heat Transfer with Radiation in Participating Media>Outflow

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Outflow

Periodic Condition

Use this node to add periodic temperature conditions to boundary pairs. The 
Destination Selection subnode is available from the context menu (right-click the parent 
node) or from the Physics toolbar, Attributes menu.

For information about the Orientation of Source section, see Orientation of Source and 
Destination in the COMSOL Multiphysics Reference Manual.

Heat Sink: Application Library path 
Heat_Transfer_Module/Tutorials,_Forced_and_Natural_Convection/heat_sink
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PE R I O D I C  C O N D I T I O N

Enter a Temperature offset ΔT to the temperature periodicity. The default value is 0 K, 
so that the source and destination temperatures are equal.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Periodic Condition
Heat Transfer in Solids>Periodic Condition
Heat Transfer in Fluids>Periodic Condition
Heat Transfer in Porous Media>Periodic Condition
Bioheat Transfer>Periodic Condition
Heat Transfer with Surface-to-Surface Radiation>Periodic Condition
Heat Transfer with Radiation in Participating Media>Periodic Condition

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Periodic Condition

Prescribed Radiosity

Use this node to specify radiosity on the boundary for each spectral band. Radiosity 
can be defined as blackbody or graybody radiation. A user-defined surface radiosity 
expression can also be defined.

M O D E L  I N P U T S

These settings are the same as for Diffuse Mirror.

Convection Cooling of Circuit Boards—3D Forced Convection: 
Application Library path 
Heat_Transfer_Module/Power_Electronics_and_Electronic_Cooling/circuit_bo

ard_forced_3d
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R A D I A T I O N  D I R E C T I O N

When Wavelength dependence of emissivity is set to Constant select a Radiation direction 

based on the geometric normal (nx, ny, nz): Opacity controlled (the default), Negative 

normal direction, Positive normal direction, or Both sides.

• Opacity controlled requires that each boundary is adjacent to exactly one opaque 
domain. Opacity is controlled by the Opacity condition.

• Select Negative normal direction to specify that the surface radiates in the negative 
normal direction.

• Select Positive normal direction if the surface radiates in the positive normal 
direction.

• Select Both sides if the surface radiates on both sides.

When Wavelength dependence of emissivity is set to Solar and ambient or Multiple 

spectral bands select a Radiation direction for each spectral band: Opacity controlled (the 
default), Negative normal direction, Positive normal direction, or Both sides, or None. The 
Radiation direction defines the radiation direction for each spectral band similarly as 
when Wavelength dependence of emissivity is Constant.

R A D I O S I T Y

Select a Radiosity expression: Graybody radiation (the default), Blackbody radiation, or 
User defined.

If this feature is combined with heat transfer in 2D and 1D, the thickness 
is assumed to be infinite for the view factor computation. The 
user-defined value for d is still used in the heat transfer equation.

Radiosity does not directly affect the boundary condition on the boundary 
where it is specified, but rather defines how that boundary affects others 
through radiation.
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Blackbody Radiation
When Blackbody radiation is selected it sets the surface radiosity expression 
corresponding to a blackbody.

• When Wavelength dependence of emissivity is set to Constant it defines J = eb(T) 
when radiation is defined on one side or Ju = eb(Tu) and Jd = eb(Td) when radiation 
is defined on both sides.

• When Wavelength dependence of emissivity is set to Solar and ambient or Multiple 

spectral bands, it defines for each spectral band JBi = FEPBi(T)eb(T) when radiation 
is defined on one side or JBi, d = FEPBi, d(Td)eb(Td) and Ju = FEPBi, u(Tu)eb(Tu) 
when radiation is defined on both sides.

Graybody Radiation
When Graybody radiation is selected it sets the surface radiosity expression 
corresponding to a graybody.

By default, the Surface emissivity ε is defined From material. In this case, make sure that 
a material is defined at the boundary level (materials are defined by default at the 
domain level). If User defined is selected for the Surface emissivity, enter another value 
for ε.

If Wavelength dependence of emissivity is set to Constant: 

• When radiation is defined on one side, define the Surface emissivity ε to set 
J = εeb(T), or

• When radiation is defined on both sides, define the Material on upside, the Surface 

emissivity εu, Material on downside and the Surface emissivity εd on the upside and 
downside, respectively. The surface radiosity on upside and downside is then defined 
by Ju = εueb(Tu) and Jd = εdeb(Td) respectively.

• When the temperature varies across a pair (for example when a Thin 
Layer condition is active on the same boundary), the temperature used 
to define the radiosity is evaluated on the side where the surface 
radiation is defined.

• The blackbody hemispherical total emissive power is defined by 
eb(T) = n2σT4
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If Wavelength dependence of emissivity is set to Solar and ambient or Multiple spectral 

bands, for all spectral bands:

• When radiation is defined on one side for Bi spectral band, define the Surface 

emissivity εBi to set JBi = FEPBiεBieb(T), or

• When radiation is defined on both sides for Bi spectral band, define the Material on 

upside, the Surface emissivity εBi, u, Material on downside and the Surface emissivity 
εBi, d on the upside and downside, respectively. The surface radiosity on upside and 
downside is then defined by Ju = FEPBi(Tu)εBi, ueb(Tu) and 
Jd = FEPBi(Td)εBi, deb(Td), respectively.

User Defined
If Wavelength dependence of emissivity is set to Constant and Radiosity expression is set 
to User defined, it sets the surface radiosity expression to J = J0, which specifies how 
the radiosity of a boundary is evaluated when that boundary is visible in the calculation 
of the irradiation onto another boundary in the model. Enter a Surface radiosity 

expression, J0. 

When the Radiation direction is set to Both sides (under Radiation Settings) also define 
the surface Radiosity expression J0i, u and J0i, d on the upside and downside, 
respectively. The geometric normal points from the downside to the upside.

If Wavelength dependence of emissivity is Solar and ambient or Multiple spectral bands, 
similar settings are available for each spectral band.

Set the surface emissivity to a number between 0 and 1, where 0 
represents diffuse mirror and 1 is appropriate for a perfect blackbody. The 
proper value for a physical material lies somewhere in-between and can be 
found from tables or measurements.

Several settings for this node depend on the Wavelength dependence of 

emissivity setting, which is defined for the physics interface. See Radiation 
Settings.
R  6 :  T H E  H E A T  TR A N S F E R  F E A T U R E S



L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer with Surface-to-Surface Radiation>Radiation>Prescribed Radiosity

Surface-to-Surface Radiation>Prescribed Radiosity

More locations are available if the Surface-to-surface radiation check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Radiation>Prescribed Radiosity

Ribbon
Physics Tab with Surface-to-Surface Radiation selected:
Boundaries>Surface-to-Surface Radiation>Prescribed Radiosity

Physics Tab with Heat Transfer, Heat Transfer in Solids, Heat Transfer in Fluids, Heat 

Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, Heat 

Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in Participating 

Media selected:
Boundaries>Radiation>Prescribed Radiosity

Upside and downside settings can be visualized by plotting the global 
normal vector (nx, ny, nz), that always points from downside to upside. 
Note that the normal vector (ht.nx, ht.ny, ht.nz) may be oriented 
differently.

See Tangent and Normal Variables in the COMSOL Multiphysics 
Reference Manual.

To define temperature dependencies for the user inputs (surface 
emissivity for example), use the temperature variable ht.T, that 
corresponds to the appropriate variable (upside, downside, or average 
temperature of a layer, wall temperature with turbulence modeling), 
depending on the model configurations. See Boundary Wall Temperature 
for a thorough description of the boundary temperature variables.

Theory for Surface-to-Surface Radiation
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Radiation Group

This node enables you to specify radiation groups to speed up the radiation 
calculations and gather boundaries in a radiation problem that can see one another.

By default, all radiative boundaries (selected in a Diffuse Surface, Diffuse Mirror, or 
Prescribed Radiosity node) belong to the same radiation group. 

To change this, select the Use radiation groups check box under Radiation Settings to 
add a Radiation Group to a Surface-to-Surface Radiation (rad) interface or any version 
of a Heat Transfer (ht) interface with the Surface-to-surface radiation check box 
selected.

When a node is added to another radiation group, it is overridden in the default group. 
Then this boundary can be added to other radiation groups without being overridden 
by the manually added radiation groups.

The figure below shows four examples of possible boundary groupings. On boundaries 
that have no number, the user has NOT set a node among the Diffuse Surface, Diffuse 
Mirror, and Prescribed Radiosity nodes. These boundaries do not irradiate other 
boundaries, neither do other boundaries irradiate them.

Be careful when grouping boundaries in axisymmetric geometries. The 
grouping cannot be based on which boundaries have a free view toward 
each other in the 2D geometry. Instead, consider the full 3D geometry, 
obtained by revolving the model geometry about the z axis, when 
defining groups. 

For example, parallel vertical boundaries must typically belong to the 
same group in 2D axisymmetric components, but to different groups in a 
planar model using the same 2D geometry.
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On boundaries that belong to one or more radiation group, the user has set a node 
among the Diffuse Surface, Diffuse Mirror, and Prescribed Radiosity nodes. The 
numbers on each boundary specify different groups to which the boundary belongs.

Figure 6-1: Examples of radiation group boundaries.

To obtain optimal computational performance, it is good practice to specify as many 
groups as possible as opposed to specifying few but large groups. For example, case B 
is more efficient than case D.

B O U N D A R Y  S E L E C T I O N

This section should contain any boundary that is selected in a Diffuse Surface, Diffuse 

Mirror, or Prescribed Radiosity node and that has a chance to see one of the boundary 
that is already selected in the Radiation Group.

R A D I A T I O N  G R O U P

When the Wavelength dependence of emissivity is Constant, the radiation group is valid 
for all wavelengths, and all this section is then empty.

When the Wavelength dependence of emissivity is set to Solar and ambient or Multiple 

spectral bands, the radiation group is defined for all spectral bands by default. Clear 
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Radiation group defined on spectral band i check boxes to remove the Bi spectral bands 
from these radiation groups.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
If the Use radiation groups check box is selected under the Radiation Settings section:

Heat Transfer with Surface-to-Surface Radiation>Radiation>Radiation Group

Surface-to-Surface Radiation>Radiation Group

More locations are available if the Surface-to-surface radiation check box is selected 
under the Physical Model section and the Use radiation groups check box is selected 
under the Radiation Settings section. For example:
Heat Transfer in Solids>Radiation>Radiation Group

Ribbon
Physics Tab with Surface-to-Surface Radiation selected:
Boundaries>Surface-to-Surface Radiation>Radiation Group

Physics Tab with Heat Transfer, Heat Transfer in Solids, Heat Transfer in Fluids, Heat 

Transfer in Porous Media,Heat Transfer in Building Materials, Bioheat Transfer, Heat 

Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in Participating 

Media selected:
Boundaries>Radiation>Radiation Group

Several settings for this node depend on the Wavelength dependence of 

emissivity setting, which is defined for the physics interface. See Radiation 
Settings.

If this node is combined with heat transfer in 2D and 1D, the thickness is 
assumed to be infinite for the view factor computation. The user-defined 
value for d is still used in the heat transfer equation.

Theory for Surface-to-Surface Radiation
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Symmetry

This node provides a boundary condition for symmetry boundaries. This boundary 
condition is similar to a Thermal Insulation condition, and it means that there is no 
heat flux across the boundary.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Symmetry
Heat Transfer in Solids>Symmetry
Heat Transfer in Fluids>Symmetry
Heat Transfer in Porous Media>Symmetry
Bioheat Transfer>Symmetry
Heat Transfer with Surface-to-Surface Radiation>Symmetry
Heat Transfer with Radiation in Participating Media>Symmetry

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Symmetry

Temperature

Use this node to specify the temperature somewhere in the geometry, for example, on 
boundaries.

The symmetry condition only applies to the temperature field. It has no 
effect on the radiosity (surface-to-surface radiation) and on the radiative 
intensity (radiation in participating media). Use Symmetry for 
Surface-to-Surface Radiation to account for the symmetry in the 
computation of the view factors.

Heat Generation in a Disc Brake: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/brake_disc
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P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

TE M P E R A T U R E

The equation for this condition is T = T0, where T0 is the prescribed temperature on 
the boundary. For User defined, enter a value or expression for the Temperature T0. 
Else, select an Ambient temperature defined in the Ambient Settings section of a Heat 
Transfer or Heat Transfer in Shells interface.

C O N S T R A I N T  S E T T I N G S

To display this section, click the Show button ( ) and select Advanced Physics Options. 
By default Classic constraints is selected. Select the Use weak constraints check box to 
replace the standard constraints with a weak implementation. Select the Discontinuous 

Galerkin constraints button when Classic constraints do not work satisfactorily.

The Discontinuous Galerkin constraints option is especially useful to 
prevent oscillations on inlet boundaries where convection dominates. 
Unlike the Classic constraints, these constraints do not enforce the 
temperature on the boundary extremities. This is relevant on fluid inlets 
where the temperature condition should not be enforced on the walls at 
the inlet extremities. Note that Discontinuous Galerkin contraints are not 
supported for resistive thin layers or with turbulent wall functions.

You can specify a harmonic variation of the temperature value in a 
frequency domain analysis of perturbation type, by adding a Harmonic 

Perturbation subnode. See Theory for Harmonic Heat Transfer for more 
details.

Steady-State 2D Axisymmetric Heat Transfer with Conduction: 
Application Library path 
Heat_Transfer_Module/Tutorials,_Conduction/cylinder_conduction
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Temperature
Heat Transfer in Solids>Temperature
Heat Transfer in Fluids>Temperature
Heat Transfer in Porous Media>Temperature
Bioheat Transfer>Temperature
Heat Transfer with Surface-to-Surface Radiation>Temperature
Heat Transfer with Radiation in Participating Media>Temperature

Heat Transfer in Solids>Pairs>Temperature
Heat Transfer in Fluids>Pairs>Temperature
Heat Transfer in Porous Media>Pairs>Temperature
Bioheat Transfer>Pairs>Temperature
Heat Transfer with Surface-to-Surface Radiation>Pairs>Temperature
Heat Transfer with Radiation in Participating Media>Pairs>Temperature

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Temperature

Pairs>interface>Temperature

Thermal Contact

This node defines correlations for the conductance h at the interface of two bodies in 
contact. It can be added to pairs by selecting Pair Thermal Contact from the Pairs menu. 
Note that in this case the source term is applied on the destination side.

The conductance h is involved in the heat flux across the surfaces in contact according 
to:

where u and d subscripts refer to the upside and downside of the slit, respectively. Pair 

Thermal Contact should be activated on a Identity Pair or on a Contact Pair where a 
structural mechanics physics interface defines a contact pair feature.

nd– qd⋅ h– Tu Td–( ) rQb+=

nu– qu⋅ h– Td Tu–( ) 1 r–( )Qb+=
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P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

T H E R M A L  C O N T A C T

Constriction Conductance
Select a Constriction conductance: Cooper-Mikic-Yovanovich correlation (the default), 
Mikic elastic correlation, or User defined. For User defined enter a value or expression for 
hc.

Gap Conductance
Select the Gap conductance: User defined (the default) or Parallel-plate gap gas 

conductance (available if Cooper-Mikic-Yovanovich correlation or Mikic elastic correlation 
is selected as the Constriction conductance). For User defined enter a value for hg.

Radiative Conductance
When the Surface-to-surface radiation check box is selected under the Physical Model 
section on a physics interface, choose the Radiative conductance: User defined (the 
default) or Gray-diffuse parallel surfaces.

For User defined enter a value for hr.

C O N T A C T  S U R F A C E  P R O P E R T I E S

This section is available if Cooper-Mikic-Yovanovich correlation or Mikic elastic correlation 
are chosen as the Constriction conductance correlation under Contact. Enter values for 
the:

• Surface roughness, asperities average height σasp

• Surface roughness, asperities average slope masp 

• Contact pressure p

For Cooper-Mikic-Yovanovich correlation select a Hardness definition: Microhardness (the 
default), Vickers hardness, or Brinell hardness.

• For Microhardness enter a value for Hc. 

• For Vickers hardness enter a value for the Vickers correlation coefficient c1 and Vickers 

size index c2. 

• For Brinell hardness enter a value for HB. It should be between 1.30 and 7.60 GPa.
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For Mikic elastic correlation select Contact interface Young’s modulus Econtact: Weighted 

harmonic mean (the default) or User defined.

• For Weighted harmonic mean enter values or expressions for the Young’s modulus E 
and Poisson’s ratio ν.

• For User defined enter another value or expression for Econtact. 

G A P  P R O P E R T I E S

This section is available when Parallel-plate gap gas conductance is selected as the Gap 

conductance correlation under Thermal Contact.

The default Gas thermal conductivity kgap is taken From material. For User defined select 
Isotropic, Diagonal, Symmetric, or Anisotropic based on the characteristics of the gas 
thermal conductivity, and enter another value or expression.

Also enter the following:

• Gas pressure pgap

• Gas thermal accommodation parameter α

• Gas fluid parameter β

• Gas particles diameter D

R A D I A T I V E  C O N D U C T A N C E

This section is available when Gray-diffuse parallel surfaces is selected as the Radiative 

conductance correlation under Thermal Contact. 

By default the Surface emissivity ε is taken From material. For User defined enter another 
value or expression. 

T H E R M A L  F R I C T I O N

Select a Heat partition coefficient r: Charron’s relation (the default) or User defined. For 
User defined enter a value for r.

Select either the General source (the default) or Heat rate.

• For General source enter a frictional heat source Qb.

• For Heat rate enter the heat rate Pb.

Theory for Thermal Contact
B O U N D A R Y  F E A T U R E S  |  467



468 |  C H A P T E
L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Thermal Contact
Heat Transfer in Solids>Thermal Contact
Heat Transfer in Fluids>Thermal Contact
Heat Transfer in Porous Media>Thermal Contact
Bioheat Transfer>Thermal Contact
Heat Transfer with Surface-to-Surface Radiation>Thermal Contact
Heat Transfer with Radiation in Participating Media>Thermal Contact

Heat Transfer in Solids>Pairs>Pair Thermal Contact
Heat Transfer in Fluids>Pairs>Pair Thermal Contact
Heat Transfer in Porous Media>Pairs>Pair Thermal Contact
Bioheat Transfer>Pairs>Pair Thermal Contact
Heat Transfer with Surface-to-Surface Radiation>Pairs>Pair Thermal Contact
Heat Transfer with Radiation in Participating Media>Pairs>Pair Thermal Contact

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Pairs>interface>Pair Thermal Contact

Upside and downside settings can be visualized by plotting the global 
normal vector (nx, ny, nz), that always points from downside to upside. 
Note that the normal vector (ht.nx, ht.ny, ht.nz) may be oriented 
differently.

See Tangent and Normal Variables in the COMSOL Multiphysics 
Reference Manual.

Thermal Contact Resistance Between an Electronic Package and a 
Heat Sink: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/

thermal_contact_electronic_package_heat_sink
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Thermal Insulation

This node is the default boundary condition for all Heat Transfer interfaces. This 
boundary condition means that there is no heat flux across the boundary:

and hence specifies where the domain is well insulated. Intuitively, this equation says 
that the temperature gradient across the boundary is zero. For this to be true, the 
temperature on one side of the boundary must equal the temperature on the other 
side. Because there is no temperature difference across the boundary, heat cannot 
transfer across it.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Thermal Insulation
Heat Transfer in Solids>Thermal Insulation
Heat Transfer in Fluids>Thermal Insulation
Heat Transfer in Porous Media>Thermal Insulation
Bioheat Transfer>Thermal Insulation
Heat Transfer with Surface-to-Surface Radiation>Thermal Insulation
Heat Transfer with Radiation in Participating Media>Thermal Insulation

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Thermal Insulation

Thin Conductive Layer (Heat Transfer in Thin Shells Interface)

This node adds the heat equation for conductive heat transfer in shells (see 
Equation 4-50).

H E A T  C O N D U C T I O N ,  S O L I D

By default the Thermal conductivity k uses values From material. For User defined select 
Isotropic, Diagonal, Symmetric, or Anisotropic based on the characteristics of the thermal 
conductivity and enter other values or expressions in the field or matrix. 

n q⋅– 0=
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T H E R M O D Y N A M I C S ,  S O L I D

Specify the Density ρ and the Heat capacity at constant pressure Cp to describe the 
amount of heat energy required to produce a unit temperature change in a unit mass. 
The default settings use values From material for both. See Material Density in Features 
Defined on the Material Frame if a temperature-dependent density should be set. For 
User defined enter other values or expressions.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Thin Conductive Layer

Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Boundaries>Heat Transfer in Thin Shells>Thin Conductive Layer

Thin Film

This node behaves like Fluid but is applicable on boundaries.

P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

T H I N  F I L M

The available options for Thin film model are Thermally thin approximation and General. 
The former is a lumped model that accounts only for tangential temperature gradients 

Theory for Heat Transfer in Thin Structures

Theory for Surface-to-Surface Radiation

Only in-plane anisotropy is supported for the thermal conductivity of the 
thin conductive layer material.

Disk-Stack Heat Sink: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/disk_stack_heat_sink
R  6 :  T H E  H E A T  TR A N S F E R  F E A T U R E S



(along the film), whereas the latter uses the Extra Dimension tool to account also for 
the normal gradients of temperature (through the film’s thickness). The second model 
may be used for the modeling of bearings for example.

F I L M  P R O P E R T I E S

This section is only available when the node is added from one of the versions of the 
Heat Transfer interface (ht). Enter a Film thickness df.

When the node is added from one of the versions of the Heat Transfer in Thin Shells 
interface (htsh), the shell’s thickness is used instead.

L A Y E R  D I S C R E T I Z A T I O N

This section is only available when the Thin film model is set to General.

Define the Number of elements used for the discretization of the film’s thickness

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Thin Film
Heat Transfer in Solids>Thin Film
Heat Transfer in Fluids>Thin Film
Heat Transfer in Porous Media>Thin Film
Bioheat Transfer>Thin Film
Heat Transfer with Surface-to-Surface Radiation>Thin Film
Heat Transfer with Radiation in Participating Media>Thin Film
Heat Transfer in Thin Shells>Thin Film
Heat Transfer in Thin Films>Thin Film
Heat Transfer in Fractures>Thin Film

Heat Transfer>Pairs>Thin Film
Heat Transfer in Solids>Pairs>Thin Film
Heat Transfer in Fluids>Pairs>Thin Film
Heat Transfer in Porous Media>Pairs>Thin Film
Bioheat Transfer>Pairs>Thin Film

The settings for the Model Inputs, Heat Conduction, Fluid, and 
Thermodynamics, Fluid sections are the same as for Fluid.

The thermal conductivity of the thin film is supposed to be isotropic, even 
if an anisotropic property is defined for the material.
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Heat Transfer with Surface-to-Surface Radiation>Pairs>Thin Film
Heat Transfer with Radiation in Participating Media>Pairs>Thin Film

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Thin Film

Pairs>interface>Thin Film

Physics Tab with interface as Heat Transfer in Thin Shells, Heat Transfer in Thin Films or 
Heat Transfer in Fractures selected:
Boundaries>interface>Thin Film

Thin Layer

This node defines the thickness and thermal conductivity of a material located on 
internal or external boundaries. This material can be formed of one or more layers, and 
different conductive behaviors can be modeled through the setting of the Layer type:

• Select Thermally thick approximation to model a layer that is a bad thermal conductor 
compared to the adjacent geometry. In this case, the tangential heat flux is neglected 
and only the heat flux across the layer’s thickness is considered. The layer can be 
constituted of multiple sub-layers with specific thickness and conductivity. The up 
and down sides can be distinguished when a heat source is applied to the layer. This 
option may also be used to enforce consistent initial conditions. 

• Select Thermally thin approximation to model a layer that is a good thermal 
conductor compared to the adjacent geometry. In this case, the temperature 
difference and heat flux across the layer’s thickness are neglected. Only the 
tangential heat flux is considered. The up and down sides are not distinguished 
when a heat source is applied to the layer.

• Select General to model a layer in which both the normal and tangential heat fluxes 
should be considered. The layer can be constituted of multiple sub-layers with 
specific thickness and conductivity, and heat sources can be applied on a sub-layer 
selection, and on up and down sides of the layer. 
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P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

T H I N  L A Y E R

The available options for Layer type are Thermally thin approximation, Thermally thick 

approximation, and General. 

Thermally thin approximation
For Thermally thin approximation enter a value or expression for the Layer thickness ds.

Thermally thick approximation
From the Specify list select Layer properties (the default) or Thermal resistance.

• For Layer properties enter a value or expression for the Layer thickness ds. 

• For Thermal resistance enter a value or expression for the Thermal resistance Rs.

• By default the Multiple layers check box is not selected. For Layer properties click to 
select the check box to define multiple sandwiched thin layers with different thermal 
conductivities.

General
For General no additional setting is required in this section.

H E A T  C O N D U C T I O N

This section is not available when Layer type is set to Thermally thick approximation and 
Specify is set to Thermal Resistance in the Thin Layer settings. 

Thermally thin approximation (Layer Type)
For Thermally thin approximation the default Layer thermal conductivity ks is taken From 

material. For User defined select Isotropic, Diagonal, Symmetric, or Anisotropic to enter 
another value or expression. If the thickness is zero, the thin layer does not take effect.

Thermally thick approximation (Layer Type)
The default Layer thermal conductivity ks is taken From material. For User defined select 
Isotropic, Diagonal, Symmetric, or Anisotropic to enter another value or expression.
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General (Layer Type)
Select the Number of layers to define (1 to 5) and set the properties for each layer 
selected.

• Select an option from the Layer (1, 2, 3, 4, or 5) list to assign a material to each layer. 
The default Boundary material takes the material from the boundary.

• For each layer, enter the Layer thickness ds.

• The default Thermal conductivity ks is taken From material, which is then taken from 
the material selected in Layer (1, 2, ...). For User defined enter another value or 
expression.

T H E R M O D Y N A M I C S

Set the following properties for each Layer:

By default the Layer density ρs and Layer heat capacity Cp, s values are taken From 

material. See Material Density in Features Defined on the Material Frame if a 
temperature-dependent density should be set. For User defined enter other values or 
expressions. 

When Layer type is Thermally thick approximation, these properties are only used in 
time-dependent studies, but must be set in all cases.

T H I N  L A Y E R  O P A C I T Y

This section is only available when the Surface-to-surface radiation check box is selected 
under the Physical Model section on the parent physics interface.

Select Opaque (the default) or Transparent to set the layer’s opacity type.

This is needed when the thin layer (with Layer type as Thermally thick approximation or 
General) contributes with any boundary condition from the Radiation menu. It picks 
the side where irradiation starts from.

L A Y E R  D I S C R E T I Z A T I O N

This section is only available when the Layer type is set to General.
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Define the Number of elements used for discretizing the layer thickness.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Thin Layer
Heat Transfer in Solids>Thin Layer
Heat Transfer in Fluids>Thin Layer
Heat Transfer in Porous Media>Thin Layer

These subnodes are available for Thin Layer node: 

• Layer Heat Source — to add a layer internal heat source, Qs, within the 
layer. 

• Line Heat Flux (Thin Layer, Thin Film, Fracture) — to add a heat flux 
through a specified set of boundaries.

• Temperature (Thin Layer, Thin Film, Fracture, and Heat Transfer in 
Thin Shells) — to set a prescribed temperature condition on a specified 
set of boundaries. 

• Surface-to-Ambient Radiation (Thin Layer, Thin Film, Fracture) — to 
add a surface-to-ambient radiation for the layer end.

When multiple layers are defined they are numbered from the upside 
(Layer 1) to the downside.

Theory for Heat Transfer in Thin Structures

Boundary Wall Temperature

Plotting Results in Thin Layers Extra Dimensions

• Heat Transfer in a Surface-Mount Package for a Silicon Chip: 
Application Library path 
Heat_Transfer_Module/Power_Electronics_and_Electronic_Cooling/

surface_mount_package

• Silica Glass Block Coated with a Copper Layer: Application Library 
path Heat_Transfer_Module/Tutorials,_Thin_Structure/copper_layer
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Bioheat Transfer>Thin Layer
Heat Transfer with Surface-to-Surface Radiation>Thin Layer
Heat Transfer with Radiation in Participating Media>Thin Layer

Heat Transfer>Pairs>Thin Layer
Heat Transfer in Solids>Pairs>Thin Layer
Heat Transfer in Fluids>Pairs>Thin Layer
Heat Transfer in Porous Media>Pairs>Thin Layer
Bioheat Transfer>Pairs>Thin Layer
Heat Transfer with Surface-to-Surface Radiation>Pairs>Thin Layer
Heat Transfer with Radiation in Participating Media>Pairs>Thin Layer

Ribbon
Physics Tab with interface as Heat Transfer, Heat Transfer in Solids, Heat Transfer in 

Fluids, Heat Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, 
Heat Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in 

Participating Media selected:
Boundaries>interface>Thin Layer

Pairs>interface>Thin Layer

Thin Layered Shell (Heat Transfer in Thin Shells Interface)

Use this node on the boundary of a thin shell. This overrides Thin Conductive Layer 
(Heat Transfer in Thin Shells Interface) to enable modeling multiple sandwich layers 
in the shell interface.

H E A T  C O N D U C T I O N

Select the Number of layers to define (1 to 5) and set the properties for each layer.

• Select an option from the Layer (1, 2, 3, 4, or 5) list to assign a material to each layer. 
The default setting, Boundary material, takes the material from the boundary.

• For each layer, enter the Layer thickness ds.

• The default Thermal conductivity ks is taken From material, which is then taken from 
the material selected in Layer (1, 2, ...). For User defined enter another value or 
expression.

T H E R M O D Y N A M I C S

Set the following properties for each Layer.

By default the Layer density ρs and Layer heat capacity Cp, s values are taken From 

material. See Material Density in Features Defined on the Material Frame if a 
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temperature-dependent density should be set. For User defined enter other values or 
expressions.

L A Y E R  D I S C R E T I Z A T I O N

This section is available when the Layer type is set to General. Define the Number of 

elements per layer used for the discretization of the thickness for each layer (the default 
is 2).

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Thin Layered Shell

Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Boundaries>Heat Transfer in Thin Shells>Thin Layered Shell

When multiple layers are defined they are numbered from the upside 
(Layer 1) to the downside.

Theory for Heat Transfer in Thin Structures

Plotting Results in Thin Layers Extra Dimensions
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Edg e  F e a t u r e s

The Heat Transfer interfaces have the following edge nodes and subnodes available: 

Change Effective Thickness (Heat Transfer in Thin Shells Interface)

This node models edges (3D components) or point (2D and 2D axisymmetric 
components) with another thickness than the overall thickness that is specified in the 
Heat Transfer in Thin Shells interface Shell Thickness section (0.01 m by default). It 
defines the height of the part of the edge that is exposed to the ambient surroundings.

P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

• Change Effective Thickness (Heat 
Transfer in Thin Shells Interface)

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface) 

• Insulation/Continuity (Heat 
Transfer in Thin Shells Interface)

• Line Heat Source (Thin Rod)

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source

• Surface-to-Ambient Radiation 
(Heat Transfer in Thin Shells 
Interface)

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Thin Rod

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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Enter a value for the Effective thickness ds. This value replaces the overall thickness in 
the selection.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Change Effective Thickness

Heat Transfer in Thin Shells>Pairs>Change Effective Thickness

Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Support>Heat Transfer in Thin Shells>Change Effective Thickness

Pairs>Change Effective Thickness

with Support as Egdes in 3D and Points in 2D. 

Heat Flux (Heat Transfer in Thin Shells Interface)

Use this node to add heat flux across boundaries of a thin shell. A positive heat flux 
adds heat to the domain. This feature adds a heat source (or sink) to edges. It adds a 
heat flux q = dsq0.

F R A M E  S E L E C T I O N

To display this section add both a Heat Transfer in Thin Shells (htsh) and Moving 

Mesh (ale) interface (found under the Mathematics>Deformed Mesh branch when adding 
a physics interface). Then click the Show button ( ) and select Advanced Physics 

Options. The rest of the settings are the same for the Heat Flux node as described under 
Frame Selection.

H E A T  F L U X

These settings are the same as for the Heat Flux node available for the other interfaces.

Theory for Heat Transfer in Thin Structures

In 2D, q = dsdzq0 to account for the out-of-plane thickness.
E D G E  F E A T U R E S  |  479



480 |  C H A P T E
L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Heat Flux

Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Support>Heat Transfer in Thin Shells>Heat Flux

with Support as Egdes in 3D and Points in 2D. 

Heat Source (Heat Transfer in Thin Shells Interface)

This node models a linear heat source (or sink). It adds a heat source q = Ql, q = dsQb, 
or q = Pb ⁄ L. A positive q is heating and a negative q is cooling.

P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

H E A T  S O U R C E

Click the General source (the default) or Heat rate button.

For General source, from the Edge heat source type list, select Heat source defined per 

unit of length (the default) or Heat source defined per unit of area. 

• For Heat source defined per unit of length enter a value for the distributed heat 
source, Ql in unit power per unit length. Positive Ql is heating and a negative Ql is 
cooling. 

• For Heat source defined per unit of area enter the boundary heat source Qb. A 
positive Qb is heating and a negative Qb is cooling.

Theory for Heat Transfer in Thin Structures

Handling Frames in Heat Transfer

Shell Conduction: Application Library path 
Heat_Transfer_Module/Tutorials,_Thin_Structure/shell_conduction
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For Heat rate enter the heat rate Pb. In this case Ql = Pb ⁄ L, where L is the total length 
of the selected edges.

F R A M E  S E L E C T I O N

The settings are the same for the Heat Source node Frame Selection section.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Heat Source

Heat Transfer in Thin Shells>Pairs>Heat Source

Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Support>Heat Transfer in Thin Shells>Heat Source 
Pairs>Heat Source

with Support as Egdes in 3D and Points in 2D. 

Insulation/Continuity (Heat Transfer in Thin Shells Interface)

This node is the default edge condition on thin shells. On external edges, this 
condition means that there is no heat flux across the edge:

In 2D components, the equation contains an additional factor, dz, to 
account for the out-of-plane thickness. This is because the selected points 
correspond to edges in a 3D geometry.

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.

Theory for Heat Transfer in Thin Structures

Handling Frames in Heat Transfer

n– q⋅ 0=
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On internal edges, this condition means that the temperature field and its flux is 
continuous across the edge.

P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Insulation/Continuity

Heat Transfer in Thin Shells>Pairs>Insulation/Continuity

Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Support>Heat Transfer in Thin Shells>Insulation/Continuity

Pairs>Insulation/Continuity

with Support as Egdes in 3D and Points in 2D. 

Line Heat Source (Thin Rod)

Use this subnode to add an internal heat source, Ql, within the rod. Add one or more 
heat sources. 

Theory for Heat Transfer in Thin Structures

Shell Conduction: Application Library path 
Heat_Transfer_Module/Tutorials,_Thin_Structure/shell_conduction
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L I N E  H E A T  S O U R C E

Select the General source (the default) or Heat rate button to define Ql.

• For General source enter a value or expression for Ql as a heat source per volume. 

• For Heat rate define the heat rate Pl. In this case Ql = Pl ⁄ V.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Edges>Thin Rod>Line Heat Source

More locations are available. For example:
Heat Transfer in Fluids>Edges>Thin Rod>Line Heat Source

Ribbon
Physics Tab with Thin Rod selected in the model tree:
Attributes>Line Heat Source

Line Heat Flux (Thin Layer, Thin Film, Fracture)

Use this subnode to add heat flux across boundaries of a thin layer, a thin film or a 
fracture. A positive heat flux adds heat to the layer. 

H E A T  F L U X

Click the General inward heat flux (the default), Convective heat flux, or Heat rate (3D 
components only) button.

• If General inward heat flux is selected, it adds q0 to the total flux across the selected 
edges. Enter a value for q0 to represent a heat flux that enters the layer. For example, 

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.

Thin Rod
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any electric heater is well represented by this condition and its geometry can be 
omitted. 

• If Convective heat flux is selected, it adds q0 in the form q0 = h ⋅ (Text − T). Enter the 
Heat transfer coefficient h and the External temperature Text. This latter value 
depends on the geometry and the ambient flow conditions. For User defined, enter 
a value or expression. Else, select an Ambient temperature defined in the Ambient 
Settings section of a Heat Transfer or Heat Transfer in Shells interface.

• 3D Components: If Heat rate is selected, it adds q0 in the form q0 = P0 ⁄ A where 
A = Lds (for Thin Layer), A = Ldf (for Thin Film), or A = Ldfr (for Fracture), and L is 
equal to the length of the edge selection. Enter the heat rate P0. 

F R A M E  S E L E C T I O N

This section is available with 3D components. The settings are the same for the Heat 
Source node and described under Frame Selection.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Thin Layer>Line Heat Flux
Heat Transfer in Solids>Thin Film>Line Heat Flux
Heat Transfer in Porous Media>Fracture>Line Heat Flux

When Line Heat Flux is applied on a pair, the flux is only applied on the 
edge adjacent to the source boundary which is in contact with the 
destination boundary. Consider adding another pair with opposite source 
and destination boundaries to apply a flux on the edge adjacent to the 
destination boundary and in contact with the source boundary.

See Identity and Contact Pairs in the COMSOL Multiphysics Reference 
Manual for more details.

Thin Layer

Thin Film

Fracture

Theory for Heat Transfer in Thin Structures

Handling Frames in Heat Transfer
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Ribbon
Physics Tab with Thin Layer, Thin Film, or Fracture selected in the model tree:
Attributes>Line Heat Flux

Line Heat Source 

This node models a heat source (or sink) that is so thin that it has no thickness in the 
model geometry. It is available in 3D on edges. In 2D and 2D axisymmetric, it is 
available on points.

In theory, the temperature in a line source in 3D is plus or minus infinity (to 
compensate for the fact that the heat source does not have any volume). The finite 
element discretization used in COMSOL Multiphysics returns a finite temperature 
distribution along the line, but that distribution must be interpreted in a weak sense.

L I N E  H E A T  S O U R C E

Click the General source (the default) or Heat rate button.

• If General source is selected, enter a value for the distributed heat source, Ql in unit 
power per unit length. A positive Ql corresponds to heating while a negative Ql 
corresponds to cooling. 

• If Heat rate is selected, enter the heat rate Pl.

H E A T  S O U R C E  R A D I U S

With the Heat Transfer Module, you can model the heat source explicitly and apply it 
on a cylinder around the line.

Select the Specify heat source radius check box to define the Heat source radius R. This 
averages the source on a cylinder of given radius around the line. This option avoids 
obtaining an increasing temperature value at the line when meshing finer than this 
radius. It makes use of the diskavg operator for averaging around the source.

F R A M E  S E L E C T I O N

The settings are the same as for the Heat Source node and are described under Frame 

Selection.

See Built-In Operators in the COMSOL Multiphysics Reference Manual 
for additional information about the diskavg operator.
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>support>Line Heat Source

Heat Transfer in Solids>support>Line Heat Source

Heat Transfer in Fluids>support>Line Heat Source

Heat Transfer in Porous Media>support>Line Heat Source

Bioheat Transfer>support>Line Heat Source

Heat Transfer with Surface-to-Surface Radiation>support>Line Heat Source

Heat Transfer with Radiation in Participating Media>support>Line Heat Source

Ribbon
Physics Tab with Heat Transfer, Heat Transfer in Solids, Heat Transfer in Fluids, Heat 

Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, Heat 

Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in Participating 

Media selected:
Support>Line Heat Source

with Support as Egdes in 3D and Points in 2D. 

Surface-to-Ambient Radiation (Heat Transfer in Thin Shells 
Interface)

Use this node to add surface-to-ambient radiation to edges of a thin shell. The net 
inward heat flux from surface-to-ambient radiation is

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.

• Handling Frames in Heat Transfer

• About the Heat Transfer Interfaces

n– q⋅ dsεσ Tamb
4 T4

–( )=
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where ε is the surface emissivity, σ is the Stefan-Boltzmann constant (a predefined 
physical constant), and Tamb is the ambient temperature.

P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

S U R F A C E - T O - A M B I E N T  R A D I A T I O N

Surface emissivity
The default Surface emissivity ε (a dimensionless number between 0 and 1) is taken 
From material. For User defined, it should be specified. An emissivity of 0 means that 
the surface emits no radiation at all while an emissivity of 1 means that it is a perfect 
blackbody.

Ambient temperature
For User defined, enter an Ambient temperature Tamb. Else, select an Ambient 

temperature defined in the Ambient Settings section of a Heat Transfer or Heat 
Transfer in Shells interface.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Surface-to-Ambient Radiation

Heat Transfer in Thin Shells>Pairs>Surface-to-Ambient Radiation

Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Support>Heat Transfer in Thin Shells>Surface-to-Ambient Radiation

Pairs>Surface-to-Ambient Radiation

with Support as Egdes in 3D and Points in 2D. 

In 2D, the equation has an additional factor, dz, to account for the 
out-of-plane thickness.

Theory for Heat Transfer in Thin Structures
E D G E  F E A T U R E S  |  487



488 |  C H A P T E
Surface-to-Ambient Radiation (Thin Layer, Thin Film, Fracture)

Use this subnode to add surface-to-ambient radiation to lines (geometrical edges in 
3D or geometrical points in 2D and 2D axisymmetric) that represent thin boundaries 
of a thin layer, a thin film, or a fracture. 

The net inward heat flux from surface-to-ambient radiation is

where ds is the layer thickness (replaced by df for a thin film, and by dfr for a fracture), 
ε is the surface emissivity, σ is the Stefan-Boltzmann constant (a predefined physical 
constant), and Tamb is the ambient temperature.

S U R F A C E - T O - A M B I E N T  R A D I A T I O N

Ambient temperature
For User defined, enter an Ambient temperature Tamb. The default value is 
approximately room temperature, 293.15 K (20 ºC). Else, select an Ambient 

temperature defined in the Ambient Settings section of a Heat Transfer or Heat 
Transfer in Shells interface.

Surface emissivity
The default Surface emissivity ε (a dimensionless number between 0 and 1) is taken 
From material. For User defined, it should be specified. An emissivity of 0 means that 
the surface emits no radiation at all while an emissivity of 1 means that it is a perfect 
blackbody.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Thin Layer>Surface-to-Ambient Radiation
Heat Transfer in Solids>Thin Film>Surface-to-Ambient Radiation
Heat Transfer in Porous Media>Fracture>Surface-to-Ambient Radiation

Q sd
∂S
∂S 0→

lim dsεσ Tamb
4 T4

–( )=

Thin Layer

Thin Film

Fracture

Theory for Heat Transfer in Thin Structures
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Ribbon
Physics Tab with Thin Layer, Thin Film, or Fracture selected in the model tree:
Attributes>Surface-to-Ambient Radiation

Temperature (Thin Layer, Thin Film, Fracture, and Heat Transfer in 
Thin Shells)

Use this subnode to specify the temperature on a set of lines (geometrical edges in 3D 
or geometrical points in 2D and 2D axisymmetric) that represent the boundaries of a 
thin domain (layer, film, fracture, or shell). Only edges (3D) or points (2D and 2D 
axisymmetric) adjacent to the boundaries can be selected in the parent node.

TE M P E R A T U R E

For User defined, enter a value or expression for the Temperature T0. Else, select an 
Ambient temperature defined in the Ambient Settings section of a Heat Transfer or 
Heat Transfer in Shells interface.

The equation for this condition is T = T0 where T0 is the prescribed temperature.

C O N S T R A I N T  S E T T I N G S

To display this section, click the Show button ( ) and select Advanced Physics Options.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Thin Layer>Temperature
Heat Transfer in Solids>Thin Film>Temperature

You can specify a harmonic variation of the temperature value in a 
frequency domain analysis of perturbation type, by adding a Harmonic 

Perturbation subnode. See Theory for Harmonic Heat Transfer for more 
details.

Thin Layer

Thin Film

Fracture

Theory for Heat Transfer in Thin Structures
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Heat Transfer in Porous Media>Fracture>Temperature
Heat Transfer in Thin Shells>Temperature
Heat Transfer in Thin Shells>Pairs>Temperature

Ribbon
Physics Tab with Thin Layer, Thin Film, or Fracture selected in the model tree:
Attributes>Temperature

Physics Tab with Heat Transfer in Thin Shells selected in the model tree:
Support>Heat Transfer in Thin Shells>Temperature

Pairs>Temperature

with Support as Egdes in 3D and Points in 2D.

Thin Rod 

Use this node to define the thermal and radius properties of conductive rods located 
on edges in a 3D component. 

T H I N  R O D

The Rod radius rl should be specified.

H E A T  C O N D U C T I O N

The Thermal conductivity kl should be specified. By default it is taken From material. 
For User defined select Isotropic, Diagonal, Symmetric, or Anisotropic to enter another 
value or expression.

T H E R M O D Y N A M I C S

By default the Density ρl and the Heat capacity at constant pressure Cp, l values are taken 
From material. See Material Density in Features Defined on the Material Frame if a 

Shell Conduction: Application Library path 
Heat_Transfer_Module/Tutorials,_Thin_Structure/shell_conduction
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temperature-dependent density should be set. For User defined enter other values or 
expressions.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer>Edges>Thin Rod
Heat Transfer in Solids>Edges>Thin Rod
Heat Transfer in Fluids>Edges>Thin Rod
Heat Transfer in Porous Media>Edges>Thin Rod
Bioheat Transfer>Edges>Thin Rod
Heat Transfer with Surface-to-Surface Radiation>Edges>Thin Rod
Heat Transfer with Radiation in Participating Media>Edges>Thin Rod

Ribbon
Physics Tab with Heat Transfer, Heat Transfer in Solids, Heat Transfer in Fluids, Heat 

Transfer in Porous Media, Heat Transfer in Building Materials, Bioheat Transfer, Heat 

Transfer with Surface-to-Surface Radiation or Heat Transfer with Radiation in Participating 

Media selected:
Edges>Thin Rod

These additional subnodes are available for the Thin Rod node: 

• Line Heat Source (Thin Rod) — to add an internal heat source, Ql, 
within the rod. 

• Temperature (Thin Rod) — to set a prescribed temperature condition 
on a specified set of points.

• Point Heat Flux (Thin Rod) — to add a heat flux through a specified 
set of points. 

• Surface-to-Ambient Radiation (Thin Rod) — to add 
surface-to-ambient radiation at the rod end points.
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Po i n t  F e a t u r e s

The Heat Transfer interfaces have the following point nodes and subnodes available: 

Heat Source (Heat Transfer in Thin Shells Interface)

This node, available in 3D and 2D axisymmetric components only, models a point heat 
source (or sink). 

PO I N T  H E A T  S O U R C E

Enter the Point heat source Qp in unit power. A positive Qp is heating and a negative 
Qp is cooling. 

• Change Effective Thickness (Heat 
Transfer in Thin Shells Interface)

• Heat Flux (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Heat Source (Heat Transfer in Thin 
Shells Interface)

• Insulation/Continuity (Heat 
Transfer in Thin Shells Interface)

• Line Heat Flux (Thin Layer, Thin 
Film, Fracture)

• Line Heat Source 

• Point Heat Flux (Thin Rod)

• Point Heat Source

• Point Heat Source on Axis

• Surface-to-Ambient Radiation 
(Heat Transfer in Thin Shells 
Interface)

• Surface-to-Ambient Radiation (Thin 
Layer, Thin Film, Fracture)

• Surface-to-Ambient Radiation (Thin 
Rod)

• Temperature (Thin Layer, Thin 
Film, Fracture, and Heat Transfer in 
Thin Shells)

• Temperature (Thin Rod)

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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H E A T  S O U R C E  R A D I U S

Select the Specify heat source radius check box to define the Heat source radius R. This 
setting averages the source on a cylinder of a given radius around the line, and avoids 
getting an increasing temperature value at the line when meshing finer than this radius. 
It makes use of the diskavg operator for averaging around the source.

F R A M E  S E L E C T I O N

This section is not available if the Specify heat source radius option is disabled. The 
settings are the same for the Heat Source node Frame Selection section 

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Thin Shells>Points>Heat Source

Ribbon
Physics Tab with Heat Transfer in Thin Shells selected:
Points>Heat Source

Point Heat Flux (Thin Rod)

Use this subnode to add heat flux at points of a thin rod. A positive heat flux adds heat 
to the rod. 

See Built-In Operators in the COMSOL Multiphysics Reference Manual 
for additional information about the diskavg operator.

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.

Theory for Heat Transfer in Thin Structures

Handling Frames in Heat Transfer
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H E A T  F L U X

Select either the General inward heat flux (the default) or Convective heat flux buttons.

• If General inward heat flux is selected, it adds q0 to the total flux across the selected 
points. Enter a value for q0 to represent a heat flux that enters the rod.

• If Convective heat flux is selected, it adds q0 in the form q0 = h ⋅ (Text − T). Enter the 
Heat transfer coefficient h and the External temperature Text. The value depends on 
the geometry and the ambient flow conditions.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Thin Rod>Point Heat Flux

More locations are available. For example:
Heat Transfer in Fluids>Thin Rod>Point Heat Flux

Ribbon
Physics Tab with Thin Rod selected in the model tree:
Attributes>Point Heat Flux

Point Heat Source 

This node, available for 3D components, models a heat source (or sink) that is so small 
that it can be considered to have no spatial extension. 

In theory, the temperature in a point source in 3D is plus infinity (to compensate for 
the fact that the heat source does not have a spatial extension). The finite element 
discretization used in COMSOL Multiphysics returns a finite value, but that value 
must be interpreted in a weak sense.

PO I N T  H E A T  S O U R C E

Enter the Point heat source Qp in unit power. A positive Qp corresponds to heating 
while a negative Qp corresponds to cooling. 

Thin Rod
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H E A T  S O U R C E  R A D I U S

With the Heat Transfer Module, you can model the heat source explicitly and apply it 
on a ball or disk around the point.

Select the Specify heat source radius check box to define the Heat source radius R. This 
setting averages the source on a ball or disk of given radius around the point, and 
avoids obtaining an increasing temperature shift at the point when meshing finer than 
this radius. It makes use of the ballavg or diskavg operator for averaging around the 
source.

F R A M E  S E L E C T I O N

This section is not available if the Specify heat source radius option is disabled. The 
settings are the same as for the Heat Source node and are described under Frame 

Selection.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Points>Point Heat Source

Heat Transfer in Fluids>Points>Point Heat Source

See Built-In Operators in the COMSOL Multiphysics Reference Manual 
for additional information about the ballavg and diskavg operators.

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.

• Handling Frames in Heat Transfer

• About the Heat Transfer Interfaces

Heat Conduction with a Localized Heat Source on a Disk: Application 
Library path 
Heat_Transfer_Module/Verification_Examples/localized_heat_source
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Heat Transfer in Porous Media>Points>Point Heat Source

Bioheat Transfer>Points>Point Heat Source

Heat Transfer with Surface-to-Surface Radiation>Points>Point Heat Source

Heat Transfer with Radiation in Participating Media>Points>Point Heat Source

Ribbon
Physics Tab with Heat Transfer in Solids, Heat Transfer in Fluids, Heat Transfer in Porous 

Media, Heat Transfer in Building Materials, Bioheat Transfer, Heat Transfer with 

Surface-to-Surface Radiation or Heat Transfer with Radiation in Participating Media 

selected:
Points>Point Heat Source

Point Heat Source on Axis 

This node, available for 2D axisymmetric components, models a heat source (or sink) 
that is so small that it can be considered to have no spatial extension. 

The settings are the same as for the Point Heat Source node.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Points>Point Heat Source on Axis

Heat Transfer in Fluids>Points>Point Heat Source on Axis

Heat Transfer in Porous Media>Points>Point Heat Source on Axis

Bioheat Transfer>Points>Point Heat Source on Axis

Heat Transfer with Surface-to-Surface Radiation>Points>Point Heat Source on Axis

Heat Transfer with Radiation in Participating Media>Points>Point Heat Source on Axis

Ribbon
Physics Tab with Heat Transfer in Solids, Heat Transfer in Fluids, Heat Transfer in Porous 

Media, Heat Transfer in Building Materials, Bioheat Transfer, Heat Transfer with 

Surface-to-Surface Radiation or Heat Transfer with Radiation in Participating Media 

You can specify the source to be a harmonic perturbation in a frequency 
domain analysis. To mark the source as being a harmonic perturbation, 
right-click the node and choose Harmonic Perturbation. Note that this 
updates the node’s icon. See Theory for Harmonic Heat Transfer for 
more details.
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selected:
Points>Point Heat Source on Axis

Surface-to-Ambient Radiation (Thin Rod)

Use this subnode to add surface-to-ambient radiation to points that represent 
boundaries of a thin rod. 

The net inward heat flux from surface-to-ambient radiation is

where ε is the surface emissivity, σ is the Stefan-Boltzmann constant (a predefined 
physical constant), and Tamb is the ambient temperature.

S U R F A C E - T O - A M B I E N T  R A D I A T I O N

Ambient temperature
For User defined, enter an Ambient temperature Tamb. The default value is 
approximately room temperature, 293.15 K (20 ºC). Else, select an Ambient 

temperature defined in the Ambient Settings section of a Heat Transfer or Heat 
Transfer in Shells interface.

Surface emissivity
The default Surface emissivity ε (a dimensionless number between 0 and 1) is taken 
From material. For User defined, it should be specified. An emissivity of 0 means that 
the surface emits no radiation at all while an emissivity of 1 means that it is a perfect 
blackbody.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Thin Rod>Surface-to-Ambient Radiation

More locations are available. For example:
Heat Transfer in Fluids>Thin Rod>Surface-to-Ambient Radiation

Q sd
∂S
∂S 0→

lim dsεσ Tamb
4 T4

–( )=

Thin Rod
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Ribbon
Physics Tab with Thin Rod selected in the model tree:
Attributes>Surface-to-Ambient Radiation

Temperature (Thin Rod)

Use this subnode to specify the temperature on a set of points that represent 
boundaries of a rod. Only points adjacent to the boundaries can be selected in the 
parent node.

TE M P E R A T U R E

For User defined, enter a value or expression for the Temperature T0. Else, select an 
Ambient temperature defined in the Ambient Settings section of a Heat Transfer or 
Heat Transfer in Shells interface. The equation for this condition is T = T0 where T0 
is the prescribed temperature on the points. 

C O N S T R A I N T  S E T T I N G S

To display this section, click the Show button ( ) and select Advanced Physics Options.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer in Solids>Thin Rod>Temperature

More locations are available. For example:
Heat Transfer in Fluids>Thin Rod>Temperature

Ribbon
Physics Tab with Thin Rod selected in the model tree:
Attributes>Temperature

Thin Rod

You can specify a harmonic variation of the temperature value in a 
frequency domain analysis of perturbation type, by adding a Harmonic 

Perturbation subnode. See Theory for Harmonic Heat Transfer for more 
details.
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G l oba l  F e a t u r e s

The Heat Transfer interfaces have the following global nodes available: 

External Radiation Source

Use this node in 2D and 3D components to define an external radiation source as a 
point or directional radiation source with view factor calculation. Each External 

Radiation Source node contributes to the incident radiative heat flux on all spectral 
bands, GBi on all the boundaries where a Diffuse Surface or Diffuse Mirror boundary 
condition is active. The source contribution, GextDir, Bi, is equal to the product of the 
view factor of the source by the source radiosity. For radiation sources located on a 
point, GextDir, Bi=Fext, Bi Ps, Bi. For directional radiative source, GextDir, Bi=Fext, Bi 
q0, s.

Only direct irradiation from the source is accounted for. Diffuse irradiation inclusion 
is controlled through the Include diffuse radiation check box in Ambient section of 
Diffuse Surface and Diffuse Mirror features.

D I R E C T  I R R A D I A T I O N  S O U R C E

Select a Source position: Point coordinate (the default) or Infinite distance. In 3D, Solar 

position is also available.

• External Radiation Source

• Symmetry for Surface-to-Surface 
Radiation

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

• The external radiation sources are ignored on the boundaries when 
neither Diffuse Surface nor Diffuse Mirror is active.

• If this feature is combined with heat transfer in 2D and 1D, the 
thickness is assumed to be infinite for the view factor computation. The 
user-defined value for d is still used in the heat transfer equation.
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Point Coordinate
For Point coordinate define the Source location xs and the Source power Ps. The source 
radiates uniformly in all directions.

If Wavelength dependence of emissivity is Solar and ambient or Multiple spectral bands, 
set the Source power definition to Blackbody or User defined. When Blackbody is selected, 
enter the Source temperature, Ts, to define the source power on the spectral band Bi 
as Ps, Bi = FEPBi(Ts)Ps where FEPBi(Ts) is the fractional blackbody emissive power 
over Bi interval at Ts. When User defined is selected, enter an expression to define the 
source power on each spectral band Bi, Ps, Bi.

Infinite Distance
For Infinite distance define the Incident radiation direction is and the Source heat flux 
q0,s.

If Wavelength dependence of emissivity is Solar and ambient or Multiple spectral bands, 
set the Source heat flux definition to Blackbody or User defined. 

• When Blackbody is selected, enter the Source temperature, Ts, to define the source 
heat flux on the spectral band Bi as q0, s, Bi = q0, sFEPBi(Ts)q0, s where FEPBi(Ts) 
is the fractional blackbody emissive power over Bi interval at Ts. 

• When User defined is selected, enter an expression to define the source heat flux on 
each spectral band Bi, q0, s, Bi.

Solar Position

Depending on the type of Ambient data selected in the Ambient Settings section of the 
parent physics interface, further parameters should be set for the definition of the 
location on earth. 

xs should not belong to any surface where a Diffuse Surface or Diffuse 

Mirror boundary condition is active.

Solar position is available for 3D components. When this option is 
selected, use it to estimate the external radiative heat source due to the 
direct striking of the Sun rays.

North, west, and the up directions correspond to the x, y, and z 
directions, respectively. Azimuth angle is measured from true north, 
hence x direction corresponds to true north as well.
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If the type of Ambient data is Meteorological data (ASHRAE 2013), the location is set to 
the Weather station selected in the Ambient Settings section. Click to select the Include 

daylight saving time (Time zone + 1) check box to add one hour to the default setting 
for the station selected. 

Else, when Ambient data is User defined, the following parameters should be set.

Select an option from the Location defined by list: Coordinates (the default) or City.

For City select a predefined city and country combination from the list. Click to select 
the Include daylight saving time (Time zone + 1) check box to add one hour to the 
default setting for the city selected. For example, if New York City, USA is selected and 
the default standard time zone is UTC–5 hours, when the check box is selected, the 
daylight saving time is used instead (UTC–4 hours).

If Coordinates is selected, or your city is not listed in the Location defined by table, define 
the following parameters:

• Latitude, a decimal value, positive in the northern hemisphere (the default is 
Greenwich UK latitude, 51.477). Enter a value without a unit to avoid double 
conversion. This is because the latitude value is expected to represent degrees but 
the model’s unit for angles may be different (for example, the SI unit for the angle 
is radians).

• Longitude, a decimal value, positive at the east of the Prime Meridian (the default is 
Greenwich UK longitude, −0.0005). Enter a value without a unit to avoid double 
conversion. This is because the latitude value is expected to represent degrees but 
the model’s unit for angles may be different (for example, the SI unit for the angle 
is radians). 

• Time zone, the number of hours to add to UTC to get local time (the default is 
Greenwich UK time zone, 0). For example in New York City, USA the time zone is 
UTC–5 hours (standard time zone) or UTC–4 hours (with daylight saving time).

For either selection (City or Coordinates), in the Date table enter the:

• Day, the default is 01. Enter a value without a unit to avoid double conversion. This 
is because the value is expected to represent days but the model’s unit for time may 
be different (for example, the SI unit for time is seconds).
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• Month, the default is 6 (June). Enter a value without a unit to avoid double 
conversion. This is because the value is expected to represent months but the 
model’s unit for time may be different (for example, the SI unit for time is seconds).

• Year, the default is 2012. Enter a value without a unit to avoid double conversion. 
This is because the value is expected to represent years but the model’s unit for time 
may be different (for example, the SI unit for time is seconds). The solar position is 
accurate for a date between 2000 and 2199.

For either selection (City or Coordinates), in the Local time table enter the:

• Hour, the default is 12. Enter a value without a unit to avoid double conversion. This 
is because the value is expected to represent hours but the model’s unit for time may 
be different (for example, the SI unit for time is seconds).

• Minute, the default is 0. Enter a value without a unit to avoid double conversion. 
This is because the value is expected to represent minutes but the model’s unit for 
time may be different (for example, the SI unit for time is seconds). 

• Second, the default is 0.

For temporal studies, these inputs define the starting time of the simulation. By 
default, the Update time from solver check box is selected, and the time is then 
automatically updated with the time from the solver. Unselect this check box to 
manually set the time update.

For either selection of Ambient data type in the Ambient Settings section, define the 
Solar irradiance field Is as the incident radiative intensity coming directly from the sun. 
Is represents the heat flux received from the sun by a surface perpendicular to the sun 
rays. When surfaces are not perpendicular to the sun rays the heat flux received from 
the sun depends on the incident angle.

For User defined, enter a value or expression for the Solar irradiance Is. Else, select a 
Clear sky noon beam normal irradiance defined in the Ambient Settings section of a Heat 
Transfer or Heat Transfer in Shells interface.

If Wavelength dependence of emissivity is Solar and ambient or Multiple spectral bands, 
the solar irradiance is divided among all spectral bands Bi as 
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q0, s, Bi = q0,sFEPBi(Tsun)q0, s where FEPBi(Tsun) is the fractional blackbody 
emissive power over Bi interval at Tsun = 5780 K.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer with Surface-to-Surface Radiation>Global>External Radiation Source

Surface-to-Surface Radiation>Global>External Radiation Source

More locations are available if the Surface-to-surface radiation check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Global>External Radiation Source

Ribbon
Physics Tab with Heat Transfer in Solids, Heat Transfer in Fluids, Heat Transfer in Porous 

Media, Heat Transfer in Building Materials, Bioheat Transfer, Heat Transfer with 

Surface-to-Surface Radiation, Surface-to-Surface Radiation or Heat Transfer with Radiation 

The Wavelength dependence of emissivity is defined in the physics interface 
settings, in the Radiation Settings section. When only one spectral band 
is defined, the Bi subscript in variable names is removed.

The sun position is updated if the location, date, or local time changes 
during a simulation. In particular for transient analysis, if the unit system 
for the time is in seconds (the default), the time change can be taken into 
account by adding t to the Second field in the Local time table. Note that 
no validity range is prescribed on the time inputs. It is possible to enter 
values that exceed the expected boundary. For example, entering 5h 2min 
81s is equivalent to 5h 3min 21s. This makes it possible to enter t in the 
second field, even if the solution is computed for more than 60s.

The Heat Transfer with Surface-to-Surface Radiation Interface

Theory for Surface-to-Surface Radiation

Sun’s Radiation Effect on Two Coolers Placed Under a Parasol: 
Application Library path Heat_Transfer_Module/Thermal_Radiation/parasol
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in Participating Media selected:
Global>External Radiation Source

Symmetry for Surface-to-Surface Radiation

Use this node to compute view factors on only a part of a symmetric geometry to 
improve efficiency, by defining either one symmetry plane in 2D, 2D axisymmetric, 
and 3D components, multiple perpendicular symmetry planes in 2D and 3D 
components; or sectors of symmetry in 2D and 3D components. In addition, a 
reflection plane can be defined inside each sector of symmetry. Table 6-4 summarizes 
the available options for each dimension.

TABLE 6-4:  OPTIONS FOR SYMMETRY DEFINITION, EXAMPLE WITH 5 SECTORS

SYMMETRY 
TYPE

2D 2D AXISYMMETRIC 3D

One Plane

Two 
Planes

Not applicable

Three 
Planes

Not applicable Not applicable
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S Y M M E T R Y  F O R  S U R F A C E - T O - S U R F A C E  R A D I A T I O N

Depending on component’s dimension, select the Type of symmetry to be defined:

• In 2D components, select between Plane of symmetry (the default), Two 

perpendicular planes of symmetry, or Sectors of symmetry. 

• In 2D axisymmetric components, only the Plane of symmetry option is available. 

• In 3D components, select between Plane of symmetry (the default), Two 

perpendicular planes of symmetry, Three perpendicular planes of symmetry, or Sectors 

of symmetry. 

Depending on the Type of symmetry selected from the list and on the dimension, 
further settings are required.

Plane of symmetry
The coordinates of the points defining the plane should be set:

• In 2D components, the symmetry plane is defined by two points. Set the x and y 
coordinates of the First point on plane of reflection and of the Second point on plane 

of reflection.

• In 2D axisymmetric components, the symmetry plane is parallel to the z=0 plane. 
Set the z coordinate of plane of reflection, zsym.

Sectors Not applicable

Sectors 
and 
Reflection

Not applicable

TABLE 6-4:  OPTIONS FOR SYMMETRY DEFINITION, EXAMPLE WITH 5 SECTORS

SYMMETRY 
TYPE

2D 2D AXISYMMETRIC 3D
G L O B A L  F E A T U R E S  |  505



506 |  C H A P T E
• In 3D components, the symmetry plane is defined by three points. Set the x, y, and 
z coordinates of the First point on plane of reflection, the Second point on plane of 

reflection, and the Third point on plane of reflection.

The Show the plane of symmetry check box is selected by default. Clear it to hide the 
plane in the Graphics window.

Two perpendicular planes of symmetry
• In 2D components, the planes intersection line is along the out-of-plane direction. 

The Point at the intersection of symmetry planes and the Rotation angle from 
Cartesian axis, θ, should be defined.

• In 3D components, the Planes intersection line can be set Along the x-axis, Along the 

y-axis, or Along the z-axis. A Point at the intersection of symmetry planes and the 
Rotation angle from Cartesian axis, θ, should be defined. The position of the point 
along the intersection line can be arbitrary as it does not change the planes 
definition. The direction of the angle θ can be checked on the figure displayed below 
the settings, for each case of alignment of the intersection line.

The Show the planes of symmetry check box is selected by default. Clear it to hide the 
planes in the Graphics window.

Three perpendicular planes of symmetry
The planes are parallel to the Cartesian axis. Only the Point at the intersection of 

symmetry planes should be defined.

The Show the planes of symmetry check box is selected by default. Clear it to hide the 
planes in the Graphics window.

Sectors of symmetry
The coordinates of the points defining the symmetry axis should be set:

• In 2D components, the symmetry axis is the out-of-plane vector, and the center of 
the symmetry must be defined. Set the x and y coordinates of the Point of central 

symmetry.

• In 3D components, the symmetry axis is defined by two points. Set the x, y, and z 
coordinates of the First point defining sector symmetry axis and the Second point 

defining sector symmetry axis.

Enter a value for the Number of sectors. This should be a numerical value greater or 
equal to 2.
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If the Reflection for symmetrical sector check box is selected, set the coordinates of the 
Radial direction of reflection plane, u. This option may be used when each sector has 
itself a plane of symmetry.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Heat Transfer with Surface-to-Surface Radiation>Global>
Symmetry for Surface-to-Surface Radiation
Surface-to-Surface Radiation>Global>Symmetry for Surface-to-Surface Radiation

More locations are available if the Surface-to-surface radiation check box is selected 
under the Physical Model section. For example:
Heat Transfer in Solids>Global>Symmetry for Surface-to-Surface Radiation

Ribbon
Physics Tab with Heat Transfer in Solids, Heat Transfer in Fluids, Heat Transfer in Porous 

Media, Heat Transfer in Building Materials, Bioheat Transfer, Heat Transfer with 

Surface-to-Surface Radiation, Surface-to-Surface Radiation or Heat Transfer with Radiation 

in Participating Media selected:
Global>Symmetry for Surface-to-Surface Radiation

The Heat Transfer with Surface-to-Surface Radiation Interface

Theory for Surface-to-Surface Radiation
G L O B A L  F E A T U R E S  |  507



508 |  C H A P T E
 R  6 :  T H E  H E A T  TR A N S F E R  F E A T U R E S



 7
T h e  M o i s t u r e  T r a n s p o r t  F e a t u r e s
The Moisture Transport Interface has domain, boundary, and pair nodes available. 
These nodes, listed in alphabetical order in this section, are available from the 
Physics ribbon toolbar (Windows users), from the Physics context menu (Mac or 
Linux users), or by right-clicking to access the context menu (all users).

In this section:

• Domain Features

• Boundary Features
 509
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Doma i n  F e a t u r e s

The Moisture Transport interface has the following domain nodes available: 

Building Material 

Use this node to model moisture transfer in a building material through vapor 
diffusion and capillary moisture flows. The moisture content variation is expressed 
through the transfer of relative humidity

 (7-1)

 (7-2)

with the following material properties, fields, and source:

• ξ (SI unit: kg/m3) is the moisture storage capacity.

• δp (SI unit: s) is the vapor permeability.

•  (dimensionless) is the relative humidity.

• psat (SI unit: Pa) is the vapor saturation pressure.

• T (SI unit: K) is the temperature.

• Dw (SI unit: m2/s) is the moisture diffusivity.

• G (SI unit: kg/(m3⋅s)) is the moisture source (or sink). See Moisture Source node.

For a steady-state problem, the relative humidity does not change with time and the 
first term disappears.

• Building Material

• Initial Values

• Moist Air

• Moisture Source

• Turbulent Mixing

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

ξ∂φ
∂t
------ ∇ g⋅+ G=

g ξDw∇φ δp φpsat( )∇+( )–=

φ
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The transfer equation above, specifically designed for building materials under various 
assumptions, should be used carefully for some other type of porous media.

M O D E L  I N P U T S

This section has fields and values that are inputs to expressions that define material 
properties. If such user-defined property groups are added, the model inputs appear 
here.

The default Temperature Τ and Absolute pressure pA are User defined. When additional 
physics interfaces are added to the model, the temperature and absolute pressure 
variables defined by these physics interfaces can also be selected from the list. For 
example, if a Heat Transfer in Building Materials interface is added, you can select 
Temperature (ht) from the list. If a Laminar Flow interface is added, you can select 
Absolute pressure (spf) from the list.

If the node was added automatically after selecting the Heat and Moisture Transport 
predefined multiphysics interface, the temperature of the Heat and Moisture 

multiphysics node is used by default and the input field is not editable. To edit the 
Temperature field, click Make All Model Inputs Editable ( ).

B U I L D I N G  M A T E R I A L

This section sets the material properties for moisture diffusivity, moisture storage, and 
vapor diffusion.

The default Moisture diffusivity Dw is taken From material. For User defined, set a value 
to characterize the liquid transport in function of the moisture content.

The default Moisture storage function w is taken From material. For User defined, set a 
value to characterize the relationship between the amount of accumulated water and 
the relative humidity in the material.

Two options are available for the specification of the material properties for vapor 
diffusion:

• Vapor permeability (default) to define the vapor permeability δp directly. The default 
is taken From material. For User defined, set a value.

• Vapor resistance factor μ to define the vapor permeability δp as:

δp
δ
μ
---=
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where δ (SI unit: s) is the vapor permeability of still air. The default Vapor resistance 

factor is taken From material. For User defined, set a value.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Building Material

Moisture Transport in Building Materials>Building Material

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Domains>Building Material

Initial Values

This node adds an initial value for the relative humidity that can serve as an initial 
condition for a transient simulation or as an initial guess for a nonlinear solver. In 
addition to the default Initial Values node always present in the interface, you can add 
more Initial Values nodes if needed.

I N I T I A L  V A L U E S

For User defined, enter a value or expression for the initial value of the Relative humidity 

φ. The default value is 0.5. Else, select an Ambient relative humidity defined in the 
Ambient Settings section of a Heat Transfer or Heat Transfer in Shells interface.

The Moisture Transport in Building Materials Interface

The Heat and Moisture Transport Interfaces

Heat and Moisture

See Building Materials Database in the COMSOL Multiphysics Reference 
Manual for a description of materials containing the thermal and 
hygroscopic properties required by the Building Material node.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Initial Values

Moisture Transport in Building Materials>Initial Values

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Domains>Initial Values

Moist Air

Use this node to model moisture transfer in moist air through vapor diffusion and 
convection. The moisture content variation is expressed through the transport of vapor 
concentration, which itself can be expressed as the product of molar mass of water, 
relative humidity, and vapor saturation concentration:

 (7-3)

 (7-4)

with the following material properties, fields, and source:

• Μv (SI unit: kg/mol) is the molar mass of water vapor.

• φ (dimensionless) is the relative humidity.

• csat (SI unit: mol/m3) is the vapor saturation concentration.

• D (SI unit: m2/s) is the vapor diffusion coefficient in air.

• u (SI unit: m/s) is the air velocity field.

• G (SI unit: kg/(m3⋅s)) is the moisture source (or sink). See Moisture Source node.

For a steady-state problem, the relative humidity does not change with time and the 
first term disappears.

M O D E L  I N P U T S

This section has fields and values that are inputs to expressions used in Equation 7-3 
and Equation 7-4. The temperature is used for the definition of the saturation 
conditions, whereas the velocity field is used in the convection term.

cv Mvφcsat=

∂ Mvφcsat( )

∂t
--------------------------------- ∇ D Mvφcsat( )∇–( ) u Mvφcsat( )∇⋅+⋅+ G=
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The default Temperature Τ and Velocity field u are User defined. When additional 
physics interfaces are added to the model, the temperature and velocity field variables 
defined by these physics interfaces can also be selected from the list. For example, if a 
Heat Transfer in Building Materials interface is added, you can select Temperature (ht) 
from the list. If a Laminar Flow interface is added, you can select Velocity field (spf) from 
the list.

If the node was added automatically after selecting the Heat and Moisture Transport 
predefined multiphysics interface, the temperature of the Heat and Moisture 

multiphysics node is used by default and the input field is not editable. To edit the 
Temperature field, click Make All Model Inputs Editable ( ).

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Moist Air

Moisture Transport in Building Materials>Moist Air

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Domains>Moist Air

Moisture Source

This node describes moisture generation within the domain. You express addition and 
removal of moisture content with positive and negative values, respectively. Add one 

The Moisture Transport in Building Materials Interface

The Heat and Moisture Transport Interfaces

Heat and Moisture

See Turbulent Mixing to account for eddy diffusivity in moisture 
convection by turbulent flows.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
R  7 :  T H E  M O I S T U R E  TR A N S P O R T  F E A T U R E S

http://www.comsol.com/products/specifications/


or more nodes as needed — all moisture sources within a domain contribute with each 
other.

The Moisture Source node adds a source term G to the right-hand side of the moisture 
transport equation:

M O I S T U R E  S O U R C E

Enter a value or expression for the Moisture Source G0 per unit volume. 

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Moisture Source

Moisture Transport in Building Materials>Moisture Source

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Domains>Moisture Source

Turbulent Mixing

This subnode should be used to account for the turbulent mixing caused by the eddy 
diffusivity in moisture convection, for example when the specified velocity field 
corresponds to a RANS solution.

The Turbulent Mixing node adds the following contribution to the diffusion coefficient 
D of Equation 7-4 of Moist Air node: 

where νT is the turbulent kinematic viscosity (SI unit: m2/s) and ScT is the turbulent 
Schmidt number (dimensionless).

TU R B U L E N T  M I X I N G  P A R A M E T E R S

Enter a value or expression for the Turbulent kinematic viscosity νT and the Turbulent 

Schmidt number ScT. If a turbulent fluid flow interface is active, the Turbulent kinematic 

viscosity can be taken directly from this interface.

G G0=

DT
νT

ScT
----------=
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Moist Air>Turbulent Mixing

Moisture Transport in Building Materials>Moist Air>Turbulent Mixing

Ribbon
Physics Tab with Moist Air selected in the model tree:
Domains>Turbulent Mixing
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Bounda r y  F e a t u r e s

The Moisture Transport interface has the following boundary nodes available: 

Continuity

This node can be added to pairs. It prescribes that the relative humidity is continuous 
across the pair. Continuity is only suitable for pairs where the boundaries match.

P A I R  S E L E C T I O N

Choose the pair on which to apply this condition. A pair has to be created first. See 
Identity and Contact Pairs in the COMSOL Multiphysics Reference Manual for more 
details.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Pairs>Continuity

Moisture Transport in Building Materials>Pairs>Continuity

• Continuity

• Insulation

• Moist Surface

• Moisture Content

• Moisture Flux

• Outflow

• Symmetry

• Thin Moisture Barrier

• Wet Surface

For axisymmetric components, COMSOL Multiphysics takes the axial 
symmetry boundaries into account and automatically adds an Axial 

Symmetry node that is valid on the axial symmetry boundaries only.

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/
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Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Pairs>Continuity

Insulation

This node is the default boundary condition for the Moisture Transport interface. This 
boundary condition means that there is no moisture flux across the boundary:

and hence specifies where the domain is insulated. Intuitively, this equation says that 
the relative humidity gradient across the boundary is zero. For this to be true, the 
relative humidity on one side of the boundary must equal the relative humidity on the 
other side. Because there is no relative humidity difference across the boundary, 
moisture cannot transfer across it. It can be applied on exterior boundaries only.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Insulation

Moisture Transport in Building Materials>Insulation

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Boundaries>Thermal Insulation

Moist Surface

This node should be used to model evaporation from and condensation to a solid 
surface partially covered with liquid water. It adds the evaporation flux to the boundary 
conditions of Equation 7-4 of Moist Air node, and computes the corresponding latent 
heat source to be used from a Heat Transfer interface. In addition, it computes the 
liquid water concentration accumulated on the surface, during evaporation and 
condensation processes.

It can be applied on the exterior boundaries of a domain where the Moist Air node is 
active.

n g⋅– 0=
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In time-dependent studies, the evaporation flux gevap (SI unit: kg/(m2⋅s)) is defined 
as:

where Mv is the molar mass of water vapor (SI unit: kg/mol), K is the evaporation rate 
(SI unit: m/s), csat is the saturation concentration of vapor (SI unit: mol/m3), cv is 
the vapor concentration (SI unit: mol/m3), and cl is the liquid water concentration on 
surface (SI unit: mol/m2).

The liquid water concentration on surface is computed by solving the following 
equation:

with the initial condition:

In stationary studies, the initial liquid concentration is used in the definition of the 
evaporation flux:

The latent heat source qevap (SI unit: W/m2) is obtained by multiplying the 
evaporation flux by the latent heat of evaporation Lv (SI unit: J/kg):

With these definitions, gevap is negative when condensation occurs, and positive 
during evaporation. Whereas the condensation process doesn’t depend on the liquid 
concentration on the surface, the evaporation process only happens when the (initial 
or time-dependent) liquid concentration on surface is positive.

gevap
MvK csat cv–( ) if cv c> sator cl 0>

0 otherwise






=

Mv
∂cl
∂t
------- g– evap=

cl 0( ) cl init,=

gevap
MvK csat cv–( ) if cv c> sator cl init, 0>

0 otherwise






=

qevap Lvgevap=
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M O I S T  S U R F A C E  S E T T I N G S

Enter values or expressions for the Evaporation rate K and the Initial liquid water 

concentration on moist surface cl,init.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Moist Surface

Moisture Transport in Building Materials>Moist Surface

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Boundaries>Moist Surface

Moisture Content

Use this node to specify the relative humidity on interior and exterior boundaries.

P A I R  S E L E C T I O N

If this node is selected from the Pairs menu, choose the pair on which to apply this 
condition. A pair has to be created first. See Identity and Contact Pairs in the 
COMSOL Multiphysics Reference Manual for more details.

M O I S T U R E  C O N T E N T

The equation for this condition is φ = φ0, where φ0 is the prescribed relative humidity 
on the boundary. For User defined, enter a value or expression for the Relative humidity 

φ0. The default value is 0.5. Else, select an Ambient relative humidity defined in the 
Ambient Settings section of a Heat Transfer or Heat Transfer in Shells interface.

C O N S T R A I N T  S E T T I N G S

To display this section, click the Show button ( ) and select Advanced Physics Options. 
Select the Use weak constraints check box to replace the standard constraints with a 
weak implementation.

See Wet Surface node for the modeling of evaporation and condensation 
on a solid surface completely covered with liquid water.
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Moisture Content

Moisture Transport in Building Materials>Moisture Content

Moisture Transport in Air>Pairs>Moisture Content

Moisture Transport in Building Materials>Pairs>Moisture Content

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Boundaries>Moisture Content

Pairs>Moisture Content

Moisture Flux

Use this node to add moisture flux across exterior boundaries. A positive moisture flux 
adds moisture to the domain.

M O I S T U R E  F L U X

Click to select the General moisture flux (the default) or Convective moisture flux button.

General Moisture Flux
It adds g0 to the total flux across the selected boundaries. Enter a positive value for g0 
to represent a moisture flux that enters the domain.

Convective Moisture Flux
Enter a value for the Moisture transfer coefficient β. In addition, two options are 
available to specify the external conditions:

• If Relative humidity is selected (the default), set the External relative humidity, φext 
and the External temperature, Text (used for the computation of the vapor saturation 
pressure). For User defined, enter values or expressions. Else, select an Ambient 

relative humidity and an Ambient temperature defined in the Ambient Settings 
section of a Heat Transfer or Heat Transfer in Shells interface. Convective moisture 
flux is defined by g0 = β(φextpsat(Text) − φpsat(T)).

• If Partial vapor pressure is selected, enter an External partial vapor pressure, pv,ext. 
Convective moisture flux is defined by g0 = β(pv,ext − φpsat(T)).
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Moisture Flux

Moisture Transport in Building Materials>Moisture Flux

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Boundaries>Moisture Flux

Outflow

This node provides a boundary condition at outlets where the vapor is transported out 
of the air domain. It is assumed that convection is the dominating transport 
mechanism across outflow boundaries, and therefore that diffusive transport can be 
ignored, that is:

This node can be applied on the exterior boundaries of a computational domain in 
which a Moist Air node is active.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Outflow

Moisture Transport in Building Materials>Outflow

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Boundaries>Outflow

Symmetry

This node provides a boundary condition for symmetry boundaries. This boundary 
condition is similar to an Insulation condition, and it means that there is no moisture 
flux across the boundary. It can be applied on exterior boundaries only.

n D Mvφcsat( )∇⋅– 0=
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L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Symmetry

Moisture Transport in Building Materials>Symmetry

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Boundaries>Symmetry

Thin Moisture Barrier

Use this node to model a discontinuous moisture content across interior boundaries. 
By default it models a vapor barrier, with the moisture transfer coefficient β accounting 
for vapor diffusion only. A more general moisture barrier can be defined through the 
specification of a user-defined moisture transfer coefficient.

The upside and downside moisture fluxes are defined by β(φd − φu) and β(φu − φd), 
respectively.

M O D E L  I N P U T S

This section has fields and values that are inputs to expressions that define material 
properties for vapor permeability, vapor resistance factor, and saturation pressure of 
water vapor. If such user-defined property groups are added, the model inputs appear 
here.

T H I N  M O I S T U R E  B A R R I E R

Two options are available to define the moisture flux:

• If Vapor barrier material properties is selected (the default), the moisture transfer 
coefficient β is defined as

where δ is the vapor permeability of still air (SI unit: s), psat is the saturation pressure 
of water vapor (SI unit: Pa), μ is the vapor resistance factor (dimensionless), δp is the 

β
δpsat
μds

--------------
δppsat

ds
-----------------

δpsat
sd

--------------= = =
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vapor permeability (SI unit: s), sd is the vapor diffusion equivalent air layer thickness 
(SI unit: m), and ds is the layer thickness (SI unit: m).

Depending on the option selected in Specify—Vapor resistance factor (the default), 
Vapor permeability, or Vapor diffusion equivalent air layer thickness, enter values or 
expressions for the needed properties, or use properties From material.

• If Moisture transfer coefficient is selected, enter a value or expression for the Moisture 

transfer coefficient β. 

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Thin Moisture Barrier

Moisture Transport in Building Materials>Thin Moisture Barrier

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Boundaries>Thin Moisture Barrier

Wet Surface

This node should be used to model evaporation from and condensation to a solid 
surface completely covered with liquid water. It adds the evaporation flux to the 
boundary conditions of Equation 7-4 of Moist Air node, and computes the 
corresponding latent heat source to be used from a Heat Transfer interface.

It can be applied on the exterior boundaries of a domain where the Moist Air node is 
active.

The evaporation flux gevap (SI unit: kg/(m2⋅s)) is defined as:

where Mv is the molar mass of water vapor (SI unit: kg/mol), K is the evaporation rate 
(SI unit: m/s), csat is the saturation concentration of vapor (SI unit: mol/m3), and cv 
is the vapor concentration (SI unit: mol/m3).

See Building Materials Database in the COMSOL Multiphysics Reference 
Manual for a description of materials containing the thermal and 
hygroscopic properties required by the Thin Moisture Barrier node.

gevap MvK csat cv–( )=
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The latent heat source qevap (SI unit: W/m2) is obtained by multiplying the 
evaporation flux by the latent heat of evaporation Lv (SI unit: J/kg):

WE T  S U R F A C E  S E T T I N G S

Enter a value or expression for the Evaporation rate K.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Moisture Transport in Air>Wet Surface

Moisture Transport in Building Materials>Wet Surface

Ribbon
Physics Tab with interface as Moisture Transport in Air or Moisture Transport in Building 

Materials selected:
Boundaries>Wet Surface

qevap Lvgevap=

See Moist Surface node for the computation of the amount of liquid 
water accumulated on a solid surface partially covered with liquid water, 
due to evaporation and condensation.
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M u l t i p h y s i c s  I n t e r f a c e s
The Heat Transfer Module includes predefined multiphysics interfaces for 
conjugate heat transfer, thermoelectric effect, and local thermal non-equilibrium 
modeling. 

All these interfaces except the Local Thermal Non-Equilibrium interface and the 
Heat and Moisture Transport interfaces couple an interface of the Heat Transfer 
Module with an interface of another module (CFD Module, AC/DC Module). 

The multiphysics interfaces are found under the Heat Transfer branch ( ), and 
their availability depends on the COMSOL products available. 

The multiphysics interfaces add Domain Multiphysics Couplings and Boundary 
Multiphysics Couplings. They predefine the couplings through specific settings in 

For a detailed overview of the functionality available in each 
product, visit 
http://www.comsol.com/products/specifications/
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the multiphysics couplings and in the constituent interfaces to facilitate easy set up of 
models. These settings are detailed in the following sections:

• The Nonisothermal Flow and Conjugate Heat Transfer Interfaces

• The Thermoelectric Effect Interface

• The Local Thermal Non-Equilibrium Interface

• The Heat and Moisture Transport Interfaces

A brief description of other multiphysics interfaces coupling an interface of the Heat 
Transfer Module with other interfaces is given in the following sections:

• The Joule Heating Interface

• The Laser Heating Interface

• The Induction Heating Interface

• The Microwave Heating Interface

Links to thorough information about these interfaces are given in the corresponding 
sections.

Also: 

• See The Thermal Stress Interface and The Joule Heating and Thermal Expansion 
Interface in the Structural Mechanics Module User’s Guide for other multiphysics 
interfaces having The Heat Transfer in Solids Interface as a constituent interface. 
These two multiphysics interfaces (found under the Structural Mechanics 
branch ( )) add in particular the Thermal Expansion multiphysics coupling.

• See each constituent interface documentation for more details about the common 
settings (in The Heat Transfer Module Interfaces for the Heat Transfer Module 
interfaces, and in the other modules documentation for the other interfaces).

• See The Heat Transfer Features for details about the features available with the Heat 
Transfer Module constituent interfaces.

• See Multiphysics Couplings for details about the multiphysics couplings added with 
the Heat Transfer Module predefined multiphysics interfaces.

The predefined interfaces are found under the branches of the Model Wizard or Add 

Physics windows. They add the constituent interfaces and the Multiphysics node 
containing one or more multiphysics couplings. 

On the figure below, the predefined interface Conjugate Heat Transfer, Laminar Flow is 
found under the Heat Transfer branch. It adds the constituent interfaces Heat Transfer 
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and Laminar Flow, and the Multiphysics node containing the Nonisothermal Flow 
multiphysics coupling.
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Th e  Non i s o t h e rma l  F l ow and 
Con j u g a t e  Hea t  T r a n s f e r  I n t e r f a c e s

In this section:

• Advantages of Using the Multiphysics Interfaces

• The Nonisothermal Flow, Laminar Flow and Turbulent Flow Interfaces

• The Conjugate Heat Transfer, Laminar Flow and Turbulent Flow Interfaces

• Settings for Physics Interfaces and Coupling Features

• Coupling Features

• Physics Interface Features

See The Laminar Flow Interface, The Turbulent Flow, Algebraic yPlus Interface, The 
Turbulent Flow, L-VEL Interface, The Turbulent Flow, k-e Interface, and The 
Turbulent Flow, Low Re k-e Interface in the CFD Module User’s Guide for a 
description of the laminar and turbulent single-phase flow interfaces.

See Domain, Boundary, Pair, and Point Nodes for Single-Phase Flow in the CFD 
Module User’s Guide for a description of the nodes associated to these interfaces.

Advantages of Using the Multiphysics Interfaces

The Nonisothermal Flow and Conjugate Heat Transfer interfaces combine the heat 
equation with either laminar flow or turbulent flow and use either a Fluid, Porous 

Medium, or Phase Change Material domain model. The advantage of using the 
multiphysics interfaces is that predefined couplings are available in both directions. In 
particular, physics interfaces use the same definition of the density, which can therefore 
be a function of both pressure and temperature. Solving this coupled system of 
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equations usually requires numerical stabilization accounting for the couplings, which 
the predefined multiphysics interfaces also set up.

The Nonisothermal Flow, Laminar Flow and Turbulent Flow 
Interfaces

When a multiphysics interface is added from the Fluid Flow>Nonisothermal Flow branch  
of the Model Wizard or Add Physics windows, one of the Single-Phase Flow interfaces 
(laminar or turbulent flow) and Heat Transfer are added to the Model Builder. 

In addition, the Multiphysics node is added, which includes the multiphysics coupling 
feature Nonisothermal Flow. 

• The Laminar Flow interface ( ) combines a Heat Transfer in Fluids interface with 
a Laminar Flow interface. 

When the flow Compressibility is set to Incompressible flow, the 
Nonisothermal Flow coupling follows the Boussinesq approximation and 
evaluates the thermal material properties at the reference temperature. 
Hence, the Phase Change Material domain model—which requires the 
temperature dependency of the heat capacity—should be used only with 
the Weakly compressible flow and Compressible flow (Ma<0.3) options.

When the Nonisothermal Flow and Conjugate Heat Transfer interfaces 
couple a turbulent flow with a Phase Change Material domain model, it 
must be noted that only the geometry boundaries are considered for the 
definition of the wall functions and of the wall distance. For example, at 
the moving melting front between the solid and the liquid phase, no wall 
functions are used by the k-ε and k-ω turbulence models.

See also Heat Transfer and Fluid Flow Coupling for more information.

The Multiphysics Node in the COMSOL Multiphysics Reference 
Manual.
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• The Turbulent Flow, Algebraic yPlus interface ( ) combines a Heat Transfer in 
Fluids interface with a Turbulent Flow, Algebraic yPlus interface. 

• The Turbulent Flow, L-VEL interface ( ) combines a Heat Transfer in Fluids 
interface with a Turbulent Flow, L-VEL interface. The Turbulent Flow, k-ε interface 
( ) combines a Heat Transfer in Fluids interface with a Turbulent Flow, k-ε 
interface. 

• The Turbulent Flow, Low Re k-ε interface ( ) combines a Heat Transfer in Fluids 
interface with a Turbulent Flow, Low Re k-ε interface. 

The Conjugate Heat Transfer, Laminar Flow and Turbulent Flow 
Interfaces

When a multiphysics interface is added from the Heat Transfer>Conjugate Heat Transfer 

branch  of the Model Wizard or Add Physics windows, Heat Transfer and one of the 
Single-Phase Flow interfaces (laminar or turbulent flow) are added to the Model Builder. 

In addition, the Multiphysics node is added, which includes the multiphysics coupling 
feature Nonisothermal Flow. 

• The Laminar Flow interface ( ) combines a Heat Transfer interface with a Laminar 
Flow interface. 

• The Turbulent Flow, Algebraic yPlus interface ( ) combines a Heat Transfer 
interface with a Turbulent Flow, Algebraic yPlus interface. 

• The Turbulent Flow, L-VEL interface ( ) combines a Heat Transfer interface with a 
Turbulent Flow, L-VEL interface. The Turbulent Flow, k-ε interface ( ) combines 
a Heat Transfer interface with a Turbulent Flow, k-ε interface. 

• The Turbulent Flow, Low Re k-ε interface ( ) combines a Heat Transfer interface 
with a Turbulent Flow, Low Re k-ε interface. 

Settings for Physics Interfaces and Coupling Features

When physics interfaces are added using the predefined couplings, specific settings are 
included with the physics interfaces and the coupling features. 

The Multiphysics Node in the COMSOL Multiphysics Reference 
Manual.
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However, if physics interfaces are added one at a time, followed by the coupling 
features, these modified settings are not automatically included. 

For example, if single Heat Transfer in Fluids and Laminar Flow interfaces are added, 
COMSOL adds an empty Multiphysics node. When you right-click this node, you can 
choose from the available coupling features — Nonisothermal Flow, Temperature 

Coupling, and Flow Coupling — but the modified settings are not included. 

Coupling Features

See Nonisothermal Flow, Flow Coupling, and Temperature Coupling for a description 
of the multiphysics couplings.

Physics Interface Features

Physics nodes are available from the Physics ribbon toolbar (Windows users), Physics 
context menu (Mac or Linux users), or right-click to access the context menu (all 
users).

TABLE 8-1:  MODIFIED SETTINGS FOR THE NONISOTHERMAL FLOW INTERFACES

PHYSICS OR COUPLING INTERFACE MODIFIED SETTINGS (IF ANY)

Heat Transfer in Solids Discretization order from temperature Lagrange 
shape function is 1.

A Fluid feature is added with a empty default 
editable selection.

Heat Transfer in Fluids none

Nonisothermal Flow The Fluid flow and Heat transfer interfaces are 
preselected

Use the online help in COMSOL Multiphysics to locate and search all the 
documentation. All these links also work directly in COMSOL 
Multiphysics when using the Help system.

In general, to add a node, go to the Physics toolbar, no matter what 
operating system you are using. 
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H E A T  TR A N S F E R  I N  F L U I D S  ( N O N I S O T H E R M A L  F L O W )

The available physics features for The Heat Transfer in Fluids Interface are listed in 
Feature Nodes for the Heat Transfer in Fluids Interface. Also see Fluid for details 
about that feature.

H E A T  TR A N S F E R  I N  S O L I D S  ( C O N J U G A T E  H E A T  TR A N S F E R )

The available physics features for The Heat Transfer in Solids Interface are listed in 
Feature Nodes for the Heat Transfer in Solids Interface. Also see Solid for details about 
that feature.

L A M I N A R  F L O W

The available physics features for The Laminar Flow Interface are listed in the section 
Domain, Boundary, Pair, and Point Nodes for Single-Phase Flow.

TU R B U L E N T  F L O W,  A L G E B R A I C  Y P L U S

The available physics features for The Turbulent Flow, Algebraic yPlus Interface are 
listed in the section Domain, Boundary, Pair, and Point Nodes for Single-Phase Flow.

TU R B U L E N T  F L O W,  L - V E L

The available physics features for The Turbulent Flow, L-VEL Interface are listed in 
the section Domain, Boundary, Pair, and Point Nodes for Single-Phase Flow.

TU R B U L E N T  F L O W,  k-ε
The available physics features for The Turbulent Flow, k-e Interface are listed in the 
section Domain, Boundary, Pair, and Point Nodes for Single-Phase Flow.

TU R B U L E N T  F L O W,  L O W  R E  k-ε
The available physics features for The Turbulent Flow, Low Re k-e Interface are listed 
in the section Domain, Boundary, Pair, and Point Nodes for Single-Phase Flow.

Preset studies

The Stationary, One-Way Coupled, NITF and Time Dependent, One-Way Coupled, 
NITF preset studies are available with the Nonisothermal Flow and Conjugate Heat 
Transfer interfaces. They solve for the fluid flow and heat transfer variables in two 
separated steps, Stationary for the former preset study, and Time Dependent for the 
latter. 
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For a fully-coupled approach, use the Stationary, Time Dependent, Stationary with 
Initialization, or Transient with Initialization studies. See Studies and Solvers in the 
COMSOL Multiphysics Reference Manual for more details.
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Th e  Th e rmoe l e c t r i c  E f f e c t  I n t e r f a c e

The Thermoelectric Effect Interface

When the predefined Thermoelectric Effect ( ) interface is added (found under the 
Heat Transfer branch ( ) of the Model Wizard or Add Physics windows), it combines 
the Electric Currents and the Heat Transfer in Solids interfaces for modeling 
Peltier-Seebeck-Thomson effects. In addition, the Electromagnetic Heat Source, 
Thermoelectric Effect, and Boundary Thermoelectric Effect multiphysics couplings are 
added automatically.

The multiphysics couplings add the thermoelectric effect, the electromagnetic power 
dissipation, and the electromagnetic material properties, which can depend on the 
temperature.

Depending on the product license, stationary, time-domain, and frequency-domain 
modeling are supported in all space dimensions. In addition, combinations of 
frequency-domain modeling for the Electric Currents interface and stationary 
modeling for the Heat Transfer in Solids interface, called frequency-stationary and 
frequency-transient modeling, are supported.

O N  T H E  C O N S T I T U E N T  P H Y S I C S  I N T E R F A C E S

As a predefined multiphysics coupling, Electric Currents and Heat Transfer in Solids 
interfaces are added to the Model Builder. In addition, a Multiphysics node is added, 
which includes the multiphysics coupling features Thermoelectric Effect, 
Electromagnetic Heat Source, Boundary Thermoelectric Effect, Boundary Electromagnetic 

Heat Source, and Temperature Coupling. 

The Electric Currents interface calculates the electric field, current, and potential 
distributions in conducting media under conditions where inductive effects are 
negligible; that is, when the skin depth is much larger than the studied device. 
Depending on the licensed products, time and frequency domain formulations that 
account for capacitive effects are also provided. The Electric Currents interface solves 
a current conservation equation based on Ohm’s law using the scalar electric potential 
as the dependent variable.

The Heat Transfer in Solids interface provides features for modeling heat transfer by 
conduction, convection, and radiation. A Solid model is active by default on all 
domains. All functionality for including other domain types, like a fluid domain, is also 
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available. The temperature equation defined in solid domains corresponds to the 
differential form of the Fourier’s law that may contain additional contributions like 
heat sources.

A S  A N  A D D - O N  M U L T I P H Y S I C S  C O U P L I N G

The Thermoelectric Effect multiphysics coupling is also available when there is at least 
one compatible Heat Transfer interface and one compatible AC/DC interface.

The compatible Heat Transfer interfaces are:

• Heat Transfer in Solids and Heat Transfer in Fluids

• Heat Transfer in Biological Tissue

• Heat Transfer in Porous Media

• Heat Transfer with Surface-to-Surface Radiation and Heat Transfer with Radiation 
in Participating Media

• Heat Transfer in Thin Shells

The compatible AC/DC interfaces are:

• Electric Currents and Electric Currents, Shell

• Magnetic Fields, Magnetic Field Formulation, and Magnetic and Electric Fields

• Rotating Machinery, Magnetic

Settings for Physics Interfaces and Coupling Features

When physics interfaces are added using the predefined couplings — for example, 
Thermoelectric Effect — specific settings are included with the physics interfaces and the 
coupling features. 

However, if physics interfaces are added one at a time, followed by the coupling 
features, these modified settings are not automatically included. 

For example, if single Electric Currents and Heat Transfer in Solids interfaces are added, 
COMSOL adds an empty Multiphysics node. You can choose from the following 
available coupling features: Thermoelectric Effect, Electromagnetic Heat Source, Boundary 
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Thermoelectric Effect, Boundary Electromagnetic Heat Source, and Temperature Coupling, 
but the modified settings are not included. 

Coupling features are available from the context menu (right-click the 
Multiphysics node) or from the Physics toolbar, Multiphysics menu.

TABLE 8-2:  MODIFIED SETTINGS FOR A THERMOELECTRIC EFFECT INTERFACE

PHYSICS INTERFACE MODIFIED SETTINGS

Electric Currents No changes.

Heat Transfer in Solids No changes.

Thermoelectric Effect The Domain Selection is the same as that of the 
participating physics interfaces. The corresponding 
Electric Currents and Heat Transfer in Solids 
interfaces are preselected in the Thermoelectric 
Effect section.

Electromagnetic Heat Source The Domain Selection is the same as that of the 
participating physics interfaces. The corresponding 
Electric Currents and Heat Transfer in Solids 
interfaces are preselected in the Electromagnetic 
Heat Source section. 

Boundary Thermoelectric 
Effect

The Boundary Selection is the same as the exterior 
and interior boundaries of the Domain Selection of the 
participating physics interfaces. The corresponding 
Electric Currents and Heat Transfer in Solids 
interfaces are preselected in the Boundary 
Thermoelectric Effect section.

Boundary Electromagnetic 
Heat Source

The Boundary Selection contains all the boundaries of 
the participating interfaces. The corresponding 
Electric Currents and Heat Transfer in Solids 
interfaces are preselected in the Boundary 
Electromagnetic Heat Source section.

Temperature Coupling The corresponding Electric Currents and Heat 
Transfer in Solids interfaces are preselected in the 
Temperature Coupling section.
R  8 :  M U L T I P H Y S I C S  I N T E R F A C E S



Coupling Features

See Thermoelectric Effect, Boundary Thermoelectric Effect, Electromagnetic Heat 
Source, and Boundary Electromagnetic Heat Source for a description of the 
multiphysics couplings.

Physics Interface Features

Physics nodes are available from the Physics ribbon toolbar (Windows users), Physics 
context menu (Mac or Linux users), or right-click to access the context menu (all 
users).

H E A T  TR A N S F E R  I N  S O L I D S

The available physics features for The Heat Transfer in Solids Interface are listed in 
Feature Nodes for the Heat Transfer in Solids Interface.

E L E C T R I C  C U R R E N T S

The available physics features for The Electric Currents Interface are listed in Domain, 
Boundary, Edge, Point, and Pair Nodes for the Electric Currents Interface in the 
COMSOL Multiphysics Reference Manual.

Use the online help in COMSOL Multiphysics to locate and search all the 
documentation. All these links also work directly in COMSOL 
Multiphysics when using the Help system.

In general, to add a node, go to the Physics toolbar, no matter what 
operating system you are using. Subnodes are available by clicking the 
parent node and selecting it from the Attributes menu.
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Th e  L o c a l  T h e rma l  Non - Equ i l i b r i um 
I n t e r f a c e

The Local Thermal Non-Equilibrium Interface

When the predefined Local Thermal Non-Equilibrium( ) interface is added (found 
under the Heat Transfer branch ( ) of the Model Wizard or Add Physics windows), it 
combines the Heat Transfer in Solids and the Heat Transfer in Fluids interfaces to 
model heat transfer in porous media for which the solid and fluid temperatures are not 
in equilibrium.

Stationary, time-domain, and frequency-domain modeling are supported in all space 
dimensions. 

O N  T H E  C O N S T I T U E N T  P H Y S I C S  I N T E R F A C E S

As a predefined multiphysics coupling, Heat Transfer in Solids and Heat Transfer in Fluids 
interfaces are added to the Model Builder. In addition, a Multiphysics node is added, 
which automatically includes the multiphysics coupling feature Local Thermal 

Non-Equilibrium.

The Heat Transfer in Solids interface provides features for modeling heat transfer by 
conduction, convection, and radiation. A Solid model is active by default on all 
domains. 

The Heat Transfer in Fluids interface provides features for modeling heat transfer by 
conduction, convection, and radiation. A Fluid model is active by default on all 
domains. 

A S  A N  A D D - O N  M U L T I P H Y S I C S  C O U P L I N G

The Local Thermal Non-Equilibrium multiphysics coupling is also available when 
there is at least one of each of the following interfaces with the default model activated:

• Heat Transfer in Solids, with Solid model

• Heat Transfer in Fluids, with Fluid model
R  8 :  M U L T I P H Y S I C S  I N T E R F A C E S



Coupling Feature

See Local Thermal Non-Equilibrium for details about the multiphysics coupling 
feature.

Physics Interface Features

Physics nodes are available from the Physics ribbon toolbar (Windows users), Physics 
context menu (Mac or Linux users), or right-click to access the context menu (all 
users).

H E A T  TR A N S F E R  I N  S O L I D S

The available physics features for The Heat Transfer in Solids Interface are listed in 
Feature Nodes for the Heat Transfer in Solids Interface.

H E A T  TR A N S F E R  I N  F L U I D S

The available physics features for The Heat Transfer in Fluids Interface are listed in 
Feature Nodes for the Heat Transfer in Fluids Interface.

Heat sources
In the heat source features available for the constituent interfaces (Heat Source, 
Geothermal Heating, and Bioheat), the user input corresponds to the heat production 
per total unit volume. It is multiplied by the volume fraction of each phase and added 
into the corresponding heat equation. 

Heat fluxes
In the heat flux features available for the constituent interfaces (Heat Flux, Inflow 
Heat Flux), the user input corresponds to the heat flux per total unit surface. It is 
multiplied by the volume fraction of each phase and added into the corresponding heat 
equation. The surface fraction is approximated by the volume fraction.

In general, to add a node, go to the Physics toolbar, no matter what 
operating system you are using. Subnodes are available by clicking the 
parent node and selecting it from the Attributes menu.
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Th e  Hea t  and Mo i s t u r e  T r a n s p o r t  
I n t e r f a c e s

The Heat and Moisture Transport multiphysics Interfaces

The versions of the Heat and Moisture Transport multiphysics interface are:

• The Building Materials version of the Heat and Moisture Transport multiphysics 
Interface

• The Moist Air version of the Heat and Moisture Transport multiphysics Interface

The Building Materials version of the Heat and Moisture Transport 
multiphysics Interface

When the Building Materials version of the predefined Heat and Moisture Transport ( ) 
interface is added (found under the Heat Transfer branch ( ) of the Model Wizard or 
Add Physics windows), it combines the Heat Transfer in Building Materials and the 
Moisture Transport in Building Materials interfaces to model coupled heat and 
moisture transport in building materials, by taking into account heat and moisture 
storage, latent heat effects, and liquid and convective transport of moisture.

Stationary, time-domain, and frequency-domain modeling are supported in all space 
dimensions.

O N  T H E  C O N S T I T U E N T  P H Y S I C S  I N T E R F A C E S

As a predefined multiphysics coupling, Heat Transfer in Building Materials and Moisture 

Transport in Building Materials interfaces are added to the Model Builder. In addition, 
a Multiphysics node is added, which automatically includes the Heat and Moisture 
multiphysics coupling feature.

The Heat Transfer in Building Materials interface provides features for modeling heat 
transfer by conduction, convection, and radiation. The Building Material model, active 
by default in all domains, provides in addition the functionality for moisture content 
dependency of thermodynamics properties and latent heat effects.

The Moisture Transport in Building Materials interface provides features for modeling 
moisture transfer by liquid transport (capillary flow) and vapor diffusion. A Building 

Material model is active by default on all domains.
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A S  A N  A D D - O N  M U L T I P H Y S I C S  C O U P L I N G

The Heat and Moisture multiphysics coupling is also available when there is at least one 
of each of the following interfaces with the specified model activated:

• Any version of the Heat Transfer interface, with Building Material model

• Any version of the Moisture Transport interface, with Building Material model

Physics Interface Features in the Building Materials version

H E A T  TR A N S F E R  I N  B U I L D I N G  M A T E R I A L S

The available physics features for The Heat Transfer in Building Materials Interface are 
listed in Feature Nodes for the Heat Transfer in Building Materials Interface.

M O I S T U R E  TR A N S P O R T  I N  B U I L D I N G  M A T E R I A L S

The available physics features for The Moisture Transport in Building Materials 
Interface are listed in Feature Nodes for the Moisture Transport in Building Materials 
Interface.

The Moist Air version of the Heat and Moisture Transport 
multiphysics Interface

When the Moist Air version of the predefined Heat and Moisture Transport ( ) interface 
is added (found under the Heat Transfer branch ( ) of the Model Wizard or Add 

Physics windows), it combines the Heat Transfer in Moist Air and the Moisture 
Transport in Air interfaces to model coupled heat and moisture transport in moist air, 
by modeling moisture transport by vapor diffusion and convection, and heat transfer 
by conduction and convection with moisture-dependent thermodynamics properties.

Stationary, time-domain, and frequency-domain modeling are supported in all space 
dimensions.

See Building Materials Database in the COMSOL Multiphysics Reference 
Manual for a description of materials containing the thermal and 
hygroscopic properties to be used with the The Building Materials version 
of the Heat and Moisture Transport multiphysics Interface.
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O N  T H E  C O N S T I T U E N T  P H Y S I C S  I N T E R F A C E S

As a predefined multiphysics coupling, Heat Transfer in Moist Air and Moisture Transport 

in Air interfaces are added to the Model Builder. In addition, a Multiphysics node is 
added, which automatically includes the Heat and Moisture multiphysics coupling 
feature.

The Heat Transfer in Moist Air interface provides features for modeling heat transfer 
by conduction, convection, and radiation. The Moist Air model, active by default in all 
domains, provides in addition the functionality for moisture content dependency of 
thermodynamics properties.

The Moisture Transport in Air interface provides features for modeling moisture 
transfer by vapor convection and diffusion. A Moist Air model is active by default on all 
domains.

A S  A N  A D D - O N  M U L T I P H Y S I C S  C O U P L I N G

The Heat and Moisture multiphysics coupling is also available when there is at least one 
of each of the following interfaces with the specified model activated:

• Any version of the Heat Transfer interface, with Fluid or Moist Air model

• Any version of the Moisture Transport interface, with Moist Air model

Physics Interface Features in the Moist Air version

H E A T  TR A N S F E R  I N  M O I S T  A I R

The available physics features for The Heat Transfer in Moist Air Interface are listed in 
Feature Nodes for the Heat Transfer in Moist Air Interface.

M O I S T U R E  TR A N S P O R T  I N  A I R

The available physics features for The Moisture Transport in Air Interface are listed in 
Feature Nodes for the Moisture Transport in Air Interface.

Coupling Feature

See Heat and Moisture for details about the multiphysics coupling feature.
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Th e  J o u l e  Hea t i n g  I n t e r f a c e

In this section:

• The Joule Heating Interface

• Coupling Features

The Joule Heating Interface

The Joule Heating ( ) interface is used to model resistive heating and, depending on 
additional licensed products, dielectric heating in devices where inductive effects are 
negligible; that is, when the skin depth is much larger than the studied device. This 
multiphysics interface adds an Electric Currents interface and a Heat Transfer in Solids 
interface. The multiphysics couplings add the electromagnetic power dissipation as a 
heat source, and the electromagnetic material properties can depend on the 
temperature.

See The Joule Heating Interface in the COMSOL Multiphysics Reference Manual for 
more details about this multiphysics interface.

Coupling Features

See Electromagnetic Heat Source, Boundary Electromagnetic Heat Source, and 
Temperature Coupling for a description of the multiphysics couplings.
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Th e  L a s e r  Hea t i n g  I n t e r f a c e

In this section:

• The Laser Heating Interface

• Coupling Features

The Laser Heating Interface

The Laser Heating ( ) interface is used to model electromagnetic heating for systems 
and devices where the electric field amplitude varies slowly on a wavelength scale. This 
multiphysics interface adds an Electromagnetic Waves, Beam Envelopes interface and 
a Heat Transfer in Solids interface. The multiphysics couplings add the 
electromagnetic losses from the electromagnetic waves as a heat source, and the 
electromagnetic material properties can depend on the temperature. The modeling 
approach is based on the assumption that the electromagnetic cycle time is short 
compared to the thermal time scale.

See The Laser Heating Interface in the Wave Optics Module User’s Guide for more 
details about this multiphysics interface.

Coupling Features

See Electromagnetic Heat Source, Boundary Electromagnetic Heat Source, and 
Temperature Coupling for a description of the multiphysics couplings.
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Th e  I n du c t i o n  Hea t i n g  I n t e r f a c e

In this section:

• The Induction Heating Interface

• Coupling Features

The Induction Heating Interface

The Induction Heating interface ( ) is used to model induction heating and eddy 
current heating. This multiphysics interface adds a Magnetic Fields interface and a 
Heat Transfer in Solids interface. The multiphysics couplings add the electromagnetic 
power dissipation as a heat source, and the electromagnetic material properties can 
depend on the temperature.

See The Induction Heating Interface in the AC/DC Module User’s Guide for more 
details about this multiphysics interface.

Coupling Features

See Electromagnetic Heat Source, Boundary Electromagnetic Heat Source, and 
Temperature Coupling for a description of the multiphysics couplings.
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T h e  M i c r owa v e  Hea t i n g  I n t e r f a c e

In this section:

• The Microwave Heating Interface

• Coupling Features

The Microwave Heating Interface

The Microwave Heating interface ( ) is used to model electromagnetic heating for 
systems and devices that are on a scale ranging from 1/10 of a wavelength up to, 
depending on available computer memory, about 10 wavelengths. This multiphysics 
interface adds an Electromagnetic Waves, Frequency Domain interface and a Heat 
Transfer in Solids interface. The multiphysics couplings add the electromagnetic losses 
from the electromagnetic waves as a heat source, and the electromagnetic material 
properties can depend on the temperature. The modeling approach is based on the 
assumption that the electromagnetic cycle time is short compared to the thermal time 
scale.

See The Microwave Heating Interface in the RF Module User’s Guide for more details 
about this multiphysics interface.

Coupling Features

See Electromagnetic Heat Source, Boundary Electromagnetic Heat Source, and 
Temperature Coupling for a description of the multiphysics couplings.
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 9
M u l t i p h y s i c s  C o u p l i n g s
The Heat Transfer Module has multiphysics couplings available under certain 
conditions.

When a predefined multiphysics interface is added from the Model Wizard or Add 

Physics windows, it adds the constituent interfaces and the Multiphysics node, which 
automatically includes one or more multiphysics couplings.

If the constituent physics interfaces are added one at a time, then it adds an empty 
Multiphysics node. When you right-click this node, you can choose from the 
available multiphysics couplings.

The default settings of the couplings depend on the way the Multiphysics node was 
created.

In this chapter, the following multiphysics couplings are described:

• Domain Multiphysics Couplings

• Boundary Multiphysics Couplings

The Multiphysics Node in the COMSOL Multiphysics Reference 
Manual.
 549
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See The Heat Transfer Module Interfaces for details about the Heat Transfer Module 
interfaces.

See Multiphysics Interfaces for details about the predefined multiphysics interfaces of 
the Heat Transfer Module.
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Doma i n  Mu l t i p h y s i c s  C oup l i n g s

The Heat Transfer Module has the following domain multiphysics couplings 
available: 

Electromagnetic Heat Source

Use this multiphysics coupling ( ) to account for electromagnetic volumetric and 
surface losses in the heat equation.

See Electromagnetic Heat Source in the COMSOL Multiphysics Reference Manual 
for a description of this multiphysics coupling in the context of Joule heating and laser 
heating modeling.

See Electromagnetic Heat Source in the AC/DC Module User’s Guide for a 
description of this multiphysics coupling in the context of induction heating modeling.

See Electromagnetic Heat Source in the RF Module User’s Guide for a description of 
this multiphysics coupling in the context of microwave heating modeling.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Multiphysics>Electromagnetic Heat Source

• Electromagnetic Heat Source

• Flow Coupling

• Heat and Moisture

• Local Thermal Non-Equilibrium

• Nonisothermal Flow

• Temperature Coupling

• Thermal Expansion

• Thermoelectric Effect

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

Hepatic Tumor Ablation: Application Library path 
Heat_Transfer_Module/Medical_Technology/tumor_ablation
D O M A I N  M U L T I P H Y S I C S  C O U P L I N G S  |  551

http://www.comsol.com/products/specifications/


552 |  C H A P T E
when any of the following interface is added together with Heat Transfer in Solids (or 
another version of the Heat Transfer interface): 
Electric Currents

Electric Currents, Shells

Magnetic Field Formulation

Magnetic Fields

Magnetic and Electric Fields

Rotating Machinery, Magnetic

Flow Coupling

This multiphysics coupling ( ) defines u and p variables in order to set the model 
inputs in the Heat Transfer interface (or when applicable, a chemical species transport 
interface). In addition it provides all the fluids quantities that may be needed by the 
Heat Transfer interface (for example, viscosity, turbulence parameters).

S E T T I N G S

The Label is the default multiphysics coupling feature name. 

The Name is used primarily as a scope prefix for variables defined by the coupling node. 
Refer to such variables in expressions using the pattern <name>.<variable_name>. In 
order to distinguish between variables belonging to different coupling nodes or physics 
interfaces, the name string must be unique. Only letters, numbers and underscores (_) 
are permitted in the Name field. The first character must be a letter.

The default Name (for the first multiphysics coupling feature in the model) is fc1.

C O U P L E D  I N T E R F A C E S

This section defines the physics involved in the multiphysics coupling. By default, the 
applicable physics interface is selected in the Source list to apply the Destination to its 
physics interface to establish the coupling. 

You can also select None from either list to uncouple the node from a physics interface. 
If the physics interface is removed from the Model Builder — for example, Heat Transfer 
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in Solids is deleted — then the Destination list defaults to None as there is nothing to 
couple to.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Multiphysics>Flow Coupling

when any of the following interface is added together with Heat Transfer in Solids (or 
another version of the Heat Transfer Interface): 
Single-Phase Flow (any version)
Porous Media and Subsurface Flow, Brinkman Equations

Whenever the Destination interface is a heat transfer interface, the 
Nonisothermal Flow coupling node should be preferred to Flow Coupling. 
Indeed, Nonisothermal Flow brings an optimized stabilization; supports 
natural convection, including Boussinesq approximation; supports 
turbulent flow (wall functions, effective thermal conductivity); and 
handles work due to the pressure forces and viscous dissipation.

When the Destination interface is a chemical species transport interface, a 
Reacting Flow coupling node should be used instead of Flow Coupling. See 
The Reacting Flow Multiphysics Interfaces in the CFD Module User’s 
Guide for more details.

If a physics interface is deleted and then added to the model again, and in 
order to re-establish the coupling, you need to choose the physics 
interface again from the lists. This is applicable to all multiphysics 
coupling nodes that would normally default to the once present physics 
interface. See Multiphysics Modeling Approaches in the COMSOL 
Multiphysics Reference Manual.
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Heat and Moisture

Use this multiphysics coupling ( ) to model coupled heat and moisture transfer in 
two kinds of media:

• In building materials, by taking into account heat and moisture storage, latent heat 
effects, and liquid and convective transport of moisture. This coupling is available 
when a Building Material feature of the Heat Transfer interface and a Building Material 
feature of the Moisture transport interface are active on the same domain. It can be 
applied to the computation of different moisture variations phenomena in building 
components, such as drying of initial construction moisture, condensation due to 
migration of moisture from outside to inside in summer, and moisture accumulation 
by interstitial condensation due to diffusion in the winter. The thermodynamics 
properties of the building material depend both on the dry solid properties and on 
the moisture content, and the evaporation of liquid water adds a latent heat source 
in the diffusion equation for temperature. Reversely, the variations of moisture 
content due to liquid transport (capillary flow) and vapor diffusion are temperature 
dependent. 

• In moist air, by modeling moisture transport by vapor diffusion and convection, and 
heat transfer by conduction and convection. The thermodynamics properties of 
moist air depend on the moisture content, whereas the temperature is used to define 
the saturation conditions for vapor concentration. This coupling is available when a 
Fluid or Moist Air feature of the Heat Transfer interface and a Moist Air feature of the 
Moisture transport interface are active on the same domain. The Fluid type should 
be set to Moist air if the Fluid feature is used, to take fully advantage of the coupling.

The Heat and Moisture coupling synchronizes the features from the Heat Transfer and 
Moisture transport interfaces:

• It defines the relative humidity φ (with corresponding reference temperature and 
pressure) in order to set the corresponding inputs in the Moist Air feature of the Heat 
Transfer interface.

• It defines the moisture storage function w and the vapor permeability δp (or vapor 
resistance factor μ) in order to set the corresponding inputs in the Building Material 
feature of the Heat Transfer interface.

• It defines the temperature T in order to set the model inputs in the features of the 
Moisture transport interface.

S E T T I N G S

The Label is the default multiphysics coupling feature name.
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The Name is used primarily as a scope prefix for variables defined by the coupling node. 
Refer to such variables in expressions using the pattern <name>.<variable_name>. In 
order to distinguish between variables belonging to different coupling nodes or physics 
interfaces, the name string must be unique. Only letters, numbers, and underscores (_) 
are permitted in the Name field. The first character must be a letter.

The default Name (for the first multiphysics coupling feature in the model) is ham1.

D O M A I N  S E L E C T I O N

When nodes are added from the context menu, you can select Manual (the default) 
from the Selection list to choose specific domains to define the domains with heat and 
moisture transport, or select All domains as needed.

C O U P L E D  I N T E R F A C E S

This section defines the physics involved in the multiphysics coupling.

Select the Heat Transfer interface associated to the temperature dependent variable. 
Select the Moisture transport interface associated to the relative humidity variable. 

You can also select None from either list to uncouple the node from a physics interface. 
If the physics interface is removed from the Model Builder — for example, Heat Transfer 

in Building Materials is deleted — then the Heat transfer list defaults to None as there is 
nothing to couple to.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Multiphysics>Heat and Moisture

when a heat transfer interface with Building Material feature is active together with a 
moisture transport interface with Building Material feature; or when a heat transfer 
interface with Fluid or Moist Air feature is active together with a moisture transport 
interface with Moist Air feature.

Local Thermal Non-Equilibrium

Use this multiphysics coupling ( ) to account for heat transfer in porous domains 
where the solid and fluid temperatures are not in equilibrium. This is achieved by 
coupling the heat equations in the solid and fluid subdomains through a transfer term 
proportional to the temperature difference between the fluid and the solid. The 
corresponding heat equations in the solid and in the fluid subdomains read
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with the following material properties:

• θp is the solid volume fraction.

• ρs and ρf are the solid and fluid densities.

• Cp, s and Cp, f are the solid and fluid heat capacities at constant pressure.

• ks and kf are the solid and fluid thermal conductivities.

• qsf is the interstitial convective heat transfer coefficient.

• us and uf are the solid and fluid velocity vectors.

The fluid velocity is deduced from a porous velocity up, coming, for example, from the 
Darcy’s law or the Brinkmann equations, according to:

S E T T I N G S

The Label is the default multiphysics coupling feature name. 

The Name is used primarily as a scope prefix for variables defined by the coupling node. 
Refer to such variables in expressions using the pattern <name>.<variable_name>. In 
order to distinguish between variables belonging to different coupling nodes or physics 
interfaces, the name string must be unique. Only letters, numbers and underscores (_) 
are permitted in the Name field. The first character must be a letter.

The default Name (for the first multiphysics coupling feature in the model) is ltne1.

L O C A L  T H E R M A L  N O N - E Q U I L I B R I U M  S E T T I N G S

Enter a Solid volume fraction θp (dimensionless). The default value is 0.5.

Select an Interstitial convective heat transfer coefficient: Spherical pellet bed, General 

configuration, or User defined (the default).

θpρsCp s, t∂
∂Ts θpρsCp s, us Ts∇⋅+ ∇ θpks Ts∇( )⋅ qsf Tf Ts–( )+=

1 θp–( )ρfCp f, t∂
∂Tf 1 θp–( )ρfCp f, uf Tf∇⋅+ ∇ 1 θp–( )kf Tf∇( )⋅ qsf Ts Tf–( )+=

uf
up

1 θp–
---------------=

See also Local Thermal Non-Equilibrium in Theory for Heat Transfer in 
Porous Media.
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Spherical Pellet Bed
In this particular configuration, the interstitial convective heat transfer coefficient can 
be directly expressed as a function of the average pellet radius rp and the fluid-to-solid 
Nusselt number for which the fluid dynamic viscosity μ is needed.

Enter a value for the Average pellet radius rp (SI unit: m). Default value is 5e-4 m.

The default Dynamic viscosity μ (SI unit: Pa·s) is used From material. In the list, choose 
User defined to enter another value or expression. When the dynamic viscosity is set in 
the Heat Transfer in Fluids interface, it also appears in the list.

General Configuration
The interstitial convective heat transfer coefficient is expressed as the product of the 
specific surface area asf and the interstitial heat transfer coefficient hsf.

Enter a value for the Specific surface area asf (SI unit: 1/m). Default value is 0 1/m.

Enter a value for the Interstitial heat transfer coefficient hsf (SI unit: W/(m2·K)). 
Default value is 0 W/(m2·K).

User Defined
Enter a custom value for qsf (SI unit: W/(m3·K)). Default value is 0 W/(m3·K).

C O U P L E D  I N T E R F A C E S

This section defines the physics involved in the Local Thermal Non-Equilibrium 
multiphysics coupling.

Select the Heat transfer in solids interface associated to the solid temperature 
dependent variable. Select the Heat transfer in fluids interface associated to the fluid 
temperature dependent variable.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Multiphysics>Local Thermal Non-Equilibrium

The Heat Transfer in Fluids interface defines the dynamic viscosity if 
either Moist air is selected as Fluid type in the Thermodynamics, Fluid 
section, or the Equivalent conductivity for convection check box is selected 
in the Equivalent Conductivity for Convection section.
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when the Heat Transfer in Solids interface with Solid feature is added together with the 
Heat Transfer in Fluids interface with Heat Transfer in Fluids feature.

Nonisothermal Flow

Use this multiphysics coupling to simulate fluid flows where the fluid properties 
depend on temperature. Models can also include heat transfer in solids or in porous 
media as well as surface-to-surface radiation and radiation in participating media, with 
the Heat Transfer Module. The physics interface supports low Mach numbers 
(typically less than 0.3).

The Nonisothermal Flow, Laminar Flow interface solves for conservation of energy, 
mass and momentum in fluids and porous media and for conservation of energy in 
solids. It synchronizes the features from the Heat Transfer and Fluid Flow interfaces 
when a turbulent flow regime is defined. It also complements the Screen and Interior 

Fan feature from the flow interface to account for thermal effects.

When the Nonisothermal Flow is used, there is no need to add Flow 

Coupling or Temperature Coupling. Indeed, Nonisothermal Flow combines 
the effects of both of them. In addition, it also accounts for the 
multiphysics stabilization terms, for the heat transfer changes in the 
turbulent regime (for example, thermal wall functions), for work due to 
pressure forces and viscous dissipation, and for natural convection, 
including Boussinesq approximation.

The multiphysics stabilizations (streamline diffusion and crosswind 
diffusion) are controlled by the Fluid Flow interface. For example, the 
multiphysics streamline diffusion can be disabled in a Laminar Flow physics 
node, in the Stabilization section. The stabilization selected in the Heat 
Transfer physics interface has no effect if the multiphysics coupling 
stabilization is active, but remains active if not. However, the isotropic 
diffusion is not a multiphysics stabilization and is controlled by each 
physics interface.

Finally, when one of the physics interfaces or the multiphysics coupling is 
not solved in a study step, then the stabilization of each solved physics is 
used instead of the coupled stabilization, and the solver suggestions are 
uncoupled.
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S E T T I N G S

The Label is the default multiphysics coupling feature name. 

The Name is used primarily as a scope prefix for variables defined by the coupling node. 
Refer to such variables in expressions using the pattern <name>.<variable_name>. In 
order to distinguish between variables belonging to different coupling nodes or physics 
interfaces, the name string must be unique. Only letters, numbers and underscores (_) 
are permitted in the Name field. The first character must be a letter.

The default Name (for the first multiphysics coupling feature in the model) is nitf1.

D O M A I N  S E L E C T I O N

When nodes are added from the context menu, you can select Manual (the default) 
from the Selection list to choose specific domains to define the nonisothermal flow, or 
select All domains as needed.

H E A T  TR A N S F E R  TU R B U L E N C E  M O D E L

Select an option from the Heat transport turbulence model list: Kays-Crawford (the 
default), Extended Kays-Crawford, or User-defined turbulent Prandtl number. 

For Extended Kays-Crawford, enter a Reynolds number at infinity Reinf (dimensionless).

For User-defined turbulent Prandtl number, enter a Turbulent Prandtl number prT 
(dimensionless).

When the flow interface uses a RANS turbulence model, the conductive heat flux is 
defined as

with the turbulent thermal conductivity defined as

where μT is defined by the flow interface, and PrT depends on the Heat transport 

turbulence model. See Turbulent Conductivity for details.

M A T E R I A L  P R O P E R T I E S

Select an option from the Specify density list: From heat transfer interface (the default), 
From fluid flow interface, Custom, linearized density, or Custom. 

q k kT+( )– ∇T=

kT
μTCp
PrT

--------------=
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For Custom, linearized density, enter the Reference density ρref (SI unit: kg/m3) and the 
Coefficient of thermal expansion αp(SI unit:1/K), or select From material, or select a 
variable in the list if available. When Custom, linearized density is selected, regardless 
how the properties are defined they should be constant. If material properties are not 
constant you should consider using any of the other options to define the density.

For Custom, enter a Density ρ (SI unit: kg/m3), or select a density in the list if available.

The density definition in the Nonisothermal Flow node ensure that the same definition 
of the density is used on the fluid flow and heat transfer interfaces. When the fluid flow 
compressibility setting is set to Incompressible then the thermal conductivity and the 
heat capacity are evaluated at the Reference temperature defined in the fluid flow 
interface. When Include gravity is selected and the Compressibility is set to 
Incompressible flow in the fluid interface properties, the gravity forces are defined using 
the coefficient of thermal expansion. Along with the fact that the material properties 
are evaluated for a constant temperature and pressure, this gravity force definition 
corresponds to Boussinesq approximation. Unless the density is defined as Custom, 

linearized density the coefficient of thermal expansion is evaluated from the fluid 
density.

F L O W  H E A T I N G

Select the Include work done by pressure changes check box to account for the heat 
source due to pressure changes:

By default this option is not selected; however, it should be selected for compressible 
fluids as soon as significant pressure gradients occur.

Select the Include viscous dissipation check box to account for the heat source 
corresponding to viscous heating. This option is not selected by default. Because it may 
induce an extra computational cost it should be only selected in application where such 
effect is expected. If no information on this is available, selecting the option ensures 
that the energy balance for the heat and the flow equation is respected.

C O U P L E D  I N T E R F A C E S

This section defines the physics involved in the multiphysics coupling. The Fluid flow 

and Heat transfer lists include all applicable physics interfaces.

Qp αp
∂p
∂t
------ u ∇p⋅+ 
 =
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The default values depend on how this coupling node is created. 

• If it is added from the Physics ribbon (Windows users), Physics contextual toolbar 
(Mac and Linux users), or context menu (all users), then the first physics interface 
of each type in the component is selected as the default. 

• If it is added automatically when a multiphysics interface is chosen in the Model 

Wizard or Add Physics window, then the two participating physics interfaces are 
selected.

You can also select None from either list to uncouple the node from a physics interface. 
If the physics interface is removed from the Model Builder — for example, Heat Transfer 

in Fluids is deleted — then the Heat transfer list defaults to None as there is nothing to 
couple to.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Multiphysics>Nonisothermal Flow

When an interface is selected from the Heat transfer list, some of its model 
inputs are forced with values from the Nonisothermal Flow node. In 
addition, it defines how the turbulence has to be accounted for, 
depending on the Fluid flow interface’s turbulence settings. Therefore, 
each heat transfer or fluid flow interface should be used in at most one 
Nonisothermal Flow node. In cases where multiple fluid flow interfaces are 
used, an equal number of heat transfer interfaces and Nonisothermal Flow 
nodes are needed to define proper multiphysics couplings.

If a physics interface is deleted and then added to the model again, then 
in order to re-establish the coupling, you need to choose the physics 
interface again from the Fluid flow or Heat transfer lists. This behavior is 
applicable to all multiphysics coupling nodes that would normally default 
to the once present interface. See Multiphysics Modeling Approaches in 
the COMSOL Multiphysics Reference Manual.

Heat Sink: Application Library path 
Heat_Transfer_Module/Tutorials,_Forced_and_Natural_Convection/heat_sink
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when any of the following interface is added together with Heat Transfer in Solids (or 
another version of the Heat Transfer Interface): 
Single-Phase Flow (any version)
Porous Media and Subsurface Flow, Brinkman Equations

Temperature Coupling

Use this multiphysics coupling to add the temperature as the default model input for 
a standalone physics interface. 

C O U P L E D  I N T E R F A C E S

The Temperature Coupling feature is generic and specifies a Heat Transfer interface as 
Source and a second interface as Destination. When Temperature Coupling feature is 
used, the temperature from the Source is used to evaluate material properties in any 
feature from the Destination interface. The coupling can be added wherever the Heat 
Transfer interface is active.

The Source interface can be any interface defining a temperature, which includes all 
versions of heat transfer and multiphysics, except the pure radiation interfaces.

The Destination interface can be any interface providing multiphysics feature in the 
Multiphysics node — for example, Electric Current or Solid Mechanics.

See Temperature Coupling in the COMSOL Multiphysics Reference Manual for 
more details about this multiphysics coupling.

Thermal Expansion

Use this multiphysics coupling ( ) to add an internal thermal strain caused by 
changes in temperature. 

Contact Switch: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/contact_switch
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See Thermal Expansion (Multiphysics Coupling) in the Structural Mechanics Module 
User’s Guide for more details about this multiphysics coupling.

Thermoelectric Effect

Use this multiphysics coupling ( ) to account for a Peltier heat source or sink in 
domains where electrical and thermal models are defined. This modeling is achieved 
by adding PJ contribution to the heat flux. The corresponding heat equation in an 
immobile solid reads

A Thermoelectric Effect node also adds the term −σS∇T to the current density, which 
is then defined as:

Heating Circuit: Application Library path 
Heat_Transfer_Module/Power_Electronics_and_Electronic_Circuit/heating_cir

cuit

ρCp t∂
∂T ∇ k∇T– PJ+( )⋅+ Q=

J σ ∇V S∇T+( )–=

The contribution to the heat flux affects all boundary conditions where 
the conductive flux, −k∇T, is involved. In particular the thermal 
insulation condition becomes (−k∇T + PJ) ⋅ n = 0 (instead of  
(−k∇T) ⋅ n = 0 when thermoelectric effect is not active).

In 2D, the thickness used in the multiphysics contributions is the one 
defined in the electromagnetic interface.

Theory for the Thermoelectric Effect Interface

Thermoelectric Leg: Application Library path 
Heat_Transfer_Module/Verification_Examples/thermoelectric_leg
D O M A I N  M U L T I P H Y S I C S  C O U P L I N G S  |  563



564 |  C H A P T E
S E T T I N G S

The Label is the default multiphysics coupling feature name.

The Name is used primarily as a scope prefix for variables defined by the coupling node. 
Refer to such variables in expressions using the pattern <name>.<variable_name>. In 
order to distinguish between variables belonging to different coupling nodes or physics 
interfaces, the name string must be unique. Only letters, numbers, and underscores (_) 
are permitted in the Name field. The first character must be a letter.

The default Name (for the first multiphysics coupling feature in the model) is tee.

T H E R M O E L E C T R I C  P R O P E R T I E S

The default Seebeck coefficient S (SI unit: V/K) is taken From material. For User 

defined enter other values or expressions.

C O U P L E D  I N T E R F A C E S

This section defines the physics involved in the thermoelectric effect multiphysics 
coupling.

Select the Heat Transfer interface associated to the temperature dependent variable. 
Select the Electromagnetic interface associated to the electric potential dependent 
variable.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Multiphysics>Thermoelectric Effect

when any of the following interface is added together with Heat Transfer in Solids (or 
another version of the Heat Transfer Interface): 
Electric Currents

Magnetic Field Formulation

Magnetic Fields

Magnetic and Electric Fields

Rotating Machinery, Magnetic
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Bounda r y  Mu l t i p h y s i c s  C oup l i n g s

The Heat Transfer Module has the following boundary multiphysics couplings 
available:

Boundary Thermoelectric Effect

Use this multiphysics coupling ( ) to account for a Peltier heat source or sink on 
boundaries where electric and thermal shells are defined. This modeling is achieved by 
adding PsJs contribution to the heat flux. The corresponding heat equation in an 
immobile solid reads:

A Boundary Thermoelectric Effect node also contributes the term −dsσsSs∇tT to the 
current density, which is then defined as:

• Boundary Thermoelectric Effect

• Boundary Electromagnetic Heat 
Source

• Marangoni Effect

For a detailed overview of the functionality available in each product, visit 
http://www.comsol.com/products/specifications/

dsρsCs t∂
∂T ∇t ds ks∇tT– PsJs+( )⋅+ dsQs=

Js dsσs ∇tV Ss∇tT+( )–=

In 2D, the thickness used the multiphysics contributions is the one 
defined in the electromagnetic interface.

Theory for the Thermoelectric Effect Interface
B O U N D A R Y  M U L T I P H Y S I C S  C O U P L I N G S  |  565
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S E T T I N G S

The Label is the default multiphysics coupling feature name.

The Name is used primarily as a scope prefix for variables defined by the coupling node. 
Refer to such variables in expressions using the pattern <name>.<variable_name>. In 
order to distinguish between variables belonging to different coupling nodes or physics 
interfaces, the name string must be unique. Only letters, numbers, and underscores (_) 
are permitted in the Name field. The first character must be a letter.

The default Name (for the first multiphysics coupling feature in the model) is btee.

B O U N D A R Y  S E L E C T I O N

From the Selection list, choose the boundaries where boundary thermoelectric effect is 
defined. Only boundaries where both Thin Layer and Electric Shielding are active can be 
selected.

The weak contribution in only added when Layer type in Thin Layer is set to Conductive. 
If Layer type is set to either Resistive or General, the weak contribution evaluates to 0.

T H E R M O E L E C T R I C  P R O P E R T I E S

The default Seebeck coefficient S (SI unit: V/K) is taken From material. For User 

defined enter other values or expressions.

B O U N D A R Y  T H E R M O E L E C T R I C  E F F E C T

This section defines the physics involved in the thermoelectric effect multiphysics 
coupling.

Select the Heat transfer interface associated to the temperature dependent variable. 
Select the Electromagnetic interface associated to the electric potential dependent 
variable.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Multiphysics>Boundary Thermoelectric Effect

when any of the following interface is added together with Heat Transfer in Solids (or 
another version of the Heat Transfer Interface): 

Thermoelectric Leg: Application Library path 
Heat_Transfer_Module/Verification_Examples/thermoelectric_leg
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Electric Currents

Electric Currents, Shells

Magnetic Field Formulation

Magnetic Fields

Magnetic and Electric Fields

Rotating Machinery, Magnetic

Boundary Electromagnetic Heat Source

This multiphysics coupling ( ) maps the electromagnetic surface losses as a heat 
source on the boundary in the heat transfer part of the model. It is a default node.

See Boundary Electromagnetic Heat Source in the COMSOL Multiphysics Reference 
Manual for a description of this multiphysics coupling.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Multiphysics>Boundary Electromagnetic Heat Source

when any of the following interface is added together with Heat Transfer in Shells (or 
another version of the Heat Transfer in Thin Structures interface): 
Electric Currents

Electric Currents, Shells

Magnetic Field Formulation

Magnetic Fields

Magnetic and Electric Fields

Rotating Machinery, Magnetic

Marangoni Effect

This multiphysics coupling ( ) accounts for Marangoni convection. Marangoni 
convection occurs when the surface tension of an interface (generally liquid-air) 
depends on the concentration of a species or on the temperature distribution. In the 
case of temperature dependence, the Marangoni effect is also called thermo-capillary 

Contact Switch: Application Library path 
Heat_Transfer_Module/Thermal_Contact_and_Friction/contact_switch
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convection. It is of primary importance in the fields of welding, crystal growth, and 
electron beam melting of metals.

The Marangoni effect is a shear stress which depends on the tangential temperature 
gradient and should be implemented as such. It has the following contribution 
described by forces induced on the fluid/fluid interface:

where γ is the temperature derivative of the surface tension σ (N/(m·K)). Note that 
this formulation is intended for laminar flow regimes only.

S E T T I N G S

The Label is the default multiphysics coupling feature name. 

The Name is used primarily as a scope prefix for variables defined by the coupling node. 
Refer to such variables in expressions using the pattern <name>.<variable_name>. In 
order to distinguish between variables belonging to different coupling nodes or physics 
interfaces, the name string must be unique. Only letters, numbers and underscores (_) 
are permitted in the Name field. The first character must be a letter.

The default Name (for the first multiphysics coupling feature in the model) is me1.

S U R F A C E  TE N S I O N

Select a Surface tension coefficient type: Library coefficient, liquid/gas interface or User 

defined (the default).

• For Library coefficient, liquid/gas interface choose an option from the Library surface 

tension coefficient list.

• For User defined enter a Surface tension coefficient σ (SI unit: N/m).

M A R A N G O N I  E F F E C T

This section defines the physics involved in the multiphysics coupling. The Fluid flow 

and Heat transfer lists include all applicable physics interfaces.

pI– μ ∇u ∇u( )T
+( ) 2

3
---μ ∇ u⋅( )I–+ n γ∇tT=
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The default values depend on how this coupling node is created. 

• If it is added from the Physics ribbon (Windows users), Physics contextual toolbar 
(Mac and Linux users), or context menu (all users), then the first physics interface 
of each type in the component is selected as the default. 

• If it is added automatically when a multiphysics interface is chosen in the Model 

Wizard or Add Physics window, then the two participating physics interfaces are 
selected.

You can also select None from either list to uncouple the node from a physics interface. 
If the physics interface is removed from the Model Builder — for example, Heat Transfer 

in Fluids is deleted — then the Heat transfer list defaults to None as there is nothing to 
couple to.

L O C A T I O N  I N  U S E R  I N T E R F A C E

Context menus
Multiphysics>Marangoni Effect

when any of the following interface is added together with Heat Transfer in Solids (or 
another version of the Heat Transfer Interface): 
Single-Phase Flow (any version)
Porous Media and Subsurface Flow, Brinkman Equations

If a physics interface is deleted and then added to the model again, then 
in order to re-establish the coupling, you need to choose the physics 
interface again from the Fluid flow or Heat transfer lists. This is applicable 
to all multiphysics coupling nodes that would normally default to the 
once present interface. See Multiphysics Modeling Approaches in the 
COMSOL Multiphysics Reference Manual.

Marangoni Effect: Application Library path 
Heat_Transfer_Module/Tutorials,_Forced_and_Natural_Convection/marangon

i_effect
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A absolute pressure 43, 157, 362, 377, 388, 

433

acceleration of gravity 40, 242

activation energy 39, 148, 353, 406

apparent heat capacity 156

Application Libraries window 30

application library examples

ambient settings 119, 283

bioheat 351

bioheat transfer interface 307

biological tissue 355

boundary electromagnetic heat source 

567

boundary thermoelectric effect 566

consistent stabilization 88

continuity 418

continuity on interior boundary 419

diffuse surface 428

electromagnetic heat source 551

external radiation source 503

fluid 366

heat flux 435

heat flux (heat transfer in thin shells in-

terface) 438, 480

heat source 370

heat transfer in porous media 299

heat transfer in thin shells 322

heat transfer with surface-to-surface 

radiation 311

highly conductive layers 177

initial values (heat transfer in thin 

shells interface) 445

insulation/continuity (heat transfer in 

thin shells interface) 482

isothermal domain 376

isothermal domain interface 447

marangoni effect 569

moist air 378

nonisothermal flow 561

opaque 380

opaque surface 452

open boundary 453

outflow 454

out-of-plane heat flux 381

out-of-plane radiation 383

periodic condition 455

phase change material 386

point heat source 495

porous medium 393

radiation in participating media 339

radiation in participating media (heat 

transfer interface) 399

radiation in participating media (rpm 

interface) 402

solid 404

symmetry 463

temperature (heat transfer in thin 

shells interface) 490

temperature (heat transfer interface) 

464

temperature coupling 562

thermal contact 229, 468

thermal expansion 563

thermoelectric effect 563

thin conductive layer (heat transfer in 

thin shells interface) 470

thin layer 475

translational motion 411

arterial blood temperature 46, 351

average gas particle diameter 39, 227

average particle diameter 39, 151

axisymmetric geometries 196, 335, 460
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azimuth 50, 196

azimuthal sectors 196

B beam orientation 39, 419

bioheat (node) 84, 350, 352

bioheat transfer interface 274, 306

theory 146

biological tissue (node) 84, 306, 352

black walls 451

blackbody radiation 456

blackbody radiation intensity 41, 198, 396

boundary conditions

heat equation, and 78

heat transfer coefficients, and 240

boundary electromagnetic heat source 

(multiphysics coupling) 539, 545–548, 

567

boundary flux variables (heat transfer in 

thin shells interface) 65

boundary flux variables (heat transfer in-

terface) 63

boundary heat source (node) 415

boundary heat source variable 69

boundary multiphysics nodes 527, 565

boundary nodes 414, 517

boundary thermoelectric effect (multi-

physics coupling) 539, 565

Boussinesq approximation 214

Brinell hardness 41, 226–227

building material (moisture transport in-

terface) 342

building material (node) 84

heat transfer interface 303, 305, 356, 

555

moisture transport interface 510, 555

bulk velocity 242

C change cross-section (node) 84, 360

change effective thickness (node) 478

change thickness (node) 84

heat transfer in thin shells interface 

417

heat transfer interface 361

characteristic length 242

Charron’s relation 228, 467

coefficient of thermal expansion 47, 135, 

242, 394

common settings 24

concentration 38, 231, 363, 377, 388

conduction, definition 137

conductive heat flux variable 61, 65

conductive heat flux vector 78

conjugate heat transfer (multiphysics in-

terface) 532

conjugate heat transfer (settings) 297

consistent stabilization (settings) 283, 

287, 343, 345

consistent stabilization method 88

constraints, Galerkin 464

continuity (moisture transport interface) 

517

continuity (node) 418

continuity on interior boundary (node) 

315–316, 339, 419

convection, definition 138

convection, natural and forced 241

convective heat flux variable 64

convective heat flux variable, cflux 62, 65

Cooper-Mikic-Yovanovich (CMY) corre-

lation 226, 466

cross sectional area 38, 279, 342, 345

cross sectional perimeter 43, 279, 342, 

345

crosswind diffusion

definition 88

heat transfer, and 88

crosswind diffusion, consistent stabiliza-

tion method 88



D Dalton’s law 230

damage integral analysis discretization 

(settings) 306

Darcy number 39, 151

density, blood 49, 351

dependent variables (settings) 285, 288

deposited beam power (node) 419

diffuse gray radiation model 286, 334

diffuse mirror (node) 421

diffuse spectral radiation model 286, 334

diffuse surface (node) 422

diffuse-gray surfaces 186, 189

diffuse-spectral surface 191

Dirac pulse 157

direct area integration, axisymmetric ge-

ometry and 196

direct area integration, radiation settings 

286, 334

discontinuous Galerkin constraints 464

discrete ordinates method (DOM) 202, 

315–317, 339, 396, 400

discretization (settings) 284, 288–289, 

293, 306, 311, 316, 322, 326, 330, 343, 

346

dispersion tensor 39, 408

dispersivities, porous media 49, 408

domain flux variables 61

domain heat source variables 68

domain multiphysics nodes 527, 551

domain nodes 350, 510

dry solid density 159, 358

dry solid specific heat capacity 159, 358

dry solid thermal conductivity 159, 357

E edge nodes 478

effective thermal conductivity 42, 152, 

159, 223, 356, 387, 392, 408

effective volumetric heat capacity 47, 

152, 159, 223, 391, 404

electric currents interface 539

electromagnetic heat source 44

electromagnetic heat source (multiphys-

ics coupling) 539, 545–548, 551

elevation 196

emailing COMSOL 30

emission, radiation and 198

energy rates 260

evaluating view factors 193

external radiation source (node) 499

external temperature (node) 428, 430

F Favre average 213

film thickness 179

flow coupling (multiphysics coupling) 91, 

533, 552

fluid (node) 84, 361, 555

Fourier’s law 363, 389, 391, 403

fracture (node) 329, 430

frames, conversions between 262

frames, moving 82

frequency factor 38, 148, 353, 406

G Galerkin constraints, heat transfer 464

gap conductance 40, 227, 465

geothermal heating (node) 84, 367

global nodes 499

Grashof number 40, 242

gravity 40, 242

gray walls 451

graybody radiation 191, 456

gray-diffuse parallel plate model 228

guidelines, solving surface-to-surface ra-

diation problems 105

H harmonic perturbation (node)

heat transfer interface 432

heat and moisture (multiphysics cou-

pling) 544, 554

heat and moisture transport (multiphys-
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ics interface) 303, 305, 542–543

heat balance 138

heat capacity at constant pressure 38, 

135

heat flux (node)

heat transfer in thin shells interface 

436, 479

heat transfer interface 433

heat flux, theory 257

heat rate 369, 415, 433, 435, 467

heat source (node) 84, 438, 440–441

heat transfer 368

heat transfer in thin shells interface 

439, 492

heat transfer in thin shells, point or 

edge condition 480

heat sources

defining as heat rate 369

line and point 485

local thermal non-equilibrium 541

thin film 438, 440

thin layer 448

thin layered shell 441

thin rod 482

heat transfer coefficients

out-of-plane heat transfer 437

theory 241

heat transfer in biological tissue (set-

tings) 280

heat transfer in building materials inter-

face 274

heat transfer in fluids (node) 293, 297

heat transfer in fluids interface 274, 293, 

297, 541, 543–544

theory 144

heat transfer in fractures interface 276, 

329

heat transfer in participating media inter-

face 315

heat transfer in porous media (settings) 

280, 286, 298

heat transfer in porous media interface 

274, 298, 303, 305

theory 151

heat transfer in solids (node) 297, 315

heat transfer in solids interface 274, 289, 

539, 541, 543–544

theory 143

heat transfer in thin films interface 276, 

325

heat transfer in thin shells interface 276, 

321

heat transfer in thin shells interfaces 276

heat transfer interface 274, 297, 303, 305

heat transfer interfaces 274

Heat Transfer Module 58

heat transfer with radiation in participat-

ing media interface 274

heat transfer with surface-to-surface ra-

diation interface 274, 310

heat transfer, and streamline diffusion 88

Heaviside function 157

hemicubes, axisymmetric geometry and 

196

hemicubes, radiation settings 286, 334

htsh_tf_etemp 430

I immobile fluids (node) 84, 371

incident intensity (node) 316, 339, 442

inconsistent stabilization (settings) 284, 

287, 343, 346

inconsistent stabilization methods 89

induction heating (multiphysics interface) 

547

infinite elements (node) 84

inflow heat flux (node) 443

initial values (node) 289, 293, 298, 303, 



305–306, 310, 315, 321, 325, 329

heat transfer in thin shells interface 

444

heat transfer interface 374

moisture transport interface 512

in-plane conductive heat flux variable 66

in-plane convective heat flux variable 66

in-plane total energy flux variable 66

in-plane total heat flux variable 66

insulation (node) 518

insulation/continuity (node) 321, 325, 

329, 481

internal boundary heat flux variables 66

internal energy 39, 257

Internet resources 28

inward heat flux 78

irreversible transformation (node) 405

isothermal domain (node) 291, 374

isothermal domain (settings) 280, 291

isothermal domain interface (node) 291, 

445

isotropic diffusion 89, 343, 346

J Joule heating (multiphysics interface) 545

K Karman constant 218

Kays-Crawford models 217

knowledge base, COMSOL 31

L laminar flow interface 531

laser heating (multiphysics interface) 546

latent heat of evaporation 43, 160, 223, 

356

latitude 196, 501

layer heat source (node) 448

layer thickness 39, 171–172, 176

Legendre coefficient 38, 206, 398, 401

line and point heat source variables 69

line heat flux (node)

fracture subnode 483

thin film subnode 483

thin layer subnode 483

line heat source (node) 450

heat transfer interface 485

thin rod subnode 482

line heat source on axis (node) 450

heat transfer 450

line heat source variable 69

local thermal non-equilibrium (multi-

physics coupling) 541, 555

local thermal non-equilibrium (multi-

physics interface) 298, 540

local thermal non-equilibrium interface

theory 153

longitude 196, 501

M Marangoni effect (multiphysics coupling) 

567

mean effective thermal conductivity 403

mean effective thermal diffusivity 404

mechanisms of heat transfer 137

metabolic heat source 44, 351

microwave heating (multiphysics inter-

face) 548

Mikic elastic correlation 227, 466

moist air 364, 390

moist air (moisture transport interface) 

345

moist air (node) 376, 555

moist surface (node) 518

moisture content 47, 230, 364, 377, 390

moisture content (node) 520

moisture diffusivity 39, 209, 224, 510

moisture flux (node) 521

moisture source (node)

moisture transport interface 514

moisture storage capacity 51, 209, 223, 

510

moisture storage function 47
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moisture transfer coefficient 48

moisture transport in air interface 277, 

345

moisture transport in building materials 

interface 277, 342

moisture transport interface 555

moisture transport interfaces 277

moving frames 82

moving mesh, heat transfer, and 158, 386

MPH-files 30

multiphysics couplings

boundary electromagnetic heat source 

(node) 567

boundary thermoelectric effect (node) 

565

electromagnetic heat source (node) 

551

flow coupling (node) 552

heat and moisture (node) 554

local thermal non-equilibrium (node) 

555

Marangoni effect (node) 567

nonisothermal flow (node) 558

temperature coupling (node) 562

thermal expansion (node) 562

thermoelectric effect (node) 563

mutual irradiation 40, 190

N natural and forced convection 241

nodes, common settings 24

nonisothermal flow (multiphysics cou-

pling) 91–92, 533, 558

nonisothermal flow (multiphysics inter-

face) 531

nonisothermal flow interface

theory 211

normal conductive heat flux variable 64

normal convective heat flux variable 64

normal total energy flux variable 64

normal translational heat flux variable 64

Nusselt number 43, 155, 241, 365, 557

O opacity (node) 310

opaque (node) 379

opaque surface (node) 315–316, 339, 450

open boundary (node) 452

outflow (moisture transport interface) 

522

outflow (node) 453

out-of-plane flux variables 63

out-of-plane heat flux (node) 380

out-of-plane heat transfer

theory 237

thin shells theory 175

out-of-plane inward heat flux variable 63

out-of-plane radiation (node) 382

out-of-plane thickness 39, 171–172, 176, 

179, 285, 437

P P1 approximation 205, 315–316, 339, 396, 

400

pair boundary heat source (node) 415

pair thermal contact (node) 465

participating media, radiative heat trans-

fer 198

Peltier effect 219, 563

Pennes’ approximation 146, 352

performance index 43, 316, 339

perfusion rate, blood 51, 351

periodic condition (node) 454

phase change material (node) 84, 384

phase transitions 384

physical model (settings) 279, 285, 289, 

293, 298, 306, 310, 342, 345

physics interfaces, common settings 24

point heat flux (node)

thin rod subnode 493

point heat source (node)

heat transfer 494



point heat source on axis (node) 496

point heat source variable 69

point nodes 492

points

heat flux 493

surface-to-ambient radiation 497

temperature 498

porous matrix model, extended (set-

tings) 299

porous medium (moisture transport in-

terface) 510

porous medium (node) 84, 298

Prandtl number 44, 155, 217, 242

prescribed radiosity (node) 455

pressure work (node) 394

R radiation

axisymmetric geometries, and 196, 

335, 460

participating media 198

radiation branch (settings) 310, 315, 333

radiation group (node) 460

radiation in participating media (node)

heat transfer interface 395

rpm interface 399

radiation in participating media (settings) 

279, 315

radiation in participating media interface 

315, 338

theory 198

radiation intensity, blackbody 41, 198, 

396

radiation settings (settings) 310

radiation, definition 138

radiative conductance 41, 225, 228, 466

radiative heat flux variable 64

radiative heat, theory 182

radiative out-of-plane heat flux variable 

63

radiative transfer equation 199

radiogenic heating per mass 44, 367

radiosity 41, 182, 189, 192, 421–422, 455, 

463, 499

radiosity expressions 456

radiosity method 183, 189

ratio of specific heats 48, 364, 385, 389–

390

Rayleigh number 45, 242

reflectivity 49, 182, 201

refractive index 43, 184–185, 199, 201, 

205, 316, 339

relative humidity 50, 160, 209–210, 223, 

230, 356, 365, 377, 390, 510, 513

Reynolds number 45, 241, 559

extended Kays-Crawford 217

Rodriguez formula 200

Rosseland approximation 204, 315–316, 

396

S scattering, radiation and 198

sectors, azimuthal 196

Seebeck coefficient 46, 220, 564

Seebeck effect 219

sensible enthalpy 137

shell thickness 171–172, 176, 179, 285, 

417

solar position 196, 499

solid (node) 84, 289, 402

solver settings 98

solving surface-to-surface radiation 

problems 105

source terms, bioheat 350, 352

spatial frames 284, 288

specific heat capacity

biological tissue 352

blood 38

damaged tissue 38, 354, 407

definition 135
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fluid 38, 362

fracture 38, 431

phase change 385

porous media 38, 387

solid 38, 470

solids 402

thin rod 490

specific heat, blood 351

specific surface area 38, 155, 557

spectral band 38, 185, 379, 421, 455, 499

stabilization techniques

crosswind diffusion 88, 283, 287, 343, 

345

isotropic diffusion 284, 287, 343, 346

streamline diffusion 283, 287, 343, 345

standard settings 24

stationary study 273

Subsurface Flow Module 368, 373, 392

sun position 503

surface emissivity 48, 189, 382, 421, 426, 

451, 457, 467, 487–488, 497

surface reflectivity 49

surface-to-ambient radiation (node)

fracture subnode 488

heat transfer in thin shells interface 

486

thin film subnode 488

thin layer subnode 488

thin rod subnode 497

surface-to-surface radiation (settings) 

279, 286, 310

surface-to-surface radiation interface 

310, 333

theory 182

symmetry (moisture transport interface) 

522

symmetry (node) 463

T technical support, COMSOL 30

temperature (node)

heat transfer in thin shells interface 

489

heat transfer interface 463

thin rod subnode 498

temperature coupling (multiphysics cou-

pling) 533, 545–548, 562

theory

bioheat transfer interface 146

conjugate heat transfer multiphysics 

interface 211

heat flux and balance 257

heat transfer coefficients 240–241

heat transfer in fluids interface 144

heat transfer in porous media interface 

151

heat transfer in solids interface 143

isothermal domain feature 163

local thermal non-equilibrium inter-

face 153

material and spatial frames 261

moist air fluid type 230

nonisothermal flow 211

out-of-plane heat transfer 237

radiation in participating media inter-
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